Namespaces

Bookmaker SDK
Namespaces
Namespace | Description
Sportradar.SDK.Common |
Sportradar.SDK.Common.Exceptions |
Sportradar.SDK.Common.Interfaces |
Sportradar.SDK.Common.Utils |
Sportradar.SDK.FeedProviders.Common |
Sportradar.SDK.FeedProviders.Lcoo |
Sportradar.SDK.FeedProviders.Lcoo.Internal |
Sportradar.SDK.FeedProviders.LiveOdds.Common |
Sportradar.SDK.FeedProviders.LiveOdds.Internal |
Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces |
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds |
Sportradar.SDK.FeedProviders.LiveOdds.Outrights |
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common |
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr |
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc |
Sportradar.SDK.FeedProviders.LiveScout |
Sportradar.SDK.FeedProviders.LiveScout.Enums |
Sportradar.SDK.FeedProviders.LiveScout.Internal |
Sportradar.SDK.FeedProviders.LiveScout.Types |
Sportradar.SDK.FeedProviders.OddsCreator |
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator |
Sportradar.SDK.Services.RateLimiter |
Sportradar.SDK.Services.Sdk |
Sportradar.SDK.Services.Sdk.WindsorResolvers |
Sportradar.SDK.Services.SdkConfiguration |
Sportradar.SDK.Services.SdkConfiguration.Converters |
Sportradar.SDK.Services.SdkConfiguration.Validators |

Copyright ©2014-2023, Sportradar AG

Send comments on this topic to SDK team


Sportradar.SDK.Common Namespace

Classes
 | Class | Description
Public class | AliveCheckData |
Public class | BetOutcome | Localized bet outcome / odds field.
Public class | BetTypeKey | Bet type key (e.g. "3w" = 2)
Public class | BetValue | Value associated with a specified BetTypeKey. This includes localized bet type name (e.g. en="hc", fi="Taaoitus") and localized outcomes/odds fields (e.g. "1", "x", "2" in different languages)
Public class | CipherSettings |
Public class | ClientPersistentStateItem | Client persistent state item.
Public class | CommonLoggerManager |
Public class | ConfigItem |
Public class | ConnectionData |
Public class | DynamicConfigIgnoreClassAttribute | Attribute specifying that ConfigurationElement can be ignored by the dynamic configuration handling code.
Public class | DynamicConfigItemAttribute | Attribute specifying configuration property as dynamic. Dynamic configuration properties can be updated by configuration server in runtime.
Public class | EntityBase | Serves as a base class for all client data contracts/entities.
Public class | GlobalSettings |
Public class | LiveOddsPersistentStateItem |
Public class | LocalizedString | Localized string container where a string is represented by its international value and a collection of translations to other languages.
Public class | LoggerData |
Public class | PersistentStateItem |
Public class | PersistentStateItemKey |
Public class | PoisonQueueElt |
Public class | Priority | Event priority.
Public class | PriorityQueueElt |
Public class | ProtocolData |
Public class | ProtocolProviderType | Type of protocol provider
Public class | SchemaValidationStrictness | Schema validation strictness. Remarks Order is important - from least to most strict. Best choice is probably STRICT. This means it will not spend lots of CPU time while processing eventual junk messages. Our schema supports any attributes so this is not a problem. The only issue could present new (unknown) XML elements.
Public class | TimeKeeper |
Public class | TimeKeeperResponse |
Public class | TypeValueTuple | TypeValueTuple


AliveCheckData Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.AliveCheckData"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonAliveCheckData

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class AliveCheckData

The AliveCheckData type exposes the following members.

Constructors
 | Name | Description
Public method | AliveCheckData | Initializes a new instance of the AliveCheckData class
Top
Properties
 | Name | Description
Public property | Handled |
Public property | MessageToSend |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


AliveCheckData Constructor

Initializes a new instance of the AliveCheckData class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public AliveCheckData()
See Also

Reference

AliveCheckData Class
Sportradar.SDK.Common Namespace


AliveCheckData Properties

The AliveCheckData type exposes the following members.

Properties
 | Name | Description
Public property | Handled |
Public property | MessageToSend |
Top
See Also

Reference

AliveCheckData Class
Sportradar.SDK.Common Namespace


AliveCheckData.Handled Property

Bookmaker SDK Documentation

AliveCheckDataHandled Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.AliveCheckData.Handled"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Handled { get; set; }

Property Value

Boolean
See Also

Reference

AliveCheckData Class
Sportradar.SDK.Common Namespace


AliveCheckData.MessageToSend Property

AliveCheckDataMessageToSend Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.AliveCheckData.MessageToSend"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MessageToSend { get; set; }

Property Value

String
See Also

Reference

AliveCheckData Class
Sportradar.SDK.Common Namespace


AliveCheckData Methods

The AliveCheckData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AliveCheckData Class
Sportradar.SDK.Common Namespace


BetOutcome Class

Localized bet outcome / odds field.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonBetOutcome

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetOutcome

The BetOutcome type exposes the following members.

Constructors
 | Name | Description
Public method | BetOutcome | Initializes a new instance of the BetOutcome class
Top
Properties
 | Name | Description
Public property | Translation | Localized odds field name (e.g. en="u", fi="u", ru="M")
Public property | Type | Odds field name (e.g. "u" for under)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


BetOutcome Constructor

Initializes a new instance of the BetOutcome class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetOutcome(
    string type
)

Parameters

type String
Odds field name
See Also

Reference

BetOutcome Class
Sportradar.SDK.Common Namespace


BetOutcome Properties

The BetOutcome type exposes the following members.

Properties
 | Name | Description
Public property | Translation | Localized odds field name (e.g. en="u", fi="u", ru="M")
Public property | Type | Odds field name (e.g. "u" for under)
Top
See Also

Reference

BetOutcome Class
Sportradar.SDK.Common Namespace


BetOutcome.Translation Property

BetOutcomeTranslation Property

Localized odds field name (e.g. en="u", fi="u", ru="M")

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString Translation { get; }

Property Value

LocalizedString
See Also

Reference

BetOutcome Class
Sportradar.SDK.Common Namespace


BetOutcome.Type Property

BetOutcomeType Property

Odds field name (e.g. "u" for under)

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Type { get; }

Property Value

String
See Also

Reference

BetOutcome Class
Sportradar.SDK.Common Namespace


BetOutcome Methods

The BetOutcome type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

BetOutcome Class
Sportradar.SDK.Common Namespace


BetOutcome.ToString Method

BetOutcomeToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

BetOutcome Class
Sportradar.SDK.Common Namespace


BetTypeKey Class

Bet type key (e.g. "3w" = 2)
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonBetTypeKey

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetTypeKey : IEquatable<BetTypeKey>

The BetTypeKey type exposes the following members.

Constructors
 | Name | Description
Public method | BetTypeKey(Int64) | Initializes a new instance of the BetTypeKey class
Public method | BetTypeKey(Int64, NullableInt64) | Initializes a new instance of the BetTypeKey class
Top
Properties
 | Name | Description
Public property | BetSubType | Optional bet subtype id (e.g. type="ft3w" typeid="6" subtype="13" freetext="Next goal")
Public property | BetTypeId | Unique bet type id (e.g. type="3w", typeid="2")
Top
Methods
 | Name | Description
Public method | Equals(BetTypeKey) | Check for equality.
Public method | Equals(Object) | Check for equality. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


BetTypeKey Constructor

Overload List
 | Name | Description
Public method | BetTypeKey(Int64) | Initializes a new instance of the BetTypeKey class
Public method | BetTypeKey(Int64, NullableInt64) | Initializes a new instance of the BetTypeKey class
Top
See Also

Reference

BetTypeKey Class
Sportradar.SDK.Common Namespace


BetTypeKey(Int64) Constructor

Initializes a new instance of the BetTypeKey class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetTypeKey(
    long odds_type_id
)

Parameters

odds_type_id Int64
Bet type id
See Also

Reference

BetTypeKey Class
BetTypeKey Overload
Sportradar.SDK.Common Namespace


BetTypeKey(Int64, Nullable<Int64>) Constructor

BetTypeKey(Int64, NullableInt64) Constructor

Initializes a new instance of the BetTypeKey class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetTypeKey(
    long odds_type_id,
    long? odds_sub_type
)

Parameters

odds_type_id Int64
Bet type id
odds_sub_type Nullable Int64
Optional bet subtype id
See Also

Reference

BetTypeKey Class
BetTypeKey Overload
Sportradar.SDK.Common Namespace


BetTypeKey Properties

The BetTypeKey type exposes the following members.

Properties
 | Name | Description
Public property | BetSubType | Optional bet subtype id (e.g. type="ft3w" typeid="6" subtype="13" freetext="Next goal")
Public property | BetTypeId | Unique bet type id (e.g. type="3w", typeid="2")
Top
See Also

Reference

BetTypeKey Class
Sportradar.SDK.Common Namespace


BetTypeKey.BetSubType Property

BetTypeKeyBetSubType Property

Optional bet subtype id (e.g. type="ft3w" typeid="6" subtype="13" freetext="Next goal")

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? BetSubType { get; }

Property Value

Nullable Int64
See Also

Reference

BetTypeKey Class
Sportradar.SDK.Common Namespace


BetTypeKey.BetTypeId Property

BetTypeKeyBetTypeId Property

Unique bet type id (e.g. type="3w", typeid="2")

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long BetTypeId { get; }

Property Value

Int64
See Also

Reference

BetTypeKey Class
Sportradar.SDK.Common Namespace


BetTypeKey Methods

The BetTypeKey type exposes the following members.

Methods
 | Name | Description
Public method | Equals(BetTypeKey) | Check for equality.
Public method | Equals(Object) | Check for equality. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString)
Top
See Also

Reference

BetTypeKey Class
Sportradar.SDK.Common Namespace


BetTypeKey.Equals Method

BetTypeKeyEquals Method

Overload List
 | Name | Description
Public method | Equals(BetTypeKey) | Check for equality.
Public method | Equals(Object) | Check for equality.
Top
See Also

Reference

BetTypeKey Class
Sportradar.SDK.Common Namespace


BetTypeKey.Equals(BetTypeKey) Method

BetTypeKeyEquals(BetTypeKey) Method

Check for equality.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Equals(
    BetTypeKey other
)

Parameters

other BetTypeKey
other object

Return Value

Boolean
true when equal; false else

Implements

IEquatableTEquals(T)
See Also

Reference

BetTypeKey Class
Equals Overload
Sportradar.SDK.Common Namespace


BetTypeKey.Equals(Object) Method

BetTypeKeyEquals(Object) Method

Check for equality.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object
other object

Return Value

Boolean
true when equal; false else
See Also

Reference

BetTypeKey Class
Equals Overload
Sportradar.SDK.Common Namespace


BetTypeKey.GetHashCode Method

BetTypeKeyGetHashCode Method

Serves as a hash function for a particular type.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32
Hash for current object
See Also

Reference

BetTypeKey Class
Sportradar.SDK.Common Namespace


BetTypeKey.ToString Method

BetTypeKeyToString Method

Returns a String that represents this instance.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A String that represents this instance.
See Also

Reference

BetTypeKey Class
Sportradar.SDK.Common Namespace


BetValue Class

Value associated with a specified BetTypeKey. This includes localized bet type name (e.g. en="hc", fi="Taaoitus") and localized outcomes/odds fields (e.g. "1", "x", "2" in different languages)
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonBetValue

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetValue : ICloneable

The BetValue type exposes the following members.

Constructors
 | Name | Description
Public method | BetValue | Initializes a new instance of the BetValue class
Top
Properties
 | Name | Description
Public property | Key | Corresponding key.
Public property | Name | Localized bet type name
Public property | Outcomes | Collection of localized outcomes / odds fields
Public property | Type | Odds type name (international, e.g. "3w", "to", "hc" );
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


BetValue Constructor

Initializes a new instance of the BetValue class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetValue(
    string type,
    LocalizedString name,
    BetTypeKey key
)

Parameters

type String
Odds type name
name LocalizedString
Odds internationalized name
key BetTypeKey
Odds type key
See Also

Reference

BetValue Class
Sportradar.SDK.Common Namespace


BetValue Properties

The BetValue type exposes the following members.

Properties
 | Name | Description
Public property | Key | Corresponding key.
Public property | Name | Localized bet type name
Public property | Outcomes | Collection of localized outcomes / odds fields
Public property | Type | Odds type name (international, e.g. "3w", "to", "hc" );
Top
See Also

Reference

BetValue Class
Sportradar.SDK.Common Namespace


BetValue.Key Property

BetValueKey Property

Corresponding key.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetTypeKey Key { get; }

Property Value

BetTypeKey
See Also

Reference

BetValue Class
Sportradar.SDK.Common Namespace


BetValue.Name Property

BetValueName Property

Localized bet type name

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString Name { get; }

Property Value

LocalizedString
See Also

Reference

BetValue Class
Sportradar.SDK.Common Namespace


BetValue.Outcomes Property

BetValueOutcomes Property

Collection of localized outcomes / odds fields

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IDictionary<string, BetOutcome> Outcomes { get; }

Property Value

IDictionary String, BetOutcome
See Also

Reference

BetValue Class
Sportradar.SDK.Common Namespace


BetValue.Type Property

BetValueType Property

Odds type name (international, e.g. "3w", "to", "hc" );

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Type { get; }

Property Value

String
See Also

Reference

BetValue Class
Sportradar.SDK.Common Namespace


BetValue Methods

The BetValue type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

BetValue Class
Sportradar.SDK.Common Namespace


BetValue.Clone Method

BetValueClone Method

Creates a new object that is a copy of the current instance.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Object Clone()

Return Value

Object
A new object that is a copy of this instance.

Implements

ICloneableClone
See Also

Reference

BetValue Class
Sportradar.SDK.Common Namespace


BetValue.ToString Method

BetValueToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

BetValue Class
Sportradar.SDK.Common Namespace


CipherSettings Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.CipherSettings"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonCipherSettings

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class CipherSettings : ICipherSettings,
    ICloneable

The CipherSettings type exposes the following members.

Constructors
 | Name | Description
Public method | CipherSettings | Initializes a new instance of the CipherSettings class
Top
Properties
 | Name | Description
Public property | MinCipherStrength |
Public property | MinHashStrength |
Public property | MinKeyExchangeStrength |
Public property | SSLThumbPrint |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


CipherSettings Constructor

Initializes a new instance of the CipherSettings class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CipherSettings()
See Also

Reference

CipherSettings Class
Sportradar.SDK.Common Namespace


CipherSettings Properties

The CipherSettings type exposes the following members.

Properties
 | Name | Description
Public property | MinCipherStrength |
Public property | MinHashStrength |
Public property | MinKeyExchangeStrength |
Public property | SSLThumbPrint |
Top
See Also

Reference

CipherSettings Class
Sportradar.SDK.Common Namespace


CipherSettings.MinCipherStrength Property

CipherSettingsMinCipherStrength Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.CipherSettings.MinCipherStrength"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual int MinCipherStrength { get; set; }

Property Value

Int32

Implements

ICipherSettingsMinCipherStrength
See Also

Reference

CipherSettings Class
Sportradar.SDK.Common Namespace


CipherSettings.MinHashStrength Property

CipherSettingsMinHashStrength Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.CipherSettings.MinHashStrength"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual int MinHashStrength { get; set; }

Property Value

Int32

Implements

ICipherSettingsMinHashStrength
See Also

Reference

CipherSettings Class
Sportradar.SDK.Common Namespace


CipherSettings.MinKeyExchangeStrength Property

CipherSettingsMinKeyExchangeStrength Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.CipherSettings.MinKeyExchangeStrength"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual int MinKeyExchangeStrength { get; set; }

Property Value

Int32

Implements

ICipherSettingsMinKeyExchangeStrength
See Also

Reference

CipherSettings Class
Sportradar.SDK.Common Namespace


CipherSettings.SSLThumbPrint Property

CipherSettingsSSLThumbPrint Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.CipherSettings.SSLThumbPrint"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual string SSLThumbPrint { get; set; }

Property Value

String

Implements

ICipherSettingsSSLThumbPrint
See Also

Reference

CipherSettings Class
Sportradar.SDK.Common Namespace


CipherSettings Methods

The CipherSettings type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CipherSettings Class
Sportradar.SDK.Common Namespace


CipherSettings.Clone Method

CipherSettingsClone Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.CipherSettings.Clone"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Object Clone()

Return Value

Object

[Missing <returns> documentation for "M:Sportradar.SDK.Common.CipherSettings.Clone"]

Implements

ICloneableClone
See Also

Reference

CipherSettings Class
Sportradar.SDK.Common Namespace


ClientPersistentStateItem Class

Client persistent state item.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonClientPersistentStateItem

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public sealed class ClientPersistentStateItem

The ClientPersistentStateItem type exposes the following members.

Constructors
 | Name | Description
Public method | ClientPersistentStateItem | Initializes a new instance of the ClientPersistentStateItem class.
Top
Properties
 | Name | Description
Public property | ItemLastUpdated | Time when item was last updated.
Public property | Key | Persistent state item key.
Public property | Value | Persistent state item value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


ClientPersistentStateItem Constructor

Initializes a new instance of the ClientPersistentStateItem class.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ClientPersistentStateItem(
    string key,
    byte[] value,
    DateTime item_last_updated
)

Parameters

key String
The key
value Byte
The value
item_last_updated DateTime
The time the item was last updated
Exceptions
Exception | Condition
ArgumentException | key
See Also

Reference

ClientPersistentStateItem Class
Sportradar.SDK.Common Namespace


ClientPersistentStateItem Properties

The ClientPersistentStateItem type exposes the following members.

Properties
 | Name | Description
Public property | ItemLastUpdated | Time when item was last updated.
Public property | Key | Persistent state item key.
Public property | Value | Persistent state item value.
Top
See Also

Reference

ClientPersistentStateItem Class
Sportradar.SDK.Common Namespace


ClientPersistentStateItem.ItemLastUpdated Property

ClientPersistentStateItemItemLastUpdated Property

Time when item was last updated.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime ItemLastUpdated { get; set; }

Property Value

DateTime
See Also

Reference

ClientPersistentStateItem Class
Sportradar.SDK.Common Namespace


ClientPersistentStateItem.Key Property

ClientPersistentStateItemKey Property

Persistent state item key.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Key { get; set; }

Property Value

String
See Also

Reference

ClientPersistentStateItem Class
Sportradar.SDK.Common Namespace


ClientPersistentStateItem.Value Property

ClientPersistentStateItemValue Property

Persistent state item value.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public byte[] Value { get; set; }

Property Value

Byte
See Also

Reference

ClientPersistentStateItem Class
Sportradar.SDK.Common Namespace


ClientPersistentStateItem Methods

The ClientPersistentStateItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ClientPersistentStateItem Class
Sportradar.SDK.Common Namespace


ClientPersistentStateItem.GetObjectData Method

ClientPersistentStateItemGetObjectData Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.ClientPersistentStateItem.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo

[Missing <param name="info"/> documentation for "M:Sportradar.SDK.Common.ClientPersistentStateItem.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context StreamingContext

[Missing <param name="context"/> documentation for "M:Sportradar.SDK.Common.ClientPersistentStateItem.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

See Also

Reference

ClientPersistentStateItem Class
Sportradar.SDK.Common Namespace


CommonLoggerManager Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.CommonLoggerManager"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonCommonLoggerManager

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class CommonLoggerManager

The CommonLoggerManager type exposes the following members.

Properties
Name | Description
Enabled |
Top
Methods
Name | Description
GetLogger(String) |
GetLogger(Type) |
Top
See Also

Reference

Sportradar.SDK.Common Namespace


CommonLoggerManager Properties

The CommonLoggerManager type exposes the following members.

Properties
Name | Description
Enabled |
Top
See Also

Reference

CommonLoggerManager Class
Sportradar.SDK.Common Namespace


CommonLoggerManager.Enabled Property

CommonLoggerManagerEnabled Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.CommonLoggerManager.Enabled"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool Enabled { get; set; }

Property Value

Boolean
See Also

Reference

CommonLoggerManager Class
Sportradar.SDK.Common Namespace


CommonLoggerManager Methods

The CommonLoggerManager type exposes the following members.

Methods
Name | Description
GetLogger(String) |
GetLogger(Type) |
Top
See Also

Reference

CommonLoggerManager Class
Sportradar.SDK.Common Namespace


CommonLoggerManager.GetLogger Method

CommonLoggerManagerGetLogger Method

Overload List
Name | Description
GetLogger(String) |
GetLogger(Type) |
Top
See Also

Reference

CommonLoggerManager Class
Sportradar.SDK.Common Namespace


CommonLoggerManager.GetLogger(String) Method

CommonLoggerManagerGetLogger(String) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.CommonLoggerManager.GetLogger(System.String)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static ILog GetLogger(
    string type
)

Parameters

type String

[Missing <param name="type"/> documentation for "M:Sportradar.SDK.Common.CommonLoggerManager.GetLogger(System.String)"]

Return Value

ILog

[Missing <returns> documentation for "M:Sportradar.SDK.Common.CommonLoggerManager.GetLogger(System.String)"]

See Also

Reference

CommonLoggerManager Class
GetLogger Overload
Sportradar.SDK.Common Namespace


CommonLoggerManager.GetLogger(Type) Method

CommonLoggerManagerGetLogger(Type) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.CommonLoggerManager.GetLogger(System.Type)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static ILog GetLogger(
    Type type
)

Parameters

type Type

[Missing <param name="type"/> documentation for "M:Sportradar.SDK.Common.CommonLoggerManager.GetLogger(System.Type)"]

Return Value

ILog

[Missing <returns> documentation for "M:Sportradar.SDK.Common.CommonLoggerManager.GetLogger(System.Type)"]

See Also

Reference

CommonLoggerManager Class
GetLogger Overload
Sportradar.SDK.Common Namespace


ConfigItem Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.ConfigItem"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonConfigItem

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class ConfigItem

The ConfigItem type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigItem | Initializes a new instance of the ConfigItem class
Top
Properties
 | Name | Description
Public property | Key |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


ConfigItem Constructor

Initializes a new instance of the ConfigItem class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ConfigItem()
See Also

Reference

ConfigItem Class
Sportradar.SDK.Common Namespace


ConfigItem Properties

The ConfigItem type exposes the following members.

Properties
 | Name | Description
Public property | Key |
Public property | Value |
Top
See Also

Reference

ConfigItem Class
Sportradar.SDK.Common Namespace


ConfigItem.Key Property

ConfigItemKey Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConfigItem.Key"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Key { get; set; }

Property Value

String
See Also

Reference

ConfigItem Class
Sportradar.SDK.Common Namespace


ConfigItem.Value Property

ConfigItemValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConfigItem.Value"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; set; }

Property Value

String
See Also

Reference

ConfigItem Class
Sportradar.SDK.Common Namespace


ConfigItem Methods

The ConfigItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConfigItem Class
Sportradar.SDK.Common Namespace


ConnectionData Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.ConnectionData"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonConnectionData

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class ConnectionData : IConnectionData,
    ICloneable

The ConnectionData type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionData | Initializes a new instance of the ConnectionData class
Top
Properties
 | Name | Description
Public property | CipherSettings |
Public property | ClientAliveMsgTimeout |
Public property | DisallowNonPrintableChars |
Public property | DoValidityCheck |
Public property | Encoding |
Public property | Hostname |
Public property | InvalidDataReconnectWait |
Public property | MaxReconnectWait |
Public property | MinReconnectWait |
Public property | Port |
Public property | ReceiveBufferSize |
Public property | ReceiveTimeout |
Public property | SendTimeout |
Public property | ServerAliveMsgTimeout |
Public property | TotalBufferSize |
Public property | UseSSL |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


ConnectionData Constructor

Initializes a new instance of the ConnectionData class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ConnectionData()
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData Properties

The ConnectionData type exposes the following members.

Properties
 | Name | Description
Public property | CipherSettings |
Public property | ClientAliveMsgTimeout |
Public property | DisallowNonPrintableChars |
Public property | DoValidityCheck |
Public property | Encoding |
Public property | Hostname |
Public property | InvalidDataReconnectWait |
Public property | MaxReconnectWait |
Public property | MinReconnectWait |
Public property | Port |
Public property | ReceiveBufferSize |
Public property | ReceiveTimeout |
Public property | SendTimeout |
Public property | ServerAliveMsgTimeout |
Public property | TotalBufferSize |
Public property | UseSSL |
Top
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.CipherSettings Property

ConnectionDataCipherSettings Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.CipherSettings"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual ICipherSettings CipherSettings { get; set; }

Property Value

ICipherSettings

Implements

IConnectionDataCipherSettings
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.ClientAliveMsgTimeout Property

ConnectionDataClientAliveMsgTimeout Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.ClientAliveMsgTimeout"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual TimeSpan ClientAliveMsgTimeout { get; set; }

Property Value

TimeSpan

Implements

IConnectionDataClientAliveMsgTimeout
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.DisallowNonPrintableChars Property

ConnectionDataDisallowNonPrintableChars Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.DisallowNonPrintableChars"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool DisallowNonPrintableChars { get; set; }

Property Value

Boolean

Implements

IConnectionDataDisallowNonPrintableChars
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.DoValidityCheck Property

ConnectionDataDoValidityCheck Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.DoValidityCheck"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool DoValidityCheck { get; set; }

Property Value

Boolean

Implements

IConnectionDataDoValidityCheck
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.Encoding Property

ConnectionDataEncoding Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.Encoding"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual Encoding Encoding { get; set; }

Property Value

Encoding

Implements

IConnectionDataEncoding
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.Hostname Property

ConnectionDataHostname Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.Hostname"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual string Hostname { get; set; }

Property Value

String

Implements

IConnectionDataHostname
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.InvalidDataReconnectWait Property

ConnectionDataInvalidDataReconnectWait Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.InvalidDataReconnectWait"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual TimeSpan InvalidDataReconnectWait { get; set; }

Property Value

TimeSpan

Implements

IConnectionDataInvalidDataReconnectWait
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.MaxReconnectWait Property

ConnectionDataMaxReconnectWait Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.MaxReconnectWait"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual TimeSpan MaxReconnectWait { get; set; }

Property Value

TimeSpan

Implements

IConnectionDataMaxReconnectWait
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.MinReconnectWait Property

ConnectionDataMinReconnectWait Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.MinReconnectWait"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual TimeSpan MinReconnectWait { get; set; }

Property Value

TimeSpan

Implements

IConnectionDataMinReconnectWait
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.Port Property

ConnectionDataPort Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.Port"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual int Port { get; set; }

Property Value

Int32

Implements

IConnectionDataPort
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.ReceiveBufferSize Property

ConnectionDataReceiveBufferSize Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.ReceiveBufferSize"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual int ReceiveBufferSize { get; set; }

Property Value

Int32

Implements

IConnectionDataReceiveBufferSize
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.ReceiveTimeout Property

ConnectionDataReceiveTimeout Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.ReceiveTimeout"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual TimeSpan ReceiveTimeout { get; set; }

Property Value

TimeSpan

Implements

IConnectionDataReceiveTimeout
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.SendTimeout Property

ConnectionDataSendTimeout Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.SendTimeout"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual TimeSpan SendTimeout { get; set; }

Property Value

TimeSpan

Implements

IConnectionDataSendTimeout
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.ServerAliveMsgTimeout Property

ConnectionDataServerAliveMsgTimeout Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.ServerAliveMsgTimeout"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual TimeSpan ServerAliveMsgTimeout { get; set; }

Property Value

TimeSpan

Implements

IConnectionDataServerAliveMsgTimeout
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.TotalBufferSize Property

ConnectionDataTotalBufferSize Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.TotalBufferSize"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual int TotalBufferSize { get; set; }

Property Value

Int32

Implements

IConnectionDataTotalBufferSize
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.UseSSL Property

ConnectionDataUseSSL Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ConnectionData.UseSSL"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool UseSSL { get; set; }

Property Value

Boolean

Implements

IConnectionDataUseSSL
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData Methods

The ConnectionData type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


ConnectionData.Clone Method

ConnectionDataClone Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.ConnectionData.Clone"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual Object Clone()

Return Value

Object

[Missing <returns> documentation for "M:Sportradar.SDK.Common.ConnectionData.Clone"]

Implements

ICloneableClone
See Also

Reference

ConnectionData Class
Sportradar.SDK.Common Namespace


DynamicConfigIgnoreClassAttribute Class

Attribute specifying that ConfigurationElement can be ignored by the dynamic configuration handling code.
Inheritance Hierarchy
SystemObject
SystemAttribute
Sportradar.SDK.CommonDynamicConfigIgnoreClassAttribute

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class DynamicConfigIgnoreClassAttribute : Attribute

The DynamicConfigIgnoreClassAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicConfigIgnoreClassAttribute | Initializes a new instance of the DynamicConfigIgnoreClassAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


DynamicConfigIgnoreClassAttribute Constructor

Initializes a new instance of the DynamicConfigIgnoreClassAttribute class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DynamicConfigIgnoreClassAttribute()
See Also

Reference

DynamicConfigIgnoreClassAttribute Class
Sportradar.SDK.Common Namespace


DynamicConfigIgnoreClassAttribute Properties

The DynamicConfigIgnoreClassAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
See Also

Reference

DynamicConfigIgnoreClassAttribute Class
Sportradar.SDK.Common Namespace


DynamicConfigIgnoreClassAttribute Methods

The DynamicConfigIgnoreClassAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DynamicConfigIgnoreClassAttribute Class
Sportradar.SDK.Common Namespace


DynamicConfigItemAttribute Class

Attribute specifying configuration property as dynamic. Dynamic configuration properties can be updated by configuration server in runtime.
Inheritance Hierarchy
SystemObject
SystemAttribute
Sportradar.SDK.CommonDynamicConfigItemAttribute

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class DynamicConfigItemAttribute : Attribute

The DynamicConfigItemAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicConfigItemAttribute | Initializes a new instance of the DynamicConfigItemAttribute class
Public method | DynamicConfigItemAttribute(String) | Initializes a new instance of the DynamicConfigItemAttribute class
Top
Properties
 | Name | Description
Public property | DefaultValue |
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


DynamicConfigItemAttribute Constructor

Overload List
 | Name | Description
Public method | DynamicConfigItemAttribute | Initializes a new instance of the DynamicConfigItemAttribute class
Public method | DynamicConfigItemAttribute(String) | Initializes a new instance of the DynamicConfigItemAttribute class
Top
See Also

Reference

DynamicConfigItemAttribute Class
Sportradar.SDK.Common Namespace


DynamicConfigItemAttribute Constructor

Initializes a new instance of the DynamicConfigItemAttribute class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DynamicConfigItemAttribute()
See Also

Reference

DynamicConfigItemAttribute Class
DynamicConfigItemAttribute Overload
Sportradar.SDK.Common Namespace


DynamicConfigItemAttribute(String) Constructor

Initializes a new instance of the DynamicConfigItemAttribute class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DynamicConfigItemAttribute(
    string name
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Sportradar.SDK.Common.DynamicConfigItemAttribute.#ctor(System.String)"]

See Also

Reference

DynamicConfigItemAttribute Class
DynamicConfigItemAttribute Overload
Sportradar.SDK.Common Namespace


DynamicConfigItemAttribute Properties

The DynamicConfigItemAttribute type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue |
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
See Also

Reference

DynamicConfigItemAttribute Class
Sportradar.SDK.Common Namespace


DynamicConfigItemAttribute.DefaultValue Property

DynamicConfigItemAttributeDefaultValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.DynamicConfigItemAttribute.DefaultValue"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Object DefaultValue { get; set; }

Property Value

Object
See Also

Reference

DynamicConfigItemAttribute Class
Sportradar.SDK.Common Namespace


DynamicConfigItemAttribute.Name Property

DynamicConfigItemAttributeName Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.DynamicConfigItemAttribute.Name"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

DynamicConfigItemAttribute Class
Sportradar.SDK.Common Namespace


DynamicConfigItemAttribute Methods

The DynamicConfigItemAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DynamicConfigItemAttribute Class
Sportradar.SDK.Common Namespace


EntityBase Class

Serves as a base class for all client data contracts/entities.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LcooLcooEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class EntityBase

The EntityBase type exposes the following members.

Constructors
 | Name | Description
Public method | EntityBase | Initializes a new instance of the EntityBase class
Top
Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


EntityBase Constructor

Initializes a new instance of the EntityBase class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EntityBase(
    XmlAttribute[] any_attr
)

Parameters

any_attr XmlAttribute

[Missing <param name="any_attr"/> documentation for "M:Sportradar.SDK.Common.EntityBase.#ctor(System.Xml.XmlAttribute[])"]

See Also

Reference

EntityBase Class
Sportradar.SDK.Common Namespace


EntityBase Properties

The EntityBase type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples.
Top
See Also

Reference

EntityBase Class
Sportradar.SDK.Common Namespace


EntityBase.AdditionalData Property

EntityBaseAdditionalData Property

Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IDictionary<string, string> AdditionalData { get; }

Property Value

IDictionary String, String
See Also

Reference

EntityBase Class
Sportradar.SDK.Common Namespace


EntityBase Methods

The EntityBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

EntityBase Class
Sportradar.SDK.Common Namespace


EntityBase.ToString Method

EntityBaseToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

EntityBase Class
Sportradar.SDK.Common Namespace


GlobalSettings Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.GlobalSettings"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonGlobalSettings

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class GlobalSettings

The GlobalSettings type exposes the following members.

Fields
Name | Description
ERROR_STRING |
SDK_LOG_REPOSITORY |
Top
See Also

Reference

Sportradar.SDK.Common Namespace


GlobalSettings Fields

The GlobalSettings type exposes the following members.

Fields
Name | Description
ERROR_STRING |
SDK_LOG_REPOSITORY |
Top
See Also

Reference

GlobalSettings Class
Sportradar.SDK.Common Namespace


GlobalSettings.ERROR_STRING Field

GlobalSettingsERROR_STRING Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.GlobalSettings.ERROR_STRING"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const string ERROR_STRING = "Error at ToString()"

Field Value

String
See Also

Reference

GlobalSettings Class
Sportradar.SDK.Common Namespace


GlobalSettings.SDK_LOG_REPOSITORY Field

GlobalSettingsSDK_LOG_REPOSITORY Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.GlobalSettings.SDK_LOG_REPOSITORY"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const string SDK_LOG_REPOSITORY = "SdkLogRepository"

Field Value

String
See Also

Reference

GlobalSettings Class
Sportradar.SDK.Common Namespace


LiveOddsPersistentStateItem Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.LiveOddsPersistentStateItem"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonPersistentStateItem
Sportradar.SDK.CommonLiveOddsPersistentStateItem

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class LiveOddsPersistentStateItem : PersistentStateItem

The LiveOddsPersistentStateItem type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsPersistentStateItem(ClientPersistentStateItem) | Initializes a new instance of the LiveOddsPersistentStateItem class
Public method | LiveOddsPersistentStateItem(ProtocolProviderType, Int64, NullableInt64, DateTime, Boolean) | Initializes a new instance of the LiveOddsPersistentStateItem class
Top
Properties
 | Name | Description
Public property | Active |
Public property | EntityTimeStamp |
Public property | IsDirty | (Inherited from PersistentStateItem)
Public property | ItemLastUpdated | (Inherited from PersistentStateItem)
Public property | Key | (Inherited from PersistentStateItem)
Public property | MatchId |
Public property | Msgnr |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToClientItem | (Overrides PersistentStateItemToClientItem)
Public method | ToString | Returns a string that represents the current object. (Overrides PersistentStateItemToString)
Public method | Touch | (Inherited from PersistentStateItem)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


LiveOddsPersistentStateItem Constructor

Overload List
 | Name | Description
Public method | LiveOddsPersistentStateItem(ClientPersistentStateItem) | Initializes a new instance of the LiveOddsPersistentStateItem class
Public method | LiveOddsPersistentStateItem(ProtocolProviderType, Int64, NullableInt64, DateTime, Boolean) | Initializes a new instance of the LiveOddsPersistentStateItem class
Top
See Also

Reference

LiveOddsPersistentStateItem Class
Sportradar.SDK.Common Namespace


LiveOddsPersistentStateItem(ClientPersistentStateItem) Constructor

Initializes a new instance of the LiveOddsPersistentStateItem class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsPersistentStateItem(
    ClientPersistentStateItem item
)

Parameters

item ClientPersistentStateItem

[Missing <param name="item"/> documentation for "M:Sportradar.SDK.Common.LiveOddsPersistentStateItem.#ctor(Sportradar.SDK.Common.ClientPersistentStateItem)"]

See Also

Reference

LiveOddsPersistentStateItem Class
LiveOddsPersistentStateItem Overload
Sportradar.SDK.Common Namespace


LiveOddsPersistentStateItem(ProtocolProviderType, Int64, Nullable<Int64>, DateTime, Boolean) Constructor

LiveOddsPersistentStateItem(ProtocolProviderType, Int64, NullableInt64, DateTime, Boolean) Constructor

Initializes a new instance of the LiveOddsPersistentStateItem class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsPersistentStateItem(
    ProtocolProviderType type,
    long match_id,
    long? msg_nr,
    DateTime entity_timestamp,
    bool active
)

Parameters

type ProtocolProviderType

[Missing <param name="type"/> documentation for "M:Sportradar.SDK.Common.LiveOddsPersistentStateItem.#ctor(Sportradar.SDK.Common.ProtocolProviderType,System.Int64,System.Nullable{System.Int64},System.DateTime,System.Boolean)"]

match_id Int64

[Missing <param name="match_id"/> documentation for "M:Sportradar.SDK.Common.LiveOddsPersistentStateItem.#ctor(Sportradar.SDK.Common.ProtocolProviderType,System.Int64,System.Nullable{System.Int64},System.DateTime,System.Boolean)"]

msg_nr Nullable Int64

[Missing <param name="msg_nr"/> documentation for "M:Sportradar.SDK.Common.LiveOddsPersistentStateItem.#ctor(Sportradar.SDK.Common.ProtocolProviderType,System.Int64,System.Nullable{System.Int64},System.DateTime,System.Boolean)"]

entity_timestamp DateTime

[Missing <param name="entity_timestamp"/> documentation for "M:Sportradar.SDK.Common.LiveOddsPersistentStateItem.#ctor(Sportradar.SDK.Common.ProtocolProviderType,System.Int64,System.Nullable{System.Int64},System.DateTime,System.Boolean)"]

active Boolean

[Missing <param name="active"/> documentation for "M:Sportradar.SDK.Common.LiveOddsPersistentStateItem.#ctor(Sportradar.SDK.Common.ProtocolProviderType,System.Int64,System.Nullable{System.Int64},System.DateTime,System.Boolean)"]

See Also

Reference

LiveOddsPersistentStateItem Class
LiveOddsPersistentStateItem Overload
Sportradar.SDK.Common Namespace


LiveOddsPersistentStateItem Properties

The LiveOddsPersistentStateItem type exposes the following members.

Properties
 | Name | Description
Public property | Active |
Public property | EntityTimeStamp |
Public property | IsDirty | (Inherited from PersistentStateItem)
Public property | ItemLastUpdated | (Inherited from PersistentStateItem)
Public property | Key | (Inherited from PersistentStateItem)
Public property | MatchId |
Public property | Msgnr |
Top
See Also

Reference

LiveOddsPersistentStateItem Class
Sportradar.SDK.Common Namespace


LiveOddsPersistentStateItem.Active Property

LiveOddsPersistentStateItemActive Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.LiveOddsPersistentStateItem.Active"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Active { get; set; }

Property Value

Boolean
See Also

Reference

LiveOddsPersistentStateItem Class
Sportradar.SDK.Common Namespace


LiveOddsPersistentStateItem.EntityTimeStamp Property

LiveOddsPersistentStateItemEntityTimeStamp Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.LiveOddsPersistentStateItem.EntityTimeStamp"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime EntityTimeStamp { get; set; }

Property Value

DateTime
See Also

Reference

LiveOddsPersistentStateItem Class
Sportradar.SDK.Common Namespace


LiveOddsPersistentStateItem.MatchId Property

LiveOddsPersistentStateItemMatchId Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.LiveOddsPersistentStateItem.MatchId"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long MatchId { get; }

Property Value

Int64
See Also

Reference

LiveOddsPersistentStateItem Class
Sportradar.SDK.Common Namespace


LiveOddsPersistentStateItem.Msgnr Property

LiveOddsPersistentStateItemMsgnr Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.LiveOddsPersistentStateItem.Msgnr"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Msgnr { get; set; }

Property Value

Nullable Int64
See Also

Reference

LiveOddsPersistentStateItem Class
Sportradar.SDK.Common Namespace


LiveOddsPersistentStateItem Methods

The LiveOddsPersistentStateItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToClientItem | (Overrides PersistentStateItemToClientItem)
Public method | ToString | Returns a string that represents the current object. (Overrides PersistentStateItemToString)
Public method | Touch | (Inherited from PersistentStateItem)
Top
See Also

Reference

LiveOddsPersistentStateItem Class
Sportradar.SDK.Common Namespace


LiveOddsPersistentStateItem.ToClientItem Method

LiveOddsPersistentStateItemToClientItem Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.LiveOddsPersistentStateItem.ToClientItem"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override ClientPersistentStateItem ToClientItem()

Return Value

ClientPersistentStateItem

[Missing <returns> documentation for "M:Sportradar.SDK.Common.LiveOddsPersistentStateItem.ToClientItem"]

See Also

Reference

LiveOddsPersistentStateItem Class
Sportradar.SDK.Common Namespace


LiveOddsPersistentStateItem.ToString Method

LiveOddsPersistentStateItemToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

LiveOddsPersistentStateItem Class
Sportradar.SDK.Common Namespace


LocalizedString Class

Localized string container where a string is represented by its international value and a collection of translations to other languages.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonLocalizedString

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class LocalizedString : IEquatable<LocalizedString>

The LocalizedString type exposes the following members.

Constructors
 | Name | Description
Public method | LocalizedString | Constructs a new localized string.
Top
Properties
 | Name | Description
Public property | AvailableTranslationLanguages | Available language codes this instance is translated to. For instance "de", "en" and so on.
Public property | International | Returns international string.
Top
Methods
 | Name | Description
Public method | AddTranslation | Adds a new translation to the string. Overrides the previous language translations if existed.
Public method | Equals(LocalizedString) | Check for equality.
Public method | Equals(Object) | Check for equality. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode)
Public method | GetTranslation | Returns translation for the specified language. Falls back to international string if translation does not exist.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns international string (Overrides ObjectToString)
Top
Operators
Name | Description
Equality(LocalizedString, LocalizedString) | Check for equality.
Inequality(LocalizedString, LocalizedString) | Check for non-equality.
Top
Extension Methods
 | Name | Description
Public Extension Method | CloneWithValueReplacement | (Defined by DiffEngine)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


LocalizedString Constructor

Constructs a new localized string.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString(
    string international_value
)

Parameters

international_value String
International value
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LocalizedString Properties

The LocalizedString type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslationLanguages | Available language codes this instance is translated to. For instance "de", "en" and so on.
Public property | International | Returns international string.
Top
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LocalizedString.AvailableTranslationLanguages Property

LocalizedStringAvailableTranslationLanguages Property

Available language codes this instance is translated to. For instance "de", "en" and so on.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string[] AvailableTranslationLanguages { get; }

Property Value

String
Remarks
Might be empty, then you still have the international name
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LocalizedString.International Property

LocalizedStringInternational Property

Returns international string.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string International { get; }

Property Value

String
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LocalizedString Methods

The LocalizedString type exposes the following members.

Methods
 | Name | Description
Public method | AddTranslation | Adds a new translation to the string. Overrides the previous language translations if existed.
Public method | Equals(LocalizedString) | Check for equality.
Public method | Equals(Object) | Check for equality. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode)
Public method | GetTranslation | Returns translation for the specified language. Falls back to international string if translation does not exist.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns international string (Overrides ObjectToString)
Top
Extension Methods
 | Name | Description
Public Extension Method | CloneWithValueReplacement | (Defined by DiffEngine)
Top
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LocalizedString.AddTranslation Method

LocalizedStringAddTranslation Method

Adds a new translation to the string. Overrides the previous language translations if existed.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void AddTranslation(
    string lang,
    string translation
)

Parameters

lang String
Language code
translation String
Translation for this language
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LocalizedString.Equals Method

LocalizedStringEquals Method

Overload List
 | Name | Description
Public method | Equals(LocalizedString) | Check for equality.
Public method | Equals(Object) | Check for equality.
Top
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LocalizedString.Equals(LocalizedString) Method

LocalizedStringEquals(LocalizedString) Method

Check for equality.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Equals(
    LocalizedString other
)

Parameters

other LocalizedString
other object

Return Value

Boolean
true when equal; false else

Implements

IEquatableTEquals(T)
Remarks
Compares by the international value only.
See Also

Reference

LocalizedString Class
Equals Overload
Sportradar.SDK.Common Namespace


LocalizedString.Equals(Object) Method

LocalizedStringEquals(Object) Method

Check for equality.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object
other object

Return Value

Boolean
true when equal; false else
See Also

Reference

LocalizedString Class
Equals Overload
Sportradar.SDK.Common Namespace


LocalizedString.GetHashCode Method

LocalizedStringGetHashCode Method

Serves as a hash function for a particular type.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32
Hash for current object
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LocalizedString.GetTranslation Method

LocalizedStringGetTranslation Method

Returns translation for the specified language. Falls back to international string if translation does not exist.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string GetTranslation(
    string lang
)

Parameters

lang String
Language code (null for international string)

Return Value

String
Translation for the specified language.
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LocalizedString.ToString Method

LocalizedStringToString Method

Returns international string

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
International string
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LocalizedString Operators

The LocalizedString type exposes the following members.

Operators
Name | Description
Equality(LocalizedString, LocalizedString) | Check for equality.
Inequality(LocalizedString, LocalizedString) | Check for non-equality.
Top
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LocalizedString.Equality Operator

LocalizedStringEquality Operator

Check for equality.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool operator ==(
    LocalizedString x,
    LocalizedString y
)

Parameters

x LocalizedString
First object
y LocalizedString
Second object

Return Value

Boolean
true when equal; false else
Remarks
Compares by the international value only.
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LocalizedString.Inequality Operator

LocalizedStringInequality Operator

Check for non-equality.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool operator !=(
    LocalizedString x,
    LocalizedString y
)

Parameters

x LocalizedString
First object
y LocalizedString
Second object

Return Value

Boolean
true when not equal; false else
Remarks
Compares by the international value only.
See Also

Reference

LocalizedString Class
Sportradar.SDK.Common Namespace


LoggerData Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.LoggerData"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonLoggerData

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LoggerData : ILoggerData, ICloneable

The LoggerData type exposes the following members.

Constructors
 | Name | Description
Public method | LoggerData | Initializes a new instance of the LoggerData class
Top
Properties
 | Name | Description
Public property | AlertLogLevel |
Public property | ClientInteractionLogLevel |
Public property | ConfigLogLevel |
Public property | DeadLetterLogLevel |
Public property | InvalidMsgLogLevel |
Public property | LoggingFeedName |
Public property | StatsLogLevel |
Public property | TrafficLogLevel |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


LoggerData Constructor

Initializes a new instance of the LoggerData class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LoggerData()
See Also

Reference

LoggerData Class
Sportradar.SDK.Common Namespace


LoggerData Properties

The LoggerData type exposes the following members.

Properties
 | Name | Description
Public property | AlertLogLevel |
Public property | ClientInteractionLogLevel |
Public property | ConfigLogLevel |
Public property | DeadLetterLogLevel |
Public property | InvalidMsgLogLevel |
Public property | LoggingFeedName |
Public property | StatsLogLevel |
Public property | TrafficLogLevel |
Top
See Also

Reference

LoggerData Class
Sportradar.SDK.Common Namespace


LoggerData.AlertLogLevel Property

LoggerDataAlertLogLevel Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.LoggerData.AlertLogLevel"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Level AlertLogLevel { get; set; }

Property Value

Level

Implements

ILoggerDataAlertLogLevel
See Also

Reference

LoggerData Class
Sportradar.SDK.Common Namespace


LoggerData.ClientInteractionLogLevel Property

LoggerDataClientInteractionLogLevel Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.LoggerData.ClientInteractionLogLevel"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Level ClientInteractionLogLevel { get; set; }

Property Value

Level

Implements

ILoggerDataClientInteractionLogLevel
See Also

Reference

LoggerData Class
Sportradar.SDK.Common Namespace


LoggerData.ConfigLogLevel Property

LoggerDataConfigLogLevel Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.LoggerData.ConfigLogLevel"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Level ConfigLogLevel { get; set; }

Property Value

Level
See Also

Reference

LoggerData Class
Sportradar.SDK.Common Namespace


LoggerData.DeadLetterLogLevel Property

LoggerDataDeadLetterLogLevel Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.LoggerData.DeadLetterLogLevel"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Level DeadLetterLogLevel { get; set; }

Property Value

Level

Implements

ILoggerDataDeadLetterLogLevel
See Also

Reference

LoggerData Class
Sportradar.SDK.Common Namespace


LoggerData.InvalidMsgLogLevel Property

LoggerDataInvalidMsgLogLevel Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.LoggerData.InvalidMsgLogLevel"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Level InvalidMsgLogLevel { get; set; }

Property Value

Level

Implements

ILoggerDataInvalidMsgLogLevel
See Also

Reference

LoggerData Class
Sportradar.SDK.Common Namespace


LoggerData.LoggingFeedName Property

LoggerDataLoggingFeedName Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.LoggerData.LoggingFeedName"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string LoggingFeedName { get; set; }

Property Value

String

Implements

ILoggerDataLoggingFeedName
See Also

Reference

LoggerData Class
Sportradar.SDK.Common Namespace


LoggerData.StatsLogLevel Property

LoggerDataStatsLogLevel Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.LoggerData.StatsLogLevel"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Level StatsLogLevel { get; set; }

Property Value

Level
See Also

Reference

LoggerData Class
Sportradar.SDK.Common Namespace


LoggerData.TrafficLogLevel Property

LoggerDataTrafficLogLevel Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.LoggerData.TrafficLogLevel"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Level TrafficLogLevel { get; set; }

Property Value

Level

Implements

ILoggerDataTrafficLogLevel
See Also

Reference

LoggerData Class
Sportradar.SDK.Common Namespace


LoggerData Methods

The LoggerData type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LoggerData Class
Sportradar.SDK.Common Namespace


LoggerData.Clone Method

LoggerDataClone Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.LoggerData.Clone"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Object Clone()

Return Value

Object

[Missing <returns> documentation for "M:Sportradar.SDK.Common.LoggerData.Clone"]

Implements

ICloneableClone
See Also

Reference

LoggerData Class
Sportradar.SDK.Common Namespace


PersistentStateItem Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.PersistentStateItem"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonPersistentStateItem
Sportradar.SDK.CommonLiveOddsPersistentStateItem

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class PersistentStateItem

The PersistentStateItem type exposes the following members.

Properties
 | Name | Description
Public property | IsDirty |
Public property | ItemLastUpdated |
Public property | Key |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | FromClientItem |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToClientItem |
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Public method | Touch |
Top
See Also

Reference

Sportradar.SDK.Common Namespace


PersistentStateItem Properties

The PersistentStateItem type exposes the following members.

Properties
 | Name | Description
Public property | IsDirty |
Public property | ItemLastUpdated |
Public property | Key |
Top
See Also

Reference

PersistentStateItem Class
Sportradar.SDK.Common Namespace


PersistentStateItem.IsDirty Property

PersistentStateItemIsDirty Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PersistentStateItem.IsDirty"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsDirty { get; set; }

Property Value

Boolean
See Also

Reference

PersistentStateItem Class
Sportradar.SDK.Common Namespace


PersistentStateItem.ItemLastUpdated Property

PersistentStateItemItemLastUpdated Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PersistentStateItem.ItemLastUpdated"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual DateTime ItemLastUpdated { get; set; }

Property Value

DateTime
See Also

Reference

PersistentStateItem Class
Sportradar.SDK.Common Namespace


PersistentStateItem.Key Property

PersistentStateItemKey Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PersistentStateItem.Key"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PersistentStateItemKey Key { get; }

Property Value

PersistentStateItemKey
See Also

Reference

PersistentStateItem Class
Sportradar.SDK.Common Namespace


PersistentStateItem Methods

The PersistentStateItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | FromClientItem |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToClientItem |
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Public method | Touch |
Top
See Also

Reference

PersistentStateItem Class
Sportradar.SDK.Common Namespace


PersistentStateItem.FromClientItem Method

PersistentStateItemFromClientItem Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PersistentStateItem.FromClientItem(Sportradar.SDK.Common.ClientPersistentStateItem)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static PersistentStateItem FromClientItem(
    ClientPersistentStateItem client_item
)

Parameters

client_item ClientPersistentStateItem

[Missing <param name="client_item"/> documentation for "M:Sportradar.SDK.Common.PersistentStateItem.FromClientItem(Sportradar.SDK.Common.ClientPersistentStateItem)"]

Return Value

PersistentStateItem

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PersistentStateItem.FromClientItem(Sportradar.SDK.Common.ClientPersistentStateItem)"]

See Also

Reference

PersistentStateItem Class
Sportradar.SDK.Common Namespace


PersistentStateItem.ToClientItem Method

PersistentStateItemToClientItem Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PersistentStateItem.ToClientItem"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual ClientPersistentStateItem ToClientItem()

Return Value

ClientPersistentStateItem

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PersistentStateItem.ToClientItem"]

See Also

Reference

PersistentStateItem Class
Sportradar.SDK.Common Namespace


PersistentStateItem.ToString Method

PersistentStateItemToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

PersistentStateItem Class
Sportradar.SDK.Common Namespace


PersistentStateItem.Touch Method

PersistentStateItemTouch Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PersistentStateItem.Touch"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Touch()
See Also

Reference

PersistentStateItem Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.PersistentStateItemKey"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonPersistentStateItemKey

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class PersistentStateItemKey : IEquatable<PersistentStateItemKey>

The PersistentStateItemKey type exposes the following members.

Constructors
 | Name | Description
Public method | PersistentStateItemKey | Initializes a new instance of the PersistentStateItemKey class
Top
Properties
 | Name | Description
Public property | Key |
Public property | ProviderType |
Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | Equals(PersistentStateItemKey) |
 | FromClientKey |
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToClientKey |
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
Operators
Name | Description
Equality(PersistentStateItemKey, PersistentStateItemKey) |
Inequality(PersistentStateItemKey, PersistentStateItemKey) |
Top
See Also

Reference

Sportradar.SDK.Common Namespace


PersistentStateItemKey Constructor

Initializes a new instance of the PersistentStateItemKey class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PersistentStateItemKey(
    ProtocolProviderType provider_type,
    string key
)

Parameters

provider_type ProtocolProviderType

[Missing <param name="provider_type"/> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.#ctor(Sportradar.SDK.Common.ProtocolProviderType,System.String)"]

key String

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.#ctor(Sportradar.SDK.Common.ProtocolProviderType,System.String)"]

See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey Properties

The PersistentStateItemKey type exposes the following members.

Properties
 | Name | Description
Public property | Key |
Public property | ProviderType |
Top
See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey.Key Property

PersistentStateItemKeyKey Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PersistentStateItemKey.Key"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Key { get; }

Property Value

String
See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey.ProviderType Property

PersistentStateItemKeyProviderType Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PersistentStateItemKey.ProviderType"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey Methods

The PersistentStateItemKey type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | Equals(PersistentStateItemKey) |
 | FromClientKey |
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToClientKey |
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey.Equals Method

PersistentStateItemKeyEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) |
Public method | Equals(PersistentStateItemKey) |
Top
See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey.Equals(Object) Method

PersistentStateItemKeyEquals(Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.Equals(System.Object)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.Equals(System.Object)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.Equals(System.Object)"]

See Also

Reference

PersistentStateItemKey Class
Equals Overload
Sportradar.SDK.Common Namespace


PersistentStateItemKey.Equals(PersistentStateItemKey) Method

PersistentStateItemKeyEquals(PersistentStateItemKey) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.Equals(Sportradar.SDK.Common.PersistentStateItemKey)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Equals(
    PersistentStateItemKey other
)

Parameters

other PersistentStateItemKey

[Missing <param name="other"/> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.Equals(Sportradar.SDK.Common.PersistentStateItemKey)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.Equals(Sportradar.SDK.Common.PersistentStateItemKey)"]

Implements

IEquatableTEquals(T)
See Also

Reference

PersistentStateItemKey Class
Equals Overload
Sportradar.SDK.Common Namespace


PersistentStateItemKey.FromClientKey Method

PersistentStateItemKeyFromClientKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.FromClientKey(System.String)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static PersistentStateItemKey FromClientKey(
    string key
)

Parameters

key String

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.FromClientKey(System.String)"]

Return Value

PersistentStateItemKey

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.FromClientKey(System.String)"]

See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey.GetHashCode Method

PersistentStateItemKeyGetHashCode Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.GetHashCode"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.GetHashCode"]

See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey.GetObjectData Method

PersistentStateItemKeyGetObjectData Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo

[Missing <param name="info"/> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context StreamingContext

[Missing <param name="context"/> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey.ToClientKey Method

PersistentStateItemKeyToClientKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.ToClientKey"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ToClientKey()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.ToClientKey"]

See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey.ToString Method

PersistentStateItemKeyToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey Operators

The PersistentStateItemKey type exposes the following members.

Operators
Name | Description
Equality(PersistentStateItemKey, PersistentStateItemKey) |
Inequality(PersistentStateItemKey, PersistentStateItemKey) |
Top
See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey.Equality Operator

PersistentStateItemKeyEquality Operator

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.op_Equality(Sportradar.SDK.Common.PersistentStateItemKey,Sportradar.SDK.Common.PersistentStateItemKey)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool operator ==(
    PersistentStateItemKey x,
    PersistentStateItemKey y
)

Parameters

x PersistentStateItemKey

[Missing <param name="x"/> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.op_Equality(Sportradar.SDK.Common.PersistentStateItemKey,Sportradar.SDK.Common.PersistentStateItemKey)"]

y PersistentStateItemKey

[Missing <param name="y"/> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.op_Equality(Sportradar.SDK.Common.PersistentStateItemKey,Sportradar.SDK.Common.PersistentStateItemKey)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.op_Equality(Sportradar.SDK.Common.PersistentStateItemKey,Sportradar.SDK.Common.PersistentStateItemKey)"]

See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PersistentStateItemKey.Inequality Operator

PersistentStateItemKeyInequality Operator

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.op_Inequality(Sportradar.SDK.Common.PersistentStateItemKey,Sportradar.SDK.Common.PersistentStateItemKey)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool operator !=(
    PersistentStateItemKey x,
    PersistentStateItemKey y
)

Parameters

x PersistentStateItemKey

[Missing <param name="x"/> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.op_Inequality(Sportradar.SDK.Common.PersistentStateItemKey,Sportradar.SDK.Common.PersistentStateItemKey)"]

y PersistentStateItemKey

[Missing <param name="y"/> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.op_Inequality(Sportradar.SDK.Common.PersistentStateItemKey,Sportradar.SDK.Common.PersistentStateItemKey)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PersistentStateItemKey.op_Inequality(Sportradar.SDK.Common.PersistentStateItemKey,Sportradar.SDK.Common.PersistentStateItemKey)"]

See Also

Reference

PersistentStateItemKey Class
Sportradar.SDK.Common Namespace


PoisonQueueElt Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.PoisonQueueElt"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonPoisonQueueElt

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class PoisonQueueElt : IComparable,
    IComparable<PoisonQueueElt>

The PoisonQueueElt type exposes the following members.

Constructors
 | Name | Description
Public method | PoisonQueueElt | Initializes a new instance of the PoisonQueueElt class
Top
Properties
 | Name | Description
Public property | IgnoreUntil |
Public property | NumTriesLeft |
Public property | Value |
Top
Methods
 | Name | Description
Public method | AnotherTry |
Public method | CompareTo(Object) |
Public method | CompareTo(PoisonQueueElt) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


PoisonQueueElt Constructor

Initializes a new instance of the PoisonQueueElt class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PoisonQueueElt(
    PriorityQueueElt val
)

Parameters

val PriorityQueueElt

[Missing <param name="val"/> documentation for "M:Sportradar.SDK.Common.PoisonQueueElt.#ctor(Sportradar.SDK.Common.PriorityQueueElt)"]

See Also

Reference

PoisonQueueElt Class
Sportradar.SDK.Common Namespace


PoisonQueueElt Properties

The PoisonQueueElt type exposes the following members.

Properties
 | Name | Description
Public property | IgnoreUntil |
Public property | NumTriesLeft |
Public property | Value |
Top
See Also

Reference

PoisonQueueElt Class
Sportradar.SDK.Common Namespace


PoisonQueueElt.IgnoreUntil Property

PoisonQueueEltIgnoreUntil Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PoisonQueueElt.IgnoreUntil"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime IgnoreUntil { get; }

Property Value

DateTime
See Also

Reference

PoisonQueueElt Class
Sportradar.SDK.Common Namespace


PoisonQueueElt.NumTriesLeft Property

PoisonQueueEltNumTriesLeft Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PoisonQueueElt.NumTriesLeft"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public byte NumTriesLeft { get; set; }

Property Value

Byte
See Also

Reference

PoisonQueueElt Class
Sportradar.SDK.Common Namespace


PoisonQueueElt.Value Property

PoisonQueueEltValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PoisonQueueElt.Value"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PriorityQueueElt Value { get; }

Property Value

PriorityQueueElt
See Also

Reference

PoisonQueueElt Class
Sportradar.SDK.Common Namespace


PoisonQueueElt Methods

The PoisonQueueElt type exposes the following members.

Methods
 | Name | Description
Public method | AnotherTry |
Public method | CompareTo(Object) |
Public method | CompareTo(PoisonQueueElt) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PoisonQueueElt Class
Sportradar.SDK.Common Namespace


PoisonQueueElt.AnotherTry Method

PoisonQueueEltAnotherTry Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PoisonQueueElt.AnotherTry"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool AnotherTry()

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PoisonQueueElt.AnotherTry"]

See Also

Reference

PoisonQueueElt Class
Sportradar.SDK.Common Namespace


PoisonQueueElt.CompareTo Method

PoisonQueueEltCompareTo Method

Overload List
 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(PoisonQueueElt) |
Top
See Also

Reference

PoisonQueueElt Class
Sportradar.SDK.Common Namespace


PoisonQueueElt.CompareTo(Object) Method

PoisonQueueEltCompareTo(Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PoisonQueueElt.CompareTo(System.Object)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int CompareTo(
    Object obj
)

Parameters

obj Object

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Common.PoisonQueueElt.CompareTo(System.Object)"]

Return Value

Int32

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PoisonQueueElt.CompareTo(System.Object)"]

Implements

IComparableCompareTo(Object)
See Also

Reference

PoisonQueueElt Class
CompareTo Overload
Sportradar.SDK.Common Namespace


PoisonQueueElt.CompareTo(PoisonQueueElt) Method

PoisonQueueEltCompareTo(PoisonQueueElt) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PoisonQueueElt.CompareTo(Sportradar.SDK.Common.PoisonQueueElt)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int CompareTo(
    PoisonQueueElt other
)

Parameters

other PoisonQueueElt

[Missing <param name="other"/> documentation for "M:Sportradar.SDK.Common.PoisonQueueElt.CompareTo(Sportradar.SDK.Common.PoisonQueueElt)"]

Return Value

Int32

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PoisonQueueElt.CompareTo(Sportradar.SDK.Common.PoisonQueueElt)"]

Implements

IComparableTCompareTo(T)
See Also

Reference

PoisonQueueElt Class
CompareTo Overload
Sportradar.SDK.Common Namespace


Priority Class

Event priority.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.CommonPriority

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class Priority : Enum

The Priority type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | HIGH | High priority
 | LOW | Low priority
 | UNDEFINED | Undefined
Public field | value__ |
Top
Remarks
Priorities are not used in this SDK release.
See Also

Reference

Sportradar.SDK.Common Namespace


Priority Methods

The Priority type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

Priority Class
Sportradar.SDK.Common Namespace


Priority Fields

The Priority type exposes the following members.

Fields
 | Name | Description
 | HIGH | High priority
 | LOW | Low priority
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

Priority Class
Sportradar.SDK.Common Namespace


Priority.HIGH Field

PriorityHIGH Field

High priority

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Priority HIGH = 2

Field Value

Priority
See Also

Reference

Priority Class
Sportradar.SDK.Common Namespace


Priority.LOW Field

PriorityLOW Field

Low priority

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Priority LOW = 1

Field Value

Priority
See Also

Reference

Priority Class
Sportradar.SDK.Common Namespace


Priority.UNDEFINED Field

PriorityUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Priority UNDEFINED = 0

Field Value

Priority
See Also

Reference

Priority Class
Sportradar.SDK.Common Namespace


Priority.value__ Field

Priorityvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Priority.value__"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

Priority Class
Sportradar.SDK.Common Namespace


PriorityQueueElt Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.PriorityQueueElt"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonPriorityQueueElt

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class PriorityQueueElt : IComparable,
    IComparable<PriorityQueueElt>

The PriorityQueueElt type exposes the following members.

Constructors
 | Name | Description
Public method | PriorityQueueElt | Initializes a new instance of the PriorityQueueElt class
Top
Properties
 | Name | Description
Public property | CreatedOn |
Public property | PoisonElt |
Public property | Priority |
Public property | ProviderType |
Public property | Value |
Top
Methods
 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(PriorityQueueElt) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


PriorityQueueElt Constructor

Initializes a new instance of the PriorityQueueElt class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PriorityQueueElt(
    Priority prio,
    ProtocolProviderType type,
    Object val
)

Parameters

prio Priority

[Missing <param name="prio"/> documentation for "M:Sportradar.SDK.Common.PriorityQueueElt.#ctor(Sportradar.SDK.Common.Priority,Sportradar.SDK.Common.ProtocolProviderType,System.Object)"]

type ProtocolProviderType

[Missing <param name="type"/> documentation for "M:Sportradar.SDK.Common.PriorityQueueElt.#ctor(Sportradar.SDK.Common.Priority,Sportradar.SDK.Common.ProtocolProviderType,System.Object)"]

val Object

[Missing <param name="val"/> documentation for "M:Sportradar.SDK.Common.PriorityQueueElt.#ctor(Sportradar.SDK.Common.Priority,Sportradar.SDK.Common.ProtocolProviderType,System.Object)"]

See Also

Reference

PriorityQueueElt Class
Sportradar.SDK.Common Namespace


PriorityQueueElt Properties

The PriorityQueueElt type exposes the following members.

Properties
 | Name | Description
Public property | CreatedOn |
Public property | PoisonElt |
Public property | Priority |
Public property | ProviderType |
Public property | Value |
Top
See Also

Reference

PriorityQueueElt Class
Sportradar.SDK.Common Namespace


PriorityQueueElt.CreatedOn Property

PriorityQueueEltCreatedOn Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PriorityQueueElt.CreatedOn"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime CreatedOn { get; }

Property Value

DateTime
See Also

Reference

PriorityQueueElt Class
Sportradar.SDK.Common Namespace


PriorityQueueElt.PoisonElt Property

PriorityQueueEltPoisonElt Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PriorityQueueElt.PoisonElt"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PoisonQueueElt PoisonElt { get; set; }

Property Value

PoisonQueueElt
See Also

Reference

PriorityQueueElt Class
Sportradar.SDK.Common Namespace


PriorityQueueElt.Priority Property

PriorityQueueEltPriority Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PriorityQueueElt.Priority"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Priority Priority { get; }

Property Value

Priority
See Also

Reference

PriorityQueueElt Class
Sportradar.SDK.Common Namespace


PriorityQueueElt.ProviderType Property

PriorityQueueEltProviderType Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PriorityQueueElt.ProviderType"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
See Also

Reference

PriorityQueueElt Class
Sportradar.SDK.Common Namespace


PriorityQueueElt.Value Property

PriorityQueueEltValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.PriorityQueueElt.Value"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Object Value { get; }

Property Value

Object
See Also

Reference

PriorityQueueElt Class
Sportradar.SDK.Common Namespace


PriorityQueueElt Methods

The PriorityQueueElt type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(PriorityQueueElt) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

PriorityQueueElt Class
Sportradar.SDK.Common Namespace


PriorityQueueElt.CompareTo Method

PriorityQueueEltCompareTo Method

Overload List
 | Name | Description
Public method | CompareTo(Object) |
Public method | CompareTo(PriorityQueueElt) |
Top
See Also

Reference

PriorityQueueElt Class
Sportradar.SDK.Common Namespace


PriorityQueueElt.CompareTo(Object) Method

PriorityQueueEltCompareTo(Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PriorityQueueElt.CompareTo(System.Object)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int CompareTo(
    Object obj
)

Parameters

obj Object

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Common.PriorityQueueElt.CompareTo(System.Object)"]

Return Value

Int32

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PriorityQueueElt.CompareTo(System.Object)"]

Implements

IComparableCompareTo(Object)
See Also

Reference

PriorityQueueElt Class
CompareTo Overload
Sportradar.SDK.Common Namespace


PriorityQueueElt.CompareTo(PriorityQueueElt) Method

PriorityQueueEltCompareTo(PriorityQueueElt) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.PriorityQueueElt.CompareTo(Sportradar.SDK.Common.PriorityQueueElt)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int CompareTo(
    PriorityQueueElt other
)

Parameters

other PriorityQueueElt

[Missing <param name="other"/> documentation for "M:Sportradar.SDK.Common.PriorityQueueElt.CompareTo(Sportradar.SDK.Common.PriorityQueueElt)"]

Return Value

Int32

[Missing <returns> documentation for "M:Sportradar.SDK.Common.PriorityQueueElt.CompareTo(Sportradar.SDK.Common.PriorityQueueElt)"]

Implements

IComparableTCompareTo(T)
See Also

Reference

PriorityQueueElt Class
CompareTo Overload
Sportradar.SDK.Common Namespace


PriorityQueueElt.ToString Method

PriorityQueueEltToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

PriorityQueueElt Class
Sportradar.SDK.Common Namespace


ProtocolData Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.ProtocolData"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonProtocolData

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class ProtocolData : IProtocolData,
    ICloneable

The ProtocolData type exposes the following members.

Constructors
 | Name | Description
Public method | ProtocolData | Initializes a new instance of the ProtocolData class
Top
Properties
 | Name | Description
Public property | BookmakerId |
Public property | BookmakerKey |
Public property | EventRequestLimiter |
Public property | LoginLimiter |
Public property | MaxTimeSkew |
Public property | RequestLimiter |
Public property | RestartOnParseError |
Public property | SchemaStrictness |
Public property | ScoutPassword |
Public property | ScoutUsername |
Public property | SendClientTimeInRequest |
Public property | SendClientVersionInLogin |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


ProtocolData Constructor

Initializes a new instance of the ProtocolData class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ProtocolData()
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData Properties

The ProtocolData type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId |
Public property | BookmakerKey |
Public property | EventRequestLimiter |
Public property | LoginLimiter |
Public property | MaxTimeSkew |
Public property | RequestLimiter |
Public property | RestartOnParseError |
Public property | SchemaStrictness |
Public property | ScoutPassword |
Public property | ScoutUsername |
Public property | SendClientTimeInRequest |
Public property | SendClientVersionInLogin |
Top
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.BookmakerId Property

ProtocolDataBookmakerId Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ProtocolData.BookmakerId"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual long BookmakerId { get; set; }

Property Value

Int64

Implements

IProtocolDataBookmakerId
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.BookmakerKey Property

ProtocolDataBookmakerKey Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ProtocolData.BookmakerKey"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual SecureString BookmakerKey { get; set; }

Property Value

SecureString

Implements

IProtocolDataBookmakerKey
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.EventRequestLimiter Property

ProtocolDataEventRequestLimiter Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ProtocolData.EventRequestLimiter"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IRateGate EventRequestLimiter { get; set; }

Property Value

IRateGate

Implements

IProtocolDataEventRequestLimiter
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.LoginLimiter Property

ProtocolDataLoginLimiter Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ProtocolData.LoginLimiter"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IRateGate LoginLimiter { get; set; }

Property Value

IRateGate

Implements

IProtocolDataLoginLimiter
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.MaxTimeSkew Property

ProtocolDataMaxTimeSkew Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ProtocolData.MaxTimeSkew"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual TimeSpan MaxTimeSkew { get; set; }

Property Value

TimeSpan

Implements

IProtocolDataMaxTimeSkew
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.RequestLimiter Property

ProtocolDataRequestLimiter Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ProtocolData.RequestLimiter"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IRateGate RequestLimiter { get; set; }

Property Value

IRateGate

Implements

IProtocolDataRequestLimiter
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.RestartOnParseError Property

ProtocolDataRestartOnParseError Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ProtocolData.RestartOnParseError"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool RestartOnParseError { get; set; }

Property Value

Boolean

Implements

IProtocolDataRestartOnParseError
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.SchemaStrictness Property

ProtocolDataSchemaStrictness Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ProtocolData.SchemaStrictness"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual SchemaValidationStrictness SchemaStrictness { get; set; }

Property Value

SchemaValidationStrictness

Implements

IProtocolDataSchemaStrictness
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.ScoutPassword Property

ProtocolDataScoutPassword Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ProtocolData.ScoutPassword"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual SecureString ScoutPassword { get; set; }

Property Value

SecureString

Implements

IProtocolDataScoutPassword
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.ScoutUsername Property

ProtocolDataScoutUsername Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ProtocolData.ScoutUsername"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual string ScoutUsername { get; set; }

Property Value

String

Implements

IProtocolDataScoutUsername
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.SendClientTimeInRequest Property

ProtocolDataSendClientTimeInRequest Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ProtocolData.SendClientTimeInRequest"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool SendClientTimeInRequest { get; set; }

Property Value

Boolean

Implements

IProtocolDataSendClientTimeInRequest
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.SendClientVersionInLogin Property

ProtocolDataSendClientVersionInLogin Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.ProtocolData.SendClientVersionInLogin"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool SendClientVersionInLogin { get; set; }

Property Value

Boolean

Implements

IProtocolDataSendClientVersionInLogin
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData Methods

The ProtocolData type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolData.Clone Method

ProtocolDataClone Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.ProtocolData.Clone"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual Object Clone()

Return Value

Object

[Missing <returns> documentation for "M:Sportradar.SDK.Common.ProtocolData.Clone"]

Implements

ICloneableClone
See Also

Reference

ProtocolData Class
Sportradar.SDK.Common Namespace


ProtocolProviderType Class

Type of protocol provider
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.CommonProtocolProviderType

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class ProtocolProviderType : Enum

The ProtocolProviderType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | LCOO | Odds Creator Provider
 | LIVEODDS | Live Odds Provider
 | LIVEODDS_BETPAL | Live Odds BetPal Provider
 | LIVEODDS_LIVEPLEX | Live Odds Liveplex Provider
 | LIVEODDS_SOCCER_ROULETTE | Live Odds Soccer Roulette provider
 | LIVEODDS_VBL | Live Odds VBL Provider
 | LIVEODDS_VDR | Live Odds Virtual Dog Racing
 | LIVEODDS_VFC | Virtual Football Cup
 | LIVEODDS_VFL | Live Odds VFL Provider
 | LIVEODDS_VHC | Live Odds Virtual Horse Classics
 | LIVEODDS_VTO | Live Odds VTO Provider
 | LIVESCOUT | Live Scout Provider
 | ODDS_CREATOR | Odds Creator Provider
 | UNKNOWN | Unknown
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.Common Namespace


ProtocolProviderType Methods

The ProtocolProviderType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType Fields

The ProtocolProviderType type exposes the following members.

Fields
 | Name | Description
 | LCOO | Odds Creator Provider
 | LIVEODDS | Live Odds Provider
 | LIVEODDS_BETPAL | Live Odds BetPal Provider
 | LIVEODDS_LIVEPLEX | Live Odds Liveplex Provider
 | LIVEODDS_SOCCER_ROULETTE | Live Odds Soccer Roulette provider
 | LIVEODDS_VBL | Live Odds VBL Provider
 | LIVEODDS_VDR | Live Odds Virtual Dog Racing
 | LIVEODDS_VFC | Virtual Football Cup
 | LIVEODDS_VFL | Live Odds VFL Provider
 | LIVEODDS_VHC | Live Odds Virtual Horse Classics
 | LIVEODDS_VTO | Live Odds VTO Provider
 | LIVESCOUT | Live Scout Provider
 | ODDS_CREATOR | Odds Creator Provider
 | UNKNOWN | Unknown
Public field | value__ |
Top
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.LCOO Field

ProtocolProviderTypeLCOO Field

Odds Creator Provider

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType LCOO = 13

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.LIVEODDS Field

ProtocolProviderTypeLIVEODDS Field

Live Odds Provider

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType LIVEODDS = 1

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.LIVEODDS_BETPAL Field

ProtocolProviderTypeLIVEODDS_BETPAL Field

Live Odds BetPal Provider

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType LIVEODDS_BETPAL = 5

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.LIVEODDS_LIVEPLEX Field

ProtocolProviderTypeLIVEODDS_LIVEPLEX Field

Live Odds Liveplex Provider

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType LIVEODDS_LIVEPLEX = 6

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.LIVEODDS_SOCCER_ROULETTE Field

ProtocolProviderTypeLIVEODDS_SOCCER_ROULETTE Field

Live Odds Soccer Roulette provider

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType LIVEODDS_SOCCER_ROULETTE = 7

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.LIVEODDS_VBL Field

ProtocolProviderTypeLIVEODDS_VBL Field

Live Odds VBL Provider

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType LIVEODDS_VBL = 2

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.LIVEODDS_VDR Field

ProtocolProviderTypeLIVEODDS_VDR Field

Live Odds Virtual Dog Racing

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType LIVEODDS_VDR = 9

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.LIVEODDS_VFC Field

ProtocolProviderTypeLIVEODDS_VFC Field

Virtual Football Cup

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType LIVEODDS_VFC = 10

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.LIVEODDS_VFL Field

ProtocolProviderTypeLIVEODDS_VFL Field

Live Odds VFL Provider

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType LIVEODDS_VFL = 3

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.LIVEODDS_VHC Field

ProtocolProviderTypeLIVEODDS_VHC Field

Live Odds Virtual Horse Classics

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType LIVEODDS_VHC = 8

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.LIVEODDS_VTO Field

ProtocolProviderTypeLIVEODDS_VTO Field

Live Odds VTO Provider

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType LIVEODDS_VTO = 4

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.LIVESCOUT Field

ProtocolProviderTypeLIVESCOUT Field

Live Scout Provider

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType LIVESCOUT = 11

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.ODDS_CREATOR Field

ProtocolProviderTypeODDS_CREATOR Field

Odds Creator Provider

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType ODDS_CREATOR = 12

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.UNKNOWN Field

ProtocolProviderTypeUNKNOWN Field

Unknown

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ProtocolProviderType UNKNOWN = 0

Field Value

ProtocolProviderType
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


ProtocolProviderType.value__ Field

ProtocolProviderTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.ProtocolProviderType.value__"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

ProtocolProviderType Class
Sportradar.SDK.Common Namespace


SchemaValidationStrictness Class

Schema validation strictness.
Remarks
Order is important - from least to most strict. Best choice is probably STRICT. This means it will not spend lots of CPU time while processing eventual junk messages. Our schema supports any attributes so this is not a problem. The only issue could present new (unknown) XML elements.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.CommonSchemaValidationStrictness

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class SchemaValidationStrictness : Enum

The SchemaValidationStrictness type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | OFF | No schema validation is performed at all.
 | ON | If schema validation fails the message is still deserialized (but it might fail with an exception later).
 | STRICT | Schema validation failure means the message must be discarded immediately.
Public field | value__ |
 | VERY_STRICT | Same as above except that any warning is also treated as fatal error.
Top
See Also

Reference

Sportradar.SDK.Common Namespace


SchemaValidationStrictness Methods

The SchemaValidationStrictness type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

SchemaValidationStrictness Class
Sportradar.SDK.Common Namespace


SchemaValidationStrictness Fields

The SchemaValidationStrictness type exposes the following members.

Fields
 | Name | Description
 | OFF | No schema validation is performed at all.
 | ON | If schema validation fails the message is still deserialized (but it might fail with an exception later).
 | STRICT | Schema validation failure means the message must be discarded immediately.
Public field | value__ |
 | VERY_STRICT | Same as above except that any warning is also treated as fatal error.
Top
See Also

Reference

SchemaValidationStrictness Class
Sportradar.SDK.Common Namespace


SchemaValidationStrictness.OFF Field

SchemaValidationStrictnessOFF Field

No schema validation is performed at all.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const SchemaValidationStrictness OFF = 0

Field Value

SchemaValidationStrictness
See Also

Reference

SchemaValidationStrictness Class
Sportradar.SDK.Common Namespace


SchemaValidationStrictness.ON Field

SchemaValidationStrictnessON Field

If schema validation fails the message is still deserialized (but it might fail with an exception later).

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const SchemaValidationStrictness ON = 1

Field Value

SchemaValidationStrictness
See Also

Reference

SchemaValidationStrictness Class
Sportradar.SDK.Common Namespace


SchemaValidationStrictness.STRICT Field

SchemaValidationStrictnessSTRICT Field

Schema validation failure means the message must be discarded immediately.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const SchemaValidationStrictness STRICT = 2

Field Value

SchemaValidationStrictness
See Also

Reference

SchemaValidationStrictness Class
Sportradar.SDK.Common Namespace


SchemaValidationStrictness.value__ Field

SchemaValidationStrictnessvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.SchemaValidationStrictness.value__"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

SchemaValidationStrictness Class
Sportradar.SDK.Common Namespace


SchemaValidationStrictness.VERY_STRICT Field

SchemaValidationStrictnessVERY_STRICT Field

Same as above except that any warning is also treated as fatal error.

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const SchemaValidationStrictness VERY_STRICT = 3

Field Value

SchemaValidationStrictness
See Also

Reference

SchemaValidationStrictness Class
Sportradar.SDK.Common Namespace


TimeKeeper Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.TimeKeeper"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonTimeKeeper

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class TimeKeeper : ITimeKeeper

The TimeKeeper type exposes the following members.

Constructors
 | Name | Description
Public method | TimeKeeper | Initializes a new instance of the TimeKeeper class
Top
Properties
 | Name | Description
Public property | LastServerTime |
Public property | LastSyncTime |
Public property | ServerTime |
Top
Methods
 | Name | Description
Public method | CheckTime |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NewTime |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


TimeKeeper Constructor

Initializes a new instance of the TimeKeeper class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeKeeper(
    int maximum_samples,
    TimeSpan max_age
)

Parameters

maximum_samples Int32

[Missing <param name="maximum_samples"/> documentation for "M:Sportradar.SDK.Common.TimeKeeper.#ctor(System.Int32,System.TimeSpan)"]

max_age TimeSpan

[Missing <param name="max_age"/> documentation for "M:Sportradar.SDK.Common.TimeKeeper.#ctor(System.Int32,System.TimeSpan)"]

See Also

Reference

TimeKeeper Class
Sportradar.SDK.Common Namespace


TimeKeeper Properties

The TimeKeeper type exposes the following members.

Properties
 | Name | Description
Public property | LastServerTime |
Public property | LastSyncTime |
Public property | ServerTime |
Top
See Also

Reference

TimeKeeper Class
Sportradar.SDK.Common Namespace


TimeKeeper.LastServerTime Property

TimeKeeperLastServerTime Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.TimeKeeper.LastServerTime"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime LastServerTime { get; }

Property Value

DateTime

Implements

ITimeKeeperLastServerTime
See Also

Reference

TimeKeeper Class
Sportradar.SDK.Common Namespace


TimeKeeper.LastSyncTime Property

TimeKeeperLastSyncTime Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.TimeKeeper.LastSyncTime"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime LastSyncTime { get; }

Property Value

DateTime

Implements

ITimeKeeperLastSyncTime
See Also

Reference

TimeKeeper Class
Sportradar.SDK.Common Namespace


TimeKeeper.ServerTime Property

TimeKeeperServerTime Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.TimeKeeper.ServerTime"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime? ServerTime { get; }

Property Value

Nullable DateTime

Implements

ITimeKeeperServerTime
See Also

Reference

TimeKeeper Class
Sportradar.SDK.Common Namespace


TimeKeeper Methods

The TimeKeeper type exposes the following members.

Methods
 | Name | Description
Public method | CheckTime |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NewTime |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TimeKeeper Class
Sportradar.SDK.Common Namespace


TimeKeeper.CheckTime Method

TimeKeeperCheckTime Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.TimeKeeper.CheckTime(System.DateTime,System.DateTime)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeKeeperResponse CheckTime(
    DateTime server_time,
    DateTime received_time = null
)

Parameters

server_time DateTime

[Missing <param name="server_time"/> documentation for "M:Sportradar.SDK.Common.TimeKeeper.CheckTime(System.DateTime,System.DateTime)"]

received_time DateTime (Optional)

[Missing <param name="received_time"/> documentation for "M:Sportradar.SDK.Common.TimeKeeper.CheckTime(System.DateTime,System.DateTime)"]

Return Value

TimeKeeperResponse

[Missing <returns> documentation for "M:Sportradar.SDK.Common.TimeKeeper.CheckTime(System.DateTime,System.DateTime)"]

Implements

ITimeKeeperCheckTime(DateTime, DateTime)
See Also

Reference

TimeKeeper Class
Sportradar.SDK.Common Namespace


TimeKeeper.NewTime Method

TimeKeeperNewTime Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.TimeKeeper.NewTime(System.DateTime,System.DateTime)"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeKeeperResponse NewTime(
    DateTime server_time,
    DateTime received_time = null
)

Parameters

server_time DateTime

[Missing <param name="server_time"/> documentation for "M:Sportradar.SDK.Common.TimeKeeper.NewTime(System.DateTime,System.DateTime)"]

received_time DateTime (Optional)

[Missing <param name="received_time"/> documentation for "M:Sportradar.SDK.Common.TimeKeeper.NewTime(System.DateTime,System.DateTime)"]

Return Value

TimeKeeperResponse

[Missing <returns> documentation for "M:Sportradar.SDK.Common.TimeKeeper.NewTime(System.DateTime,System.DateTime)"]

Implements

ITimeKeeperNewTime(DateTime, DateTime)
See Also

Reference

TimeKeeper Class
Sportradar.SDK.Common Namespace


TimeKeeperResponse Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.TimeKeeperResponse"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonTimeKeeperResponse

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class TimeKeeperResponse

The TimeKeeperResponse type exposes the following members.

Constructors
 | Name | Description
Public method | TimeKeeperResponse | Initializes a new instance of the TimeKeeperResponse class
Top
Properties
 | Name | Description
Public property | DiffToAverage |
Public property | IsBehindLastSample |
Public property | NumSamples |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


TimeKeeperResponse Constructor

Initializes a new instance of the TimeKeeperResponse class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeKeeperResponse()
See Also

Reference

TimeKeeperResponse Class
Sportradar.SDK.Common Namespace


TimeKeeperResponse Properties

The TimeKeeperResponse type exposes the following members.

Properties
 | Name | Description
Public property | DiffToAverage |
Public property | IsBehindLastSample |
Public property | NumSamples |
Top
See Also

Reference

TimeKeeperResponse Class
Sportradar.SDK.Common Namespace


TimeKeeperResponse.DiffToAverage Property

TimeKeeperResponseDiffToAverage Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.TimeKeeperResponse.DiffToAverage"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan DiffToAverage { get; set; }

Property Value

TimeSpan
See Also

Reference

TimeKeeperResponse Class
Sportradar.SDK.Common Namespace


TimeKeeperResponse.IsBehindLastSample Property

TimeKeeperResponseIsBehindLastSample Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.TimeKeeperResponse.IsBehindLastSample"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsBehindLastSample { get; set; }

Property Value

Boolean
See Also

Reference

TimeKeeperResponse Class
Sportradar.SDK.Common Namespace


TimeKeeperResponse.NumSamples Property

TimeKeeperResponseNumSamples Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.TimeKeeperResponse.NumSamples"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int NumSamples { get; set; }

Property Value

Int32
See Also

Reference

TimeKeeperResponse Class
Sportradar.SDK.Common Namespace


TimeKeeperResponse Methods

The TimeKeeperResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

TimeKeeperResponse Class
Sportradar.SDK.Common Namespace


TimeKeeperResponse.ToString Method

TimeKeeperResponseToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.TimeKeeperResponse.ToString"]

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.TimeKeeperResponse.ToString"]

See Also

Reference

TimeKeeperResponse Class
Sportradar.SDK.Common Namespace


TypeValueTuple Class

TypeValueTuple
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonTypeValueTuple

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class TypeValueTuple

The TypeValueTuple type exposes the following members.

Constructors
 | Name | Description
Public method | TypeValueTuple | Initializes a new instance of the TypeValueTuple class
Top
Properties
 | Name | Description
Public property | Type | Type
Public property | Value | Value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common Namespace


TypeValueTuple Constructor

Initializes a new instance of the TypeValueTuple class

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TypeValueTuple()
See Also

Reference

TypeValueTuple Class
Sportradar.SDK.Common Namespace


TypeValueTuple Properties

The TypeValueTuple type exposes the following members.

Properties
 | Name | Description
Public property | Type | Type
Public property | Value | Value
Top
See Also

Reference

TypeValueTuple Class
Sportradar.SDK.Common Namespace


TypeValueTuple.Type Property

TypeValueTupleType Property

Type

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Type { get; set; }

Property Value

String
See Also

Reference

TypeValueTuple Class
Sportradar.SDK.Common Namespace


TypeValueTuple.Value Property

TypeValueTupleValue Property

Value

Namespace: Sportradar.SDK.Common
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; set; }

Property Value

String
See Also

Reference

TypeValueTuple Class
Sportradar.SDK.Common Namespace


TypeValueTuple Methods

The TypeValueTuple type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TypeValueTuple Class
Sportradar.SDK.Common Namespace


Sportradar.SDK.Common.Exceptions Namespace

Classes
 | Class | Description
Public class | BufferOverflowException | Buffer overflow exception.
Public class | DefaultExceptionRenderer | Log4Net exception renderer. Includes special exception identifier for all exceptions derived from SdkBaseException.
Public class | DisconnectedStateException | Communication channel disconnected exception.
Public class | InitException | Initialization exception.
Public class | InvalidDataReceivedException | Invalid data received exception.
Public class | LoginRateLimitingException | Login rate limiting threshold exceeded exception.
Public class | NotInitializedException | Component not initialized exception.
Public class | NotStartedException | A required component was not started.
Public class | RateLimitingException | Rate limit threshold exceeded exception.
Public class | SdkBaseException | SDK base application exception that all other SDK exception should derive from.
Public class | SdkConfigException | SDK configuration exception (e.g. configuration setting validation)
Public class | TimeSkewException | Client-Server system time skew exception.


BufferOverflowException Class

Buffer overflow exception.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
Sportradar.SDK.Common.ExceptionsInvalidDataReceivedException
Sportradar.SDK.Common.ExceptionsBufferOverflowException

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BufferOverflowException : InvalidDataReceivedException

The BufferOverflowException type exposes the following members.

Constructors
 | Name | Description
Public method | BufferOverflowException | Initializes a new instance of the BufferOverflowException class
Public method | BufferOverflowException(String) | Initializes a new instance of the BufferOverflowException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.SDK.Common.Exceptions Namespace


BufferOverflowException Constructor

Overload List
 | Name | Description
Public method | BufferOverflowException | Initializes a new instance of the BufferOverflowException class
Public method | BufferOverflowException(String) | Initializes a new instance of the BufferOverflowException class
Top
See Also

Reference

BufferOverflowException Class
Sportradar.SDK.Common.Exceptions Namespace


BufferOverflowException Constructor

Initializes a new instance of the BufferOverflowException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BufferOverflowException()
See Also

Reference

BufferOverflowException Class
BufferOverflowException Overload
Sportradar.SDK.Common.Exceptions Namespace


BufferOverflowException(String) Constructor

Initializes a new instance of the BufferOverflowException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BufferOverflowException(
    string message
)

Parameters

message String
Exception message
See Also

Reference

BufferOverflowException Class
BufferOverflowException Overload
Sportradar.SDK.Common.Exceptions Namespace


BufferOverflowException Properties

The BufferOverflowException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

BufferOverflowException Class
Sportradar.SDK.Common.Exceptions Namespace


BufferOverflowException Methods

The BufferOverflowException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

BufferOverflowException Class
Sportradar.SDK.Common.Exceptions Namespace


DefaultExceptionRenderer Class

Log4Net exception renderer. Includes special exception identifier for all exceptions derived from SdkBaseException.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.ExceptionsDefaultExceptionRenderer

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class DefaultExceptionRenderer : IObjectRenderer

The DefaultExceptionRenderer type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultExceptionRenderer | Initializes a new instance of the DefaultExceptionRenderer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Exceptions Namespace


DefaultExceptionRenderer Constructor

Initializes a new instance of the DefaultExceptionRenderer class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DefaultExceptionRenderer()
See Also

Reference

DefaultExceptionRenderer Class
Sportradar.SDK.Common.Exceptions Namespace


DefaultExceptionRenderer Methods

The DefaultExceptionRenderer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DefaultExceptionRenderer Class
Sportradar.SDK.Common.Exceptions Namespace


DisconnectedStateException Class

Communication channel disconnected exception.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
Sportradar.SDK.Common.ExceptionsDisconnectedStateException

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class DisconnectedStateException : SdkBaseException

The DisconnectedStateException type exposes the following members.

Constructors
 | Name | Description
Public method | DisconnectedStateException | Initializes a new instance of the DisconnectedStateException class
Public method | DisconnectedStateException(String) | Initializes a new instance of the DisconnectedStateException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.SDK.Common.Exceptions Namespace


DisconnectedStateException Constructor

Overload List
 | Name | Description
Public method | DisconnectedStateException | Initializes a new instance of the DisconnectedStateException class
Public method | DisconnectedStateException(String) | Initializes a new instance of the DisconnectedStateException class
Top
See Also

Reference

DisconnectedStateException Class
Sportradar.SDK.Common.Exceptions Namespace


DisconnectedStateException Constructor

Initializes a new instance of the DisconnectedStateException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DisconnectedStateException()
See Also

Reference

DisconnectedStateException Class
DisconnectedStateException Overload
Sportradar.SDK.Common.Exceptions Namespace


DisconnectedStateException(String) Constructor

Initializes a new instance of the DisconnectedStateException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DisconnectedStateException(
    string message
)

Parameters

message String
Exception message
See Also

Reference

DisconnectedStateException Class
DisconnectedStateException Overload
Sportradar.SDK.Common.Exceptions Namespace


DisconnectedStateException Properties

The DisconnectedStateException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

DisconnectedStateException Class
Sportradar.SDK.Common.Exceptions Namespace


DisconnectedStateException Methods

The DisconnectedStateException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

DisconnectedStateException Class
Sportradar.SDK.Common.Exceptions Namespace


InitException Class

Initialization exception.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
Sportradar.SDK.Common.ExceptionsInitException
Sportradar.SDK.Common.ExceptionsNotInitializedException
Sportradar.SDK.Common.ExceptionsNotStartedException

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class InitException : SdkBaseException

The InitException type exposes the following members.

Constructors
 | Name | Description
Public method | InitException | Initializes a new instance of the InitException class
Public method | InitException(String) | Initializes a new instance of the InitException class
Public method | InitException(String, Exception) | Initializes a new instance of the InitException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.SDK.Common.Exceptions Namespace


InitException Constructor

Overload List
 | Name | Description
Public method | InitException | Initializes a new instance of the InitException class
Public method | InitException(String) | Initializes a new instance of the InitException class
Public method | InitException(String, Exception) | Initializes a new instance of the InitException class
Top
See Also

Reference

InitException Class
Sportradar.SDK.Common.Exceptions Namespace


InitException Constructor

Initializes a new instance of the InitException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public InitException()
See Also

Reference

InitException Class
InitException Overload
Sportradar.SDK.Common.Exceptions Namespace


InitException(String) Constructor

Initializes a new instance of the InitException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public InitException(
    string message
)

Parameters

message String
Exception message
See Also

Reference

InitException Class
InitException Overload
Sportradar.SDK.Common.Exceptions Namespace


InitException(String, Exception) Constructor

Initializes a new instance of the InitException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public InitException(
    string message,
    Exception inner_exception
)

Parameters

message String
Exception message
inner_exception Exception
Inner exception
See Also

Reference

InitException Class
InitException Overload
Sportradar.SDK.Common.Exceptions Namespace


InitException Properties

The InitException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

InitException Class
Sportradar.SDK.Common.Exceptions Namespace


InitException Methods

The InitException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

InitException Class
Sportradar.SDK.Common.Exceptions Namespace


InvalidDataReceivedException Class

Invalid data received exception.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
Sportradar.SDK.Common.ExceptionsInvalidDataReceivedException
Sportradar.SDK.Common.ExceptionsBufferOverflowException

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class InvalidDataReceivedException : SdkBaseException

The InvalidDataReceivedException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidDataReceivedException | Initializes a new instance of the InvalidDataReceivedException class
Public method | InvalidDataReceivedException(String) | Initializes a new instance of the InvalidDataReceivedException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.SDK.Common.Exceptions Namespace


InvalidDataReceivedException Constructor

Overload List
 | Name | Description
Public method | InvalidDataReceivedException | Initializes a new instance of the InvalidDataReceivedException class
Public method | InvalidDataReceivedException(String) | Initializes a new instance of the InvalidDataReceivedException class
Top
See Also

Reference

InvalidDataReceivedException Class
Sportradar.SDK.Common.Exceptions Namespace


InvalidDataReceivedException Constructor

Initializes a new instance of the InvalidDataReceivedException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public InvalidDataReceivedException()
See Also

Reference

InvalidDataReceivedException Class
InvalidDataReceivedException Overload
Sportradar.SDK.Common.Exceptions Namespace


InvalidDataReceivedException(String) Constructor

Initializes a new instance of the InvalidDataReceivedException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public InvalidDataReceivedException(
    string message
)

Parameters

message String
Exception message
See Also

Reference

InvalidDataReceivedException Class
InvalidDataReceivedException Overload
Sportradar.SDK.Common.Exceptions Namespace


InvalidDataReceivedException Properties

The InvalidDataReceivedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

InvalidDataReceivedException Class
Sportradar.SDK.Common.Exceptions Namespace


InvalidDataReceivedException Methods

The InvalidDataReceivedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

InvalidDataReceivedException Class
Sportradar.SDK.Common.Exceptions Namespace


LoginRateLimitingException Class

Login rate limiting threshold exceeded exception.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
Sportradar.SDK.Common.ExceptionsRateLimitingException
Sportradar.SDK.Common.ExceptionsLoginRateLimitingException

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class LoginRateLimitingException : RateLimitingException

The LoginRateLimitingException type exposes the following members.

Constructors
 | Name | Description
Public method | LoginRateLimitingException | Initializes a new instance of the LoginRateLimitingException class
Top
Properties
 | Name | Description
Public property | Command | Request message that was rejected during rate limiting (Inherited from RateLimitingException)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | WaitUntil | Required time to wait in order to pass the rate limiter (Inherited from RateLimitingException)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.SDK.Common.Exceptions Namespace


LoginRateLimitingException Constructor

Initializes a new instance of the LoginRateLimitingException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LoginRateLimitingException(
    TimeSpan wait_until,
    IProtocolRequest request
)

Parameters

wait_until TimeSpan
Required time to wait in order to pass the rate limiter
request IProtocolRequest
Login request message that was rejected during rate limiting
See Also

Reference

LoginRateLimitingException Class
Sportradar.SDK.Common.Exceptions Namespace


LoginRateLimitingException Properties

The LoginRateLimitingException type exposes the following members.

Properties
 | Name | Description
Public property | Command | Request message that was rejected during rate limiting (Inherited from RateLimitingException)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | WaitUntil | Required time to wait in order to pass the rate limiter (Inherited from RateLimitingException)
Top
See Also

Reference

LoginRateLimitingException Class
Sportradar.SDK.Common.Exceptions Namespace


LoginRateLimitingException Methods

The LoginRateLimitingException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

LoginRateLimitingException Class
Sportradar.SDK.Common.Exceptions Namespace


NotInitializedException Class

Component not initialized exception.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
Sportradar.SDK.Common.ExceptionsInitException
Sportradar.SDK.Common.ExceptionsNotInitializedException

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class NotInitializedException : InitException

The NotInitializedException type exposes the following members.

Constructors
 | Name | Description
Public method | NotInitializedException | Initializes a new instance of the NotInitializedException class
Public method | NotInitializedException(String) | Initializes a new instance of the NotInitializedException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.SDK.Common.Exceptions Namespace


NotInitializedException Constructor

Overload List
 | Name | Description
Public method | NotInitializedException | Initializes a new instance of the NotInitializedException class
Public method | NotInitializedException(String) | Initializes a new instance of the NotInitializedException class
Top
See Also

Reference

NotInitializedException Class
Sportradar.SDK.Common.Exceptions Namespace


NotInitializedException Constructor

Initializes a new instance of the NotInitializedException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public NotInitializedException()
See Also

Reference

NotInitializedException Class
NotInitializedException Overload
Sportradar.SDK.Common.Exceptions Namespace


NotInitializedException(String) Constructor

Initializes a new instance of the NotInitializedException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public NotInitializedException(
    string message
)

Parameters

message String
Exception message
See Also

Reference

NotInitializedException Class
NotInitializedException Overload
Sportradar.SDK.Common.Exceptions Namespace


NotInitializedException Properties

The NotInitializedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

NotInitializedException Class
Sportradar.SDK.Common.Exceptions Namespace


NotInitializedException Methods

The NotInitializedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

NotInitializedException Class
Sportradar.SDK.Common.Exceptions Namespace


NotStartedException Class

A required component was not started.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
Sportradar.SDK.Common.ExceptionsInitException
Sportradar.SDK.Common.ExceptionsNotStartedException

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class NotStartedException : InitException

The NotStartedException type exposes the following members.

Constructors
 | Name | Description
Public method | NotStartedException | Initializes a new instance of the NotStartedException class
Public method | NotStartedException(String) | Initializes a new instance of the NotStartedException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.SDK.Common.Exceptions Namespace


NotStartedException Constructor

Overload List
 | Name | Description
Public method | NotStartedException | Initializes a new instance of the NotStartedException class
Public method | NotStartedException(String) | Initializes a new instance of the NotStartedException class
Top
See Also

Reference

NotStartedException Class
Sportradar.SDK.Common.Exceptions Namespace


NotStartedException Constructor

Initializes a new instance of the NotStartedException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public NotStartedException()
See Also

Reference

NotStartedException Class
NotStartedException Overload
Sportradar.SDK.Common.Exceptions Namespace


NotStartedException(String) Constructor

Initializes a new instance of the NotStartedException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public NotStartedException(
    string message
)

Parameters

message String
Exception message
See Also

Reference

NotStartedException Class
NotStartedException Overload
Sportradar.SDK.Common.Exceptions Namespace


NotStartedException Properties

The NotStartedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

NotStartedException Class
Sportradar.SDK.Common.Exceptions Namespace


NotStartedException Methods

The NotStartedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

NotStartedException Class
Sportradar.SDK.Common.Exceptions Namespace


RateLimitingException Class

Rate limit threshold exceeded exception.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
Sportradar.SDK.Common.ExceptionsRateLimitingException
Sportradar.SDK.Common.ExceptionsLoginRateLimitingException

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RateLimitingException : SdkBaseException

The RateLimitingException type exposes the following members.

Constructors
 | Name | Description
Public method | RateLimitingException | Initializes a new instance of the RateLimitingException class
Public method | RateLimitingException(TimeSpan, IProtocolRequest) | Initializes a new instance of the RateLimitingException class
Top
Properties
 | Name | Description
Public property | Command | Request message that was rejected during rate limiting
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | WaitUntil | Required time to wait in order to pass the rate limiter
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.SDK.Common.Exceptions Namespace


RateLimitingException Constructor

Overload List
 | Name | Description
Public method | RateLimitingException | Initializes a new instance of the RateLimitingException class
Public method | RateLimitingException(TimeSpan, IProtocolRequest) | Initializes a new instance of the RateLimitingException class
Top
See Also

Reference

RateLimitingException Class
Sportradar.SDK.Common.Exceptions Namespace


RateLimitingException Constructor

Initializes a new instance of the RateLimitingException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RateLimitingException()
See Also

Reference

RateLimitingException Class
RateLimitingException Overload
Sportradar.SDK.Common.Exceptions Namespace


RateLimitingException(TimeSpan, IProtocolRequest) Constructor

Initializes a new instance of the RateLimitingException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RateLimitingException(
    TimeSpan wait_until,
    IProtocolRequest request
)

Parameters

wait_until TimeSpan
Required time to wait in order to pass the rate limiter
request IProtocolRequest
Request message that was rejected during rate limiting
See Also

Reference

RateLimitingException Class
RateLimitingException Overload
Sportradar.SDK.Common.Exceptions Namespace


RateLimitingException Properties

The RateLimitingException type exposes the following members.

Properties
 | Name | Description
Public property | Command | Request message that was rejected during rate limiting
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | WaitUntil | Required time to wait in order to pass the rate limiter
Top
See Also

Reference

RateLimitingException Class
Sportradar.SDK.Common.Exceptions Namespace


RateLimitingException.Command Property

RateLimitingExceptionCommand Property

Request message that was rejected during rate limiting

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IProtocolRequest Command { get; }

Property Value

IProtocolRequest
See Also

Reference

RateLimitingException Class
Sportradar.SDK.Common.Exceptions Namespace


RateLimitingException.WaitUntil Property

RateLimitingExceptionWaitUntil Property

Required time to wait in order to pass the rate limiter

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan WaitUntil { get; }

Property Value

TimeSpan
See Also

Reference

RateLimitingException Class
Sportradar.SDK.Common.Exceptions Namespace


RateLimitingException Methods

The RateLimitingException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

RateLimitingException Class
Sportradar.SDK.Common.Exceptions Namespace


SdkBaseException Class

SDK base application exception that all other SDK exception should derive from.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
More

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class SdkBaseException : ApplicationException

The SdkBaseException type exposes the following members.

Constructors
 | Name | Description
Public method | SdkBaseException | Initializes a new instance of the SdkBaseException class
Public method | SdkBaseException(String) | Initializes a new instance of the SdkBaseException class
Public method | SdkBaseException(String, Exception) | Initializes a new instance of the SdkBaseException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files.
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.SDK.Common.Exceptions Namespace
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
Sportradar.SDK.Common.ExceptionsDisconnectedStateException
Sportradar.SDK.Common.ExceptionsInitException
Sportradar.SDK.Common.ExceptionsInvalidDataReceivedException
Sportradar.SDK.Common.ExceptionsRateLimitingException
Sportradar.SDK.Common.ExceptionsSdkConfigException
Sportradar.SDK.Common.ExceptionsTimeSkewException
Sportradar.SDK.FeedProviders.OddsCreatorOddsCreatorException


SdkBaseException Constructor

Overload List
 | Name | Description
Public method | SdkBaseException | Initializes a new instance of the SdkBaseException class
Public method | SdkBaseException(String) | Initializes a new instance of the SdkBaseException class
Public method | SdkBaseException(String, Exception) | Initializes a new instance of the SdkBaseException class
Top
See Also

Reference

SdkBaseException Class
Sportradar.SDK.Common.Exceptions Namespace


SdkBaseException Constructor

Initializes a new instance of the SdkBaseException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkBaseException()
See Also

Reference

SdkBaseException Class
SdkBaseException Overload
Sportradar.SDK.Common.Exceptions Namespace


SdkBaseException(String) Constructor

Initializes a new instance of the SdkBaseException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkBaseException(
    string message
)

Parameters

message String
Exception message
See Also

Reference

SdkBaseException Class
SdkBaseException Overload
Sportradar.SDK.Common.Exceptions Namespace


SdkBaseException(String, Exception) Constructor

Initializes a new instance of the SdkBaseException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkBaseException(
    string message,
    Exception inner_exception
)

Parameters

message String
Exception message
inner_exception Exception
Inner exception
See Also

Reference

SdkBaseException Class
SdkBaseException Overload
Sportradar.SDK.Common.Exceptions Namespace


SdkBaseException Properties

The SdkBaseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files.
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

SdkBaseException Class
Sportradar.SDK.Common.Exceptions Namespace


SdkBaseException.Identifier Property

SdkBaseExceptionIdentifier Property

Special exception identifier that can be used for tracking down exception details in the log files.

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Guid Identifier { get; }

Property Value

Guid
See Also

Reference

SdkBaseException Class
Sportradar.SDK.Common.Exceptions Namespace


SdkBaseException Methods

The SdkBaseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

SdkBaseException Class
Sportradar.SDK.Common.Exceptions Namespace


SdkConfigException Class

SDK configuration exception (e.g. configuration setting validation)
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
Sportradar.SDK.Common.ExceptionsSdkConfigException

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class SdkConfigException : SdkBaseException

The SdkConfigException type exposes the following members.

Constructors
 | Name | Description
Public method | SdkConfigException | Initializes a new instance of the SdkConfigException class
Public method | SdkConfigException(String) | Initializes a new instance of the SdkConfigException class
Public method | SdkConfigException(String, Exception) | Initializes a new instance of the SdkConfigException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.SDK.Common.Exceptions Namespace


SdkConfigException Constructor

Overload List
 | Name | Description
Public method | SdkConfigException | Initializes a new instance of the SdkConfigException class
Public method | SdkConfigException(String) | Initializes a new instance of the SdkConfigException class
Public method | SdkConfigException(String, Exception) | Initializes a new instance of the SdkConfigException class
Top
See Also

Reference

SdkConfigException Class
Sportradar.SDK.Common.Exceptions Namespace


SdkConfigException Constructor

Initializes a new instance of the SdkConfigException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigException()
See Also

Reference

SdkConfigException Class
SdkConfigException Overload
Sportradar.SDK.Common.Exceptions Namespace


SdkConfigException(String) Constructor

Initializes a new instance of the SdkConfigException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigException(
    string message
)

Parameters

message String
Exception message
See Also

Reference

SdkConfigException Class
SdkConfigException Overload
Sportradar.SDK.Common.Exceptions Namespace


SdkConfigException(String, Exception) Constructor

Initializes a new instance of the SdkConfigException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigException(
    string message,
    Exception inner_exception
)

Parameters

message String
Exception message
inner_exception Exception
Inner exception
See Also

Reference

SdkConfigException Class
SdkConfigException Overload
Sportradar.SDK.Common.Exceptions Namespace


SdkConfigException Properties

The SdkConfigException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

SdkConfigException Class
Sportradar.SDK.Common.Exceptions Namespace


SdkConfigException Methods

The SdkConfigException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

SdkConfigException Class
Sportradar.SDK.Common.Exceptions Namespace


TimeSkewException Class

Client-Server system time skew exception.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
Sportradar.SDK.Common.ExceptionsTimeSkewException

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class TimeSkewException : SdkBaseException

The TimeSkewException type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSkewException | Initializes a new instance of the TimeSkewException class
Public method | TimeSkewException(String) | Initializes a new instance of the TimeSkewException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.SDK.Common.Exceptions Namespace


TimeSkewException Constructor

Overload List
 | Name | Description
Public method | TimeSkewException | Initializes a new instance of the TimeSkewException class
Public method | TimeSkewException(String) | Initializes a new instance of the TimeSkewException class
Top
See Also

Reference

TimeSkewException Class
Sportradar.SDK.Common.Exceptions Namespace


TimeSkewException Constructor

Initializes a new instance of the TimeSkewException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSkewException()
See Also

Reference

TimeSkewException Class
TimeSkewException Overload
Sportradar.SDK.Common.Exceptions Namespace


TimeSkewException(String) Constructor

Initializes a new instance of the TimeSkewException class

Namespace: Sportradar.SDK.Common.Exceptions
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSkewException(
    string message
)

Parameters

message String
Exception message
See Also

Reference

TimeSkewException Class
TimeSkewException Overload
Sportradar.SDK.Common.Exceptions Namespace


TimeSkewException Properties

The TimeSkewException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

TimeSkewException Class
Sportradar.SDK.Common.Exceptions Namespace


TimeSkewException Methods

The TimeSkewException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

TimeSkewException Class
Sportradar.SDK.Common.Exceptions Namespace


Sportradar.SDK.Common.Interfaces Namespace

Classes
 | Class | Description
Public class | ConnectionProviderDelegates |
Public class | ConnectionProviderDelegatesAliveCheckNecessaryDelegate |
Public class | ConnectionProviderDelegatesCommunicationErrorDelegate |
Public class | ConnectionProviderDelegatesConnectionDelegate |
Public class | ConnectionProviderDelegatesDataReceivedDelegate |
Public class | ConnectionProviderDelegatesDataReceivedOutcome |
Public class | ConnectionProviderDelegatesOutcome |
Public class | ConnectionProviderDelegatesSimpleDataReceivedDelegate |
Public class | ConnectionProviderDelegatesValidDataCheckNecessaryDelegate |
Public class | DispatcherOperationMode |
Public class | DispatchStatus |
Public class | GuidIdentifier |
Public class | MessageDispatcherDelegates |
Public class | MessageDispatcherDelegatesDispatcherHealthStatusDelegate |
Public class | MessageIdentifier |
Public class | PersistentStateDelegates |
Public class | PersistentStateDelegatesPersistentStateStatusChangedDelegate |
Public class | PoisonQueueDelegates |
Public class | PoisonQueueDelegatesPoisonQueueEltDead |
Public class | PoisonQueueDelegatesPoisonQueueEltPromoted |
Public class | QueueLimitAction | Queue limit action (whether a limit was reached or retreated)
Public class | QueueLimitEventArgs | Event arguments passed with the QueueLimitType
Public class | QueueLimitType | Type of queue size limit
Interfaces
 | Interface | Description
Public interface | ICipherSettings |
Public interface | IClientPersistentState | Persistent state store interface that should be implemented by the client.
Public interface | IConnectionData |
Public interface | IConnectionProvider | Connection provider
Public interface | IDeadLetterQueue | Dead Letter queue interface that should be implemented by the client.
Public interface | IFeedDispatcher |
Public interface | ILiveOddsTypeProvider |
Public interface | ILoggerData |
Public interface | IMessageDispatcher |
Public interface | IMessageIdentifier |
Public interface | IPersistentStateBuffer | Persistent state buffer interface that buffers the underlying client persistent state store.
Public interface | IPoisonQueue | Poison queue interface
Public interface | IProtocolBase | All request and reply messages implement this interface.
Public interface | IProtocolData |
Public interface | IProtocolRequest | All request messages implement this interface.
Public interface | IProtocolResponse |
Public interface | IRateGate |
Public interface | IStartable | Interface specifying that a component is startable, i.e. should first be started before any other call are made and stopped at the end.
Public interface | ITimeKeeper |


ConnectionProviderDelegates Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.InterfacesConnectionProviderDelegates

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class ConnectionProviderDelegates
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.AliveCheckNecessaryDelegate Class

ConnectionProviderDelegatesAliveCheckNecessaryDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.AliveCheckNecessaryDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Common.InterfacesConnectionProviderDelegatesAliveCheckNecessaryDelegate

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class AliveCheckNecessaryDelegate : MulticastDelegate

The ConnectionProviderDelegatesAliveCheckNecessaryDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionProviderDelegatesAliveCheckNecessaryDelegate | Initializes a new instance of the ConnectionProviderDelegatesAliveCheckNecessaryDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.AliveCheckNecessaryDelegate Constructor

ConnectionProviderDelegatesAliveCheckNecessaryDelegate Constructor

Initializes a new instance of the ConnectionProviderDelegatesAliveCheckNecessaryDelegate class

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public AliveCheckNecessaryDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.AliveCheckNecessaryDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.AliveCheckNecessaryDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

ConnectionProviderDelegatesAliveCheckNecessaryDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


AliveCheckNecessaryDelegate Properties

The ConnectionProviderDelegatesAliveCheckNecessaryDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

ConnectionProviderDelegatesAliveCheckNecessaryDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


AliveCheckNecessaryDelegate Methods

The ConnectionProviderDelegatesAliveCheckNecessaryDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionProviderDelegatesAliveCheckNecessaryDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.AliveCheckNecessaryDelegate.BeginInvoke Method

ConnectionProviderDelegatesAliveCheckNecessaryDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.AliveCheckNecessaryDelegate.BeginInvoke(Sportradar.SDK.Common.AliveCheckData,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    AliveCheckData data,
    AsyncCallback callback,
    Object object
)

Parameters

data AliveCheckData

[Missing <param name="data"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.AliveCheckNecessaryDelegate.BeginInvoke(Sportradar.SDK.Common.AliveCheckData,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.AliveCheckNecessaryDelegate.BeginInvoke(Sportradar.SDK.Common.AliveCheckData,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.AliveCheckNecessaryDelegate.BeginInvoke(Sportradar.SDK.Common.AliveCheckData,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.AliveCheckNecessaryDelegate.BeginInvoke(Sportradar.SDK.Common.AliveCheckData,System.AsyncCallback,System.Object)"]

See Also

Reference

ConnectionProviderDelegatesAliveCheckNecessaryDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.AliveCheckNecessaryDelegate.EndInvoke Method

ConnectionProviderDelegatesAliveCheckNecessaryDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.AliveCheckNecessaryDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.AliveCheckNecessaryDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

ConnectionProviderDelegatesAliveCheckNecessaryDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.AliveCheckNecessaryDelegate.Invoke Method

ConnectionProviderDelegatesAliveCheckNecessaryDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.AliveCheckNecessaryDelegate.Invoke(Sportradar.SDK.Common.AliveCheckData)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    AliveCheckData data
)

Parameters

data AliveCheckData

[Missing <param name="data"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.AliveCheckNecessaryDelegate.Invoke(Sportradar.SDK.Common.AliveCheckData)"]

See Also

Reference

ConnectionProviderDelegatesAliveCheckNecessaryDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.CommunicationErrorDelegate Class

ConnectionProviderDelegatesCommunicationErrorDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Common.InterfacesConnectionProviderDelegatesCommunicationErrorDelegate

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class CommunicationErrorDelegate : MulticastDelegate

The ConnectionProviderDelegatesCommunicationErrorDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionProviderDelegatesCommunicationErrorDelegate | Initializes a new instance of the ConnectionProviderDelegatesCommunicationErrorDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.CommunicationErrorDelegate Constructor

ConnectionProviderDelegatesCommunicationErrorDelegate Constructor

Initializes a new instance of the ConnectionProviderDelegatesCommunicationErrorDelegate class

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CommunicationErrorDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

ConnectionProviderDelegatesCommunicationErrorDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


CommunicationErrorDelegate Properties

The ConnectionProviderDelegatesCommunicationErrorDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

ConnectionProviderDelegatesCommunicationErrorDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


CommunicationErrorDelegate Methods

The ConnectionProviderDelegatesCommunicationErrorDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionProviderDelegatesCommunicationErrorDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.CommunicationErrorDelegate.BeginInvoke Method

ConnectionProviderDelegatesCommunicationErrorDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.BeginInvoke(System.Exception,System.Boolean,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Exception exception,
    bool is_fatal,
    AsyncCallback callback,
    Object object
)

Parameters

exception Exception

[Missing <param name="exception"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.BeginInvoke(System.Exception,System.Boolean,System.AsyncCallback,System.Object)"]

is_fatal Boolean

[Missing <param name="is_fatal"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.BeginInvoke(System.Exception,System.Boolean,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.BeginInvoke(System.Exception,System.Boolean,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.BeginInvoke(System.Exception,System.Boolean,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.BeginInvoke(System.Exception,System.Boolean,System.AsyncCallback,System.Object)"]

See Also

Reference

ConnectionProviderDelegatesCommunicationErrorDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.CommunicationErrorDelegate.EndInvoke Method

ConnectionProviderDelegatesCommunicationErrorDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

ConnectionProviderDelegatesCommunicationErrorDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.CommunicationErrorDelegate.Invoke Method

ConnectionProviderDelegatesCommunicationErrorDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.Invoke(System.Exception,System.Boolean)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Exception exception,
    bool is_fatal
)

Parameters

exception Exception

[Missing <param name="exception"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.Invoke(System.Exception,System.Boolean)"]

is_fatal Boolean

[Missing <param name="is_fatal"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.CommunicationErrorDelegate.Invoke(System.Exception,System.Boolean)"]

See Also

Reference

ConnectionProviderDelegatesCommunicationErrorDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.ConnectionDelegate Class

ConnectionProviderDelegatesConnectionDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ConnectionDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Common.InterfacesConnectionProviderDelegatesConnectionDelegate

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class ConnectionDelegate : MulticastDelegate

The ConnectionProviderDelegatesConnectionDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionProviderDelegatesConnectionDelegate | Initializes a new instance of the ConnectionProviderDelegatesConnectionDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.ConnectionDelegate Constructor

ConnectionProviderDelegatesConnectionDelegate Constructor

Initializes a new instance of the ConnectionProviderDelegatesConnectionDelegate class

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ConnectionDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ConnectionDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ConnectionDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

ConnectionProviderDelegatesConnectionDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionDelegate Properties

The ConnectionProviderDelegatesConnectionDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

ConnectionProviderDelegatesConnectionDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionDelegate Methods

The ConnectionProviderDelegatesConnectionDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionProviderDelegatesConnectionDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.ConnectionDelegate.BeginInvoke Method

ConnectionProviderDelegatesConnectionDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ConnectionDelegate.BeginInvoke(System.Nullable{System.DateTime},System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    DateTime? time,
    AsyncCallback callback,
    Object object
)

Parameters

time Nullable DateTime

[Missing <param name="time"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ConnectionDelegate.BeginInvoke(System.Nullable{System.DateTime},System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ConnectionDelegate.BeginInvoke(System.Nullable{System.DateTime},System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ConnectionDelegate.BeginInvoke(System.Nullable{System.DateTime},System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ConnectionDelegate.BeginInvoke(System.Nullable{System.DateTime},System.AsyncCallback,System.Object)"]

See Also

Reference

ConnectionProviderDelegatesConnectionDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.ConnectionDelegate.EndInvoke Method

ConnectionProviderDelegatesConnectionDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ConnectionDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ConnectionDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

ConnectionProviderDelegatesConnectionDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.ConnectionDelegate.Invoke Method

ConnectionProviderDelegatesConnectionDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ConnectionDelegate.Invoke(System.Nullable{System.DateTime})"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    DateTime? time
)

Parameters

time Nullable DateTime

[Missing <param name="time"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ConnectionDelegate.Invoke(System.Nullable{System.DateTime})"]

See Also

Reference

ConnectionProviderDelegatesConnectionDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.DataReceivedDelegate Class

ConnectionProviderDelegatesDataReceivedDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Common.InterfacesConnectionProviderDelegatesDataReceivedDelegate

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class DataReceivedDelegate : MulticastDelegate

The ConnectionProviderDelegatesDataReceivedDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionProviderDelegatesDataReceivedDelegate | Initializes a new instance of the ConnectionProviderDelegatesDataReceivedDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.DataReceivedDelegate Constructor

ConnectionProviderDelegatesDataReceivedDelegate Constructor

Initializes a new instance of the ConnectionProviderDelegatesDataReceivedDelegate class

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DataReceivedDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

ConnectionProviderDelegatesDataReceivedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


DataReceivedDelegate Properties

The ConnectionProviderDelegatesDataReceivedDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

ConnectionProviderDelegatesDataReceivedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


DataReceivedDelegate Methods

The ConnectionProviderDelegatesDataReceivedDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionProviderDelegatesDataReceivedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.DataReceivedDelegate.BeginInvoke Method

ConnectionProviderDelegatesDataReceivedDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    IMessageIdentifier identifier,
    string message,
    ConnectionProviderDelegatesDataReceivedOutcome outcome,
    AsyncCallback callback,
    Object object
)

Parameters

identifier IMessageIdentifier

[Missing <param name="identifier"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

message String

[Missing <param name="message"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

outcome ConnectionProviderDelegatesDataReceivedOutcome

[Missing <param name="outcome"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

See Also

Reference

ConnectionProviderDelegatesDataReceivedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.DataReceivedDelegate.EndInvoke Method

ConnectionProviderDelegatesDataReceivedDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

ConnectionProviderDelegatesDataReceivedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.DataReceivedDelegate.Invoke Method

ConnectionProviderDelegatesDataReceivedDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.Invoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    IMessageIdentifier identifier,
    string message,
    ConnectionProviderDelegatesDataReceivedOutcome outcome
)

Parameters

identifier IMessageIdentifier

[Missing <param name="identifier"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.Invoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome)"]

message String

[Missing <param name="message"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.Invoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome)"]

outcome ConnectionProviderDelegatesDataReceivedOutcome

[Missing <param name="outcome"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedDelegate.Invoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome)"]

See Also

Reference

ConnectionProviderDelegatesDataReceivedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.DataReceivedOutcome Class

ConnectionProviderDelegatesDataReceivedOutcome Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.InterfacesConnectionProviderDelegatesDataReceivedOutcome

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class DataReceivedOutcome

The ConnectionProviderDelegatesDataReceivedOutcome type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionProviderDelegatesDataReceivedOutcome | Initializes a new instance of the ConnectionProviderDelegatesDataReceivedOutcome class
Top
Properties
 | Name | Description
Public property | Outcome |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.DataReceivedOutcome Constructor

ConnectionProviderDelegatesDataReceivedOutcome Constructor

Initializes a new instance of the ConnectionProviderDelegatesDataReceivedOutcome class

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DataReceivedOutcome()
See Also

Reference

ConnectionProviderDelegatesDataReceivedOutcome Class
Sportradar.SDK.Common.Interfaces Namespace


DataReceivedOutcome Properties

The ConnectionProviderDelegatesDataReceivedOutcome type exposes the following members.

Properties
 | Name | Description
Public property | Outcome |
Top
See Also

Reference

ConnectionProviderDelegatesDataReceivedOutcome Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.DataReceivedOutcome.Outcome Property

ConnectionProviderDelegatesDataReceivedOutcomeOutcome Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome.Outcome"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ConnectionProviderDelegatesOutcome Outcome { get; set; }

Property Value

ConnectionProviderDelegatesOutcome
See Also

Reference

ConnectionProviderDelegatesDataReceivedOutcome Class
Sportradar.SDK.Common.Interfaces Namespace


DataReceivedOutcome Methods

The ConnectionProviderDelegatesDataReceivedOutcome type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionProviderDelegatesDataReceivedOutcome Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.Outcome Class

ConnectionProviderDelegatesOutcome Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.Outcome"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.Common.InterfacesConnectionProviderDelegatesOutcome

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class Outcome : Enum

The ConnectionProviderDelegatesOutcome type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | CONSUMED |
 | ERROR |
 | INCOMPLETE |
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


Outcome Methods

The ConnectionProviderDelegatesOutcome type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

ConnectionProviderDelegatesOutcome Class
Sportradar.SDK.Common.Interfaces Namespace


Outcome Fields

The ConnectionProviderDelegatesOutcome type exposes the following members.

Fields
 | Name | Description
 | CONSUMED |
 | ERROR |
 | INCOMPLETE |
Public field | value__ |
Top
See Also

Reference

ConnectionProviderDelegatesOutcome Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.Outcome.CONSUMED Field

ConnectionProviderDelegatesOutcomeCONSUMED Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.Outcome.CONSUMED"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ConnectionProviderDelegatesOutcome CONSUMED = 0

Field Value

ConnectionProviderDelegatesOutcome
See Also

Reference

ConnectionProviderDelegatesOutcome Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.Outcome.ERROR Field

ConnectionProviderDelegatesOutcomeERROR Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.Outcome.ERROR"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ConnectionProviderDelegatesOutcome ERROR = 1

Field Value

ConnectionProviderDelegatesOutcome
See Also

Reference

ConnectionProviderDelegatesOutcome Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.Outcome.INCOMPLETE Field

ConnectionProviderDelegatesOutcomeINCOMPLETE Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.Outcome.INCOMPLETE"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ConnectionProviderDelegatesOutcome INCOMPLETE = 2

Field Value

ConnectionProviderDelegatesOutcome
See Also

Reference

ConnectionProviderDelegatesOutcome Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.Outcome.value__ Field

ConnectionProviderDelegatesOutcomevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.Outcome.value__"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

ConnectionProviderDelegatesOutcome Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.SimpleDataReceivedDelegate Class

ConnectionProviderDelegatesSimpleDataReceivedDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Common.InterfacesConnectionProviderDelegatesSimpleDataReceivedDelegate

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class SimpleDataReceivedDelegate : MulticastDelegate

The ConnectionProviderDelegatesSimpleDataReceivedDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionProviderDelegatesSimpleDataReceivedDelegate | Initializes a new instance of the ConnectionProviderDelegatesSimpleDataReceivedDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.SimpleDataReceivedDelegate Constructor

ConnectionProviderDelegatesSimpleDataReceivedDelegate Constructor

Initializes a new instance of the ConnectionProviderDelegatesSimpleDataReceivedDelegate class

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SimpleDataReceivedDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

ConnectionProviderDelegatesSimpleDataReceivedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


SimpleDataReceivedDelegate Properties

The ConnectionProviderDelegatesSimpleDataReceivedDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

ConnectionProviderDelegatesSimpleDataReceivedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


SimpleDataReceivedDelegate Methods

The ConnectionProviderDelegatesSimpleDataReceivedDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionProviderDelegatesSimpleDataReceivedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.SimpleDataReceivedDelegate.BeginInvoke Method

ConnectionProviderDelegatesSimpleDataReceivedDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    IMessageIdentifier identifier,
    string message,
    AsyncCallback callback,
    Object object
)

Parameters

identifier IMessageIdentifier

[Missing <param name="identifier"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,System.AsyncCallback,System.Object)"]

message String

[Missing <param name="message"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.BeginInvoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String,System.AsyncCallback,System.Object)"]

See Also

Reference

ConnectionProviderDelegatesSimpleDataReceivedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.SimpleDataReceivedDelegate.EndInvoke Method

ConnectionProviderDelegatesSimpleDataReceivedDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

ConnectionProviderDelegatesSimpleDataReceivedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.SimpleDataReceivedDelegate.Invoke Method

ConnectionProviderDelegatesSimpleDataReceivedDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.Invoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    IMessageIdentifier identifier,
    string message
)

Parameters

identifier IMessageIdentifier

[Missing <param name="identifier"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.Invoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String)"]

message String

[Missing <param name="message"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.SimpleDataReceivedDelegate.Invoke(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String)"]

See Also

Reference

ConnectionProviderDelegatesSimpleDataReceivedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate Class

ConnectionProviderDelegatesValidDataCheckNecessaryDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Common.InterfacesConnectionProviderDelegatesValidDataCheckNecessaryDelegate

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class ValidDataCheckNecessaryDelegate : MulticastDelegate

The ConnectionProviderDelegatesValidDataCheckNecessaryDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionProviderDelegatesValidDataCheckNecessaryDelegate | Initializes a new instance of the ConnectionProviderDelegatesValidDataCheckNecessaryDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate Constructor

ConnectionProviderDelegatesValidDataCheckNecessaryDelegate Constructor

Initializes a new instance of the ConnectionProviderDelegatesValidDataCheckNecessaryDelegate class

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ValidDataCheckNecessaryDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

ConnectionProviderDelegatesValidDataCheckNecessaryDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ValidDataCheckNecessaryDelegate Properties

The ConnectionProviderDelegatesValidDataCheckNecessaryDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

ConnectionProviderDelegatesValidDataCheckNecessaryDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ValidDataCheckNecessaryDelegate Methods

The ConnectionProviderDelegatesValidDataCheckNecessaryDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionProviderDelegatesValidDataCheckNecessaryDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.BeginInvoke Method

ConnectionProviderDelegatesValidDataCheckNecessaryDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.BeginInvoke(System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    string message,
    ConnectionProviderDelegatesDataReceivedOutcome outcome,
    AsyncCallback callback,
    Object object
)

Parameters

message String

[Missing <param name="message"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.BeginInvoke(System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

outcome ConnectionProviderDelegatesDataReceivedOutcome

[Missing <param name="outcome"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.BeginInvoke(System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.BeginInvoke(System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.BeginInvoke(System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.BeginInvoke(System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome,System.AsyncCallback,System.Object)"]

See Also

Reference

ConnectionProviderDelegatesValidDataCheckNecessaryDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.EndInvoke Method

ConnectionProviderDelegatesValidDataCheckNecessaryDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

ConnectionProviderDelegatesValidDataCheckNecessaryDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.Invoke Method

ConnectionProviderDelegatesValidDataCheckNecessaryDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.Invoke(System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    string message,
    ConnectionProviderDelegatesDataReceivedOutcome outcome
)

Parameters

message String

[Missing <param name="message"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.Invoke(System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome)"]

outcome ConnectionProviderDelegatesDataReceivedOutcome

[Missing <param name="outcome"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.ValidDataCheckNecessaryDelegate.Invoke(System.String,Sportradar.SDK.Common.Interfaces.ConnectionProviderDelegates.DataReceivedOutcome)"]

See Also

Reference

ConnectionProviderDelegatesValidDataCheckNecessaryDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


DispatcherOperationMode Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.DispatcherOperationMode"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.Common.InterfacesDispatcherOperationMode

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class DispatcherOperationMode : Enum

The DispatcherOperationMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | ERROR_RECOVERY_PHASE1 |
 | ERROR_RECOVERY_PHASE2 |
 | NORMAL |
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


DispatcherOperationMode Methods

The DispatcherOperationMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

DispatcherOperationMode Class
Sportradar.SDK.Common.Interfaces Namespace


DispatcherOperationMode Fields

The DispatcherOperationMode type exposes the following members.

Fields
 | Name | Description
 | ERROR_RECOVERY_PHASE1 |
 | ERROR_RECOVERY_PHASE2 |
 | NORMAL |
Public field | value__ |
Top
See Also

Reference

DispatcherOperationMode Class
Sportradar.SDK.Common.Interfaces Namespace


DispatcherOperationMode.ERROR_RECOVERY_PHASE1 Field

DispatcherOperationModeERROR_RECOVERY_PHASE1 Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.DispatcherOperationMode.ERROR_RECOVERY_PHASE1"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const DispatcherOperationMode ERROR_RECOVERY_PHASE1 = 1

Field Value

DispatcherOperationMode
See Also

Reference

DispatcherOperationMode Class
Sportradar.SDK.Common.Interfaces Namespace


DispatcherOperationMode.ERROR_RECOVERY_PHASE2 Field

DispatcherOperationModeERROR_RECOVERY_PHASE2 Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.DispatcherOperationMode.ERROR_RECOVERY_PHASE2"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const DispatcherOperationMode ERROR_RECOVERY_PHASE2 = 2

Field Value

DispatcherOperationMode
See Also

Reference

DispatcherOperationMode Class
Sportradar.SDK.Common.Interfaces Namespace


DispatcherOperationMode.NORMAL Field

DispatcherOperationModeNORMAL Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.DispatcherOperationMode.NORMAL"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const DispatcherOperationMode NORMAL = 0

Field Value

DispatcherOperationMode
See Also

Reference

DispatcherOperationMode Class
Sportradar.SDK.Common.Interfaces Namespace


DispatcherOperationMode.value__ Field

DispatcherOperationModevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.DispatcherOperationMode.value__"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

DispatcherOperationMode Class
Sportradar.SDK.Common.Interfaces Namespace


DispatchStatus Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.DispatchStatus"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.Common.InterfacesDispatchStatus

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class DispatchStatus : Enum

The DispatchStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | FAILED |
 | SUCCESSFUL |
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


DispatchStatus Methods

The DispatchStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

DispatchStatus Class
Sportradar.SDK.Common.Interfaces Namespace


DispatchStatus Fields

The DispatchStatus type exposes the following members.

Fields
 | Name | Description
 | FAILED |
 | SUCCESSFUL |
Public field | value__ |
Top
See Also

Reference

DispatchStatus Class
Sportradar.SDK.Common.Interfaces Namespace


DispatchStatus.FAILED Field

DispatchStatusFAILED Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.DispatchStatus.FAILED"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const DispatchStatus FAILED = 0

Field Value

DispatchStatus
See Also

Reference

DispatchStatus Class
Sportradar.SDK.Common.Interfaces Namespace


DispatchStatus.SUCCESSFUL Field

DispatchStatusSUCCESSFUL Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.DispatchStatus.SUCCESSFUL"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const DispatchStatus SUCCESSFUL = 1

Field Value

DispatchStatus
See Also

Reference

DispatchStatus Class
Sportradar.SDK.Common.Interfaces Namespace


DispatchStatus.value__ Field

DispatchStatusvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.DispatchStatus.value__"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

DispatchStatus Class
Sportradar.SDK.Common.Interfaces Namespace


GuidIdentifier Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.GuidIdentifier"]

Inheritance Hierarchy
SystemObject
SystemValueType
Sportradar.SDK.Common.InterfacesGuidIdentifier

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class GuidIdentifier : ValueType,
    IMessageIdentifier, IEquatable<GuidIdentifier>

The GuidIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Guid |
Top
Methods
 | Name | Description
Public method | Equals(GuidIdentifier) |
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object))
Public method | GetHashCode | (Overrides ValueTypeGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ValueTypeToString)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


GuidIdentifier Properties

The GuidIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Guid |
Top
See Also

Reference

GuidIdentifier Class
Sportradar.SDK.Common.Interfaces Namespace


GuidIdentifier.Guid Property

GuidIdentifierGuid Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.GuidIdentifier.Guid"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Guid Guid { get; }

Property Value

Guid
See Also

Reference

GuidIdentifier Class
Sportradar.SDK.Common.Interfaces Namespace


GuidIdentifier Methods

The GuidIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals(GuidIdentifier) |
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object))
Public method | GetHashCode | (Overrides ValueTypeGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ValueTypeToString)
Top
See Also

Reference

GuidIdentifier Class
Sportradar.SDK.Common.Interfaces Namespace


GuidIdentifier.Equals Method

GuidIdentifierEquals Method

Overload List
 | Name | Description
Public method | Equals(GuidIdentifier) |
Public method | Equals(Object) |
Top
See Also

Reference

GuidIdentifier Class
Sportradar.SDK.Common.Interfaces Namespace


GuidIdentifier.Equals(GuidIdentifier) Method

GuidIdentifierEquals(GuidIdentifier) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.GuidIdentifier.Equals(Sportradar.SDK.Common.Interfaces.GuidIdentifier)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Equals(
    GuidIdentifier other
)

Parameters

other GuidIdentifier

[Missing <param name="other"/> documentation for "M:Sportradar.SDK.Common.Interfaces.GuidIdentifier.Equals(Sportradar.SDK.Common.Interfaces.GuidIdentifier)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.GuidIdentifier.Equals(Sportradar.SDK.Common.Interfaces.GuidIdentifier)"]

Implements

IEquatableTEquals(T)
See Also

Reference

GuidIdentifier Class
Equals Overload
Sportradar.SDK.Common.Interfaces Namespace


GuidIdentifier.Equals(Object) Method

GuidIdentifierEquals(Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.GuidIdentifier.Equals(System.Object)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Common.Interfaces.GuidIdentifier.Equals(System.Object)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.GuidIdentifier.Equals(System.Object)"]

See Also

Reference

GuidIdentifier Class
Equals Overload
Sportradar.SDK.Common.Interfaces Namespace


GuidIdentifier.GetHashCode Method

GuidIdentifierGetHashCode Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.GuidIdentifier.GetHashCode"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.GuidIdentifier.GetHashCode"]

See Also

Reference

GuidIdentifier Class
Sportradar.SDK.Common.Interfaces Namespace


GuidIdentifier.ToString Method

GuidIdentifierToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.GuidIdentifier.ToString"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.GuidIdentifier.ToString"]

See Also

Reference

GuidIdentifier Class
Sportradar.SDK.Common.Interfaces Namespace


ICipherSettings Interface

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ICipherSettings"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ICipherSettings : ICloneable

The ICipherSettings type exposes the following members.

Properties
 | Name | Description
Public property | MinCipherStrength |
Public property | MinHashStrength |
Public property | MinKeyExchangeStrength |
Public property | SSLThumbPrint |
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


ICipherSettings Properties

The ICipherSettings type exposes the following members.

Properties
 | Name | Description
Public property | MinCipherStrength |
Public property | MinHashStrength |
Public property | MinKeyExchangeStrength |
Public property | SSLThumbPrint |
Top
See Also

Reference

ICipherSettings Interface
Sportradar.SDK.Common.Interfaces Namespace


ICipherSettings.MinCipherStrength Property

ICipherSettingsMinCipherStrength Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.ICipherSettings.MinCipherStrength"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
int MinCipherStrength { get; }

Property Value

Int32
See Also

Reference

ICipherSettings Interface
Sportradar.SDK.Common.Interfaces Namespace


ICipherSettings.MinHashStrength Property

ICipherSettingsMinHashStrength Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.ICipherSettings.MinHashStrength"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
int MinHashStrength { get; }

Property Value

Int32
See Also

Reference

ICipherSettings Interface
Sportradar.SDK.Common.Interfaces Namespace


ICipherSettings.MinKeyExchangeStrength Property

ICipherSettingsMinKeyExchangeStrength Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.ICipherSettings.MinKeyExchangeStrength"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
int MinKeyExchangeStrength { get; }

Property Value

Int32
See Also

Reference

ICipherSettings Interface
Sportradar.SDK.Common.Interfaces Namespace


ICipherSettings.SSLThumbPrint Property

ICipherSettingsSSLThumbPrint Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.ICipherSettings.SSLThumbPrint"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
string SSLThumbPrint { get; }

Property Value

String
See Also

Reference

ICipherSettings Interface
Sportradar.SDK.Common.Interfaces Namespace


ICipherSettings Methods

The ICipherSettings type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable)
Top
See Also

Reference

ICipherSettings Interface
Sportradar.SDK.Common.Interfaces Namespace


IClientPersistentState Interface

Persistent state store interface that should be implemented by the client.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IClientPersistentState

The IClientPersistentState type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears persistent state store contents.
Public method | Read | Retrieves value for the given key from the persistent store.
Public method | ReadAll | Returns all persistent state items from the store.
Public method | Remove | Removes an item by key
Public method | RemoveOld | Removes stale persistent state items that haven't been updated in a while.
Public method | Write | Write batch of key-value pairs into client provided persistent store (DB, file system).
Top
Remarks
If this interface is not implemented, XML feed error recovery will not be possible
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IClientPersistentState Methods

The IClientPersistentState type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears persistent state store contents.
Public method | Read | Retrieves value for the given key from the persistent store.
Public method | ReadAll | Returns all persistent state items from the store.
Public method | Remove | Removes an item by key
Public method | RemoveOld | Removes stale persistent state items that haven't been updated in a while.
Public method | Write | Write batch of key-value pairs into client provided persistent store (DB, file system).
Top
See Also

Reference

IClientPersistentState Interface
Sportradar.SDK.Common.Interfaces Namespace


IClientPersistentState.Clear Method

IClientPersistentStateClear Method

Clears persistent state store contents.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Clear()
See Also

Reference

IClientPersistentState Interface
Sportradar.SDK.Common.Interfaces Namespace


IClientPersistentState.Read Method

IClientPersistentStateRead Method

Retrieves value for the given key from the persistent store.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
ClientPersistentStateItem Read(
    string key
)

Parameters

key String
Key

Return Value

ClientPersistentStateItem
Retrieved item
Remarks
Returns null if key is not found. Used at error recovery and for double-checking whether persistent state store contents are consistent with buffered values.
See Also

Reference

IClientPersistentState Interface
Sportradar.SDK.Common.Interfaces Namespace


IClientPersistentState.ReadAll Method

IClientPersistentStateReadAll Method

Returns all persistent state items from the store.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
IEnumerable<ClientPersistentStateItem> ReadAll()

Return Value

IEnumerable ClientPersistentStateItem
All persistent state items from the store
See Also

Reference

IClientPersistentState Interface
Sportradar.SDK.Common.Interfaces Namespace


IClientPersistentState.Remove Method

IClientPersistentStateRemove Method

Removes an item by key

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Remove(
    string key
)

Parameters

key String
Key
See Also

Reference

IClientPersistentState Interface
Sportradar.SDK.Common.Interfaces Namespace


IClientPersistentState.RemoveOld Method

IClientPersistentStateRemoveOld Method

Removes stale persistent state items that haven't been updated in a while.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void RemoveOld(
    DateTime max_age
)

Parameters

max_age DateTime
All items older than max_age will be removed from the store
See Also

Reference

IClientPersistentState Interface
Sportradar.SDK.Common.Interfaces Namespace


IClientPersistentState.Write Method

IClientPersistentStateWrite Method

Write batch of key-value pairs into client provided persistent store (DB, file system).

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Write(
    IList<ClientPersistentStateItem> items
)

Parameters

items IList ClientPersistentStateItem
Batch of items
Remarks
Overwrites existing values so that stale items can be removed.
See Also

Reference

IClientPersistentState Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData Interface

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.IConnectionData"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IConnectionData : ICloneable

The IConnectionData type exposes the following members.

Properties
 | Name | Description
Public property | CipherSettings | SSL stream cipher settings.
Public property | ClientAliveMsgTimeout | Client alive message timeout
Public property | DisallowNonPrintableChars | Should non-printable characters in the stream trigger a disconnect.
Public property | DoValidityCheck | Should connection provider do a quick validity check.
Public property | Encoding | Communication channel character encoding
Public property | Hostname | Server name
Public property | InvalidDataReconnectWait | Delay before we try reconnecting to server after we received some garbage data
Public property | MaxReconnectWait | Delay before we try reconnecting to server after we got disconnected (max)
Public property | MinReconnectWait | Delay before we try reconnecting to server after we got disconnected (min)
Public property | Port | Server port number
Public property | ReceiveBufferSize | Message line buffer size. Complete message line should fit in here.
Public property | ReceiveTimeout |
Public property | SendTimeout | Amount of time to wait for (socket) send operation to complete successfully
Public property | ServerAliveMsgTimeout | Server alive message timeout
Public property | TotalBufferSize | Total message buffer size. A complete XML message should fit in here.
Public property | UseSSL | Use secure sockets for communication.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IConnectionData Properties

The IConnectionData type exposes the following members.

Properties
 | Name | Description
Public property | CipherSettings | SSL stream cipher settings.
Public property | ClientAliveMsgTimeout | Client alive message timeout
Public property | DisallowNonPrintableChars | Should non-printable characters in the stream trigger a disconnect.
Public property | DoValidityCheck | Should connection provider do a quick validity check.
Public property | Encoding | Communication channel character encoding
Public property | Hostname | Server name
Public property | InvalidDataReconnectWait | Delay before we try reconnecting to server after we received some garbage data
Public property | MaxReconnectWait | Delay before we try reconnecting to server after we got disconnected (max)
Public property | MinReconnectWait | Delay before we try reconnecting to server after we got disconnected (min)
Public property | Port | Server port number
Public property | ReceiveBufferSize | Message line buffer size. Complete message line should fit in here.
Public property | ReceiveTimeout |
Public property | SendTimeout | Amount of time to wait for (socket) send operation to complete successfully
Public property | ServerAliveMsgTimeout | Server alive message timeout
Public property | TotalBufferSize | Total message buffer size. A complete XML message should fit in here.
Public property | UseSSL | Use secure sockets for communication.
Top
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.CipherSettings Property

IConnectionDataCipherSettings Property

SSL stream cipher settings.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
ICipherSettings CipherSettings { get; }

Property Value

ICipherSettings
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.ClientAliveMsgTimeout Property

IConnectionDataClientAliveMsgTimeout Property

Client alive message timeout

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
TimeSpan ClientAliveMsgTimeout { get; }

Property Value

TimeSpan
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.DisallowNonPrintableChars Property

IConnectionDataDisallowNonPrintableChars Property

Should non-printable characters in the stream trigger a disconnect.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool DisallowNonPrintableChars { get; }

Property Value

Boolean
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.DoValidityCheck Property

IConnectionDataDoValidityCheck Property

Should connection provider do a quick validity check.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool DoValidityCheck { get; }

Property Value

Boolean
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.Encoding Property

IConnectionDataEncoding Property

Communication channel character encoding

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
Encoding Encoding { get; }

Property Value

Encoding
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.Hostname Property

IConnectionDataHostname Property

Server name

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
string Hostname { get; }

Property Value

String
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.InvalidDataReconnectWait Property

IConnectionDataInvalidDataReconnectWait Property

Delay before we try reconnecting to server after we received some garbage data

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
TimeSpan InvalidDataReconnectWait { get; }

Property Value

TimeSpan
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.MaxReconnectWait Property

IConnectionDataMaxReconnectWait Property

Delay before we try reconnecting to server after we got disconnected (max)

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
TimeSpan MaxReconnectWait { get; }

Property Value

TimeSpan
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.MinReconnectWait Property

IConnectionDataMinReconnectWait Property

Delay before we try reconnecting to server after we got disconnected (min)

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
TimeSpan MinReconnectWait { get; }

Property Value

TimeSpan
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.Port Property

IConnectionDataPort Property

Server port number

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
int Port { get; }

Property Value

Int32
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.ReceiveBufferSize Property

IConnectionDataReceiveBufferSize Property

Message line buffer size. Complete message line should fit in here.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
int ReceiveBufferSize { get; }

Property Value

Int32
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.ReceiveTimeout Property

IConnectionDataReceiveTimeout Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.IConnectionData.ReceiveTimeout"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
TimeSpan ReceiveTimeout { get; }

Property Value

TimeSpan
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.SendTimeout Property

IConnectionDataSendTimeout Property

Amount of time to wait for (socket) send operation to complete successfully

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
TimeSpan SendTimeout { get; }

Property Value

TimeSpan
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.ServerAliveMsgTimeout Property

IConnectionDataServerAliveMsgTimeout Property

Server alive message timeout

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
TimeSpan ServerAliveMsgTimeout { get; }

Property Value

TimeSpan
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.TotalBufferSize Property

IConnectionDataTotalBufferSize Property

Total message buffer size. A complete XML message should fit in here.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
int TotalBufferSize { get; }

Property Value

Int32
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData.UseSSL Property

IConnectionDataUseSSL Property

Use secure sockets for communication.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool UseSSL { get; }

Property Value

Boolean
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionData Methods

The IConnectionData type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable)
Top
See Also

Reference

IConnectionData Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider Interface

Connection provider

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IConnectionProvider

The IConnectionProvider type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionData | Obtain current connection data
Public property | IsStarted | Obtain whether the connection provider is running.
Public property | RxEnabled | Whether reading from input stream is enabled or not (i.e. input msg queue going over the high watermark should disable all RX)
Top
Methods
 | Name | Description
Public method | Error | Obsolete. Start immediate error recovery. Usually due to an error on the upper layer.
Public method | IsReceiveThread |
Public method | SendMessage | Deliver a protocol unit (as a string) to the server.
Public method | Start | Start the connection provider (connects to the server and start the automatic reconnection). ConnectionData must be initialized or else an exception is thrown.
Public method | Start(IConnectionData) | Start the connection provider (connects to the server and start the automatic reconnection).
Public method | Stop | Stop the connection provider. Opposite of Start().
Public method | WaitForConnection | Block and wait until the connection is established.
Public method | WaitForConnection(TimeSpan) |
Public method | WaitForDisconnection | Block and wait until the connection is not established anymore.
Public method | WaitForDisconnection(TimeSpan) |
Top
Events
 | Name | Description
Public event | OnAliveCheckNecessary | Invoked when the protocol requires an alive check.
Public event | OnCommunicationError | Invoked when a communication error on the physical connection is detected
Public event | OnConnected | Invoked when the physical connection to the server is established.
Public event | OnDisconnected | Invoked when the physical connection to the server is dropped.
Public event | OnMessageReceived | Invoked when a new protocol data unit in string format is received.
Public event | OnValidDataCheckNecessary | Invoked when the protocol requires a check for valid data.
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider Properties

The IConnectionProvider type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionData | Obtain current connection data
Public property | IsStarted | Obtain whether the connection provider is running.
Public property | RxEnabled | Whether reading from input stream is enabled or not (i.e. input msg queue going over the high watermark should disable all RX)
Top
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.ConnectionData Property

IConnectionProviderConnectionData Property

Obtain current connection data

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
IConnectionData ConnectionData { get; }

Property Value

IConnectionData
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.IsStarted Property

IConnectionProviderIsStarted Property

Obtain whether the connection provider is running.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool IsStarted { get; }

Property Value

Boolean
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.RxEnabled Property

IConnectionProviderRxEnabled Property

Whether reading from input stream is enabled or not (i.e. input msg queue going over the high watermark should disable all RX)

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
ManualResetEventSlim RxEnabled { get; }

Property Value

ManualResetEventSlim
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider Methods

The IConnectionProvider type exposes the following members.

Methods
 | Name | Description
Public method | Error | Obsolete. Start immediate error recovery. Usually due to an error on the upper layer.
Public method | IsReceiveThread |
Public method | SendMessage | Deliver a protocol unit (as a string) to the server.
Public method | Start | Start the connection provider (connects to the server and start the automatic reconnection). ConnectionData must be initialized or else an exception is thrown.
Public method | Start(IConnectionData) | Start the connection provider (connects to the server and start the automatic reconnection).
Public method | Stop | Stop the connection provider. Opposite of Start().
Public method | WaitForConnection | Block and wait until the connection is established.
Public method | WaitForConnection(TimeSpan) |
Public method | WaitForDisconnection | Block and wait until the connection is not established anymore.
Public method | WaitForDisconnection(TimeSpan) |
Top
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.Error Method

IConnectionProviderError Method

Note: This API is now obsolete.

Start immediate error recovery. Usually due to an error on the upper layer.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
[ObsoleteAttribute]
void Error(
    string opt_protocol_message,
    string log_message
)

Parameters

opt_protocol_message String
Optional message that should be sent before disconnection
log_message String
Informative error description
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.IsReceiveThread Method

IConnectionProviderIsReceiveThread Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.IConnectionProvider.IsReceiveThread"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool IsReceiveThread()

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.IConnectionProvider.IsReceiveThread"]

See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.SendMessage Method

IConnectionProviderSendMessage Method

Deliver a protocol unit (as a string) to the server.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool SendMessage(
    string message,
    bool only_try = false
)

Parameters

message String
protocol unit (in string format)
only_try Boolean (Optional)
when true do not throw any exceptions

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.IConnectionProvider.SendMessage(System.String,System.Boolean)"]

Exceptions
Exception | Condition
DisconnectedStateException | If we are currently disconnected
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.Start Method

IConnectionProviderStart Method

Overload List
 | Name | Description
Public method | Start | Start the connection provider (connects to the server and start the automatic reconnection). ConnectionData must be initialized or else an exception is thrown.
Public method | Start(IConnectionData) | Start the connection provider (connects to the server and start the automatic reconnection).
Top
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.Start Method

IConnectionProviderStart Method

Start the connection provider (connects to the server and start the automatic reconnection). ConnectionData must be initialized or else an exception is thrown.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Start()
See Also

Reference

IConnectionProvider Interface
Start Overload
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.Start(IConnectionData) Method

IConnectionProviderStart(IConnectionData) Method

Start the connection provider (connects to the server and start the automatic reconnection).

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Start(
    IConnectionData connection_data
)

Parameters

connection_data IConnectionData
connection data
See Also

Reference

IConnectionProvider Interface
Start Overload
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.Stop Method

IConnectionProviderStop Method

Stop the connection provider. Opposite of Start().

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Stop(
    string opt_protocol_message
)

Parameters

opt_protocol_message String
Optional message that should be sent before disconnection
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.WaitForConnection Method

IConnectionProviderWaitForConnection Method

Overload List
 | Name | Description
Public method | WaitForConnection | Block and wait until the connection is established.
Public method | WaitForConnection(TimeSpan) |
Top
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.WaitForConnection Method

IConnectionProviderWaitForConnection Method

Block and wait until the connection is established.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool WaitForConnection()

Return Value

Boolean
true if the connection is established; false (should rarely happen) in case of a race-condition or when wait_time times out
Remarks
The method might return true and the connection can get broken right after that, so do not assume after that method we are for sure in a "connected" state, it might have been just a temporary state.
See Also

Reference

IConnectionProvider Interface
WaitForConnection Overload
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.WaitForConnection(TimeSpan) Method

IConnectionProviderWaitForConnection(TimeSpan) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.IConnectionProvider.WaitForConnection(System.TimeSpan)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool WaitForConnection(
    TimeSpan wait_time
)

Parameters

wait_time TimeSpan

[Missing <param name="wait_time"/> documentation for "M:Sportradar.SDK.Common.Interfaces.IConnectionProvider.WaitForConnection(System.TimeSpan)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.IConnectionProvider.WaitForConnection(System.TimeSpan)"]

See Also

Reference

IConnectionProvider Interface
WaitForConnection Overload
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.WaitForDisconnection Method

IConnectionProviderWaitForDisconnection Method

Overload List
 | Name | Description
Public method | WaitForDisconnection | Block and wait until the connection is not established anymore.
Public method | WaitForDisconnection(TimeSpan) |
Top
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.WaitForDisconnection Method

IConnectionProviderWaitForDisconnection Method

Block and wait until the connection is not established anymore.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool WaitForDisconnection()

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.IConnectionProvider.WaitForDisconnection"]

See Also

Reference

IConnectionProvider Interface
WaitForDisconnection Overload
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.WaitForDisconnection(TimeSpan) Method

IConnectionProviderWaitForDisconnection(TimeSpan) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.IConnectionProvider.WaitForDisconnection(System.TimeSpan)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool WaitForDisconnection(
    TimeSpan wait_time
)

Parameters

wait_time TimeSpan

[Missing <param name="wait_time"/> documentation for "M:Sportradar.SDK.Common.Interfaces.IConnectionProvider.WaitForDisconnection(System.TimeSpan)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.IConnectionProvider.WaitForDisconnection(System.TimeSpan)"]

See Also

Reference

IConnectionProvider Interface
WaitForDisconnection Overload
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider Events

The IConnectionProvider type exposes the following members.

Events
 | Name | Description
Public event | OnAliveCheckNecessary | Invoked when the protocol requires an alive check.
Public event | OnCommunicationError | Invoked when a communication error on the physical connection is detected
Public event | OnConnected | Invoked when the physical connection to the server is established.
Public event | OnDisconnected | Invoked when the physical connection to the server is dropped.
Public event | OnMessageReceived | Invoked when a new protocol data unit in string format is received.
Public event | OnValidDataCheckNecessary | Invoked when the protocol requires a check for valid data.
Top
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.OnAliveCheckNecessary Event

IConnectionProviderOnAliveCheckNecessary Event

Invoked when the protocol requires an alive check.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
event ConnectionProviderDelegatesAliveCheckNecessaryDelegate OnAliveCheckNecessary

Value

ConnectionProviderDelegatesAliveCheckNecessaryDelegate
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.OnCommunicationError Event

IConnectionProviderOnCommunicationError Event

Invoked when a communication error on the physical connection is detected

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
event ConnectionProviderDelegatesCommunicationErrorDelegate OnCommunicationError

Value

ConnectionProviderDelegatesCommunicationErrorDelegate
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.OnConnected Event

IConnectionProviderOnConnected Event

Invoked when the physical connection to the server is established.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
event ConnectionProviderDelegatesConnectionDelegate OnConnected

Value

ConnectionProviderDelegatesConnectionDelegate
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.OnDisconnected Event

IConnectionProviderOnDisconnected Event

Invoked when the physical connection to the server is dropped.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
event ConnectionProviderDelegatesConnectionDelegate OnDisconnected

Value

ConnectionProviderDelegatesConnectionDelegate
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.OnMessageReceived Event

IConnectionProviderOnMessageReceived Event

Invoked when a new protocol data unit in string format is received.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
event ConnectionProviderDelegatesDataReceivedDelegate OnMessageReceived

Value

ConnectionProviderDelegatesDataReceivedDelegate
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IConnectionProvider.OnValidDataCheckNecessary Event

IConnectionProviderOnValidDataCheckNecessary Event

Invoked when the protocol requires a check for valid data.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
event ConnectionProviderDelegatesValidDataCheckNecessaryDelegate OnValidDataCheckNecessary

Value

ConnectionProviderDelegatesValidDataCheckNecessaryDelegate
See Also

Reference

IConnectionProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


IDeadLetterQueue Interface

Dead Letter queue interface that should be implemented by the client.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IDeadLetterQueue

The IDeadLetterQueue type exposes the following members.

Methods
 | Name | Description
Public method | Enqueue | Enqueues a message into dead letter queue after the message was removed from the poison queue and could not be delivered successfully to the client.
Top
Remarks
Implementation of this interface is optional for the client
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IDeadLetterQueue Methods

The IDeadLetterQueue type exposes the following members.

Methods
 | Name | Description
Public method | Enqueue | Enqueues a message into dead letter queue after the message was removed from the poison queue and could not be delivered successfully to the client.
Top
See Also

Reference

IDeadLetterQueue Interface
Sportradar.SDK.Common.Interfaces Namespace


IDeadLetterQueue.Enqueue Method

IDeadLetterQueueEnqueue Method

Enqueues a message into dead letter queue after the message was removed from the poison queue and could not be delivered successfully to the client.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Enqueue(
    EntityBase failed_msg
)

Parameters

failed_msg EntityBase
Failed msg
See Also

Reference

IDeadLetterQueue Interface
Sportradar.SDK.Common.Interfaces Namespace


IFeedDispatcher Interface

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.IFeedDispatcher"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IFeedDispatcher

The IFeedDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType |
Top
Methods
 | Name | Description
Public method | DispatchEntity |
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IFeedDispatcher Properties

The IFeedDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType |
Top
See Also

Reference

IFeedDispatcher Interface
Sportradar.SDK.Common.Interfaces Namespace


IFeedDispatcher.ProviderType Property

IFeedDispatcherProviderType Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.IFeedDispatcher.ProviderType"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
See Also

Reference

IFeedDispatcher Interface
Sportradar.SDK.Common.Interfaces Namespace


IFeedDispatcher Methods

The IFeedDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | DispatchEntity |
Top
See Also

Reference

IFeedDispatcher Interface
Sportradar.SDK.Common.Interfaces Namespace


IFeedDispatcher.DispatchEntity Method

IFeedDispatcherDispatchEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.IFeedDispatcher.DispatchEntity(Sportradar.SDK.Common.EntityBase)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
DispatchStatus DispatchEntity(
    EntityBase entity
)

Parameters

entity EntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.Common.Interfaces.IFeedDispatcher.DispatchEntity(Sportradar.SDK.Common.EntityBase)"]

Return Value

DispatchStatus

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.IFeedDispatcher.DispatchEntity(Sportradar.SDK.Common.EntityBase)"]

See Also

Reference

IFeedDispatcher Interface
Sportradar.SDK.Common.Interfaces Namespace


ILiveOddsTypeProvider Interface

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOddsTypeProvider : IStartable

The ILiveOddsTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations |
Top
Methods
 | Name | Description
Public method | GetAllBetTypes |
Public method | GetBetType |
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


ILiveOddsTypeProvider Properties

The ILiveOddsTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations |
Top
See Also

Reference

ILiveOddsTypeProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


ILiveOddsTypeProvider.AvailableTranslations Property

ILiveOddsTypeProviderAvailableTranslations Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider.AvailableTranslations"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
HashSet<string> AvailableTranslations { get; }

Property Value

HashSet String
See Also

Reference

ILiveOddsTypeProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


ILiveOddsTypeProvider Methods

The ILiveOddsTypeProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetAllBetTypes |
Public method | GetBetType |
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Top
See Also

Reference

ILiveOddsTypeProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


ILiveOddsTypeProvider.GetAllBetTypes Method

ILiveOddsTypeProviderGetAllBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider.GetAllBetTypes"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
BetValue[] GetAllBetTypes()

Return Value

BetValue

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider.GetAllBetTypes"]

See Also

Reference

ILiveOddsTypeProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


ILiveOddsTypeProvider.GetBetType Method

ILiveOddsTypeProviderGetBetType Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider.GetBetType(Sportradar.SDK.Common.BetTypeKey)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
BetValue GetBetType(
    BetTypeKey key
)

Parameters

key BetTypeKey

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider.GetBetType(Sportradar.SDK.Common.BetTypeKey)"]

Return Value

BetValue

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider.GetBetType(Sportradar.SDK.Common.BetTypeKey)"]

See Also

Reference

ILiveOddsTypeProvider Interface
Sportradar.SDK.Common.Interfaces Namespace


ILoggerData Interface

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ILoggerData"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILoggerData : ICloneable

The ILoggerData type exposes the following members.

Properties
 | Name | Description
Public property | AlertLogLevel | Specifies log level threshold used while logging alert messages.
Public property | ClientInteractionLogLevel | Specifies log level threshold used while logging client interaction messages.
Public property | DeadLetterLogLevel | Specifies log level threshold used while logging dead letter messages.
Public property | InvalidMsgLogLevel | Specifies log level threshold used while logging invalid/corrupt messages.
Public property | LoggingFeedName | Prefix used in logging
Public property | TrafficLogLevel | Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages).
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


ILoggerData Properties

The ILoggerData type exposes the following members.

Properties
 | Name | Description
Public property | AlertLogLevel | Specifies log level threshold used while logging alert messages.
Public property | ClientInteractionLogLevel | Specifies log level threshold used while logging client interaction messages.
Public property | DeadLetterLogLevel | Specifies log level threshold used while logging dead letter messages.
Public property | InvalidMsgLogLevel | Specifies log level threshold used while logging invalid/corrupt messages.
Public property | LoggingFeedName | Prefix used in logging
Public property | TrafficLogLevel | Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages).
Top
See Also

Reference

ILoggerData Interface
Sportradar.SDK.Common.Interfaces Namespace


ILoggerData.AlertLogLevel Property

ILoggerDataAlertLogLevel Property

Specifies log level threshold used while logging alert messages.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
Level AlertLogLevel { get; }

Property Value

Level
See Also

Reference

ILoggerData Interface
Sportradar.SDK.Common.Interfaces Namespace


ILoggerData.ClientInteractionLogLevel Property

ILoggerDataClientInteractionLogLevel Property

Specifies log level threshold used while logging client interaction messages.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
Level ClientInteractionLogLevel { get; }

Property Value

Level
See Also

Reference

ILoggerData Interface
Sportradar.SDK.Common.Interfaces Namespace


ILoggerData.DeadLetterLogLevel Property

ILoggerDataDeadLetterLogLevel Property

Specifies log level threshold used while logging dead letter messages.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
Level DeadLetterLogLevel { get; }

Property Value

Level
See Also

Reference

ILoggerData Interface
Sportradar.SDK.Common.Interfaces Namespace


ILoggerData.InvalidMsgLogLevel Property

ILoggerDataInvalidMsgLogLevel Property

Specifies log level threshold used while logging invalid/corrupt messages.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
Level InvalidMsgLogLevel { get; }

Property Value

Level
See Also

Reference

ILoggerData Interface
Sportradar.SDK.Common.Interfaces Namespace


ILoggerData.LoggingFeedName Property

ILoggerDataLoggingFeedName Property

Prefix used in logging

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
string LoggingFeedName { get; }

Property Value

String
See Also

Reference

ILoggerData Interface
Sportradar.SDK.Common.Interfaces Namespace


ILoggerData.TrafficLogLevel Property

ILoggerDataTrafficLogLevel Property

Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages).

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
Level TrafficLogLevel { get; }

Property Value

Level
See Also

Reference

ILoggerData Interface
Sportradar.SDK.Common.Interfaces Namespace


ILoggerData Methods

The ILoggerData type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable)
Top
See Also

Reference

ILoggerData Interface
Sportradar.SDK.Common.Interfaces Namespace


IMessageDispatcher Interface

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.IMessageDispatcher"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IMessageDispatcher : IStartable

The IMessageDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | HealthStatus |
Top
Methods
 | Name | Description
Public method | EnqueueEntity |
Public method | RegisterFeedDispatchers |
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Top
Events
 | Name | Description
Public event | OnDispatcherHealthStatusChanged |
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IMessageDispatcher Properties

The IMessageDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | HealthStatus |
Top
See Also

Reference

IMessageDispatcher Interface
Sportradar.SDK.Common.Interfaces Namespace


IMessageDispatcher.HealthStatus Property

IMessageDispatcherHealthStatus Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.IMessageDispatcher.HealthStatus"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool HealthStatus { get; }

Property Value

Boolean
See Also

Reference

IMessageDispatcher Interface
Sportradar.SDK.Common.Interfaces Namespace


IMessageDispatcher Methods

The IMessageDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | EnqueueEntity |
Public method | RegisterFeedDispatchers |
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Top
See Also

Reference

IMessageDispatcher Interface
Sportradar.SDK.Common.Interfaces Namespace


IMessageDispatcher.EnqueueEntity Method

IMessageDispatcherEnqueueEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.IMessageDispatcher.EnqueueEntity(Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.EntityBase)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void EnqueueEntity(
    ProtocolProviderType provider,
    EntityBase entity
)

Parameters

provider ProtocolProviderType

[Missing <param name="provider"/> documentation for "M:Sportradar.SDK.Common.Interfaces.IMessageDispatcher.EnqueueEntity(Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.EntityBase)"]

entity EntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.Common.Interfaces.IMessageDispatcher.EnqueueEntity(Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.EntityBase)"]

See Also

Reference

IMessageDispatcher Interface
Sportradar.SDK.Common.Interfaces Namespace


IMessageDispatcher.RegisterFeedDispatchers Method

IMessageDispatcherRegisterFeedDispatchers Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.IMessageDispatcher.RegisterFeedDispatchers(System.Collections.Generic.IList{Sportradar.SDK.Common.Interfaces.IFeedDispatcher})"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void RegisterFeedDispatchers(
    IList<IFeedDispatcher> feed_dispatchers
)

Parameters

feed_dispatchers IList IFeedDispatcher

[Missing <param name="feed_dispatchers"/> documentation for "M:Sportradar.SDK.Common.Interfaces.IMessageDispatcher.RegisterFeedDispatchers(System.Collections.Generic.IList{Sportradar.SDK.Common.Interfaces.IFeedDispatcher})"]

See Also

Reference

IMessageDispatcher Interface
Sportradar.SDK.Common.Interfaces Namespace


IMessageDispatcher Events

The IMessageDispatcher type exposes the following members.

Events
 | Name | Description
Public event | OnDispatcherHealthStatusChanged |
Top
See Also

Reference

IMessageDispatcher Interface
Sportradar.SDK.Common.Interfaces Namespace


IMessageDispatcher.OnDispatcherHealthStatusChanged Event

IMessageDispatcherOnDispatcherHealthStatusChanged Event

[Missing <summary> documentation for "E:Sportradar.SDK.Common.Interfaces.IMessageDispatcher.OnDispatcherHealthStatusChanged"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
event MessageDispatcherDelegatesDispatcherHealthStatusDelegate OnDispatcherHealthStatusChanged

Value

MessageDispatcherDelegatesDispatcherHealthStatusDelegate
See Also

Reference

IMessageDispatcher Interface
Sportradar.SDK.Common.Interfaces Namespace


IMessageIdentifier Interface

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.IMessageIdentifier"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IMessageIdentifier
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IPersistentStateBuffer Interface

Persistent state buffer interface that buffers the underlying client persistent state store.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IPersistentStateBuffer : IStartable

The IPersistentStateBuffer type exposes the following members.

Properties
 | Name | Description
Public property | TestStatus | Returns true if persistent state buffer is in consistent state and if the underlying client state store is functioning properly.
Top
Methods
 | Name | Description
Public method | Clear | Clears persistent state store contents.
Public method | GetAllProviderItems | Returns all persistent state items that belong to specific provider.
Public method | Read | Retrieves value for the given key from the persistent store.
Public method | Remove | Removes an item by key
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Write | Write persistent state item into client provided persistent store (DB, file system).
Top
Events
 | Name | Description
Public event | OnPersistentStateStatusChanged | Fires event whenever persistent state buffer encounters an error condition (e.g. underlying state store error)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IPersistentStateBuffer Properties

The IPersistentStateBuffer type exposes the following members.

Properties
 | Name | Description
Public property | TestStatus | Returns true if persistent state buffer is in consistent state and if the underlying client state store is functioning properly.
Top
See Also

Reference

IPersistentStateBuffer Interface
Sportradar.SDK.Common.Interfaces Namespace


IPersistentStateBuffer.TestStatus Property

IPersistentStateBufferTestStatus Property

Returns true if persistent state buffer is in consistent state and if the underlying client state store is functioning properly.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool TestStatus { get; }

Property Value

Boolean
See Also

Reference

IPersistentStateBuffer Interface
Sportradar.SDK.Common.Interfaces Namespace


IPersistentStateBuffer Methods

The IPersistentStateBuffer type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears persistent state store contents.
Public method | GetAllProviderItems | Returns all persistent state items that belong to specific provider.
Public method | Read | Retrieves value for the given key from the persistent store.
Public method | Remove | Removes an item by key
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Write | Write persistent state item into client provided persistent store (DB, file system).
Top
See Also

Reference

IPersistentStateBuffer Interface
Sportradar.SDK.Common.Interfaces Namespace


IPersistentStateBuffer.Clear Method

IPersistentStateBufferClear Method

Clears persistent state store contents.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Clear()
See Also

Reference

IPersistentStateBuffer Interface
Sportradar.SDK.Common.Interfaces Namespace


IPersistentStateBuffer.GetAllProviderItems Method

IPersistentStateBufferGetAllProviderItems Method

Returns all persistent state items that belong to specific provider.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
IEnumerable<PersistentStateItem> GetAllProviderItems(
    ProtocolProviderType provider_type
)

Parameters

provider_type ProtocolProviderType
Provider type

Return Value

IEnumerable PersistentStateItem
All persistent state items that belong to specific provider.
See Also

Reference

IPersistentStateBuffer Interface
Sportradar.SDK.Common.Interfaces Namespace


IPersistentStateBuffer.Read Method

IPersistentStateBufferRead Method

Retrieves value for the given key from the persistent store.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
PersistentStateItem Read(
    PersistentStateItemKey key
)

Parameters

key PersistentStateItemKey
Key

Return Value

PersistentStateItem
Retrieved item
Remarks
Returns null if key is not found. Used at error recovery and for double-checking whether persistent state store contents are consistent with buffered values.
See Also

Reference

IPersistentStateBuffer Interface
Sportradar.SDK.Common.Interfaces Namespace


IPersistentStateBuffer.Remove Method

IPersistentStateBufferRemove Method

Removes an item by key

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Remove(
    PersistentStateItemKey key
)

Parameters

key PersistentStateItemKey
Key
See Also

Reference

IPersistentStateBuffer Interface
Sportradar.SDK.Common.Interfaces Namespace


IPersistentStateBuffer.Write Method

IPersistentStateBufferWrite Method

Write persistent state item into client provided persistent store (DB, file system).

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Write(
    PersistentStateItem item
)

Parameters

item PersistentStateItem
Persistent state item
Remarks
Overwrites existing values so that stale items can be removed.
See Also

Reference

IPersistentStateBuffer Interface
Sportradar.SDK.Common.Interfaces Namespace


IPersistentStateBuffer Events

The IPersistentStateBuffer type exposes the following members.

Events
 | Name | Description
Public event | OnPersistentStateStatusChanged | Fires event whenever persistent state buffer encounters an error condition (e.g. underlying state store error)
Top
See Also

Reference

IPersistentStateBuffer Interface
Sportradar.SDK.Common.Interfaces Namespace


IPersistentStateBuffer.OnPersistentStateStatusChanged Event

IPersistentStateBufferOnPersistentStateStatusChanged Event

Fires event whenever persistent state buffer encounters an error condition (e.g. underlying state store error)

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
event PersistentStateDelegatesPersistentStateStatusChangedDelegate OnPersistentStateStatusChanged

Value

PersistentStateDelegatesPersistentStateStatusChangedDelegate
See Also

Reference

IPersistentStateBuffer Interface
Sportradar.SDK.Common.Interfaces Namespace


IPoisonQueue Interface

Poison queue interface

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IPoisonQueue

The IPoisonQueue type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType | Poison queue must be assigned a to particular feed provider.
Top
Methods
 | Name | Description
Public method | Enqueue | Enqueue a new poison element. Throws PoisonQueueException if there is already poison elements for the same match enqueued.
Public method | IsMatchPoisonous | Checks whether there is a poison element linked to this match
Public method | WaitForElementRemoved | Waits until an element is removed (promoted or deceased) from the poison queue.
Top
Events
 | Name | Description
Public event | OnPoisonQueueEltDead | Event raised whenever an element is to be dumped into dead letter queue.
Public event | OnPoisonQueueEltPromoted | Event raised whenever an element is promoted from Poison queue and moved back into Main queue.
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IPoisonQueue Properties

The IPoisonQueue type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType | Poison queue must be assigned a to particular feed provider.
Top
See Also

Reference

IPoisonQueue Interface
Sportradar.SDK.Common.Interfaces Namespace


IPoisonQueue.ProviderType Property

IPoisonQueueProviderType Property

Poison queue must be assigned a to particular feed provider.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
See Also

Reference

IPoisonQueue Interface
Sportradar.SDK.Common.Interfaces Namespace


IPoisonQueue Methods

The IPoisonQueue type exposes the following members.

Methods
 | Name | Description
Public method | Enqueue | Enqueue a new poison element. Throws PoisonQueueException if there is already poison elements for the same match enqueued.
Public method | IsMatchPoisonous | Checks whether there is a poison element linked to this match
Public method | WaitForElementRemoved | Waits until an element is removed (promoted or deceased) from the poison queue.
Top
See Also

Reference

IPoisonQueue Interface
Sportradar.SDK.Common.Interfaces Namespace


IPoisonQueue.Enqueue Method

IPoisonQueueEnqueue Method

Enqueue a new poison element. Throws PoisonQueueException if there is already poison elements for the same match enqueued.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Enqueue(
    PoisonQueueElt obj
)

Parameters

obj PoisonQueueElt
Poison element
See Also

Reference

IPoisonQueue Interface
Sportradar.SDK.Common.Interfaces Namespace


IPoisonQueue.IsMatchPoisonous Method

IPoisonQueueIsMatchPoisonous Method

Checks whether there is a poison element linked to this match

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool IsMatchPoisonous(
    IList<long> match_ids
)

Parameters

match_ids IList Int64
Match ids

Return Value

Boolean
Returns true if there is a poison element linked to this match
See Also

Reference

IPoisonQueue Interface
Sportradar.SDK.Common.Interfaces Namespace


IPoisonQueue.WaitForElementRemoved Method

IPoisonQueueWaitForElementRemoved Method

Waits until an element is removed (promoted or deceased) from the poison queue.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool WaitForElementRemoved(
    TimeSpan wait_timeout
)

Parameters

wait_timeout TimeSpan
Wait timeout

Return Value

Boolean
True if the wait was successful or false if the timeout occurred.
See Also

Reference

IPoisonQueue Interface
Sportradar.SDK.Common.Interfaces Namespace


IPoisonQueue Events

The IPoisonQueue type exposes the following members.

Events
 | Name | Description
Public event | OnPoisonQueueEltDead | Event raised whenever an element is to be dumped into dead letter queue.
Public event | OnPoisonQueueEltPromoted | Event raised whenever an element is promoted from Poison queue and moved back into Main queue.
Top
See Also

Reference

IPoisonQueue Interface
Sportradar.SDK.Common.Interfaces Namespace


IPoisonQueue.OnPoisonQueueEltDead Event

IPoisonQueueOnPoisonQueueEltDead Event

Event raised whenever an element is to be dumped into dead letter queue.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
event PoisonQueueDelegatesPoisonQueueEltDead OnPoisonQueueEltDead

Value

PoisonQueueDelegatesPoisonQueueEltDead
See Also

Reference

IPoisonQueue Interface
Sportradar.SDK.Common.Interfaces Namespace


IPoisonQueue.OnPoisonQueueEltPromoted Event

IPoisonQueueOnPoisonQueueEltPromoted Event

Event raised whenever an element is promoted from Poison queue and moved back into Main queue.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
event PoisonQueueDelegatesPoisonQueueEltPromoted OnPoisonQueueEltPromoted

Value

PoisonQueueDelegatesPoisonQueueEltPromoted
See Also

Reference

IPoisonQueue Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolBase Interface

All request and reply messages implement this interface.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IProtocolBase
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IProtocolData Interface

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.IProtocolData"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IProtocolData : ICloneable

The IProtocolData type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Bookmaker ID
Public property | BookmakerKey | Bookmaker key
Public property | EventRequestLimiter | Limits the number of matches that a client can reference in a given time frame (get status, meta info, book, subscribe or error recovery).
Public property | LoginLimiter | Limits the number of logins a client can perform in a given time frame.
Public property | MaxTimeSkew | Max message timestamp skew. Zero to disable the check.
Public property | RequestLimiter | Limits the number of requests a client can send in a given time frame.
Public property | RestartOnParseError | If true, the feed will reconnect on any parse error
Public property | SchemaStrictness | XSD schema validation strictness. Can be OFF, ON, STRICT or VERY STRICT
Public property | ScoutPassword | Scout client password
Public property | ScoutUsername | Scout client username
Public property | SendClientTimeInRequest | Whether client UTC time should be included in every request message (LiveOdds).
Public property | SendClientVersionInLogin | Whether client version should be sent in login.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IProtocolData Properties

The IProtocolData type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Bookmaker ID
Public property | BookmakerKey | Bookmaker key
Public property | EventRequestLimiter | Limits the number of matches that a client can reference in a given time frame (get status, meta info, book, subscribe or error recovery).
Public property | LoginLimiter | Limits the number of logins a client can perform in a given time frame.
Public property | MaxTimeSkew | Max message timestamp skew. Zero to disable the check.
Public property | RequestLimiter | Limits the number of requests a client can send in a given time frame.
Public property | RestartOnParseError | If true, the feed will reconnect on any parse error
Public property | SchemaStrictness | XSD schema validation strictness. Can be OFF, ON, STRICT or VERY STRICT
Public property | ScoutPassword | Scout client password
Public property | ScoutUsername | Scout client username
Public property | SendClientTimeInRequest | Whether client UTC time should be included in every request message (LiveOdds).
Public property | SendClientVersionInLogin | Whether client version should be sent in login.
Top
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData.BookmakerId Property

IProtocolDataBookmakerId Property

Bookmaker ID

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
long BookmakerId { get; }

Property Value

Int64
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData.BookmakerKey Property

IProtocolDataBookmakerKey Property

Bookmaker key

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
SecureString BookmakerKey { get; }

Property Value

SecureString
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData.EventRequestLimiter Property

IProtocolDataEventRequestLimiter Property

Limits the number of matches that a client can reference in a given time frame (get status, meta info, book, subscribe or error recovery).

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
IRateGate EventRequestLimiter { get; }

Property Value

IRateGate
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData.LoginLimiter Property

IProtocolDataLoginLimiter Property

Limits the number of logins a client can perform in a given time frame.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
IRateGate LoginLimiter { get; }

Property Value

IRateGate
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData.MaxTimeSkew Property

IProtocolDataMaxTimeSkew Property

Max message timestamp skew. Zero to disable the check.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
TimeSpan MaxTimeSkew { get; }

Property Value

TimeSpan
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData.RequestLimiter Property

IProtocolDataRequestLimiter Property

Limits the number of requests a client can send in a given time frame.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
IRateGate RequestLimiter { get; }

Property Value

IRateGate
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData.RestartOnParseError Property

IProtocolDataRestartOnParseError Property

If true, the feed will reconnect on any parse error

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool RestartOnParseError { get; }

Property Value

Boolean
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData.SchemaStrictness Property

IProtocolDataSchemaStrictness Property

XSD schema validation strictness. Can be OFF, ON, STRICT or VERY STRICT

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
SchemaValidationStrictness SchemaStrictness { get; }

Property Value

SchemaValidationStrictness
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData.ScoutPassword Property

IProtocolDataScoutPassword Property

Scout client password

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
SecureString ScoutPassword { get; }

Property Value

SecureString
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData.ScoutUsername Property

IProtocolDataScoutUsername Property

Scout client username

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
string ScoutUsername { get; }

Property Value

String
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData.SendClientTimeInRequest Property

IProtocolDataSendClientTimeInRequest Property

Whether client UTC time should be included in every request message (LiveOdds).

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool SendClientTimeInRequest { get; }

Property Value

Boolean
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData.SendClientVersionInLogin Property

IProtocolDataSendClientVersionInLogin Property

Whether client version should be sent in login.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool SendClientVersionInLogin { get; }

Property Value

Boolean
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolData Methods

The IProtocolData type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable)
Top
See Also

Reference

IProtocolData Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolRequest Interface

All request messages implement this interface.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IProtocolRequest : IProtocolBase

The IProtocolRequest type exposes the following members.

Methods
 | Name | Description
Public method | GetMessageType | Get type of the message.
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IProtocolRequest Methods

The IProtocolRequest type exposes the following members.

Methods
 | Name | Description
Public method | GetMessageType | Get type of the message.
Top
See Also

Reference

IProtocolRequest Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolRequest.GetMessageType Method

IProtocolRequestGetMessageType Method

Get type of the message.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
string GetMessageType()

Return Value

String
A human readable message type.
See Also

Reference

IProtocolRequest Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolResponse Interface

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.IProtocolResponse"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IProtocolResponse : IProtocolBase

The IProtocolResponse type exposes the following members.

Methods
 | Name | Description
Public method | GetMessageType |
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IProtocolResponse Methods

The IProtocolResponse type exposes the following members.

Methods
 | Name | Description
Public method | GetMessageType |
Top
See Also

Reference

IProtocolResponse Interface
Sportradar.SDK.Common.Interfaces Namespace


IProtocolResponse.GetMessageType Method

IProtocolResponseGetMessageType Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.IProtocolResponse.GetMessageType"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
string GetMessageType()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.IProtocolResponse.GetMessageType"]

See Also

Reference

IProtocolResponse Interface
Sportradar.SDK.Common.Interfaces Namespace


IRateGate Interface

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.IRateGate"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IRateGate : IDisposable

The IRateGate type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Peek |
Public method | WaitToProceed(Int32) |
Public method | WaitToProceed(TimeSpan, Int32) |
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IRateGate Properties

The IRateGate type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

IRateGate Interface
Sportradar.SDK.Common.Interfaces Namespace


IRateGate.Name Property

IRateGateName Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.IRateGate.Name"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
string Name { get; }

Property Value

String
See Also

Reference

IRateGate Interface
Sportradar.SDK.Common.Interfaces Namespace


IRateGate Methods

The IRateGate type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Peek |
Public method | WaitToProceed(Int32) |
Public method | WaitToProceed(TimeSpan, Int32) |
Top
See Also

Reference

IRateGate Interface
Sportradar.SDK.Common.Interfaces Namespace


IRateGate.Peek Method

IRateGatePeek Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.IRateGate.Peek"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
TimeSpan Peek()

Return Value

TimeSpan

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.IRateGate.Peek"]

See Also

Reference

IRateGate Interface
Sportradar.SDK.Common.Interfaces Namespace


IRateGate.WaitToProceed Method

IRateGateWaitToProceed Method

Overload List
 | Name | Description
Public method | WaitToProceed(Int32) |
Public method | WaitToProceed(TimeSpan, Int32) |
Top
See Also

Reference

IRateGate Interface
Sportradar.SDK.Common.Interfaces Namespace


IRateGate.WaitToProceed(Int32) Method

IRateGateWaitToProceed(Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.IRateGate.WaitToProceed(System.Int32)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void WaitToProceed(
    int count
)

Parameters

count Int32

[Missing <param name="count"/> documentation for "M:Sportradar.SDK.Common.Interfaces.IRateGate.WaitToProceed(System.Int32)"]

See Also

Reference

IRateGate Interface
WaitToProceed Overload
Sportradar.SDK.Common.Interfaces Namespace


IRateGate.WaitToProceed(TimeSpan, Int32) Method

IRateGateWaitToProceed(TimeSpan, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.IRateGate.WaitToProceed(System.TimeSpan,System.Int32)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool WaitToProceed(
    TimeSpan timeout,
    int count
)

Parameters

timeout TimeSpan

[Missing <param name="timeout"/> documentation for "M:Sportradar.SDK.Common.Interfaces.IRateGate.WaitToProceed(System.TimeSpan,System.Int32)"]

count Int32

[Missing <param name="count"/> documentation for "M:Sportradar.SDK.Common.Interfaces.IRateGate.WaitToProceed(System.TimeSpan,System.Int32)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.IRateGate.WaitToProceed(System.TimeSpan,System.Int32)"]

See Also

Reference

IRateGate Interface
WaitToProceed Overload
Sportradar.SDK.Common.Interfaces Namespace


IStartable Interface

Interface specifying that a component is startable, i.e. should first be started before any other call are made and stopped at the end.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IStartable

The IStartable type exposes the following members.

Methods
 | Name | Description
Public method | Start | Start component.
Public method | Stop | Stop / shutdown component.
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


IStartable Methods

The IStartable type exposes the following members.

Methods
 | Name | Description
Public method | Start | Start component.
Public method | Stop | Stop / shutdown component.
Top
See Also

Reference

IStartable Interface
Sportradar.SDK.Common.Interfaces Namespace


IStartable.Start Method

IStartableStart Method

Start component.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Start()
Remarks
The component should be initialized first.
See Also

Reference

IStartable Interface
Sportradar.SDK.Common.Interfaces Namespace


IStartable.Stop Method

IStartableStop Method

Stop / shutdown component.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Stop()
See Also

Reference

IStartable Interface
Sportradar.SDK.Common.Interfaces Namespace


ITimeKeeper Interface

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.ITimeKeeper"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ITimeKeeper

The ITimeKeeper type exposes the following members.

Properties
 | Name | Description
Public property | LastServerTime |
Public property | LastSyncTime |
Public property | ServerTime |
Top
Methods
 | Name | Description
Public method | CheckTime |
Public method | NewTime |
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


ITimeKeeper Properties

The ITimeKeeper type exposes the following members.

Properties
 | Name | Description
Public property | LastServerTime |
Public property | LastSyncTime |
Public property | ServerTime |
Top
See Also

Reference

ITimeKeeper Interface
Sportradar.SDK.Common.Interfaces Namespace


ITimeKeeper.LastServerTime Property

ITimeKeeperLastServerTime Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.ITimeKeeper.LastServerTime"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
DateTime LastServerTime { get; }

Property Value

DateTime
See Also

Reference

ITimeKeeper Interface
Sportradar.SDK.Common.Interfaces Namespace


ITimeKeeper.LastSyncTime Property

ITimeKeeperLastSyncTime Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.ITimeKeeper.LastSyncTime"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
DateTime LastSyncTime { get; }

Property Value

DateTime
See Also

Reference

ITimeKeeper Interface
Sportradar.SDK.Common.Interfaces Namespace


ITimeKeeper.ServerTime Property

ITimeKeeperServerTime Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Interfaces.ITimeKeeper.ServerTime"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
DateTime? ServerTime { get; }

Property Value

Nullable DateTime
See Also

Reference

ITimeKeeper Interface
Sportradar.SDK.Common.Interfaces Namespace


ITimeKeeper Methods

The ITimeKeeper type exposes the following members.

Methods
 | Name | Description
Public method | CheckTime |
Public method | NewTime |
Top
See Also

Reference

ITimeKeeper Interface
Sportradar.SDK.Common.Interfaces Namespace


ITimeKeeper.CheckTime Method

ITimeKeeperCheckTime Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ITimeKeeper.CheckTime(System.DateTime,System.DateTime)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
TimeKeeperResponse CheckTime(
    DateTime server_time,
    DateTime received_time = null
)

Parameters

server_time DateTime

[Missing <param name="server_time"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ITimeKeeper.CheckTime(System.DateTime,System.DateTime)"]

received_time DateTime (Optional)

[Missing <param name="received_time"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ITimeKeeper.CheckTime(System.DateTime,System.DateTime)"]

Return Value

TimeKeeperResponse

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.ITimeKeeper.CheckTime(System.DateTime,System.DateTime)"]

See Also

Reference

ITimeKeeper Interface
Sportradar.SDK.Common.Interfaces Namespace


ITimeKeeper.NewTime Method

ITimeKeeperNewTime Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.ITimeKeeper.NewTime(System.DateTime,System.DateTime)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
TimeKeeperResponse NewTime(
    DateTime server_time,
    DateTime received_time = null
)

Parameters

server_time DateTime

[Missing <param name="server_time"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ITimeKeeper.NewTime(System.DateTime,System.DateTime)"]

received_time DateTime (Optional)

[Missing <param name="received_time"/> documentation for "M:Sportradar.SDK.Common.Interfaces.ITimeKeeper.NewTime(System.DateTime,System.DateTime)"]

Return Value

TimeKeeperResponse

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.ITimeKeeper.NewTime(System.DateTime,System.DateTime)"]

See Also

Reference

ITimeKeeper Interface
Sportradar.SDK.Common.Interfaces Namespace


MessageDispatcherDelegates Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.InterfacesMessageDispatcherDelegates

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class MessageDispatcherDelegates
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


MessageDispatcherDelegates.DispatcherHealthStatusDelegate Class

MessageDispatcherDelegatesDispatcherHealthStatusDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates.DispatcherHealthStatusDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Common.InterfacesMessageDispatcherDelegatesDispatcherHealthStatusDelegate

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class DispatcherHealthStatusDelegate : MulticastDelegate

The MessageDispatcherDelegatesDispatcherHealthStatusDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | MessageDispatcherDelegatesDispatcherHealthStatusDelegate | Initializes a new instance of the MessageDispatcherDelegatesDispatcherHealthStatusDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


MessageDispatcherDelegates.DispatcherHealthStatusDelegate Constructor

MessageDispatcherDelegatesDispatcherHealthStatusDelegate Constructor

Initializes a new instance of the MessageDispatcherDelegatesDispatcherHealthStatusDelegate class

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DispatcherHealthStatusDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates.DispatcherHealthStatusDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates.DispatcherHealthStatusDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

MessageDispatcherDelegatesDispatcherHealthStatusDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


DispatcherHealthStatusDelegate Properties

The MessageDispatcherDelegatesDispatcherHealthStatusDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

MessageDispatcherDelegatesDispatcherHealthStatusDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


DispatcherHealthStatusDelegate Methods

The MessageDispatcherDelegatesDispatcherHealthStatusDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MessageDispatcherDelegatesDispatcherHealthStatusDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


MessageDispatcherDelegates.DispatcherHealthStatusDelegate.BeginInvoke Method

MessageDispatcherDelegatesDispatcherHealthStatusDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates.DispatcherHealthStatusDelegate.BeginInvoke(System.Boolean,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    bool health_status,
    AsyncCallback callback,
    Object object
)

Parameters

health_status Boolean

[Missing <param name="health_status"/> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates.DispatcherHealthStatusDelegate.BeginInvoke(System.Boolean,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates.DispatcherHealthStatusDelegate.BeginInvoke(System.Boolean,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates.DispatcherHealthStatusDelegate.BeginInvoke(System.Boolean,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates.DispatcherHealthStatusDelegate.BeginInvoke(System.Boolean,System.AsyncCallback,System.Object)"]

See Also

Reference

MessageDispatcherDelegatesDispatcherHealthStatusDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


MessageDispatcherDelegates.DispatcherHealthStatusDelegate.EndInvoke Method

MessageDispatcherDelegatesDispatcherHealthStatusDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates.DispatcherHealthStatusDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates.DispatcherHealthStatusDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

MessageDispatcherDelegatesDispatcherHealthStatusDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


MessageDispatcherDelegates.DispatcherHealthStatusDelegate.Invoke Method

MessageDispatcherDelegatesDispatcherHealthStatusDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates.DispatcherHealthStatusDelegate.Invoke(System.Boolean)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    bool health_status
)

Parameters

health_status Boolean

[Missing <param name="health_status"/> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageDispatcherDelegates.DispatcherHealthStatusDelegate.Invoke(System.Boolean)"]

See Also

Reference

MessageDispatcherDelegatesDispatcherHealthStatusDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


MessageIdentifier Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.MessageIdentifier"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.InterfacesMessageIdentifier

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class MessageIdentifier

The MessageIdentifier type exposes the following members.

Methods
Name | Description
CreateIdentifier |
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


MessageIdentifier Methods

The MessageIdentifier type exposes the following members.

Methods
Name | Description
CreateIdentifier |
Top
See Also

Reference

MessageIdentifier Class
Sportradar.SDK.Common.Interfaces Namespace


MessageIdentifier.CreateIdentifier Method

MessageIdentifierCreateIdentifier Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageIdentifier.CreateIdentifier"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static IMessageIdentifier CreateIdentifier()

Return Value

IMessageIdentifier

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.MessageIdentifier.CreateIdentifier"]

See Also

Reference

MessageIdentifier Class
Sportradar.SDK.Common.Interfaces Namespace


PersistentStateDelegates Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.InterfacesPersistentStateDelegates

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class PersistentStateDelegates
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


PersistentStateDelegates.PersistentStateStatusChangedDelegate Class

PersistentStateDelegatesPersistentStateStatusChangedDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates.PersistentStateStatusChangedDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Common.InterfacesPersistentStateDelegatesPersistentStateStatusChangedDelegate

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class PersistentStateStatusChangedDelegate : MulticastDelegate

The PersistentStateDelegatesPersistentStateStatusChangedDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | PersistentStateDelegatesPersistentStateStatusChangedDelegate | Initializes a new instance of the PersistentStateDelegatesPersistentStateStatusChangedDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


PersistentStateDelegates.PersistentStateStatusChangedDelegate Constructor

PersistentStateDelegatesPersistentStateStatusChangedDelegate Constructor

Initializes a new instance of the PersistentStateDelegatesPersistentStateStatusChangedDelegate class

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PersistentStateStatusChangedDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates.PersistentStateStatusChangedDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates.PersistentStateStatusChangedDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

PersistentStateDelegatesPersistentStateStatusChangedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


PersistentStateStatusChangedDelegate Properties

The PersistentStateDelegatesPersistentStateStatusChangedDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

PersistentStateDelegatesPersistentStateStatusChangedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


PersistentStateStatusChangedDelegate Methods

The PersistentStateDelegatesPersistentStateStatusChangedDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PersistentStateDelegatesPersistentStateStatusChangedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


PersistentStateDelegates.PersistentStateStatusChangedDelegate.BeginInvoke Method

PersistentStateDelegatesPersistentStateStatusChangedDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates.PersistentStateStatusChangedDelegate.BeginInvoke(System.Boolean,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    bool test_status,
    AsyncCallback callback,
    Object object
)

Parameters

test_status Boolean

[Missing <param name="test_status"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates.PersistentStateStatusChangedDelegate.BeginInvoke(System.Boolean,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates.PersistentStateStatusChangedDelegate.BeginInvoke(System.Boolean,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates.PersistentStateStatusChangedDelegate.BeginInvoke(System.Boolean,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates.PersistentStateStatusChangedDelegate.BeginInvoke(System.Boolean,System.AsyncCallback,System.Object)"]

See Also

Reference

PersistentStateDelegatesPersistentStateStatusChangedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


PersistentStateDelegates.PersistentStateStatusChangedDelegate.EndInvoke Method

PersistentStateDelegatesPersistentStateStatusChangedDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates.PersistentStateStatusChangedDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates.PersistentStateStatusChangedDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

PersistentStateDelegatesPersistentStateStatusChangedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


PersistentStateDelegates.PersistentStateStatusChangedDelegate.Invoke Method

PersistentStateDelegatesPersistentStateStatusChangedDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates.PersistentStateStatusChangedDelegate.Invoke(System.Boolean)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    bool test_status
)

Parameters

test_status Boolean

[Missing <param name="test_status"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PersistentStateDelegates.PersistentStateStatusChangedDelegate.Invoke(System.Boolean)"]

See Also

Reference

PersistentStateDelegatesPersistentStateStatusChangedDelegate Class
Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueDelegates Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.InterfacesPoisonQueueDelegates

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class PoisonQueueDelegates
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueDelegates.PoisonQueueEltDead Class

PoisonQueueDelegatesPoisonQueueEltDead Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltDead"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Common.InterfacesPoisonQueueDelegatesPoisonQueueEltDead

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class PoisonQueueEltDead : MulticastDelegate

The PoisonQueueDelegatesPoisonQueueEltDead type exposes the following members.

Constructors
 | Name | Description
Public method | PoisonQueueDelegatesPoisonQueueEltDead | Initializes a new instance of the PoisonQueueDelegatesPoisonQueueEltDead class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueDelegates.PoisonQueueEltDead Constructor

PoisonQueueDelegatesPoisonQueueEltDead Constructor

Initializes a new instance of the PoisonQueueDelegatesPoisonQueueEltDead class

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PoisonQueueEltDead(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltDead.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltDead.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

PoisonQueueDelegatesPoisonQueueEltDead Class
Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueEltDead Properties

The PoisonQueueDelegatesPoisonQueueEltDead type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

PoisonQueueDelegatesPoisonQueueEltDead Class
Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueEltDead Methods

The PoisonQueueDelegatesPoisonQueueEltDead type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PoisonQueueDelegatesPoisonQueueEltDead Class
Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueDelegates.PoisonQueueEltDead.BeginInvoke Method

PoisonQueueDelegatesPoisonQueueEltDeadBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltDead.BeginInvoke(Sportradar.SDK.Common.PoisonQueueElt,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    PoisonQueueElt elt,
    AsyncCallback callback,
    Object object
)

Parameters

elt PoisonQueueElt

[Missing <param name="elt"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltDead.BeginInvoke(Sportradar.SDK.Common.PoisonQueueElt,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltDead.BeginInvoke(Sportradar.SDK.Common.PoisonQueueElt,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltDead.BeginInvoke(Sportradar.SDK.Common.PoisonQueueElt,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltDead.BeginInvoke(Sportradar.SDK.Common.PoisonQueueElt,System.AsyncCallback,System.Object)"]

See Also

Reference

PoisonQueueDelegatesPoisonQueueEltDead Class
Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueDelegates.PoisonQueueEltDead.EndInvoke Method

PoisonQueueDelegatesPoisonQueueEltDeadEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltDead.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltDead.EndInvoke(System.IAsyncResult)"]

See Also

Reference

PoisonQueueDelegatesPoisonQueueEltDead Class
Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueDelegates.PoisonQueueEltDead.Invoke Method

PoisonQueueDelegatesPoisonQueueEltDeadInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltDead.Invoke(Sportradar.SDK.Common.PoisonQueueElt)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    PoisonQueueElt elt
)

Parameters

elt PoisonQueueElt

[Missing <param name="elt"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltDead.Invoke(Sportradar.SDK.Common.PoisonQueueElt)"]

See Also

Reference

PoisonQueueDelegatesPoisonQueueEltDead Class
Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueDelegates.PoisonQueueEltPromoted Class

PoisonQueueDelegatesPoisonQueueEltPromoted Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltPromoted"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Common.InterfacesPoisonQueueDelegatesPoisonQueueEltPromoted

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class PoisonQueueEltPromoted : MulticastDelegate

The PoisonQueueDelegatesPoisonQueueEltPromoted type exposes the following members.

Constructors
 | Name | Description
Public method | PoisonQueueDelegatesPoisonQueueEltPromoted | Initializes a new instance of the PoisonQueueDelegatesPoisonQueueEltPromoted class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueDelegates.PoisonQueueEltPromoted Constructor

PoisonQueueDelegatesPoisonQueueEltPromoted Constructor

Initializes a new instance of the PoisonQueueDelegatesPoisonQueueEltPromoted class

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PoisonQueueEltPromoted(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltPromoted.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltPromoted.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

PoisonQueueDelegatesPoisonQueueEltPromoted Class
Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueEltPromoted Properties

The PoisonQueueDelegatesPoisonQueueEltPromoted type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

PoisonQueueDelegatesPoisonQueueEltPromoted Class
Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueEltPromoted Methods

The PoisonQueueDelegatesPoisonQueueEltPromoted type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PoisonQueueDelegatesPoisonQueueEltPromoted Class
Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueDelegates.PoisonQueueEltPromoted.BeginInvoke Method

PoisonQueueDelegatesPoisonQueueEltPromotedBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltPromoted.BeginInvoke(Sportradar.SDK.Common.PoisonQueueElt,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    PoisonQueueElt elt,
    AsyncCallback callback,
    Object object
)

Parameters

elt PoisonQueueElt

[Missing <param name="elt"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltPromoted.BeginInvoke(Sportradar.SDK.Common.PoisonQueueElt,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltPromoted.BeginInvoke(Sportradar.SDK.Common.PoisonQueueElt,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltPromoted.BeginInvoke(Sportradar.SDK.Common.PoisonQueueElt,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltPromoted.BeginInvoke(Sportradar.SDK.Common.PoisonQueueElt,System.AsyncCallback,System.Object)"]

See Also

Reference

PoisonQueueDelegatesPoisonQueueEltPromoted Class
Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueDelegates.PoisonQueueEltPromoted.EndInvoke Method

PoisonQueueDelegatesPoisonQueueEltPromotedEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltPromoted.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltPromoted.EndInvoke(System.IAsyncResult)"]

See Also

Reference

PoisonQueueDelegatesPoisonQueueEltPromoted Class
Sportradar.SDK.Common.Interfaces Namespace


PoisonQueueDelegates.PoisonQueueEltPromoted.Invoke Method

PoisonQueueDelegatesPoisonQueueEltPromotedInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltPromoted.Invoke(Sportradar.SDK.Common.PoisonQueueElt)"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    PoisonQueueElt elt
)

Parameters

elt PoisonQueueElt

[Missing <param name="elt"/> documentation for "M:Sportradar.SDK.Common.Interfaces.PoisonQueueDelegates.PoisonQueueEltPromoted.Invoke(Sportradar.SDK.Common.PoisonQueueElt)"]

See Also

Reference

PoisonQueueDelegatesPoisonQueueEltPromoted Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitAction Class

Queue limit action (whether a limit was reached or retreated)
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.Common.InterfacesQueueLimitAction

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class QueueLimitAction : Enum

The QueueLimitAction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | REACHED | Queue limit was reached
 | RETREATED | Queue limit was retreated
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


QueueLimitAction Methods

The QueueLimitAction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

QueueLimitAction Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitAction Fields

The QueueLimitAction type exposes the following members.

Fields
 | Name | Description
 | REACHED | Queue limit was reached
 | RETREATED | Queue limit was retreated
Public field | value__ |
Top
See Also

Reference

QueueLimitAction Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitAction.REACHED Field

QueueLimitActionREACHED Field

Queue limit was reached

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const QueueLimitAction REACHED = 0

Field Value

QueueLimitAction
See Also

Reference

QueueLimitAction Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitAction.RETREATED Field

QueueLimitActionRETREATED Field

Queue limit was retreated

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const QueueLimitAction RETREATED = 1

Field Value

QueueLimitAction
See Also

Reference

QueueLimitAction Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitAction.value__ Field

QueueLimitActionvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.QueueLimitAction.value__"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

QueueLimitAction Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitEventArgs Class

Event arguments passed with the QueueLimitType
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.Common.InterfacesQueueLimitEventArgs

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class QueueLimitEventArgs : EventArgs

The QueueLimitEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | QueueLimitEventArgs | QueueLimitEventArgs constructor.
Top
Properties
 | Name | Description
Public property | Action | Whether queue limit was reached or retreated
Public property | NewCount | Current queue size
Public property | OldCount | Previous queue size
Public property | QueueName | Queue name
Public property | Type | Type of queue limit reached or retreated
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


QueueLimitEventArgs Constructor

QueueLimitEventArgs constructor.

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public QueueLimitEventArgs(
    string queue_name,
    QueueLimitType type,
    QueueLimitAction action,
    int old_count,
    int new_count
)

Parameters

queue_name String
name of the queue
type QueueLimitType
type of the limit
action QueueLimitAction
action of the limit
old_count Int32
old count
new_count Int32
new (current) count
See Also

Reference

QueueLimitEventArgs Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitEventArgs Properties

The QueueLimitEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Action | Whether queue limit was reached or retreated
Public property | NewCount | Current queue size
Public property | OldCount | Previous queue size
Public property | QueueName | Queue name
Public property | Type | Type of queue limit reached or retreated
Top
See Also

Reference

QueueLimitEventArgs Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitEventArgs.Action Property

QueueLimitEventArgsAction Property

Whether queue limit was reached or retreated

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public QueueLimitAction Action { get; }

Property Value

QueueLimitAction
See Also

Reference

QueueLimitEventArgs Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitEventArgs.NewCount Property

QueueLimitEventArgsNewCount Property

Current queue size

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int NewCount { get; }

Property Value

Int32
See Also

Reference

QueueLimitEventArgs Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitEventArgs.OldCount Property

QueueLimitEventArgsOldCount Property

Previous queue size

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int OldCount { get; }

Property Value

Int32
See Also

Reference

QueueLimitEventArgs Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitEventArgs.QueueName Property

QueueLimitEventArgsQueueName Property

Queue name

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string QueueName { get; }

Property Value

String
See Also

Reference

QueueLimitEventArgs Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitEventArgs.Type Property

QueueLimitEventArgsType Property

Type of queue limit reached or retreated

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public QueueLimitType Type { get; }

Property Value

QueueLimitType
See Also

Reference

QueueLimitEventArgs Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitEventArgs Methods

The QueueLimitEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QueueLimitEventArgs Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitType Class

Type of queue size limit
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.Common.InterfacesQueueLimitType

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class QueueLimitType : Enum

The QueueLimitType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | HIGH | High threshold (almost at the full capacity)
 | LOW | Queue size at low threshold (reason for being worried)
 | NORMAL | Queue size below low threshold (not getting filled up)
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.Common.Interfaces Namespace


QueueLimitType Methods

The QueueLimitType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

QueueLimitType Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitType Fields

The QueueLimitType type exposes the following members.

Fields
 | Name | Description
 | HIGH | High threshold (almost at the full capacity)
 | LOW | Queue size at low threshold (reason for being worried)
 | NORMAL | Queue size below low threshold (not getting filled up)
Public field | value__ |
Top
See Also

Reference

QueueLimitType Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitType.HIGH Field

QueueLimitTypeHIGH Field

High threshold (almost at the full capacity)

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const QueueLimitType HIGH = 2

Field Value

QueueLimitType
See Also

Reference

QueueLimitType Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitType.LOW Field

QueueLimitTypeLOW Field

Queue size at low threshold (reason for being worried)

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const QueueLimitType LOW = 1

Field Value

QueueLimitType
See Also

Reference

QueueLimitType Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitType.NORMAL Field

QueueLimitTypeNORMAL Field

Queue size below low threshold (not getting filled up)

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const QueueLimitType NORMAL = 0

Field Value

QueueLimitType
See Also

Reference

QueueLimitType Class
Sportradar.SDK.Common.Interfaces Namespace


QueueLimitType.value__ Field

QueueLimitTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Interfaces.QueueLimitType.value__"]

Namespace: Sportradar.SDK.Common.Interfaces
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

QueueLimitType Class
Sportradar.SDK.Common.Interfaces Namespace


Sportradar.SDK.Common.Utils Namespace

Classes
Class | Description
Public class | AutoExpireDictionaryK, V
Public class | CloningDictionaryK, V
Public class | CommonUtils
Public class | DiffEngine
Public class | FtpLib
Public class | FtpProtocol
Public class | LevelTypeConverter
Public class | MathExt
Public class StreamWrapper Another workaround for a .NET bug (http://social.msdn.microsoft.com/Forums/en-US/netfxnetcom/thread/f4c3d019-aecd-4fc6-9dea-680f04faa900)

NetworkStream

  • non-blocking Read() returns 0 bytes when there is nothing to read
  • IOException when "the underlying Socket is closed." -> reconnect
  • Write() is thread-safe

SslStream

  • >non-blocking Read() throws IOException -> no need to reconnect
  • after the exception a subsequent non-blocking Read() (when there is nothing to read) returns 5 bytes of SSL keep-alive data (23 3 1 0 17) 23 is TLS application protocol, 3 1 means TLS 1.0, 3 0 would be SSL 3.0
  • Write() is NOT thread-safe

Unify the behavior to NetworkStream behavior.
Public class | StringUtils
Public class | ToStringBuilderT
Public class | XmlUtils
Interfaces
 | Interface | Description
Public interface | IResequencerT | Stateful component that allows to obtain items in correct sequence.
Public interface | IStashT | Stateful component that allows to stash elements until needed. You get duplicate detection and ordering guarantees.


AutoExpireDictionary<K, V> Class

AutoExpireDictionaryK, V Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.UtilsAutoExpireDictionaryK, V

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class AutoExpireDictionary<K, V> : IDictionary<K, V>,
    ICollection<KeyValuePair<K, V>>, IEnumerable<KeyValuePair<K, V>>,
    IEnumerable

Type Parameters

K

[Missing <typeparam name="K"/> documentation for "T:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2"]

V

[Missing <typeparam name="V"/> documentation for "T:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2"]

The AutoExpireDictionaryK, V type exposes the following members.

Constructors
 | Name | Description
Public method | AutoExpireDictionaryK, V | Initializes a new instance of the AutoExpireDictionaryK, V class
Top
Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | Keys |
Public property | Values |
Top
Methods
 | Name | Description
Public method | Add(KeyValuePairK, V) |
Public method | Add(K, V) |
Public method | Clear |
Public method | Contains |
Public method | ContainsKey |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Remove(K) |
Public method | Remove(KeyValuePairK, V) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | TryGetValue |
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V> Constructor

AutoExpireDictionaryK, V Constructor

Initializes a new instance of the AutoExpireDictionaryK, V class

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public AutoExpireDictionary(
    TimeSpan max_age,
    TimeSpan check_interval
)

Parameters

max_age TimeSpan

[Missing <param name="max_age"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.#ctor(System.TimeSpan,System.TimeSpan)"]

check_interval TimeSpan

[Missing <param name="check_interval"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.#ctor(System.TimeSpan,System.TimeSpan)"]

See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V> Properties

AutoExpireDictionaryK, V Properties

The AutoExpireDictionaryK, V type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | Keys |
Public property | Values |
Top
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.Count Property

AutoExpireDictionaryK, VCount Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Count"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Count { get; }

Property Value

Int32

Implements

ICollectionTCount
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.IsReadOnly Property

AutoExpireDictionaryK, VIsReadOnly Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.IsReadOnly"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsReadOnly { get; }

Property Value

Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.Item Property

AutoExpireDictionaryK, VItem Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Item(`0)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public V this[
    K key
] { get; set; }

Parameters

key K

Property Value

V

Implements

IDictionaryTKey, TValueItemTKey
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.Keys Property

AutoExpireDictionaryK, VKeys Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Keys"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ICollection<K> Keys { get; }

Property Value

ICollection K

Implements

IDictionaryTKey, TValueKeys
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.Values Property

AutoExpireDictionaryK, VValues Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Values"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ICollection<V> Values { get; }

Property Value

ICollection V

Implements

IDictionaryTKey, TValueValues
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V> Methods

AutoExpireDictionaryK, V Methods

The AutoExpireDictionaryK, V type exposes the following members.

Methods
 | Name | Description
Public method | Add(KeyValuePairK, V) |
Public method | Add(K, V) |
Public method | Clear |
Public method | Contains |
Public method | ContainsKey |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Remove(K) |
Public method | Remove(KeyValuePairK, V) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | TryGetValue |
Top
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.Add Method

AutoExpireDictionaryK, VAdd Method

Overload List
 | Name | Description
Public method | Add(KeyValuePairK, V) |
Public method | Add(K, V) |
Top
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.Add(KeyValuePair<K, V>) Method

AutoExpireDictionaryK, VAdd(KeyValuePairK, V) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Add(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Add(
    KeyValuePair<K, V> item
)

Parameters

item KeyValuePair K, V

[Missing <param name="item"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Add(System.Collections.Generic.KeyValuePair{`0,`1})"]

Implements

ICollectionTAdd(T)
See Also

Reference

AutoExpireDictionaryK, V Class
Add Overload
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.Add(K, V) Method

AutoExpireDictionaryK, VAdd(K, V) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Add(`0,`1)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Add(
    K key,
    V value
)

Parameters

key K

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Add(`0,`1)"]

value V

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Add(`0,`1)"]

Implements

IDictionaryTKey, TValueAdd(TKey, TValue)
See Also

Reference

AutoExpireDictionaryK, V Class
Add Overload
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.Clear Method

AutoExpireDictionaryK, VClear Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Clear"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Clear()

Implements

ICollectionTClear
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.Contains Method

AutoExpireDictionaryK, VContains Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Contains(
    KeyValuePair<K, V> item
)

Parameters

item KeyValuePair K, V

[Missing <param name="item"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

Implements

ICollectionTContains(T)
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.ContainsKey Method

AutoExpireDictionaryK, VContainsKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.ContainsKey(`0)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool ContainsKey(
    K key
)

Parameters

key K

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.ContainsKey(`0)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.ContainsKey(`0)"]

Implements

IDictionaryTKey, TValueContainsKey(TKey)
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.CopyTo Method

AutoExpireDictionaryK, VCopyTo Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.CopyTo(System.Collections.Generic.KeyValuePair{`0,`1}[],System.Int32)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void CopyTo(
    KeyValuePair<K, V>[] array,
    int arrayIndex
)

Parameters

array KeyValuePair K, V

[Missing <param name="array"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.CopyTo(System.Collections.Generic.KeyValuePair{`0,`1}[],System.Int32)"]

arrayIndex Int32

[Missing <param name="arrayIndex"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.CopyTo(System.Collections.Generic.KeyValuePair{`0,`1}[],System.Int32)"]

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.GetEnumerator Method

AutoExpireDictionaryK, VGetEnumerator Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.GetEnumerator"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IEnumerator<KeyValuePair<K, V>> GetEnumerator()

Return Value

IEnumerator KeyValuePair K, V

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.Remove Method

AutoExpireDictionaryK, VRemove Method

Overload List
 | Name | Description
Public method | Remove(K) |
Public method | Remove(KeyValuePairK, V) |
Top
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.Remove(K) Method

AutoExpireDictionaryK, VRemove(K) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Remove(`0)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Remove(
    K key
)

Parameters

key K

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Remove(`0)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Remove(`0)"]

Implements

IDictionaryTKey, TValueRemove(TKey)
See Also

Reference

AutoExpireDictionaryK, V Class
Remove Overload
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.Remove(KeyValuePair<K, V>) Method

AutoExpireDictionaryK, VRemove(KeyValuePairK, V) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Remove(
    KeyValuePair<K, V> item
)

Parameters

item KeyValuePair K, V

[Missing <param name="item"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Implements

ICollectionTRemove(T)
See Also

Reference

AutoExpireDictionaryK, V Class
Remove Overload
Sportradar.SDK.Common.Utils Namespace


AutoExpireDictionary<K, V>.TryGetValue Method

AutoExpireDictionaryK, VTryGetValue Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.TryGetValue(`0,`1@)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool TryGetValue(
    K key,
    out V value
)

Parameters

key K

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.TryGetValue(`0,`1@)"]

value V

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.TryGetValue(`0,`1@)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.AutoExpireDictionary`2.TryGetValue(`0,`1@)"]

Implements

IDictionaryTKey, TValueTryGetValue(TKey, TValue)
See Also

Reference

AutoExpireDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V> Class

CloningDictionaryK, V Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Utils.CloningDictionary`2"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.UtilsCloningDictionaryK, V

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class CloningDictionary<K, V> : IDictionary<K, V>,
    ICollection<KeyValuePair<K, V>>, IEnumerable<KeyValuePair<K, V>>,
    IEnumerable
where V : ICloneable

Type Parameters

K

[Missing <typeparam name="K"/> documentation for "T:Sportradar.SDK.Common.Utils.CloningDictionary`2"]

V

[Missing <typeparam name="V"/> documentation for "T:Sportradar.SDK.Common.Utils.CloningDictionary`2"]

The CloningDictionaryK, V type exposes the following members.

Constructors
 | Name | Description
Public method | CloningDictionaryK, V | Initializes a new instance of the CloningDictionaryK, V class
Top
Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | Keys |
Public property | Values |
Top
Methods
 | Name | Description
Public method | Add(KeyValuePairK, V) |
Public method | Add(K, V) |
Public method | Clear |
Public method | Contains |
Public method | ContainsKey |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Remove(K) |
Public method | Remove(KeyValuePairK, V) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | TryGetValue |
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V> Constructor

CloningDictionaryK, V Constructor

Initializes a new instance of the CloningDictionaryK, V class

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CloningDictionary(
    IDictionary<K, V> inner
)

Parameters

inner IDictionary K, V

[Missing <param name="inner"/> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.#ctor(System.Collections.Generic.IDictionary{`0,`1})"]

See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V> Properties

CloningDictionaryK, V Properties

The CloningDictionaryK, V type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | Keys |
Public property | Values |
Top
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.Count Property

CloningDictionaryK, VCount Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.CloningDictionary`2.Count"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Count { get; }

Property Value

Int32

Implements

ICollectionTCount
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.IsReadOnly Property

CloningDictionaryK, VIsReadOnly Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.CloningDictionary`2.IsReadOnly"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsReadOnly { get; }

Property Value

Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.Item Property

CloningDictionaryK, VItem Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.CloningDictionary`2.Item(`0)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public V this[
    K key
] { get; set; }

Parameters

key K

Property Value

V

Implements

IDictionaryTKey, TValueItemTKey
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.Keys Property

CloningDictionaryK, VKeys Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.CloningDictionary`2.Keys"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ICollection<K> Keys { get; }

Property Value

ICollection K

Implements

IDictionaryTKey, TValueKeys
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.Values Property

CloningDictionaryK, VValues Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.CloningDictionary`2.Values"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ICollection<V> Values { get; }

Property Value

ICollection V

Implements

IDictionaryTKey, TValueValues
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V> Methods

CloningDictionaryK, V Methods

The CloningDictionaryK, V type exposes the following members.

Methods
 | Name | Description
Public method | Add(KeyValuePairK, V) |
Public method | Add(K, V) |
Public method | Clear |
Public method | Contains |
Public method | ContainsKey |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Remove(K) |
Public method | Remove(KeyValuePairK, V) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | TryGetValue |
Top
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.Add Method

CloningDictionaryK, VAdd Method

Overload List
 | Name | Description
Public method | Add(KeyValuePairK, V) |
Public method | Add(K, V) |
Top
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.Add(KeyValuePair<K, V>) Method

CloningDictionaryK, VAdd(KeyValuePairK, V) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Add(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Add(
    KeyValuePair<K, V> item
)

Parameters

item KeyValuePair K, V

[Missing <param name="item"/> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Add(System.Collections.Generic.KeyValuePair{`0,`1})"]

Implements

ICollectionTAdd(T)
See Also

Reference

CloningDictionaryK, V Class
Add Overload
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.Add(K, V) Method

CloningDictionaryK, VAdd(K, V) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Add(`0,`1)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Add(
    K key,
    V value
)

Parameters

key K

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Add(`0,`1)"]

value V

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Add(`0,`1)"]

Implements

IDictionaryTKey, TValueAdd(TKey, TValue)
See Also

Reference

CloningDictionaryK, V Class
Add Overload
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.Clear Method

CloningDictionaryK, VClear Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Clear"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Clear()

Implements

ICollectionTClear
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.Contains Method

CloningDictionaryK, VContains Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Contains(
    KeyValuePair<K, V> item
)

Parameters

item KeyValuePair K, V

[Missing <param name="item"/> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Contains(System.Collections.Generic.KeyValuePair{`0,`1})"]

Implements

ICollectionTContains(T)
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.ContainsKey Method

CloningDictionaryK, VContainsKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.ContainsKey(`0)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool ContainsKey(
    K key
)

Parameters

key K

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.ContainsKey(`0)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.ContainsKey(`0)"]

Implements

IDictionaryTKey, TValueContainsKey(TKey)
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.CopyTo Method

CloningDictionaryK, VCopyTo Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.CopyTo(System.Collections.Generic.KeyValuePair{`0,`1}[],System.Int32)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void CopyTo(
    KeyValuePair<K, V>[] array,
    int arrayIndex
)

Parameters

array KeyValuePair K, V

[Missing <param name="array"/> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.CopyTo(System.Collections.Generic.KeyValuePair{`0,`1}[],System.Int32)"]

arrayIndex Int32

[Missing <param name="arrayIndex"/> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.CopyTo(System.Collections.Generic.KeyValuePair{`0,`1}[],System.Int32)"]

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.GetEnumerator Method

CloningDictionaryK, VGetEnumerator Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.GetEnumerator"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IEnumerator<KeyValuePair<K, V>> GetEnumerator()

Return Value

IEnumerator KeyValuePair K, V

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.Remove Method

CloningDictionaryK, VRemove Method

Overload List
 | Name | Description
Public method | Remove(K) |
Public method | Remove(KeyValuePairK, V) |
Top
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.Remove(K) Method

CloningDictionaryK, VRemove(K) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Remove(`0)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Remove(
    K key
)

Parameters

key K

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Remove(`0)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Remove(`0)"]

Implements

IDictionaryTKey, TValueRemove(TKey)
See Also

Reference

CloningDictionaryK, V Class
Remove Overload
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.Remove(KeyValuePair<K, V>) Method

CloningDictionaryK, VRemove(KeyValuePairK, V) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Remove(
    KeyValuePair<K, V> item
)

Parameters

item KeyValuePair K, V

[Missing <param name="item"/> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.Remove(System.Collections.Generic.KeyValuePair{`0,`1})"]

Implements

ICollectionTRemove(T)
See Also

Reference

CloningDictionaryK, V Class
Remove Overload
Sportradar.SDK.Common.Utils Namespace


CloningDictionary<K, V>.TryGetValue Method

CloningDictionaryK, VTryGetValue Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.TryGetValue(`0,`1@)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool TryGetValue(
    K key,
    out V value
)

Parameters

key K

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.TryGetValue(`0,`1@)"]

value V

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.TryGetValue(`0,`1@)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CloningDictionary`2.TryGetValue(`0,`1@)"]

Implements

IDictionaryTKey, TValueTryGetValue(TKey, TValue)
See Also

Reference

CloningDictionaryK, V Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Utils.CommonUtils"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.UtilsCommonUtils

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class CommonUtils

The CommonUtils type exposes the following members.

Methods
Name | Description
CheckForAnyAttrT
CheckWritePermForDir
ConvertEnumByNameTout(String)
ConvertEnumByNameTin, Tout(Tin)
ConvertToResourceName
DeserializeT
EnsureDifferentThread | When is_different_thread is true run in the same thread, else start a new one
FromTimespan
FromTimestamp | Convert from UNIX timestamp to local or UTC timestamp.
GetEnumMaxValueTEnum
GetEnumMinValueTEnum
GetEnumValueT(Int32) Converts the provided
C#
Copy
value
to the member of the specified enum
GetEnumValueT(String) Converts the provided
C#
Copy
value
(enum value name) to the member of the specified enum
GetEnumValueT(Int32, T) Converts the provided
C#
Copy
value
to the member of the specified enum, or returns
C#
Copy
defaultValue
GetEnumValueT(String, T) Converts the provided
C#
Copy
value
(enum value name) to the member of the specified enum
GetEnumValueT(Boolean, Int32, T) Converts the provided
C#
Copy
value
to the member of the specified enum, or returns
C#
Copy
defaultValue
if value of
C#
Copy
specified
is false
GetTimeSpan
GetVersion
IntegerToBoolean | IntegerToBoolean
IsEnumMemberTEnum | Determines whether the provided value is member of the specified enumeration
OpenResourceStream
ParseDecimal
ReadResourceStream
RemoveConsecutiveDots
SafeWaitTime
SerializeT
StringToBoolean | StringToBoolean
StringToDateTime | StringToDateTime
ToTimestamp
Top
Fields
Name | Description
g_decimal_fmt |
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


CommonUtils Methods

The CommonUtils type exposes the following members.

Methods
Name | Description
CheckForAnyAttrT
CheckWritePermForDir
ConvertEnumByNameTout(String)
ConvertEnumByNameTin, Tout(Tin)
ConvertToResourceName
DeserializeT
EnsureDifferentThread | When is_different_thread is true run in the same thread, else start a new one
FromTimespan
FromTimestamp | Convert from UNIX timestamp to local or UTC timestamp.
GetEnumMaxValueTEnum
GetEnumMinValueTEnum
GetEnumValueT(Int32) Converts the provided
C#
Copy
value
to the member of the specified enum
GetEnumValueT(String) Converts the provided
C#
Copy
value
(enum value name) to the member of the specified enum
GetEnumValueT(Int32, T) Converts the provided
C#
Copy
value
to the member of the specified enum, or returns
C#
Copy
defaultValue
GetEnumValueT(String, T) Converts the provided
C#
Copy
value
(enum value name) to the member of the specified enum
GetEnumValueT(Boolean, Int32, T) Converts the provided
C#
Copy
value
to the member of the specified enum, or returns
C#
Copy
defaultValue
if value of
C#
Copy
specified
is false
GetTimeSpan
GetVersion
IntegerToBoolean | IntegerToBoolean
IsEnumMemberTEnum | Determines whether the provided value is member of the specified enumeration
OpenResourceStream
ParseDecimal
ReadResourceStream
RemoveConsecutiveDots
SafeWaitTime
SerializeT
StringToBoolean | StringToBoolean
StringToDateTime | StringToDateTime
ToTimestamp
Top
See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.CheckForAnyAttr<T> Method

CommonUtilsCheckForAnyAttrT Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.CheckForAnyAttr``1(``0)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool CheckForAnyAttr<T>(
    T obj
)

Parameters

obj T

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.CheckForAnyAttr``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.CheckForAnyAttr``1(``0)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.CheckForAnyAttr``1(``0)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.CheckWritePermForDir Method

CommonUtilsCheckWritePermForDir Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.CheckWritePermForDir(System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool CheckWritePermForDir(
    string directory
)

Parameters

directory String

[Missing <param name="directory"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.CheckWritePermForDir(System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.CheckWritePermForDir(System.String)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.ConvertEnumByName Method

CommonUtilsConvertEnumByName Method

Overload List
Name | Description
ConvertEnumByNameTout(String) |
ConvertEnumByNameTin, Tout(Tin) |
Top
See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.ConvertEnumByName<Tin, Tout>(Tin) Method

CommonUtilsConvertEnumByNameTin, Tout(Tin) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ConvertEnumByName``2(``0)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static Tout ConvertEnumByName<Tin, Tout>(
    Tin orig
)
where Tin : struct, new(), IConvertible
where Tout : struct, new(), IConvertible

Parameters

orig Tin

[Missing <param name="orig"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ConvertEnumByName``2(``0)"]

Type Parameters

Tin

[Missing <typeparam name="Tin"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ConvertEnumByName``2(``0)"]

Tout

[Missing <typeparam name="Tout"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ConvertEnumByName``2(``0)"]

Return Value

Tout

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ConvertEnumByName``2(``0)"]

See Also

Reference

CommonUtils Class
ConvertEnumByName Overload
Sportradar.SDK.Common.Utils Namespace


CommonUtils.ConvertEnumByName<Tout>(String) Method

CommonUtilsConvertEnumByNameTout(String) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ConvertEnumByName``1(System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static Tout ConvertEnumByName<Tout>(
    string orig
)
where Tout : struct, new(), IConvertible

Parameters

orig String

[Missing <param name="orig"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ConvertEnumByName``1(System.String)"]

Type Parameters

Tout

[Missing <typeparam name="Tout"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ConvertEnumByName``1(System.String)"]

Return Value

Tout

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ConvertEnumByName``1(System.String)"]

See Also

Reference

CommonUtils Class
ConvertEnumByName Overload
Sportradar.SDK.Common.Utils Namespace


CommonUtils.ConvertToResourceName Method

CommonUtilsConvertToResourceName Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ConvertToResourceName(System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static string ConvertToResourceName(
    string name
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ConvertToResourceName(System.String)"]

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ConvertToResourceName(System.String)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.Deserialize<T> Method

CommonUtilsDeserializeT Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.Deserialize``1(System.Byte[])"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static T Deserialize<T>(
    byte[] arr
)

Parameters

arr Byte

[Missing <param name="arr"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.Deserialize``1(System.Byte[])"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.Deserialize``1(System.Byte[])"]

Return Value

T

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.Deserialize``1(System.Byte[])"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.EnsureDifferentThread Method

CommonUtilsEnsureDifferentThread Method

When is_different_thread is true run in the same thread, else start a new one

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static void EnsureDifferentThread(
    bool is_different_thread,
    Action action
)

Parameters

is_different_thread Boolean
boolean condition
action Action
action to be executed
See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.FromTimespan Method

CommonUtilsFromTimespan Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.FromTimespan(System.TimeSpan)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static long FromTimespan(
    TimeSpan ts
)

Parameters

ts TimeSpan

[Missing <param name="ts"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.FromTimespan(System.TimeSpan)"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.FromTimespan(System.TimeSpan)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.FromTimestamp Method

CommonUtilsFromTimestamp Method

Convert from UNIX timestamp to local or UTC timestamp.

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static DateTime FromTimestamp(
    long time,
    DateTimeKind convert_to = 1
)

Parameters

time Int64
UTC time in UNIX format (*1000)
convert_to DateTimeKind (Optional)
Date time kind to convert to

Return Value

DateTime
Date time of the specified kind
See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.GetEnumMaxValue<TEnum> Method

CommonUtilsGetEnumMaxValueTEnum Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetEnumMaxValue``1"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static TEnum GetEnumMaxValue<TEnum>()
where TEnum : IComparable, IConvertible, IFormattable

Type Parameters

TEnum

[Missing <typeparam name="TEnum"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetEnumMaxValue``1"]

Return Value

TEnum

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetEnumMaxValue``1"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.GetEnumMinValue<TEnum> Method

CommonUtilsGetEnumMinValueTEnum Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetEnumMinValue``1"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static TEnum GetEnumMinValue<TEnum>()
where TEnum : IComparable, IConvertible, IFormattable

Type Parameters

TEnum

[Missing <typeparam name="TEnum"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetEnumMinValue``1"]

Return Value

TEnum

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetEnumMinValue``1"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.GetEnumValue Method

CommonUtilsGetEnumValue Method

Overload List
Name Description
GetEnumValueT(Int32) Converts the provided
C#
Copy
value
to the member of the specified enum
GetEnumValueT(String) Converts the provided
C#
Copy
value
(enum value name) to the member of the specified enum
GetEnumValueT(Int32, T) Converts the provided
C#
Copy
value
to the member of the specified enum, or returns
C#
Copy
defaultValue
GetEnumValueT(String, T) Converts the provided
C#
Copy
value
(enum value name) to the member of the specified enum
GetEnumValueT(Boolean, Int32, T) Converts the provided
C#
Copy
value
to the member of the specified enum, or returns
C#
Copy
defaultValue
if value of
C#
Copy
specified
is false
Top
See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.GetEnumValue<T>(Int32) Method

CommonUtilsGetEnumValueT(Int32) Method

Converts the provided
C#
Copy
value
to the member of the specified enum

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static T GetEnumValue<T>(
    int value
)
where T : struct, new(), IConvertible

Parameters

value Int32
The value to be converted

Type Parameters

T
The type of enum to which to convert the
C#
Copy
value

Return Value

T
The member of the specified enum
See Also

Reference

CommonUtils Class
GetEnumValue Overload
Sportradar.SDK.Common.Utils Namespace


CommonUtils.GetEnumValue<T>(String) Method

CommonUtilsGetEnumValueT(String) Method

Converts the provided
C#
Copy
value
(enum value name) to the member of the specified enum

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static T GetEnumValue<T>(
    string value
)
where T : struct, new(), IConvertible

Parameters

value String
The value name to be converted

Type Parameters

T
The type of enum to which to convert the
C#
Copy
value

Return Value

T
The member of the specified enum
See Also

Reference

CommonUtils Class
GetEnumValue Overload
Sportradar.SDK.Common.Utils Namespace


CommonUtils.GetEnumValue<T>(Int32, T) Method

CommonUtilsGetEnumValueT(Int32, T) Method

Converts the provided
C#
Copy
value
to the member of the specified enum, or returns
C#
Copy
defaultValue

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static T GetEnumValue<T>(
    int value,
    T defaultValue
)
where T : struct, new(), IConvertible

Parameters

value Int32
The value in the feed message
defaultValue T
A [!:T] member to be returned if unknown
C#
Copy
value

Type Parameters

T
The type of enum to which to convert the
C#
Copy
value

Return Value

T
The
C#
Copy
value
converted to enum [!:T] member
See Also

Reference

CommonUtils Class
GetEnumValue Overload
Sportradar.SDK.Common.Utils Namespace


CommonUtils.GetEnumValue<T>(String, T) Method

CommonUtilsGetEnumValueT(String, T) Method

Converts the provided
C#
Copy
value
(enum value name) to the member of the specified enum

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static T GetEnumValue<T>(
    string value,
    T defaultValue
)
where T : struct, new(), IConvertible

Parameters

value String
The value name to be converted
defaultValue T
A [!:T] member to be returned if
C#
Copy
value
is not member of enum

Type Parameters

T
The type of enum to which to convert the
C#
Copy
value

Return Value

T
The member of the specified enum
See Also

Reference

CommonUtils Class
GetEnumValue Overload
Sportradar.SDK.Common.Utils Namespace


CommonUtils.GetEnumValue<T>(Boolean, Int32, T) Method

CommonUtilsGetEnumValueT(Boolean, Int32, T) Method

Converts the provided
C#
Copy
value
to the member of the specified enum, or returns
C#
Copy
defaultValue
if value of
C#
Copy
specified
is false

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static T GetEnumValue<T>(
    bool specified,
    int value,
    T defaultValue
)
where T : struct, new(), IConvertible

Parameters

specified Boolean
Value indicating whether the value field was specified in the feed message
value Int32
The value in the feed message
defaultValue T
A [!:T] member to be returned if
C#
Copy
specified
is false

Type Parameters

T
The type of enum to which to convert the
C#
Copy
value

Return Value

T
The
C#
Copy
value
converted to enum [!:T] member
See Also

Reference

CommonUtils Class
GetEnumValue Overload
Sportradar.SDK.Common.Utils Namespace


CommonUtils.GetTimeSpan Method

CommonUtilsGetTimeSpan Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetTimeSpan(System.TimeSpan,System.TimeSpan)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static TimeSpan GetTimeSpan(
    TimeSpan ts,
    TimeSpan default_ts
)

Parameters

ts TimeSpan

[Missing <param name="ts"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetTimeSpan(System.TimeSpan,System.TimeSpan)"]

default_ts TimeSpan

[Missing <param name="default_ts"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetTimeSpan(System.TimeSpan,System.TimeSpan)"]

Return Value

TimeSpan

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetTimeSpan(System.TimeSpan,System.TimeSpan)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.GetVersion Method

CommonUtilsGetVersion Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetVersion(System.Type)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static string GetVersion(
    Type t
)

Parameters

t Type

[Missing <param name="t"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetVersion(System.Type)"]

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.GetVersion(System.Type)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.IntegerToBoolean Method

CommonUtilsIntegerToBoolean Method

IntegerToBoolean

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool IntegerToBoolean(
    int value
)

Parameters

value Int32

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.IntegerToBoolean(System.Int32)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.IntegerToBoolean(System.Int32)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.IsEnumMember<TEnum> Method

CommonUtilsIsEnumMemberTEnum Method

Determines whether the provided value is member of the specified enumeration

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool IsEnumMember<TEnum>(
    Object value
)
where TEnum : struct, new()

Parameters

value Object
The value to check.

Type Parameters

TEnum
The enumeration whose members are to be checked

Return Value

Boolean
True if the provided value is member of the specified enumeration. Otherwise false.
See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.OpenResourceStream Method

CommonUtilsOpenResourceStream Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.OpenResourceStream(System.Reflection.Assembly,System.Type,System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static Stream OpenResourceStream(
    Assembly assembly,
    Type type,
    string name
)

Parameters

assembly Assembly

[Missing <param name="assembly"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.OpenResourceStream(System.Reflection.Assembly,System.Type,System.String)"]

type Type

[Missing <param name="type"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.OpenResourceStream(System.Reflection.Assembly,System.Type,System.String)"]

name String

[Missing <param name="name"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.OpenResourceStream(System.Reflection.Assembly,System.Type,System.String)"]

Return Value

Stream

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.OpenResourceStream(System.Reflection.Assembly,System.Type,System.String)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.ParseDecimal Method

CommonUtilsParseDecimal Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ParseDecimal(System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static decimal ParseDecimal(
    string s
)

Parameters

s String

[Missing <param name="s"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ParseDecimal(System.String)"]

Return Value

Decimal

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ParseDecimal(System.String)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.ReadResourceStream Method

CommonUtilsReadResourceStream Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ReadResourceStream(System.Reflection.Assembly,System.Type,System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static byte[] ReadResourceStream(
    Assembly assembly,
    Type type,
    string name
)

Parameters

assembly Assembly

[Missing <param name="assembly"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ReadResourceStream(System.Reflection.Assembly,System.Type,System.String)"]

type Type

[Missing <param name="type"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ReadResourceStream(System.Reflection.Assembly,System.Type,System.String)"]

name String

[Missing <param name="name"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ReadResourceStream(System.Reflection.Assembly,System.Type,System.String)"]

Return Value

Byte

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ReadResourceStream(System.Reflection.Assembly,System.Type,System.String)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.RemoveConsecutiveDots Method

CommonUtilsRemoveConsecutiveDots Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.RemoveConsecutiveDots(System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static string RemoveConsecutiveDots(
    string name
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.RemoveConsecutiveDots(System.String)"]

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.RemoveConsecutiveDots(System.String)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.SafeWaitTime Method

CommonUtilsSafeWaitTime Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.SafeWaitTime(System.TimeSpan)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static TimeSpan SafeWaitTime(
    TimeSpan ts
)

Parameters

ts TimeSpan

[Missing <param name="ts"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.SafeWaitTime(System.TimeSpan)"]

Return Value

TimeSpan

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.SafeWaitTime(System.TimeSpan)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.Serialize<T> Method

CommonUtilsSerializeT Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.Serialize``1(``0)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static byte[] Serialize<T>(
    T obj
)

Parameters

obj T

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.Serialize``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.Serialize``1(``0)"]

Return Value

Byte

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.Serialize``1(``0)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.StringToBoolean Method

CommonUtilsStringToBoolean Method

StringToBoolean

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool StringToBoolean(
    string value
)

Parameters

value String

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.StringToBoolean(System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.StringToBoolean(System.String)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.StringToDateTime Method

CommonUtilsStringToDateTime Method

StringToDateTime

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static DateTime StringToDateTime(
    string value,
    string zone
)

Parameters

value String

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.StringToDateTime(System.String,System.String)"]

zone String

[Missing <param name="zone"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.StringToDateTime(System.String,System.String)"]

Return Value

DateTime

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.StringToDateTime(System.String,System.String)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.ToTimestamp Method

CommonUtilsToTimestamp Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ToTimestamp(System.DateTime,System.Boolean)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static long ToTimestamp(
    DateTime time,
    bool warn = true
)

Parameters

time DateTime

[Missing <param name="time"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ToTimestamp(System.DateTime,System.Boolean)"]

warn Boolean (Optional)

[Missing <param name="warn"/> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ToTimestamp(System.DateTime,System.Boolean)"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.CommonUtils.ToTimestamp(System.DateTime,System.Boolean)"]

See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils Fields

The CommonUtils type exposes the following members.

Fields
Name | Description
g_decimal_fmt |
Top
See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


CommonUtils.g_decimal_fmt Field

CommonUtilsg_decimal_fmt Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Utils.CommonUtils.g_decimal_fmt"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly NumberFormatInfo g_decimal_fmt

Field Value

NumberFormatInfo
See Also

Reference

CommonUtils Class
Sportradar.SDK.Common.Utils Namespace


DiffEngine Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Utils.DiffEngine"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.UtilsDiffEngine

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class DiffEngine

The DiffEngine type exposes the following members.

Methods
 | Name | Description
Public Extension Method | CloneWithValueReplacement |
Public Extension Method | FixOrdinalAddendums |
 | GetReplacements |
 | GetWords |
Public Extension Method | IgnoreOrdinalAddendums |
 | Replace |
 | ReplaceAll |
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


DiffEngine Methods

The DiffEngine type exposes the following members.

Methods
 | Name | Description
Public Extension Method | CloneWithValueReplacement |
Public Extension Method | FixOrdinalAddendums |
 | GetReplacements |
 | GetWords |
Public Extension Method | IgnoreOrdinalAddendums |
 | Replace |
 | ReplaceAll |
Top
See Also

Reference

DiffEngine Class
Sportradar.SDK.Common.Utils Namespace


DiffEngine.CloneWithValueReplacement Method

DiffEngineCloneWithValueReplacement Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.CloneWithValueReplacement(Sportradar.SDK.Common.LocalizedString,System.String,System.Boolean)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static LocalizedString CloneWithValueReplacement(
    this LocalizedString orig,
    string new_international_value,
    bool fix_ordinal_addendums
)

Parameters

orig LocalizedString

[Missing <param name="orig"/> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.CloneWithValueReplacement(Sportradar.SDK.Common.LocalizedString,System.String,System.Boolean)"]

new_international_value String

[Missing <param name="new_international_value"/> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.CloneWithValueReplacement(Sportradar.SDK.Common.LocalizedString,System.String,System.Boolean)"]

fix_ordinal_addendums Boolean

[Missing <param name="fix_ordinal_addendums"/> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.CloneWithValueReplacement(Sportradar.SDK.Common.LocalizedString,System.String,System.Boolean)"]

Return Value

LocalizedString

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.CloneWithValueReplacement(Sportradar.SDK.Common.LocalizedString,System.String,System.Boolean)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type LocalizedString. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DiffEngine Class
Sportradar.SDK.Common.Utils Namespace


DiffEngine.FixOrdinalAddendums Method

DiffEngineFixOrdinalAddendums Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.FixOrdinalAddendums(System.Collections.Generic.IEnumerable{System.Tuple{System.String,System.String}})"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static IEnumerable<Tuple<string, string, bool>> FixOrdinalAddendums(
    this IEnumerable<Tuple<string, string>> tuples
)

Parameters

tuples IEnumerable Tuple String, String

[Missing <param name="tuples"/> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.FixOrdinalAddendums(System.Collections.Generic.IEnumerable{System.Tuple{System.String,System.String}})"]

Return Value

IEnumerable Tuple String, String, Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.FixOrdinalAddendums(System.Collections.Generic.IEnumerable{System.Tuple{System.String,System.String}})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable Tuple String, String . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DiffEngine Class
Sportradar.SDK.Common.Utils Namespace


DiffEngine.GetReplacements Method

DiffEngineGetReplacements Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.GetReplacements(System.String,System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static IEnumerable<Tuple<string, string>> GetReplacements(
    string variable_str,
    string value_str
)

Parameters

variable_str String

[Missing <param name="variable_str"/> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.GetReplacements(System.String,System.String)"]

value_str String

[Missing <param name="value_str"/> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.GetReplacements(System.String,System.String)"]

Return Value

IEnumerable Tuple String, String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.GetReplacements(System.String,System.String)"]

See Also

Reference

DiffEngine Class
Sportradar.SDK.Common.Utils Namespace


DiffEngine.GetWords Method

DiffEngineGetWords Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.GetWords(System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static IEnumerable<string> GetWords(
    string str
)

Parameters

str String

[Missing <param name="str"/> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.GetWords(System.String)"]

Return Value

IEnumerable String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.GetWords(System.String)"]

See Also

Reference

DiffEngine Class
Sportradar.SDK.Common.Utils Namespace


DiffEngine.IgnoreOrdinalAddendums Method

DiffEngineIgnoreOrdinalAddendums Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.IgnoreOrdinalAddendums(System.Collections.Generic.IEnumerable{System.Tuple{System.String,System.String}})"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static IEnumerable<Tuple<string, string, bool>> IgnoreOrdinalAddendums(
    this IEnumerable<Tuple<string, string>> tuples
)

Parameters

tuples IEnumerable Tuple String, String

[Missing <param name="tuples"/> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.IgnoreOrdinalAddendums(System.Collections.Generic.IEnumerable{System.Tuple{System.String,System.String}})"]

Return Value

IEnumerable Tuple String, String, Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.IgnoreOrdinalAddendums(System.Collections.Generic.IEnumerable{System.Tuple{System.String,System.String}})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable Tuple String, String . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DiffEngine Class
Sportradar.SDK.Common.Utils Namespace


DiffEngine.Replace Method

DiffEngineReplace Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.Replace(System.String,System.Tuple{System.String,System.String,System.Boolean})"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static string Replace(
    string str,
    Tuple<string, string, bool> tuple
)

Parameters

str String

[Missing <param name="str"/> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.Replace(System.String,System.Tuple{System.String,System.String,System.Boolean})"]

tuple Tuple String, String, Boolean

[Missing <param name="tuple"/> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.Replace(System.String,System.Tuple{System.String,System.String,System.Boolean})"]

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.Replace(System.String,System.Tuple{System.String,System.String,System.Boolean})"]

See Also

Reference

DiffEngine Class
Sportradar.SDK.Common.Utils Namespace


DiffEngine.ReplaceAll Method

DiffEngineReplaceAll Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.ReplaceAll(System.String,System.Collections.Generic.IEnumerable{System.Tuple{System.String,System.String,System.Boolean}})"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static string ReplaceAll(
    string str,
    IEnumerable<Tuple<string, string, bool>> tuples
)

Parameters

str String

[Missing <param name="str"/> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.ReplaceAll(System.String,System.Collections.Generic.IEnumerable{System.Tuple{System.String,System.String,System.Boolean}})"]

tuples IEnumerable Tuple String, String, Boolean

[Missing <param name="tuples"/> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.ReplaceAll(System.String,System.Collections.Generic.IEnumerable{System.Tuple{System.String,System.String,System.Boolean}})"]

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.DiffEngine.ReplaceAll(System.String,System.Collections.Generic.IEnumerable{System.Tuple{System.String,System.String,System.Boolean}})"]

See Also

Reference

DiffEngine Class
Sportradar.SDK.Common.Utils Namespace


FtpLib Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Utils.FtpLib"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.UtilsFtpLib

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class FtpLib

The FtpLib type exposes the following members.

Methods
Name | Description
DownloadFile |
UploadFile |
Top
Fields
Name | Description
BUFFER_SIZE |
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


FtpLib Methods

The FtpLib type exposes the following members.

Methods
Name | Description
DownloadFile |
UploadFile |
Top
See Also

Reference

FtpLib Class
Sportradar.SDK.Common.Utils Namespace


FtpLib.DownloadFile Method

FtpLibDownloadFile Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.DownloadFile(System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool DownloadFile(
    string hostname,
    string username,
    string password,
    string remote_path_name,
    string local_path_name,
    bool binary
)

Parameters

hostname String

[Missing <param name="hostname"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.DownloadFile(System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

username String

[Missing <param name="username"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.DownloadFile(System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

password String

[Missing <param name="password"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.DownloadFile(System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

remote_path_name String

[Missing <param name="remote_path_name"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.DownloadFile(System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

local_path_name String

[Missing <param name="local_path_name"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.DownloadFile(System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

binary Boolean

[Missing <param name="binary"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.DownloadFile(System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.DownloadFile(System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

See Also

Reference

FtpLib Class
Sportradar.SDK.Common.Utils Namespace


FtpLib.UploadFile Method

FtpLibUploadFile Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.UploadFile(Sportradar.SDK.Common.Utils.FtpProtocol,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool UploadFile(
    FtpProtocol protocol,
    string hostname,
    string username,
    string password,
    string local_path_name,
    string remote_path_name,
    bool binary = false
)

Parameters

protocol FtpProtocol

[Missing <param name="protocol"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.UploadFile(Sportradar.SDK.Common.Utils.FtpProtocol,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

hostname String

[Missing <param name="hostname"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.UploadFile(Sportradar.SDK.Common.Utils.FtpProtocol,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

username String

[Missing <param name="username"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.UploadFile(Sportradar.SDK.Common.Utils.FtpProtocol,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

password String

[Missing <param name="password"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.UploadFile(Sportradar.SDK.Common.Utils.FtpProtocol,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

local_path_name String

[Missing <param name="local_path_name"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.UploadFile(Sportradar.SDK.Common.Utils.FtpProtocol,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

remote_path_name String

[Missing <param name="remote_path_name"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.UploadFile(Sportradar.SDK.Common.Utils.FtpProtocol,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

binary Boolean (Optional)

[Missing <param name="binary"/> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.UploadFile(Sportradar.SDK.Common.Utils.FtpProtocol,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.FtpLib.UploadFile(Sportradar.SDK.Common.Utils.FtpProtocol,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

See Also

Reference

FtpLib Class
Sportradar.SDK.Common.Utils Namespace


FtpLib Fields

The FtpLib type exposes the following members.

Fields
Name | Description
BUFFER_SIZE |
Top
See Also

Reference

FtpLib Class
Sportradar.SDK.Common.Utils Namespace


FtpLib.BUFFER_SIZE Field

FtpLibBUFFER_SIZE Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Utils.FtpLib.BUFFER_SIZE"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const int BUFFER_SIZE = 16384

Field Value

Int32
See Also

Reference

FtpLib Class
Sportradar.SDK.Common.Utils Namespace


FtpProtocol Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Utils.FtpProtocol"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.Common.UtilsFtpProtocol

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class FtpProtocol : Enum

The FtpProtocol type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | PLAIN |
 | SSL |
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


FtpProtocol Methods

The FtpProtocol type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

FtpProtocol Class
Sportradar.SDK.Common.Utils Namespace


FtpProtocol Fields

The FtpProtocol type exposes the following members.

Fields
 | Name | Description
 | PLAIN |
 | SSL |
Public field | value__ |
Top
See Also

Reference

FtpProtocol Class
Sportradar.SDK.Common.Utils Namespace


FtpProtocol.PLAIN Field

FtpProtocolPLAIN Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Utils.FtpProtocol.PLAIN"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FtpProtocol PLAIN = 0

Field Value

FtpProtocol
See Also

Reference

FtpProtocol Class
Sportradar.SDK.Common.Utils Namespace


FtpProtocol.SSL Field

FtpProtocolSSL Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Utils.FtpProtocol.SSL"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FtpProtocol SSL = 1

Field Value

FtpProtocol
See Also

Reference

FtpProtocol Class
Sportradar.SDK.Common.Utils Namespace


FtpProtocol.value__ Field

FtpProtocolvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.Common.Utils.FtpProtocol.value__"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

FtpProtocol Class
Sportradar.SDK.Common.Utils Namespace


IResequencer<T> Interface

IResequencerT Interface

Stateful component that allows to obtain items in correct sequence.

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IResequencer<T> : IStash<T>

Type Parameters

T
Type of the elements

The IResequencerT type exposes the following members.

Properties
 | Name | Description
Public property | LastSeqNum | Latest sequence number
Public property | MaxSeqWaiting | The waiting element with maximum sequence number. (Inherited from IStashT)
Public property | MinSeqWaiting | The waiting element with minimum sequence number. (Inherited from IStashT)
Top
Methods
 | Name | Description
Public method | Add | Add a new element.
Public method | AddStash | Add an item to stash. (When using the resequencer as kind of a stash for elements). (Inherited from IStashT)
Public method | Clear | Clear complete state and possibly also reset first desired state. Possible fresh star for sequence numbers
Public method | ClearWaiting | Clear waiting (out-of-sequence) elements. (Inherited from IStashT)
Public method | GetWaiting | Get the out-of-sequence elements that are still waiting. (Inherited from IStashT)
Top
Events
 | Name | Description
Public event | OnDuplicate | How to resolve a duplicate. (seq_number, old, fresh) => replacement element (Inherited from IStashT)
Public event | OnSeqData | Event fired when another in-sequence element was found.
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


IResequencer<T> Properties

IResequencerT Properties

The IResequencerT type exposes the following members.

Properties
 | Name | Description
Public property | LastSeqNum | Latest sequence number
Public property | MaxSeqWaiting | The waiting element with maximum sequence number. (Inherited from IStashT)
Public property | MinSeqWaiting | The waiting element with minimum sequence number. (Inherited from IStashT)
Top
See Also

Reference

IResequencerT Interface
Sportradar.SDK.Common.Utils Namespace


IResequencer<T>.LastSeqNum Property

IResequencerTLastSeqNum Property

Latest sequence number

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
long? LastSeqNum { get; }

Property Value

Nullable Int64
See Also

Reference

IResequencerT Interface
Sportradar.SDK.Common.Utils Namespace


IResequencer<T> Methods

IResequencerT Methods

The IResequencerT type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add a new element.
Public method | AddStash | Add an item to stash. (When using the resequencer as kind of a stash for elements). (Inherited from IStashT)
Public method | Clear | Clear complete state and possibly also reset first desired state. Possible fresh star for sequence numbers
Public method | ClearWaiting | Clear waiting (out-of-sequence) elements. (Inherited from IStashT)
Public method | GetWaiting | Get the out-of-sequence elements that are still waiting. (Inherited from IStashT)
Top
See Also

Reference

IResequencerT Interface
Sportradar.SDK.Common.Utils Namespace


IResequencer<T>.Add Method

IResequencerTAdd Method

Add a new element.

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool Add(
    T item
)

Parameters

item T
a new element

Return Value

Boolean
true when item is in-sequence; false else (duplicate, out-of-sequence, etc.)
See Also

Reference

IResequencerT Interface
Sportradar.SDK.Common.Utils Namespace


IResequencer<T>.Clear Method

IResequencerTClear Method

Clear complete state and possibly also reset first desired state. Possible fresh star for sequence numbers

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Clear(
    long? fresh_seq_start = null
)

Parameters

fresh_seq_start Nullable Int64 (Optional)

[Missing <param name="fresh_seq_start"/> documentation for "M:Sportradar.SDK.Common.Utils.IResequencer`1.Clear(System.Nullable{System.Int64})"]

See Also

Reference

IResequencerT Interface
Sportradar.SDK.Common.Utils Namespace


IResequencer<T> Events

IResequencerT Events

The IResequencerT type exposes the following members.

Events
 | Name | Description
Public event | OnDuplicate | How to resolve a duplicate. (seq_number, old, fresh) => replacement element (Inherited from IStashT)
Public event | OnSeqData | Event fired when another in-sequence element was found.
Top
See Also

Reference

IResequencerT Interface
Sportradar.SDK.Common.Utils Namespace


IResequencer<T>.OnSeqData Event

IResequencerTOnSeqData Event

Event fired when another in-sequence element was found.

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
event Action<T, bool> OnSeqData

Value

Action T, Boolean
See Also

Reference

IResequencerT Interface
Sportradar.SDK.Common.Utils Namespace


IStash<T> Interface

IStashT Interface

Stateful component that allows to stash elements until needed. You get duplicate detection and ordering guarantees.

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IStash<T>

Type Parameters

T
Type of the elements

The IStashT type exposes the following members.

Properties
 | Name | Description
Public property | MaxSeqWaiting | The waiting element with maximum sequence number.
Public property | MinSeqWaiting | The waiting element with minimum sequence number.
Top
Methods
 | Name | Description
Public method | AddStash | Add an item to stash. (When using the resequencer as kind of a stash for elements).
Public method | ClearWaiting | Clear waiting (out-of-sequence) elements.
Public method | GetWaiting | Get the out-of-sequence elements that are still waiting.
Top
Events
 | Name | Description
Public event | OnDuplicate | How to resolve a duplicate. (seq_number, old, fresh) => replacement element
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


IStash<T> Properties

IStashT Properties

The IStashT type exposes the following members.

Properties
 | Name | Description
Public property | MaxSeqWaiting | The waiting element with maximum sequence number.
Public property | MinSeqWaiting | The waiting element with minimum sequence number.
Top
See Also

Reference

IStashT Interface
Sportradar.SDK.Common.Utils Namespace


IStash<T>.MaxSeqWaiting Property

IStashTMaxSeqWaiting Property

The waiting element with maximum sequence number.

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
T MaxSeqWaiting { get; }

Property Value

T
See Also

Reference

IStashT Interface
Sportradar.SDK.Common.Utils Namespace


IStash<T>.MinSeqWaiting Property

IStashTMinSeqWaiting Property

The waiting element with minimum sequence number.

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
T MinSeqWaiting { get; }

Property Value

T
See Also

Reference

IStashT Interface
Sportradar.SDK.Common.Utils Namespace


IStash<T> Methods

IStashT Methods

The IStashT type exposes the following members.

Methods
 | Name | Description
Public method | AddStash | Add an item to stash. (When using the resequencer as kind of a stash for elements).
Public method | ClearWaiting | Clear waiting (out-of-sequence) elements.
Public method | GetWaiting | Get the out-of-sequence elements that are still waiting.
Top
See Also

Reference

IStashT Interface
Sportradar.SDK.Common.Utils Namespace


IStash<T>.AddStash Method

IStashTAddStash Method

Add an item to stash. (When using the resequencer as kind of a stash for elements).

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void AddStash(
    T item
)

Parameters

item T
a new element
See Also

Reference

IStashT Interface
Sportradar.SDK.Common.Utils Namespace


IStash<T>.ClearWaiting Method

IStashTClearWaiting Method

Clear waiting (out-of-sequence) elements.

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
void ClearWaiting()
See Also

Reference

IStashT Interface
Sportradar.SDK.Common.Utils Namespace


IStash<T>.GetWaiting Method

IStashTGetWaiting Method

Get the out-of-sequence elements that are still waiting.

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
ReadOnlyCollection<T> GetWaiting()

Return Value

ReadOnlyCollection T
the waiting elements
See Also

Reference

IStashT Interface
Sportradar.SDK.Common.Utils Namespace


IStash<T> Events

IStashT Events

The IStashT type exposes the following members.

Events
 | Name | Description
Public event | OnDuplicate | How to resolve a duplicate. (seq_number, old, fresh) => replacement element
Top
See Also

Reference

IStashT Interface
Sportradar.SDK.Common.Utils Namespace


IStash<T>.OnDuplicate Event

IStashTOnDuplicate Event

How to resolve a duplicate. (seq_number, old, fresh) => replacement element

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
event Func<long, T, T, T> OnDuplicate

Value

Func Int64, T, T, T
See Also

Reference

IStashT Interface
Sportradar.SDK.Common.Utils Namespace


LevelTypeConverter Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Utils.LevelTypeConverter"]

Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
Sportradar.SDK.Common.UtilsLevelTypeConverter

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LevelTypeConverter : TypeConverter

The LevelTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | LevelTypeConverter | Initializes a new instance of the LevelTypeConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) |
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter)
Public method | CanConvertTo(ITypeDescriptorContext, Type) |
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) |
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


LevelTypeConverter Constructor

Initializes a new instance of the LevelTypeConverter class

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LevelTypeConverter()
See Also

Reference

LevelTypeConverter Class
Sportradar.SDK.Common.Utils Namespace


LevelTypeConverter Methods

The LevelTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) |
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter)
Public method | CanConvertTo(ITypeDescriptorContext, Type) |
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) |
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LevelTypeConverter Class
Sportradar.SDK.Common.Utils Namespace


LevelTypeConverter.CanConvertFrom Method

LevelTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter.
Public method | CanConvertFrom(ITypeDescriptorContext, Type) |
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.
Top
See Also

Reference

LevelTypeConverter Class
Sportradar.SDK.Common.Utils Namespace


LevelTypeConverter.CanConvertFrom(ITypeDescriptorContext, Type) Method

LevelTypeConverterCanConvertFrom(ITypeDescriptorContext, Type) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)

Parameters

context ITypeDescriptorContext

[Missing <param name="context"/> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

sourceType Type

[Missing <param name="sourceType"/> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

See Also

Reference

LevelTypeConverter Class
CanConvertFrom Overload
Sportradar.SDK.Common.Utils Namespace


LevelTypeConverter.CanConvertTo Method

LevelTypeConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type.
Public method | CanConvertTo(ITypeDescriptorContext, Type) |
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context.
Top
See Also

Reference

LevelTypeConverter Class
Sportradar.SDK.Common.Utils Namespace


LevelTypeConverter.CanConvertTo(ITypeDescriptorContext, Type) Method

LevelTypeConverterCanConvertTo(ITypeDescriptorContext, Type) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)

Parameters

context ITypeDescriptorContext

[Missing <param name="context"/> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

destinationType Type

[Missing <param name="destinationType"/> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

See Also

Reference

LevelTypeConverter Class
CanConvertTo Overload
Sportradar.SDK.Common.Utils Namespace


LevelTypeConverter.ConvertFrom Method

LevelTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter.
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) |
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information.
Top
See Also

Reference

LevelTypeConverter Class
Sportradar.SDK.Common.Utils Namespace


LevelTypeConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) Method

LevelTypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)

Parameters

context ITypeDescriptorContext

[Missing <param name="context"/> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

culture CultureInfo

[Missing <param name="culture"/> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

value Object

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

Return Value

Object

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.LevelTypeConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

See Also

Reference

LevelTypeConverter Class
ConvertFrom Overload
Sportradar.SDK.Common.Utils Namespace


MathExt Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Utils.MathExt"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.UtilsMathExt

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class MathExt

The MathExt type exposes the following members.

Methods
Name | Description
Lengthen(Decimal) | The opposite of Math.Truncate.
Lengthen(Double) | The opposite of Math.Truncate.
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


MathExt Methods

The MathExt type exposes the following members.

Methods
Name | Description
Lengthen(Decimal) | The opposite of Math.Truncate.
Lengthen(Double) | The opposite of Math.Truncate.
Top
See Also

Reference

MathExt Class
Sportradar.SDK.Common.Utils Namespace


MathExt.Lengthen Method

MathExtLengthen Method

Overload List
Name | Description
Lengthen(Decimal) | The opposite of Math.Truncate.
Lengthen(Double) | The opposite of Math.Truncate.
Top
See Also

Reference

MathExt Class
Sportradar.SDK.Common.Utils Namespace


MathExt.Lengthen(Decimal) Method

MathExtLengthen(Decimal) Method

The opposite of Math.Truncate.

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static decimal Lengthen(
    decimal num
)

Parameters

num Decimal
Number

Return Value

Decimal
Truncate will round towards zero, this method rounds towards - or + infinity. This is like Math.Ceil for positive numbers, and like Math.Floor for negative numbers.
See Also

Reference

MathExt Class
Lengthen Overload
Sportradar.SDK.Common.Utils Namespace


MathExt.Lengthen(Double) Method

MathExtLengthen(Double) Method

The opposite of Math.Truncate.

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static double Lengthen(
    double num
)

Parameters

num Double
Number

Return Value

Double
Truncate will round towards zero, this method rounds towards - or + infinity. This is like Math.Ceil for positive numbers, and like Math.Floor for negative numbers.
See Also

Reference

MathExt Class
Lengthen Overload
Sportradar.SDK.Common.Utils Namespace


StreamWrapper Class

Another workaround for a .NET bug (http://social.msdn.microsoft.com/Forums/en-US/netfxnetcom/thread/f4c3d019-aecd-4fc6-9dea-680f04faa900)

NetworkStream

  • non-blocking Read() returns 0 bytes when there is nothing to read
  • IOException when "the underlying Socket is closed." -> reconnect
  • Write() is thread-safe

SslStream

  • >non-blocking Read() throws IOException -> no need to reconnect
  • after the exception a subsequent non-blocking Read() (when there is nothing to read) returns 5 bytes of SSL keep-alive data (23 3 1 0 17) 23 is TLS application protocol, 3 1 means TLS 1.0, 3 0 would be SSL 3.0
  • Write() is NOT thread-safe

Unify the behavior to NetworkStream behavior.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.UtilsStreamWrapper

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class StreamWrapper

The StreamWrapper type exposes the following members.

Constructors
 | Name | Description
Public method | StreamWrapper | Initializes a new instance of the StreamWrapper class
Top
Properties
 | Name | Description
Public property | ReadTimeout |
Public property | Stream |
Public property | TcpClient |
Public property | WriteTimeout |
Top
Methods
 | Name | Description
Public method | Close |
Public method | Equals | (Overrides ObjectEquals(Object))
Public method | Flush |
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Read |
Public method | ToString | (Overrides ObjectToString)
Public method | Write |
Top
Remarks
This implementation of stream wrapper is not thread safe.
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


StreamWrapper Constructor

Initializes a new instance of the StreamWrapper class

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public StreamWrapper()
See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper Properties

The StreamWrapper type exposes the following members.

Properties
 | Name | Description
Public property | ReadTimeout |
Public property | Stream |
Public property | TcpClient |
Public property | WriteTimeout |
Top
See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper.ReadTimeout Property

StreamWrapperReadTimeout Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.StreamWrapper.ReadTimeout"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int ReadTimeout { get; set; }

Property Value

Int32
See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper.Stream Property

StreamWrapperStream Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.StreamWrapper.Stream"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Stream Stream { set; }

Property Value

Stream
See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper.TcpClient Property

StreamWrapperTcpClient Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.StreamWrapper.TcpClient"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TcpClient TcpClient { get; set; }

Property Value

TcpClient
See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper.WriteTimeout Property

StreamWrapperWriteTimeout Property

[Missing <summary> documentation for "P:Sportradar.SDK.Common.Utils.StreamWrapper.WriteTimeout"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int WriteTimeout { get; set; }

Property Value

Int32
See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper Methods

The StreamWrapper type exposes the following members.

Methods
 | Name | Description
Public method | Close |
Public method | Equals | (Overrides ObjectEquals(Object))
Public method | Flush |
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Read |
Public method | ToString | (Overrides ObjectToString)
Public method | Write |
Top
See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper.Close Method

StreamWrapperClose Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Close"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Close()
See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper.Equals Method

StreamWrapperEquals Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Equals(System.Object)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Equals(System.Object)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Equals(System.Object)"]

See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper.Flush Method

StreamWrapperFlush Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Flush"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Flush()
See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper.GetHashCode Method

StreamWrapperGetHashCode Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.GetHashCode"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.GetHashCode"]

See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper.Read Method

StreamWrapperRead Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Read(System.Byte[],System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Read(
    byte[] buffer,
    int offset,
    int count
)

Parameters

buffer Byte

[Missing <param name="buffer"/> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Read(System.Byte[],System.Int32,System.Int32)"]

offset Int32

[Missing <param name="offset"/> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Read(System.Byte[],System.Int32,System.Int32)"]

count Int32

[Missing <param name="count"/> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Read(System.Byte[],System.Int32,System.Int32)"]

Return Value

Int32

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Read(System.Byte[],System.Int32,System.Int32)"]

See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper.ToString Method

StreamWrapperToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.ToString"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.ToString"]

See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StreamWrapper.Write Method

StreamWrapperWrite Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Write(System.Byte[],System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Write(
    byte[] buffer,
    int offset,
    int count
)

Parameters

buffer Byte

[Missing <param name="buffer"/> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Write(System.Byte[],System.Int32,System.Int32)"]

offset Int32

[Missing <param name="offset"/> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Write(System.Byte[],System.Int32,System.Int32)"]

count Int32

[Missing <param name="count"/> documentation for "M:Sportradar.SDK.Common.Utils.StreamWrapper.Write(System.Byte[],System.Int32,System.Int32)"]

See Also

Reference

StreamWrapper Class
Sportradar.SDK.Common.Utils Namespace


StringUtils Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Utils.StringUtils"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.UtilsStringUtils

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class StringUtils

The StringUtils type exposes the following members.

Methods
Name | Description
ClearString |
ClearStringByRef |
SecureStringToString |
StringToSecureString |
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


StringUtils Methods

The StringUtils type exposes the following members.

Methods
Name | Description
ClearString |
ClearStringByRef |
SecureStringToString |
StringToSecureString |
Top
See Also

Reference

StringUtils Class
Sportradar.SDK.Common.Utils Namespace


StringUtils.ClearString Method

StringUtilsClearString Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.StringUtils.ClearString(System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool ClearString(
    string str
)

Parameters

str String

[Missing <param name="str"/> documentation for "M:Sportradar.SDK.Common.Utils.StringUtils.ClearString(System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.StringUtils.ClearString(System.String)"]

See Also

Reference

StringUtils Class
Sportradar.SDK.Common.Utils Namespace


StringUtils.ClearStringByRef Method

StringUtilsClearStringByRef Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.StringUtils.ClearStringByRef(System.String@)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool ClearStringByRef(
    ref string s
)

Parameters

s String

[Missing <param name="s"/> documentation for "M:Sportradar.SDK.Common.Utils.StringUtils.ClearStringByRef(System.String@)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.StringUtils.ClearStringByRef(System.String@)"]

See Also

Reference

StringUtils Class
Sportradar.SDK.Common.Utils Namespace


StringUtils.SecureStringToString Method

StringUtilsSecureStringToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.StringUtils.SecureStringToString(System.Security.SecureString)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static string SecureStringToString(
    SecureString input
)

Parameters

input SecureString

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.Common.Utils.StringUtils.SecureStringToString(System.Security.SecureString)"]

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.StringUtils.SecureStringToString(System.Security.SecureString)"]

See Also

Reference

StringUtils Class
Sportradar.SDK.Common.Utils Namespace


StringUtils.StringToSecureString Method

StringUtilsStringToSecureString Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.StringUtils.StringToSecureString(System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static SecureString StringToSecureString(
    string input
)

Parameters

input String

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.Common.Utils.StringUtils.StringToSecureString(System.String)"]

Return Value

SecureString

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.StringUtils.StringToSecureString(System.String)"]

See Also

Reference

StringUtils Class
Sportradar.SDK.Common.Utils Namespace


ToStringBuilder<T> Class

ToStringBuilderT Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Utils.ToStringBuilder`1"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.UtilsToStringBuilderT

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class ToStringBuilder<T>

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Sportradar.SDK.Common.Utils.ToStringBuilder`1"]

The ToStringBuilderT type exposes the following members.

Constructors
 | Name | Description
Public method | ToStringBuilderT | Initializes a new instance of the ToStringBuilderT class
Top
Methods
 | Name | Description
Public method | Append(String) |
Public method | AppendTProperty(Object, ExpressionFuncT, TProperty) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ListPropertyT |
Public method | ToString | (Overrides ObjectToString)
Public method | ToStringWithoutTypeName |
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


ToStringBuilder<T> Constructor

ToStringBuilderT Constructor

Initializes a new instance of the ToStringBuilderT class

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ToStringBuilder(
    T target
)

Parameters

target T

[Missing <param name="target"/> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.#ctor(`0)"]

See Also

Reference

ToStringBuilderT Class
Sportradar.SDK.Common.Utils Namespace


ToStringBuilder<T> Methods

ToStringBuilderT Methods

The ToStringBuilderT type exposes the following members.

Methods
 | Name | Description
Public method | Append(String) |
Public method | AppendTProperty(Object, ExpressionFuncT, TProperty) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ListPropertyT |
Public method | ToString | (Overrides ObjectToString)
Public method | ToStringWithoutTypeName |
Top
See Also

Reference

ToStringBuilderT Class
Sportradar.SDK.Common.Utils Namespace


ToStringBuilder<T>.Append Method

ToStringBuilderTAppend Method

Overload List
 | Name | Description
Public method | Append(String) |
Public method | AppendTProperty(Object, ExpressionFuncT, TProperty) |
Top
See Also

Reference

ToStringBuilderT Class
Sportradar.SDK.Common.Utils Namespace


ToStringBuilder<T>.Append(String) Method

ToStringBuilderTAppend(String) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.Append(System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ToStringBuilder<T> Append(
    string value
)

Parameters

value String

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.Append(System.String)"]

Return Value

ToStringBuilder T

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.Append(System.String)"]

See Also

Reference

ToStringBuilderT Class
Append Overload
Sportradar.SDK.Common.Utils Namespace


ToStringBuilder<T>.Append<TProperty>(Object, Expression<Func<T, TProperty>>) Method

ToStringBuilderTAppendTProperty(Object, ExpressionFuncT, TProperty) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.Append``1(System.Object,System.Linq.Expressions.Expression{System.Func{`0,``0}})"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ToStringBuilder<T> Append<TProperty>(
    Object invoke,
    Expression<Func<T, TProperty>> propertyExpression
)

Parameters

invoke Object

[Missing <param name="invoke"/> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.Append``1(System.Object,System.Linq.Expressions.Expression{System.Func{`0,``0}})"]

propertyExpression Expression Func T, TProperty

[Missing <param name="propertyExpression"/> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.Append``1(System.Object,System.Linq.Expressions.Expression{System.Func{`0,``0}})"]

Type Parameters

TProperty

[Missing <typeparam name="TProperty"/> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.Append``1(System.Object,System.Linq.Expressions.Expression{System.Func{`0,``0}})"]

Return Value

ToStringBuilder T

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.Append``1(System.Object,System.Linq.Expressions.Expression{System.Func{`0,``0}})"]

See Also

Reference

ToStringBuilderT Class
Append Overload
Sportradar.SDK.Common.Utils Namespace


ToStringBuilder<T>.ListProperty<T> Method

ToStringBuilderTListPropertyT Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.ListProperty``1(System.Collections.Generic.List{``0})"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ListProperty<T>(
    List<T> input
)

Parameters

input List T

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.ListProperty``1(System.Collections.Generic.List{``0})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.ListProperty``1(System.Collections.Generic.List{``0})"]

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.ListProperty``1(System.Collections.Generic.List{``0})"]

See Also

Reference

ToStringBuilderT Class
Sportradar.SDK.Common.Utils Namespace


ToStringBuilder<T>.ToString Method

ToStringBuilderTToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.ToString"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.ToString"]

See Also

Reference

ToStringBuilderT Class
Sportradar.SDK.Common.Utils Namespace


ToStringBuilder<T>.ToStringWithoutTypeName Method

ToStringBuilderTToStringWithoutTypeName Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.ToStringWithoutTypeName"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ToStringWithoutTypeName()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.ToStringBuilder`1.ToStringWithoutTypeName"]

See Also

Reference

ToStringBuilderT Class
Sportradar.SDK.Common.Utils Namespace


XmlUtils Class

[Missing <summary> documentation for "T:Sportradar.SDK.Common.Utils.XmlUtils"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Common.UtilsXmlUtils

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class XmlUtils

The XmlUtils type exposes the following members.

Methods
Name | Description
DeserializeT |
GetXmlSerializerByType |
ToXmlT |
Validate |
Top
See Also

Reference

Sportradar.SDK.Common.Utils Namespace


XmlUtils Methods

The XmlUtils type exposes the following members.

Methods
Name | Description
DeserializeT |
GetXmlSerializerByType |
ToXmlT |
Validate |
Top
See Also

Reference

XmlUtils Class
Sportradar.SDK.Common.Utils Namespace


XmlUtils.Deserialize<T> Method

XmlUtilsDeserializeT Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.Deserialize``1(System.String)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static T Deserialize<T>(
    string msg
)
where T : IProtocolBase

Parameters

msg String

[Missing <param name="msg"/> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.Deserialize``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.Deserialize``1(System.String)"]

Return Value

T

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.Deserialize``1(System.String)"]

See Also

Reference

XmlUtils Class
Sportradar.SDK.Common.Utils Namespace


XmlUtils.GetXmlSerializerByType Method

XmlUtilsGetXmlSerializerByType Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.GetXmlSerializerByType(System.Type)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static XmlSerializer GetXmlSerializerByType(
    Type type
)

Parameters

type Type

[Missing <param name="type"/> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.GetXmlSerializerByType(System.Type)"]

Return Value

XmlSerializer

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.GetXmlSerializerByType(System.Type)"]

See Also

Reference

XmlUtils Class
Sportradar.SDK.Common.Utils Namespace


XmlUtils.ToXml<T> Method

XmlUtilsToXmlT Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.ToXml``1(``0)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static string ToXml<T>(
    T status
)

Parameters

status T

[Missing <param name="status"/> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.ToXml``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.ToXml``1(``0)"]

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.ToXml``1(``0)"]

See Also

Reference

XmlUtils Class
Sportradar.SDK.Common.Utils Namespace


XmlUtils.Validate Method

XmlUtilsValidate Method

[Missing <summary> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.Validate(System.Xml.Schema.XmlSchemaSet,System.String,System.Boolean)"]

Namespace: Sportradar.SDK.Common.Utils
Assembly: Common (in Common.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static bool Validate(
    XmlSchemaSet schemas,
    string msg,
    bool warn_as_error = false
)

Parameters

schemas XmlSchemaSet

[Missing <param name="schemas"/> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.Validate(System.Xml.Schema.XmlSchemaSet,System.String,System.Boolean)"]

msg String

[Missing <param name="msg"/> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.Validate(System.Xml.Schema.XmlSchemaSet,System.String,System.Boolean)"]

warn_as_error Boolean (Optional)

[Missing <param name="warn_as_error"/> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.Validate(System.Xml.Schema.XmlSchemaSet,System.String,System.Boolean)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Common.Utils.XmlUtils.Validate(System.Xml.Schema.XmlSchemaSet,System.String,System.Boolean)"]

See Also

Reference

XmlUtils Class
Sportradar.SDK.Common.Utils Namespace


Sportradar.SDK.FeedProviders.Common Namespace

Classes
 | Class | Description
Public class | ErrorCause | Error cause.
Public class | ErrorSeverity | Error severity.
Public class | FeedErrorEventArgs | Event arguments passed with OnFeedError
Public class | HomeAwayT | Home and away tuple (e.g. counters, stats).
Public class | IdNameTuple | Id and localized name tuple with optional unique id field.
Public class | Team | Home or Away team
Interfaces
 | Interface | Description
Public interface | ILiveFeeds | Live feeds base client interface.


ErrorCause Class

Error cause.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.CommonErrorCause

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class ErrorCause : Enum

The ErrorCause type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | DISCONNECTED | OnDisconnected from server
 | PARSE | Feed parsing error occurred
 | UNKNOWN | Unknown
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Common Namespace


ErrorCause Methods

The ErrorCause type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

ErrorCause Class
Sportradar.SDK.FeedProviders.Common Namespace


ErrorCause Fields

The ErrorCause type exposes the following members.

Fields
 | Name | Description
 | DISCONNECTED | OnDisconnected from server
 | PARSE | Feed parsing error occurred
 | UNKNOWN | Unknown
Public field | value__ |
Top
See Also

Reference

ErrorCause Class
Sportradar.SDK.FeedProviders.Common Namespace


ErrorCause.DISCONNECTED Field

ErrorCauseDISCONNECTED Field

OnDisconnected from server

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ErrorCause DISCONNECTED = 2

Field Value

ErrorCause
See Also

Reference

ErrorCause Class
Sportradar.SDK.FeedProviders.Common Namespace


ErrorCause.PARSE Field

ErrorCausePARSE Field

Feed parsing error occurred

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ErrorCause PARSE = 1

Field Value

ErrorCause
See Also

Reference

ErrorCause Class
Sportradar.SDK.FeedProviders.Common Namespace


ErrorCause.UNKNOWN Field

ErrorCauseUNKNOWN Field

Unknown

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ErrorCause UNKNOWN = 0

Field Value

ErrorCause
See Also

Reference

ErrorCause Class
Sportradar.SDK.FeedProviders.Common Namespace


ErrorCause.value__ Field

ErrorCausevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Common.ErrorCause.value__"]

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

ErrorCause Class
Sportradar.SDK.FeedProviders.Common Namespace


ErrorSeverity Class

Error severity.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.CommonErrorSeverity

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class ErrorSeverity : Enum

The ErrorSeverity type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | CRITICAL | Critical level
 | ERROR | Error level
Public field | value__ |
 | WARNING | Warning level
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Common Namespace


ErrorSeverity Methods

The ErrorSeverity type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

ErrorSeverity Class
Sportradar.SDK.FeedProviders.Common Namespace


ErrorSeverity Fields

The ErrorSeverity type exposes the following members.

Fields
 | Name | Description
 | CRITICAL | Critical level
 | ERROR | Error level
Public field | value__ |
 | WARNING | Warning level
Top
See Also

Reference

ErrorSeverity Class
Sportradar.SDK.FeedProviders.Common Namespace


ErrorSeverity.CRITICAL Field

ErrorSeverityCRITICAL Field

Critical level

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ErrorSeverity CRITICAL = 0

Field Value

ErrorSeverity
See Also

Reference

ErrorSeverity Class
Sportradar.SDK.FeedProviders.Common Namespace


ErrorSeverity.ERROR Field

ErrorSeverityERROR Field

Error level

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ErrorSeverity ERROR = 1

Field Value

ErrorSeverity
See Also

Reference

ErrorSeverity Class
Sportradar.SDK.FeedProviders.Common Namespace


ErrorSeverity.value__ Field

ErrorSeverityvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Common.ErrorSeverity.value__"]

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

ErrorSeverity Class
Sportradar.SDK.FeedProviders.Common Namespace


ErrorSeverity.WARNING Field

ErrorSeverityWARNING Field

Warning level

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ErrorSeverity WARNING = 2

Field Value

ErrorSeverity
See Also

Reference

ErrorSeverity Class
Sportradar.SDK.FeedProviders.Common Namespace


FeedErrorEventArgs Class

Event arguments passed with OnFeedError
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.CommonFeedErrorEventArgs

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class FeedErrorEventArgs : EventArgs

The FeedErrorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FeedErrorEventArgs | Initializes a new instance of the FeedErrorEventArgs class
Top
Properties
 | Name | Description
Public property | Cause | Error cause
Public property | ErrorMessage | Error message
Public property | LocalTimestamp | Error timestamp (local UTC timestamp)
Public property | Severity | Error severity
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Common Namespace


FeedErrorEventArgs Constructor

Initializes a new instance of the FeedErrorEventArgs class

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public FeedErrorEventArgs()
See Also

Reference

FeedErrorEventArgs Class
Sportradar.SDK.FeedProviders.Common Namespace


FeedErrorEventArgs Properties

The FeedErrorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cause | Error cause
Public property | ErrorMessage | Error message
Public property | LocalTimestamp | Error timestamp (local UTC timestamp)
Public property | Severity | Error severity
Top
See Also

Reference

FeedErrorEventArgs Class
Sportradar.SDK.FeedProviders.Common Namespace


FeedErrorEventArgs.Cause Property

FeedErrorEventArgsCause Property

Error cause

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ErrorCause Cause { get; }

Property Value

ErrorCause
See Also

Reference

FeedErrorEventArgs Class
Sportradar.SDK.FeedProviders.Common Namespace


FeedErrorEventArgs.ErrorMessage Property

FeedErrorEventArgsErrorMessage Property

Error message

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ErrorMessage { get; }

Property Value

String
See Also

Reference

FeedErrorEventArgs Class
Sportradar.SDK.FeedProviders.Common Namespace


FeedErrorEventArgs.LocalTimestamp Property

FeedErrorEventArgsLocalTimestamp Property

Error timestamp (local UTC timestamp)

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime LocalTimestamp { get; }

Property Value

DateTime
See Also

Reference

FeedErrorEventArgs Class
Sportradar.SDK.FeedProviders.Common Namespace


FeedErrorEventArgs.Severity Property

FeedErrorEventArgsSeverity Property

Error severity

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ErrorSeverity Severity { get; }

Property Value

ErrorSeverity
See Also

Reference

FeedErrorEventArgs Class
Sportradar.SDK.FeedProviders.Common Namespace


FeedErrorEventArgs Methods

The FeedErrorEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FeedErrorEventArgs Class
Sportradar.SDK.FeedProviders.Common Namespace


HomeAway<T> Class

HomeAwayT Class

Home and away tuple (e.g. counters, stats).
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.CommonHomeAwayT

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class HomeAway<T>

Type Parameters

T
Type that has a home and away value.

The HomeAwayT type exposes the following members.

Constructors
 | Name | Description
Public method | HomeAwayT | Initializes a new instance of the HomeAwayT class.
Top
Properties
 | Name | Description
Public property | Team1 | Team 1 / Home team.
Public property | Team2 | Team 2 / Away team.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Convert to string representation. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Common Namespace


HomeAway<T> Constructor

HomeAwayT Constructor

Initializes a new instance of the HomeAwayT class.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway(
    T team1,
    T team2
)

Parameters

team1 T
Team 1 / Home team
team2 T
Team 2 / Away team
See Also

Reference

HomeAwayT Class
Sportradar.SDK.FeedProviders.Common Namespace


HomeAway<T> Properties

HomeAwayT Properties

The HomeAwayT type exposes the following members.

Properties
 | Name | Description
Public property | Team1 | Team 1 / Home team.
Public property | Team2 | Team 2 / Away team.
Top
See Also

Reference

HomeAwayT Class
Sportradar.SDK.FeedProviders.Common Namespace


HomeAway<T>.Team1 Property

HomeAwayTTeam1 Property

Team 1 / Home team.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public T Team1 { get; }

Property Value

T
See Also

Reference

HomeAwayT Class
Sportradar.SDK.FeedProviders.Common Namespace


HomeAway<T>.Team2 Property

HomeAwayTTeam2 Property

Team 2 / Away team.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public T Team2 { get; }

Property Value

T
See Also

Reference

HomeAwayT Class
Sportradar.SDK.FeedProviders.Common Namespace


HomeAway<T> Methods

HomeAwayT Methods

The HomeAwayT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Convert to string representation. (Overrides ObjectToString)
Top
See Also

Reference

HomeAwayT Class
Sportradar.SDK.FeedProviders.Common Namespace


HomeAway<T>.ToString Method

HomeAwayTToString Method

Convert to string representation.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
Proper string representation.
See Also

Reference

HomeAwayT Class
Sportradar.SDK.FeedProviders.Common Namespace


IdNameTuple Class

Id and localized name tuple with optional unique id field.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.CommonIdNameTuple

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class IdNameTuple

The IdNameTuple type exposes the following members.

Constructors
 | Name | Description
Public method | IdNameTuple(Int64, String, Boolean) | Initialize a new IdNameTuple instance.
Public method | IdNameTuple(Int64, String, Int64, Boolean, Boolean) | Initialize a new IdNameTuple instance.
Top
Properties
 | Name | Description
Public property | Id | Entity id
Public property | Name | Localized entity name
Public property | UniqueId | Specified the team unique id. The teams have two id's; one named id and another named uniqueid. The id is for that team in that tournament, and the uniqueid is for that team in all tournaments. Not all teams have the uniqueid attribute, so it should only be used to identify that two teams in different tournaments are the same.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Convert to string representation. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Common Namespace


IdNameTuple Constructor

Overload List
 | Name | Description
Public method | IdNameTuple(Int64, String, Boolean) | Initialize a new IdNameTuple instance.
Public method | IdNameTuple(Int64, String, Int64, Boolean, Boolean) | Initialize a new IdNameTuple instance.
Top
See Also

Reference

IdNameTuple Class
Sportradar.SDK.FeedProviders.Common Namespace


IdNameTuple(Int64, String, Boolean) Constructor

Initialize a new IdNameTuple instance.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple(
    long id,
    string value,
    bool id_specified = true
)

Parameters

id Int64
Entity id
value String
Entity value
id_specified Boolean (Optional)
Whether id is specified or not
See Also

Reference

IdNameTuple Class
IdNameTuple Overload
Sportradar.SDK.FeedProviders.Common Namespace


IdNameTuple(Int64, String, Int64, Boolean, Boolean) Constructor

Initialize a new IdNameTuple instance.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple(
    long id,
    string value,
    long unique_id,
    bool id_specified = true,
    bool unique_id_specified = true
)

Parameters

id Int64
Entity id
value String
Entity value
unique_id Int64
Entity unique id (i.e. team unique id)
id_specified Boolean (Optional)
Whether id is specified or not
unique_id_specified Boolean (Optional)
Whether unique id is specified or not
See Also

Reference

IdNameTuple Class
IdNameTuple Overload
Sportradar.SDK.FeedProviders.Common Namespace


IdNameTuple Properties

The IdNameTuple type exposes the following members.

Properties
 | Name | Description
Public property | Id | Entity id
Public property | Name | Localized entity name
Public property | UniqueId | Specified the team unique id. The teams have two id's; one named id and another named uniqueid. The id is for that team in that tournament, and the uniqueid is for that team in all tournaments. Not all teams have the uniqueid attribute, so it should only be used to identify that two teams in different tournaments are the same.
Top
See Also

Reference

IdNameTuple Class
Sportradar.SDK.FeedProviders.Common Namespace


IdNameTuple.Id Property

IdNameTupleId Property

Entity id

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Id { get; }

Property Value

Nullable Int64
See Also

Reference

IdNameTuple Class
Sportradar.SDK.FeedProviders.Common Namespace


IdNameTuple.Name Property

IdNameTupleName Property

Localized entity name

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString Name { get; }

Property Value

LocalizedString
See Also

Reference

IdNameTuple Class
Sportradar.SDK.FeedProviders.Common Namespace


IdNameTuple.UniqueId Property

IdNameTupleUniqueId Property

Specified the team unique id. The teams have two id's; one named id and another named uniqueid. The id is for that team in that tournament, and the uniqueid is for that team in all tournaments. Not all teams have the uniqueid attribute, so it should only be used to identify that two teams in different tournaments are the same.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? UniqueId { get; }

Property Value

Nullable Int64
See Also

Reference

IdNameTuple Class
Sportradar.SDK.FeedProviders.Common Namespace


IdNameTuple Methods

The IdNameTuple type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Convert to string representation. (Overrides ObjectToString)
Top
See Also

Reference

IdNameTuple Class
Sportradar.SDK.FeedProviders.Common Namespace


IdNameTuple.ToString Method

IdNameTupleToString Method

Convert to string representation.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
Proper string representation.
See Also

Reference

IdNameTuple Class
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds Interface

Live feeds base client interface.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveFeeds : IStartable

The ILiveFeeds type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations.
Public property | LastAliveMessage | Get time when the last alive message from the server was received.
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent.
Public property | ServerTime | Get approximate server time.
Public property | SubscribedEvents | All event ids we are currently subscribed to.
Top
Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface.
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup.
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events.
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent.
Top
Events
 | Name | Description
Public event | OnFeedError | Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds Properties

The ILiveFeeds type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations.
Public property | LastAliveMessage | Get time when the last alive message from the server was received.
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent.
Public property | ServerTime | Get approximate server time.
Public property | SubscribedEvents | All event ids we are currently subscribed to.
Top
See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds.AvailableTranslations Property

ILiveFeedsAvailableTranslations Property

Language codes of the currently available translations.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
string[] AvailableTranslations { get; }

Property Value

String
See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds.LastAliveMessage Property

ILiveFeedsLastAliveMessage Property

Get time when the last alive message from the server was received.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
DateTime LastAliveMessage { get; }

Property Value

DateTime
Remarks
Time is in UTC according to the local computer or DateTime.MinValue if no message was received yet in this session. A too old value might indicate a problem. Notice that you should not check against this value and disconnect manually MaxTimeSkew setting is meant for that.
See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds.LastServerMessage Property

ILiveFeedsLastServerMessage Property

Get time when the last message from the server was received. This includes alive messages that are periodically sent.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
DateTime LastServerMessage { get; }

Property Value

DateTime
Remarks
Time is in UTC according to the local computer or DateTime.MinValue if no message was received yet in this session. A too old value might indicate a problem. Notice that you should not check against this value and disconnect manually MaxTimeSkew setting is meant for that.
See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds.ServerTime Property

ILiveFeedsServerTime Property

Get approximate server time.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
DateTime? ServerTime { get; }

Property Value

Nullable DateTime
Remarks
Time is is synchronized from LiveOdds server in every received message and periodically from LiveScout (according to ServerTimeSyncInterval). Interpolation is used so this should approximately be the time on the server (not the time of the last message). Value can be null if last successful synchronization was more than MaxServerTimestampAge ago.
See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds.SubscribedEvents Property

ILiveFeedsSubscribedEvents Property

All event ids we are currently subscribed to.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
long[] SubscribedEvents { get; }

Property Value

Int64
See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds Methods

The ILiveFeeds type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface.
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup.
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events.
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent.
Top
See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds.BookEvents Method

ILiveFeedsBookEvents Method

Book the specified events. Booked events cannot be cancelled through this interface.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
long? BookEvents(
    IEnumerable<long> event_ids
)

Parameters

event_ids IEnumerable Int64
event ids

Return Value

Nullable Int64
Request id. LiveOdds : You can use this to match response if "Include response reply number in meta" is enabled
Remarks

You should prefer using the Live Calendar on the Betradar website (http://www.betradar.com) which offers automatic booking for certain types of events.

Note that booking events will have a cost depending on the type of agreement you have with Sportradar.

LiveScout: Expect [!:Sportradar.SDK.FeedProviders.LiveScout.ILiveScout.OnMatchBookingReply] message in reply.

See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds.ClearState Method

ILiveFeedsClearState Method

Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
void ClearState()
Remarks
Should be used with extreme caution!
See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds.Subscribe Method

ILiveFeedsSubscribe Method

Subscribe to specified events.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Subscribe(
    IEnumerable<long> event_ids
)

Parameters

event_ids IEnumerable Int64
Array of event ids
Remarks

LiveOdds: If successful and you have "Enable response on register and unregister requests" enabled in the XML config, then expect [!:Sportradar.SDK.FeedProviders.LiveOdds.ILiveOdds.OnMetaInfo] message with [!:Sportradar.SDK.FeedProviders.LiveOdds.OddsReplyType] = "register" in response.

LiveScout: Expect [!:Sportradar.SDK.FeedProviders.LiveScout.ILiveScout.OneventUpdate] message is response. If event subscription is successful, a full match update is sent out. Otherwise explanation will be given in the response message (e.g. you do not have access to the match or there are already two open subscriptions for the event).

With LiveOdds you will automatically receive interesting updates and you should not Subscribe() unless you explicitly called Unsubscribe(IEnumerableInt64) manually for that event before.

With LiveScout you must explicitly call Subscribe() at start-up or no data will be received.

See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds.Unsubscribe Method

ILiveFeedsUnsubscribe Method

Unsubscribe from the specified events. After this no more events associated with these event ids will be sent.

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Unsubscribe(
    IEnumerable<long> event_ids
)

Parameters

event_ids IEnumerable Int64
Array of event ids
Remarks

LiveOdds: If successful and you have “Enable response on register and unregister requests" enabled in the XML config, then you should receive [!:Sportradar.SDK.FeedProviders.LiveOdds.ILiveOdds.OnMetaInfo] message with [!:Sportradar.SDK.FeedProviders.LiveOdds.OddsReplyType] = "unregister" in response.

LiveScout: Expect [!:Sportradar.SDK.FeedProviders.LiveScout.ILiveScout.OnMatchStop] message is response.

See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds Events

The ILiveFeeds type exposes the following members.

Events
 | Name | Description
Public event | OnFeedError | Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
Top
See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


ILiveFeeds.OnFeedError Event

ILiveFeedsOnFeedError Event

Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<FeedErrorEventArgs> OnFeedError

Value

EventHandler FeedErrorEventArgs
Remarks
It is suggested that this event handler is wired to some Monitoring Service
See Also

Reference

ILiveFeeds Interface
Sportradar.SDK.FeedProviders.Common Namespace


Team Class

Home or Away team
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.CommonTeam

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class Team : Enum

The Team type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | AWAY | Away team
 | HOME | Home team
 | NONE | None (neither home or away)
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Common Namespace


Team Methods

The Team type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

Team Class
Sportradar.SDK.FeedProviders.Common Namespace


Team Fields

The Team type exposes the following members.

Fields
 | Name | Description
 | AWAY | Away team
 | HOME | Home team
 | NONE | None (neither home or away)
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

Team Class
Sportradar.SDK.FeedProviders.Common Namespace


Team.AWAY Field

TeamAWAY Field

Away team

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Team AWAY = 1

Field Value

Team
See Also

Reference

Team Class
Sportradar.SDK.FeedProviders.Common Namespace


Team.HOME Field

TeamHOME Field

Home team

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Team HOME = 2

Field Value

Team
See Also

Reference

Team Class
Sportradar.SDK.FeedProviders.Common Namespace


Team.NONE Field

TeamNONE Field

None (neither home or away)

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Team NONE = 3

Field Value

Team
Remarks
Different from UNDEFINED
See Also

Reference

Team Class
Sportradar.SDK.FeedProviders.Common Namespace


Team.UNDEFINED Field

TeamUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Team UNDEFINED = 0

Field Value

Team
See Also

Reference

Team Class
Sportradar.SDK.FeedProviders.Common Namespace


Team.value__ Field

Teamvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Common.Team.value__"]

Namespace: Sportradar.SDK.FeedProviders.Common
Assembly: FeedProviderCommon (in FeedProviderCommon.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

Team Class
Sportradar.SDK.FeedProviders.Common Namespace


Sportradar.SDK.FeedProviders.Lcoo Namespace

Classes
 | Class | Description
Public class | AggregateScoreEntity |
Public class | BetEntity |
Public class | BetfairIdEntity |
Public class | BetResultEntity |
Public class | CardEntity |
Public class | CardsEntity |
Public class | CardType |
Public class | CategoryEntity |
Public class | CommentEntity |
Public class | CompetitorsEntity |
Public class | CoordinatesEntity |
Public class | CornerEntity |
Public class | CornersEntity |
Public class | DateInfoEntity |
Public class | EventInfoEntity |
Public class | FeedType |
Public class | FixtureEntity |
Public class | GoalEntity |
Public class | GoalsEntity |
Public class | Hand |
Public class | LcooBetDataEntity |
Public class | LcooEntityBase |
Public class | MatchEntity |
Public class | MatchEventOdds |
Public class | OddsEntity |
Public class | OddsProbabilityEntity |
Public class | OutrightEntity |
Public class | OutrightEventOdds |
Public class | OutrightResultEntity |
Public class | PitcherEntity |
Public class | PlayerEntity |
Public class | PlayersEntity |
Public class | ProbabilityEntity |
Public class | ResultEntity |
Public class | RoundInfoEntity |
Public class | ScoresInfoEntity |
Public class | SeriesResultEntity |
Public class | SportEntity |
Public class | StatusInfoEntity |
Public class | StreamingMatch |
Public class | TextEntity |
Public class | TextsEntity |
Public class | ThreeBallEntity |
Public class | ThreeBallEventArgs |
Public class | TournamentEntity |
Public class | TvChannelEntity |
Public class | VenueEntity |
Public class | WinningOutcomeEntity |
Interfaces
 | Interface | Description
Public interface | ILcoo |


AggregateScoreEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.AggregateScoreEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooSeriesResultEntity
Sportradar.SDK.FeedProviders.LcooAggregateScoreEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class AggregateScoreEntity : SeriesResultEntity

The AggregateScoreEntity type exposes the following members.

Constructors
 | Name | Description
Public method | AggregateScoreEntity | Initializes a new instance of the AggregateScoreEntity class
Top
Properties
 | Name | Description
Public property | Value | (Inherited from SeriesResultEntity)
Public property | Winner | (Inherited from SeriesResultEntity)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides SeriesResultEntityToString)
Public method | ToStringWithoutTypeName | (Inherited from SeriesResultEntity)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


AggregateScoreEntity Constructor

Initializes a new instance of the AggregateScoreEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public AggregateScoreEntity()
See Also

Reference

AggregateScoreEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


AggregateScoreEntity Properties

The AggregateScoreEntity type exposes the following members.

Properties
 | Name | Description
Public property | Value | (Inherited from SeriesResultEntity)
Public property | Winner | (Inherited from SeriesResultEntity)
Top
See Also

Reference

AggregateScoreEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


AggregateScoreEntity Methods

The AggregateScoreEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides SeriesResultEntityToString)
Public method | ToStringWithoutTypeName | (Inherited from SeriesResultEntity)
Top
See Also

Reference

AggregateScoreEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


AggregateScoreEntity.ToString Method

AggregateScoreEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.AggregateScoreEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.AggregateScoreEntity.ToString"]

See Also

Reference

AggregateScoreEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.BetEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooBetEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetEntity

The BetEntity type exposes the following members.

Constructors
 | Name | Description
Public method | BetEntity | Initializes a new instance of the BetEntity class
Top
Properties
 | Name | Description
Public property | Odds |
Public property | OddsType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


BetEntity Constructor

Initializes a new instance of the BetEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetEntity()
See Also

Reference

BetEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetEntity Properties

The BetEntity type exposes the following members.

Properties
 | Name | Description
Public property | Odds |
Public property | OddsType |
Top
See Also

Reference

BetEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetEntity.Odds Property

BetEntityOdds Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetEntity.Odds"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<OddsEntity> Odds { get; set; }

Property Value

List OddsEntity
See Also

Reference

BetEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetEntity.OddsType Property

BetEntityOddsType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetEntity.OddsType"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int OddsType { get; set; }

Property Value

Int32
See Also

Reference

BetEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetEntity Methods

The BetEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

BetEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetEntity.ToString Method

BetEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.BetEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.BetEntity.ToString"]

See Also

Reference

BetEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetfairIdEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.BetfairIdEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooBetfairIdEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetfairIdEntity

The BetfairIdEntity type exposes the following members.

Constructors
 | Name | Description
Public method | BetfairIdEntity | Initializes a new instance of the BetfairIdEntity class
Top
Properties
 | Name | Description
Public property | EventId |
Public property | Runner1 |
Public property | Runner2 |
Public property | SportId |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


BetfairIdEntity Constructor

Initializes a new instance of the BetfairIdEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetfairIdEntity()
See Also

Reference

BetfairIdEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetfairIdEntity Properties

The BetfairIdEntity type exposes the following members.

Properties
 | Name | Description
Public property | EventId |
Public property | Runner1 |
Public property | Runner2 |
Public property | SportId |
Top
See Also

Reference

BetfairIdEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetfairIdEntity.EventId Property

BetfairIdEntityEventId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetfairIdEntity.EventId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int EventId { get; }

Property Value

Int32
See Also

Reference

BetfairIdEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetfairIdEntity.Runner1 Property

BetfairIdEntityRunner1 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetfairIdEntity.Runner1"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Runner1 { get; }

Property Value

Int32
See Also

Reference

BetfairIdEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetfairIdEntity.Runner2 Property

BetfairIdEntityRunner2 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetfairIdEntity.Runner2"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Runner2 { get; }

Property Value

Int32
See Also

Reference

BetfairIdEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetfairIdEntity.SportId Property

BetfairIdEntitySportId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetfairIdEntity.SportId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int SportId { get; }

Property Value

Int32
See Also

Reference

BetfairIdEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetfairIdEntity Methods

The BetfairIdEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

BetfairIdEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetfairIdEntity.ToString Method

BetfairIdEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.BetfairIdEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.BetfairIdEntity.ToString"]

See Also

Reference

BetfairIdEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.BetResultEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooBetResultEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetResultEntity

The BetResultEntity type exposes the following members.

Constructors
 | Name | Description
Public method | BetResultEntity | Initializes a new instance of the BetResultEntity class
Top
Properties
 | Name | Description
Public property | OddsType |
Public property | Outcome |
Public property | OutcomeId |
Public property | PlayerId |
Public property | Reason |
Public property | SpecialBetValue |
Public property | Status |
Public property | TeamId |
Public property | VoidFactor |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity Constructor

Initializes a new instance of the BetResultEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetResultEntity()
See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity Properties

The BetResultEntity type exposes the following members.

Properties
 | Name | Description
Public property | OddsType |
Public property | Outcome |
Public property | OutcomeId |
Public property | PlayerId |
Public property | Reason |
Public property | SpecialBetValue |
Public property | Status |
Public property | TeamId |
Public property | VoidFactor |
Top
See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity.OddsType Property

BetResultEntityOddsType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetResultEntity.OddsType"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long OddsType { get; }

Property Value

Int64
See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity.Outcome Property

BetResultEntityOutcome Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetResultEntity.Outcome"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Outcome { get; }

Property Value

String
See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity.OutcomeId Property

BetResultEntityOutcomeId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetResultEntity.OutcomeId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string OutcomeId { get; }

Property Value

String
See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity.PlayerId Property

BetResultEntityPlayerId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetResultEntity.PlayerId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string PlayerId { get; }

Property Value

String
See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity.Reason Property

BetResultEntityReason Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetResultEntity.Reason"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Reason { get; }

Property Value

String
See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity.SpecialBetValue Property

BetResultEntitySpecialBetValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetResultEntity.SpecialBetValue"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SpecialBetValue { get; }

Property Value

String
See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity.Status Property

BetResultEntityStatus Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetResultEntity.Status"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? Status { get; }

Property Value

Nullable Boolean
See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity.TeamId Property

BetResultEntityTeamId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetResultEntity.TeamId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string TeamId { get; }

Property Value

String
See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity.VoidFactor Property

BetResultEntityVoidFactor Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.BetResultEntity.VoidFactor"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string VoidFactor { get; }

Property Value

String
See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity Methods

The BetResultEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


BetResultEntity.ToString Method

BetResultEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.BetResultEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.BetResultEntity.ToString"]

See Also

Reference

BetResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.CardEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooCardEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class CardEntity

The CardEntity type exposes the following members.

Constructors
 | Name | Description
Public method | CardEntity | Initializes a new instance of the CardEntity class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Player |
Public property | Time |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


CardEntity Constructor

Initializes a new instance of the CardEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CardEntity()
See Also

Reference

CardEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardEntity Properties

The CardEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Player |
Public property | Time |
Public property | Type |
Top
See Also

Reference

CardEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardEntity.Id Property

CardEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CardEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long Id { get; }

Property Value

Int64
See Also

Reference

CardEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardEntity.Player Property

CardEntityPlayer Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CardEntity.Player"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PlayerEntity Player { get; }

Property Value

PlayerEntity
See Also

Reference

CardEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardEntity.Time Property

CardEntityTime Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CardEntity.Time"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Time { get; }

Property Value

String
See Also

Reference

CardEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardEntity.Type Property

CardEntityType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CardEntity.Type"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CardType? Type { get; }

Property Value

Nullable CardType
See Also

Reference

CardEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardEntity Methods

The CardEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

CardEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardEntity.ToString Method

CardEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CardEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CardEntity.ToString"]

See Also

Reference

CardEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardsEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.CardsEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooCardsEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class CardsEntity

The CardsEntity type exposes the following members.

Constructors
 | Name | Description
Public method | CardsEntity | Initializes a new instance of the CardsEntity class
Top
Properties
 | Name | Description
Public property | Cards |
Public property | Doubtful |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


CardsEntity Constructor

Initializes a new instance of the CardsEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CardsEntity()
See Also

Reference

CardsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardsEntity Properties

The CardsEntity type exposes the following members.

Properties
 | Name | Description
Public property | Cards |
Public property | Doubtful |
Top
See Also

Reference

CardsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardsEntity.Cards Property

CardsEntityCards Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CardsEntity.Cards"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<CardEntity> Cards { get; }

Property Value

List CardEntity
See Also

Reference

CardsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardsEntity.Doubtful Property

CardsEntityDoubtful Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CardsEntity.Doubtful"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Doubtful { get; }

Property Value

Boolean
See Also

Reference

CardsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardsEntity Methods

The CardsEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

CardsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardsEntity.ToString Method

CardsEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CardsEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CardsEntity.ToString"]

See Also

Reference

CardsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardType Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.CardType"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LcooCardType

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class CardType : Enum

The CardType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | RED |
 | UNDEFINED |
Public field | value__ |
 | YELLOW |
 | YELLOWRED |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


CardType Methods

The CardType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

CardType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardType Fields

The CardType type exposes the following members.

Fields
 | Name | Description
 | RED |
 | UNDEFINED |
Public field | value__ |
 | YELLOW |
 | YELLOWRED |
Top
See Also

Reference

CardType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardType.RED Field

CardTypeRED Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.CardType.RED"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const CardType RED = 1

Field Value

CardType
See Also

Reference

CardType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardType.UNDEFINED Field

CardTypeUNDEFINED Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.CardType.UNDEFINED"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const CardType UNDEFINED = 0

Field Value

CardType
See Also

Reference

CardType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardType.value__ Field

CardTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.CardType.value__"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

CardType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardType.YELLOW Field

CardTypeYELLOW Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.CardType.YELLOW"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const CardType YELLOW = 3

Field Value

CardType
See Also

Reference

CardType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CardType.YELLOWRED Field

CardTypeYELLOWRED Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.CardType.YELLOWRED"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const CardType YELLOWRED = 2

Field Value

CardType
See Also

Reference

CardType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CategoryEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooTextsEntity
Sportradar.SDK.FeedProviders.LcooCategoryEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class CategoryEntity : TextsEntity

The CategoryEntity type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryEntity | Initializes a new instance of the CategoryEntity class
Top
Properties
 | Name | Description
Public property | Id |
Public property | IsoId |
Public property | IsoName |
Public property | Texts | (Inherited from TextsEntity)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides TextsEntityToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


CategoryEntity Constructor

Initializes a new instance of the CategoryEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CategoryEntity()
See Also

Reference

CategoryEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CategoryEntity Properties

The CategoryEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | IsoId |
Public property | IsoName |
Public property | Texts | (Inherited from TextsEntity)
Top
See Also

Reference

CategoryEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CategoryEntity.Id Property

CategoryEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long Id { get; }

Property Value

Int64
See Also

Reference

CategoryEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CategoryEntity.IsoId Property

CategoryEntityIsoId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity.IsoId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? IsoId { get; }

Property Value

Nullable Int64
See Also

Reference

CategoryEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CategoryEntity.IsoName Property

CategoryEntityIsoName Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity.IsoName"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string IsoName { get; }

Property Value

String
See Also

Reference

CategoryEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CategoryEntity Methods

The CategoryEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides TextsEntityToString)
Top
See Also

Reference

CategoryEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CategoryEntity.ToString Method

CategoryEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity.ToString"]

See Also

Reference

CategoryEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CommentEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.CommentEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooTextsEntity
Sportradar.SDK.FeedProviders.LcooCommentEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class CommentEntity : TextsEntity

The CommentEntity type exposes the following members.

Constructors
 | Name | Description
Public method | CommentEntity | Initializes a new instance of the CommentEntity class
Top
Properties
 | Name | Description
Public property | Language |
Public property | Texts | (Inherited from TextsEntity)
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides TextsEntityToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


CommentEntity Constructor

Initializes a new instance of the CommentEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CommentEntity()
See Also

Reference

CommentEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CommentEntity Properties

The CommentEntity type exposes the following members.

Properties
 | Name | Description
Public property | Language |
Public property | Texts | (Inherited from TextsEntity)
Public property | Value |
Top
See Also

Reference

CommentEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CommentEntity.Language Property

CommentEntityLanguage Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CommentEntity.Language"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Language { get; }

Property Value

String
See Also

Reference

CommentEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CommentEntity.Value Property

CommentEntityValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CommentEntity.Value"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; }

Property Value

String
See Also

Reference

CommentEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CommentEntity Methods

The CommentEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides TextsEntityToString)
Top
See Also

Reference

CommentEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CommentEntity.ToString Method

CommentEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CommentEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CommentEntity.ToString"]

See Also

Reference

CommentEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CompetitorsEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.CompetitorsEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooCompetitorsEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class CompetitorsEntity

The CompetitorsEntity type exposes the following members.

Constructors
 | Name | Description
Public method | CompetitorsEntity | Initializes a new instance of the CompetitorsEntity class
Top
Properties
 | Name | Description
Public property | Players |
Public property | Texts |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


CompetitorsEntity Constructor

Initializes a new instance of the CompetitorsEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CompetitorsEntity()
See Also

Reference

CompetitorsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CompetitorsEntity Properties

The CompetitorsEntity type exposes the following members.

Properties
 | Name | Description
Public property | Players |
Public property | Texts |
Top
See Also

Reference

CompetitorsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CompetitorsEntity.Players Property

CompetitorsEntityPlayers Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CompetitorsEntity.Players"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<PlayerEntity> Players { get; }

Property Value

List PlayerEntity
See Also

Reference

CompetitorsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CompetitorsEntity.Texts Property

CompetitorsEntityTexts Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CompetitorsEntity.Texts"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<TextsEntity> Texts { get; }

Property Value

List TextsEntity
See Also

Reference

CompetitorsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CompetitorsEntity Methods

The CompetitorsEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

CompetitorsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CompetitorsEntity.ToString Method

CompetitorsEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CompetitorsEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CompetitorsEntity.ToString"]

See Also

Reference

CompetitorsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CoordinatesEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.CoordinatesEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooCoordinatesEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class CoordinatesEntity

The CoordinatesEntity type exposes the following members.

Constructors
 | Name | Description
Public method | CoordinatesEntity | Initializes a new instance of the CoordinatesEntity class
Top
Properties
 | Name | Description
Public property | Latitude |
Public property | Longitude |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


CoordinatesEntity Constructor

Initializes a new instance of the CoordinatesEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CoordinatesEntity()
See Also

Reference

CoordinatesEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CoordinatesEntity Properties

The CoordinatesEntity type exposes the following members.

Properties
 | Name | Description
Public property | Latitude |
Public property | Longitude |
Top
See Also

Reference

CoordinatesEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CoordinatesEntity.Latitude Property

CoordinatesEntityLatitude Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CoordinatesEntity.Latitude"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public float Latitude { get; }

Property Value

Single
See Also

Reference

CoordinatesEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CoordinatesEntity.Longitude Property

CoordinatesEntityLongitude Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CoordinatesEntity.Longitude"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public float Longitude { get; }

Property Value

Single
See Also

Reference

CoordinatesEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CoordinatesEntity Methods

The CoordinatesEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

CoordinatesEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CoordinatesEntity.ToString Method

CoordinatesEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CoordinatesEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CoordinatesEntity.ToString"]

See Also

Reference

CoordinatesEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornerEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.CornerEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooCornerEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class CornerEntity

The CornerEntity type exposes the following members.

Constructors
 | Name | Description
Public method | CornerEntity | Initializes a new instance of the CornerEntity class
Top
Properties
 | Name | Description
Public property | Count |
Public property | Team |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


CornerEntity Constructor

Initializes a new instance of the CornerEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CornerEntity()
See Also

Reference

CornerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornerEntity Properties

The CornerEntity type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Team |
Public property | Type |
Top
See Also

Reference

CornerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornerEntity.Count Property

CornerEntityCount Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CornerEntity.Count"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Count { get; }

Property Value

Int32
See Also

Reference

CornerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornerEntity.Team Property

CornerEntityTeam Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CornerEntity.Team"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team Team { get; }

Property Value

Team
See Also

Reference

CornerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornerEntity.Type Property

CornerEntityType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CornerEntity.Type"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Type { get; }

Property Value

String
See Also

Reference

CornerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornerEntity Methods

The CornerEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

CornerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornerEntity.ToString Method

CornerEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CornerEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CornerEntity.ToString"]

See Also

Reference

CornerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornersEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.CornersEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooCornersEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class CornersEntity

The CornersEntity type exposes the following members.

Constructors
 | Name | Description
Public method | CornersEntity | Initializes a new instance of the CornersEntity class
Top
Properties
 | Name | Description
Public property | Corners |
Public property | Doubtful |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


CornersEntity Constructor

Initializes a new instance of the CornersEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CornersEntity()
See Also

Reference

CornersEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornersEntity Properties

The CornersEntity type exposes the following members.

Properties
 | Name | Description
Public property | Corners |
Public property | Doubtful |
Top
See Also

Reference

CornersEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornersEntity.Corners Property

CornersEntityCorners Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CornersEntity.Corners"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<CornerEntity> Corners { get; }

Property Value

List CornerEntity
See Also

Reference

CornersEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornersEntity.Doubtful Property

CornersEntityDoubtful Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.CornersEntity.Doubtful"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Doubtful { get; }

Property Value

Boolean
See Also

Reference

CornersEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornersEntity Methods

The CornersEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

CornersEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


CornersEntity.ToString Method

CornersEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CornersEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.CornersEntity.ToString"]

See Also

Reference

CornersEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


DateInfoEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.DateInfoEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooDateInfoEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class DateInfoEntity

The DateInfoEntity type exposes the following members.

Constructors
 | Name | Description
Public method | DateInfoEntity | Initializes a new instance of the DateInfoEntity class
Top
Properties
 | Name | Description
Public property | Comment |
Public property | ConfirmedMatchStart |
Public property | Info |
Public property | MatchDate |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


DateInfoEntity Constructor

Initializes a new instance of the DateInfoEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateInfoEntity()
See Also

Reference

DateInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


DateInfoEntity Properties

The DateInfoEntity type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | ConfirmedMatchStart |
Public property | Info |
Public property | MatchDate |
Top
See Also

Reference

DateInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


DateInfoEntity.Comment Property

DateInfoEntityComment Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.DateInfoEntity.Comment"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<CommentEntity> Comment { get; }

Property Value

List CommentEntity
See Also

Reference

DateInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


DateInfoEntity.ConfirmedMatchStart Property

DateInfoEntityConfirmedMatchStart Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.DateInfoEntity.ConfirmedMatchStart"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime ConfirmedMatchStart { get; }

Property Value

DateTime
See Also

Reference

DateInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


DateInfoEntity.Info Property

DateInfoEntityInfo Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.DateInfoEntity.Info"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TypeValueTuple Info { get; }

Property Value

TypeValueTuple
See Also

Reference

DateInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


DateInfoEntity.MatchDate Property

DateInfoEntityMatchDate Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.DateInfoEntity.MatchDate"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime MatchDate { get; }

Property Value

DateTime
See Also

Reference

DateInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


DateInfoEntity Methods

The DateInfoEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

DateInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


DateInfoEntity.ToString Method

DateInfoEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.DateInfoEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.DateInfoEntity.ToString"]

See Also

Reference

DateInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


EventInfoEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.EventInfoEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooEventInfoEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class EventInfoEntity

The EventInfoEntity type exposes the following members.

Constructors
 | Name | Description
Public method | EventInfoEntity | Initializes a new instance of the EventInfoEntity class
Top
Properties
 | Name | Description
Public property | Active |
Public property | EventDate |
Public property | EventEndDate |
Public property | EventName |
Public property | EventStart |
Public property | NumberOfWinners |
Public property | TournamentId |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


EventInfoEntity Constructor

Initializes a new instance of the EventInfoEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventInfoEntity()
See Also

Reference

EventInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


EventInfoEntity Properties

The EventInfoEntity type exposes the following members.

Properties
 | Name | Description
Public property | Active |
Public property | EventDate |
Public property | EventEndDate |
Public property | EventName |
Public property | EventStart |
Public property | NumberOfWinners |
Public property | TournamentId |
Top
See Also

Reference

EventInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


EventInfoEntity.Active Property

EventInfoEntityActive Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.EventInfoEntity.Active"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Active { get; }

Property Value

Boolean
See Also

Reference

EventInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


EventInfoEntity.EventDate Property

EventInfoEntityEventDate Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.EventInfoEntity.EventDate"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime EventDate { get; }

Property Value

DateTime
See Also

Reference

EventInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


EventInfoEntity.EventEndDate Property

EventInfoEntityEventEndDate Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.EventInfoEntity.EventEndDate"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime EventEndDate { get; }

Property Value

DateTime
See Also

Reference

EventInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


EventInfoEntity.EventName Property

EventInfoEntityEventName Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.EventInfoEntity.EventName"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TextsEntity EventName { get; }

Property Value

TextsEntity
See Also

Reference

EventInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


EventInfoEntity.EventStart Property

EventInfoEntityEventStart Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.EventInfoEntity.EventStart"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime EventStart { get; }

Property Value

DateTime
See Also

Reference

EventInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


EventInfoEntity.NumberOfWinners Property

EventInfoEntityNumberOfWinners Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.EventInfoEntity.NumberOfWinners"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? NumberOfWinners { get; }

Property Value

Nullable Int32
See Also

Reference

EventInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


EventInfoEntity.TournamentId Property

EventInfoEntityTournamentId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.EventInfoEntity.TournamentId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? TournamentId { get; }

Property Value

Nullable Int64
See Also

Reference

EventInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


EventInfoEntity Methods

The EventInfoEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

EventInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


EventInfoEntity.ToString Method

EventInfoEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.EventInfoEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.EventInfoEntity.ToString"]

See Also

Reference

EventInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FeedType Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.FeedType"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LcooFeedType

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class FeedType : Enum

The FeedType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | DELTA |
 | FULL |
 | TOURNAMENT |
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


FeedType Methods

The FeedType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

FeedType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FeedType Fields

The FeedType type exposes the following members.

Fields
 | Name | Description
 | DELTA |
 | FULL |
 | TOURNAMENT |
Public field | value__ |
Top
See Also

Reference

FeedType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FeedType.DELTA Field

FeedTypeDELTA Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.FeedType.DELTA"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedType DELTA = 2

Field Value

FeedType
See Also

Reference

FeedType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FeedType.FULL Field

FeedTypeFULL Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.FeedType.FULL"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedType FULL = 0

Field Value

FeedType
See Also

Reference

FeedType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FeedType.TOURNAMENT Field

FeedTypeTOURNAMENT Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.FeedType.TOURNAMENT"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedType TOURNAMENT = 1

Field Value

FeedType
See Also

Reference

FeedType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FeedType.value__ Field

FeedTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.FeedType.value__"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

FeedType Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooFixtureEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class FixtureEntity

The FixtureEntity type exposes the following members.

Constructors
 | Name | Description
Public method | FixtureEntity | Initializes a new instance of the FixtureEntity class
Top
Properties
 | Name | Description
Public property | AamsCalendarId |
Public property | AggregateScore |
Public property | AustrianDistrict |
Public property | Competitors |
Public property | DateInfo |
Public property | EventInfo |
Public property | HasStatistics |
Public property | LiveMultiCast |
Public property | LiveScore |
Public property | NeutralGround |
Public property | NumberOfFrames |
Public property | NumberOfSets |
Public property | Players |
Public property | RoundInfo |
Public property | SeriesResult |
Public property | StatusInfo |
Public property | StreamingMatch |
Public property | Venue |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity Constructor

Initializes a new instance of the FixtureEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public FixtureEntity()
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity Properties

The FixtureEntity type exposes the following members.

Properties
 | Name | Description
Public property | AamsCalendarId |
Public property | AggregateScore |
Public property | AustrianDistrict |
Public property | Competitors |
Public property | DateInfo |
Public property | EventInfo |
Public property | HasStatistics |
Public property | LiveMultiCast |
Public property | LiveScore |
Public property | NeutralGround |
Public property | NumberOfFrames |
Public property | NumberOfSets |
Public property | Players |
Public property | RoundInfo |
Public property | SeriesResult |
Public property | StatusInfo |
Public property | StreamingMatch |
Public property | Venue |
Top
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.AamsCalendarId Property

FixtureEntityAamsCalendarId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.AamsCalendarId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? AamsCalendarId { get; }

Property Value

Nullable Int32
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.AggregateScore Property

FixtureEntityAggregateScore Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.AggregateScore"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public AggregateScoreEntity AggregateScore { get; }

Property Value

AggregateScoreEntity
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.AustrianDistrict Property

FixtureEntityAustrianDistrict Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.AustrianDistrict"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? AustrianDistrict { get; }

Property Value

Nullable Int64
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.Competitors Property

FixtureEntityCompetitors Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.Competitors"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CompetitorsEntity Competitors { get; }

Property Value

CompetitorsEntity
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.DateInfo Property

FixtureEntityDateInfo Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.DateInfo"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateInfoEntity DateInfo { get; }

Property Value

DateInfoEntity
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.EventInfo Property

FixtureEntityEventInfo Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.EventInfo"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventInfoEntity EventInfo { get; }

Property Value

EventInfoEntity
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.HasStatistics Property

FixtureEntityHasStatistics Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.HasStatistics"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool HasStatistics { get; }

Property Value

Boolean
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.LiveMultiCast Property

FixtureEntityLiveMultiCast Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.LiveMultiCast"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool LiveMultiCast { get; }

Property Value

Boolean
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.LiveScore Property

FixtureEntityLiveScore Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.LiveScore"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool LiveScore { get; }

Property Value

Boolean
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.NeutralGround Property

FixtureEntityNeutralGround Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.NeutralGround"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool NeutralGround { get; }

Property Value

Boolean
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.NumberOfFrames Property

FixtureEntityNumberOfFrames Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.NumberOfFrames"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? NumberOfFrames { get; }

Property Value

Nullable Int32
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.NumberOfSets Property

FixtureEntityNumberOfSets Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.NumberOfSets"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? NumberOfSets { get; }

Property Value

Nullable Int64
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.Players Property

FixtureEntityPlayers Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.Players"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PlayersEntity Players { get; }

Property Value

PlayersEntity
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.RoundInfo Property

FixtureEntityRoundInfo Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.RoundInfo"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RoundInfoEntity RoundInfo { get; }

Property Value

RoundInfoEntity
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.SeriesResult Property

FixtureEntitySeriesResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.SeriesResult"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SeriesResultEntity SeriesResult { get; }

Property Value

SeriesResultEntity
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.StatusInfo Property

FixtureEntityStatusInfo Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.StatusInfo"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public StatusInfoEntity StatusInfo { get; }

Property Value

StatusInfoEntity
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.StreamingMatch Property

FixtureEntityStreamingMatch Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.StreamingMatch"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<StreamingMatch> StreamingMatch { get; }

Property Value

List StreamingMatch
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.Venue Property

FixtureEntityVenue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.Venue"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public VenueEntity Venue { get; }

Property Value

VenueEntity
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity Methods

The FixtureEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


FixtureEntity.ToString Method

FixtureEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.FixtureEntity.ToString"]

See Also

Reference

FixtureEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.GoalEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooGoalEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class GoalEntity

The GoalEntity type exposes the following members.

Constructors
 | Name | Description
Public method | GoalEntity | Initializes a new instance of the GoalEntity class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Player |
Public property | Score |
Public property | ScoringTeam |
Public property | Time |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalEntity Constructor

Initializes a new instance of the GoalEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public GoalEntity()
See Also

Reference

GoalEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalEntity Properties

The GoalEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Player |
Public property | Score |
Public property | ScoringTeam |
Public property | Time |
Public property | Type |
Top
See Also

Reference

GoalEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalEntity.Id Property

GoalEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.GoalEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long Id { get; }

Property Value

Int64
See Also

Reference

GoalEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalEntity.Player Property

GoalEntityPlayer Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.GoalEntity.Player"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PlayerEntity Player { get; }

Property Value

PlayerEntity
See Also

Reference

GoalEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalEntity.Score Property

GoalEntityScore Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.GoalEntity.Score"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<long?> Score { get; }

Property Value

HomeAway Nullable Int64
See Also

Reference

GoalEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalEntity.ScoringTeam Property

GoalEntityScoringTeam Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.GoalEntity.ScoringTeam"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team ScoringTeam { get; }

Property Value

Team
See Also

Reference

GoalEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalEntity.Time Property

GoalEntityTime Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.GoalEntity.Time"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Time { get; }

Property Value

String
See Also

Reference

GoalEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalEntity.Type Property

GoalEntityType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.GoalEntity.Type"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Type { get; }

Property Value

String
See Also

Reference

GoalEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalEntity Methods

The GoalEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

GoalEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalEntity.ToString Method

GoalEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.GoalEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.GoalEntity.ToString"]

See Also

Reference

GoalEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalsEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.GoalsEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooGoalsEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class GoalsEntity

The GoalsEntity type exposes the following members.

Constructors
 | Name | Description
Public method | GoalsEntity | Initializes a new instance of the GoalsEntity class
Top
Properties
 | Name | Description
Public property | Doubtful |
Public property | Goals |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalsEntity Constructor

Initializes a new instance of the GoalsEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public GoalsEntity()
See Also

Reference

GoalsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalsEntity Properties

The GoalsEntity type exposes the following members.

Properties
 | Name | Description
Public property | Doubtful |
Public property | Goals |
Top
See Also

Reference

GoalsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalsEntity.Doubtful Property

GoalsEntityDoubtful Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.GoalsEntity.Doubtful"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Doubtful { get; }

Property Value

Boolean
See Also

Reference

GoalsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalsEntity.Goals Property

GoalsEntityGoals Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.GoalsEntity.Goals"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<GoalEntity> Goals { get; }

Property Value

List GoalEntity
See Also

Reference

GoalsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalsEntity Methods

The GoalsEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

GoalsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


GoalsEntity.ToString Method

GoalsEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.GoalsEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.GoalsEntity.ToString"]

See Also

Reference

GoalsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


Hand Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.Hand"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LcooHand

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class Hand : Enum

The Hand type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | LEFT |
 | RIGHT |
 | UNDEFINED |
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


Hand Methods

The Hand type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

Hand Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


Hand Fields

The Hand type exposes the following members.

Fields
 | Name | Description
 | LEFT |
 | RIGHT |
 | UNDEFINED |
Public field | value__ |
Top
See Also

Reference

Hand Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


Hand.LEFT Field

HandLEFT Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.Hand.LEFT"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Hand LEFT = 2

Field Value

Hand
See Also

Reference

Hand Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


Hand.RIGHT Field

HandRIGHT Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.Hand.RIGHT"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Hand RIGHT = 1

Field Value

Hand
See Also

Reference

Hand Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


Hand.UNDEFINED Field

HandUNDEFINED Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.Hand.UNDEFINED"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Hand UNDEFINED = 0

Field Value

Hand
See Also

Reference

Hand Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


Hand.value__ Field

Handvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.Lcoo.Hand.value__"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

Hand Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ILcoo Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.ILcoo"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILcoo : IStartable

The ILcoo type exposes the following members.

Methods
 | Name | Description
Public method | ClearQueue |
Public method | Refresh |
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Top
Events
 | Name | Description
Public event | OnMatch |
Public event | OnOutright |
Public event | OnThreeBall |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


ILcoo Methods

The ILcoo type exposes the following members.

Methods
 | Name | Description
Public method | ClearQueue |
Public method | Refresh |
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Top
See Also

Reference

ILcoo Interface
Sportradar.SDK.FeedProviders.Lcoo Namespace


ILcoo.ClearQueue Method

ILcooClearQueue Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.ILcoo.ClearQueue"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void ClearQueue()
See Also

Reference

ILcoo Interface
Sportradar.SDK.FeedProviders.Lcoo Namespace


ILcoo.Refresh Method

ILcooRefresh Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.ILcoo.Refresh"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Refresh()
See Also

Reference

ILcoo Interface
Sportradar.SDK.FeedProviders.Lcoo Namespace


ILcoo Events

The ILcoo type exposes the following members.

Events
 | Name | Description
Public event | OnMatch |
Public event | OnOutright |
Public event | OnThreeBall |
Top
See Also

Reference

ILcoo Interface
Sportradar.SDK.FeedProviders.Lcoo Namespace


ILcoo.OnMatch Event

ILcooOnMatch Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.Lcoo.ILcoo.OnMatch"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MatchEventOdds> OnMatch

Value

EventHandler MatchEventOdds
See Also

Reference

ILcoo Interface
Sportradar.SDK.FeedProviders.Lcoo Namespace


ILcoo.OnOutright Event

ILcooOnOutright Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.Lcoo.ILcoo.OnOutright"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OutrightEventOdds> OnOutright

Value

EventHandler OutrightEventOdds
See Also

Reference

ILcoo Interface
Sportradar.SDK.FeedProviders.Lcoo Namespace


ILcoo.OnThreeBall Event

ILcooOnThreeBall Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.Lcoo.ILcoo.OnThreeBall"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<ThreeBallEventArgs> OnThreeBall

Value

EventHandler ThreeBallEventArgs
See Also

Reference

ILcoo Interface
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooBetDataEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.LcooBetDataEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LcooLcooEntityBase
Sportradar.SDK.FeedProviders.LcooLcooBetDataEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class LcooBetDataEntity : LcooEntityBase

The LcooBetDataEntity type exposes the following members.

Constructors
 | Name | Description
Public method | LcooBetDataEntity | Initializes a new instance of the LcooBetDataEntity class
Public method | LcooBetDataEntity(XmlAttribute) | Initializes a new instance of the LcooBetDataEntity class
Top
Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | FeedType | (Inherited from LcooEntityBase)
Public property | MatchEntities |
Public property | OutrightEntities |
Public property | ThreeBallEntities |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides LcooEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooBetDataEntity Constructor

Overload List
 | Name | Description
Public method | LcooBetDataEntity | Initializes a new instance of the LcooBetDataEntity class
Public method | LcooBetDataEntity(XmlAttribute) | Initializes a new instance of the LcooBetDataEntity class
Top
See Also

Reference

LcooBetDataEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooBetDataEntity Constructor

Initializes a new instance of the LcooBetDataEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LcooBetDataEntity()
See Also

Reference

LcooBetDataEntity Class
LcooBetDataEntity Overload
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooBetDataEntity(XmlAttribute[]) Constructor

LcooBetDataEntity(XmlAttribute) Constructor

Initializes a new instance of the LcooBetDataEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LcooBetDataEntity(
    XmlAttribute[] any_attr
)

Parameters

any_attr XmlAttribute

[Missing <param name="any_attr"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.LcooBetDataEntity.#ctor(System.Xml.XmlAttribute[])"]

See Also

Reference

LcooBetDataEntity Class
LcooBetDataEntity Overload
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooBetDataEntity Properties

The LcooBetDataEntity type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | FeedType | (Inherited from LcooEntityBase)
Public property | MatchEntities |
Public property | OutrightEntities |
Public property | ThreeBallEntities |
Top
See Also

Reference

LcooBetDataEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooBetDataEntity.MatchEntities Property

LcooBetDataEntityMatchEntities Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.LcooBetDataEntity.MatchEntities"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<MatchEntity> MatchEntities { get; }

Property Value

List MatchEntity
See Also

Reference

LcooBetDataEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooBetDataEntity.OutrightEntities Property

LcooBetDataEntityOutrightEntities Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.LcooBetDataEntity.OutrightEntities"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<OutrightEntity> OutrightEntities { get; }

Property Value

List OutrightEntity
See Also

Reference

LcooBetDataEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooBetDataEntity.ThreeBallEntities Property

LcooBetDataEntityThreeBallEntities Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.LcooBetDataEntity.ThreeBallEntities"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<ThreeBallEntity> ThreeBallEntities { get; }

Property Value

List ThreeBallEntity
See Also

Reference

LcooBetDataEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooBetDataEntity Methods

The LcooBetDataEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides LcooEntityBaseToString)
Top
See Also

Reference

LcooBetDataEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooBetDataEntity.ToString Method

LcooBetDataEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.LcooBetDataEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.LcooBetDataEntity.ToString"]

See Also

Reference

LcooBetDataEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooEntityBase Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.LcooEntityBase"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LcooLcooEntityBase
Sportradar.SDK.FeedProviders.LcooLcooBetDataEntity
Sportradar.SDK.FeedProviders.LcooMatchEntity
Sportradar.SDK.FeedProviders.LcooOutrightEntity
Sportradar.SDK.FeedProviders.LcooThreeBallEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class LcooEntityBase : EntityBase

The LcooEntityBase type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | FeedType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides EntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooEntityBase Properties

The LcooEntityBase type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | FeedType |
Top
See Also

Reference

LcooEntityBase Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooEntityBase.FeedType Property

LcooEntityBaseFeedType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.LcooEntityBase.FeedType"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public FeedType? FeedType { get; }

Property Value

Nullable FeedType
See Also

Reference

LcooEntityBase Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooEntityBase Methods

The LcooEntityBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides EntityBaseToString)
Top
See Also

Reference

LcooEntityBase Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


LcooEntityBase.ToString Method

LcooEntityBaseToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.LcooEntityBase.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.LcooEntityBase.ToString"]

See Also

Reference

LcooEntityBase Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LcooLcooEntityBase
Sportradar.SDK.FeedProviders.LcooMatchEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchEntity : LcooEntityBase

The MatchEntity type exposes the following members.

Properties
 | Name | Description
Public property | Aamsids |
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | AwayTeamBetradarMatchId |
Public property | AwayTeamMonitoringMatchId |
Public property | BetdaqId |
Public property | BetfairId |
Public property | BetResults |
Public property | Cards |
Public property | Category |
Public property | Corners |
Public property | FeedType | (Inherited from LcooEntityBase)
Public property | Fixture |
Public property | Goals |
Public property | HomeTeamBetradarMatchId |
Public property | HomeTeamMonitoringMatchId |
Public property | Information |
Public property | MatchId |
Public property | MessageTime |
Public property | MonitoringMatchId |
Public property | Odds |
Public property | Pitcher |
Public property | Probabilities |
Public property | Result |
Public property | RotationNumber |
Public property | Sport |
Public property | Tournament |
Public property | TvChannels |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides LcooEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity Properties

The MatchEntity type exposes the following members.

Properties
 | Name | Description
Public property | Aamsids |
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | AwayTeamBetradarMatchId |
Public property | AwayTeamMonitoringMatchId |
Public property | BetdaqId |
Public property | BetfairId |
Public property | BetResults |
Public property | Cards |
Public property | Category |
Public property | Corners |
Public property | FeedType | (Inherited from LcooEntityBase)
Public property | Fixture |
Public property | Goals |
Public property | HomeTeamBetradarMatchId |
Public property | HomeTeamMonitoringMatchId |
Public property | Information |
Public property | MatchId |
Public property | MessageTime |
Public property | MonitoringMatchId |
Public property | Odds |
Public property | Pitcher |
Public property | Probabilities |
Public property | Result |
Public property | RotationNumber |
Public property | Sport |
Public property | Tournament |
Public property | TvChannels |
Top
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Aamsids Property

MatchEntityAamsids Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Aamsids"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Aamsids { get; }

Property Value

String
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.AwayTeamBetradarMatchId Property

MatchEntityAwayTeamBetradarMatchId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.AwayTeamBetradarMatchId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? AwayTeamBetradarMatchId { get; }

Property Value

Nullable Int64
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.AwayTeamMonitoringMatchId Property

MatchEntityAwayTeamMonitoringMatchId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.AwayTeamMonitoringMatchId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? AwayTeamMonitoringMatchId { get; }

Property Value

Nullable Int64
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.BetdaqId Property

MatchEntityBetdaqId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.BetdaqId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Object BetdaqId { get; }

Property Value

Object
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.BetfairId Property

MatchEntityBetfairId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.BetfairId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetfairIdEntity BetfairId { get; }

Property Value

BetfairIdEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.BetResults Property

MatchEntityBetResults Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.BetResults"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<BetResultEntity> BetResults { get; }

Property Value

List BetResultEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Cards Property

MatchEntityCards Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Cards"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CardsEntity Cards { get; }

Property Value

CardsEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Category Property

MatchEntityCategory Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Category"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CategoryEntity Category { get; }

Property Value

CategoryEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Corners Property

MatchEntityCorners Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Corners"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CornersEntity Corners { get; }

Property Value

CornersEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Fixture Property

MatchEntityFixture Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Fixture"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public FixtureEntity Fixture { get; }

Property Value

FixtureEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Goals Property

MatchEntityGoals Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Goals"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public GoalsEntity Goals { get; }

Property Value

GoalsEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.HomeTeamBetradarMatchId Property

MatchEntityHomeTeamBetradarMatchId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.HomeTeamBetradarMatchId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? HomeTeamBetradarMatchId { get; }

Property Value

Nullable Int64
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.HomeTeamMonitoringMatchId Property

MatchEntityHomeTeamMonitoringMatchId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.HomeTeamMonitoringMatchId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? HomeTeamMonitoringMatchId { get; }

Property Value

Nullable Int64
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Information Property

MatchEntityInformation Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Information"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<TextsEntity> Information { get; }

Property Value

List TextsEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.MatchId Property

MatchEntityMatchId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.MatchId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long MatchId { get; }

Property Value

Int64
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.MessageTime Property

MatchEntityMessageTime Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.MessageTime"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime? MessageTime { get; }

Property Value

Nullable DateTime
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.MonitoringMatchId Property

MatchEntityMonitoringMatchId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.MonitoringMatchId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MonitoringMatchId { get; }

Property Value

String
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Odds Property

MatchEntityOdds Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Odds"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<BetEntity> Odds { get; }

Property Value

List BetEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Pitcher Property

MatchEntityPitcher Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Pitcher"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<PitcherEntity> Pitcher { get; }

Property Value

HomeAway PitcherEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Probabilities Property

MatchEntityProbabilities Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Probabilities"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<ProbabilityEntity> Probabilities { get; }

Property Value

List ProbabilityEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Result Property

MatchEntityResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Result"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ResultEntity Result { get; }

Property Value

ResultEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.RotationNumber Property

MatchEntityRotationNumber Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.RotationNumber"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<long?> RotationNumber { get; }

Property Value

HomeAway Nullable Int64
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Sport Property

MatchEntitySport Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Sport"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SportEntity Sport { get; }

Property Value

SportEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.Tournament Property

MatchEntityTournament Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.Tournament"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TournamentEntity Tournament { get; }

Property Value

TournamentEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.TvChannels Property

MatchEntityTvChannels Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.TvChannels"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<TvChannelEntity> TvChannels { get; }

Property Value

List TvChannelEntity
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity Methods

The MatchEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides LcooEntityBaseToString)
Top
See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEntity.ToString Method

MatchEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.MatchEntity.ToString"]

See Also

Reference

MatchEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEventOdds Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.MatchEventOdds"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LcooMatchEventOdds

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchEventOdds : EventArgs

The MatchEventOdds type exposes the following members.

Constructors
 | Name | Description
Public method | MatchEventOdds | Initializes a new instance of the MatchEventOdds class
Top
Properties
 | Name | Description
Public property | MatchEntity |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEventOdds Constructor

Initializes a new instance of the MatchEventOdds class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchEventOdds()
See Also

Reference

MatchEventOdds Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEventOdds Properties

The MatchEventOdds type exposes the following members.

Properties
 | Name | Description
Public property | MatchEntity |
Top
See Also

Reference

MatchEventOdds Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEventOdds.MatchEntity Property

MatchEventOddsMatchEntity Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.MatchEventOdds.MatchEntity"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchEntity MatchEntity { get; }

Property Value

MatchEntity
See Also

Reference

MatchEventOdds Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


MatchEventOdds Methods

The MatchEventOdds type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MatchEventOdds Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.OddsEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooOddsEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OddsEntity

The OddsEntity type exposes the following members.

Constructors
 | Name | Description
Public method | OddsEntity | Initializes a new instance of the OddsEntity class
Top
Properties
 | Name | Description
Public property | Id |
Public property | OutCome |
Public property | OutcomeId |
Public property | PlayerId |
Public property | SpecialBetValue |
Public property | TeamId |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsEntity Constructor

Initializes a new instance of the OddsEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsEntity()
See Also

Reference

OddsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsEntity Properties

The OddsEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | OutCome |
Public property | OutcomeId |
Public property | PlayerId |
Public property | SpecialBetValue |
Public property | TeamId |
Public property | Value |
Top
See Also

Reference

OddsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsEntity.Id Property

OddsEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Id { get; }

Property Value

Nullable Int32
See Also

Reference

OddsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsEntity.OutCome Property

OddsEntityOutCome Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsEntity.OutCome"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string OutCome { get; }

Property Value

String
See Also

Reference

OddsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsEntity.OutcomeId Property

OddsEntityOutcomeId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsEntity.OutcomeId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string OutcomeId { get; }

Property Value

String
See Also

Reference

OddsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsEntity.PlayerId Property

OddsEntityPlayerId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsEntity.PlayerId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string PlayerId { get; }

Property Value

String
See Also

Reference

OddsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsEntity.SpecialBetValue Property

OddsEntitySpecialBetValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsEntity.SpecialBetValue"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SpecialBetValue { get; }

Property Value

String
See Also

Reference

OddsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsEntity.TeamId Property

OddsEntityTeamId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsEntity.TeamId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string TeamId { get; }

Property Value

String
See Also

Reference

OddsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsEntity.Value Property

OddsEntityValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsEntity.Value"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; }

Property Value

String
See Also

Reference

OddsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsEntity Methods

The OddsEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

OddsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsEntity.ToString Method

OddsEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.OddsEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.OddsEntity.ToString"]

See Also

Reference

OddsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsProbabilityEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.OddsProbabilityEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooOddsProbabilityEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OddsProbabilityEntity

The OddsProbabilityEntity type exposes the following members.

Constructors
 | Name | Description
Public method | OddsProbabilityEntity | Initializes a new instance of the OddsProbabilityEntity class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Outcome |
Public property | OutcomeId |
Public property | PlayerId |
Public property | SpecialBetValue |
Public property | TeamId |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsProbabilityEntity Constructor

Initializes a new instance of the OddsProbabilityEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsProbabilityEntity()
See Also

Reference

OddsProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsProbabilityEntity Properties

The OddsProbabilityEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Outcome |
Public property | OutcomeId |
Public property | PlayerId |
Public property | SpecialBetValue |
Public property | TeamId |
Public property | Value |
Top
See Also

Reference

OddsProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsProbabilityEntity.Id Property

OddsProbabilityEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsProbabilityEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Id { get; }

Property Value

Nullable Int64
See Also

Reference

OddsProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsProbabilityEntity.Outcome Property

OddsProbabilityEntityOutcome Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsProbabilityEntity.Outcome"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Outcome { get; }

Property Value

String
See Also

Reference

OddsProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsProbabilityEntity.OutcomeId Property

OddsProbabilityEntityOutcomeId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsProbabilityEntity.OutcomeId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string OutcomeId { get; }

Property Value

String
See Also

Reference

OddsProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsProbabilityEntity.PlayerId Property

OddsProbabilityEntityPlayerId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsProbabilityEntity.PlayerId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string PlayerId { get; }

Property Value

String
See Also

Reference

OddsProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsProbabilityEntity.SpecialBetValue Property

OddsProbabilityEntitySpecialBetValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsProbabilityEntity.SpecialBetValue"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SpecialBetValue { get; }

Property Value

String
See Also

Reference

OddsProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsProbabilityEntity.TeamId Property

OddsProbabilityEntityTeamId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsProbabilityEntity.TeamId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string TeamId { get; }

Property Value

String
See Also

Reference

OddsProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsProbabilityEntity.Value Property

OddsProbabilityEntityValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OddsProbabilityEntity.Value"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; }

Property Value

String
See Also

Reference

OddsProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsProbabilityEntity Methods

The OddsProbabilityEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

OddsProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OddsProbabilityEntity.ToString Method

OddsProbabilityEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.OddsProbabilityEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.OddsProbabilityEntity.ToString"]

See Also

Reference

OddsProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LcooLcooEntityBase
Sportradar.SDK.FeedProviders.LcooOutrightEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightEntity : LcooEntityBase

The OutrightEntity type exposes the following members.

Properties
 | Name | Description
Public property | AamsCalendarId |
Public property | AAmsOutrightIDs |
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Category |
Public property | FeedType | (Inherited from LcooEntityBase)
Public property | Fixture |
Public property | Id |
Public property | MessageTime |
Public property | Odds |
Public property | Result |
Public property | Sport |
Public property | StageId |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides LcooEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity Properties

The OutrightEntity type exposes the following members.

Properties
 | Name | Description
Public property | AamsCalendarId |
Public property | AAmsOutrightIDs |
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Category |
Public property | FeedType | (Inherited from LcooEntityBase)
Public property | Fixture |
Public property | Id |
Public property | MessageTime |
Public property | Odds |
Public property | Result |
Public property | Sport |
Public property | StageId |
Top
See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity.AamsCalendarId Property

OutrightEntityAamsCalendarId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity.AamsCalendarId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? AamsCalendarId { get; }

Property Value

Nullable Int32
See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity.AAmsOutrightIDs Property

OutrightEntityAAmsOutrightIDs Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity.AAmsOutrightIDs"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AAmsOutrightIDs { get; }

Property Value

String
See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity.Category Property

OutrightEntityCategory Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity.Category"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CategoryEntity Category { get; }

Property Value

CategoryEntity
See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity.Fixture Property

OutrightEntityFixture Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity.Fixture"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public FixtureEntity Fixture { get; }

Property Value

FixtureEntity
See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity.Id Property

OutrightEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity.MessageTime Property

OutrightEntityMessageTime Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity.MessageTime"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime? MessageTime { get; }

Property Value

Nullable DateTime
See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity.Odds Property

OutrightEntityOdds Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity.Odds"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetEntity Odds { get; }

Property Value

BetEntity
See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity.Result Property

OutrightEntityResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity.Result"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<OutrightResultEntity> Result { get; }

Property Value

List OutrightResultEntity
See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity.Sport Property

OutrightEntitySport Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity.Sport"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SportEntity Sport { get; }

Property Value

SportEntity
See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity.StageId Property

OutrightEntityStageId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity.StageId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? StageId { get; }

Property Value

Nullable Int64
See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity Methods

The OutrightEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides LcooEntityBaseToString)
Top
See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEntity.ToString Method

OutrightEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.OutrightEntity.ToString"]

See Also

Reference

OutrightEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEventOdds Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.OutrightEventOdds"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LcooOutrightEventOdds

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightEventOdds : EventArgs

The OutrightEventOdds type exposes the following members.

Constructors
 | Name | Description
Public method | OutrightEventOdds | Initializes a new instance of the OutrightEventOdds class
Top
Properties
 | Name | Description
Public property | OutrightEntity |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEventOdds Constructor

Initializes a new instance of the OutrightEventOdds class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightEventOdds()
See Also

Reference

OutrightEventOdds Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEventOdds Properties

The OutrightEventOdds type exposes the following members.

Properties
 | Name | Description
Public property | OutrightEntity |
Top
See Also

Reference

OutrightEventOdds Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEventOdds.OutrightEntity Property

OutrightEventOddsOutrightEntity Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightEventOdds.OutrightEntity"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightEntity OutrightEntity { get; }

Property Value

OutrightEntity
See Also

Reference

OutrightEventOdds Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightEventOdds Methods

The OutrightEventOdds type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OutrightEventOdds Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightResultEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.OutrightResultEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooOutrightResultEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightResultEntity

The OutrightResultEntity type exposes the following members.

Constructors
 | Name | Description
Public method | OutrightResultEntity | Initializes a new instance of the OutrightResultEntity class
Top
Properties
 | Name | Description
Public property | DeadHeatFactor |
Public property | Id |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightResultEntity Constructor

Initializes a new instance of the OutrightResultEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightResultEntity()
See Also

Reference

OutrightResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightResultEntity Properties

The OutrightResultEntity type exposes the following members.

Properties
 | Name | Description
Public property | DeadHeatFactor |
Public property | Id |
Public property | Value |
Top
See Also

Reference

OutrightResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightResultEntity.DeadHeatFactor Property

OutrightResultEntityDeadHeatFactor Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightResultEntity.DeadHeatFactor"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double? DeadHeatFactor { get; }

Property Value

Nullable Double
See Also

Reference

OutrightResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightResultEntity.Id Property

OutrightResultEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightResultEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Id { get; }

Property Value

String
See Also

Reference

OutrightResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightResultEntity.Value Property

OutrightResultEntityValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.OutrightResultEntity.Value"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; }

Property Value

String
See Also

Reference

OutrightResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightResultEntity Methods

The OutrightResultEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

OutrightResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


OutrightResultEntity.ToString Method

OutrightResultEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.OutrightResultEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.OutrightResultEntity.ToString"]

See Also

Reference

OutrightResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PitcherEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.PitcherEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooPitcherEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class PitcherEntity

The PitcherEntity type exposes the following members.

Constructors
 | Name | Description
Public method | PitcherEntity | Initializes a new instance of the PitcherEntity class
Top
Properties
 | Name | Description
Public property | Hand |
Public property | Name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


PitcherEntity Constructor

Initializes a new instance of the PitcherEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PitcherEntity()
See Also

Reference

PitcherEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PitcherEntity Properties

The PitcherEntity type exposes the following members.

Properties
 | Name | Description
Public property | Hand |
Public property | Name |
Top
See Also

Reference

PitcherEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PitcherEntity.Hand Property

PitcherEntityHand Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.PitcherEntity.Hand"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Hand Hand { get; }

Property Value

Hand
See Also

Reference

PitcherEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PitcherEntity.Name Property

PitcherEntityName Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.PitcherEntity.Name"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; }

Property Value

String
See Also

Reference

PitcherEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PitcherEntity Methods

The PitcherEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

PitcherEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PitcherEntity.ToString Method

PitcherEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.PitcherEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.PitcherEntity.ToString"]

See Also

Reference

PitcherEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayerEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.PlayerEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooTextsEntity
Sportradar.SDK.FeedProviders.LcooPlayerEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class PlayerEntity : TextsEntity

The PlayerEntity type exposes the following members.

Constructors
 | Name | Description
Public method | PlayerEntity | Initializes a new instance of the PlayerEntity class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Name |
Public property | Order |
Public property | SuperId |
Public property | TeamId |
Public property | Texts | (Inherited from TextsEntity)
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides TextsEntityToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayerEntity Constructor

Initializes a new instance of the PlayerEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PlayerEntity()
See Also

Reference

PlayerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayerEntity Properties

The PlayerEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Name |
Public property | Order |
Public property | SuperId |
Public property | TeamId |
Public property | Texts | (Inherited from TextsEntity)
Public property | Value |
Top
See Also

Reference

PlayerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayerEntity.Id Property

PlayerEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.PlayerEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Id { get; }

Property Value

Nullable Int64
See Also

Reference

PlayerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayerEntity.Name Property

PlayerEntityName Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.PlayerEntity.Name"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString Name { get; }

Property Value

LocalizedString
See Also

Reference

PlayerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayerEntity.Order Property

PlayerEntityOrder Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.PlayerEntity.Order"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Order { get; }

Property Value

Int32
See Also

Reference

PlayerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayerEntity.SuperId Property

PlayerEntitySuperId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.PlayerEntity.SuperId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? SuperId { get; }

Property Value

Nullable Int64
See Also

Reference

PlayerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayerEntity.TeamId Property

PlayerEntityTeamId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.PlayerEntity.TeamId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? TeamId { get; }

Property Value

Nullable Int64
See Also

Reference

PlayerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayerEntity.Value Property

PlayerEntityValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.PlayerEntity.Value"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; }

Property Value

String
See Also

Reference

PlayerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayerEntity Methods

The PlayerEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides TextsEntityToString)
Top
See Also

Reference

PlayerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayerEntity.ToString Method

PlayerEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.PlayerEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.PlayerEntity.ToString"]

See Also

Reference

PlayerEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayersEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.PlayersEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooPlayersEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class PlayersEntity

The PlayersEntity type exposes the following members.

Constructors
 | Name | Description
Public method | PlayersEntity | Initializes a new instance of the PlayersEntity class
Top
Properties
 | Name | Description
Public property | Players |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayersEntity Constructor

Initializes a new instance of the PlayersEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PlayersEntity()
See Also

Reference

PlayersEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayersEntity Properties

The PlayersEntity type exposes the following members.

Properties
 | Name | Description
Public property | Players |
Top
See Also

Reference

PlayersEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayersEntity.Players Property

PlayersEntityPlayers Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.PlayersEntity.Players"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<PlayerEntity> Players { get; }

Property Value

List PlayerEntity
See Also

Reference

PlayersEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayersEntity Methods

The PlayersEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

PlayersEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


PlayersEntity.ToString Method

PlayersEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.PlayersEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.PlayersEntity.ToString"]

See Also

Reference

PlayersEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ProbabilityEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.ProbabilityEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooProbabilityEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ProbabilityEntity

The ProbabilityEntity type exposes the following members.

Constructors
 | Name | Description
Public method | ProbabilityEntity | Initializes a new instance of the ProbabilityEntity class
Top
Properties
 | Name | Description
Public property | OddsProbabilities |
Public property | OddsType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


ProbabilityEntity Constructor

Initializes a new instance of the ProbabilityEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ProbabilityEntity()
See Also

Reference

ProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ProbabilityEntity Properties

The ProbabilityEntity type exposes the following members.

Properties
 | Name | Description
Public property | OddsProbabilities |
Public property | OddsType |
Top
See Also

Reference

ProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ProbabilityEntity.OddsProbabilities Property

ProbabilityEntityOddsProbabilities Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ProbabilityEntity.OddsProbabilities"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<OddsProbabilityEntity> OddsProbabilities { get; }

Property Value

List OddsProbabilityEntity
See Also

Reference

ProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ProbabilityEntity.OddsType Property

ProbabilityEntityOddsType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ProbabilityEntity.OddsType"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int OddsType { get; }

Property Value

Int32
See Also

Reference

ProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ProbabilityEntity Methods

The ProbabilityEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

ProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ProbabilityEntity.ToString Method

ProbabilityEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.ProbabilityEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.ProbabilityEntity.ToString"]

See Also

Reference

ProbabilityEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ResultEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.ResultEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooResultEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ResultEntity

The ResultEntity type exposes the following members.

Constructors
 | Name | Description
Public method | ResultEntity | Initializes a new instance of the ResultEntity class
Top
Properties
 | Name | Description
Public property | Comment |
Public property | ScoresInfo |
Public property | WinningOutcome |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


ResultEntity Constructor

Initializes a new instance of the ResultEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ResultEntity()
See Also

Reference

ResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ResultEntity Properties

The ResultEntity type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | ScoresInfo |
Public property | WinningOutcome |
Top
See Also

Reference

ResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ResultEntity.Comment Property

ResultEntityComment Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ResultEntity.Comment"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CommentEntity Comment { get; }

Property Value

CommentEntity
See Also

Reference

ResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ResultEntity.ScoresInfo Property

ResultEntityScoresInfo Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ResultEntity.ScoresInfo"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoresInfoEntity ScoresInfo { get; }

Property Value

ScoresInfoEntity
See Also

Reference

ResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ResultEntity.WinningOutcome Property

ResultEntityWinningOutcome Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ResultEntity.WinningOutcome"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public WinningOutcomeEntity WinningOutcome { get; }

Property Value

WinningOutcomeEntity
See Also

Reference

ResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ResultEntity Methods

The ResultEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

ResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ResultEntity.ToString Method

ResultEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.ResultEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.ResultEntity.ToString"]

See Also

Reference

ResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


RoundInfoEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.RoundInfoEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooRoundInfoEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RoundInfoEntity

The RoundInfoEntity type exposes the following members.

Constructors
 | Name | Description
Public method | RoundInfoEntity | Initializes a new instance of the RoundInfoEntity class
Top
Properties
 | Name | Description
Public property | Cupround |
Public property | Id |
Public property | MatchNr |
Public property | Round |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


RoundInfoEntity Constructor

Initializes a new instance of the RoundInfoEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RoundInfoEntity()
See Also

Reference

RoundInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


RoundInfoEntity Properties

The RoundInfoEntity type exposes the following members.

Properties
 | Name | Description
Public property | Cupround |
Public property | Id |
Public property | MatchNr |
Public property | Round |
Top
See Also

Reference

RoundInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


RoundInfoEntity.Cupround Property

RoundInfoEntityCupround Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.RoundInfoEntity.Cupround"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Cupround { get; }

Property Value

String
See Also

Reference

RoundInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


RoundInfoEntity.Id Property

RoundInfoEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.RoundInfoEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Id { get; }

Property Value

Nullable Int64
See Also

Reference

RoundInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


RoundInfoEntity.MatchNr Property

RoundInfoEntityMatchNr Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.RoundInfoEntity.MatchNr"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MatchNr { get; }

Property Value

String
See Also

Reference

RoundInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


RoundInfoEntity.Round Property

RoundInfoEntityRound Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.RoundInfoEntity.Round"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Round { get; }

Property Value

Nullable Int64
See Also

Reference

RoundInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


RoundInfoEntity Methods

The RoundInfoEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

RoundInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


RoundInfoEntity.ToString Method

RoundInfoEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.RoundInfoEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.RoundInfoEntity.ToString"]

See Also

Reference

RoundInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ScoresInfoEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.ScoresInfoEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooScoresInfoEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ScoresInfoEntity

The ScoresInfoEntity type exposes the following members.

Constructors
 | Name | Description
Public method | ScoresInfoEntity | Initializes a new instance of the ScoresInfoEntity class
Top
Properties
 | Name | Description
Public property | DecidedByFa |
Public property | Scores |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


ScoresInfoEntity Constructor

Initializes a new instance of the ScoresInfoEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoresInfoEntity()
See Also

Reference

ScoresInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ScoresInfoEntity Properties

The ScoresInfoEntity type exposes the following members.

Properties
 | Name | Description
Public property | DecidedByFa |
Public property | Scores |
Top
See Also

Reference

ScoresInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ScoresInfoEntity.DecidedByFa Property

ScoresInfoEntityDecidedByFa Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ScoresInfoEntity.DecidedByFa"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool DecidedByFa { get; }

Property Value

Boolean
See Also

Reference

ScoresInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ScoresInfoEntity.Scores Property

ScoresInfoEntityScores Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ScoresInfoEntity.Scores"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<TypeValueTuple> Scores { get; }

Property Value

List TypeValueTuple
See Also

Reference

ScoresInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ScoresInfoEntity Methods

The ScoresInfoEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

ScoresInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ScoresInfoEntity.ToString Method

ScoresInfoEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.ScoresInfoEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.ScoresInfoEntity.ToString"]

See Also

Reference

ScoresInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


SeriesResultEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.SeriesResultEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooSeriesResultEntity
Sportradar.SDK.FeedProviders.LcooAggregateScoreEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class SeriesResultEntity

The SeriesResultEntity type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesResultEntity | Initializes a new instance of the SeriesResultEntity class
Top
Properties
 | Name | Description
Public property | Value |
Public property | Winner |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Public method | ToStringWithoutTypeName |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


SeriesResultEntity Constructor

Initializes a new instance of the SeriesResultEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SeriesResultEntity()
See Also

Reference

SeriesResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


SeriesResultEntity Properties

The SeriesResultEntity type exposes the following members.

Properties
 | Name | Description
Public property | Value |
Public property | Winner |
Top
See Also

Reference

SeriesResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


SeriesResultEntity.Value Property

SeriesResultEntityValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.SeriesResultEntity.Value"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; set; }

Property Value

String
See Also

Reference

SeriesResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


SeriesResultEntity.Winner Property

SeriesResultEntityWinner Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.SeriesResultEntity.Winner"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Winner { get; set; }

Property Value

String
See Also

Reference

SeriesResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


SeriesResultEntity Methods

The SeriesResultEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Public method | ToStringWithoutTypeName |
Top
See Also

Reference

SeriesResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


SeriesResultEntity.ToString Method

SeriesResultEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.SeriesResultEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.SeriesResultEntity.ToString"]

See Also

Reference

SeriesResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


SeriesResultEntity.ToStringWithoutTypeName Method

SeriesResultEntityToStringWithoutTypeName Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.SeriesResultEntity.ToStringWithoutTypeName"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ToStringWithoutTypeName()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.SeriesResultEntity.ToStringWithoutTypeName"]

See Also

Reference

SeriesResultEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


SportEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.SportEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooTextsEntity
Sportradar.SDK.FeedProviders.LcooSportEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class SportEntity : TextsEntity

The SportEntity type exposes the following members.

Constructors
 | Name | Description
Public method | SportEntity | Initializes a new instance of the SportEntity class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Texts | (Inherited from TextsEntity)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides TextsEntityToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


SportEntity Constructor

Initializes a new instance of the SportEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SportEntity()
See Also

Reference

SportEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


SportEntity Properties

The SportEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Texts | (Inherited from TextsEntity)
Top
See Also

Reference

SportEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


SportEntity.Id Property

SportEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.SportEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

SportEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


SportEntity Methods

The SportEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides TextsEntityToString)
Top
See Also

Reference

SportEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


SportEntity.ToString Method

SportEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.SportEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.SportEntity.ToString"]

See Also

Reference

SportEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


StatusInfoEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.StatusInfoEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooStatusInfoEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class StatusInfoEntity

The StatusInfoEntity type exposes the following members.

Constructors
 | Name | Description
Public method | StatusInfoEntity | Initializes a new instance of the StatusInfoEntity class
Top
Properties
 | Name | Description
Public property | IsActive |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


StatusInfoEntity Constructor

Initializes a new instance of the StatusInfoEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public StatusInfoEntity()
See Also

Reference

StatusInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


StatusInfoEntity Properties

The StatusInfoEntity type exposes the following members.

Properties
 | Name | Description
Public property | IsActive |
Top
See Also

Reference

StatusInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


StatusInfoEntity.IsActive Property

StatusInfoEntityIsActive Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.StatusInfoEntity.IsActive"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsActive { get; set; }

Property Value

Boolean
See Also

Reference

StatusInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


StatusInfoEntity Methods

The StatusInfoEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

StatusInfoEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


StreamingMatch Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.StreamingMatch"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooStreamingMatch

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class StreamingMatch

The StreamingMatch type exposes the following members.

Constructors
 | Name | Description
Public method | StreamingMatch | Initializes a new instance of the StreamingMatch class
Top
Properties
 | Name | Description
Public property | Disabled |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


StreamingMatch Constructor

Initializes a new instance of the StreamingMatch class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public StreamingMatch()
See Also

Reference

StreamingMatch Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


StreamingMatch Properties

The StreamingMatch type exposes the following members.

Properties
 | Name | Description
Public property | Disabled |
Public property | Value |
Top
See Also

Reference

StreamingMatch Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


StreamingMatch.Disabled Property

StreamingMatchDisabled Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.StreamingMatch.Disabled"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? Disabled { get; }

Property Value

Nullable Boolean
See Also

Reference

StreamingMatch Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


StreamingMatch.Value Property

StreamingMatchValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.StreamingMatch.Value"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; }

Property Value

String
See Also

Reference

StreamingMatch Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


StreamingMatch Methods

The StreamingMatch type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

StreamingMatch Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


StreamingMatch.ToString Method

StreamingMatchToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.StreamingMatch.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.StreamingMatch.ToString"]

See Also

Reference

StreamingMatch Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.TextEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooTextEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class TextEntity

The TextEntity type exposes the following members.

Constructors
 | Name | Description
Public method | TextEntity | Initializes a new instance of the TextEntity class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Language |
Public property | Superid |
Public property | TeamId |
Public property | Text |
Public property | Type |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


TextEntity Constructor

Initializes a new instance of the TextEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TextEntity()
See Also

Reference

TextEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextEntity Properties

The TextEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Language |
Public property | Superid |
Public property | TeamId |
Public property | Text |
Public property | Type |
Public property | Value |
Top
See Also

Reference

TextEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextEntity.Id Property

TextEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TextEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Id { get; }

Property Value

Nullable Int64
See Also

Reference

TextEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextEntity.Language Property

TextEntityLanguage Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TextEntity.Language"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Language { get; }

Property Value

String
See Also

Reference

TextEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextEntity.Superid Property

TextEntitySuperid Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TextEntity.Superid"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Superid { get; }

Property Value

Nullable Int64
See Also

Reference

TextEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextEntity.TeamId Property

TextEntityTeamId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TextEntity.TeamId"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? TeamId { get; }

Property Value

Nullable Int64
See Also

Reference

TextEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextEntity.Text Property

TextEntityText Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TextEntity.Text"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<TextEntity> Text { get; }

Property Value

List TextEntity
See Also

Reference

TextEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextEntity.Type Property

TextEntityType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TextEntity.Type"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Type { get; }

Property Value

String
See Also

Reference

TextEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextEntity.Value Property

TextEntityValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TextEntity.Value"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; }

Property Value

String
See Also

Reference

TextEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextEntity Methods

The TextEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

TextEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextEntity.ToString Method

TextEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.TextEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.TextEntity.ToString"]

See Also

Reference

TextEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextsEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.TextsEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooTextsEntity
More

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class TextsEntity

The TextsEntity type exposes the following members.

Constructors
 | Name | Description
Public method | TextsEntity | Initializes a new instance of the TextsEntity class
Top
Properties
 | Name | Description
Public property | Texts |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooTextsEntity
Sportradar.SDK.FeedProviders.LcooCategoryEntity
Sportradar.SDK.FeedProviders.LcooCommentEntity
Sportradar.SDK.FeedProviders.LcooPlayerEntity
Sportradar.SDK.FeedProviders.LcooSportEntity
Sportradar.SDK.FeedProviders.LcooTournamentEntity
Sportradar.SDK.FeedProviders.LcooVenueEntity


TextsEntity Constructor

Initializes a new instance of the TextsEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TextsEntity()
See Also

Reference

TextsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextsEntity Properties

The TextsEntity type exposes the following members.

Properties
 | Name | Description
Public property | Texts |
Top
See Also

Reference

TextsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextsEntity.Texts Property

TextsEntityTexts Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TextsEntity.Texts"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<TextEntity> Texts { get; }

Property Value

List TextEntity
See Also

Reference

TextsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextsEntity Methods

The TextsEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

TextsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TextsEntity.ToString Method

TextsEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.TextsEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.TextsEntity.ToString"]

See Also

Reference

TextsEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LcooLcooEntityBase
Sportradar.SDK.FeedProviders.LcooThreeBallEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ThreeBallEntity : LcooEntityBase

The ThreeBallEntity type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Category |
Public property | FeedType | (Inherited from LcooEntityBase)
Public property | Fixture |
Public property | Id |
Public property | MessageTime |
Public property | Odds |
Public property | Result |
Public property | Round |
Public property | Sport |
Public property | Tournament |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides LcooEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity Properties

The ThreeBallEntity type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Category |
Public property | FeedType | (Inherited from LcooEntityBase)
Public property | Fixture |
Public property | Id |
Public property | MessageTime |
Public property | Odds |
Public property | Result |
Public property | Round |
Public property | Sport |
Public property | Tournament |
Top
See Also

Reference

ThreeBallEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity.Category Property

ThreeBallEntityCategory Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEntity.Category"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CategoryEntity Category { get; }

Property Value

CategoryEntity
See Also

Reference

ThreeBallEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity.Fixture Property

ThreeBallEntityFixture Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEntity.Fixture"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public FixtureEntity Fixture { get; }

Property Value

FixtureEntity
See Also

Reference

ThreeBallEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity.Id Property

ThreeBallEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long Id { get; }

Property Value

Int64
See Also

Reference

ThreeBallEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity.MessageTime Property

ThreeBallEntityMessageTime Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEntity.MessageTime"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime? MessageTime { get; }

Property Value

Nullable DateTime
See Also

Reference

ThreeBallEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity.Odds Property

ThreeBallEntityOdds Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEntity.Odds"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<BetEntity> Odds { get; }

Property Value

List BetEntity
See Also

Reference

ThreeBallEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity.Result Property

ThreeBallEntityResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEntity.Result"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ResultEntity Result { get; }

Property Value

ResultEntity
See Also

Reference

ThreeBallEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity.Round Property

ThreeBallEntityRound Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEntity.Round"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Round { get; }

Property Value

Nullable Int64
See Also

Reference

ThreeBallEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity.Sport Property

ThreeBallEntitySport Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEntity.Sport"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SportEntity Sport { get; }

Property Value

SportEntity
See Also

Reference

ThreeBallEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity.Tournament Property

ThreeBallEntityTournament Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEntity.Tournament"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TournamentEntity Tournament { get; }

Property Value

TournamentEntity
See Also

Reference

ThreeBallEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity Methods

The ThreeBallEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides LcooEntityBaseToString)
Top
See Also

Reference

ThreeBallEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEntity.ToString Method

ThreeBallEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEntity.ToString"]

See Also

Reference

ThreeBallEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LcooThreeBallEventArgs

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ThreeBallEventArgs : EventArgs

The ThreeBallEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ThreeBallEventArgs | Initializes a new instance of the ThreeBallEventArgs class
Top
Properties
 | Name | Description
Public property | ThreeBallEntity |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEventArgs Constructor

Initializes a new instance of the ThreeBallEventArgs class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ThreeBallEventArgs()
See Also

Reference

ThreeBallEventArgs Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEventArgs Properties

The ThreeBallEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ThreeBallEntity |
Top
See Also

Reference

ThreeBallEventArgs Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEventArgs.ThreeBallEntity Property

ThreeBallEventArgsThreeBallEntity Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.ThreeBallEventArgs.ThreeBallEntity"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ThreeBallEntity ThreeBallEntity { get; }

Property Value

ThreeBallEntity
See Also

Reference

ThreeBallEventArgs Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


ThreeBallEventArgs Methods

The ThreeBallEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ThreeBallEventArgs Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TournamentEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooTextsEntity
Sportradar.SDK.FeedProviders.LcooTournamentEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class TournamentEntity : TextsEntity

The TournamentEntity type exposes the following members.

Constructors
 | Name | Description
Public method | TournamentEntity | Initializes a new instance of the TournamentEntity class
Top
Properties
 | Name | Description
Public property | Id |
Public property | SuperTournament |
Public property | Texts | (Inherited from TextsEntity)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides TextsEntityToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


TournamentEntity Constructor

Initializes a new instance of the TournamentEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TournamentEntity()
See Also

Reference

TournamentEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TournamentEntity Properties

The TournamentEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | SuperTournament |
Public property | Texts | (Inherited from TextsEntity)
Top
See Also

Reference

TournamentEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TournamentEntity.Id Property

TournamentEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

TournamentEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TournamentEntity.SuperTournament Property

TournamentEntitySuperTournament Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity.SuperTournament"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple SuperTournament { get; }

Property Value

IdNameTuple
See Also

Reference

TournamentEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TournamentEntity Methods

The TournamentEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides TextsEntityToString)
Top
See Also

Reference

TournamentEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TournamentEntity.ToString Method

TournamentEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity.ToString"]

See Also

Reference

TournamentEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TvChannelEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.TvChannelEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooTvChannelEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class TvChannelEntity

The TvChannelEntity type exposes the following members.

Constructors
 | Name | Description
Public method | TvChannelEntity | Initializes a new instance of the TvChannelEntity class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Name |
Public property | StartDate |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


TvChannelEntity Constructor

Initializes a new instance of the TvChannelEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TvChannelEntity()
See Also

Reference

TvChannelEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TvChannelEntity Properties

The TvChannelEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Name |
Public property | StartDate |
Top
See Also

Reference

TvChannelEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TvChannelEntity.Id Property

TvChannelEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TvChannelEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

TvChannelEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TvChannelEntity.Name Property

TvChannelEntityName Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TvChannelEntity.Name"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; }

Property Value

String
See Also

Reference

TvChannelEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TvChannelEntity.StartDate Property

TvChannelEntityStartDate Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.TvChannelEntity.StartDate"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime StartDate { get; }

Property Value

DateTime
See Also

Reference

TvChannelEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TvChannelEntity Methods

The TvChannelEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

TvChannelEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


TvChannelEntity.ToString Method

TvChannelEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.TvChannelEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.TvChannelEntity.ToString"]

See Also

Reference

TvChannelEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


VenueEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.VenueEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooTextsEntity
Sportradar.SDK.FeedProviders.LcooVenueEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class VenueEntity : TextsEntity

The VenueEntity type exposes the following members.

Constructors
 | Name | Description
Public method | VenueEntity | Initializes a new instance of the VenueEntity class
Top
Properties
 | Name | Description
Public property | Coordinates |
Public property | Id |
Public property | Texts | (Inherited from TextsEntity)
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides TextsEntityToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


VenueEntity Constructor

Initializes a new instance of the VenueEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public VenueEntity()
See Also

Reference

VenueEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


VenueEntity Properties

The VenueEntity type exposes the following members.

Properties
 | Name | Description
Public property | Coordinates |
Public property | Id |
Public property | Texts | (Inherited from TextsEntity)
Public property | Value |
Top
See Also

Reference

VenueEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


VenueEntity.Coordinates Property

VenueEntityCoordinates Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.VenueEntity.Coordinates"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CoordinatesEntity Coordinates { get; }

Property Value

CoordinatesEntity
See Also

Reference

VenueEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


VenueEntity.Id Property

VenueEntityId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.VenueEntity.Id"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Id { get; }

Property Value

Nullable Int64
See Also

Reference

VenueEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


VenueEntity.Value Property

VenueEntityValue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.VenueEntity.Value"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; }

Property Value

String
See Also

Reference

VenueEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


VenueEntity Methods

The VenueEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides TextsEntityToString)
Top
See Also

Reference

VenueEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


VenueEntity.ToString Method

VenueEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.VenueEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.VenueEntity.ToString"]

See Also

Reference

VenueEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


WinningOutcomeEntity Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.WinningOutcomeEntity"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LcooWinningOutcomeEntity

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class WinningOutcomeEntity

The WinningOutcomeEntity type exposes the following members.

Constructors
 | Name | Description
Public method | WinningOutcomeEntity | Initializes a new instance of the WinningOutcomeEntity class
Top
Properties
 | Name | Description
Public property | Outcome |
Public property | Reason |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo Namespace


WinningOutcomeEntity Constructor

Initializes a new instance of the WinningOutcomeEntity class

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public WinningOutcomeEntity()
See Also

Reference

WinningOutcomeEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


WinningOutcomeEntity Properties

The WinningOutcomeEntity type exposes the following members.

Properties
 | Name | Description
Public property | Outcome |
Public property | Reason |
Top
See Also

Reference

WinningOutcomeEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


WinningOutcomeEntity.Outcome Property

WinningOutcomeEntityOutcome Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.WinningOutcomeEntity.Outcome"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Outcome { get; }

Property Value

String
See Also

Reference

WinningOutcomeEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


WinningOutcomeEntity.Reason Property

WinningOutcomeEntityReason Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.WinningOutcomeEntity.Reason"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Reason { get; }

Property Value

String
See Also

Reference

WinningOutcomeEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


WinningOutcomeEntity Methods

The WinningOutcomeEntity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

WinningOutcomeEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


WinningOutcomeEntity.ToString Method

WinningOutcomeEntityToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.WinningOutcomeEntity.ToString"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.WinningOutcomeEntity.ToString"]

See Also

Reference

WinningOutcomeEntity Class
Sportradar.SDK.FeedProviders.Lcoo Namespace


Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace

Classes
 | Class | Description
Public class | LcooEntityFactory |
Public class | LcooEntityHelper |
Public class | LcooFeedDispatcher |
Public class | LcooFeedProvider |
Interfaces
 | Interface | Description
Public interface | ILcooEntityFactory |
Public interface | ILcooFeedDispatcher |


ILcooEntityFactory Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooEntityFactory"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILcooEntityFactory

The ILcooEntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildLcooEntity |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


ILcooEntityFactory Methods

The ILcooEntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildLcooEntity |
Top
See Also

Reference

ILcooEntityFactory Interface
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


ILcooEntityFactory.BuildLcooEntity Method

ILcooEntityFactoryBuildLcooEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooEntityFactory.BuildLcooEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetradarBetData)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
LcooBetDataEntity BuildLcooEntity(
    BetradarBetData input
)

Parameters

input BetradarBetData

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooEntityFactory.BuildLcooEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetradarBetData)"]

Return Value

LcooBetDataEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooEntityFactory.BuildLcooEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetradarBetData)"]

See Also

Reference

ILcooEntityFactory Interface
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


ILcooFeedDispatcher Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooFeedDispatcher"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILcooFeedDispatcher : IFeedDispatcher

The ILcooFeedDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType | (Inherited from IFeedDispatcher)
Top
Methods
 | Name | Description
Public method | DispatchEntity | (Inherited from IFeedDispatcher)
Top
Events
 | Name | Description
Public event | OnMatch |
Public event | OnOutright |
Public event | OnThreeBall |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


ILcooFeedDispatcher Properties

The ILcooFeedDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType | (Inherited from IFeedDispatcher)
Top
See Also

Reference

ILcooFeedDispatcher Interface
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


ILcooFeedDispatcher Methods

The ILcooFeedDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | DispatchEntity | (Inherited from IFeedDispatcher)
Top
See Also

Reference

ILcooFeedDispatcher Interface
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


ILcooFeedDispatcher Events

The ILcooFeedDispatcher type exposes the following members.

Events
 | Name | Description
Public event | OnMatch |
Public event | OnOutright |
Public event | OnThreeBall |
Top
See Also

Reference

ILcooFeedDispatcher Interface
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


ILcooFeedDispatcher.OnMatch Event

ILcooFeedDispatcherOnMatch Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooFeedDispatcher.OnMatch"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MatchEventOdds> OnMatch

Value

EventHandler MatchEventOdds
See Also

Reference

ILcooFeedDispatcher Interface
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


ILcooFeedDispatcher.OnOutright Event

ILcooFeedDispatcherOnOutright Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooFeedDispatcher.OnOutright"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OutrightEventOdds> OnOutright

Value

EventHandler OutrightEventOdds
See Also

Reference

ILcooFeedDispatcher Interface
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


ILcooFeedDispatcher.OnThreeBall Event

ILcooFeedDispatcherOnThreeBall Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooFeedDispatcher.OnThreeBall"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<ThreeBallEventArgs> OnThreeBall

Value

EventHandler ThreeBallEventArgs
See Also

Reference

ILcooFeedDispatcher Interface
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityFactory Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityFactory"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.Lcoo.InternalLcooEntityFactory

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LcooEntityFactory : ILcooEntityFactory

The LcooEntityFactory type exposes the following members.

Constructors
 | Name | Description
Public method | LcooEntityFactory | Initializes a new instance of the LcooEntityFactory class
Top
Methods
 | Name | Description
Public method | BuildLcooEntity |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityFactory Constructor

Initializes a new instance of the LcooEntityFactory class

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LcooEntityFactory()
See Also

Reference

LcooEntityFactory Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityFactory Methods

The LcooEntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildLcooEntity |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LcooEntityFactory Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityFactory.BuildLcooEntity Method

LcooEntityFactoryBuildLcooEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityFactory.BuildLcooEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetradarBetData)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LcooBetDataEntity BuildLcooEntity(
    BetradarBetData orig
)

Parameters

orig BetradarBetData

[Missing <param name="orig"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityFactory.BuildLcooEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetradarBetData)"]

Return Value

LcooBetDataEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityFactory.BuildLcooEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetradarBetData)"]

Implements

ILcooEntityFactoryBuildLcooEntity(BetradarBetData)
See Also

Reference

LcooEntityFactory Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.Lcoo.InternalLcooEntityHelper

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LcooEntityHelper

The LcooEntityHelper type exposes the following members.

Constructors
 | Name | Description
Public method | LcooEntityHelper | Initializes a new instance of the LcooEntityHelper class
Top
Properties
Name | Description
FixtureTimeZone |
Top
Methods
 | Name | Description
 | BuildAggregateScoreEntity |
 | BuildBetEntities |
 | BuildBetEntity(Bet) |
 | BuildBetEntity(OutrightOdds) |
 | BuildBetfairIdEntity |
 | BuildBetResultEntities |
 | BuildBetResultEntity |
 | BuildCardEntity |
 | BuildCardsEntity |
 | BuildCategoryEntity |
 | BuildCommentEntities |
 | BuildCommentEntity |
 | BuildCompetitorsEntity |
 | BuildCoordinatesEntity |
 | BuildDateInfoEntity |
 | BuildEventInfoEntity |
 | BuildEventName |
 | BuildFixtureEntity |
 | BuildGoalEntity |
 | BuildGoalsEntity |
 | BuildInfo |
 | BuildMatchEntity |
 | BuildOddsEntities |
 | BuildOddsEntity |
 | BuildOddsProbabilityEntities |
 | BuildOddsProbabilityEntity |
 | BuildOutrightEntity |
 | BuildOutrightResultEntities |
 | BuildOutrightResultEntity |
 | BuildPitcherEntity |
 | BuildPlayer1Entity |
 | BuildPlayer2Entity |
 | BuildPlayer3Entity |
 | BuildPlayer4Entity |
 | BuildPlayerEntity |
 | BuildProbabilityEntities |
 | BuildProbabilityEntity |
 | BuildResultEntity |
 | BuildRotationNumber |
 | BuildRoundInfoEntity |
 | BuildScoresInfoEntity |
 | BuildSeriesResultEntity |
 | BuildSportEntity |
 | BuildTextEntity |
 | BuildTexts |
 | BuildTextsList |
 | BuildThreeBallEntity |
 | BuildTimestamp |
 | BuildTournamentEntity |
 | BuildTvChannelEntities |
 | BuildTvChannelEntity |
 | BuildVenueEntity |
 | BuildWinningOutcomeEntity |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper Constructor

Initializes a new instance of the LcooEntityHelper class

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LcooEntityHelper()
See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper Properties

The LcooEntityHelper type exposes the following members.

Properties
Name | Description
FixtureTimeZone |
Top
See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.FixtureTimeZone Property

LcooEntityHelperFixtureTimeZone Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.FixtureTimeZone"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static string FixtureTimeZone { get; set; }

Property Value

String
See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper Methods

The LcooEntityHelper type exposes the following members.

Methods
 | Name | Description
 | BuildAggregateScoreEntity |
 | BuildBetEntities |
 | BuildBetEntity(Bet) |
 | BuildBetEntity(OutrightOdds) |
 | BuildBetfairIdEntity |
 | BuildBetResultEntities |
 | BuildBetResultEntity |
 | BuildCardEntity |
 | BuildCardsEntity |
 | BuildCategoryEntity |
 | BuildCommentEntities |
 | BuildCommentEntity |
 | BuildCompetitorsEntity |
 | BuildCoordinatesEntity |
 | BuildDateInfoEntity |
 | BuildEventInfoEntity |
 | BuildEventName |
 | BuildFixtureEntity |
 | BuildGoalEntity |
 | BuildGoalsEntity |
 | BuildInfo |
 | BuildMatchEntity |
 | BuildOddsEntities |
 | BuildOddsEntity |
 | BuildOddsProbabilityEntities |
 | BuildOddsProbabilityEntity |
 | BuildOutrightEntity |
 | BuildOutrightResultEntities |
 | BuildOutrightResultEntity |
 | BuildPitcherEntity |
 | BuildPlayer1Entity |
 | BuildPlayer2Entity |
 | BuildPlayer3Entity |
 | BuildPlayer4Entity |
 | BuildPlayerEntity |
 | BuildProbabilityEntities |
 | BuildProbabilityEntity |
 | BuildResultEntity |
 | BuildRotationNumber |
 | BuildRoundInfoEntity |
 | BuildScoresInfoEntity |
 | BuildSeriesResultEntity |
 | BuildSportEntity |
 | BuildTextEntity |
 | BuildTexts |
 | BuildTextsList |
 | BuildThreeBallEntity |
 | BuildTimestamp |
 | BuildTournamentEntity |
 | BuildTvChannelEntities |
 | BuildTvChannelEntity |
 | BuildVenueEntity |
 | BuildWinningOutcomeEntity |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildAggregateScoreEntity Method

LcooEntityHelperBuildAggregateScoreEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildAggregateScoreEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.AggregateScore)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static AggregateScoreEntity BuildAggregateScoreEntity(
    AggregateScore aggregate_score
)

Parameters

aggregate_score AggregateScore

[Missing <param name="aggregate_score"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildAggregateScoreEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.AggregateScore)"]

Return Value

AggregateScoreEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildAggregateScoreEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.AggregateScore)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildBetEntities Method

LcooEntityHelperBuildBetEntities Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.MatchOdds)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static List<BetEntity> BuildBetEntities(
    MatchOdds odds
)

Parameters

odds MatchOdds

[Missing <param name="odds"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.MatchOdds)"]

Return Value

List BetEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.MatchOdds)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildBetEntity Method

LcooEntityHelperBuildBetEntity Method

Overload List
Name | Description
BuildBetEntity(Bet) |
BuildBetEntity(OutrightOdds) |
Top
See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildBetEntity(Bet) Method

LcooEntityHelperBuildBetEntity(Bet) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Bet)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static BetEntity BuildBetEntity(
    Bet bet
)

Parameters

bet Bet

[Missing <param name="bet"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Bet)"]

Return Value

BetEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Bet)"]

See Also

Reference

LcooEntityHelper Class
BuildBetEntity Overload
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildBetEntity(OutrightOdds) Method

LcooEntityHelperBuildBetEntity(OutrightOdds) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.OutrightOdds)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static BetEntity BuildBetEntity(
    OutrightOdds odd
)

Parameters

odd OutrightOdds

[Missing <param name="odd"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.OutrightOdds)"]

Return Value

BetEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.OutrightOdds)"]

See Also

Reference

LcooEntityHelper Class
BuildBetEntity Overload
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildBetfairIdEntity Method

LcooEntityHelperBuildBetfairIdEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetfairIdEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetfairIDs)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static BetfairIdEntity BuildBetfairIdEntity(
    BetfairIDs betfair
)

Parameters

betfair BetfairIDs

[Missing <param name="betfair"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetfairIdEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetfairIDs)"]

Return Value

BetfairIdEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetfairIdEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetfairIDs)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildBetResultEntities Method

LcooEntityHelperBuildBetResultEntities Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetResultEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetResultW[])"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static List<BetResultEntity> BuildBetResultEntities(
    BetResultW[] bet_results
)

Parameters

bet_results BetResultW

[Missing <param name="bet_results"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetResultEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetResultW[])"]

Return Value

List BetResultEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetResultEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetResultW[])"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildBetResultEntity Method

LcooEntityHelperBuildBetResultEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetResultEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetResultW)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static BetResultEntity BuildBetResultEntity(
    BetResultW input
)

Parameters

input BetResultW

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetResultEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetResultW)"]

Return Value

BetResultEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildBetResultEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.BetResultW)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildCardEntity Method

LcooEntityHelperBuildCardEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCardEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.CardsCard)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static CardEntity BuildCardEntity(
    CardsCard card
)

Parameters

card CardsCard

[Missing <param name="card"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCardEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.CardsCard)"]

Return Value

CardEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCardEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.CardsCard)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildCardsEntity Method

LcooEntityHelperBuildCardsEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCardsEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Cards)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static CardsEntity BuildCardsEntity(
    Cards cards
)

Parameters

cards Cards

[Missing <param name="cards"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCardsEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Cards)"]

Return Value

CardsEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCardsEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Cards)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildCategoryEntity Method

LcooEntityHelperBuildCategoryEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCategoryEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Category)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static CategoryEntity BuildCategoryEntity(
    Category category
)

Parameters

category Category

[Missing <param name="category"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCategoryEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Category)"]

Return Value

CategoryEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCategoryEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Category)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildCommentEntities Method

LcooEntityHelperBuildCommentEntities Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCommentEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Comment[])"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static List<CommentEntity> BuildCommentEntities(
    Comment[] comments
)

Parameters

comments Comment

[Missing <param name="comments"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCommentEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Comment[])"]

Return Value

List CommentEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCommentEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Comment[])"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildCommentEntity Method

LcooEntityHelperBuildCommentEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCommentEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Comment)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static CommentEntity BuildCommentEntity(
    Comment comment
)

Parameters

comment Comment

[Missing <param name="comment"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCommentEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Comment)"]

Return Value

CommentEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCommentEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Comment)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildCompetitorsEntity Method

LcooEntityHelperBuildCompetitorsEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCompetitorsEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Competitors)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static CompetitorsEntity BuildCompetitorsEntity(
    Competitors competitors
)

Parameters

competitors Competitors

[Missing <param name="competitors"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCompetitorsEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Competitors)"]

Return Value

CompetitorsEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCompetitorsEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Competitors)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildCoordinatesEntity Method

LcooEntityHelperBuildCoordinatesEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCoordinatesEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Coordinates)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static CoordinatesEntity BuildCoordinatesEntity(
    Coordinates coordinates
)

Parameters

coordinates Coordinates

[Missing <param name="coordinates"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCoordinatesEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Coordinates)"]

Return Value

CoordinatesEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildCoordinatesEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Coordinates)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildDateInfoEntity Method

LcooEntityHelperBuildDateInfoEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildDateInfoEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.DateInfo)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static DateInfoEntity BuildDateInfoEntity(
    DateInfo date_info
)

Parameters

date_info DateInfo

[Missing <param name="date_info"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildDateInfoEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.DateInfo)"]

Return Value

DateInfoEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildDateInfoEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.DateInfo)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildEventInfoEntity Method

LcooEntityHelperBuildEventInfoEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildEventInfoEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.EventInfo)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static EventInfoEntity BuildEventInfoEntity(
    EventInfo event_info
)

Parameters

event_info EventInfo

[Missing <param name="event_info"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildEventInfoEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.EventInfo)"]

Return Value

EventInfoEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildEventInfoEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.EventInfo)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildEventName Method

LcooEntityHelperBuildEventName Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildEventName(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.EventName)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static TextsEntity BuildEventName(
    EventName event_name
)

Parameters

event_name EventName

[Missing <param name="event_name"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildEventName(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.EventName)"]

Return Value

TextsEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildEventName(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.EventName)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildFixtureEntity Method

LcooEntityHelperBuildFixtureEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildFixtureEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Fixture)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static FixtureEntity BuildFixtureEntity(
    Fixture fixture
)

Parameters

fixture Fixture

[Missing <param name="fixture"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildFixtureEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Fixture)"]

Return Value

FixtureEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildFixtureEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Fixture)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildGoalEntity Method

LcooEntityHelperBuildGoalEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildGoalEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.GoalsGoal)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static GoalEntity BuildGoalEntity(
    GoalsGoal goal
)

Parameters

goal GoalsGoal

[Missing <param name="goal"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildGoalEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.GoalsGoal)"]

Return Value

GoalEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildGoalEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.GoalsGoal)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildGoalsEntity Method

LcooEntityHelperBuildGoalsEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildGoalsEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Goals)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static GoalsEntity BuildGoalsEntity(
    Goals goals
)

Parameters

goals Goals

[Missing <param name="goals"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildGoalsEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Goals)"]

Return Value

GoalsEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildGoalsEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Goals)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildInfo Method

LcooEntityHelperBuildInfo Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Info)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static TypeValueTuple BuildInfo(
    Info info
)

Parameters

info Info

[Missing <param name="info"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Info)"]

Return Value

TypeValueTuple

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Info)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildMatchEntity Method

LcooEntityHelperBuildMatchEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildMatchEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Match,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static MatchEntity BuildMatchEntity(
    Match match,
    FeedType? feed_type,
    DateTime? message_time,
    SportEntity sport,
    CategoryEntity category,
    TournamentEntity tournament
)

Parameters

match Match

[Missing <param name="match"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildMatchEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Match,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

feed_type Nullable FeedType

[Missing <param name="feed_type"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildMatchEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Match,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

message_time Nullable DateTime

[Missing <param name="message_time"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildMatchEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Match,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

sport SportEntity

[Missing <param name="sport"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildMatchEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Match,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

category CategoryEntity

[Missing <param name="category"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildMatchEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Match,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

tournament TournamentEntity

[Missing <param name="tournament"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildMatchEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Match,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

Return Value

MatchEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildMatchEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Match,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildOddsEntities Method

LcooEntityHelperBuildOddsEntities Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOddsEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Odds[])"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static List<OddsEntity> BuildOddsEntities(
    Odds[] odds
)

Parameters

odds Odds

[Missing <param name="odds"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOddsEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Odds[])"]

Return Value

List OddsEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOddsEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Odds[])"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildOddsEntity Method

LcooEntityHelperBuildOddsEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOddsEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Odds)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static OddsEntity BuildOddsEntity(
    Odds odds
)

Parameters

odds Odds

[Missing <param name="odds"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOddsEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Odds)"]

Return Value

OddsEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOddsEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Odds)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildOddsProbabilityEntities Method

LcooEntityHelperBuildOddsProbabilityEntities Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOddsProbabilityEntities(System.Collections.Generic.List{Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.P})"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static List<OddsProbabilityEntity> BuildOddsProbabilityEntities(
    List<P> p_list
)

Parameters

p_list List P

[Missing <param name="p_list"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOddsProbabilityEntities(System.Collections.Generic.List{Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.P})"]

Return Value

List OddsProbabilityEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOddsProbabilityEntities(System.Collections.Generic.List{Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.P})"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildOddsProbabilityEntity Method

LcooEntityHelperBuildOddsProbabilityEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOddsProbabilityEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.P)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static OddsProbabilityEntity BuildOddsProbabilityEntity(
    P p
)

Parameters

p P

[Missing <param name="p"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOddsProbabilityEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.P)"]

Return Value

OddsProbabilityEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOddsProbabilityEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.P)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildOutrightEntity Method

LcooEntityHelperBuildOutrightEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Outright,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static OutrightEntity BuildOutrightEntity(
    Outright outright,
    FeedType? feed_type,
    DateTime? message_time,
    SportEntity sport_entity,
    CategoryEntity category
)

Parameters

outright Outright

[Missing <param name="outright"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Outright,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity)"]

feed_type Nullable FeedType

[Missing <param name="feed_type"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Outright,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity)"]

message_time Nullable DateTime

[Missing <param name="message_time"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Outright,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity)"]

sport_entity SportEntity

[Missing <param name="sport_entity"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Outright,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity)"]

category CategoryEntity

[Missing <param name="category"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Outright,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity)"]

Return Value

OutrightEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Outright,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildOutrightResultEntities Method

LcooEntityHelperBuildOutrightResultEntities Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightResultEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.OutrightResultResult[])"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static List<OutrightResultEntity> BuildOutrightResultEntities(
    OutrightResultResult[] results
)

Parameters

results OutrightResultResult

[Missing <param name="results"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightResultEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.OutrightResultResult[])"]

Return Value

List OutrightResultEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightResultEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.OutrightResultResult[])"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildOutrightResultEntity Method

LcooEntityHelperBuildOutrightResultEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightResultEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.OutrightResultResult)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static OutrightResultEntity BuildOutrightResultEntity(
    OutrightResultResult result
)

Parameters

result OutrightResultResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightResultEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.OutrightResultResult)"]

Return Value

OutrightResultEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildOutrightResultEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.OutrightResultResult)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildPitcherEntity Method

LcooEntityHelperBuildPitcherEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPitcherEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Pitcher)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static HomeAway<PitcherEntity> BuildPitcherEntity(
    Pitcher pitcher
)

Parameters

pitcher Pitcher

[Missing <param name="pitcher"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPitcherEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Pitcher)"]

Return Value

HomeAway PitcherEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPitcherEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Pitcher)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildPlayer1Entity Method

LcooEntityHelperBuildPlayer1Entity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayer1Entity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Player1)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static PlayerEntity BuildPlayer1Entity(
    Player1 player
)

Parameters

player Player1

[Missing <param name="player"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayer1Entity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Player1)"]

Return Value

PlayerEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayer1Entity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Player1)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildPlayer2Entity Method

LcooEntityHelperBuildPlayer2Entity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayer2Entity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Player2)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static PlayerEntity BuildPlayer2Entity(
    Player2 player
)

Parameters

player Player2

[Missing <param name="player"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayer2Entity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Player2)"]

Return Value

PlayerEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayer2Entity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Player2)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildPlayer3Entity Method

LcooEntityHelperBuildPlayer3Entity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayer3Entity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Player3)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static PlayerEntity BuildPlayer3Entity(
    Player3 player
)

Parameters

player Player3

[Missing <param name="player"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayer3Entity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Player3)"]

Return Value

PlayerEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayer3Entity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Player3)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildPlayer4Entity Method

LcooEntityHelperBuildPlayer4Entity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayer4Entity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Player4)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static PlayerEntity BuildPlayer4Entity(
    Player4 player
)

Parameters

player Player4

[Missing <param name="player"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayer4Entity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Player4)"]

Return Value

PlayerEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayer4Entity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Player4)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildPlayerEntity Method

LcooEntityHelperBuildPlayerEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayerEntity(System.Collections.Generic.List{Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Text},System.String,System.Nullable{System.Int32},System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static PlayerEntity BuildPlayerEntity(
    List<Text> texts,
    string value,
    int? superid,
    int id
)

Parameters

texts List Text

[Missing <param name="texts"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayerEntity(System.Collections.Generic.List{Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Text},System.String,System.Nullable{System.Int32},System.Int32)"]

value String

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayerEntity(System.Collections.Generic.List{Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Text},System.String,System.Nullable{System.Int32},System.Int32)"]

superid Nullable Int32

[Missing <param name="superid"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayerEntity(System.Collections.Generic.List{Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Text},System.String,System.Nullable{System.Int32},System.Int32)"]

id Int32

[Missing <param name="id"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayerEntity(System.Collections.Generic.List{Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Text},System.String,System.Nullable{System.Int32},System.Int32)"]

Return Value

PlayerEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildPlayerEntity(System.Collections.Generic.List{Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Text},System.String,System.Nullable{System.Int32},System.Int32)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildProbabilityEntities Method

LcooEntityHelperBuildProbabilityEntities Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildProbabilityEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Probabilities)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static List<ProbabilityEntity> BuildProbabilityEntities(
    Probabilities probabilities
)

Parameters

probabilities Probabilities

[Missing <param name="probabilities"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildProbabilityEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Probabilities)"]

Return Value

List ProbabilityEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildProbabilityEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Probabilities)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildProbabilityEntity Method

LcooEntityHelperBuildProbabilityEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildProbabilityEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.PR)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static ProbabilityEntity BuildProbabilityEntity(
    PR probability
)

Parameters

probability PR

[Missing <param name="probability"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildProbabilityEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.PR)"]

Return Value

ProbabilityEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildProbabilityEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.PR)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildResultEntity Method

LcooEntityHelperBuildResultEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildResultEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Result)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static ResultEntity BuildResultEntity(
    Result result
)

Parameters

result Result

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildResultEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Result)"]

Return Value

ResultEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildResultEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Result)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildRotationNumber Method

LcooEntityHelperBuildRotationNumber Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildRotationNumber(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.RotationNumber)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static HomeAway<long?> BuildRotationNumber(
    RotationNumber rotation_number
)

Parameters

rotation_number RotationNumber

[Missing <param name="rotation_number"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildRotationNumber(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.RotationNumber)"]

Return Value

HomeAway Nullable Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildRotationNumber(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.RotationNumber)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildRoundInfoEntity Method

LcooEntityHelperBuildRoundInfoEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildRoundInfoEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.RoundInfo)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static RoundInfoEntity BuildRoundInfoEntity(
    RoundInfo round_info
)

Parameters

round_info RoundInfo

[Missing <param name="round_info"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildRoundInfoEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.RoundInfo)"]

Return Value

RoundInfoEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildRoundInfoEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.RoundInfo)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildScoresInfoEntity Method

LcooEntityHelperBuildScoresInfoEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildScoresInfoEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.ScoreInfo)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static ScoresInfoEntity BuildScoresInfoEntity(
    ScoreInfo score_info
)

Parameters

score_info ScoreInfo

[Missing <param name="score_info"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildScoresInfoEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.ScoreInfo)"]

Return Value

ScoresInfoEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildScoresInfoEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.ScoreInfo)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildSeriesResultEntity Method

LcooEntityHelperBuildSeriesResultEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildSeriesResultEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.SeriesResult)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static SeriesResultEntity BuildSeriesResultEntity(
    SeriesResult series_result
)

Parameters

series_result SeriesResult

[Missing <param name="series_result"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildSeriesResultEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.SeriesResult)"]

Return Value

SeriesResultEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildSeriesResultEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.SeriesResult)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildSportEntity Method

LcooEntityHelperBuildSportEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildSportEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Sport)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static SportEntity BuildSportEntity(
    Sport sport
)

Parameters

sport Sport

[Missing <param name="sport"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildSportEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Sport)"]

Return Value

SportEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildSportEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Sport)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildTextEntity Method

LcooEntityHelperBuildTextEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTextEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Text)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static TextEntity BuildTextEntity(
    Text text
)

Parameters

text Text

[Missing <param name="text"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTextEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Text)"]

Return Value

TextEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTextEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Text)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildTexts Method

LcooEntityHelperBuildTexts Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTexts(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Text[])"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static List<TextEntity> BuildTexts(
    Text[] texts
)

Parameters

texts Text

[Missing <param name="texts"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTexts(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Text[])"]

Return Value

List TextEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTexts(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Text[])"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildTextsList Method

LcooEntityHelperBuildTextsList Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTextsList(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Texts[])"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static List<TextsEntity> BuildTextsList(
    Texts[] texts
)

Parameters

texts Texts

[Missing <param name="texts"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTextsList(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Texts[])"]

Return Value

List TextsEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTextsList(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Texts[])"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildThreeBallEntity Method

LcooEntityHelperBuildThreeBallEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildThreeBallEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.ThreeBall,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static ThreeBallEntity BuildThreeBallEntity(
    ThreeBall three_ball,
    FeedType? feed_type,
    DateTime? message_time,
    SportEntity sport,
    CategoryEntity category,
    TournamentEntity tournament
)

Parameters

three_ball ThreeBall

[Missing <param name="three_ball"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildThreeBallEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.ThreeBall,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

feed_type Nullable FeedType

[Missing <param name="feed_type"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildThreeBallEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.ThreeBall,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

message_time Nullable DateTime

[Missing <param name="message_time"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildThreeBallEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.ThreeBall,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

sport SportEntity

[Missing <param name="sport"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildThreeBallEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.ThreeBall,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

category CategoryEntity

[Missing <param name="category"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildThreeBallEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.ThreeBall,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

tournament TournamentEntity

[Missing <param name="tournament"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildThreeBallEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.ThreeBall,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

Return Value

ThreeBallEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildThreeBallEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.ThreeBall,System.Nullable{Sportradar.SDK.FeedProviders.Lcoo.FeedType},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.Lcoo.SportEntity,Sportradar.SDK.FeedProviders.Lcoo.CategoryEntity,Sportradar.SDK.FeedProviders.Lcoo.TournamentEntity)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildTimestamp Method

LcooEntityHelperBuildTimestamp Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTimestamp(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Timestamp)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static DateTime? BuildTimestamp(
    Timestamp timestamp
)

Parameters

timestamp Timestamp

[Missing <param name="timestamp"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTimestamp(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Timestamp)"]

Return Value

Nullable DateTime

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTimestamp(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Timestamp)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildTournamentEntity Method

LcooEntityHelperBuildTournamentEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTournamentEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Tournament)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static TournamentEntity BuildTournamentEntity(
    Tournament tournament
)

Parameters

tournament Tournament

[Missing <param name="tournament"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTournamentEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Tournament)"]

Return Value

TournamentEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTournamentEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Tournament)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildTvChannelEntities Method

LcooEntityHelperBuildTvChannelEntities Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTvChannelEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.TVChannelInfo)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static List<TvChannelEntity> BuildTvChannelEntities(
    TVChannelInfo tv_channels
)

Parameters

tv_channels TVChannelInfo

[Missing <param name="tv_channels"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTvChannelEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.TVChannelInfo)"]

Return Value

List TvChannelEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTvChannelEntities(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.TVChannelInfo)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildTvChannelEntity Method

LcooEntityHelperBuildTvChannelEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTvChannelEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.MatchOnTV)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static TvChannelEntity BuildTvChannelEntity(
    MatchOnTV tv_channel
)

Parameters

tv_channel MatchOnTV

[Missing <param name="tv_channel"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTvChannelEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.MatchOnTV)"]

Return Value

TvChannelEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildTvChannelEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.MatchOnTV)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildVenueEntity Method

LcooEntityHelperBuildVenueEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildVenueEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Venue)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static VenueEntity BuildVenueEntity(
    Venue venue
)

Parameters

venue Venue

[Missing <param name="venue"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildVenueEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Venue)"]

Return Value

VenueEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildVenueEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.Venue)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooEntityHelper.BuildWinningOutcomeEntity Method

LcooEntityHelperBuildWinningOutcomeEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildWinningOutcomeEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.W)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static WinningOutcomeEntity BuildWinningOutcomeEntity(
    W outcome
)

Parameters

outcome W

[Missing <param name="outcome"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildWinningOutcomeEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.W)"]

Return Value

WinningOutcomeEntity

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooEntityHelper.BuildWinningOutcomeEntity(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LCoO.Incoming.W)"]

See Also

Reference

LcooEntityHelper Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedDispatcher Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedDispatcher"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.Lcoo.InternalLcooFeedDispatcher

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LcooFeedDispatcher : ILcooFeedDispatcher,
    IFeedDispatcher

The LcooFeedDispatcher type exposes the following members.

Constructors
 | Name | Description
Public method | LcooFeedDispatcher | Initializes a new instance of the LcooFeedDispatcher class
Top
Properties
 | Name | Description
Public property | ProviderType |
Top
Methods
 | Name | Description
Public method | DispatchEntity |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | OnMatch |
Public event | OnOutright |
Public event | OnThreeBall |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedDispatcher Constructor

Initializes a new instance of the LcooFeedDispatcher class

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LcooFeedDispatcher(
    ISdkLogger sdk_logger,
    ProtocolProviderType provider_type
)

Parameters

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedDispatcher.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.Common.ProtocolProviderType)"]

provider_type ProtocolProviderType

[Missing <param name="provider_type"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedDispatcher.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.Common.ProtocolProviderType)"]

See Also

Reference

LcooFeedDispatcher Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedDispatcher Properties

The LcooFeedDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType |
Top
See Also

Reference

LcooFeedDispatcher Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedDispatcher.ProviderType Property

LcooFeedDispatcherProviderType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedDispatcher.ProviderType"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType

Implements

IFeedDispatcherProviderType
See Also

Reference

LcooFeedDispatcher Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedDispatcher Methods

The LcooFeedDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | DispatchEntity |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LcooFeedDispatcher Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedDispatcher.DispatchEntity Method

LcooFeedDispatcherDispatchEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedDispatcher.DispatchEntity(Sportradar.SDK.Common.EntityBase)"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DispatchStatus DispatchEntity(
    EntityBase entity
)

Parameters

entity EntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedDispatcher.DispatchEntity(Sportradar.SDK.Common.EntityBase)"]

Return Value

DispatchStatus

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedDispatcher.DispatchEntity(Sportradar.SDK.Common.EntityBase)"]

Implements

IFeedDispatcherDispatchEntity(EntityBase)
See Also

Reference

LcooFeedDispatcher Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedDispatcher Events

The LcooFeedDispatcher type exposes the following members.

Events
 | Name | Description
Public event | OnMatch |
Public event | OnOutright |
Public event | OnThreeBall |
Top
See Also

Reference

LcooFeedDispatcher Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedDispatcher.OnMatch Event

LcooFeedDispatcherOnMatch Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedDispatcher.OnMatch"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<MatchEventOdds> OnMatch

Value

EventHandler MatchEventOdds

Implements

ILcooFeedDispatcherOnMatch
See Also

Reference

LcooFeedDispatcher Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedDispatcher.OnOutright Event

LcooFeedDispatcherOnOutright Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedDispatcher.OnOutright"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<OutrightEventOdds> OnOutright

Value

EventHandler OutrightEventOdds

Implements

ILcooFeedDispatcherOnOutright
See Also

Reference

LcooFeedDispatcher Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedDispatcher.OnThreeBall Event

LcooFeedDispatcherOnThreeBall Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedDispatcher.OnThreeBall"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<ThreeBallEventArgs> OnThreeBall

Value

EventHandler ThreeBallEventArgs

Implements

ILcooFeedDispatcherOnThreeBall
See Also

Reference

LcooFeedDispatcher Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedProvider Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.Lcoo.InternalLcooFeedProvider

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LcooFeedProvider : ILcoo,
    IStartable

The LcooFeedProvider type exposes the following members.

Constructors
 | Name | Description
Public method | LcooFeedProvider | Initializes a new instance of the LcooFeedProvider class
Top
Methods
 | Name | Description
Public method | ClearQueue |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Refresh |
Public method | Start |
Public method | Stop |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | OnMatch |
Public event | OnOutright |
Public event | OnThreeBall |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedProvider Constructor

Initializes a new instance of the LcooFeedProvider class

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LcooFeedProvider(
    ILcooProtocolProvider protocol_provider,
    ILcooFeedDispatcher feed_dispatcher,
    IMessageDispatcher message_dispatcher,
    ILcooEntityFactory entity_factory,
    ISdkLogger sdk_logger
)

Parameters

protocol_provider ILcooProtocolProvider

[Missing <param name="protocol_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider.#ctor(Sportradar.SDK.ProtocolProviders.ILcooProtocolProvider,Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooFeedDispatcher,Sportradar.SDK.Common.Interfaces.IMessageDispatcher,Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooEntityFactory,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_dispatcher ILcooFeedDispatcher

[Missing <param name="feed_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider.#ctor(Sportradar.SDK.ProtocolProviders.ILcooProtocolProvider,Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooFeedDispatcher,Sportradar.SDK.Common.Interfaces.IMessageDispatcher,Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooEntityFactory,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

message_dispatcher IMessageDispatcher

[Missing <param name="message_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider.#ctor(Sportradar.SDK.ProtocolProviders.ILcooProtocolProvider,Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooFeedDispatcher,Sportradar.SDK.Common.Interfaces.IMessageDispatcher,Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooEntityFactory,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

entity_factory ILcooEntityFactory

[Missing <param name="entity_factory"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider.#ctor(Sportradar.SDK.ProtocolProviders.ILcooProtocolProvider,Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooFeedDispatcher,Sportradar.SDK.Common.Interfaces.IMessageDispatcher,Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooEntityFactory,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider.#ctor(Sportradar.SDK.ProtocolProviders.ILcooProtocolProvider,Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooFeedDispatcher,Sportradar.SDK.Common.Interfaces.IMessageDispatcher,Sportradar.SDK.FeedProviders.Lcoo.Internal.ILcooEntityFactory,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

LcooFeedProvider Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedProvider Methods

The LcooFeedProvider type exposes the following members.

Methods
 | Name | Description
Public method | ClearQueue |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Refresh |
Public method | Start |
Public method | Stop |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LcooFeedProvider Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedProvider.ClearQueue Method

LcooFeedProviderClearQueue Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider.ClearQueue"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void ClearQueue()

Implements

ILcooClearQueue
See Also

Reference

LcooFeedProvider Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedProvider.Refresh Method

LcooFeedProviderRefresh Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider.Refresh"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Refresh()

Implements

ILcooRefresh
See Also

Reference

LcooFeedProvider Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedProvider.Start Method

LcooFeedProviderStart Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider.Start"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Start()

Implements

IStartableStart
See Also

Reference

LcooFeedProvider Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedProvider.Stop Method

LcooFeedProviderStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider.Stop"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Stop()

Implements

IStartableStop
See Also

Reference

LcooFeedProvider Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedProvider Events

The LcooFeedProvider type exposes the following members.

Events
 | Name | Description
Public event | OnMatch |
Public event | OnOutright |
Public event | OnThreeBall |
Top
See Also

Reference

LcooFeedProvider Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedProvider.OnMatch Event

LcooFeedProviderOnMatch Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider.OnMatch"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<MatchEventOdds> OnMatch

Value

EventHandler MatchEventOdds

Implements

ILcooOnMatch
See Also

Reference

LcooFeedProvider Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedProvider.OnOutright Event

LcooFeedProviderOnOutright Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider.OnOutright"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<OutrightEventOdds> OnOutright

Value

EventHandler OutrightEventOdds

Implements

ILcooOnOutright
See Also

Reference

LcooFeedProvider Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


LcooFeedProvider.OnThreeBall Event

LcooFeedProviderOnThreeBall Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.Lcoo.Internal.LcooFeedProvider.OnThreeBall"]

Namespace: Sportradar.SDK.FeedProviders.Lcoo.Internal
Assembly: LcooFeedProvider (in LcooFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<ThreeBallEventArgs> OnThreeBall

Value

EventHandler ThreeBallEventArgs

Implements

ILcooOnThreeBall
See Also

Reference

LcooFeedProvider Class
Sportradar.SDK.FeedProviders.Lcoo.Internal Namespace


Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace

Classes
Class | Description
Public class Alive

Betradar system sends Alive message every 10 seconds so that a bookmaker client can be sure that it has a working connection to the Betradar system at all times.

This message contains status, timestamp in UTC, and empty Match elements to identify the events that Betradar system supplies live odds for at the given time. Every event element also contains betstatus information ("started" or "stopped").

Score information included with the event indicates the current score in the event while the msgnr indicates the number of the last message sent for this event.

Public class | AliveEventArgs | Event arguments passed with OnAlive.
Public class | BaseWaiter
Public class | BetCancel | Indicates that an odds type for a match has been cancelled for a reason. All bets accepted on the odds with that id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the StartTime and EndTime are set, only bets accepted in this interval should be cancelled.
Public class | BetCancelEventArgs | Event arguments passed with OnBetCancel.
Public class | BetCancelUndo | Indicates undo of some previous bet cancellation when for some reason an odds type has been cancelled when it shouldn’t have been. Odds element will match the Odds element of the corresponding “cancelbet" message. StartTime and EndTime will also match the values from the previous “cancelbet" message.
Public class | BetCancelUndoEventArgs | Event arguments passed with OnBetCancelUndo.
Public class BetClear

Indicates that a situation occurred during the match so that a bet can be decided. Time which is set to (Timestamp - Time) seconds indicates the time at which the event happened. The message also includes the match element indicating the match id and the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField and the status of the outcomes.

Some bet types, like Asian handicap and Asian total, can also include void factor for each EventOddsField element. Void factor can either be 1 or 0.5 indicating that the whole or half the bet is voided and should be refunded to the customer. When the void factor is set to 0.5 the outcome attribute will indicate if the other half is won or lost.

The id attribute in the Odds element corresponds to the odds elements in the previously sent out odds change messages. Evaluation of bet outcomes is responsibility of the client.

Public class | BetClearEventArgs | Event arguments passed with OnBetClear.
Public class | BetClearRollback | Indicates that a wrong information was sent out about a bet clearing and that previous bet clear should be rolled back now. Odds identified by corresponding ids tell what odds the bet clear rollback is for. ClearedScore will be set to the cleared score of the original bet clearing. The time for the original bet clearing is (Timestamp - Time) seconds. The odds element also includes odds field elements to indicate what field was cleared in the original bet clearing. The client is responsible to handle this accordingly.
Public class | BetClearRollbackEventArgs | Event arguments passed with OnBetClearRollback.
Public class | BetStart | Indicates that the bets for a particular match can open again. The message contains s Timestamp and also a Time attribute which tells when the situation occurred in seconds before the Timestamp. If time is 0, bet start is from timestamp, if time > 0, bet start is from (Timestamp - Time). Score indicates the current score in the match.
Public class | BetStartEventArgs | Event arguments passed with OnBetStart.
Public class | BetStop | Indicates that a betstop situation occurred during a match (e.g. goal, red card or other important event occurred). When the bets can open again, a "betstart" message will be sent. Bet stop message contains Timestamp and also a Time attribute which tells when the situation occurred in seconds before the Timestamp. If time is 0 betstop is from timestamp, if time > 0, betstop is from (Timestamp - Time). Score indicates the current score in the match.
Public class | BetStopEventArgs | Event arguments passed with OnBetStop.
Public class | BetStopReason | Reason abut a bet stop.
Public class | BookmatchWaiter
Public class | CurrentWaiter
Public class | ErrorWaiter
Public class | EventBetStatus | Bet status
Public class | EventDataReceivedEventArgs | Event arguments passed with OnEventMessages and OnEventStatus.
Public class | EventHeader | Contains core data about an event. Base class for RaceHeader and MatchHeader
Public class | EventOdds | Match odds and corresponding odd fields.
Public class | EventOddsField | Match odds field specifying each outcome for a specific odds type. Only odds types that are active contain odds fields.
Public class | EventOddsLite | Match odds used for bet type registration request (i.e. activation and deactivation of odds types and fields).
Public class | EventOddsType | Event odds type
Public class | EventStatus | Event status as used by Live Odds.
Public class | IrrelevantOddsChange | Indicates that a change occurred which should be of no interest to the client. This could for example be bet clearing of an odds type which is unsubscribed. If this is not set, then an odds update is sent instead.
Public class | MetaInfo | Contains event meta-information in response to client meta request or when a event is added to the system or when a event has been cancelled.
Public class | MetaInfoDataContainer | Base class for data contained in MetaInfo. Classes extending this one are LiveOddsMetaData and RaceMetaData
Public class | MetaInfoEventArgs | Event arguments passed with OnMetaInfo.
Public class | MetaInfoReply | Asynchronous response wrapper for the GetMatchListAsync method.
Public class | MetaWaiter
Public class | OddsChange | When an odds change occurs, all the odds types for that match are sent in a message. Only active odds types contain odds fields, while inactive odds types do not. Each odds type also has an attribute named changed which indicates whether this odds type has been changed or not. An attribute score indicates the current score in the match.
Public class | OddsChangeEventArgs | Event arguments passed with OnOddsChange.
Public class | OddsEntityBase | Serves as a base class that all LiveOdds entities should be derived from.
Public class | OddsMatchEarlyBetStatus | Early bet status
Public class | OddsReplyType | Message reply type that identifies the type of message coming from betradar.com. This attribute is used for replies to error, current, unregister, register and score requests from clients.
Public class | OddsServerType | Live odds feed server type
Public class | OddsStatus | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.)
Public class | OddsTypeFieldStatus | Odds field status used during bet type registration.
Public class | RaceResultEventArgs | Event arguments passed with OnRaceResult.
Public class | ReplyStartEnd | Reply start and reply end messages can be used to easier group the response messages together and to know when a new response starts and ends.
Public class | ScoreCardSummaryEventArgs | Event arguments passed with OnScoreCardSummary.
Public class | ScoreCardWaiter
Public class | SingleHeaderEvent | Base class for all events that regard only one event
Public class | SingleHeaderWithOddsEvent | Base class for all events that regard only one event and contain odds
Public class | SubscriptionWaiter
Public class | UserRequest | Use requests.
Public class | UserRequestUserRequestTarget
Interfaces
 | Interface | Description
Public interface | ILiveOddsCommon | Interface describing events and methods common for all LiveOdds feeds which do not contain outrights
Public interface | ILiveOddsCommonBase | Interface describing events and methods common for all LiveOdds feeds


Alive Class

Betradar system sends Alive message every 10 seconds so that a bookmaker client can be sure that it has a working connection to the Betradar system at all times.

This message contains status, timestamp in UTC, and empty Match elements to identify the events that Betradar system supplies live odds for at the given time. Every event element also contains betstatus information ("started" or "stopped").

Score information included with the event indicates the current score in the event while the msgnr indicates the number of the last message sent for this event.

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonAlive
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsAliveWithOutrights

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Alive : OddsEntityBase

The Alive type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeaders | List of empty event elements to identify the events that Betradar system supplies live odds for at the given time (with betstatus and score information).
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides OddsEntityBaseToString)
Top
Remarks
SDK will stop all bets on all events in case it hasn't received any alive messages in timespan defined in settings or if the connection to the Betradar system is lost. All bets are stopped until the connection with the Betradar system is stable again. Event appears in "alive" approximately 15 minutes before start and stays in "alive" 5 minutes after end (after operator closed the event).
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


Alive Properties

The Alive type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeaders | List of empty event elements to identify the events that Betradar system supplies live odds for at the given time (with betstatus and score information).
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

Alive Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


Alive.EventHeaders Property

AliveEventHeaders Property

List of empty event elements to identify the events that Betradar system supplies live odds for at the given time (with betstatus and score information).

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<EventHeader> EventHeaders { get; }

Property Value

List EventHeader
See Also

Reference

Alive Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


Alive Methods

The Alive type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides OddsEntityBaseToString)
Top
See Also

Reference

Alive Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


Alive.ToString Method

AliveToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Alive Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


AliveEventArgs Class

Event arguments passed with OnAlive.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.CommonAliveEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class AliveEventArgs : EventArgs

The AliveEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AliveEventArgs | Initializes a new instance of the AliveEventArgs class
Top
Properties
 | Name | Description
Public property | Alive | Entitiy that contains all the info about the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


AliveEventArgs Constructor

Initializes a new instance of the AliveEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public AliveEventArgs()
See Also

Reference

AliveEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


AliveEventArgs Properties

The AliveEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Alive | Entitiy that contains all the info about the event
Top
See Also

Reference

AliveEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


AliveEventArgs.Alive Property

AliveEventArgsAlive Property

Entitiy that contains all the info about the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Alive Alive { get; }

Property Value

Alive
See Also

Reference

AliveEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


AliveEventArgs Methods

The AliveEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AliveEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BaseWaiter Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Common.BaseWaiter"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonBaseWaiter
More

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public abstract class BaseWaiter : IDisposable

The BaseWaiter type exposes the following members.

Constructors
 | Name | Description
Public method | BaseWaiter | Initializes a new instance of the BaseWaiter class
Top
Properties
 | Name | Description
Public property | Action |
Public property | RequestNr |
Top
Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonBaseWaiter
Sportradar.SDK.FeedProviders.LiveOdds.CommonBookmatchWaiter
Sportradar.SDK.FeedProviders.LiveOdds.CommonCurrentWaiter
Sportradar.SDK.FeedProviders.LiveOdds.CommonErrorWaiter
Sportradar.SDK.FeedProviders.LiveOdds.CommonMetaWaiter
Sportradar.SDK.FeedProviders.LiveOdds.CommonScoreCardWaiter
Sportradar.SDK.FeedProviders.LiveOdds.CommonSubscriptionWaiter


BaseWaiter Constructor

Initializes a new instance of the BaseWaiter class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BaseWaiter(
    ILiveOdds itf
)

Parameters

itf ILiveOdds

[Missing <param name="itf"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.BaseWaiter.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOdds)"]

See Also

Reference

BaseWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BaseWaiter Properties

The BaseWaiter type exposes the following members.

Properties
 | Name | Description
Public property | Action |
Public property | RequestNr |
Top
See Also

Reference

BaseWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BaseWaiter.Action Property

BaseWaiterAction Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Common.BaseWaiter.Action"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Action Action { set; }

Property Value

Action
See Also

Reference

BaseWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BaseWaiter.RequestNr Property

BaseWaiterRequestNr Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Common.BaseWaiter.RequestNr"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long RequestNr { get; set; }

Property Value

Int64
See Also

Reference

BaseWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BaseWaiter Methods

The BaseWaiter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait |
Top
See Also

Reference

BaseWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BaseWaiter.Dispose Method

BaseWaiterDispose Method

Releases unmanaged resources held by an instance of this class.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

BaseWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BaseWaiter.InvokeAction Method

BaseWaiterInvokeAction Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.BaseWaiter.InvokeAction"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void InvokeAction()
See Also

Reference

BaseWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BaseWaiter.Wait Method

BaseWaiterWait Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.BaseWaiter.Wait(System.TimeSpan)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool Wait(
    TimeSpan ttl
)

Parameters

ttl TimeSpan

[Missing <param name="ttl"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.BaseWaiter.Wait(System.TimeSpan)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.BaseWaiter.Wait(System.TimeSpan)"]

See Also

Reference

BaseWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancel Class

Indicates that an odds type for a match has been cancelled for a reason. All bets accepted on the odds with that id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the StartTime and EndTime are set, only bets accepted in this interval should be cancelled.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderWithOddsEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetCancel
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetCancelUndo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetCancel : SingleHeaderWithOddsEvent

The BetCancel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EndTime | If StartTime and EndTime are set only bets accepted in this interval should be cancelled or in BetCancelUndo uncancelled
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event (Inherited from SingleHeaderWithOddsEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | StartTime | If StartTime and EndTime are set only bets accepted in this interval should be cancelled or in BetCancelUndo uncancelled
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderWithOddsEventToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancel Properties

The BetCancel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EndTime | If StartTime and EndTime are set only bets accepted in this interval should be cancelled or in BetCancelUndo uncancelled
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event (Inherited from SingleHeaderWithOddsEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | StartTime | If StartTime and EndTime are set only bets accepted in this interval should be cancelled or in BetCancelUndo uncancelled
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

BetCancel Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancel.EndTime Property

BetCancelEndTime Property

If StartTime and EndTime are set only bets accepted in this interval should be cancelled or in BetCancelUndo uncancelled

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime? EndTime { get; }

Property Value

Nullable DateTime
See Also

Reference

BetCancel Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancel.StartTime Property

BetCancelStartTime Property

If StartTime and EndTime are set only bets accepted in this interval should be cancelled or in BetCancelUndo uncancelled

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime? StartTime { get; }

Property Value

Nullable DateTime
See Also

Reference

BetCancel Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancel Methods

The BetCancel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderWithOddsEventToString)
Top
See Also

Reference

BetCancel Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancel.ToString Method

BetCancelToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

BetCancel Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelEventArgs Class

Event arguments passed with OnBetCancel.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetCancelEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetCancelEventArgs : EventArgs

The BetCancelEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BetCancelEventArgs | Initializes a new instance of the BetCancelEventArgs class
Top
Properties
 | Name | Description
Public property | BetCancel | Entity that contains all the info about the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelEventArgs Constructor

Initializes a new instance of the BetCancelEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetCancelEventArgs()
See Also

Reference

BetCancelEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelEventArgs Properties

The BetCancelEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BetCancel | Entity that contains all the info about the event
Top
See Also

Reference

BetCancelEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelEventArgs.BetCancel Property

BetCancelEventArgsBetCancel Property

Entity that contains all the info about the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetCancel BetCancel { get; }

Property Value

BetCancel
See Also

Reference

BetCancelEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelEventArgs Methods

The BetCancelEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BetCancelEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelUndo Class

Indicates undo of some previous bet cancellation when for some reason an odds type has been cancelled when it shouldn’t have been. Odds element will match the Odds element of the corresponding “cancelbet" message. StartTime and EndTime will also match the values from the previous “cancelbet" message.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderWithOddsEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetCancel
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetCancelUndo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetCancelUndo : BetCancel

The BetCancelUndo type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EndTime | If StartTime and EndTime are set only bets accepted in this interval should be cancelled or in BetCancelUndo uncancelled (Inherited from BetCancel)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event (Inherited from SingleHeaderWithOddsEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | StartTime | If StartTime and EndTime are set only bets accepted in this interval should be cancelled or in BetCancelUndo uncancelled (Inherited from BetCancel)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides BetCancelToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelUndo Properties

The BetCancelUndo type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EndTime | If StartTime and EndTime are set only bets accepted in this interval should be cancelled or in BetCancelUndo uncancelled (Inherited from BetCancel)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event (Inherited from SingleHeaderWithOddsEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | StartTime | If StartTime and EndTime are set only bets accepted in this interval should be cancelled or in BetCancelUndo uncancelled (Inherited from BetCancel)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

BetCancelUndo Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelUndo Methods

The BetCancelUndo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides BetCancelToString)
Top
See Also

Reference

BetCancelUndo Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelUndo.ToString Method

BetCancelUndoToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

BetCancelUndo Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelUndoEventArgs Class

Event arguments passed with OnBetCancelUndo.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetCancelUndoEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetCancelUndoEventArgs : EventArgs

The BetCancelUndoEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BetCancelUndoEventArgs | Initializes a new instance of the BetCancelUndoEventArgs class
Top
Properties
 | Name | Description
Public property | BetCancelUndo | Entitiy that contains all the info about the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelUndoEventArgs Constructor

Initializes a new instance of the BetCancelUndoEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetCancelUndoEventArgs()
See Also

Reference

BetCancelUndoEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelUndoEventArgs Properties

The BetCancelUndoEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BetCancelUndo | Entitiy that contains all the info about the event
Top
See Also

Reference

BetCancelUndoEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelUndoEventArgs.BetCancelUndo Property

BetCancelUndoEventArgsBetCancelUndo Property

Entitiy that contains all the info about the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetCancelUndo BetCancelUndo { get; }

Property Value

BetCancelUndo
See Also

Reference

BetCancelUndoEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetCancelUndoEventArgs Methods

The BetCancelUndoEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BetCancelUndoEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClear Class

Indicates that a situation occurred during the match so that a bet can be decided. Time which is set to (Timestamp - Time) seconds indicates the time at which the event happened. The message also includes the match element indicating the match id and the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField and the status of the outcomes.

Some bet types, like Asian handicap and Asian total, can also include void factor for each EventOddsField element. Void factor can either be 1 or 0.5 indicating that the whole or half the bet is voided and should be refunded to the customer. When the void factor is set to 0.5 the outcome attribute will indicate if the other half is won or lost.

The id attribute in the Odds element corresponds to the odds elements in the previously sent out odds change messages. Evaluation of bet outcomes is responsibility of the client.

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderWithOddsEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetClear

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetClear : SingleHeaderWithOddsEvent

The BetClear type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event (Inherited from SingleHeaderWithOddsEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderWithOddsEventToString)
Top
Remarks
Possible combinations of outcome and void factor:
  • outcome="0" and no void factor: Lose entire bet
  • outcome="1" and no void factor: Win entire bet
  • outcome="0" and void factor="1": Refund entire bet
  • outcome="1" and void factor="0.5": Refund half bet and win other half
  • outcome="0" and void factor="0.5": Refund half bet and lose other half
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClear Properties

The BetClear type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event (Inherited from SingleHeaderWithOddsEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

BetClear Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClear Methods

The BetClear type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderWithOddsEventToString)
Top
See Also

Reference

BetClear Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClear.ToString Method

BetClearToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

BetClear Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearEventArgs Class

Event arguments passed with OnBetClear.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetClearEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetClearEventArgs : EventArgs

The BetClearEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BetClearEventArgs | Initializes a new instance of the BetClearEventArgs class
Top
Properties
 | Name | Description
Public property | BetClear | Entitiy that contains all the info about the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearEventArgs Constructor

Initializes a new instance of the BetClearEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetClearEventArgs()
See Also

Reference

BetClearEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearEventArgs Properties

The BetClearEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BetClear | Entitiy that contains all the info about the event
Top
See Also

Reference

BetClearEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearEventArgs.BetClear Property

BetClearEventArgsBetClear Property

Entitiy that contains all the info about the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetClear BetClear { get; }

Property Value

BetClear
See Also

Reference

BetClearEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearEventArgs Methods

The BetClearEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BetClearEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearRollback Class

Indicates that a wrong information was sent out about a bet clearing and that previous bet clear should be rolled back now. Odds identified by corresponding ids tell what odds the bet clear rollback is for. ClearedScore will be set to the cleared score of the original bet clearing. The time for the original bet clearing is (Timestamp - Time) seconds. The odds element also includes odds field elements to indicate what field was cleared in the original bet clearing. The client is responsible to handle this accordingly.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderWithOddsEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetClearRollback

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetClearRollback : SingleHeaderWithOddsEvent

The BetClearRollback type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event (Inherited from SingleHeaderWithOddsEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderWithOddsEventToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearRollback Properties

The BetClearRollback type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event (Inherited from SingleHeaderWithOddsEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

BetClearRollback Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearRollback Methods

The BetClearRollback type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderWithOddsEventToString)
Top
See Also

Reference

BetClearRollback Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearRollback.ToString Method

BetClearRollbackToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

BetClearRollback Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearRollbackEventArgs Class

Event arguments passed with OnBetClearRollback.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetClearRollbackEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetClearRollbackEventArgs : EventArgs

The BetClearRollbackEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BetClearRollbackEventArgs | Initializes a new instance of the BetClearRollbackEventArgs class
Top
Properties
 | Name | Description
Public property | BetClearRollback | Entitiy that contains all the info about the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearRollbackEventArgs Constructor

Initializes a new instance of the BetClearRollbackEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetClearRollbackEventArgs()
See Also

Reference

BetClearRollbackEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearRollbackEventArgs Properties

The BetClearRollbackEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BetClearRollback | Entitiy that contains all the info about the event
Top
See Also

Reference

BetClearRollbackEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearRollbackEventArgs.BetClearRollback Property

BetClearRollbackEventArgsBetClearRollback Property

Entitiy that contains all the info about the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetClearRollback BetClearRollback { get; }

Property Value

BetClearRollback
See Also

Reference

BetClearRollbackEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetClearRollbackEventArgs Methods

The BetClearRollbackEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BetClearRollbackEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStart Class

Indicates that the bets for a particular match can open again. The message contains s Timestamp and also a Time attribute which tells when the situation occurred in seconds before the Timestamp. If time is 0, bet start is from timestamp, if time > 0, bet start is from (Timestamp - Time). Score indicates the current score in the match.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetStart

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetStart : SingleHeaderEvent

The BetStart type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderEventToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStart Properties

The BetStart type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

BetStart Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStart Methods

The BetStart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderEventToString)
Top
See Also

Reference

BetStart Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStart.ToString Method

BetStartToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

BetStart Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStartEventArgs Class

Event arguments passed with OnBetStart.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetStartEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetStartEventArgs : EventArgs

The BetStartEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BetStartEventArgs | Initializes a new instance of the BetStartEventArgs class
Top
Properties
 | Name | Description
Public property | BetStart | Entity that contains all the info about the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStartEventArgs Constructor

Initializes a new instance of the BetStartEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStartEventArgs()
See Also

Reference

BetStartEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStartEventArgs Properties

The BetStartEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BetStart | Entity that contains all the info about the event
Top
See Also

Reference

BetStartEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStartEventArgs.BetStart Property

BetStartEventArgsBetStart Property

Entity that contains all the info about the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStart BetStart { get; }

Property Value

BetStart
See Also

Reference

BetStartEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStartEventArgs Methods

The BetStartEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BetStartEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStop Class

Indicates that a betstop situation occurred during a match (e.g. goal, red card or other important event occurred). When the bets can open again, a "betstart" message will be sent. Bet stop message contains Timestamp and also a Time attribute which tells when the situation occurred in seconds before the Timestamp. If time is 0 betstop is from timestamp, if time > 0, betstop is from (Timestamp - Time). Score indicates the current score in the match.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetStop

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetStop : SingleHeaderEvent

The BetStop type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsArtificial | Was this BetStop triggered by the SDK itself
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderEventToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStop Properties

The BetStop type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsArtificial | Was this BetStop triggered by the SDK itself
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

BetStop Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStop.IsArtificial Property

BetStopIsArtificial Property

Was this BetStop triggered by the SDK itself

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsArtificial { get; }

Property Value

Boolean
See Also

Reference

BetStop Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStop Methods

The BetStop type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderEventToString)
Top
See Also

Reference

BetStop Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStop.ToString Method

BetStopToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

BetStop Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStopEventArgs Class

Event arguments passed with OnBetStop.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetStopEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetStopEventArgs : EventArgs

The BetStopEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BetStopEventArgs | Initializes a new instance of the BetStopEventArgs class
Top
Properties
 | Name | Description
Public property | BetStop | Entitiy that contains all the info about the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStopEventArgs Constructor

Initializes a new instance of the BetStopEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStopEventArgs()
See Also

Reference

BetStopEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStopEventArgs Properties

The BetStopEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BetStop | Entitiy that contains all the info about the event
Top
See Also

Reference

BetStopEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStopEventArgs.BetStop Property

BetStopEventArgsBetStop Property

Entitiy that contains all the info about the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStop BetStop { get; }

Property Value

BetStop
See Also

Reference

BetStopEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStopEventArgs Methods

The BetStopEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BetStopEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStopReason Class

Reason abut a bet stop.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetStopReason

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetStopReason

The BetStopReason type exposes the following members.

Properties
 | Name | Description
Public property | Id | Betstop reason id.
Public property | Reason | Explanation of the betstop.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStopReason Properties

The BetStopReason type exposes the following members.

Properties
 | Name | Description
Public property | Id | Betstop reason id.
Public property | Reason | Explanation of the betstop.
Top
See Also

Reference

BetStopReason Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStopReason.Id Property

BetStopReasonId Property

Betstop reason id.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

BetStopReason Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStopReason.Reason Property

BetStopReasonReason Property

Explanation of the betstop.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Reason { get; }

Property Value

String
See Also

Reference

BetStopReason Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStopReason Methods

The BetStopReason type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

BetStopReason Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BetStopReason.ToString Method

BetStopReasonToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

BetStopReason Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BookmatchWaiter Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Common.BookmatchWaiter"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonBaseWaiter
Sportradar.SDK.FeedProviders.LiveOdds.CommonBookmatchWaiter

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class BookmatchWaiter : BaseWaiter

The BookmatchWaiter type exposes the following members.

Constructors
 | Name | Description
Public method | BookmatchWaiter | Initializes a new instance of the BookmatchWaiter class
Top
Properties
 | Name | Description
Public property | Action | (Inherited from BaseWaiter)
Public property | RequestNr | (Inherited from BaseWaiter)
Top
Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class. (Inherited from BaseWaiter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction | (Inherited from BaseWaiter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait | (Inherited from BaseWaiter)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BookmatchWaiter Constructor

Initializes a new instance of the BookmatchWaiter class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BookmatchWaiter(
    ILiveOdds itf,
    HashSet<long> matches
)

Parameters

itf ILiveOdds

[Missing <param name="itf"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.BookmatchWaiter.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOdds,System.Collections.Generic.HashSet{System.Int64})"]

matches HashSet Int64

[Missing <param name="matches"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.BookmatchWaiter.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOdds,System.Collections.Generic.HashSet{System.Int64})"]

See Also

Reference

BookmatchWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BookmatchWaiter Properties

The BookmatchWaiter type exposes the following members.

Properties
 | Name | Description
Public property | Action | (Inherited from BaseWaiter)
Public property | RequestNr | (Inherited from BaseWaiter)
Top
See Also

Reference

BookmatchWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


BookmatchWaiter Methods

The BookmatchWaiter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class. (Inherited from BaseWaiter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction | (Inherited from BaseWaiter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait | (Inherited from BaseWaiter)
Top
See Also

Reference

BookmatchWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


CurrentWaiter Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Common.CurrentWaiter"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonBaseWaiter
Sportradar.SDK.FeedProviders.LiveOdds.CommonCurrentWaiter

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class CurrentWaiter : BaseWaiter,
    IDisposable

The CurrentWaiter type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentWaiter | Initializes a new instance of the CurrentWaiter class
Top
Properties
 | Name | Description
Public property | Action | (Inherited from BaseWaiter)
Public property | RequestNr | (Inherited from BaseWaiter)
Public property | Result |
Top
Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class. (Inherited from BaseWaiter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction | (Inherited from BaseWaiter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait | (Inherited from BaseWaiter)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


CurrentWaiter Constructor

Initializes a new instance of the CurrentWaiter class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CurrentWaiter(
    ILiveOdds itf
)

Parameters

itf ILiveOdds

[Missing <param name="itf"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.CurrentWaiter.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOdds)"]

See Also

Reference

CurrentWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


CurrentWaiter Properties

The CurrentWaiter type exposes the following members.

Properties
 | Name | Description
Public property | Action | (Inherited from BaseWaiter)
Public property | RequestNr | (Inherited from BaseWaiter)
Public property | Result |
Top
See Also

Reference

CurrentWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


CurrentWaiter.Result Property

CurrentWaiterResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Common.CurrentWaiter.Result"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<OddsEntityBase> Result { get; }

Property Value

List OddsEntityBase
See Also

Reference

CurrentWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


CurrentWaiter Methods

The CurrentWaiter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class. (Inherited from BaseWaiter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction | (Inherited from BaseWaiter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait | (Inherited from BaseWaiter)
Top
See Also

Reference

CurrentWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ErrorWaiter Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Common.ErrorWaiter"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonBaseWaiter
Sportradar.SDK.FeedProviders.LiveOdds.CommonErrorWaiter

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class ErrorWaiter : BaseWaiter,
    IDisposable

The ErrorWaiter type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorWaiter | Initializes a new instance of the ErrorWaiter class
Top
Properties
 | Name | Description
Public property | Action | (Inherited from BaseWaiter)
Public property | RequestNr | (Inherited from BaseWaiter)
Public property | Result |
Top
Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class. (Inherited from BaseWaiter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction | (Inherited from BaseWaiter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait | (Inherited from BaseWaiter)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ErrorWaiter Constructor

Initializes a new instance of the ErrorWaiter class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ErrorWaiter(
    ILiveOdds itf
)

Parameters

itf ILiveOdds

[Missing <param name="itf"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.ErrorWaiter.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOdds)"]

See Also

Reference

ErrorWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ErrorWaiter Properties

The ErrorWaiter type exposes the following members.

Properties
 | Name | Description
Public property | Action | (Inherited from BaseWaiter)
Public property | RequestNr | (Inherited from BaseWaiter)
Public property | Result |
Top
See Also

Reference

ErrorWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ErrorWaiter.Result Property

ErrorWaiterResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Common.ErrorWaiter.Result"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<OddsEntityBase> Result { get; }

Property Value

List OddsEntityBase
See Also

Reference

ErrorWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ErrorWaiter Methods

The ErrorWaiter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class. (Inherited from BaseWaiter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction | (Inherited from BaseWaiter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait | (Inherited from BaseWaiter)
Top
See Also

Reference

ErrorWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventBetStatus Class

Bet status
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.CommonEventBetStatus

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class EventBetStatus : Enum

The EventBetStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | STARTED | Betting started
 | STOPPED | Betting stopped
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventBetStatus Methods

The EventBetStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

EventBetStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventBetStatus Fields

The EventBetStatus type exposes the following members.

Fields
 | Name | Description
 | STARTED | Betting started
 | STOPPED | Betting stopped
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

EventBetStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventBetStatus.STARTED Field

EventBetStatusSTARTED Field

Betting started

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventBetStatus STARTED = 1

Field Value

EventBetStatus
See Also

Reference

EventBetStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventBetStatus.STOPPED Field

EventBetStatusSTOPPED Field

Betting stopped

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventBetStatus STOPPED = 2

Field Value

EventBetStatus
See Also

Reference

EventBetStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventBetStatus.UNDEFINED Field

EventBetStatusUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventBetStatus UNDEFINED = 0

Field Value

EventBetStatus
See Also

Reference

EventBetStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventBetStatus.value__ Field

EventBetStatusvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Common.EventBetStatus.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

EventBetStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventDataReceivedEventArgs Class

Event arguments passed with OnEventMessages and OnEventStatus.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.CommonEventDataReceivedEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class EventDataReceivedEventArgs : EventArgs

The EventDataReceivedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Messages | All the received messages.
Public property | ReplyNr | Reply number which correspond with request number
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventDataReceivedEventArgs Properties

The EventDataReceivedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Messages | All the received messages.
Public property | ReplyNr | Reply number which correspond with request number
Top
See Also

Reference

EventDataReceivedEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventDataReceivedEventArgs.Messages Property

EventDataReceivedEventArgsMessages Property

All the received messages.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<OddsEntityBase> Messages { get; set; }

Property Value

List OddsEntityBase
See Also

Reference

EventDataReceivedEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventDataReceivedEventArgs.ReplyNr Property

EventDataReceivedEventArgsReplyNr Property

Reply number which correspond with request number

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? ReplyNr { get; }

Property Value

Nullable Int64
See Also

Reference

EventDataReceivedEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventDataReceivedEventArgs Methods

The EventDataReceivedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EventDataReceivedEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventHeader Class

Contains core data about an event. Base class for RaceHeader and MatchHeader
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonEventHeader
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsMatchHeader
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightHeader
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.CommonRaceHeader

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class EventHeader

The EventHeader type exposes the following members.

Constructors
 | Name | Description
Public method | EventHeader | Initializes a new instance of the EventHeader class
Top
Properties
 | Name | Description
Public property | Active | Set to false when a match is removed (in this case also see the Message for the reason for removal). Also set to false if the client has unregistered a match. The message element will include the text "unregistered" in such case.
Public property | BetStatus | Current bet status
Public property | Id | Betradar id for the event
Public property | Message | Optional textual message attached to the match (e.g. why a match has been removed, information that a client has unregistered from a match, etc.)
Public property | Msgnr | Incremental message id that starts with 1 for every match. Only messages that changes the state of a match will include this property. Alive messages, meta-information and login response messages will not include this incremental id.
Public property | Status | Event status
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventHeader Constructor

Initializes a new instance of the EventHeader class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventHeader()
See Also

Reference

EventHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventHeader Properties

The EventHeader type exposes the following members.

Properties
 | Name | Description
Public property | Active | Set to false when a match is removed (in this case also see the Message for the reason for removal). Also set to false if the client has unregistered a match. The message element will include the text "unregistered" in such case.
Public property | BetStatus | Current bet status
Public property | Id | Betradar id for the event
Public property | Message | Optional textual message attached to the match (e.g. why a match has been removed, information that a client has unregistered from a match, etc.)
Public property | Msgnr | Incremental message id that starts with 1 for every match. Only messages that changes the state of a match will include this property. Alive messages, meta-information and login response messages will not include this incremental id.
Public property | Status | Event status
Top
See Also

Reference

EventHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventHeader.Active Property

EventHeaderActive Property

Set to false when a match is removed (in this case also see the Message for the reason for removal). Also set to false if the client has unregistered a match. The message element will include the text "unregistered" in such case.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Active { get; }

Property Value

Boolean
See Also

Reference

EventHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventHeader.BetStatus Property

EventHeaderBetStatus Property

Current bet status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventBetStatus? BetStatus { get; }

Property Value

Nullable EventBetStatus
See Also

Reference

EventHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventHeader.Id Property

EventHeaderId Property

Betradar id for the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long Id { get; }

Property Value

Int64
See Also

Reference

EventHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventHeader.Message Property

EventHeaderMessage Property

Optional textual message attached to the match (e.g. why a match has been removed, information that a client has unregistered from a match, etc.)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string[] Message { get; }

Property Value

String
See Also

Reference

EventHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventHeader.Msgnr Property

EventHeaderMsgnr Property

Incremental message id that starts with 1 for every match. Only messages that changes the state of a match will include this property. Alive messages, meta-information and login response messages will not include this incremental id.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Msgnr { get; }

Property Value

Nullable Int64
See Also

Reference

EventHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventHeader.Status Property

EventHeaderStatus Property

Event status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventStatus Status { get; }

Property Value

EventStatus
See Also

Reference

EventHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventHeader Methods

The EventHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

EventHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventHeader.ToString Method

EventHeaderToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

EventHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds Class

Match odds and corresponding odd fields.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonEventOdds

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class EventOdds

The EventOdds type exposes the following members.

Constructors
 | Name | Description
Public method | EventOdds | Initializes a new instance of the EventOdds class
Top
Properties
 | Name | Description
Public property | Active | Whether odds are active or not
Public property | Changed | Indicates if this odds type has been changed or not.
Public property | Combination | Contains information about combination of bets and can have values of 0 – 4, where 0 indicates unlimited combination, 1 indicates single bet and 2-4 indicates 2-4 combinations, respectively.
Public property | ForTheRest | Contains the handicap value for the rest of the match in addition to the special odds value which reflects the handicap value for the whole match.
Public property | Freetext | The freetext as received from the server.
Public property | Id | Unique identifier for this particular odds in this match, and will be used whenever this odds is sent out. This id will also be used when this odds is cleared.
Public property | MostBalanced | Marks the most balanced odds of an odds type.
Public property | Name | Specifies the textual description of this odds (international value is freetext) (e.g. subtype="2" freetext="Which team has kick off?".)
Public property | OddsFields | Collection of odds fields. Odds types that are active contain odds fields, while inactive odds types do not. Key is represented by the odds type.
Public property | SpecialOddsValue | Special odds values are specified only for some odds types like total, handicap and freetext3way/2way/nway. This indicates the total value, handicap value or freetext details respectively.
Public property | SubType | Specifies with the freetext odds and tells what kind of freetext odds this is (e.g. subtype="2" freetext="Which team has kick off?".)
Public property | Type | Odds type
Public property | TypeId | Odds type id that is the same for this odds type in all matches.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds Constructor

Initializes a new instance of the EventOdds class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventOdds()
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds Properties

The EventOdds type exposes the following members.

Properties
 | Name | Description
Public property | Active | Whether odds are active or not
Public property | Changed | Indicates if this odds type has been changed or not.
Public property | Combination | Contains information about combination of bets and can have values of 0 – 4, where 0 indicates unlimited combination, 1 indicates single bet and 2-4 indicates 2-4 combinations, respectively.
Public property | ForTheRest | Contains the handicap value for the rest of the match in addition to the special odds value which reflects the handicap value for the whole match.
Public property | Freetext | The freetext as received from the server.
Public property | Id | Unique identifier for this particular odds in this match, and will be used whenever this odds is sent out. This id will also be used when this odds is cleared.
Public property | MostBalanced | Marks the most balanced odds of an odds type.
Public property | Name | Specifies the textual description of this odds (international value is freetext) (e.g. subtype="2" freetext="Which team has kick off?".)
Public property | OddsFields | Collection of odds fields. Odds types that are active contain odds fields, while inactive odds types do not. Key is represented by the odds type.
Public property | SpecialOddsValue | Special odds values are specified only for some odds types like total, handicap and freetext3way/2way/nway. This indicates the total value, handicap value or freetext details respectively.
Public property | SubType | Specifies with the freetext odds and tells what kind of freetext odds this is (e.g. subtype="2" freetext="Which team has kick off?".)
Public property | Type | Odds type
Public property | TypeId | Odds type id that is the same for this odds type in all matches.
Top
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.Active Property

EventOddsActive Property

Whether odds are active or not

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Active { get; }

Property Value

Boolean
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.Changed Property

EventOddsChanged Property

Indicates if this odds type has been changed or not.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? Changed { get; }

Property Value

Nullable Boolean
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.Combination Property

EventOddsCombination Property

Contains information about combination of bets and can have values of 0 – 4, where 0 indicates unlimited combination, 1 indicates single bet and 2-4 indicates 2-4 combinations, respectively.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Combination { get; }

Property Value

Nullable Int64
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.ForTheRest Property

EventOddsForTheRest Property

Contains the handicap value for the rest of the match in addition to the special odds value which reflects the handicap value for the whole match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ForTheRest { get; }

Property Value

String
Remarks
Available only with "Include Asian Handicap spread for the rest for all Asian Handicap markets" turned on.
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.Freetext Property

EventOddsFreetext Property

The freetext as received from the server.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Freetext { get; }

Property Value

String
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.Id Property

EventOddsId Property

Unique identifier for this particular odds in this match, and will be used whenever this odds is sent out. This id will also be used when this odds is cleared.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long Id { get; }

Property Value

Int64
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.MostBalanced Property

EventOddsMostBalanced Property

Marks the most balanced odds of an odds type.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? MostBalanced { get; }

Property Value

Nullable Boolean
Remarks
Present only if "Mark most balanced odds" XML configuration settings has been activated.
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.Name Property

EventOddsName Property

Specifies the textual description of this odds (international value is freetext) (e.g. subtype="2" freetext="Which team has kick off?".)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString Name { get; }

Property Value

LocalizedString
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.OddsFields Property

EventOddsOddsFields Property

Collection of odds fields. Odds types that are active contain odds fields, while inactive odds types do not. Key is represented by the odds type.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IDictionary<string, EventOddsField> OddsFields { get; }

Property Value

IDictionary String, EventOddsField
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.SpecialOddsValue Property

EventOddsSpecialOddsValue Property

Special odds values are specified only for some odds types like total, handicap and freetext3way/2way/nway. This indicates the total value, handicap value or freetext details respectively.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SpecialOddsValue { get; }

Property Value

String
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.SubType Property

EventOddsSubType Property

Specifies with the freetext odds and tells what kind of freetext odds this is (e.g. subtype="2" freetext="Which team has kick off?".)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? SubType { get; }

Property Value

Nullable Int64
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.Type Property

EventOddsType Property

Odds type

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventOddsType Type { get; }

Property Value

EventOddsType
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.TypeId Property

EventOddsTypeId Property

Odds type id that is the same for this odds type in all matches.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long TypeId { get; }

Property Value

Int64
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds Methods

The EventOdds type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOdds.ToString Method

EventOddsToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

EventOdds Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField Class

Match odds field specifying each outcome for a specific odds type. Only odds types that are active contain odds fields.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonEventOddsField

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class EventOddsField

The EventOddsField type exposes the following members.

Constructors
 | Name | Description
Public method | EventOddsField | Initializes a new instance of the EventOddsField class
Top
Properties
 | Name | Description
Public property | Active | Whether odds field is active or not.
Public property | Outcome | Status of the outcome. See also VoidFactor.
Public property | PlayerId | The ID of the player referenced in the bet.
Public property | Probability | Outcome probability
Public property | Type | Type of odds field (e.g. over, under, etc.)
Public property | TypeId | Optional odds type id
Public property | Value | Odds field value
Public property | ViewIndex | Returns the original index(position) of EventOddsField as SDK stores them in a IDictionary
Public property | VoidFactor | Void factor can either be 1 or 0.5, indicating that the whole or half of the bet is voided and should be refunded to the customer. When the void factor is set to 0.5, the Outcome will indicate if the other half has won or lost.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField Constructor

Initializes a new instance of the EventOddsField class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventOddsField()
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField Properties

The EventOddsField type exposes the following members.

Properties
 | Name | Description
Public property | Active | Whether odds field is active or not.
Public property | Outcome | Status of the outcome. See also VoidFactor.
Public property | PlayerId | The ID of the player referenced in the bet.
Public property | Probability | Outcome probability
Public property | Type | Type of odds field (e.g. over, under, etc.)
Public property | TypeId | Optional odds type id
Public property | Value | Odds field value
Public property | ViewIndex | Returns the original index(position) of EventOddsField as SDK stores them in a IDictionary
Public property | VoidFactor | Void factor can either be 1 or 0.5, indicating that the whole or half of the bet is voided and should be refunded to the customer. When the void factor is set to 0.5, the Outcome will indicate if the other half has won or lost.
Top
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField.Active Property

EventOddsFieldActive Property

Whether odds field is active or not.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Active { get; }

Property Value

Boolean
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField.Outcome Property

EventOddsFieldOutcome Property

Status of the outcome. See also VoidFactor.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? Outcome { get; }

Property Value

Nullable Boolean
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField.PlayerId Property

EventOddsFieldPlayerId Property

The ID of the player referenced in the bet.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? PlayerId { get; }

Property Value

Nullable Int64
Remarks
Available only with "Include playerid in oddsfield tag" turned on.
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField.Probability Property

EventOddsFieldProbability Property

Outcome probability

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double? Probability { get; }

Property Value

Nullable Double
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField.Type Property

EventOddsFieldType Property

Type of odds field (e.g. over, under, etc.)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString Type { get; }

Property Value

LocalizedString
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField.TypeId Property

EventOddsFieldTypeId Property

Optional odds type id

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? TypeId { get; }

Property Value

Nullable Int32
Remarks
Available only with "Include typeid in oddsfield tag" turned on.
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField.Value Property

EventOddsFieldValue Property

Odds field value

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public decimal? Value { get; }

Property Value

Nullable Decimal
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField.ViewIndex Property

EventOddsFieldViewIndex Property

Returns the original index(position) of EventOddsField as SDK stores them in a IDictionary

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int ViewIndex { get; }

Property Value

Int32
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField.VoidFactor Property

EventOddsFieldVoidFactor Property

Void factor can either be 1 or 0.5, indicating that the whole or half of the bet is voided and should be refunded to the customer. When the void factor is set to 0.5, the Outcome will indicate if the other half has won or lost.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double? VoidFactor { get; }

Property Value

Nullable Double
Remarks
Only some bet types, like asian handicap and asian total, can include void factor. Possible combinations of outcome and void factor:
  • outcome="0" and no void factor: Lose entire bet
  • outcome="1" and no void factor: Win entire bet
  • outcome="0" and void factor="1": Refund entire bet
  • outcome="1" and void factor="0.5": Refund half bet and win other half
  • outcome="0" and void factor="0.5": Refund half bet and lose other half
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField Methods

The EventOddsField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsField.ToString Method

EventOddsFieldToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

EventOddsField Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsLite Class

Match odds used for bet type registration request (i.e. activation and deactivation of odds types and fields).
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonEventOddsLite

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class EventOddsLite

The EventOddsLite type exposes the following members.

Constructors
 | Name | Description
Public method | EventOddsLite | Initializes a new instance of the EventOddsLite class
Top
Properties
 | Name | Description
Public property | SubType | Specified with the freetext odds and tells what kind of freetext odds this is (e.g. subtype="2" freetext="Which team has kick off?".)
Public property | Type | Odds type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsLite Constructor

Initializes a new instance of the EventOddsLite class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventOddsLite()
See Also

Reference

EventOddsLite Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsLite Properties

The EventOddsLite type exposes the following members.

Properties
 | Name | Description
Public property | SubType | Specified with the freetext odds and tells what kind of freetext odds this is (e.g. subtype="2" freetext="Which team has kick off?".)
Public property | Type | Odds type
Top
See Also

Reference

EventOddsLite Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsLite.SubType Property

EventOddsLiteSubType Property

Specified with the freetext odds and tells what kind of freetext odds this is (e.g. subtype="2" freetext="Which team has kick off?".)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? SubType { get; set; }

Property Value

Nullable Int64
See Also

Reference

EventOddsLite Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsLite.Type Property

EventOddsLiteType Property

Odds type

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventOddsType Type { get; set; }

Property Value

EventOddsType
See Also

Reference

EventOddsLite Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsLite Methods

The EventOddsLite type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

EventOddsLite Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsLite.ToString Method

EventOddsLiteToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

EventOddsLite Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType Class

Event odds type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.CommonEventOddsType

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class EventOddsType : Enum

The EventOddsType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | FT2W | Free text - 2 way
 | FT3W | Free text - 3 way
 | FTNW | Free text - n way
 | HC | Handicap
 | ITEM3W | 3 way
 | NG | Obsolete. Next goal (obsolete now, replaced with a special FT3W odds type)
 | OUTRIGHT | Outright
 | TO | Total
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType Methods

The EventOddsType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

EventOddsType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType Fields

The EventOddsType type exposes the following members.

Fields
 | Name | Description
 | FT2W | Free text - 2 way
 | FT3W | Free text - 3 way
 | FTNW | Free text - n way
 | HC | Handicap
 | ITEM3W | 3 way
 | NG | Obsolete. Next goal (obsolete now, replaced with a special FT3W odds type)
 | OUTRIGHT | Outright
 | TO | Total
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

EventOddsType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType.FT2W Field

EventOddsTypeFT2W Field

Free text - 2 way

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventOddsType FT2W = 7

Field Value

EventOddsType
See Also

Reference

EventOddsType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType.FT3W Field

EventOddsTypeFT3W Field

Free text - 3 way

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventOddsType FT3W = 6

Field Value

EventOddsType
See Also

Reference

EventOddsType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType.FTNW Field

EventOddsTypeFTNW Field

Free text - n way

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventOddsType FTNW = 8

Field Value

EventOddsType
See Also

Reference

EventOddsType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType.HC Field

EventOddsTypeHC Field

Handicap

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventOddsType HC = 4

Field Value

EventOddsType
See Also

Reference

EventOddsType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType.ITEM3W Field

EventOddsTypeITEM3W Field

3 way

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventOddsType ITEM3W = 2

Field Value

EventOddsType
See Also

Reference

EventOddsType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType.NG Field

EventOddsTypeNG Field

Note: This API is now obsolete.

Next goal (obsolete now, replaced with a special FT3W odds type)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[ObsoleteAttribute]
public const EventOddsType NG = 3

Field Value

EventOddsType
See Also

Reference

EventOddsType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType.OUTRIGHT Field

EventOddsTypeOUTRIGHT Field

Outright

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventOddsType OUTRIGHT = 9

Field Value

EventOddsType
See Also

Reference

EventOddsType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType.TO Field

EventOddsTypeTO Field

Total

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventOddsType TO = 5

Field Value

EventOddsType
See Also

Reference

EventOddsType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType.UNDEFINED Field

EventOddsTypeUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventOddsType UNDEFINED = 0

Field Value

EventOddsType
See Also

Reference

EventOddsType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventOddsType.value__ Field

EventOddsTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Common.EventOddsType.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

EventOddsType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus Class

Event status as used by Live Odds.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.CommonEventStatus

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class EventStatus : Enum

The EventStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | ABANDONED | Abandoned
 | AFTER_GSET | The after golden set
 | AFTER_OT | After overtime
 | AFTER_PEN | After penalties
 | AFTER_SD | After sudden death
 | AFTER_SO | After super over
 | AWAITING_GSET | The awaiting golden set
 | AWAITING_OT | Awaiting overtime
 | AWAITING_PEN | Awaiting penalties
 | AWAITING_SD | Awaiting sudden death
 | AWAITING_SO | Awaiting super over
 | BT1B1 | Break 1st top 1st bottom
 | BT2B1 | Break 2nd top 1st bottom
 | BT2B2 | Break 2nd top 2nd bottom
 | BT3B2 | Break 3rd top 2nd bottom
 | BT3B3 | Break 3rd top 3rd bottom
 | BT4B3 | Break 4th top 3rd bottom
 | BT4B4 | Break 4th top 4th bottom
 | BT5B4 | Break 5th top 4th bottom
 | BT5B5 | Break 5th top 5th bottom
 | BT6B5 | Break 6th top 5th bottom
 | BT6B6 | Break 6th top 6th bottom
 | BT7B6 | Break 7th top 6th bottom
 | BT7B7 | Break 7th top 7th bottom
 | BT8B7 | Break 8th top 7th bottom
 | BT8B8 | Break 8th top 8th bottom
 | BT9B8 | Break 9th top 8th bottom
 | BT9B9 | Break 9th top 9th bottom
 | BTEIB7 | The btei b7
 | BTEIB9 | Break EI top 9th bottom
 | BTEIBEI | Break EI top EI bottom
 | CANCELED | Canceled, used in LiveOdds
 | CANCELLED | Cancelled, used in VHC, VDR, VTO
 | DEFAULTED1 | Defaulted 1
 | DEFAULTED2 | Defaulted 2
 | DELAYED | Delayed
 | EIB | Extra inning bottom
 | EIT | Extra inning top
 | ENDED | Ended
 | GSET | Golden set
 | IN_PROGRESS | In progress
 | INJURY_BREAK | Injury break
 | INNINGS_BREAK | Innings break
 | INTERRUPTED | Interrupted
 | ITEM1G | 1st game
 | ITEM1I_AT | First innings, away team
 | ITEM1I_HT | First innings, home team
 | ITEM1IB | 1st inning (bottom)
 | ITEM1IT | 1st inning (top)
 | ITEM1MAP | First map
 | ITEM1P | 1st period
 | ITEM1P_OT | 1st period overtime
 | ITEM1Q | 1st quarter
 | ITEM1SET | 1st set
 | ITEM2G | 2nd game
 | ITEM2I_AT | Second innings, away team
 | ITEM2I_HT | Second innings, home team
 | ITEM2IB | 2nd inning (bottom)
 | ITEM2IT | 2nd inning (top)
 | ITEM2MAP | Second map
 | ITEM2P | 2nd period
 | ITEM2P_OT | 2nd period overtime
 | ITEM2Q | 2nd quarter
 | ITEM2SET | 2nd set
 | ITEM3G | 3rd game
 | ITEM3IB | 3rd inning (bottom)
 | ITEM3IT | 3rd inning (top)
 | ITEM3MAP | Third map
 | ITEM3P | 3rd period
 | ITEM3Q | 3rd quarter
 | ITEM3SET | 3rd set
 | ITEM4G | 4th game
 | ITEM4IB | 4th inning (bottom)
 | ITEM4IT | 4th inning (top)
 | ITEM4MAP | Fourth map
 | ITEM4P | 4th period
 | ITEM4Q | 4th quarter
 | ITEM4SET | 4th set
 | ITEM5G | 5th game
 | ITEM5IB | 5th inning (bottom)
 | ITEM5IT | 5th inning (top)
 | ITEM5MAP | Fifth map
 | ITEM5P | 5th period
 | ITEM5SET | 5th set
 | ITEM6IB | 6th inning (bottom)
 | ITEM6IT | 6th inning (top)
 | ITEM6MAP | Sixth map
 | ITEM6SET | 6th set
 | ITEM7IB | 7th inning (bottom)
 | ITEM7IT | 7th inning (top)
 | ITEM7MAP | Seventh map
 | ITEM7SET | 7th set
 | ITEM8IB | 8th inning (bottom)
 | ITEM8IT | 8th inning (top)
 | ITEM9IB | 9th inning (bottom)
 | ITEM9IT | 9th inning (top)
 | LUNCH_BREAK | Lunch break
 | NOT_STARTED | Not started
 | OT | Overtime
 | OT_HT | Overtime halftime
 | PAUSE1 | 1st pause
 | PAUSE2 | 2nd pause
 | PAUSE3 | 3rd pause
 | PAUSE4 | 4th pause
 | PAUSE5 | 5th pause
 | PAUSE6 | 6th pause
 | PAUSED | Paused
 | PEN | Penalties
 | POSTPONED | Postponed
 | RETIRED | Retired
 | RETIRED1 | 1st retired
 | RETIRED2 | 2nd retired
 | SD | Sudden death
 | SESSION_BREAK | Session break
 | SO_AT | Super over, away team
 | SO_BREAK | Super over break
 | SO_HT | Super over, home team
 | STARTED | Started
 | STUMPS | Stumps
 | TEA_BREAK | Tea break
 | UNDEFINED | Undefined
Public field | value__ |
 | WALKOVER | Walkover
 | WALKOVER1 | 1st walkover
 | WALKOVER2 | 2nd walkover
Top
Remarks
Soccer:
  • not_started Not started yet
  • 1p 1st period of the match
  • paused Match pause
  • 2p 2nd period of the match
  • ended The match has ended
  • awaiting_ot Waiting for overtime to start
  • ot Overtime (when normal time is over)
  • 1p_ot 1st overtime period
  • ot_ht Pause between 1st and 2nd overtime period
  • 2p_ot 2nd overtime period
  • after_ot Overtime is finished
  • awaiting_pen Waiting for penalty shooting to start
  • pen Penalty shooting
  • ended The match has ended
  • interrupted The match has been interrupted
Tennis:
  • not_started Not started yet
  • 1set 1st set
  • 2set 2nd set
  • 3set 3rd set
  • 4set 4th set
  • 5set 5th set
  • ended The match has ended
  • walkover A player won the match on walkover
  • retired The match is ended because a player has retired
  • delayed The match start is delayed
  • interrupted The match has been interrupted
Ice Hockey:
  • not_started Not started yet
  • 1p 1st period
  • 2p 2nd period
  • 3p 3rd period
  • paused Match pause
  • ot Overtime (Used during the entire overtime)
  • pen Penalty shooting
  • ended The match has ended
  • interrupted The match has been interrupted
  • awaiting_ot Waiting for overtime to start
  • after_ot Overtime is finished
  • awaiting_pen Waiting for penalty shooting to start
Basketball:
  • not_started Not started yet
  • 1q 1st quarter
  • pause1 1st pause
  • 2q 2nd quarter
  • pause2 2nd pause
  • 3q 3rd quarter
  • pause3 3rd pause
  • 4q 4th quarter
  • ended The match has ended
  • ot Overtime (Used during the entire overtime)
  • interrupted The match has been interrupted
  • awaiting_ot Waiting for overtime to start
  • after_ot Overtime is finished
Handball:
  • not_started Not started yet
  • 1p 1st period of the match
  • paused Match pause
  • 2p 2nd period of the match
  • ended The match has ended
  • awaiting_ot Waiting for overtime to start
  • ot Overtime (when normal time is over)
  • 1p_ot 1st overtime period
  • ot_ht Pause between 1st and 2nd overtime period
  • 2p_ot 2nd overtime period
  • after_ot Overtime is finished
  • awaiting_pen Waiting for penalty shooting to start
  • pen Penalty shooting
  • ended The match has ended
  • interrupted The match has been interrupted
Volleyball:
  • not_started Not started yet
  • 1set 1st set
  • pause1 1st pause
  • 2set 2nd set
  • pause2 2nd pause
  • 3set 3rd set
  • pause3 3rd pause
  • 4set 4th set
  • pause4 4th pause
  • 5set 5th set
  • ended The match has ended
  • walkover A player won the match on walkover
  • retired The match is ended because a player has retired
  • delayed The match start is delayed
  • interrupted The match has been interrupted
  • gset Used if there is a golden set
Beach volleyball:
  • not_started Not started yet
  • 1set 1st set
  • pause1 1st pause
  • 2set 2nd set
  • pause2 2nd pause
  • 3set 3rd set
  • ended The match has ended
  • walkover A player won the match on walkover
  • retired The match is ended because a player has retired
  • delayed The match start is delayed
  • interrupted The match has been interrupted
  • gset Used if there is a golden set
Futsal:
  • not_started Not started yet
  • 1p 1st period of the match
  • paused Match pause
  • 2p 2nd period of the match
  • ended The match has ended
  • awaiting_ot Waiting for overtime to start
  • ot Overtime (when normal time is over)
  • 1p_ot 1st overtime period
  • ot_ht Pause between 1st and 2nd overtime period
  • 2p_ot 2nd overtime period
  • after_ot Overtime is finished
  • awaiting_pen Waiting for penalty shooting to start
  • pen Penalty shooting
  • ended The match has ended
  • interrupted The match has been interrupted
Baseball:
  • not_started Not started yet
  • 1IT 1st inning top
  • BT1B1 Break 1st top 1st bottom
  • 1IB 1st inning bottom
  • BT2B1 Break 2nd top 1st bottom
  • 2IT 2nd inning top
  • BT2B2 Break 2nd top 2nd bottom
  • 2IB 2nd inning bottom
  • BT3B2 Break 3rd top 2nd bottom
  • 3IT 3rd inning top
  • BT3B3 Break 3rd top 3rd bottom
  • 3IB 3rd inning bottom
  • BT4B3 Break 4th top 3rd bottom
  • 4IT 4th inning top
  • BT4B4 Break 4th top 4th bottom
  • 4IB 4th inning bottom
  • BT5B4 Break 5th top 4th bottom
  • 5IT 5th inning top
  • BT5B5 Break 5th top 5th bottom
  • 5IB 5th inning bottom
  • BT6B5 Break 6th top 5th bottom
  • 6IT 6th inning top
  • BT6B6 Break 6th top 6th bottom
  • 6IB 6th inning bottom
  • BT7B6 Break 7th top 6th bottom
  • 7IT 7th inning top
  • BT7B7 Break 7th top 7th bottom
  • 7IB 7th inning bottom
  • BT8B7 Break 8th top 7th bottom
  • 8IT 8th inning top
  • BT8B8 Break 8th top 8th bottom
  • 8IB 8th inning bottom
  • BT9B8 Break 9th top 8th bottom
  • 9IT 9th inning top
  • BT9B9 Break 9th top 9th bottom
  • 9IB 9th inning bottom
  • BTEIB9 Break EI top 9th bottom
  • EIT Extra inning top
  • BTEIBEI Break EI top EI bottom
  • EIB Extra inning bottom
American Football:
  • not_started Not started yet
  • 1q 1st quarter
  • pause1 1st pause
  • 2q 2nd quarter
  • pause2 2nd pause
  • 3q 3rd quarter
  • pause3 3rd pause
  • 4q 4th quarter
  • ended The match has ended
  • ot Overtime (Used during the entire overtime)
  • interrupted The match has been interrupted
  • awaiting_ot Waiting for overtime to start
  • after_ot Overtime is finished
For Badminton:
  • not_started Not started yet
  • 1set 1st set
  • pause1 1st pause
  • 2set 2nd set
  • pause2 2nd pause
  • 3set 3rd set
  • ended The match has ended
  • walkover A player won the match on walkover
  • retired The match is ended because a player has retired
  • delayed The match start is delayed
  • interrupted The match has been interrupted
  • postponed The match has been postponed
For Rugby:
  • not_started Not started yet
  • 1p 1st period of the match
  • paused Match pause
  • 2p 2nd period of the match
  • ended The match has ended
  • awaiting_ot Waiting for overtime to start
  • ot Overtime (when normal time is over)
  • 1p_ot 1st overtime period
  • ot_ht Pause between 1st and 2nd overtime period
  • 2p_ot 2nd overtime period
  • after_ot Overtime is finished
  • awaiting_pen Waiting for penalty shooting to start
  • pen Penalty shooting
  • SD Sudden death
  • ended The match has ended
  • interrupted The match has been interrupted
For Dart:
  • not_started Not started yet
  • in_progress The match is in progress
  • paused Match pause
  • delayed The match start is delayed
  • interrupted The match has been interrupted
  • abandoned The match has been abandoned
  • walkover A player won the match on walkover
  • retired The match is ended because a player has retired
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus Methods

The EventStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus Fields

The EventStatus type exposes the following members.

Fields
 | Name | Description
 | ABANDONED | Abandoned
 | AFTER_GSET | The after golden set
 | AFTER_OT | After overtime
 | AFTER_PEN | After penalties
 | AFTER_SD | After sudden death
 | AFTER_SO | After super over
 | AWAITING_GSET | The awaiting golden set
 | AWAITING_OT | Awaiting overtime
 | AWAITING_PEN | Awaiting penalties
 | AWAITING_SD | Awaiting sudden death
 | AWAITING_SO | Awaiting super over
 | BT1B1 | Break 1st top 1st bottom
 | BT2B1 | Break 2nd top 1st bottom
 | BT2B2 | Break 2nd top 2nd bottom
 | BT3B2 | Break 3rd top 2nd bottom
 | BT3B3 | Break 3rd top 3rd bottom
 | BT4B3 | Break 4th top 3rd bottom
 | BT4B4 | Break 4th top 4th bottom
 | BT5B4 | Break 5th top 4th bottom
 | BT5B5 | Break 5th top 5th bottom
 | BT6B5 | Break 6th top 5th bottom
 | BT6B6 | Break 6th top 6th bottom
 | BT7B6 | Break 7th top 6th bottom
 | BT7B7 | Break 7th top 7th bottom
 | BT8B7 | Break 8th top 7th bottom
 | BT8B8 | Break 8th top 8th bottom
 | BT9B8 | Break 9th top 8th bottom
 | BT9B9 | Break 9th top 9th bottom
 | BTEIB7 | The btei b7
 | BTEIB9 | Break EI top 9th bottom
 | BTEIBEI | Break EI top EI bottom
 | CANCELED | Canceled, used in LiveOdds
 | CANCELLED | Cancelled, used in VHC, VDR, VTO
 | DEFAULTED1 | Defaulted 1
 | DEFAULTED2 | Defaulted 2
 | DELAYED | Delayed
 | EIB | Extra inning bottom
 | EIT | Extra inning top
 | ENDED | Ended
 | GSET | Golden set
 | IN_PROGRESS | In progress
 | INJURY_BREAK | Injury break
 | INNINGS_BREAK | Innings break
 | INTERRUPTED | Interrupted
 | ITEM1G | 1st game
 | ITEM1I_AT | First innings, away team
 | ITEM1I_HT | First innings, home team
 | ITEM1IB | 1st inning (bottom)
 | ITEM1IT | 1st inning (top)
 | ITEM1MAP | First map
 | ITEM1P | 1st period
 | ITEM1P_OT | 1st period overtime
 | ITEM1Q | 1st quarter
 | ITEM1SET | 1st set
 | ITEM2G | 2nd game
 | ITEM2I_AT | Second innings, away team
 | ITEM2I_HT | Second innings, home team
 | ITEM2IB | 2nd inning (bottom)
 | ITEM2IT | 2nd inning (top)
 | ITEM2MAP | Second map
 | ITEM2P | 2nd period
 | ITEM2P_OT | 2nd period overtime
 | ITEM2Q | 2nd quarter
 | ITEM2SET | 2nd set
 | ITEM3G | 3rd game
 | ITEM3IB | 3rd inning (bottom)
 | ITEM3IT | 3rd inning (top)
 | ITEM3MAP | Third map
 | ITEM3P | 3rd period
 | ITEM3Q | 3rd quarter
 | ITEM3SET | 3rd set
 | ITEM4G | 4th game
 | ITEM4IB | 4th inning (bottom)
 | ITEM4IT | 4th inning (top)
 | ITEM4MAP | Fourth map
 | ITEM4P | 4th period
 | ITEM4Q | 4th quarter
 | ITEM4SET | 4th set
 | ITEM5G | 5th game
 | ITEM5IB | 5th inning (bottom)
 | ITEM5IT | 5th inning (top)
 | ITEM5MAP | Fifth map
 | ITEM5P | 5th period
 | ITEM5SET | 5th set
 | ITEM6IB | 6th inning (bottom)
 | ITEM6IT | 6th inning (top)
 | ITEM6MAP | Sixth map
 | ITEM6SET | 6th set
 | ITEM7IB | 7th inning (bottom)
 | ITEM7IT | 7th inning (top)
 | ITEM7MAP | Seventh map
 | ITEM7SET | 7th set
 | ITEM8IB | 8th inning (bottom)
 | ITEM8IT | 8th inning (top)
 | ITEM9IB | 9th inning (bottom)
 | ITEM9IT | 9th inning (top)
 | LUNCH_BREAK | Lunch break
 | NOT_STARTED | Not started
 | OT | Overtime
 | OT_HT | Overtime halftime
 | PAUSE1 | 1st pause
 | PAUSE2 | 2nd pause
 | PAUSE3 | 3rd pause
 | PAUSE4 | 4th pause
 | PAUSE5 | 5th pause
 | PAUSE6 | 6th pause
 | PAUSED | Paused
 | PEN | Penalties
 | POSTPONED | Postponed
 | RETIRED | Retired
 | RETIRED1 | 1st retired
 | RETIRED2 | 2nd retired
 | SD | Sudden death
 | SESSION_BREAK | Session break
 | SO_AT | Super over, away team
 | SO_BREAK | Super over break
 | SO_HT | Super over, home team
 | STARTED | Started
 | STUMPS | Stumps
 | TEA_BREAK | Tea break
 | UNDEFINED | Undefined
Public field | value__ |
 | WALKOVER | Walkover
 | WALKOVER1 | 1st walkover
 | WALKOVER2 | 2nd walkover
Top
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ABANDONED Field

EventStatusABANDONED Field

Abandoned

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ABANDONED = 46

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.AFTER_GSET Field

EventStatusAFTER_GSET Field

The after golden set

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus AFTER_GSET = 123

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.AFTER_OT Field

EventStatusAFTER_OT Field

After overtime

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus AFTER_OT = 36

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.AFTER_PEN Field

EventStatusAFTER_PEN Field

After penalties

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus AFTER_PEN = 39

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.AFTER_SD Field

EventStatusAFTER_SD Field

After sudden death

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus AFTER_SD = 95

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.AFTER_SO Field

EventStatusAFTER_SO Field

After super over

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus AFTER_SO = 107

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.AWAITING_GSET Field

EventStatusAWAITING_GSET Field

The awaiting golden set

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus AWAITING_GSET = 122

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.AWAITING_OT Field

EventStatusAWAITING_OT Field

Awaiting overtime

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus AWAITING_OT = 32

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.AWAITING_PEN Field

EventStatusAWAITING_PEN Field

Awaiting penalties

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus AWAITING_PEN = 37

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.AWAITING_SD Field

EventStatusAWAITING_SD Field

Awaiting sudden death

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus AWAITING_SD = 114

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.AWAITING_SO Field

EventStatusAWAITING_SO Field

Awaiting super over

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus AWAITING_SO = 104

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT1B1 Field

EventStatusBT1B1 Field

Break 1st top 1st bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT1B1 = 73

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT2B1 Field

EventStatusBT2B1 Field

Break 2nd top 1st bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT2B1 = 74

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT2B2 Field

EventStatusBT2B2 Field

Break 2nd top 2nd bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT2B2 = 75

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT3B2 Field

EventStatusBT3B2 Field

Break 3rd top 2nd bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT3B2 = 76

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT3B3 Field

EventStatusBT3B3 Field

Break 3rd top 3rd bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT3B3 = 77

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT4B3 Field

EventStatusBT4B3 Field

Break 4th top 3rd bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT4B3 = 78

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT4B4 Field

EventStatusBT4B4 Field

Break 4th top 4th bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT4B4 = 79

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT5B4 Field

EventStatusBT5B4 Field

Break 5th top 4th bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT5B4 = 80

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT5B5 Field

EventStatusBT5B5 Field

Break 5th top 5th bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT5B5 = 81

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT6B5 Field

EventStatusBT6B5 Field

Break 6th top 5th bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT6B5 = 82

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT6B6 Field

EventStatusBT6B6 Field

Break 6th top 6th bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT6B6 = 83

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT7B6 Field

EventStatusBT7B6 Field

Break 7th top 6th bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT7B6 = 84

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT7B7 Field

EventStatusBT7B7 Field

Break 7th top 7th bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT7B7 = 85

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT8B7 Field

EventStatusBT8B7 Field

Break 8th top 7th bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT8B7 = 86

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT8B8 Field

EventStatusBT8B8 Field

Break 8th top 8th bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT8B8 = 88

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT9B8 Field

EventStatusBT9B8 Field

Break 9th top 8th bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT9B8 = 89

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BT9B9 Field

EventStatusBT9B9 Field

Break 9th top 9th bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BT9B9 = 90

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BTEIB7 Field

EventStatusBTEIB7 Field

The btei b7

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BTEIB7 = 87

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BTEIB9 Field

EventStatusBTEIB9 Field

Break EI top 9th bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BTEIB9 = 91

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.BTEIBEI Field

EventStatusBTEIBEI Field

Break EI top EI bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus BTEIBEI = 92

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.CANCELED Field

EventStatusCANCELED Field

Canceled, used in LiveOdds

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus CANCELED = 43

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.CANCELLED Field

EventStatusCANCELLED Field

Cancelled, used in VHC, VDR, VTO

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus CANCELLED = 44

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.DEFAULTED1 Field

EventStatusDEFAULTED1 Field

Defaulted 1

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus DEFAULTED1 = 98

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.DEFAULTED2 Field

EventStatusDEFAULTED2 Field

Defaulted 2

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus DEFAULTED2 = 99

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.DELAYED Field

EventStatusDELAYED Field

Delayed

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus DELAYED = 42

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.EIB Field

EventStatusEIB Field

Extra inning bottom

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus EIB = 72

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.EIT Field

EventStatusEIT Field

Extra inning top

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus EIT = 71

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ENDED Field

EventStatusENDED Field

Ended

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ENDED = 40

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.GSET Field

EventStatusGSET Field

Golden set

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus GSET = 93

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.IN_PROGRESS Field

EventStatusIN_PROGRESS Field

In progress

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus IN_PROGRESS = 96

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.INJURY_BREAK Field

EventStatusINJURY_BREAK Field

Injury break

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus INJURY_BREAK = 113

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.INNINGS_BREAK Field

EventStatusINNINGS_BREAK Field

Innings break

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus INNINGS_BREAK = 108

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.INTERRUPTED Field

EventStatusINTERRUPTED Field

Interrupted

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus INTERRUPTED = 45

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM1G Field

EventStatusITEM1G Field

1st game

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM1G = 19

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM1I_AT Field

EventStatusITEM1I_AT Field

First innings, away team

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM1I_AT = 101

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM1I_HT Field

EventStatusITEM1I_HT Field

First innings, home team

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM1I_HT = 100

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM1IB Field

EventStatusITEM1IB Field

1st inning (bottom)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM1IB = 54

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM1IT Field

EventStatusITEM1IT Field

1st inning (top)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM1IT = 53

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM1MAP Field

EventStatusITEM1MAP Field

First map

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM1MAP = 115

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM1P Field

EventStatusITEM1P Field

1st period

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM1P = 3

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM1P_OT Field

EventStatusITEM1P_OT Field

1st period overtime

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM1P_OT = 33

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM1Q Field

EventStatusITEM1Q Field

1st quarter

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM1Q = 15

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM1SET Field

EventStatusITEM1SET Field

1st set

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM1SET = 8

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM2G Field

EventStatusITEM2G Field

2nd game

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM2G = 20

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM2I_AT Field

EventStatusITEM2I_AT Field

Second innings, away team

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM2I_AT = 103

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM2I_HT Field

EventStatusITEM2I_HT Field

Second innings, home team

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM2I_HT = 102

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM2IB Field

EventStatusITEM2IB Field

2nd inning (bottom)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM2IB = 56

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM2IT Field

EventStatusITEM2IT Field

2nd inning (top)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM2IT = 55

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM2MAP Field

EventStatusITEM2MAP Field

Second map

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM2MAP = 116

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM2P Field

EventStatusITEM2P Field

2nd period

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM2P = 4

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM2P_OT Field

EventStatusITEM2P_OT Field

2nd period overtime

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM2P_OT = 35

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM2Q Field

EventStatusITEM2Q Field

2nd quarter

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM2Q = 16

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM2SET Field

EventStatusITEM2SET Field

2nd set

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM2SET = 9

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM3G Field

EventStatusITEM3G Field

3rd game

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM3G = 21

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM3IB Field

EventStatusITEM3IB Field

3rd inning (bottom)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM3IB = 58

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM3IT Field

EventStatusITEM3IT Field

3rd inning (top)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM3IT = 57

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM3MAP Field

EventStatusITEM3MAP Field

Third map

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM3MAP = 117

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM3P Field

EventStatusITEM3P Field

3rd period

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM3P = 5

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM3Q Field

EventStatusITEM3Q Field

3rd quarter

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM3Q = 17

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM3SET Field

EventStatusITEM3SET Field

3rd set

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM3SET = 10

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM4G Field

EventStatusITEM4G Field

4th game

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM4G = 22

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM4IB Field

EventStatusITEM4IB Field

4th inning (bottom)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM4IB = 60

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM4IT Field

EventStatusITEM4IT Field

4th inning (top)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM4IT = 59

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM4MAP Field

EventStatusITEM4MAP Field

Fourth map

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM4MAP = 118

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM4P Field

EventStatusITEM4P Field

4th period

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM4P = 6

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM4Q Field

EventStatusITEM4Q Field

4th quarter

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM4Q = 18

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM4SET Field

EventStatusITEM4SET Field

4th set

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM4SET = 11

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM5G Field

EventStatusITEM5G Field

5th game

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM5G = 23

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM5IB Field

EventStatusITEM5IB Field

5th inning (bottom)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM5IB = 62

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM5IT Field

EventStatusITEM5IT Field

5th inning (top)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM5IT = 61

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM5MAP Field

EventStatusITEM5MAP Field

Fifth map

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM5MAP = 119

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM5P Field

EventStatusITEM5P Field

5th period

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM5P = 7

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM5SET Field

EventStatusITEM5SET Field

5th set

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM5SET = 12

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM6IB Field

EventStatusITEM6IB Field

6th inning (bottom)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM6IB = 64

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM6IT Field

EventStatusITEM6IT Field

6th inning (top)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM6IT = 63

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM6MAP Field

EventStatusITEM6MAP Field

Sixth map

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM6MAP = 120

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM6SET Field

EventStatusITEM6SET Field

6th set

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM6SET = 13

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM7IB Field

EventStatusITEM7IB Field

7th inning (bottom)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM7IB = 66

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM7IT Field

EventStatusITEM7IT Field

7th inning (top)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM7IT = 65

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM7MAP Field

EventStatusITEM7MAP Field

Seventh map

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM7MAP = 121

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM7SET Field

EventStatusITEM7SET Field

7th set

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM7SET = 14

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM8IB Field

EventStatusITEM8IB Field

8th inning (bottom)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM8IB = 68

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM8IT Field

EventStatusITEM8IT Field

8th inning (top)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM8IT = 67

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM9IB Field

EventStatusITEM9IB Field

9th inning (bottom)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM9IB = 70

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.ITEM9IT Field

EventStatusITEM9IT Field

9th inning (top)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus ITEM9IT = 69

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.LUNCH_BREAK Field

EventStatusLUNCH_BREAK Field

Lunch break

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus LUNCH_BREAK = 110

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.NOT_STARTED Field

EventStatusNOT_STARTED Field

Not started

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus NOT_STARTED = 1

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.OT Field

EventStatusOT Field

Overtime

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus OT = 31

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.OT_HT Field

EventStatusOT_HT Field

Overtime halftime

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus OT_HT = 34

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.PAUSE1 Field

EventStatusPAUSE1 Field

1st pause

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus PAUSE1 = 25

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.PAUSE2 Field

EventStatusPAUSE2 Field

2nd pause

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus PAUSE2 = 26

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.PAUSE3 Field

EventStatusPAUSE3 Field

3rd pause

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus PAUSE3 = 27

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.PAUSE4 Field

EventStatusPAUSE4 Field

4th pause

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus PAUSE4 = 28

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.PAUSE5 Field

EventStatusPAUSE5 Field

5th pause

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus PAUSE5 = 29

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.PAUSE6 Field

EventStatusPAUSE6 Field

6th pause

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus PAUSE6 = 30

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.PAUSED Field

EventStatusPAUSED Field

Paused

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus PAUSED = 24

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.PEN Field

EventStatusPEN Field

Penalties

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus PEN = 38

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.POSTPONED Field

EventStatusPOSTPONED Field

Postponed

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus POSTPONED = 41

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.RETIRED Field

EventStatusRETIRED Field

Retired

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus RETIRED = 50

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.RETIRED1 Field

EventStatusRETIRED1 Field

1st retired

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus RETIRED1 = 51

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.RETIRED2 Field

EventStatusRETIRED2 Field

2nd retired

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus RETIRED2 = 52

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.SD Field

EventStatusSD Field

Sudden death

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus SD = 94

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.SESSION_BREAK Field

EventStatusSESSION_BREAK Field

Session break

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus SESSION_BREAK = 97

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.SO_AT Field

EventStatusSO_AT Field

Super over, away team

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus SO_AT = 106

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.SO_BREAK Field

EventStatusSO_BREAK Field

Super over break

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus SO_BREAK = 109

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.SO_HT Field

EventStatusSO_HT Field

Super over, home team

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus SO_HT = 105

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.STARTED Field

EventStatusSTARTED Field

Started

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus STARTED = 2

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.STUMPS Field

EventStatusSTUMPS Field

Stumps

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus STUMPS = 112

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.TEA_BREAK Field

EventStatusTEA_BREAK Field

Tea break

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus TEA_BREAK = 111

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.UNDEFINED Field

EventStatusUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus UNDEFINED = 0

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.value__ Field

EventStatusvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Common.EventStatus.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.WALKOVER Field

EventStatusWALKOVER Field

Walkover

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus WALKOVER = 47

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.WALKOVER1 Field

EventStatusWALKOVER1 Field

1st walkover

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus WALKOVER1 = 48

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


EventStatus.WALKOVER2 Field

EventStatusWALKOVER2 Field

2nd walkover

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventStatus WALKOVER2 = 49

Field Value

EventStatus
See Also

Reference

EventStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommon Interface

Interface describing events and methods common for all LiveOdds feeds which do not contain outrights

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOddsCommon : ILiveOddsCommonBase,
    ILiveFeeds, IStartable

The ILiveOddsCommon type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from ILiveFeeds)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from ILiveOddsCommonBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from ILiveFeeds)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from ILiveFeeds)
Public property | ServerTime | Get approximate server time. (Inherited from ILiveFeeds)
Public property | SubscribedEvents | All event ids we are currently subscribed to. (Inherited from ILiveFeeds)
Top
Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface. (Inherited from ILiveFeeds)
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup. (Inherited from ILiveFeeds)
Public method | GetEventList(IEnumerableInt64) | Request meta-information about the events(matches, races) specified by it's ids The response message includes teams playing, match date and time, TV channel names and sport/category/tournament for every match. (Inherited from ILiveOddsCommonBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | Request meta-information about all events(matches, races, outcomes, ...) in a given interval. The maximum interval is 10 days. If no date is specified, all events started 24 hours in the past, and 7 days in the future are returned. The response message includes teams playing, event date and time, TV channel names and sport/category/tournament for every event. (Inherited from ILiveOddsCommonBase)
Public method | GetEventMessages | Request exact match messages ("error" server request). (Inherited from ILiveOddsCommonBase)
Public method | GetEventsStatus | Requests the match statuses for a given time ("current" server request). This includes odds, activation of odds and match status for the matches requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetEventStatus | Requests the match status for a given time ("current" server request). This includes odds, activation of odds and match status for the match requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events. (Inherited from ILiveFeeds)
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent. (Inherited from ILiveFeeds)
Top
Events
Name | Description
Public event | OnAlive | Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
Public event OnBetCancel Signals that odds type for a match should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
(Inherited from ILiveOddsCommonBase)
Public event OnBetCancelUndo Signals that an odds type has been cancelled due to some reason when it actually shouldnt have been. This can be undone. The Odds element should match the Odds element in the corresponding OnCancelBet event. The same goes for the starttime and endtime - they should match the values in the OnCancelBet event.
(Inherited from ILiveOddsCommonBase)
Public event OnBetClear

Signals that situation occurred during the match so that a bet can be decided. Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

(Inherited from ILiveOddsCommonBase)
Public event OnBetClearRollback Signals that there was some wrong information sent out about bet clearing. Notification includes the Odds element that rollback is targeted to. The clearedscore contains the cleared score of the original bet clearing. The time for the original bet clearing is timestamp – time seconds. The Odds element includes a list of EventOddsField elements to indicate what field was cleared in the original bet clearing. The Client system is responsible to handle this accordingly.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStart Signals that bets for a specific match can open again after they have been stopped.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStop Signals that a bet stop situation occurred for a specific match. OnBetStart event is triggered when the bets can open again.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionStable Signals that the initial sync is complete and the connection to the server is stable.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionUnstable Signals that the connection is unstable.
(Inherited from ILiveOddsCommonBase)
Public event OnEventMessages Signals that all of the requested match messages were received.
(Inherited from ILiveOddsCommonBase)
Public event OnEventStatus Signals that a requested match status was received.
(Inherited from ILiveOddsCommonBase)
Public event OnFeedError Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
(Inherited from ILiveFeeds)
Public event OnMetaInfo Event contains information like the date and time of the match, sport, category, tournament, teams and what TV-channels a match is broadcasted on. When a match is removed, Active is set to false for the match with an optional textual reason why the match has been removed. Active flag can also set to false if the client has unregistered a match. The message element will include the text unregistered in such cases. Match meta-information will also be broadcasted when a match is added to the system, or when a match has been cancelled.
(Inherited from ILiveOddsCommonBase)
Public event OnOddsChange Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
(Inherited from ILiveOddsCommonBase)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommon Properties

The ILiveOddsCommon type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from ILiveFeeds)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from ILiveOddsCommonBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from ILiveFeeds)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from ILiveFeeds)
Public property | ServerTime | Get approximate server time. (Inherited from ILiveFeeds)
Public property | SubscribedEvents | All event ids we are currently subscribed to. (Inherited from ILiveFeeds)
Top
See Also

Reference

ILiveOddsCommon Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommon Methods

The ILiveOddsCommon type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface. (Inherited from ILiveFeeds)
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup. (Inherited from ILiveFeeds)
Public method | GetEventList(IEnumerableInt64) | Request meta-information about the events(matches, races) specified by it's ids The response message includes teams playing, match date and time, TV channel names and sport/category/tournament for every match. (Inherited from ILiveOddsCommonBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | Request meta-information about all events(matches, races, outcomes, ...) in a given interval. The maximum interval is 10 days. If no date is specified, all events started 24 hours in the past, and 7 days in the future are returned. The response message includes teams playing, event date and time, TV channel names and sport/category/tournament for every event. (Inherited from ILiveOddsCommonBase)
Public method | GetEventMessages | Request exact match messages ("error" server request). (Inherited from ILiveOddsCommonBase)
Public method | GetEventsStatus | Requests the match statuses for a given time ("current" server request). This includes odds, activation of odds and match status for the matches requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetEventStatus | Requests the match status for a given time ("current" server request). This includes odds, activation of odds and match status for the match requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events. (Inherited from ILiveFeeds)
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent. (Inherited from ILiveFeeds)
Top
See Also

Reference

ILiveOddsCommon Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommon Events

The ILiveOddsCommon type exposes the following members.

Events
Name | Description
Public event | OnAlive | Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
Public event OnBetCancel Signals that odds type for a match should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
(Inherited from ILiveOddsCommonBase)
Public event OnBetCancelUndo Signals that an odds type has been cancelled due to some reason when it actually shouldnt have been. This can be undone. The Odds element should match the Odds element in the corresponding OnCancelBet event. The same goes for the starttime and endtime - they should match the values in the OnCancelBet event.
(Inherited from ILiveOddsCommonBase)
Public event OnBetClear

Signals that situation occurred during the match so that a bet can be decided. Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

(Inherited from ILiveOddsCommonBase)
Public event OnBetClearRollback Signals that there was some wrong information sent out about bet clearing. Notification includes the Odds element that rollback is targeted to. The clearedscore contains the cleared score of the original bet clearing. The time for the original bet clearing is timestamp – time seconds. The Odds element includes a list of EventOddsField elements to indicate what field was cleared in the original bet clearing. The Client system is responsible to handle this accordingly.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStart Signals that bets for a specific match can open again after they have been stopped.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStop Signals that a bet stop situation occurred for a specific match. OnBetStart event is triggered when the bets can open again.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionStable Signals that the initial sync is complete and the connection to the server is stable.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionUnstable Signals that the connection is unstable.
(Inherited from ILiveOddsCommonBase)
Public event OnEventMessages Signals that all of the requested match messages were received.
(Inherited from ILiveOddsCommonBase)
Public event OnEventStatus Signals that a requested match status was received.
(Inherited from ILiveOddsCommonBase)
Public event OnFeedError Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
(Inherited from ILiveFeeds)
Public event OnMetaInfo Event contains information like the date and time of the match, sport, category, tournament, teams and what TV-channels a match is broadcasted on. When a match is removed, Active is set to false for the match with an optional textual reason why the match has been removed. Active flag can also set to false if the client has unregistered a match. The message element will include the text unregistered in such cases. Match meta-information will also be broadcasted when a match is added to the system, or when a match has been cancelled.
(Inherited from ILiveOddsCommonBase)
Public event OnOddsChange Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
(Inherited from ILiveOddsCommonBase)
Top
See Also

Reference

ILiveOddsCommon Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommon.OnAlive Event

ILiveOddsCommonOnAlive Event

Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<AliveEventArgs> OnAlive

Value

EventHandler AliveEventArgs
Remarks
SDK will send out bet stops for all matches if no alive message has been received in the last 20 seconds. In this case client shouldn't accept any bets for any matches until the connection is stable again. SDK will also take care that if the connection to the Betradar server is lost, bet stops for all matches are sent out until a stable connection is established again.
See Also

Reference

ILiveOddsCommon Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase Interface

Interface describing events and methods common for all LiveOdds feeds

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOddsCommonBase : ILiveFeeds,
    IStartable

The ILiveOddsCommonBase type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from ILiveFeeds)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely?
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from ILiveFeeds)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from ILiveFeeds)
Public property | ServerTime | Get approximate server time. (Inherited from ILiveFeeds)
Public property | SubscribedEvents | All event ids we are currently subscribed to. (Inherited from ILiveFeeds)
Top
Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface. (Inherited from ILiveFeeds)
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup. (Inherited from ILiveFeeds)
Public method | GetEventList(IEnumerableInt64) | Request meta-information about the events(matches, races) specified by it's ids The response message includes teams playing, match date and time, TV channel names and sport/category/tournament for every match.
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | Request meta-information about all events(matches, races, outcomes, ...) in a given interval. The maximum interval is 10 days. If no date is specified, all events started 24 hours in the past, and 7 days in the future are returned. The response message includes teams playing, event date and time, TV channel names and sport/category/tournament for every event.
Public method | GetEventMessages | Request exact match messages ("error" server request).
Public method | GetEventsStatus | Requests the match statuses for a given time ("current" server request). This includes odds, activation of odds and match status for the matches requested, current bet status and all bet clearing messages before the timestamp.
Public method | GetEventStatus | Requests the match status for a given time ("current" server request). This includes odds, activation of odds and match status for the match requested, current bet status and all bet clearing messages before the timestamp.
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events. (Inherited from ILiveFeeds)
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent. (Inherited from ILiveFeeds)
Top
Events
Name | Description
Public event | OnBetCancel | Signals that odds type for a match should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
Public event | OnBetCancelUndo | Signals that an odds type has been cancelled due to some reason when it actually shouldnt have been. This can be undone. The Odds element should match the Odds element in the corresponding OnCancelBet event. The same goes for the starttime and endtime - they should match the values in the OnCancelBet event.
Public event OnBetClear

Signals that situation occurred during the match so that a bet can be decided. Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

Public event | OnBetClearRollback | Signals that there was some wrong information sent out about bet clearing. Notification includes the Odds element that rollback is targeted to. The clearedscore contains the cleared score of the original bet clearing. The time for the original bet clearing is timestamp – time seconds. The Odds element includes a list of EventOddsField elements to indicate what field was cleared in the original bet clearing. The Client system is responsible to handle this accordingly.
Public event | OnBetStart | Signals that bets for a specific match can open again after they have been stopped.
Public event | OnBetStop | Signals that a bet stop situation occurred for a specific match. OnBetStart event is triggered when the bets can open again.
Public event | OnConnectionStable | Signals that the initial sync is complete and the connection to the server is stable.
Public event | OnConnectionUnstable | Signals that the connection is unstable.
Public event | OnEventMessages | Signals that all of the requested match messages were received.
Public event | OnEventStatus | Signals that a requested match status was received.
Public event OnFeedError Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
(Inherited from ILiveFeeds)
Public event | OnMetaInfo | Event contains information like the date and time of the match, sport, category, tournament, teams and what TV-channels a match is broadcasted on. When a match is removed, Active is set to false for the match with an optional textual reason why the match has been removed. Active flag can also set to false if the client has unregistered a match. The message element will include the text unregistered in such cases. Match meta-information will also be broadcasted when a match is added to the system, or when a match has been cancelled.
Public event | OnOddsChange | Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase Properties

The ILiveOddsCommonBase type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from ILiveFeeds)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely?
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from ILiveFeeds)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from ILiveFeeds)
Public property | ServerTime | Get approximate server time. (Inherited from ILiveFeeds)
Public property | SubscribedEvents | All event ids we are currently subscribed to. (Inherited from ILiveFeeds)
Top
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.IsConnectionStable Property

ILiveOddsCommonBaseIsConnectionStable Property

Is the current connection stable enough to accept bets safely?

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool IsConnectionStable { get; }

Property Value

Boolean
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase Methods

The ILiveOddsCommonBase type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface. (Inherited from ILiveFeeds)
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup. (Inherited from ILiveFeeds)
Public method | GetEventList(IEnumerableInt64) | Request meta-information about the events(matches, races) specified by it's ids The response message includes teams playing, match date and time, TV channel names and sport/category/tournament for every match.
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | Request meta-information about all events(matches, races, outcomes, ...) in a given interval. The maximum interval is 10 days. If no date is specified, all events started 24 hours in the past, and 7 days in the future are returned. The response message includes teams playing, event date and time, TV channel names and sport/category/tournament for every event.
Public method | GetEventMessages | Request exact match messages ("error" server request).
Public method | GetEventsStatus | Requests the match statuses for a given time ("current" server request). This includes odds, activation of odds and match status for the matches requested, current bet status and all bet clearing messages before the timestamp.
Public method | GetEventStatus | Requests the match status for a given time ("current" server request). This includes odds, activation of odds and match status for the match requested, current bet status and all bet clearing messages before the timestamp.
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events. (Inherited from ILiveFeeds)
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent. (Inherited from ILiveFeeds)
Top
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.GetEventList Method

ILiveOddsCommonBaseGetEventList Method

Overload List
 | Name | Description
Public method | GetEventList(IEnumerableInt64) | Request meta-information about the events(matches, races) specified by it's ids The response message includes teams playing, match date and time, TV channel names and sport/category/tournament for every match.
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | Request meta-information about all events(matches, races, outcomes, ...) in a given interval. The maximum interval is 10 days. If no date is specified, all events started 24 hours in the past, and 7 days in the future are returned. The response message includes teams playing, event date and time, TV channel names and sport/category/tournament for every event.
Top
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.GetEventList(IEnumerable<Int64>) Method

ILiveOddsCommonBaseGetEventList(IEnumerableInt64) Method

Request meta-information about the events(matches, races) specified by it's ids The response message includes teams playing, match date and time, TV channel names and sport/category/tournament for every match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long GetEventList(
    IEnumerable<long> event_ids
)

Parameters

event_ids IEnumerable Int64
Return meta info only for the matches specified.

Return Value

Int64
Returns immediately with the request number or zero, but expect to receive OnMetaInfo event in response
See Also

Reference

ILiveOddsCommonBase Interface
GetEventList Overload
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.GetEventList(Nullable<DateTime>, Nullable<DateTime>, Boolean) Method

ILiveOddsCommonBaseGetEventList(NullableDateTime, NullableDateTime, Boolean) Method

Request meta-information about all events(matches, races, outcomes, ...) in a given interval. The maximum interval is 10 days. If no date is specified, all events started 24 hours in the past, and 7 days in the future are returned. The response message includes teams playing, event date and time, TV channel names and sport/category/tournament for every event.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long GetEventList(
    DateTime? from,
    DateTime? to,
    bool include_available = false
)

Parameters

from Nullable DateTime
Start of time interval
to Nullable DateTime
End of time interval
include_available Boolean (Optional)
Include matches that are available for booking but not booked yet.

Return Value

Int64
Returns immediately with the request number or zero, but expect to receive OnMetaInfo event in response
See Also

Reference

ILiveOddsCommonBase Interface
GetEventList Overload
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.GetEventMessages Method

ILiveOddsCommonBaseGetEventMessages Method

Request exact match messages ("error" server request).

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long GetEventMessages(
    long match_id,
    long? from = 1,
    long? to = 9223372036854775807,
    bool package = true
)

Parameters

match_id Int64
Match id
from Nullable Int64 (Optional)
Sequence number of the first included message (null means 1)
to Nullable Int64 (Optional)
Sequence number of the last included message or greater (null means MaxValue)
package Boolean (Optional)
All replies get packaged in one see OnEventMessages when true; else normal events will get invoked.

Return Value

Int64
Returns immediately with the request number or zero but expect to receive an event afterwards.
Remarks
Notice that the reply is throttled on the server so it may take some minutes to receive the whole reply. SDK already handles error recovery for on-going matches, no matter whether there is a crash or connection to the server is lost, so during normal operation there should be no need to call this method!
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.GetEventsStatus Method

ILiveOddsCommonBaseGetEventsStatus Method

Requests the match statuses for a given time ("current" server request). This includes odds, activation of odds and match status for the matches requested, current bet status and all bet clearing messages before the timestamp.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long GetEventsStatus(
    IEnumerable<long> event_id,
    DateTime? from = null,
    bool package = true
)

Parameters

event_id IEnumerable Int64
Match ids, maximum is 50 per request to avoid having server queue filling up
from Nullable DateTime (Optional)
Matches statuses on particular time (leave null for current match status)
package Boolean (Optional)
All replies get packaged in one see OnEventStatus when true; else normal events will get invoked.

Return Value

Int64
Returns immediately with the request number or zero but expect to receive an event afterwards.
Remarks
SDK already handles error recovery for on-going matches, no matter whether there is a crash or connection to the server is lost, so during normal operation there should be no need to call this method! The purpose of it is for book-keeping after a match has ended. For instance after a match is not active anymore you might want to settle all open bets or check whether a match is really about to start. Notice that the match messages do not include a message number (msgnr). The received "state" is an abstract concept derived from the sent messages not any sent message so it cannot have a sequence number. If you are interested in replaying certain messages for a match you could try GetEventMessages(Int64, NullableInt64, NullableInt64, Boolean).
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.GetEventStatus Method

ILiveOddsCommonBaseGetEventStatus Method

Requests the match status for a given time ("current" server request). This includes odds, activation of odds and match status for the match requested, current bet status and all bet clearing messages before the timestamp.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long GetEventStatus(
    long event_id,
    DateTime? from = null,
    bool package = true
)

Parameters

event_id Int64
Match id
from Nullable DateTime (Optional)
Match status on particular time (leave null for current match status)
package Boolean (Optional)
All replies get packaged in one see OnEventStatus when true; else normal events will get invoked.

Return Value

Int64
Returns immediately with the request number or zero but expect to receive an event afterwards.
Remarks
SDK already handles error recovery for on-going matches, no matter whether there is a crash or connection to the server is lost, so during normal operation there should be no need to call this method! The purpose of it is for book-keeping after a match has ended. For instance after a match is not active anymore you might want to settle all open bets or check whether a match is really about to start. Notice that the match messages do not include a message number (msgnr). The received "state" is an abstract concept derived from the sent messages not any sent message so it cannot have a sequence number. If you are interested in replaying certain messages for a match you could try GetEventMessages(Int64, NullableInt64, NullableInt64, Boolean).
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase Events

The ILiveOddsCommonBase type exposes the following members.

Events
Name | Description
Public event | OnBetCancel | Signals that odds type for a match should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
Public event | OnBetCancelUndo | Signals that an odds type has been cancelled due to some reason when it actually shouldnt have been. This can be undone. The Odds element should match the Odds element in the corresponding OnCancelBet event. The same goes for the starttime and endtime - they should match the values in the OnCancelBet event.
Public event OnBetClear

Signals that situation occurred during the match so that a bet can be decided. Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

Public event | OnBetClearRollback | Signals that there was some wrong information sent out about bet clearing. Notification includes the Odds element that rollback is targeted to. The clearedscore contains the cleared score of the original bet clearing. The time for the original bet clearing is timestamp – time seconds. The Odds element includes a list of EventOddsField elements to indicate what field was cleared in the original bet clearing. The Client system is responsible to handle this accordingly.
Public event | OnBetStart | Signals that bets for a specific match can open again after they have been stopped.
Public event | OnBetStop | Signals that a bet stop situation occurred for a specific match. OnBetStart event is triggered when the bets can open again.
Public event | OnConnectionStable | Signals that the initial sync is complete and the connection to the server is stable.
Public event | OnConnectionUnstable | Signals that the connection is unstable.
Public event | OnEventMessages | Signals that all of the requested match messages were received.
Public event | OnEventStatus | Signals that a requested match status was received.
Public event OnFeedError Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
(Inherited from ILiveFeeds)
Public event | OnMetaInfo | Event contains information like the date and time of the match, sport, category, tournament, teams and what TV-channels a match is broadcasted on. When a match is removed, Active is set to false for the match with an optional textual reason why the match has been removed. Active flag can also set to false if the client has unregistered a match. The message element will include the text unregistered in such cases. Match meta-information will also be broadcasted when a match is added to the system, or when a match has been cancelled.
Public event | OnOddsChange | Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
Top
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.OnBetCancel Event

ILiveOddsCommonBaseOnBetCancel Event

Signals that odds type for a match should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<BetCancelEventArgs> OnBetCancel

Value

EventHandler BetCancelEventArgs
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.OnBetCancelUndo Event

ILiveOddsCommonBaseOnBetCancelUndo Event

Signals that an odds type has been cancelled due to some reason when it actually shouldnt have been. This can be undone. The Odds element should match the Odds element in the corresponding OnCancelBet event. The same goes for the starttime and endtime - they should match the values in the OnCancelBet event.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<BetCancelUndoEventArgs> OnBetCancelUndo

Value

EventHandler BetCancelUndoEventArgs
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.OnBetClear Event

ILiveOddsCommonBaseOnBetClear Event

Signals that situation occurred during the match so that a bet can be decided. Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<BetClearEventArgs> OnBetClear

Value

EventHandler BetClearEventArgs
Remarks

Some bettypes, like asian handicap and asian total, can include void factor for each EventOddsField element. Void factor can either be 1 or 0.5 indicating that the whole or half the bet is voided and should be refunded to the customer. When the void factor is set to 0.5 the outcome attribute will indicate if the other half has won or lost.

These are all possible combinations of outcome and void factors:

  1. outcome="0" and no voidfactor: Lose entire bet
  2. outcome="1" and no voidfactor: Win entire bet
  3. outcome="0" and voidfactor="1": Refund entire bet
  4. outcome="1" and voidfactor="0.5": Refund half bet and win other half
  5. outcome="0" and voidfactor="0.5": Refund half bet and lose other half

See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.OnBetClearRollback Event

ILiveOddsCommonBaseOnBetClearRollback Event

Signals that there was some wrong information sent out about bet clearing. Notification includes the Odds element that rollback is targeted to. The clearedscore contains the cleared score of the original bet clearing. The time for the original bet clearing is timestamp – time seconds. The Odds element includes a list of EventOddsField elements to indicate what field was cleared in the original bet clearing. The Client system is responsible to handle this accordingly.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<BetClearRollbackEventArgs> OnBetClearRollback

Value

EventHandler BetClearRollbackEventArgs
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.OnBetStart Event

ILiveOddsCommonBaseOnBetStart Event

Signals that bets for a specific match can open again after they have been stopped.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<BetStartEventArgs> OnBetStart

Value

EventHandler BetStartEventArgs
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.OnBetStop Event

ILiveOddsCommonBaseOnBetStop Event

Signals that a bet stop situation occurred for a specific match. OnBetStart event is triggered when the bets can open again.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<BetStopEventArgs> OnBetStop

Value

EventHandler BetStopEventArgs
Remarks
Bet stop is triggered after following events take place:
  1. Goals
  2. Red cards
  3. Penalty
  4. One on one situations
  5. Free kicks within 20 meters
  6. Match is interrupted temporarily
Administrative events which cause a bet stop condition:
  1. Loss of TV coverage
  2. Loss of connection to the scout
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.OnConnectionStable Event

ILiveOddsCommonBaseOnConnectionStable Event

Signals that the initial sync is complete and the connection to the server is stable.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler OnConnectionStable

Value

EventHandler
Remarks
Only after this event match state changes SHOULD be processed (and bets accepted). Messages received before that event should not be completely ignored, but handled with care.
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.OnConnectionUnstable Event

ILiveOddsCommonBaseOnConnectionUnstable Event

Signals that the connection is unstable.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler OnConnectionUnstable

Value

EventHandler
Remarks
After this event match state changes SHOULD NOT be processed (and bets accepted). Messages received after that event should not be completely ignored, but handled with care.
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.OnEventMessages Event

ILiveOddsCommonBaseOnEventMessages Event

Signals that all of the requested match messages were received.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<EventDataReceivedEventArgs> OnEventMessages

Value

EventHandler EventDataReceivedEventArgs
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.OnEventStatus Event

ILiveOddsCommonBaseOnEventStatus Event

Signals that a requested match status was received.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<EventDataReceivedEventArgs> OnEventStatus

Value

EventHandler EventDataReceivedEventArgs
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.OnMetaInfo Event

ILiveOddsCommonBaseOnMetaInfo Event

Event contains information like the date and time of the match, sport, category, tournament, teams and what TV-channels a match is broadcasted on. When a match is removed, Active is set to false for the match with an optional textual reason why the match has been removed. Active flag can also set to false if the client has unregistered a match. The message element will include the text unregistered in such cases. Match meta-information will also be broadcasted when a match is added to the system, or when a match has been cancelled.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MetaInfoEventArgs> OnMetaInfo

Value

EventHandler MetaInfoEventArgs
Remarks

The teams have two id's; one named id and another named uniqueId. The id is for that team in that tournament, and the uniqueId is for that team in all tournaments. Not all teams have the uniqueId attribute, so it should only be used to identify that two teams in different tournaments are the same.

It is possible to include you own match id’s in the meta message. To do this you need to contact our support team, so they can setup this. When this is done an extra attribute named SourceId will be included in the meta event. It will be left empty if we are missing your id for a particular match.

See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ILiveOddsCommonBase.OnOddsChange Event

ILiveOddsCommonBaseOnOddsChange Event

Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OddsChangeEventArgs> OnOddsChange

Value

EventHandler OddsChangeEventArgs
See Also

Reference

ILiveOddsCommonBase Interface
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


IrrelevantOddsChange Class

Indicates that a change occurred which should be of no interest to the client. This could for example be bet clearing of an odds type which is unsubscribed. If this is not set, then an odds update is sent instead.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderWithOddsEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsChange
Sportradar.SDK.FeedProviders.LiveOdds.CommonIrrelevantOddsChange

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class IrrelevantOddsChange : OddsChange

The IrrelevantOddsChange type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event (Inherited from SingleHeaderWithOddsEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides OddsChangeToString)
Top
Remarks
This message is only active if client has enabled the "Send irrelevant change message for changes that aren’t of interest" XML configuration option.
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


IrrelevantOddsChange Properties

The IrrelevantOddsChange type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event (Inherited from SingleHeaderWithOddsEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

IrrelevantOddsChange Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


IrrelevantOddsChange Methods

The IrrelevantOddsChange type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides OddsChangeToString)
Top
See Also

Reference

IrrelevantOddsChange Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


IrrelevantOddsChange.ToString Method

IrrelevantOddsChangeToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

IrrelevantOddsChange Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfo Class

Contains event meta-information in response to client meta request or when a event is added to the system or when a event has been cancelled.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonMetaInfo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MetaInfo : OddsEntityBase

The MetaInfo type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | MetaInfoDataContainer |
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides OddsEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfo Properties

The MetaInfo type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | MetaInfoDataContainer |
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

MetaInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfo.MetaInfoDataContainer Property

MetaInfoMetaInfoDataContainer Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Common.MetaInfo.MetaInfoDataContainer"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MetaInfoDataContainer MetaInfoDataContainer { get; }

Property Value

MetaInfoDataContainer
See Also

Reference

MetaInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfo Methods

The MetaInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides OddsEntityBaseToString)
Top
See Also

Reference

MetaInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfo.ToString Method

MetaInfoToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

MetaInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfoDataContainer Class

Base class for data contained in MetaInfo. Classes extending this one are LiveOddsMetaData and RaceMetaData
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonMetaInfoDataContainer
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsLiveOddsMetaData
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.CommonRaceMetaData

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class MetaInfoDataContainer

The MetaInfoDataContainer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfoDataContainer Methods

The MetaInfoDataContainer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MetaInfoDataContainer Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfoEventArgs Class

Event arguments passed with OnMetaInfo.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.CommonMetaInfoEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MetaInfoEventArgs : EventArgs

The MetaInfoEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MetaInfoEventArgs | Initializes a new instance of the MetaInfoEventArgs class
Top
Properties
 | Name | Description
Public property | MetaInfo | Entitiy that contains all the info about the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfoEventArgs Constructor

Initializes a new instance of the MetaInfoEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MetaInfoEventArgs()
See Also

Reference

MetaInfoEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfoEventArgs Properties

The MetaInfoEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MetaInfo | Entitiy that contains all the info about the event
Top
See Also

Reference

MetaInfoEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfoEventArgs.MetaInfo Property

MetaInfoEventArgsMetaInfo Property

Entitiy that contains all the info about the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MetaInfo MetaInfo { get; }

Property Value

MetaInfo
See Also

Reference

MetaInfoEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfoEventArgs Methods

The MetaInfoEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MetaInfoEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfoReply Class

Asynchronous response wrapper for the GetMatchListAsync method.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonMetaInfoReply

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class MetaInfoReply

The MetaInfoReply type exposes the following members.

Constructors
 | Name | Description
Public method | MetaInfoReply | Initializes a new instance of the MetaInfoReply class
Top
Properties
 | Name | Description
Public property | MatchHeaderInfos | Array of match infos.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfoReply Constructor

Initializes a new instance of the MetaInfoReply class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MetaInfoReply()
See Also

Reference

MetaInfoReply Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfoReply Properties

The MetaInfoReply type exposes the following members.

Properties
 | Name | Description
Public property | MatchHeaderInfos | Array of match infos.
Top
See Also

Reference

MetaInfoReply Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfoReply.MatchHeaderInfos Property

MetaInfoReplyMatchHeaderInfos Property

Array of match infos.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MetaInfo MatchHeaderInfos { get; set; }

Property Value

MetaInfo
See Also

Reference

MetaInfoReply Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaInfoReply Methods

The MetaInfoReply type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MetaInfoReply Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaWaiter Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Common.MetaWaiter"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonBaseWaiter
Sportradar.SDK.FeedProviders.LiveOdds.CommonMetaWaiter

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class MetaWaiter : BaseWaiter, IDisposable

The MetaWaiter type exposes the following members.

Constructors
 | Name | Description
Public method | MetaWaiter | Initializes a new instance of the MetaWaiter class
Top
Properties
 | Name | Description
Public property | Action | (Inherited from BaseWaiter)
Public property | RequestNr | (Inherited from BaseWaiter)
Public property | Result |
Top
Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class. (Inherited from BaseWaiter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction | (Inherited from BaseWaiter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait | (Inherited from BaseWaiter)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaWaiter Constructor

Initializes a new instance of the MetaWaiter class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MetaWaiter(
    ILiveOdds itf
)

Parameters

itf ILiveOdds

[Missing <param name="itf"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.MetaWaiter.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOdds)"]

See Also

Reference

MetaWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaWaiter Properties

The MetaWaiter type exposes the following members.

Properties
 | Name | Description
Public property | Action | (Inherited from BaseWaiter)
Public property | RequestNr | (Inherited from BaseWaiter)
Public property | Result |
Top
See Also

Reference

MetaWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaWaiter.Result Property

MetaWaiterResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Common.MetaWaiter.Result"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MetaInfoReply Result { get; }

Property Value

MetaInfoReply
See Also

Reference

MetaWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


MetaWaiter Methods

The MetaWaiter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class. (Inherited from BaseWaiter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction | (Inherited from BaseWaiter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait | (Inherited from BaseWaiter)
Top
See Also

Reference

MetaWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsChange Class

When an odds change occurs, all the odds types for that match are sent in a message. Only active odds types contain odds fields, while inactive odds types do not. Each odds type also has an attribute named changed which indicates whether this odds type has been changed or not. An attribute score indicates the current score in the match.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderWithOddsEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsChange
Sportradar.SDK.FeedProviders.LiveOdds.CommonIrrelevantOddsChange

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OddsChange : SingleHeaderWithOddsEvent

The OddsChange type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event (Inherited from SingleHeaderWithOddsEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderWithOddsEventToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsChange Properties

The OddsChange type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event (Inherited from SingleHeaderWithOddsEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

OddsChange Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsChange Methods

The OddsChange type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderWithOddsEventToString)
Top
See Also

Reference

OddsChange Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsChange.ToString Method

OddsChangeToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

OddsChange Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsChangeEventArgs Class

Event arguments passed with OnOddsChange.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsChangeEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OddsChangeEventArgs : EventArgs

The OddsChangeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OddsChangeEventArgs | Initializes a new instance of the OddsChangeEventArgs class
Top
Properties
 | Name | Description
Public property | OddsChange | Entitiy that contains all the info about the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsChangeEventArgs Constructor

Initializes a new instance of the OddsChangeEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsChangeEventArgs()
See Also

Reference

OddsChangeEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsChangeEventArgs Properties

The OddsChangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OddsChange | Entitiy that contains all the info about the event
Top
See Also

Reference

OddsChangeEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsChangeEventArgs.OddsChange Property

OddsChangeEventArgsOddsChange Property

Entitiy that contains all the info about the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsChange OddsChange { get; }

Property Value

OddsChange
See Also

Reference

OddsChangeEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsChangeEventArgs Methods

The OddsChangeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OddsChangeEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase Class

Serves as a base class that all LiveOdds entities should be derived from.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
More

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class OddsEntityBase : EntityBase

The OddsEntityBase type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually).
Public property | Messages | Additional textual information attached to the message.
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it.
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly.
Public property | ReplyType | Message reply type (e.g. Current, Error, Register)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...)
Public property | ServerVersion | XML feeds server version
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback".
Public property | Timestamp | Time from server in UTC.
Public property | VirtualGameId | Virtual game id.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides EntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonAlive
Sportradar.SDK.FeedProviders.LiveOdds.CommonMetaInfo
Sportradar.SDK.FeedProviders.LiveOdds.CommonReplyStartEnd
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightEvent


OddsEntityBase Properties

The OddsEntityBase type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually).
Public property | Messages | Additional textual information attached to the message.
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it.
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly.
Public property | ReplyType | Message reply type (e.g. Current, Error, Register)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...)
Public property | ServerVersion | XML feeds server version
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback".
Public property | Timestamp | Time from server in UTC.
Public property | VirtualGameId | Virtual game id.
Top
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase.IsOutOfBand Property

OddsEntityBaseIsOutOfBand Property

Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually).

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsOutOfBand { get; set; }

Property Value

Boolean
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase.Messages Property

OddsEntityBaseMessages Property

Additional textual information attached to the message.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string[] Messages { get; }

Property Value

String
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase.Msgnr Property

OddsEntityBaseMsgnr Property

To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Msgnr { get; }

Property Value

Nullable Int64
Remarks

If "Send bet clearings even if match is not active" XML configuration option is enabled Sportradar will send bet clearings and bet cancellations even if match has been deactivated. When this option has been activated, you will not receive all msgnr for that match.

For example, you might have received up to msgnr 100 for a match, and then it is deactivated. When the match has ended you will receive all bet clearings starting at msgnr 135 for example. Also during the bet clearing some msgnr might be omitted.

See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase.ReplyNr Property

OddsEntityBaseReplyNr Property

Reply number matching the request number, thus enabling us to pair request and response messages properly.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? ReplyNr { get; }

Property Value

Nullable Int64
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase.ReplyType Property

OddsEntityBaseReplyType Property

Message reply type (e.g. Current, Error, Register)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsReplyType? ReplyType { get; }

Property Value

Nullable OddsReplyType
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase.ServerType Property

OddsEntityBaseServerType Property

Live odds feed server type (e.g. LiveOdds, BetPal, ...)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsServerType? ServerType { get; }

Property Value

Nullable OddsServerType
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase.ServerVersion Property

OddsEntityBaseServerVersion Property

XML feeds server version

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ServerVersion { get; }

Property Value

String
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase.Status Property

OddsEntityBaseStatus Property

Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsStatus Status { get; set; }

Property Value

OddsStatus
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase.Time Property

OddsEntityBaseTime Property

Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback".

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Time { get; }

Property Value

Nullable Int64
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase.Timestamp Property

OddsEntityBaseTimestamp Property

Time from server in UTC.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime Timestamp { get; }

Property Value

DateTime
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase.VirtualGameId Property

OddsEntityBaseVirtualGameId Property

Virtual game id.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? VirtualGameId { get; }

Property Value

Nullable Int64
Remarks
If one server is used for multiple feeds this identifies the source.
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase Methods

The OddsEntityBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides EntityBaseToString)
Top
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsEntityBase.ToString Method

OddsEntityBaseToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

OddsEntityBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsMatchEarlyBetStatus Class

Early bet status
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsMatchEarlyBetStatus

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class OddsMatchEarlyBetStatus : Enum

The OddsMatchEarlyBetStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | STARTED | Started
 | STOPPED | Stopped
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsMatchEarlyBetStatus Methods

The OddsMatchEarlyBetStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

OddsMatchEarlyBetStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsMatchEarlyBetStatus Fields

The OddsMatchEarlyBetStatus type exposes the following members.

Fields
 | Name | Description
 | STARTED | Started
 | STOPPED | Stopped
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

OddsMatchEarlyBetStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsMatchEarlyBetStatus.STARTED Field

OddsMatchEarlyBetStatusSTARTED Field

Started

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsMatchEarlyBetStatus STARTED = 1

Field Value

OddsMatchEarlyBetStatus
See Also

Reference

OddsMatchEarlyBetStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsMatchEarlyBetStatus.STOPPED Field

OddsMatchEarlyBetStatusSTOPPED Field

Stopped

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsMatchEarlyBetStatus STOPPED = 2

Field Value

OddsMatchEarlyBetStatus
See Also

Reference

OddsMatchEarlyBetStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsMatchEarlyBetStatus.UNDEFINED Field

OddsMatchEarlyBetStatusUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsMatchEarlyBetStatus UNDEFINED = 0

Field Value

OddsMatchEarlyBetStatus
See Also

Reference

OddsMatchEarlyBetStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsMatchEarlyBetStatus.value__ Field

OddsMatchEarlyBetStatusvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsMatchEarlyBetStatus.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

OddsMatchEarlyBetStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsReplyType Class

Message reply type that identifies the type of message coming from betradar.com. This attribute is used for replies to error, current, unregister, register and score requests from clients.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsReplyType

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class OddsReplyType : Enum

The OddsReplyType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | CURRENT | Reply to Current request from client
 | ERROR | Reply to Error request from client
 | REGISTER | Reply to Register request from client
 | RISKADJUSTMENT_UPDATE | Risk adjustment notification
 | SCOREANDCARDSUMMARY | Reply to ScoreAndCard request from client
 | UNDEFINED | Undefined
 | UNREGISTER | Reply to Unregister request from client
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsReplyType Methods

The OddsReplyType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

OddsReplyType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsReplyType Fields

The OddsReplyType type exposes the following members.

Fields
 | Name | Description
 | CURRENT | Reply to Current request from client
 | ERROR | Reply to Error request from client
 | REGISTER | Reply to Register request from client
 | RISKADJUSTMENT_UPDATE | Risk adjustment notification
 | SCOREANDCARDSUMMARY | Reply to ScoreAndCard request from client
 | UNDEFINED | Undefined
 | UNREGISTER | Reply to Unregister request from client
Public field | value__ |
Top
See Also

Reference

OddsReplyType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsReplyType.CURRENT Field

OddsReplyTypeCURRENT Field

Reply to Current request from client

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsReplyType CURRENT = 1

Field Value

OddsReplyType
See Also

Reference

OddsReplyType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsReplyType.ERROR Field

OddsReplyTypeERROR Field

Reply to Error request from client

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsReplyType ERROR = 2

Field Value

OddsReplyType
See Also

Reference

OddsReplyType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsReplyType.REGISTER Field

OddsReplyTypeREGISTER Field

Reply to Register request from client

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsReplyType REGISTER = 3

Field Value

OddsReplyType
See Also

Reference

OddsReplyType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsReplyType.RISKADJUSTMENT_UPDATE Field

OddsReplyTypeRISKADJUSTMENT_UPDATE Field

Risk adjustment notification

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsReplyType RISKADJUSTMENT_UPDATE = 6

Field Value

OddsReplyType
See Also

Reference

OddsReplyType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsReplyType.SCOREANDCARDSUMMARY Field

OddsReplyTypeSCOREANDCARDSUMMARY Field

Reply to ScoreAndCard request from client

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsReplyType SCOREANDCARDSUMMARY = 5

Field Value

OddsReplyType
See Also

Reference

OddsReplyType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsReplyType.UNDEFINED Field

OddsReplyTypeUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsReplyType UNDEFINED = 0

Field Value

OddsReplyType
See Also

Reference

OddsReplyType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsReplyType.UNREGISTER Field

OddsReplyTypeUNREGISTER Field

Reply to Unregister request from client

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsReplyType UNREGISTER = 4

Field Value

OddsReplyType
See Also

Reference

OddsReplyType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsReplyType.value__ Field

OddsReplyTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsReplyType.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

OddsReplyType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsServerType Class

Live odds feed server type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsServerType

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class OddsServerType : Enum

The OddsServerType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | LIVEODDS | Regular Live odds feed.
 | SCOUTMATCH | Live odds with scout matches delivered in the same feed as regular matches. This is an extension to the regular LiveOdds feed and needs to be purchased first.
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsServerType Methods

The OddsServerType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

OddsServerType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsServerType Fields

The OddsServerType type exposes the following members.

Fields
 | Name | Description
 | LIVEODDS | Regular Live odds feed.
 | SCOUTMATCH | Live odds with scout matches delivered in the same feed as regular matches. This is an extension to the regular LiveOdds feed and needs to be purchased first.
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

OddsServerType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsServerType.LIVEODDS Field

OddsServerTypeLIVEODDS Field

Regular Live odds feed.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsServerType LIVEODDS = 1

Field Value

OddsServerType
See Also

Reference

OddsServerType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsServerType.SCOUTMATCH Field

OddsServerTypeSCOUTMATCH Field

Live odds with scout matches delivered in the same feed as regular matches. This is an extension to the regular LiveOdds feed and needs to be purchased first.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsServerType SCOUTMATCH = 2

Field Value

OddsServerType
See Also

Reference

OddsServerType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsServerType.UNDEFINED Field

OddsServerTypeUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsServerType UNDEFINED = 0

Field Value

OddsServerType
See Also

Reference

OddsServerType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsServerType.value__ Field

OddsServerTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsServerType.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

OddsServerType Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus Class

Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.)
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsStatus

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class OddsStatus : Enum

The OddsStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | ALIVE | Alive message status
 | BETSTART | Bet start message status
 | BETSTOP | Bet stop message status
 | CANCELBET | Cancel bet message status
 | CARDS | Cards message status
 | CHANGE | Change message status
 | CLEARBET | Clear bet message status
 | ERROR | Error message status
 | IRRELEVANTCHANGE | Irrelevant change message status
 | LOGINFAILED | Login failed message status
 | LOGINOK | Login OK message status
 | META | Meta info message status
 | REPLYEND | Reply end message status
 | REPLYSTART | Reply start message status
 | RESULT | Race result status
 | ROLLBACK | Bet clear rollback message status
 | SCORE | Score message status
 | TRANSLATION | Translation message status
 | UNDEFINED | Undefined
 | UNDOCANCELBET | Undo cancel bet message status
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus Methods

The OddsStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus Fields

The OddsStatus type exposes the following members.

Fields
 | Name | Description
 | ALIVE | Alive message status
 | BETSTART | Bet start message status
 | BETSTOP | Bet stop message status
 | CANCELBET | Cancel bet message status
 | CARDS | Cards message status
 | CHANGE | Change message status
 | CLEARBET | Clear bet message status
 | ERROR | Error message status
 | IRRELEVANTCHANGE | Irrelevant change message status
 | LOGINFAILED | Login failed message status
 | LOGINOK | Login OK message status
 | META | Meta info message status
 | REPLYEND | Reply end message status
 | REPLYSTART | Reply start message status
 | RESULT | Race result status
 | ROLLBACK | Bet clear rollback message status
 | SCORE | Score message status
 | TRANSLATION | Translation message status
 | UNDEFINED | Undefined
 | UNDOCANCELBET | Undo cancel bet message status
Public field | value__ |
Top
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.ALIVE Field

OddsStatusALIVE Field

Alive message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus ALIVE = 4

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.BETSTART Field

OddsStatusBETSTART Field

Bet start message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus BETSTART = 2

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.BETSTOP Field

OddsStatusBETSTOP Field

Bet stop message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus BETSTOP = 1

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.CANCELBET Field

OddsStatusCANCELBET Field

Cancel bet message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus CANCELBET = 6

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.CARDS Field

OddsStatusCARDS Field

Cards message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus CARDS = 10

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.CHANGE Field

OddsStatusCHANGE Field

Change message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus CHANGE = 3

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.CLEARBET Field

OddsStatusCLEARBET Field

Clear bet message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus CLEARBET = 5

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.ERROR Field

OddsStatusERROR Field

Error message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus ERROR = 14

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.IRRELEVANTCHANGE Field

OddsStatusIRRELEVANTCHANGE Field

Irrelevant change message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus IRRELEVANTCHANGE = 18

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.LOGINFAILED Field

OddsStatusLOGINFAILED Field

Login failed message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus LOGINFAILED = 12

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.LOGINOK Field

OddsStatusLOGINOK Field

Login OK message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus LOGINOK = 11

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.META Field

OddsStatusMETA Field

Meta info message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus META = 13

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.REPLYEND Field

OddsStatusREPLYEND Field

Reply end message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus REPLYEND = 16

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.REPLYSTART Field

OddsStatusREPLYSTART Field

Reply start message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus REPLYSTART = 15

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.RESULT Field

OddsStatusRESULT Field

Race result status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus RESULT = 19

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.ROLLBACK Field

OddsStatusROLLBACK Field

Bet clear rollback message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus ROLLBACK = 8

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.SCORE Field

OddsStatusSCORE Field

Score message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus SCORE = 9

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.TRANSLATION Field

OddsStatusTRANSLATION Field

Translation message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus TRANSLATION = 17

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.UNDEFINED Field

OddsStatusUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus UNDEFINED = 0

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.UNDOCANCELBET Field

OddsStatusUNDOCANCELBET Field

Undo cancel bet message status

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsStatus UNDOCANCELBET = 7

Field Value

OddsStatus
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsStatus.value__ Field

OddsStatusvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsStatus.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

OddsStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsTypeFieldStatus Class

Odds field status used during bet type registration.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsTypeFieldStatus

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class OddsTypeFieldStatus : Enum

The OddsTypeFieldStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | ITEM0 | 0
 | ITEM1 | 1
 | ITEM2 | 2
 | UNDEFINED | None
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsTypeFieldStatus Methods

The OddsTypeFieldStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

OddsTypeFieldStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsTypeFieldStatus Fields

The OddsTypeFieldStatus type exposes the following members.

Fields
 | Name | Description
 | ITEM0 | 0
 | ITEM1 | 1
 | ITEM2 | 2
 | UNDEFINED | None
Public field | value__ |
Top
See Also

Reference

OddsTypeFieldStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsTypeFieldStatus.ITEM0 Field

OddsTypeFieldStatusITEM0 Field

0

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsTypeFieldStatus ITEM0 = 1

Field Value

OddsTypeFieldStatus
See Also

Reference

OddsTypeFieldStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsTypeFieldStatus.ITEM1 Field

OddsTypeFieldStatusITEM1 Field

1

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsTypeFieldStatus ITEM1 = 2

Field Value

OddsTypeFieldStatus
See Also

Reference

OddsTypeFieldStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsTypeFieldStatus.ITEM2 Field

OddsTypeFieldStatusITEM2 Field

2

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsTypeFieldStatus ITEM2 = 3

Field Value

OddsTypeFieldStatus
See Also

Reference

OddsTypeFieldStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsTypeFieldStatus.UNDEFINED Field

OddsTypeFieldStatusUNDEFINED Field

None

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsTypeFieldStatus UNDEFINED = 0

Field Value

OddsTypeFieldStatus
See Also

Reference

OddsTypeFieldStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


OddsTypeFieldStatus.value__ Field

OddsTypeFieldStatusvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsTypeFieldStatus.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

OddsTypeFieldStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


RaceResultEventArgs Class

Event arguments passed with OnRaceResult.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.CommonRaceResultEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RaceResultEventArgs : EventArgs

The RaceResultEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RaceResultEventArgs | Initializes a new instance of the RaceResultEventArgs class
Top
Properties
 | Name | Description
Public property | RaceResult | Entity that contains all the info about the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


RaceResultEventArgs Constructor

Initializes a new instance of the RaceResultEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceResultEventArgs()
See Also

Reference

RaceResultEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


RaceResultEventArgs Properties

The RaceResultEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | RaceResult | Entity that contains all the info about the event
Top
See Also

Reference

RaceResultEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


RaceResultEventArgs.RaceResult Property

RaceResultEventArgsRaceResult Property

Entity that contains all the info about the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceResult RaceResult { get; }

Property Value

RaceResult
See Also

Reference

RaceResultEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


RaceResultEventArgs Methods

The RaceResultEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RaceResultEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ReplyStartEnd Class

Reply start and reply end messages can be used to easier group the response messages together and to know when a new response starts and ends.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonReplyStartEnd

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ReplyStartEnd : OddsEntityBase

The ReplyStartEnd type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | IsStart | Specifies whether this is a ReplyStart or ReplyEnd message.
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides OddsEntityBaseToString)
Top
Remarks
Only available if "Include response reply number" option is enabled in the XML feed configuration.
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ReplyStartEnd Properties

The ReplyStartEnd type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | IsStart | Specifies whether this is a ReplyStart or ReplyEnd message.
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

ReplyStartEnd Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ReplyStartEnd.IsStart Property

ReplyStartEndIsStart Property

Specifies whether this is a ReplyStart or ReplyEnd message.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsStart { get; }

Property Value

Boolean
See Also

Reference

ReplyStartEnd Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ReplyStartEnd Methods

The ReplyStartEnd type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides OddsEntityBaseToString)
Top
See Also

Reference

ReplyStartEnd Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ReplyStartEnd.ToString Method

ReplyStartEndToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

ReplyStartEnd Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ScoreCardSummaryEventArgs Class

Event arguments passed with OnScoreCardSummary.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.CommonScoreCardSummaryEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ScoreCardSummaryEventArgs : EventArgs

The ScoreCardSummaryEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ScoreCardSummaryEventArgs | Initializes a new instance of the ScoreCardSummaryEventArgs class
Top
Properties
 | Name | Description
Public property | ScoreCardSummary | Entitiy that contains all the info about the event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ScoreCardSummaryEventArgs Constructor

Initializes a new instance of the ScoreCardSummaryEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoreCardSummaryEventArgs()
See Also

Reference

ScoreCardSummaryEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ScoreCardSummaryEventArgs Properties

The ScoreCardSummaryEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ScoreCardSummary | Entitiy that contains all the info about the event
Top
See Also

Reference

ScoreCardSummaryEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ScoreCardSummaryEventArgs.ScoreCardSummary Property

ScoreCardSummaryEventArgsScoreCardSummary Property

Entitiy that contains all the info about the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoreCardSummary ScoreCardSummary { get; }

Property Value

ScoreCardSummary
See Also

Reference

ScoreCardSummaryEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ScoreCardSummaryEventArgs Methods

The ScoreCardSummaryEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ScoreCardSummaryEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ScoreCardWaiter Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Common.ScoreCardWaiter"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonBaseWaiter
Sportradar.SDK.FeedProviders.LiveOdds.CommonScoreCardWaiter

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class ScoreCardWaiter : BaseWaiter,
    IDisposable

The ScoreCardWaiter type exposes the following members.

Constructors
 | Name | Description
Public method | ScoreCardWaiter | Initializes a new instance of the ScoreCardWaiter class
Top
Properties
 | Name | Description
Public property | Action | (Inherited from BaseWaiter)
Public property | RequestNr | (Inherited from BaseWaiter)
Public property | Result |
Top
Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class. (Inherited from BaseWaiter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction | (Inherited from BaseWaiter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait | (Inherited from BaseWaiter)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ScoreCardWaiter Constructor

Initializes a new instance of the ScoreCardWaiter class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoreCardWaiter(
    ILiveOdds itf
)

Parameters

itf ILiveOdds

[Missing <param name="itf"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.ScoreCardWaiter.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOdds)"]

See Also

Reference

ScoreCardWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ScoreCardWaiter Properties

The ScoreCardWaiter type exposes the following members.

Properties
 | Name | Description
Public property | Action | (Inherited from BaseWaiter)
Public property | RequestNr | (Inherited from BaseWaiter)
Public property | Result |
Top
See Also

Reference

ScoreCardWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ScoreCardWaiter.Result Property

ScoreCardWaiterResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Common.ScoreCardWaiter.Result"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoreCardSummary Result { get; }

Property Value

ScoreCardSummary
See Also

Reference

ScoreCardWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


ScoreCardWaiter Methods

The ScoreCardWaiter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class. (Inherited from BaseWaiter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction | (Inherited from BaseWaiter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait | (Inherited from BaseWaiter)
Top
See Also

Reference

ScoreCardWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SingleHeaderEvent Class

Base class for all events that regard only one event
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
More

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class SingleHeaderEvent : OddsEntityBase

The SingleHeaderEvent type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides OddsEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetStart
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetStop
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderWithOddsEvent
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsScoreCardSummary
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.CommonRaceResult


SingleHeaderEvent Properties

The SingleHeaderEvent type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

SingleHeaderEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SingleHeaderEvent.EventHeader Property

SingleHeaderEventEventHeader Property

Core info about the event for this event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventHeader EventHeader { get; }

Property Value

EventHeader
See Also

Reference

SingleHeaderEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SingleHeaderEvent Methods

The SingleHeaderEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides OddsEntityBaseToString)
Top
See Also

Reference

SingleHeaderEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SingleHeaderEvent.ToString Method

SingleHeaderEventToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

SingleHeaderEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SingleHeaderWithOddsEvent Class

Base class for all events that regard only one event and contain odds
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderWithOddsEvent
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetCancel
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetClear
Sportradar.SDK.FeedProviders.LiveOdds.CommonBetClearRollback
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsChange

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class SingleHeaderWithOddsEvent : SingleHeaderEvent

The SingleHeaderWithOddsEvent type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderEventToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SingleHeaderWithOddsEvent Properties

The SingleHeaderWithOddsEvent type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Odds relevant to the event
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

SingleHeaderWithOddsEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SingleHeaderWithOddsEvent.Odds Property

SingleHeaderWithOddsEventOdds Property

Odds relevant to the event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<EventOdds> Odds { get; }

Property Value

List EventOdds
See Also

Reference

SingleHeaderWithOddsEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SingleHeaderWithOddsEvent Methods

The SingleHeaderWithOddsEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderEventToString)
Top
See Also

Reference

SingleHeaderWithOddsEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SingleHeaderWithOddsEvent.ToString Method

SingleHeaderWithOddsEventToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

SingleHeaderWithOddsEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SubscriptionWaiter Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Common.SubscriptionWaiter"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonBaseWaiter
Sportradar.SDK.FeedProviders.LiveOdds.CommonSubscriptionWaiter

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SubscriptionWaiter : BaseWaiter

The SubscriptionWaiter type exposes the following members.

Constructors
 | Name | Description
Public method | SubscriptionWaiter | Initializes a new instance of the SubscriptionWaiter class
Top
Properties
 | Name | Description
Public property | Action | (Inherited from BaseWaiter)
Public property | RequestNr | (Inherited from BaseWaiter)
Top
Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class. (Inherited from BaseWaiter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction | (Inherited from BaseWaiter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait | (Inherited from BaseWaiter)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SubscriptionWaiter Constructor

Initializes a new instance of the SubscriptionWaiter class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: FeedProviderExt (in FeedProviderExt.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SubscriptionWaiter(
    ILiveOdds itf,
    bool subscription
)

Parameters

itf ILiveOdds

[Missing <param name="itf"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.SubscriptionWaiter.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOdds,System.Boolean)"]

subscription Boolean

[Missing <param name="subscription"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Common.SubscriptionWaiter.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOdds,System.Boolean)"]

See Also

Reference

SubscriptionWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SubscriptionWaiter Properties

The SubscriptionWaiter type exposes the following members.

Properties
 | Name | Description
Public property | Action | (Inherited from BaseWaiter)
Public property | RequestNr | (Inherited from BaseWaiter)
Top
See Also

Reference

SubscriptionWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


SubscriptionWaiter Methods

The SubscriptionWaiter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class. (Inherited from BaseWaiter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InvokeAction | (Inherited from BaseWaiter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Wait | (Inherited from BaseWaiter)
Top
See Also

Reference

SubscriptionWaiter Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


UserRequest Class

Use requests.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonUserRequest

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class UserRequest

The UserRequest type exposes the following members.

Constructors
 | Name | Description
Public method | UserRequest | Initializes a new instance of the UserRequest class.
Top
Properties
 | Name | Description
Public property | List | Gets or sets the list.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


UserRequest Constructor

Initializes a new instance of the UserRequest class.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public UserRequest()
See Also

Reference

UserRequest Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


UserRequest Properties

The UserRequest type exposes the following members.

Properties
 | Name | Description
Public property | List | Gets or sets the list.
Top
See Also

Reference

UserRequest Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


UserRequest.List Property

UserRequestList Property

Gets or sets the list.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<OddsEntityBase> List { get; set; }

Property Value

List OddsEntityBase
The list.
See Also

Reference

UserRequest Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


UserRequest Methods

The UserRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

UserRequest Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


UserRequest.UserRequestTarget Class

UserRequestUserRequestTarget Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Common.UserRequest.UserRequestTarget"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.CommonUserRequestUserRequestTarget

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class UserRequestTarget : Enum

The UserRequestUserRequestTarget type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


UserRequestTarget Methods

The UserRequestUserRequestTarget type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

UserRequestUserRequestTarget Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


UserRequestTarget Fields

The UserRequestUserRequestTarget type exposes the following members.

Fields
 | Name | Description
Public field | value__ |
Top
See Also

Reference

UserRequestUserRequestTarget Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


UserRequest.UserRequestTarget.value__ Field

UserRequestUserRequestTargetvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Common.UserRequest.UserRequestTarget.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

UserRequestUserRequestTarget Class
Sportradar.SDK.FeedProviders.LiveOdds.Common Namespace


Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace

Classes
 | Class | Description
Public class | CommonErrorManager |
Public class | ErrorManager | Handles the complete LiveOdds error-recovery algorithm using (minimal amount of) "current" requests. For virtual games there are more instances with each one handling one game.
Public class | ErrorManagerBase |
Public class | ErrorManagerWithOutrights |
Public class | EventState |
Public class | EventWrapper | A wrapper used by the error manager which wrapps a SingleHeaderEvent and SingleOutrightEvent into a common type
Public class | EventWrapperEventWrapperId | A unique identifier for the EventWrapper instances
Public class | EventWrapperHeaderType |
Public class | IncrementalSequenceProvider |
Public class | LiveOddsCommonFeedProvider |
Public class | LiveOddsCommonFeedProviderBase |
Public class | LiveOddsEntityFactory |
Public class | LiveOddsFeedDispatcher |
Public class | LiveOddsFeedMonitor |
Public class | LiveOddsFeedProvider |
Public class | LiveOddsFeedProviderBetPal | BetPal provider.
Public class | LiveOddsFeedProviderLivePlex |
Public class | LiveOddsFeedProviderSoccerRoulette |
Public class | LiveOddsFeedProviderVbl | Virtual basketball league LiveOdds provider.
Public class | LiveOddsFeedProviderVdr |
Public class | LiveOddsFeedProviderVfl | Virtual football league LiveOdds provider.
Public class | LiveOddsFeedProviderVhc |
Public class | LiveOddsFeedProviderVto | BetPal provider.
Public class | LiveOddsFeedStatusDelegates |
Public class | LiveOddsFeedStatusDelegatesInterceptionOutcome |
Public class | LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus |
Public class | LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate |
Public class | LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate |
Public class | LiveOddsRaceFeedProvider |
Public class | LiveOddsRequestProducer |
Public class | LiveOddsTestManager |
Public class | LiveOddsWithOutrightsDispatcher |
Public class | LiveOddsWithOutrightsFeedProvider |
Public class | MatchMsgNrStatusTuple | Match id, message number and betstatus tuple.
Public class | MatchMsgNrTuple | Match id, message number tuple.
Public class | PreparationRequest |
Public class | PreparationResult |
Public class | RequestProducerDelegates |
Public class | RequestProducerDelegatesRequestDelegate |
Public class | SequenceMonitor |
Public class | UserRequestManager | Handles batching of replies for a user-request (so he gets everything at once with "replyend") and flagging messages with IsOutOfBand.
Public class | VdrEntityFactory |
Public class | VdrRequestProducer |
Public class | VfcEntityFactory |
Public class | VfcRequestProducer |
Public class | VhcEntityFactory |
Public class | VhcRequestProducer |
Interfaces
 | Interface | Description
Public interface | IErrorManager |
Public interface | IFakeBetStopFactory |
Public interface | IFakeBetStopFactoryWithOutrights |
Public interface | IFeedRecoveryDispatcher |
Public interface | IFeedWithOutrightsRecoveryDispatcher |
Public interface | ILiveOddsEntityFactory |
Public interface | ILiveOddsFeedDispatcher |
Public interface | ILiveOddsFeedMonitor |
Public interface | ILiveOddsRequestProducer |
Public interface | ILiveOddsWithOutrightsRequestProducer |
Public interface | ISequenceMonitor |


CommonErrorManager Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.CommonErrorManager"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalCommonErrorManager

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public abstract class CommonErrorManager : IErrorManager

The CommonErrorManager type exposes the following members.

Properties
 | Name | Description
Public property | IsConnectionStable |
Top
Methods
 | Name | Description
Public method | Disable |
Public method | Enable |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterMessageDispatcher |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


CommonErrorManager Properties

The CommonErrorManager type exposes the following members.

Properties
 | Name | Description
Public property | IsConnectionStable |
Top
See Also

Reference

CommonErrorManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


CommonErrorManager.IsConnectionStable Property

CommonErrorManagerIsConnectionStable Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.CommonErrorManager.IsConnectionStable"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool IsConnectionStable { get; }

Property Value

Boolean

Implements

IErrorManagerIsConnectionStable
See Also

Reference

CommonErrorManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


CommonErrorManager Methods

The CommonErrorManager type exposes the following members.

Methods
 | Name | Description
Public method | Disable |
Public method | Enable |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterMessageDispatcher |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CommonErrorManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


CommonErrorManager.Disable Method

CommonErrorManagerDisable Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.CommonErrorManager.Disable"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Disable()

Implements

IErrorManagerDisable
See Also

Reference

CommonErrorManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


CommonErrorManager.Enable Method

CommonErrorManagerEnable Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.CommonErrorManager.Enable"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Enable()

Implements

IErrorManagerEnable
See Also

Reference

CommonErrorManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


CommonErrorManager.RegisterMessageDispatcher Method

CommonErrorManagerRegisterMessageDispatcher Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.CommonErrorManager.RegisterMessageDispatcher(Sportradar.SDK.Common.Interfaces.IMessageDispatcher)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void RegisterMessageDispatcher(
    IMessageDispatcher message_dispatcher
)

Parameters

message_dispatcher IMessageDispatcher

[Missing <param name="message_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.CommonErrorManager.RegisterMessageDispatcher(Sportradar.SDK.Common.Interfaces.IMessageDispatcher)"]

Implements

IErrorManagerRegisterMessageDispatcher(IMessageDispatcher)
See Also

Reference

CommonErrorManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManager Class

Handles the complete LiveOdds error-recovery algorithm using (minimal amount of) "current" requests. For virtual games there are more instances with each one handling one game.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalErrorManagerBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalErrorManager

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class ErrorManager : ErrorManagerBase

The ErrorManager type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorManager | Initializes a new instance of the ErrorManager class
Top
Properties
 | Name | Description
Public property | IsConnectionStable | Gets a value indicating whether the connection to feed server is stable (Inherited from ErrorManagerBase)
Top
Methods
 | Name | Description
Public method | Disable | Disables (stops) the current ErrorManagerBase instance (Inherited from ErrorManagerBase)
Public method | Enable | Enables (starts) the current ErrorManagerBase instance (Inherited from ErrorManagerBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterMessageDispatcher | Registers a IMessageDispatcher used to dispatch events (Inherited from ErrorManagerBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManager Constructor

Initializes a new instance of the ErrorManager class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ErrorManager(
    ILiveOddsFeedMonitor feed_monitor,
    IFeedRecoveryDispatcher error_recovery_dispatcher,
    ILiveOddsRequestProducer request_producer,
    ProtocolProviderType protocol_provider_type,
    ITimeKeeper time_keeper,
    SdkConfigurationLiveOdds live_odds_config
)

Parameters

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManager.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

error_recovery_dispatcher IFeedRecoveryDispatcher

[Missing <param name="error_recovery_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManager.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

request_producer ILiveOddsRequestProducer

[Missing <param name="request_producer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManager.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

protocol_provider_type ProtocolProviderType

[Missing <param name="protocol_provider_type"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManager.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

time_keeper ITimeKeeper

[Missing <param name="time_keeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManager.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

live_odds_config SdkConfigurationLiveOdds

[Missing <param name="live_odds_config"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManager.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

ErrorManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManager Properties

The ErrorManager type exposes the following members.

Properties
 | Name | Description
Public property | IsConnectionStable | Gets a value indicating whether the connection to feed server is stable (Inherited from ErrorManagerBase)
Top
See Also

Reference

ErrorManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManager Methods

The ErrorManager type exposes the following members.

Methods
 | Name | Description
Public method | Disable | Disables (stops) the current ErrorManagerBase instance (Inherited from ErrorManagerBase)
Public method | Enable | Enables (starts) the current ErrorManagerBase instance (Inherited from ErrorManagerBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterMessageDispatcher | Registers a IMessageDispatcher used to dispatch events (Inherited from ErrorManagerBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ErrorManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManagerBase Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManagerBase"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalErrorManagerBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalErrorManager
Sportradar.SDK.FeedProviders.LiveOdds.InternalErrorManagerWithOutrights

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public abstract class ErrorManagerBase : IErrorManager

The ErrorManagerBase type exposes the following members.

Properties
 | Name | Description
Public property | IsConnectionStable | Gets a value indicating whether the connection to feed server is stable
Top
Methods
 | Name | Description
Public method | Disable | Disables (stops) the current ErrorManagerBase instance
Public method | Enable | Enables (starts) the current ErrorManagerBase instance
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterMessageDispatcher | Registers a IMessageDispatcher used to dispatch events
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManagerBase Properties

The ErrorManagerBase type exposes the following members.

Properties
 | Name | Description
Public property | IsConnectionStable | Gets a value indicating whether the connection to feed server is stable
Top
See Also

Reference

ErrorManagerBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManagerBase.IsConnectionStable Property

ErrorManagerBaseIsConnectionStable Property

Gets a value indicating whether the connection to feed server is stable

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool IsConnectionStable { get; }

Property Value

Boolean

Implements

IErrorManagerIsConnectionStable
See Also

Reference

ErrorManagerBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManagerBase Methods

The ErrorManagerBase type exposes the following members.

Methods
 | Name | Description
Public method | Disable | Disables (stops) the current ErrorManagerBase instance
Public method | Enable | Enables (starts) the current ErrorManagerBase instance
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterMessageDispatcher | Registers a IMessageDispatcher used to dispatch events
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ErrorManagerBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManagerBase.Disable Method

ErrorManagerBaseDisable Method

Disables (stops) the current ErrorManagerBase instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Disable()

Implements

IErrorManagerDisable
See Also

Reference

ErrorManagerBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManagerBase.Enable Method

ErrorManagerBaseEnable Method

Enables (starts) the current ErrorManagerBase instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Enable()

Implements

IErrorManagerEnable
See Also

Reference

ErrorManagerBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManagerBase.RegisterMessageDispatcher Method

ErrorManagerBaseRegisterMessageDispatcher Method

Registers a IMessageDispatcher used to dispatch events

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void RegisterMessageDispatcher(
    IMessageDispatcher message_dispatcher
)

Parameters

message_dispatcher IMessageDispatcher

Implements

IErrorManagerRegisterMessageDispatcher(IMessageDispatcher)
See Also

Reference

ErrorManagerBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManagerWithOutrights Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManagerWithOutrights"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalErrorManagerBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalErrorManagerWithOutrights

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class ErrorManagerWithOutrights : ErrorManagerBase

The ErrorManagerWithOutrights type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorManagerWithOutrights | Initializes a new instance of the ErrorManagerWithOutrights class
Top
Properties
 | Name | Description
Public property | IsConnectionStable | Gets a value indicating whether the connection to feed server is stable (Inherited from ErrorManagerBase)
Top
Methods
 | Name | Description
Public method | Disable | Disables (stops) the current ErrorManagerBase instance (Inherited from ErrorManagerBase)
Public method | Enable | Enables (starts) the current ErrorManagerBase instance (Inherited from ErrorManagerBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterMessageDispatcher | Registers a IMessageDispatcher used to dispatch events (Inherited from ErrorManagerBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManagerWithOutrights Constructor

Initializes a new instance of the ErrorManagerWithOutrights class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ErrorManagerWithOutrights(
    ILiveOddsFeedMonitor feed_monitor,
    IFeedWithOutrightsRecoveryDispatcher error_recovery_dispatcher,
    ILiveOddsWithOutrightsRequestProducer request_producer,
    ProtocolProviderType protocol_provider_type,
    ITimeKeeper timekeeper,
    SdkConfigurationLiveOdds live_odds_config
)

Parameters

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManagerWithOutrights.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

error_recovery_dispatcher IFeedWithOutrightsRecoveryDispatcher

[Missing <param name="error_recovery_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManagerWithOutrights.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

request_producer ILiveOddsWithOutrightsRequestProducer

[Missing <param name="request_producer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManagerWithOutrights.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

protocol_provider_type ProtocolProviderType

[Missing <param name="protocol_provider_type"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManagerWithOutrights.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

timekeeper ITimeKeeper

[Missing <param name="timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManagerWithOutrights.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

live_odds_config SdkConfigurationLiveOdds

[Missing <param name="live_odds_config"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ErrorManagerWithOutrights.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

ErrorManagerWithOutrights Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManagerWithOutrights Properties

The ErrorManagerWithOutrights type exposes the following members.

Properties
 | Name | Description
Public property | IsConnectionStable | Gets a value indicating whether the connection to feed server is stable (Inherited from ErrorManagerBase)
Top
See Also

Reference

ErrorManagerWithOutrights Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ErrorManagerWithOutrights Methods

The ErrorManagerWithOutrights type exposes the following members.

Methods
 | Name | Description
Public method | Disable | Disables (stops) the current ErrorManagerBase instance (Inherited from ErrorManagerBase)
Public method | Enable | Enables (starts) the current ErrorManagerBase instance (Inherited from ErrorManagerBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterMessageDispatcher | Registers a IMessageDispatcher used to dispatch events (Inherited from ErrorManagerBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ErrorManagerWithOutrights Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalEventState

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class EventState

The EventState type exposes the following members.

Constructors
 | Name | Description
Public method | EventState | Initializes a new instance of the EventState class
Top
Properties
 | Name | Description
Public property | BetStatus |
Public property | EventStatus |
Public property | Index |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | FromOddsStatus |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Fields
Name | Description
BETCLEARING |
BETSTART |
BETSTOP |
CANCELATION |
META |
ODDS_CHANGE |
RESULT |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState Constructor

Initializes a new instance of the EventState class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventState(
    int index,
    EventBetStatus bet_status,
    EventStatus event_status
)

Parameters

index Int32

[Missing <param name="index"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.#ctor(System.Int32,Sportradar.SDK.FeedProviders.LiveOdds.Common.EventBetStatus,Sportradar.SDK.FeedProviders.LiveOdds.Common.EventStatus)"]

bet_status EventBetStatus

[Missing <param name="bet_status"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.#ctor(System.Int32,Sportradar.SDK.FeedProviders.LiveOdds.Common.EventBetStatus,Sportradar.SDK.FeedProviders.LiveOdds.Common.EventStatus)"]

event_status EventStatus

[Missing <param name="event_status"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.#ctor(System.Int32,Sportradar.SDK.FeedProviders.LiveOdds.Common.EventBetStatus,Sportradar.SDK.FeedProviders.LiveOdds.Common.EventStatus)"]

See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState Properties

The EventState type exposes the following members.

Properties
 | Name | Description
Public property | BetStatus |
Public property | EventStatus |
Public property | Index |
Top
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState.BetStatus Property

EventStateBetStatus Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.BetStatus"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventBetStatus BetStatus { get; }

Property Value

EventBetStatus
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState.EventStatus Property

EventStateEventStatus Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.EventStatus"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventStatus EventStatus { get; }

Property Value

EventStatus
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState.Index Property

EventStateIndex Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.Index"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Index { get; }

Property Value

Int32
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState Methods

The EventState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | FromOddsStatus |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState.FromOddsStatus Method

EventStateFromOddsStatus Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.FromOddsStatus(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsStatus)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static EventState FromOddsStatus(
    OddsStatus status
)

Parameters

status OddsStatus

[Missing <param name="status"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.FromOddsStatus(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsStatus)"]

Return Value

EventState

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.FromOddsStatus(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsStatus)"]

See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState Fields

The EventState type exposes the following members.

Fields
Name | Description
BETCLEARING |
BETSTART |
BETSTOP |
CANCELATION |
META |
ODDS_CHANGE |
RESULT |
Top
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState.BETCLEARING Field

EventStateBETCLEARING Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.BETCLEARING"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly EventState BETCLEARING

Field Value

EventState
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState.BETSTART Field

EventStateBETSTART Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.BETSTART"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly EventState BETSTART

Field Value

EventState
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState.BETSTOP Field

EventStateBETSTOP Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.BETSTOP"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly EventState BETSTOP

Field Value

EventState
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState.CANCELATION Field

EventStateCANCELATION Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.CANCELATION"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly EventState CANCELATION

Field Value

EventState
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState.META Field

EventStateMETA Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.META"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly EventState META

Field Value

EventState
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState.ODDS_CHANGE Field

EventStateODDS_CHANGE Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.ODDS_CHANGE"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly EventState ODDS_CHANGE

Field Value

EventState
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventState.RESULT Field

EventStateRESULT Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventState.RESULT"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly EventState RESULT

Field Value

EventState
See Also

Reference

EventState Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper Class

A wrapper used by the error manager which wrapps a SingleHeaderEvent and SingleOutrightEvent into a common type
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalEventWrapper

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class EventWrapper

The EventWrapper type exposes the following members.

Properties
 | Name | Description
Public property | Entity | Gets the OddsEntityBase instance from which the current EventWrapper was constructed
Public property | EntityType | Gets the EventWrapperHeaderType enum member specifying the type of the entity from which the current EventWrapper instance was created
Public property | Header | Gets the EventHeader instance associated with the current EventWrapper instance
Public property | Key | Gets a EventWrapperEventWrapperId instance used to uniquely identify the event associated with current EventWrapper
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper Properties

The EventWrapper type exposes the following members.

Properties
 | Name | Description
Public property | Entity | Gets the OddsEntityBase instance from which the current EventWrapper was constructed
Public property | EntityType | Gets the EventWrapperHeaderType enum member specifying the type of the entity from which the current EventWrapper instance was created
Public property | Header | Gets the EventHeader instance associated with the current EventWrapper instance
Public property | Key | Gets a EventWrapperEventWrapperId instance used to uniquely identify the event associated with current EventWrapper
Top
See Also

Reference

EventWrapper Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.Entity Property

EventWrapperEntity Property

Gets the OddsEntityBase instance from which the current EventWrapper was constructed

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsEntityBase Entity { get; }

Property Value

OddsEntityBase
See Also

Reference

EventWrapper Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.EntityType Property

EventWrapperEntityType Property

Gets the EventWrapperHeaderType enum member specifying the type of the entity from which the current EventWrapper instance was created

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventWrapperHeaderType EntityType { get; }

Property Value

EventWrapperHeaderType
See Also

Reference

EventWrapper Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.Header Property

EventWrapperHeader Property

Gets the EventHeader instance associated with the current EventWrapper instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventHeader Header { get; }

Property Value

EventHeader
See Also

Reference

EventWrapper Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.Key Property

EventWrapperKey Property

Gets a EventWrapperEventWrapperId instance used to uniquely identify the event associated with current EventWrapper

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventWrapperEventWrapperId Key { get; }

Property Value

EventWrapperEventWrapperId
See Also

Reference

EventWrapper Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper Methods

The EventWrapper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EventWrapper Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.EventWrapperId Class

EventWrapperEventWrapperId Class

A unique identifier for the EventWrapper instances
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalEventWrapperEventWrapperId

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class EventWrapperId

The EventWrapperEventWrapperId type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the id of the event wrapped by the current EventWrapperEventWrapperId instance
Public property | Type | Gets a EventWrapperHeaderType specifying the type (event, outright, ...) of the wrapped item
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the passed Object is equal to current EventWrapperEventWrapperId instance (Overrides ObjectEquals(Object))
Public method | GetHashCode | Calculates and returns the hash code of the current EventWrapperEventWrapperId instance (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Constructs and returns a String representation of the current EventWrapperEventWrapperId instance (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapperId Properties

The EventWrapperEventWrapperId type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the id of the event wrapped by the current EventWrapperEventWrapperId instance
Public property | Type | Gets a EventWrapperHeaderType specifying the type (event, outright, ...) of the wrapped item
Top
See Also

Reference

EventWrapperEventWrapperId Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.EventWrapperId.Id Property

EventWrapperEventWrapperIdId Property

Gets the id of the event wrapped by the current EventWrapperEventWrapperId instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long Id { get; }

Property Value

Int64
See Also

Reference

EventWrapperEventWrapperId Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.EventWrapperId.Type Property

EventWrapperEventWrapperIdType Property

Gets a EventWrapperHeaderType specifying the type (event, outright, ...) of the wrapped item

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventWrapperHeaderType Type { get; }

Property Value

EventWrapperHeaderType
See Also

Reference

EventWrapperEventWrapperId Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapperId Methods

The EventWrapperEventWrapperId type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the passed Object is equal to current EventWrapperEventWrapperId instance (Overrides ObjectEquals(Object))
Public method | GetHashCode | Calculates and returns the hash code of the current EventWrapperEventWrapperId instance (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Constructs and returns a String representation of the current EventWrapperEventWrapperId instance (Overrides ObjectToString)
Top
See Also

Reference

EventWrapperEventWrapperId Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.EventWrapperId.Equals Method

EventWrapperEventWrapperIdEquals Method

Determines whether the passed Object is equal to current EventWrapperEventWrapperId instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object
A Object instance to be checked for equality to current EventWrapperEventWrapperId instance

Return Value

Boolean
True if the passed Object is equal to current EventWrapperEventWrapperId instance; Otherwise false
See Also

Reference

EventWrapperEventWrapperId Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.EventWrapperId.GetHashCode Method

EventWrapperEventWrapperIdGetHashCode Method

Calculates and returns the hash code of the current EventWrapperEventWrapperId instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32
A hash code of the current EventWrapperEventWrapperId instance
See Also

Reference

EventWrapperEventWrapperId Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.EventWrapperId.ToString Method

EventWrapperEventWrapperIdToString Method

Constructs and returns a String representation of the current EventWrapperEventWrapperId instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A String representation of the current EventWrapperEventWrapperId instance
See Also

Reference

EventWrapperEventWrapperId Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.HeaderType Class

EventWrapperHeaderType Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.HeaderType"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.InternalEventWrapperHeaderType

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class HeaderType : Enum

The EventWrapperHeaderType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | EVENT | Indicates that the associated EventWrapper represents an event (match, race, ...)
 | OUTRIGHT | Indicates that the associated EventWrapper represents an outright
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


HeaderType Methods

The EventWrapperHeaderType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

EventWrapperHeaderType Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


HeaderType Fields

The EventWrapperHeaderType type exposes the following members.

Fields
 | Name | Description
 | EVENT | Indicates that the associated EventWrapper represents an event (match, race, ...)
 | OUTRIGHT | Indicates that the associated EventWrapper represents an outright
Public field | value__ |
Top
See Also

Reference

EventWrapperHeaderType Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.HeaderType.EVENT Field

EventWrapperHeaderTypeEVENT Field

Indicates that the associated EventWrapper represents an event (match, race, ...)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventWrapperHeaderType EVENT = 1

Field Value

EventWrapperHeaderType
See Also

Reference

EventWrapperHeaderType Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.HeaderType.OUTRIGHT Field

EventWrapperHeaderTypeOUTRIGHT Field

Indicates that the associated EventWrapper represents an outright

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventWrapperHeaderType OUTRIGHT = 2

Field Value

EventWrapperHeaderType
See Also

Reference

EventWrapperHeaderType Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


EventWrapper.HeaderType.value__ Field

EventWrapperHeaderTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.HeaderType.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

EventWrapperHeaderType Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IErrorManager Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IErrorManager

The IErrorManager type exposes the following members.

Properties
 | Name | Description
Public property | IsConnectionStable |
Top
Methods
 | Name | Description
Public method | Disable |
Public method | Enable |
Public method | RegisterMessageDispatcher |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IErrorManager Properties

The IErrorManager type exposes the following members.

Properties
 | Name | Description
Public property | IsConnectionStable |
Top
See Also

Reference

IErrorManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IErrorManager.IsConnectionStable Property

IErrorManagerIsConnectionStable Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager.IsConnectionStable"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool IsConnectionStable { get; }

Property Value

Boolean
See Also

Reference

IErrorManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IErrorManager Methods

The IErrorManager type exposes the following members.

Methods
 | Name | Description
Public method | Disable |
Public method | Enable |
Public method | RegisterMessageDispatcher |
Top
See Also

Reference

IErrorManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IErrorManager.Disable Method

IErrorManagerDisable Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager.Disable"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Disable()
See Also

Reference

IErrorManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IErrorManager.Enable Method

IErrorManagerEnable Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager.Enable"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Enable()
See Also

Reference

IErrorManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IErrorManager.RegisterMessageDispatcher Method

IErrorManagerRegisterMessageDispatcher Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager.RegisterMessageDispatcher(Sportradar.SDK.Common.Interfaces.IMessageDispatcher)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void RegisterMessageDispatcher(
    IMessageDispatcher message_dispatcher
)

Parameters

message_dispatcher IMessageDispatcher

[Missing <param name="message_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager.RegisterMessageDispatcher(Sportradar.SDK.Common.Interfaces.IMessageDispatcher)"]

See Also

Reference

IErrorManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFakeBetStopFactory Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactory"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IFakeBetStopFactory

The IFakeBetStopFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildFakeBetStop |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFakeBetStopFactory Methods

The IFakeBetStopFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildFakeBetStop |
Top
See Also

Reference

IFakeBetStopFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFakeBetStopFactory.BuildFakeBetStop Method

IFakeBetStopFactoryBuildFakeBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactory.BuildFakeBetStop(System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
BetStop BuildFakeBetStop(
    long event_id
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactory.BuildFakeBetStop(System.Int64)"]

Return Value

BetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactory.BuildFakeBetStop(System.Int64)"]

See Also

Reference

IFakeBetStopFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFakeBetStopFactoryWithOutrights Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactoryWithOutrights"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IFakeBetStopFactoryWithOutrights : IFakeBetStopFactory

The IFakeBetStopFactoryWithOutrights type exposes the following members.

Methods
 | Name | Description
Public method | BuildFakeBetStop | (Inherited from IFakeBetStopFactory)
Public method | BuildFakeOutrightBetStop |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFakeBetStopFactoryWithOutrights Methods

The IFakeBetStopFactoryWithOutrights type exposes the following members.

Methods
 | Name | Description
Public method | BuildFakeBetStop | (Inherited from IFakeBetStopFactory)
Public method | BuildFakeOutrightBetStop |
Top
See Also

Reference

IFakeBetStopFactoryWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFakeBetStopFactoryWithOutrights.BuildFakeOutrightBetStop Method

IFakeBetStopFactoryWithOutrightsBuildFakeOutrightBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactoryWithOutrights.BuildFakeOutrightBetStop(System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
OutrightBetStop BuildFakeOutrightBetStop(
    long outright_id
)

Parameters

outright_id Int64

[Missing <param name="outright_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactoryWithOutrights.BuildFakeOutrightBetStop(System.Int64)"]

Return Value

OutrightBetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactoryWithOutrights.BuildFakeOutrightBetStop(System.Int64)"]

See Also

Reference

IFakeBetStopFactoryWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFeedRecoveryDispatcher Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IFeedRecoveryDispatcher

The IFeedRecoveryDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | DispatchArtificialBetStop |
Public method | DispatchArtificialBetStops |
Public method | DispatchConnectionStable |
Public method | DispatchConnectionUnstable |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFeedRecoveryDispatcher Methods

The IFeedRecoveryDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | DispatchArtificialBetStop |
Public method | DispatchArtificialBetStops |
Public method | DispatchConnectionStable |
Public method | DispatchConnectionUnstable |
Top
See Also

Reference

IFeedRecoveryDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFeedRecoveryDispatcher.DispatchArtificialBetStop Method

IFeedRecoveryDispatcherDispatchArtificialBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher.DispatchArtificialBetStop(System.Nullable{System.Int64},System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void DispatchArtificialBetStop(
    long? virtual_game_id,
    long event_id
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher.DispatchArtificialBetStop(System.Nullable{System.Int64},System.Int64)"]

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher.DispatchArtificialBetStop(System.Nullable{System.Int64},System.Int64)"]

See Also

Reference

IFeedRecoveryDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFeedRecoveryDispatcher.DispatchArtificialBetStops Method

IFeedRecoveryDispatcherDispatchArtificialBetStops Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher.DispatchArtificialBetStops(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void DispatchArtificialBetStops(
    long? virtual_game_id,
    IEnumerable<long> event_ids
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher.DispatchArtificialBetStops(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher.DispatchArtificialBetStops(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

See Also

Reference

IFeedRecoveryDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFeedRecoveryDispatcher.DispatchConnectionStable Method

IFeedRecoveryDispatcherDispatchConnectionStable Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher.DispatchConnectionStable(System.Nullable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void DispatchConnectionStable(
    long? virtual_game_id
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher.DispatchConnectionStable(System.Nullable{System.Int64})"]

See Also

Reference

IFeedRecoveryDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFeedRecoveryDispatcher.DispatchConnectionUnstable Method

IFeedRecoveryDispatcherDispatchConnectionUnstable Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher.DispatchConnectionUnstable(System.Nullable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void DispatchConnectionUnstable(
    long? virtual_game_id
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedRecoveryDispatcher.DispatchConnectionUnstable(System.Nullable{System.Int64})"]

See Also

Reference

IFeedRecoveryDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFeedWithOutrightsRecoveryDispatcher Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IFeedWithOutrightsRecoveryDispatcher : IFeedRecoveryDispatcher

The IFeedWithOutrightsRecoveryDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | DispatchArtificialBetStop | (Inherited from IFeedRecoveryDispatcher)
Public method | DispatchArtificialBetStops | (Inherited from IFeedRecoveryDispatcher)
Public method | DispatchConnectionStable | (Inherited from IFeedRecoveryDispatcher)
Public method | DispatchConnectionUnstable | (Inherited from IFeedRecoveryDispatcher)
Public method | DispatchOutrightArtificialBetStop |
Public method | DispatchOutrightArtificialBetStops |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFeedWithOutrightsRecoveryDispatcher Methods

The IFeedWithOutrightsRecoveryDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | DispatchArtificialBetStop | (Inherited from IFeedRecoveryDispatcher)
Public method | DispatchArtificialBetStops | (Inherited from IFeedRecoveryDispatcher)
Public method | DispatchConnectionStable | (Inherited from IFeedRecoveryDispatcher)
Public method | DispatchConnectionUnstable | (Inherited from IFeedRecoveryDispatcher)
Public method | DispatchOutrightArtificialBetStop |
Public method | DispatchOutrightArtificialBetStops |
Top
See Also

Reference

IFeedWithOutrightsRecoveryDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFeedWithOutrightsRecoveryDispatcher.DispatchOutrightArtificialBetStop Method

IFeedWithOutrightsRecoveryDispatcherDispatchOutrightArtificialBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher.DispatchOutrightArtificialBetStop(System.Nullable{System.Int64},System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void DispatchOutrightArtificialBetStop(
    long? virtual_game_id,
    long outright_id
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher.DispatchOutrightArtificialBetStop(System.Nullable{System.Int64},System.Int64)"]

outright_id Int64

[Missing <param name="outright_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher.DispatchOutrightArtificialBetStop(System.Nullable{System.Int64},System.Int64)"]

See Also

Reference

IFeedWithOutrightsRecoveryDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IFeedWithOutrightsRecoveryDispatcher.DispatchOutrightArtificialBetStops Method

IFeedWithOutrightsRecoveryDispatcherDispatchOutrightArtificialBetStops Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher.DispatchOutrightArtificialBetStops(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void DispatchOutrightArtificialBetStops(
    long? virtual_game_id,
    IEnumerable<long> outright_ids
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher.DispatchOutrightArtificialBetStops(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

outright_ids IEnumerable Int64

[Missing <param name="outright_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFeedWithOutrightsRecoveryDispatcher.DispatchOutrightArtificialBetStops(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

See Also

Reference

IFeedWithOutrightsRecoveryDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOddsEntityFactory

The ILiveOddsEntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildAlive |
Public method | BuildBetCancel |
Public method | BuildBetCancelUndo |
Public method | BuildBetClear |
Public method | BuildBetClearRollback |
Public method | BuildBetStart |
Public method | BuildBetStop | BuildBetStop
Public method | BuildIrrelevantOddsChange | BuildIrrelevantOddsChange
Public method | BuildMetaInfo | BuildMetaInfo
Public method | BuildOddsChange | BuildOddsChange
Public method | BuildReplyStartEnd | BuildReplyStartEnd
Public method | BuildScoreCardSummary | BuildScoreCardSummary
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory Methods

The ILiveOddsEntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildAlive |
Public method | BuildBetCancel |
Public method | BuildBetCancelUndo |
Public method | BuildBetClear |
Public method | BuildBetClearRollback |
Public method | BuildBetStart |
Public method | BuildBetStop | BuildBetStop
Public method | BuildIrrelevantOddsChange | BuildIrrelevantOddsChange
Public method | BuildMetaInfo | BuildMetaInfo
Public method | BuildOddsChange | BuildOddsChange
Public method | BuildReplyStartEnd | BuildReplyStartEnd
Public method | BuildScoreCardSummary | BuildScoreCardSummary
Top
See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory.BuildAlive Method

ILiveOddsEntityFactoryBuildAlive Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
Alive BuildAlive(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

Alive

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory.BuildBetCancel Method

ILiveOddsEntityFactoryBuildBetCancel Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
BetCancel BuildBetCancel(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

BetCancel

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory.BuildBetCancelUndo Method

ILiveOddsEntityFactoryBuildBetCancelUndo Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetCancelUndo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
BetCancelUndo BuildBetCancelUndo(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetCancelUndo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

BetCancelUndo

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetCancelUndo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory.BuildBetClear Method

ILiveOddsEntityFactoryBuildBetClear Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
BetClear BuildBetClear(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

BetClear

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory.BuildBetClearRollback Method

ILiveOddsEntityFactoryBuildBetClearRollback Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetClearRollback(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
BetClearRollback BuildBetClearRollback(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetClearRollback(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

BetClearRollback

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetClearRollback(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory.BuildBetStart Method

ILiveOddsEntityFactoryBuildBetStart Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
BetStart BuildBetStart(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

BetStart

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory.BuildBetStop Method

ILiveOddsEntityFactoryBuildBetStop Method

BuildBetStop

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
BetStop BuildBetStop(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

BetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory.BuildIrrelevantOddsChange Method

ILiveOddsEntityFactoryBuildIrrelevantOddsChange Method

BuildIrrelevantOddsChange

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IrrelevantOddsChange BuildIrrelevantOddsChange(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildIrrelevantOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

IrrelevantOddsChange

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildIrrelevantOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory.BuildMetaInfo Method

ILiveOddsEntityFactoryBuildMetaInfo Method

BuildMetaInfo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
MetaInfo BuildMetaInfo(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildMetaInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

MetaInfo

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildMetaInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory.BuildOddsChange Method

ILiveOddsEntityFactoryBuildOddsChange Method

BuildOddsChange

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
OddsChange BuildOddsChange(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

OddsChange

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory.BuildReplyStartEnd Method

ILiveOddsEntityFactoryBuildReplyStartEnd Method

BuildReplyStartEnd

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
ReplyStartEnd BuildReplyStartEnd(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

ReplyStartEnd

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsEntityFactory.BuildScoreCardSummary Method

ILiveOddsEntityFactoryBuildScoreCardSummary Method

BuildScoreCardSummary

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
ScoreCardSummary BuildScoreCardSummary(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildScoreCardSummary(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

ScoreCardSummary

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory.BuildScoreCardSummary(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

See Also

Reference

ILiveOddsEntityFactory Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOddsFeedDispatcher : IFeedDispatcher

The ILiveOddsFeedDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType | (Inherited from IFeedDispatcher)
Top
Methods
 | Name | Description
Public method | DispatchEntity | Dispatches the entity.
Public method | DispatchParseError | DispatchParseError
Public method | DispatchUserRequest | Dispatches the user request.
Top
Events
 | Name | Description
Public event | AfterMessageDispatched | Occurs when [after message dispatched].
Public event | OnAlive | Occurs when [on alive received].
Public event | OnBetCancel | Occurs when [on bet cancel].
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone].
Public event | OnBetClear | Occurs when [on bet clear].
Public event | OnBetClearRollback | Occurs when [on bet clear rollback].
Public event | OnBetStart | Occurs when [on bet start].
Public event | OnBetStop | Occurs when [on bet stop].
Public event | OnConnectionStable | Occurs when connection stable.
Public event | OnConnectionUnstable | Occurs when connection unstable.
Public event | OnEventMessages | Occurs when [on match messages received].
Public event | OnEventStatus | Occurs when [on match status received].
Public event | OnFeedError | Occurs when [on feed error].
Public event | OnMetaInfo | Occurs when [on meta info received].
Public event | OnOddsChange | Occurs when [on odds change].
Public event | OnRaceResult | Occurs when [on race result].
Public event | OnScoreCard | Occurs when [on score card received].
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher Properties

The ILiveOddsFeedDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType | (Inherited from IFeedDispatcher)
Top
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher Methods

The ILiveOddsFeedDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | DispatchEntity | Dispatches the entity.
Public method | DispatchParseError | DispatchParseError
Public method | DispatchUserRequest | Dispatches the user request.
Top
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.DispatchEntity Method

ILiveOddsFeedDispatcherDispatchEntity Method

Dispatches the entity.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
DispatchStatus DispatchEntity(
    EntityBase entity
)

Parameters

entity EntityBase
The entity.

Return Value

DispatchStatus

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher.DispatchEntity(Sportradar.SDK.Common.EntityBase)"]

Implements

IFeedDispatcherDispatchEntity(EntityBase)
Exceptions
Exception | Condition
ArgumentNullException | dispatcher_state
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.DispatchParseError Method

ILiveOddsFeedDispatcherDispatchParseError Method

DispatchParseError

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void DispatchParseError(
    IMessageIdentifier identifier,
    string message
)

Parameters

identifier IMessageIdentifier

[Missing <param name="identifier"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher.DispatchParseError(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String)"]

message String

[Missing <param name="message"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher.DispatchParseError(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String)"]

See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.DispatchUserRequest Method

ILiveOddsFeedDispatcherDispatchUserRequest Method

Dispatches the user request.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void DispatchUserRequest(
    UserRequest request,
    OddsReplyType? reply_type,
    long key
)

Parameters

request UserRequest
The request.
reply_type Nullable OddsReplyType
The reply_type.
key Int64
The key.
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher Events

The ILiveOddsFeedDispatcher type exposes the following members.

Events
 | Name | Description
Public event | AfterMessageDispatched | Occurs when [after message dispatched].
Public event | OnAlive | Occurs when [on alive received].
Public event | OnBetCancel | Occurs when [on bet cancel].
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone].
Public event | OnBetClear | Occurs when [on bet clear].
Public event | OnBetClearRollback | Occurs when [on bet clear rollback].
Public event | OnBetStart | Occurs when [on bet start].
Public event | OnBetStop | Occurs when [on bet stop].
Public event | OnConnectionStable | Occurs when connection stable.
Public event | OnConnectionUnstable | Occurs when connection unstable.
Public event | OnEventMessages | Occurs when [on match messages received].
Public event | OnEventStatus | Occurs when [on match status received].
Public event | OnFeedError | Occurs when [on feed error].
Public event | OnMetaInfo | Occurs when [on meta info received].
Public event | OnOddsChange | Occurs when [on odds change].
Public event | OnRaceResult | Occurs when [on race result].
Public event | OnScoreCard | Occurs when [on score card received].
Top
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.AfterMessageDispatched Event

ILiveOddsFeedDispatcherAfterMessageDispatched Event

Occurs when [after message dispatched].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate AfterMessageDispatched

Value

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnAlive Event

ILiveOddsFeedDispatcherOnAlive Event

Occurs when [on alive received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<AliveEventArgs> OnAlive

Value

EventHandler AliveEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnBetCancel Event

ILiveOddsFeedDispatcherOnBetCancel Event

Occurs when [on bet cancel].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<BetCancelEventArgs> OnBetCancel

Value

EventHandler BetCancelEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnBetCancelUndo Event

ILiveOddsFeedDispatcherOnBetCancelUndo Event

Occurs when [on bet cancel undone].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<BetCancelUndoEventArgs> OnBetCancelUndo

Value

EventHandler BetCancelUndoEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnBetClear Event

ILiveOddsFeedDispatcherOnBetClear Event

Occurs when [on bet clear].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<BetClearEventArgs> OnBetClear

Value

EventHandler BetClearEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnBetClearRollback Event

ILiveOddsFeedDispatcherOnBetClearRollback Event

Occurs when [on bet clear rollback].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<BetClearRollbackEventArgs> OnBetClearRollback

Value

EventHandler BetClearRollbackEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnBetStart Event

ILiveOddsFeedDispatcherOnBetStart Event

Occurs when [on bet start].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<BetStartEventArgs> OnBetStart

Value

EventHandler BetStartEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnBetStop Event

ILiveOddsFeedDispatcherOnBetStop Event

Occurs when [on bet stop].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<BetStopEventArgs> OnBetStop

Value

EventHandler BetStopEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnConnectionStable Event

ILiveOddsFeedDispatcherOnConnectionStable Event

Occurs when connection stable.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler OnConnectionStable

Value

EventHandler
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnConnectionUnstable Event

ILiveOddsFeedDispatcherOnConnectionUnstable Event

Occurs when connection unstable.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler OnConnectionUnstable

Value

EventHandler
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnEventMessages Event

ILiveOddsFeedDispatcherOnEventMessages Event

Occurs when [on match messages received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<EventDataReceivedEventArgs> OnEventMessages

Value

EventHandler EventDataReceivedEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnEventStatus Event

ILiveOddsFeedDispatcherOnEventStatus Event

Occurs when [on match status received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<EventDataReceivedEventArgs> OnEventStatus

Value

EventHandler EventDataReceivedEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnFeedError Event

ILiveOddsFeedDispatcherOnFeedError Event

Occurs when [on feed error].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<FeedErrorEventArgs> OnFeedError

Value

EventHandler FeedErrorEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnMetaInfo Event

ILiveOddsFeedDispatcherOnMetaInfo Event

Occurs when [on meta info received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MetaInfoEventArgs> OnMetaInfo

Value

EventHandler MetaInfoEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnOddsChange Event

ILiveOddsFeedDispatcherOnOddsChange Event

Occurs when [on odds change].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OddsChangeEventArgs> OnOddsChange

Value

EventHandler OddsChangeEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnRaceResult Event

ILiveOddsFeedDispatcherOnRaceResult Event

Occurs when [on race result].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<RaceResultEventArgs> OnRaceResult

Value

EventHandler RaceResultEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedDispatcher.OnScoreCard Event

ILiveOddsFeedDispatcherOnScoreCard Event

Occurs when [on score card received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<ScoreCardSummaryEventArgs> OnScoreCard

Value

EventHandler ScoreCardSummaryEventArgs
See Also

Reference

ILiveOddsFeedDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOddsFeedMonitor

The ILiveOddsFeedMonitor type exposes the following members.

Properties
 | Name | Description
Public property | ActiveEventIds |
Top
Methods
 | Name | Description
Public method | AfterMessageDispatched |
Public method | BeforeParsedMessageReceived |
Public method | Connected |
Public method | Disconnected |
Top
Events
 | Name | Description
Public event | OnAfterMessageDispatched |
Public event | OnBeforeParsedMessageReceived |
Public event | OnConnected |
Public event | OnDisconnected |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor Properties

The ILiveOddsFeedMonitor type exposes the following members.

Properties
 | Name | Description
Public property | ActiveEventIds |
Top
See Also

Reference

ILiveOddsFeedMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor.ActiveEventIds Property

ILiveOddsFeedMonitorActiveEventIds Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.ActiveEventIds"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
HashSet<long> ActiveEventIds { get; }

Property Value

HashSet Int64
See Also

Reference

ILiveOddsFeedMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor Methods

The ILiveOddsFeedMonitor type exposes the following members.

Methods
 | Name | Description
Public method | AfterMessageDispatched |
Public method | BeforeParsedMessageReceived |
Public method | Connected |
Public method | Disconnected |
Top
See Also

Reference

ILiveOddsFeedMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor.AfterMessageDispatched Method

ILiveOddsFeedMonitorAfterMessageDispatched Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.AfterMessageDispatched(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void AfterMessageDispatched(
    OddsEntityBase entity,
    DispatchStatus status
)

Parameters

entity OddsEntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.AfterMessageDispatched(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus)"]

status DispatchStatus

[Missing <param name="status"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.AfterMessageDispatched(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus)"]

See Also

Reference

ILiveOddsFeedMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor.BeforeParsedMessageReceived Method

ILiveOddsFeedMonitorBeforeParsedMessageReceived Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.BeforeParsedMessageReceived(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void BeforeParsedMessageReceived(
    OddsEntityBase entity,
    LiveOddsFeedStatusDelegatesInterceptionOutcome outcome
)

Parameters

entity OddsEntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.BeforeParsedMessageReceived(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome)"]

outcome LiveOddsFeedStatusDelegatesInterceptionOutcome

[Missing <param name="outcome"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.BeforeParsedMessageReceived(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome)"]

See Also

Reference

ILiveOddsFeedMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor.Connected Method

ILiveOddsFeedMonitorConnected Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.Connected(System.Nullable{System.DateTime})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Connected(
    DateTime? time
)

Parameters

time Nullable DateTime

[Missing <param name="time"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.Connected(System.Nullable{System.DateTime})"]

See Also

Reference

ILiveOddsFeedMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor.Disconnected Method

ILiveOddsFeedMonitorDisconnected Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.Disconnected(System.Nullable{System.DateTime})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void Disconnected(
    DateTime? time
)

Parameters

time Nullable DateTime

[Missing <param name="time"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.Disconnected(System.Nullable{System.DateTime})"]

See Also

Reference

ILiveOddsFeedMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor Events

The ILiveOddsFeedMonitor type exposes the following members.

Events
 | Name | Description
Public event | OnAfterMessageDispatched |
Public event | OnBeforeParsedMessageReceived |
Public event | OnConnected |
Public event | OnDisconnected |
Top
See Also

Reference

ILiveOddsFeedMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor.OnAfterMessageDispatched Event

ILiveOddsFeedMonitorOnAfterMessageDispatched Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.OnAfterMessageDispatched"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate OnAfterMessageDispatched

Value

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate
See Also

Reference

ILiveOddsFeedMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor.OnBeforeParsedMessageReceived Event

ILiveOddsFeedMonitorOnBeforeParsedMessageReceived Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.OnBeforeParsedMessageReceived"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate OnBeforeParsedMessageReceived

Value

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate
See Also

Reference

ILiveOddsFeedMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor.OnConnected Event

ILiveOddsFeedMonitorOnConnected Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.OnConnected"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event ConnectionProviderDelegatesConnectionDelegate OnConnected

Value

ConnectionProviderDelegatesConnectionDelegate
See Also

Reference

ILiveOddsFeedMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsFeedMonitor.OnDisconnected Event

ILiveOddsFeedMonitorOnDisconnected Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor.OnDisconnected"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event ConnectionProviderDelegatesConnectionDelegate OnDisconnected

Value

ConnectionProviderDelegatesConnectionDelegate
See Also

Reference

ILiveOddsFeedMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOddsRequestProducer

The ILiveOddsRequestProducer type exposes the following members.

Methods
 | Name | Description
Public method | PrepareBook |
Public method | PrepareGetEventList |
Public method | PrepareGetEventMessages |
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetScoreAndCardSummary |
Public method | PrepareRacedayMetaRequest |
Public method | PrepareRegisterBetTypes |
Public method | PrepareSubscribe |
Public method | PrepareUnregisterBetTypes |
Public method | PrepareUnsubscribe |
Public method | SendCurrentRequest |
Top
Events
 | Name | Description
Public event | OnRequestAdded |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer Methods

The ILiveOddsRequestProducer type exposes the following members.

Methods
 | Name | Description
Public method | PrepareBook |
Public method | PrepareGetEventList |
Public method | PrepareGetEventMessages |
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetScoreAndCardSummary |
Public method | PrepareRacedayMetaRequest |
Public method | PrepareRegisterBetTypes |
Public method | PrepareSubscribe |
Public method | PrepareUnregisterBetTypes |
Public method | PrepareUnsubscribe |
Public method | SendCurrentRequest |
Top
See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.PrepareBook Method

ILiveOddsRequestProducerPrepareBook Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareBook(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.PrepareGetEventList Method

ILiveOddsRequestProducerPrepareGetEventList Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareGetEventList(
    DateTime? from,
    DateTime? to,
    PreparationRequest prep,
    IEnumerable<long> event_ids = null,
    bool? include_available = null
)

Parameters

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

to Nullable DateTime

[Missing <param name="to"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

event_ids IEnumerable Int64 (Optional)

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

include_available Nullable Boolean (Optional)

[Missing <param name="include_available"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.PrepareGetEventMessages Method

ILiveOddsRequestProducerPrepareGetEventMessages Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareGetEventMessages(
    long event_id,
    long? from,
    long? to,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable Int64

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

to Nullable Int64

[Missing <param name="to"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.PrepareGetEventStatus Method

ILiveOddsRequestProducerPrepareGetEventStatus Method

Overload List
 | Name | Description
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Top
See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.PrepareGetEventStatus(IEnumerable<Int64>, Nullable<DateTime>, PreparationRequest, Boolean) Method

ILiveOddsRequestProducerPrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareGetEventStatus(
    IEnumerable<long> event_ids,
    DateTime? from,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

See Also

Reference

ILiveOddsRequestProducer Interface
PrepareGetEventStatus Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.PrepareGetEventStatus(Int64, Nullable<DateTime>, PreparationRequest, Boolean) Method

ILiveOddsRequestProducerPrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareGetEventStatus(
    long event_id,
    DateTime? from,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

See Also

Reference

ILiveOddsRequestProducer Interface
PrepareGetEventStatus Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.PrepareGetScoreAndCardSummary Method

ILiveOddsRequestProducerPrepareGetScoreAndCardSummary Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareGetScoreAndCardSummary(
    long event_id,
    PreparationRequest prep
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.PrepareRacedayMetaRequest Method

ILiveOddsRequestProducerPrepareRacedayMetaRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareRacedayMetaRequest(
    IEnumerable<int> racedays,
    PreparationRequest prep
)

Parameters

racedays IEnumerable Int32

[Missing <param name="racedays"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.PrepareRegisterBetTypes Method

ILiveOddsRequestProducerPrepareRegisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareRegisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes,
    PreparationRequest prep
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.PrepareSubscribe Method

ILiveOddsRequestProducerPrepareSubscribe Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareSubscribe(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.PrepareUnregisterBetTypes Method

ILiveOddsRequestProducerPrepareUnregisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareUnregisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes,
    PreparationRequest prep
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.PrepareUnsubscribe Method

ILiveOddsRequestProducerPrepareUnsubscribe Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareUnsubscribe(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.SendCurrentRequest Method

ILiveOddsRequestProducerSendCurrentRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long SendCurrentRequest(
    long? virtual_game_id,
    IEnumerable<long> event_ids
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer Events

The ILiveOddsRequestProducer type exposes the following members.

Events
 | Name | Description
Public event | OnRequestAdded |
Top
See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsRequestProducer.OnRequestAdded Event

ILiveOddsRequestProducerOnRequestAdded Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer.OnRequestAdded"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event RequestProducerDelegatesRequestDelegate OnRequestAdded

Value

RequestProducerDelegatesRequestDelegate
See Also

Reference

ILiveOddsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsWithOutrightsRequestProducer Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOddsWithOutrightsRequestProducer : ILiveOddsRequestProducer

The ILiveOddsWithOutrightsRequestProducer type exposes the following members.

Methods
 | Name | Description
Public method | PrepareBook | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareGetEventList | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareGetEventMessages | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareGetOutrightList |
Public method | PrepareGetOutrightStatus |
Public method | PrepareGetScoreAndCardSummary | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareRacedayMetaRequest | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareRegisterBetTypes | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareSubscribe | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareUnregisterBetTypes | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareUnsubscribe | (Inherited from ILiveOddsRequestProducer)
Public method | SendCurrentRequest(NullableInt64, IEnumerableInt64) | (Inherited from ILiveOddsRequestProducer)
Public method | SendCurrentRequest(NullableInt64, IEnumerableInt64, IEnumerableInt64) |
Top
Events
 | Name | Description
Public event | OnRequestAdded | (Inherited from ILiveOddsRequestProducer)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsWithOutrightsRequestProducer Methods

The ILiveOddsWithOutrightsRequestProducer type exposes the following members.

Methods
 | Name | Description
Public method | PrepareBook | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareGetEventList | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareGetEventMessages | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareGetOutrightList |
Public method | PrepareGetOutrightStatus |
Public method | PrepareGetScoreAndCardSummary | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareRacedayMetaRequest | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareRegisterBetTypes | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareSubscribe | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareUnregisterBetTypes | (Inherited from ILiveOddsRequestProducer)
Public method | PrepareUnsubscribe | (Inherited from ILiveOddsRequestProducer)
Public method | SendCurrentRequest(NullableInt64, IEnumerableInt64) | (Inherited from ILiveOddsRequestProducer)
Public method | SendCurrentRequest(NullableInt64, IEnumerableInt64, IEnumerableInt64) |
Top
See Also

Reference

ILiveOddsWithOutrightsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightList Method

ILiveOddsWithOutrightsRequestProducerPrepareGetOutrightList Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightList(Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareGetOutrightList(
    PreparationRequest prep,
    IEnumerable<long> outright_ids = null,
    bool? include_available = null
)

Parameters

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightList(Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

outright_ids IEnumerable Int64 (Optional)

[Missing <param name="outright_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightList(Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

include_available Nullable Boolean (Optional)

[Missing <param name="include_available"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightList(Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightList(Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

See Also

Reference

ILiveOddsWithOutrightsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightStatus Method

ILiveOddsWithOutrightsRequestProducerPrepareGetOutrightStatus Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
PreparationResult PrepareGetOutrightStatus(
    IEnumerable<long> outright_ids,
    DateTime? from,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

outright_ids IEnumerable Int64

[Missing <param name="outright_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.PrepareGetOutrightStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

See Also

Reference

ILiveOddsWithOutrightsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsWithOutrightsRequestProducer.SendCurrentRequest Method

ILiveOddsWithOutrightsRequestProducerSendCurrentRequest Method

Overload List
 | Name | Description
Public method | SendCurrentRequest(NullableInt64, IEnumerableInt64) |
Public method | SendCurrentRequest(NullableInt64, IEnumerableInt64, IEnumerableInt64) |
Top
See Also

Reference

ILiveOddsWithOutrightsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsWithOutrightsRequestProducer.SendCurrentRequest(Nullable<Int64>, IEnumerable<Int64>, IEnumerable<Int64>) Method

ILiveOddsWithOutrightsRequestProducerSendCurrentRequest(NullableInt64, IEnumerableInt64, IEnumerableInt64) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long SendCurrentRequest(
    long? virtual_game_id,
    IEnumerable<long> event_ids,
    IEnumerable<long> outright_ids
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

outright_ids IEnumerable Int64

[Missing <param name="outright_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

See Also

Reference

ILiveOddsWithOutrightsRequestProducer Interface
SendCurrentRequest Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ILiveOddsWithOutrightsRequestProducer Events

The ILiveOddsWithOutrightsRequestProducer type exposes the following members.

Events
 | Name | Description
Public event | OnRequestAdded | (Inherited from ILiveOddsRequestProducer)
Top
See Also

Reference

ILiveOddsWithOutrightsRequestProducer Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IncrementalSequenceProvider Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IncrementalSequenceProvider"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalIncrementalSequenceProvider

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class IncrementalSequenceProvider

The IncrementalSequenceProvider type exposes the following members.

Constructors
 | Name | Description
Public method | IncrementalSequenceProvider | Initializes a new instance of the IncrementalSequenceProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSeqNum |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IncrementalSequenceProvider Constructor

Initializes a new instance of the IncrementalSequenceProvider class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IncrementalSequenceProvider(
    long min,
    long max
)

Parameters

min Int64

[Missing <param name="min"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IncrementalSequenceProvider.#ctor(System.Int64,System.Int64)"]

max Int64

[Missing <param name="max"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IncrementalSequenceProvider.#ctor(System.Int64,System.Int64)"]

See Also

Reference

IncrementalSequenceProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IncrementalSequenceProvider Methods

The IncrementalSequenceProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSeqNum |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

IncrementalSequenceProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


IncrementalSequenceProvider.GetSeqNum Method

IncrementalSequenceProviderGetSeqNum Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IncrementalSequenceProvider.GetSeqNum"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long GetSeqNum()

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.IncrementalSequenceProvider.GetSeqNum"]

See Also

Reference

IncrementalSequenceProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ISequenceMonitor Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ISequenceMonitor"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ISequenceMonitor

The ISequenceMonitor type exposes the following members.

Methods
 | Name | Description
Public method | Current |
Public method | ForceSequenceNumber |
Public method | NewEvent |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ISequenceMonitor Methods

The ISequenceMonitor type exposes the following members.

Methods
 | Name | Description
Public method | Current |
Public method | ForceSequenceNumber |
Public method | NewEvent |
Top
See Also

Reference

ISequenceMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ISequenceMonitor.Current Method

ISequenceMonitorCurrent Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ISequenceMonitor.Current(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long? Current(
    EventWrapperEventWrapperId event_id
)

Parameters

event_id EventWrapperEventWrapperId

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ISequenceMonitor.Current(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId)"]

Return Value

Nullable Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ISequenceMonitor.Current(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId)"]

See Also

Reference

ISequenceMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ISequenceMonitor.ForceSequenceNumber Method

ISequenceMonitorForceSequenceNumber Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ISequenceMonitor.ForceSequenceNumber(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void ForceSequenceNumber(
    EventWrapperEventWrapperId event_id,
    long seq_nr
)

Parameters

event_id EventWrapperEventWrapperId

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ISequenceMonitor.ForceSequenceNumber(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

seq_nr Int64

[Missing <param name="seq_nr"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ISequenceMonitor.ForceSequenceNumber(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

See Also

Reference

ISequenceMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


ISequenceMonitor.NewEvent Method

ISequenceMonitorNewEvent Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ISequenceMonitor.NewEvent(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
bool NewEvent(
    EventWrapperEventWrapperId event_id,
    long seq_nr
)

Parameters

event_id EventWrapperEventWrapperId

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ISequenceMonitor.NewEvent(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

seq_nr Int64

[Missing <param name="seq_nr"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ISequenceMonitor.NewEvent(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.ISequenceMonitor.NewEvent(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

See Also

Reference

ISequenceMonitor Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProvider Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProvider"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsRaceFeedProvider

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public abstract class LiveOddsCommonFeedProvider : LiveOddsCommonFeedProviderBase,
    ILiveOddsCommon, ILiveOddsCommonBase, ILiveFeeds, IStartable

The LiveOddsCommonFeedProvider type exposes the following members.

Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | Start component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Stop | Stop / shutdown component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received].
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProvider Properties

The LiveOddsCommonFeedProvider type exposes the following members.

Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsCommonFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProvider Methods

The LiveOddsCommonFeedProvider type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | Start component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Stop | Stop / shutdown component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsCommonFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProvider Events

The LiveOddsCommonFeedProvider type exposes the following members.

Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received].
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsCommonFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProvider.OnAlive Event

LiveOddsCommonFeedProviderOnAlive Event

Occurs when [on alive received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<AliveEventArgs> OnAlive

Value

EventHandler AliveEventArgs

Implements

ILiveOddsCommonOnAlive
See Also

Reference

LiveOddsCommonFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsWithOutrightsFeedProvider

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public abstract class LiveOddsCommonFeedProviderBase : ILiveOddsCommonBase,
    ILiveFeeds, IStartable

The LiveOddsCommonFeedProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations.
Public property | AvailableTranslations | Language codes of the currently available translations.
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely?
Public property | LastAliveMessage | Get time when the last alive message from the server was received.
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent.
Public property | ProtoProvider | Underlying protocol provider.
Public property | ProviderType |
Public property | ServerTime | Get current server time (or null if it is stale).
Public property | SubscribedEvents |
Top
Methods
 | Name | Description
Public method | BookEvents |
Public method | ClearState |
Public method | DisableErrorRecovery |
Public method | EnableErrorRecovery |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) |
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) |
Public method | GetEventMessages |
Public method | GetEventsStatus |
Public method | GetEventStatus |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity |
Public method | RegisterMessageDispatcher |
Public method | Start | Start component.
Public method | Stop | Stop / shutdown component.
Public method | Subscribe |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe |
Top
Events
 | Name | Description
Public event | OnBetCancel | Occurs when [on bet cancel].
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone].
Public event | OnBetClear | Occurs when [on bet clear].
Public event | OnBetClearRollback | Occurs when [on bet clear rollback].
Public event | OnBetStart | Occurs when [on bet start].
Public event | OnBetStop | Occurs when [on bet stop].
Public event | OnConnectionStable | Occurs when connection stable.
Public event | OnConnectionUnstable | Occurs when connection unstable.
Public event | OnEventMessages | Occurs when [on match messages received].
Public event | OnEventStatus | Occurs when [on match status received].
Public event | OnFeedError | Occurs when [on feed error].
Public event | OnMetaInfo | Occurs when [on meta info received].
Public event | OnOddsChange | Occurs when [on odds change].
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase Properties

The LiveOddsCommonFeedProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations.
Public property | AvailableTranslations | Language codes of the currently available translations.
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely?
Public property | LastAliveMessage | Get time when the last alive message from the server was received.
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent.
Public property | ProtoProvider | Underlying protocol provider.
Public property | ProviderType |
Public property | ServerTime | Get current server time (or null if it is stale).
Public property | SubscribedEvents |
Top
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.AvailableMetadataTranslations Property

LiveOddsCommonFeedProviderBaseAvailableMetadataTranslations Property

Gets the available metadata translations.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual string[] AvailableMetadataTranslations { get; }

Property Value

String
The available metadata translations.
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.AvailableTranslations Property

LiveOddsCommonFeedProviderBaseAvailableTranslations Property

Language codes of the currently available translations.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual string[] AvailableTranslations { get; }

Property Value

String

Implements

ILiveFeedsAvailableTranslations
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.IsConnectionStable Property

LiveOddsCommonFeedProviderBaseIsConnectionStable Property

Is the current connection stable enough to accept bets safely?

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool IsConnectionStable { get; }

Property Value

Boolean

Implements

ILiveOddsCommonBaseIsConnectionStable
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.LastAliveMessage Property

LiveOddsCommonFeedProviderBaseLastAliveMessage Property

Get time when the last alive message from the server was received.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual DateTime LastAliveMessage { get; }

Property Value

DateTime

Implements

ILiveFeedsLastAliveMessage
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.LastServerMessage Property

LiveOddsCommonFeedProviderBaseLastServerMessage Property

Get time when the last message from the server was received. This includes alive messages that are periodically sent.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual DateTime LastServerMessage { get; }

Property Value

DateTime

Implements

ILiveFeedsLastServerMessage
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.ProtoProvider Property

LiveOddsCommonFeedProviderBaseProtoProvider Property

Underlying protocol provider.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IProtocolProvider ProtoProvider { get; }

Property Value

IProtocolProvider
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.ProviderType Property

LiveOddsCommonFeedProviderBaseProviderType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.ProviderType"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public abstract ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.ServerTime Property

LiveOddsCommonFeedProviderBaseServerTime Property

Get current server time (or null if it is stale).

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime? ServerTime { get; }

Property Value

Nullable DateTime

Implements

ILiveFeedsServerTime
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.SubscribedEvents Property

LiveOddsCommonFeedProviderBaseSubscribedEvents Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.SubscribedEvents"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual long[] SubscribedEvents { get; }

Property Value

Int64

Implements

ILiveFeedsSubscribedEvents
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase Methods

The LiveOddsCommonFeedProviderBase type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents |
Public method | ClearState |
Public method | DisableErrorRecovery |
Public method | EnableErrorRecovery |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) |
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) |
Public method | GetEventMessages |
Public method | GetEventsStatus |
Public method | GetEventStatus |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity |
Public method | RegisterMessageDispatcher |
Public method | Start | Start component.
Public method | Stop | Stop / shutdown component.
Public method | Subscribe |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe |
Top
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.BookEvents Method

LiveOddsCommonFeedProviderBaseBookEvents Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.BookEvents(System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? BookEvents(
    IEnumerable<long> event_ids
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.BookEvents(System.Collections.Generic.IEnumerable{System.Int64})"]

Return Value

Nullable Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.BookEvents(System.Collections.Generic.IEnumerable{System.Int64})"]

See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.ClearState Method

LiveOddsCommonFeedProviderBaseClearState Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.ClearState"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void ClearState()

Implements

ILiveFeedsClearState
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.DisableErrorRecovery Method

LiveOddsCommonFeedProviderBaseDisableErrorRecovery Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.DisableErrorRecovery"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void DisableErrorRecovery()
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.EnableErrorRecovery Method

LiveOddsCommonFeedProviderBaseEnableErrorRecovery Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.EnableErrorRecovery"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EnableErrorRecovery()
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.GetEventList Method

LiveOddsCommonFeedProviderBaseGetEventList Method

Overload List
 | Name | Description
Public method | GetEventList(IEnumerableInt64) |
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) |
Top
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.GetEventList(IEnumerable<Int64>) Method

LiveOddsCommonFeedProviderBaseGetEventList(IEnumerableInt64) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventList(System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long GetEventList(
    IEnumerable<long> event_ids
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventList(System.Collections.Generic.IEnumerable{System.Int64})"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventList(System.Collections.Generic.IEnumerable{System.Int64})"]

Implements

ILiveOddsCommonBaseGetEventList(IEnumerableInt64)
See Also

Reference

LiveOddsCommonFeedProviderBase Class
GetEventList Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.GetEventList(Nullable<DateTime>, Nullable<DateTime>, Boolean) Method

LiveOddsCommonFeedProviderBaseGetEventList(NullableDateTime, NullableDateTime, Boolean) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long GetEventList(
    DateTime? from,
    DateTime? to,
    bool include_available
)

Parameters

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},System.Boolean)"]

to Nullable DateTime

[Missing <param name="to"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},System.Boolean)"]

include_available Boolean

[Missing <param name="include_available"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},System.Boolean)"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},System.Boolean)"]

Implements

ILiveOddsCommonBaseGetEventList(NullableDateTime, NullableDateTime, Boolean)
See Also

Reference

LiveOddsCommonFeedProviderBase Class
GetEventList Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.GetEventMessages Method

LiveOddsCommonFeedProviderBaseGetEventMessages Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual long GetEventMessages(
    long match_id,
    long? from,
    long? to,
    bool package
)

Parameters

match_id Int64

[Missing <param name="match_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},System.Boolean)"]

from Nullable Int64

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},System.Boolean)"]

to Nullable Int64

[Missing <param name="to"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},System.Boolean)"]

package Boolean

[Missing <param name="package"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},System.Boolean)"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},System.Boolean)"]

Implements

ILiveOddsCommonBaseGetEventMessages(Int64, NullableInt64, NullableInt64, Boolean)
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.GetEventsStatus Method

LiveOddsCommonFeedProviderBaseGetEventsStatus Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventsStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual long GetEventsStatus(
    IEnumerable<long> event_id,
    DateTime? from = null,
    bool package = true
)

Parameters

event_id IEnumerable Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventsStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},System.Boolean)"]

from Nullable DateTime (Optional)

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventsStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},System.Boolean)"]

package Boolean (Optional)

[Missing <param name="package"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventsStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},System.Boolean)"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventsStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},System.Boolean)"]

Implements

ILiveOddsCommonBaseGetEventsStatus(IEnumerableInt64, NullableDateTime, Boolean)
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.GetEventStatus Method

LiveOddsCommonFeedProviderBaseGetEventStatus Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventStatus(System.Int64,System.Nullable{System.DateTime},System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual long GetEventStatus(
    long event_id,
    DateTime? from,
    bool package
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventStatus(System.Int64,System.Nullable{System.DateTime},System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventStatus(System.Int64,System.Nullable{System.DateTime},System.Boolean)"]

package Boolean

[Missing <param name="package"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventStatus(System.Int64,System.Nullable{System.DateTime},System.Boolean)"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.GetEventStatus(System.Int64,System.Nullable{System.DateTime},System.Boolean)"]

Implements

ILiveOddsCommonBaseGetEventStatus(Int64, NullableDateTime, Boolean)
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.HandleEntity Method

LiveOddsCommonFeedProviderBaseHandleEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.HandleEntity(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void HandleEntity(
    OddsEntityBase entity
)

Parameters

entity OddsEntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.HandleEntity(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase)"]

See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.RegisterMessageDispatcher Method

LiveOddsCommonFeedProviderBaseRegisterMessageDispatcher Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.RegisterMessageDispatcher(Sportradar.SDK.Common.Interfaces.IMessageDispatcher)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void RegisterMessageDispatcher(
    IMessageDispatcher msg_dispatcher
)

Parameters

msg_dispatcher IMessageDispatcher

[Missing <param name="msg_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.RegisterMessageDispatcher(Sportradar.SDK.Common.Interfaces.IMessageDispatcher)"]

See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.Start Method

LiveOddsCommonFeedProviderBaseStart Method

Start component.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Start()

Implements

IStartableStart
Remarks
The component should be initialized first.
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.Stop Method

LiveOddsCommonFeedProviderBaseStop Method

Stop / shutdown component.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Stop()

Implements

IStartableStop
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.Subscribe Method

LiveOddsCommonFeedProviderBaseSubscribe Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.Subscribe(System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Subscribe(
    IEnumerable<long> event_ids
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.Subscribe(System.Collections.Generic.IEnumerable{System.Int64})"]

See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.Unsubscribe Method

LiveOddsCommonFeedProviderBaseUnsubscribe Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.Unsubscribe(System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Unsubscribe(
    IEnumerable<long> event_ids
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsCommonFeedProviderBase.Unsubscribe(System.Collections.Generic.IEnumerable{System.Int64})"]

See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase Events

The LiveOddsCommonFeedProviderBase type exposes the following members.

Events
 | Name | Description
Public event | OnBetCancel | Occurs when [on bet cancel].
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone].
Public event | OnBetClear | Occurs when [on bet clear].
Public event | OnBetClearRollback | Occurs when [on bet clear rollback].
Public event | OnBetStart | Occurs when [on bet start].
Public event | OnBetStop | Occurs when [on bet stop].
Public event | OnConnectionStable | Occurs when connection stable.
Public event | OnConnectionUnstable | Occurs when connection unstable.
Public event | OnEventMessages | Occurs when [on match messages received].
Public event | OnEventStatus | Occurs when [on match status received].
Public event | OnFeedError | Occurs when [on feed error].
Public event | OnMetaInfo | Occurs when [on meta info received].
Public event | OnOddsChange | Occurs when [on odds change].
Top
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnBetCancel Event

LiveOddsCommonFeedProviderBaseOnBetCancel Event

Occurs when [on bet cancel].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<BetCancelEventArgs> OnBetCancel

Value

EventHandler BetCancelEventArgs

Implements

ILiveOddsCommonBaseOnBetCancel
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnBetCancelUndo Event

LiveOddsCommonFeedProviderBaseOnBetCancelUndo Event

Occurs when [on bet cancel undone].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<BetCancelUndoEventArgs> OnBetCancelUndo

Value

EventHandler BetCancelUndoEventArgs

Implements

ILiveOddsCommonBaseOnBetCancelUndo
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnBetClear Event

LiveOddsCommonFeedProviderBaseOnBetClear Event

Occurs when [on bet clear].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<BetClearEventArgs> OnBetClear

Value

EventHandler BetClearEventArgs

Implements

ILiveOddsCommonBaseOnBetClear
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnBetClearRollback Event

LiveOddsCommonFeedProviderBaseOnBetClearRollback Event

Occurs when [on bet clear rollback].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<BetClearRollbackEventArgs> OnBetClearRollback

Value

EventHandler BetClearRollbackEventArgs

Implements

ILiveOddsCommonBaseOnBetClearRollback
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnBetStart Event

LiveOddsCommonFeedProviderBaseOnBetStart Event

Occurs when [on bet start].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<BetStartEventArgs> OnBetStart

Value

EventHandler BetStartEventArgs

Implements

ILiveOddsCommonBaseOnBetStart
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnBetStop Event

LiveOddsCommonFeedProviderBaseOnBetStop Event

Occurs when [on bet stop].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<BetStopEventArgs> OnBetStop

Value

EventHandler BetStopEventArgs

Implements

ILiveOddsCommonBaseOnBetStop
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnConnectionStable Event

LiveOddsCommonFeedProviderBaseOnConnectionStable Event

Occurs when connection stable.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler OnConnectionStable

Value

EventHandler

Implements

ILiveOddsCommonBaseOnConnectionStable
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnConnectionUnstable Event

LiveOddsCommonFeedProviderBaseOnConnectionUnstable Event

Occurs when connection unstable.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler OnConnectionUnstable

Value

EventHandler

Implements

ILiveOddsCommonBaseOnConnectionUnstable
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnEventMessages Event

LiveOddsCommonFeedProviderBaseOnEventMessages Event

Occurs when [on match messages received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<EventDataReceivedEventArgs> OnEventMessages

Value

EventHandler EventDataReceivedEventArgs

Implements

ILiveOddsCommonBaseOnEventMessages
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnEventStatus Event

LiveOddsCommonFeedProviderBaseOnEventStatus Event

Occurs when [on match status received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<EventDataReceivedEventArgs> OnEventStatus

Value

EventHandler EventDataReceivedEventArgs

Implements

ILiveOddsCommonBaseOnEventStatus
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnFeedError Event

LiveOddsCommonFeedProviderBaseOnFeedError Event

Occurs when [on feed error].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<FeedErrorEventArgs> OnFeedError

Value

EventHandler FeedErrorEventArgs
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnMetaInfo Event

LiveOddsCommonFeedProviderBaseOnMetaInfo Event

Occurs when [on meta info received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<MetaInfoEventArgs> OnMetaInfo

Value

EventHandler MetaInfoEventArgs

Implements

ILiveOddsCommonBaseOnMetaInfo
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsCommonFeedProviderBase.OnOddsChange Event

LiveOddsCommonFeedProviderBaseOnOddsChange Event

Occurs when [on odds change].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<OddsChangeEventArgs> OnOddsChange

Value

EventHandler OddsChangeEventArgs

Implements

ILiveOddsCommonBaseOnOddsChange
See Also

Reference

LiveOddsCommonFeedProviderBase Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsEntityFactory

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsEntityFactory : IFakeBetStopFactory,
    ILiveOddsEntityFactory

The LiveOddsEntityFactory type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsEntityFactory | Initializes a new instance of the LiveOddsEntityFactory class
Top
Methods
 | Name | Description
Public method | BuildAlive |
Public method | BuildBetCancel |
Public method | BuildBetCancelUndo |
Public method | BuildBetClear |
Public method | BuildBetClearRollback |
Public method | BuildBetStart |
Public method | BuildBetStop |
Public method | BuildFakeBetStop |
Public method | BuildIrrelevantOddsChange |
Public method | BuildMetaInfo |
Public method | BuildOddsChange |
Public method | BuildReplyStartEnd |
Public method | BuildScoreCardSummary |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory Constructor

Initializes a new instance of the LiveOddsEntityFactory class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsEntityFactory(
    ILiveOddsTypeProvider type_provider,
    ITimeKeeper server_timekeeper,
    SdkConfigurationLiveOdds local_config
)

Parameters

type_provider ILiveOddsTypeProvider

[Missing <param name="type_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.#ctor(Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

server_timekeeper ITimeKeeper

[Missing <param name="server_timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.#ctor(Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

local_config SdkConfigurationLiveOdds

[Missing <param name="local_config"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.#ctor(Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory Methods

The LiveOddsEntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildAlive |
Public method | BuildBetCancel |
Public method | BuildBetCancelUndo |
Public method | BuildBetClear |
Public method | BuildBetClearRollback |
Public method | BuildBetStart |
Public method | BuildBetStop |
Public method | BuildFakeBetStop |
Public method | BuildIrrelevantOddsChange |
Public method | BuildMetaInfo |
Public method | BuildOddsChange |
Public method | BuildReplyStartEnd |
Public method | BuildScoreCardSummary |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildAlive Method

LiveOddsEntityFactoryBuildAlive Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Alive BuildAlive(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

Alive

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Implements

ILiveOddsEntityFactoryBuildAlive(BetradarLiveOdds)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildBetCancel Method

LiveOddsEntityFactoryBuildBetCancel Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetCancel BuildBetCancel(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

BetCancel

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Implements

ILiveOddsEntityFactoryBuildBetCancel(BetradarLiveOdds)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildBetCancelUndo Method

LiveOddsEntityFactoryBuildBetCancelUndo Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetCancelUndo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetCancelUndo BuildBetCancelUndo(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetCancelUndo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

BetCancelUndo

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetCancelUndo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Implements

ILiveOddsEntityFactoryBuildBetCancelUndo(BetradarLiveOdds)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildBetClear Method

LiveOddsEntityFactoryBuildBetClear Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetClear BuildBetClear(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

BetClear

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Implements

ILiveOddsEntityFactoryBuildBetClear(BetradarLiveOdds)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildBetClearRollback Method

LiveOddsEntityFactoryBuildBetClearRollback Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetClearRollback(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetClearRollback BuildBetClearRollback(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetClearRollback(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

BetClearRollback

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetClearRollback(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Implements

ILiveOddsEntityFactoryBuildBetClearRollback(BetradarLiveOdds)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildBetStart Method

LiveOddsEntityFactoryBuildBetStart Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStart BuildBetStart(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

BetStart

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Implements

ILiveOddsEntityFactoryBuildBetStart(BetradarLiveOdds)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildBetStop Method

LiveOddsEntityFactoryBuildBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStop BuildBetStop(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

BetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Implements

ILiveOddsEntityFactoryBuildBetStop(BetradarLiveOdds)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildFakeBetStop Method

LiveOddsEntityFactoryBuildFakeBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildFakeBetStop(System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStop BuildFakeBetStop(
    long match_id
)

Parameters

match_id Int64

[Missing <param name="match_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildFakeBetStop(System.Int64)"]

Return Value

BetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildFakeBetStop(System.Int64)"]

Implements

IFakeBetStopFactoryBuildFakeBetStop(Int64)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildIrrelevantOddsChange Method

LiveOddsEntityFactoryBuildIrrelevantOddsChange Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildIrrelevantOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IrrelevantOddsChange BuildIrrelevantOddsChange(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildIrrelevantOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

IrrelevantOddsChange

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildIrrelevantOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Implements

ILiveOddsEntityFactoryBuildIrrelevantOddsChange(BetradarLiveOdds)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildMetaInfo Method

LiveOddsEntityFactoryBuildMetaInfo Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildMetaInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MetaInfo BuildMetaInfo(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildMetaInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

MetaInfo

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildMetaInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Implements

ILiveOddsEntityFactoryBuildMetaInfo(BetradarLiveOdds)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildOddsChange Method

LiveOddsEntityFactoryBuildOddsChange Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsChange BuildOddsChange(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

OddsChange

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Implements

ILiveOddsEntityFactoryBuildOddsChange(BetradarLiveOdds)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildReplyStartEnd Method

LiveOddsEntityFactoryBuildReplyStartEnd Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ReplyStartEnd BuildReplyStartEnd(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

ReplyStartEnd

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Implements

ILiveOddsEntityFactoryBuildReplyStartEnd(BetradarLiveOdds)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsEntityFactory.BuildScoreCardSummary Method

LiveOddsEntityFactoryBuildScoreCardSummary Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildScoreCardSummary(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoreCardSummary BuildScoreCardSummary(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildScoreCardSummary(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Return Value

ScoreCardSummary

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory.BuildScoreCardSummary(Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Incoming.BetradarLiveOdds)"]

Implements

ILiveOddsEntityFactoryBuildScoreCardSummary(BetradarLiveOdds)
See Also

Reference

LiveOddsEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedDispatcher
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsWithOutrightsDispatcher

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsFeedDispatcher : IFeedRecoveryDispatcher,
    ILiveOddsFeedDispatcher, IFeedDispatcher

The LiveOddsFeedDispatcher type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedDispatcher | Initializes a new instance of the LiveOddsFeedDispatcher class
Top
Properties
 | Name | Description
Public property | ProviderType |
Top
Methods
 | Name | Description
Public method | ConnectedHandler |
Public method | DisconnectedHandler |
Public method | DispatchArtificialBetStop |
Public method | DispatchArtificialBetStops | Dispatches the explicit bet stops.
Public method | DispatchConnectionStable | Dispatches the connection is stable.
Public method | DispatchConnectionUnstable | Dispatches the connection is unstable.
Public method | DispatchEntity | Dispatches the entity.
Public method | DispatchParseError |
Public method | DispatchUserRequest | Dispatches the user request.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | AfterMessageDispatched |
Public event | OnAlive | Occurs when [on alive received].
Public event | OnBetCancel | Occurs when [on bet cancel].
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone].
Public event | OnBetClear | Occurs when [on bet clear].
Public event | OnBetClearRollback | Occurs when [on bet clear rollback].
Public event | OnBetStart | Occurs when [on bet start].
Public event | OnBetStop | Occurs when [on bet stop].
Public event | OnConnectionStable | Occurs when connection stable.
Public event | OnConnectionUnstable | Occurs when connection unstable.
Public event | OnEventMessages | Occurs when [on match messages received].
Public event | OnEventStatus | Occurs when [on match status received].
Public event | OnFeedError | Occurs when [on feed error].
Public event | OnMetaInfo | Occurs when [on meta info received].
Public event | OnOddsChange | Occurs when [on odds change].
Public event | OnRaceResult | Occurs when [on race result].
Public event | OnScoreCard | Occurs when [on score card received].
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher Constructor

Initializes a new instance of the LiveOddsFeedDispatcher class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedDispatcher(
    ILiveOddsFeedMonitor feed_monitor,
    ProtocolProviderType provider_type,
    ISdkLogger sdk_logger,
    IFakeBetStopFactory fake_betstop_factory,
    ITimeKeeper server_timekeeper
)

Parameters

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactory,Sportradar.SDK.Common.Interfaces.ITimeKeeper)"]

provider_type ProtocolProviderType

[Missing <param name="provider_type"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactory,Sportradar.SDK.Common.Interfaces.ITimeKeeper)"]

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactory,Sportradar.SDK.Common.Interfaces.ITimeKeeper)"]

fake_betstop_factory IFakeBetStopFactory

[Missing <param name="fake_betstop_factory"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactory,Sportradar.SDK.Common.Interfaces.ITimeKeeper)"]

server_timekeeper ITimeKeeper

[Missing <param name="server_timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IFakeBetStopFactory,Sportradar.SDK.Common.Interfaces.ITimeKeeper)"]

See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher Properties

The LiveOddsFeedDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType |
Top
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.ProviderType Property

LiveOddsFeedDispatcherProviderType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.ProviderType"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType

Implements

IFeedDispatcherProviderType
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher Methods

The LiveOddsFeedDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | ConnectedHandler |
Public method | DisconnectedHandler |
Public method | DispatchArtificialBetStop |
Public method | DispatchArtificialBetStops | Dispatches the explicit bet stops.
Public method | DispatchConnectionStable | Dispatches the connection is stable.
Public method | DispatchConnectionUnstable | Dispatches the connection is unstable.
Public method | DispatchEntity | Dispatches the entity.
Public method | DispatchParseError |
Public method | DispatchUserRequest | Dispatches the user request.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.ConnectedHandler Method

LiveOddsFeedDispatcherConnectedHandler Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.ConnectedHandler(System.Nullable{System.DateTime})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void ConnectedHandler(
    DateTime? time
)

Parameters

time Nullable DateTime

[Missing <param name="time"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.ConnectedHandler(System.Nullable{System.DateTime})"]

See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.DisconnectedHandler Method

LiveOddsFeedDispatcherDisconnectedHandler Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.DisconnectedHandler(System.Nullable{System.DateTime})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void DisconnectedHandler(
    DateTime? time
)

Parameters

time Nullable DateTime

[Missing <param name="time"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.DisconnectedHandler(System.Nullable{System.DateTime})"]

See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.DispatchArtificialBetStop Method

LiveOddsFeedDispatcherDispatchArtificialBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.DispatchArtificialBetStop(System.Nullable{System.Int64},System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void DispatchArtificialBetStop(
    long? virtual_game_id,
    long event_id
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.DispatchArtificialBetStop(System.Nullable{System.Int64},System.Int64)"]

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.DispatchArtificialBetStop(System.Nullable{System.Int64},System.Int64)"]

Implements

IFeedRecoveryDispatcherDispatchArtificialBetStop(NullableInt64, Int64)
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.DispatchArtificialBetStops Method

LiveOddsFeedDispatcherDispatchArtificialBetStops Method

Dispatches the explicit bet stops.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void DispatchArtificialBetStops(
    long? virtual_game_id,
    IEnumerable<long> event_ids
)

Parameters

virtual_game_id Nullable Int64
Virtual game id of the event
event_ids IEnumerable Int64
The event_ids.

Implements

IFeedRecoveryDispatcherDispatchArtificialBetStops(NullableInt64, IEnumerableInt64)
Exceptions
Exception | Condition
ArgumentNullException | event_ids
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.DispatchConnectionStable Method

LiveOddsFeedDispatcherDispatchConnectionStable Method

Dispatches the connection is stable.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void DispatchConnectionStable(
    long? virtual_game_id
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.DispatchConnectionStable(System.Nullable{System.Int64})"]

Implements

IFeedRecoveryDispatcherDispatchConnectionStable(NullableInt64)
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.DispatchConnectionUnstable Method

LiveOddsFeedDispatcherDispatchConnectionUnstable Method

Dispatches the connection is unstable.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void DispatchConnectionUnstable(
    long? virtual_game_id
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.DispatchConnectionUnstable(System.Nullable{System.Int64})"]

Implements

IFeedRecoveryDispatcherDispatchConnectionUnstable(NullableInt64)
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.DispatchEntity Method

LiveOddsFeedDispatcherDispatchEntity Method

Dispatches the entity.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual DispatchStatus DispatchEntity(
    EntityBase entity
)

Parameters

entity EntityBase
The entity.

Return Value

DispatchStatus

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.DispatchEntity(Sportradar.SDK.Common.EntityBase)"]

Implements

ILiveOddsFeedDispatcherDispatchEntity(EntityBase)
IFeedDispatcherDispatchEntity(EntityBase)
Exceptions
Exception | Condition
ArgumentNullException | dispatcher_state
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.DispatchParseError Method

LiveOddsFeedDispatcherDispatchParseError Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.DispatchParseError(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void DispatchParseError(
    IMessageIdentifier identifier,
    string message
)

Parameters

identifier IMessageIdentifier

[Missing <param name="identifier"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.DispatchParseError(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String)"]

message String

[Missing <param name="message"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.DispatchParseError(Sportradar.SDK.Common.Interfaces.IMessageIdentifier,System.String)"]

Implements

ILiveOddsFeedDispatcherDispatchParseError(IMessageIdentifier, String)
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.DispatchUserRequest Method

LiveOddsFeedDispatcherDispatchUserRequest Method

Dispatches the user request.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void DispatchUserRequest(
    UserRequest request,
    OddsReplyType? reply_type,
    long key
)

Parameters

request UserRequest
The request.
reply_type Nullable OddsReplyType
The reply_type.
key Int64
The key.

Implements

ILiveOddsFeedDispatcherDispatchUserRequest(UserRequest, NullableOddsReplyType, Int64)
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher Events

The LiveOddsFeedDispatcher type exposes the following members.

Events
 | Name | Description
Public event | AfterMessageDispatched |
Public event | OnAlive | Occurs when [on alive received].
Public event | OnBetCancel | Occurs when [on bet cancel].
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone].
Public event | OnBetClear | Occurs when [on bet clear].
Public event | OnBetClearRollback | Occurs when [on bet clear rollback].
Public event | OnBetStart | Occurs when [on bet start].
Public event | OnBetStop | Occurs when [on bet stop].
Public event | OnConnectionStable | Occurs when connection stable.
Public event | OnConnectionUnstable | Occurs when connection unstable.
Public event | OnEventMessages | Occurs when [on match messages received].
Public event | OnEventStatus | Occurs when [on match status received].
Public event | OnFeedError | Occurs when [on feed error].
Public event | OnMetaInfo | Occurs when [on meta info received].
Public event | OnOddsChange | Occurs when [on odds change].
Public event | OnRaceResult | Occurs when [on race result].
Public event | OnScoreCard | Occurs when [on score card received].
Top
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.AfterMessageDispatched Event

LiveOddsFeedDispatcherAfterMessageDispatched Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedDispatcher.AfterMessageDispatched"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate AfterMessageDispatched

Value

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate

Implements

ILiveOddsFeedDispatcherAfterMessageDispatched
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnAlive Event

LiveOddsFeedDispatcherOnAlive Event

Occurs when [on alive received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<AliveEventArgs> OnAlive

Value

EventHandler AliveEventArgs

Implements

ILiveOddsFeedDispatcherOnAlive
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnBetCancel Event

LiveOddsFeedDispatcherOnBetCancel Event

Occurs when [on bet cancel].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<BetCancelEventArgs> OnBetCancel

Value

EventHandler BetCancelEventArgs

Implements

ILiveOddsFeedDispatcherOnBetCancel
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnBetCancelUndo Event

LiveOddsFeedDispatcherOnBetCancelUndo Event

Occurs when [on bet cancel undone].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<BetCancelUndoEventArgs> OnBetCancelUndo

Value

EventHandler BetCancelUndoEventArgs

Implements

ILiveOddsFeedDispatcherOnBetCancelUndo
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnBetClear Event

LiveOddsFeedDispatcherOnBetClear Event

Occurs when [on bet clear].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<BetClearEventArgs> OnBetClear

Value

EventHandler BetClearEventArgs

Implements

ILiveOddsFeedDispatcherOnBetClear
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnBetClearRollback Event

LiveOddsFeedDispatcherOnBetClearRollback Event

Occurs when [on bet clear rollback].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<BetClearRollbackEventArgs> OnBetClearRollback

Value

EventHandler BetClearRollbackEventArgs

Implements

ILiveOddsFeedDispatcherOnBetClearRollback
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnBetStart Event

LiveOddsFeedDispatcherOnBetStart Event

Occurs when [on bet start].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<BetStartEventArgs> OnBetStart

Value

EventHandler BetStartEventArgs

Implements

ILiveOddsFeedDispatcherOnBetStart
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnBetStop Event

LiveOddsFeedDispatcherOnBetStop Event

Occurs when [on bet stop].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<BetStopEventArgs> OnBetStop

Value

EventHandler BetStopEventArgs

Implements

ILiveOddsFeedDispatcherOnBetStop
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnConnectionStable Event

LiveOddsFeedDispatcherOnConnectionStable Event

Occurs when connection stable.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler OnConnectionStable

Value

EventHandler

Implements

ILiveOddsFeedDispatcherOnConnectionStable
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnConnectionUnstable Event

LiveOddsFeedDispatcherOnConnectionUnstable Event

Occurs when connection unstable.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler OnConnectionUnstable

Value

EventHandler

Implements

ILiveOddsFeedDispatcherOnConnectionUnstable
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnEventMessages Event

LiveOddsFeedDispatcherOnEventMessages Event

Occurs when [on match messages received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<EventDataReceivedEventArgs> OnEventMessages

Value

EventHandler EventDataReceivedEventArgs

Implements

ILiveOddsFeedDispatcherOnEventMessages
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnEventStatus Event

LiveOddsFeedDispatcherOnEventStatus Event

Occurs when [on match status received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<EventDataReceivedEventArgs> OnEventStatus

Value

EventHandler EventDataReceivedEventArgs

Implements

ILiveOddsFeedDispatcherOnEventStatus
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnFeedError Event

LiveOddsFeedDispatcherOnFeedError Event

Occurs when [on feed error].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<FeedErrorEventArgs> OnFeedError

Value

EventHandler FeedErrorEventArgs

Implements

ILiveOddsFeedDispatcherOnFeedError
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnMetaInfo Event

LiveOddsFeedDispatcherOnMetaInfo Event

Occurs when [on meta info received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<MetaInfoEventArgs> OnMetaInfo

Value

EventHandler MetaInfoEventArgs

Implements

ILiveOddsFeedDispatcherOnMetaInfo
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnOddsChange Event

LiveOddsFeedDispatcherOnOddsChange Event

Occurs when [on odds change].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<OddsChangeEventArgs> OnOddsChange

Value

EventHandler OddsChangeEventArgs

Implements

ILiveOddsFeedDispatcherOnOddsChange
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnRaceResult Event

LiveOddsFeedDispatcherOnRaceResult Event

Occurs when [on race result].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<RaceResultEventArgs> OnRaceResult

Value

EventHandler RaceResultEventArgs

Implements

ILiveOddsFeedDispatcherOnRaceResult
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedDispatcher.OnScoreCard Event

LiveOddsFeedDispatcherOnScoreCard Event

Occurs when [on score card received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<ScoreCardSummaryEventArgs> OnScoreCard

Value

EventHandler ScoreCardSummaryEventArgs

Implements

ILiveOddsFeedDispatcherOnScoreCard
See Also

Reference

LiveOddsFeedDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedMonitor

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsFeedMonitor : ILiveOddsFeedMonitor

The LiveOddsFeedMonitor type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedMonitor | Initializes a new instance of the LiveOddsFeedMonitor class
Top
Properties
 | Name | Description
Public property | ActiveEventIds |
Top
Methods
 | Name | Description
Public method | AfterMessageDispatched |
Public method | BeforeParsedMessageReceived |
Public method | Connected |
Public method | Disconnected |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | OnAfterMessageDispatched |
Public event | OnBeforeParsedMessageReceived |
Public event | OnConnected |
Public event | OnDisconnected |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor Constructor

Initializes a new instance of the LiveOddsFeedMonitor class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedMonitor()
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor Properties

The LiveOddsFeedMonitor type exposes the following members.

Properties
 | Name | Description
Public property | ActiveEventIds |
Top
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor.ActiveEventIds Property

LiveOddsFeedMonitorActiveEventIds Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.ActiveEventIds"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HashSet<long> ActiveEventIds { get; }

Property Value

HashSet Int64

Implements

ILiveOddsFeedMonitorActiveEventIds
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor Methods

The LiveOddsFeedMonitor type exposes the following members.

Methods
 | Name | Description
Public method | AfterMessageDispatched |
Public method | BeforeParsedMessageReceived |
Public method | Connected |
Public method | Disconnected |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor.AfterMessageDispatched Method

LiveOddsFeedMonitorAfterMessageDispatched Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.AfterMessageDispatched(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void AfterMessageDispatched(
    OddsEntityBase entity,
    DispatchStatus status
)

Parameters

entity OddsEntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.AfterMessageDispatched(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus)"]

status DispatchStatus

[Missing <param name="status"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.AfterMessageDispatched(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus)"]

Implements

ILiveOddsFeedMonitorAfterMessageDispatched(OddsEntityBase, DispatchStatus)
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor.BeforeParsedMessageReceived Method

LiveOddsFeedMonitorBeforeParsedMessageReceived Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.BeforeParsedMessageReceived(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void BeforeParsedMessageReceived(
    OddsEntityBase entity,
    LiveOddsFeedStatusDelegatesInterceptionOutcome outcome
)

Parameters

entity OddsEntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.BeforeParsedMessageReceived(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome)"]

outcome LiveOddsFeedStatusDelegatesInterceptionOutcome

[Missing <param name="outcome"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.BeforeParsedMessageReceived(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome)"]

Implements

ILiveOddsFeedMonitorBeforeParsedMessageReceived(OddsEntityBase, LiveOddsFeedStatusDelegatesInterceptionOutcome)
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor.Connected Method

LiveOddsFeedMonitorConnected Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.Connected(System.Nullable{System.DateTime})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Connected(
    DateTime? time
)

Parameters

time Nullable DateTime

[Missing <param name="time"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.Connected(System.Nullable{System.DateTime})"]

Implements

ILiveOddsFeedMonitorConnected(NullableDateTime)
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor.Disconnected Method

LiveOddsFeedMonitorDisconnected Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.Disconnected(System.Nullable{System.DateTime})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Disconnected(
    DateTime? time
)

Parameters

time Nullable DateTime

[Missing <param name="time"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.Disconnected(System.Nullable{System.DateTime})"]

Implements

ILiveOddsFeedMonitorDisconnected(NullableDateTime)
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor Events

The LiveOddsFeedMonitor type exposes the following members.

Events
 | Name | Description
Public event | OnAfterMessageDispatched |
Public event | OnBeforeParsedMessageReceived |
Public event | OnConnected |
Public event | OnDisconnected |
Top
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor.OnAfterMessageDispatched Event

LiveOddsFeedMonitorOnAfterMessageDispatched Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.OnAfterMessageDispatched"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate OnAfterMessageDispatched

Value

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate

Implements

ILiveOddsFeedMonitorOnAfterMessageDispatched
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor.OnBeforeParsedMessageReceived Event

LiveOddsFeedMonitorOnBeforeParsedMessageReceived Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.OnBeforeParsedMessageReceived"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate OnBeforeParsedMessageReceived

Value

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate

Implements

ILiveOddsFeedMonitorOnBeforeParsedMessageReceived
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor.OnConnected Event

LiveOddsFeedMonitorOnConnected Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.OnConnected"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event ConnectionProviderDelegatesConnectionDelegate OnConnected

Value

ConnectionProviderDelegatesConnectionDelegate

Implements

ILiveOddsFeedMonitorOnConnected
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedMonitor.OnDisconnected Event

LiveOddsFeedMonitorOnDisconnected Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedMonitor.OnDisconnected"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event ConnectionProviderDelegatesConnectionDelegate OnDisconnected

Value

ConnectionProviderDelegatesConnectionDelegate

Implements

ILiveOddsFeedMonitorOnDisconnected
See Also

Reference

LiveOddsFeedMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProvider
More

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsFeedProvider : LiveOddsCommonFeedProvider,
    ILiveOdds, ILiveOddsCommon, ILiveOddsCommonBase, ILiveFeeds, IStartable

The LiveOddsFeedProvider type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedProvider | Initializes a new instance of the LiveOddsFeedProvider class
Top
Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations.
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Overrides LiveOddsCommonFeedProviderBaseAvailableTranslations)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsCommonFeedProviderBaseProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Overrides LiveOddsCommonFeedProviderBaseSubscribedEvents)
Public property | TestManager |
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes |
Public method | GetBetType |
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes |
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Overrides LiveOddsCommonFeedProviderBaseStart)
Public method | Stop | (Overrides LiveOddsCommonFeedProviderBaseStop)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes |
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received].
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderBetPal
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderLivePlex
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderSoccerRoulette
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderVbl
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderVfl
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderVto


LiveOddsFeedProvider Constructor

Initializes a new instance of the LiveOddsFeedProvider class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedProvider(
    IStartable base_sdk,
    IProtocolProvider proto_provider,
    ILiveOddsFeedMonitor feed_monitor,
    ILiveOddsEntityFactory entity_factory,
    ILiveOddsTypeProvider live_odds_type_provider,
    ILiveOddsFeedDispatcher feed_dispatcher,
    ILiveOddsRequestProducer request_producer,
    IErrorManager error_manager,
    ILiveOddsTestManager test_manager,
    ITimeKeeper timekeeper,
    ISdkLogger sdk_logger
)

Parameters

base_sdk IStartable

[Missing <param name="base_sdk"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

proto_provider IProtocolProvider

[Missing <param name="proto_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

entity_factory ILiveOddsEntityFactory

[Missing <param name="entity_factory"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

live_odds_type_provider ILiveOddsTypeProvider

[Missing <param name="live_odds_type_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_dispatcher ILiveOddsFeedDispatcher

[Missing <param name="feed_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

request_producer ILiveOddsRequestProducer

[Missing <param name="request_producer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

error_manager IErrorManager

[Missing <param name="error_manager"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

test_manager ILiveOddsTestManager

[Missing <param name="test_manager"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

timekeeper ITimeKeeper

[Missing <param name="timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider Properties

The LiveOddsFeedProvider type exposes the following members.

Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations.
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Overrides LiveOddsCommonFeedProviderBaseAvailableTranslations)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsCommonFeedProviderBaseProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Overrides LiveOddsCommonFeedProviderBaseSubscribedEvents)
Public property | TestManager |
Top
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.AvailableBetTypeTranslations Property

LiveOddsFeedProviderAvailableBetTypeTranslations Property

Gets the available bet type translations.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual string[] AvailableBetTypeTranslations { get; }

Property Value

String
The available bet type translations.
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.AvailableTranslations Property

LiveOddsFeedProviderAvailableTranslations Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.AvailableTranslations"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string[] AvailableTranslations { get; }

Property Value

String

Implements

ILiveFeedsAvailableTranslations
ILiveFeedsAvailableTranslations
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.ProviderType Property

LiveOddsFeedProviderProviderType Property

Gets the type of the provider.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
The type of the provider.
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.SubscribedEvents Property

LiveOddsFeedProviderSubscribedEvents Property

All match ids for matches were are currently subscribed to.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override long[] SubscribedEvents { get; }

Property Value

Int64

Implements

ILiveFeedsSubscribedEvents
ILiveFeedsSubscribedEvents
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.TestManager Property

LiveOddsFeedProviderTestManager Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.TestManager"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILiveOddsTestManager TestManager { get; }

Property Value

ILiveOddsTestManager

Implements

ILiveOddsTestManager
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider Methods

The LiveOddsFeedProvider type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes |
Public method | GetBetType |
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes |
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Overrides LiveOddsCommonFeedProviderBaseStart)
Public method | Stop | (Overrides LiveOddsCommonFeedProviderBaseStop)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes |
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.GetAllBetTypes Method

LiveOddsFeedProviderGetAllBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.GetAllBetTypes"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetValue[] GetAllBetTypes()

Return Value

BetValue

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.GetAllBetTypes"]

Implements

ILiveOddsGetAllBetTypes
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.GetBetType Method

LiveOddsFeedProviderGetBetType Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.GetBetType(Sportradar.SDK.Common.BetTypeKey)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetValue GetBetType(
    BetTypeKey key
)

Parameters

key BetTypeKey

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.GetBetType(Sportradar.SDK.Common.BetTypeKey)"]

Return Value

BetValue

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.GetBetType(Sportradar.SDK.Common.BetTypeKey)"]

Implements

ILiveOddsGetBetType(BetTypeKey)
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.GetScoreAndCardSummary Method

LiveOddsFeedProviderGetScoreAndCardSummary Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.GetScoreAndCardSummary(System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long GetScoreAndCardSummary(
    long match_id
)

Parameters

match_id Int64

[Missing <param name="match_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.GetScoreAndCardSummary(System.Int64)"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.GetScoreAndCardSummary(System.Int64)"]

Implements

ILiveOddsGetScoreAndCardSummary(Int64)
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.RegisterBetTypes Method

LiveOddsFeedProviderRegisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.RegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void RegisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.RegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType})"]

Implements

ILiveOddsRegisterBetTypes(IEnumerableRegisterUnregisterBetType)
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.Start Method

LiveOddsFeedProviderStart Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.Start"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override void Start()

Implements

IStartableStart
IStartableStart
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.Stop Method

LiveOddsFeedProviderStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.Stop"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override void Stop()

Implements

IStartableStop
IStartableStop
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.UnregisterBetTypes Method

LiveOddsFeedProviderUnregisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.UnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void UnregisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProvider.UnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType})"]

Implements

ILiveOddsUnregisterBetTypes(IEnumerableRegisterUnregisterBetType)
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider Events

The LiveOddsFeedProvider type exposes the following members.

Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received].
Top
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProvider.OnScoreCardSummary Event

LiveOddsFeedProviderOnScoreCardSummary Event

Occurs when [on score card received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<ScoreCardSummaryEventArgs> OnScoreCardSummary

Value

EventHandler ScoreCardSummaryEventArgs

Implements

ILiveOddsOnScoreCardSummary
See Also

Reference

LiveOddsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderBetPal Class

BetPal provider.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderBetPal

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsFeedProviderBetPal : LiveOddsFeedProvider

The LiveOddsFeedProviderBetPal type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedProviderBetPal | Initializes a new instance of the LiveOddsFeedProviderBetPal class
Top
Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations. (Inherited from LiveOddsFeedProvider)
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Inherited from LiveOddsFeedProvider)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsFeedProviderProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Inherited from LiveOddsFeedProvider)
Public property | TestManager | (Inherited from LiveOddsFeedProvider)
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | GetBetType | (Inherited from LiveOddsFeedProvider)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary | (Inherited from LiveOddsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Inherited from LiveOddsFeedProvider)
Public method | Stop | (Inherited from LiveOddsFeedProvider)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received]. (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderBetPal Constructor

Initializes a new instance of the LiveOddsFeedProviderBetPal class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedProviderBetPal(
    IStartable base_sdk,
    IProtocolProvider proto_provider,
    ILiveOddsFeedMonitor feed_monitor,
    LiveOddsEntityFactory entity_factory,
    ILiveOddsTypeProvider live_odds_type_provider,
    ILiveOddsFeedDispatcher feed_dispatcher,
    ILiveOddsRequestProducer request_producer,
    IErrorManager error_manager,
    ITimeKeeper timekeeper,
    ISdkLogger sdk_logger
)

Parameters

base_sdk IStartable

[Missing <param name="base_sdk"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderBetPal.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

proto_provider IProtocolProvider

[Missing <param name="proto_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderBetPal.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderBetPal.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

entity_factory LiveOddsEntityFactory

[Missing <param name="entity_factory"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderBetPal.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

live_odds_type_provider ILiveOddsTypeProvider

[Missing <param name="live_odds_type_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderBetPal.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_dispatcher ILiveOddsFeedDispatcher

[Missing <param name="feed_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderBetPal.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

request_producer ILiveOddsRequestProducer

[Missing <param name="request_producer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderBetPal.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

error_manager IErrorManager

[Missing <param name="error_manager"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderBetPal.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

timekeeper ITimeKeeper

[Missing <param name="timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderBetPal.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderBetPal.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

LiveOddsFeedProviderBetPal Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderBetPal Properties

The LiveOddsFeedProviderBetPal type exposes the following members.

Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations. (Inherited from LiveOddsFeedProvider)
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Inherited from LiveOddsFeedProvider)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsFeedProviderProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Inherited from LiveOddsFeedProvider)
Public property | TestManager | (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderBetPal Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderBetPal.ProviderType Property

LiveOddsFeedProviderBetPalProviderType Property

Gets the type of the provider.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
The type of the provider.
See Also

Reference

LiveOddsFeedProviderBetPal Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderBetPal Methods

The LiveOddsFeedProviderBetPal type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | GetBetType | (Inherited from LiveOddsFeedProvider)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary | (Inherited from LiveOddsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Inherited from LiveOddsFeedProvider)
Public method | Stop | (Inherited from LiveOddsFeedProvider)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsFeedProviderBetPal Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderBetPal Events

The LiveOddsFeedProviderBetPal type exposes the following members.

Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received]. (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderBetPal Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderLivePlex Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderLivePlex"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderLivePlex

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsFeedProviderLivePlex : LiveOddsFeedProvider

The LiveOddsFeedProviderLivePlex type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedProviderLivePlex | Initializes a new instance of the LiveOddsFeedProviderLivePlex class
Top
Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations. (Inherited from LiveOddsFeedProvider)
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Inherited from LiveOddsFeedProvider)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsFeedProviderProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Inherited from LiveOddsFeedProvider)
Public property | TestManager | (Inherited from LiveOddsFeedProvider)
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | GetBetType | (Inherited from LiveOddsFeedProvider)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary | (Inherited from LiveOddsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Inherited from LiveOddsFeedProvider)
Public method | Stop | (Inherited from LiveOddsFeedProvider)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received]. (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderLivePlex Constructor

Initializes a new instance of the LiveOddsFeedProviderLivePlex class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedProviderLivePlex(
    IStartable base_sdk,
    IProtocolProvider proto_provider,
    ILiveOddsFeedMonitor feed_monitor,
    LiveOddsEntityFactory entity_factory,
    ILiveOddsTypeProvider live_odds_type_provider,
    ILiveOddsFeedDispatcher feed_dispatcher,
    ILiveOddsRequestProducer request_producer,
    IErrorManager error_manager,
    ITimeKeeper timekeeper,
    ISdkLogger sdk_logger
)

Parameters

base_sdk IStartable

[Missing <param name="base_sdk"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderLivePlex.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

proto_provider IProtocolProvider

[Missing <param name="proto_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderLivePlex.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderLivePlex.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

entity_factory LiveOddsEntityFactory

[Missing <param name="entity_factory"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderLivePlex.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

live_odds_type_provider ILiveOddsTypeProvider

[Missing <param name="live_odds_type_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderLivePlex.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_dispatcher ILiveOddsFeedDispatcher

[Missing <param name="feed_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderLivePlex.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

request_producer ILiveOddsRequestProducer

[Missing <param name="request_producer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderLivePlex.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

error_manager IErrorManager

[Missing <param name="error_manager"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderLivePlex.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

timekeeper ITimeKeeper

[Missing <param name="timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderLivePlex.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderLivePlex.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

LiveOddsFeedProviderLivePlex Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderLivePlex Properties

The LiveOddsFeedProviderLivePlex type exposes the following members.

Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations. (Inherited from LiveOddsFeedProvider)
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Inherited from LiveOddsFeedProvider)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsFeedProviderProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Inherited from LiveOddsFeedProvider)
Public property | TestManager | (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderLivePlex Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderLivePlex.ProviderType Property

LiveOddsFeedProviderLivePlexProviderType Property

Gets the type of the provider.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
The type of the provider.
See Also

Reference

LiveOddsFeedProviderLivePlex Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderLivePlex Methods

The LiveOddsFeedProviderLivePlex type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | GetBetType | (Inherited from LiveOddsFeedProvider)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary | (Inherited from LiveOddsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Inherited from LiveOddsFeedProvider)
Public method | Stop | (Inherited from LiveOddsFeedProvider)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsFeedProviderLivePlex Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderLivePlex Events

The LiveOddsFeedProviderLivePlex type exposes the following members.

Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received]. (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderLivePlex Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderSoccerRoulette Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderSoccerRoulette"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderSoccerRoulette

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsFeedProviderSoccerRoulette : LiveOddsFeedProvider

The LiveOddsFeedProviderSoccerRoulette type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedProviderSoccerRoulette | Initializes a new instance of the LiveOddsFeedProviderSoccerRoulette class
Top
Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations. (Inherited from LiveOddsFeedProvider)
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Inherited from LiveOddsFeedProvider)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsFeedProviderProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Inherited from LiveOddsFeedProvider)
Public property | TestManager | (Inherited from LiveOddsFeedProvider)
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | GetBetType | (Inherited from LiveOddsFeedProvider)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary | (Inherited from LiveOddsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Inherited from LiveOddsFeedProvider)
Public method | Stop | (Inherited from LiveOddsFeedProvider)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received]. (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderSoccerRoulette Constructor

Initializes a new instance of the LiveOddsFeedProviderSoccerRoulette class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedProviderSoccerRoulette(
    IStartable base_sdk,
    IProtocolProvider proto_provider,
    ILiveOddsFeedMonitor feed_monitor,
    LiveOddsEntityFactory entity_factory,
    ILiveOddsTypeProvider live_odds_type_provider,
    ILiveOddsFeedDispatcher feed_dispatcher,
    ILiveOddsRequestProducer request_producer,
    IErrorManager error_manager,
    ITimeKeeper timekeeper,
    ISdkLogger sdk_logger
)

Parameters

base_sdk IStartable

[Missing <param name="base_sdk"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderSoccerRoulette.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

proto_provider IProtocolProvider

[Missing <param name="proto_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderSoccerRoulette.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderSoccerRoulette.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

entity_factory LiveOddsEntityFactory

[Missing <param name="entity_factory"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderSoccerRoulette.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

live_odds_type_provider ILiveOddsTypeProvider

[Missing <param name="live_odds_type_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderSoccerRoulette.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_dispatcher ILiveOddsFeedDispatcher

[Missing <param name="feed_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderSoccerRoulette.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

request_producer ILiveOddsRequestProducer

[Missing <param name="request_producer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderSoccerRoulette.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

error_manager IErrorManager

[Missing <param name="error_manager"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderSoccerRoulette.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

timekeeper ITimeKeeper

[Missing <param name="timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderSoccerRoulette.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderSoccerRoulette.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

LiveOddsFeedProviderSoccerRoulette Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderSoccerRoulette Properties

The LiveOddsFeedProviderSoccerRoulette type exposes the following members.

Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations. (Inherited from LiveOddsFeedProvider)
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Inherited from LiveOddsFeedProvider)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsFeedProviderProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Inherited from LiveOddsFeedProvider)
Public property | TestManager | (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderSoccerRoulette Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderSoccerRoulette.ProviderType Property

LiveOddsFeedProviderSoccerRouletteProviderType Property

Gets the type of the provider.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
The type of the provider.
See Also

Reference

LiveOddsFeedProviderSoccerRoulette Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderSoccerRoulette Methods

The LiveOddsFeedProviderSoccerRoulette type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | GetBetType | (Inherited from LiveOddsFeedProvider)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary | (Inherited from LiveOddsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Inherited from LiveOddsFeedProvider)
Public method | Stop | (Inherited from LiveOddsFeedProvider)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsFeedProviderSoccerRoulette Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderSoccerRoulette Events

The LiveOddsFeedProviderSoccerRoulette type exposes the following members.

Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received]. (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderSoccerRoulette Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVbl Class

Virtual basketball league LiveOdds provider.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderVbl

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsFeedProviderVbl : LiveOddsFeedProvider

The LiveOddsFeedProviderVbl type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedProviderVbl | Initializes a new instance of the LiveOddsFeedProviderVbl class
Top
Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations. (Inherited from LiveOddsFeedProvider)
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Inherited from LiveOddsFeedProvider)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsFeedProviderProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Inherited from LiveOddsFeedProvider)
Public property | TestManager | (Inherited from LiveOddsFeedProvider)
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | GetBetType | (Inherited from LiveOddsFeedProvider)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary | (Inherited from LiveOddsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Inherited from LiveOddsFeedProvider)
Public method | Stop | (Inherited from LiveOddsFeedProvider)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received]. (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVbl Constructor

Initializes a new instance of the LiveOddsFeedProviderVbl class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedProviderVbl(
    IStartable base_sdk,
    IProtocolProvider proto_provider,
    ILiveOddsFeedMonitor feed_monitor,
    LiveOddsEntityFactory entity_factory,
    ILiveOddsTypeProvider live_odds_type_provider,
    ILiveOddsFeedDispatcher feed_dispatcher,
    ILiveOddsRequestProducer request_producer,
    IErrorManager error_manager,
    ITimeKeeper timekeeper,
    ISdkLogger sdk_logger
)

Parameters

base_sdk IStartable

[Missing <param name="base_sdk"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVbl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

proto_provider IProtocolProvider

[Missing <param name="proto_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVbl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVbl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

entity_factory LiveOddsEntityFactory

[Missing <param name="entity_factory"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVbl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

live_odds_type_provider ILiveOddsTypeProvider

[Missing <param name="live_odds_type_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVbl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_dispatcher ILiveOddsFeedDispatcher

[Missing <param name="feed_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVbl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

request_producer ILiveOddsRequestProducer

[Missing <param name="request_producer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVbl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

error_manager IErrorManager

[Missing <param name="error_manager"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVbl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

timekeeper ITimeKeeper

[Missing <param name="timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVbl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVbl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

LiveOddsFeedProviderVbl Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVbl Properties

The LiveOddsFeedProviderVbl type exposes the following members.

Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations. (Inherited from LiveOddsFeedProvider)
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Inherited from LiveOddsFeedProvider)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsFeedProviderProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Inherited from LiveOddsFeedProvider)
Public property | TestManager | (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderVbl Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVbl.ProviderType Property

LiveOddsFeedProviderVblProviderType Property

Gets the type of the provider.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
The type of the provider.
See Also

Reference

LiveOddsFeedProviderVbl Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVbl Methods

The LiveOddsFeedProviderVbl type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | GetBetType | (Inherited from LiveOddsFeedProvider)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary | (Inherited from LiveOddsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Inherited from LiveOddsFeedProvider)
Public method | Stop | (Inherited from LiveOddsFeedProvider)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsFeedProviderVbl Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVbl Events

The LiveOddsFeedProviderVbl type exposes the following members.

Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received]. (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderVbl Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVdr Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVdr"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsRaceFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderVdr

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsFeedProviderVdr : LiveOddsRaceFeedProvider

The LiveOddsFeedProviderVdr type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedProviderVdr | Initializes a new instance of the LiveOddsFeedProviderVdr class
Top
Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | (Overrides LiveOddsCommonFeedProviderBaseProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | (Inherited from LiveOddsRaceFeedProvider)
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRacedayMetaInfo | (Inherited from LiveOddsRaceFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsRaceFeedProvider)
Public method | Start | Start component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Stop | Stop / shutdown component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnRaceResult | Occurs when [on race result received]. (Inherited from LiveOddsRaceFeedProvider)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVdr Constructor

Initializes a new instance of the LiveOddsFeedProviderVdr class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedProviderVdr(
    IStartable mSdk,
    IProtocolProvider mProtoProvider,
    VdrEntityFactory entity_factory,
    ILiveOddsFeedMonitor feed_monitor,
    ILiveOddsFeedDispatcher mFeedDispatcher,
    ILiveOddsRequestProducer mRequestProducer,
    IErrorManager error_manager,
    ITimeKeeper timekeeper,
    ISdkLogger mSdkLogger
)

Parameters

mSdk IStartable

[Missing <param name="mSdk"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVdr.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

mProtoProvider IProtocolProvider

[Missing <param name="mProtoProvider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVdr.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

entity_factory VdrEntityFactory

[Missing <param name="entity_factory"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVdr.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVdr.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

mFeedDispatcher ILiveOddsFeedDispatcher

[Missing <param name="mFeedDispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVdr.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

mRequestProducer ILiveOddsRequestProducer

[Missing <param name="mRequestProducer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVdr.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

error_manager IErrorManager

[Missing <param name="error_manager"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVdr.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

timekeeper ITimeKeeper

[Missing <param name="timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVdr.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

mSdkLogger ISdkLogger

[Missing <param name="mSdkLogger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVdr.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

LiveOddsFeedProviderVdr Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVdr Properties

The LiveOddsFeedProviderVdr type exposes the following members.

Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | (Overrides LiveOddsCommonFeedProviderBaseProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | (Inherited from LiveOddsRaceFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderVdr Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVdr.ProviderType Property

LiveOddsFeedProviderVdrProviderType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVdr.ProviderType"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
See Also

Reference

LiveOddsFeedProviderVdr Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVdr Methods

The LiveOddsFeedProviderVdr type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRacedayMetaInfo | (Inherited from LiveOddsRaceFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsRaceFeedProvider)
Public method | Start | Start component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Stop | Stop / shutdown component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsFeedProviderVdr Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVdr Events

The LiveOddsFeedProviderVdr type exposes the following members.

Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnRaceResult | Occurs when [on race result received]. (Inherited from LiveOddsRaceFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderVdr Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVfl Class

Virtual football league LiveOdds provider.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderVfl

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsFeedProviderVfl : LiveOddsFeedProvider

The LiveOddsFeedProviderVfl type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedProviderVfl | Initializes a new instance of the LiveOddsFeedProviderVfl class
Top
Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations. (Inherited from LiveOddsFeedProvider)
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Inherited from LiveOddsFeedProvider)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsFeedProviderProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Inherited from LiveOddsFeedProvider)
Public property | TestManager | (Inherited from LiveOddsFeedProvider)
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | GetBetType | (Inherited from LiveOddsFeedProvider)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary | (Inherited from LiveOddsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Inherited from LiveOddsFeedProvider)
Public method | Stop | (Inherited from LiveOddsFeedProvider)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received]. (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVfl Constructor

Initializes a new instance of the LiveOddsFeedProviderVfl class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedProviderVfl(
    IStartable base_sdk,
    IProtocolProvider proto_provider,
    ILiveOddsFeedMonitor feed_monitor,
    LiveOddsEntityFactory entity_factory,
    ILiveOddsTypeProvider live_odds_type_provider,
    ILiveOddsFeedDispatcher feed_dispatcher,
    ILiveOddsRequestProducer request_producer,
    IErrorManager error_manager,
    ITimeKeeper timekeeper,
    ISdkLogger sdk_logger
)

Parameters

base_sdk IStartable

[Missing <param name="base_sdk"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVfl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

proto_provider IProtocolProvider

[Missing <param name="proto_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVfl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVfl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

entity_factory LiveOddsEntityFactory

[Missing <param name="entity_factory"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVfl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

live_odds_type_provider ILiveOddsTypeProvider

[Missing <param name="live_odds_type_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVfl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_dispatcher ILiveOddsFeedDispatcher

[Missing <param name="feed_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVfl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

request_producer ILiveOddsRequestProducer

[Missing <param name="request_producer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVfl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

error_manager IErrorManager

[Missing <param name="error_manager"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVfl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

timekeeper ITimeKeeper

[Missing <param name="timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVfl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVfl.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

LiveOddsFeedProviderVfl Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVfl Properties

The LiveOddsFeedProviderVfl type exposes the following members.

Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations. (Inherited from LiveOddsFeedProvider)
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Inherited from LiveOddsFeedProvider)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsFeedProviderProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Inherited from LiveOddsFeedProvider)
Public property | TestManager | (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderVfl Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVfl.ProviderType Property

LiveOddsFeedProviderVflProviderType Property

Gets the type of the provider.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
The type of the provider.
See Also

Reference

LiveOddsFeedProviderVfl Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVfl Methods

The LiveOddsFeedProviderVfl type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | GetBetType | (Inherited from LiveOddsFeedProvider)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary | (Inherited from LiveOddsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Inherited from LiveOddsFeedProvider)
Public method | Stop | (Inherited from LiveOddsFeedProvider)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsFeedProviderVfl Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVfl Events

The LiveOddsFeedProviderVfl type exposes the following members.

Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received]. (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderVfl Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVhc Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVhc"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsRaceFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderVhc

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsFeedProviderVhc : LiveOddsRaceFeedProvider

The LiveOddsFeedProviderVhc type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedProviderVhc | Initializes a new instance of the LiveOddsFeedProviderVhc class
Top
Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | (Overrides LiveOddsCommonFeedProviderBaseProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | (Inherited from LiveOddsRaceFeedProvider)
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRacedayMetaInfo | (Inherited from LiveOddsRaceFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsRaceFeedProvider)
Public method | Start | Start component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Stop | Stop / shutdown component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnRaceResult | Occurs when [on race result received]. (Inherited from LiveOddsRaceFeedProvider)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVhc Constructor

Initializes a new instance of the LiveOddsFeedProviderVhc class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedProviderVhc(
    IStartable mSdk,
    IProtocolProvider mProtoProvider,
    VhcEntityFactory entity_factory,
    ILiveOddsFeedMonitor feed_monitor,
    ILiveOddsFeedDispatcher mFeedDispatcher,
    ILiveOddsRequestProducer mRequestProducer,
    IErrorManager error_manager,
    ITimeKeeper timekeeper,
    ISdkLogger mSdkLogger
)

Parameters

mSdk IStartable

[Missing <param name="mSdk"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVhc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

mProtoProvider IProtocolProvider

[Missing <param name="mProtoProvider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVhc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

entity_factory VhcEntityFactory

[Missing <param name="entity_factory"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVhc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVhc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

mFeedDispatcher ILiveOddsFeedDispatcher

[Missing <param name="mFeedDispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVhc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

mRequestProducer ILiveOddsRequestProducer

[Missing <param name="mRequestProducer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVhc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

error_manager IErrorManager

[Missing <param name="error_manager"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVhc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

timekeeper ITimeKeeper

[Missing <param name="timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVhc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

mSdkLogger ISdkLogger

[Missing <param name="mSdkLogger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVhc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

LiveOddsFeedProviderVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVhc Properties

The LiveOddsFeedProviderVhc type exposes the following members.

Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | (Overrides LiveOddsCommonFeedProviderBaseProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | (Inherited from LiveOddsRaceFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVhc.ProviderType Property

LiveOddsFeedProviderVhcProviderType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVhc.ProviderType"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
See Also

Reference

LiveOddsFeedProviderVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVhc Methods

The LiveOddsFeedProviderVhc type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRacedayMetaInfo | (Inherited from LiveOddsRaceFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsRaceFeedProvider)
Public method | Start | Start component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Stop | Stop / shutdown component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsFeedProviderVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVhc Events

The LiveOddsFeedProviderVhc type exposes the following members.

Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnRaceResult | Occurs when [on race result received]. (Inherited from LiveOddsRaceFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVto Class

BetPal provider.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderVto

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsFeedProviderVto : LiveOddsFeedProvider

The LiveOddsFeedProviderVto type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedProviderVto | Initializes a new instance of the LiveOddsFeedProviderVto class
Top
Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations. (Inherited from LiveOddsFeedProvider)
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Inherited from LiveOddsFeedProvider)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsFeedProviderProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Inherited from LiveOddsFeedProvider)
Public property | TestManager | (Inherited from LiveOddsFeedProvider)
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | GetBetType | (Inherited from LiveOddsFeedProvider)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary | (Inherited from LiveOddsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Inherited from LiveOddsFeedProvider)
Public method | Stop | (Inherited from LiveOddsFeedProvider)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received]. (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVto Constructor

Initializes a new instance of the LiveOddsFeedProviderVto class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedProviderVto(
    IStartable base_sdk,
    IProtocolProvider proto_provider,
    ILiveOddsFeedMonitor feed_monitor,
    LiveOddsEntityFactory entity_factory,
    ILiveOddsTypeProvider live_odds_type_provider,
    ILiveOddsFeedDispatcher feed_dispatcher,
    ILiveOddsRequestProducer request_producer,
    IErrorManager error_manager,
    ITimeKeeper timekeeper,
    ISdkLogger sdk_logger
)

Parameters

base_sdk IStartable

[Missing <param name="base_sdk"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVto.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

proto_provider IProtocolProvider

[Missing <param name="proto_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVto.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVto.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

entity_factory LiveOddsEntityFactory

[Missing <param name="entity_factory"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVto.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

live_odds_type_provider ILiveOddsTypeProvider

[Missing <param name="live_odds_type_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVto.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_dispatcher ILiveOddsFeedDispatcher

[Missing <param name="feed_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVto.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

request_producer ILiveOddsRequestProducer

[Missing <param name="request_producer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVto.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

error_manager IErrorManager

[Missing <param name="error_manager"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVto.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

timekeeper ITimeKeeper

[Missing <param name="timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVto.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedProviderVto.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsEntityFactory,Sportradar.SDK.Common.Interfaces.ILiveOddsTypeProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

LiveOddsFeedProviderVto Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVto Properties

The LiveOddsFeedProviderVto type exposes the following members.

Properties
 | Name | Description
Public property | AvailableBetTypeTranslations | Gets the available bet type translations. (Inherited from LiveOddsFeedProvider)
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | (Inherited from LiveOddsFeedProvider)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsFeedProviderProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | All match ids for matches were are currently subscribed to. (Inherited from LiveOddsFeedProvider)
Public property | TestManager | (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderVto Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVto.ProviderType Property

LiveOddsFeedProviderVtoProviderType Property

Gets the type of the provider.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
The type of the provider.
See Also

Reference

LiveOddsFeedProviderVto Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVto Methods

The LiveOddsFeedProviderVto type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | GetBetType | (Inherited from LiveOddsFeedProvider)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetScoreAndCardSummary | (Inherited from LiveOddsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | (Inherited from LiveOddsFeedProvider)
Public method | Stop | (Inherited from LiveOddsFeedProvider)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnregisterBetTypes | (Inherited from LiveOddsFeedProvider)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsFeedProviderVto Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedProviderVto Events

The LiveOddsFeedProviderVto type exposes the following members.

Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnScoreCardSummary | Occurs when [on score card received]. (Inherited from LiveOddsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderVto Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedStatusDelegates

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class LiveOddsFeedStatusDelegates
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.InterceptionOutcome Class

LiveOddsFeedStatusDelegatesInterceptionOutcome Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedStatusDelegatesInterceptionOutcome

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class InterceptionOutcome

The LiveOddsFeedStatusDelegatesInterceptionOutcome type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedStatusDelegatesInterceptionOutcome | Initializes a new instance of the LiveOddsFeedStatusDelegatesInterceptionOutcome class
Top
Properties
 | Name | Description
Public property | Outcome |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.InterceptionOutcome Constructor

LiveOddsFeedStatusDelegatesInterceptionOutcome Constructor

Initializes a new instance of the LiveOddsFeedStatusDelegatesInterceptionOutcome class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public InterceptionOutcome()
See Also

Reference

LiveOddsFeedStatusDelegatesInterceptionOutcome Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


InterceptionOutcome Properties

The LiveOddsFeedStatusDelegatesInterceptionOutcome type exposes the following members.

Properties
 | Name | Description
Public property | Outcome |
Top
See Also

Reference

LiveOddsFeedStatusDelegatesInterceptionOutcome Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.InterceptionOutcome.Outcome Property

LiveOddsFeedStatusDelegatesInterceptionOutcomeOutcome Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome.Outcome"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus Outcome { get; set; }

Property Value

LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus
See Also

Reference

LiveOddsFeedStatusDelegatesInterceptionOutcome Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


InterceptionOutcome Methods

The LiveOddsFeedStatusDelegatesInterceptionOutcome type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsFeedStatusDelegatesInterceptionOutcome Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.InterceptionOutcomeStatus Class

LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcomeStatus"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedStatusDelegatesInterceptionOutcomeStatus

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class InterceptionOutcomeStatus : Enum

The LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | CONSUMED |
 | CONTINUE |
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


InterceptionOutcomeStatus Methods

The LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


InterceptionOutcomeStatus Fields

The LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus type exposes the following members.

Fields
 | Name | Description
 | CONSUMED |
 | CONTINUE |
Public field | value__ |
Top
See Also

Reference

LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.InterceptionOutcomeStatus.CONSUMED Field

LiveOddsFeedStatusDelegatesInterceptionOutcomeStatusCONSUMED Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcomeStatus.CONSUMED"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus CONSUMED = 0

Field Value

LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus
See Also

Reference

LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.InterceptionOutcomeStatus.CONTINUE Field

LiveOddsFeedStatusDelegatesInterceptionOutcomeStatusCONTINUE Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcomeStatus.CONTINUE"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus CONTINUE = 1

Field Value

LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus
See Also

Reference

LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.InterceptionOutcomeStatus.value__ Field

LiveOddsFeedStatusDelegatesInterceptionOutcomeStatusvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcomeStatus.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

LiveOddsFeedStatusDelegatesInterceptionOutcomeStatus Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate Class

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class MessageDispatchedInterceptorDelegate : MulticastDelegate

The LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate | Initializes a new instance of the LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate Constructor

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate Constructor

Initializes a new instance of the LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MessageDispatchedInterceptorDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MessageDispatchedInterceptorDelegate Properties

The LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MessageDispatchedInterceptorDelegate Methods

The LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.BeginInvoke Method

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.BeginInvoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    OddsEntityBase entity,
    DispatchStatus status,
    AsyncCallback callback,
    Object object
)

Parameters

entity OddsEntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.BeginInvoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus,System.AsyncCallback,System.Object)"]

status DispatchStatus

[Missing <param name="status"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.BeginInvoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.BeginInvoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.BeginInvoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.BeginInvoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus,System.AsyncCallback,System.Object)"]

See Also

Reference

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.EndInvoke Method

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.Invoke Method

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.Invoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    OddsEntityBase entity,
    DispatchStatus status
)

Parameters

entity OddsEntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.Invoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus)"]

status DispatchStatus

[Missing <param name="status"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageDispatchedInterceptorDelegate.Invoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.Common.Interfaces.DispatchStatus)"]

See Also

Reference

LiveOddsFeedStatusDelegatesMessageDispatchedInterceptorDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate Class

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class MessageReceivedInterceptorDelegate : MulticastDelegate

The LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate | Initializes a new instance of the LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate Constructor

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate Constructor

Initializes a new instance of the LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MessageReceivedInterceptorDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MessageReceivedInterceptorDelegate Properties

The LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MessageReceivedInterceptorDelegate Methods

The LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.BeginInvoke Method

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.BeginInvoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    OddsEntityBase entity,
    LiveOddsFeedStatusDelegatesInterceptionOutcome outcome,
    AsyncCallback callback,
    Object object
)

Parameters

entity OddsEntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.BeginInvoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome,System.AsyncCallback,System.Object)"]

outcome LiveOddsFeedStatusDelegatesInterceptionOutcome

[Missing <param name="outcome"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.BeginInvoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.BeginInvoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.BeginInvoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.BeginInvoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome,System.AsyncCallback,System.Object)"]

See Also

Reference

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.EndInvoke Method

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.Invoke Method

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.Invoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    OddsEntityBase entity,
    LiveOddsFeedStatusDelegatesInterceptionOutcome outcome
)

Parameters

entity OddsEntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.Invoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome)"]

outcome LiveOddsFeedStatusDelegatesInterceptionOutcome

[Missing <param name="outcome"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.MessageReceivedInterceptorDelegate.Invoke(Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsEntityBase,Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsFeedStatusDelegates.InterceptionOutcome)"]

See Also

Reference

LiveOddsFeedStatusDelegatesMessageReceivedInterceptorDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRaceFeedProvider Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsRaceFeedProvider
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderVdr
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedProviderVhc

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public abstract class LiveOddsRaceFeedProvider : LiveOddsCommonFeedProvider,
    ILiveOddsRace, ILiveOddsCommon, ILiveOddsCommonBase, ILiveFeeds, IStartable

The LiveOddsRaceFeedProvider type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsRaceFeedProvider | Initializes a new instance of the LiveOddsRaceFeedProvider class
Top
Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | (Overrides LiveOddsCommonFeedProviderBaseSubscribedEvents)
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRacedayMetaInfo |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterMessageDispatcher |
Public method | Start | Start component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Stop | Stop / shutdown component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnRaceResult | Occurs when [on race result received].
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRaceFeedProvider Constructor

Initializes a new instance of the LiveOddsRaceFeedProvider class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsRaceFeedProvider(
    IStartable mSdk,
    IProtocolProvider mProtoProvider,
    ILiveOddsFeedMonitor feed_monitor,
    ILiveOddsFeedDispatcher mFeedDispatcher,
    ILiveOddsRequestProducer mRequestProducer,
    IErrorManager error_manager,
    ITimeKeeper timekeeper,
    ISdkLogger mSdkLogger
)

Parameters

mSdk IStartable

[Missing <param name="mSdk"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

mProtoProvider IProtocolProvider

[Missing <param name="mProtoProvider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

mFeedDispatcher ILiveOddsFeedDispatcher

[Missing <param name="mFeedDispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

mRequestProducer ILiveOddsRequestProducer

[Missing <param name="mRequestProducer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

error_manager IErrorManager

[Missing <param name="error_manager"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

timekeeper ITimeKeeper

[Missing <param name="timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

mSdkLogger ISdkLogger

[Missing <param name="mSdkLogger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

LiveOddsRaceFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRaceFeedProvider Properties

The LiveOddsRaceFeedProvider type exposes the following members.

Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | (Overrides LiveOddsCommonFeedProviderBaseSubscribedEvents)
Top
See Also

Reference

LiveOddsRaceFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRaceFeedProvider.SubscribedEvents Property

LiveOddsRaceFeedProviderSubscribedEvents Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.SubscribedEvents"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override long[] SubscribedEvents { get; }

Property Value

Int64

Implements

ILiveFeedsSubscribedEvents
ILiveFeedsSubscribedEvents
See Also

Reference

LiveOddsRaceFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRaceFeedProvider Methods

The LiveOddsRaceFeedProvider type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRacedayMetaInfo |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterMessageDispatcher |
Public method | Start | Start component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Stop | Stop / shutdown component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsRaceFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRaceFeedProvider.GetRacedayMetaInfo Method

LiveOddsRaceFeedProviderGetRacedayMetaInfo Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.GetRacedayMetaInfo(System.Collections.Generic.IEnumerable{System.Int32})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long GetRacedayMetaInfo(
    IEnumerable<int> racedays
)

Parameters

racedays IEnumerable Int32

[Missing <param name="racedays"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.GetRacedayMetaInfo(System.Collections.Generic.IEnumerable{System.Int32})"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.GetRacedayMetaInfo(System.Collections.Generic.IEnumerable{System.Int32})"]

Implements

ILiveOddsRaceGetRacedayMetaInfo(IEnumerableInt32)
See Also

Reference

LiveOddsRaceFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRaceFeedProvider.RegisterMessageDispatcher Method

LiveOddsRaceFeedProviderRegisterMessageDispatcher Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.RegisterMessageDispatcher(Sportradar.SDK.Common.Interfaces.IMessageDispatcher)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void RegisterMessageDispatcher(
    IMessageDispatcher msg_dispatcher
)

Parameters

msg_dispatcher IMessageDispatcher

[Missing <param name="msg_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRaceFeedProvider.RegisterMessageDispatcher(Sportradar.SDK.Common.Interfaces.IMessageDispatcher)"]

See Also

Reference

LiveOddsRaceFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRaceFeedProvider Events

The LiveOddsRaceFeedProvider type exposes the following members.

Events
 | Name | Description
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsCommonFeedProvider)
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnRaceResult | Occurs when [on race result received].
Top
See Also

Reference

LiveOddsRaceFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRaceFeedProvider.OnRaceResult Event

LiveOddsRaceFeedProviderOnRaceResult Event

Occurs when [on race result received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<RaceResultEventArgs> OnRaceResult

Value

EventHandler RaceResultEventArgs

Implements

ILiveOddsRaceOnRaceResult
See Also

Reference

LiveOddsRaceFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsRequestProducer

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsRequestProducer : ILiveOddsRequestProducer

The LiveOddsRequestProducer type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsRequestProducer | Initializes a new instance of the LiveOddsRequestProducer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FillRequest |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PrepareBook |
Public method | PrepareGetEventList |
Public method | PrepareGetEventMessages |
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetScoreAndCardSummary |
Public method | PrepareRacedayMetaRequest |
Public method | PrepareRegisterBetTypes |
Public method | PrepareRegisterUnregisterBetTypes |
Public method | PrepareSubscribe |
Public method | PrepareUnregisterBetTypes |
Public method | PrepareUnsubscribe |
Public method | SendCurrentRequest |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | OnRequestAdded |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer Constructor

Initializes a new instance of the LiveOddsRequestProducer class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsRequestProducer(
    ISdkLogger sdk_logger,
    IProtocolProvider proto_provider,
    SdkConfigurationLiveOdds local_config
)

Parameters

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

proto_provider IProtocolProvider

[Missing <param name="proto_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

local_config SdkConfigurationLiveOdds

[Missing <param name="local_config"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer Methods

The LiveOddsRequestProducer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FillRequest |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PrepareBook |
Public method | PrepareGetEventList |
Public method | PrepareGetEventMessages |
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetScoreAndCardSummary |
Public method | PrepareRacedayMetaRequest |
Public method | PrepareRegisterBetTypes |
Public method | PrepareRegisterUnregisterBetTypes |
Public method | PrepareSubscribe |
Public method | PrepareUnregisterBetTypes |
Public method | PrepareUnsubscribe |
Public method | SendCurrentRequest |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.FillRequest Method

LiveOddsRequestProducerFillRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.FillRequest(Sportradar.SDK.Common.Interfaces.IProtocolRequest,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationResult FillRequest(
    IProtocolRequest req,
    PreparationRequest prep
)

Parameters

req IProtocolRequest

[Missing <param name="req"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.FillRequest(Sportradar.SDK.Common.Interfaces.IProtocolRequest,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.FillRequest(Sportradar.SDK.Common.Interfaces.IProtocolRequest,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.FillRequest(Sportradar.SDK.Common.Interfaces.IProtocolRequest,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareBook Method

LiveOddsRequestProducerPrepareBook Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareBook(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareBook(IEnumerableInt64, PreparationRequest)
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareGetEventList Method

LiveOddsRequestProducerPrepareGetEventList Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventList(
    DateTime? from,
    DateTime? to,
    PreparationRequest prep,
    IEnumerable<long> event_ids = null,
    bool? include_available = null
)

Parameters

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

to Nullable DateTime

[Missing <param name="to"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

event_ids IEnumerable Int64 (Optional)

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

include_available Nullable Boolean (Optional)

[Missing <param name="include_available"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Implements

ILiveOddsRequestProducerPrepareGetEventList(NullableDateTime, NullableDateTime, PreparationRequest, IEnumerableInt64, NullableBoolean)
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareGetEventMessages Method

LiveOddsRequestProducerPrepareGetEventMessages Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventMessages(
    long event_id,
    long? from,
    long? to,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable Int64

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

to Nullable Int64

[Missing <param name="to"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsRequestProducerPrepareGetEventMessages(Int64, NullableInt64, NullableInt64, PreparationRequest, Boolean)
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareGetEventStatus Method

LiveOddsRequestProducerPrepareGetEventStatus Method

Overload List
 | Name | Description
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Top
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareGetEventStatus(IEnumerable<Int64>, Nullable<DateTime>, PreparationRequest, Boolean) Method

LiveOddsRequestProducerPrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationResult PrepareGetEventStatus(
    IEnumerable<long> event_ids,
    DateTime? from,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsRequestProducerPrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean)
See Also

Reference

LiveOddsRequestProducer Class
PrepareGetEventStatus Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareGetEventStatus(Int64, Nullable<DateTime>, PreparationRequest, Boolean) Method

LiveOddsRequestProducerPrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventStatus(
    long event_id,
    DateTime? from,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsRequestProducerPrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean)
See Also

Reference

LiveOddsRequestProducer Class
PrepareGetEventStatus Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareGetScoreAndCardSummary Method

LiveOddsRequestProducerPrepareGetScoreAndCardSummary Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetScoreAndCardSummary(
    long event_id,
    PreparationRequest prep
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareGetScoreAndCardSummary(Int64, PreparationRequest)
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareRacedayMetaRequest Method

LiveOddsRequestProducerPrepareRacedayMetaRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationResult PrepareRacedayMetaRequest(
    IEnumerable<int> racedays,
    PreparationRequest prep
)

Parameters

racedays IEnumerable Int32

[Missing <param name="racedays"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareRacedayMetaRequest(IEnumerableInt32, PreparationRequest)
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareRegisterBetTypes Method

LiveOddsRequestProducerPrepareRegisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareRegisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes,
    PreparationRequest prep
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareRegisterBetTypes(IEnumerableRegisterUnregisterBetType, PreparationRequest)
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareRegisterUnregisterBetTypes Method

LiveOddsRequestProducerPrepareRegisterUnregisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRegisterUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Outgoing.BookmakerStatusType,System.String,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareRegisterUnregisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes,
    BookmakerStatusType type,
    string name,
    PreparationRequest prep
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRegisterUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Outgoing.BookmakerStatusType,System.String,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

type BookmakerStatusType

[Missing <param name="type"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRegisterUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Outgoing.BookmakerStatusType,System.String,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

name String

[Missing <param name="name"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRegisterUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Outgoing.BookmakerStatusType,System.String,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRegisterUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Outgoing.BookmakerStatusType,System.String,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareRegisterUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.ProtocolProviders.ProtocolUnits.LiveOdds.Outgoing.BookmakerStatusType,System.String,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareSubscribe Method

LiveOddsRequestProducerPrepareSubscribe Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareSubscribe(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareSubscribe(IEnumerableInt64, PreparationRequest)
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareUnregisterBetTypes Method

LiveOddsRequestProducerPrepareUnregisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareUnregisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes,
    PreparationRequest prep
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareUnregisterBetTypes(IEnumerableRegisterUnregisterBetType, PreparationRequest)
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.PrepareUnsubscribe Method

LiveOddsRequestProducerPrepareUnsubscribe Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareUnsubscribe(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareUnsubscribe(IEnumerableInt64, PreparationRequest)
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.SendCurrentRequest Method

LiveOddsRequestProducerSendCurrentRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual long SendCurrentRequest(
    long? virtual_game_id,
    IEnumerable<long> event_ids
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Implements

ILiveOddsRequestProducerSendCurrentRequest(NullableInt64, IEnumerableInt64)
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer Events

The LiveOddsRequestProducer type exposes the following members.

Events
 | Name | Description
Public event | OnRequestAdded |
Top
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsRequestProducer.OnRequestAdded Event

LiveOddsRequestProducerOnRequestAdded Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsRequestProducer.OnRequestAdded"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event RequestProducerDelegatesRequestDelegate OnRequestAdded

Value

RequestProducerDelegatesRequestDelegate

Implements

ILiveOddsRequestProducerOnRequestAdded
See Also

Reference

LiveOddsRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsTestManager Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsTestManager

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsTestManager : ILiveOddsTestManager

The LiveOddsTestManager type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsTestManager | Initializes a new instance of the LiveOddsTestManager class
Top
Methods
 | Name | Description
Public method | ChangeXmlConfig |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ResetXmlConfig |
Public method | StartAuto |
Public method | StartMatchReplay |
Public method | StartScenario |
Public method | StopAll |
Public method | StopAuto |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsTestManager Constructor

Initializes a new instance of the LiveOddsTestManager class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsTestManager(
    IProtocolProvider protocol_provider
)

Parameters

protocol_provider IProtocolProvider

[Missing <param name="protocol_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.#ctor(Sportradar.SDK.ProtocolProviders.IProtocolProvider)"]

See Also

Reference

LiveOddsTestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsTestManager Methods

The LiveOddsTestManager type exposes the following members.

Methods
 | Name | Description
Public method | ChangeXmlConfig |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ResetXmlConfig |
Public method | StartAuto |
Public method | StartMatchReplay |
Public method | StartScenario |
Public method | StopAll |
Public method | StopAuto |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsTestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsTestManager.ChangeXmlConfig Method

LiveOddsTestManagerChangeXmlConfig Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.ChangeXmlConfig(System.Int32,System.Boolean,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void ChangeXmlConfig(
    int config_id,
    bool enable,
    bool reset = false
)

Parameters

config_id Int32

[Missing <param name="config_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.ChangeXmlConfig(System.Int32,System.Boolean,System.Boolean)"]

enable Boolean

[Missing <param name="enable"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.ChangeXmlConfig(System.Int32,System.Boolean,System.Boolean)"]

reset Boolean (Optional)

[Missing <param name="reset"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.ChangeXmlConfig(System.Int32,System.Boolean,System.Boolean)"]

Implements

ILiveOddsTestManagerChangeXmlConfig(Int32, Boolean, Boolean)
See Also

Reference

LiveOddsTestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsTestManager.ResetXmlConfig Method

LiveOddsTestManagerResetXmlConfig Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.ResetXmlConfig"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void ResetXmlConfig()

Implements

ILiveOddsTestManagerResetXmlConfig
See Also

Reference

LiveOddsTestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsTestManager.StartAuto Method

LiveOddsTestManagerStartAuto Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StartAuto"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void StartAuto()

Implements

ILiveOddsTestManagerStartAuto
See Also

Reference

LiveOddsTestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsTestManager.StartMatchReplay Method

LiveOddsTestManagerStartMatchReplay Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StartMatchReplay(System.Int64,System.Nullable{System.Int64},System.Nullable{System.TimeSpan},System.Nullable{System.Int32},System.Nullable{System.Boolean})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void StartMatchReplay(
    long match_id,
    long? msgn_nr,
    TimeSpan? fast_forward,
    int? speed = null,
    bool? persistent = null
)

Parameters

match_id Int64

[Missing <param name="match_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StartMatchReplay(System.Int64,System.Nullable{System.Int64},System.Nullable{System.TimeSpan},System.Nullable{System.Int32},System.Nullable{System.Boolean})"]

msgn_nr Nullable Int64

[Missing <param name="msgn_nr"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StartMatchReplay(System.Int64,System.Nullable{System.Int64},System.Nullable{System.TimeSpan},System.Nullable{System.Int32},System.Nullable{System.Boolean})"]

fast_forward Nullable TimeSpan

[Missing <param name="fast_forward"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StartMatchReplay(System.Int64,System.Nullable{System.Int64},System.Nullable{System.TimeSpan},System.Nullable{System.Int32},System.Nullable{System.Boolean})"]

speed Nullable Int32 (Optional)

[Missing <param name="speed"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StartMatchReplay(System.Int64,System.Nullable{System.Int64},System.Nullable{System.TimeSpan},System.Nullable{System.Int32},System.Nullable{System.Boolean})"]

persistent Nullable Boolean (Optional)

[Missing <param name="persistent"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StartMatchReplay(System.Int64,System.Nullable{System.Int64},System.Nullable{System.TimeSpan},System.Nullable{System.Int32},System.Nullable{System.Boolean})"]

Implements

ILiveOddsTestManagerStartMatchReplay(Int64, NullableInt64, NullableTimeSpan, NullableInt32, NullableBoolean)
See Also

Reference

LiveOddsTestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsTestManager.StartScenario Method

LiveOddsTestManagerStartScenario Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StartScenario(System.Int32,System.Nullable{System.TimeSpan},System.Nullable{System.Int32},System.Nullable{System.Boolean})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void StartScenario(
    int scenario_number,
    TimeSpan? fast_forward,
    int? speed = null,
    bool? persistent = null
)

Parameters

scenario_number Int32

[Missing <param name="scenario_number"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StartScenario(System.Int32,System.Nullable{System.TimeSpan},System.Nullable{System.Int32},System.Nullable{System.Boolean})"]

fast_forward Nullable TimeSpan

[Missing <param name="fast_forward"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StartScenario(System.Int32,System.Nullable{System.TimeSpan},System.Nullable{System.Int32},System.Nullable{System.Boolean})"]

speed Nullable Int32 (Optional)

[Missing <param name="speed"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StartScenario(System.Int32,System.Nullable{System.TimeSpan},System.Nullable{System.Int32},System.Nullable{System.Boolean})"]

persistent Nullable Boolean (Optional)

[Missing <param name="persistent"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StartScenario(System.Int32,System.Nullable{System.TimeSpan},System.Nullable{System.Int32},System.Nullable{System.Boolean})"]

Implements

ILiveOddsTestManagerStartScenario(Int32, NullableTimeSpan, NullableInt32, NullableBoolean)
See Also

Reference

LiveOddsTestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsTestManager.StopAll Method

LiveOddsTestManagerStopAll Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StopAll(System.Nullable{System.Boolean})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void StopAll(
    bool? persistent = null
)

Parameters

persistent Nullable Boolean (Optional)

[Missing <param name="persistent"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StopAll(System.Nullable{System.Boolean})"]

Implements

ILiveOddsTestManagerStopAll(NullableBoolean)
See Also

Reference

LiveOddsTestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsTestManager.StopAuto Method

LiveOddsTestManagerStopAuto Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsTestManager.StopAuto"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void StopAuto()

Implements

ILiveOddsTestManagerStopAuto
See Also

Reference

LiveOddsTestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsDispatcher"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsFeedDispatcher
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsWithOutrightsDispatcher

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsWithOutrightsDispatcher : LiveOddsFeedDispatcher,
    ILiveOddsWithOutrightsDispatcher, ILiveOddsFeedDispatcher, IFeedDispatcher, IFeedWithOutrightsRecoveryDispatcher, IFeedRecoveryDispatcher

The LiveOddsWithOutrightsDispatcher type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsWithOutrightsDispatcher | Initializes a new instance of the LiveOddsWithOutrightsDispatcher class
Top
Properties
 | Name | Description
Public property | ProviderType | (Inherited from LiveOddsFeedDispatcher)
Top
Methods
 | Name | Description
Public method | ConnectedHandler | (Inherited from LiveOddsFeedDispatcher)
Public method | DisconnectedHandler | (Inherited from LiveOddsFeedDispatcher)
Public method | DispatchArtificialBetStop | (Inherited from LiveOddsFeedDispatcher)
Public method | DispatchArtificialBetStops | Dispatches the explicit bet stops. (Inherited from LiveOddsFeedDispatcher)
Public method | DispatchConnectionStable | Dispatches the connection is stable. (Inherited from LiveOddsFeedDispatcher)
Public method | DispatchConnectionUnstable | Dispatches the connection is unstable. (Inherited from LiveOddsFeedDispatcher)
Public method | DispatchEntity | Dispatches the entity. (Overrides LiveOddsFeedDispatcherDispatchEntity(EntityBase))
Public method | DispatchOutrightArtificialBetStop |
Public method | DispatchOutrightArtificialBetStops |
Public method | DispatchParseError | (Inherited from LiveOddsFeedDispatcher)
Public method | DispatchUserRequest | (Overrides LiveOddsFeedDispatcherDispatchUserRequest(UserRequest, NullableOddsReplyType, Int64))
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | AfterMessageDispatched | (Inherited from LiveOddsFeedDispatcher)
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnAliveWithOutrights | Occurs when [on alive with outrights received].
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsFeedDispatcher)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsFeedDispatcher)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnOutrightBetCancel | Occurs when OutrightBetCancel is received
Public event | OnOutrightBetClear | Occurs when OutrightBetClear is received
Public event | OnOutrightBetStart | Occurs when OutrightBetStart is received
Public event | OnOutrightBetStop | Occurs when OutrightBetStop is received
Public event | OnOutrightOddsChange | Occurs when OutrightOddsChange is received
Public event | OnOutrightStatus | Occurs when outright status messages are received
Public event | OnRaceResult | Occurs when [on race result]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnScoreCard | Occurs when [on score card received]. (Inherited from LiveOddsFeedDispatcher)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher Constructor

Initializes a new instance of the LiveOddsWithOutrightsDispatcher class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsWithOutrightsDispatcher(
    ILiveOddsFeedMonitor feed_monitor,
    ProtocolProviderType provider_type,
    ISdkLogger sdk_logger,
    IFakeBetStopFactoryWithOutrights fake_betstop_factory,
    ITimeKeeper server_timekeeper
)

Parameters

feed_monitor ILiveOddsFeedMonitor
A ILiveOddsFeedMonitor used to monitor the feed
provider_type ProtocolProviderType
A ProtocolProviderType specifying the type of protocol provider
sdk_logger ISdkLogger
A ISdkLogger used for traffic, client interaction, ... logging
fake_betstop_factory IFakeBetStopFactoryWithOutrights
A IFakeBetStopFactoryWithOutrights used to create SDK generated bet-stops
server_timekeeper ITimeKeeper
A ITimeKeeper tracking the server time
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher Properties

The LiveOddsWithOutrightsDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType | (Inherited from LiveOddsFeedDispatcher)
Top
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher Methods

The LiveOddsWithOutrightsDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | ConnectedHandler | (Inherited from LiveOddsFeedDispatcher)
Public method | DisconnectedHandler | (Inherited from LiveOddsFeedDispatcher)
Public method | DispatchArtificialBetStop | (Inherited from LiveOddsFeedDispatcher)
Public method | DispatchArtificialBetStops | Dispatches the explicit bet stops. (Inherited from LiveOddsFeedDispatcher)
Public method | DispatchConnectionStable | Dispatches the connection is stable. (Inherited from LiveOddsFeedDispatcher)
Public method | DispatchConnectionUnstable | Dispatches the connection is unstable. (Inherited from LiveOddsFeedDispatcher)
Public method | DispatchEntity | Dispatches the entity. (Overrides LiveOddsFeedDispatcherDispatchEntity(EntityBase))
Public method | DispatchOutrightArtificialBetStop |
Public method | DispatchOutrightArtificialBetStops |
Public method | DispatchParseError | (Inherited from LiveOddsFeedDispatcher)
Public method | DispatchUserRequest | (Overrides LiveOddsFeedDispatcherDispatchUserRequest(UserRequest, NullableOddsReplyType, Int64))
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher.DispatchEntity Method

LiveOddsWithOutrightsDispatcherDispatchEntity Method

Dispatches the entity.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override DispatchStatus DispatchEntity(
    EntityBase entity
)

Parameters

entity EntityBase
The entity.

Return Value

DispatchStatus

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsDispatcher.DispatchEntity(Sportradar.SDK.Common.EntityBase)"]

Implements

ILiveOddsFeedDispatcherDispatchEntity(EntityBase)
IFeedDispatcherDispatchEntity(EntityBase)
ILiveOddsFeedDispatcherDispatchEntity(EntityBase)
IFeedDispatcherDispatchEntity(EntityBase)
Exceptions
Exception | Condition
ArgumentNullException | dispatcher_state
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher.DispatchOutrightArtificialBetStop Method

LiveOddsWithOutrightsDispatcherDispatchOutrightArtificialBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsDispatcher.DispatchOutrightArtificialBetStop(System.Nullable{System.Int64},System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void DispatchOutrightArtificialBetStop(
    long? virtual_game_id,
    long outright_id
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsDispatcher.DispatchOutrightArtificialBetStop(System.Nullable{System.Int64},System.Int64)"]

outright_id Int64

[Missing <param name="outright_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsDispatcher.DispatchOutrightArtificialBetStop(System.Nullable{System.Int64},System.Int64)"]

Implements

IFeedWithOutrightsRecoveryDispatcherDispatchOutrightArtificialBetStop(NullableInt64, Int64)
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher.DispatchOutrightArtificialBetStops Method

LiveOddsWithOutrightsDispatcherDispatchOutrightArtificialBetStops Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsDispatcher.DispatchOutrightArtificialBetStops(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void DispatchOutrightArtificialBetStops(
    long? virtual_game_id,
    IEnumerable<long> outright_ids
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsDispatcher.DispatchOutrightArtificialBetStops(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

outright_ids IEnumerable Int64

[Missing <param name="outright_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsDispatcher.DispatchOutrightArtificialBetStops(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Implements

IFeedWithOutrightsRecoveryDispatcherDispatchOutrightArtificialBetStops(NullableInt64, IEnumerableInt64)
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher.DispatchUserRequest Method

LiveOddsWithOutrightsDispatcherDispatchUserRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsDispatcher.DispatchUserRequest(Sportradar.SDK.FeedProviders.LiveOdds.Common.UserRequest,System.Nullable{Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsReplyType},System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override void DispatchUserRequest(
    UserRequest request,
    OddsReplyType? reply_type,
    long key
)

Parameters

request UserRequest

[Missing <param name="request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsDispatcher.DispatchUserRequest(Sportradar.SDK.FeedProviders.LiveOdds.Common.UserRequest,System.Nullable{Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsReplyType},System.Int64)"]

reply_type Nullable OddsReplyType

[Missing <param name="reply_type"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsDispatcher.DispatchUserRequest(Sportradar.SDK.FeedProviders.LiveOdds.Common.UserRequest,System.Nullable{Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsReplyType},System.Int64)"]

key Int64

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsDispatcher.DispatchUserRequest(Sportradar.SDK.FeedProviders.LiveOdds.Common.UserRequest,System.Nullable{Sportradar.SDK.FeedProviders.LiveOdds.Common.OddsReplyType},System.Int64)"]

Implements

ILiveOddsFeedDispatcherDispatchUserRequest(UserRequest, NullableOddsReplyType, Int64)
ILiveOddsFeedDispatcherDispatchUserRequest(UserRequest, NullableOddsReplyType, Int64)
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher Events

The LiveOddsWithOutrightsDispatcher type exposes the following members.

Events
 | Name | Description
Public event | AfterMessageDispatched | (Inherited from LiveOddsFeedDispatcher)
Public event | OnAlive | Occurs when [on alive received]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnAliveWithOutrights | Occurs when [on alive with outrights received].
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from LiveOddsFeedDispatcher)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from LiveOddsFeedDispatcher)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnOutrightBetCancel | Occurs when OutrightBetCancel is received
Public event | OnOutrightBetClear | Occurs when OutrightBetClear is received
Public event | OnOutrightBetStart | Occurs when OutrightBetStart is received
Public event | OnOutrightBetStop | Occurs when OutrightBetStop is received
Public event | OnOutrightOddsChange | Occurs when OutrightOddsChange is received
Public event | OnOutrightStatus | Occurs when outright status messages are received
Public event | OnRaceResult | Occurs when [on race result]. (Inherited from LiveOddsFeedDispatcher)
Public event | OnScoreCard | Occurs when [on score card received]. (Inherited from LiveOddsFeedDispatcher)
Top
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher.OnAliveWithOutrights Event

LiveOddsWithOutrightsDispatcherOnAliveWithOutrights Event

Occurs when [on alive with outrights received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<AliveWithOutrightsEventArgs> OnAliveWithOutrights

Value

EventHandler AliveWithOutrightsEventArgs

Implements

ILiveOddsWithOutrightsDispatcherOnAliveWithOutrights
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher.OnOutrightBetCancel Event

LiveOddsWithOutrightsDispatcherOnOutrightBetCancel Event

Occurs when OutrightBetCancel is received

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<OutrightBetCancelEventArgs> OnOutrightBetCancel

Value

EventHandler OutrightBetCancelEventArgs

Implements

ILiveOddsWithOutrightsDispatcherOnOutrightBetCancel
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher.OnOutrightBetClear Event

LiveOddsWithOutrightsDispatcherOnOutrightBetClear Event

Occurs when OutrightBetClear is received

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<OutrightBetClearEventArgs> OnOutrightBetClear

Value

EventHandler OutrightBetClearEventArgs

Implements

ILiveOddsWithOutrightsDispatcherOnOutrightBetClear
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher.OnOutrightBetStart Event

LiveOddsWithOutrightsDispatcherOnOutrightBetStart Event

Occurs when OutrightBetStart is received

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<OutrightBetStartEventArgs> OnOutrightBetStart

Value

EventHandler OutrightBetStartEventArgs

Implements

ILiveOddsWithOutrightsDispatcherOnOutrightBetStart
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher.OnOutrightBetStop Event

LiveOddsWithOutrightsDispatcherOnOutrightBetStop Event

Occurs when OutrightBetStop is received

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<OutrightBetStopEventArgs> OnOutrightBetStop

Value

EventHandler OutrightBetStopEventArgs

Implements

ILiveOddsWithOutrightsDispatcherOnOutrightBetStop
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher.OnOutrightOddsChange Event

LiveOddsWithOutrightsDispatcherOnOutrightOddsChange Event

Occurs when OutrightOddsChange is received

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<OutrightOddsChangeEventArgs> OnOutrightOddsChange

Value

EventHandler OutrightOddsChangeEventArgs

Implements

ILiveOddsWithOutrightsDispatcherOnOutrightOddsChange
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsDispatcher.OnOutrightStatus Event

LiveOddsWithOutrightsDispatcherOnOutrightStatus Event

Occurs when outright status messages are received

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<EventDataReceivedEventArgs> OnOutrightStatus

Value

EventHandler EventDataReceivedEventArgs

Implements

ILiveOddsWithOutrightsDispatcherOnOutrightStatus
See Also

Reference

LiveOddsWithOutrightsDispatcher Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.LiveOddsWithOutrightsFeedProvider"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsWithOutrightsFeedProvider
Sportradar.SDK.Services.SdkLiveOddsFeedProviderVfc

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public abstract class LiveOddsWithOutrightsFeedProvider : LiveOddsCommonFeedProviderBase,
    ILiveOddsWithOutrights, ILiveOddsCommonBase, ILiveFeeds, IStartable

The LiveOddsWithOutrightsFeedProvider type exposes the following members.

Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOutrightList | Request meta-information about outrights specified by it's ids
Public method | GetOutrightsStatus | Requests the outright statuses for a given time ("current" server request). This includes odds, activation of odds and status for the outright requested, current bet status and all bet clearing messages before the timestamp.
Public method | GetOutrightStatus | Requests the outright status for a given time ("current" server request). This includes odds, activation of odds and status for the ouright requested, current bet status and all bet clearing messages before the timestamp.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | Start component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Stop | Stop / shutdown component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
Name | Description
Public event | OnAliveWithOutrights | Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
Public event OnBetCancel Occurs when [on bet cancel].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetCancelUndo Occurs when [on bet cancel undone].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetClear Occurs when [on bet clear].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetClearRollback Occurs when [on bet clear rollback].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetStart Occurs when [on bet start].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetStop Occurs when [on bet stop].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnConnectionStable Occurs when connection stable.
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnConnectionUnstable Occurs when connection unstable.
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnEventMessages Occurs when [on match messages received].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnEventStatus Occurs when [on match status received].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnFeedError Occurs when [on feed error].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnMetaInfo Occurs when [on meta info received].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnOddsChange Occurs when [on odds change].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOutrightBetCancel | Signals that odds type for an outright should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
Public event OnOutrightBetClear

Signals that bets placed on this outright can be settled Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

Public event | OnOutrightBetStart | Signals that bets for a specific outright can open again after they have been stopped.
Public event | OnOutrightBetStop | Signals that a bet stop situation occurred for a specific outright. OnBetStart event is triggered when the bets can open again.
Public event | OnOutrightOddsChange | Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
Public event | OnOutrightStatus | Occurs when outright status messages are received
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider Properties

The LiveOddsWithOutrightsFeedProvider type exposes the following members.

Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider Methods

The LiveOddsWithOutrightsFeedProvider type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOutrightList | Request meta-information about outrights specified by it's ids
Public method | GetOutrightsStatus | Requests the outright statuses for a given time ("current" server request). This includes odds, activation of odds and status for the outright requested, current bet status and all bet clearing messages before the timestamp.
Public method | GetOutrightStatus | Requests the outright status for a given time ("current" server request). This includes odds, activation of odds and status for the ouright requested, current bet status and all bet clearing messages before the timestamp.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | Start component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Stop | Stop / shutdown component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider.GetOutrightList Method

LiveOddsWithOutrightsFeedProviderGetOutrightList Method

Request meta-information about outrights specified by it's ids

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long GetOutrightList(
    IEnumerable<long> outright_ids
)

Parameters

outright_ids IEnumerable Int64
Specifies the outrights for which to retrieve meta info

Return Value

Int64
Returns immediately with the request number or zero, but expect to receive [!:ILiveOdds.OnMetaInfo] event in response

Implements

ILiveOddsWithOutrightsGetOutrightList(IEnumerableInt64)
See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider.GetOutrightsStatus Method

LiveOddsWithOutrightsFeedProviderGetOutrightsStatus Method

Requests the outright statuses for a given time ("current" server request). This includes odds, activation of odds and status for the outright requested, current bet status and all bet clearing messages before the timestamp.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long GetOutrightsStatus(
    IEnumerable<long> outright_ids,
    DateTime? from = null,
    bool package = true
)

Parameters

outright_ids IEnumerable Int64
Outright ids, maximum is 50 per request to avoid having server queue filling up
from Nullable DateTime (Optional)
Outrights statuses on particular time (leave null for current outright status)
package Boolean (Optional)
All replies get packaged in one see OnOutrightStatus when true; else normal events will get invoked.

Return Value

Int64
Returns immediately with the request number or zero but expect to receive an event afterwards.

Implements

ILiveOddsWithOutrightsGetOutrightsStatus(IEnumerableInt64, NullableDateTime, Boolean)
Remarks
SDK already handles error recovery for on-going outrights, no matter whether there is a crash or connection to the server is lost, so during normal operation there should be no need to call this method! The purpose of it is for book-keeping after an outright has ended. For instance after an outright is not active anymore you might want to settle all open bets or check whether a match is really about to start. Notice that the match messages do not include a message number (msgnr). The received "state" is an abstract concept derived from the sent messages not any sent message so it cannot have a sequence number.
See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider.GetOutrightStatus Method

LiveOddsWithOutrightsFeedProviderGetOutrightStatus Method

Requests the outright status for a given time ("current" server request). This includes odds, activation of odds and status for the ouright requested, current bet status and all bet clearing messages before the timestamp.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long GetOutrightStatus(
    long outright_id,
    DateTime? from = null,
    bool package = true
)

Parameters

outright_id Int64
Outright id
from Nullable DateTime (Optional)
Outright status on particular time (leave null for current outright status)
package Boolean (Optional)
All replies get packaged in one see OnOutrightStatus when true; else normal events will get invoked.

Return Value

Int64
Returns immediately with the request number or zero but expect to receive an event afterwards.

Implements

ILiveOddsWithOutrightsGetOutrightStatus(Int64, NullableDateTime, Boolean)
Remarks
SDK already handles error recovery for on-going outrights, no matter whether there is a crash or connection to the server is lost, so during normal operation there should be no need to call this method! The purpose of it is for book-keeping after an outright has ended. For instance after an outright is not active anymore you might want to settle all open bets or check whether a outright is really about to start. Notice that the outright messages do not include a message number (msgnr). The received "state" is an abstract concept derived from the sent messages not any sent message so it cannot have a sequence number.
See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider Events

The LiveOddsWithOutrightsFeedProvider type exposes the following members.

Events
Name | Description
Public event | OnAliveWithOutrights | Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
Public event OnBetCancel Occurs when [on bet cancel].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetCancelUndo Occurs when [on bet cancel undone].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetClear Occurs when [on bet clear].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetClearRollback Occurs when [on bet clear rollback].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetStart Occurs when [on bet start].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetStop Occurs when [on bet stop].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnConnectionStable Occurs when connection stable.
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnConnectionUnstable Occurs when connection unstable.
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnEventMessages Occurs when [on match messages received].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnEventStatus Occurs when [on match status received].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnFeedError Occurs when [on feed error].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnMetaInfo Occurs when [on meta info received].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnOddsChange Occurs when [on odds change].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event | OnOutrightBetCancel | Signals that odds type for an outright should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
Public event OnOutrightBetClear

Signals that bets placed on this outright can be settled Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

Public event | OnOutrightBetStart | Signals that bets for a specific outright can open again after they have been stopped.
Public event | OnOutrightBetStop | Signals that a bet stop situation occurred for a specific outright. OnBetStart event is triggered when the bets can open again.
Public event | OnOutrightOddsChange | Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
Public event | OnOutrightStatus | Occurs when outright status messages are received
Top
See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider.OnAliveWithOutrights Event

LiveOddsWithOutrightsFeedProviderOnAliveWithOutrights Event

Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<AliveWithOutrightsEventArgs> OnAliveWithOutrights

Value

EventHandler AliveWithOutrightsEventArgs

Implements

ILiveOddsWithOutrightsOnAliveWithOutrights
Remarks
SDK will send out bet stops for all matches if no alive message has been received in the last 20 seconds. In this case client shouldn't accept any bets for any matches until the connection is stable again. SDK will also take care that if the connection to the Betradar server is lost, bet stops for all matches are sent out until a stable connection is established again.
See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider.OnOutrightBetCancel Event

LiveOddsWithOutrightsFeedProviderOnOutrightBetCancel Event

Signals that odds type for an outright should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<OutrightBetCancelEventArgs> OnOutrightBetCancel

Value

EventHandler OutrightBetCancelEventArgs

Implements

ILiveOddsWithOutrightsOnOutrightBetCancel
See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider.OnOutrightBetClear Event

LiveOddsWithOutrightsFeedProviderOnOutrightBetClear Event

Signals that bets placed on this outright can be settled Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<OutrightBetClearEventArgs> OnOutrightBetClear

Value

EventHandler OutrightBetClearEventArgs

Implements

ILiveOddsWithOutrightsOnOutrightBetClear
Remarks

Some bettypes, like asian handicap and asian total, can include void factor for each EventOddsField element. Void factor can either be 1 or 0.5 indicating that the whole or half the bet is voided and should be refunded to the customer. When the void factor is set to 0.5 the outcome attribute will indicate if the other half has won or lost.

These are all possible combinations of outcome and void factors:

  1. outcome="0" and no voidfactor: Lose entire bet
  2. outcome="1" and no voidfactor: Win entire bet
  3. outcome="0" and voidfactor="1": Refund entire bet
  4. outcome="1" and voidfactor="0.5": Refund half bet and win other half
  5. outcome="0" and voidfactor="0.5": Refund half bet and lose other half

See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider.OnOutrightBetStart Event

LiveOddsWithOutrightsFeedProviderOnOutrightBetStart Event

Signals that bets for a specific outright can open again after they have been stopped.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<OutrightBetStartEventArgs> OnOutrightBetStart

Value

EventHandler OutrightBetStartEventArgs

Implements

ILiveOddsWithOutrightsOnOutrightBetStart
See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider.OnOutrightBetStop Event

LiveOddsWithOutrightsFeedProviderOnOutrightBetStop Event

Signals that a bet stop situation occurred for a specific outright. OnBetStart event is triggered when the bets can open again.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<OutrightBetStopEventArgs> OnOutrightBetStop

Value

EventHandler OutrightBetStopEventArgs

Implements

ILiveOddsWithOutrightsOnOutrightBetStop
Remarks
Bet stop is triggered after following events take place:
  1. Goals
  2. Red cards
  3. Penalty
  4. One on one situations
  5. Free kicks within 20 meters
  6. Match is interrupted temporarily
Administrative events which cause a bet stop condition:
  1. Loss of TV coverage
  2. Loss of connection to the scout
See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider.OnOutrightOddsChange Event

LiveOddsWithOutrightsFeedProviderOnOutrightOddsChange Event

Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<OutrightOddsChangeEventArgs> OnOutrightOddsChange

Value

EventHandler OutrightOddsChangeEventArgs

Implements

ILiveOddsWithOutrightsOnOutrightOddsChange
See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


LiveOddsWithOutrightsFeedProvider.OnOutrightStatus Event

LiveOddsWithOutrightsFeedProviderOnOutrightStatus Event

Occurs when outright status messages are received

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<EventDataReceivedEventArgs> OnOutrightStatus

Value

EventHandler EventDataReceivedEventArgs

Implements

ILiveOddsWithOutrightsOnOutrightStatus
See Also

Reference

LiveOddsWithOutrightsFeedProvider Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MatchMsgNrStatusTuple Class

Match id, message number and betstatus tuple.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalMatchMsgNrTuple
Sportradar.SDK.FeedProviders.LiveOdds.InternalMatchMsgNrStatusTuple

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class MatchMsgNrStatusTuple : MatchMsgNrTuple

The MatchMsgNrStatusTuple type exposes the following members.

Constructors
 | Name | Description
Public method | MatchMsgNrStatusTuple | Initializes a new instance of the MatchMsgNrStatusTuple class
Top
Properties
 | Name | Description
Public property | BetStatus | Current bet status.
Public property | MatchId | Gets or sets the match id. (Inherited from MatchMsgNrTuple)
Public property | MsgNr | Gets or sets the message number. (Inherited from MatchMsgNrTuple)
Public property | Timestamp | Timestamp of the thing (Inherited from MatchMsgNrTuple)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MatchMsgNrStatusTuple Constructor

Initializes a new instance of the MatchMsgNrStatusTuple class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchMsgNrStatusTuple()
See Also

Reference

MatchMsgNrStatusTuple Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MatchMsgNrStatusTuple Properties

The MatchMsgNrStatusTuple type exposes the following members.

Properties
 | Name | Description
Public property | BetStatus | Current bet status.
Public property | MatchId | Gets or sets the match id. (Inherited from MatchMsgNrTuple)
Public property | MsgNr | Gets or sets the message number. (Inherited from MatchMsgNrTuple)
Public property | Timestamp | Timestamp of the thing (Inherited from MatchMsgNrTuple)
Top
See Also

Reference

MatchMsgNrStatusTuple Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MatchMsgNrStatusTuple.BetStatus Property

MatchMsgNrStatusTupleBetStatus Property

Current bet status.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventBetStatus BetStatus { get; set; }

Property Value

EventBetStatus
See Also

Reference

MatchMsgNrStatusTuple Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MatchMsgNrStatusTuple Methods

The MatchMsgNrStatusTuple type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MatchMsgNrStatusTuple Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MatchMsgNrTuple Class

Match id, message number tuple.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalMatchMsgNrTuple
Sportradar.SDK.FeedProviders.LiveOdds.InternalMatchMsgNrStatusTuple

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class MatchMsgNrTuple

The MatchMsgNrTuple type exposes the following members.

Constructors
 | Name | Description
Public method | MatchMsgNrTuple | Initializes a new instance of the MatchMsgNrTuple class
Top
Properties
 | Name | Description
Public property | MatchId | Gets or sets the match id.
Public property | MsgNr | Gets or sets the message number.
Public property | Timestamp | Timestamp of the thing
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MatchMsgNrTuple Constructor

Initializes a new instance of the MatchMsgNrTuple class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchMsgNrTuple()
See Also

Reference

MatchMsgNrTuple Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MatchMsgNrTuple Properties

The MatchMsgNrTuple type exposes the following members.

Properties
 | Name | Description
Public property | MatchId | Gets or sets the match id.
Public property | MsgNr | Gets or sets the message number.
Public property | Timestamp | Timestamp of the thing
Top
See Also

Reference

MatchMsgNrTuple Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MatchMsgNrTuple.MatchId Property

MatchMsgNrTupleMatchId Property

Gets or sets the match id.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long MatchId { get; set; }

Property Value

Int64
The match id.
See Also

Reference

MatchMsgNrTuple Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MatchMsgNrTuple.MsgNr Property

MatchMsgNrTupleMsgNr Property

Gets or sets the message number.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long MsgNr { get; set; }

Property Value

Int64
The message number.
See Also

Reference

MatchMsgNrTuple Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MatchMsgNrTuple.Timestamp Property

MatchMsgNrTupleTimestamp Property

Timestamp of the thing

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime Timestamp { get; set; }

Property Value

DateTime
See Also

Reference

MatchMsgNrTuple Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


MatchMsgNrTuple Methods

The MatchMsgNrTuple type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MatchMsgNrTuple Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationRequest Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalPreparationRequest

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class PreparationRequest

The PreparationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | PreparationRequest | Initializes a new instance of the PreparationRequest class
Public method | PreparationRequest(NullableInt64, Boolean) | Initializes a new instance of the PreparationRequest class
Top
Properties
 | Name | Description
Public property | DesiredRequestNr |
Public property | IsInternal |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Fields
Name | Description
ASYNC_VARIANT |
SYNC_VARIANT |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationRequest Constructor

Overload List
 | Name | Description
Public method | PreparationRequest | Initializes a new instance of the PreparationRequest class
Public method | PreparationRequest(NullableInt64, Boolean) | Initializes a new instance of the PreparationRequest class
Top
See Also

Reference

PreparationRequest Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationRequest Constructor

Initializes a new instance of the PreparationRequest class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationRequest()
See Also

Reference

PreparationRequest Class
PreparationRequest Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationRequest(Nullable<Int64>, Boolean) Constructor

PreparationRequest(NullableInt64, Boolean) Constructor

Initializes a new instance of the PreparationRequest class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationRequest(
    long? desired_request_nr,
    bool is_internal
)

Parameters

desired_request_nr Nullable Int64

[Missing <param name="desired_request_nr"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest.#ctor(System.Nullable{System.Int64},System.Boolean)"]

is_internal Boolean

[Missing <param name="is_internal"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest.#ctor(System.Nullable{System.Int64},System.Boolean)"]

See Also

Reference

PreparationRequest Class
PreparationRequest Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationRequest Properties

The PreparationRequest type exposes the following members.

Properties
 | Name | Description
Public property | DesiredRequestNr |
Public property | IsInternal |
Top
See Also

Reference

PreparationRequest Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationRequest.DesiredRequestNr Property

PreparationRequestDesiredRequestNr Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest.DesiredRequestNr"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? DesiredRequestNr { get; set; }

Property Value

Nullable Int64
See Also

Reference

PreparationRequest Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationRequest.IsInternal Property

PreparationRequestIsInternal Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest.IsInternal"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsInternal { get; set; }

Property Value

Boolean
See Also

Reference

PreparationRequest Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationRequest Methods

The PreparationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PreparationRequest Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationRequest Fields

The PreparationRequest type exposes the following members.

Fields
Name | Description
ASYNC_VARIANT |
SYNC_VARIANT |
Top
See Also

Reference

PreparationRequest Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationRequest.ASYNC_VARIANT Field

PreparationRequestASYNC_VARIANT Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest.ASYNC_VARIANT"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static PreparationRequest ASYNC_VARIANT

Field Value

PreparationRequest
See Also

Reference

PreparationRequest Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationRequest.SYNC_VARIANT Field

PreparationRequestSYNC_VARIANT Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest.SYNC_VARIANT"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static PreparationRequest SYNC_VARIANT

Field Value

PreparationRequest
See Also

Reference

PreparationRequest Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationResult Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationResult"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalPreparationResult

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class PreparationResult

The PreparationResult type exposes the following members.

Constructors
 | Name | Description
Public method | PreparationResult | Initializes a new instance of the PreparationResult class
Top
Properties
 | Name | Description
Public property | Execute |
Public property | ReplyNumber |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationResult Constructor

Initializes a new instance of the PreparationResult class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationResult()
See Also

Reference

PreparationResult Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationResult Properties

The PreparationResult type exposes the following members.

Properties
 | Name | Description
Public property | Execute |
Public property | ReplyNumber |
Top
See Also

Reference

PreparationResult Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationResult.Execute Property

PreparationResultExecute Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationResult.Execute"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Action Execute { get; set; }

Property Value

Action
See Also

Reference

PreparationResult Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationResult.ReplyNumber Property

PreparationResultReplyNumber Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationResult.ReplyNumber"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long ReplyNumber { get; set; }

Property Value

Int64
See Also

Reference

PreparationResult Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


PreparationResult Methods

The PreparationResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PreparationResult Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


RequestProducerDelegates Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalRequestProducerDelegates

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class RequestProducerDelegates

The RequestProducerDelegates type exposes the following members.

Constructors
 | Name | Description
Public method | RequestProducerDelegates | Initializes a new instance of the RequestProducerDelegates class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


RequestProducerDelegates Constructor

Initializes a new instance of the RequestProducerDelegates class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RequestProducerDelegates()
See Also

Reference

RequestProducerDelegates Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


RequestProducerDelegates Methods

The RequestProducerDelegates type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RequestProducerDelegates Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


RequestProducerDelegates.RequestDelegate Class

RequestProducerDelegatesRequestDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates.RequestDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.FeedProviders.LiveOdds.InternalRequestProducerDelegatesRequestDelegate

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class RequestDelegate : MulticastDelegate

The RequestProducerDelegatesRequestDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | RequestProducerDelegatesRequestDelegate | Initializes a new instance of the RequestProducerDelegatesRequestDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


RequestProducerDelegates.RequestDelegate Constructor

RequestProducerDelegatesRequestDelegate Constructor

Initializes a new instance of the RequestProducerDelegatesRequestDelegate class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RequestDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates.RequestDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates.RequestDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

RequestProducerDelegatesRequestDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


RequestDelegate Properties

The RequestProducerDelegatesRequestDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

RequestProducerDelegatesRequestDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


RequestDelegate Methods

The RequestProducerDelegatesRequestDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RequestProducerDelegatesRequestDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


RequestProducerDelegates.RequestDelegate.BeginInvoke Method

RequestProducerDelegatesRequestDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates.RequestDelegate.BeginInvoke(System.Int64,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    long eventId,
    AsyncCallback callback,
    Object object
)

Parameters

eventId Int64

[Missing <param name="eventId"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates.RequestDelegate.BeginInvoke(System.Int64,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates.RequestDelegate.BeginInvoke(System.Int64,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates.RequestDelegate.BeginInvoke(System.Int64,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates.RequestDelegate.BeginInvoke(System.Int64,System.AsyncCallback,System.Object)"]

See Also

Reference

RequestProducerDelegatesRequestDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


RequestProducerDelegates.RequestDelegate.EndInvoke Method

RequestProducerDelegatesRequestDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates.RequestDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates.RequestDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

RequestProducerDelegatesRequestDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


RequestProducerDelegates.RequestDelegate.Invoke Method

RequestProducerDelegatesRequestDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates.RequestDelegate.Invoke(System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    long eventId
)

Parameters

eventId Int64

[Missing <param name="eventId"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.RequestProducerDelegates.RequestDelegate.Invoke(System.Int64)"]

See Also

Reference

RequestProducerDelegatesRequestDelegate Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


SequenceMonitor Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalSequenceMonitor

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SequenceMonitor : ISequenceMonitor

The SequenceMonitor type exposes the following members.

Constructors
 | Name | Description
Public method | SequenceMonitor | Initializes a new instance of the SequenceMonitor class
Top
Methods
 | Name | Description
Public method | Current |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForceSequenceNumber |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NewEvent |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


SequenceMonitor Constructor

Initializes a new instance of the SequenceMonitor class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SequenceMonitor(
    TimeSpan max_age,
    TimeSpan check_interval
)

Parameters

max_age TimeSpan

[Missing <param name="max_age"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor.#ctor(System.TimeSpan,System.TimeSpan)"]

check_interval TimeSpan

[Missing <param name="check_interval"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor.#ctor(System.TimeSpan,System.TimeSpan)"]

See Also

Reference

SequenceMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


SequenceMonitor Methods

The SequenceMonitor type exposes the following members.

Methods
 | Name | Description
Public method | Current |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForceSequenceNumber |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NewEvent |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SequenceMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


SequenceMonitor.Current Method

SequenceMonitorCurrent Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor.Current(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Current(
    EventWrapperEventWrapperId event_id
)

Parameters

event_id EventWrapperEventWrapperId

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor.Current(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId)"]

Return Value

Nullable Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor.Current(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId)"]

Implements

ISequenceMonitorCurrent(EventWrapperEventWrapperId)
See Also

Reference

SequenceMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


SequenceMonitor.ForceSequenceNumber Method

SequenceMonitorForceSequenceNumber Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor.ForceSequenceNumber(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void ForceSequenceNumber(
    EventWrapperEventWrapperId event_id,
    long seq_nr
)

Parameters

event_id EventWrapperEventWrapperId

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor.ForceSequenceNumber(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

seq_nr Int64

[Missing <param name="seq_nr"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor.ForceSequenceNumber(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

Implements

ISequenceMonitorForceSequenceNumber(EventWrapperEventWrapperId, Int64)
See Also

Reference

SequenceMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


SequenceMonitor.NewEvent Method

SequenceMonitorNewEvent Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor.NewEvent(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool NewEvent(
    EventWrapperEventWrapperId event_id,
    long seq_nr
)

Parameters

event_id EventWrapperEventWrapperId

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor.NewEvent(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

seq_nr Int64

[Missing <param name="seq_nr"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor.NewEvent(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.SequenceMonitor.NewEvent(Sportradar.SDK.FeedProviders.LiveOdds.Internal.EventWrapper.EventWrapperId,System.Int64)"]

Implements

ISequenceMonitorNewEvent(EventWrapperEventWrapperId, Int64)
See Also

Reference

SequenceMonitor Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


UserRequestManager Class

Handles batching of replies for a user-request (so he gets everything at once with "replyend") and flagging messages with IsOutOfBand.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalUserRequestManager

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class UserRequestManager

The UserRequestManager type exposes the following members.

Constructors
 | Name | Description
Public method | UserRequestManager | Initializes a new instance of the UserRequestManager class
Top
Methods
 | Name | Description
Public method | AddRequestId |
Public method | Disable | Disable all operation (prevents intercepting messages).
Public method | Enable | Enable all operation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
User can also request data to directly get messages (not batched) in this case this component is stateless but still does the IsOutOfBand flagging.
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


UserRequestManager Constructor

Initializes a new instance of the UserRequestManager class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public UserRequestManager(
    ILiveOddsRequestProducer request_producer,
    ILiveOddsFeedMonitor feed_monitor,
    ILiveOddsFeedDispatcher feed_dispatcher
)

Parameters

request_producer ILiveOddsRequestProducer

[Missing <param name="request_producer"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.UserRequestManager.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher)"]

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.UserRequestManager.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher)"]

feed_dispatcher ILiveOddsFeedDispatcher

[Missing <param name="feed_dispatcher"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.UserRequestManager.#ctor(Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedDispatcher)"]

See Also

Reference

UserRequestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


UserRequestManager Methods

The UserRequestManager type exposes the following members.

Methods
 | Name | Description
Public method | AddRequestId |
Public method | Disable | Disable all operation (prevents intercepting messages).
Public method | Enable | Enable all operation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

UserRequestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


UserRequestManager.AddRequestId Method

UserRequestManagerAddRequestId Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.UserRequestManager.AddRequestId(System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void AddRequestId(
    long request_id
)

Parameters

request_id Int64

[Missing <param name="request_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.UserRequestManager.AddRequestId(System.Int64)"]

See Also

Reference

UserRequestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


UserRequestManager.Disable Method

UserRequestManagerDisable Method

Disable all operation (prevents intercepting messages).

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Disable()
See Also

Reference

UserRequestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


UserRequestManager.Enable Method

UserRequestManagerEnable Method

Enable all operation.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Enable()
See Also

Reference

UserRequestManager Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalVdrEntityFactory

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class VdrEntityFactory : IFakeBetStopFactory

The VdrEntityFactory type exposes the following members.

Constructors
 | Name | Description
Public method | VdrEntityFactory | Initializes a new instance of the VdrEntityFactory class
Top
Methods
 | Name | Description
Public method | buildAlive |
Public method | buildBetCancel |
Public method | buildBetClear |
Public method | buildBetStart |
Public method | buildBetStop |
Public method | BuildFakeBetStop |
Public method | buildMetaInfo |
Public method | buildOddsChange |
Public method | buildRaceResult |
Public method | buildReplyStartEnd |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory Constructor

Initializes a new instance of the VdrEntityFactory class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public VdrEntityFactory(
    ITimeKeeper server_timekeeper
)

Parameters

server_timekeeper ITimeKeeper

[Missing <param name="server_timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.#ctor(Sportradar.SDK.Common.Interfaces.ITimeKeeper)"]

See Also

Reference

VdrEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory Methods

The VdrEntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | buildAlive |
Public method | buildBetCancel |
Public method | buildBetClear |
Public method | buildBetStart |
Public method | buildBetStop |
Public method | BuildFakeBetStop |
Public method | buildMetaInfo |
Public method | buildOddsChange |
Public method | buildRaceResult |
Public method | buildReplyStartEnd |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

VdrEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory.buildAlive Method

VdrEntityFactorybuildAlive Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Alive buildAlive(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Return Value

Alive

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

See Also

Reference

VdrEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory.buildBetCancel Method

VdrEntityFactorybuildBetCancel Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetCancel buildBetCancel(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Return Value

BetCancel

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

See Also

Reference

VdrEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory.buildBetClear Method

VdrEntityFactorybuildBetClear Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetClear buildBetClear(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Return Value

BetClear

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

See Also

Reference

VdrEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory.buildBetStart Method

VdrEntityFactorybuildBetStart Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStart buildBetStart(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Return Value

BetStart

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

See Also

Reference

VdrEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory.buildBetStop Method

VdrEntityFactorybuildBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStop buildBetStop(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Return Value

BetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

See Also

Reference

VdrEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory.BuildFakeBetStop Method

VdrEntityFactoryBuildFakeBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.BuildFakeBetStop(System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStop BuildFakeBetStop(
    long match_id
)

Parameters

match_id Int64

[Missing <param name="match_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.BuildFakeBetStop(System.Int64)"]

Return Value

BetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.BuildFakeBetStop(System.Int64)"]

Implements

IFakeBetStopFactoryBuildFakeBetStop(Int64)
See Also

Reference

VdrEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory.buildMetaInfo Method

VdrEntityFactorybuildMetaInfo Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildMetaInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MetaInfo buildMetaInfo(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildMetaInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Return Value

MetaInfo

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildMetaInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

See Also

Reference

VdrEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory.buildOddsChange Method

VdrEntityFactorybuildOddsChange Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsChange buildOddsChange(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Return Value

OddsChange

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

See Also

Reference

VdrEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory.buildRaceResult Method

VdrEntityFactorybuildRaceResult Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildRaceResult(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceResult buildRaceResult(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildRaceResult(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Return Value

RaceResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildRaceResult(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

See Also

Reference

VdrEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrEntityFactory.buildReplyStartEnd Method

VdrEntityFactorybuildReplyStartEnd Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ReplyStartEnd buildReplyStartEnd(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

Return Value

ReplyStartEnd

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrEntityFactory.buildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vdr.Incoming.BetradarLiveOdds)"]

See Also

Reference

VdrEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalVdrRequestProducer

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class VdrRequestProducer : ILiveOddsRequestProducer

The VdrRequestProducer type exposes the following members.

Constructors
 | Name | Description
Public method | VdrRequestProducer | Initializes a new instance of the VdrRequestProducer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FillRequest |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PrepareBook |
Public method | PrepareGetEventList |
Public method | PrepareGetEventMessages |
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetScoreAndCardSummary |
Public method | PrepareRacedayMetaRequest |
Public method | PrepareRegisterBetTypes |
Public method | PrepareSubscribe |
Public method | PrepareUnregisterBetTypes |
Public method | PrepareUnsubscribe |
Public method | SendCurrentRequest |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | OnRequestAdded |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer Constructor

Initializes a new instance of the VdrRequestProducer class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public VdrRequestProducer(
    ISdkLogger sdk_logger,
    IProtocolProvider proto_provider,
    SdkConfigurationLiveOdds local_config
)

Parameters

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

proto_provider IProtocolProvider

[Missing <param name="proto_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

local_config SdkConfigurationLiveOdds

[Missing <param name="local_config"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer Methods

The VdrRequestProducer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FillRequest |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PrepareBook |
Public method | PrepareGetEventList |
Public method | PrepareGetEventMessages |
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetScoreAndCardSummary |
Public method | PrepareRacedayMetaRequest |
Public method | PrepareRegisterBetTypes |
Public method | PrepareSubscribe |
Public method | PrepareUnregisterBetTypes |
Public method | PrepareUnsubscribe |
Public method | SendCurrentRequest |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.FillRequest Method

VdrRequestProducerFillRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.FillRequest(Sportradar.SDK.Common.Interfaces.IProtocolRequest,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationResult FillRequest(
    IProtocolRequest req,
    PreparationRequest prep
)

Parameters

req IProtocolRequest

[Missing <param name="req"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.FillRequest(Sportradar.SDK.Common.Interfaces.IProtocolRequest,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.FillRequest(Sportradar.SDK.Common.Interfaces.IProtocolRequest,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.FillRequest(Sportradar.SDK.Common.Interfaces.IProtocolRequest,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.PrepareBook Method

VdrRequestProducerPrepareBook Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareBook(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareBook(IEnumerableInt64, PreparationRequest)
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.PrepareGetEventList Method

VdrRequestProducerPrepareGetEventList Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventList(
    DateTime? from,
    DateTime? to,
    PreparationRequest prep,
    IEnumerable<long> event_ids = null,
    bool? include_available = null
)

Parameters

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

to Nullable DateTime

[Missing <param name="to"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

event_ids IEnumerable Int64 (Optional)

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

include_available Nullable Boolean (Optional)

[Missing <param name="include_available"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Implements

ILiveOddsRequestProducerPrepareGetEventList(NullableDateTime, NullableDateTime, PreparationRequest, IEnumerableInt64, NullableBoolean)
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.PrepareGetEventMessages Method

VdrRequestProducerPrepareGetEventMessages Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventMessages(
    long event_id,
    long? from,
    long? to,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable Int64

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

to Nullable Int64

[Missing <param name="to"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsRequestProducerPrepareGetEventMessages(Int64, NullableInt64, NullableInt64, PreparationRequest, Boolean)
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.PrepareGetEventStatus Method

VdrRequestProducerPrepareGetEventStatus Method

Overload List
 | Name | Description
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Top
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.PrepareGetEventStatus(IEnumerable<Int64>, Nullable<DateTime>, PreparationRequest, Boolean) Method

VdrRequestProducerPrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationResult PrepareGetEventStatus(
    IEnumerable<long> event_ids,
    DateTime? from,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsRequestProducerPrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean)
See Also

Reference

VdrRequestProducer Class
PrepareGetEventStatus Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.PrepareGetEventStatus(Int64, Nullable<DateTime>, PreparationRequest, Boolean) Method

VdrRequestProducerPrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventStatus(
    long event_id,
    DateTime? from,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsRequestProducerPrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean)
See Also

Reference

VdrRequestProducer Class
PrepareGetEventStatus Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.PrepareGetScoreAndCardSummary Method

VdrRequestProducerPrepareGetScoreAndCardSummary Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetScoreAndCardSummary(
    long event_id,
    PreparationRequest prep
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareGetScoreAndCardSummary(Int64, PreparationRequest)
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.PrepareRacedayMetaRequest Method

VdrRequestProducerPrepareRacedayMetaRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationResult PrepareRacedayMetaRequest(
    IEnumerable<int> racedays,
    PreparationRequest prep
)

Parameters

racedays IEnumerable Int32

[Missing <param name="racedays"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareRacedayMetaRequest(IEnumerableInt32, PreparationRequest)
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.PrepareRegisterBetTypes Method

VdrRequestProducerPrepareRegisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareRegisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes,
    PreparationRequest prep
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareRegisterBetTypes(IEnumerableRegisterUnregisterBetType, PreparationRequest)
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.PrepareSubscribe Method

VdrRequestProducerPrepareSubscribe Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareSubscribe(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareSubscribe(IEnumerableInt64, PreparationRequest)
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.PrepareUnregisterBetTypes Method

VdrRequestProducerPrepareUnregisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareUnregisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes,
    PreparationRequest prep
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareUnregisterBetTypes(IEnumerableRegisterUnregisterBetType, PreparationRequest)
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.PrepareUnsubscribe Method

VdrRequestProducerPrepareUnsubscribe Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareUnsubscribe(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareUnsubscribe(IEnumerableInt64, PreparationRequest)
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.SendCurrentRequest Method

VdrRequestProducerSendCurrentRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual long SendCurrentRequest(
    long? virtual_game_id,
    IEnumerable<long> event_ids
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Implements

ILiveOddsRequestProducerSendCurrentRequest(NullableInt64, IEnumerableInt64)
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer Events

The VdrRequestProducer type exposes the following members.

Events
 | Name | Description
Public event | OnRequestAdded |
Top
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VdrRequestProducer.OnRequestAdded Event

VdrRequestProducerOnRequestAdded Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VdrRequestProducer.OnRequestAdded"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event RequestProducerDelegatesRequestDelegate OnRequestAdded

Value

RequestProducerDelegatesRequestDelegate

Implements

ILiveOddsRequestProducerOnRequestAdded
See Also

Reference

VdrRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalVfcEntityFactory

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class VfcEntityFactory : IFakeBetStopFactoryWithOutrights,
    IFakeBetStopFactory

The VfcEntityFactory type exposes the following members.

Constructors
 | Name | Description
Public method | VfcEntityFactory | Initializes a new instance of the VfcEntityFactory class
Top
Methods
 | Name | Description
Public method | BuildAlive |
Public method | BuildBetCancel |
Public method | BuildBetClear |
Public method | BuildBetStart |
Public method | BuildBetStop |
Public method | BuildFakeBetStop |
Public method | BuildFakeOutrightBetStop |
Public method | buildMeta |
Public method | BuildOddsChange |
Public method | BuildOutrightBetCancel |
Public method | BuildOutrightBetClear |
Public method | BuildOutrightBetStart |
Public method | BuildOutrightBetStop |
Public method | BuildOutrightOddsChange |
Public method | BuildReplyStartEnd |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory Constructor

Initializes a new instance of the VfcEntityFactory class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public VfcEntityFactory(
    ITimeKeeper server_timekeeper
)

Parameters

server_timekeeper ITimeKeeper

[Missing <param name="server_timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.#ctor(Sportradar.SDK.Common.Interfaces.ITimeKeeper)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory Methods

The VfcEntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildAlive |
Public method | BuildBetCancel |
Public method | BuildBetClear |
Public method | BuildBetStart |
Public method | BuildBetStop |
Public method | BuildFakeBetStop |
Public method | BuildFakeOutrightBetStop |
Public method | buildMeta |
Public method | BuildOddsChange |
Public method | BuildOutrightBetCancel |
Public method | BuildOutrightBetClear |
Public method | BuildOutrightBetStart |
Public method | BuildOutrightBetStop |
Public method | BuildOutrightOddsChange |
Public method | BuildReplyStartEnd |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildAlive Method

VfcEntityFactoryBuildAlive Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public AliveWithOutrights BuildAlive(
    BetradarLiveOdds liveOdds
)

Parameters

liveOdds BetradarLiveOdds

[Missing <param name="liveOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

AliveWithOutrights

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildBetCancel Method

VfcEntityFactoryBuildBetCancel Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetCancel BuildBetCancel(
    BetradarLiveOdds record
)

Parameters

record BetradarLiveOdds

[Missing <param name="record"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

BetCancel

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildBetClear Method

VfcEntityFactoryBuildBetClear Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetClear BuildBetClear(
    BetradarLiveOdds record
)

Parameters

record BetradarLiveOdds

[Missing <param name="record"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

BetClear

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildBetStart Method

VfcEntityFactoryBuildBetStart Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStart BuildBetStart(
    BetradarLiveOdds record
)

Parameters

record BetradarLiveOdds

[Missing <param name="record"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

BetStart

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildBetStop Method

VfcEntityFactoryBuildBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStop BuildBetStop(
    BetradarLiveOdds record
)

Parameters

record BetradarLiveOdds

[Missing <param name="record"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

BetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildFakeBetStop Method

VfcEntityFactoryBuildFakeBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildFakeBetStop(System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStop BuildFakeBetStop(
    long event_id
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildFakeBetStop(System.Int64)"]

Return Value

BetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildFakeBetStop(System.Int64)"]

Implements

IFakeBetStopFactoryBuildFakeBetStop(Int64)
See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildFakeOutrightBetStop Method

VfcEntityFactoryBuildFakeOutrightBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildFakeOutrightBetStop(System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightBetStop BuildFakeOutrightBetStop(
    long outright_id
)

Parameters

outright_id Int64

[Missing <param name="outright_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildFakeOutrightBetStop(System.Int64)"]

Return Value

OutrightBetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildFakeOutrightBetStop(System.Int64)"]

Implements

IFakeBetStopFactoryWithOutrightsBuildFakeOutrightBetStop(Int64)
See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.buildMeta Method

VfcEntityFactorybuildMeta Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.buildMeta(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MetaInfo buildMeta(
    BetradarLiveOdds liveOdds
)

Parameters

liveOdds BetradarLiveOdds

[Missing <param name="liveOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.buildMeta(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

MetaInfo

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.buildMeta(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildOddsChange Method

VfcEntityFactoryBuildOddsChange Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsChange BuildOddsChange(
    BetradarLiveOdds record
)

Parameters

record BetradarLiveOdds

[Missing <param name="record"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

OddsChange

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildOutrightBetCancel Method

VfcEntityFactoryBuildOutrightBetCancel Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightBetCancel BuildOutrightBetCancel(
    BetradarLiveOdds record
)

Parameters

record BetradarLiveOdds

[Missing <param name="record"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

OutrightBetCancel

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildOutrightBetClear Method

VfcEntityFactoryBuildOutrightBetClear Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightBetClear BuildOutrightBetClear(
    BetradarLiveOdds record
)

Parameters

record BetradarLiveOdds

[Missing <param name="record"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

OutrightBetClear

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildOutrightBetStart Method

VfcEntityFactoryBuildOutrightBetStart Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightBetStart BuildOutrightBetStart(
    BetradarLiveOdds liveOdds
)

Parameters

liveOdds BetradarLiveOdds

[Missing <param name="liveOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

OutrightBetStart

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildOutrightBetStop Method

VfcEntityFactoryBuildOutrightBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightBetStop BuildOutrightBetStop(
    BetradarLiveOdds record
)

Parameters

record BetradarLiveOdds

[Missing <param name="record"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

OutrightBetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildOutrightOddsChange Method

VfcEntityFactoryBuildOutrightOddsChange Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightOddsChange BuildOutrightOddsChange(
    BetradarLiveOdds liveOdds
)

Parameters

liveOdds BetradarLiveOdds

[Missing <param name="liveOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

OutrightOddsChange

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildOutrightOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcEntityFactory.BuildReplyStartEnd Method

VfcEntityFactoryBuildReplyStartEnd Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ReplyStartEnd BuildReplyStartEnd(
    BetradarLiveOdds record
)

Parameters

record BetradarLiveOdds

[Missing <param name="record"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

Return Value

ReplyStartEnd

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory.BuildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vfc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VfcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalVfcRequestProducer

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class VfcRequestProducer : ILiveOddsWithOutrightsRequestProducer,
    ILiveOddsRequestProducer

The VfcRequestProducer type exposes the following members.

Constructors
 | Name | Description
Public method | VfcRequestProducer | Initializes a new instance of the VfcRequestProducer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PrepareBook |
Public method | PrepareGetEventList |
Public method | PrepareGetEventMessages |
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetOutrightList |
Public method | PrepareGetOutrightStatus |
Public method | PrepareGetScoreAndCardSummary |
Public method | PrepareRacedayMetaRequest |
Public method | PrepareRegisterBetTypes |
Public method | PrepareSubscribe |
Public method | PrepareUnregisterBetTypes |
Public method | PrepareUnsubscribe |
Public method | SendCurrentRequest(NullableInt64, IEnumerableInt64) |
Public method | SendCurrentRequest(NullableInt64, IEnumerableInt64, IEnumerableInt64) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | OnRequestAdded |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer Constructor

Initializes a new instance of the VfcRequestProducer class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public VfcRequestProducer(
    ISdkLogger sdk_logger,
    IProtocolProvider proto_provider,
    SdkConfigurationLiveOdds local_config
)

Parameters

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

proto_provider IProtocolProvider

[Missing <param name="proto_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

local_config SdkConfigurationLiveOdds

[Missing <param name="local_config"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer Methods

The VfcRequestProducer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PrepareBook |
Public method | PrepareGetEventList |
Public method | PrepareGetEventMessages |
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetOutrightList |
Public method | PrepareGetOutrightStatus |
Public method | PrepareGetScoreAndCardSummary |
Public method | PrepareRacedayMetaRequest |
Public method | PrepareRegisterBetTypes |
Public method | PrepareSubscribe |
Public method | PrepareUnregisterBetTypes |
Public method | PrepareUnsubscribe |
Public method | SendCurrentRequest(NullableInt64, IEnumerableInt64) |
Public method | SendCurrentRequest(NullableInt64, IEnumerableInt64, IEnumerableInt64) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareBook Method

VfcRequestProducerPrepareBook Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareBook(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareBook(IEnumerableInt64, PreparationRequest)
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareGetEventList Method

VfcRequestProducerPrepareGetEventList Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventList(
    DateTime? from,
    DateTime? to,
    PreparationRequest prep,
    IEnumerable<long> event_ids = null,
    bool? include_available = null
)

Parameters

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

to Nullable DateTime

[Missing <param name="to"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

event_ids IEnumerable Int64 (Optional)

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

include_available Nullable Boolean (Optional)

[Missing <param name="include_available"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Implements

ILiveOddsRequestProducerPrepareGetEventList(NullableDateTime, NullableDateTime, PreparationRequest, IEnumerableInt64, NullableBoolean)
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareGetEventMessages Method

VfcRequestProducerPrepareGetEventMessages Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventMessages(
    long event_id,
    long? from,
    long? to,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable Int64

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

to Nullable Int64

[Missing <param name="to"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsRequestProducerPrepareGetEventMessages(Int64, NullableInt64, NullableInt64, PreparationRequest, Boolean)
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareGetEventStatus Method

VfcRequestProducerPrepareGetEventStatus Method

Overload List
 | Name | Description
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Top
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareGetEventStatus(IEnumerable<Int64>, Nullable<DateTime>, PreparationRequest, Boolean) Method

VfcRequestProducerPrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventStatus(
    IEnumerable<long> event_ids,
    DateTime? from,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsRequestProducerPrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean)
See Also

Reference

VfcRequestProducer Class
PrepareGetEventStatus Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareGetEventStatus(Int64, Nullable<DateTime>, PreparationRequest, Boolean) Method

VfcRequestProducerPrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventStatus(
    long event_id,
    DateTime? from,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsRequestProducerPrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean)
See Also

Reference

VfcRequestProducer Class
PrepareGetEventStatus Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareGetOutrightList Method

VfcRequestProducerPrepareGetOutrightList Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetOutrightList(Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetOutrightList(
    PreparationRequest prep,
    IEnumerable<long> outright_ids = null,
    bool? include_available = null
)

Parameters

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetOutrightList(Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

outright_ids IEnumerable Int64 (Optional)

[Missing <param name="outright_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetOutrightList(Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

include_available Nullable Boolean (Optional)

[Missing <param name="include_available"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetOutrightList(Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetOutrightList(Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Implements

ILiveOddsWithOutrightsRequestProducerPrepareGetOutrightList(PreparationRequest, IEnumerableInt64, NullableBoolean)
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareGetOutrightStatus Method

VfcRequestProducerPrepareGetOutrightStatus Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetOutrightStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationResult PrepareGetOutrightStatus(
    IEnumerable<long> outright_ids,
    DateTime? from,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

outright_ids IEnumerable Int64

[Missing <param name="outright_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetOutrightStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetOutrightStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetOutrightStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetOutrightStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetOutrightStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsWithOutrightsRequestProducerPrepareGetOutrightStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean)
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareGetScoreAndCardSummary Method

VfcRequestProducerPrepareGetScoreAndCardSummary Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetScoreAndCardSummary(
    long event_id,
    PreparationRequest prep
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareGetScoreAndCardSummary(Int64, PreparationRequest)
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareRacedayMetaRequest Method

VfcRequestProducerPrepareRacedayMetaRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationResult PrepareRacedayMetaRequest(
    IEnumerable<int> racedays,
    PreparationRequest prep
)

Parameters

racedays IEnumerable Int32

[Missing <param name="racedays"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareRacedayMetaRequest(IEnumerableInt32, PreparationRequest)
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareRegisterBetTypes Method

VfcRequestProducerPrepareRegisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareRegisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes,
    PreparationRequest prep
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareRegisterBetTypes(IEnumerableRegisterUnregisterBetType, PreparationRequest)
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareSubscribe Method

VfcRequestProducerPrepareSubscribe Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareSubscribe(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareSubscribe(IEnumerableInt64, PreparationRequest)
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareUnregisterBetTypes Method

VfcRequestProducerPrepareUnregisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareUnregisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes,
    PreparationRequest prep
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareUnregisterBetTypes(IEnumerableRegisterUnregisterBetType, PreparationRequest)
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.PrepareUnsubscribe Method

VfcRequestProducerPrepareUnsubscribe Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareUnsubscribe(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareUnsubscribe(IEnumerableInt64, PreparationRequest)
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.SendCurrentRequest Method

VfcRequestProducerSendCurrentRequest Method

Overload List
 | Name | Description
Public method | SendCurrentRequest(NullableInt64, IEnumerableInt64) |
Public method | SendCurrentRequest(NullableInt64, IEnumerableInt64, IEnumerableInt64) |
Top
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.SendCurrentRequest(Nullable<Int64>, IEnumerable<Int64>) Method

VfcRequestProducerSendCurrentRequest(NullableInt64, IEnumerableInt64) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual long SendCurrentRequest(
    long? virtual_game_id,
    IEnumerable<long> event_ids
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Implements

ILiveOddsRequestProducerSendCurrentRequest(NullableInt64, IEnumerableInt64)
See Also

Reference

VfcRequestProducer Class
SendCurrentRequest Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.SendCurrentRequest(Nullable<Int64>, IEnumerable<Int64>, IEnumerable<Int64>) Method

VfcRequestProducerSendCurrentRequest(NullableInt64, IEnumerableInt64, IEnumerableInt64) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long SendCurrentRequest(
    long? virtual_game_id,
    IEnumerable<long> event_ids,
    IEnumerable<long> outright_ids
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

outright_ids IEnumerable Int64

[Missing <param name="outright_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Implements

ILiveOddsWithOutrightsRequestProducerSendCurrentRequest(NullableInt64, IEnumerableInt64, IEnumerableInt64)
See Also

Reference

VfcRequestProducer Class
SendCurrentRequest Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer Events

The VfcRequestProducer type exposes the following members.

Events
 | Name | Description
Public event | OnRequestAdded |
Top
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VfcRequestProducer.OnRequestAdded Event

VfcRequestProducerOnRequestAdded Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcRequestProducer.OnRequestAdded"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event RequestProducerDelegatesRequestDelegate OnRequestAdded

Value

RequestProducerDelegatesRequestDelegate

Implements

ILiveOddsRequestProducerOnRequestAdded
See Also

Reference

VfcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalVhcEntityFactory

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class VhcEntityFactory : IFakeBetStopFactory

The VhcEntityFactory type exposes the following members.

Constructors
 | Name | Description
Public method | VhcEntityFactory | Initializes a new instance of the VhcEntityFactory class
Top
Methods
 | Name | Description
Public method | buildAlive |
Public method | buildBetCancel |
Public method | buildBetClear |
Public method | buildBetStart |
Public method | buildBetStop |
Public method | BuildFakeBetStop |
Public method | buildMetaInfo |
Public method | buildOddsChange |
Public method | buildRaceResult |
Public method | buildReplyStartEnd |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory Constructor

Initializes a new instance of the VhcEntityFactory class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public VhcEntityFactory(
    ITimeKeeper server_timekeeper
)

Parameters

server_timekeeper ITimeKeeper

[Missing <param name="server_timekeeper"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.#ctor(Sportradar.SDK.Common.Interfaces.ITimeKeeper)"]

See Also

Reference

VhcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory Methods

The VhcEntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | buildAlive |
Public method | buildBetCancel |
Public method | buildBetClear |
Public method | buildBetStart |
Public method | buildBetStop |
Public method | BuildFakeBetStop |
Public method | buildMetaInfo |
Public method | buildOddsChange |
Public method | buildRaceResult |
Public method | buildReplyStartEnd |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

VhcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory.buildAlive Method

VhcEntityFactorybuildAlive Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Alive buildAlive(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Return Value

Alive

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildAlive(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VhcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory.buildBetCancel Method

VhcEntityFactorybuildBetCancel Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetCancel buildBetCancel(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Return Value

BetCancel

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildBetCancel(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VhcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory.buildBetClear Method

VhcEntityFactorybuildBetClear Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetClear buildBetClear(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Return Value

BetClear

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildBetClear(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VhcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory.buildBetStart Method

VhcEntityFactorybuildBetStart Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStart buildBetStart(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Return Value

BetStart

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildBetStart(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VhcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory.buildBetStop Method

VhcEntityFactorybuildBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStop buildBetStop(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Return Value

BetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildBetStop(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VhcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory.BuildFakeBetStop Method

VhcEntityFactoryBuildFakeBetStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.BuildFakeBetStop(System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStop BuildFakeBetStop(
    long match_id
)

Parameters

match_id Int64

[Missing <param name="match_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.BuildFakeBetStop(System.Int64)"]

Return Value

BetStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.BuildFakeBetStop(System.Int64)"]

Implements

IFakeBetStopFactoryBuildFakeBetStop(Int64)
See Also

Reference

VhcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory.buildMetaInfo Method

VhcEntityFactorybuildMetaInfo Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildMetaInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MetaInfo buildMetaInfo(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildMetaInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Return Value

MetaInfo

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildMetaInfo(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VhcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory.buildOddsChange Method

VhcEntityFactorybuildOddsChange Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsChange buildOddsChange(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Return Value

OddsChange

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildOddsChange(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VhcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory.buildRaceResult Method

VhcEntityFactorybuildRaceResult Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildRaceResult(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceResult buildRaceResult(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildRaceResult(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Return Value

RaceResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildRaceResult(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VhcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcEntityFactory.buildReplyStartEnd Method

VhcEntityFactorybuildReplyStartEnd Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ReplyStartEnd buildReplyStartEnd(
    BetradarLiveOdds input
)

Parameters

input BetradarLiveOdds

[Missing <param name="input"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

Return Value

ReplyStartEnd

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcEntityFactory.buildReplyStartEnd(Sportradar.SDK.ProtocolProviders.ProtocolUnits.Vhc.Incoming.BetradarLiveOdds)"]

See Also

Reference

VhcEntityFactory Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalVhcRequestProducer

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class VhcRequestProducer : ILiveOddsRequestProducer

The VhcRequestProducer type exposes the following members.

Constructors
 | Name | Description
Public method | VhcRequestProducer | Initializes a new instance of the VhcRequestProducer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FillRequest |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PrepareBook |
Public method | PrepareGetEventList |
Public method | PrepareGetEventMessages |
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetScoreAndCardSummary |
Public method | PrepareRacedayMetaRequest |
Public method | PrepareRegisterBetTypes |
Public method | PrepareSubscribe |
Public method | PrepareUnregisterBetTypes |
Public method | PrepareUnsubscribe |
Public method | SendCurrentRequest |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | OnRequestAdded |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer Constructor

Initializes a new instance of the VhcRequestProducer class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public VhcRequestProducer(
    ISdkLogger sdk_logger,
    IProtocolProvider proto_provider,
    SdkConfigurationLiveOdds local_config
)

Parameters

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

proto_provider IProtocolProvider

[Missing <param name="proto_provider"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

local_config SdkConfigurationLiveOdds

[Missing <param name="local_config"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.#ctor(Sportradar.SDK.Services.SdkLogger.ISdkLogger,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer Methods

The VhcRequestProducer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FillRequest |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PrepareBook |
Public method | PrepareGetEventList |
Public method | PrepareGetEventMessages |
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetScoreAndCardSummary |
Public method | PrepareRacedayMetaRequest |
Public method | PrepareRegisterBetTypes |
Public method | PrepareSubscribe |
Public method | PrepareUnregisterBetTypes |
Public method | PrepareUnsubscribe |
Public method | SendCurrentRequest |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.FillRequest Method

VhcRequestProducerFillRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.FillRequest(Sportradar.SDK.Common.Interfaces.IProtocolRequest,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationResult FillRequest(
    IProtocolRequest req,
    PreparationRequest prep
)

Parameters

req IProtocolRequest

[Missing <param name="req"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.FillRequest(Sportradar.SDK.Common.Interfaces.IProtocolRequest,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.FillRequest(Sportradar.SDK.Common.Interfaces.IProtocolRequest,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.FillRequest(Sportradar.SDK.Common.Interfaces.IProtocolRequest,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.PrepareBook Method

VhcRequestProducerPrepareBook Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareBook(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareBook(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareBook(IEnumerableInt64, PreparationRequest)
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.PrepareGetEventList Method

VhcRequestProducerPrepareGetEventList Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventList(
    DateTime? from,
    DateTime? to,
    PreparationRequest prep,
    IEnumerable<long> event_ids = null,
    bool? include_available = null
)

Parameters

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

to Nullable DateTime

[Missing <param name="to"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

event_ids IEnumerable Int64 (Optional)

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

include_available Nullable Boolean (Optional)

[Missing <param name="include_available"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventList(System.Nullable{System.DateTime},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.Boolean})"]

Implements

ILiveOddsRequestProducerPrepareGetEventList(NullableDateTime, NullableDateTime, PreparationRequest, IEnumerableInt64, NullableBoolean)
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.PrepareGetEventMessages Method

VhcRequestProducerPrepareGetEventMessages Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventMessages(
    long event_id,
    long? from,
    long? to,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable Int64

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

to Nullable Int64

[Missing <param name="to"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventMessages(System.Int64,System.Nullable{System.Int64},System.Nullable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsRequestProducerPrepareGetEventMessages(Int64, NullableInt64, NullableInt64, PreparationRequest, Boolean)
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.PrepareGetEventStatus Method

VhcRequestProducerPrepareGetEventStatus Method

Overload List
 | Name | Description
Public method | PrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) |
Public method | PrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) |
Top
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.PrepareGetEventStatus(IEnumerable<Int64>, Nullable<DateTime>, PreparationRequest, Boolean) Method

VhcRequestProducerPrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationResult PrepareGetEventStatus(
    IEnumerable<long> event_ids,
    DateTime? from,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventStatus(System.Collections.Generic.IEnumerable{System.Int64},System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsRequestProducerPrepareGetEventStatus(IEnumerableInt64, NullableDateTime, PreparationRequest, Boolean)
See Also

Reference

VhcRequestProducer Class
PrepareGetEventStatus Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.PrepareGetEventStatus(Int64, Nullable<DateTime>, PreparationRequest, Boolean) Method

VhcRequestProducerPrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetEventStatus(
    long event_id,
    DateTime? from,
    PreparationRequest prep,
    bool add_user_request
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

from Nullable DateTime

[Missing <param name="from"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

add_user_request Boolean

[Missing <param name="add_user_request"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetEventStatus(System.Int64,System.Nullable{System.DateTime},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest,System.Boolean)"]

Implements

ILiveOddsRequestProducerPrepareGetEventStatus(Int64, NullableDateTime, PreparationRequest, Boolean)
See Also

Reference

VhcRequestProducer Class
PrepareGetEventStatus Overload
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.PrepareGetScoreAndCardSummary Method

VhcRequestProducerPrepareGetScoreAndCardSummary Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareGetScoreAndCardSummary(
    long event_id,
    PreparationRequest prep
)

Parameters

event_id Int64

[Missing <param name="event_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareGetScoreAndCardSummary(System.Int64,Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareGetScoreAndCardSummary(Int64, PreparationRequest)
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.PrepareRacedayMetaRequest Method

VhcRequestProducerPrepareRacedayMetaRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PreparationResult PrepareRacedayMetaRequest(
    IEnumerable<int> racedays,
    PreparationRequest prep
)

Parameters

racedays IEnumerable Int32

[Missing <param name="racedays"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareRacedayMetaRequest(System.Collections.Generic.IEnumerable{System.Int32},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareRacedayMetaRequest(IEnumerableInt32, PreparationRequest)
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.PrepareRegisterBetTypes Method

VhcRequestProducerPrepareRegisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareRegisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes,
    PreparationRequest prep
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareRegisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareRegisterBetTypes(IEnumerableRegisterUnregisterBetType, PreparationRequest)
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.PrepareSubscribe Method

VhcRequestProducerPrepareSubscribe Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareSubscribe(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareSubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareSubscribe(IEnumerableInt64, PreparationRequest)
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.PrepareUnregisterBetTypes Method

VhcRequestProducerPrepareUnregisterBetTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareUnregisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes,
    PreparationRequest prep
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType

[Missing <param name="betTypes"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareUnregisterBetTypes(System.Collections.Generic.IEnumerable{Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.RegisterUnregisterBetType},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareUnregisterBetTypes(IEnumerableRegisterUnregisterBetType, PreparationRequest)
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.PrepareUnsubscribe Method

VhcRequestProducerPrepareUnsubscribe Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual PreparationResult PrepareUnsubscribe(
    IEnumerable<long> event_ids,
    PreparationRequest prep
)

Parameters

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

prep PreparationRequest

[Missing <param name="prep"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Return Value

PreparationResult

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.PrepareUnsubscribe(System.Collections.Generic.IEnumerable{System.Int64},Sportradar.SDK.FeedProviders.LiveOdds.Internal.PreparationRequest)"]

Implements

ILiveOddsRequestProducerPrepareUnsubscribe(IEnumerableInt64, PreparationRequest)
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.SendCurrentRequest Method

VhcRequestProducerSendCurrentRequest Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual long SendCurrentRequest(
    long? virtual_game_id,
    IEnumerable<long> event_ids
)

Parameters

virtual_game_id Nullable Int64

[Missing <param name="virtual_game_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

event_ids IEnumerable Int64

[Missing <param name="event_ids"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Return Value

Int64

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.SendCurrentRequest(System.Nullable{System.Int64},System.Collections.Generic.IEnumerable{System.Int64})"]

Implements

ILiveOddsRequestProducerSendCurrentRequest(NullableInt64, IEnumerableInt64)
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer Events

The VhcRequestProducer type exposes the following members.

Events
 | Name | Description
Public event | OnRequestAdded |
Top
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


VhcRequestProducer.OnRequestAdded Event

VhcRequestProducerOnRequestAdded Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveOdds.Internal.VhcRequestProducer.OnRequestAdded"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event RequestProducerDelegatesRequestDelegate OnRequestAdded

Value

RequestProducerDelegatesRequestDelegate

Implements

ILiveOddsRequestProducerOnRequestAdded
See Also

Reference

VhcRequestProducer Class
Sportradar.SDK.FeedProviders.LiveOdds.Internal Namespace


Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces Namespace

Interfaces
 | Interface | Description
Public interface | ILiveOddsWithOutrightsDispatcher | Defines a contract implemented by classes used to dispatch outright related messages to the user


ILiveOddsWithOutrightsDispatcher Interface

Defines a contract implemented by classes used to dispatch outright related messages to the user

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOddsWithOutrightsDispatcher : ILiveOddsFeedDispatcher,
    IFeedDispatcher

The ILiveOddsWithOutrightsDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType | (Inherited from IFeedDispatcher)
Top
Methods
 | Name | Description
Public method | DispatchEntity | Dispatches the entity. (Inherited from ILiveOddsFeedDispatcher)
Public method | DispatchParseError | DispatchParseError (Inherited from ILiveOddsFeedDispatcher)
Public method | DispatchUserRequest | Dispatches the user request. (Inherited from ILiveOddsFeedDispatcher)
Top
Events
 | Name | Description
Public event | AfterMessageDispatched | Occurs when [after message dispatched]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnAlive | Occurs when [on alive received]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnAliveWithOutrights | Occurs when [AliveWithOutrights with outrights received].
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnOutrightBetCancel | Occurs when [OutrightBetCancel is received]
Public event | OnOutrightBetClear | Occurs when [OutrightBetClear is received]
Public event | OnOutrightBetStart | Occurs when [OutrightBetStart is received]
Public event | OnOutrightBetStop | Occurs when [OutrightBetStop is received]
Public event | OnOutrightOddsChange | Occurs when [OutrightOddsChange is received]
Public event | OnOutrightStatus | Occurs when outright status messages are received
Public event | OnRaceResult | Occurs when [on race result]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnScoreCard | Occurs when [on score card received]. (Inherited from ILiveOddsFeedDispatcher)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces Namespace


ILiveOddsWithOutrightsDispatcher Properties

The ILiveOddsWithOutrightsDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | ProviderType | (Inherited from IFeedDispatcher)
Top
See Also

Reference

ILiveOddsWithOutrightsDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces Namespace


ILiveOddsWithOutrightsDispatcher Methods

The ILiveOddsWithOutrightsDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | DispatchEntity | Dispatches the entity. (Inherited from ILiveOddsFeedDispatcher)
Public method | DispatchParseError | DispatchParseError (Inherited from ILiveOddsFeedDispatcher)
Public method | DispatchUserRequest | Dispatches the user request. (Inherited from ILiveOddsFeedDispatcher)
Top
See Also

Reference

ILiveOddsWithOutrightsDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces Namespace


ILiveOddsWithOutrightsDispatcher Events

The ILiveOddsWithOutrightsDispatcher type exposes the following members.

Events
 | Name | Description
Public event | AfterMessageDispatched | Occurs when [after message dispatched]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnAlive | Occurs when [on alive received]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnAliveWithOutrights | Occurs when [AliveWithOutrights with outrights received].
Public event | OnBetCancel | Occurs when [on bet cancel]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnBetCancelUndo | Occurs when [on bet cancel undone]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnBetClear | Occurs when [on bet clear]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnBetClearRollback | Occurs when [on bet clear rollback]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnBetStart | Occurs when [on bet start]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnBetStop | Occurs when [on bet stop]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnConnectionStable | Occurs when connection stable. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnConnectionUnstable | Occurs when connection unstable. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnEventMessages | Occurs when [on match messages received]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnEventStatus | Occurs when [on match status received]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnFeedError | Occurs when [on feed error]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnMetaInfo | Occurs when [on meta info received]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnOddsChange | Occurs when [on odds change]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnOutrightBetCancel | Occurs when [OutrightBetCancel is received]
Public event | OnOutrightBetClear | Occurs when [OutrightBetClear is received]
Public event | OnOutrightBetStart | Occurs when [OutrightBetStart is received]
Public event | OnOutrightBetStop | Occurs when [OutrightBetStop is received]
Public event | OnOutrightOddsChange | Occurs when [OutrightOddsChange is received]
Public event | OnOutrightStatus | Occurs when outright status messages are received
Public event | OnRaceResult | Occurs when [on race result]. (Inherited from ILiveOddsFeedDispatcher)
Public event | OnScoreCard | Occurs when [on score card received]. (Inherited from ILiveOddsFeedDispatcher)
Top
See Also

Reference

ILiveOddsWithOutrightsDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces Namespace


ILiveOddsWithOutrightsDispatcher.OnAliveWithOutrights Event

ILiveOddsWithOutrightsDispatcherOnAliveWithOutrights Event

Occurs when [AliveWithOutrights with outrights received].

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<AliveWithOutrightsEventArgs> OnAliveWithOutrights

Value

EventHandler AliveWithOutrightsEventArgs
See Also

Reference

ILiveOddsWithOutrightsDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces Namespace


ILiveOddsWithOutrightsDispatcher.OnOutrightBetCancel Event

ILiveOddsWithOutrightsDispatcherOnOutrightBetCancel Event

Occurs when [OutrightBetCancel is received]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OutrightBetCancelEventArgs> OnOutrightBetCancel

Value

EventHandler OutrightBetCancelEventArgs
See Also

Reference

ILiveOddsWithOutrightsDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces Namespace


ILiveOddsWithOutrightsDispatcher.OnOutrightBetClear Event

ILiveOddsWithOutrightsDispatcherOnOutrightBetClear Event

Occurs when [OutrightBetClear is received]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OutrightBetClearEventArgs> OnOutrightBetClear

Value

EventHandler OutrightBetClearEventArgs
See Also

Reference

ILiveOddsWithOutrightsDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces Namespace


ILiveOddsWithOutrightsDispatcher.OnOutrightBetStart Event

ILiveOddsWithOutrightsDispatcherOnOutrightBetStart Event

Occurs when [OutrightBetStart is received]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OutrightBetStartEventArgs> OnOutrightBetStart

Value

EventHandler OutrightBetStartEventArgs
See Also

Reference

ILiveOddsWithOutrightsDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces Namespace


ILiveOddsWithOutrightsDispatcher.OnOutrightBetStop Event

ILiveOddsWithOutrightsDispatcherOnOutrightBetStop Event

Occurs when [OutrightBetStop is received]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OutrightBetStopEventArgs> OnOutrightBetStop

Value

EventHandler OutrightBetStopEventArgs
See Also

Reference

ILiveOddsWithOutrightsDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces Namespace


ILiveOddsWithOutrightsDispatcher.OnOutrightOddsChange Event

ILiveOddsWithOutrightsDispatcherOnOutrightOddsChange Event

Occurs when [OutrightOddsChange is received]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OutrightOddsChangeEventArgs> OnOutrightOddsChange

Value

EventHandler OutrightOddsChangeEventArgs
See Also

Reference

ILiveOddsWithOutrightsDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces Namespace


ILiveOddsWithOutrightsDispatcher.OnOutrightStatus Event

ILiveOddsWithOutrightsDispatcherOnOutrightStatus Event

Occurs when outright status messages are received

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<EventDataReceivedEventArgs> OnOutrightStatus

Value

EventHandler EventDataReceivedEventArgs
See Also

Reference

ILiveOddsWithOutrightsDispatcher Interface
Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces Namespace


Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace

Classes
 | Class | Description
Public class | BaseScoreCardEntry | Score/Card summary by time. Used for live reporting of results/cards and final results (fulltime/halftime). The same card and the same score can be sent several times; this is used to update information, for example player or time. Serves as a base class for CardEntry and ScoreEntry.
Public class | BetPal | BetPal info object
Public class | Card | Card type (yellow or red)
Public class | CardEntry | Card summary by time that is updated live.
Public class | CoveredFromType | Indicates whether the match is being covered from a television feed or the scout is at the match venue
Public class | ExtraMatchInfo | Additional information about period lengths, number of sets played, etc., that is included with MatchInfo. Other information might be added later on, so a client should be able to handle it.
Public class | LiveOddsMetaData | MetaInfoDataContainer for match oriented feeds
 | MatchHeader | Basic match information.
Public class | MatchHeaderInfo | Combined MatchHeader and MatchInfo information.
Public class | MatchInfo | Match information containing the date and time of the match, sport, category, tournament, teams and what TV-channels this match is broadcasted on.
Public class | OddsScoreType | Score type (full time, half time, live, etc.)
Public class | RegisterUnregisterBetType | Supports activation of the whole match as well as activation of odds types and nested odds fields for a particular match.
Public class | ScoreCardSummary | Used for live reporting of results/cards and final results (e.g. fulltime, halftime, overtime).
Public class | ScoreEntry | Score summary by time that is updated live or when final results after full/half/over time are known.
Interfaces
 | Interface | Description
Public interface | ILiveOdds | Live odds client interface.
Public interface | ILiveOddsTestManager | Enables replay of matches on LiveOdds test server. Wait for OnConnectionStable before using it


BaseScoreCardEntry Class

Score/Card summary by time. Used for live reporting of results/cards and final results (fulltime/halftime). The same card and the same score can be sent several times; this is used to update information, for example player or time. Serves as a base class for CardEntry and ScoreEntry.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsBaseScoreCardEntry
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsCardEntry
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsScoreEntry

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class BaseScoreCardEntry

The BaseScoreCardEntry type exposes the following members.

Properties
 | Name | Description
Public property | AffectedPlayer | Player that scored or received a card.
Public property | AffectedTeam | Team that scored or received a card.
Public property | Cancelled | True if a particular score or card has been cancelled. After this a new message with the correct score will be sent for score cancelling.
Public property | Id | Id that uniquely identifies each score and card. For score types "ht", "ft", "ot" and "pen" Id will not be set.
Public property | PlayerId | Id of player that scored or received a card.
Public property | Time | Match time in minutes when the goal/card occurred. When no time is known it is set to “-1", and the AffectedPlayer property is empty.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BaseScoreCardEntry Properties

The BaseScoreCardEntry type exposes the following members.

Properties
 | Name | Description
Public property | AffectedPlayer | Player that scored or received a card.
Public property | AffectedTeam | Team that scored or received a card.
Public property | Cancelled | True if a particular score or card has been cancelled. After this a new message with the correct score will be sent for score cancelling.
Public property | Id | Id that uniquely identifies each score and card. For score types "ht", "ft", "ot" and "pen" Id will not be set.
Public property | PlayerId | Id of player that scored or received a card.
Public property | Time | Match time in minutes when the goal/card occurred. When no time is known it is set to “-1", and the AffectedPlayer property is empty.
Top
See Also

Reference

BaseScoreCardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BaseScoreCardEntry.AffectedPlayer Property

BaseScoreCardEntryAffectedPlayer Property

Player that scored or received a card.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AffectedPlayer { get; }

Property Value

String
See Also

Reference

BaseScoreCardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BaseScoreCardEntry.AffectedTeam Property

BaseScoreCardEntryAffectedTeam Property

Team that scored or received a card.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team AffectedTeam { get; }

Property Value

Team
See Also

Reference

BaseScoreCardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BaseScoreCardEntry.Cancelled Property

BaseScoreCardEntryCancelled Property

True if a particular score or card has been cancelled. After this a new message with the correct score will be sent for score cancelling.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Cancelled { get; }

Property Value

Boolean
See Also

Reference

BaseScoreCardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BaseScoreCardEntry.Id Property

BaseScoreCardEntryId Property

Id that uniquely identifies each score and card. For score types "ht", "ft", "ot" and "pen" Id will not be set.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Id { get; }

Property Value

Nullable Int64
See Also

Reference

BaseScoreCardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BaseScoreCardEntry.PlayerId Property

BaseScoreCardEntryPlayerId Property

Id of player that scored or received a card.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? PlayerId { get; }

Property Value

Nullable Int32
See Also

Reference

BaseScoreCardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BaseScoreCardEntry.Time Property

BaseScoreCardEntryTime Property

Match time in minutes when the goal/card occurred. When no time is known it is set to “-1", and the AffectedPlayer property is empty.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long Time { get; }

Property Value

Int64
See Also

Reference

BaseScoreCardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BaseScoreCardEntry Methods

The BaseScoreCardEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

BaseScoreCardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BaseScoreCardEntry.ToString Method

BaseScoreCardEntryToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

BaseScoreCardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BetPal Class

BetPal info object
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsBetPal

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class BetPal

The BetPal type exposes the following members.

Constructors
 | Name | Description
Public method | BetPal | Initializes a new instance of the BetPal class
Top
Properties
 | Name | Description
Public property | Type | Type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BetPal Constructor

Initializes a new instance of the BetPal class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetPal()
See Also

Reference

BetPal Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BetPal Properties

The BetPal type exposes the following members.

Properties
 | Name | Description
Public property | Type | Type
Top
See Also

Reference

BetPal Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BetPal.Type Property

BetPalType Property

Type

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Type { get; }

Property Value

IdNameTuple
See Also

Reference

BetPal Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BetPal Methods

The BetPal type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

BetPal Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


BetPal.ToString Method

BetPalToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

BetPal Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


Card Class

Card type (yellow or red)
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsCard

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class Card : Enum

The Card type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | RED | Red card
 | UNDEFINED | Undefined
Public field | value__ |
 | YELLOW | Yellow card
 | YELLOWRED | 2nd yellow card resulting in a red card
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


Card Methods

The Card type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

Card Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


Card Fields

The Card type exposes the following members.

Fields
 | Name | Description
 | RED | Red card
 | UNDEFINED | Undefined
Public field | value__ |
 | YELLOW | Yellow card
 | YELLOWRED | 2nd yellow card resulting in a red card
Top
See Also

Reference

Card Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


Card.RED Field

CardRED Field

Red card

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Card RED = 3

Field Value

Card
See Also

Reference

Card Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


Card.UNDEFINED Field

CardUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Card UNDEFINED = 0

Field Value

Card
See Also

Reference

Card Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


Card.value__ Field

Cardvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.Card.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

Card Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


Card.YELLOW Field

CardYELLOW Field

Yellow card

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Card YELLOW = 1

Field Value

Card
See Also

Reference

Card Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


Card.YELLOWRED Field

CardYELLOWRED Field

2nd yellow card resulting in a red card

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Card YELLOWRED = 2

Field Value

Card
See Also

Reference

Card Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CardEntry Class

Card summary by time that is updated live.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsBaseScoreCardEntry
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsCardEntry

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class CardEntry : BaseScoreCardEntry

The CardEntry type exposes the following members.

Constructors
 | Name | Description
Public method | CardEntry | Initializes a new instance of the CardEntry class
Top
Properties
 | Name | Description
Public property | AffectedPlayer | Player that scored or received a card. (Inherited from BaseScoreCardEntry)
Public property | AffectedTeam | Team that scored or received a card. (Inherited from BaseScoreCardEntry)
Public property | Cancelled | True if a particular score or card has been cancelled. After this a new message with the correct score will be sent for score cancelling. (Inherited from BaseScoreCardEntry)
Public property | Id | Id that uniquely identifies each score and card. For score types "ht", "ft", "ot" and "pen" Id will not be set. (Inherited from BaseScoreCardEntry)
Public property | PlayerId | Id of player that scored or received a card. (Inherited from BaseScoreCardEntry)
Public property | Time | Match time in minutes when the goal/card occurred. When no time is known it is set to “-1", and the AffectedPlayer property is empty. (Inherited from BaseScoreCardEntry)
Public property | Type | Card type (yellow or red)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides BaseScoreCardEntryToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CardEntry Constructor

Initializes a new instance of the CardEntry class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CardEntry()
See Also

Reference

CardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CardEntry Properties

The CardEntry type exposes the following members.

Properties
 | Name | Description
Public property | AffectedPlayer | Player that scored or received a card. (Inherited from BaseScoreCardEntry)
Public property | AffectedTeam | Team that scored or received a card. (Inherited from BaseScoreCardEntry)
Public property | Cancelled | True if a particular score or card has been cancelled. After this a new message with the correct score will be sent for score cancelling. (Inherited from BaseScoreCardEntry)
Public property | Id | Id that uniquely identifies each score and card. For score types "ht", "ft", "ot" and "pen" Id will not be set. (Inherited from BaseScoreCardEntry)
Public property | PlayerId | Id of player that scored or received a card. (Inherited from BaseScoreCardEntry)
Public property | Time | Match time in minutes when the goal/card occurred. When no time is known it is set to “-1", and the AffectedPlayer property is empty. (Inherited from BaseScoreCardEntry)
Public property | Type | Card type (yellow or red)
Top
See Also

Reference

CardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CardEntry.Type Property

CardEntryType Property

Card type (yellow or red)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Card Type { get; }

Property Value

Card
See Also

Reference

CardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CardEntry Methods

The CardEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides BaseScoreCardEntryToString)
Top
See Also

Reference

CardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CardEntry.ToString Method

CardEntryToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

CardEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CoveredFromType Class

Indicates whether the match is being covered from a television feed or the scout is at the match venue
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsCoveredFromType

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class CoveredFromType : Enum

The CoveredFromType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | NA | Covered from not specified
 | TV | Covered from a television
Public field | value__ |
 | VENUE | Covered from the match venue
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CoveredFromType Methods

The CoveredFromType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

CoveredFromType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CoveredFromType Fields

The CoveredFromType type exposes the following members.

Fields
 | Name | Description
 | NA | Covered from not specified
 | TV | Covered from a television
Public field | value__ |
 | VENUE | Covered from the match venue
Top
See Also

Reference

CoveredFromType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CoveredFromType.NA Field

CoveredFromTypeNA Field

Covered from not specified

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const CoveredFromType NA = 2

Field Value

CoveredFromType
See Also

Reference

CoveredFromType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CoveredFromType.TV Field

CoveredFromTypeTV Field

Covered from a television

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const CoveredFromType TV = 1

Field Value

CoveredFromType
See Also

Reference

CoveredFromType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CoveredFromType.value__ Field

CoveredFromTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.CoveredFromType.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

CoveredFromType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


CoveredFromType.VENUE Field

CoveredFromTypeVENUE Field

Covered from the match venue

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const CoveredFromType VENUE = 0

Field Value

CoveredFromType
See Also

Reference

CoveredFromType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ExtraMatchInfo Class

Additional information about period lengths, number of sets played, etc., that is included with MatchInfo. Other information might be added later on, so a client should be able to handle it.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsExtraMatchInfo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ExtraMatchInfo

The ExtraMatchInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ExtraMatchInfo | Initializes a new instance of the ExtraMatchInfo class
Top
Properties
 | Name | Description
Public property | Type | Type of additional match information (e.g. NumberOfSets, PeriodLength, OvertimeLength)
Public property | Value | Info value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
Remarks
Currently following types are available.

For Soccer, Hockey, Handball, Basketball, Futsal and American Football:

  • PeriodLength
  • OvertimeLength

For Tennis, Volleyball, Beach Volleyball, Badminton and Table Tennis:

  • NumberOfSets

Volleyball:

  • Format

Darts:

  • DrawPossible
  • BestOfXSets
  • BestOfXLegs
  • LegsInLastSet

See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ExtraMatchInfo Constructor

Initializes a new instance of the ExtraMatchInfo class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ExtraMatchInfo()
See Also

Reference

ExtraMatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ExtraMatchInfo Properties

The ExtraMatchInfo type exposes the following members.

Properties
 | Name | Description
Public property | Type | Type of additional match information (e.g. NumberOfSets, PeriodLength, OvertimeLength)
Public property | Value | Info value
Top
See Also

Reference

ExtraMatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ExtraMatchInfo.Type Property

ExtraMatchInfoType Property

Type of additional match information (e.g. NumberOfSets, PeriodLength, OvertimeLength)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Type { get; }

Property Value

String
See Also

Reference

ExtraMatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ExtraMatchInfo.Value Property

ExtraMatchInfoValue Property

Info value

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; }

Property Value

String
See Also

Reference

ExtraMatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ExtraMatchInfo Methods

The ExtraMatchInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

ExtraMatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ExtraMatchInfo.ToString Method

ExtraMatchInfoToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

ExtraMatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOdds Interface

Live odds client interface.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOdds : ILiveOddsCommon,
    ILiveOddsCommonBase, ILiveFeeds, IStartable

The ILiveOdds type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from ILiveFeeds)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from ILiveOddsCommonBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from ILiveFeeds)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from ILiveFeeds)
Public property | ServerTime | Get approximate server time. (Inherited from ILiveFeeds)
Public property | SubscribedEvents | All event ids we are currently subscribed to. (Inherited from ILiveFeeds)
Public property | TestManager | Manages replay on test server. Only available if Test=true and the feed support replay.
Top
Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface. (Inherited from ILiveFeeds)
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup. (Inherited from ILiveFeeds)
Public method | GetAllBetTypes | Returns all available bet types.
Public method | GetBetType | Returns detailed bet type information for the specified type.
Public method | GetEventList(IEnumerableInt64) | Request meta-information about the events(matches, races) specified by it's ids The response message includes teams playing, match date and time, TV channel names and sport/category/tournament for every match. (Inherited from ILiveOddsCommonBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | Request meta-information about all events(matches, races, outcomes, ...) in a given interval. The maximum interval is 10 days. If no date is specified, all events started 24 hours in the past, and 7 days in the future are returned. The response message includes teams playing, event date and time, TV channel names and sport/category/tournament for every event. (Inherited from ILiveOddsCommonBase)
Public method | GetEventMessages | Request exact match messages ("error" server request). (Inherited from ILiveOddsCommonBase)
Public method | GetEventsStatus | Requests the match statuses for a given time ("current" server request). This includes odds, activation of odds and match status for the matches requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetEventStatus | Requests the match status for a given time ("current" server request). This includes odds, activation of odds and match status for the match requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetScoreAndCardSummary | Requests a list of all cards and scores for a match.
Public method | RegisterBetTypes | Register specific bet types within the given match. This gives the opportunity to activate specific odd types for a match.
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events. (Inherited from ILiveFeeds)
Public method | UnregisterBetTypes | Unregister from specific bet types within the given match. This gives the opportunity to deactivate specific odd types for a match.
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent. (Inherited from ILiveFeeds)
Top
Events
Name Description
Public event OnAlive Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
(Inherited from ILiveOddsCommon)
Public event OnBetCancel Signals that odds type for a match should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
(Inherited from ILiveOddsCommonBase)
Public event OnBetCancelUndo Signals that an odds type has been cancelled due to some reason when it actually shouldnt have been. This can be undone. The Odds element should match the Odds element in the corresponding OnCancelBet event. The same goes for the starttime and endtime - they should match the values in the OnCancelBet event.
(Inherited from ILiveOddsCommonBase)
Public event OnBetClear

Signals that situation occurred during the match so that a bet can be decided. Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

(Inherited from ILiveOddsCommonBase)
Public event OnBetClearRollback Signals that there was some wrong information sent out about bet clearing. Notification includes the Odds element that rollback is targeted to. The clearedscore contains the cleared score of the original bet clearing. The time for the original bet clearing is timestamp – time seconds. The Odds element includes a list of EventOddsField elements to indicate what field was cleared in the original bet clearing. The Client system is responsible to handle this accordingly.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStart Signals that bets for a specific match can open again after they have been stopped.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStop Signals that a bet stop situation occurred for a specific match. OnBetStart event is triggered when the bets can open again.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionStable Signals that the initial sync is complete and the connection to the server is stable.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionUnstable Signals that the connection is unstable.
(Inherited from ILiveOddsCommonBase)
Public event OnEventMessages Signals that all of the requested match messages were received.
(Inherited from ILiveOddsCommonBase)
Public event OnEventStatus Signals that a requested match status was received.
(Inherited from ILiveOddsCommonBase)
Public event OnFeedError Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
(Inherited from ILiveFeeds)
Public event OnMetaInfo Event contains information like the date and time of the match, sport, category, tournament, teams and what TV-channels a match is broadcasted on. When a match is removed, Active is set to false for the match with an optional textual reason why the match has been removed. Active flag can also set to false if the client has unregistered a match. The message element will include the text unregistered in such cases. Match meta-information will also be broadcasted when a match is added to the system, or when a match has been cancelled.
(Inherited from ILiveOddsCommonBase)
Public event OnOddsChange Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
(Inherited from ILiveOddsCommonBase)
Public event OnScoreCardSummary

This event can be used for two types of information - live reporting of results/cards and final results (fulltime/halftime). Event is triggered as soon as a score/card is detected during a match and includes the timestamp of the actual event. The Id uniquely identifies each score and card. In addition, the scoring team and the player causing the event are both specified.

The same card and the same score can be sent several times; this is used to update information, for example player or time. When no time is known it is set to “-1", and the player attribute is empty. Cancelled indicates whether the score or card is cancelled or not. If cancelled then a new message with the correct score will be sent for score cancelling.

There is also live score information available during a match. After the match is ended, results with time=T, and type: halftime(ht), fulltime(ft), after overtime(ao), after penalties(pen) or score(when the goal happened) are indicated. T is the match time in minutes when the goal occurred. Here all cards registered during the match are sent. For the score types ht, ft, ot and pen there is no Id attribute. Score indicates the current score in the match. Evaluation of the bet outcomes is the responsibility of the Client system.

Top
Remarks
Usually there is no need to call any methods, just handle the events.
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOdds Properties

The ILiveOdds type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from ILiveFeeds)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from ILiveOddsCommonBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from ILiveFeeds)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from ILiveFeeds)
Public property | ServerTime | Get approximate server time. (Inherited from ILiveFeeds)
Public property | SubscribedEvents | All event ids we are currently subscribed to. (Inherited from ILiveFeeds)
Public property | TestManager | Manages replay on test server. Only available if Test=true and the feed support replay.
Top
See Also

Reference

ILiveOdds Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOdds.TestManager Property

ILiveOddsTestManager Property

Manages replay on test server. Only available if Test=true and the feed support replay.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
ILiveOddsTestManager TestManager { get; }

Property Value

ILiveOddsTestManager
See Also

Reference

ILiveOdds Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOdds Methods

The ILiveOdds type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface. (Inherited from ILiveFeeds)
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup. (Inherited from ILiveFeeds)
Public method | GetAllBetTypes | Returns all available bet types.
Public method | GetBetType | Returns detailed bet type information for the specified type.
Public method | GetEventList(IEnumerableInt64) | Request meta-information about the events(matches, races) specified by it's ids The response message includes teams playing, match date and time, TV channel names and sport/category/tournament for every match. (Inherited from ILiveOddsCommonBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | Request meta-information about all events(matches, races, outcomes, ...) in a given interval. The maximum interval is 10 days. If no date is specified, all events started 24 hours in the past, and 7 days in the future are returned. The response message includes teams playing, event date and time, TV channel names and sport/category/tournament for every event. (Inherited from ILiveOddsCommonBase)
Public method | GetEventMessages | Request exact match messages ("error" server request). (Inherited from ILiveOddsCommonBase)
Public method | GetEventsStatus | Requests the match statuses for a given time ("current" server request). This includes odds, activation of odds and match status for the matches requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetEventStatus | Requests the match status for a given time ("current" server request). This includes odds, activation of odds and match status for the match requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetScoreAndCardSummary | Requests a list of all cards and scores for a match.
Public method | RegisterBetTypes | Register specific bet types within the given match. This gives the opportunity to activate specific odd types for a match.
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events. (Inherited from ILiveFeeds)
Public method | UnregisterBetTypes | Unregister from specific bet types within the given match. This gives the opportunity to deactivate specific odd types for a match.
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent. (Inherited from ILiveFeeds)
Top
See Also

Reference

ILiveOdds Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOdds.GetAllBetTypes Method

ILiveOddsGetAllBetTypes Method

Returns all available bet types.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
BetValue[] GetAllBetTypes()

Return Value

BetValue
Available bet types.
Remarks
The method returns a cached response that is periodically fetched from the server. RefreshInterval control's the interval.
See Also

Reference

ILiveOdds Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOdds.GetBetType Method

ILiveOddsGetBetType Method

Returns detailed bet type information for the specified type.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
BetValue GetBetType(
    BetTypeKey key
)

Parameters

key BetTypeKey
Bet type key

Return Value

BetValue
Detailed bet type information for the specified type.
Remarks
The method returns a cached response that is periodically fetched from the server. RefreshInterval control's the interval.
See Also

Reference

ILiveOdds Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOdds.GetScoreAndCardSummary Method

ILiveOddsGetScoreAndCardSummary Method

Requests a list of all cards and scores for a match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long GetScoreAndCardSummary(
    long match_id
)

Parameters

match_id Int64
Match id

Return Value

Int64
Returns immediately with the request number or zero, but expect to receive OnScoreCardSummary event in response
See Also

Reference

ILiveOdds Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOdds.RegisterBetTypes Method

ILiveOddsRegisterBetTypes Method

Register specific bet types within the given match. This gives the opportunity to activate specific odd types for a match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void RegisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType
List of matches and bet types to register
Remarks
There is no need to call this method (all bet types are registered automatically). Beware when there are more instances of the same bet type (i.e. "Next goal"), this will activate all (except the ones that are already decided - safety precaution).
See Also

Reference

ILiveOdds Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOdds.UnregisterBetTypes Method

ILiveOddsUnregisterBetTypes Method

Unregister from specific bet types within the given match. This gives the opportunity to deactivate specific odd types for a match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void UnregisterBetTypes(
    IEnumerable<RegisterUnregisterBetType> betTypes
)

Parameters

betTypes IEnumerable RegisterUnregisterBetType
List of matches and bet types to unregister from
Remarks
There is no need to call this method. Beware when there are more instances of the same bet type active (i.e. "Next goal"), this will deactivate all!
See Also

Reference

ILiveOdds Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOdds Events

The ILiveOdds type exposes the following members.

Events
Name Description
Public event OnAlive Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
(Inherited from ILiveOddsCommon)
Public event OnBetCancel Signals that odds type for a match should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
(Inherited from ILiveOddsCommonBase)
Public event OnBetCancelUndo Signals that an odds type has been cancelled due to some reason when it actually shouldnt have been. This can be undone. The Odds element should match the Odds element in the corresponding OnCancelBet event. The same goes for the starttime and endtime - they should match the values in the OnCancelBet event.
(Inherited from ILiveOddsCommonBase)
Public event OnBetClear

Signals that situation occurred during the match so that a bet can be decided. Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

(Inherited from ILiveOddsCommonBase)
Public event OnBetClearRollback Signals that there was some wrong information sent out about bet clearing. Notification includes the Odds element that rollback is targeted to. The clearedscore contains the cleared score of the original bet clearing. The time for the original bet clearing is timestamp – time seconds. The Odds element includes a list of EventOddsField elements to indicate what field was cleared in the original bet clearing. The Client system is responsible to handle this accordingly.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStart Signals that bets for a specific match can open again after they have been stopped.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStop Signals that a bet stop situation occurred for a specific match. OnBetStart event is triggered when the bets can open again.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionStable Signals that the initial sync is complete and the connection to the server is stable.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionUnstable Signals that the connection is unstable.
(Inherited from ILiveOddsCommonBase)
Public event OnEventMessages Signals that all of the requested match messages were received.
(Inherited from ILiveOddsCommonBase)
Public event OnEventStatus Signals that a requested match status was received.
(Inherited from ILiveOddsCommonBase)
Public event OnFeedError Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
(Inherited from ILiveFeeds)
Public event OnMetaInfo Event contains information like the date and time of the match, sport, category, tournament, teams and what TV-channels a match is broadcasted on. When a match is removed, Active is set to false for the match with an optional textual reason why the match has been removed. Active flag can also set to false if the client has unregistered a match. The message element will include the text unregistered in such cases. Match meta-information will also be broadcasted when a match is added to the system, or when a match has been cancelled.
(Inherited from ILiveOddsCommonBase)
Public event OnOddsChange Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
(Inherited from ILiveOddsCommonBase)
Public event OnScoreCardSummary

This event can be used for two types of information - live reporting of results/cards and final results (fulltime/halftime). Event is triggered as soon as a score/card is detected during a match and includes the timestamp of the actual event. The Id uniquely identifies each score and card. In addition, the scoring team and the player causing the event are both specified.

The same card and the same score can be sent several times; this is used to update information, for example player or time. When no time is known it is set to “-1", and the player attribute is empty. Cancelled indicates whether the score or card is cancelled or not. If cancelled then a new message with the correct score will be sent for score cancelling.

There is also live score information available during a match. After the match is ended, results with time=T, and type: halftime(ht), fulltime(ft), after overtime(ao), after penalties(pen) or score(when the goal happened) are indicated. T is the match time in minutes when the goal occurred. Here all cards registered during the match are sent. For the score types ht, ft, ot and pen there is no Id attribute. Score indicates the current score in the match. Evaluation of the bet outcomes is the responsibility of the Client system.

Top
See Also

Reference

ILiveOdds Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOdds.OnScoreCardSummary Event

ILiveOddsOnScoreCardSummary Event

This event can be used for two types of information - live reporting of results/cards and final results (fulltime/halftime). Event is triggered as soon as a score/card is detected during a match and includes the timestamp of the actual event. The Id uniquely identifies each score and card. In addition, the scoring team and the player causing the event are both specified.

The same card and the same score can be sent several times; this is used to update information, for example player or time. When no time is known it is set to “-1", and the player attribute is empty. Cancelled indicates whether the score or card is cancelled or not. If cancelled then a new message with the correct score will be sent for score cancelling.

There is also live score information available during a match. After the match is ended, results with time=T, and type: halftime(ht), fulltime(ft), after overtime(ao), after penalties(pen) or score(when the goal happened) are indicated. T is the match time in minutes when the goal occurred. Here all cards registered during the match are sent. For the score types ht, ft, ot and pen there is no Id attribute. Score indicates the current score in the match. Evaluation of the bet outcomes is the responsibility of the Client system.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<ScoreCardSummaryEventArgs> OnScoreCardSummary

Value

EventHandler ScoreCardSummaryEventArgs
See Also

Reference

ILiveOdds Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOddsTestManager Interface

Enables replay of matches on LiveOdds test server. Wait for OnConnectionStable before using it

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOddsTestManager

The ILiveOddsTestManager type exposes the following members.

Methods
 | Name | Description
Public method | ChangeXmlConfig | Sends XML config change request. Note: Reply is not according to XSD schema, so parsing will fail but changes will come into effect
Public method | ResetXmlConfig | Sends Forces xml config update. Note: Reply is not according to XSD schema, so parsing will fail but changes will come into effect
Public method | StartAuto | Automatically start replay of all matches with a delay of 48 hours, essentially replicating the conditions on the live-system 48 hours ago. This gives you all matches that were offered in Live Odds at this time, regardless if you had them booked in live-system.
Public method | StartMatchReplay | Starts to replay a single recent match (must have ended at least 1 hour ago)
Public method | StartScenario | Start replay of a pre-recorded match. These matches are not subject to time restrictions, and can be replayed at any time. The start of the test will usually be set to a few seconds before the first message. A test replay may contain more than one match, e.g. recording for an entire day. In this case it’s possible that at the default start time, one or more of the matches is already underway.
Public method | StopAll | Stops all currently running Single match replays and Test match replays
Public method | StopAuto | Stops replay of delayed matches
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOddsTestManager Methods

The ILiveOddsTestManager type exposes the following members.

Methods
 | Name | Description
Public method | ChangeXmlConfig | Sends XML config change request. Note: Reply is not according to XSD schema, so parsing will fail but changes will come into effect
Public method | ResetXmlConfig | Sends Forces xml config update. Note: Reply is not according to XSD schema, so parsing will fail but changes will come into effect
Public method | StartAuto | Automatically start replay of all matches with a delay of 48 hours, essentially replicating the conditions on the live-system 48 hours ago. This gives you all matches that were offered in Live Odds at this time, regardless if you had them booked in live-system.
Public method | StartMatchReplay | Starts to replay a single recent match (must have ended at least 1 hour ago)
Public method | StartScenario | Start replay of a pre-recorded match. These matches are not subject to time restrictions, and can be replayed at any time. The start of the test will usually be set to a few seconds before the first message. A test replay may contain more than one match, e.g. recording for an entire day. In this case it’s possible that at the default start time, one or more of the matches is already underway.
Public method | StopAll | Stops all currently running Single match replays and Test match replays
Public method | StopAuto | Stops replay of delayed matches
Top
See Also

Reference

ILiveOddsTestManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOddsTestManager.ChangeXmlConfig Method

ILiveOddsTestManagerChangeXmlConfig Method

Sends XML config change request. Note: Reply is not according to XSD schema, so parsing will fail but changes will come into effect

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void ChangeXmlConfig(
    int config_id,
    bool enable,
    bool reset = false
)

Parameters

config_id Int32

[Missing <param name="config_id"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager.ChangeXmlConfig(System.Int32,System.Boolean,System.Boolean)"]

enable Boolean

[Missing <param name="enable"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager.ChangeXmlConfig(System.Int32,System.Boolean,System.Boolean)"]

reset Boolean (Optional)

[Missing <param name="reset"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.ILiveOddsTestManager.ChangeXmlConfig(System.Int32,System.Boolean,System.Boolean)"]

See Also

Reference

ILiveOddsTestManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOddsTestManager.ResetXmlConfig Method

ILiveOddsTestManagerResetXmlConfig Method

Sends Forces xml config update. Note: Reply is not according to XSD schema, so parsing will fail but changes will come into effect

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void ResetXmlConfig()
See Also

Reference

ILiveOddsTestManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOddsTestManager.StartAuto Method

ILiveOddsTestManagerStartAuto Method

Automatically start replay of all matches with a delay of 48 hours, essentially replicating the conditions on the live-system 48 hours ago. This gives you all matches that were offered in Live Odds at this time, regardless if you had them booked in live-system.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void StartAuto()
See Also

Reference

ILiveOddsTestManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOddsTestManager.StartMatchReplay Method

ILiveOddsTestManagerStartMatchReplay Method

Starts to replay a single recent match (must have ended at least 1 hour ago)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void StartMatchReplay(
    long match_id,
    long? msgn_nr = null,
    TimeSpan? fast_forward = null,
    int? speed = null,
    bool? persistent = null
)

Parameters

match_id Int64
Match id to replay
msgn_nr Nullable Int64 (Optional)
If specified, it will start the replay at specified message number
fast_forward Nullable TimeSpan (Optional)
If specified, skips the match to the specified time
speed Nullable Int32 (Optional)
The amount of milliseconds between messages. This can be used to speed up the replay of a match.
persistent Nullable Boolean (Optional)
If multiple clients are logged in with the same client id they will all receive the XML messages for the started match. If one of the clients disconnects, the messages will still be sent to the other clients. After reconnecting, the disconnected client will receive all messages from that point on again.
See Also

Reference

ILiveOddsTestManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOddsTestManager.StartScenario Method

ILiveOddsTestManagerStartScenario Method

Start replay of a pre-recorded match. These matches are not subject to time restrictions, and can be replayed at any time. The start of the test will usually be set to a few seconds before the first message. A test replay may contain more than one match, e.g. recording for an entire day. In this case it’s possible that at the default start time, one or more of the matches is already underway.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void StartScenario(
    int scenario_number,
    TimeSpan? fast_forward = null,
    int? speed = null,
    bool? persistent = null
)

Parameters

scenario_number Int32
Which scenario to start
fast_forward Nullable TimeSpan (Optional)
If specified, skips the test to the specified time
speed Nullable Int32 (Optional)
The amount of milliseconds between messages. This can be used to speed up the replay of a match.
persistent Nullable Boolean (Optional)
If multiple clients are logged in with the same client id they will all receive the XML messages for the started match. If one of the clients disconnects, the messages will still be sent to the other clients. After reconnecting, the disconnected client will receive all messages from that point on again.
Remarks
  • 1 - Soccer - Deep Coverage
  • 2 - Soccer - Basic Coverage
  • 3 - Tennis
  • 4 - Ice Hockey
  • 5 - Basketball
  • 6 - Baseball
  • 7 - American Football
  • 8 - Handball
  • 9 - Futsal
  • 10 - Volleyball
  • 11 - Beach Volleyball
  • 12 - Badminton
  • 13 - Rugby Union
  • 14 - Darts
  • 15 - Snooker
  • 17 - Ice Hockey with penalties
  • 18 - Ice Hockey with overtime
  • 19 - Soccer - ExtraTime
  • 20 - American Football - Short match
  • 21 - Table Tennis
  • 22 – Basketball with overtime
  • 23 – Bowls
  • 24 – Cricket
  • 25 – Darts - Match in sets
  • 26 – Darts - Match in legs with draw
See Also

Reference

ILiveOddsTestManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOddsTestManager.StopAll Method

ILiveOddsTestManagerStopAll Method

Stops all currently running Single match replays and Test match replays

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void StopAll(
    bool? persistent = null
)

Parameters

persistent Nullable Boolean (Optional)
if true also ends persistent matches
See Also

Reference

ILiveOddsTestManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ILiveOddsTestManager.StopAuto Method

ILiveOddsTestManagerStopAuto Method

Stops replay of delayed matches

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void StopAuto()
See Also

Reference

ILiveOddsTestManager Interface
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


LiveOddsMetaData Class

MetaInfoDataContainer for match oriented feeds
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonMetaInfoDataContainer
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsLiveOddsMetaData
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsMatchAndOutrightMetaData

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class LiveOddsMetaData : MetaInfoDataContainer

The LiveOddsMetaData type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsMetaData | Initializes a new instance of the LiveOddsMetaData class
Top
Properties
 | Name | Description
Public property | MatchHeaderInfos | Match meta information.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


LiveOddsMetaData Constructor

Initializes a new instance of the LiveOddsMetaData class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsMetaData()
See Also

Reference

LiveOddsMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


LiveOddsMetaData Properties

The LiveOddsMetaData type exposes the following members.

Properties
 | Name | Description
Public property | MatchHeaderInfos | Match meta information.
Top
See Also

Reference

LiveOddsMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


LiveOddsMetaData.MatchHeaderInfos Property

LiveOddsMetaDataMatchHeaderInfos Property

Match meta information.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<MatchHeaderInfo> MatchHeaderInfos { get; }

Property Value

List MatchHeaderInfo
See Also

Reference

LiveOddsMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


LiveOddsMetaData Methods

The LiveOddsMetaData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

LiveOddsMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


LiveOddsMetaData.ToString Method

LiveOddsMetaDataToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

LiveOddsMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader Class

Basic match information.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonEventHeader
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsMatchHeader

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchHeader : EventHeader

The MatchHeader type exposes the following members.

Constructors
 | Name | Description
Public method | MatchHeader | Initializes a new instance of the MatchHeader class
Top
Properties
 | Name | Description
Public property | Active | Set to false when a match is removed (in this case also see the Message for the reason for removal). Also set to false if the client has unregistered a match. The message element will include the text "unregistered" in such case. (Inherited from EventHeader)
Public property | AutoTraded | Indicates if is match auto traded
Public property | Balls | Used by baseball and similar sports. Part of pitch count statistic. Denotes the number of fouls (bad throws) from the pitcher for current half-inning.
Public property | Bases | Used by baseball and similar sports. Comma separated list which tells if a base is occupied or not.
Public property | Batter | Used by baseball and similar sports. Denotes which batter is currently active.
Public property | BetStatus | Current bet status (Inherited from EventHeader)
Public property | BetStopReason | The reason why a betstop occurred.
Public property | Booked | The meta-message includes matches that are booked or included in the package that is purchased. By adding specifying includeavailable="true" in the meta request, or activating it through XML configuration ‘Include non booked matches in meta’, the meta response will also include matches that are available for booking but not booked yet. The match element in the meta-response will then also include this property specifying whether the match is already booked (true), or not booked yet (false).
Public property | ClearedScore | Cleared score in bet clear and bet clear rollback situations.
Public property | ClockStopped | Indicates that a clock has been stopped in the middle of the match for Basketball, Ice Hockey and Handball matches. This status will only be present if the corresponding XML configuration is activated.
Public property | Corners | Number of corners for the Home/Away team.
Public property | CurrentCtTeam | Current ct team
Public property | CurrentEnd | Current end in set
Public property | Delivery | Player of which team will deliver the next bowl or in cricket which ball delivery in the over it is
Public property | Dismissals | Number of dismissals per team
Public property | EarlyBetStatus | Early bet status (if configured in XML LiveOdds config). This status is set to “started" once the score is changed and remains so until the match continues (re-kick off), which causes that “earlybetstatus" is set to “stopped". The bookmaker can now decide whether to receive new prices right after the score change or after the match continues (re-kick off). If one or both of the flags betstatus or earlybetstatus is set to started it can be treated as betstart, otherwise it is betstop.
Public property | Expedite | Expedite
Public property | GameScore | Provides the point score in the current Tennis game. The score is in the format 15:40. If one player has advantage the game score will be 50:40 or 40:50. This attribute is also used for the tiebreak score when the game is in a tiebreak.
Public property | Id | Betradar id for the event (Inherited from EventHeader)
Public property | Innings | Number of innings
Public property | LegScore | Used in darts Leg (game) score
Public property | MatchTime | Indicates the playing minute of the match. Only included for soccer, ice hockey and basketball matches when the match has status 1p, 2p, 1p_ot or 2p_ot in soccer and 1p, 2p, 3p and ot in ice hockey and 1q, 2q, 3q, 4q and ot for basket.
Public property | MatchTimeExtended | Extended match time (if configured in XML LiveOdds config). This will also show the injury time.
Public property | Message | Optional textual message attached to the match (e.g. why a match has been removed, information that a client has unregistered from a match, etc.) (Inherited from EventHeader)
Public property | Msgnr | Incremental message id that starts with 1 for every match. Only messages that changes the state of a match will include this property. Alive messages, meta-information and login response messages will not include this incremental id. (Inherited from EventHeader)
Public property | Outs | Used by baseball and similar sports. Denotes the number of outs in current half-inning.
Public property | Over | Number of overs
Public property | PenaltyRuns | Number of penalty runs per team
Public property | Position | Ball position will be sent as x yards to go till opponent’s end zone for the team in possession. Number in range [1,100]; e.g. own x will be sent as “100 – x" while opposite x will be sent as “x"
Public property | Possession | Which team has the ball.
Public property | RedCards | Number of red cards for the Home/Away team.
Public property | RemainingBowls | The remaining bowls of the teams
Public property | RemainingReds | Remaining red balls (used in snooker).
Public property | RemainingTime | Remaining time for basketball matches only (if this has been activated for your account). This will contain the remaining minutes and seconds in the format mm:ss (e.g. "38:10").
Public property | RemainingTimeInPeriod | Specifies the remaining time in this period (when this applies).
Public property | Score | Indicates the current score in the match. Before the match has started the value of the score attribute will be “-:-", afterwards it will be in the format “0:0".
Public property | Server | Indicates which player has the serve at the moment during a Tennis match. Possible values are “1" for player one and “2" for player two. This is optional as some Tennis matches might not have this.
Public property | SetScores | For Tennis it contains the scores for all sets that have ended and the current running set. For Ice Hockey and Basketball it includes the period score for all finished periods. If "Show current period score during period" XML config setting is enabled, the score of the current period will be included also during the current period, not only after the period is over.
Public property | SourceId | Client's own match id. It will be empty if we are missing your id for a particular match.
Public property | Status | Event status (Inherited from EventHeader)
Public property | StatusId | Gets the status identifier.
Public property | Strikes | Used by baseball and similar sports. Part of pitch count statistic. Denotes the number of fouls from the striker for current half-inning.
Public property | Suspend | Number of suspensions.
Public property | Throw | Number of throws. (Snooker?)
Public property | TieBreak | Indicates if a Tennis match is in a tiebreak.
Public property | Try | Try number. A number in range [1,4], it's the current “down" until reaching the 10 yards if defined
Public property | Visit | Number of turns (used in snooker).
Public property | Yards | Yards till first down. How many yards down in this drive (the drive is a series of offensive plays)
Public property | YellowCards | Number of yellow cards for the Home/Away team.
Public property | YellowRedCards | Number of yellow cards that resulted in red card for the Home/Away team.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides EventHeaderToString)
Top
Example
active="1" betstatus="started" gamescore="0:0" matchid="935457" score="1:0" server="1" setscore1="6:3" setscore2="1:3" status="2set" tiebreak="false"
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader Constructor

Initializes a new instance of the MatchHeader class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchHeader()
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader Properties

The MatchHeader type exposes the following members.

Properties
 | Name | Description
Public property | Active | Set to false when a match is removed (in this case also see the Message for the reason for removal). Also set to false if the client has unregistered a match. The message element will include the text "unregistered" in such case. (Inherited from EventHeader)
Public property | AutoTraded | Indicates if is match auto traded
Public property | Balls | Used by baseball and similar sports. Part of pitch count statistic. Denotes the number of fouls (bad throws) from the pitcher for current half-inning.
Public property | Bases | Used by baseball and similar sports. Comma separated list which tells if a base is occupied or not.
Public property | Batter | Used by baseball and similar sports. Denotes which batter is currently active.
Public property | BetStatus | Current bet status (Inherited from EventHeader)
Public property | BetStopReason | The reason why a betstop occurred.
Public property | Booked | The meta-message includes matches that are booked or included in the package that is purchased. By adding specifying includeavailable="true" in the meta request, or activating it through XML configuration ‘Include non booked matches in meta’, the meta response will also include matches that are available for booking but not booked yet. The match element in the meta-response will then also include this property specifying whether the match is already booked (true), or not booked yet (false).
Public property | ClearedScore | Cleared score in bet clear and bet clear rollback situations.
Public property | ClockStopped | Indicates that a clock has been stopped in the middle of the match for Basketball, Ice Hockey and Handball matches. This status will only be present if the corresponding XML configuration is activated.
Public property | Corners | Number of corners for the Home/Away team.
Public property | CurrentCtTeam | Current ct team
Public property | CurrentEnd | Current end in set
Public property | Delivery | Player of which team will deliver the next bowl or in cricket which ball delivery in the over it is
Public property | Dismissals | Number of dismissals per team
Public property | EarlyBetStatus | Early bet status (if configured in XML LiveOdds config). This status is set to “started" once the score is changed and remains so until the match continues (re-kick off), which causes that “earlybetstatus" is set to “stopped". The bookmaker can now decide whether to receive new prices right after the score change or after the match continues (re-kick off). If one or both of the flags betstatus or earlybetstatus is set to started it can be treated as betstart, otherwise it is betstop.
Public property | Expedite | Expedite
Public property | GameScore | Provides the point score in the current Tennis game. The score is in the format 15:40. If one player has advantage the game score will be 50:40 or 40:50. This attribute is also used for the tiebreak score when the game is in a tiebreak.
Public property | Id | Betradar id for the event (Inherited from EventHeader)
Public property | Innings | Number of innings
Public property | LegScore | Used in darts Leg (game) score
Public property | MatchTime | Indicates the playing minute of the match. Only included for soccer, ice hockey and basketball matches when the match has status 1p, 2p, 1p_ot or 2p_ot in soccer and 1p, 2p, 3p and ot in ice hockey and 1q, 2q, 3q, 4q and ot for basket.
Public property | MatchTimeExtended | Extended match time (if configured in XML LiveOdds config). This will also show the injury time.
Public property | Message | Optional textual message attached to the match (e.g. why a match has been removed, information that a client has unregistered from a match, etc.) (Inherited from EventHeader)
Public property | Msgnr | Incremental message id that starts with 1 for every match. Only messages that changes the state of a match will include this property. Alive messages, meta-information and login response messages will not include this incremental id. (Inherited from EventHeader)
Public property | Outs | Used by baseball and similar sports. Denotes the number of outs in current half-inning.
Public property | Over | Number of overs
Public property | PenaltyRuns | Number of penalty runs per team
Public property | Position | Ball position will be sent as x yards to go till opponent’s end zone for the team in possession. Number in range [1,100]; e.g. own x will be sent as “100 – x" while opposite x will be sent as “x"
Public property | Possession | Which team has the ball.
Public property | RedCards | Number of red cards for the Home/Away team.
Public property | RemainingBowls | The remaining bowls of the teams
Public property | RemainingReds | Remaining red balls (used in snooker).
Public property | RemainingTime | Remaining time for basketball matches only (if this has been activated for your account). This will contain the remaining minutes and seconds in the format mm:ss (e.g. "38:10").
Public property | RemainingTimeInPeriod | Specifies the remaining time in this period (when this applies).
Public property | Score | Indicates the current score in the match. Before the match has started the value of the score attribute will be “-:-", afterwards it will be in the format “0:0".
Public property | Server | Indicates which player has the serve at the moment during a Tennis match. Possible values are “1" for player one and “2" for player two. This is optional as some Tennis matches might not have this.
Public property | SetScores | For Tennis it contains the scores for all sets that have ended and the current running set. For Ice Hockey and Basketball it includes the period score for all finished periods. If "Show current period score during period" XML config setting is enabled, the score of the current period will be included also during the current period, not only after the period is over.
Public property | SourceId | Client's own match id. It will be empty if we are missing your id for a particular match.
Public property | Status | Event status (Inherited from EventHeader)
Public property | StatusId | Gets the status identifier.
Public property | Strikes | Used by baseball and similar sports. Part of pitch count statistic. Denotes the number of fouls from the striker for current half-inning.
Public property | Suspend | Number of suspensions.
Public property | Throw | Number of throws. (Snooker?)
Public property | TieBreak | Indicates if a Tennis match is in a tiebreak.
Public property | Try | Try number. A number in range [1,4], it's the current “down" until reaching the 10 yards if defined
Public property | Visit | Number of turns (used in snooker).
Public property | Yards | Yards till first down. How many yards down in this drive (the drive is a series of offensive plays)
Public property | YellowCards | Number of yellow cards for the Home/Away team.
Public property | YellowRedCards | Number of yellow cards that resulted in red card for the Home/Away team.
Top
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.AutoTraded Property

MatchHeaderAutoTraded Property

Indicates if is match auto traded

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? AutoTraded { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Balls Property

MatchHeaderBalls Property

Used by baseball and similar sports. Part of pitch count statistic. Denotes the number of fouls (bad throws) from the pitcher for current half-inning.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Balls { get; }

Property Value

Nullable Int32
Remarks
Can be 0, 1, 2 or 3.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Bases Property

MatchHeaderBases Property

Used by baseball and similar sports. Comma separated list which tells if a base is occupied or not.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Bases { get; }

Property Value

String
Remarks
Each component can either be 0 or 1 so examples are for instance "0,1,0" or "1,1,0" .
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Batter Property

MatchHeaderBatter Property

Used by baseball and similar sports. Denotes which batter is currently active.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int?> Batter { get; }

Property Value

HomeAway Nullable Int32
Remarks
The number can be from 1 - 9 for each side.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.BetStopReason Property

MatchHeaderBetStopReason Property

The reason why a betstop occurred.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetStopReason BetStopReason { get; }

Property Value

BetStopReason
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Booked Property

MatchHeaderBooked Property

The meta-message includes matches that are booked or included in the package that is purchased. By adding specifying includeavailable="true" in the meta request, or activating it through XML configuration ‘Include non booked matches in meta’, the meta response will also include matches that are available for booking but not booked yet. The match element in the meta-response will then also include this property specifying whether the match is already booked (true), or not booked yet (false).

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? Booked { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.ClearedScore Property

MatchHeaderClearedScore Property

Cleared score in bet clear and bet clear rollback situations.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ClearedScore { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.ClockStopped Property

MatchHeaderClockStopped Property

Indicates that a clock has been stopped in the middle of the match for Basketball, Ice Hockey and Handball matches. This status will only be present if the corresponding XML configuration is activated.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? ClockStopped { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Corners Property

MatchHeaderCorners Property

Number of corners for the Home/Away team.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int?> Corners { get; }

Property Value

HomeAway Nullable Int32
Remarks
Only if corner and card counters are activated in the XML configuration.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.CurrentCtTeam Property

MatchHeaderCurrentCtTeam Property

Current ct team

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? CurrentCtTeam { get; }

Property Value

Nullable Team
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.CurrentEnd Property

MatchHeaderCurrentEnd Property

Current end in set

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? CurrentEnd { get; }

Property Value

Nullable Int32
Remarks
Used in Bowls
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Delivery Property

MatchHeaderDelivery Property

Player of which team will deliver the next bowl or in cricket which ball delivery in the over it is

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Delivery { get; }

Property Value

Nullable Int32
Remarks
default: 1 = home; 2 = away
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Dismissals Property

MatchHeaderDismissals Property

Number of dismissals per team

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int?> Dismissals { get; }

Property Value

HomeAway Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.EarlyBetStatus Property

MatchHeaderEarlyBetStatus Property

Early bet status (if configured in XML LiveOdds config). This status is set to “started" once the score is changed and remains so until the match continues (re-kick off), which causes that “earlybetstatus" is set to “stopped". The bookmaker can now decide whether to receive new prices right after the score change or after the match continues (re-kick off). If one or both of the flags betstatus or earlybetstatus is set to started it can be treated as betstart, otherwise it is betstop.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsMatchEarlyBetStatus? EarlyBetStatus { get; }

Property Value

Nullable OddsMatchEarlyBetStatus
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Expedite Property

MatchHeaderExpedite Property

Expedite

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? Expedite { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.GameScore Property

MatchHeaderGameScore Property

Provides the point score in the current Tennis game. The score is in the format 15:40. If one player has advantage the game score will be 50:40 or 40:50. This attribute is also used for the tiebreak score when the game is in a tiebreak.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string GameScore { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Innings Property

MatchHeaderInnings Property

Number of innings

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Innings { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.LegScore Property

MatchHeaderLegScore Property

Used in darts Leg (game) score

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string LegScore { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.MatchTime Property

MatchHeaderMatchTime Property

Indicates the playing minute of the match. Only included for soccer, ice hockey and basketball matches when the match has status 1p, 2p, 1p_ot or 2p_ot in soccer and 1p, 2p, 3p and ot in ice hockey and 1q, 2q, 3q, 4q and ot for basket.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? MatchTime { get; }

Property Value

Nullable Int64
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.MatchTimeExtended Property

MatchHeaderMatchTimeExtended Property

Extended match time (if configured in XML LiveOdds config). This will also show the injury time.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MatchTimeExtended { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Outs Property

MatchHeaderOuts Property

Used by baseball and similar sports. Denotes the number of outs in current half-inning.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Outs { get; }

Property Value

Nullable Int32
Remarks
In baseball, an out occurs when the defensive, or fielding, team effects any of a number of different events, and the umpire rules a batter or baserunner out. When a player is called out, he is said to be retired. When three outs are recorded in an inning during a team's turn at offense, that team's half of the inning finishes, and it is said that "the side is retired." Can be 0, 1 or 2.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Over Property

MatchHeaderOver Property

Number of overs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Over { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.PenaltyRuns Property

MatchHeaderPenaltyRuns Property

Number of penalty runs per team

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int?> PenaltyRuns { get; }

Property Value

HomeAway Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Position Property

MatchHeaderPosition Property

Ball position will be sent as x yards to go till opponent’s end zone for the team in possession. Number in range [1,100]; e.g. own x will be sent as “100 – x" while opposite x will be sent as “x"

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Position { get; }

Property Value

Nullable Int32
Remarks
-1 = undefined; will not be updated during overtime (set to -1)
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Possession Property

MatchHeaderPossession Property

Which team has the ball.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? Possession { get; }

Property Value

Nullable Team
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.RedCards Property

MatchHeaderRedCards Property

Number of red cards for the Home/Away team.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int?> RedCards { get; }

Property Value

HomeAway Nullable Int32
Remarks
Only if corner and card counters are activated in the XML configuration.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.RemainingBowls Property

MatchHeaderRemainingBowls Property

The remaining bowls of the teams

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int?> RemainingBowls { get; }

Property Value

HomeAway Nullable Int32
Remarks
Used in Bowls
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.RemainingReds Property

MatchHeaderRemainingReds Property

Remaining red balls (used in snooker).

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? RemainingReds { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.RemainingTime Property

MatchHeaderRemainingTime Property

Remaining time for basketball matches only (if this has been activated for your account). This will contain the remaining minutes and seconds in the format mm:ss (e.g. "38:10").

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string RemainingTime { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.RemainingTimeInPeriod Property

MatchHeaderRemainingTimeInPeriod Property

Specifies the remaining time in this period (when this applies).

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string RemainingTimeInPeriod { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Score Property

MatchHeaderScore Property

Indicates the current score in the match. Before the match has started the value of the score attribute will be “-:-", afterwards it will be in the format “0:0".

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Score { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Server Property

MatchHeaderServer Property

Indicates which player has the serve at the moment during a Tennis match. Possible values are “1" for player one and “2" for player two. This is optional as some Tennis matches might not have this.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Server { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.SetScores Property

MatchHeaderSetScores Property

For Tennis it contains the scores for all sets that have ended and the current running set. For Ice Hockey and Basketball it includes the period score for all finished periods. If "Show current period score during period" XML config setting is enabled, the score of the current period will be included also during the current period, not only after the period is over.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string[] SetScores { get; }

Property Value

String
Remarks
Currently scores for max. 10 sets are included (index [0-9])
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.SourceId Property

MatchHeaderSourceId Property

Client's own match id. It will be empty if we are missing your id for a particular match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SourceId { get; }

Property Value

String
Remarks
To do this you need to contact our support team, so they can set it up.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.StatusId Property

MatchHeaderStatusId Property

Gets the status identifier.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? StatusId { get; }

Property Value

Nullable Int32
The status identifier
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Strikes Property

MatchHeaderStrikes Property

Used by baseball and similar sports. Part of pitch count statistic. Denotes the number of fouls from the striker for current half-inning.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Strikes { get; }

Property Value

Nullable Int32
Remarks
A strike in baseball results when a batter swings at and misses a pitch, doesn't swing at a pitch in the strike zone or hits a foul ball that is not caught. Can be 0, 1 or 2.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Suspend Property

MatchHeaderSuspend Property

Number of suspensions.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int?> Suspend { get; }

Property Value

HomeAway Nullable Int32
Remarks
"Include power play counters in feed" feature must be enabled to get this value for supported sports (currently handball, futsal and ice hockey).
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Throw Property

MatchHeaderThrow Property

Number of throws. (Snooker?)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Throw { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.TieBreak Property

MatchHeaderTieBreak Property

Indicates if a Tennis match is in a tiebreak.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? TieBreak { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Try Property

MatchHeaderTry Property

Try number. A number in range [1,4], it's the current “down" until reaching the 10 yards if defined

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Try { get; }

Property Value

Nullable Int32
Remarks
-1 = undefined; will not be updated during overtime (set to -1)
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Visit Property

MatchHeaderVisit Property

Number of turns (used in snooker).

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Visit { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.Yards Property

MatchHeaderYards Property

Yards till first down. How many yards down in this drive (the drive is a series of offensive plays)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Yards { get; }

Property Value

Nullable Int32
Remarks
-1 = undefined; will not be updated during overtime (set to -1)
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.YellowCards Property

MatchHeaderYellowCards Property

Number of yellow cards for the Home/Away team.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int?> YellowCards { get; }

Property Value

HomeAway Nullable Int32
Remarks
Only if corner and card counters are activated in the XML configuration.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.YellowRedCards Property

MatchHeaderYellowRedCards Property

Number of yellow cards that resulted in red card for the Home/Away team.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int?> YellowRedCards { get; }

Property Value

HomeAway Nullable Int32
Remarks
Only if corner and card counters are activated in the XML configuration.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader Methods

The MatchHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides EventHeaderToString)
Top
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeader.ToString Method

MatchHeaderToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeaderInfo Class

Combined MatchHeader and MatchInfo information.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsMatchHeaderInfo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchHeaderInfo

The MatchHeaderInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MatchHeaderInfo | Initialize a new instance.
Top
Properties
 | Name | Description
Public property | MatchHeader | Basic match header.
Public property | MatchInfo | Match information.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeaderInfo Constructor

Initialize a new instance.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchHeaderInfo(
    MatchHeader hdr,
    MatchInfo info
)

Parameters

hdr MatchHeader
Match header
info MatchInfo
Match info
See Also

Reference

MatchHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeaderInfo Properties

The MatchHeaderInfo type exposes the following members.

Properties
 | Name | Description
Public property | MatchHeader | Basic match header.
Public property | MatchInfo | Match information.
Top
See Also

Reference

MatchHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeaderInfo.MatchHeader Property

MatchHeaderInfoMatchHeader Property

Basic match header.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchHeader MatchHeader { get; }

Property Value

MatchHeader
See Also

Reference

MatchHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeaderInfo.MatchInfo Property

MatchHeaderInfoMatchInfo Property

Match information.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchInfo MatchInfo { get; }

Property Value

MatchInfo
See Also

Reference

MatchHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeaderInfo Methods

The MatchHeaderInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

MatchHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchHeaderInfo.ToString Method

MatchHeaderInfoToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

MatchHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo Class

Match information containing the date and time of the match, sport, category, tournament, teams and what TV-channels this match is broadcasted on.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsMatchInfo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchInfo

The MatchInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MatchInfo | Initializes a new instance of the MatchInfo class
Top
Properties
 | Name | Description
Public property | AwayCompetitors | Away competitors, localized
Public property | AwayTeam | Away team, localized
Public property | BetPal | BetPal info object
Public property | Category | Category, localized (e.g. Germany, Italy, International, etc.)
Public property | CoverageInfo | Info about match coverage
Public property | CoveredFrom | Gets the info whether the match is being covered from a television feed or the scout is at the match venue.
Public property | DateOfMatch | Date of match in UTC
Public property | ExtraInfo | Additional match info (e.g. period lengths, etc.)
Public property | HomeCompetitors | Home competitors, localized
Public property | HomeTeam | Home team, localized
Public property | Round | Round, localized, used in VTO
Public property | Season | Season, localized
Public property | Sport | Sport, localized (e.g. Soccer, Basketball, etc.)
Public property | StreamingChannels | List of streaming channels where this match is broadcasted
Public property | Tournament | Tournament, localized (e.g. Premier League)
Public property | TvChannels | List of TV channels where this match is broadcasted (e.g. PREMIERE Austria)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo Constructor

Initializes a new instance of the MatchInfo class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchInfo()
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo Properties

The MatchInfo type exposes the following members.

Properties
 | Name | Description
Public property | AwayCompetitors | Away competitors, localized
Public property | AwayTeam | Away team, localized
Public property | BetPal | BetPal info object
Public property | Category | Category, localized (e.g. Germany, Italy, International, etc.)
Public property | CoverageInfo | Info about match coverage
Public property | CoveredFrom | Gets the info whether the match is being covered from a television feed or the scout is at the match venue.
Public property | DateOfMatch | Date of match in UTC
Public property | ExtraInfo | Additional match info (e.g. period lengths, etc.)
Public property | HomeCompetitors | Home competitors, localized
Public property | HomeTeam | Home team, localized
Public property | Round | Round, localized, used in VTO
Public property | Season | Season, localized
Public property | Sport | Sport, localized (e.g. Soccer, Basketball, etc.)
Public property | StreamingChannels | List of streaming channels where this match is broadcasted
Public property | Tournament | Tournament, localized (e.g. Premier League)
Public property | TvChannels | List of TV channels where this match is broadcasted (e.g. PREMIERE Austria)
Top
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.AwayCompetitors Property

MatchInfoAwayCompetitors Property

Away competitors, localized

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<IdNameTuple> AwayCompetitors { get; }

Property Value

List IdNameTuple
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.AwayTeam Property

MatchInfoAwayTeam Property

Away team, localized

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple AwayTeam { get; }

Property Value

IdNameTuple
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.BetPal Property

MatchInfoBetPal Property

BetPal info object

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BetPal BetPal { get; }

Property Value

BetPal
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.Category Property

MatchInfoCategory Property

Category, localized (e.g. Germany, Italy, International, etc.)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Category { get; }

Property Value

IdNameTuple
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.CoverageInfo Property

MatchInfoCoverageInfo Property

Info about match coverage

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<IdNameTuple> CoverageInfo { get; }

Property Value

List IdNameTuple
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.CoveredFrom Property

MatchInfoCoveredFrom Property

Gets the info whether the match is being covered from a television feed or the scout is at the match venue.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public CoveredFromType CoveredFrom { get; }

Property Value

CoveredFromType
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.DateOfMatch Property

MatchInfoDateOfMatch Property

Date of match in UTC

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime? DateOfMatch { get; }

Property Value

Nullable DateTime
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.ExtraInfo Property

MatchInfoExtraInfo Property

Additional match info (e.g. period lengths, etc.)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<ExtraMatchInfo> ExtraInfo { get; }

Property Value

List ExtraMatchInfo
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.HomeCompetitors Property

MatchInfoHomeCompetitors Property

Home competitors, localized

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<IdNameTuple> HomeCompetitors { get; }

Property Value

List IdNameTuple
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.HomeTeam Property

MatchInfoHomeTeam Property

Home team, localized

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple HomeTeam { get; }

Property Value

IdNameTuple
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.Round Property

MatchInfoRound Property

Round, localized, used in VTO

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Round { get; }

Property Value

IdNameTuple
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.Season Property

MatchInfoSeason Property

Season, localized

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Season { get; }

Property Value

IdNameTuple
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.Sport Property

MatchInfoSport Property

Sport, localized (e.g. Soccer, Basketball, etc.)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Sport { get; }

Property Value

IdNameTuple
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.StreamingChannels Property

MatchInfoStreamingChannels Property

List of streaming channels where this match is broadcasted

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<IdNameTuple> StreamingChannels { get; }

Property Value

List IdNameTuple
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.Tournament Property

MatchInfoTournament Property

Tournament, localized (e.g. Premier League)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Tournament { get; }

Property Value

IdNameTuple
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.TvChannels Property

MatchInfoTvChannels Property

List of TV channels where this match is broadcasted (e.g. PREMIERE Austria)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<string> TvChannels { get; }

Property Value

List String
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo Methods

The MatchInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


MatchInfo.ToString Method

MatchInfoToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

MatchInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


OddsScoreType Class

Score type (full time, half time, live, etc.)
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsOddsScoreType

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class OddsScoreType : Enum

The OddsScoreType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | FT | Score at full time
 | HT | Score at half time
 | LIVE | Score during a match
 | OT | Score after over time
 | PEN | Score after penalties
 | SCORE | Score after a goal was scored.
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


OddsScoreType Methods

The OddsScoreType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

OddsScoreType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


OddsScoreType Fields

The OddsScoreType type exposes the following members.

Fields
 | Name | Description
 | FT | Score at full time
 | HT | Score at half time
 | LIVE | Score during a match
 | OT | Score after over time
 | PEN | Score after penalties
 | SCORE | Score after a goal was scored.
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

OddsScoreType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


OddsScoreType.FT Field

OddsScoreTypeFT Field

Score at full time

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsScoreType FT = 1

Field Value

OddsScoreType
See Also

Reference

OddsScoreType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


OddsScoreType.HT Field

OddsScoreTypeHT Field

Score at half time

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsScoreType HT = 2

Field Value

OddsScoreType
See Also

Reference

OddsScoreType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


OddsScoreType.LIVE Field

OddsScoreTypeLIVE Field

Score during a match

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsScoreType LIVE = 5

Field Value

OddsScoreType
See Also

Reference

OddsScoreType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


OddsScoreType.OT Field

OddsScoreTypeOT Field

Score after over time

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsScoreType OT = 3

Field Value

OddsScoreType
See Also

Reference

OddsScoreType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


OddsScoreType.PEN Field

OddsScoreTypePEN Field

Score after penalties

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsScoreType PEN = 4

Field Value

OddsScoreType
See Also

Reference

OddsScoreType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


OddsScoreType.SCORE Field

OddsScoreTypeSCORE Field

Score after a goal was scored.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsScoreType SCORE = 6

Field Value

OddsScoreType
See Also

Reference

OddsScoreType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


OddsScoreType.UNDEFINED Field

OddsScoreTypeUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const OddsScoreType UNDEFINED = 0

Field Value

OddsScoreType
See Also

Reference

OddsScoreType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


OddsScoreType.value__ Field

OddsScoreTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds.OddsScoreType.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

OddsScoreType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


RegisterUnregisterBetType Class

Supports activation of the whole match as well as activation of odds types and nested odds fields for a particular match.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsRegisterUnregisterBetType

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RegisterUnregisterBetType

The RegisterUnregisterBetType type exposes the following members.

Constructors
 | Name | Description
Public method | RegisterUnregisterBetType | Initializes a new instance of the RegisterUnregisterBetType class
Top
Properties
 | Name | Description
Public property | BetTypes | Activation of odds types and nested odds fields for this match
Public property | MatchId | Match id
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


RegisterUnregisterBetType Constructor

Initializes a new instance of the RegisterUnregisterBetType class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RegisterUnregisterBetType()
See Also

Reference

RegisterUnregisterBetType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


RegisterUnregisterBetType Properties

The RegisterUnregisterBetType type exposes the following members.

Properties
 | Name | Description
Public property | BetTypes | Activation of odds types and nested odds fields for this match
Public property | MatchId | Match id
Top
See Also

Reference

RegisterUnregisterBetType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


RegisterUnregisterBetType.BetTypes Property

RegisterUnregisterBetTypeBetTypes Property

Activation of odds types and nested odds fields for this match

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<EventOddsLite> BetTypes { get; set; }

Property Value

List EventOddsLite
See Also

Reference

RegisterUnregisterBetType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


RegisterUnregisterBetType.MatchId Property

RegisterUnregisterBetTypeMatchId Property

Match id

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long MatchId { get; set; }

Property Value

Int64
See Also

Reference

RegisterUnregisterBetType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


RegisterUnregisterBetType Methods

The RegisterUnregisterBetType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

RegisterUnregisterBetType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


RegisterUnregisterBetType.ToString Method

RegisterUnregisterBetTypeToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

RegisterUnregisterBetType Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreCardSummary Class

Used for live reporting of results/cards and final results (e.g. fulltime, halftime, overtime).
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsScoreCardSummary

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ScoreCardSummary : SingleHeaderEvent

The ScoreCardSummary type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | CardsByTime | List of card summaries sorted by time
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ScoresByTime | List of score summaries sorted by time
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderEventToString)
Top
Remarks
Evaluation of the bet outcomes is the responsibility of the Client system.
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreCardSummary Properties

The ScoreCardSummary type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | CardsByTime | List of card summaries sorted by time
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ScoresByTime | List of score summaries sorted by time
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

ScoreCardSummary Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreCardSummary.CardsByTime Property

ScoreCardSummaryCardsByTime Property

List of card summaries sorted by time

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<CardEntry> CardsByTime { get; }

Property Value

List CardEntry
See Also

Reference

ScoreCardSummary Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreCardSummary.ScoresByTime Property

ScoreCardSummaryScoresByTime Property

List of score summaries sorted by time

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<ScoreEntry> ScoresByTime { get; }

Property Value

List ScoreEntry
See Also

Reference

ScoreCardSummary Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreCardSummary Methods

The ScoreCardSummary type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderEventToString)
Top
See Also

Reference

ScoreCardSummary Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreCardSummary.ToString Method

ScoreCardSummaryToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

ScoreCardSummary Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreEntry Class

Score summary by time that is updated live or when final results after full/half/over time are known.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsBaseScoreCardEntry
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsScoreEntry

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ScoreEntry : BaseScoreCardEntry

The ScoreEntry type exposes the following members.

Constructors
 | Name | Description
Public method | ScoreEntry | Initializes a new instance of the ScoreEntry class
Top
Properties
 | Name | Description
Public property | AffectedPlayer | Player that scored or received a card. (Inherited from BaseScoreCardEntry)
Public property | AffectedTeam | Team that scored or received a card. (Inherited from BaseScoreCardEntry)
Public property | Cancelled | True if a particular score or card has been cancelled. After this a new message with the correct score will be sent for score cancelling. (Inherited from BaseScoreCardEntry)
Public property | Id | Id that uniquely identifies each score and card. For score types "ht", "ft", "ot" and "pen" Id will not be set. (Inherited from BaseScoreCardEntry)
Public property | PlayerId | Id of player that scored or received a card. (Inherited from BaseScoreCardEntry)
Public property | Score | Score (home:away)
Public property | Time | Match time in minutes when the goal/card occurred. When no time is known it is set to “-1", and the AffectedPlayer property is empty. (Inherited from BaseScoreCardEntry)
Public property | Type | Indicates score type during a match (e.g. full time, half time, live, etc.).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides BaseScoreCardEntryToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreEntry Constructor

Initializes a new instance of the ScoreEntry class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoreEntry()
See Also

Reference

ScoreEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreEntry Properties

The ScoreEntry type exposes the following members.

Properties
 | Name | Description
Public property | AffectedPlayer | Player that scored or received a card. (Inherited from BaseScoreCardEntry)
Public property | AffectedTeam | Team that scored or received a card. (Inherited from BaseScoreCardEntry)
Public property | Cancelled | True if a particular score or card has been cancelled. After this a new message with the correct score will be sent for score cancelling. (Inherited from BaseScoreCardEntry)
Public property | Id | Id that uniquely identifies each score and card. For score types "ht", "ft", "ot" and "pen" Id will not be set. (Inherited from BaseScoreCardEntry)
Public property | PlayerId | Id of player that scored or received a card. (Inherited from BaseScoreCardEntry)
Public property | Score | Score (home:away)
Public property | Time | Match time in minutes when the goal/card occurred. When no time is known it is set to “-1", and the AffectedPlayer property is empty. (Inherited from BaseScoreCardEntry)
Public property | Type | Indicates score type during a match (e.g. full time, half time, live, etc.).
Top
See Also

Reference

ScoreEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreEntry.Score Property

ScoreEntryScore Property

Score (home:away)

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<double> Score { get; }

Property Value

HomeAway Double
See Also

Reference

ScoreEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreEntry.Type Property

ScoreEntryType Property

Indicates score type during a match (e.g. full time, half time, live, etc.).

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsScoreType Type { get; }

Property Value

OddsScoreType
See Also

Reference

ScoreEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreEntry Methods

The ScoreEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides BaseScoreCardEntryToString)
Top
See Also

Reference

ScoreEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


ScoreEntry.ToString Method

ScoreEntryToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

ScoreEntry Class
Sportradar.SDK.FeedProviders.LiveOdds.LiveOdds Namespace


Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace

Classes
Class | Description
Public class | AliveWithOutrights | Represents an alive message containing both events and outright information
Public class | AliveWithOutrightsEventArgs | Event arguments passed with OnAliveWithOutrights.
Public class | MatchAndOutrightMetaData | Contains meta information for associated matches and outrights
Public class | OutrightBetCancel | Indicates that an odds type for an outright has been cancelled for a reason. All bets accepted on the odds with that id should be cancelled and cashed out with an odd of 1,0 (stakes returned).
Public class | OutrightBetCancelEventArgs | Event arguments passed with OnOutrightBetCancel.
Public class OutrightBetClear

Indicates that a situation occurred during the match so that a bet can be decided. Time which is set to (Timestamp - Time) seconds indicates the time at which the event happened. The message also includes the match element indicating the match id and the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField and the status of the outcomes.

Some bettypes, like Asian handicap and Asian total, can also include void factor for each EventOddsField element. Void factor can either be 1 or 0.5 indicating that the whole or half the bet is voided and should be refunded to the customer. When the void factor is set to 0.5 the outcome attribute will indicate if the other half is won or lost.

The id attribute in the Odds element corresponds to the odds elements in the previously sent out odds change messages. Evaluation of bet outcomes is responsibility of the client.

Public class | OutrightBetClearEventArgs | Event arguments passed with OnOutrightBetClear.
Public class | OutrightBetStart | Indicates that the bets for a particular outright can open again. The message contains s Timestamp and also a Time attribute which tells when the situation occurred in seconds before the Timestamp. If time is 0, bet start is from timestamp, if time > 0, bet start is from (Timestamp - Time).
Public class | OutrightBetStartEventArgs | Event arguments passed with OnOutrightBetStart.
Public class | OutrightBetStop | Indicates that a betstop situation occurred during a match (e.g. goal, red card or other important event occurred). When the bets can open again, a "betstart" message will be sent. Bet stop message contains Timestamp and also a Time attribute which tells when the situation occurred in seconds before the Timestamp. If time is 0 betstop is from timestamp, if time > 0, betstop is from (Timestamp - Time).
Public class | OutrightBetStopEventArgs | Event arguments passed with OnOutrightBetStop.
Public class | OutrightHeader | Contains basic information about an outright
Public class | OutrightHeaderInfo | Combines a OutrightHeader and OutrightInfo instances
Public class | OutrightInfo | Outright information containing the date and time, sport, category and tournament of the outright and what TV-channels this match is broadcasted on.
Public class | OutrightOddsChange | When an odds change occurs, all the odds types for that match are sent in a message. Only active odds types contain odds fields, while inactive odds types do not. Each odds type also has an attribute named changed which indicates whether this odds type has been changed or not. An attribute score indicates the current score in the match.
Public class | OutrightOddsChangeEventArgs | Event arguments passed with OnOutrightOddsChange.
Public class | SingleOutrightEvent | Base class for events associated with (only) one outright
Public class | SingleOutrightWithOddsEvent | Represents an event associated with a single outright which carries odds information
Interfaces
 | Interface | Description
Public interface | ILiveOddsWithOutrights | Interface describing events and methods common for all LiveOdds feeds containing outrights


AliveWithOutrights Class

Represents an alive message containing both events and outright information
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonAlive
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsAliveWithOutrights

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class AliveWithOutrights : Alive

The AliveWithOutrights type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeaders | List of empty event elements to identify the events that Betradar system supplies live odds for at the given time (with betstatus and score information). (Inherited from Alive)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | OutrightHeaders | Gets a list of OutrightHeader items identifying outrights that Betradar is supplying at a given time
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a String representation of the current AliveWithOutrights instance (Overrides AliveToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


AliveWithOutrights Properties

The AliveWithOutrights type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeaders | List of empty event elements to identify the events that Betradar system supplies live odds for at the given time (with betstatus and score information). (Inherited from Alive)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | OutrightHeaders | Gets a list of OutrightHeader items identifying outrights that Betradar is supplying at a given time
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

AliveWithOutrights Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


AliveWithOutrights.OutrightHeaders Property

AliveWithOutrightsOutrightHeaders Property

Gets a list of OutrightHeader items identifying outrights that Betradar is supplying at a given time

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<OutrightHeader> OutrightHeaders { get; }

Property Value

List OutrightHeader
See Also

Reference

AliveWithOutrights Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


AliveWithOutrights Methods

The AliveWithOutrights type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a String representation of the current AliveWithOutrights instance (Overrides AliveToString)
Top
See Also

Reference

AliveWithOutrights Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


AliveWithOutrights.ToString Method

AliveWithOutrightsToString Method

Returns a String representation of the current AliveWithOutrights instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
a String representation of the current AliveWithOutrights instance
See Also

Reference

AliveWithOutrights Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


AliveWithOutrightsEventArgs Class

Event arguments passed with OnAliveWithOutrights.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsAliveWithOutrightsEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class AliveWithOutrightsEventArgs : EventArgs

The AliveWithOutrightsEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AliveWithOutrights | Gets a AliveWithOutrights instance containing information about current events and outrights
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


AliveWithOutrightsEventArgs Properties

The AliveWithOutrightsEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AliveWithOutrights | Gets a AliveWithOutrights instance containing information about current events and outrights
Top
See Also

Reference

AliveWithOutrightsEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


AliveWithOutrightsEventArgs.AliveWithOutrights Property

AliveWithOutrightsEventArgsAliveWithOutrights Property

Gets a AliveWithOutrights instance containing information about current events and outrights

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public AliveWithOutrights AliveWithOutrights { get; }

Property Value

AliveWithOutrights
See Also

Reference

AliveWithOutrightsEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


AliveWithOutrightsEventArgs Methods

The AliveWithOutrightsEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AliveWithOutrightsEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights Interface

Interface describing events and methods common for all LiveOdds feeds containing outrights

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOddsWithOutrights : ILiveOddsCommonBase,
    ILiveFeeds, IStartable

The ILiveOddsWithOutrights type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from ILiveFeeds)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from ILiveOddsCommonBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from ILiveFeeds)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from ILiveFeeds)
Public property | ServerTime | Get approximate server time. (Inherited from ILiveFeeds)
Public property | SubscribedEvents | All event ids we are currently subscribed to. (Inherited from ILiveFeeds)
Top
Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface. (Inherited from ILiveFeeds)
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup. (Inherited from ILiveFeeds)
Public method | GetEventList(IEnumerableInt64) | Request meta-information about the events(matches, races) specified by it's ids The response message includes teams playing, match date and time, TV channel names and sport/category/tournament for every match. (Inherited from ILiveOddsCommonBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | Request meta-information about all events(matches, races, outcomes, ...) in a given interval. The maximum interval is 10 days. If no date is specified, all events started 24 hours in the past, and 7 days in the future are returned. The response message includes teams playing, event date and time, TV channel names and sport/category/tournament for every event. (Inherited from ILiveOddsCommonBase)
Public method | GetEventMessages | Request exact match messages ("error" server request). (Inherited from ILiveOddsCommonBase)
Public method | GetEventsStatus | Requests the match statuses for a given time ("current" server request). This includes odds, activation of odds and match status for the matches requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetEventStatus | Requests the match status for a given time ("current" server request). This includes odds, activation of odds and match status for the match requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetOutrightList | Request meta-information about outrights specified by it's ids
Public method | GetOutrightsStatus | Requests the outright statuses for a given time ("current" server request). This includes odds, activation of odds and status for the outright requested, current bet status and all bet clearing messages before the timestamp.
Public method | GetOutrightStatus | Requests the outright status for a given time ("current" server request). This includes odds, activation of odds and status for the ouright requested, current bet status and all bet clearing messages before the timestamp.
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events. (Inherited from ILiveFeeds)
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent. (Inherited from ILiveFeeds)
Top
Events
Name | Description
Public event | OnAliveWithOutrights | Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
Public event OnBetCancel Signals that odds type for a match should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
(Inherited from ILiveOddsCommonBase)
Public event OnBetCancelUndo Signals that an odds type has been cancelled due to some reason when it actually shouldnt have been. This can be undone. The Odds element should match the Odds element in the corresponding OnCancelBet event. The same goes for the starttime and endtime - they should match the values in the OnCancelBet event.
(Inherited from ILiveOddsCommonBase)
Public event OnBetClear

Signals that situation occurred during the match so that a bet can be decided. Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

(Inherited from ILiveOddsCommonBase)
Public event OnBetClearRollback Signals that there was some wrong information sent out about bet clearing. Notification includes the Odds element that rollback is targeted to. The clearedscore contains the cleared score of the original bet clearing. The time for the original bet clearing is timestamp – time seconds. The Odds element includes a list of EventOddsField elements to indicate what field was cleared in the original bet clearing. The Client system is responsible to handle this accordingly.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStart Signals that bets for a specific match can open again after they have been stopped.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStop Signals that a bet stop situation occurred for a specific match. OnBetStart event is triggered when the bets can open again.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionStable Signals that the initial sync is complete and the connection to the server is stable.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionUnstable Signals that the connection is unstable.
(Inherited from ILiveOddsCommonBase)
Public event OnEventMessages Signals that all of the requested match messages were received.
(Inherited from ILiveOddsCommonBase)
Public event OnEventStatus Signals that a requested match status was received.
(Inherited from ILiveOddsCommonBase)
Public event OnFeedError Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
(Inherited from ILiveFeeds)
Public event OnMetaInfo Event contains information like the date and time of the match, sport, category, tournament, teams and what TV-channels a match is broadcasted on. When a match is removed, Active is set to false for the match with an optional textual reason why the match has been removed. Active flag can also set to false if the client has unregistered a match. The message element will include the text unregistered in such cases. Match meta-information will also be broadcasted when a match is added to the system, or when a match has been cancelled.
(Inherited from ILiveOddsCommonBase)
Public event OnOddsChange Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
(Inherited from ILiveOddsCommonBase)
Public event | OnOutrightBetCancel | Signals that odds type for an outright should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
Public event OnOutrightBetClear

Signals that bets placed on this outright can be settled Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

Public event | OnOutrightBetStart | Signals that bets for a specific outright can open again after they have been stopped.
Public event | OnOutrightBetStop | Signals that a bet stop situation occurred for a specific outright. OnBetStart event is triggered when the bets can open again.
Public event | OnOutrightOddsChange | Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
Public event | OnOutrightStatus | Occurs when outright status messages are received
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights Properties

The ILiveOddsWithOutrights type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from ILiveFeeds)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from ILiveOddsCommonBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from ILiveFeeds)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from ILiveFeeds)
Public property | ServerTime | Get approximate server time. (Inherited from ILiveFeeds)
Public property | SubscribedEvents | All event ids we are currently subscribed to. (Inherited from ILiveFeeds)
Top
See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights Methods

The ILiveOddsWithOutrights type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface. (Inherited from ILiveFeeds)
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup. (Inherited from ILiveFeeds)
Public method | GetEventList(IEnumerableInt64) | Request meta-information about the events(matches, races) specified by it's ids The response message includes teams playing, match date and time, TV channel names and sport/category/tournament for every match. (Inherited from ILiveOddsCommonBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | Request meta-information about all events(matches, races, outcomes, ...) in a given interval. The maximum interval is 10 days. If no date is specified, all events started 24 hours in the past, and 7 days in the future are returned. The response message includes teams playing, event date and time, TV channel names and sport/category/tournament for every event. (Inherited from ILiveOddsCommonBase)
Public method | GetEventMessages | Request exact match messages ("error" server request). (Inherited from ILiveOddsCommonBase)
Public method | GetEventsStatus | Requests the match statuses for a given time ("current" server request). This includes odds, activation of odds and match status for the matches requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetEventStatus | Requests the match status for a given time ("current" server request). This includes odds, activation of odds and match status for the match requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetOutrightList | Request meta-information about outrights specified by it's ids
Public method | GetOutrightsStatus | Requests the outright statuses for a given time ("current" server request). This includes odds, activation of odds and status for the outright requested, current bet status and all bet clearing messages before the timestamp.
Public method | GetOutrightStatus | Requests the outright status for a given time ("current" server request). This includes odds, activation of odds and status for the ouright requested, current bet status and all bet clearing messages before the timestamp.
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events. (Inherited from ILiveFeeds)
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent. (Inherited from ILiveFeeds)
Top
See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights.GetOutrightList Method

ILiveOddsWithOutrightsGetOutrightList Method

Request meta-information about outrights specified by it's ids

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long GetOutrightList(
    IEnumerable<long> outright_ids
)

Parameters

outright_ids IEnumerable Int64
Specifies the outrights for which to retrieve meta info

Return Value

Int64
Returns immediately with the request number or zero, but expect to receive [!:ILiveOdds.OnMetaInfo] event in response
See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights.GetOutrightsStatus Method

ILiveOddsWithOutrightsGetOutrightsStatus Method

Requests the outright statuses for a given time ("current" server request). This includes odds, activation of odds and status for the outright requested, current bet status and all bet clearing messages before the timestamp.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long GetOutrightsStatus(
    IEnumerable<long> outright_ids,
    DateTime? from = null,
    bool package = true
)

Parameters

outright_ids IEnumerable Int64
Outright ids, maximum is 50 per request to avoid having server queue filling up
from Nullable DateTime (Optional)
Outrights statuses on particular time (leave null for current outright status)
package Boolean (Optional)
All replies get packaged in one see OnOutrightStatus when true; else normal events will get invoked.

Return Value

Int64
Returns immediately with the request number or zero but expect to receive an event afterwards.
Remarks
SDK already handles error recovery for on-going outrights, no matter whether there is a crash or connection to the server is lost, so during normal operation there should be no need to call this method! The purpose of it is for book-keeping after an outright has ended. For instance after an outright is not active anymore you might want to settle all open bets or check whether a match is really about to start. Notice that the match messages do not include a message number (msgnr). The received "state" is an abstract concept derived from the sent messages not any sent message so it cannot have a sequence number.
See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights.GetOutrightStatus Method

ILiveOddsWithOutrightsGetOutrightStatus Method

Requests the outright status for a given time ("current" server request). This includes odds, activation of odds and status for the ouright requested, current bet status and all bet clearing messages before the timestamp.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long GetOutrightStatus(
    long outright_id,
    DateTime? from = null,
    bool package = true
)

Parameters

outright_id Int64
Outright id
from Nullable DateTime (Optional)
Outright status on particular time (leave null for current outright status)
package Boolean (Optional)
All replies get packaged in one see OnOutrightStatus when true; else normal events will get invoked.

Return Value

Int64
Returns immediately with the request number or zero but expect to receive an event afterwards.
Remarks
SDK already handles error recovery for on-going outrights, no matter whether there is a crash or connection to the server is lost, so during normal operation there should be no need to call this method! The purpose of it is for book-keeping after an outright has ended. For instance after an outright is not active anymore you might want to settle all open bets or check whether a outright is really about to start. Notice that the outright messages do not include a message number (msgnr). The received "state" is an abstract concept derived from the sent messages not any sent message so it cannot have a sequence number.
See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights Events

The ILiveOddsWithOutrights type exposes the following members.

Events
Name | Description
Public event | OnAliveWithOutrights | Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
Public event OnBetCancel Signals that odds type for a match should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
(Inherited from ILiveOddsCommonBase)
Public event OnBetCancelUndo Signals that an odds type has been cancelled due to some reason when it actually shouldnt have been. This can be undone. The Odds element should match the Odds element in the corresponding OnCancelBet event. The same goes for the starttime and endtime - they should match the values in the OnCancelBet event.
(Inherited from ILiveOddsCommonBase)
Public event OnBetClear

Signals that situation occurred during the match so that a bet can be decided. Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

(Inherited from ILiveOddsCommonBase)
Public event OnBetClearRollback Signals that there was some wrong information sent out about bet clearing. Notification includes the Odds element that rollback is targeted to. The clearedscore contains the cleared score of the original bet clearing. The time for the original bet clearing is timestamp – time seconds. The Odds element includes a list of EventOddsField elements to indicate what field was cleared in the original bet clearing. The Client system is responsible to handle this accordingly.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStart Signals that bets for a specific match can open again after they have been stopped.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStop Signals that a bet stop situation occurred for a specific match. OnBetStart event is triggered when the bets can open again.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionStable Signals that the initial sync is complete and the connection to the server is stable.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionUnstable Signals that the connection is unstable.
(Inherited from ILiveOddsCommonBase)
Public event OnEventMessages Signals that all of the requested match messages were received.
(Inherited from ILiveOddsCommonBase)
Public event OnEventStatus Signals that a requested match status was received.
(Inherited from ILiveOddsCommonBase)
Public event OnFeedError Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
(Inherited from ILiveFeeds)
Public event OnMetaInfo Event contains information like the date and time of the match, sport, category, tournament, teams and what TV-channels a match is broadcasted on. When a match is removed, Active is set to false for the match with an optional textual reason why the match has been removed. Active flag can also set to false if the client has unregistered a match. The message element will include the text unregistered in such cases. Match meta-information will also be broadcasted when a match is added to the system, or when a match has been cancelled.
(Inherited from ILiveOddsCommonBase)
Public event OnOddsChange Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
(Inherited from ILiveOddsCommonBase)
Public event | OnOutrightBetCancel | Signals that odds type for an outright should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
Public event OnOutrightBetClear

Signals that bets placed on this outright can be settled Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

Public event | OnOutrightBetStart | Signals that bets for a specific outright can open again after they have been stopped.
Public event | OnOutrightBetStop | Signals that a bet stop situation occurred for a specific outright. OnBetStart event is triggered when the bets can open again.
Public event | OnOutrightOddsChange | Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
Public event | OnOutrightStatus | Occurs when outright status messages are received
Top
See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights.OnAliveWithOutrights Event

ILiveOddsWithOutrightsOnAliveWithOutrights Event

Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<AliveWithOutrightsEventArgs> OnAliveWithOutrights

Value

EventHandler AliveWithOutrightsEventArgs
Remarks
SDK will send out bet stops for all matches if no alive message has been received in the last 20 seconds. In this case client shouldn't accept any bets for any matches until the connection is stable again. SDK will also take care that if the connection to the Betradar server is lost, bet stops for all matches are sent out until a stable connection is established again.
See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights.OnOutrightBetCancel Event

ILiveOddsWithOutrightsOnOutrightBetCancel Event

Signals that odds type for an outright should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OutrightBetCancelEventArgs> OnOutrightBetCancel

Value

EventHandler OutrightBetCancelEventArgs
See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights.OnOutrightBetClear Event

ILiveOddsWithOutrightsOnOutrightBetClear Event

Signals that bets placed on this outright can be settled Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OutrightBetClearEventArgs> OnOutrightBetClear

Value

EventHandler OutrightBetClearEventArgs
Remarks

Some bettypes, like asian handicap and asian total, can include void factor for each EventOddsField element. Void factor can either be 1 or 0.5 indicating that the whole or half the bet is voided and should be refunded to the customer. When the void factor is set to 0.5 the outcome attribute will indicate if the other half has won or lost.

These are all possible combinations of outcome and void factors:

  1. outcome="0" and no voidfactor: Lose entire bet
  2. outcome="1" and no voidfactor: Win entire bet
  3. outcome="0" and voidfactor="1": Refund entire bet
  4. outcome="1" and voidfactor="0.5": Refund half bet and win other half
  5. outcome="0" and voidfactor="0.5": Refund half bet and lose other half

See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights.OnOutrightBetStart Event

ILiveOddsWithOutrightsOnOutrightBetStart Event

Signals that bets for a specific outright can open again after they have been stopped.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OutrightBetStartEventArgs> OnOutrightBetStart

Value

EventHandler OutrightBetStartEventArgs
See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights.OnOutrightBetStop Event

ILiveOddsWithOutrightsOnOutrightBetStop Event

Signals that a bet stop situation occurred for a specific outright. OnBetStart event is triggered when the bets can open again.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OutrightBetStopEventArgs> OnOutrightBetStop

Value

EventHandler OutrightBetStopEventArgs
Remarks
Bet stop is triggered after following events take place:
  1. Goals
  2. Red cards
  3. Penalty
  4. One on one situations
  5. Free kicks within 20 meters
  6. Match is interrupted temporarily
Administrative events which cause a bet stop condition:
  1. Loss of TV coverage
  2. Loss of connection to the scout
See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights.OnOutrightOddsChange Event

ILiveOddsWithOutrightsOnOutrightOddsChange Event

Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<OutrightOddsChangeEventArgs> OnOutrightOddsChange

Value

EventHandler OutrightOddsChangeEventArgs
See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


ILiveOddsWithOutrights.OnOutrightStatus Event

ILiveOddsWithOutrightsOnOutrightStatus Event

Occurs when outright status messages are received

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<EventDataReceivedEventArgs> OnOutrightStatus

Value

EventHandler EventDataReceivedEventArgs
See Also

Reference

ILiveOddsWithOutrights Interface
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


MatchAndOutrightMetaData Class

Contains meta information for associated matches and outrights
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonMetaInfoDataContainer
Sportradar.SDK.FeedProviders.LiveOdds.LiveOddsLiveOddsMetaData
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsMatchAndOutrightMetaData

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchAndOutrightMetaData : LiveOddsMetaData

The MatchAndOutrightMetaData type exposes the following members.

Properties
 | Name | Description
Public property | MatchHeaderInfos | Match meta information. (Inherited from LiveOddsMetaData)
Public property | OutrightHeaderInfos | Gets a list of OutrightHeaderInfo instances containing meta information about associated outrights
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a String representation of the current MatchAndOutrightMetaData instance (Overrides LiveOddsMetaDataToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


MatchAndOutrightMetaData Properties

The MatchAndOutrightMetaData type exposes the following members.

Properties
 | Name | Description
Public property | MatchHeaderInfos | Match meta information. (Inherited from LiveOddsMetaData)
Public property | OutrightHeaderInfos | Gets a list of OutrightHeaderInfo instances containing meta information about associated outrights
Top
See Also

Reference

MatchAndOutrightMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


MatchAndOutrightMetaData.OutrightHeaderInfos Property

MatchAndOutrightMetaDataOutrightHeaderInfos Property

Gets a list of OutrightHeaderInfo instances containing meta information about associated outrights

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<OutrightHeaderInfo> OutrightHeaderInfos { get; }

Property Value

List OutrightHeaderInfo
See Also

Reference

MatchAndOutrightMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


MatchAndOutrightMetaData Methods

The MatchAndOutrightMetaData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a String representation of the current MatchAndOutrightMetaData instance (Overrides LiveOddsMetaDataToString)
Top
See Also

Reference

MatchAndOutrightMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


MatchAndOutrightMetaData.ToString Method

MatchAndOutrightMetaDataToString Method

Returns a String representation of the current MatchAndOutrightMetaData instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
a String representation of the current MatchAndOutrightMetaData instance
See Also

Reference

MatchAndOutrightMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetCancel Class

Indicates that an odds type for an outright has been cancelled for a reason. All bets accepted on the odds with that id should be cancelled and cashed out with an odd of 1,0 (stakes returned).
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightEvent
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightWithOddsEvent
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightBetCancel

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightBetCancel : SingleOutrightWithOddsEvent

The OutrightBetCancel type exposes the following members.

Constructors
 | Name | Description
Public method | OutrightBetCancel | Initializes a new instance of the OutrightBetCancel class
Top
Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Gets a list of EventOdds instances representing the odds for the outright associated with the current SingleOutrightWithOddsEvent instance (Inherited from SingleOutrightWithOddsEvent)
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event (Inherited from SingleOutrightEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current OutrightBetCancel instance (Overrides SingleOutrightWithOddsEventToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetCancel Constructor

Initializes a new instance of the OutrightBetCancel class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightBetCancel(
    XmlAttribute[] any_attr
)

Parameters

any_attr XmlAttribute
An array of XmlAttribute containing extra values
See Also

Reference

OutrightBetCancel Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetCancel Properties

The OutrightBetCancel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Gets a list of EventOdds instances representing the odds for the outright associated with the current SingleOutrightWithOddsEvent instance (Inherited from SingleOutrightWithOddsEvent)
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event (Inherited from SingleOutrightEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

OutrightBetCancel Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetCancel Methods

The OutrightBetCancel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current OutrightBetCancel instance (Overrides SingleOutrightWithOddsEventToString)
Top
See Also

Reference

OutrightBetCancel Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetCancel.ToString Method

OutrightBetCancelToString Method

Returnes a String representation of the current OutrightBetCancel instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
a String representation of the current OutrightBetCancel instance
See Also

Reference

OutrightBetCancel Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetCancelEventArgs Class

Event arguments passed with OnOutrightBetCancel.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightBetCancelEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightBetCancelEventArgs : EventArgs

The OutrightBetCancelEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OutrightBetCancel | Gets a OutrightBetCancel instance containing information about cancelled markets and the associated outright
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetCancelEventArgs Properties

The OutrightBetCancelEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OutrightBetCancel | Gets a OutrightBetCancel instance containing information about cancelled markets and the associated outright
Top
See Also

Reference

OutrightBetCancelEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetCancelEventArgs.OutrightBetCancel Property

OutrightBetCancelEventArgsOutrightBetCancel Property

Gets a OutrightBetCancel instance containing information about cancelled markets and the associated outright

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightBetCancel OutrightBetCancel { get; }

Property Value

OutrightBetCancel
See Also

Reference

OutrightBetCancelEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetCancelEventArgs Methods

The OutrightBetCancelEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OutrightBetCancelEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetClear Class

Indicates that a situation occurred during the match so that a bet can be decided. Time which is set to (Timestamp - Time) seconds indicates the time at which the event happened. The message also includes the match element indicating the match id and the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField and the status of the outcomes.

Some bettypes, like Asian handicap and Asian total, can also include void factor for each EventOddsField element. Void factor can either be 1 or 0.5 indicating that the whole or half the bet is voided and should be refunded to the customer. When the void factor is set to 0.5 the outcome attribute will indicate if the other half is won or lost.

The id attribute in the Odds element corresponds to the odds elements in the previously sent out odds change messages. Evaluation of bet outcomes is responsibility of the client.

Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightEvent
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightWithOddsEvent
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightBetClear

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightBetClear : SingleOutrightWithOddsEvent

The OutrightBetClear type exposes the following members.

Constructors
 | Name | Description
Public method | OutrightBetClear | Initializes a new instance of the OutrightBetClear class
Top
Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Gets a list of EventOdds instances representing the odds for the outright associated with the current SingleOutrightWithOddsEvent instance (Inherited from SingleOutrightWithOddsEvent)
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event (Inherited from SingleOutrightEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current OutrightBetClear instance (Overrides SingleOutrightWithOddsEventToString)
Top
Remarks
Possible combinations of outcome and void factor:
  • outcome="0" and no voidfactor: Lose entire bet
  • outcome="1" and no voidfactor: Win entire bet
  • outcome="0" and voidfactor="1": Refund entire bet
  • outcome="1" and voidfactor="0.5": Refund half bet and win other half
  • outcome="0" and voidfactor="0.5": Refund half bet and lose other half
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetClear Constructor

Initializes a new instance of the OutrightBetClear class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightBetClear(
    XmlAttribute[] any_attr
)

Parameters

any_attr XmlAttribute
An array of XmlAttribute containing extra values
See Also

Reference

OutrightBetClear Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetClear Properties

The OutrightBetClear type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Gets a list of EventOdds instances representing the odds for the outright associated with the current SingleOutrightWithOddsEvent instance (Inherited from SingleOutrightWithOddsEvent)
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event (Inherited from SingleOutrightEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

OutrightBetClear Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetClear Methods

The OutrightBetClear type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current OutrightBetClear instance (Overrides SingleOutrightWithOddsEventToString)
Top
See Also

Reference

OutrightBetClear Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetClear.ToString Method

OutrightBetClearToString Method

Returnes a String representation of the current OutrightBetClear instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
a String representation of the current OutrightBetClear instance
See Also

Reference

OutrightBetClear Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetClearEventArgs Class

Event arguments passed with OnOutrightBetClear.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightBetClearEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightBetClearEventArgs : EventArgs

The OutrightBetClearEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OutrightBetClear | Gets a OutrightBetClear instance containing information about cleared markets and associated outright
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetClearEventArgs Properties

The OutrightBetClearEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OutrightBetClear | Gets a OutrightBetClear instance containing information about cleared markets and associated outright
Top
See Also

Reference

OutrightBetClearEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetClearEventArgs.OutrightBetClear Property

OutrightBetClearEventArgsOutrightBetClear Property

Gets a OutrightBetClear instance containing information about cleared markets and associated outright

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightBetClear OutrightBetClear { get; }

Property Value

OutrightBetClear
See Also

Reference

OutrightBetClearEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetClearEventArgs Methods

The OutrightBetClearEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OutrightBetClearEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStart Class

Indicates that the bets for a particular outright can open again. The message contains s Timestamp and also a Time attribute which tells when the situation occurred in seconds before the Timestamp. If time is 0, bet start is from timestamp, if time > 0, bet start is from (Timestamp - Time).
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightEvent
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightBetStart

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightBetStart : SingleOutrightEvent

The OutrightBetStart type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event (Inherited from SingleOutrightEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current OutrightBetStart instance (Overrides SingleOutrightEventToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStart Properties

The OutrightBetStart type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event (Inherited from SingleOutrightEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

OutrightBetStart Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStart Methods

The OutrightBetStart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current OutrightBetStart instance (Overrides SingleOutrightEventToString)
Top
See Also

Reference

OutrightBetStart Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStart.ToString Method

OutrightBetStartToString Method

Returnes a String representation of the current OutrightBetStart instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
a String representation of the current OutrightBetStart instance
See Also

Reference

OutrightBetStart Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStartEventArgs Class

Event arguments passed with OnOutrightBetStart.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightBetStartEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightBetStartEventArgs : EventArgs

The OutrightBetStartEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OutrightBetStart | Gets a OutrightBetStart instance containing information about outright on which the betting can be started
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStartEventArgs Properties

The OutrightBetStartEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OutrightBetStart | Gets a OutrightBetStart instance containing information about outright on which the betting can be started
Top
See Also

Reference

OutrightBetStartEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStartEventArgs.OutrightBetStart Property

OutrightBetStartEventArgsOutrightBetStart Property

Gets a OutrightBetStart instance containing information about outright on which the betting can be started

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightBetStart OutrightBetStart { get; }

Property Value

OutrightBetStart
See Also

Reference

OutrightBetStartEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStartEventArgs Methods

The OutrightBetStartEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OutrightBetStartEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStop Class

Indicates that a betstop situation occurred during a match (e.g. goal, red card or other important event occurred). When the bets can open again, a "betstart" message will be sent. Bet stop message contains Timestamp and also a Time attribute which tells when the situation occurred in seconds before the Timestamp. If time is 0 betstop is from timestamp, if time > 0, betstop is from (Timestamp - Time).
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightEvent
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightBetStop

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightBetStop : SingleOutrightEvent

The OutrightBetStop type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsArtifical | Gets a value indicating whether current OutrightBetStop was issued by the SDK itself or as a result of message received thrgough the feed
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event (Inherited from SingleOutrightEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current OutrightBetStop instance (Overrides SingleOutrightEventToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStop Properties

The OutrightBetStop type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsArtifical | Gets a value indicating whether current OutrightBetStop was issued by the SDK itself or as a result of message received thrgough the feed
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event (Inherited from SingleOutrightEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

OutrightBetStop Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStop.IsArtifical Property

OutrightBetStopIsArtifical Property

Gets a value indicating whether current OutrightBetStop was issued by the SDK itself or as a result of message received thrgough the feed

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsArtifical { get; }

Property Value

Boolean
See Also

Reference

OutrightBetStop Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStop Methods

The OutrightBetStop type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current OutrightBetStop instance (Overrides SingleOutrightEventToString)
Top
See Also

Reference

OutrightBetStop Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStop.ToString Method

OutrightBetStopToString Method

Returnes a String representation of the current OutrightBetStop instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
a String representation of the current OutrightBetStop instance
See Also

Reference

OutrightBetStop Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStopEventArgs Class

Event arguments passed with OnOutrightBetStop.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightBetStopEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightBetStopEventArgs : EventArgs

The OutrightBetStopEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OutrightBetStop | Gets a OutrightBetStop instance containing information about the outright on which the betting must be stopped
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStopEventArgs Properties

The OutrightBetStopEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OutrightBetStop | Gets a OutrightBetStop instance containing information about the outright on which the betting must be stopped
Top
See Also

Reference

OutrightBetStopEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStopEventArgs.OutrightBetStop Property

OutrightBetStopEventArgsOutrightBetStop Property

Gets a OutrightBetStop instance containing information about the outright on which the betting must be stopped

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightBetStop OutrightBetStop { get; }

Property Value

OutrightBetStop
See Also

Reference

OutrightBetStopEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightBetStopEventArgs Methods

The OutrightBetStopEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OutrightBetStopEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightHeader Class

Contains basic information about an outright
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonEventHeader
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightHeader

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightHeader : EventHeader

The OutrightHeader type exposes the following members.

Constructors
 | Name | Description
Public method | OutrightHeader | Initializes a new instance of the OutrightHeader class
Top
Properties
 | Name | Description
Public property | Active | Set to false when a match is removed (in this case also see the Message for the reason for removal). Also set to false if the client has unregistered a match. The message element will include the text "unregistered" in such case. (Inherited from EventHeader)
Public property | BetStatus | Current bet status (Inherited from EventHeader)
Public property | Id | Betradar id for the event (Inherited from EventHeader)
Public property | Message | Optional textual message attached to the match (e.g. why a match has been removed, information that a client has unregistered from a match, etc.) (Inherited from EventHeader)
Public property | Msgnr | Incremental message id that starts with 1 for every match. Only messages that changes the state of a match will include this property. Alive messages, meta-information and login response messages will not include this incremental id. (Inherited from EventHeader)
Public property | Status | Event status (Inherited from EventHeader)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a String representation of the current OutrightHeader instance (Overrides EventHeaderToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightHeader Constructor

Initializes a new instance of the OutrightHeader class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightHeader()
See Also

Reference

OutrightHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightHeader Properties

The OutrightHeader type exposes the following members.

Properties
 | Name | Description
Public property | Active | Set to false when a match is removed (in this case also see the Message for the reason for removal). Also set to false if the client has unregistered a match. The message element will include the text "unregistered" in such case. (Inherited from EventHeader)
Public property | BetStatus | Current bet status (Inherited from EventHeader)
Public property | Id | Betradar id for the event (Inherited from EventHeader)
Public property | Message | Optional textual message attached to the match (e.g. why a match has been removed, information that a client has unregistered from a match, etc.) (Inherited from EventHeader)
Public property | Msgnr | Incremental message id that starts with 1 for every match. Only messages that changes the state of a match will include this property. Alive messages, meta-information and login response messages will not include this incremental id. (Inherited from EventHeader)
Public property | Status | Event status (Inherited from EventHeader)
Top
See Also

Reference

OutrightHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightHeader Methods

The OutrightHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a String representation of the current OutrightHeader instance (Overrides EventHeaderToString)
Top
See Also

Reference

OutrightHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightHeader.ToString Method

OutrightHeaderToString Method

Returns a String representation of the current OutrightHeader instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
a String representation of the current OutrightHeader instance
See Also

Reference

OutrightHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightHeaderInfo Class

Combines a OutrightHeader and OutrightInfo instances
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightHeaderInfo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightHeaderInfo

The OutrightHeaderInfo type exposes the following members.

Constructors
 | Name | Description
Public method | OutrightHeaderInfo | Initializes a new instance of the OutrightHeaderInfo class
Top
Properties
 | Name | Description
Public property | OutrightHeader | Gets a OutrightHeader instance containing basic information about the outright
Public property | OutrightInfo | Gets a OutrightInfo instance containing extended information about the outright
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a String representation of the current OutrightHeaderInfo instance (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightHeaderInfo Constructor

Initializes a new instance of the OutrightHeaderInfo class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightHeaderInfo(
    OutrightHeader outrightHeader,
    OutrightInfo outrightInfo
)

Parameters

outrightHeader OutrightHeader
A OutrightHeader instance containing basic information about the outright
outrightInfo OutrightInfo
A OutrightInfo instance containing extended information about the outright
See Also

Reference

OutrightHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightHeaderInfo Properties

The OutrightHeaderInfo type exposes the following members.

Properties
 | Name | Description
Public property | OutrightHeader | Gets a OutrightHeader instance containing basic information about the outright
Public property | OutrightInfo | Gets a OutrightInfo instance containing extended information about the outright
Top
See Also

Reference

OutrightHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightHeaderInfo.OutrightHeader Property

OutrightHeaderInfoOutrightHeader Property

Gets a OutrightHeader instance containing basic information about the outright

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightHeader OutrightHeader { get; }

Property Value

OutrightHeader
See Also

Reference

OutrightHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightHeaderInfo.OutrightInfo Property

OutrightHeaderInfoOutrightInfo Property

Gets a OutrightInfo instance containing extended information about the outright

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightInfo OutrightInfo { get; }

Property Value

OutrightInfo
See Also

Reference

OutrightHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightHeaderInfo Methods

The OutrightHeaderInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a String representation of the current OutrightHeaderInfo instance (Overrides ObjectToString)
Top
See Also

Reference

OutrightHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightHeaderInfo.ToString Method

OutrightHeaderInfoToString Method

Returns a String representation of the current OutrightHeaderInfo instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
a String representation of the current OutrightHeaderInfo instance
See Also

Reference

OutrightHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightInfo Class

Outright information containing the date and time, sport, category and tournament of the outright and what TV-channels this match is broadcasted on.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightInfo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightInfo

The OutrightInfo type exposes the following members.

Constructors
 | Name | Description
Public method | OutrightInfo | Initializes a new instance of the OutrightInfo class
Top
Properties
 | Name | Description
Public property | Category | Gets a IdNameTuple specifying the category associated with the current OutrightInfo instance
Public property | EndDate | Gets a DateTime specifying the end-date of the outright represented by the current OutrightInfo instance
Public property | Name | Gets the name of the outright represented by the current OutrightInfo instance
Public property | Season | Gets a IdNameTuple specifying the season associated with the current OutrightInfo instance
Public property | Sport | Gets a IdNameTuple specifying the sport associated with the current OutrightInfo instance
Public property | Tournament | Gets a IdNameTuple specifying the tournament associated with the current OutrightInfo instance
Public property | UniqueTournament | Gets a IdNameTuple specifying the unique tournament associated with the current OutrightInfo instance
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a String representation of the current OutrightInfo instance (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightInfo Constructor

Initializes a new instance of the OutrightInfo class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightInfo()
See Also

Reference

OutrightInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightInfo Properties

The OutrightInfo type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets a IdNameTuple specifying the category associated with the current OutrightInfo instance
Public property | EndDate | Gets a DateTime specifying the end-date of the outright represented by the current OutrightInfo instance
Public property | Name | Gets the name of the outright represented by the current OutrightInfo instance
Public property | Season | Gets a IdNameTuple specifying the season associated with the current OutrightInfo instance
Public property | Sport | Gets a IdNameTuple specifying the sport associated with the current OutrightInfo instance
Public property | Tournament | Gets a IdNameTuple specifying the tournament associated with the current OutrightInfo instance
Public property | UniqueTournament | Gets a IdNameTuple specifying the unique tournament associated with the current OutrightInfo instance
Top
See Also

Reference

OutrightInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightInfo.Category Property

OutrightInfoCategory Property

Gets a IdNameTuple specifying the category associated with the current OutrightInfo instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Category { get; }

Property Value

IdNameTuple
See Also

Reference

OutrightInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightInfo.EndDate Property

OutrightInfoEndDate Property

Gets a DateTime specifying the end-date of the outright represented by the current OutrightInfo instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime EndDate { get; }

Property Value

DateTime
See Also

Reference

OutrightInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightInfo.Name Property

OutrightInfoName Property

Gets the name of the outright represented by the current OutrightInfo instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; }

Property Value

String
See Also

Reference

OutrightInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightInfo.Season Property

OutrightInfoSeason Property

Gets a IdNameTuple specifying the season associated with the current OutrightInfo instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Season { get; }

Property Value

IdNameTuple
See Also

Reference

OutrightInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightInfo.Sport Property

OutrightInfoSport Property

Gets a IdNameTuple specifying the sport associated with the current OutrightInfo instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Sport { get; }

Property Value

IdNameTuple
See Also

Reference

OutrightInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightInfo.Tournament Property

OutrightInfoTournament Property

Gets a IdNameTuple specifying the tournament associated with the current OutrightInfo instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Tournament { get; }

Property Value

IdNameTuple
See Also

Reference

OutrightInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightInfo.UniqueTournament Property

OutrightInfoUniqueTournament Property

Gets a IdNameTuple specifying the unique tournament associated with the current OutrightInfo instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple UniqueTournament { get; }

Property Value

IdNameTuple
See Also

Reference

OutrightInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightInfo Methods

The OutrightInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a String representation of the current OutrightInfo instance (Overrides ObjectToString)
Top
See Also

Reference

OutrightInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightInfo.ToString Method

OutrightInfoToString Method

Returns a String representation of the current OutrightInfo instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
a String representation of the current OutrightInfo instance
See Also

Reference

OutrightInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightOddsChange Class

When an odds change occurs, all the odds types for that match are sent in a message. Only active odds types contain odds fields, while inactive odds types do not. Each odds type also has an attribute named changed which indicates whether this odds type has been changed or not. An attribute score indicates the current score in the match.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightEvent
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightWithOddsEvent
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightOddsChange

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightOddsChange : SingleOutrightWithOddsEvent

The OutrightOddsChange type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Gets a list of EventOdds instances representing the odds for the outright associated with the current SingleOutrightWithOddsEvent instance (Inherited from SingleOutrightWithOddsEvent)
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event (Inherited from SingleOutrightEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current OutrightOddsChange instance (Overrides SingleOutrightWithOddsEventToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightOddsChange Properties

The OutrightOddsChange type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Gets a list of EventOdds instances representing the odds for the outright associated with the current SingleOutrightWithOddsEvent instance (Inherited from SingleOutrightWithOddsEvent)
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event (Inherited from SingleOutrightEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

OutrightOddsChange Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightOddsChange Methods

The OutrightOddsChange type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current OutrightOddsChange instance (Overrides SingleOutrightWithOddsEventToString)
Top
See Also

Reference

OutrightOddsChange Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightOddsChange.ToString Method

OutrightOddsChangeToString Method

Returnes a String representation of the current OutrightOddsChange instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
a String representation of the current OutrightOddsChange instance
See Also

Reference

OutrightOddsChange Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightOddsChangeEventArgs Class

Event arguments passed with OnOutrightOddsChange.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightOddsChangeEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OutrightOddsChangeEventArgs : EventArgs

The OutrightOddsChangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OutrightOddsChange | Gets a OutrightOddsChange instance containing new odds for the associated markets
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightOddsChangeEventArgs Properties

The OutrightOddsChangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OutrightOddsChange | Gets a OutrightOddsChange instance containing new odds for the associated markets
Top
See Also

Reference

OutrightOddsChangeEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightOddsChangeEventArgs.OutrightOddsChange Property

OutrightOddsChangeEventArgsOutrightOddsChange Property

Gets a OutrightOddsChange instance containing new odds for the associated markets

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightOddsChange OutrightOddsChange { get; }

Property Value

OutrightOddsChange
See Also

Reference

OutrightOddsChangeEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


OutrightOddsChangeEventArgs Methods

The OutrightOddsChangeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OutrightOddsChangeEventArgs Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


SingleOutrightEvent Class

Base class for events associated with (only) one outright
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightEvent
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightBetStart
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightBetStop
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightWithOddsEvent

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class SingleOutrightEvent : OddsEntityBase

The SingleOutrightEvent type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current SingleOutrightEvent instance (Overrides OddsEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


SingleOutrightEvent Properties

The SingleOutrightEvent type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

SingleOutrightEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


SingleOutrightEvent.OutrightHeader Property

SingleOutrightEventOutrightHeader Property

Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OutrightHeader OutrightHeader { get; }

Property Value

OutrightHeader
See Also

Reference

SingleOutrightEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


SingleOutrightEvent Methods

The SingleOutrightEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current SingleOutrightEvent instance (Overrides OddsEntityBaseToString)
Top
See Also

Reference

SingleOutrightEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


SingleOutrightEvent.ToString Method

SingleOutrightEventToString Method

Returnes a String representation of the current SingleOutrightEvent instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
a String representation of the current SingleOutrightEvent instance
See Also

Reference

SingleOutrightEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


SingleOutrightWithOddsEvent Class

Represents an event associated with a single outright which carries odds information
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightEvent
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsSingleOutrightWithOddsEvent
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightBetCancel
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightBetClear
Sportradar.SDK.FeedProviders.LiveOdds.OutrightsOutrightOddsChange

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class SingleOutrightWithOddsEvent : SingleOutrightEvent

The SingleOutrightWithOddsEvent type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Gets a list of EventOdds instances representing the odds for the outright associated with the current SingleOutrightWithOddsEvent instance
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event (Inherited from SingleOutrightEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current SingleOutrightWithOddsEvent instance (Overrides SingleOutrightEventToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


SingleOutrightWithOddsEvent Properties

The SingleOutrightWithOddsEvent type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | Odds | Gets a list of EventOdds instances representing the odds for the outright associated with the current SingleOutrightWithOddsEvent instance
Public property | OutrightHeader | Gets or sets a OutrightHeader instance containing basic information about an outright associated with current event (Inherited from SingleOutrightEvent)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

SingleOutrightWithOddsEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


SingleOutrightWithOddsEvent.Odds Property

SingleOutrightWithOddsEventOdds Property

Gets a list of EventOdds instances representing the odds for the outright associated with the current SingleOutrightWithOddsEvent instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<EventOdds> Odds { get; }

Property Value

List EventOdds
See Also

Reference

SingleOutrightWithOddsEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


SingleOutrightWithOddsEvent Methods

The SingleOutrightWithOddsEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returnes a String representation of the current SingleOutrightWithOddsEvent instance (Overrides SingleOutrightEventToString)
Top
See Also

Reference

SingleOutrightWithOddsEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


SingleOutrightWithOddsEvent.ToString Method

SingleOutrightWithOddsEventToString Method

Returnes a String representation of the current SingleOutrightWithOddsEvent instance

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.Outrights
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
a String representation of the current SingleOutrightWithOddsEvent instance
See Also

Reference

SingleOutrightWithOddsEvent Class
Sportradar.SDK.FeedProviders.LiveOdds.Outrights Namespace


Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace

Classes
 | Class | Description
Public class | RaceCompetitor | Represents a competitor in a race Base class for RaceCompetitorVdr and RaceCompetitorVhc
Public class | RaceDay | Entity containg data about specific race day
Public class | RaceHeader | Contains core data about a race
Public class | RaceHeaderInfo | Entity containing RaceHeader and RaceInfo. Appears in MetaInfo in race feeds
Public class | RaceInfo | Contains extra info about a race
Public class | RaceMetaData | MetaInfoDataContainer for race oriented feeds
Public class | RaceResult | Represents the results of a race.
Interfaces
 | Interface | Description
Public interface | ILiveOddsRace | Interface describing events and methods in race oriented LiveOdds feeds


ILiveOddsRace Interface

Interface describing events and methods in race oriented LiveOdds feeds

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveOddsRace : ILiveOddsCommon,
    ILiveOddsCommonBase, ILiveFeeds, IStartable

The ILiveOddsRace type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from ILiveFeeds)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from ILiveOddsCommonBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from ILiveFeeds)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from ILiveFeeds)
Public property | ServerTime | Get approximate server time. (Inherited from ILiveFeeds)
Public property | SubscribedEvents | All event ids we are currently subscribed to. (Inherited from ILiveFeeds)
Top
Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface. (Inherited from ILiveFeeds)
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup. (Inherited from ILiveFeeds)
Public method | GetEventList(IEnumerableInt64) | Request meta-information about the events(matches, races) specified by it's ids The response message includes teams playing, match date and time, TV channel names and sport/category/tournament for every match. (Inherited from ILiveOddsCommonBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | Request meta-information about all events(matches, races, outcomes, ...) in a given interval. The maximum interval is 10 days. If no date is specified, all events started 24 hours in the past, and 7 days in the future are returned. The response message includes teams playing, event date and time, TV channel names and sport/category/tournament for every event. (Inherited from ILiveOddsCommonBase)
Public method | GetEventMessages | Request exact match messages ("error" server request). (Inherited from ILiveOddsCommonBase)
Public method | GetEventsStatus | Requests the match statuses for a given time ("current" server request). This includes odds, activation of odds and match status for the matches requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetEventStatus | Requests the match status for a given time ("current" server request). This includes odds, activation of odds and match status for the match requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetRacedayMetaInfo | Requests racedays meta info. OnMetaInfo will be triggered when response arrives.
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events. (Inherited from ILiveFeeds)
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent. (Inherited from ILiveFeeds)
Top
Events
Name | Description
Public event OnAlive Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
(Inherited from ILiveOddsCommon)
Public event OnBetCancel Signals that odds type for a match should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
(Inherited from ILiveOddsCommonBase)
Public event OnBetCancelUndo Signals that an odds type has been cancelled due to some reason when it actually shouldnt have been. This can be undone. The Odds element should match the Odds element in the corresponding OnCancelBet event. The same goes for the starttime and endtime - they should match the values in the OnCancelBet event.
(Inherited from ILiveOddsCommonBase)
Public event OnBetClear

Signals that situation occurred during the match so that a bet can be decided. Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

(Inherited from ILiveOddsCommonBase)
Public event OnBetClearRollback Signals that there was some wrong information sent out about bet clearing. Notification includes the Odds element that rollback is targeted to. The clearedscore contains the cleared score of the original bet clearing. The time for the original bet clearing is timestamp – time seconds. The Odds element includes a list of EventOddsField elements to indicate what field was cleared in the original bet clearing. The Client system is responsible to handle this accordingly.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStart Signals that bets for a specific match can open again after they have been stopped.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStop Signals that a bet stop situation occurred for a specific match. OnBetStart event is triggered when the bets can open again.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionStable Signals that the initial sync is complete and the connection to the server is stable.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionUnstable Signals that the connection is unstable.
(Inherited from ILiveOddsCommonBase)
Public event OnEventMessages Signals that all of the requested match messages were received.
(Inherited from ILiveOddsCommonBase)
Public event OnEventStatus Signals that a requested match status was received.
(Inherited from ILiveOddsCommonBase)
Public event OnFeedError Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
(Inherited from ILiveFeeds)
Public event OnMetaInfo Event contains information like the date and time of the match, sport, category, tournament, teams and what TV-channels a match is broadcasted on. When a match is removed, Active is set to false for the match with an optional textual reason why the match has been removed. Active flag can also set to false if the client has unregistered a match. The message element will include the text unregistered in such cases. Match meta-information will also be broadcasted when a match is added to the system, or when a match has been cancelled.
(Inherited from ILiveOddsCommonBase)
Public event OnOddsChange Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
(Inherited from ILiveOddsCommonBase)
Public event | OnRaceResult | Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


ILiveOddsRace Properties

The ILiveOddsRace type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from ILiveFeeds)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from ILiveOddsCommonBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from ILiveFeeds)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from ILiveFeeds)
Public property | ServerTime | Get approximate server time. (Inherited from ILiveFeeds)
Public property | SubscribedEvents | All event ids we are currently subscribed to. (Inherited from ILiveFeeds)
Top
See Also

Reference

ILiveOddsRace Interface
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


ILiveOddsRace Methods

The ILiveOddsRace type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface. (Inherited from ILiveFeeds)
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup. (Inherited from ILiveFeeds)
Public method | GetEventList(IEnumerableInt64) | Request meta-information about the events(matches, races) specified by it's ids The response message includes teams playing, match date and time, TV channel names and sport/category/tournament for every match. (Inherited from ILiveOddsCommonBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | Request meta-information about all events(matches, races, outcomes, ...) in a given interval. The maximum interval is 10 days. If no date is specified, all events started 24 hours in the past, and 7 days in the future are returned. The response message includes teams playing, event date and time, TV channel names and sport/category/tournament for every event. (Inherited from ILiveOddsCommonBase)
Public method | GetEventMessages | Request exact match messages ("error" server request). (Inherited from ILiveOddsCommonBase)
Public method | GetEventsStatus | Requests the match statuses for a given time ("current" server request). This includes odds, activation of odds and match status for the matches requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetEventStatus | Requests the match status for a given time ("current" server request). This includes odds, activation of odds and match status for the match requested, current bet status and all bet clearing messages before the timestamp. (Inherited from ILiveOddsCommonBase)
Public method | GetRacedayMetaInfo | Requests racedays meta info. OnMetaInfo will be triggered when response arrives.
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events. (Inherited from ILiveFeeds)
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent. (Inherited from ILiveFeeds)
Top
See Also

Reference

ILiveOddsRace Interface
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


ILiveOddsRace.GetRacedayMetaInfo Method

ILiveOddsRaceGetRacedayMetaInfo Method

Requests racedays meta info. OnMetaInfo will be triggered when response arrives.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
long GetRacedayMetaInfo(
    IEnumerable<int> racedays
)

Parameters

racedays IEnumerable Int32
List of racedays to request meta info for

Return Value

Int64
Returns immediately with the request number or zero but expect to receive an event afterwards.
See Also

Reference

ILiveOddsRace Interface
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


ILiveOddsRace Events

The ILiveOddsRace type exposes the following members.

Events
Name | Description
Public event OnAlive Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
(Inherited from ILiveOddsCommon)
Public event OnBetCancel Signals that odds type for a match should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
(Inherited from ILiveOddsCommonBase)
Public event OnBetCancelUndo Signals that an odds type has been cancelled due to some reason when it actually shouldnt have been. This can be undone. The Odds element should match the Odds element in the corresponding OnCancelBet event. The same goes for the starttime and endtime - they should match the values in the OnCancelBet event.
(Inherited from ILiveOddsCommonBase)
Public event OnBetClear

Signals that situation occurred during the match so that a bet can be decided. Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

(Inherited from ILiveOddsCommonBase)
Public event OnBetClearRollback Signals that there was some wrong information sent out about bet clearing. Notification includes the Odds element that rollback is targeted to. The clearedscore contains the cleared score of the original bet clearing. The time for the original bet clearing is timestamp – time seconds. The Odds element includes a list of EventOddsField elements to indicate what field was cleared in the original bet clearing. The Client system is responsible to handle this accordingly.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStart Signals that bets for a specific match can open again after they have been stopped.
(Inherited from ILiveOddsCommonBase)
Public event OnBetStop Signals that a bet stop situation occurred for a specific match. OnBetStart event is triggered when the bets can open again.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionStable Signals that the initial sync is complete and the connection to the server is stable.
(Inherited from ILiveOddsCommonBase)
Public event OnConnectionUnstable Signals that the connection is unstable.
(Inherited from ILiveOddsCommonBase)
Public event OnEventMessages Signals that all of the requested match messages were received.
(Inherited from ILiveOddsCommonBase)
Public event OnEventStatus Signals that a requested match status was received.
(Inherited from ILiveOddsCommonBase)
Public event OnFeedError Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
(Inherited from ILiveFeeds)
Public event OnMetaInfo Event contains information like the date and time of the match, sport, category, tournament, teams and what TV-channels a match is broadcasted on. When a match is removed, Active is set to false for the match with an optional textual reason why the match has been removed. Active flag can also set to false if the client has unregistered a match. The message element will include the text unregistered in such cases. Match meta-information will also be broadcasted when a match is added to the system, or when a match has been cancelled.
(Inherited from ILiveOddsCommonBase)
Public event OnOddsChange Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
(Inherited from ILiveOddsCommonBase)
Public event | OnRaceResult | Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
Top
See Also

Reference

ILiveOddsRace Interface
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


ILiveOddsRace.OnRaceResult Event

ILiveOddsRaceOnRaceResult Event

Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<RaceResultEventArgs> OnRaceResult

Value

EventHandler RaceResultEventArgs
Remarks
SDK will send out bet stops for all matches if no alive message has been received in the last 20 seconds. In this case client shouldn't accept any bets for any matches until the connection is stable again. SDK will also take care that if the connection to the Betradar server is lost, bet stops for all matches are sent out until a stable connection is established again.
See Also

Reference

ILiveOddsRace Interface
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceCompetitor Class

Represents a competitor in a race Base class for RaceCompetitorVdr and RaceCompetitorVhc
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.CommonRaceCompetitor
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.VdrRaceCompetitorVdr
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.VhcRaceCompetitorVhc

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class RaceCompetitor

The RaceCompetitor type exposes the following members.

Properties
 | Name | Description
Public property | Position | Position in the race.
Public property | StartBox | Box where horse/dog is starting.
Public property | Time | Time of the race.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceCompetitor Properties

The RaceCompetitor type exposes the following members.

Properties
 | Name | Description
Public property | Position | Position in the race.
Public property | StartBox | Box where horse/dog is starting.
Public property | Time | Time of the race.
Top
See Also

Reference

RaceCompetitor Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceCompetitor.Position Property

RaceCompetitorPosition Property

Position in the race.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Position { get; }

Property Value

Nullable Int32
Remarks
1 means winner and so on. Only available in OnRaceResult
See Also

Reference

RaceCompetitor Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceCompetitor.StartBox Property

RaceCompetitorStartBox Property

Box where horse/dog is starting.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int StartBox { get; }

Property Value

Int32
See Also

Reference

RaceCompetitor Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceCompetitor.Time Property

RaceCompetitorTime Property

Time of the race.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? Time { get; }

Property Value

Nullable Int64
Remarks
Only available in OnRaceResult
See Also

Reference

RaceCompetitor Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceCompetitor Methods

The RaceCompetitor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

RaceCompetitor Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceCompetitor.ToString Method

RaceCompetitorToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

RaceCompetitor Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay Class

Entity containg data about specific race day
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.CommonRaceDay

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RaceDay

The RaceDay type exposes the following members.

Constructors
 | Name | Description
Public method | RaceDay | Initializes a new instance of the RaceDay class
Top
Properties
 | Name | Description
Public property | Active | Whether race day is active.
 | ChannelId | Id of the channel where the race is broadcasted.
Public property | EndTime | End time of the race day.
Public property | Id | Unique id of the race day.
 | Name | Name of the race day.
Public property | ParentId | Parent id of the race day.
 | RaceDayNumber | Incremental race day number.
Public property | StartTime | Start time of the race day.
Public property | Status | Status.
 | Surface | Type of the surface.
 | TrackName | Name of the track
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay Constructor

Initializes a new instance of the RaceDay class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceDay()
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay Properties

The RaceDay type exposes the following members.

Properties
 | Name | Description
Public property | Active | Whether race day is active.
 | ChannelId | Id of the channel where the race is broadcasted.
Public property | EndTime | End time of the race day.
Public property | Id | Unique id of the race day.
 | Name | Name of the race day.
Public property | ParentId | Parent id of the race day.
 | RaceDayNumber | Incremental race day number.
Public property | StartTime | Start time of the race day.
Public property | Status | Status.
 | Surface | Type of the surface.
 | TrackName | Name of the track
Top
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay.Active Property

RaceDayActive Property

Whether race day is active.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Active { get; }

Property Value

Boolean
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay.ChannelId Property

RaceDayChannelId Property

Id of the channel where the race is broadcasted.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? ChannelId { get; }

Property Value

Nullable Int32
Example
1
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay.EndTime Property

RaceDayEndTime Property

End time of the race day.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime? EndTime { get; }

Property Value

Nullable DateTime
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay.Id Property

RaceDayId Property

Unique id of the race day.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay.Name Property

RaceDayName Property

Name of the race day.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString Name { get; }

Property Value

LocalizedString
Example
"Race day 1"
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay.ParentId Property

RaceDayParentId Property

Parent id of the race day.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? ParentId { get; }

Property Value

Nullable Int32
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay.RaceDayNumber Property

RaceDayRaceDayNumber Property

Incremental race day number.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? RaceDayNumber { get; }

Property Value

Nullable Int32
Example
6785
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay.StartTime Property

RaceDayStartTime Property

Start time of the race day.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime StartTime { get; }

Property Value

DateTime
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay.Status Property

RaceDayStatus Property

Status.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventStatus Status { get; }

Property Value

EventStatus
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay.Surface Property

RaceDaySurface Property

Type of the surface.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Surface { get; }

Property Value

String
Example
"Dirt"
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay.TrackName Property

RaceDayTrackName Property

Name of the track

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString TrackName { get; }

Property Value

LocalizedString
Example
"Anbaren Parks"
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay Methods

The RaceDay type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceDay.ToString Method

RaceDayToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

RaceDay Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeader Class

Contains core data about a race
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonEventHeader
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.CommonRaceHeader

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RaceHeader : EventHeader

The RaceHeader type exposes the following members.

Constructors
 | Name | Description
Public method | RaceHeader | Initializes a new instance of the RaceHeader class
Top
Properties
 | Name | Description
Public property | Active | Set to false when a match is removed (in this case also see the Message for the reason for removal). Also set to false if the client has unregistered a match. The message element will include the text "unregistered" in such case. (Inherited from EventHeader)
Public property | BetStatus | Current bet status (Inherited from EventHeader)
Public property | Booked | The meta-message includes matches that are booked or included in the package that is purchased. By adding specifying includeavailable="true" in the meta request, or activating it through XML configuration ‘Include non booked matches in meta’, the meta response will also include matches that are available for booking but not booked yet. The match element in the meta-response will then also include this property specifying whether the match is already booked (true), or not booked yet (false).
Public property | Id | Betradar id for the event (Inherited from EventHeader)
Public property | Message | Optional textual message attached to the match (e.g. why a match has been removed, information that a client has unregistered from a match, etc.) (Inherited from EventHeader)
Public property | Msgnr | Incremental message id that starts with 1 for every match. Only messages that changes the state of a match will include this property. Alive messages, meta-information and login response messages will not include this incremental id. (Inherited from EventHeader)
Public property | ParentId | Parent id
Public property | Status | Event status (Inherited from EventHeader)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides EventHeaderToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeader Constructor

Initializes a new instance of the RaceHeader class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceHeader()
See Also

Reference

RaceHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeader Properties

The RaceHeader type exposes the following members.

Properties
 | Name | Description
Public property | Active | Set to false when a match is removed (in this case also see the Message for the reason for removal). Also set to false if the client has unregistered a match. The message element will include the text "unregistered" in such case. (Inherited from EventHeader)
Public property | BetStatus | Current bet status (Inherited from EventHeader)
Public property | Booked | The meta-message includes matches that are booked or included in the package that is purchased. By adding specifying includeavailable="true" in the meta request, or activating it through XML configuration ‘Include non booked matches in meta’, the meta response will also include matches that are available for booking but not booked yet. The match element in the meta-response will then also include this property specifying whether the match is already booked (true), or not booked yet (false).
Public property | Id | Betradar id for the event (Inherited from EventHeader)
Public property | Message | Optional textual message attached to the match (e.g. why a match has been removed, information that a client has unregistered from a match, etc.) (Inherited from EventHeader)
Public property | Msgnr | Incremental message id that starts with 1 for every match. Only messages that changes the state of a match will include this property. Alive messages, meta-information and login response messages will not include this incremental id. (Inherited from EventHeader)
Public property | ParentId | Parent id
Public property | Status | Event status (Inherited from EventHeader)
Top
See Also

Reference

RaceHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeader.Booked Property

RaceHeaderBooked Property

The meta-message includes matches that are booked or included in the package that is purchased. By adding specifying includeavailable="true" in the meta request, or activating it through XML configuration ‘Include non booked matches in meta’, the meta response will also include matches that are available for booking but not booked yet. The match element in the meta-response will then also include this property specifying whether the match is already booked (true), or not booked yet (false).

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? Booked { get; }

Property Value

Nullable Boolean
See Also

Reference

RaceHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeader.ParentId Property

RaceHeaderParentId Property

Parent id

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int ParentId { get; }

Property Value

Int32
See Also

Reference

RaceHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeader Methods

The RaceHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides EventHeaderToString)
Top
See Also

Reference

RaceHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeader.ToString Method

RaceHeaderToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

RaceHeader Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeaderInfo Class

Entity containing RaceHeader and RaceInfo. Appears in MetaInfo in race feeds
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.CommonRaceHeaderInfo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RaceHeaderInfo

The RaceHeaderInfo type exposes the following members.

Constructors
 | Name | Description
Public method | RaceHeaderInfo | Initialize a new instance.
Top
Properties
 | Name | Description
Public property | RaceHeader | Basic race header.
Public property | RaceInfo | Race information.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeaderInfo Constructor

Initialize a new instance.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceHeaderInfo(
    RaceHeader hdr,
    RaceInfo infoVdr
)

Parameters

hdr RaceHeader
Race header
infoVdr RaceInfo
Race infoVdr
See Also

Reference

RaceHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeaderInfo Properties

The RaceHeaderInfo type exposes the following members.

Properties
 | Name | Description
Public property | RaceHeader | Basic race header.
Public property | RaceInfo | Race information.
Top
See Also

Reference

RaceHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeaderInfo.RaceHeader Property

RaceHeaderInfoRaceHeader Property

Basic race header.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceHeader RaceHeader { get; }

Property Value

RaceHeader
See Also

Reference

RaceHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeaderInfo.RaceInfo Property

RaceHeaderInfoRaceInfo Property

Race information.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceInfo RaceInfo { get; }

Property Value

RaceInfo
See Also

Reference

RaceHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeaderInfo Methods

The RaceHeaderInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

RaceHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceHeaderInfo.ToString Method

RaceHeaderInfoToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

RaceHeaderInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo Class

Contains extra info about a race
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.CommonRaceInfo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RaceInfo

The RaceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | RaceInfo | Initializes a new instance of the RaceInfo class
Top
Properties
 | Name | Description
Public property | Competitors | List of all the competitors in this race
Public property | Distance | Human readable actual distance.
Public property | DistanceName | Name of the distance.
Public property | EndTime | End time of the race.
Public property | NumParticipants | Number of participants.
Public property | RaceNumber | Race number
Public property | StartTime | Start time of the race.
Public property | TrackName | Track name
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo Constructor

Initializes a new instance of the RaceInfo class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceInfo()
See Also

Reference

RaceInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo Properties

The RaceInfo type exposes the following members.

Properties
 | Name | Description
Public property | Competitors | List of all the competitors in this race
Public property | Distance | Human readable actual distance.
Public property | DistanceName | Name of the distance.
Public property | EndTime | End time of the race.
Public property | NumParticipants | Number of participants.
Public property | RaceNumber | Race number
Public property | StartTime | Start time of the race.
Public property | TrackName | Track name
Top
See Also

Reference

RaceInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo.Competitors Property

RaceInfoCompetitors Property

List of all the competitors in this race

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<RaceCompetitor> Competitors { get; }

Property Value

List RaceCompetitor
See Also

Reference

RaceInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo.Distance Property

RaceInfoDistance Property

Human readable actual distance.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString Distance { get; }

Property Value

LocalizedString
See Also

Reference

RaceInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo.DistanceName Property

RaceInfoDistanceName Property

Name of the distance.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString DistanceName { get; }

Property Value

LocalizedString
See Also

Reference

RaceInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo.EndTime Property

RaceInfoEndTime Property

End time of the race.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime EndTime { get; }

Property Value

DateTime
See Also

Reference

RaceInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo.NumParticipants Property

RaceInfoNumParticipants Property

Number of participants.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? NumParticipants { get; }

Property Value

Nullable Int32
See Also

Reference

RaceInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo.RaceNumber Property

RaceInfoRaceNumber Property

Race number

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? RaceNumber { get; }

Property Value

Nullable Int32
See Also

Reference

RaceInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo.StartTime Property

RaceInfoStartTime Property

Start time of the race.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime StartTime { get; }

Property Value

DateTime
See Also

Reference

RaceInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo.TrackName Property

RaceInfoTrackName Property

Track name

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString TrackName { get; }

Property Value

LocalizedString
See Also

Reference

RaceInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo Methods

The RaceInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

RaceInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceInfo.ToString Method

RaceInfoToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

RaceInfo Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceMetaData Class

MetaInfoDataContainer for race oriented feeds
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.CommonMetaInfoDataContainer
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.CommonRaceMetaData

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RaceMetaData : MetaInfoDataContainer

The RaceMetaData type exposes the following members.

Constructors
 | Name | Description
Public method | RaceMetaData | Initializes a new instance of the RaceMetaData class
Top
Properties
 | Name | Description
Public property | RaceDays | All the race days that are contained in MetaInfo
Public property | RaceHeaderInfos | Info about all the races are contained in MetaInfo
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceMetaData Constructor

Initializes a new instance of the RaceMetaData class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceMetaData()
See Also

Reference

RaceMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceMetaData Properties

The RaceMetaData type exposes the following members.

Properties
 | Name | Description
Public property | RaceDays | All the race days that are contained in MetaInfo
Public property | RaceHeaderInfos | Info about all the races are contained in MetaInfo
Top
See Also

Reference

RaceMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceMetaData.RaceDays Property

RaceMetaDataRaceDays Property

All the race days that are contained in MetaInfo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<RaceDay> RaceDays { get; }

Property Value

List RaceDay
See Also

Reference

RaceMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceMetaData.RaceHeaderInfos Property

RaceMetaDataRaceHeaderInfos Property

Info about all the races are contained in MetaInfo

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<RaceHeaderInfo> RaceHeaderInfos { get; }

Property Value

List RaceHeaderInfo
See Also

Reference

RaceMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceMetaData Methods

The RaceMetaData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

RaceMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceMetaData.ToString Method

RaceMetaDataToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

RaceMetaData Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceResult Class

Represents the results of a race.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonOddsEntityBase
Sportradar.SDK.FeedProviders.LiveOdds.CommonSingleHeaderEvent
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.CommonRaceResult

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RaceResult : SingleHeaderEvent

The RaceResult type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | Results | The actual results.
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderEventToString)
Top
Remarks
Used with VHC.
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceResult Properties

The RaceResult type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | EventHeader | Core info about the event for this event (Inherited from SingleHeaderEvent)
Public property | IsOutOfBand | Is the message out-of-band by purpose i.e., explicitly requested by user? True when yes; false else (usually). (Inherited from OddsEntityBase)
Public property | Messages | Additional textual information attached to the message. (Inherited from OddsEntityBase)
Public property | Msgnr | To make sure that client system receives all messages from the Betradar system, all messages sent out have an incremental id. It starts with 1 for every event. Only messages that change the state of a event include this attribute. Alive, meta-information and login response messages do not include it. (Inherited from OddsEntityBase)
Public property | ReplyNr | Reply number matching the request number, thus enabling us to pair request and response messages properly. (Inherited from OddsEntityBase)
Public property | ReplyType | Message reply type (e.g. Current, Error, Register) (Inherited from OddsEntityBase)
Public property | Results | The actual results.
Public property | ServerType | Live odds feed server type (e.g. LiveOdds, BetPal, ...) (Inherited from OddsEntityBase)
Public property | ServerVersion | XML feeds server version (Inherited from OddsEntityBase)
Public property | Status | Live Odds status specifying the actual message type (e.g. current, clearbet, change, score, cards, etc.) (Inherited from OddsEntityBase)
Public property | Time | Time in seconds. For "betstart", "betstop", "betclear" it tells when the situation occurred in seconds before Timestamp. Also used to indicate time for the original bet clearing in case of "betrollback". (Inherited from OddsEntityBase)
Public property | Timestamp | Time from server in UTC. (Inherited from OddsEntityBase)
Public property | VirtualGameId | Virtual game id. (Inherited from OddsEntityBase)
Top
See Also

Reference

RaceResult Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceResult.Results Property

RaceResultResults Property

The actual results.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<RaceCompetitor> Results { get; }

Property Value

List RaceCompetitor
See Also

Reference

RaceResult Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceResult Methods

The RaceResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides SingleHeaderEventToString)
Top
See Also

Reference

RaceResult Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


RaceResult.ToString Method

RaceResultToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

RaceResult Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Common Namespace


Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr Namespace

Classes
 | Class | Description
Public class | RaceCompetitorVdr | Specifies a competitor in a dog race.


RaceCompetitorVdr Class

Specifies a competitor in a dog race.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.CommonRaceCompetitor
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.VdrRaceCompetitorVdr

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RaceCompetitorVdr : RaceCompetitor

The RaceCompetitorVdr type exposes the following members.

Constructors
 | Name | Description
Public method | RaceCompetitorVdr | Initializes a new instance of the RaceCompetitorVdr class
Top
Properties
 | Name | Description
Public property | DogId | Id of the dog
Public property | DogName | Name of the dog
Public property | Position | Position in the race. (Inherited from RaceCompetitor)
Public property | StartBox | Box where horse/dog is starting. (Inherited from RaceCompetitor)
Public property | Time | Time of the race. (Inherited from RaceCompetitor)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides RaceCompetitorToString)
Top
Remarks
Used with VDR.
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr Namespace


RaceCompetitorVdr Constructor

Initializes a new instance of the RaceCompetitorVdr class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceCompetitorVdr()
See Also

Reference

RaceCompetitorVdr Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr Namespace


RaceCompetitorVdr Properties

The RaceCompetitorVdr type exposes the following members.

Properties
 | Name | Description
Public property | DogId | Id of the dog
Public property | DogName | Name of the dog
Public property | Position | Position in the race. (Inherited from RaceCompetitor)
Public property | StartBox | Box where horse/dog is starting. (Inherited from RaceCompetitor)
Public property | Time | Time of the race. (Inherited from RaceCompetitor)
Top
See Also

Reference

RaceCompetitorVdr Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr Namespace


RaceCompetitorVdr.DogId Property

RaceCompetitorVdrDogId Property

Id of the dog

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? DogId { get; }

Property Value

Nullable Int32
See Also

Reference

RaceCompetitorVdr Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr Namespace


RaceCompetitorVdr.DogName Property

RaceCompetitorVdrDogName Property

Name of the dog

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString DogName { get; }

Property Value

LocalizedString
See Also

Reference

RaceCompetitorVdr Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr Namespace


RaceCompetitorVdr Methods

The RaceCompetitorVdr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides RaceCompetitorToString)
Top
See Also

Reference

RaceCompetitorVdr Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr Namespace


RaceCompetitorVdr.ToString Method

RaceCompetitorVdrToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

RaceCompetitorVdr Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vdr Namespace


Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc Namespace

Classes
 | Class | Description
Public class | RaceCompetitorVhc | Specifies a competitor in a horse race.


RaceCompetitorVhc Class

Specifies a competitor in a horse race.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.CommonRaceCompetitor
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.VhcRaceCompetitorVhc

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class RaceCompetitorVhc : RaceCompetitor

The RaceCompetitorVhc type exposes the following members.

Constructors
 | Name | Description
Public method | RaceCompetitorVhc | Initializes a new instance of the RaceCompetitorVhc class
Top
Properties
 | Name | Description
Public property | HorseId | ID of the horse.
Public property | HorseName | Name of the horse.
Public property | JockeyId | Id of the jockey.
Public property | JockeyName | Name of the jockey.
Public property | Position | Position in the race. (Inherited from RaceCompetitor)
Public property | StartBox | Box where horse/dog is starting. (Inherited from RaceCompetitor)
Public property | Time | Time of the race. (Inherited from RaceCompetitor)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides RaceCompetitorToString)
Top
Remarks
Used with VHC.
See Also

Reference

Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc Namespace


RaceCompetitorVhc Constructor

Initializes a new instance of the RaceCompetitorVhc class

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RaceCompetitorVhc()
See Also

Reference

RaceCompetitorVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc Namespace


RaceCompetitorVhc Properties

The RaceCompetitorVhc type exposes the following members.

Properties
 | Name | Description
Public property | HorseId | ID of the horse.
Public property | HorseName | Name of the horse.
Public property | JockeyId | Id of the jockey.
Public property | JockeyName | Name of the jockey.
Public property | Position | Position in the race. (Inherited from RaceCompetitor)
Public property | StartBox | Box where horse/dog is starting. (Inherited from RaceCompetitor)
Public property | Time | Time of the race. (Inherited from RaceCompetitor)
Top
See Also

Reference

RaceCompetitorVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc Namespace


RaceCompetitorVhc.HorseId Property

RaceCompetitorVhcHorseId Property

ID of the horse.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long HorseId { get; }

Property Value

Int64
See Also

Reference

RaceCompetitorVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc Namespace


RaceCompetitorVhc.HorseName Property

RaceCompetitorVhcHorseName Property

Name of the horse.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString HorseName { get; }

Property Value

LocalizedString
See Also

Reference

RaceCompetitorVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc Namespace


RaceCompetitorVhc.JockeyId Property

RaceCompetitorVhcJockeyId Property

Id of the jockey.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? JockeyId { get; }

Property Value

Nullable Int64
See Also

Reference

RaceCompetitorVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc Namespace


RaceCompetitorVhc.JockeyName Property

RaceCompetitorVhcJockeyName Property

Name of the jockey.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LocalizedString JockeyName { get; }

Property Value

LocalizedString
See Also

Reference

RaceCompetitorVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc Namespace


RaceCompetitorVhc Methods

The RaceCompetitorVhc type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides RaceCompetitorToString)
Top
See Also

Reference

RaceCompetitorVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc Namespace


RaceCompetitorVhc.ToString Method

RaceCompetitorVhcToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc
Assembly: LiveOddsFeedProvider (in LiveOddsFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

RaceCompetitorVhc Class
Sportradar.SDK.FeedProviders.LiveOdds.RaceLiveOdds.Vhc Namespace


Sportradar.SDK.FeedProviders.LiveScout Namespace

Classes
 | Class | Description
Public class | Attribute | Attribute
Public class | Behinds | Behinds
Public class | BookMatchResult | Book match result
Public class | ConnectionChangeEventArgs | Event arguments passed with OnClosed and OnOpened.
Public class | ConnectionTest | Connection test.
Public class | Court | Court
Public class | Coverage | Type of match coverage.
Public class | EventType | Event type. See LiveScout documentation to see which event types are supported for each sport. New event types can be offered in future.
Public class | Format | Format
Public class | FormatType | Format type
Public class | Goals | Goals
Public class | Gold | gold
Public class | IceConditions | Ice conditions
Public class | Inning | Inning half
Public class | Innings | Innings
Public class | InningScore | Inning score
Public class | Jersey | Jersey
Public class | Lineups | The current lineup.
Public class | LineupsEventArgs | Event arguments passed with OnLineups.
Public class | Manager | Team manager
Public class | MatchBetStatus | Bet status (whether market is open or closed)
Public class | MatchBooking | Match booking reply. This reply is sent when a client books a match.
Public class | MatchBookingReplyEventArgs | Event arguments passed with OnMatchBookingReply.
Public class | MatchData | Match time information during a game.
Public class | MatchDataEventArgs | Event arguments passed with OnMatchData.
Public class | MatchHeader | Basic match information specifying match id, teams playing, bet status, feed type and other info.
Public class | MatchList | List of matches in the time frame requested by the client.
Public class | MatchListEventArgs | Event arguments passed with OnMatchList.
Public class | MatchListUpdate | List of matches sent unsolicited from server (uses same format as MatchList for now).
Public class | MatchProperty | Match Property
Public class | MatchRole | Match role
Public class | MatchStop | Reply sent when a client unsubscribes from a match or when a match subscription failed.
Public class | MatchStopEventArgs | Event arguments passed with OnMatchStop.
Public class | MatchTeam | Match Team
Public class | MatchUpdate | Match information message. Contains statistical information about a match as well as individual events (e.g. goals, cards, etc.).
Public class | MatchUpdateEventArgs | Event arguments passed OnMatchUpdate, OnMatchUpdateDelta, OnMatchUpdateDeltaUpdate and OnMatchUpdateFull.
Public class | Networth | Networth
Public class | PitchConditions | Pitch conditions.
Public class | Player | A player in the lineup.
Public class | Score | Score
Public class | Scout | Scout
Public class | ScoutEntityBase | Serves as a base class that all LiveOdds entities should be derived from.
Public class | ScoutEvent | Scout event like a card, corner kick, half time, penalty, etc.
Public class | ScoutFeedType | Type of scout match information message (full, delta or deltaupdate).
Public class | ScoutInfo | Contains basic information about the match.
Public class | ScoutInfoEventArgs | Event arguments passed with OnScoutInfo.
Public class | ScoutInfos | Match information messages (e.g. Distance between teams, Pre-match avg. odds, etc.)
Public class | ScoutMatchStatus | Match status as used by Live Odds. Not all match statuses are used by each sport.
Public class | ScoutMatchStatusClasses | Group ScoutMatchStatus in to different classes.
Public class | Sex | Sex (gender) of the contestant or the whole team.
Public class | SurfaceType | Type of surface
Public class | Suspensions |
Public class | TeamOffical | Team offical
Public class | WeatherConditions | Weather conditions
Interfaces
 | Interface | Description
Public interface | ILiveScout | Live scout client interface.


Attribute Class

Attribute
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutAttribute

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Attribute

The Attribute type exposes the following members.

Constructors
 | Name | Description
Public method | Attribute | Initializes a new instance of the Attribute class
Top
Properties
 | Name | Description
Public property | Type | Type
Public property | TypeId | Type id
Public property | Value | Value
Public property | ValueId | Value id
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Attribute Constructor

Initializes a new instance of the Attribute class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Attribute()
See Also

Reference

Attribute Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Attribute Properties

The Attribute type exposes the following members.

Properties
 | Name | Description
Public property | Type | Type
Public property | TypeId | Type id
Public property | Value | Value
Public property | ValueId | Value id
Top
See Also

Reference

Attribute Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Attribute.Type Property

AttributeType Property

Type

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Type { get; set; }

Property Value

String
See Also

Reference

Attribute Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Attribute.TypeId Property

AttributeTypeId Property

Type id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int TypeId { get; set; }

Property Value

Int32
See Also

Reference

Attribute Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Attribute.Value Property

AttributeValue Property

Value

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; set; }

Property Value

String
See Also

Reference

Attribute Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Attribute.ValueId Property

AttributeValueId Property

Value id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int ValueId { get; set; }

Property Value

Int32
See Also

Reference

Attribute Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Attribute Methods

The Attribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Attribute Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Attribute.ToString Method

AttributeToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Attribute Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Behinds Class

Behinds
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutBehinds

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Behinds

The Behinds type exposes the following members.

Constructors
 | Name | Description
Public method | Behinds | Initializes a new instance of the Behinds class
Top
Properties
 | Name | Description
Public property | T1 | Gets the T1
Public property | T2 | Gets the T2
Public property | Type | Gets the type (aussie_rules_score_type)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Behinds Constructor

Initializes a new instance of the Behinds class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Behinds()
See Also

Reference

Behinds Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Behinds Properties

The Behinds type exposes the following members.

Properties
 | Name | Description
Public property | T1 | Gets the T1
Public property | T2 | Gets the T2
Public property | Type | Gets the type (aussie_rules_score_type)
Top
See Also

Reference

Behinds Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Behinds.T1 Property

BehindsT1 Property

Gets the T1

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int T1 { get; }

Property Value

Int32
The T1
See Also

Reference

Behinds Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Behinds.T2 Property

BehindsT2 Property

Gets the T2

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int T2 { get; }

Property Value

Int32
The T2
See Also

Reference

Behinds Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Behinds.Type Property

BehindsType Property

Gets the type (aussie_rules_score_type)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Type { get; }

Property Value

String
The type
See Also

Reference

Behinds Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Behinds Methods

The Behinds type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object (Overrides ObjectToString)
Top
See Also

Reference

Behinds Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Behinds.ToString Method

BehindsToString Method

Returns a string that represents the current object

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object
Remarks
Can be used for diagnostics purposes
See Also

Reference

Behinds Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


BookMatchResult Class

Book match result
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutBookMatchResult

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class BookMatchResult : Enum

The BookMatchResult type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | INVALID | Invalid
 | UNDEFINED | Undefined
 | VALID | Valid
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


BookMatchResult Methods

The BookMatchResult type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

BookMatchResult Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


BookMatchResult Fields

The BookMatchResult type exposes the following members.

Fields
 | Name | Description
 | INVALID | Invalid
 | UNDEFINED | Undefined
 | VALID | Valid
Public field | value__ |
Top
See Also

Reference

BookMatchResult Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


BookMatchResult.INVALID Field

BookMatchResultINVALID Field

Invalid

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const BookMatchResult INVALID = 2

Field Value

BookMatchResult
See Also

Reference

BookMatchResult Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


BookMatchResult.UNDEFINED Field

BookMatchResultUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const BookMatchResult UNDEFINED = 0

Field Value

BookMatchResult
See Also

Reference

BookMatchResult Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


BookMatchResult.VALID Field

BookMatchResultVALID Field

Valid

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const BookMatchResult VALID = 1

Field Value

BookMatchResult
See Also

Reference

BookMatchResult Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


BookMatchResult.value__ Field

BookMatchResultvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.BookMatchResult.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

BookMatchResult Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ConnectionChangeEventArgs Class

Event arguments passed with OnClosed and OnOpened.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveScoutConnectionChangeEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ConnectionChangeEventArgs : EventArgs

The ConnectionChangeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionChangeEventArgs | Initializes a new instance of the ConnectionChangeEventArgs class
Top
Properties
 | Name | Description
Public property | LocalTimestamp | Connection change timestamp (local UTC timestamp)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


ConnectionChangeEventArgs Constructor

Initializes a new instance of the ConnectionChangeEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ConnectionChangeEventArgs()
See Also

Reference

ConnectionChangeEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ConnectionChangeEventArgs Properties

The ConnectionChangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | LocalTimestamp | Connection change timestamp (local UTC timestamp)
Top
See Also

Reference

ConnectionChangeEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ConnectionChangeEventArgs.LocalTimestamp Property

ConnectionChangeEventArgsLocalTimestamp Property

Connection change timestamp (local UTC timestamp)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime LocalTimestamp { get; }

Property Value

DateTime
See Also

Reference

ConnectionChangeEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ConnectionChangeEventArgs Methods

The ConnectionChangeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionChangeEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ConnectionTest Class

Connection test.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase
Sportradar.SDK.FeedProviders.LiveScoutConnectionTest

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ConnectionTest : ScoutEntityBase

The ConnectionTest type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionTest | Initializes a new instance of the ConnectionTest class
Top
Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


ConnectionTest Constructor

Initializes a new instance of the ConnectionTest class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ConnectionTest()
See Also

Reference

ConnectionTest Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ConnectionTest Properties

The ConnectionTest type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Top
See Also

Reference

ConnectionTest Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ConnectionTest Methods

The ConnectionTest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

ConnectionTest Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ConnectionTest.ToString Method

ConnectionTestToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

ConnectionTest Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Court Class

Court
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutCourt

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Court

The Court type exposes the following members.

Constructors
 | Name | Description
Public method | Court | Initializes a new instance of the Court class
Top
Properties
 | Name | Description
Public property | CourtSeq | Court seq
Public property | Id | Id
Public property | Name | Name
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Court Constructor

Initializes a new instance of the Court class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Court()
See Also

Reference

Court Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Court Properties

The Court type exposes the following members.

Properties
 | Name | Description
Public property | CourtSeq | Court seq
Public property | Id | Id
Public property | Name | Name
Top
See Also

Reference

Court Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Court.CourtSeq Property

CourtCourtSeq Property

Court seq

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? CourtSeq { get; }

Property Value

Nullable Int32
See Also

Reference

Court Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Court.Id Property

CourtId Property

Id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

Court Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Court.Name Property

CourtName Property

Name

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; }

Property Value

String
See Also

Reference

Court Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Court Methods

The Court type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Court Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Court.ToString Method

CourtToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Court Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Coverage Class

Type of match coverage.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutCoverage

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class Coverage : Enum

The Coverage type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | TV | TV coverage
 | UNDEFINED | Undefined
Public field | value__ |
 | VENUE | Coverage from the venue
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Coverage Methods

The Coverage type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

Coverage Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Coverage Fields

The Coverage type exposes the following members.

Fields
 | Name | Description
 | TV | TV coverage
 | UNDEFINED | Undefined
Public field | value__ |
 | VENUE | Coverage from the venue
Top
See Also

Reference

Coverage Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Coverage.TV Field

CoverageTV Field

TV coverage

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Coverage TV = 1

Field Value

Coverage
See Also

Reference

Coverage Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Coverage.UNDEFINED Field

CoverageUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Coverage UNDEFINED = 0

Field Value

Coverage
See Also

Reference

Coverage Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Coverage.value__ Field

Coveragevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.Coverage.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

Coverage Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Coverage.VENUE Field

CoverageVENUE Field

Coverage from the venue

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Coverage VENUE = 2

Field Value

Coverage
See Also

Reference

Coverage Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType Class

Event type. See LiveScout documentation to see which event types are supported for each sport. New event types can be offered in future.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutEventType

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class EventType : Enum

The EventType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | ACTIVE_GOAL_KEEPER | Active goal keeper
 | ADD_BALL | Add ball
 | AMERICAN_FOOTBALL_KICKOFF | American football kickoff
 | APPEAL | Appeal
 | ATTACK | Attack (Tennis)
 | ATTENDANCE | Attendance
 | BADMINTON_SCORE_CHANGE | Badminton score change
 | BALK | Balk
 | BALL | Ball
 | BALL_CHANGE_FREQUENCY | Ball change frequency
 | BALL_FINISHED | Ball finished
 | BALL_HIT | Ball hit
 | BALL_IN_PLAY | Ball in play at Volleyball and Beach Volleyball
 | BALL_IN_PLAY_SERVICE_TAKEN | Ball in play / Service taken at Tennis
 | BALL_KICKED | Ball kicked
 | BALL_POSITION | Ball position
 | BALL_POSSESSION | Ball possession
 | BALL_POT | Ball pot
 | BALL_RECYCLED | Ball recycled
 | BALL_SAFE | Ball safe
 | BASKETBALL_SCORE_CHANGE | Basketball score change
 | BASKETBALL_SCORE_MISS | Basketball score miss
 | BATSMAN_COMING_ON | Batsman coming on
 | BATTER_ADVANCES_TO_BASE_X | Batter advanced to base x
 | BATTER_OUT | Batter out
 | BEST_OF_FRAMES | Best of frames
 | BEST_OF_LEGS | Best of legs
 | BET_START | Bet start
 | BET_STOP | Bet stop
 | BIG_PLAY | Big play
 | BLACKCARD | Black card
 | BLOCK | Block
 | BLUE_CARD | Yellow and red card
 | BOUNDARY | Boundary
 | BOWL | Bowl
 | BOWLER_CHANGE | Bowler change
 | BOWLER_RUNNING_IN | Bowler running in
 | BOWLER_STARTS | Bowler starts
 | BREAK_DUE_TO_EXTREME_WEATHER_CONDITIONS | Break due to extreme weather conditions (Tennis)
 | BREAK_DUE_TO_EXTREME_WEATHER_CONDITIONS_OVER | Break due to extreme weather conditions over (Tennis)
 | CANCELED_2_POINT_CONVERSION | Canceled 2 point conversion
 | CANCELED_CHALLENGE | Delayed penalty (Ice Hockey)
 | CANCELED_EXTRA_POINT | Canceled extra point
 | CANCELED_FIELD_GOAL | Canceled field goal
 | CANCELED_PUNT | Canceled punt
 | CANCELED_SAFETY | Canceled safety
 | CANCELED_TURNOVER | Canceled turnover
 | CANCELED_VIDEO_ASSISTANT_REFEREE | The canceled video assistant referee
 | CANCELED_VIDEO_REVIEW | Sent when video review is not confirmed
 | CANCELLED_CORNER | Cancelled corner
 | CANCELLED_EXCLUSION | Cancelled exclusion (Handball)
 | CANCELLED_GOAL | Cancelled goal Extra info: 0 or -1(not specified, 1(off side, 2(foul, 3(incorrect entry, 4(out of bounds, 5(play stopped
 | CANCELLED_PENALTY | Cancelled penalty
 | CANCELLED_POINT | Cancelled point
 | CANCELLED_RED_CARD | Cancelled red card
 | CANCELLED_SUSPENSION | Cancelled suspension (Handball)
 | CANCELLED_YELLOW_CARD | Cancelled yellow card
 | CHAIR_UMPIRE_ON_COURT | Chair umpire on court (Tennis)
 | CHALLENGE | Challenge
 | CHALLENGE_AF | Challenge af
 | CHALLENGE_COUNT | Interception count (American Football)
 | CHALLENGE_DECISION | Challenge decision
 | CHALLENGE_NOT_CONFIRMED | Challenge not confirmed
 | CHECKED_RUNNER | Checked runner
 | CODE_VIOLATION | Code violation (Tennis)
 | CONVERSION | Conversion
 | CORNER | Corner
 | CORNER_KICK_COUNT | Corner kick count
 | CORRECT_BALL_DATA | Correct ball data (Cricket)
 | CORRECT_BATSMAN_DATA | Correct Batsman data (Cricket)
 | CORRECT_BATSMAN_ON_STRIKE | Correct batsman on strike (Cricket)
 | CORRECT_BOWLER_DATA | Correct bowler data (Cricket)
 | CORRECT_TEAM_DATA | Correct team data (Cricket)
 | COVERAGE_STATUS | Coverage status
 | DANGEROUS_ATTACK | Dangerous attack
 | DARTS_SCORE_CHANGE | Darts score change
 | DEAD_BALL | Dead ball
 | DEAD_BOWL | Dead bowl
 | DEAD_END | Dead end
 | DEAD_JACK | Dead jack
 | DECISION_REVIEW | Decision review
 | DECISION_REVIEW_RESULT | Decision review result
 | DEFENSIVE_FOUL | Defensive foul (Handball)
 | DEFENSIVE_RETURN | Defensive return
 | DEFENSIVE_RETURN_NOT_CONFIRMED | Defensive return not confirmed
 | DELAYED_PENALTY | Delayed penalty
 | DELETED_EVENT_ALERT | Deleted event alert
 | DENIED_DROP_GOAL | Denied drop goal
 | DENIED_TRY | Denied try
 | DIRECT_FOUL | Direct foul
 | DIRECT_FREE_KICK | Direct free kick
 | DISMISSAL_BOWLED | Dismissal bowled
 | DISMISSAL_CAUGHT | Dismissal caught
 | DISMISSAL_HANDLED_THE_BALL | Dismissal handled by the ball
 | DISMISSAL_HIT_THE_BALL_TWICE | Dismissal hit the ball twice
 | DISMISSAL_HIT_WICKET | Dismissal hit wicket
 | DISMISSAL_LBW | Dismissal lbw
 | DISMISSAL_OBSTRUCTING_THE_FIELD | Dismissal obstructing the field
 | DISMISSAL_RETIRED | Dismissal retired
 | DISMISSAL_RUN_OUT | Dismissal run out
 | DISMISSAL_STUMPED | Dismissal stumped
 | DISMISSAL_TIMED_OUT | Dismissal timed out
 | DISQUALIFICATION | Disqualification
 | DOT_BALL | Dot ball
 | DRIVES_COUNT | Drives count (American Football)
 | DROP_GOAL | Drop goal
 | DROP_GOAL_ATTEMPT | Drop goal attempt
 | DROP_GOAL_FROM_MARK | Drop goal from mark
 | DROP_OUT | Drop out (used in Rugby)
 | DUCKWORTH_LEWIS | Duckworth lewis
 | EARLY_BETSTATUS | Early bet status
 | EMPTY_NET_SITUATION | Empty net situation
 | EMPTY_NET_SITUATION_CANCELLED | Empty net situation cancelled
 | EMPTY_NET_SITUATION_OVER | Empty net situation over
 | ENABLE_DISABLE_BOOKING_MARKETS | Enable/disable booking markets
 | ENABLE_DISABLE_CORNER_MARKETS | Enable/disable corner markets
 | END_START | End start
 | EXCLUSION | Exclusion (Handball)
 | EXPEDITE_MODE | Expedite mode
 | EXTRA_POINT | Extra point
 | EXTRAS_BYE | Extras bye
 | EXTRAS_BYE_BYE | Extras bye bye
 | EXTRAS_NO_BALL | Extras no ball
 | EXTRAS_PENALTY_RUNS | Extras penalty runs
 | EXTRAS_WIDE | Extras wide
 | FIELD_GOAL_RESULT | Field goal result
 | FIRST_SET_AWARDED | First set awarded
 | FOLLOW_ON | Follow on
 | FORTY_TWENTY | 40-20 (used in Rugby)
 | FOUL | Foul at Basketball
 | FOUL_BALL | Foul ball
 | FOULS_COUNT | Fouls count at Soccer
 | FREE_BALL | Free ball
 | FREE_BALL_AWARDED | Free ball awarded (snooker)
 | FREE_HIT | Free hit
 | FREE_KICK | Free kick
 | FREE_KICK_COUNT | Free kick count
 | FREE_TEXT | Free text
 | FREE_THROW | Free throw
 | FUMBLE | Fumble
 | FUMBLE_COUNT | Fumble count (American Football)
 | FUMBLE_RECOVERED | Fumble recovered
 | FUMBLE_RECOVERED_COUNT | Fumble recovered count (American Football)
 | GAME_ON | Game on
 | GOAL | Goal
 | GOAL_KICK | Goal kick
 | GOAL_KICK_COUNT | Goal kick count
 | GOALKEEPER_SAVE | Goalkeeper save
 | GOALKEEPER_SAVE_COUNT | Goalkeeper save count
 | GOING_FOR_KICK_AT_GOAL | Going for kick at goal
 | INJURY | Injury
 | INJURY_TIME | Injury time
 | INNINGS_FINISHED | Innings finished
 | INNINGS_STARTED | Innings started
 | INTERCEPTION | Interception
 | INTERCEPTION_COUNT | Turnover count (American Football)
 | JACK_ROLL | Jack roll
 | KICK_TO_TOUCH | Kick to touch
 | KICKOFF_TEAM | Kick-off team at Soccer
 | LINE_OUT | Line out
 | LINE_OUT_WON | Line out won
 | MANUAL_TIME_ADJUSTMENT | Manual time adjustment
 | MATCH_ABOUT_TO_START | Match about to start
 | MATCH_CALLED | Match called (Tennis)
 | MATCH_FORMAT | Match format
 | MATCH_STATUS | Match status
 | MATCH_STOP_OR_SUSPENSION | Match stop / suspension (Tennis) Extra info: 3(injury), 4(flood light failure), 5(persons entering field of play), 6 (crowd control issue), 7(water break), 8(disciplinary issue), 9(gone to TMO (video referee))
 | MATCH_STOP_OR_SUSPENSION_OVER | Match stop / suspension over (Tennis)
 | MISSED_RUGBY_POINT | Missed rugby point
 | NEW_BALL | New ball
 | NEW_PHASE | New phase
 | NUMBER_OF_FREE_THROWS | Number of free throws
 | OFFSIDE | Offside
 | OFFSIDE_COUNT | Offside count
 | ONE_SHORT | One short
 | OVER_FINISHED | Over finished
 | OVER_STARTED | Over started
 | OVERRULE | Overrule
 | PASS | Pass
 | PASS_COUNT | Pass count (American Football)
 | PASSIVE_PLAY | Passive play
 | PASSIVE_PLAY_CALLED | Passive play called (Handball)
 | PASSIVE_PLAY_CANCELED | Passive play canceled
 | PENALTY | Penalty
 | PENALTY_ADVANTAGE | Penalty advantage (used in Rugby)
 | PENALTY_AWARDED | Penalty awarded at Futsal
 | PENALTY_COUNT | Penalty count (American Football)
 | PENALTY_MISSED | Penalty missed at Soccer
 | PENALTY_POINTS | Penalty points
 | PENALTY_SHOOTOUT | Penalty shootout at Ice Hockey
 | PENALTY_SHOOTOUT_EVENT_DEEP_COVERAGE | Penalty shootout event deep coverage
 | PENALTY_SHOOTOUT_MISSED | Penalty shootout missed at Ice Hockey
 | PENALTY_SHOOTOUT_STARTING_TEAM | Penalty shootout starting team
 | PENALTY_TRY | Penalty try
 | PITCH_CONDITIONS | Pitch conditions
 | PITCH_MAP | Pitch map
 | PLAY_ABOUT_TO_START | Play about to start
 | PLAY_CANCELLED | Play cancelled (Basketball)
 | PLAY_OVER | Play over (Basketball)
 | PLAY_OVER_AF | Play over af
 | PLAY_OVER_BB | Play over bb
 | PLAY_RESUMES_AFTER_GOAL | Play resumes after goal
 | PLAY_START | Play start (Basketball)
 | PLAY_START_AF | Play start af
 | PLAY_START_BB | Play start bb
 | PLAY_START_COUNT | Play start count (American Football)
 | PLAYER_BACK_FROM_INJURY | Player back from injury
 | PLAYERS_WALK_ON | Players walk on
 | POSSIBLE_2_POINT_CONVERSION | Possible 2 point conversion
 | POSSIBLE_7_METER_THROW | Possible 7 meter throw at Handball
 | POSSIBLE_BOUNDARY | Possible boundary
 | POSSIBLE_CHALLENGE | Possible challenge
 | POSSIBLE_CORNER | Possible corner
 | POSSIBLE_DEFENSIVE_RETURN | Possible defensive return
 | POSSIBLE_EMPTY_NET_SITUATION | Possible empty net situation Events (POSSIBLE_EMPTY_NET_SITUATION and EMPTY_NET_SITUATION) were switched on 2014-12-02
 | POSSIBLE_EXCLUSION | Possible exclusion (Handball)
 | POSSIBLE_EXTRA_POINT | Possible extra point
 | POSSIBLE_FIELD_GOAL | Possible field goal
 | POSSIBLE_FOURTH_DOWN_ATTEMPT | Possible fourth down attempt
 | POSSIBLE_GOAL | Possible goal
 | POSSIBLE_ONSIDE_KICK | Possible onside kick
 | POSSIBLE_PENALTY | Possible penalty at Soccer, Ice Hockey and Futsal
 | POSSIBLE_PUNT | Possible punt
 | POSSIBLE_RED_CARD | Possible red card
 | POSSIBLE_SAFETY | Possible safety
 | POSSIBLE_SUSPENSION | Possible suspension (Handball)
 | POSSIBLE_TOUCHDOWN | Possible touchdown
 | POSSIBLE_TRY | Possible try
 | POSSIBLE_TURNOVER | Possible turnover
 | POSSIBLE_VIDEO_ASSISTANT_REFEREE | The possible video assistant referee
 | POSSIBLE_WICKET | Possible wicket
 | POSSIBLE_YELLOW_CARD | Possible yellow card
 | POWER_PLAY_FINISHED | Power play finished (Cricket)
 | POWER_PLAY_STARTED | Power play started (Cricket)
 | PUNT_RESULT | Punt result
 | REBOUND | Rebound
 | REBOUND_COUNT | Rebound count (Basketball)
 | RED_CARD | Red card
 | REDELIVER_JACK | Redeliver jack
 | REDUCED_OVERS_MATCH | Reduced overs match (Cricket)
 | REMOVE_BALL | Remove ball
 | REPLAY_BOWL | Replay bowl
 | REPLAY_OF_POINT | Replay of point (Tennis)
 | RERACK | Rerack
 | RESET_PHASE_COUNT | Reset phase count
 | RESTART_END | Restart end
 | RETIRED_HURT | Retired hurt
 | RULE_SET | Rule set
 | RUN_SCORED | Run scored
 | RUNNER_ADVANCES_TO_BASE_X | Runner advances to base
 | RUNNER_OUT | Runner out
 | RUNNERS_IN_MOTION | Runners in motion
 | RUNS | Runs
 | RUSH | Rush
 | RUSH_COUNT | Rush count (American Football)
 | SACK | Sack
 | SAFETY | Safety
 | SCORE_ADJUSTMENT | Score adjustment (Handball, Basketball and Volleyball)
 | SCORE_CHANGE | Score change
 | SCORE_EVENT_CORRECTION | Score event correction
 | SCRUM_OUTCOME | Scrum outcome
 | SCRUM_RESET | Scrum reset
 | SERVICE_TAKEN | Service taken
 | SESSION_FINISHED | Session finished
 | SESSION_STARTED | Session started
 | SEVEN_METER_THROW | 7 meter throw at Handball
 | SEVEN_METER_THROW_MISSED | 7 meter throw missed at Handball
 | SEVENTH_PLAYER_SUB | Empty net
 | SHOT_BLOCKED | Shot blocked
 | SHOT_BLOCKED_COUNT | Shot blocked count
 | SHOT_OFF_TARGET | Shot off target
 | SHOT_OFF_TARGET_COUNT | Shot off target count
 | SHOT_ON_TARGET | Shot on target
 | SHOT_ON_TARGET_COUNT | Shot on target count
 | SINGLE_DART_THROW | Single dart throw
 | SNOOKER_FOUL | Snooker foul
 | SNOOKER_SCORE_CHANGE | Snooker score change
 | START_DELAYED | Start delayed
 | STATS_CORRECTION | Stats correction
 | STEAL | Steal (Handball)
 | STEAL_BASKETBALL | Steal basketball
 | STRIKE | Strike
 | SUBSTITUTION | Substitution
 | SURFACE_TYPE | The surface type
 | SUSPENSION | Suspension
 | SUSPENSION_OVER | Suspension over
 | TABLE_READY | Table ready
 | TABLE_TENNIS_SCORE_CHANGE | Table tennis score change
 | TABLE_TENNIS_VIOLATION | Table tennis violation
 | TAP_AND_GO | Tap and go
 | TECHNICAL_FAULT | Technical rule fault (TRF) (Handball)
 | TECHNICAL_FOUL | Technical ball handling fault (TF) (Handball)
 | TELEVISION_MATCH_OFFICIAL_ASSISTS | Television match official assists
 | TEMPERATURE | Temperature
 | TEMPORARY_INTERRUPTION | Temporary interruption
 | TENNIS_SCORE_CHANGE | Tennis score change
 | TENNIS_SERVICE_FAULT | Tennis service fault
 | THIRD_UMPIRE | Third umpire
 | THREE_POINT_MISS_COUNT | Three point miss count (Basketball)
 | THROW_IN | Throw in
 | THROW_IN_COUNT | Throw in count
 | TIME_STARTSTOP | Time start/stop
 | TIME_VIOLATION | Time violation (Tennis)
 | TIMEOUT | Timeout
 | TIMEOUT_OVER | Timeout over
 | TOILET_BREAK_OR_CHANGE_OF_ATTIRE | Toilet break / change of attire (Tennis)
 | TOILET_BREAK_OR_CHANGE_OF_ATTIRE_OVER | Toilet break / change of attire over (Tennis)
 | TOSS | Toss
 | TOUCHDOWN | Touchdown
 | TRAINER_CALLED | Trainer called (Tennis)
 | TRAINER_CALLED_FINISHED | Trainer called finished (Tennis)
 | TRIAL_END | Trial end
 | TRY | Try
 | TURNOVER | Turnover
 | TURNOVER_AF | Turnover af
 | TURNOVER_BASKETBALL | Turnover
 | TURNOVER_COUNT | Turnover count (American Football)
 | TV_TIMEOUT | TV Timeout (Ice Hockey)
 | TV_TIMEOUT_OVER | Tv Timeout over (Ice Hockey)
 | TWENTY_M_RESTART | 20m restart (used in Rugby)
 | TWENTYTWO_DROP_OUT | Twenty two drop out
 | TWO_POINT_CONVERSION | Two point conversion
 | TWO_POINT_MISS_COUNT | Two point miss count (Basketball)
 | UNDEFINED | Unknown, check event id
 | UNSCHEDULED_BREAK | Unscheduled break
 | USE_CHALLENGES_OFFICIAL_REVIEWS | Use challenges official reviews
Public field | value__ |
 | VIDEO_ASSISTANT_REFEREE | The video assistant referee
 | VIDEO_ASSISTANT_REFEREE_OVER | The video assistant referee over
 | VIDEO_REVIEW_OVER | Video review over
 | VIDEO_REVIEW_START | Video review start
 | VOLLEYBALL_SCORE_CHANGE | Volleyball score change
 | WARNING | Warning
 | WEATHER_CONDITIONS | Weather conditions
 | WHICH_PLAYER_RECEIVES_FIRST_WITHIN_A_DOUBLES_TEAM | Which player receives first within a doubles team (Tennis)
 | WHICH_PLAYER_SERVES_FIRST_WITHIN_A_DOUBLES_TEAM | Which player serves first within a doubles team (Tennis)
 | WHICH_TEAM_SERVES_FIRST | Which team serves first
 | WHICH_TEAM_STARTS_SERVING_ON_THE_LEFT_HAND_SIDE_OF_THE_UMPIRE | Which team starts serving on the left hand side of the umpire (Tennis)
 | WHICH_TEAM_STARTS_WITH_POSSESSION | Which team starts with possession at Ice Hockey
 | WHO_MADE_FIRST_SERVER_DECISION | Who made first server decision (Tennis)
 | WHO_SERVES_FIRST_IN_TIE_BREAK_SET | Who serves first in tie break set
 | WHO_THROWS_THE_FIRST_PITCH | Who throws the first pitch
 | WHO_WON_COIN_TOSS | Who won coin toss (Tennis)
 | WHO_WON_JUMP_BALL | Who won jump ball
 | WIND | Wind
 | WIND_ADVANTAGE | Wind advantage
 | YELLOW_CARD | Yellow card
 | YELLOWRED_CARD | Yellow and red card
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType Methods

The EventType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType Fields

The EventType type exposes the following members.

Fields
 | Name | Description
 | ACTIVE_GOAL_KEEPER | Active goal keeper
 | ADD_BALL | Add ball
 | AMERICAN_FOOTBALL_KICKOFF | American football kickoff
 | APPEAL | Appeal
 | ATTACK | Attack (Tennis)
 | ATTENDANCE | Attendance
 | BADMINTON_SCORE_CHANGE | Badminton score change
 | BALK | Balk
 | BALL | Ball
 | BALL_CHANGE_FREQUENCY | Ball change frequency
 | BALL_FINISHED | Ball finished
 | BALL_HIT | Ball hit
 | BALL_IN_PLAY | Ball in play at Volleyball and Beach Volleyball
 | BALL_IN_PLAY_SERVICE_TAKEN | Ball in play / Service taken at Tennis
 | BALL_KICKED | Ball kicked
 | BALL_POSITION | Ball position
 | BALL_POSSESSION | Ball possession
 | BALL_POT | Ball pot
 | BALL_RECYCLED | Ball recycled
 | BALL_SAFE | Ball safe
 | BASKETBALL_SCORE_CHANGE | Basketball score change
 | BASKETBALL_SCORE_MISS | Basketball score miss
 | BATSMAN_COMING_ON | Batsman coming on
 | BATTER_ADVANCES_TO_BASE_X | Batter advanced to base x
 | BATTER_OUT | Batter out
 | BEST_OF_FRAMES | Best of frames
 | BEST_OF_LEGS | Best of legs
 | BET_START | Bet start
 | BET_STOP | Bet stop
 | BIG_PLAY | Big play
 | BLACKCARD | Black card
 | BLOCK | Block
 | BLUE_CARD | Yellow and red card
 | BOUNDARY | Boundary
 | BOWL | Bowl
 | BOWLER_CHANGE | Bowler change
 | BOWLER_RUNNING_IN | Bowler running in
 | BOWLER_STARTS | Bowler starts
 | BREAK_DUE_TO_EXTREME_WEATHER_CONDITIONS | Break due to extreme weather conditions (Tennis)
 | BREAK_DUE_TO_EXTREME_WEATHER_CONDITIONS_OVER | Break due to extreme weather conditions over (Tennis)
 | CANCELED_2_POINT_CONVERSION | Canceled 2 point conversion
 | CANCELED_CHALLENGE | Delayed penalty (Ice Hockey)
 | CANCELED_EXTRA_POINT | Canceled extra point
 | CANCELED_FIELD_GOAL | Canceled field goal
 | CANCELED_PUNT | Canceled punt
 | CANCELED_SAFETY | Canceled safety
 | CANCELED_TURNOVER | Canceled turnover
 | CANCELED_VIDEO_ASSISTANT_REFEREE | The canceled video assistant referee
 | CANCELED_VIDEO_REVIEW | Sent when video review is not confirmed
 | CANCELLED_CORNER | Cancelled corner
 | CANCELLED_EXCLUSION | Cancelled exclusion (Handball)
 | CANCELLED_GOAL | Cancelled goal Extra info: 0 or -1(not specified, 1(off side, 2(foul, 3(incorrect entry, 4(out of bounds, 5(play stopped
 | CANCELLED_PENALTY | Cancelled penalty
 | CANCELLED_POINT | Cancelled point
 | CANCELLED_RED_CARD | Cancelled red card
 | CANCELLED_SUSPENSION | Cancelled suspension (Handball)
 | CANCELLED_YELLOW_CARD | Cancelled yellow card
 | CHAIR_UMPIRE_ON_COURT | Chair umpire on court (Tennis)
 | CHALLENGE | Challenge
 | CHALLENGE_AF | Challenge af
 | CHALLENGE_COUNT | Interception count (American Football)
 | CHALLENGE_DECISION | Challenge decision
 | CHALLENGE_NOT_CONFIRMED | Challenge not confirmed
 | CHECKED_RUNNER | Checked runner
 | CODE_VIOLATION | Code violation (Tennis)
 | CONVERSION | Conversion
 | CORNER | Corner
 | CORNER_KICK_COUNT | Corner kick count
 | CORRECT_BALL_DATA | Correct ball data (Cricket)
 | CORRECT_BATSMAN_DATA | Correct Batsman data (Cricket)
 | CORRECT_BATSMAN_ON_STRIKE | Correct batsman on strike (Cricket)
 | CORRECT_BOWLER_DATA | Correct bowler data (Cricket)
 | CORRECT_TEAM_DATA | Correct team data (Cricket)
 | COVERAGE_STATUS | Coverage status
 | DANGEROUS_ATTACK | Dangerous attack
 | DARTS_SCORE_CHANGE | Darts score change
 | DEAD_BALL | Dead ball
 | DEAD_BOWL | Dead bowl
 | DEAD_END | Dead end
 | DEAD_JACK | Dead jack
 | DECISION_REVIEW | Decision review
 | DECISION_REVIEW_RESULT | Decision review result
 | DEFENSIVE_FOUL | Defensive foul (Handball)
 | DEFENSIVE_RETURN | Defensive return
 | DEFENSIVE_RETURN_NOT_CONFIRMED | Defensive return not confirmed
 | DELAYED_PENALTY | Delayed penalty
 | DELETED_EVENT_ALERT | Deleted event alert
 | DENIED_DROP_GOAL | Denied drop goal
 | DENIED_TRY | Denied try
 | DIRECT_FOUL | Direct foul
 | DIRECT_FREE_KICK | Direct free kick
 | DISMISSAL_BOWLED | Dismissal bowled
 | DISMISSAL_CAUGHT | Dismissal caught
 | DISMISSAL_HANDLED_THE_BALL | Dismissal handled by the ball
 | DISMISSAL_HIT_THE_BALL_TWICE | Dismissal hit the ball twice
 | DISMISSAL_HIT_WICKET | Dismissal hit wicket
 | DISMISSAL_LBW | Dismissal lbw
 | DISMISSAL_OBSTRUCTING_THE_FIELD | Dismissal obstructing the field
 | DISMISSAL_RETIRED | Dismissal retired
 | DISMISSAL_RUN_OUT | Dismissal run out
 | DISMISSAL_STUMPED | Dismissal stumped
 | DISMISSAL_TIMED_OUT | Dismissal timed out
 | DISQUALIFICATION | Disqualification
 | DOT_BALL | Dot ball
 | DRIVES_COUNT | Drives count (American Football)
 | DROP_GOAL | Drop goal
 | DROP_GOAL_ATTEMPT | Drop goal attempt
 | DROP_GOAL_FROM_MARK | Drop goal from mark
 | DROP_OUT | Drop out (used in Rugby)
 | DUCKWORTH_LEWIS | Duckworth lewis
 | EARLY_BETSTATUS | Early bet status
 | EMPTY_NET_SITUATION | Empty net situation
 | EMPTY_NET_SITUATION_CANCELLED | Empty net situation cancelled
 | EMPTY_NET_SITUATION_OVER | Empty net situation over
 | ENABLE_DISABLE_BOOKING_MARKETS | Enable/disable booking markets
 | ENABLE_DISABLE_CORNER_MARKETS | Enable/disable corner markets
 | END_START | End start
 | EXCLUSION | Exclusion (Handball)
 | EXPEDITE_MODE | Expedite mode
 | EXTRA_POINT | Extra point
 | EXTRAS_BYE | Extras bye
 | EXTRAS_BYE_BYE | Extras bye bye
 | EXTRAS_NO_BALL | Extras no ball
 | EXTRAS_PENALTY_RUNS | Extras penalty runs
 | EXTRAS_WIDE | Extras wide
 | FIELD_GOAL_RESULT | Field goal result
 | FIRST_SET_AWARDED | First set awarded
 | FOLLOW_ON | Follow on
 | FORTY_TWENTY | 40-20 (used in Rugby)
 | FOUL | Foul at Basketball
 | FOUL_BALL | Foul ball
 | FOULS_COUNT | Fouls count at Soccer
 | FREE_BALL | Free ball
 | FREE_BALL_AWARDED | Free ball awarded (snooker)
 | FREE_HIT | Free hit
 | FREE_KICK | Free kick
 | FREE_KICK_COUNT | Free kick count
 | FREE_TEXT | Free text
 | FREE_THROW | Free throw
 | FUMBLE | Fumble
 | FUMBLE_COUNT | Fumble count (American Football)
 | FUMBLE_RECOVERED | Fumble recovered
 | FUMBLE_RECOVERED_COUNT | Fumble recovered count (American Football)
 | GAME_ON | Game on
 | GOAL | Goal
 | GOAL_KICK | Goal kick
 | GOAL_KICK_COUNT | Goal kick count
 | GOALKEEPER_SAVE | Goalkeeper save
 | GOALKEEPER_SAVE_COUNT | Goalkeeper save count
 | GOING_FOR_KICK_AT_GOAL | Going for kick at goal
 | INJURY | Injury
 | INJURY_TIME | Injury time
 | INNINGS_FINISHED | Innings finished
 | INNINGS_STARTED | Innings started
 | INTERCEPTION | Interception
 | INTERCEPTION_COUNT | Turnover count (American Football)
 | JACK_ROLL | Jack roll
 | KICK_TO_TOUCH | Kick to touch
 | KICKOFF_TEAM | Kick-off team at Soccer
 | LINE_OUT | Line out
 | LINE_OUT_WON | Line out won
 | MANUAL_TIME_ADJUSTMENT | Manual time adjustment
 | MATCH_ABOUT_TO_START | Match about to start
 | MATCH_CALLED | Match called (Tennis)
 | MATCH_FORMAT | Match format
 | MATCH_STATUS | Match status
 | MATCH_STOP_OR_SUSPENSION | Match stop / suspension (Tennis) Extra info: 3(injury), 4(flood light failure), 5(persons entering field of play), 6 (crowd control issue), 7(water break), 8(disciplinary issue), 9(gone to TMO (video referee))
 | MATCH_STOP_OR_SUSPENSION_OVER | Match stop / suspension over (Tennis)
 | MISSED_RUGBY_POINT | Missed rugby point
 | NEW_BALL | New ball
 | NEW_PHASE | New phase
 | NUMBER_OF_FREE_THROWS | Number of free throws
 | OFFSIDE | Offside
 | OFFSIDE_COUNT | Offside count
 | ONE_SHORT | One short
 | OVER_FINISHED | Over finished
 | OVER_STARTED | Over started
 | OVERRULE | Overrule
 | PASS | Pass
 | PASS_COUNT | Pass count (American Football)
 | PASSIVE_PLAY | Passive play
 | PASSIVE_PLAY_CALLED | Passive play called (Handball)
 | PASSIVE_PLAY_CANCELED | Passive play canceled
 | PENALTY | Penalty
 | PENALTY_ADVANTAGE | Penalty advantage (used in Rugby)
 | PENALTY_AWARDED | Penalty awarded at Futsal
 | PENALTY_COUNT | Penalty count (American Football)
 | PENALTY_MISSED | Penalty missed at Soccer
 | PENALTY_POINTS | Penalty points
 | PENALTY_SHOOTOUT | Penalty shootout at Ice Hockey
 | PENALTY_SHOOTOUT_EVENT_DEEP_COVERAGE | Penalty shootout event deep coverage
 | PENALTY_SHOOTOUT_MISSED | Penalty shootout missed at Ice Hockey
 | PENALTY_SHOOTOUT_STARTING_TEAM | Penalty shootout starting team
 | PENALTY_TRY | Penalty try
 | PITCH_CONDITIONS | Pitch conditions
 | PITCH_MAP | Pitch map
 | PLAY_ABOUT_TO_START | Play about to start
 | PLAY_CANCELLED | Play cancelled (Basketball)
 | PLAY_OVER | Play over (Basketball)
 | PLAY_OVER_AF | Play over af
 | PLAY_OVER_BB | Play over bb
 | PLAY_RESUMES_AFTER_GOAL | Play resumes after goal
 | PLAY_START | Play start (Basketball)
 | PLAY_START_AF | Play start af
 | PLAY_START_BB | Play start bb
 | PLAY_START_COUNT | Play start count (American Football)
 | PLAYER_BACK_FROM_INJURY | Player back from injury
 | PLAYERS_WALK_ON | Players walk on
 | POSSIBLE_2_POINT_CONVERSION | Possible 2 point conversion
 | POSSIBLE_7_METER_THROW | Possible 7 meter throw at Handball
 | POSSIBLE_BOUNDARY | Possible boundary
 | POSSIBLE_CHALLENGE | Possible challenge
 | POSSIBLE_CORNER | Possible corner
 | POSSIBLE_DEFENSIVE_RETURN | Possible defensive return
 | POSSIBLE_EMPTY_NET_SITUATION | Possible empty net situation Events (POSSIBLE_EMPTY_NET_SITUATION and EMPTY_NET_SITUATION) were switched on 2014-12-02
 | POSSIBLE_EXCLUSION | Possible exclusion (Handball)
 | POSSIBLE_EXTRA_POINT | Possible extra point
 | POSSIBLE_FIELD_GOAL | Possible field goal
 | POSSIBLE_FOURTH_DOWN_ATTEMPT | Possible fourth down attempt
 | POSSIBLE_GOAL | Possible goal
 | POSSIBLE_ONSIDE_KICK | Possible onside kick
 | POSSIBLE_PENALTY | Possible penalty at Soccer, Ice Hockey and Futsal
 | POSSIBLE_PUNT | Possible punt
 | POSSIBLE_RED_CARD | Possible red card
 | POSSIBLE_SAFETY | Possible safety
 | POSSIBLE_SUSPENSION | Possible suspension (Handball)
 | POSSIBLE_TOUCHDOWN | Possible touchdown
 | POSSIBLE_TRY | Possible try
 | POSSIBLE_TURNOVER | Possible turnover
 | POSSIBLE_VIDEO_ASSISTANT_REFEREE | The possible video assistant referee
 | POSSIBLE_WICKET | Possible wicket
 | POSSIBLE_YELLOW_CARD | Possible yellow card
 | POWER_PLAY_FINISHED | Power play finished (Cricket)
 | POWER_PLAY_STARTED | Power play started (Cricket)
 | PUNT_RESULT | Punt result
 | REBOUND | Rebound
 | REBOUND_COUNT | Rebound count (Basketball)
 | RED_CARD | Red card
 | REDELIVER_JACK | Redeliver jack
 | REDUCED_OVERS_MATCH | Reduced overs match (Cricket)
 | REMOVE_BALL | Remove ball
 | REPLAY_BOWL | Replay bowl
 | REPLAY_OF_POINT | Replay of point (Tennis)
 | RERACK | Rerack
 | RESET_PHASE_COUNT | Reset phase count
 | RESTART_END | Restart end
 | RETIRED_HURT | Retired hurt
 | RULE_SET | Rule set
 | RUN_SCORED | Run scored
 | RUNNER_ADVANCES_TO_BASE_X | Runner advances to base
 | RUNNER_OUT | Runner out
 | RUNNERS_IN_MOTION | Runners in motion
 | RUNS | Runs
 | RUSH | Rush
 | RUSH_COUNT | Rush count (American Football)
 | SACK | Sack
 | SAFETY | Safety
 | SCORE_ADJUSTMENT | Score adjustment (Handball, Basketball and Volleyball)
 | SCORE_CHANGE | Score change
 | SCORE_EVENT_CORRECTION | Score event correction
 | SCRUM_OUTCOME | Scrum outcome
 | SCRUM_RESET | Scrum reset
 | SERVICE_TAKEN | Service taken
 | SESSION_FINISHED | Session finished
 | SESSION_STARTED | Session started
 | SEVEN_METER_THROW | 7 meter throw at Handball
 | SEVEN_METER_THROW_MISSED | 7 meter throw missed at Handball
 | SEVENTH_PLAYER_SUB | Empty net
 | SHOT_BLOCKED | Shot blocked
 | SHOT_BLOCKED_COUNT | Shot blocked count
 | SHOT_OFF_TARGET | Shot off target
 | SHOT_OFF_TARGET_COUNT | Shot off target count
 | SHOT_ON_TARGET | Shot on target
 | SHOT_ON_TARGET_COUNT | Shot on target count
 | SINGLE_DART_THROW | Single dart throw
 | SNOOKER_FOUL | Snooker foul
 | SNOOKER_SCORE_CHANGE | Snooker score change
 | START_DELAYED | Start delayed
 | STATS_CORRECTION | Stats correction
 | STEAL | Steal (Handball)
 | STEAL_BASKETBALL | Steal basketball
 | STRIKE | Strike
 | SUBSTITUTION | Substitution
 | SURFACE_TYPE | The surface type
 | SUSPENSION | Suspension
 | SUSPENSION_OVER | Suspension over
 | TABLE_READY | Table ready
 | TABLE_TENNIS_SCORE_CHANGE | Table tennis score change
 | TABLE_TENNIS_VIOLATION | Table tennis violation
 | TAP_AND_GO | Tap and go
 | TECHNICAL_FAULT | Technical rule fault (TRF) (Handball)
 | TECHNICAL_FOUL | Technical ball handling fault (TF) (Handball)
 | TELEVISION_MATCH_OFFICIAL_ASSISTS | Television match official assists
 | TEMPERATURE | Temperature
 | TEMPORARY_INTERRUPTION | Temporary interruption
 | TENNIS_SCORE_CHANGE | Tennis score change
 | TENNIS_SERVICE_FAULT | Tennis service fault
 | THIRD_UMPIRE | Third umpire
 | THREE_POINT_MISS_COUNT | Three point miss count (Basketball)
 | THROW_IN | Throw in
 | THROW_IN_COUNT | Throw in count
 | TIME_STARTSTOP | Time start/stop
 | TIME_VIOLATION | Time violation (Tennis)
 | TIMEOUT | Timeout
 | TIMEOUT_OVER | Timeout over
 | TOILET_BREAK_OR_CHANGE_OF_ATTIRE | Toilet break / change of attire (Tennis)
 | TOILET_BREAK_OR_CHANGE_OF_ATTIRE_OVER | Toilet break / change of attire over (Tennis)
 | TOSS | Toss
 | TOUCHDOWN | Touchdown
 | TRAINER_CALLED | Trainer called (Tennis)
 | TRAINER_CALLED_FINISHED | Trainer called finished (Tennis)
 | TRIAL_END | Trial end
 | TRY | Try
 | TURNOVER | Turnover
 | TURNOVER_AF | Turnover af
 | TURNOVER_BASKETBALL | Turnover
 | TURNOVER_COUNT | Turnover count (American Football)
 | TV_TIMEOUT | TV Timeout (Ice Hockey)
 | TV_TIMEOUT_OVER | Tv Timeout over (Ice Hockey)
 | TWENTY_M_RESTART | 20m restart (used in Rugby)
 | TWENTYTWO_DROP_OUT | Twenty two drop out
 | TWO_POINT_CONVERSION | Two point conversion
 | TWO_POINT_MISS_COUNT | Two point miss count (Basketball)
 | UNDEFINED | Unknown, check event id
 | UNSCHEDULED_BREAK | Unscheduled break
 | USE_CHALLENGES_OFFICIAL_REVIEWS | Use challenges official reviews
Public field | value__ |
 | VIDEO_ASSISTANT_REFEREE | The video assistant referee
 | VIDEO_ASSISTANT_REFEREE_OVER | The video assistant referee over
 | VIDEO_REVIEW_OVER | Video review over
 | VIDEO_REVIEW_START | Video review start
 | VOLLEYBALL_SCORE_CHANGE | Volleyball score change
 | WARNING | Warning
 | WEATHER_CONDITIONS | Weather conditions
 | WHICH_PLAYER_RECEIVES_FIRST_WITHIN_A_DOUBLES_TEAM | Which player receives first within a doubles team (Tennis)
 | WHICH_PLAYER_SERVES_FIRST_WITHIN_A_DOUBLES_TEAM | Which player serves first within a doubles team (Tennis)
 | WHICH_TEAM_SERVES_FIRST | Which team serves first
 | WHICH_TEAM_STARTS_SERVING_ON_THE_LEFT_HAND_SIDE_OF_THE_UMPIRE | Which team starts serving on the left hand side of the umpire (Tennis)
 | WHICH_TEAM_STARTS_WITH_POSSESSION | Which team starts with possession at Ice Hockey
 | WHO_MADE_FIRST_SERVER_DECISION | Who made first server decision (Tennis)
 | WHO_SERVES_FIRST_IN_TIE_BREAK_SET | Who serves first in tie break set
 | WHO_THROWS_THE_FIRST_PITCH | Who throws the first pitch
 | WHO_WON_COIN_TOSS | Who won coin toss (Tennis)
 | WHO_WON_JUMP_BALL | Who won jump ball
 | WIND | Wind
 | WIND_ADVANTAGE | Wind advantage
 | YELLOW_CARD | Yellow card
 | YELLOWRED_CARD | Yellow and red card
Top
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.ACTIVE_GOAL_KEEPER Field

EventTypeACTIVE_GOAL_KEEPER Field

Active goal keeper

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType ACTIVE_GOAL_KEEPER = 1704

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.ADD_BALL Field

EventTypeADD_BALL Field

Add ball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType ADD_BALL = 1175

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.AMERICAN_FOOTBALL_KICKOFF Field

EventTypeAMERICAN_FOOTBALL_KICKOFF Field

American football kickoff

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType AMERICAN_FOOTBALL_KICKOFF = 1445

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.APPEAL Field

EventTypeAPPEAL Field

Appeal

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType APPEAL = 1335

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.ATTACK Field

EventTypeATTACK Field

Attack (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType ATTACK = 1126

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.ATTENDANCE Field

EventTypeATTENDANCE Field

Attendance

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType ATTENDANCE = 165

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BADMINTON_SCORE_CHANGE Field

EventTypeBADMINTON_SCORE_CHANGE Field

Badminton score change

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BADMINTON_SCORE_CHANGE = 1141

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALK Field

EventTypeBALK Field

Balk

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALK = 1728

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALL Field

EventTypeBALL Field

Ball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALL = 1723

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALL_CHANGE_FREQUENCY Field

EventTypeBALL_CHANGE_FREQUENCY Field

Ball change frequency

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALL_CHANGE_FREQUENCY = 1106

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALL_FINISHED Field

EventTypeBALL_FINISHED Field

Ball finished

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALL_FINISHED = 1308

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALL_HIT Field

EventTypeBALL_HIT Field

Ball hit

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALL_HIT = 1310

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALL_IN_PLAY Field

EventTypeBALL_IN_PLAY Field

Ball in play at Volleyball and Beach Volleyball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALL_IN_PLAY = 1031

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALL_IN_PLAY_SERVICE_TAKEN Field

EventTypeBALL_IN_PLAY_SERVICE_TAKEN Field

Ball in play / Service taken at Tennis

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALL_IN_PLAY_SERVICE_TAKEN = 1031

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALL_KICKED Field

EventTypeBALL_KICKED Field

Ball kicked

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALL_KICKED = 1144

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALL_POSITION Field

EventTypeBALL_POSITION Field

Ball position

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALL_POSITION = 1062

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALL_POSSESSION Field

EventTypeBALL_POSSESSION Field

Ball possession

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALL_POSSESSION = 110

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALL_POT Field

EventTypeBALL_POT Field

Ball pot

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALL_POT = 1169

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALL_RECYCLED Field

EventTypeBALL_RECYCLED Field

Ball recycled

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALL_RECYCLED = 1143

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BALL_SAFE Field

EventTypeBALL_SAFE Field

Ball safe

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BALL_SAFE = 1030

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BASKETBALL_SCORE_CHANGE Field

EventTypeBASKETBALL_SCORE_CHANGE Field

Basketball score change

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BASKETBALL_SCORE_CHANGE = 1037

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BASKETBALL_SCORE_MISS Field

EventTypeBASKETBALL_SCORE_MISS Field

Basketball score miss

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BASKETBALL_SCORE_MISS = 1038

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BATSMAN_COMING_ON Field

EventTypeBATSMAN_COMING_ON Field

Batsman coming on

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BATSMAN_COMING_ON = 1339

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BATTER_ADVANCES_TO_BASE_X Field

EventTypeBATTER_ADVANCES_TO_BASE_X Field

Batter advanced to base x

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BATTER_ADVANCES_TO_BASE_X = 1727

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BATTER_OUT Field

EventTypeBATTER_OUT Field

Batter out

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BATTER_OUT = 1726

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BEST_OF_FRAMES Field

EventTypeBEST_OF_FRAMES Field

Best of frames

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BEST_OF_FRAMES = 1136

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BEST_OF_LEGS Field

EventTypeBEST_OF_LEGS Field

Best of legs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BEST_OF_LEGS = 1135

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BET_START Field

EventTypeBET_START Field

Bet start

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BET_START = 1010

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BET_STOP Field

EventTypeBET_STOP Field

Bet stop

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BET_STOP = 1011

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BIG_PLAY Field

EventTypeBIG_PLAY Field

Big play

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BIG_PLAY = 1736

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BLACKCARD Field

EventTypeBLACKCARD Field

Black card

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BLACKCARD = 1142

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BLOCK Field

EventTypeBLOCK Field

Block

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BLOCK = 1735

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BLUE_CARD Field

EventTypeBLUE_CARD Field

Yellow and red card

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BLUE_CARD = 48

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BOUNDARY Field

EventTypeBOUNDARY Field

Boundary

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BOUNDARY = 1312

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BOWL Field

EventTypeBOWL Field

Bowl

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BOWL = 1504

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BOWLER_CHANGE Field

EventTypeBOWLER_CHANGE Field

Bowler change

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BOWLER_CHANGE = 1340

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BOWLER_RUNNING_IN Field

EventTypeBOWLER_RUNNING_IN Field

Bowler running in

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BOWLER_RUNNING_IN = 1307

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BOWLER_STARTS Field

EventTypeBOWLER_STARTS Field

Bowler starts

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BOWLER_STARTS = 1501

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BREAK_DUE_TO_EXTREME_WEATHER_CONDITIONS Field

EventTypeBREAK_DUE_TO_EXTREME_WEATHER_CONDITIONS Field

Break due to extreme weather conditions (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BREAK_DUE_TO_EXTREME_WEATHER_CONDITIONS = 1108

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.BREAK_DUE_TO_EXTREME_WEATHER_CONDITIONS_OVER Field

EventTypeBREAK_DUE_TO_EXTREME_WEATHER_CONDITIONS_OVER Field

Break due to extreme weather conditions over (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType BREAK_DUE_TO_EXTREME_WEATHER_CONDITIONS_OVER = 1109

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELED_2_POINT_CONVERSION Field

EventTypeCANCELED_2_POINT_CONVERSION Field

Canceled 2 point conversion

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELED_2_POINT_CONVERSION = 1450

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELED_CHALLENGE Field

EventTypeCANCELED_CHALLENGE Field

Delayed penalty (Ice Hockey)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELED_CHALLENGE = 1443

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELED_EXTRA_POINT Field

EventTypeCANCELED_EXTRA_POINT Field

Canceled extra point

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELED_EXTRA_POINT = 1452

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELED_FIELD_GOAL Field

EventTypeCANCELED_FIELD_GOAL Field

Canceled field goal

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELED_FIELD_GOAL = 1425

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELED_PUNT Field

EventTypeCANCELED_PUNT Field

Canceled punt

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELED_PUNT = 1456

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELED_SAFETY Field

EventTypeCANCELED_SAFETY Field

Canceled safety

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELED_SAFETY = 1454

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELED_TURNOVER Field

EventTypeCANCELED_TURNOVER Field

Canceled turnover

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELED_TURNOVER = 1448

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELED_VIDEO_ASSISTANT_REFEREE Field

EventTypeCANCELED_VIDEO_ASSISTANT_REFEREE Field

The canceled video assistant referee

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELED_VIDEO_ASSISTANT_REFEREE = 2067

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELED_VIDEO_REVIEW Field

EventTypeCANCELED_VIDEO_REVIEW Field

Sent when video review is not confirmed

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELED_VIDEO_REVIEW = 1921

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELLED_CORNER Field

EventTypeCANCELLED_CORNER Field

Cancelled corner

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELLED_CORNER = 1017

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELLED_EXCLUSION Field

EventTypeCANCELLED_EXCLUSION Field

Cancelled exclusion (Handball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELLED_EXCLUSION = 1419

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELLED_GOAL Field

EventTypeCANCELLED_GOAL Field

Cancelled goal Extra info: 0 or -1(not specified, 1(off side, 2(foul, 3(incorrect entry, 4(out of bounds, 5(play stopped

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELLED_GOAL = 1019

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELLED_PENALTY Field

EventTypeCANCELLED_PENALTY Field

Cancelled penalty

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELLED_PENALTY = 1043

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELLED_POINT Field

EventTypeCANCELLED_POINT Field

Cancelled point

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELLED_POINT = 1028

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELLED_RED_CARD Field

EventTypeCANCELLED_RED_CARD Field

Cancelled red card

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELLED_RED_CARD = 1041

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELLED_SUSPENSION Field

EventTypeCANCELLED_SUSPENSION Field

Cancelled suspension (Handball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELLED_SUSPENSION = 1418

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CANCELLED_YELLOW_CARD Field

EventTypeCANCELLED_YELLOW_CARD Field

Cancelled yellow card

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CANCELLED_YELLOW_CARD = 1085

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CHAIR_UMPIRE_ON_COURT Field

EventTypeCHAIR_UMPIRE_ON_COURT Field

Chair umpire on court (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CHAIR_UMPIRE_ON_COURT = 1107

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CHALLENGE Field

EventTypeCHALLENGE Field

Challenge

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CHALLENGE = 1659

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CHALLENGE_AF Field

EventTypeCHALLENGE_AF Field

Challenge af

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CHALLENGE_AF = 1433

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CHALLENGE_COUNT Field

EventTypeCHALLENGE_COUNT Field

Interception count (American Football)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CHALLENGE_COUNT = 1614

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CHALLENGE_DECISION Field

EventTypeCHALLENGE_DECISION Field

Challenge decision

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CHALLENGE_DECISION = 1656

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CHALLENGE_NOT_CONFIRMED Field

EventTypeCHALLENGE_NOT_CONFIRMED Field

Challenge not confirmed

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CHALLENGE_NOT_CONFIRMED = 1660

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CHECKED_RUNNER Field

EventTypeCHECKED_RUNNER Field

Checked runner

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CHECKED_RUNNER = 1718

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CODE_VIOLATION Field

EventTypeCODE_VIOLATION Field

Code violation (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CODE_VIOLATION = 1115

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CONVERSION Field

EventTypeCONVERSION Field

Conversion

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CONVERSION = 1156

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CORNER Field

EventTypeCORNER Field

Corner

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CORNER = 154

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CORNER_KICK_COUNT Field

EventTypeCORNER_KICK_COUNT Field

Corner kick count

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CORNER_KICK_COUNT = 124

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CORRECT_BALL_DATA Field

EventTypeCORRECT_BALL_DATA Field

Correct ball data (Cricket)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CORRECT_BALL_DATA = 1349

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CORRECT_BATSMAN_DATA Field

EventTypeCORRECT_BATSMAN_DATA Field

Correct Batsman data (Cricket)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CORRECT_BATSMAN_DATA = 1345

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CORRECT_BATSMAN_ON_STRIKE Field

EventTypeCORRECT_BATSMAN_ON_STRIKE Field

Correct batsman on strike (Cricket)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CORRECT_BATSMAN_ON_STRIKE = 1348

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CORRECT_BOWLER_DATA Field

EventTypeCORRECT_BOWLER_DATA Field

Correct bowler data (Cricket)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CORRECT_BOWLER_DATA = 1346

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.CORRECT_TEAM_DATA Field

EventTypeCORRECT_TEAM_DATA Field

Correct team data (Cricket)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType CORRECT_TEAM_DATA = 1347

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.COVERAGE_STATUS Field

EventTypeCOVERAGE_STATUS Field

Coverage status

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType COVERAGE_STATUS = 1102

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DANGEROUS_ATTACK Field

EventTypeDANGEROUS_ATTACK Field

Dangerous attack

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DANGEROUS_ATTACK = 1029

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DARTS_SCORE_CHANGE Field

EventTypeDARTS_SCORE_CHANGE Field

Darts score change

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DARTS_SCORE_CHANGE = 1130

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DEAD_BALL Field

EventTypeDEAD_BALL Field

Dead ball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DEAD_BALL = 1332

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DEAD_BOWL Field

EventTypeDEAD_BOWL Field

Dead bowl

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DEAD_BOWL = 1509

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DEAD_END Field

EventTypeDEAD_END Field

Dead end

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DEAD_END = 1507

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DEAD_JACK Field

EventTypeDEAD_JACK Field

Dead jack

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DEAD_JACK = 1508

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DECISION_REVIEW Field

EventTypeDECISION_REVIEW Field

Decision review

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DECISION_REVIEW = 1337

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DECISION_REVIEW_RESULT Field

EventTypeDECISION_REVIEW_RESULT Field

Decision review result

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DECISION_REVIEW_RESULT = 1338

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DEFENSIVE_FOUL Field

EventTypeDEFENSIVE_FOUL Field

Defensive foul (Handball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DEFENSIVE_FOUL = 1411

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DEFENSIVE_RETURN Field

EventTypeDEFENSIVE_RETURN Field

Defensive return

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DEFENSIVE_RETURN = 1738

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DEFENSIVE_RETURN_NOT_CONFIRMED Field

EventTypeDEFENSIVE_RETURN_NOT_CONFIRMED Field

Defensive return not confirmed

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DEFENSIVE_RETURN_NOT_CONFIRMED = 1739

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DELAYED_PENALTY Field

EventTypeDELAYED_PENALTY Field

Delayed penalty

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DELAYED_PENALTY = 1521

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DELETED_EVENT_ALERT Field

EventTypeDELETED_EVENT_ALERT Field

Deleted event alert

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DELETED_EVENT_ALERT = 1044

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DENIED_DROP_GOAL Field

EventTypeDENIED_DROP_GOAL Field

Denied drop goal

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DENIED_DROP_GOAL = 1168

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DENIED_TRY Field

EventTypeDENIED_TRY Field

Denied try

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DENIED_TRY = 1167

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DIRECT_FOUL Field

EventTypeDIRECT_FOUL Field

Direct foul

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DIRECT_FOUL = 1059

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DIRECT_FREE_KICK Field

EventTypeDIRECT_FREE_KICK Field

Direct free kick

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DIRECT_FREE_KICK = 1060

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DISMISSAL_BOWLED Field

EventTypeDISMISSAL_BOWLED Field

Dismissal bowled

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DISMISSAL_BOWLED = 1322

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DISMISSAL_CAUGHT Field

EventTypeDISMISSAL_CAUGHT Field

Dismissal caught

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DISMISSAL_CAUGHT = 1324

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DISMISSAL_HANDLED_THE_BALL Field

EventTypeDISMISSAL_HANDLED_THE_BALL Field

Dismissal handled by the ball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DISMISSAL_HANDLED_THE_BALL = 1325

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DISMISSAL_HIT_THE_BALL_TWICE Field

EventTypeDISMISSAL_HIT_THE_BALL_TWICE Field

Dismissal hit the ball twice

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DISMISSAL_HIT_THE_BALL_TWICE = 1326

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DISMISSAL_HIT_WICKET Field

EventTypeDISMISSAL_HIT_WICKET Field

Dismissal hit wicket

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DISMISSAL_HIT_WICKET = 1327

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DISMISSAL_LBW Field

EventTypeDISMISSAL_LBW Field

Dismissal lbw

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DISMISSAL_LBW = 1328

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DISMISSAL_OBSTRUCTING_THE_FIELD Field

EventTypeDISMISSAL_OBSTRUCTING_THE_FIELD Field

Dismissal obstructing the field

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DISMISSAL_OBSTRUCTING_THE_FIELD = 1329

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DISMISSAL_RETIRED Field

EventTypeDISMISSAL_RETIRED Field

Dismissal retired

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DISMISSAL_RETIRED = 1321

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DISMISSAL_RUN_OUT Field

EventTypeDISMISSAL_RUN_OUT Field

Dismissal run out

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DISMISSAL_RUN_OUT = 1330

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DISMISSAL_STUMPED Field

EventTypeDISMISSAL_STUMPED Field

Dismissal stumped

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DISMISSAL_STUMPED = 1331

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DISMISSAL_TIMED_OUT Field

EventTypeDISMISSAL_TIMED_OUT Field

Dismissal timed out

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DISMISSAL_TIMED_OUT = 1323

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DISQUALIFICATION Field

EventTypeDISQUALIFICATION Field

Disqualification

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DISQUALIFICATION = 1511

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DOT_BALL Field

EventTypeDOT_BALL Field

Dot ball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DOT_BALL = 1311

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DRIVES_COUNT Field

EventTypeDRIVES_COUNT Field

Drives count (American Football)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DRIVES_COUNT = 1633

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DROP_GOAL Field

EventTypeDROP_GOAL Field

Drop goal

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DROP_GOAL = 1158

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DROP_GOAL_ATTEMPT Field

EventTypeDROP_GOAL_ATTEMPT Field

Drop goal attempt

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DROP_GOAL_ATTEMPT = 1166

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DROP_GOAL_FROM_MARK Field

EventTypeDROP_GOAL_FROM_MARK Field

Drop goal from mark

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DROP_GOAL_FROM_MARK = 1159

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DROP_OUT Field

EventTypeDROP_OUT Field

Drop out (used in Rugby)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DROP_OUT = 1200

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.DUCKWORTH_LEWIS Field

EventTypeDUCKWORTH_LEWIS Field

Duckworth lewis

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType DUCKWORTH_LEWIS = 1344

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.EARLY_BETSTATUS Field

EventTypeEARLY_BETSTATUS Field

Early bet status

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType EARLY_BETSTATUS = 1091

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.EMPTY_NET_SITUATION Field

EventTypeEMPTY_NET_SITUATION Field

Empty net situation

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType EMPTY_NET_SITUATION = 1051

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.EMPTY_NET_SITUATION_CANCELLED Field

EventTypeEMPTY_NET_SITUATION_CANCELLED Field

Empty net situation cancelled

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType EMPTY_NET_SITUATION_CANCELLED = 1053

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.EMPTY_NET_SITUATION_OVER Field

EventTypeEMPTY_NET_SITUATION_OVER Field

Empty net situation over

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType EMPTY_NET_SITUATION_OVER = 1052

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.ENABLE_DISABLE_BOOKING_MARKETS Field

EventTypeENABLE_DISABLE_BOOKING_MARKETS Field

Enable/disable booking markets

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType ENABLE_DISABLE_BOOKING_MARKETS = 1083

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.ENABLE_DISABLE_CORNER_MARKETS Field

EventTypeENABLE_DISABLE_CORNER_MARKETS Field

Enable/disable corner markets

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType ENABLE_DISABLE_CORNER_MARKETS = 1082

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.END_START Field

EventTypeEND_START Field

End start

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType END_START = 1512

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.EXCLUSION Field

EventTypeEXCLUSION Field

Exclusion (Handball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType EXCLUSION = 1415

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.EXPEDITE_MODE Field

EventTypeEXPEDITE_MODE Field

Expedite mode

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType EXPEDITE_MODE = 1176

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.EXTRA_POINT Field

EventTypeEXTRA_POINT Field

Extra point

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType EXTRA_POINT = 1423

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.EXTRAS_BYE Field

EventTypeEXTRAS_BYE Field

Extras bye

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType EXTRAS_BYE = 1317

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.EXTRAS_BYE_BYE Field

EventTypeEXTRAS_BYE_BYE Field

Extras bye bye

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType EXTRAS_BYE_BYE = 1318

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.EXTRAS_NO_BALL Field

EventTypeEXTRAS_NO_BALL Field

Extras no ball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType EXTRAS_NO_BALL = 1315

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.EXTRAS_PENALTY_RUNS Field

EventTypeEXTRAS_PENALTY_RUNS Field

Extras penalty runs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType EXTRAS_PENALTY_RUNS = 1319

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.EXTRAS_WIDE Field

EventTypeEXTRAS_WIDE Field

Extras wide

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType EXTRAS_WIDE = 1316

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FIELD_GOAL_RESULT Field

EventTypeFIELD_GOAL_RESULT Field

Field goal result

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FIELD_GOAL_RESULT = 1426

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FIRST_SET_AWARDED Field

EventTypeFIRST_SET_AWARDED Field

First set awarded

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FIRST_SET_AWARDED = 1516

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FOLLOW_ON Field

EventTypeFOLLOW_ON Field

Follow on

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FOLLOW_ON = 1342

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FORTY_TWENTY Field

EventTypeFORTY_TWENTY Field

40-20 (used in Rugby)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FORTY_TWENTY = 1202

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FOUL Field

EventTypeFOUL Field

Foul at Basketball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FOUL = 129

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FOUL_BALL Field

EventTypeFOUL_BALL Field

Foul ball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FOUL_BALL = 1724

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FOULS_COUNT Field

EventTypeFOULS_COUNT Field

Fouls count at Soccer

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FOULS_COUNT = 129

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FREE_BALL Field

EventTypeFREE_BALL Field

Free ball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FREE_BALL = 1170

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FREE_BALL_AWARDED Field

EventTypeFREE_BALL_AWARDED Field

Free ball awarded (snooker)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FREE_BALL_AWARDED = 1203

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FREE_HIT Field

EventTypeFREE_HIT Field

Free hit

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FREE_HIT = 1320

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FREE_KICK Field

EventTypeFREE_KICK Field

Free kick

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FREE_KICK = 150

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FREE_KICK_COUNT Field

EventTypeFREE_KICK_COUNT Field

Free kick count

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FREE_KICK_COUNT = 120

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FREE_TEXT Field

EventTypeFREE_TEXT Field

Free text

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FREE_TEXT = 1015

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FREE_THROW Field

EventTypeFREE_THROW Field

Free throw

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FREE_THROW = 1054

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FUMBLE Field

EventTypeFUMBLE Field

Fumble

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FUMBLE = 1428

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FUMBLE_COUNT Field

EventTypeFUMBLE_COUNT Field

Fumble count (American Football)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FUMBLE_COUNT = 1610

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FUMBLE_RECOVERED Field

EventTypeFUMBLE_RECOVERED Field

Fumble recovered

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FUMBLE_RECOVERED = 1446

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.FUMBLE_RECOVERED_COUNT Field

EventTypeFUMBLE_RECOVERED_COUNT Field

Fumble recovered count (American Football)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType FUMBLE_RECOVERED_COUNT = 1611

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.GAME_ON Field

EventTypeGAME_ON Field

Game on

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType GAME_ON = 16

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.GOAL Field

EventTypeGOAL Field

Goal

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType GOAL = 30

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.GOAL_KICK Field

EventTypeGOAL_KICK Field

Goal kick

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType GOAL_KICK = 151

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.GOAL_KICK_COUNT Field

EventTypeGOAL_KICK_COUNT Field

Goal kick count

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType GOAL_KICK_COUNT = 121

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.GOALKEEPER_SAVE Field

EventTypeGOALKEEPER_SAVE Field

Goalkeeper save

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType GOALKEEPER_SAVE = 157

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.GOALKEEPER_SAVE_COUNT Field

EventTypeGOALKEEPER_SAVE_COUNT Field

Goalkeeper save count

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType GOALKEEPER_SAVE_COUNT = 127

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.GOING_FOR_KICK_AT_GOAL Field

EventTypeGOING_FOR_KICK_AT_GOAL Field

Going for kick at goal

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType GOING_FOR_KICK_AT_GOAL = 1164

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.INJURY Field

EventTypeINJURY Field

Injury

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType INJURY = 158

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.INJURY_TIME Field

EventTypeINJURY_TIME Field

Injury time

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType INJURY_TIME = 90

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.INNINGS_FINISHED Field

EventTypeINNINGS_FINISHED Field

Innings finished

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType INNINGS_FINISHED = 1304

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.INNINGS_STARTED Field

EventTypeINNINGS_STARTED Field

Innings started

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType INNINGS_STARTED = 1303

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.INTERCEPTION Field

EventTypeINTERCEPTION Field

Interception

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType INTERCEPTION = 1429

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.INTERCEPTION_COUNT Field

EventTypeINTERCEPTION_COUNT Field

Turnover count (American Football)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType INTERCEPTION_COUNT = 1613

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.JACK_ROLL Field

EventTypeJACK_ROLL Field

Jack roll

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType JACK_ROLL = 1502

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.KICK_TO_TOUCH Field

EventTypeKICK_TO_TOUCH Field

Kick to touch

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType KICK_TO_TOUCH = 1150

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.KICKOFF_TEAM Field

EventTypeKICKOFF_TEAM Field

Kick-off team at Soccer

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType KICKOFF_TEAM = 1012

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.LINE_OUT Field

EventTypeLINE_OUT Field

Line out

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType LINE_OUT = 1097

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.LINE_OUT_WON Field

EventTypeLINE_OUT_WON Field

Line out won

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType LINE_OUT_WON = 1147

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.MANUAL_TIME_ADJUSTMENT Field

EventTypeMANUAL_TIME_ADJUSTMENT Field

Manual time adjustment

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType MANUAL_TIME_ADJUSTMENT = 1039

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.MATCH_ABOUT_TO_START Field

EventTypeMATCH_ABOUT_TO_START Field

Match about to start

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType MATCH_ABOUT_TO_START = 1024

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.MATCH_CALLED Field

EventTypeMATCH_CALLED Field

Match called (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType MATCH_CALLED = 1124

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.MATCH_FORMAT Field

EventTypeMATCH_FORMAT Field

Match format

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType MATCH_FORMAT = 1515

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.MATCH_STATUS Field

EventTypeMATCH_STATUS Field

Match status

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType MATCH_STATUS = 1013

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.MATCH_STOP_OR_SUSPENSION Field

EventTypeMATCH_STOP_OR_SUSPENSION Field

Match stop / suspension (Tennis) Extra info: 3(injury), 4(flood light failure), 5(persons entering field of play), 6 (crowd control issue), 7(water break), 8(disciplinary issue), 9(gone to TMO (video referee))

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType MATCH_STOP_OR_SUSPENSION = 1112

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.MATCH_STOP_OR_SUSPENSION_OVER Field

EventTypeMATCH_STOP_OR_SUSPENSION_OVER Field

Match stop / suspension over (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType MATCH_STOP_OR_SUSPENSION_OVER = 1113

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.MISSED_RUGBY_POINT Field

EventTypeMISSED_RUGBY_POINT Field

Missed rugby point

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType MISSED_RUGBY_POINT = 1096

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.NEW_BALL Field

EventTypeNEW_BALL Field

New ball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType NEW_BALL = 1343

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.NEW_PHASE Field

EventTypeNEW_PHASE Field

New phase

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType NEW_PHASE = 1145

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.NUMBER_OF_FREE_THROWS Field

EventTypeNUMBER_OF_FREE_THROWS Field

Number of free throws

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType NUMBER_OF_FREE_THROWS = 1056

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.OFFSIDE Field

EventTypeOFFSIDE Field

Offside

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType OFFSIDE = 153

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.OFFSIDE_COUNT Field

EventTypeOFFSIDE_COUNT Field

Offside count

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType OFFSIDE_COUNT = 123

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.ONE_SHORT Field

EventTypeONE_SHORT Field

One short

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType ONE_SHORT = 1314

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.OVER_FINISHED Field

EventTypeOVER_FINISHED Field

Over finished

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType OVER_FINISHED = 1306

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.OVER_STARTED Field

EventTypeOVER_STARTED Field

Over started

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType OVER_STARTED = 1305

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.OVERRULE Field

EventTypeOVERRULE Field

Overrule

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType OVERRULE = 1658

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PASS Field

EventTypePASS Field

Pass

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PASS = 1440

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PASS_COUNT Field

EventTypePASS_COUNT Field

Pass count (American Football)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PASS_COUNT = 1606

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PASSIVE_PLAY Field

EventTypePASSIVE_PLAY Field

Passive play

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PASSIVE_PLAY = 1700

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PASSIVE_PLAY_CALLED Field

EventTypePASSIVE_PLAY_CALLED Field

Passive play called (Handball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PASSIVE_PLAY_CALLED = 1701

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PASSIVE_PLAY_CANCELED Field

EventTypePASSIVE_PLAY_CANCELED Field

Passive play canceled

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PASSIVE_PLAY_CANCELED = 1702

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PENALTY Field

EventTypePENALTY Field

Penalty

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PENALTY = 1435

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PENALTY_ADVANTAGE Field

EventTypePENALTY_ADVANTAGE Field

Penalty advantage (used in Rugby)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PENALTY_ADVANTAGE = 1196

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PENALTY_AWARDED Field

EventTypePENALTY_AWARDED Field

Penalty awarded at Futsal

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PENALTY_AWARDED = 161

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PENALTY_COUNT Field

EventTypePENALTY_COUNT Field

Penalty count (American Football)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PENALTY_COUNT = 1608

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PENALTY_MISSED Field

EventTypePENALTY_MISSED Field

Penalty missed at Soccer

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PENALTY_MISSED = 666

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PENALTY_POINTS Field

EventTypePENALTY_POINTS Field

Penalty points

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PENALTY_POINTS = 1157

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PENALTY_SHOOTOUT Field

EventTypePENALTY_SHOOTOUT Field

Penalty shootout at Ice Hockey

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PENALTY_SHOOTOUT = 161

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PENALTY_SHOOTOUT_EVENT_DEEP_COVERAGE Field

EventTypePENALTY_SHOOTOUT_EVENT_DEEP_COVERAGE Field

Penalty shootout event deep coverage

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PENALTY_SHOOTOUT_EVENT_DEEP_COVERAGE = 1002

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PENALTY_SHOOTOUT_MISSED Field

EventTypePENALTY_SHOOTOUT_MISSED Field

Penalty shootout missed at Ice Hockey

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PENALTY_SHOOTOUT_MISSED = 666

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PENALTY_SHOOTOUT_STARTING_TEAM Field

EventTypePENALTY_SHOOTOUT_STARTING_TEAM Field

Penalty shootout starting team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PENALTY_SHOOTOUT_STARTING_TEAM = 1104

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PENALTY_TRY Field

EventTypePENALTY_TRY Field

Penalty try

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PENALTY_TRY = 1155

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PITCH_CONDITIONS Field

EventTypePITCH_CONDITIONS Field

Pitch conditions

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PITCH_CONDITIONS = 1014

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PITCH_MAP Field

EventTypePITCH_MAP Field

Pitch map

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PITCH_MAP = 1309

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PLAY_ABOUT_TO_START Field

EventTypePLAY_ABOUT_TO_START Field

Play about to start

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PLAY_ABOUT_TO_START = 1187

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PLAY_CANCELLED Field

EventTypePLAY_CANCELLED Field

Play cancelled (Basketball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PLAY_CANCELLED = 1605

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PLAY_OVER Field

EventTypePLAY_OVER Field

Play over (Basketball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PLAY_OVER = 1604

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PLAY_OVER_AF Field

EventTypePLAY_OVER_AF Field

Play over af

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PLAY_OVER_AF = 1431

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PLAY_OVER_BB Field

EventTypePLAY_OVER_BB Field

Play over bb

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PLAY_OVER_BB = 1716

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PLAY_RESUMES_AFTER_GOAL Field

EventTypePLAY_RESUMES_AFTER_GOAL Field

Play resumes after goal

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PLAY_RESUMES_AFTER_GOAL = 1064

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PLAY_START Field

EventTypePLAY_START Field

Play start (Basketball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PLAY_START = 1603

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PLAY_START_AF Field

EventTypePLAY_START_AF Field

Play start af

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PLAY_START_AF = 1430

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PLAY_START_BB Field

EventTypePLAY_START_BB Field

Play start bb

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PLAY_START_BB = 1715

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PLAY_START_COUNT Field

EventTypePLAY_START_COUNT Field

Play start count (American Football)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PLAY_START_COUNT = 1609

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PLAYER_BACK_FROM_INJURY Field

EventTypePLAYER_BACK_FROM_INJURY Field

Player back from injury

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PLAYER_BACK_FROM_INJURY = 168

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PLAYERS_WALK_ON Field

EventTypePLAYERS_WALK_ON Field

Players walk on

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PLAYERS_WALK_ON = 1179

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_2_POINT_CONVERSION Field

EventTypePOSSIBLE_2_POINT_CONVERSION Field

Possible 2 point conversion

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_2_POINT_CONVERSION = 1449

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_7_METER_THROW Field

EventTypePOSSIBLE_7_METER_THROW Field

Possible 7 meter throw at Handball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_7_METER_THROW = 1042

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_BOUNDARY Field

EventTypePOSSIBLE_BOUNDARY Field

Possible boundary

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_BOUNDARY = 1334

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_CHALLENGE Field

EventTypePOSSIBLE_CHALLENGE Field

Possible challenge

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_CHALLENGE = 1434

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_CORNER Field

EventTypePOSSIBLE_CORNER Field

Possible corner

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_CORNER = 1016

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_DEFENSIVE_RETURN Field

EventTypePOSSIBLE_DEFENSIVE_RETURN Field

Possible defensive return

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_DEFENSIVE_RETURN = 1737

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_EMPTY_NET_SITUATION Field

EventTypePOSSIBLE_EMPTY_NET_SITUATION Field

Possible empty net situation Events (POSSIBLE_EMPTY_NET_SITUATION and EMPTY_NET_SITUATION) were switched on 2014-12-02

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_EMPTY_NET_SITUATION = 1050

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_EXCLUSION Field

EventTypePOSSIBLE_EXCLUSION Field

Possible exclusion (Handball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_EXCLUSION = 1417

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_EXTRA_POINT Field

EventTypePOSSIBLE_EXTRA_POINT Field

Possible extra point

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_EXTRA_POINT = 1451

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_FIELD_GOAL Field

EventTypePOSSIBLE_FIELD_GOAL Field

Possible field goal

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_FIELD_GOAL = 1424

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_FOURTH_DOWN_ATTEMPT Field

EventTypePOSSIBLE_FOURTH_DOWN_ATTEMPT Field

Possible fourth down attempt

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_FOURTH_DOWN_ATTEMPT = 1740

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_GOAL Field

EventTypePOSSIBLE_GOAL Field

Possible goal

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_GOAL = 1018

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_ONSIDE_KICK Field

EventTypePOSSIBLE_ONSIDE_KICK Field

Possible onside kick

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_ONSIDE_KICK = 1747

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_PENALTY Field

EventTypePOSSIBLE_PENALTY Field

Possible penalty at Soccer, Ice Hockey and Futsal

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_PENALTY = 1042

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_PUNT Field

EventTypePOSSIBLE_PUNT Field

Possible punt

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_PUNT = 1455

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_RED_CARD Field

EventTypePOSSIBLE_RED_CARD Field

Possible red card

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_RED_CARD = 1040

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_SAFETY Field

EventTypePOSSIBLE_SAFETY Field

Possible safety

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_SAFETY = 1453

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_SUSPENSION Field

EventTypePOSSIBLE_SUSPENSION Field

Possible suspension (Handball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_SUSPENSION = 1416

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_TOUCHDOWN Field

EventTypePOSSIBLE_TOUCHDOWN Field

Possible touchdown

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_TOUCHDOWN = 1436

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_TRY Field

EventTypePOSSIBLE_TRY Field

Possible try

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_TRY = 1195

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_TURNOVER Field

EventTypePOSSIBLE_TURNOVER Field

Possible turnover

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_TURNOVER = 1447

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_VIDEO_ASSISTANT_REFEREE Field

EventTypePOSSIBLE_VIDEO_ASSISTANT_REFEREE Field

The possible video assistant referee

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_VIDEO_ASSISTANT_REFEREE = 2066

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_WICKET Field

EventTypePOSSIBLE_WICKET Field

Possible wicket

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_WICKET = 1333

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POSSIBLE_YELLOW_CARD Field

EventTypePOSSIBLE_YELLOW_CARD Field

Possible yellow card

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POSSIBLE_YELLOW_CARD = 1084

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POWER_PLAY_FINISHED Field

EventTypePOWER_PLAY_FINISHED Field

Power play finished (Cricket)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POWER_PLAY_FINISHED = 1352

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.POWER_PLAY_STARTED Field

EventTypePOWER_PLAY_STARTED Field

Power play started (Cricket)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType POWER_PLAY_STARTED = 1351

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.PUNT_RESULT Field

EventTypePUNT_RESULT Field

Punt result

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType PUNT_RESULT = 1432

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.REBOUND Field

EventTypeREBOUND Field

Rebound

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType REBOUND = 1034

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.REBOUND_COUNT Field

EventTypeREBOUND_COUNT Field

Rebound count (Basketball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType REBOUND_COUNT = 1602

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RED_CARD Field

EventTypeRED_CARD Field

Red card

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RED_CARD = 50

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.REDELIVER_JACK Field

EventTypeREDELIVER_JACK Field

Redeliver jack

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType REDELIVER_JACK = 1503

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.REDUCED_OVERS_MATCH Field

EventTypeREDUCED_OVERS_MATCH Field

Reduced overs match (Cricket)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType REDUCED_OVERS_MATCH = 1350

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.REMOVE_BALL Field

EventTypeREMOVE_BALL Field

Remove ball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType REMOVE_BALL = 1174

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.REPLAY_BOWL Field

EventTypeREPLAY_BOWL Field

Replay bowl

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType REPLAY_BOWL = 1510

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.REPLAY_OF_POINT Field

EventTypeREPLAY_OF_POINT Field

Replay of point (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType REPLAY_OF_POINT = 1127

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RERACK Field

EventTypeRERACK Field

Rerack

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RERACK = 1173

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RESET_PHASE_COUNT Field

EventTypeRESET_PHASE_COUNT Field

Reset phase count

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RESET_PHASE_COUNT = 1149

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RESTART_END Field

EventTypeRESTART_END Field

Restart end

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RESTART_END = 1506

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RETIRED_HURT Field

EventTypeRETIRED_HURT Field

Retired hurt

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RETIRED_HURT = 1341

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RULE_SET Field

EventTypeRULE_SET Field

Rule set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RULE_SET = 1461

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RUN_SCORED Field

EventTypeRUN_SCORED Field

Run scored

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RUN_SCORED = 1720

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RUNNER_ADVANCES_TO_BASE_X Field

EventTypeRUNNER_ADVANCES_TO_BASE_X Field

Runner advances to base

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RUNNER_ADVANCES_TO_BASE_X = 1719

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RUNNER_OUT Field

EventTypeRUNNER_OUT Field

Runner out

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RUNNER_OUT = 1721

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RUNNERS_IN_MOTION Field

EventTypeRUNNERS_IN_MOTION Field

Runners in motion

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RUNNERS_IN_MOTION = 1717

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RUNS Field

EventTypeRUNS Field

Runs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RUNS = 1313

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RUSH Field

EventTypeRUSH Field

Rush

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RUSH = 1441

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.RUSH_COUNT Field

EventTypeRUSH_COUNT Field

Rush count (American Football)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType RUSH_COUNT = 1607

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SACK Field

EventTypeSACK Field

Sack

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SACK = 1442

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SAFETY Field

EventTypeSAFETY Field

Safety

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SAFETY = 1421

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SCORE_ADJUSTMENT Field

EventTypeSCORE_ADJUSTMENT Field

Score adjustment (Handball, Basketball and Volleyball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SCORE_ADJUSTMENT = 1550

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SCORE_CHANGE Field

EventTypeSCORE_CHANGE Field

Score change

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SCORE_CHANGE = 1500

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SCORE_EVENT_CORRECTION Field

EventTypeSCORE_EVENT_CORRECTION Field

Score event correction

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SCORE_EVENT_CORRECTION = 1742

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SCRUM_OUTCOME Field

EventTypeSCRUM_OUTCOME Field

Scrum outcome

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SCRUM_OUTCOME = 1092

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SCRUM_RESET Field

EventTypeSCRUM_RESET Field

Scrum reset

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SCRUM_RESET = 1146

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SERVICE_TAKEN Field

EventTypeSERVICE_TAKEN Field

Service taken

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SERVICE_TAKEN = 1061

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SESSION_FINISHED Field

EventTypeSESSION_FINISHED Field

Session finished

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SESSION_FINISHED = 1302

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SESSION_STARTED Field

EventTypeSESSION_STARTED Field

Session started

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SESSION_STARTED = 1301

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SEVEN_METER_THROW Field

EventTypeSEVEN_METER_THROW Field

7 meter throw at Handball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SEVEN_METER_THROW = 161

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SEVEN_METER_THROW_MISSED Field

EventTypeSEVEN_METER_THROW_MISSED Field

7 meter throw missed at Handball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SEVEN_METER_THROW_MISSED = 666

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SEVENTH_PLAYER_SUB Field

EventTypeSEVENTH_PLAYER_SUB Field

Empty net

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SEVENTH_PLAYER_SUB = 1703

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SHOT_BLOCKED Field

EventTypeSHOT_BLOCKED Field

Shot blocked

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SHOT_BLOCKED = 172

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SHOT_BLOCKED_COUNT Field

EventTypeSHOT_BLOCKED_COUNT Field

Shot blocked count

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SHOT_BLOCKED_COUNT = 171

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SHOT_OFF_TARGET Field

EventTypeSHOT_OFF_TARGET Field

Shot off target

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SHOT_OFF_TARGET = 156

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SHOT_OFF_TARGET_COUNT Field

EventTypeSHOT_OFF_TARGET_COUNT Field

Shot off target count

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SHOT_OFF_TARGET_COUNT = 126

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SHOT_ON_TARGET Field

EventTypeSHOT_ON_TARGET Field

Shot on target

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SHOT_ON_TARGET = 155

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SHOT_ON_TARGET_COUNT Field

EventTypeSHOT_ON_TARGET_COUNT Field

Shot on target count

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SHOT_ON_TARGET_COUNT = 125

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SINGLE_DART_THROW Field

EventTypeSINGLE_DART_THROW Field

Single dart throw

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SINGLE_DART_THROW = 1132

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SNOOKER_FOUL Field

EventTypeSNOOKER_FOUL Field

Snooker foul

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SNOOKER_FOUL = 1171

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SNOOKER_SCORE_CHANGE Field

EventTypeSNOOKER_SCORE_CHANGE Field

Snooker score change

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SNOOKER_SCORE_CHANGE = 1137

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.START_DELAYED Field

EventTypeSTART_DELAYED Field

Start delayed

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType START_DELAYED = 1514

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.STATS_CORRECTION Field

EventTypeSTATS_CORRECTION Field

Stats correction

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType STATS_CORRECTION = 1832

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.STEAL Field

EventTypeSTEAL Field

Steal (Handball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType STEAL = 1412

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.STEAL_BASKETBALL Field

EventTypeSTEAL_BASKETBALL Field

Steal basketball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType STEAL_BASKETBALL = 1733

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.STRIKE Field

EventTypeSTRIKE Field

Strike

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType STRIKE = 1722

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SUBSTITUTION Field

EventTypeSUBSTITUTION Field

Substitution

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SUBSTITUTION = 60

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SURFACE_TYPE Field

EventTypeSURFACE_TYPE Field

The surface type

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SURFACE_TYPE = 1020

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SUSPENSION Field

EventTypeSUSPENSION Field

Suspension

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SUSPENSION = 43

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.SUSPENSION_OVER Field

EventTypeSUSPENSION_OVER Field

Suspension over

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType SUSPENSION_OVER = 1049

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TABLE_READY Field

EventTypeTABLE_READY Field

Table ready

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TABLE_READY = 1186

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TABLE_TENNIS_SCORE_CHANGE Field

EventTypeTABLE_TENNIS_SCORE_CHANGE Field

Table tennis score change

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TABLE_TENNIS_SCORE_CHANGE = 1161

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TABLE_TENNIS_VIOLATION Field

EventTypeTABLE_TENNIS_VIOLATION Field

Table tennis violation

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TABLE_TENNIS_VIOLATION = 1177

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TAP_AND_GO Field

EventTypeTAP_AND_GO Field

Tap and go

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TAP_AND_GO = 1148

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TECHNICAL_FAULT Field

EventTypeTECHNICAL_FAULT Field

Technical rule fault (TRF) (Handball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TECHNICAL_FAULT = 1414

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TECHNICAL_FOUL Field

EventTypeTECHNICAL_FOUL Field

Technical ball handling fault (TF) (Handball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TECHNICAL_FOUL = 1413

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TELEVISION_MATCH_OFFICIAL_ASSISTS Field

EventTypeTELEVISION_MATCH_OFFICIAL_ASSISTS Field

Television match official assists

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TELEVISION_MATCH_OFFICIAL_ASSISTS = 1165

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TEMPERATURE Field

EventTypeTEMPERATURE Field

Temperature

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TEMPERATURE = 1152

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TEMPORARY_INTERRUPTION Field

EventTypeTEMPORARY_INTERRUPTION Field

Temporary interruption

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TEMPORARY_INTERRUPTION = 15

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TENNIS_SCORE_CHANGE Field

EventTypeTENNIS_SCORE_CHANGE Field

Tennis score change

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TENNIS_SCORE_CHANGE = 1025

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TENNIS_SERVICE_FAULT Field

EventTypeTENNIS_SERVICE_FAULT Field

Tennis service fault

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TENNIS_SERVICE_FAULT = 1032

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.THIRD_UMPIRE Field

EventTypeTHIRD_UMPIRE Field

Third umpire

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType THIRD_UMPIRE = 1336

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.THREE_POINT_MISS_COUNT Field

EventTypeTHREE_POINT_MISS_COUNT Field

Three point miss count (Basketball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType THREE_POINT_MISS_COUNT = 1601

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.THROW_IN Field

EventTypeTHROW_IN Field

Throw in

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType THROW_IN = 152

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.THROW_IN_COUNT Field

EventTypeTHROW_IN_COUNT Field

Throw in count

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType THROW_IN_COUNT = 122

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TIME_STARTSTOP Field

EventTypeTIME_STARTSTOP Field

Time start/stop

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TIME_STARTSTOP = 1036

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TIME_VIOLATION Field

EventTypeTIME_VIOLATION Field

Time violation (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TIME_VIOLATION = 1116

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TIMEOUT Field

EventTypeTIMEOUT Field

Timeout

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TIMEOUT = 1035

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TIMEOUT_OVER Field

EventTypeTIMEOUT_OVER Field

Timeout over

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TIMEOUT_OVER = 1047

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TOILET_BREAK_OR_CHANGE_OF_ATTIRE Field

EventTypeTOILET_BREAK_OR_CHANGE_OF_ATTIRE Field

Toilet break / change of attire (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TOILET_BREAK_OR_CHANGE_OF_ATTIRE = 1110

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TOILET_BREAK_OR_CHANGE_OF_ATTIRE_OVER Field

EventTypeTOILET_BREAK_OR_CHANGE_OF_ATTIRE_OVER Field

Toilet break / change of attire over (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TOILET_BREAK_OR_CHANGE_OF_ATTIRE_OVER = 1111

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TOSS Field

EventTypeTOSS Field

Toss

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TOSS = 1300

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TOUCHDOWN Field

EventTypeTOUCHDOWN Field

Touchdown

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TOUCHDOWN = 1444

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TRAINER_CALLED Field

EventTypeTRAINER_CALLED Field

Trainer called (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TRAINER_CALLED = 1118

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TRAINER_CALLED_FINISHED Field

EventTypeTRAINER_CALLED_FINISHED Field

Trainer called finished (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TRAINER_CALLED_FINISHED = 1119

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TRIAL_END Field

EventTypeTRIAL_END Field

Trial end

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TRIAL_END = 1513

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TRY Field

EventTypeTRY Field

Try

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TRY = 1154

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TURNOVER Field

EventTypeTURNOVER Field

Turnover

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TURNOVER = 1162

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TURNOVER_AF Field

EventTypeTURNOVER_AF Field

Turnover af

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TURNOVER_AF = 1427

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TURNOVER_BASKETBALL Field

EventTypeTURNOVER_BASKETBALL Field

Turnover

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TURNOVER_BASKETBALL = 1734

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TURNOVER_COUNT Field

EventTypeTURNOVER_COUNT Field

Turnover count (American Football)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TURNOVER_COUNT = 1612

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TV_TIMEOUT Field

EventTypeTV_TIMEOUT Field

TV Timeout (Ice Hockey)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TV_TIMEOUT = 1437

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TV_TIMEOUT_OVER Field

EventTypeTV_TIMEOUT_OVER Field

Tv Timeout over (Ice Hockey)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TV_TIMEOUT_OVER = 1438

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TWENTY_M_RESTART Field

EventTypeTWENTY_M_RESTART Field

20m restart (used in Rugby)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TWENTY_M_RESTART = 1201

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TWENTYTWO_DROP_OUT Field

EventTypeTWENTYTWO_DROP_OUT Field

Twenty two drop out

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TWENTYTWO_DROP_OUT = 1151

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TWO_POINT_CONVERSION Field

EventTypeTWO_POINT_CONVERSION Field

Two point conversion

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TWO_POINT_CONVERSION = 1457

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.TWO_POINT_MISS_COUNT Field

EventTypeTWO_POINT_MISS_COUNT Field

Two point miss count (Basketball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType TWO_POINT_MISS_COUNT = 1600

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.UNDEFINED Field

EventTypeUNDEFINED Field

Unknown, check event id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType UNDEFINED = -1

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.UNSCHEDULED_BREAK Field

EventTypeUNSCHEDULED_BREAK Field

Unscheduled break

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType UNSCHEDULED_BREAK = 1139

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.USE_CHALLENGES_OFFICIAL_REVIEWS Field

EventTypeUSE_CHALLENGES_OFFICIAL_REVIEWS Field

Use challenges official reviews

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType USE_CHALLENGES_OFFICIAL_REVIEWS = 1657

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.value__ Field

EventTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.EventType.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.VIDEO_ASSISTANT_REFEREE Field

EventTypeVIDEO_ASSISTANT_REFEREE Field

The video assistant referee

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType VIDEO_ASSISTANT_REFEREE = 2064

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.VIDEO_ASSISTANT_REFEREE_OVER Field

EventTypeVIDEO_ASSISTANT_REFEREE_OVER Field

The video assistant referee over

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType VIDEO_ASSISTANT_REFEREE_OVER = 2065

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.VIDEO_REVIEW_OVER Field

EventTypeVIDEO_REVIEW_OVER Field

Video review over

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType VIDEO_REVIEW_OVER = 1459

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.VIDEO_REVIEW_START Field

EventTypeVIDEO_REVIEW_START Field

Video review start

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType VIDEO_REVIEW_START = 1458

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.VOLLEYBALL_SCORE_CHANGE Field

EventTypeVOLLEYBALL_SCORE_CHANGE Field

Volleyball score change

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType VOLLEYBALL_SCORE_CHANGE = 1046

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WARNING Field

EventTypeWARNING Field

Warning

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WARNING = 1505

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WEATHER_CONDITIONS Field

EventTypeWEATHER_CONDITIONS Field

Weather conditions

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WEATHER_CONDITIONS = 164

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WHICH_PLAYER_RECEIVES_FIRST_WITHIN_A_DOUBLES_TEAM Field

EventTypeWHICH_PLAYER_RECEIVES_FIRST_WITHIN_A_DOUBLES_TEAM Field

Which player receives first within a doubles team (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WHICH_PLAYER_RECEIVES_FIRST_WITHIN_A_DOUBLES_TEAM = 1125

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WHICH_PLAYER_SERVES_FIRST_WITHIN_A_DOUBLES_TEAM Field

EventTypeWHICH_PLAYER_SERVES_FIRST_WITHIN_A_DOUBLES_TEAM Field

Which player serves first within a doubles team (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WHICH_PLAYER_SERVES_FIRST_WITHIN_A_DOUBLES_TEAM = 1122

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WHICH_TEAM_SERVES_FIRST Field

EventTypeWHICH_TEAM_SERVES_FIRST Field

Which team serves first

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WHICH_TEAM_SERVES_FIRST = 1022

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WHICH_TEAM_STARTS_SERVING_ON_THE_LEFT_HAND_SIDE_OF_THE_UMPIRE Field

EventTypeWHICH_TEAM_STARTS_SERVING_ON_THE_LEFT_HAND_SIDE_OF_THE_UMPIRE Field

Which team starts serving on the left hand side of the umpire (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WHICH_TEAM_STARTS_SERVING_ON_THE_LEFT_HAND_SIDE_OF_THE_UMPIRE = 1128

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WHICH_TEAM_STARTS_WITH_POSSESSION Field

EventTypeWHICH_TEAM_STARTS_WITH_POSSESSION Field

Which team starts with possession at Ice Hockey

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WHICH_TEAM_STARTS_WITH_POSSESSION = 1012

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WHO_MADE_FIRST_SERVER_DECISION Field

EventTypeWHO_MADE_FIRST_SERVER_DECISION Field

Who made first server decision (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WHO_MADE_FIRST_SERVER_DECISION = 1121

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WHO_SERVES_FIRST_IN_TIE_BREAK_SET Field

EventTypeWHO_SERVES_FIRST_IN_TIE_BREAK_SET Field

Who serves first in tie break set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WHO_SERVES_FIRST_IN_TIE_BREAK_SET = 1058

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WHO_THROWS_THE_FIRST_PITCH Field

EventTypeWHO_THROWS_THE_FIRST_PITCH Field

Who throws the first pitch

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WHO_THROWS_THE_FIRST_PITCH = 1725

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WHO_WON_COIN_TOSS Field

EventTypeWHO_WON_COIN_TOSS Field

Who won coin toss (Tennis)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WHO_WON_COIN_TOSS = 1120

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WHO_WON_JUMP_BALL Field

EventTypeWHO_WON_JUMP_BALL Field

Who won jump ball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WHO_WON_JUMP_BALL = 1033

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WIND Field

EventTypeWIND Field

Wind

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WIND = 1153

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.WIND_ADVANTAGE Field

EventTypeWIND_ADVANTAGE Field

Wind advantage

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType WIND_ADVANTAGE = 1163

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.YELLOW_CARD Field

EventTypeYELLOW_CARD Field

Yellow card

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType YELLOW_CARD = 40

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


EventType.YELLOWRED_CARD Field

EventTypeYELLOWRED_CARD Field

Yellow and red card

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const EventType YELLOWRED_CARD = 45

Field Value

EventType
See Also

Reference

EventType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Format Class

Format
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutFormat

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Format

The Format type exposes the following members.

Constructors
 | Name | Description
Public method | Format | Initializes a new instance of the Format class
Top
Properties
 | Name | Description
Public property | Type | Format type
Public property | Value | Format value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Format Constructor

Initializes a new instance of the Format class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Format()
See Also

Reference

Format Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Format Properties

The Format type exposes the following members.

Properties
 | Name | Description
Public property | Type | Format type
Public property | Value | Format value
Top
See Also

Reference

Format Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Format.Type Property

FormatType Property

Format type

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public FormatType Type { get; }

Property Value

FormatType
See Also

Reference

Format Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Format.Value Property

FormatValue Property

Format value

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Value { get; }

Property Value

Int32
See Also

Reference

Format Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Format Methods

The Format type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Format Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Format.ToString Method

FormatToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Format Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType Class

Format type
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutFormatType

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class FormatType : Enum

The FormatType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | BATTINGPOWERPLAYOVERS | Batting powerplay overs
 | CONVERSIONVALUE | Conversion value
 | DAYS | Days
 | DROPGOALVALUE | Drop goal value
 | EXTRAPOINTYARDLINE | Extra point yard line
 | LENGTHOVERTIMEPERIODS | Length overtime periods
 | LENGTHSUDDENDEATH | Length sudden death
 | LIMITEDOVERS | Limited overs
 | MANDATORYPOWERPLAYOVERS | Mandatory powerplay overs
 | MAPS | Maps
 | MAXOVERSPERBOWLER | Max overs per bowler
 | NOBALLPENALTYVALUE | Penalty value of no ball
 | NUMBEROFPERIODS | Number of periods
 | NUMBEROVERTIMEPERIODS | Number overtime time periods
 | OVERS | Overs
 | OVERTIMEROUNDS | Overtime rounds
 | PENALTYSHOOTOUT | Penalty shootout
 | PENALTYTRYVALUE | Penalty try value
 | PENALTYVALUE | Penalty value
 | PERIODLENGTH | Period length
 | POWERPLAY1OVERS | Powerplay 1 overs
 | POWERPLAY2OVERS | Powerplay 2 overs
 | POWERPLAY3OVERS | Powerplay 3 overs
 | REGULARINNINGS | Number of regular innings in MLB
 | REVIEWS | Reviews
 | ROUNDS | Rounds
 | RULESET | Rule set
 | TIEBREAKERMETHOD | How a tied match is resolved, if at all
 | TRYVALUE | Try value
 | TWOPOINTCONVERSIONYARDLINE | Two point conversion yard line
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType Methods

The FormatType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType Fields

The FormatType type exposes the following members.

Fields
 | Name | Description
 | BATTINGPOWERPLAYOVERS | Batting powerplay overs
 | CONVERSIONVALUE | Conversion value
 | DAYS | Days
 | DROPGOALVALUE | Drop goal value
 | EXTRAPOINTYARDLINE | Extra point yard line
 | LENGTHOVERTIMEPERIODS | Length overtime periods
 | LENGTHSUDDENDEATH | Length sudden death
 | LIMITEDOVERS | Limited overs
 | MANDATORYPOWERPLAYOVERS | Mandatory powerplay overs
 | MAPS | Maps
 | MAXOVERSPERBOWLER | Max overs per bowler
 | NOBALLPENALTYVALUE | Penalty value of no ball
 | NUMBEROFPERIODS | Number of periods
 | NUMBEROVERTIMEPERIODS | Number overtime time periods
 | OVERS | Overs
 | OVERTIMEROUNDS | Overtime rounds
 | PENALTYSHOOTOUT | Penalty shootout
 | PENALTYTRYVALUE | Penalty try value
 | PENALTYVALUE | Penalty value
 | PERIODLENGTH | Period length
 | POWERPLAY1OVERS | Powerplay 1 overs
 | POWERPLAY2OVERS | Powerplay 2 overs
 | POWERPLAY3OVERS | Powerplay 3 overs
 | REGULARINNINGS | Number of regular innings in MLB
 | REVIEWS | Reviews
 | ROUNDS | Rounds
 | RULESET | Rule set
 | TIEBREAKERMETHOD | How a tied match is resolved, if at all
 | TRYVALUE | Try value
 | TWOPOINTCONVERSIONYARDLINE | Two point conversion yard line
Public field | value__ |
Top
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.BATTINGPOWERPLAYOVERS Field

FormatTypeBATTINGPOWERPLAYOVERS Field

Batting powerplay overs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType BATTINGPOWERPLAYOVERS = 4

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.CONVERSIONVALUE Field

FormatTypeCONVERSIONVALUE Field

Conversion value

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType CONVERSIONVALUE = 16

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.DAYS Field

FormatTypeDAYS Field

Days

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType DAYS = 2

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.DROPGOALVALUE Field

FormatTypeDROPGOALVALUE Field

Drop goal value

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType DROPGOALVALUE = 18

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.EXTRAPOINTYARDLINE Field

FormatTypeEXTRAPOINTYARDLINE Field

Extra point yard line

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType EXTRAPOINTYARDLINE = 26

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.LENGTHOVERTIMEPERIODS Field

FormatTypeLENGTHOVERTIMEPERIODS Field

Length overtime periods

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType LENGTHOVERTIMEPERIODS = 21

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.LENGTHSUDDENDEATH Field

FormatTypeLENGTHSUDDENDEATH Field

Length sudden death

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType LENGTHSUDDENDEATH = 22

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.LIMITEDOVERS Field

FormatTypeLIMITEDOVERS Field

Limited overs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType LIMITEDOVERS = 0

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.MANDATORYPOWERPLAYOVERS Field

FormatTypeMANDATORYPOWERPLAYOVERS Field

Mandatory powerplay overs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType MANDATORYPOWERPLAYOVERS = 3

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.MAPS Field

FormatTypeMAPS Field

Maps

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType MAPS = 10

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.MAXOVERSPERBOWLER Field

FormatTypeMAXOVERSPERBOWLER Field

Max overs per bowler

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType MAXOVERSPERBOWLER = 8

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.NOBALLPENALTYVALUE Field

FormatTypeNOBALLPENALTYVALUE Field

Penalty value of no ball

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType NOBALLPENALTYVALUE = 27

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.NUMBEROFPERIODS Field

FormatTypeNUMBEROFPERIODS Field

Number of periods

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType NUMBEROFPERIODS = 13

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.NUMBEROVERTIMEPERIODS Field

FormatTypeNUMBEROVERTIMEPERIODS Field

Number overtime time periods

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType NUMBEROVERTIMEPERIODS = 20

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.OVERS Field

FormatTypeOVERS Field

Overs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType OVERS = 1

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.OVERTIMEROUNDS Field

FormatTypeOVERTIMEROUNDS Field

Overtime rounds

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType OVERTIMEROUNDS = 12

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.PENALTYSHOOTOUT Field

FormatTypePENALTYSHOOTOUT Field

Penalty shootout

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType PENALTYSHOOTOUT = 23

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.PENALTYTRYVALUE Field

FormatTypePENALTYTRYVALUE Field

Penalty try value

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType PENALTYTRYVALUE = 19

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.PENALTYVALUE Field

FormatTypePENALTYVALUE Field

Penalty value

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType PENALTYVALUE = 17

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.PERIODLENGTH Field

FormatTypePERIODLENGTH Field

Period length

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType PERIODLENGTH = 14

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.POWERPLAY1OVERS Field

FormatTypePOWERPLAY1OVERS Field

Powerplay 1 overs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType POWERPLAY1OVERS = 5

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.POWERPLAY2OVERS Field

FormatTypePOWERPLAY2OVERS Field

Powerplay 2 overs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType POWERPLAY2OVERS = 6

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.POWERPLAY3OVERS Field

FormatTypePOWERPLAY3OVERS Field

Powerplay 3 overs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType POWERPLAY3OVERS = 7

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.REGULARINNINGS Field

FormatTypeREGULARINNINGS Field

Number of regular innings in MLB

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType REGULARINNINGS = 29

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.REVIEWS Field

FormatTypeREVIEWS Field

Reviews

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType REVIEWS = 9

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.ROUNDS Field

FormatTypeROUNDS Field

Rounds

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType ROUNDS = 11

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.RULESET Field

FormatTypeRULESET Field

Rule set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType RULESET = 24

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.TIEBREAKERMETHOD Field

FormatTypeTIEBREAKERMETHOD Field

How a tied match is resolved, if at all

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType TIEBREAKERMETHOD = 28

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.TRYVALUE Field

FormatTypeTRYVALUE Field

Try value

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType TRYVALUE = 15

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.TWOPOINTCONVERSIONYARDLINE Field

FormatTypeTWOPOINTCONVERSIONYARDLINE Field

Two point conversion yard line

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FormatType TWOPOINTCONVERSIONYARDLINE = 25

Field Value

FormatType
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


FormatType.value__ Field

FormatTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.FormatType.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

FormatType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Goals Class

Goals
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutGoals

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Goals

The Goals type exposes the following members.

Constructors
 | Name | Description
Public method | Goals | Initializes a new instance of the Goals class
Top
Properties
 | Name | Description
Public property | T1 | Gets the T1
Public property | T2 | Gets the T2
Public property | Type | Gets the type (aussie_rules_score_type)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Goals Constructor

Initializes a new instance of the Goals class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Goals()
See Also

Reference

Goals Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Goals Properties

The Goals type exposes the following members.

Properties
 | Name | Description
Public property | T1 | Gets the T1
Public property | T2 | Gets the T2
Public property | Type | Gets the type (aussie_rules_score_type)
Top
See Also

Reference

Goals Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Goals.T1 Property

GoalsT1 Property

Gets the T1

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int T1 { get; }

Property Value

Int32
The T1
See Also

Reference

Goals Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Goals.T2 Property

GoalsT2 Property

Gets the T2

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int T2 { get; }

Property Value

Int32
The T2
See Also

Reference

Goals Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Goals.Type Property

GoalsType Property

Gets the type (aussie_rules_score_type)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Type { get; }

Property Value

String
The type
See Also

Reference

Goals Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Goals Methods

The Goals type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object (Overrides ObjectToString)
Top
See Also

Reference

Goals Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Goals.ToString Method

GoalsToString Method

Returns a string that represents the current object

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object
Remarks
Can be used for diagnostics purposes
See Also

Reference

Goals Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Gold Class

gold
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutGold

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Gold

The Gold type exposes the following members.

Constructors
 | Name | Description
Public method | Gold | Initializes a new instance of the Gold class
Top
Properties
 | Name | Description
Public property | MapNr | mapnr
Public property | T1 | t1
Public property | T2 | t2
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Gold Constructor

Initializes a new instance of the Gold class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Gold()
See Also

Reference

Gold Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Gold Properties

The Gold type exposes the following members.

Properties
 | Name | Description
Public property | MapNr | mapnr
Public property | T1 | t1
Public property | T2 | t2
Top
See Also

Reference

Gold Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Gold.MapNr Property

GoldMapNr Property

mapnr

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int MapNr { get; }

Property Value

Int32
See Also

Reference

Gold Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Gold.T1 Property

GoldT1 Property

t1

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int T1 { get; }

Property Value

Int32
See Also

Reference

Gold Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Gold.T2 Property

GoldT2 Property

t2

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int T2 { get; }

Property Value

Int32
See Also

Reference

Gold Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Gold Methods

The Gold type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Gold Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Gold.ToString Method

GoldToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Gold Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


IceConditions Class

Ice conditions
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutIceConditions

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class IceConditions : Enum

The IceConditions type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | GOOD |
 | MEDIUM |
 | POOR |
 | UNDEFINED |
 | UNKNOWN |
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


IceConditions Methods

The IceConditions type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

IceConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


IceConditions Fields

The IceConditions type exposes the following members.

Fields
 | Name | Description
 | GOOD |
 | MEDIUM |
 | POOR |
 | UNDEFINED |
 | UNKNOWN |
Public field | value__ |
Top
See Also

Reference

IceConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


IceConditions.GOOD Field

IceConditionsGOOD Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.IceConditions.GOOD"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const IceConditions GOOD = 1

Field Value

IceConditions
See Also

Reference

IceConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


IceConditions.MEDIUM Field

IceConditionsMEDIUM Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.IceConditions.MEDIUM"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const IceConditions MEDIUM = 2

Field Value

IceConditions
See Also

Reference

IceConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


IceConditions.POOR Field

IceConditionsPOOR Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.IceConditions.POOR"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const IceConditions POOR = 3

Field Value

IceConditions
See Also

Reference

IceConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


IceConditions.UNDEFINED Field

IceConditionsUNDEFINED Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.IceConditions.UNDEFINED"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const IceConditions UNDEFINED = -1

Field Value

IceConditions
See Also

Reference

IceConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


IceConditions.UNKNOWN Field

IceConditionsUNKNOWN Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.IceConditions.UNKNOWN"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const IceConditions UNKNOWN = 0

Field Value

IceConditions
See Also

Reference

IceConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


IceConditions.value__ Field

IceConditionsvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.IceConditions.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

IceConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout Interface

Live scout client interface.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ILiveScout : ILiveFeeds,
    IStartable

The ILiveScout type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from ILiveFeeds)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from ILiveFeeds)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from ILiveFeeds)
Public property | ServerTime | Get approximate server time. (Inherited from ILiveFeeds)
Public property | SubscribedEvents | All event ids we are currently subscribed to. (Inherited from ILiveFeeds)
Top
Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface. (Inherited from ILiveFeeds)
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup. (Inherited from ILiveFeeds)
Public method | GetMatchList | Request a list of available scout matches for a given time frame. By default only matches you have access to will be sent. You can also request all available matches by setting the include_avail. If this is done the reply will also include matches that are open for booking.
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events. (Inherited from ILiveFeeds)
Public method | SubscribeTest | Request a full feed for the match, and then update messages will follow in the same pace as they were sent out live.
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent. (Inherited from ILiveFeeds)
Top
Events
Name | Description
Public event | OnClosed | Signals that the underlaying connection has been closed (disconnect)
Public event OnFeedError Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
(Inherited from ILiveFeeds)
Public event | OnLineups | Player lineups for both teams were received.
Public event | OnMatchBookingReply | Reply sent when a client books a match. If match booking failed for some reason (match already bought, match finished etc.), the reply will contain additional explanation.
Public event | OnMatchData | Occurs when [on match data].
Public event | OnMatchList | Signals that a list of matches in the time frame requested by the client has been received.
Public event | OnMatchListUpdate | Signals that an unsolicited list of matches has been received.
Public event | OnMatchStop | Reply sent after client unsubscribed from a match. It could also be sent if match subscription failed for any reason (e.g. too many match subscriptions).
Public event OnMatchUpdate

Signals that a match update message was received. There are three types of match information messages: full match feed, delta match feed and delta update feed (see MatchHeader.TypeOfFeed). All three can contain statistical information as well as individual events (an event being a goal, card, etc.).

When a client application subscribes to a match, it will receive a full match update immediately after (given the subscription was successful). This message will contain all data for the match. Different event types are offered for different sports. Note that new event types will be added in the future.

After a full match update is received, most updates will be sent as delta updates. In these messages only the new data is sent, if a yellow card is given only this event will be sent. In addition summary data will be sent for the event type in question, i.e. the total number of yellow cards for the home/away team for the match.

If an existing event is changed, a delta update is sent for this event. E.g. a yellow card event is entered, and 1 minute later the event is updated by including which player got the card. Client must consider this as an update to an existing event, and not a new event (based on Event Id property).

Public event | OnMatchUpdateDelta | Delta match update event. See OnMatchUpdate for more info.
Public event | OnMatchUpdateDeltaUpdate | Delta update match update event. See OnMatchUpdate for more info.
Public event | OnMatchUpdateFull | Full match update event. See OnMatchUpdate for more info.
Public event | OnOpened | Signals that the underlaying connection has been opened (connect)
Public event | OnScoutInfo | Signals some basic information about the match. Sent out when a client subscribes to a match.
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout Properties

The ILiveScout type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from ILiveFeeds)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from ILiveFeeds)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from ILiveFeeds)
Public property | ServerTime | Get approximate server time. (Inherited from ILiveFeeds)
Public property | SubscribedEvents | All event ids we are currently subscribed to. (Inherited from ILiveFeeds)
Top
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout Methods

The ILiveScout type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | Book the specified events. Booked events cannot be cancelled through this interface. (Inherited from ILiveFeeds)
Public method | ClearState | Clears complete state for this provider, that can otherwise be used in case of feed error recovery which can occur after every feed server reconnect or at initial SDK startup. (Inherited from ILiveFeeds)
Public method | GetMatchList | Request a list of available scout matches for a given time frame. By default only matches you have access to will be sent. You can also request all available matches by setting the include_avail. If this is done the reply will also include matches that are open for booking.
Public method | Start | Start component. (Inherited from IStartable)
Public method | Stop | Stop / shutdown component. (Inherited from IStartable)
Public method | Subscribe | Subscribe to specified events. (Inherited from ILiveFeeds)
Public method | SubscribeTest | Request a full feed for the match, and then update messages will follow in the same pace as they were sent out live.
Public method | Unsubscribe | Unsubscribe from the specified events. After this no more events associated with these event ids will be sent. (Inherited from ILiveFeeds)
Top
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.GetMatchList Method

ILiveScoutGetMatchList Method

Request a list of available scout matches for a given time frame. By default only matches you have access to will be sent. You can also request all available matches by setting the include_avail. If this is done the reply will also include matches that are open for booking.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void GetMatchList(
    int hours_back,
    int hours_fwd,
    bool include_avail = false,
    int[] sportIds = null,
    int[] matchIds = null
)

Parameters

hours_back Int32
Start of time frame
hours_fwd Int32
End of time frame
include_avail Boolean (Optional)
Whether to also include all available matches for booking
sportIds Int32 (Optional)
Filter by sports
matchIds Int32 (Optional)
Filter by match ids (Not implemented yet on LDS side !!)
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.SubscribeTest Method

ILiveScoutSubscribeTest Method

Request a full feed for the match, and then update messages will follow in the same pace as they were sent out live.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
void SubscribeTest(
    long match_id,
    int? message_delay = null,
    int? start_message = null
)

Parameters

match_id Int64
Match id.
message_delay Nullable Int32 (Optional)
Specifies how many milliseconds to wait in between sending out each message.
start_message Nullable Int32 (Optional)
Specifies which message to start replay on (how far into the match). If startmessage is greater than or equal to the number of messages for the match, a full feed for the finished match is sent out, and no more messages will follow after this.
Remarks
This should only be used on the test server.
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout Events

The ILiveScout type exposes the following members.

Events
Name | Description
Public event | OnClosed | Signals that the underlaying connection has been closed (disconnect)
Public event OnFeedError Signals that a feed error has occurred (e.g. we got disconnected from the feed server, XML message parsing error occurred).
(Inherited from ILiveFeeds)
Public event | OnLineups | Player lineups for both teams were received.
Public event | OnMatchBookingReply | Reply sent when a client books a match. If match booking failed for some reason (match already bought, match finished etc.), the reply will contain additional explanation.
Public event | OnMatchData | Occurs when [on match data].
Public event | OnMatchList | Signals that a list of matches in the time frame requested by the client has been received.
Public event | OnMatchListUpdate | Signals that an unsolicited list of matches has been received.
Public event | OnMatchStop | Reply sent after client unsubscribed from a match. It could also be sent if match subscription failed for any reason (e.g. too many match subscriptions).
Public event OnMatchUpdate

Signals that a match update message was received. There are three types of match information messages: full match feed, delta match feed and delta update feed (see MatchHeader.TypeOfFeed). All three can contain statistical information as well as individual events (an event being a goal, card, etc.).

When a client application subscribes to a match, it will receive a full match update immediately after (given the subscription was successful). This message will contain all data for the match. Different event types are offered for different sports. Note that new event types will be added in the future.

After a full match update is received, most updates will be sent as delta updates. In these messages only the new data is sent, if a yellow card is given only this event will be sent. In addition summary data will be sent for the event type in question, i.e. the total number of yellow cards for the home/away team for the match.

If an existing event is changed, a delta update is sent for this event. E.g. a yellow card event is entered, and 1 minute later the event is updated by including which player got the card. Client must consider this as an update to an existing event, and not a new event (based on Event Id property).

Public event | OnMatchUpdateDelta | Delta match update event. See OnMatchUpdate for more info.
Public event | OnMatchUpdateDeltaUpdate | Delta update match update event. See OnMatchUpdate for more info.
Public event | OnMatchUpdateFull | Full match update event. See OnMatchUpdate for more info.
Public event | OnOpened | Signals that the underlaying connection has been opened (connect)
Public event | OnScoutInfo | Signals some basic information about the match. Sent out when a client subscribes to a match.
Top
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnClosed Event

ILiveScoutOnClosed Event

Signals that the underlaying connection has been closed (disconnect)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<ConnectionChangeEventArgs> OnClosed

Value

EventHandler ConnectionChangeEventArgs
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnLineups Event

ILiveScoutOnLineups Event

Player lineups for both teams were received.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<LineupsEventArgs> OnLineups

Value

EventHandler LineupsEventArgs
Remarks
The event is dispatched immediately after subscribing to a match and every time the lineup changes. XML configuration option "Send lineups for matches where this is available" needs to be activated (currently works just for deep coverage soccer matches).
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnMatchBookingReply Event

ILiveScoutOnMatchBookingReply Event

Reply sent when a client books a match. If match booking failed for some reason (match already bought, match finished etc.), the reply will contain additional explanation.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MatchBookingReplyEventArgs> OnMatchBookingReply

Value

EventHandler MatchBookingReplyEventArgs
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnMatchData Event

ILiveScoutOnMatchData Event

Occurs when [on match data].

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MatchDataEventArgs> OnMatchData

Value

EventHandler MatchDataEventArgs
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnMatchList Event

ILiveScoutOnMatchList Event

Signals that a list of matches in the time frame requested by the client has been received.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MatchListEventArgs> OnMatchList

Value

EventHandler MatchListEventArgs
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnMatchListUpdate Event

ILiveScoutOnMatchListUpdate Event

Signals that an unsolicited list of matches has been received.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MatchListEventArgs> OnMatchListUpdate

Value

EventHandler MatchListEventArgs
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnMatchStop Event

ILiveScoutOnMatchStop Event

Reply sent after client unsubscribed from a match. It could also be sent if match subscription failed for any reason (e.g. too many match subscriptions).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MatchStopEventArgs> OnMatchStop

Value

EventHandler MatchStopEventArgs
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnMatchUpdate Event

ILiveScoutOnMatchUpdate Event

Signals that a match update message was received. There are three types of match information messages: full match feed, delta match feed and delta update feed (see MatchHeader.TypeOfFeed). All three can contain statistical information as well as individual events (an event being a goal, card, etc.).

When a client application subscribes to a match, it will receive a full match update immediately after (given the subscription was successful). This message will contain all data for the match. Different event types are offered for different sports. Note that new event types will be added in the future.

After a full match update is received, most updates will be sent as delta updates. In these messages only the new data is sent, if a yellow card is given only this event will be sent. In addition summary data will be sent for the event type in question, i.e. the total number of yellow cards for the home/away team for the match.

If an existing event is changed, a delta update is sent for this event. E.g. a yellow card event is entered, and 1 minute later the event is updated by including which player got the card. Client must consider this as an update to an existing event, and not a new event (based on Event Id property).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MatchUpdateEventArgs> OnMatchUpdate

Value

EventHandler MatchUpdateEventArgs
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnMatchUpdateDelta Event

ILiveScoutOnMatchUpdateDelta Event

Delta match update event. See OnMatchUpdate for more info.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MatchUpdateEventArgs> OnMatchUpdateDelta

Value

EventHandler MatchUpdateEventArgs
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnMatchUpdateDeltaUpdate Event

ILiveScoutOnMatchUpdateDeltaUpdate Event

Delta update match update event. See OnMatchUpdate for more info.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MatchUpdateEventArgs> OnMatchUpdateDeltaUpdate

Value

EventHandler MatchUpdateEventArgs
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnMatchUpdateFull Event

ILiveScoutOnMatchUpdateFull Event

Full match update event. See OnMatchUpdate for more info.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<MatchUpdateEventArgs> OnMatchUpdateFull

Value

EventHandler MatchUpdateEventArgs
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnOpened Event

ILiveScoutOnOpened Event

Signals that the underlaying connection has been opened (connect)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<ConnectionChangeEventArgs> OnOpened

Value

EventHandler ConnectionChangeEventArgs
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


ILiveScout.OnScoutInfo Event

ILiveScoutOnScoutInfo Event

Signals some basic information about the match. Sent out when a client subscribes to a match.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
event EventHandler<ScoutInfoEventArgs> OnScoutInfo

Value

EventHandler ScoutInfoEventArgs
See Also

Reference

ILiveScout Interface
Sportradar.SDK.FeedProviders.LiveScout Namespace


Inning Class

Inning half
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutInning

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class Inning : Enum

The Inning type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | B | Bottom
 | T | Top
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Inning Methods

The Inning type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

Inning Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Inning Fields

The Inning type exposes the following members.

Fields
 | Name | Description
 | B | Bottom
 | T | Top
Public field | value__ |
Top
See Also

Reference

Inning Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Inning.B Field

InningB Field

Bottom

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Inning B = 1

Field Value

Inning
See Also

Reference

Inning Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Inning.T Field

InningT Field

Top

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Inning T = 0

Field Value

Inning
See Also

Reference

Inning Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Inning.value__ Field

Inningvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.Inning.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

Inning Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Innings Class

Innings
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutInnings

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Innings

The Innings type exposes the following members.

Constructors
 | Name | Description
Public method | Innings | Initializes a new instance of the Innings class
Top
Properties
 | Name | Description
Public property | Dismissals | Dismissals
Public property | Runs | Runs
Public property | StatusId | Status id
Public property | StatusName | Status Name
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Innings Constructor

Initializes a new instance of the Innings class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Innings()
See Also

Reference

Innings Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Innings Properties

The Innings type exposes the following members.

Properties
 | Name | Description
Public property | Dismissals | Dismissals
Public property | Runs | Runs
Public property | StatusId | Status id
Public property | StatusName | Status Name
Top
See Also

Reference

Innings Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Innings.Dismissals Property

InningsDismissals Property

Dismissals

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Dismissals { get; }

Property Value

Int32
See Also

Reference

Innings Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Innings.Runs Property

InningsRuns Property

Runs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Runs { get; }

Property Value

Int32
See Also

Reference

Innings Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Innings.StatusId Property

InningsStatusId Property

Status id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int StatusId { get; }

Property Value

Int32
See Also

Reference

Innings Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Innings.StatusName Property

InningsStatusName Property

Status Name

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string StatusName { get; }

Property Value

String
See Also

Reference

Innings Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Innings Methods

The Innings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Innings Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Innings.ToString Method

InningsToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Innings Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


InningScore Class

Inning score
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutInningScore

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class InningScore

The InningScore type exposes the following members.

Constructors
 | Name | Description
Public method | InningScore | Initializes a new instance of the InningScore class
Top
Properties
 | Name | Description
Public property | Inning | Inning
Public property | Score | Inning
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


InningScore Constructor

Initializes a new instance of the InningScore class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public InningScore()
See Also

Reference

InningScore Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


InningScore Properties

The InningScore type exposes the following members.

Properties
 | Name | Description
Public property | Inning | Inning
Public property | Score | Inning
Top
See Also

Reference

InningScore Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


InningScore.Inning Property

InningScoreInning Property

Inning

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Inning { get; }

Property Value

Int32
See Also

Reference

InningScore Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


InningScore.Score Property

InningScoreScore Property

Inning

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> Score { get; }

Property Value

HomeAway Int32
See Also

Reference

InningScore Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


InningScore Methods

The InningScore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

InningScore Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


InningScore.ToString Method

InningScoreToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

InningScore Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey Class

Jersey
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutJersey

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Jersey

The Jersey type exposes the following members.

Constructors
 | Name | Description
Public method | Jersey | Initializes a new instance of the Jersey class
Top
Properties
 | Name | Description
Public property | Base | Gets the base.
Public property | HorizontalStripes | Gets the horizontal stripes.
Public property | JerseyType | Gets the type of the jersey.
Public property | Number | Gets the number.
Public property | Outline | Gets the outline.
Public property | ShirtType | Gets the type of the shirt.
Public property | Side | Gets the side.
Public property | Sleeve | Gets the sleeve.
Public property | Split | Gets the split.
Public property | Squares | Gets the squares.
Public property | VerticalStripes | Gets the vertical stripes.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey Constructor

Initializes a new instance of the Jersey class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Jersey()
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey Properties

The Jersey type exposes the following members.

Properties
 | Name | Description
Public property | Base | Gets the base.
Public property | HorizontalStripes | Gets the horizontal stripes.
Public property | JerseyType | Gets the type of the jersey.
Public property | Number | Gets the number.
Public property | Outline | Gets the outline.
Public property | ShirtType | Gets the type of the shirt.
Public property | Side | Gets the side.
Public property | Sleeve | Gets the sleeve.
Public property | Split | Gets the split.
Public property | Squares | Gets the squares.
Public property | VerticalStripes | Gets the vertical stripes.
Top
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey.Base Property

JerseyBase Property

Gets the base.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Base { get; }

Property Value

String
The base.
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey.HorizontalStripes Property

JerseyHorizontalStripes Property

Gets the horizontal stripes.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HorizontalStripes { get; }

Property Value

String
The horizontal stripes.
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey.JerseyType Property

JerseyJerseyType Property

Gets the type of the jersey.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int JerseyType { get; }

Property Value

Int32
The type of the jersey.
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey.Number Property

JerseyNumber Property

Gets the number.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Number { get; }

Property Value

String
The number.
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey.Outline Property

JerseyOutline Property

Gets the outline.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Outline { get; }

Property Value

String
The outline.
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey.ShirtType Property

JerseyShirtType Property

Gets the type of the shirt.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ShirtType { get; }

Property Value

String
The type of the shirt.
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey.Side Property

JerseySide Property

Gets the side.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Side { get; }

Property Value

Int32
The side.
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey.Sleeve Property

JerseySleeve Property

Gets the sleeve.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Sleeve { get; }

Property Value

String
The sleeve.
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey.Split Property

JerseySplit Property

Gets the split.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Split { get; }

Property Value

String
The split.
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey.Squares Property

JerseySquares Property

Gets the squares.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Squares { get; }

Property Value

String
The squares.
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey.VerticalStripes Property

JerseyVerticalStripes Property

Gets the vertical stripes.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string VerticalStripes { get; }

Property Value

String
The vertical stripes.
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey Methods

The Jersey type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Jersey.ToString Method

JerseyToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Jersey Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Lineups Class

The current lineup.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase
Sportradar.SDK.FeedProviders.LiveScoutLineups

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Lineups : ScoutEntityBase

The Lineups type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Managers | Team managers
Public property | MatchId | Match ID.
Public property | Players | List of players in lineup
Public property | TeamOfficals | Team officals
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Lineups Properties

The Lineups type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Managers | Team managers
Public property | MatchId | Match ID.
Public property | Players | List of players in lineup
Public property | TeamOfficals | Team officals
Top
See Also

Reference

Lineups Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Lineups.Managers Property

LineupsManagers Property

Team managers

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<Manager> Managers { get; }

Property Value

List Manager
See Also

Reference

Lineups Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Lineups.MatchId Property

LineupsMatchId Property

Match ID.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long MatchId { get; }

Property Value

Int64
See Also

Reference

Lineups Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Lineups.Players Property

LineupsPlayers Property

List of players in lineup

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<Player> Players { get; }

Property Value

List Player
See Also

Reference

Lineups Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Lineups.TeamOfficals Property

LineupsTeamOfficals Property

Team officals

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<TeamOffical> TeamOfficals { get; }

Property Value

List TeamOffical
See Also

Reference

Lineups Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Lineups Methods

The Lineups type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

Lineups Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Lineups.ToString Method

LineupsToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Lineups Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


LineupsEventArgs Class

Event arguments passed with OnLineups.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveScoutLineupsEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class LineupsEventArgs : EventArgs

The LineupsEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LineupsEventArgs | Initializes a new instance of the LineupsEventArgs class
Top
Properties
 | Name | Description
Public property | Lineups | The lineups
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


LineupsEventArgs Constructor

Initializes a new instance of the LineupsEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LineupsEventArgs()
See Also

Reference

LineupsEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


LineupsEventArgs Properties

The LineupsEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Lineups | The lineups
Top
See Also

Reference

LineupsEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


LineupsEventArgs.Lineups Property

LineupsEventArgsLineups Property

The lineups

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Lineups Lineups { get; }

Property Value

Lineups
See Also

Reference

LineupsEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


LineupsEventArgs Methods

The LineupsEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LineupsEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Manager Class

Team manager
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutManager

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Manager

The Manager type exposes the following members.

Constructors
 | Name | Description
Public method | Manager | Initializes a new instance of the Manager class
Top
Properties
 | Name | Description
Public property | Id | Manager id
Public property | Name | Manager name
Public property | Team | Home or Away team
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Manager Constructor

Initializes a new instance of the Manager class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Manager()
See Also

Reference

Manager Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Manager Properties

The Manager type exposes the following members.

Properties
 | Name | Description
Public property | Id | Manager id
Public property | Name | Manager name
Public property | Team | Home or Away team
Top
See Also

Reference

Manager Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Manager.Id Property

ManagerId Property

Manager id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

Manager Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Manager.Name Property

ManagerName Property

Manager name

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; }

Property Value

String
See Also

Reference

Manager Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Manager.Team Property

ManagerTeam Property

Home or Away team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team Team { get; }

Property Value

Team
See Also

Reference

Manager Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Manager Methods

The Manager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Manager Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Manager.ToString Method

ManagerToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Manager Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBetStatus Class

Bet status (whether market is open or closed)
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutMatchBetStatus

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class MatchBetStatus : Enum

The MatchBetStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | BETSTOP | Bet stop
 | NOT_STARTED | Not started
 | STARTED | Started
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBetStatus Methods

The MatchBetStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

MatchBetStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBetStatus Fields

The MatchBetStatus type exposes the following members.

Fields
 | Name | Description
 | BETSTOP | Bet stop
 | NOT_STARTED | Not started
 | STARTED | Started
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

MatchBetStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBetStatus.BETSTOP Field

MatchBetStatusBETSTOP Field

Bet stop

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const MatchBetStatus BETSTOP = 3

Field Value

MatchBetStatus
See Also

Reference

MatchBetStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBetStatus.NOT_STARTED Field

MatchBetStatusNOT_STARTED Field

Not started

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const MatchBetStatus NOT_STARTED = 1

Field Value

MatchBetStatus
See Also

Reference

MatchBetStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBetStatus.STARTED Field

MatchBetStatusSTARTED Field

Started

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const MatchBetStatus STARTED = 2

Field Value

MatchBetStatus
See Also

Reference

MatchBetStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBetStatus.UNDEFINED Field

MatchBetStatusUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const MatchBetStatus UNDEFINED = 0

Field Value

MatchBetStatus
See Also

Reference

MatchBetStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBetStatus.value__ Field

MatchBetStatusvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.MatchBetStatus.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

MatchBetStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBooking Class

Match booking reply. This reply is sent when a client books a match.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase
Sportradar.SDK.FeedProviders.LiveScoutMatchBooking

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchBooking : ScoutEntityBase

The MatchBooking type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | MatchId | The ID of the match booking reply is for.
Public property | Message | If the match booking fails for any reason (match already bought, match finished etc.), the message will contain an explanation.
Public property | Result | Result of match booking (either valid or invalid)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBooking Properties

The MatchBooking type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | MatchId | The ID of the match booking reply is for.
Public property | Message | If the match booking fails for any reason (match already bought, match finished etc.), the message will contain an explanation.
Public property | Result | Result of match booking (either valid or invalid)
Top
See Also

Reference

MatchBooking Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBooking.MatchId Property

MatchBookingMatchId Property

The ID of the match booking reply is for.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? MatchId { get; }

Property Value

Nullable Int64
See Also

Reference

MatchBooking Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBooking.Message Property

MatchBookingMessage Property

If the match booking fails for any reason (match already bought, match finished etc.), the message will contain an explanation.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Message { get; }

Property Value

String
See Also

Reference

MatchBooking Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBooking.Result Property

MatchBookingResult Property

Result of match booking (either valid or invalid)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public BookMatchResult Result { get; }

Property Value

BookMatchResult
See Also

Reference

MatchBooking Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBooking Methods

The MatchBooking type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

MatchBooking Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBooking.ToString Method

MatchBookingToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

MatchBooking Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBookingReplyEventArgs Class

Event arguments passed with OnMatchBookingReply.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveScoutMatchBookingReplyEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchBookingReplyEventArgs : EventArgs

The MatchBookingReplyEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MatchBookingReplyEventArgs | Initializes a new instance of the MatchBookingReplyEventArgs class
Top
Properties
 | Name | Description
Public property | MatchBooking | Match booking reply
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBookingReplyEventArgs Constructor

Initializes a new instance of the MatchBookingReplyEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchBookingReplyEventArgs()
See Also

Reference

MatchBookingReplyEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBookingReplyEventArgs Properties

The MatchBookingReplyEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MatchBooking | Match booking reply
Top
See Also

Reference

MatchBookingReplyEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBookingReplyEventArgs.MatchBooking Property

MatchBookingReplyEventArgsMatchBooking Property

Match booking reply

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchBooking MatchBooking { get; }

Property Value

MatchBooking
See Also

Reference

MatchBookingReplyEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchBookingReplyEventArgs Methods

The MatchBookingReplyEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MatchBookingReplyEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchData Class

Match time information during a game.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase
Sportradar.SDK.FeedProviders.LiveScoutMatchData

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchData : ScoutEntityBase

The MatchData type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | MatchId | Match id.
Public property | MatchTime | Match time.
Public property | RemainingTimeInPeriod | Specifies the remaining time in this period (when this applies).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchData Properties

The MatchData type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | MatchId | Match id.
Public property | MatchTime | Match time.
Public property | RemainingTimeInPeriod | Specifies the remaining time in this period (when this applies).
Top
See Also

Reference

MatchData Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchData.MatchId Property

MatchDataMatchId Property

Match id.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long MatchId { get; }

Property Value

Int64
See Also

Reference

MatchData Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchData.MatchTime Property

MatchDataMatchTime Property

Match time.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MatchTime { get; }

Property Value

String
See Also

Reference

MatchData Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchData.RemainingTimeInPeriod Property

MatchDataRemainingTimeInPeriod Property

Specifies the remaining time in this period (when this applies).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string RemainingTimeInPeriod { get; }

Property Value

String
See Also

Reference

MatchData Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchData Methods

The MatchData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

MatchData Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchData.ToString Method

MatchDataToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

MatchData Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchDataEventArgs Class

Event arguments passed with OnMatchData.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveScoutMatchDataEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchDataEventArgs : EventArgs

The MatchDataEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MatchDataEventArgs | Initializes a new instance of the MatchDataEventArgs class
Top
Properties
 | Name | Description
Public property | MatchData | Gets the match data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchDataEventArgs Constructor

Initializes a new instance of the MatchDataEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchDataEventArgs()
See Also

Reference

MatchDataEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchDataEventArgs Properties

The MatchDataEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MatchData | Gets the match data.
Top
See Also

Reference

MatchDataEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchDataEventArgs.MatchData Property

MatchDataEventArgsMatchData Property

Gets the match data.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchData MatchData { get; }

Property Value

MatchData
The match data.
See Also

Reference

MatchDataEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchDataEventArgs Methods

The MatchDataEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MatchDataEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader Class

Basic match information specifying match id, teams playing, bet status, feed type and other info.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutMatchHeader

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchHeader

The MatchHeader type exposes the following members.

Constructors
 | Name | Description
Public method | MatchHeader | Initializes a new instance of the MatchHeader class
Top
Properties
Name | Description
Public property | Active | Is match active?
Public property | AwayState
Public property | BetStatus | Whether market is open or closed.
Public property | ConnectionStatus | Whether scout is currently connected or not.
Public property | CoverageStatusId | Gets the coverage status identifier
Public property | CoveredFrom | Whether the match is covered from TV or venue.
Public property Device Device used for scouting
  • 1 – Hardphone/Asterisk
  • 2 – Softphone
  • 3 – Scout Admin
  • 4 – Scout Mobile App
  • 5 – External Data Feed
Public property | Distance | Distance between teams in km.
Public property | ExtMatchId
Public property ExtraInfo Integer specifying special information for the match. Can be one of the following:
  • 1 – Soccer match played 2*40 minutes (+2*10 minutes extra time)
  • 2 – Tennis no advantage rule, super tie break to 10 points
  • 3 – Tennis no advantage rule, super tie break to 7 points
  • 4 – Tennis no advantage rule, no super tie break
  • 5 – Tennis advantage rule, super tie break to 10 points
  • 6 – Tennis advantage rule, super tie break to 7 points
  • 7 – Basketball 12 minute periods
  • 8 – Volleyball best of 3 sets
  • 9 - Soccer match played 2*35 minutes (+2* 5 minutes extra time)
  • 10 - Soccer match played 2*30 minutes (+2* 5 minutes extra time)
  • 11 - Soccer match played 2*25 minutes (+2* 5 minutes extra time)
  • 12 - Ice hockey 10 minutes extra time periods
  • 13 - Ice hockey 20 minutes extra time periods
  • 14 – Futsal match played 2*25 minutes (+2* 5 minutes extra time)
Tennis advantage rule is when games must be won by at least 2 points (i.e. the use of deuce and advantage player X). In doubles matches advantage rule is usually not used. Super tie break in tennis is when the last set is a special tie break set.
Public property | FirstServe | Which player / team has first serve of match (tennis).
Public property | FirstServeGoldenSet | Which player / team has first serve of golden set
Public property | FirstServeTieBreak | Which player / team has first serve in tie-break (tennis).
Public property | HomeState
Public property | IsBooked | Whether the match is booked by the client.
Public property | IsCancelled
Public property | IsDeepCoverage | Whether this is a deep coverage match.
Public property | IsTimeRunning | Whether time/clock is running/active or not.
Public property | MatchId | Match Id.
Public property | MatchTime | Match time, mm:ss (e.g. 40:00 or 00:00).
Public property | NumberOfSets | Number of sets in match (tennis).
Public property | SetLimit | Number of points needed to win a set
Public property | Sex | Gender (sex) of the player / team.
Public property | SourceId | Customer match id. Included if set up and if available for this match. Contact Sportradar in order to include this in the scout feed
Public property | SportId | Gets the sport identifier
Public property | St1Id | Betradar super team id for team 1.
Public property | St2Id | Betradar super team id for team 2.
Public property | Start | Official match start time, as a timestamp in UTC.
Public property | STime
Public property | Team1 | Betradar team 1 (home team).
Public property | Team1Abbreviation | Team 1 abbreviation
Public property | Team1Division
Public property | Team1Natural | Betradar team 1 (home team) - natural
Public property | Team2 | Betradar team 2 (away team).
Public property | Team2Abbreviation | Team 2 abbreviation
Public property | Team2Division
Public property | Team2Natural | Betradar team 2 (away team) - natural
Public property | TeamMatch
Public property | TeamMatchId
Public property | TieBreakLastSet | Last set has tie break.
Public property | TypeOfFeed | Whether this is a full, delta or delta update message.
Public property | Var
Public property | VbpClassification
Public property | Venue
Public property | WonJumpBall | Which team won jump ball at the start of the match.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader Constructor

Initializes a new instance of the MatchHeader class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchHeader()
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader Properties

The MatchHeader type exposes the following members.

Properties
Name | Description
Public property | Active | Is match active?
Public property | AwayState
Public property | BetStatus | Whether market is open or closed.
Public property | ConnectionStatus | Whether scout is currently connected or not.
Public property | CoverageStatusId | Gets the coverage status identifier
Public property | CoveredFrom | Whether the match is covered from TV or venue.
Public property Device Device used for scouting
  • 1 – Hardphone/Asterisk
  • 2 – Softphone
  • 3 – Scout Admin
  • 4 – Scout Mobile App
  • 5 – External Data Feed
Public property | Distance | Distance between teams in km.
Public property | ExtMatchId
Public property ExtraInfo Integer specifying special information for the match. Can be one of the following:
  • 1 – Soccer match played 2*40 minutes (+2*10 minutes extra time)
  • 2 – Tennis no advantage rule, super tie break to 10 points
  • 3 – Tennis no advantage rule, super tie break to 7 points
  • 4 – Tennis no advantage rule, no super tie break
  • 5 – Tennis advantage rule, super tie break to 10 points
  • 6 – Tennis advantage rule, super tie break to 7 points
  • 7 – Basketball 12 minute periods
  • 8 – Volleyball best of 3 sets
  • 9 - Soccer match played 2*35 minutes (+2* 5 minutes extra time)
  • 10 - Soccer match played 2*30 minutes (+2* 5 minutes extra time)
  • 11 - Soccer match played 2*25 minutes (+2* 5 minutes extra time)
  • 12 - Ice hockey 10 minutes extra time periods
  • 13 - Ice hockey 20 minutes extra time periods
  • 14 – Futsal match played 2*25 minutes (+2* 5 minutes extra time)
Tennis advantage rule is when games must be won by at least 2 points (i.e. the use of deuce and advantage player X). In doubles matches advantage rule is usually not used. Super tie break in tennis is when the last set is a special tie break set.
Public property | FirstServe | Which player / team has first serve of match (tennis).
Public property | FirstServeGoldenSet | Which player / team has first serve of golden set
Public property | FirstServeTieBreak | Which player / team has first serve in tie-break (tennis).
Public property | HomeState
Public property | IsBooked | Whether the match is booked by the client.
Public property | IsCancelled
Public property | IsDeepCoverage | Whether this is a deep coverage match.
Public property | IsTimeRunning | Whether time/clock is running/active or not.
Public property | MatchId | Match Id.
Public property | MatchTime | Match time, mm:ss (e.g. 40:00 or 00:00).
Public property | NumberOfSets | Number of sets in match (tennis).
Public property | SetLimit | Number of points needed to win a set
Public property | Sex | Gender (sex) of the player / team.
Public property | SourceId | Customer match id. Included if set up and if available for this match. Contact Sportradar in order to include this in the scout feed
Public property | SportId | Gets the sport identifier
Public property | St1Id | Betradar super team id for team 1.
Public property | St2Id | Betradar super team id for team 2.
Public property | Start | Official match start time, as a timestamp in UTC.
Public property | STime
Public property | Team1 | Betradar team 1 (home team).
Public property | Team1Abbreviation | Team 1 abbreviation
Public property | Team1Division
Public property | Team1Natural | Betradar team 1 (home team) - natural
Public property | Team2 | Betradar team 2 (away team).
Public property | Team2Abbreviation | Team 2 abbreviation
Public property | Team2Division
Public property | Team2Natural | Betradar team 2 (away team) - natural
Public property | TeamMatch
Public property | TeamMatchId
Public property | TieBreakLastSet | Last set has tie break.
Public property | TypeOfFeed | Whether this is a full, delta or delta update message.
Public property | Var
Public property | VbpClassification
Public property | Venue
Public property | WonJumpBall | Which team won jump ball at the start of the match.
Top
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Active Property

MatchHeaderActive Property

Is match active?

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? Active { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.AwayState Property

MatchHeaderAwayState Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.MatchHeader.AwayState"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayState { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.BetStatus Property

MatchHeaderBetStatus Property

Whether market is open or closed.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchBetStatus? BetStatus { get; }

Property Value

Nullable MatchBetStatus
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.ConnectionStatus Property

MatchHeaderConnectionStatus Property

Whether scout is currently connected or not.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? ConnectionStatus { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.CoverageStatusId Property

MatchHeaderCoverageStatusId Property

Gets the coverage status identifier

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? CoverageStatusId { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.CoveredFrom Property

MatchHeaderCoveredFrom Property

Whether the match is covered from TV or venue.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Coverage? CoveredFrom { get; }

Property Value

Nullable Coverage
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Device Property

MatchHeaderDevice Property

Device used for scouting
  • 1 – Hardphone/Asterisk
  • 2 – Softphone
  • 3 – Scout Admin
  • 4 – Scout Mobile App
  • 5 – External Data Feed

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Device { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Distance Property

MatchHeaderDistance Property

Distance between teams in km.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Distance { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.ExtMatchId Property

MatchHeaderExtMatchId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.MatchHeader.ExtMatchId"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtMatchId { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.ExtraInfo Property

MatchHeaderExtraInfo Property

Integer specifying special information for the match. Can be one of the following:
  • 1 – Soccer match played 2*40 minutes (+2*10 minutes extra time)
  • 2 – Tennis no advantage rule, super tie break to 10 points
  • 3 – Tennis no advantage rule, super tie break to 7 points
  • 4 – Tennis no advantage rule, no super tie break
  • 5 – Tennis advantage rule, super tie break to 10 points
  • 6 – Tennis advantage rule, super tie break to 7 points
  • 7 – Basketball 12 minute periods
  • 8 – Volleyball best of 3 sets
  • 9 - Soccer match played 2*35 minutes (+2* 5 minutes extra time)
  • 10 - Soccer match played 2*30 minutes (+2* 5 minutes extra time)
  • 11 - Soccer match played 2*25 minutes (+2* 5 minutes extra time)
  • 12 - Ice hockey 10 minutes extra time periods
  • 13 - Ice hockey 20 minutes extra time periods
  • 14 – Futsal match played 2*25 minutes (+2* 5 minutes extra time)
Tennis advantage rule is when games must be won by at least 2 points (i.e. the use of deuce and advantage player X). In doubles matches advantage rule is usually not used. Super tie break in tennis is when the last set is a special tie break set.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? ExtraInfo { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.FirstServe Property

MatchHeaderFirstServe Property

Which player / team has first serve of match (tennis).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? FirstServe { get; }

Property Value

Nullable Team
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.FirstServeGoldenSet Property

MatchHeaderFirstServeGoldenSet Property

Which player / team has first serve of golden set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? FirstServeGoldenSet { get; }

Property Value

Nullable Team
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.FirstServeTieBreak Property

MatchHeaderFirstServeTieBreak Property

Which player / team has first serve in tie-break (tennis).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? FirstServeTieBreak { get; }

Property Value

Nullable Team
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.HomeState Property

MatchHeaderHomeState Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.MatchHeader.HomeState"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomeState { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.IsBooked Property

MatchHeaderIsBooked Property

Whether the match is booked by the client.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? IsBooked { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.IsCancelled Property

MatchHeaderIsCancelled Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.MatchHeader.IsCancelled"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? IsCancelled { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.IsDeepCoverage Property

MatchHeaderIsDeepCoverage Property

Whether this is a deep coverage match.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? IsDeepCoverage { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.IsTimeRunning Property

MatchHeaderIsTimeRunning Property

Whether time/clock is running/active or not.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? IsTimeRunning { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.MatchId Property

MatchHeaderMatchId Property

Match Id.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long MatchId { get; }

Property Value

Int64
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.MatchTime Property

MatchHeaderMatchTime Property

Match time, mm:ss (e.g. 40:00 or 00:00).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MatchTime { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.NumberOfSets Property

MatchHeaderNumberOfSets Property

Number of sets in match (tennis).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? NumberOfSets { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.SetLimit Property

MatchHeaderSetLimit Property

Number of points needed to win a set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? SetLimit { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Sex Property

MatchHeaderSex Property

Gender (sex) of the player / team.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Sex Sex { get; }

Property Value

Sex
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.SourceId Property

MatchHeaderSourceId Property

Customer match id. Included if set up and if available for this match. Contact Sportradar in order to include this in the scout feed

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SourceId { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.SportId Property

MatchHeaderSportId Property

Gets the sport identifier

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? SportId { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.St1Id Property

MatchHeaderSt1Id Property

Betradar super team id for team 1.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? St1Id { get; }

Property Value

Nullable Int32
Remarks
Super team is the parent a certain team derives from. New sponsor might completely change the name of the team no matter it is actually the same thing.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.St2Id Property

MatchHeaderSt2Id Property

Betradar super team id for team 2.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? St2Id { get; }

Property Value

Nullable Int32
Remarks
Super team is the parent a certain team derives from. New sponsor might completely change the name of the team no matter it is actually the same thing.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Start Property

MatchHeaderStart Property

Official match start time, as a timestamp in UTC.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime? Start { get; }

Property Value

Nullable DateTime
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.STime Property

MatchHeaderSTime Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.MatchHeader.STime"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? STime { get; }

Property Value

Nullable Int64
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Team1 Property

MatchHeaderTeam1 Property

Betradar team 1 (home team).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Team1 { get; }

Property Value

IdNameTuple
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Team1Abbreviation Property

MatchHeaderTeam1Abbreviation Property

Team 1 abbreviation

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Team1Abbreviation { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Team1Division Property

MatchHeaderTeam1Division Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.MatchHeader.Team1Division"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Team1Division { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Team1Natural Property

MatchHeaderTeam1Natural Property

Betradar team 1 (home team) - natural

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Team1Natural { get; }

Property Value

IdNameTuple
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Team2 Property

MatchHeaderTeam2 Property

Betradar team 2 (away team).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Team2 { get; }

Property Value

IdNameTuple
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Team2Abbreviation Property

MatchHeaderTeam2Abbreviation Property

Team 2 abbreviation

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Team2Abbreviation { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Team2Division Property

MatchHeaderTeam2Division Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.MatchHeader.Team2Division"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Team2Division { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Team2Natural Property

MatchHeaderTeam2Natural Property

Betradar team 2 (away team) - natural

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Team2Natural { get; }

Property Value

IdNameTuple
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.TeamMatch Property

MatchHeaderTeamMatch Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.MatchHeader.TeamMatch"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? TeamMatch { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.TeamMatchId Property

MatchHeaderTeamMatchId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.MatchHeader.TeamMatchId"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? TeamMatchId { get; }

Property Value

Nullable Int64
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.TieBreakLastSet Property

MatchHeaderTieBreakLastSet Property

Last set has tie break.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? TieBreakLastSet { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.TypeOfFeed Property

MatchHeaderTypeOfFeed Property

Whether this is a full, delta or delta update message.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoutFeedType? TypeOfFeed { get; }

Property Value

Nullable ScoutFeedType
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Var Property

MatchHeaderVar Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.MatchHeader.Var"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Var { get; }

Property Value

Nullable Int32
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.VbpClassification Property

MatchHeaderVbpClassification Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.MatchHeader.VbpClassification"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public VbpClassification VbpClassification { get; }

Property Value

VbpClassification
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.Venue Property

MatchHeaderVenue Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.MatchHeader.Venue"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Venue { get; }

Property Value

String
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.WonJumpBall Property

MatchHeaderWonJumpBall Property

Which team won jump ball at the start of the match.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? WonJumpBall { get; }

Property Value

Nullable Team
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader Methods

The MatchHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchHeader.ToString Method

MatchHeaderToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

MatchHeader Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchList Class

List of matches in the time frame requested by the client.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase
Sportradar.SDK.FeedProviders.LiveScoutMatchList
Sportradar.SDK.FeedProviders.LiveScoutMatchListUpdate

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchList : ScoutEntityBase

The MatchList type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Matches | List of matches in the time frame requested by the client.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchList Properties

The MatchList type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Matches | List of matches in the time frame requested by the client.
Top
See Also

Reference

MatchList Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchList.Matches Property

MatchListMatches Property

List of matches in the time frame requested by the client.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<MatchUpdate> Matches { get; }

Property Value

List MatchUpdate
See Also

Reference

MatchList Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchList Methods

The MatchList type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

MatchList Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchList.ToString Method

MatchListToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

MatchList Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchListEventArgs Class

Event arguments passed with OnMatchList.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveScoutMatchListEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchListEventArgs : EventArgs

The MatchListEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MatchListEventArgs | Initializes a new instance of the MatchListEventArgs class
Top
Properties
 | Name | Description
Public property | MatchList | List of match infos
Public property | WasRequested | Is the event a reply for something we asked for? true when yes; false else (when some schedule was changed and we get this)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchListEventArgs Constructor

Initializes a new instance of the MatchListEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchListEventArgs()
See Also

Reference

MatchListEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchListEventArgs Properties

The MatchListEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MatchList | List of match infos
Public property | WasRequested | Is the event a reply for something we asked for? true when yes; false else (when some schedule was changed and we get this)
Top
See Also

Reference

MatchListEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchListEventArgs.MatchList Property

MatchListEventArgsMatchList Property

List of match infos

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchUpdate[] MatchList { get; }

Property Value

MatchUpdate
See Also

Reference

MatchListEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchListEventArgs.WasRequested Property

MatchListEventArgsWasRequested Property

Is the event a reply for something we asked for? true when yes; false else (when some schedule was changed and we get this)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool WasRequested { get; }

Property Value

Boolean
See Also

Reference

MatchListEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchListEventArgs Methods

The MatchListEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MatchListEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchListUpdate Class

List of matches sent unsolicited from server (uses same format as MatchList for now).
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase
Sportradar.SDK.FeedProviders.LiveScoutMatchList
Sportradar.SDK.FeedProviders.LiveScoutMatchListUpdate

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchListUpdate : MatchList

The MatchListUpdate type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Matches | List of matches in the time frame requested by the client. (Inherited from MatchList)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides MatchListToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchListUpdate Properties

The MatchListUpdate type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Matches | List of matches in the time frame requested by the client. (Inherited from MatchList)
Top
See Also

Reference

MatchListUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchListUpdate Methods

The MatchListUpdate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides MatchListToString)
Top
See Also

Reference

MatchListUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchListUpdate.ToString Method

MatchListUpdateToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

MatchListUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchProperty Class

Match Property
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutMatchProperty

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchProperty

The MatchProperty type exposes the following members.

Constructors
 | Name | Description
Public method | MatchProperty | Initializes a new instance of the MatchProperty class
Top
Properties
 | Name | Description
Public property | Type | Format type
Public property | Value | Format value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchProperty Constructor

Initializes a new instance of the MatchProperty class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchProperty()
See Also

Reference

MatchProperty Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchProperty Properties

The MatchProperty type exposes the following members.

Properties
 | Name | Description
Public property | Type | Format type
Public property | Value | Format value
Top
See Also

Reference

MatchProperty Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchProperty.Type Property

MatchPropertyType Property

Format type

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Type { get; }

Property Value

String
See Also

Reference

MatchProperty Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchProperty.Value Property

MatchPropertyValue Property

Format value

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; }

Property Value

String
See Also

Reference

MatchProperty Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchProperty Methods

The MatchProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object (Overrides ObjectToString)
Top
See Also

Reference

MatchProperty Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchProperty.ToString Method

MatchPropertyToString Method

Returns a string that represents the current object

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object
Remarks
Can be used for diagnostics purposes
See Also

Reference

MatchProperty Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchRole Class

Match role
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutMatchRole

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchRole

The MatchRole type exposes the following members.

Constructors
 | Name | Description
Public method | MatchRole | Initializes a new instance of the MatchRole class
Top
Properties
 | Name | Description
Public property | Description | Description
Public property | Id | Id
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchRole Constructor

Initializes a new instance of the MatchRole class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchRole()
See Also

Reference

MatchRole Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchRole Properties

The MatchRole type exposes the following members.

Properties
 | Name | Description
Public property | Description | Description
Public property | Id | Id
Top
See Also

Reference

MatchRole Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchRole.Description Property

MatchRoleDescription Property

Description

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Description { get; set; }

Property Value

String
See Also

Reference

MatchRole Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchRole.Id Property

MatchRoleId Property

Id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; set; }

Property Value

Int32
See Also

Reference

MatchRole Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchRole Methods

The MatchRole type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

MatchRole Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchRole.ToString Method

MatchRoleToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

MatchRole Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchStop Class

Reply sent when a client unsubscribes from a match or when a match subscription failed.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase
Sportradar.SDK.FeedProviders.LiveScoutMatchStop

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchStop : ScoutEntityBase

The MatchStop type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | MatchId | Match id
Public property | Reason | Reason for match subscription failure or notification that un-subscription was successful.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchStop Properties

The MatchStop type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | MatchId | Match id
Public property | Reason | Reason for match subscription failure or notification that un-subscription was successful.
Top
See Also

Reference

MatchStop Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchStop.MatchId Property

MatchStopMatchId Property

Match id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long MatchId { get; }

Property Value

Int64
See Also

Reference

MatchStop Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchStop.Reason Property

MatchStopReason Property

Reason for match subscription failure or notification that un-subscription was successful.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Reason { get; }

Property Value

String
See Also

Reference

MatchStop Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchStop Methods

The MatchStop type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

MatchStop Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchStop.ToString Method

MatchStopToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

MatchStop Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchStopEventArgs Class

Event arguments passed with OnMatchStop.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveScoutMatchStopEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchStopEventArgs : EventArgs

The MatchStopEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MatchStopEventArgs | Initializes a new instance of the MatchStopEventArgs class
Top
Properties
 | Name | Description
Public property | MatchId | Match id
Public property | Reason | Reason could be a match subscription failure or client unsubscribing from a match.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchStopEventArgs Constructor

Initializes a new instance of the MatchStopEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchStopEventArgs()
See Also

Reference

MatchStopEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchStopEventArgs Properties

The MatchStopEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MatchId | Match id
Public property | Reason | Reason could be a match subscription failure or client unsubscribing from a match.
Top
See Also

Reference

MatchStopEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchStopEventArgs.MatchId Property

MatchStopEventArgsMatchId Property

Match id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long MatchId { get; }

Property Value

Int64
See Also

Reference

MatchStopEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchStopEventArgs.Reason Property

MatchStopEventArgsReason Property

Reason could be a match subscription failure or client unsubscribing from a match.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Reason { get; }

Property Value

String
See Also

Reference

MatchStopEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchStopEventArgs Methods

The MatchStopEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MatchStopEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchTeam Class

Match Team
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutMatchTeam

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchTeam

The MatchTeam type exposes the following members.

Constructors
 | Name | Description
Public method | MatchTeam | Initializes a new instance of the MatchTeam class
Top
Properties
 | Name | Description
Public property | DateOfBirth | Date of birth
Public property | Nationality | Nationality
Public property | Side | Gets the home or away side of team
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchTeam Constructor

Initializes a new instance of the MatchTeam class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchTeam()
See Also

Reference

MatchTeam Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchTeam Properties

The MatchTeam type exposes the following members.

Properties
 | Name | Description
Public property | DateOfBirth | Date of birth
Public property | Nationality | Nationality
Public property | Side | Gets the home or away side of team
Top
See Also

Reference

MatchTeam Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchTeam.DateOfBirth Property

MatchTeamDateOfBirth Property

Date of birth

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string DateOfBirth { get; }

Property Value

String
See Also

Reference

MatchTeam Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchTeam.Nationality Property

MatchTeamNationality Property

Nationality

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Nationality { get; }

Property Value

String
See Also

Reference

MatchTeam Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchTeam.Side Property

MatchTeamSide Property

Gets the home or away side of team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team Side { get; }

Property Value

Team
The home or away side of team
See Also

Reference

MatchTeam Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchTeam Methods

The MatchTeam type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object (Overrides ObjectToString)
Top
See Also

Reference

MatchTeam Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchTeam.ToString Method

MatchTeamToString Method

Returns a string that represents the current object

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object
Remarks
Can be used for diagnostics purposes
See Also

Reference

MatchTeam Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate Class

Match information message. Contains statistical information about a match as well as individual events (e.g. goals, cards, etc.).
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase
Sportradar.SDK.FeedProviders.LiveScoutMatchUpdate

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchUpdate : ScoutEntityBase

The MatchUpdate type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Attacks | Attacks statistics.
Public property | Behinds | Gets the behinds
Public property | BlackCards | Black cards (badminton)
Public property | Category | Sport category.
Public property | Corners | Corner statistics.
Public property | Court | Type of court.
Public property | DangerousAttacks | Dangerous attack statistics.
Public property | DirectFoulsPeriod | Direct fouls for current period statistics (futsal).
Public property | DirectFreeKicks | Direct free kicks statistics (futsal).
Public property | Events | List of scout events.
Public property | FreeKicks | Free kick statistics.
Public property | FreeThrows | Free throws statistics.
Public property | GoalkeeperSaves | Goal keeper saves statistics.
Public property | GoalKicks | Goal kick statistics.
Public property | Goals | Gets the goals
Public property | Gold | Gets the gold.
Public property | GreenCards | Green card statistics.
Public property | IceConditions | Ice conditions
Public property | Injuries | Injuries statistics.
Public property | Innings | Innings
Public property | IsTieBreak | Whether the match is currently in tie break status (tennis).
Public property | Jerseys | Gets the jerseys
Public property | KickoffTeam | Kickoff team
Public property | KickoffTeamFirstHalf | Kickoff team
Public property | KickoffTeamOt | Kickoff team
Public property | KickoffTeamSecondHalf | Kickoff team
Public property | MatchFormat | Match format
Public property | MatchHeader | Basic match information.
Public property | MatchStatus | Current match status. Same status codes as in LiveOdds and LiveScore.
Public property | MatchStatusId | Current match status id. Same status codes as in LiveOdds and LiveScore.
Public property | MatchStatusStart | Time stamp for when match status was set in UTC.
Public property | Networth | Gets the networth
Public property | Offsides | Offside statistics.
Public property | OpeningFaceoff1StPeriod | Opening faceoff 1st period
Public property | OpeningFaceoff2NdPeriod | Opening faceoff 2nd period
Public property | OpeningFaceoff3RdPeriod | Opening faceoff 3rd period
Public property | OpeningFaceoffOvertime | Opening faceoff overtime
Public property | Penalties | Penalties statistics.
Public property | PitchConditions | Pitch / grass conditions.
Public property | Possession | Ball possession statistics.
Public property | PossessionTeam | Which team currently has possession of the ball.
Public property | Properties | Match properties
Public property | RedCards | Red card statistics.
Public property | Score | Match score information.
Public property | Scores | Gets the match scores
Public property | Scout | Scout
Public property | Serve | Which player/team currently has the serve (tennis, volleyball).
Public property | ShotsBlocked | Shots blocked statistics.
Public property | ShotsOffTarget | Shots off target statistics.
Public property | ShotsOnTarget | Shots on target statistics.
Public property | Sport | Type of sport.
Public property | SubTeam | Sub team.
Public property | SurfaceType | Surface type (tennis).
Public property | Suspensions | Suspensions statistics.
Public property | Teams | Match teams
Public property | Throwins | Throw-in statistics.
Public property | Tournament | Sport tournament.
Public property | WeatherConditions | Weather conditions.
Public property | YellowCards | Yellow cards statistics.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate Properties

The MatchUpdate type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Attacks | Attacks statistics.
Public property | Behinds | Gets the behinds
Public property | BlackCards | Black cards (badminton)
Public property | Category | Sport category.
Public property | Corners | Corner statistics.
Public property | Court | Type of court.
Public property | DangerousAttacks | Dangerous attack statistics.
Public property | DirectFoulsPeriod | Direct fouls for current period statistics (futsal).
Public property | DirectFreeKicks | Direct free kicks statistics (futsal).
Public property | Events | List of scout events.
Public property | FreeKicks | Free kick statistics.
Public property | FreeThrows | Free throws statistics.
Public property | GoalkeeperSaves | Goal keeper saves statistics.
Public property | GoalKicks | Goal kick statistics.
Public property | Goals | Gets the goals
Public property | Gold | Gets the gold.
Public property | GreenCards | Green card statistics.
Public property | IceConditions | Ice conditions
Public property | Injuries | Injuries statistics.
Public property | Innings | Innings
Public property | IsTieBreak | Whether the match is currently in tie break status (tennis).
Public property | Jerseys | Gets the jerseys
Public property | KickoffTeam | Kickoff team
Public property | KickoffTeamFirstHalf | Kickoff team
Public property | KickoffTeamOt | Kickoff team
Public property | KickoffTeamSecondHalf | Kickoff team
Public property | MatchFormat | Match format
Public property | MatchHeader | Basic match information.
Public property | MatchStatus | Current match status. Same status codes as in LiveOdds and LiveScore.
Public property | MatchStatusId | Current match status id. Same status codes as in LiveOdds and LiveScore.
Public property | MatchStatusStart | Time stamp for when match status was set in UTC.
Public property | Networth | Gets the networth
Public property | Offsides | Offside statistics.
Public property | OpeningFaceoff1StPeriod | Opening faceoff 1st period
Public property | OpeningFaceoff2NdPeriod | Opening faceoff 2nd period
Public property | OpeningFaceoff3RdPeriod | Opening faceoff 3rd period
Public property | OpeningFaceoffOvertime | Opening faceoff overtime
Public property | Penalties | Penalties statistics.
Public property | PitchConditions | Pitch / grass conditions.
Public property | Possession | Ball possession statistics.
Public property | PossessionTeam | Which team currently has possession of the ball.
Public property | Properties | Match properties
Public property | RedCards | Red card statistics.
Public property | Score | Match score information.
Public property | Scores | Gets the match scores
Public property | Scout | Scout
Public property | Serve | Which player/team currently has the serve (tennis, volleyball).
Public property | ShotsBlocked | Shots blocked statistics.
Public property | ShotsOffTarget | Shots off target statistics.
Public property | ShotsOnTarget | Shots on target statistics.
Public property | Sport | Type of sport.
Public property | SubTeam | Sub team.
Public property | SurfaceType | Surface type (tennis).
Public property | Suspensions | Suspensions statistics.
Public property | Teams | Match teams
Public property | Throwins | Throw-in statistics.
Public property | Tournament | Sport tournament.
Public property | WeatherConditions | Weather conditions.
Public property | YellowCards | Yellow cards statistics.
Top
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Attacks Property

MatchUpdateAttacks Property

Attacks statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> Attacks { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Behinds Property

MatchUpdateBehinds Property

Gets the behinds

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Behinds Behinds { get; }

Property Value

Behinds
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.BlackCards Property

MatchUpdateBlackCards Property

Black cards (badminton)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> BlackCards { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Category Property

MatchUpdateCategory Property

Sport category.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Category { get; }

Property Value

IdNameTuple
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Corners Property

MatchUpdateCorners Property

Corner statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> Corners { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Court Property

MatchUpdateCourt Property

Type of court.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Court Court { get; }

Property Value

Court
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.DangerousAttacks Property

MatchUpdateDangerousAttacks Property

Dangerous attack statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> DangerousAttacks { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.DirectFoulsPeriod Property

MatchUpdateDirectFoulsPeriod Property

Direct fouls for current period statistics (futsal).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> DirectFoulsPeriod { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.DirectFreeKicks Property

MatchUpdateDirectFreeKicks Property

Direct free kicks statistics (futsal).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> DirectFreeKicks { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Events Property

MatchUpdateEvents Property

List of scout events.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<ScoutEvent> Events { get; }

Property Value

List ScoutEvent
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.FreeKicks Property

MatchUpdateFreeKicks Property

Free kick statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> FreeKicks { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.FreeThrows Property

MatchUpdateFreeThrows Property

Free throws statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> FreeThrows { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.GoalkeeperSaves Property

MatchUpdateGoalkeeperSaves Property

Goal keeper saves statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> GoalkeeperSaves { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.GoalKicks Property

MatchUpdateGoalKicks Property

Goal kick statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> GoalKicks { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Goals Property

MatchUpdateGoals Property

Gets the goals

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Goals Goals { get; }

Property Value

Goals
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Gold Property

MatchUpdateGold Property

Gets the gold.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Gold Gold { get; }

Property Value

Gold
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.GreenCards Property

MatchUpdateGreenCards Property

Green card statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> GreenCards { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.IceConditions Property

MatchUpdateIceConditions Property

Ice conditions

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IceConditions? IceConditions { get; }

Property Value

Nullable IceConditions
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Injuries Property

MatchUpdateInjuries Property

Injuries statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> Injuries { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Innings Property

MatchUpdateInnings Property

Innings

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<Innings> Innings { get; }

Property Value

List Innings
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.IsTieBreak Property

MatchUpdateIsTieBreak Property

Whether the match is currently in tie break status (tennis).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? IsTieBreak { get; }

Property Value

Nullable Boolean
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Jerseys Property

MatchUpdateJerseys Property

Gets the jerseys

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<Jersey> Jerseys { get; }

Property Value

List Jersey
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.KickoffTeam Property

MatchUpdateKickoffTeam Property

Kickoff team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? KickoffTeam { get; }

Property Value

Nullable Team
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.KickoffTeamFirstHalf Property

MatchUpdateKickoffTeamFirstHalf Property

Kickoff team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? KickoffTeamFirstHalf { get; }

Property Value

Nullable Team
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.KickoffTeamOt Property

MatchUpdateKickoffTeamOt Property

Kickoff team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? KickoffTeamOt { get; }

Property Value

Nullable Team
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.KickoffTeamSecondHalf Property

MatchUpdateKickoffTeamSecondHalf Property

Kickoff team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? KickoffTeamSecondHalf { get; }

Property Value

Nullable Team
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.MatchFormat Property

MatchUpdateMatchFormat Property

Match format

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<Format> MatchFormat { get; }

Property Value

List Format
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.MatchHeader Property

MatchUpdateMatchHeader Property

Basic match information.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchHeader MatchHeader { get; }

Property Value

MatchHeader
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.MatchStatus Property

MatchUpdateMatchStatus Property

Current match status. Same status codes as in LiveOdds and LiveScore.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoutMatchStatus MatchStatus { get; }

Property Value

ScoutMatchStatus
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.MatchStatusId Property

MatchUpdateMatchStatusId Property

Current match status id. Same status codes as in LiveOdds and LiveScore.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int MatchStatusId { get; }

Property Value

Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.MatchStatusStart Property

MatchUpdateMatchStatusStart Property

Time stamp for when match status was set in UTC.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime MatchStatusStart { get; }

Property Value

DateTime
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Networth Property

MatchUpdateNetworth Property

Gets the networth

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Networth Networth { get; }

Property Value

Networth
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Offsides Property

MatchUpdateOffsides Property

Offside statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> Offsides { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.OpeningFaceoff1StPeriod Property

MatchUpdateOpeningFaceoff1StPeriod Property

Opening faceoff 1st period

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? OpeningFaceoff1StPeriod { get; }

Property Value

Nullable Team
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.OpeningFaceoff2NdPeriod Property

MatchUpdateOpeningFaceoff2NdPeriod Property

Opening faceoff 2nd period

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? OpeningFaceoff2NdPeriod { get; }

Property Value

Nullable Team
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.OpeningFaceoff3RdPeriod Property

MatchUpdateOpeningFaceoff3RdPeriod Property

Opening faceoff 3rd period

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? OpeningFaceoff3RdPeriod { get; }

Property Value

Nullable Team
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.OpeningFaceoffOvertime Property

MatchUpdateOpeningFaceoffOvertime Property

Opening faceoff overtime

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? OpeningFaceoffOvertime { get; }

Property Value

Nullable Team
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Penalties Property

MatchUpdatePenalties Property

Penalties statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> Penalties { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.PitchConditions Property

MatchUpdatePitchConditions Property

Pitch / grass conditions.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public PitchConditions PitchConditions { get; }

Property Value

PitchConditions
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Possession Property

MatchUpdatePossession Property

Ball possession statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int?> Possession { get; }

Property Value

HomeAway Nullable Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.PossessionTeam Property

MatchUpdatePossessionTeam Property

Which team currently has possession of the ball.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team PossessionTeam { get; }

Property Value

Team
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Properties Property

MatchUpdateProperties Property

Match properties

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<MatchProperty> Properties { get; }

Property Value

List MatchProperty
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.RedCards Property

MatchUpdateRedCards Property

Red card statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> RedCards { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Score Property

MatchUpdateScore Property

Match score information.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IDictionary<string, HomeAway<double>> Score { get; }

Property Value

IDictionary String, HomeAway Double
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Scores Property

MatchUpdateScores Property

Gets the match scores

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<Score> Scores { get; }

Property Value

List Score
The match scores
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Scout Property

MatchUpdateScout Property

Scout

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Scout Scout { get; }

Property Value

Scout
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Serve Property

MatchUpdateServe Property

Which player/team currently has the serve (tennis, volleyball).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team Serve { get; }

Property Value

Team
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.ShotsBlocked Property

MatchUpdateShotsBlocked Property

Shots blocked statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> ShotsBlocked { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.ShotsOffTarget Property

MatchUpdateShotsOffTarget Property

Shots off target statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> ShotsOffTarget { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.ShotsOnTarget Property

MatchUpdateShotsOnTarget Property

Shots on target statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> ShotsOnTarget { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Sport Property

MatchUpdateSport Property

Type of sport.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Sport { get; }

Property Value

IdNameTuple
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.SubTeam Property

MatchUpdateSubTeam Property

Sub team.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SubTeam SubTeam { get; }

Property Value

SubTeam
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.SurfaceType Property

MatchUpdateSurfaceType Property

Surface type (tennis).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SurfaceType SurfaceType { get; }

Property Value

SurfaceType
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Suspensions Property

MatchUpdateSuspensions Property

Suspensions statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Suspensions Suspensions { get; }

Property Value

Suspensions
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Teams Property

MatchUpdateTeams Property

Match teams

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<MatchTeam> Teams { get; }

Property Value

List MatchTeam
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Throwins Property

MatchUpdateThrowins Property

Throw-in statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> Throwins { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.Tournament Property

MatchUpdateTournament Property

Sport tournament.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdNameTuple Tournament { get; }

Property Value

IdNameTuple
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.WeatherConditions Property

MatchUpdateWeatherConditions Property

Weather conditions.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public WeatherConditions WeatherConditions { get; }

Property Value

WeatherConditions
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.YellowCards Property

MatchUpdateYellowCards Property

Yellow cards statistics.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HomeAway<int> YellowCards { get; }

Property Value

HomeAway Int32
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate Methods

The MatchUpdate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdate.ToString Method

MatchUpdateToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

MatchUpdate Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdateEventArgs Class

Event arguments passed OnMatchUpdate, OnMatchUpdateDelta, OnMatchUpdateDeltaUpdate and OnMatchUpdateFull.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveScoutMatchUpdateEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class MatchUpdateEventArgs : EventArgs

The MatchUpdateEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MatchUpdateEventArgs | Initializes a new instance of the MatchUpdateEventArgs class
Top
Properties
 | Name | Description
Public property | MatchUpdate | Match update (full, delta or delta update)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdateEventArgs Constructor

Initializes a new instance of the MatchUpdateEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchUpdateEventArgs()
See Also

Reference

MatchUpdateEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdateEventArgs Properties

The MatchUpdateEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MatchUpdate | Match update (full, delta or delta update)
Top
See Also

Reference

MatchUpdateEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdateEventArgs.MatchUpdate Property

MatchUpdateEventArgsMatchUpdate Property

Match update (full, delta or delta update)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchUpdate MatchUpdate { get; }

Property Value

MatchUpdate
See Also

Reference

MatchUpdateEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


MatchUpdateEventArgs Methods

The MatchUpdateEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MatchUpdateEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Networth Class

Networth
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutNetworth

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Networth

The Networth type exposes the following members.

Constructors
 | Name | Description
Public method | Networth | Initializes a new instance of the Networth class
Top
Properties
 | Name | Description
Public property | MapNr | map number
Public property | T1 | t1
Public property | T2 | t2
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Networth Constructor

Initializes a new instance of the Networth class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Networth()
See Also

Reference

Networth Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Networth Properties

The Networth type exposes the following members.

Properties
 | Name | Description
Public property | MapNr | map number
Public property | T1 | t1
Public property | T2 | t2
Top
See Also

Reference

Networth Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Networth.MapNr Property

NetworthMapNr Property

map number

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int MapNr { get; }

Property Value

Int32
See Also

Reference

Networth Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Networth.T1 Property

NetworthT1 Property

t1

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int T1 { get; }

Property Value

Int32
See Also

Reference

Networth Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Networth.T2 Property

NetworthT2 Property

t2

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int T2 { get; }

Property Value

Int32
See Also

Reference

Networth Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Networth Methods

The Networth type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Networth Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Networth.ToString Method

NetworthToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Networth Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


PitchConditions Class

Pitch conditions.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutPitchConditions

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class PitchConditions : Enum

The PitchConditions type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | BAD | Bad
 | GOOD | Good
 | MEDIUM | Medium
 | UNDEFINED | Undefined
 | UNKNOWN | Unknown
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


PitchConditions Methods

The PitchConditions type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

PitchConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


PitchConditions Fields

The PitchConditions type exposes the following members.

Fields
 | Name | Description
 | BAD | Bad
 | GOOD | Good
 | MEDIUM | Medium
 | UNDEFINED | Undefined
 | UNKNOWN | Unknown
Public field | value__ |
Top
See Also

Reference

PitchConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


PitchConditions.BAD Field

PitchConditionsBAD Field

Bad

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const PitchConditions BAD = 3

Field Value

PitchConditions
See Also

Reference

PitchConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


PitchConditions.GOOD Field

PitchConditionsGOOD Field

Good

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const PitchConditions GOOD = 1

Field Value

PitchConditions
See Also

Reference

PitchConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


PitchConditions.MEDIUM Field

PitchConditionsMEDIUM Field

Medium

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const PitchConditions MEDIUM = 2

Field Value

PitchConditions
See Also

Reference

PitchConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


PitchConditions.UNDEFINED Field

PitchConditionsUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const PitchConditions UNDEFINED = 0

Field Value

PitchConditions
See Also

Reference

PitchConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


PitchConditions.UNKNOWN Field

PitchConditionsUNKNOWN Field

Unknown

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const PitchConditions UNKNOWN = 4

Field Value

PitchConditions
See Also

Reference

PitchConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


PitchConditions.value__ Field

PitchConditionsvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.PitchConditions.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

PitchConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player Class

A player in the lineup.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase
Sportradar.SDK.FeedProviders.LiveScoutPlayer

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Player : ScoutEntityBase

The Player type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Attributes | Attributes
Public property | Id | ID of the player
Public property | IsSubstitute | Is the player a substitute?
Public property | MatchRoles | Match roles
Public property | Name | Name of the player.
Public property | Nickname | Player nickname
Public property | Order | The order id
Public property | Position | Player position
Public property | ShirtNumber | Shirt number.
Public property | Team | Team of the player.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Player Properties

The Player type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Attributes | Attributes
Public property | Id | ID of the player
Public property | IsSubstitute | Is the player a substitute?
Public property | MatchRoles | Match roles
Public property | Name | Name of the player.
Public property | Nickname | Player nickname
Public property | Order | The order id
Public property | Position | Player position
Public property | ShirtNumber | Shirt number.
Public property | Team | Team of the player.
Top
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player.Attributes Property

PlayerAttributes Property

Attributes

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<Attribute> Attributes { get; }

Property Value

List Attribute
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player.Id Property

PlayerId Property

ID of the player

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player.IsSubstitute Property

PlayerIsSubstitute Property

Is the player a substitute?

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsSubstitute { get; }

Property Value

Boolean
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player.MatchRoles Property

PlayerMatchRoles Property

Match roles

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<MatchRole> MatchRoles { get; }

Property Value

List MatchRole
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player.Name Property

PlayerName Property

Name of the player.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; }

Property Value

String
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player.Nickname Property

PlayerNickname Property

Player nickname

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Nickname { get; }

Property Value

String
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player.Order Property

PlayerOrder Property

The order id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Order { get; }

Property Value

Nullable Int32
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player.Position Property

PlayerPosition Property

Player position

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Position { get; }

Property Value

String
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player.ShirtNumber Property

PlayerShirtNumber Property

Shirt number.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int ShirtNumber { get; }

Property Value

Int32
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player.Team Property

PlayerTeam Property

Team of the player.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team Team { get; }

Property Value

Team
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player Methods

The Player type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Player.ToString Method

PlayerToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Player Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Score Class

Score
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutScore

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Score

The Score type exposes the following members.

Properties
 | Name | Description
Public property | SubScore |
Public property | Team1 |
Public property | Team2 |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Score Properties

The Score type exposes the following members.

Properties
 | Name | Description
Public property | SubScore |
Public property | Team1 |
Public property | Team2 |
Public property | Type |
Top
See Also

Reference

Score Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Score.SubScore Property

ScoreSubScore Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.Score.SubScore"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Score SubScore { get; }

Property Value

Score
See Also

Reference

Score Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Score.Team1 Property

ScoreTeam1 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.Score.Team1"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double Team1 { get; }

Property Value

Double
See Also

Reference

Score Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Score.Team2 Property

ScoreTeam2 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.Score.Team2"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double Team2 { get; }

Property Value

Double
See Also

Reference

Score Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Score.Type Property

ScoreType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.Score.Type"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Type { get; }

Property Value

String
See Also

Reference

Score Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Score Methods

The Score type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Score Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Score.ToString Method

ScoreToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Score Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Scout Class

Scout
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutScout

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Scout

The Scout type exposes the following members.

Constructors
 | Name | Description
Public method | Scout | Initializes a new instance of the Scout class
Top
Properties
 | Name | Description
Public property | Id | Id
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Scout Constructor

Initializes a new instance of the Scout class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Scout()
See Also

Reference

Scout Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Scout Properties

The Scout type exposes the following members.

Properties
 | Name | Description
Public property | Id | Id
Top
See Also

Reference

Scout Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Scout.Id Property

ScoutId Property

Id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

Scout Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Scout Methods

The Scout type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Scout Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Scout.ToString Method

ScoutToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

Scout Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEntityBase Class

Serves as a base class that all LiveOdds entities should be derived from.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase
More

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public abstract class ScoutEntityBase : EntityBase

The ScoutEntityBase type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides EntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase
Sportradar.SDK.FeedProviders.LiveScoutConnectionTest
Sportradar.SDK.FeedProviders.LiveScoutLineups
Sportradar.SDK.FeedProviders.LiveScoutMatchBooking
Sportradar.SDK.FeedProviders.LiveScoutMatchData
Sportradar.SDK.FeedProviders.LiveScoutMatchList
Sportradar.SDK.FeedProviders.LiveScoutMatchStop
Sportradar.SDK.FeedProviders.LiveScoutMatchUpdate
Sportradar.SDK.FeedProviders.LiveScoutPlayer
Sportradar.SDK.FeedProviders.LiveScoutScoutInfos


ScoutEntityBase Properties

The ScoutEntityBase type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Top
See Also

Reference

ScoutEntityBase Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEntityBase Methods

The ScoutEntityBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides EntityBaseToString)
Top
See Also

Reference

ScoutEntityBase Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEntityBase.ToString Method

ScoutEntityBaseToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

ScoutEntityBase Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent Class

Scout event like a card, corner kick, half time, penalty, etc.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutScoutEvent

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ScoutEvent

The ScoutEvent type exposes the following members.

Constructors
 | Name | Description
Public method | ScoutEvent | Initializes a new instance of the ScoutEvent class
Top
Properties
Name | Description
Public property | ActualMatchStatistics
Public property | Assists | Assists
Public property | AtBatNumber
Public property | AtBatPitchNumber
Public property | AttackingPlayers
Public property | Automatic | Identifies whether event was automatically generated automatically or not.
Public property | AwayPlayers
Public property | AwayPlayerStatsDef
Public property | AwayPlayerStatsOt
Public property | AwayPlayerStatsP1
Public property | AwayPlayerStatsP2
Public property | AwayPlayerStatsP3
Public property | AwayPlayerStatsP4
Public property | AwayPlayerStatsPass
Public property | AwayPlayerStatsRec
Public property | AwayPlayerStatsRush
Public property | AwayPlayerStatsTotal
Public property | AwayTeamStats
Public property | AwayTeamStatsOt
Public property | AwayTeamStatsP1
Public property | AwayTeamStatsP2
Public property | AwayTeamStatsP3
Public property | AwayTeamStatsP4
Public property | AwayTeamStatsTotal
Public property | AwayTimeOnCourt
Public property | AwayTimeOnIce
Public property | BallNumber | Ball number
Public property | Balls | Number of balls.
Public property | BallSpotting | Ball spotting
Public property | BaronKills | Baron kills
Public property | BaseInfo | Base info.
Public property | BatBallAngle | Gets the angle of the ball, relative from the ground, as the ball leaves the bat
Public property | BatBallDirection | Gets the direction of the ball as it leaves the bat
Public property | BatBallDistance
Public property | BatBallSpeed | Gets the speed at which the ball leaves the bat, mph
Public property | BatBallX
Public property | BatBallY
Public property | BattingAverages | Gets the batting averages.
Public property | Behinds | Gets the behinds
Public property | BlockedBy
Public property | BreakScore | Break score
Public property | CaughtBy
Public property | CausedBy
Public property | ChampionDamage
Public property | Cloud
Public property | ConversionType | Gets the type of the conversion.
Public property | CorrectedFrom | Corrected from, used with score correction event
Public property | CorrectedTo | Corrected to, used with score correction event
Public property | Damage
Public property | Deaths | Deaths
Public property | DefensedBy
Public property | Denies | Denies
Public property | Direction
Public property | DismissalsInInnings | Dismissals in innings
Public property | DoubleKills | Double kills
Public property | DownedBy
Public property | DragonKills | Dragon kills
Public property | DragonType
Public property | DriveInfoStatus
Public property | DrivePlayInfo
Public property | EarlyBetstartType | EarlyBetstartType
Public property | EndScore | End score
Public property | Errors | Number of errors.
Public property | ErrorsAway | Errors away
Public property | ErrorsHome | Errors home
Public property | Experience | Experience
Public property ExtraInfo Integer value, meaning of this attribute depends on event type:
  • 30 (score): 0 or -1 = not specified, 1 = penalty, 2 = own goal, 3 = header
  • 1019 (cancel goal): 0 or -1 = not specified, 1 = off side, 2 = foul, 3 = incorrect entry
  • 1013 (match status): match status enumeration
  • 1025 (tennis full score): tennis point type – 0=standard, 1=ace, 2=double fault opponent
  • 158 (injury): Player still injured – 1=yes, 0=no 165 (attendance): Attendance
  • 1039 (manual time adjustment): Number of seconds adjusted. Can be both a positive and a negative integer
  • 1044 (event deleted): Id of event that was deleted
  • 1037 (basketball points): Number of points scored – 1, 2 or 3
  • 1038 (basketball points missed): Point attempt missed – 1, 2 or 3 (points)
  • 1046 (volleyball full score): volleyball point type – 0=standard, 1=ace, 2=service error
  • 1056 (number of free throws): Number of free throws
  • 1036 (time start stop): 1 = time is running, 0 = time is stopped
  • 43 (suspensions): Number of minutes player is suspended for
  • 90 (injury time): Number of minutes injury time added
  • 1082 (corner markets): 1 = safe to accept bets, 0 = not safe
  • 1083 (booking markets): 1 = safe to accept bets, 0 = not safe
  • 1002 (penalty shootout): -1=penalty not taken, 1=penalty scored, 0=penalty missed
  • 1060 (direct free kick): -1 = not taken, 0 = miss, 1 = score
  • 1102 (coverage status): 0 - match covered, 1 - coverage abandoned (used when abandoning coverage after a match has started), 2 - match will not be covered (used when we are unable to cover a match that we were supposed to cover)
All counter event types (throw in count etc.): Number of events of this type for team specified by “side" attribute
Public property | ExtraInfoBaseball | Extra info baseball.
Public property | ExtraInfoBasketball | Extra info for basketball game
Public property | ExtraInfoBowls | Extra info for bowls game
Public property | ExtraInfoCricket | Extra info for cricket game
Public property | ExtraInfoCsGo | Extra info for counter strike global offensive
Public property | ExtraInfoDarts | Extra info for dart game
Public property | ExtraInfoFootball | Extra info for football game
Public property | ExtraInfoHandball | Extra info for handball game
Public property | ExtraInfoIceHockey | Extra info ice hockey.
Public property | ExtraInfoKabaddi
Public property | ExtraInfoMoba | Extra info moba
Public property | ExtraInfoSnooker | Extra info for snooker game
Public property | ExtraInfoVolleyball | Extra info for volleyball game
Public property | FieldGoalDistance
Public property | FieldingPlayers
Public property | FirstBaseLoaded | First base loaded
Public property | FirstBasePlayer
Public property | FoulTypeDescriptor
Public property | FoulTypeQualifier
Public property | FrameNumber | Frame number
Public property | FrameScore | Frame score
Public property | FreeKickReason
Public property | FumbledBy
Public property | GameNumber | In tennis, which game number in the set.
Public property | GameScore | In tennis, the game score.
Public property | Goals | Gets the goals
Public property | HappenedAt
Public property | HealthRemaining
Public property | HeroesAliveAway | Level
Public property | HeroesAliveHome | Heroes alive home
Public property | HeroId | Hero Id
Public property | HeroName | Hero Name
Public property | HitsAway | Hits away
Public property | HitsHome | Hits home
Public property | HomePlayers
Public property | HomePlayerStatsDef
Public property | HomePlayerStatsOt
Public property | HomePlayerStatsP1
Public property | HomePlayerStatsP2
Public property | HomePlayerStatsP3
Public property | HomePlayerStatsP4
Public property | HomePlayerStatsPass
Public property | HomePlayerStatsRec
Public property | HomePlayerStatsRush
Public property | HomePlayerStatsTotal
Public property | HomeRunsAway
Public property | HomeRunsHome
Public property | HomeTeamStats
Public property | HomeTeamStatsOt
Public property | HomeTeamStatsP1
Public property | HomeTeamStatsP2
Public property | HomeTeamStatsP3
Public property | HomeTeamStatsP4
Public property | HomeTeamStatsTotal
Public property | HomeTimeOnCourt
Public property | HomeTimeOnIce
Public property | Humidity
Public property | Id | Unique event id.
Public property | Info | Text description of event.
Public property | InhibitorKills | Inhibitor kills
Public property | InjuryPlayer
Public property | InjuryReturn
Public property | InningHalf | Inning half.
Public property | InningsScore | Innings scores
Public property | IntendedReceiver
Public property | InterceptedBy
Public property | Inventory
Public property | Item
Public property | ItemName | Item name
Public property | KickedBy
Public property | Kills | Kills
Public property | KillsAway | Kills away
Public property | KillsHome | Kills home
Public property | LastHits | Last hits
Public property | LegScore | Used in darts Leg (game) score
Public property | Level | Level
Public property | MapName | Map name
Public property | MapNumber | Map number
Public property | MapScore | Map score
Public property | MatchScore | In tennis, the match score.
Public property | MatchStatus | The match status
Public property | MatchTime | Match time, mm:ss (e.g. 40:00 or 00:00).
Public property | MaxBreakFrame
Public property | MonsterType
Public property | MuffedBy
Public property | NetWorth | Net worth
Public property | NextBatter
Public property | Outs | Number of outs.
Public property | PassedBy
Public property | PenaltyDistance
Public property | PenaltyNoPlay
Public property | PenaltyReason
Public property | PentaKills | Penta kills
Public property | PeriodNumber | Period number of match.
Public property | PeriodScore | Period score.
Public property | PitchCount | Pitch count.
Public property | PitchingSubstitution
Public property | PitchSpeed | Gets how fast the ball was pitched in MPH numeric values
Public property | PitchType | Gets the type of how was the ball pitched
Public property | PlacedAt
Public property Player1Id Sportradar player id for player 1 connected to this event. The meaning of this attribute depends on event type:
  • 30 (goal): Goal scorer
  • 50, 40, 45 (red, yellow, yellow/red card): Who got card
  • 60 (substitution): Outgoing player
  • 154 (corner): Who took corner
  • 161 (penalty awarded): Who caused penalty – offender
  • 155, 156 (shot on/off target): Who shot
  • 153 (off side): Who was off side
  • 158 (injury): Who was injured
Public property Player2Id Sportradar player id for player 2 connected to this event. The meaning of this attribute depends on event type:
  • 60 (substitution): Incoming player
  • 161 (penalty awarded): Who was awarded a penalty
Public property Player3Id Sportradar player id for player 3 connected to this event. The meaning of this attribute depends on event type:
  • 30 (goal): player3 = Second assisting player
Public property Player4Id Sportradar player id for player 3 connected to this event. The meaning of this attribute depends on event type:
  • 30 (goal): player3 = Second assisting player
Public property | PointsRemaining
Public property | PointsUntilSnookerNeeded | Points until snooker needed
Public property | PositionPlayerPitching
Public property | PossibleBreak | Possible break
Public property | PosX | Horizontal position on pitch, posx being a number from 0 to 100. The reference point 0 is at home teams goal.
Public property | PosY | Vertical position on pitch, posy being a number from 0 to 100. The reference point 0 is on top of pitch when home teams goal is on the left hand side.
Public property | PreliminaryMatchStatistics
Public property | PrevPitcher
Public property | PuntDistance
Public property | PushedBy
Public property | QuadraKills | Quadra kills
Public property | RanOutOfBoundsAt
Public property | ReceivedAt
Public property | ReceivedBy
Public property | RecoveredAt
Public property | RecoveredBy
Public property | Reds
Public property | RefUuId
Public property | RemainingTimeInPeriod | Remaining time of match, mm:ss
Public property | RoundNumber | Round number
Public property | RoundScore
Public property | Runs | Number of runs.
Public property | RunsAway | Runs away
Public property | RunsHome | Runs home
Public property | RunsInInnings | Runs in innings
Public property | RushedBy
Public property | RushSpeed
Public property | SackedBy
Public property | SafetyBy
Public property | ScoreTypeQualifier
Public property | SecondBaseLoaded | Second base loaded
Public property | SecondBasePlayer
Public property | SecondScoreType | Seconds score type
Public property | Server | Serving team
Public property | ServerTime | Server time of event, time stamp in UTC.
Public property | SetNumber | In tennis, which set number in the match.
Public property | SetScore | In tennis, the set score.
Public property | ShotDistance
Public property | Side | Which side had an event - home, away or none.
Public property | SnappedBy
Public property | Spot
Public property | SpottedAt
Public property | StadiumType
Public property | Strikes | Number of strikes.
Public property | Structure
Public property | TackledBy
Public property | Temperature
Public property | ThirdBaseLoaded | Third loaded
Public property | ThirdBasePlayer
Public property | ThrownTo
Public property | TippedTo
Public property | TotalPitchCount
Public property | TotalYardsGained
Public property | TouchBackAt
Public property | TouchdownType | Gets the type of the touchdown.
Public property | TowerKills | Tower kills
Public property | TripleKills | Triple kills
Public property | TurfType
Public property | Type | Each event type has an id (e.g. yellow card 40, event deleted 1044, early bet status 1091, etc.). See LiveData documentation to see which event types are supported for each sport New event types can be offered in the future.
Public property | TypeId | Each event type has an id (e.g. yellow card 40, event deleted 1044, early bet status 1091, etc.). See LiveScout documentation to see which event types are supported for each sport. New event types can be offered in the future.
Public property | UnavailablePlayersAway
Public property | UnavailablePlayersHome
Public property | UuId
Public property | WardsPlaced
Public property | WeaponId | Weapon id
Public property | WeaponName | Weapon name
Public property | WindChill
Public property | WindDirection
Public property | WindSpeed
Public property | YardLine
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent Constructor

Initializes a new instance of the ScoutEvent class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoutEvent()
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent Properties

The ScoutEvent type exposes the following members.

Properties
Name | Description
Public property | ActualMatchStatistics
Public property | Assists | Assists
Public property | AtBatNumber
Public property | AtBatPitchNumber
Public property | AttackingPlayers
Public property | Automatic | Identifies whether event was automatically generated automatically or not.
Public property | AwayPlayers
Public property | AwayPlayerStatsDef
Public property | AwayPlayerStatsOt
Public property | AwayPlayerStatsP1
Public property | AwayPlayerStatsP2
Public property | AwayPlayerStatsP3
Public property | AwayPlayerStatsP4
Public property | AwayPlayerStatsPass
Public property | AwayPlayerStatsRec
Public property | AwayPlayerStatsRush
Public property | AwayPlayerStatsTotal
Public property | AwayTeamStats
Public property | AwayTeamStatsOt
Public property | AwayTeamStatsP1
Public property | AwayTeamStatsP2
Public property | AwayTeamStatsP3
Public property | AwayTeamStatsP4
Public property | AwayTeamStatsTotal
Public property | AwayTimeOnCourt
Public property | AwayTimeOnIce
Public property | BallNumber | Ball number
Public property | Balls | Number of balls.
Public property | BallSpotting | Ball spotting
Public property | BaronKills | Baron kills
Public property | BaseInfo | Base info.
Public property | BatBallAngle | Gets the angle of the ball, relative from the ground, as the ball leaves the bat
Public property | BatBallDirection | Gets the direction of the ball as it leaves the bat
Public property | BatBallDistance
Public property | BatBallSpeed | Gets the speed at which the ball leaves the bat, mph
Public property | BatBallX
Public property | BatBallY
Public property | BattingAverages | Gets the batting averages.
Public property | Behinds | Gets the behinds
Public property | BlockedBy
Public property | BreakScore | Break score
Public property | CaughtBy
Public property | CausedBy
Public property | ChampionDamage
Public property | Cloud
Public property | ConversionType | Gets the type of the conversion.
Public property | CorrectedFrom | Corrected from, used with score correction event
Public property | CorrectedTo | Corrected to, used with score correction event
Public property | Damage
Public property | Deaths | Deaths
Public property | DefensedBy
Public property | Denies | Denies
Public property | Direction
Public property | DismissalsInInnings | Dismissals in innings
Public property | DoubleKills | Double kills
Public property | DownedBy
Public property | DragonKills | Dragon kills
Public property | DragonType
Public property | DriveInfoStatus
Public property | DrivePlayInfo
Public property | EarlyBetstartType | EarlyBetstartType
Public property | EndScore | End score
Public property | Errors | Number of errors.
Public property | ErrorsAway | Errors away
Public property | ErrorsHome | Errors home
Public property | Experience | Experience
Public property ExtraInfo Integer value, meaning of this attribute depends on event type:
  • 30 (score): 0 or -1 = not specified, 1 = penalty, 2 = own goal, 3 = header
  • 1019 (cancel goal): 0 or -1 = not specified, 1 = off side, 2 = foul, 3 = incorrect entry
  • 1013 (match status): match status enumeration
  • 1025 (tennis full score): tennis point type – 0=standard, 1=ace, 2=double fault opponent
  • 158 (injury): Player still injured – 1=yes, 0=no 165 (attendance): Attendance
  • 1039 (manual time adjustment): Number of seconds adjusted. Can be both a positive and a negative integer
  • 1044 (event deleted): Id of event that was deleted
  • 1037 (basketball points): Number of points scored – 1, 2 or 3
  • 1038 (basketball points missed): Point attempt missed – 1, 2 or 3 (points)
  • 1046 (volleyball full score): volleyball point type – 0=standard, 1=ace, 2=service error
  • 1056 (number of free throws): Number of free throws
  • 1036 (time start stop): 1 = time is running, 0 = time is stopped
  • 43 (suspensions): Number of minutes player is suspended for
  • 90 (injury time): Number of minutes injury time added
  • 1082 (corner markets): 1 = safe to accept bets, 0 = not safe
  • 1083 (booking markets): 1 = safe to accept bets, 0 = not safe
  • 1002 (penalty shootout): -1=penalty not taken, 1=penalty scored, 0=penalty missed
  • 1060 (direct free kick): -1 = not taken, 0 = miss, 1 = score
  • 1102 (coverage status): 0 - match covered, 1 - coverage abandoned (used when abandoning coverage after a match has started), 2 - match will not be covered (used when we are unable to cover a match that we were supposed to cover)
All counter event types (throw in count etc.): Number of events of this type for team specified by “side" attribute
Public property | ExtraInfoBaseball | Extra info baseball.
Public property | ExtraInfoBasketball | Extra info for basketball game
Public property | ExtraInfoBowls | Extra info for bowls game
Public property | ExtraInfoCricket | Extra info for cricket game
Public property | ExtraInfoCsGo | Extra info for counter strike global offensive
Public property | ExtraInfoDarts | Extra info for dart game
Public property | ExtraInfoFootball | Extra info for football game
Public property | ExtraInfoHandball | Extra info for handball game
Public property | ExtraInfoIceHockey | Extra info ice hockey.
Public property | ExtraInfoKabaddi
Public property | ExtraInfoMoba | Extra info moba
Public property | ExtraInfoSnooker | Extra info for snooker game
Public property | ExtraInfoVolleyball | Extra info for volleyball game
Public property | FieldGoalDistance
Public property | FieldingPlayers
Public property | FirstBaseLoaded | First base loaded
Public property | FirstBasePlayer
Public property | FoulTypeDescriptor
Public property | FoulTypeQualifier
Public property | FrameNumber | Frame number
Public property | FrameScore | Frame score
Public property | FreeKickReason
Public property | FumbledBy
Public property | GameNumber | In tennis, which game number in the set.
Public property | GameScore | In tennis, the game score.
Public property | Goals | Gets the goals
Public property | HappenedAt
Public property | HealthRemaining
Public property | HeroesAliveAway | Level
Public property | HeroesAliveHome | Heroes alive home
Public property | HeroId | Hero Id
Public property | HeroName | Hero Name
Public property | HitsAway | Hits away
Public property | HitsHome | Hits home
Public property | HomePlayers
Public property | HomePlayerStatsDef
Public property | HomePlayerStatsOt
Public property | HomePlayerStatsP1
Public property | HomePlayerStatsP2
Public property | HomePlayerStatsP3
Public property | HomePlayerStatsP4
Public property | HomePlayerStatsPass
Public property | HomePlayerStatsRec
Public property | HomePlayerStatsRush
Public property | HomePlayerStatsTotal
Public property | HomeRunsAway
Public property | HomeRunsHome
Public property | HomeTeamStats
Public property | HomeTeamStatsOt
Public property | HomeTeamStatsP1
Public property | HomeTeamStatsP2
Public property | HomeTeamStatsP3
Public property | HomeTeamStatsP4
Public property | HomeTeamStatsTotal
Public property | HomeTimeOnCourt
Public property | HomeTimeOnIce
Public property | Humidity
Public property | Id | Unique event id.
Public property | Info | Text description of event.
Public property | InhibitorKills | Inhibitor kills
Public property | InjuryPlayer
Public property | InjuryReturn
Public property | InningHalf | Inning half.
Public property | InningsScore | Innings scores
Public property | IntendedReceiver
Public property | InterceptedBy
Public property | Inventory
Public property | Item
Public property | ItemName | Item name
Public property | KickedBy
Public property | Kills | Kills
Public property | KillsAway | Kills away
Public property | KillsHome | Kills home
Public property | LastHits | Last hits
Public property | LegScore | Used in darts Leg (game) score
Public property | Level | Level
Public property | MapName | Map name
Public property | MapNumber | Map number
Public property | MapScore | Map score
Public property | MatchScore | In tennis, the match score.
Public property | MatchStatus | The match status
Public property | MatchTime | Match time, mm:ss (e.g. 40:00 or 00:00).
Public property | MaxBreakFrame
Public property | MonsterType
Public property | MuffedBy
Public property | NetWorth | Net worth
Public property | NextBatter
Public property | Outs | Number of outs.
Public property | PassedBy
Public property | PenaltyDistance
Public property | PenaltyNoPlay
Public property | PenaltyReason
Public property | PentaKills | Penta kills
Public property | PeriodNumber | Period number of match.
Public property | PeriodScore | Period score.
Public property | PitchCount | Pitch count.
Public property | PitchingSubstitution
Public property | PitchSpeed | Gets how fast the ball was pitched in MPH numeric values
Public property | PitchType | Gets the type of how was the ball pitched
Public property | PlacedAt
Public property Player1Id Sportradar player id for player 1 connected to this event. The meaning of this attribute depends on event type:
  • 30 (goal): Goal scorer
  • 50, 40, 45 (red, yellow, yellow/red card): Who got card
  • 60 (substitution): Outgoing player
  • 154 (corner): Who took corner
  • 161 (penalty awarded): Who caused penalty – offender
  • 155, 156 (shot on/off target): Who shot
  • 153 (off side): Who was off side
  • 158 (injury): Who was injured
Public property Player2Id Sportradar player id for player 2 connected to this event. The meaning of this attribute depends on event type:
  • 60 (substitution): Incoming player
  • 161 (penalty awarded): Who was awarded a penalty
Public property Player3Id Sportradar player id for player 3 connected to this event. The meaning of this attribute depends on event type:
  • 30 (goal): player3 = Second assisting player
Public property Player4Id Sportradar player id for player 3 connected to this event. The meaning of this attribute depends on event type:
  • 30 (goal): player3 = Second assisting player
Public property | PointsRemaining
Public property | PointsUntilSnookerNeeded | Points until snooker needed
Public property | PositionPlayerPitching
Public property | PossibleBreak | Possible break
Public property | PosX | Horizontal position on pitch, posx being a number from 0 to 100. The reference point 0 is at home teams goal.
Public property | PosY | Vertical position on pitch, posy being a number from 0 to 100. The reference point 0 is on top of pitch when home teams goal is on the left hand side.
Public property | PreliminaryMatchStatistics
Public property | PrevPitcher
Public property | PuntDistance
Public property | PushedBy
Public property | QuadraKills | Quadra kills
Public property | RanOutOfBoundsAt
Public property | ReceivedAt
Public property | ReceivedBy
Public property | RecoveredAt
Public property | RecoveredBy
Public property | Reds
Public property | RefUuId
Public property | RemainingTimeInPeriod | Remaining time of match, mm:ss
Public property | RoundNumber | Round number
Public property | RoundScore
Public property | Runs | Number of runs.
Public property | RunsAway | Runs away
Public property | RunsHome | Runs home
Public property | RunsInInnings | Runs in innings
Public property | RushedBy
Public property | RushSpeed
Public property | SackedBy
Public property | SafetyBy
Public property | ScoreTypeQualifier
Public property | SecondBaseLoaded | Second base loaded
Public property | SecondBasePlayer
Public property | SecondScoreType | Seconds score type
Public property | Server | Serving team
Public property | ServerTime | Server time of event, time stamp in UTC.
Public property | SetNumber | In tennis, which set number in the match.
Public property | SetScore | In tennis, the set score.
Public property | ShotDistance
Public property | Side | Which side had an event - home, away or none.
Public property | SnappedBy
Public property | Spot
Public property | SpottedAt
Public property | StadiumType
Public property | Strikes | Number of strikes.
Public property | Structure
Public property | TackledBy
Public property | Temperature
Public property | ThirdBaseLoaded | Third loaded
Public property | ThirdBasePlayer
Public property | ThrownTo
Public property | TippedTo
Public property | TotalPitchCount
Public property | TotalYardsGained
Public property | TouchBackAt
Public property | TouchdownType | Gets the type of the touchdown.
Public property | TowerKills | Tower kills
Public property | TripleKills | Triple kills
Public property | TurfType
Public property | Type | Each event type has an id (e.g. yellow card 40, event deleted 1044, early bet status 1091, etc.). See LiveData documentation to see which event types are supported for each sport New event types can be offered in the future.
Public property | TypeId | Each event type has an id (e.g. yellow card 40, event deleted 1044, early bet status 1091, etc.). See LiveScout documentation to see which event types are supported for each sport. New event types can be offered in the future.
Public property | UnavailablePlayersAway
Public property | UnavailablePlayersHome
Public property | UuId
Public property | WardsPlaced
Public property | WeaponId | Weapon id
Public property | WeaponName | Weapon name
Public property | WindChill
Public property | WindDirection
Public property | WindSpeed
Public property | YardLine
Top
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ActualMatchStatistics Property

ScoutEventActualMatchStatistics Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.ActualMatchStatistics"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ActualMatchStatistics { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Assists Property

ScoutEventAssists Property

Assists

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Assists { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AtBatNumber Property

ScoutEventAtBatNumber Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AtBatNumber"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? AtBatNumber { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AtBatPitchNumber Property

ScoutEventAtBatPitchNumber Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AtBatPitchNumber"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? AtBatPitchNumber { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AttackingPlayers Property

ScoutEventAttackingPlayers Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AttackingPlayers"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AttackingPlayers { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Automatic Property

ScoutEventAutomatic Property

Identifies whether event was automatically generated automatically or not.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Automatic { get; }

Property Value

Nullable Int32
Remarks
Probably not useful.
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayPlayers Property

ScoutEventAwayPlayers Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayPlayers"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayPlayers { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayPlayerStatsDef Property

ScoutEventAwayPlayerStatsDef Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayPlayerStatsDef"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayPlayerStatsDef { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayPlayerStatsOt Property

ScoutEventAwayPlayerStatsOt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayPlayerStatsOt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayPlayerStatsOt { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayPlayerStatsP1 Property

ScoutEventAwayPlayerStatsP1 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayPlayerStatsP1"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayPlayerStatsP1 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayPlayerStatsP2 Property

ScoutEventAwayPlayerStatsP2 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayPlayerStatsP2"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayPlayerStatsP2 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayPlayerStatsP3 Property

ScoutEventAwayPlayerStatsP3 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayPlayerStatsP3"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayPlayerStatsP3 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayPlayerStatsP4 Property

ScoutEventAwayPlayerStatsP4 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayPlayerStatsP4"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayPlayerStatsP4 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayPlayerStatsPass Property

ScoutEventAwayPlayerStatsPass Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayPlayerStatsPass"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayPlayerStatsPass { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayPlayerStatsRec Property

ScoutEventAwayPlayerStatsRec Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayPlayerStatsRec"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayPlayerStatsRec { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayPlayerStatsRush Property

ScoutEventAwayPlayerStatsRush Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayPlayerStatsRush"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayPlayerStatsRush { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayPlayerStatsTotal Property

ScoutEventAwayPlayerStatsTotal Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayPlayerStatsTotal"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayPlayerStatsTotal { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayTeamStats Property

ScoutEventAwayTeamStats Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayTeamStats"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayTeamStats { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayTeamStatsOt Property

ScoutEventAwayTeamStatsOt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayTeamStatsOt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayTeamStatsOt { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayTeamStatsP1 Property

ScoutEventAwayTeamStatsP1 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayTeamStatsP1"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayTeamStatsP1 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayTeamStatsP2 Property

ScoutEventAwayTeamStatsP2 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayTeamStatsP2"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayTeamStatsP2 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayTeamStatsP3 Property

ScoutEventAwayTeamStatsP3 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayTeamStatsP3"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayTeamStatsP3 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayTeamStatsP4 Property

ScoutEventAwayTeamStatsP4 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayTeamStatsP4"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayTeamStatsP4 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayTeamStatsTotal Property

ScoutEventAwayTeamStatsTotal Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayTeamStatsTotal"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayTeamStatsTotal { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayTimeOnCourt Property

ScoutEventAwayTimeOnCourt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayTimeOnCourt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayTimeOnCourt { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.AwayTimeOnIce Property

ScoutEventAwayTimeOnIce Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.AwayTimeOnIce"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string AwayTimeOnIce { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BallNumber Property

ScoutEventBallNumber Property

Ball number

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string BallNumber { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Balls Property

ScoutEventBalls Property

Number of balls.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Balls { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BallSpotting Property

ScoutEventBallSpotting Property

Ball spotting

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? BallSpotting { get; }

Property Value

Nullable Boolean
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BaronKills Property

ScoutEventBaronKills Property

Baron kills

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int BaronKills { get; }

Property Value

Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BaseInfo Property

ScoutEventBaseInfo Property

Base info.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string BaseInfo { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BatBallAngle Property

ScoutEventBatBallAngle Property

Gets the angle of the ball, relative from the ground, as the ball leaves the bat

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double? BatBallAngle { get; }

Property Value

Nullable Double
The angle of the ball, relative from the ground, as the ball leaves the bat
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BatBallDirection Property

ScoutEventBatBallDirection Property

Gets the direction of the ball as it leaves the bat

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double? BatBallDirection { get; }

Property Value

Nullable Double
The direction of the ball as it leaves the bat
Remarks
-45 = left field bounds, 45 = right field bounds, 0 = straight forward
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BatBallDistance Property

ScoutEventBatBallDistance Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.BatBallDistance"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double? BatBallDistance { get; }

Property Value

Nullable Double
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BatBallSpeed Property

ScoutEventBatBallSpeed Property

Gets the speed at which the ball leaves the bat, mph

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double? BatBallSpeed { get; }

Property Value

Nullable Double
The speed at which the ball leaves the bat, mph
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BatBallX Property

ScoutEventBatBallX Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.BatBallX"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double? BatBallX { get; }

Property Value

Nullable Double
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BatBallY Property

ScoutEventBatBallY Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.BatBallY"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double? BatBallY { get; }

Property Value

Nullable Double
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BattingAverages Property

ScoutEventBattingAverages Property

Gets the batting averages.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string BattingAverages { get; }

Property Value

String
The batting averages.
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Behinds Property

ScoutEventBehinds Property

Gets the behinds

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Behinds { get; }

Property Value

String
The behinds
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BlockedBy Property

ScoutEventBlockedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.BlockedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string BlockedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.BreakScore Property

ScoutEventBreakScore Property

Break score

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string BreakScore { get; }

Property Value

String
Remarks
Used in snooker
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.CaughtBy Property

ScoutEventCaughtBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.CaughtBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string CaughtBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.CausedBy Property

ScoutEventCausedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.CausedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string CausedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ChampionDamage Property

ScoutEventChampionDamage Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.ChampionDamage"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? ChampionDamage { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Cloud Property

ScoutEventCloud Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.Cloud"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Cloud { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ConversionType Property

ScoutEventConversionType Property

Gets the type of the conversion.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int ConversionType { get; }

Property Value

Int32
The type of the conversion.
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.CorrectedFrom Property

ScoutEventCorrectedFrom Property

Corrected from, used with score correction event

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? CorrectedFrom { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.CorrectedTo Property

ScoutEventCorrectedTo Property

Corrected to, used with score correction event

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? CorrectedTo { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Damage Property

ScoutEventDamage Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.Damage"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Damage { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Deaths Property

ScoutEventDeaths Property

Deaths

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Deaths { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.DefensedBy Property

ScoutEventDefensedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.DefensedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string DefensedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Denies Property

ScoutEventDenies Property

Denies

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Denies { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Direction Property

ScoutEventDirection Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.Direction"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Direction { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.DismissalsInInnings Property

ScoutEventDismissalsInInnings Property

Dismissals in innings

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? DismissalsInInnings { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.DoubleKills Property

ScoutEventDoubleKills Property

Double kills

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int DoubleKills { get; }

Property Value

Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.DownedBy Property

ScoutEventDownedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.DownedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string DownedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.DragonKills Property

ScoutEventDragonKills Property

Dragon kills

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int DragonKills { get; }

Property Value

Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.DragonType Property

ScoutEventDragonType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.DragonType"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string DragonType { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.DriveInfoStatus Property

ScoutEventDriveInfoStatus Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.DriveInfoStatus"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string DriveInfoStatus { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.DrivePlayInfo Property

ScoutEventDrivePlayInfo Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.DrivePlayInfo"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string DrivePlayInfo { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.EarlyBetstartType Property

ScoutEventEarlyBetstartType Property

EarlyBetstartType

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? EarlyBetstartType { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.EndScore Property

ScoutEventEndScore Property

End score

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string EndScore { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Errors Property

ScoutEventErrors Property

Number of errors.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Errors { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ErrorsAway Property

ScoutEventErrorsAway Property

Errors away

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? ErrorsAway { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ErrorsHome Property

ScoutEventErrorsHome Property

Errors home

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? ErrorsHome { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Experience Property

ScoutEventExperience Property

Experience

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Experience { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfo Property

ScoutEventExtraInfo Property

Integer value, meaning of this attribute depends on event type:
  • 30 (score): 0 or -1 = not specified, 1 = penalty, 2 = own goal, 3 = header
  • 1019 (cancel goal): 0 or -1 = not specified, 1 = off side, 2 = foul, 3 = incorrect entry
  • 1013 (match status): match status enumeration
  • 1025 (tennis full score): tennis point type – 0=standard, 1=ace, 2=double fault opponent
  • 158 (injury): Player still injured – 1=yes, 0=no 165 (attendance): Attendance
  • 1039 (manual time adjustment): Number of seconds adjusted. Can be both a positive and a negative integer
  • 1044 (event deleted): Id of event that was deleted
  • 1037 (basketball points): Number of points scored – 1, 2 or 3
  • 1038 (basketball points missed): Point attempt missed – 1, 2 or 3 (points)
  • 1046 (volleyball full score): volleyball point type – 0=standard, 1=ace, 2=service error
  • 1056 (number of free throws): Number of free throws
  • 1036 (time start stop): 1 = time is running, 0 = time is stopped
  • 43 (suspensions): Number of minutes player is suspended for
  • 90 (injury time): Number of minutes injury time added
  • 1082 (corner markets): 1 = safe to accept bets, 0 = not safe
  • 1083 (booking markets): 1 = safe to accept bets, 0 = not safe
  • 1002 (penalty shootout): -1=penalty not taken, 1=penalty scored, 0=penalty missed
  • 1060 (direct free kick): -1 = not taken, 0 = miss, 1 = score
  • 1102 (coverage status): 0 - match covered, 1 - coverage abandoned (used when abandoning coverage after a match has started), 2 - match will not be covered (used when we are unable to cover a match that we were supposed to cover)
All counter event types (throw in count etc.): Number of events of this type for team specified by “side" attribute

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? ExtraInfo { get; }

Property Value

Nullable Int64
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoBaseball Property

ScoutEventExtraInfoBaseball Property

Extra info baseball.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoBaseball { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoBasketball Property

ScoutEventExtraInfoBasketball Property

Extra info for basketball game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoBasketball { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoBowls Property

ScoutEventExtraInfoBowls Property

Extra info for bowls game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoBowls { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoCricket Property

ScoutEventExtraInfoCricket Property

Extra info for cricket game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoCricket { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoCsGo Property

ScoutEventExtraInfoCsGo Property

Extra info for counter strike global offensive

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoCsGo { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoDarts Property

ScoutEventExtraInfoDarts Property

Extra info for dart game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoDarts { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoFootball Property

ScoutEventExtraInfoFootball Property

Extra info for football game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoFootball { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoHandball Property

ScoutEventExtraInfoHandball Property

Extra info for handball game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoHandball { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoIceHockey Property

ScoutEventExtraInfoIceHockey Property

Extra info ice hockey.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoIceHockey { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoKabaddi Property

ScoutEventExtraInfoKabaddi Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.ExtraInfoKabaddi"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoKabaddi { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoMoba Property

ScoutEventExtraInfoMoba Property

Extra info moba

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoMoba { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoSnooker Property

ScoutEventExtraInfoSnooker Property

Extra info for snooker game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoSnooker { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ExtraInfoVolleyball Property

ScoutEventExtraInfoVolleyball Property

Extra info for volleyball game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ExtraInfoVolleyball { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.FieldGoalDistance Property

ScoutEventFieldGoalDistance Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.FieldGoalDistance"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string FieldGoalDistance { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.FieldingPlayers Property

ScoutEventFieldingPlayers Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.FieldingPlayers"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string FieldingPlayers { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.FirstBaseLoaded Property

ScoutEventFirstBaseLoaded Property

First base loaded

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? FirstBaseLoaded { get; }

Property Value

Nullable Boolean
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.FirstBasePlayer Property

ScoutEventFirstBasePlayer Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.FirstBasePlayer"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? FirstBasePlayer { get; }

Property Value

Nullable Int64
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.FoulTypeDescriptor Property

ScoutEventFoulTypeDescriptor Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.FoulTypeDescriptor"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? FoulTypeDescriptor { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.FoulTypeQualifier Property

ScoutEventFoulTypeQualifier Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.FoulTypeQualifier"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string FoulTypeQualifier { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.FrameNumber Property

ScoutEventFrameNumber Property

Frame number

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? FrameNumber { get; }

Property Value

Nullable Int32
Remarks
Used in snooker
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.FrameScore Property

ScoutEventFrameScore Property

Frame score

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string FrameScore { get; }

Property Value

String
Remarks
Used in snooker
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.FreeKickReason Property

ScoutEventFreeKickReason Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.FreeKickReason"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int FreeKickReason { get; }

Property Value

Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.FumbledBy Property

ScoutEventFumbledBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.FumbledBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string FumbledBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.GameNumber Property

ScoutEventGameNumber Property

In tennis, which game number in the set.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? GameNumber { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.GameScore Property

ScoutEventGameScore Property

In tennis, the game score.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string GameScore { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Goals Property

ScoutEventGoals Property

Gets the goals

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Goals { get; }

Property Value

String
The goals
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HappenedAt Property

ScoutEventHappenedAt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HappenedAt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? HappenedAt { get; }

Property Value

Nullable Int64
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HealthRemaining Property

ScoutEventHealthRemaining Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HealthRemaining"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? HealthRemaining { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HeroesAliveAway Property

ScoutEventHeroesAliveAway Property

Level

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? HeroesAliveAway { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HeroesAliveHome Property

ScoutEventHeroesAliveHome Property

Heroes alive home

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? HeroesAliveHome { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HeroId Property

ScoutEventHeroId Property

Hero Id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? HeroId { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HeroName Property

ScoutEventHeroName Property

Hero Name

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HeroName { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HitsAway Property

ScoutEventHitsAway Property

Hits away

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? HitsAway { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HitsHome Property

ScoutEventHitsHome Property

Hits home

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? HitsHome { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomePlayers Property

ScoutEventHomePlayers Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomePlayers"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomePlayers { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomePlayerStatsDef Property

ScoutEventHomePlayerStatsDef Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomePlayerStatsDef"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomePlayerStatsDef { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomePlayerStatsOt Property

ScoutEventHomePlayerStatsOt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomePlayerStatsOt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomePlayerStatsOt { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomePlayerStatsP1 Property

ScoutEventHomePlayerStatsP1 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomePlayerStatsP1"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomePlayerStatsP1 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomePlayerStatsP2 Property

ScoutEventHomePlayerStatsP2 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomePlayerStatsP2"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomePlayerStatsP2 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomePlayerStatsP3 Property

ScoutEventHomePlayerStatsP3 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomePlayerStatsP3"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomePlayerStatsP3 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomePlayerStatsP4 Property

ScoutEventHomePlayerStatsP4 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomePlayerStatsP4"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomePlayerStatsP4 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomePlayerStatsPass Property

ScoutEventHomePlayerStatsPass Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomePlayerStatsPass"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomePlayerStatsPass { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomePlayerStatsRec Property

ScoutEventHomePlayerStatsRec Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomePlayerStatsRec"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomePlayerStatsRec { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomePlayerStatsRush Property

ScoutEventHomePlayerStatsRush Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomePlayerStatsRush"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomePlayerStatsRush { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomePlayerStatsTotal Property

ScoutEventHomePlayerStatsTotal Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomePlayerStatsTotal"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomePlayerStatsTotal { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomeRunsAway Property

ScoutEventHomeRunsAway Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomeRunsAway"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? HomeRunsAway { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomeRunsHome Property

ScoutEventHomeRunsHome Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomeRunsHome"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? HomeRunsHome { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomeTeamStats Property

ScoutEventHomeTeamStats Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomeTeamStats"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomeTeamStats { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomeTeamStatsOt Property

ScoutEventHomeTeamStatsOt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomeTeamStatsOt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomeTeamStatsOt { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomeTeamStatsP1 Property

ScoutEventHomeTeamStatsP1 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomeTeamStatsP1"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomeTeamStatsP1 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomeTeamStatsP2 Property

ScoutEventHomeTeamStatsP2 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomeTeamStatsP2"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomeTeamStatsP2 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomeTeamStatsP3 Property

ScoutEventHomeTeamStatsP3 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomeTeamStatsP3"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomeTeamStatsP3 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomeTeamStatsP4 Property

ScoutEventHomeTeamStatsP4 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomeTeamStatsP4"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomeTeamStatsP4 { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomeTeamStatsTotal Property

ScoutEventHomeTeamStatsTotal Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomeTeamStatsTotal"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomeTeamStatsTotal { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomeTimeOnCourt Property

ScoutEventHomeTimeOnCourt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomeTimeOnCourt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomeTimeOnCourt { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.HomeTimeOnIce Property

ScoutEventHomeTimeOnIce Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.HomeTimeOnIce"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HomeTimeOnIce { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Humidity Property

ScoutEventHumidity Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.Humidity"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Humidity { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Id Property

ScoutEventId Property

Unique event id.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long Id { get; }

Property Value

Int64
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Info Property

ScoutEventInfo Property

Text description of event.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Info { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.InhibitorKills Property

ScoutEventInhibitorKills Property

Inhibitor kills

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int InhibitorKills { get; }

Property Value

Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.InjuryPlayer Property

ScoutEventInjuryPlayer Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.InjuryPlayer"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string InjuryPlayer { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.InjuryReturn Property

ScoutEventInjuryReturn Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.InjuryReturn"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string InjuryReturn { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.InningHalf Property

ScoutEventInningHalf Property

Inning half.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Inning? InningHalf { get; }

Property Value

Nullable Inning
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.InningsScore Property

ScoutEventInningsScore Property

Innings scores

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public InningScore[] InningsScore { get; }

Property Value

InningScore
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.IntendedReceiver Property

ScoutEventIntendedReceiver Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.IntendedReceiver"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? IntendedReceiver { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.InterceptedBy Property

ScoutEventInterceptedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.InterceptedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string InterceptedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Inventory Property

ScoutEventInventory Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.Inventory"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Inventory { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Item Property

ScoutEventItem Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.Item"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Item { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ItemName Property

ScoutEventItemName Property

Item name

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ItemName { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.KickedBy Property

ScoutEventKickedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.KickedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string KickedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Kills Property

ScoutEventKills Property

Kills

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Kills { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.KillsAway Property

ScoutEventKillsAway Property

Kills away

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? KillsAway { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.KillsHome Property

ScoutEventKillsHome Property

Kills home

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? KillsHome { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.LastHits Property

ScoutEventLastHits Property

Last hits

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? LastHits { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.LegScore Property

ScoutEventLegScore Property

Used in darts Leg (game) score

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string LegScore { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Level Property

ScoutEventLevel Property

Level

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Level { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.MapName Property

ScoutEventMapName Property

Map name

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MapName { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.MapNumber Property

ScoutEventMapNumber Property

Map number

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? MapNumber { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.MapScore Property

ScoutEventMapScore Property

Map score

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MapScore { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.MatchScore Property

ScoutEventMatchScore Property

In tennis, the match score.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MatchScore { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.MatchStatus Property

ScoutEventMatchStatus Property

The match status

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MatchStatus { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.MatchTime Property

ScoutEventMatchTime Property

Match time, mm:ss (e.g. 40:00 or 00:00).

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MatchTime { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.MaxBreakFrame Property

ScoutEventMaxBreakFrame Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.MaxBreakFrame"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int MaxBreakFrame { get; }

Property Value

Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.MonsterType Property

ScoutEventMonsterType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.MonsterType"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MonsterType { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.MuffedBy Property

ScoutEventMuffedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.MuffedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MuffedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.NetWorth Property

ScoutEventNetWorth Property

Net worth

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? NetWorth { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.NextBatter Property

ScoutEventNextBatter Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.NextBatter"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? NextBatter { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Outs Property

ScoutEventOuts Property

Number of outs.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Outs { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PassedBy Property

ScoutEventPassedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.PassedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string PassedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PenaltyDistance Property

ScoutEventPenaltyDistance Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.PenaltyDistance"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string PenaltyDistance { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PenaltyNoPlay Property

ScoutEventPenaltyNoPlay Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.PenaltyNoPlay"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string PenaltyNoPlay { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PenaltyReason Property

ScoutEventPenaltyReason Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.PenaltyReason"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string PenaltyReason { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PentaKills Property

ScoutEventPentaKills Property

Penta kills

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int PentaKills { get; }

Property Value

Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PeriodNumber Property

ScoutEventPeriodNumber Property

Period number of match.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? PeriodNumber { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PeriodScore Property

ScoutEventPeriodScore Property

Period score.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string PeriodScore { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PitchCount Property

ScoutEventPitchCount Property

Pitch count.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? PitchCount { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PitchingSubstitution Property

ScoutEventPitchingSubstitution Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.PitchingSubstitution"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? PitchingSubstitution { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PitchSpeed Property

ScoutEventPitchSpeed Property

Gets how fast the ball was pitched in MPH numeric values

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double? PitchSpeed { get; }

Property Value

Nullable Double
The pitch speed.
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PitchType Property

ScoutEventPitchType Property

Gets the type of how was the ball pitched

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? PitchType { get; }

Property Value

Nullable Int32
The type of the pitch.
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PlacedAt Property

ScoutEventPlacedAt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.PlacedAt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string PlacedAt { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Player1Id Property

ScoutEventPlayer1Id Property

Sportradar player id for player 1 connected to this event. The meaning of this attribute depends on event type:
  • 30 (goal): Goal scorer
  • 50, 40, 45 (red, yellow, yellow/red card): Who got card
  • 60 (substitution): Outgoing player
  • 154 (corner): Who took corner
  • 161 (penalty awarded): Who caused penalty – offender
  • 155, 156 (shot on/off target): Who shot
  • 153 (off side): Who was off side
  • 158 (injury): Who was injured

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Player1Id { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Player2Id Property

ScoutEventPlayer2Id Property

Sportradar player id for player 2 connected to this event. The meaning of this attribute depends on event type:
  • 60 (substitution): Incoming player
  • 161 (penalty awarded): Who was awarded a penalty

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Player2Id { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Player3Id Property

ScoutEventPlayer3Id Property

Sportradar player id for player 3 connected to this event. The meaning of this attribute depends on event type:
  • 30 (goal): player3 = Second assisting player

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Player3Id { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Player4Id Property

ScoutEventPlayer4Id Property

Sportradar player id for player 3 connected to this event. The meaning of this attribute depends on event type:
  • 30 (goal): player3 = Second assisting player

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Player4Id { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PointsRemaining Property

ScoutEventPointsRemaining Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.PointsRemaining"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? PointsRemaining { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PointsUntilSnookerNeeded Property

ScoutEventPointsUntilSnookerNeeded Property

Points until snooker needed

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? PointsUntilSnookerNeeded { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PositionPlayerPitching Property

ScoutEventPositionPlayerPitching Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.PositionPlayerPitching"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool PositionPlayerPitching { get; }

Property Value

Boolean
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PossibleBreak Property

ScoutEventPossibleBreak Property

Possible break

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? PossibleBreak { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PosX Property

ScoutEventPosX Property

Horizontal position on pitch, posx being a number from 0 to 100. The reference point 0 is at home teams goal.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? PosX { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PosY Property

ScoutEventPosY Property

Vertical position on pitch, posy being a number from 0 to 100. The reference point 0 is on top of pitch when home teams goal is on the left hand side.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? PosY { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PreliminaryMatchStatistics Property

ScoutEventPreliminaryMatchStatistics Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.PreliminaryMatchStatistics"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string PreliminaryMatchStatistics { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PrevPitcher Property

ScoutEventPrevPitcher Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.PrevPitcher"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? PrevPitcher { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PuntDistance Property

ScoutEventPuntDistance Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.PuntDistance"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string PuntDistance { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.PushedBy Property

ScoutEventPushedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.PushedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string PushedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.QuadraKills Property

ScoutEventQuadraKills Property

Quadra kills

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int QuadraKills { get; }

Property Value

Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.RanOutOfBoundsAt Property

ScoutEventRanOutOfBoundsAt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.RanOutOfBoundsAt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string RanOutOfBoundsAt { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ReceivedAt Property

ScoutEventReceivedAt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.ReceivedAt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ReceivedAt { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ReceivedBy Property

ScoutEventReceivedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.ReceivedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ReceivedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.RecoveredAt Property

ScoutEventRecoveredAt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.RecoveredAt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string RecoveredAt { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.RecoveredBy Property

ScoutEventRecoveredBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.RecoveredBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string RecoveredBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Reds Property

ScoutEventReds Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.Reds"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Reds { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.RefUuId Property

ScoutEventRefUuId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.RefUuId"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string RefUuId { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.RemainingTimeInPeriod Property

ScoutEventRemainingTimeInPeriod Property

Remaining time of match, mm:ss

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string RemainingTimeInPeriod { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.RoundNumber Property

ScoutEventRoundNumber Property

Round number

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? RoundNumber { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.RoundScore Property

ScoutEventRoundScore Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.RoundScore"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string RoundScore { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Runs Property

ScoutEventRuns Property

Number of runs.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Runs { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.RunsAway Property

ScoutEventRunsAway Property

Runs away

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? RunsAway { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.RunsHome Property

ScoutEventRunsHome Property

Runs home

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? RunsHome { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.RunsInInnings Property

ScoutEventRunsInInnings Property

Runs in innings

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? RunsInInnings { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.RushedBy Property

ScoutEventRushedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.RushedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string RushedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.RushSpeed Property

ScoutEventRushSpeed Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.RushSpeed"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string RushSpeed { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.SackedBy Property

ScoutEventSackedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.SackedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SackedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.SafetyBy Property

ScoutEventSafetyBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.SafetyBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SafetyBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ScoreTypeQualifier Property

ScoutEventScoreTypeQualifier Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.ScoreTypeQualifier"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ScoreTypeQualifier { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.SecondBaseLoaded Property

ScoutEventSecondBaseLoaded Property

Second base loaded

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? SecondBaseLoaded { get; }

Property Value

Nullable Boolean
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.SecondBasePlayer Property

ScoutEventSecondBasePlayer Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.SecondBasePlayer"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? SecondBasePlayer { get; }

Property Value

Nullable Int64
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.SecondScoreType Property

ScoutEventSecondScoreType Property

Seconds score type

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? SecondScoreType { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Server Property

ScoutEventServer Property

Serving team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team? Server { get; }

Property Value

Nullable Team
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ServerTime Property

ScoutEventServerTime Property

Server time of event, time stamp in UTC.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DateTime ServerTime { get; }

Property Value

DateTime
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.SetNumber Property

ScoutEventSetNumber Property

In tennis, which set number in the match.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? SetNumber { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.SetScore Property

ScoutEventSetScore Property

In tennis, the set score.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SetScore { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ShotDistance Property

ScoutEventShotDistance Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.ShotDistance"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double? ShotDistance { get; }

Property Value

Nullable Double
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Side Property

ScoutEventSide Property

Which side had an event - home, away or none.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team Side { get; }

Property Value

Team
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.SnappedBy Property

ScoutEventSnappedBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.SnappedBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SnappedBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Spot Property

ScoutEventSpot Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.Spot"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Spot { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.SpottedAt Property

ScoutEventSpottedAt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.SpottedAt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SpottedAt { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.StadiumType Property

ScoutEventStadiumType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.StadiumType"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string StadiumType { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Strikes Property

ScoutEventStrikes Property

Number of strikes.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Strikes { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Structure Property

ScoutEventStructure Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.Structure"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Structure { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.TackledBy Property

ScoutEventTackledBy Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.TackledBy"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string TackledBy { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Temperature Property

ScoutEventTemperature Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.Temperature"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? Temperature { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ThirdBaseLoaded Property

ScoutEventThirdBaseLoaded Property

Third loaded

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? ThirdBaseLoaded { get; }

Property Value

Nullable Boolean
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ThirdBasePlayer Property

ScoutEventThirdBasePlayer Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.ThirdBasePlayer"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long? ThirdBasePlayer { get; }

Property Value

Nullable Int64
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ThrownTo Property

ScoutEventThrownTo Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.ThrownTo"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ThrownTo { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.TippedTo Property

ScoutEventTippedTo Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.TippedTo"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? TippedTo { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.TotalPitchCount Property

ScoutEventTotalPitchCount Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.TotalPitchCount"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? TotalPitchCount { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.TotalYardsGained Property

ScoutEventTotalYardsGained Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.TotalYardsGained"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? TotalYardsGained { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.TouchBackAt Property

ScoutEventTouchBackAt Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.TouchBackAt"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string TouchBackAt { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.TouchdownType Property

ScoutEventTouchdownType Property

Gets the type of the touchdown.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int TouchdownType { get; }

Property Value

Int32
The type of the touchdown.
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.TowerKills Property

ScoutEventTowerKills Property

Tower kills

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int TowerKills { get; }

Property Value

Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.TripleKills Property

ScoutEventTripleKills Property

Triple kills

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int TripleKills { get; }

Property Value

Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.TurfType Property

ScoutEventTurfType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.TurfType"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string TurfType { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.Type Property

ScoutEventType Property

Each event type has an id (e.g. yellow card 40, event deleted 1044, early bet status 1091, etc.). See LiveData documentation to see which event types are supported for each sport New event types can be offered in the future.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public EventType Type { get; }

Property Value

EventType
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.TypeId Property

ScoutEventTypeId Property

Each event type has an id (e.g. yellow card 40, event deleted 1044, early bet status 1091, etc.). See LiveScout documentation to see which event types are supported for each sport. New event types can be offered in the future.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int TypeId { get; }

Property Value

Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.UnavailablePlayersAway Property

ScoutEventUnavailablePlayersAway Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.UnavailablePlayersAway"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string UnavailablePlayersAway { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.UnavailablePlayersHome Property

ScoutEventUnavailablePlayersHome Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.UnavailablePlayersHome"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string UnavailablePlayersHome { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.UuId Property

ScoutEventUuId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.UuId"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string UuId { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.WardsPlaced Property

ScoutEventWardsPlaced Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.WardsPlaced"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? WardsPlaced { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.WeaponId Property

ScoutEventWeaponId Property

Weapon id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? WeaponId { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.WeaponName Property

ScoutEventWeaponName Property

Weapon name

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string WeaponName { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.WindChill Property

ScoutEventWindChill Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.WindChill"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? WindChill { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.WindDirection Property

ScoutEventWindDirection Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.WindDirection"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string WindDirection { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.WindSpeed Property

ScoutEventWindSpeed Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.WindSpeed"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? WindSpeed { get; }

Property Value

Nullable Int32
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.YardLine Property

ScoutEventYardLine Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.ScoutEvent.YardLine"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string YardLine { get; }

Property Value

String
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent Methods

The ScoutEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutEvent.ToString Method

ScoutEventToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

ScoutEvent Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutFeedType Class

Type of scout match information message (full, delta or deltaupdate).
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutScoutFeedType

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class ScoutFeedType : Enum

The ScoutFeedType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | DELTA | Delta message
 | DELTAUPDATE | Delta update message
 | FULL | Full message
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutFeedType Methods

The ScoutFeedType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

ScoutFeedType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutFeedType Fields

The ScoutFeedType type exposes the following members.

Fields
 | Name | Description
 | DELTA | Delta message
 | DELTAUPDATE | Delta update message
 | FULL | Full message
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

ScoutFeedType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutFeedType.DELTA Field

ScoutFeedTypeDELTA Field

Delta message

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutFeedType DELTA = 2

Field Value

ScoutFeedType
See Also

Reference

ScoutFeedType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutFeedType.DELTAUPDATE Field

ScoutFeedTypeDELTAUPDATE Field

Delta update message

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutFeedType DELTAUPDATE = 3

Field Value

ScoutFeedType
See Also

Reference

ScoutFeedType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutFeedType.FULL Field

ScoutFeedTypeFULL Field

Full message

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutFeedType FULL = 1

Field Value

ScoutFeedType
See Also

Reference

ScoutFeedType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutFeedType.UNDEFINED Field

ScoutFeedTypeUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutFeedType UNDEFINED = 0

Field Value

ScoutFeedType
See Also

Reference

ScoutFeedType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutFeedType.value__ Field

ScoutFeedTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.ScoutFeedType.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

ScoutFeedType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfo Class

Contains basic information about the match.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutScoutInfo

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ScoutInfo

The ScoutInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ScoutInfo | Initializes a new instance of the ScoutInfo class
Top
Properties
 | Name | Description
Public property | Header | Caption text.
Public property | Link | Whether this is URL or not.
Public property | Order | Sort order
Public property | Value | Info text. If Link is true then this is URL.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
Remarks
Could be that this information is only of interest for the flash scout client.
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfo Constructor

Initializes a new instance of the ScoutInfo class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoutInfo()
See Also

Reference

ScoutInfo Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfo Properties

The ScoutInfo type exposes the following members.

Properties
 | Name | Description
Public property | Header | Caption text.
Public property | Link | Whether this is URL or not.
Public property | Order | Sort order
Public property | Value | Info text. If Link is true then this is URL.
Top
See Also

Reference

ScoutInfo Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfo.Header Property

ScoutInfoHeader Property

Caption text.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Header { get; }

Property Value

String
See Also

Reference

ScoutInfo Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfo.Link Property

ScoutInfoLink Property

Whether this is URL or not.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool? Link { get; }

Property Value

Nullable Boolean
See Also

Reference

ScoutInfo Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfo.Order Property

ScoutInfoOrder Property

Sort order

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Order { get; }

Property Value

Int32
See Also

Reference

ScoutInfo Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfo.Value Property

ScoutInfoValue Property

Info text. If Link is true then this is URL.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Value { get; }

Property Value

String
See Also

Reference

ScoutInfo Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfo Methods

The ScoutInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

ScoutInfo Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfo.ToString Method

ScoutInfoToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

ScoutInfo Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfoEventArgs Class

Event arguments passed with OnScoutInfo.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.SDK.FeedProviders.LiveScoutScoutInfoEventArgs

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ScoutInfoEventArgs : EventArgs

The ScoutInfoEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ScoutInfoEventArgs | Initializes a new instance of the ScoutInfoEventArgs class
Top
Properties
 | Name | Description
Public property | MatchId | Match id
Public property | ScoutInfos | Basic information about the match
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfoEventArgs Constructor

Initializes a new instance of the ScoutInfoEventArgs class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoutInfoEventArgs()
See Also

Reference

ScoutInfoEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfoEventArgs Properties

The ScoutInfoEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MatchId | Match id
Public property | ScoutInfos | Basic information about the match
Top
See Also

Reference

ScoutInfoEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfoEventArgs.MatchId Property

ScoutInfoEventArgsMatchId Property

Match id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long MatchId { get; }

Property Value

Int64
See Also

Reference

ScoutInfoEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfoEventArgs.ScoutInfos Property

ScoutInfoEventArgsScoutInfos Property

Basic information about the match

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoutInfo[] ScoutInfos { get; }

Property Value

ScoutInfo
See Also

Reference

ScoutInfoEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfoEventArgs Methods

The ScoutInfoEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ScoutInfoEventArgs Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfos Class

Match information messages (e.g. Distance between teams, Pre-match avg. odds, etc.)
Inheritance Hierarchy
SystemObject
Sportradar.SDK.CommonEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutEntityBase
Sportradar.SDK.FeedProviders.LiveScoutScoutInfos

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class ScoutInfos : ScoutEntityBase

The ScoutInfos type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Infos | Collection of match information messages.
Public property | MatchId | Match id.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfos Properties

The ScoutInfos type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Contains any additional XML attributes found while parsing XML feed messages that are not supported with the current version of the data contracts. These are represented as an XML attribute name-value tuples. (Inherited from EntityBase)
Public property | Infos | Collection of match information messages.
Public property | MatchId | Match id.
Top
See Also

Reference

ScoutInfos Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfos.Infos Property

ScoutInfosInfos Property

Collection of match information messages.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<ScoutInfo> Infos { get; }

Property Value

List ScoutInfo
See Also

Reference

ScoutInfos Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfos.MatchId Property

ScoutInfosMatchId Property

Match id.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long MatchId { get; }

Property Value

Int64
See Also

Reference

ScoutInfos Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfos Methods

The ScoutInfos type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ScoutEntityBaseToString)
Top
See Also

Reference

ScoutInfos Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutInfos.ToString Method

ScoutInfosToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

ScoutInfos Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus Class

Match status as used by Live Odds. Not all match statuses are used by each sport.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutScoutMatchStatus

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class ScoutMatchStatus : Enum

The ScoutMatchStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | ABANDONED | The match has been abandoned
 | AFTER_GOLDEN_SET | The after golden set
 | AFTER_OT | Overtime is finished
 | AFTER_PENALTIES | Penalties are finished
 | AFTER_SD | After sudden death
 | AFTER_SUPER_OVER | After super over
 | AWAITING_GOLDEN_SET | The awaiting golden set
 | AWAITING_OT | Waiting for overtime to start
 | AWAITING_PENALTIES | Waiting for penalty shooting to start
 | AWAITING_SD | Awaiting sudden death
 | AWAITING_SUPER_OVER | Awaiting super over
 | BREAK_TOP1_BOTTOM1 | Break top 1 bottom 1
 | BREAK_TOP2_BOTTOM1 | Break top 2 bottom 1
 | BREAK_TOP2_BOTTOM2 | Break top 2 bottom 2
 | BREAK_TOP3_BOTTOM2 | Break top 3 bottom 2
 | BREAK_TOP3_BOTTOM3 | Break top 3 bottom 3
 | BREAK_TOP4_BOTTOM3 | Break top 4 bottom 3
 | BREAK_TOP4_BOTTOM4 | Break top 4 bottom 4
 | BREAK_TOP5_BOTTOM4 | Break top 5 bottom 4
 | BREAK_TOP5_BOTTOM5 | Break top 5 bottom 5
 | BREAK_TOP6_BOTTOM5 | Break top 6 bottom 5
 | BREAK_TOP6_BOTTOM6 | Break top 6 bottom 6
 | BREAK_TOP7_BOTTOM6 | Break top 7 bottom 6
 | BREAK_TOP7_BOTTOM7 | Break top 7 bottom 7
 | BREAK_TOP8_BOTTOM7 | Break top 8 bottom 7
 | BREAK_TOP8_BOTTOM8 | Break top 8 bottom 8
 | BREAK_TOP9_BOTTOM8 | Break top 9 bottom 8
 | BREAK_TOP9_BOTTOM9 | Break top 9 bottom 9
 | BREAK_TOPEI_BOTTOM7 | Break top extra inning bottom 7
 | BREAK_TOPEI_BOTTOM9 | Break top extra inning bottom 9
 | BREAK_TOPEI_BOTTOMEI | Break top extra inning bottom extra inning
 | CANCELLED | The match has been cancelled
 | DEFAULTED1 | Player 1 defaulted (e.g. by being disqualified or failing to attend the match)
 | DEFAULTED2 | Player 2 defaulted (e.g. by being disqualified or failing to attend the match)
 | DELAYED | The match start is delayed
 | EIGHTH_INNING_BOTTOM | Eighth inning bottom
 | EIGHTH_INNING_TOP | Eighth inning top
 | ENDED | The match has ended
 | EXTRA_INNING_BOTTOM | Extra inning bottom
 | EXTRA_INNING_TOP | Extra inning top
 | FIFTH_GAME | Fifth game
 | FIFTH_INNING_BOTTOM | Fifth inning bottom
 | FIFTH_INNING_TOP | Fifth inning top
 | FIFTH_MAP | Fifth map
 | FIFTH_PAUSE | 5th pause
 | FIFTH_PERIOD | 5th period of the match
 | FIFTH_SET | 5th set
 | FIRST_GAME | First game
 | FIRST_HALF | 1st half of the match
 | FIRST_HALF_OT | 1st half of overtime
 | FIRST_INNING_BOTTOM | First inning bottom
 | FIRST_INNING_TOP | First inning top
 | FIRST_INNINGS_AWAY_TEAM | First innings away team
 | FIRST_INNINGS_HOME_TEAM | First innings home team
 | FIRST_MAP | First map
 | FIRST_PAUSE | 1st pause
 | FIRST_PERIOD | 1st period of the match
 | FIRST_QUARTER | 1st quarter
 | FIRST_SET | 1st set
 | FOURTH_GAME | Fourth game
 | FOURTH_INNING_BOTTOM | Fourth inning bottom
 | FOURTH_INNING_TOP | Fourth inning top
 | FOURTH_MAP | Fourth map
 | FOURTH_PAUSE | 4th pause
 | FOURTH_PERIOD | 4th period of the match
 | FOURTH_QUARTER | 4th quarter
 | FOURTH_SET | 4th set
 | GOLDEN_SET | Golden set (volleyball and beach volleyball)
 | HALFTIME | Half time
 | IN_PROGRESS | In progress
 | INNINGS_BREAK | Innings break
 | INTERRUPTED | The match has been interrupted
 | LUNCH_BREAK | Lunch break
 | NINTH_INNING_BOTTOM | Ninth inning bottom
 | NINTH_INNING_TOP | Ninth inning top
 | NOT_STARTED | Not started yet
 | OT_HALFTIME | Pause between 1st and 2nd overtime period
 | OVERTIME | Match overtime
 | PAUSE | Match paused
 | PENALTY_SHOOTING | Penalty shooting
 | POSTPONED | The match has been postponed and will be played later.
 | RETIRED | Player retired
 | RETIRED1 | Player 1 retired
 | RETIRED2 | Player 2 retired
 | SECOND_GAME | Second game
 | SECOND_HALF | 2nd half of the match
 | SECOND_HALF_OT | 2nd half of overtime
 | SECOND_INNING_BOTTOM | Second inning bottom
 | SECOND_INNING_TOP | Second inning top
 | SECOND_INNINGS_AWAY_TEAM | Second innings away team
 | SECOND_INNINGS_HOME_TEAM | Second innings home team
 | SECOND_MAP | Second map
 | SECOND_PAUSE | 2nd pause
 | SECOND_PERIOD | 2nd period of the match
 | SECOND_QUARTER | 2nd quarter
 | SECOND_SET | 2nd set
 | SESSION_BREAK | Session break
 | SEVENTH_INNING_BOTTOM | Seventh inning bottom
 | SEVENTH_INNING_TOP | Seventh inning top
 | SEVENTH_MAP | Seventh map
 | SEVENTH_SET | 7th set
 | SIXTH_INNING_BOTTOM | Sixth inning bottom
 | SIXTH_INNING_TOP | Sixth inning top
 | SIXTH_MAP | Sixth map
 | SIXTH_PAUSE | 6th pause
 | SIXTH_SET | 6th set
 | STARTED | Match started
 | STUMPS | Stumps
 | SUDDEN_DEATH | Sudden death
 | SUPER_OVER_AWAY_TEAM | Super over away team
 | SUPER_OVER_BREAK | Super over break
 | SUPER_OVER_HOME_TEAM | Super over home team
 | TEA_BREAK | Tea break
 | THIRD_GAME | Third game
 | THIRD_INNING_BOTTOM | Third inning bottom
 | THIRD_INNING_TOP | Third inning top
 | THIRD_MAP | Third map
 | THIRD_PAUSE | 3rd pause
 | THIRD_PERIOD | 3rd period of the match
 | THIRD_QUARTER | 3rd quarter
 | THIRD_SET | 3rd set
 | UNDEFINED | Undefined
Public field | value__ |
 | WALKOVER | A walkover has been awarded
 | WALKOVER1 | Player 1 won by walkover
 | WALKOVER2 | Player 2 won by walkover
Top
Remarks
Match statuses used by the different sports:
  • Soccer: NOT_STARTED, FIRST_HALF, HALFTIME, SECOND_HALF, INTERRUPTED, ABANDONED, ENDED, AWAITING_OT, FIRST_HALF_OT, OT_HALFTIME, SECOND_HALF_OT, AFTER_OT, AWAITING_PENALTIES, PENALTY_SHOOTING, AFTER_PENALTIES
  • Ice Hockey: NOT_STARTED, FIRST_HALF, HALFTIME, SECOND_HALF, INTERRUPTED, ABANDONED, ENDED, AWAITING_OT, FIRST_HALF_OT, OT_HALFTIME, SECOND_HALF_OT, AFTER_OT, AWAITING_PENALTIES, PENALTY_SHOOTING, AFTER_PENALTIES
  • Tennis: NOT_STARTED, FIRST_SET, SECOND_SET, THIRD_SET, FOURTH_SET, FIFTH_SET, ENDED, WALKOVER1, WALKOVER2, RETIRED1, RETIRED2, DELAYED, INTERRUPTED, ABANDONED, DEFAULTED1, DEFAULTED2
  • Basketball: NOT_STARTED, FIRST_QUARTER, FIRST_PAUSE, SECOND_QUARTER, SECOND_PAUSE, THIRD_QUARTER, THIRD_PAUSE, FOURTH_QUARTER, ENDED, AWAITING_OT, OVERTIME, AFTER_OT, INTERRUPTED, ABANDONED
  • Volleyball: NOT_STARTED, FIRST_SET, FIRST_PAUSE, SECOND_SET, SECOND_PAUSE , THIRD_SET, THIRD_PAUSE, FOURTH_SET, FOURTH_PAUSE, FIFTH_SET, ENDED, GOLDEN_SET, WALKOVER1, WALKOVER2, RETIRED1, RETIRED2, DELAYED, INTERRUPTED, ABANDONED
  • Beach Volleyball: NOT_STARTED, FIRST_SET, FIRST_PAUSE, SECOND_SET, SECOND_PAUSE , THIRD_SET, ENDED, GOLDEN_SET, WALKOVER1, WALKOVER2, RETIRED1, RETIRED2, DELAYED, INTERRUPTED, ABANDONED
  • Handball: NOT_STARTED, FIRST_HALF, HALFTIME, SECOND_HALF, INTERRUPTED, ABANDONED, ENDED, AWAITING_OT, FIRST_HALF_OT, OT_HALFTIME, SECOND_HALF_OT, AFTER_OT, AWAITING_PENALTIES, PENALTY_SHOOTING, AFTER_PENALTIES
  • Futsal: NOT_STARTED, FIRST_HALF, HALFTIME, SECOND_HALF, INTERRUPTED, ABANDONED, ENDED, AWAITING_OT, FIRST_HALF_OT, OT_HALFTIME,SECOND_HALF_OT, AFTER_OT, AWAITING_PENALTIES, PENALTY_SHOOTING, AFTER_PENALTIES
  • Rugby union: NOT_STARTED, FIRST_HALF, HALFTIME, SECOND_HALF, AWAITING_OT, FIRST_HALF_OT, OT_HALFTIME,SECOND_HALF_OT, AFTER_OT, AWAITING_PENALTIES, PENALTY_SHOOTING, AFTER_PENALTIES, AWAITING_SD, SUDDEN_DEATH, AFTER_SD, ENDED, INTERRUPTED, ABANDONED, POSTPONED
  • Darts: NOT_STARTED, IN_PROGRESS, PAUSE, ENDED, WALKOVER1, WALKOVER2, RETIRED1, RETIRED2, DEFAULTED1, DEFAULTED2, DELAYED, INTERRUPTED, ABANDONED
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus Methods

The ScoutMatchStatus type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus Fields

The ScoutMatchStatus type exposes the following members.

Fields
 | Name | Description
 | ABANDONED | The match has been abandoned
 | AFTER_GOLDEN_SET | The after golden set
 | AFTER_OT | Overtime is finished
 | AFTER_PENALTIES | Penalties are finished
 | AFTER_SD | After sudden death
 | AFTER_SUPER_OVER | After super over
 | AWAITING_GOLDEN_SET | The awaiting golden set
 | AWAITING_OT | Waiting for overtime to start
 | AWAITING_PENALTIES | Waiting for penalty shooting to start
 | AWAITING_SD | Awaiting sudden death
 | AWAITING_SUPER_OVER | Awaiting super over
 | BREAK_TOP1_BOTTOM1 | Break top 1 bottom 1
 | BREAK_TOP2_BOTTOM1 | Break top 2 bottom 1
 | BREAK_TOP2_BOTTOM2 | Break top 2 bottom 2
 | BREAK_TOP3_BOTTOM2 | Break top 3 bottom 2
 | BREAK_TOP3_BOTTOM3 | Break top 3 bottom 3
 | BREAK_TOP4_BOTTOM3 | Break top 4 bottom 3
 | BREAK_TOP4_BOTTOM4 | Break top 4 bottom 4
 | BREAK_TOP5_BOTTOM4 | Break top 5 bottom 4
 | BREAK_TOP5_BOTTOM5 | Break top 5 bottom 5
 | BREAK_TOP6_BOTTOM5 | Break top 6 bottom 5
 | BREAK_TOP6_BOTTOM6 | Break top 6 bottom 6
 | BREAK_TOP7_BOTTOM6 | Break top 7 bottom 6
 | BREAK_TOP7_BOTTOM7 | Break top 7 bottom 7
 | BREAK_TOP8_BOTTOM7 | Break top 8 bottom 7
 | BREAK_TOP8_BOTTOM8 | Break top 8 bottom 8
 | BREAK_TOP9_BOTTOM8 | Break top 9 bottom 8
 | BREAK_TOP9_BOTTOM9 | Break top 9 bottom 9
 | BREAK_TOPEI_BOTTOM7 | Break top extra inning bottom 7
 | BREAK_TOPEI_BOTTOM9 | Break top extra inning bottom 9
 | BREAK_TOPEI_BOTTOMEI | Break top extra inning bottom extra inning
 | CANCELLED | The match has been cancelled
 | DEFAULTED1 | Player 1 defaulted (e.g. by being disqualified or failing to attend the match)
 | DEFAULTED2 | Player 2 defaulted (e.g. by being disqualified or failing to attend the match)
 | DELAYED | The match start is delayed
 | EIGHTH_INNING_BOTTOM | Eighth inning bottom
 | EIGHTH_INNING_TOP | Eighth inning top
 | ENDED | The match has ended
 | EXTRA_INNING_BOTTOM | Extra inning bottom
 | EXTRA_INNING_TOP | Extra inning top
 | FIFTH_GAME | Fifth game
 | FIFTH_INNING_BOTTOM | Fifth inning bottom
 | FIFTH_INNING_TOP | Fifth inning top
 | FIFTH_MAP | Fifth map
 | FIFTH_PAUSE | 5th pause
 | FIFTH_PERIOD | 5th period of the match
 | FIFTH_SET | 5th set
 | FIRST_GAME | First game
 | FIRST_HALF | 1st half of the match
 | FIRST_HALF_OT | 1st half of overtime
 | FIRST_INNING_BOTTOM | First inning bottom
 | FIRST_INNING_TOP | First inning top
 | FIRST_INNINGS_AWAY_TEAM | First innings away team
 | FIRST_INNINGS_HOME_TEAM | First innings home team
 | FIRST_MAP | First map
 | FIRST_PAUSE | 1st pause
 | FIRST_PERIOD | 1st period of the match
 | FIRST_QUARTER | 1st quarter
 | FIRST_SET | 1st set
 | FOURTH_GAME | Fourth game
 | FOURTH_INNING_BOTTOM | Fourth inning bottom
 | FOURTH_INNING_TOP | Fourth inning top
 | FOURTH_MAP | Fourth map
 | FOURTH_PAUSE | 4th pause
 | FOURTH_PERIOD | 4th period of the match
 | FOURTH_QUARTER | 4th quarter
 | FOURTH_SET | 4th set
 | GOLDEN_SET | Golden set (volleyball and beach volleyball)
 | HALFTIME | Half time
 | IN_PROGRESS | In progress
 | INNINGS_BREAK | Innings break
 | INTERRUPTED | The match has been interrupted
 | LUNCH_BREAK | Lunch break
 | NINTH_INNING_BOTTOM | Ninth inning bottom
 | NINTH_INNING_TOP | Ninth inning top
 | NOT_STARTED | Not started yet
 | OT_HALFTIME | Pause between 1st and 2nd overtime period
 | OVERTIME | Match overtime
 | PAUSE | Match paused
 | PENALTY_SHOOTING | Penalty shooting
 | POSTPONED | The match has been postponed and will be played later.
 | RETIRED | Player retired
 | RETIRED1 | Player 1 retired
 | RETIRED2 | Player 2 retired
 | SECOND_GAME | Second game
 | SECOND_HALF | 2nd half of the match
 | SECOND_HALF_OT | 2nd half of overtime
 | SECOND_INNING_BOTTOM | Second inning bottom
 | SECOND_INNING_TOP | Second inning top
 | SECOND_INNINGS_AWAY_TEAM | Second innings away team
 | SECOND_INNINGS_HOME_TEAM | Second innings home team
 | SECOND_MAP | Second map
 | SECOND_PAUSE | 2nd pause
 | SECOND_PERIOD | 2nd period of the match
 | SECOND_QUARTER | 2nd quarter
 | SECOND_SET | 2nd set
 | SESSION_BREAK | Session break
 | SEVENTH_INNING_BOTTOM | Seventh inning bottom
 | SEVENTH_INNING_TOP | Seventh inning top
 | SEVENTH_MAP | Seventh map
 | SEVENTH_SET | 7th set
 | SIXTH_INNING_BOTTOM | Sixth inning bottom
 | SIXTH_INNING_TOP | Sixth inning top
 | SIXTH_MAP | Sixth map
 | SIXTH_PAUSE | 6th pause
 | SIXTH_SET | 6th set
 | STARTED | Match started
 | STUMPS | Stumps
 | SUDDEN_DEATH | Sudden death
 | SUPER_OVER_AWAY_TEAM | Super over away team
 | SUPER_OVER_BREAK | Super over break
 | SUPER_OVER_HOME_TEAM | Super over home team
 | TEA_BREAK | Tea break
 | THIRD_GAME | Third game
 | THIRD_INNING_BOTTOM | Third inning bottom
 | THIRD_INNING_TOP | Third inning top
 | THIRD_MAP | Third map
 | THIRD_PAUSE | 3rd pause
 | THIRD_PERIOD | 3rd period of the match
 | THIRD_QUARTER | 3rd quarter
 | THIRD_SET | 3rd set
 | UNDEFINED | Undefined
Public field | value__ |
 | WALKOVER | A walkover has been awarded
 | WALKOVER1 | Player 1 won by walkover
 | WALKOVER2 | Player 2 won by walkover
Top
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.ABANDONED Field

ScoutMatchStatusABANDONED Field

The match has been abandoned

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus ABANDONED = 33

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.AFTER_GOLDEN_SET Field

ScoutMatchStatusAFTER_GOLDEN_SET Field

The after golden set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus AFTER_GOLDEN_SET = 124

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.AFTER_OT Field

ScoutMatchStatusAFTER_OT Field

Overtime is finished

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus AFTER_OT = 46

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.AFTER_PENALTIES Field

ScoutMatchStatusAFTER_PENALTIES Field

Penalties are finished

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus AFTER_PENALTIES = 47

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.AFTER_SD Field

ScoutMatchStatusAFTER_SD Field

After sudden death

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus AFTER_SD = 56

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.AFTER_SUPER_OVER Field

ScoutMatchStatusAFTER_SUPER_OVER Field

After super over

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus AFTER_SUPER_OVER = 65

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.AWAITING_GOLDEN_SET Field

ScoutMatchStatusAWAITING_GOLDEN_SET Field

The awaiting golden set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus AWAITING_GOLDEN_SET = 123

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.AWAITING_OT Field

ScoutMatchStatusAWAITING_OT Field

Waiting for overtime to start

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus AWAITING_OT = 43

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.AWAITING_PENALTIES Field

ScoutMatchStatusAWAITING_PENALTIES Field

Waiting for penalty shooting to start

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus AWAITING_PENALTIES = 45

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.AWAITING_SD Field

ScoutMatchStatusAWAITING_SD Field

Awaiting sudden death

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus AWAITING_SD = 55

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.AWAITING_SUPER_OVER Field

ScoutMatchStatusAWAITING_SUPER_OVER Field

Awaiting super over

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus AWAITING_SUPER_OVER = 62

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP1_BOTTOM1 Field

ScoutMatchStatusBREAK_TOP1_BOTTOM1 Field

Break top 1 bottom 1

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP1_BOTTOM1 = 72

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP2_BOTTOM1 Field

ScoutMatchStatusBREAK_TOP2_BOTTOM1 Field

Break top 2 bottom 1

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP2_BOTTOM1 = 74

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP2_BOTTOM2 Field

ScoutMatchStatusBREAK_TOP2_BOTTOM2 Field

Break top 2 bottom 2

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP2_BOTTOM2 = 76

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP3_BOTTOM2 Field

ScoutMatchStatusBREAK_TOP3_BOTTOM2 Field

Break top 3 bottom 2

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP3_BOTTOM2 = 78

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP3_BOTTOM3 Field

ScoutMatchStatusBREAK_TOP3_BOTTOM3 Field

Break top 3 bottom 3

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP3_BOTTOM3 = 80

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP4_BOTTOM3 Field

ScoutMatchStatusBREAK_TOP4_BOTTOM3 Field

Break top 4 bottom 3

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP4_BOTTOM3 = 82

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP4_BOTTOM4 Field

ScoutMatchStatusBREAK_TOP4_BOTTOM4 Field

Break top 4 bottom 4

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP4_BOTTOM4 = 84

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP5_BOTTOM4 Field

ScoutMatchStatusBREAK_TOP5_BOTTOM4 Field

Break top 5 bottom 4

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP5_BOTTOM4 = 86

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP5_BOTTOM5 Field

ScoutMatchStatusBREAK_TOP5_BOTTOM5 Field

Break top 5 bottom 5

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP5_BOTTOM5 = 88

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP6_BOTTOM5 Field

ScoutMatchStatusBREAK_TOP6_BOTTOM5 Field

Break top 6 bottom 5

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP6_BOTTOM5 = 90

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP6_BOTTOM6 Field

ScoutMatchStatusBREAK_TOP6_BOTTOM6 Field

Break top 6 bottom 6

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP6_BOTTOM6 = 92

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP7_BOTTOM6 Field

ScoutMatchStatusBREAK_TOP7_BOTTOM6 Field

Break top 7 bottom 6

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP7_BOTTOM6 = 94

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP7_BOTTOM7 Field

ScoutMatchStatusBREAK_TOP7_BOTTOM7 Field

Break top 7 bottom 7

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP7_BOTTOM7 = 96

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP8_BOTTOM7 Field

ScoutMatchStatusBREAK_TOP8_BOTTOM7 Field

Break top 8 bottom 7

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP8_BOTTOM7 = 98

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP8_BOTTOM8 Field

ScoutMatchStatusBREAK_TOP8_BOTTOM8 Field

Break top 8 bottom 8

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP8_BOTTOM8 = 100

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP9_BOTTOM8 Field

ScoutMatchStatusBREAK_TOP9_BOTTOM8 Field

Break top 9 bottom 8

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP9_BOTTOM8 = 102

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOP9_BOTTOM9 Field

ScoutMatchStatusBREAK_TOP9_BOTTOM9 Field

Break top 9 bottom 9

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOP9_BOTTOM9 = 104

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOPEI_BOTTOM7 Field

ScoutMatchStatusBREAK_TOPEI_BOTTOM7 Field

Break top extra inning bottom 7

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOPEI_BOTTOM7 = 106

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOPEI_BOTTOM9 Field

ScoutMatchStatusBREAK_TOPEI_BOTTOM9 Field

Break top extra inning bottom 9

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOPEI_BOTTOM9 = 107

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.BREAK_TOPEI_BOTTOMEI Field

ScoutMatchStatusBREAK_TOPEI_BOTTOMEI Field

Break top extra inning bottom extra inning

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus BREAK_TOPEI_BOTTOMEI = 109

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.CANCELLED Field

ScoutMatchStatusCANCELLED Field

The match has been cancelled

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus CANCELLED = 31

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.DEFAULTED1 Field

ScoutMatchStatusDEFAULTED1 Field

Player 1 defaulted (e.g. by being disqualified or failing to attend the match)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus DEFAULTED1 = 40

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.DEFAULTED2 Field

ScoutMatchStatusDEFAULTED2 Field

Player 2 defaulted (e.g. by being disqualified or failing to attend the match)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus DEFAULTED2 = 41

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.DELAYED Field

ScoutMatchStatusDELAYED Field

The match start is delayed

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus DELAYED = 30

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.EIGHTH_INNING_BOTTOM Field

ScoutMatchStatusEIGHTH_INNING_BOTTOM Field

Eighth inning bottom

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus EIGHTH_INNING_BOTTOM = 101

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.EIGHTH_INNING_TOP Field

ScoutMatchStatusEIGHTH_INNING_TOP Field

Eighth inning top

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus EIGHTH_INNING_TOP = 99

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.ENDED Field

ScoutMatchStatusENDED Field

The match has ended

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus ENDED = 42

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.EXTRA_INNING_BOTTOM Field

ScoutMatchStatusEXTRA_INNING_BOTTOM Field

Extra inning bottom

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus EXTRA_INNING_BOTTOM = 110

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.EXTRA_INNING_TOP Field

ScoutMatchStatusEXTRA_INNING_TOP Field

Extra inning top

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus EXTRA_INNING_TOP = 108

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIFTH_GAME Field

ScoutMatchStatusFIFTH_GAME Field

Fifth game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIFTH_GAME = 122

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIFTH_INNING_BOTTOM Field

ScoutMatchStatusFIFTH_INNING_BOTTOM Field

Fifth inning bottom

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIFTH_INNING_BOTTOM = 89

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIFTH_INNING_TOP Field

ScoutMatchStatusFIFTH_INNING_TOP Field

Fifth inning top

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIFTH_INNING_TOP = 87

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIFTH_MAP Field

ScoutMatchStatusFIFTH_MAP Field

Fifth map

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIFTH_MAP = 115

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIFTH_PAUSE Field

ScoutMatchStatusFIFTH_PAUSE Field

5th pause

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIFTH_PAUSE = 52

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIFTH_PERIOD Field

ScoutMatchStatusFIFTH_PERIOD Field

5th period of the match

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIFTH_PERIOD = 6

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIFTH_SET Field

ScoutMatchStatusFIFTH_SET Field

5th set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIFTH_SET = 13

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIRST_GAME Field

ScoutMatchStatusFIRST_GAME Field

First game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIRST_GAME = 118

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIRST_HALF Field

ScoutMatchStatusFIRST_HALF Field

1st half of the match

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIRST_HALF = 7

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIRST_HALF_OT Field

ScoutMatchStatusFIRST_HALF_OT Field

1st half of overtime

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIRST_HALF_OT = 26

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIRST_INNING_BOTTOM Field

ScoutMatchStatusFIRST_INNING_BOTTOM Field

First inning bottom

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIRST_INNING_BOTTOM = 73

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIRST_INNING_TOP Field

ScoutMatchStatusFIRST_INNING_TOP Field

First inning top

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIRST_INNING_TOP = 71

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIRST_INNINGS_AWAY_TEAM Field

ScoutMatchStatusFIRST_INNINGS_AWAY_TEAM Field

First innings away team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIRST_INNINGS_AWAY_TEAM = 59

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIRST_INNINGS_HOME_TEAM Field

ScoutMatchStatusFIRST_INNINGS_HOME_TEAM Field

First innings home team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIRST_INNINGS_HOME_TEAM = 58

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIRST_MAP Field

ScoutMatchStatusFIRST_MAP Field

First map

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIRST_MAP = 111

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIRST_PAUSE Field

ScoutMatchStatusFIRST_PAUSE Field

1st pause

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIRST_PAUSE = 48

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIRST_PERIOD Field

ScoutMatchStatusFIRST_PERIOD Field

1st period of the match

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIRST_PERIOD = 2

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIRST_QUARTER Field

ScoutMatchStatusFIRST_QUARTER Field

1st quarter

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIRST_QUARTER = 16

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FIRST_SET Field

ScoutMatchStatusFIRST_SET Field

1st set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FIRST_SET = 9

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FOURTH_GAME Field

ScoutMatchStatusFOURTH_GAME Field

Fourth game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FOURTH_GAME = 121

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FOURTH_INNING_BOTTOM Field

ScoutMatchStatusFOURTH_INNING_BOTTOM Field

Fourth inning bottom

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FOURTH_INNING_BOTTOM = 85

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FOURTH_INNING_TOP Field

ScoutMatchStatusFOURTH_INNING_TOP Field

Fourth inning top

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FOURTH_INNING_TOP = 83

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FOURTH_MAP Field

ScoutMatchStatusFOURTH_MAP Field

Fourth map

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FOURTH_MAP = 114

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FOURTH_PAUSE Field

ScoutMatchStatusFOURTH_PAUSE Field

4th pause

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FOURTH_PAUSE = 51

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FOURTH_PERIOD Field

ScoutMatchStatusFOURTH_PERIOD Field

4th period of the match

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FOURTH_PERIOD = 5

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FOURTH_QUARTER Field

ScoutMatchStatusFOURTH_QUARTER Field

4th quarter

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FOURTH_QUARTER = 19

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.FOURTH_SET Field

ScoutMatchStatusFOURTH_SET Field

4th set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus FOURTH_SET = 12

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.GOLDEN_SET Field

ScoutMatchStatusGOLDEN_SET Field

Golden set (volleyball and beach volleyball)

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus GOLDEN_SET = 20

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.HALFTIME Field

ScoutMatchStatusHALFTIME Field

Half time

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus HALFTIME = 24

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.IN_PROGRESS Field

ScoutMatchStatusIN_PROGRESS Field

In progress

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus IN_PROGRESS = 22

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.INNINGS_BREAK Field

ScoutMatchStatusINNINGS_BREAK Field

Innings break

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus INNINGS_BREAK = 66

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.INTERRUPTED Field

ScoutMatchStatusINTERRUPTED Field

The match has been interrupted

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus INTERRUPTED = 32

Field Value

ScoutMatchStatus
Remarks
Interrupted after start, will continue later. If the match cannot be continued, it will then be abandoned.
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.LUNCH_BREAK Field

ScoutMatchStatusLUNCH_BREAK Field

Lunch break

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus LUNCH_BREAK = 68

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.NINTH_INNING_BOTTOM Field

ScoutMatchStatusNINTH_INNING_BOTTOM Field

Ninth inning bottom

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus NINTH_INNING_BOTTOM = 105

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.NINTH_INNING_TOP Field

ScoutMatchStatusNINTH_INNING_TOP Field

Ninth inning top

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus NINTH_INNING_TOP = 103

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.NOT_STARTED Field

ScoutMatchStatusNOT_STARTED Field

Not started yet

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus NOT_STARTED = 1

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.OT_HALFTIME Field

ScoutMatchStatusOT_HALFTIME Field

Pause between 1st and 2nd overtime period

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus OT_HALFTIME = 44

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.OVERTIME Field

ScoutMatchStatusOVERTIME Field

Match overtime

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus OVERTIME = 25

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.PAUSE Field

ScoutMatchStatusPAUSE Field

Match paused

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus PAUSE = 23

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.PENALTY_SHOOTING Field

ScoutMatchStatusPENALTY_SHOOTING Field

Penalty shooting

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus PENALTY_SHOOTING = 28

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.POSTPONED Field

ScoutMatchStatusPOSTPONED Field

The match has been postponed and will be played later.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus POSTPONED = 29

Field Value

ScoutMatchStatus
Remarks
Signals a significant delay (will not be played on the same day), in which case a new match (with a different match ID) will be created.
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.RETIRED Field

ScoutMatchStatusRETIRED Field

Player retired

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus RETIRED = 35

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.RETIRED1 Field

ScoutMatchStatusRETIRED1 Field

Player 1 retired

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus RETIRED1 = 38

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.RETIRED2 Field

ScoutMatchStatusRETIRED2 Field

Player 2 retired

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus RETIRED2 = 39

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SECOND_GAME Field

ScoutMatchStatusSECOND_GAME Field

Second game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SECOND_GAME = 119

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SECOND_HALF Field

ScoutMatchStatusSECOND_HALF Field

2nd half of the match

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SECOND_HALF = 8

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SECOND_HALF_OT Field

ScoutMatchStatusSECOND_HALF_OT Field

2nd half of overtime

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SECOND_HALF_OT = 27

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SECOND_INNING_BOTTOM Field

ScoutMatchStatusSECOND_INNING_BOTTOM Field

Second inning bottom

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SECOND_INNING_BOTTOM = 77

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SECOND_INNING_TOP Field

ScoutMatchStatusSECOND_INNING_TOP Field

Second inning top

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SECOND_INNING_TOP = 75

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SECOND_INNINGS_AWAY_TEAM Field

ScoutMatchStatusSECOND_INNINGS_AWAY_TEAM Field

Second innings away team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SECOND_INNINGS_AWAY_TEAM = 61

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SECOND_INNINGS_HOME_TEAM Field

ScoutMatchStatusSECOND_INNINGS_HOME_TEAM Field

Second innings home team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SECOND_INNINGS_HOME_TEAM = 60

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SECOND_MAP Field

ScoutMatchStatusSECOND_MAP Field

Second map

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SECOND_MAP = 112

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SECOND_PAUSE Field

ScoutMatchStatusSECOND_PAUSE Field

2nd pause

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SECOND_PAUSE = 49

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SECOND_PERIOD Field

ScoutMatchStatusSECOND_PERIOD Field

2nd period of the match

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SECOND_PERIOD = 3

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SECOND_QUARTER Field

ScoutMatchStatusSECOND_QUARTER Field

2nd quarter

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SECOND_QUARTER = 17

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SECOND_SET Field

ScoutMatchStatusSECOND_SET Field

2nd set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SECOND_SET = 10

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SESSION_BREAK Field

ScoutMatchStatusSESSION_BREAK Field

Session break

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SESSION_BREAK = 57

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SEVENTH_INNING_BOTTOM Field

ScoutMatchStatusSEVENTH_INNING_BOTTOM Field

Seventh inning bottom

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SEVENTH_INNING_BOTTOM = 97

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SEVENTH_INNING_TOP Field

ScoutMatchStatusSEVENTH_INNING_TOP Field

Seventh inning top

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SEVENTH_INNING_TOP = 95

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SEVENTH_MAP Field

ScoutMatchStatusSEVENTH_MAP Field

Seventh map

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SEVENTH_MAP = 117

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SEVENTH_SET Field

ScoutMatchStatusSEVENTH_SET Field

7th set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SEVENTH_SET = 15

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SIXTH_INNING_BOTTOM Field

ScoutMatchStatusSIXTH_INNING_BOTTOM Field

Sixth inning bottom

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SIXTH_INNING_BOTTOM = 93

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SIXTH_INNING_TOP Field

ScoutMatchStatusSIXTH_INNING_TOP Field

Sixth inning top

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SIXTH_INNING_TOP = 91

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SIXTH_MAP Field

ScoutMatchStatusSIXTH_MAP Field

Sixth map

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SIXTH_MAP = 116

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SIXTH_PAUSE Field

ScoutMatchStatusSIXTH_PAUSE Field

6th pause

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SIXTH_PAUSE = 53

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SIXTH_SET Field

ScoutMatchStatusSIXTH_SET Field

6th set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SIXTH_SET = 14

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.STARTED Field

ScoutMatchStatusSTARTED Field

Match started

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus STARTED = 21

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.STUMPS Field

ScoutMatchStatusSTUMPS Field

Stumps

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus STUMPS = 70

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SUDDEN_DEATH Field

ScoutMatchStatusSUDDEN_DEATH Field

Sudden death

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SUDDEN_DEATH = 54

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SUPER_OVER_AWAY_TEAM Field

ScoutMatchStatusSUPER_OVER_AWAY_TEAM Field

Super over away team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SUPER_OVER_AWAY_TEAM = 64

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SUPER_OVER_BREAK Field

ScoutMatchStatusSUPER_OVER_BREAK Field

Super over break

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SUPER_OVER_BREAK = 67

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.SUPER_OVER_HOME_TEAM Field

ScoutMatchStatusSUPER_OVER_HOME_TEAM Field

Super over home team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus SUPER_OVER_HOME_TEAM = 63

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.TEA_BREAK Field

ScoutMatchStatusTEA_BREAK Field

Tea break

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus TEA_BREAK = 69

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.THIRD_GAME Field

ScoutMatchStatusTHIRD_GAME Field

Third game

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus THIRD_GAME = 120

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.THIRD_INNING_BOTTOM Field

ScoutMatchStatusTHIRD_INNING_BOTTOM Field

Third inning bottom

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus THIRD_INNING_BOTTOM = 81

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.THIRD_INNING_TOP Field

ScoutMatchStatusTHIRD_INNING_TOP Field

Third inning top

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus THIRD_INNING_TOP = 79

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.THIRD_MAP Field

ScoutMatchStatusTHIRD_MAP Field

Third map

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus THIRD_MAP = 113

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.THIRD_PAUSE Field

ScoutMatchStatusTHIRD_PAUSE Field

3rd pause

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus THIRD_PAUSE = 50

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.THIRD_PERIOD Field

ScoutMatchStatusTHIRD_PERIOD Field

3rd period of the match

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus THIRD_PERIOD = 4

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.THIRD_QUARTER Field

ScoutMatchStatusTHIRD_QUARTER Field

3rd quarter

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus THIRD_QUARTER = 18

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.THIRD_SET Field

ScoutMatchStatusTHIRD_SET Field

3rd set

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus THIRD_SET = 11

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.UNDEFINED Field

ScoutMatchStatusUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus UNDEFINED = 0

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.value__ Field

ScoutMatchStatusvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.ScoutMatchStatus.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.WALKOVER Field

ScoutMatchStatusWALKOVER Field

A walkover has been awarded

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus WALKOVER = 34

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.WALKOVER1 Field

ScoutMatchStatusWALKOVER1 Field

Player 1 won by walkover

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus WALKOVER1 = 36

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatus.WALKOVER2 Field

ScoutMatchStatusWALKOVER2 Field

Player 2 won by walkover

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const ScoutMatchStatus WALKOVER2 = 37

Field Value

ScoutMatchStatus
See Also

Reference

ScoutMatchStatus Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatusClasses Class

Group ScoutMatchStatus in to different classes.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutScoutMatchStatusClasses

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class ScoutMatchStatusClasses

The ScoutMatchStatusClasses type exposes the following members.

Constructors
 | Name | Description
Public method | ScoutMatchStatusClasses | Initializes a new instance of the ScoutMatchStatusClasses class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Fields
Name | Description
DELAYED | An unexpected delay has occurred on the match.
TERMINAL | Terminal states.
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatusClasses Constructor

Initializes a new instance of the ScoutMatchStatusClasses class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoutMatchStatusClasses()
See Also

Reference

ScoutMatchStatusClasses Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatusClasses Methods

The ScoutMatchStatusClasses type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ScoutMatchStatusClasses Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatusClasses Fields

The ScoutMatchStatusClasses type exposes the following members.

Fields
Name | Description
DELAYED | An unexpected delay has occurred on the match.
TERMINAL | Terminal states.
Top
See Also

Reference

ScoutMatchStatusClasses Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatusClasses.DELAYED Field

ScoutMatchStatusClassesDELAYED Field

An unexpected delay has occurred on the match.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly ScoutMatchStatus[] DELAYED

Field Value

ScoutMatchStatus
Remarks
You should not purge such matches in that state.
See Also

Reference

ScoutMatchStatusClasses Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


ScoutMatchStatusClasses.TERMINAL Field

ScoutMatchStatusClassesTERMINAL Field

Terminal states.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly ScoutMatchStatus[] TERMINAL

Field Value

ScoutMatchStatus
Remarks
The match is no longer interesting for us after the transition to that state.
See Also

Reference

ScoutMatchStatusClasses Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Sex Class

Sex (gender) of the contestant or the whole team.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutSex

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class Sex : Enum

The Sex type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | FEMALE | Female team or contestant.
 | MALE | Male team or contestant.
 | MIXED | Mixed team.
 | UNDEFINED | Undefined.
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Sex Methods

The Sex type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

Sex Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Sex Fields

The Sex type exposes the following members.

Fields
 | Name | Description
 | FEMALE | Female team or contestant.
 | MALE | Male team or contestant.
 | MIXED | Mixed team.
 | UNDEFINED | Undefined.
Public field | value__ |
Top
See Also

Reference

Sex Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Sex.FEMALE Field

SexFEMALE Field

Female team or contestant.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Sex FEMALE = 2

Field Value

Sex
See Also

Reference

Sex Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Sex.MALE Field

SexMALE Field

Male team or contestant.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Sex MALE = 1

Field Value

Sex
See Also

Reference

Sex Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Sex.MIXED Field

SexMIXED Field

Mixed team.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Sex MIXED = 3

Field Value

Sex
See Also

Reference

Sex Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Sex.UNDEFINED Field

SexUNDEFINED Field

Undefined.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const Sex UNDEFINED = 0

Field Value

Sex
See Also

Reference

Sex Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Sex.value__ Field

Sexvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.Sex.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

Sex Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


SurfaceType Class

Type of surface
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutSurfaceType

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class SurfaceType : Enum

The SurfaceType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | CARPET | Carpet
 | GRASS | Grass
 | HARDCOURT | Hard court
 | SAND | Sand
 | UNDEFINED | Undefined
 | UNKNOWN | Unknown
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


SurfaceType Methods

The SurfaceType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

SurfaceType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


SurfaceType Fields

The SurfaceType type exposes the following members.

Fields
 | Name | Description
 | CARPET | Carpet
 | GRASS | Grass
 | HARDCOURT | Hard court
 | SAND | Sand
 | UNDEFINED | Undefined
 | UNKNOWN | Unknown
Public field | value__ |
Top
See Also

Reference

SurfaceType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


SurfaceType.CARPET Field

SurfaceTypeCARPET Field

Carpet

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const SurfaceType CARPET = 4

Field Value

SurfaceType
See Also

Reference

SurfaceType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


SurfaceType.GRASS Field

SurfaceTypeGRASS Field

Grass

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const SurfaceType GRASS = 3

Field Value

SurfaceType
See Also

Reference

SurfaceType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


SurfaceType.HARDCOURT Field

SurfaceTypeHARDCOURT Field

Hard court

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const SurfaceType HARDCOURT = 2

Field Value

SurfaceType
See Also

Reference

SurfaceType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


SurfaceType.SAND Field

SurfaceTypeSAND Field

Sand

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const SurfaceType SAND = 1

Field Value

SurfaceType
See Also

Reference

SurfaceType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


SurfaceType.UNDEFINED Field

SurfaceTypeUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const SurfaceType UNDEFINED = 0

Field Value

SurfaceType
See Also

Reference

SurfaceType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


SurfaceType.UNKNOWN Field

SurfaceTypeUNKNOWN Field

Unknown

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const SurfaceType UNKNOWN = 5

Field Value

SurfaceType
See Also

Reference

SurfaceType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


SurfaceType.value__ Field

SurfaceTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.SurfaceType.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

SurfaceType Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Suspensions Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveScout.Suspensions"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutSuspensions

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Suspensions

The Suspensions type exposes the following members.

Constructors
 | Name | Description
Public method | Suspensions | Initializes a new instance of the Suspensions class
Top
Properties
 | Name | Description
Public property | PowerPlay |
Public property | Team1 |
Public property | Team2 |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


Suspensions Constructor

Initializes a new instance of the Suspensions class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Suspensions()
See Also

Reference

Suspensions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Suspensions Properties

The Suspensions type exposes the following members.

Properties
 | Name | Description
Public property | PowerPlay |
Public property | Team1 |
Public property | Team2 |
Top
See Also

Reference

Suspensions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Suspensions.PowerPlay Property

SuspensionsPowerPlay Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.Suspensions.PowerPlay"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team PowerPlay { get; }

Property Value

Team
See Also

Reference

Suspensions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Suspensions.Team1 Property

SuspensionsTeam1 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.Suspensions.Team1"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Team1 { get; }

Property Value

Int32
See Also

Reference

Suspensions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Suspensions.Team2 Property

SuspensionsTeam2 Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.Suspensions.Team2"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Team2 { get; }

Property Value

Int32
See Also

Reference

Suspensions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Suspensions Methods

The Suspensions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Suspensions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Suspensions.ToString Method

SuspensionsToString Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Suspensions.ToString"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Suspensions.ToString"]

See Also

Reference

Suspensions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


TeamOffical Class

Team offical
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScoutTeamOffical

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class TeamOffical

The TeamOffical type exposes the following members.

Constructors
 | Name | Description
Public method | TeamOffical | Initializes a new instance of the TeamOffical class
Top
Properties
 | Name | Description
Public property | Id | Manager id
Public property | Name | Manager name
Public property | Team | Home or Away team
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


TeamOffical Constructor

Initializes a new instance of the TeamOffical class

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TeamOffical()
See Also

Reference

TeamOffical Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


TeamOffical Properties

The TeamOffical type exposes the following members.

Properties
 | Name | Description
Public property | Id | Manager id
Public property | Name | Manager name
Public property | Team | Home or Away team
Top
See Also

Reference

TeamOffical Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


TeamOffical.Id Property

TeamOfficalId Property

Manager id

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

TeamOffical Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


TeamOffical.Name Property

TeamOfficalName Property

Manager name

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; }

Property Value

String
See Also

Reference

TeamOffical Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


TeamOffical.Team Property

TeamOfficalTeam Property

Home or Away team

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Team Team { get; }

Property Value

Team
See Also

Reference

TeamOffical Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


TeamOffical Methods

The TeamOffical type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

TeamOffical Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


TeamOffical.ToString Method

TeamOfficalToString Method

Returns a string that represents the current object.

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
Remarks
Can be used for diagnostics purposes.
See Also

Reference

TeamOffical Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


WeatherConditions Class

Weather conditions
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScoutWeatherConditions

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class WeatherConditions : Enum

The WeatherConditions type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | BAD | Bad
 | EXTREME | Extreme
 | GOOD | Good
 | INDOOR | Indoor
 | MEDIUM | Medium
 | UNDEFINED | Undefined
 | UNKNOWN | Unknown
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout Namespace


WeatherConditions Methods

The WeatherConditions type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

WeatherConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


WeatherConditions Fields

The WeatherConditions type exposes the following members.

Fields
 | Name | Description
 | BAD | Bad
 | EXTREME | Extreme
 | GOOD | Good
 | INDOOR | Indoor
 | MEDIUM | Medium
 | UNDEFINED | Undefined
 | UNKNOWN | Unknown
Public field | value__ |
Top
See Also

Reference

WeatherConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


WeatherConditions.BAD Field

WeatherConditionsBAD Field

Bad

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const WeatherConditions BAD = 3

Field Value

WeatherConditions
See Also

Reference

WeatherConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


WeatherConditions.EXTREME Field

WeatherConditionsEXTREME Field

Extreme

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const WeatherConditions EXTREME = 6

Field Value

WeatherConditions
See Also

Reference

WeatherConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


WeatherConditions.GOOD Field

WeatherConditionsGOOD Field

Good

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const WeatherConditions GOOD = 1

Field Value

WeatherConditions
See Also

Reference

WeatherConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


WeatherConditions.INDOOR Field

WeatherConditionsINDOOR Field

Indoor

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const WeatherConditions INDOOR = 5

Field Value

WeatherConditions
See Also

Reference

WeatherConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


WeatherConditions.MEDIUM Field

WeatherConditionsMEDIUM Field

Medium

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const WeatherConditions MEDIUM = 2

Field Value

WeatherConditions
See Also

Reference

WeatherConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


WeatherConditions.UNDEFINED Field

WeatherConditionsUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const WeatherConditions UNDEFINED = 0

Field Value

WeatherConditions
See Also

Reference

WeatherConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


WeatherConditions.UNKNOWN Field

WeatherConditionsUNKNOWN Field

Unknown

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const WeatherConditions UNKNOWN = 4

Field Value

WeatherConditions
See Also

Reference

WeatherConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


WeatherConditions.value__ Field

WeatherConditionsvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.WeatherConditions.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

WeatherConditions Class
Sportradar.SDK.FeedProviders.LiveScout Namespace


Sportradar.SDK.FeedProviders.LiveScout.Enums Namespace

Classes
 | Class | Description
Public class | VbpClassification |


VbpClassification Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveScout.Enums.VbpClassification"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.FeedProviders.LiveScout.EnumsVbpClassification

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Enums
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class VbpClassification : Enum

The VbpClassification type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | MVP | MVP
 | STAR | Star
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout.Enums Namespace


VbpClassification Methods

The VbpClassification type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

VbpClassification Class
Sportradar.SDK.FeedProviders.LiveScout.Enums Namespace


VbpClassification Fields

The VbpClassification type exposes the following members.

Fields
 | Name | Description
 | MVP | MVP
 | STAR | Star
 | UNDEFINED | Undefined
Public field | value__ |
Top
See Also

Reference

VbpClassification Class
Sportradar.SDK.FeedProviders.LiveScout.Enums Namespace


VbpClassification.MVP Field

VbpClassificationMVP Field

MVP

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Enums
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const VbpClassification MVP = 2

Field Value

VbpClassification
See Also

Reference

VbpClassification Class
Sportradar.SDK.FeedProviders.LiveScout.Enums Namespace


VbpClassification.STAR Field

VbpClassificationSTAR Field

Star

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Enums
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const VbpClassification STAR = 1

Field Value

VbpClassification
See Also

Reference

VbpClassification Class
Sportradar.SDK.FeedProviders.LiveScout.Enums Namespace


VbpClassification.UNDEFINED Field

VbpClassificationUNDEFINED Field

Undefined

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Enums
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const VbpClassification UNDEFINED = 0

Field Value

VbpClassification
See Also

Reference

VbpClassification Class
Sportradar.SDK.FeedProviders.LiveScout.Enums Namespace


VbpClassification.value__ Field

VbpClassificationvalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.FeedProviders.LiveScout.Enums.VbpClassification.value__"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Enums
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

VbpClassification Class
Sportradar.SDK.FeedProviders.LiveScout.Enums Namespace


Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace

Classes
 | Class | Description
Public class | LiveScoutEntityFactory |
Public class | LiveScoutFeedProvider |
Public class | LiveScoutFeedProviderExt | ILiveScout extension methods.


LiveScoutEntityFactory Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScout.InternalLiveScoutEntityFactory

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveScoutEntityFactory

The LiveScoutEntityFactory type exposes the following members.

Constructors
 | Name | Description
Public method | LiveScoutEntityFactory | Initializes a new instance of the LiveScoutEntityFactory class
Top
Methods
 | Name | Description
Public method | BuildFakeBetStop | Generates a special MatchUpdate messages that contains a betstop event
Public method | BuildLineups |
Public method | BuildManager |
Public method | BuildMatchBooking |
Public method | BuildMatchData |
Public method | BuildMatchFormat |
Public method | BuildMatchHeader |
Public method | BuildMatchList |
Public method | BuildMatchListUpdate |
Public method | BuildMatchProperties |
Public method | BuildMatchStop |
Public method | BuildMatchTeams |
Public method | BuildMatchUpdate |
Public method | BuildPlayer |
Public method | BuildScoutInfos |
Public method | BuildTeamOffical |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory Constructor

Initializes a new instance of the LiveScoutEntityFactory class

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveScoutEntityFactory()
See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory Methods

The LiveScoutEntityFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildFakeBetStop | Generates a special MatchUpdate messages that contains a betstop event
Public method | BuildLineups |
Public method | BuildManager |
Public method | BuildMatchBooking |
Public method | BuildMatchData |
Public method | BuildMatchFormat |
Public method | BuildMatchHeader |
Public method | BuildMatchList |
Public method | BuildMatchListUpdate |
Public method | BuildMatchProperties |
Public method | BuildMatchStop |
Public method | BuildMatchTeams |
Public method | BuildMatchUpdate |
Public method | BuildPlayer |
Public method | BuildScoutInfos |
Public method | BuildTeamOffical |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildFakeBetStop Method

LiveScoutEntityFactoryBuildFakeBetStop Method

Generates a special MatchUpdate messages that contains a betstop event

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchUpdate BuildFakeBetStop(
    long match_id,
    DateTime time
)

Parameters

match_id Int64
Id of the match
time DateTime
Time when the event should have happened

Return Value

MatchUpdate
An instance of MatchUpdate.
See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildLineups Method

LiveScoutEntityFactoryBuildLineups Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildLineups(Sportradar.SDK.ProtocolProviders.LiveScout.Server.lineups)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Lineups BuildLineups(
    lineups lineups
)

Parameters

lineups lineups

[Missing <param name="lineups"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildLineups(Sportradar.SDK.ProtocolProviders.LiveScout.Server.lineups)"]

Return Value

Lineups

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildLineups(Sportradar.SDK.ProtocolProviders.LiveScout.Server.lineups)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildManager Method

LiveScoutEntityFactoryBuildManager Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildManager(Sportradar.SDK.ProtocolProviders.LiveScout.Server.manager)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Manager BuildManager(
    manager manager
)

Parameters

manager manager

[Missing <param name="manager"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildManager(Sportradar.SDK.ProtocolProviders.LiveScout.Server.manager)"]

Return Value

Manager

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildManager(Sportradar.SDK.ProtocolProviders.LiveScout.Server.manager)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildMatchBooking Method

LiveScoutEntityFactoryBuildMatchBooking Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchBooking(Sportradar.SDK.ProtocolProviders.LiveScout.Server.bookmatch)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchBooking BuildMatchBooking(
    bookmatch bookmatch
)

Parameters

bookmatch bookmatch

[Missing <param name="bookmatch"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchBooking(Sportradar.SDK.ProtocolProviders.LiveScout.Server.bookmatch)"]

Return Value

MatchBooking

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchBooking(Sportradar.SDK.ProtocolProviders.LiveScout.Server.bookmatch)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildMatchData Method

LiveScoutEntityFactoryBuildMatchData Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchData(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchdata)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchData BuildMatchData(
    matchdata matchdata
)

Parameters

matchdata matchdata

[Missing <param name="matchdata"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchData(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchdata)"]

Return Value

MatchData

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchData(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchdata)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildMatchFormat Method

LiveScoutEntityFactoryBuildMatchFormat Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchFormat(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchformat)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<Format> BuildMatchFormat(
    matchformat matchformat
)

Parameters

matchformat matchformat

[Missing <param name="matchformat"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchFormat(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchformat)"]

Return Value

List Format

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchFormat(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchformat)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildMatchHeader Method

LiveScoutEntityFactoryBuildMatchHeader Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchHeader(Sportradar.SDK.ProtocolProviders.LiveScout.Server.match)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchHeader BuildMatchHeader(
    match orig
)

Parameters

orig match

[Missing <param name="orig"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchHeader(Sportradar.SDK.ProtocolProviders.LiveScout.Server.match)"]

Return Value

MatchHeader

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchHeader(Sportradar.SDK.ProtocolProviders.LiveScout.Server.match)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildMatchList Method

LiveScoutEntityFactoryBuildMatchList Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchList(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchlist)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchList BuildMatchList(
    matchlist matchlist
)

Parameters

matchlist matchlist

[Missing <param name="matchlist"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchList(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchlist)"]

Return Value

MatchList

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchList(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchlist)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildMatchListUpdate Method

LiveScoutEntityFactoryBuildMatchListUpdate Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchListUpdate(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchlistupdate)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchListUpdate BuildMatchListUpdate(
    matchlistupdate matchlistupdate
)

Parameters

matchlistupdate matchlistupdate

[Missing <param name="matchlistupdate"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchListUpdate(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchlistupdate)"]

Return Value

MatchListUpdate

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchListUpdate(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchlistupdate)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildMatchProperties Method

LiveScoutEntityFactoryBuildMatchProperties Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchProperties(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchproperties)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<MatchProperty> BuildMatchProperties(
    matchproperties matchProperties
)

Parameters

matchProperties matchproperties

[Missing <param name="matchProperties"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchProperties(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchproperties)"]

Return Value

List MatchProperty

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchProperties(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchproperties)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildMatchStop Method

LiveScoutEntityFactoryBuildMatchStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchStop(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchstop)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchStop BuildMatchStop(
    matchstop matchstop
)

Parameters

matchstop matchstop

[Missing <param name="matchstop"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchStop(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchstop)"]

Return Value

MatchStop

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchStop(Sportradar.SDK.ProtocolProviders.LiveScout.Server.matchstop)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildMatchTeams Method

LiveScoutEntityFactoryBuildMatchTeams Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchTeams(Sportradar.SDK.ProtocolProviders.LiveScout.Server.teams)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public List<MatchTeam> BuildMatchTeams(
    teams matchTeams
)

Parameters

matchTeams teams

[Missing <param name="matchTeams"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchTeams(Sportradar.SDK.ProtocolProviders.LiveScout.Server.teams)"]

Return Value

List MatchTeam

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchTeams(Sportradar.SDK.ProtocolProviders.LiveScout.Server.teams)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildMatchUpdate Method

LiveScoutEntityFactoryBuildMatchUpdate Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchUpdate(Sportradar.SDK.ProtocolProviders.LiveScout.Server.match)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public MatchUpdate BuildMatchUpdate(
    match match
)

Parameters

match match

[Missing <param name="match"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchUpdate(Sportradar.SDK.ProtocolProviders.LiveScout.Server.match)"]

Return Value

MatchUpdate

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildMatchUpdate(Sportradar.SDK.ProtocolProviders.LiveScout.Server.match)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildPlayer Method

LiveScoutEntityFactoryBuildPlayer Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildPlayer(Sportradar.SDK.ProtocolProviders.LiveScout.Server.player)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Player BuildPlayer(
    player player
)

Parameters

player player

[Missing <param name="player"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildPlayer(Sportradar.SDK.ProtocolProviders.LiveScout.Server.player)"]

Return Value

Player

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildPlayer(Sportradar.SDK.ProtocolProviders.LiveScout.Server.player)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildScoutInfos Method

LiveScoutEntityFactoryBuildScoutInfos Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildScoutInfos(Sportradar.SDK.ProtocolProviders.LiveScout.Server.infos)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ScoutInfos BuildScoutInfos(
    infos infos
)

Parameters

infos infos

[Missing <param name="infos"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildScoutInfos(Sportradar.SDK.ProtocolProviders.LiveScout.Server.infos)"]

Return Value

ScoutInfos

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildScoutInfos(Sportradar.SDK.ProtocolProviders.LiveScout.Server.infos)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutEntityFactory.BuildTeamOffical Method

LiveScoutEntityFactoryBuildTeamOffical Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildTeamOffical(Sportradar.SDK.ProtocolProviders.LiveScout.Server.teamofficial)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TeamOffical BuildTeamOffical(
    teamofficial teamofficial
)

Parameters

teamofficial teamofficial

[Missing <param name="teamofficial"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildTeamOffical(Sportradar.SDK.ProtocolProviders.LiveScout.Server.teamofficial)"]

Return Value

TeamOffical

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutEntityFactory.BuildTeamOffical(Sportradar.SDK.ProtocolProviders.LiveScout.Server.teamofficial)"]

See Also

Reference

LiveScoutEntityFactory Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScout.InternalLiveScoutFeedProvider

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveScoutFeedProvider : ILiveScout,
    ILiveFeeds, IStartable, IFeedDispatcher

The LiveScoutFeedProvider type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations |
Public property | ProtoProvider |
Public property | ProviderType |
Public property | SubscribedEvents |
Top
Methods
 | Name | Description
Public method | DispatchEntity |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Start |
Public method | Stop |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | OnClosed |
Public event | OnFeedError |
Public event | OnLineups |
Public event | OnMatchBookingReply |
Public event | OnMatchData |
Public event | OnMatchList |
Public event | OnMatchListUpdate |
Public event | OnMatchStop |
Public event | OnMatchUpdate |
Public event | OnMatchUpdateDelta |
Public event | OnMatchUpdateDeltaUpdate |
Public event | OnMatchUpdateFull |
Public event | OnOpened |
Public event | OnScoutInfo |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider Properties

The LiveScoutFeedProvider type exposes the following members.

Properties
 | Name | Description
Public property | AvailableTranslations |
Public property | ProtoProvider |
Public property | ProviderType |
Public property | SubscribedEvents |
Top
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.AvailableTranslations Property

LiveScoutFeedProviderAvailableTranslations Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.AvailableTranslations"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual string[] AvailableTranslations { get; }

Property Value

String

Implements

ILiveFeedsAvailableTranslations
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.ProtoProvider Property

LiveScoutFeedProviderProtoProvider Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.ProtoProvider"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual LiveScoutProtocolProvider ProtoProvider { get; }

Property Value

LiveScoutProtocolProvider
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.ProviderType Property

LiveScoutFeedProviderProviderType Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.ProviderType"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType

Implements

IFeedDispatcherProviderType
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.SubscribedEvents Property

LiveScoutFeedProviderSubscribedEvents Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.SubscribedEvents"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual long[] SubscribedEvents { get; }

Property Value

Int64

Implements

ILiveFeedsSubscribedEvents
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider Methods

The LiveScoutFeedProvider type exposes the following members.

Methods
 | Name | Description
Public method | DispatchEntity |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Start |
Public method | Stop |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.DispatchEntity Method

LiveScoutFeedProviderDispatchEntity Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.DispatchEntity(Sportradar.SDK.Common.EntityBase)"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DispatchStatus DispatchEntity(
    EntityBase entity
)

Parameters

entity EntityBase

[Missing <param name="entity"/> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.DispatchEntity(Sportradar.SDK.Common.EntityBase)"]

Return Value

DispatchStatus

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.DispatchEntity(Sportradar.SDK.Common.EntityBase)"]

Implements

IFeedDispatcherDispatchEntity(EntityBase)
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.Start Method

LiveScoutFeedProviderStart Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.Start"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Start()

Implements

IStartableStart
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.Stop Method

LiveScoutFeedProviderStop Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.Stop"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Stop()

Implements

IStartableStop
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider Events

The LiveScoutFeedProvider type exposes the following members.

Events
 | Name | Description
Public event | OnClosed |
Public event | OnFeedError |
Public event | OnLineups |
Public event | OnMatchBookingReply |
Public event | OnMatchData |
Public event | OnMatchList |
Public event | OnMatchListUpdate |
Public event | OnMatchStop |
Public event | OnMatchUpdate |
Public event | OnMatchUpdateDelta |
Public event | OnMatchUpdateDeltaUpdate |
Public event | OnMatchUpdateFull |
Public event | OnOpened |
Public event | OnScoutInfo |
Top
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnClosed Event

LiveScoutFeedProviderOnClosed Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnClosed"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<ConnectionChangeEventArgs> OnClosed

Value

EventHandler ConnectionChangeEventArgs

Implements

ILiveScoutOnClosed
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnFeedError Event

LiveScoutFeedProviderOnFeedError Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnFeedError"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<FeedErrorEventArgs> OnFeedError

Value

EventHandler FeedErrorEventArgs
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnLineups Event

LiveScoutFeedProviderOnLineups Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnLineups"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<LineupsEventArgs> OnLineups

Value

EventHandler LineupsEventArgs

Implements

ILiveScoutOnLineups
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnMatchBookingReply Event

LiveScoutFeedProviderOnMatchBookingReply Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnMatchBookingReply"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<MatchBookingReplyEventArgs> OnMatchBookingReply

Value

EventHandler MatchBookingReplyEventArgs

Implements

ILiveScoutOnMatchBookingReply
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnMatchData Event

LiveScoutFeedProviderOnMatchData Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnMatchData"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<MatchDataEventArgs> OnMatchData

Value

EventHandler MatchDataEventArgs

Implements

ILiveScoutOnMatchData
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnMatchList Event

LiveScoutFeedProviderOnMatchList Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnMatchList"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<MatchListEventArgs> OnMatchList

Value

EventHandler MatchListEventArgs

Implements

ILiveScoutOnMatchList
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnMatchListUpdate Event

LiveScoutFeedProviderOnMatchListUpdate Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnMatchListUpdate"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<MatchListEventArgs> OnMatchListUpdate

Value

EventHandler MatchListEventArgs

Implements

ILiveScoutOnMatchListUpdate
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnMatchStop Event

LiveScoutFeedProviderOnMatchStop Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnMatchStop"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<MatchStopEventArgs> OnMatchStop

Value

EventHandler MatchStopEventArgs

Implements

ILiveScoutOnMatchStop
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnMatchUpdate Event

LiveScoutFeedProviderOnMatchUpdate Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnMatchUpdate"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<MatchUpdateEventArgs> OnMatchUpdate

Value

EventHandler MatchUpdateEventArgs

Implements

ILiveScoutOnMatchUpdate
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnMatchUpdateDelta Event

LiveScoutFeedProviderOnMatchUpdateDelta Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnMatchUpdateDelta"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<MatchUpdateEventArgs> OnMatchUpdateDelta

Value

EventHandler MatchUpdateEventArgs

Implements

ILiveScoutOnMatchUpdateDelta
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnMatchUpdateDeltaUpdate Event

LiveScoutFeedProviderOnMatchUpdateDeltaUpdate Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnMatchUpdateDeltaUpdate"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<MatchUpdateEventArgs> OnMatchUpdateDeltaUpdate

Value

EventHandler MatchUpdateEventArgs

Implements

ILiveScoutOnMatchUpdateDeltaUpdate
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnMatchUpdateFull Event

LiveScoutFeedProviderOnMatchUpdateFull Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnMatchUpdateFull"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<MatchUpdateEventArgs> OnMatchUpdateFull

Value

EventHandler MatchUpdateEventArgs

Implements

ILiveScoutOnMatchUpdateFull
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnOpened Event

LiveScoutFeedProviderOnOpened Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnOpened"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event EventHandler<ConnectionChangeEventArgs> OnOpened

Value

EventHandler ConnectionChangeEventArgs

Implements

ILiveScoutOnOpened
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProvider.OnScoutInfo Event

LiveScoutFeedProviderOnScoutInfo Event

[Missing <summary> documentation for "E:Sportradar.SDK.FeedProviders.LiveScout.Internal.LiveScoutFeedProvider.OnScoutInfo"]

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual event EventHandler<ScoutInfoEventArgs> OnScoutInfo

Value

EventHandler ScoutInfoEventArgs

Implements

ILiveScoutOnScoutInfo
See Also

Reference

LiveScoutFeedProvider Class
Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


LiveScoutFeedProviderExt Class

ILiveScout extension methods.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScout.InternalLiveScoutFeedProviderExt

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Internal
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class LiveScoutFeedProviderExt
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout.Internal Namespace


Sportradar.SDK.FeedProviders.LiveScout.Types Namespace

Classes
 | Class | Description
Public class | SubTeam | Sub team


SubTeam Class

Sub team
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveScout.TypesSubTeam

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Types
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SubTeam

The SubTeam type exposes the following members.

Constructors
 | Name | Description
Public method | SubTeam | Initializes a new instance of the SubTeam class
Top
Properties
 | Name | Description
Public property | Id | Id
Public property | Name | Name
Public property | Parent | Parent
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.LiveScout.Types Namespace


SubTeam Constructor

Initializes a new instance of the SubTeam class

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Types
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SubTeam()
See Also

Reference

SubTeam Class
Sportradar.SDK.FeedProviders.LiveScout.Types Namespace


SubTeam Properties

The SubTeam type exposes the following members.

Properties
 | Name | Description
Public property | Id | Id
Public property | Name | Name
Public property | Parent | Parent
Top
See Also

Reference

SubTeam Class
Sportradar.SDK.FeedProviders.LiveScout.Types Namespace


SubTeam.Id Property

SubTeamId Property

Id

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Types
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

SubTeam Class
Sportradar.SDK.FeedProviders.LiveScout.Types Namespace


SubTeam.Name Property

SubTeamName Property

Name

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Types
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; }

Property Value

String
See Also

Reference

SubTeam Class
Sportradar.SDK.FeedProviders.LiveScout.Types Namespace


SubTeam.Parent Property

SubTeamParent Property

Parent

Namespace: Sportradar.SDK.FeedProviders.LiveScout.Types
Assembly: LiveScoutFeedProvider (in LiveScoutFeedProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Parent { get; }

Property Value

Int32
See Also

Reference

SubTeam Class
Sportradar.SDK.FeedProviders.LiveScout.Types Namespace


SubTeam Methods

The SubTeam type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SubTeam Class
Sportradar.SDK.FeedProviders.LiveScout.Types Namespace


Sportradar.SDK.FeedProviders.OddsCreator Namespace

Classes
 | Class | Description
Public class | IdName |
Public class | OddsCreatorEntityFactory |
Public class | OddsCreatorException |
Public class | OddsCreatorFeedProvider |
Public class | OddsType |
Public class | Outcome |
Interfaces
 | Interface | Description
Public interface | IOddsCreator |


IdName Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.OddsCreator.IdName"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.OddsCreatorIdName

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class IdName

The IdName type exposes the following members.

Constructors
 | Name | Description
Public method | IdName | Initializes a new instance of the IdName class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.OddsCreator Namespace


IdName Constructor

Initializes a new instance of the IdName class

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IdName(
    int id,
    string name
)

Parameters

id Int32

[Missing <param name="id"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IdName.#ctor(System.Int32,System.String)"]

name String

[Missing <param name="name"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IdName.#ctor(System.Int32,System.String)"]

See Also

Reference

IdName Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IdName Properties

The IdName type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Name |
Top
See Also

Reference

IdName Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IdName.Id Property

IdNameId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.OddsCreator.IdName.Id"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

IdName Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IdName.Name Property

IdNameName Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.OddsCreator.IdName.Name"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; }

Property Value

String
See Also

Reference

IdName Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IdName Methods

The IdName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

IdName Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator Interface

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IOddsCreator

The IOddsCreator type exposes the following members.

Methods
 | Name | Description
Public method | GetCategories |
Public method | GetGenders |
Public method | GetOddsTypeIds |
Public method | GetOutcomeTypeIds |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Double) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Double, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | GetSports |
Public method | GetSurfaces |
Public method | GetTennisMatchInfo |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32) |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Int32) |
Public method | GetTournaments |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Int32, Int32) |
Top
See Also

Reference

Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator Methods

The IOddsCreator type exposes the following members.

Methods
 | Name | Description
Public method | GetCategories |
Public method | GetGenders |
Public method | GetOddsTypeIds |
Public method | GetOutcomeTypeIds |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Double) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Double, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | GetSports |
Public method | GetSurfaces |
Public method | GetTennisMatchInfo |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32) |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Int32) |
Public method | GetTournaments |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Int32, Int32) |
Top
See Also

Reference

IOddsCreator Interface
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetCategories Method

IOddsCreatorGetCategories Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetCategories(System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<IdName> GetCategories(
    int sportId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetCategories(System.Int32)"]

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetCategories(System.Int32)"]

See Also

Reference

IOddsCreator Interface
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetGenders Method

IOddsCreatorGetGenders Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetGenders"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<IdName> GetGenders()

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetGenders"]

See Also

Reference

IOddsCreator Interface
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetOddsTypeIds Method

IOddsCreatorGetOddsTypeIds Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetOddsTypeIds(System.Int32,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<IdName> GetOddsTypeIds(
    int sportId,
    bool needMatchId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetOddsTypeIds(System.Int32,System.Boolean)"]

needMatchId Boolean

[Missing <param name="needMatchId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetOddsTypeIds(System.Int32,System.Boolean)"]

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetOddsTypeIds(System.Int32,System.Boolean)"]

See Also

Reference

IOddsCreator Interface
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetOutcomeTypeIds Method

IOddsCreatorGetOutcomeTypeIds Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetOutcomeTypeIds(System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<IdName> GetOutcomeTypeIds(
    int sportId,
    int oddsTypeId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetOutcomeTypeIds(System.Int32,System.Int32)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetOutcomeTypeIds(System.Int32,System.Int32)"]

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetOutcomeTypeIds(System.Int32,System.Int32)"]

See Also

Reference

IOddsCreator Interface
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetSidebets Method

IOddsCreatorGetSidebets Method

Overload List
 | Name | Description
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Double) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Double, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Top
See Also

Reference

IOddsCreator Interface
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32[]) Method

IOddsCreatorGetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<OddsType> GetSidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int sportId,
    int[] oddsTypeIds
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

oddsTypeIds Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

See Also

Reference

IOddsCreator Interface
GetSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Int32[]) Method

IOddsCreatorGetSidebets(Double, Double, Double, Double, Double, Double, Int64, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<OddsType> GetSidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    long matchId,
    int[] oddsTypeIds
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

oddsTypeIds Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

See Also

Reference

IOddsCreator Interface
GetSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Double) Method

IOddsCreatorGetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<OddsType> GetSidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int sportId,
    int oddsTypeId,
    double oddsKey
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

See Also

Reference

IOddsCreator Interface
GetSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Double, Int32) Method

IOddsCreatorGetSidebets(Double, Double, Double, Double, Double, Double, Int64, Double, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<OddsType> GetSidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    long matchId,
    double oddsKey,
    int oddsTypeId
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

See Also

Reference

IOddsCreator Interface
GetSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32[]) Method

IOddsCreatorGetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<OddsType> GetSidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int sportId,
    int categoryId,
    int tournamentId,
    int[] oddsTypeIds
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

oddsTypeIds Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

See Also

Reference

IOddsCreator Interface
GetSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetSports Method

IOddsCreatorGetSports Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSports"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<IdName> GetSports()

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSports"]

See Also

Reference

IOddsCreator Interface
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetSurfaces Method

IOddsCreatorGetSurfaces Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSurfaces"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<IdName> GetSurfaces()

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetSurfaces"]

See Also

Reference

IOddsCreator Interface
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetTennisMatchInfo Method

IOddsCreatorGetTennisMatchInfo Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisMatchInfo(System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<IdName> GetTennisMatchInfo(
    long matchId
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisMatchInfo(System.Int64)"]

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisMatchInfo(System.Int64)"]

See Also

Reference

IOddsCreator Interface
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetTennisSidebets Method

IOddsCreatorGetTennisSidebets Method

Overload List
 | Name | Description
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32) |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Int32) |
Top
See Also

Reference

IOddsCreator Interface
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetTennisSidebets(Double, Double, Int32, Int32, Int32) Method

IOddsCreatorGetTennisSidebets(Double, Double, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<OddsType> GetTennisSidebets(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

IOddsCreator Interface
GetTennisSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Double) Method

IOddsCreatorGetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<OddsType> GetTennisSidebets(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    int oddsTypeId,
    double oddsKey
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

See Also

Reference

IOddsCreator Interface
GetTennisSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Int32) Method

IOddsCreatorGetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<OddsType> GetTennisSidebets(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    int categoryId,
    int tournamentId
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

IOddsCreator Interface
GetTennisSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetTournaments Method

IOddsCreatorGetTournaments Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTournaments(System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<IdName> GetTournaments(
    int categoryId
)

Parameters

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTournaments(System.Int32)"]

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetTournaments(System.Int32)"]

See Also

Reference

IOddsCreator Interface
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetVolleySidebets Method

IOddsCreatorGetVolleySidebets Method

Overload List
 | Name | Description
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Int32, Int32) |
Top
See Also

Reference

IOddsCreator Interface
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32[]) Method

IOddsCreatorGetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<OddsType> GetVolleySidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int sportId,
    int gender,
    int topLeague,
    int[] oddsTypeIds
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

oddsTypeIds Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

See Also

Reference

IOddsCreator Interface
GetVolleySidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Double) Method

IOddsCreatorGetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<OddsType> GetVolleySidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int sportId,
    int gender,
    int topLeague,
    int oddsTypeId,
    double oddsKey
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

See Also

Reference

IOddsCreator Interface
GetVolleySidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


IOddsCreator.GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Int32, Int32[]) Method

IOddsCreatorGetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
IList<OddsType> GetVolleySidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int sportId,
    int categoryId,
    int tournamentId,
    int gender,
    int topLeague,
    int[] oddsTypeIds
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

oddsTypeIds Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.IOddsCreator.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

See Also

Reference

IOddsCreator Interface
GetVolleySidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorEntityFactory Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorEntityFactory"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.OddsCreatorOddsCreatorEntityFactory

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class OddsCreatorEntityFactory

The OddsCreatorEntityFactory type exposes the following members.

Constructors
 | Name | Description
Public method | OddsCreatorEntityFactory | Initializes a new instance of the OddsCreatorEntityFactory class
Top
Methods
 | Name | Description
 | BuildIdNames |
 | BuildOddsTypes |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorEntityFactory Constructor

Initializes a new instance of the OddsCreatorEntityFactory class

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsCreatorEntityFactory()
See Also

Reference

OddsCreatorEntityFactory Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorEntityFactory Methods

The OddsCreatorEntityFactory type exposes the following members.

Methods
 | Name | Description
 | BuildIdNames |
 | BuildOddsTypes |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OddsCreatorEntityFactory Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorEntityFactory.BuildIdNames Method

OddsCreatorEntityFactoryBuildIdNames Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorEntityFactory.BuildIdNames(Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.staticInfoData[])"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static ReadOnlyCollection<IdName> BuildIdNames(
    staticInfoData[] staticInfoData
)

Parameters

staticInfoData staticInfoData

[Missing <param name="staticInfoData"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorEntityFactory.BuildIdNames(Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.staticInfoData[])"]

Return Value

ReadOnlyCollection IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorEntityFactory.BuildIdNames(Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.staticInfoData[])"]

See Also

Reference

OddsCreatorEntityFactory Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorEntityFactory.BuildOddsTypes Method

OddsCreatorEntityFactoryBuildOddsTypes Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorEntityFactory.BuildOddsTypes(Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.oddsTypeData[])"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static ReadOnlyCollection<OddsType> BuildOddsTypes(
    oddsTypeData[] oddsTypeData
)

Parameters

oddsTypeData oddsTypeData

[Missing <param name="oddsTypeData"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorEntityFactory.BuildOddsTypes(Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.oddsTypeData[])"]

Return Value

ReadOnlyCollection OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorEntityFactory.BuildOddsTypes(Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.oddsTypeData[])"]

See Also

Reference

OddsCreatorEntityFactory Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorException Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorException"]

Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Sportradar.SDK.Common.ExceptionsSdkBaseException
Sportradar.SDK.FeedProviders.OddsCreatorOddsCreatorException

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OddsCreatorException : SdkBaseException

The OddsCreatorException type exposes the following members.

Constructors
 | Name | Description
Public method | OddsCreatorException | Initializes a new instance of the OddsCreatorException class
Public method | OddsCreatorException(String) | Initializes a new instance of the OddsCreatorException class
Public method | OddsCreatorException(String, Exception) | Initializes a new instance of the OddsCreatorException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorException Constructor

Overload List
 | Name | Description
Public method | OddsCreatorException | Initializes a new instance of the OddsCreatorException class
Public method | OddsCreatorException(String) | Initializes a new instance of the OddsCreatorException class
Public method | OddsCreatorException(String, Exception) | Initializes a new instance of the OddsCreatorException class
Top
See Also

Reference

OddsCreatorException Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorException Constructor

Initializes a new instance of the OddsCreatorException class

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsCreatorException()
See Also

Reference

OddsCreatorException Class
OddsCreatorException Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorException(String) Constructor

Initializes a new instance of the OddsCreatorException class

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsCreatorException(
    string message
)

Parameters

message String

[Missing <param name="message"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorException.#ctor(System.String)"]

See Also

Reference

OddsCreatorException Class
OddsCreatorException Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorException(String, Exception) Constructor

Initializes a new instance of the OddsCreatorException class

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsCreatorException(
    string message,
    Exception inner_exception
)

Parameters

message String

[Missing <param name="message"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorException.#ctor(System.String,System.Exception)"]

inner_exception Exception

[Missing <param name="inner_exception"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorException.#ctor(System.String,System.Exception)"]

See Also

Reference

OddsCreatorException Class
OddsCreatorException Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorException Properties

The OddsCreatorException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | Identifier | Special exception identifier that can be used for tracking down exception details in the log files. (Inherited from SdkBaseException)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

OddsCreatorException Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorException Methods

The OddsCreatorException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

OddsCreatorException Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.OddsCreatorOddsCreatorFeedProvider

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class OddsCreatorFeedProvider : IOddsCreator

The OddsCreatorFeedProvider type exposes the following members.

Constructors
 | Name | Description
Public method | OddsCreatorFeedProvider | Initializes a new instance of the OddsCreatorFeedProvider class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCategories |
Public method | GetGenders |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOddsTypeIds |
Public method | GetOutcomeTypeIds |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Double) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Double, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | GetSports |
Public method | GetSurfaces |
Public method | GetTennisMatchInfo |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32) |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Int32) |
Public method | GetTournaments |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Int32, Int32) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider Constructor

Initializes a new instance of the OddsCreatorFeedProvider class

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsCreatorFeedProvider(
    SdkConfigurationOddsCreator config,
    ISdkLogger sdk_logger
)

Parameters

config SdkConfigurationOddsCreator

[Missing <param name="config"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.#ctor(Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationOddsCreator,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.#ctor(Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationOddsCreator,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider Methods

The OddsCreatorFeedProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCategories |
Public method | GetGenders |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOddsTypeIds |
Public method | GetOutcomeTypeIds |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Double) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Double, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | GetSports |
Public method | GetSurfaces |
Public method | GetTennisMatchInfo |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32) |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Int32) |
Public method | GetTournaments |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Int32, Int32) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetCategories Method

OddsCreatorFeedProviderGetCategories Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetCategories(System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<IdName> GetCategories(
    int sportId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetCategories(System.Int32)"]

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetCategories(System.Int32)"]

Implements

IOddsCreatorGetCategories(Int32)
See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetGenders Method

OddsCreatorFeedProviderGetGenders Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetGenders"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<IdName> GetGenders()

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetGenders"]

Implements

IOddsCreatorGetGenders
See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetOddsTypeIds Method

OddsCreatorFeedProviderGetOddsTypeIds Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetOddsTypeIds(System.Int32,System.Boolean)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<IdName> GetOddsTypeIds(
    int sportId,
    bool needMatchId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetOddsTypeIds(System.Int32,System.Boolean)"]

needMatchId Boolean

[Missing <param name="needMatchId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetOddsTypeIds(System.Int32,System.Boolean)"]

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetOddsTypeIds(System.Int32,System.Boolean)"]

Implements

IOddsCreatorGetOddsTypeIds(Int32, Boolean)
See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetOutcomeTypeIds Method

OddsCreatorFeedProviderGetOutcomeTypeIds Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetOutcomeTypeIds(System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<IdName> GetOutcomeTypeIds(
    int sportId,
    int oddsTypeId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetOutcomeTypeIds(System.Int32,System.Int32)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetOutcomeTypeIds(System.Int32,System.Int32)"]

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetOutcomeTypeIds(System.Int32,System.Int32)"]

Implements

IOddsCreatorGetOutcomeTypeIds(Int32, Int32)
See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetSidebets Method

OddsCreatorFeedProviderGetSidebets Method

Overload List
 | Name | Description
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Double) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Double, Int32) |
Public method | GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Top
See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32[]) Method

OddsCreatorFeedProviderGetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<OddsType> GetSidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int sportId,
    int[] oddsTypeIds
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

oddsTypeIds Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32[])"]

Implements

IOddsCreatorGetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32)
See Also

Reference

OddsCreatorFeedProvider Class
GetSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Int32[]) Method

OddsCreatorFeedProviderGetSidebets(Double, Double, Double, Double, Double, Double, Int64, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<OddsType> GetSidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    long matchId,
    int[] oddsTypeIds
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

oddsTypeIds Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Int32[])"]

Implements

IOddsCreatorGetSidebets(Double, Double, Double, Double, Double, Double, Int64, Int32)
See Also

Reference

OddsCreatorFeedProvider Class
GetSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Double) Method

OddsCreatorFeedProviderGetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<OddsType> GetSidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int sportId,
    int oddsTypeId,
    double oddsKey
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Double)"]

Implements

IOddsCreatorGetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Double)
See Also

Reference

OddsCreatorFeedProvider Class
GetSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetSidebets(Double, Double, Double, Double, Double, Double, Int64, Double, Int32) Method

OddsCreatorFeedProviderGetSidebets(Double, Double, Double, Double, Double, Double, Int64, Double, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<OddsType> GetSidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    long matchId,
    double oddsKey,
    int oddsTypeId
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int64,System.Double,System.Int32)"]

Implements

IOddsCreatorGetSidebets(Double, Double, Double, Double, Double, Double, Int64, Double, Int32)
See Also

Reference

OddsCreatorFeedProvider Class
GetSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32[]) Method

OddsCreatorFeedProviderGetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<OddsType> GetSidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int sportId,
    int categoryId,
    int tournamentId,
    int[] oddsTypeIds
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

oddsTypeIds Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Implements

IOddsCreatorGetSidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32)
See Also

Reference

OddsCreatorFeedProvider Class
GetSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetSports Method

OddsCreatorFeedProviderGetSports Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSports"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<IdName> GetSports()

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSports"]

Implements

IOddsCreatorGetSports
See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetSurfaces Method

OddsCreatorFeedProviderGetSurfaces Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSurfaces"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<IdName> GetSurfaces()

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetSurfaces"]

Implements

IOddsCreatorGetSurfaces
See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetTennisMatchInfo Method

OddsCreatorFeedProviderGetTennisMatchInfo Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisMatchInfo(System.Int64)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<IdName> GetTennisMatchInfo(
    long matchId
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisMatchInfo(System.Int64)"]

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisMatchInfo(System.Int64)"]

Implements

IOddsCreatorGetTennisMatchInfo(Int64)
See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetTennisSidebets Method

OddsCreatorFeedProviderGetTennisSidebets Method

Overload List
 | Name | Description
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32) |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Int32) |
Top
See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetTennisSidebets(Double, Double, Int32, Int32, Int32) Method

OddsCreatorFeedProviderGetTennisSidebets(Double, Double, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<OddsType> GetTennisSidebets(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

Implements

IOddsCreatorGetTennisSidebets(Double, Double, Int32, Int32, Int32)
See Also

Reference

OddsCreatorFeedProvider Class
GetTennisSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Double) Method

OddsCreatorFeedProviderGetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<OddsType> GetTennisSidebets(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    int oddsTypeId,
    double oddsKey
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Implements

IOddsCreatorGetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Double)
See Also

Reference

OddsCreatorFeedProvider Class
GetTennisSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Int32) Method

OddsCreatorFeedProviderGetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<OddsType> GetTennisSidebets(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    int categoryId,
    int tournamentId
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Implements

IOddsCreatorGetTennisSidebets(Double, Double, Int32, Int32, Int32, Int32, Int32)
See Also

Reference

OddsCreatorFeedProvider Class
GetTennisSidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetTournaments Method

OddsCreatorFeedProviderGetTournaments Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTournaments(System.Int32)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<IdName> GetTournaments(
    int categoryId
)

Parameters

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTournaments(System.Int32)"]

Return Value

IList IdName

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetTournaments(System.Int32)"]

Implements

IOddsCreatorGetTournaments(Int32)
See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetVolleySidebets Method

OddsCreatorFeedProviderGetVolleySidebets Method

Overload List
 | Name | Description
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Int32, Int32) |
Top
See Also

Reference

OddsCreatorFeedProvider Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32[]) Method

OddsCreatorFeedProviderGetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<OddsType> GetVolleySidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int sportId,
    int gender,
    int topLeague,
    int[] oddsTypeIds
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

oddsTypeIds Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Implements

IOddsCreatorGetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32)
See Also

Reference

OddsCreatorFeedProvider Class
GetVolleySidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Double) Method

OddsCreatorFeedProviderGetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<OddsType> GetVolleySidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int sportId,
    int gender,
    int topLeague,
    int oddsTypeId,
    double oddsKey
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Implements

IOddsCreatorGetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Double)
See Also

Reference

OddsCreatorFeedProvider Class
GetVolleySidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsCreatorFeedProvider.GetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Int32, Int32[]) Method

OddsCreatorFeedProviderGetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<OddsType> GetVolleySidebets(
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int sportId,
    int categoryId,
    int tournamentId,
    int gender,
    int topLeague,
    int[] oddsTypeIds
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

oddsTypeIds Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Return Value

IList OddsType

[Missing <returns> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsCreatorFeedProvider.GetVolleySidebets(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32[])"]

Implements

IOddsCreatorGetVolleySidebets(Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Int32, Int32)
See Also

Reference

OddsCreatorFeedProvider Class
GetVolleySidebets Overload
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsType Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.OddsCreator.OddsType"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.OddsCreatorOddsType

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class OddsType

The OddsType type exposes the following members.

Constructors
 | Name | Description
Public method | OddsType | Initializes a new instance of the OddsType class
Top
Properties
 | Name | Description
Public property | Description |
Public property | OddsTypeId |
Public property | Outcomes |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsType Constructor

Initializes a new instance of the OddsType class

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsType(
    int oddsTypeId,
    string description,
    List<Outcome> outcomes
)

Parameters

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsType.#ctor(System.Int32,System.String,System.Collections.Generic.List{Sportradar.SDK.FeedProviders.OddsCreator.Outcome})"]

description String

[Missing <param name="description"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsType.#ctor(System.Int32,System.String,System.Collections.Generic.List{Sportradar.SDK.FeedProviders.OddsCreator.Outcome})"]

outcomes List Outcome

[Missing <param name="outcomes"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.OddsType.#ctor(System.Int32,System.String,System.Collections.Generic.List{Sportradar.SDK.FeedProviders.OddsCreator.Outcome})"]

See Also

Reference

OddsType Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsType Properties

The OddsType type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | OddsTypeId |
Public property | Outcomes |
Top
See Also

Reference

OddsType Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsType.Description Property

OddsTypeDescription Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.OddsCreator.OddsType.Description"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Description { get; }

Property Value

String
See Also

Reference

OddsType Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsType.OddsTypeId Property

OddsTypeOddsTypeId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.OddsCreator.OddsType.OddsTypeId"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int OddsTypeId { get; }

Property Value

Int32
See Also

Reference

OddsType Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsType.Outcomes Property

OddsTypeOutcomes Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.OddsCreator.OddsType.Outcomes"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ReadOnlyCollection<Outcome> Outcomes { get; }

Property Value

ReadOnlyCollection Outcome
See Also

Reference

OddsType Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


OddsType Methods

The OddsType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OddsType Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


Outcome Class

[Missing <summary> documentation for "T:Sportradar.SDK.FeedProviders.OddsCreator.Outcome"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.OddsCreatorOutcome

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class Outcome

The Outcome type exposes the following members.

Constructors
 | Name | Description
Public method | Outcome | Initializes a new instance of the Outcome class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Odds |
Public property | Spread |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.FeedProviders.OddsCreator Namespace


Outcome Constructor

Initializes a new instance of the Outcome class

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Outcome(
    int id,
    double odds,
    string spread
)

Parameters

id Int32

[Missing <param name="id"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.Outcome.#ctor(System.Int32,System.Double,System.String)"]

odds Double

[Missing <param name="odds"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.Outcome.#ctor(System.Int32,System.Double,System.String)"]

spread String

[Missing <param name="spread"/> documentation for "M:Sportradar.SDK.FeedProviders.OddsCreator.Outcome.#ctor(System.Int32,System.Double,System.String)"]

See Also

Reference

Outcome Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


Outcome Properties

The Outcome type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Odds |
Public property | Spread |
Top
See Also

Reference

Outcome Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


Outcome.Id Property

OutcomeId Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.OddsCreator.Outcome.Id"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Id { get; }

Property Value

Int32
See Also

Reference

Outcome Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


Outcome.Odds Property

OutcomeOdds Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.OddsCreator.Outcome.Odds"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double Odds { get; }

Property Value

Double
See Also

Reference

Outcome Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


Outcome.Spread Property

OutcomeSpread Property

[Missing <summary> documentation for "P:Sportradar.SDK.FeedProviders.OddsCreator.Outcome.Spread"]

Namespace: Sportradar.SDK.FeedProviders.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Spread { get; }

Property Value

String
See Also

Reference

Outcome Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


Outcome Methods

The Outcome type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Outcome Class
Sportradar.SDK.FeedProviders.OddsCreator Namespace


Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace

Classes
 | Class | Description
Public class | checkStatusCompletedEventArgs |
Public class | checkStatusCompletedEventHandler |
Public class | getCategoriesCompletedEventArgs |
Public class | getCategoriesCompletedEventHandler |
Public class | getGendersCompletedEventArgs |
Public class | getGendersCompletedEventHandler |
Public class | getOddsTypeIdsCompletedEventArgs |
Public class | getOddsTypeIdsCompletedEventHandler |
Public class | getOutcomeTypeIdsCompletedEventArgs |
Public class | getOutcomeTypeIdsCompletedEventHandler |
Public class | getSidebetsCompletedEventArgs |
Public class | getSidebetsCompletedEventHandler |
Public class | getSidebetsWithKeyCompletedEventArgs |
Public class | getSidebetsWithKeyCompletedEventHandler |
Public class | getSidebetsWithMatchidAndKeyCompletedEventArgs |
Public class | getSidebetsWithMatchidAndKeyCompletedEventHandler |
Public class | getSidebetsWithMatchidCompletedEventArgs |
Public class | getSidebetsWithMatchidCompletedEventHandler |
Public class | getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs |
Public class | getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler |
Public class | getSportsCompletedEventArgs |
Public class | getSportsCompletedEventHandler |
Public class | getSurfacesCompletedEventArgs |
Public class | getSurfacesCompletedEventHandler |
Public class | getTennisMatchInfoCompletedEventArgs |
Public class | getTennisMatchInfoCompletedEventHandler |
Public class | getTennisSidebetsCompletedEventArgs |
Public class | getTennisSidebetsCompletedEventHandler |
Public class | getTennisSidebetsWithKeyCompletedEventArgs |
Public class | getTennisSidebetsWithKeyCompletedEventHandler |
Public class | getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs |
Public class | getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler |
Public class | getTournamentsCompletedEventArgs |
Public class | getTournamentsCompletedEventHandler |
Public class | getVolleySidebetsCompletedEventArgs |
Public class | getVolleySidebetsCompletedEventHandler |
Public class | getVolleySidebetsWithKeyCompletedEventArgs |
Public class | getVolleySidebetsWithKeyCompletedEventHandler |
Public class | getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs |
Public class | getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler |
Public class | OddsCreatorService |
Public class | oddsTypeData |
Public class | outcome |
Public class | staticInfoData |


checkStatusCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorcheckStatusCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class checkStatusCompletedEventArgs : AsyncCompletedEventArgs

The checkStatusCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


checkStatusCompletedEventArgs Properties

The checkStatusCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

checkStatusCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


checkStatusCompletedEventArgs.Result Property

checkStatusCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Result { get; }

Property Value

String
See Also

Reference

checkStatusCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


checkStatusCompletedEventArgs Methods

The checkStatusCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

checkStatusCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


checkStatusCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorcheckStatusCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class checkStatusCompletedEventHandler : MulticastDelegate

The checkStatusCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | checkStatusCompletedEventHandler | Initializes a new instance of the checkStatusCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


checkStatusCompletedEventHandler Constructor

Initializes a new instance of the checkStatusCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public checkStatusCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

checkStatusCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


checkStatusCompletedEventHandler Properties

The checkStatusCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

checkStatusCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


checkStatusCompletedEventHandler Methods

The checkStatusCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

checkStatusCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


checkStatusCompletedEventHandler.BeginInvoke Method

checkStatusCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    checkStatusCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventArgs,System.AsyncCallback,System.Object)"]

e checkStatusCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

checkStatusCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


checkStatusCompletedEventHandler.EndInvoke Method

checkStatusCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

checkStatusCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


checkStatusCompletedEventHandler.Invoke Method

checkStatusCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    checkStatusCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventArgs)"]

e checkStatusCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.checkStatusCompletedEventArgs)"]

See Also

Reference

checkStatusCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getCategoriesCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetCategoriesCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getCategoriesCompletedEventArgs : AsyncCompletedEventArgs

The getCategoriesCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getCategoriesCompletedEventArgs Properties

The getCategoriesCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getCategoriesCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getCategoriesCompletedEventArgs.Result Property

getCategoriesCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] Result { get; }

Property Value

staticInfoData
See Also

Reference

getCategoriesCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getCategoriesCompletedEventArgs Methods

The getCategoriesCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getCategoriesCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getCategoriesCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetCategoriesCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getCategoriesCompletedEventHandler : MulticastDelegate

The getCategoriesCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getCategoriesCompletedEventHandler | Initializes a new instance of the getCategoriesCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getCategoriesCompletedEventHandler Constructor

Initializes a new instance of the getCategoriesCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getCategoriesCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getCategoriesCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getCategoriesCompletedEventHandler Properties

The getCategoriesCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getCategoriesCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getCategoriesCompletedEventHandler Methods

The getCategoriesCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getCategoriesCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getCategoriesCompletedEventHandler.BeginInvoke Method

getCategoriesCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getCategoriesCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getCategoriesCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getCategoriesCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getCategoriesCompletedEventHandler.EndInvoke Method

getCategoriesCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getCategoriesCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getCategoriesCompletedEventHandler.Invoke Method

getCategoriesCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getCategoriesCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventArgs)"]

e getCategoriesCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getCategoriesCompletedEventArgs)"]

See Also

Reference

getCategoriesCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getGendersCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetGendersCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getGendersCompletedEventArgs : AsyncCompletedEventArgs

The getGendersCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getGendersCompletedEventArgs Properties

The getGendersCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getGendersCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getGendersCompletedEventArgs.Result Property

getGendersCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] Result { get; }

Property Value

staticInfoData
See Also

Reference

getGendersCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getGendersCompletedEventArgs Methods

The getGendersCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getGendersCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getGendersCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetGendersCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getGendersCompletedEventHandler : MulticastDelegate

The getGendersCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getGendersCompletedEventHandler | Initializes a new instance of the getGendersCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getGendersCompletedEventHandler Constructor

Initializes a new instance of the getGendersCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getGendersCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getGendersCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getGendersCompletedEventHandler Properties

The getGendersCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getGendersCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getGendersCompletedEventHandler Methods

The getGendersCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getGendersCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getGendersCompletedEventHandler.BeginInvoke Method

getGendersCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getGendersCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getGendersCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getGendersCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getGendersCompletedEventHandler.EndInvoke Method

getGendersCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getGendersCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getGendersCompletedEventHandler.Invoke Method

getGendersCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getGendersCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventArgs)"]

e getGendersCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getGendersCompletedEventArgs)"]

See Also

Reference

getGendersCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOddsTypeIdsCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetOddsTypeIdsCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getOddsTypeIdsCompletedEventArgs : AsyncCompletedEventArgs

The getOddsTypeIdsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOddsTypeIdsCompletedEventArgs Properties

The getOddsTypeIdsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getOddsTypeIdsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOddsTypeIdsCompletedEventArgs.Result Property

getOddsTypeIdsCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] Result { get; }

Property Value

staticInfoData
See Also

Reference

getOddsTypeIdsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOddsTypeIdsCompletedEventArgs Methods

The getOddsTypeIdsCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getOddsTypeIdsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOddsTypeIdsCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetOddsTypeIdsCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getOddsTypeIdsCompletedEventHandler : MulticastDelegate

The getOddsTypeIdsCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getOddsTypeIdsCompletedEventHandler | Initializes a new instance of the getOddsTypeIdsCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOddsTypeIdsCompletedEventHandler Constructor

Initializes a new instance of the getOddsTypeIdsCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getOddsTypeIdsCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getOddsTypeIdsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOddsTypeIdsCompletedEventHandler Properties

The getOddsTypeIdsCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getOddsTypeIdsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOddsTypeIdsCompletedEventHandler Methods

The getOddsTypeIdsCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getOddsTypeIdsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOddsTypeIdsCompletedEventHandler.BeginInvoke Method

getOddsTypeIdsCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getOddsTypeIdsCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getOddsTypeIdsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getOddsTypeIdsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOddsTypeIdsCompletedEventHandler.EndInvoke Method

getOddsTypeIdsCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getOddsTypeIdsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOddsTypeIdsCompletedEventHandler.Invoke Method

getOddsTypeIdsCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getOddsTypeIdsCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventArgs)"]

e getOddsTypeIdsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOddsTypeIdsCompletedEventArgs)"]

See Also

Reference

getOddsTypeIdsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOutcomeTypeIdsCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetOutcomeTypeIdsCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getOutcomeTypeIdsCompletedEventArgs : AsyncCompletedEventArgs

The getOutcomeTypeIdsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOutcomeTypeIdsCompletedEventArgs Properties

The getOutcomeTypeIdsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getOutcomeTypeIdsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOutcomeTypeIdsCompletedEventArgs.Result Property

getOutcomeTypeIdsCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] Result { get; }

Property Value

staticInfoData
See Also

Reference

getOutcomeTypeIdsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOutcomeTypeIdsCompletedEventArgs Methods

The getOutcomeTypeIdsCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getOutcomeTypeIdsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOutcomeTypeIdsCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetOutcomeTypeIdsCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getOutcomeTypeIdsCompletedEventHandler : MulticastDelegate

The getOutcomeTypeIdsCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getOutcomeTypeIdsCompletedEventHandler | Initializes a new instance of the getOutcomeTypeIdsCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOutcomeTypeIdsCompletedEventHandler Constructor

Initializes a new instance of the getOutcomeTypeIdsCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getOutcomeTypeIdsCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getOutcomeTypeIdsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOutcomeTypeIdsCompletedEventHandler Properties

The getOutcomeTypeIdsCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getOutcomeTypeIdsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOutcomeTypeIdsCompletedEventHandler Methods

The getOutcomeTypeIdsCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getOutcomeTypeIdsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOutcomeTypeIdsCompletedEventHandler.BeginInvoke Method

getOutcomeTypeIdsCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getOutcomeTypeIdsCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getOutcomeTypeIdsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getOutcomeTypeIdsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOutcomeTypeIdsCompletedEventHandler.EndInvoke Method

getOutcomeTypeIdsCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getOutcomeTypeIdsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getOutcomeTypeIdsCompletedEventHandler.Invoke Method

getOutcomeTypeIdsCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getOutcomeTypeIdsCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventArgs)"]

e getOutcomeTypeIdsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getOutcomeTypeIdsCompletedEventArgs)"]

See Also

Reference

getOutcomeTypeIdsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSidebetsCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getSidebetsCompletedEventArgs : AsyncCompletedEventArgs

The getSidebetsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsCompletedEventArgs Properties

The getSidebetsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getSidebetsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsCompletedEventArgs.Result Property

getSidebetsCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] Result { get; }

Property Value

oddsTypeData
See Also

Reference

getSidebetsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsCompletedEventArgs Methods

The getSidebetsCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSidebetsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSidebetsCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getSidebetsCompletedEventHandler : MulticastDelegate

The getSidebetsCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getSidebetsCompletedEventHandler | Initializes a new instance of the getSidebetsCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsCompletedEventHandler Constructor

Initializes a new instance of the getSidebetsCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getSidebetsCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getSidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsCompletedEventHandler Properties

The getSidebetsCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getSidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsCompletedEventHandler Methods

The getSidebetsCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsCompletedEventHandler.BeginInvoke Method

getSidebetsCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getSidebetsCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getSidebetsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getSidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsCompletedEventHandler.EndInvoke Method

getSidebetsCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getSidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsCompletedEventHandler.Invoke Method

getSidebetsCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getSidebetsCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventArgs)"]

e getSidebetsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsCompletedEventArgs)"]

See Also

Reference

getSidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithKeyCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSidebetsWithKeyCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getSidebetsWithKeyCompletedEventArgs : AsyncCompletedEventArgs

The getSidebetsWithKeyCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithKeyCompletedEventArgs Properties

The getSidebetsWithKeyCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getSidebetsWithKeyCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithKeyCompletedEventArgs.Result Property

getSidebetsWithKeyCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] Result { get; }

Property Value

oddsTypeData
See Also

Reference

getSidebetsWithKeyCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithKeyCompletedEventArgs Methods

The getSidebetsWithKeyCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSidebetsWithKeyCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithKeyCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSidebetsWithKeyCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getSidebetsWithKeyCompletedEventHandler : MulticastDelegate

The getSidebetsWithKeyCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getSidebetsWithKeyCompletedEventHandler | Initializes a new instance of the getSidebetsWithKeyCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithKeyCompletedEventHandler Constructor

Initializes a new instance of the getSidebetsWithKeyCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getSidebetsWithKeyCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getSidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithKeyCompletedEventHandler Properties

The getSidebetsWithKeyCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getSidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithKeyCompletedEventHandler Methods

The getSidebetsWithKeyCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithKeyCompletedEventHandler.BeginInvoke Method

getSidebetsWithKeyCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getSidebetsWithKeyCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getSidebetsWithKeyCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getSidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithKeyCompletedEventHandler.EndInvoke Method

getSidebetsWithKeyCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getSidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithKeyCompletedEventHandler.Invoke Method

getSidebetsWithKeyCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getSidebetsWithKeyCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventArgs)"]

e getSidebetsWithKeyCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithKeyCompletedEventArgs)"]

See Also

Reference

getSidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidAndKeyCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSidebetsWithMatchidAndKeyCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getSidebetsWithMatchidAndKeyCompletedEventArgs : AsyncCompletedEventArgs

The getSidebetsWithMatchidAndKeyCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidAndKeyCompletedEventArgs Properties

The getSidebetsWithMatchidAndKeyCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getSidebetsWithMatchidAndKeyCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidAndKeyCompletedEventArgs.Result Property

getSidebetsWithMatchidAndKeyCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] Result { get; }

Property Value

oddsTypeData
See Also

Reference

getSidebetsWithMatchidAndKeyCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidAndKeyCompletedEventArgs Methods

The getSidebetsWithMatchidAndKeyCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSidebetsWithMatchidAndKeyCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidAndKeyCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSidebetsWithMatchidAndKeyCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getSidebetsWithMatchidAndKeyCompletedEventHandler : MulticastDelegate

The getSidebetsWithMatchidAndKeyCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getSidebetsWithMatchidAndKeyCompletedEventHandler | Initializes a new instance of the getSidebetsWithMatchidAndKeyCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidAndKeyCompletedEventHandler Constructor

Initializes a new instance of the getSidebetsWithMatchidAndKeyCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getSidebetsWithMatchidAndKeyCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getSidebetsWithMatchidAndKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidAndKeyCompletedEventHandler Properties

The getSidebetsWithMatchidAndKeyCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getSidebetsWithMatchidAndKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidAndKeyCompletedEventHandler Methods

The getSidebetsWithMatchidAndKeyCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSidebetsWithMatchidAndKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidAndKeyCompletedEventHandler.BeginInvoke Method

getSidebetsWithMatchidAndKeyCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getSidebetsWithMatchidAndKeyCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getSidebetsWithMatchidAndKeyCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getSidebetsWithMatchidAndKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidAndKeyCompletedEventHandler.EndInvoke Method

getSidebetsWithMatchidAndKeyCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getSidebetsWithMatchidAndKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidAndKeyCompletedEventHandler.Invoke Method

getSidebetsWithMatchidAndKeyCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getSidebetsWithMatchidAndKeyCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventArgs)"]

e getSidebetsWithMatchidAndKeyCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidAndKeyCompletedEventArgs)"]

See Also

Reference

getSidebetsWithMatchidAndKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSidebetsWithMatchidCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getSidebetsWithMatchidCompletedEventArgs : AsyncCompletedEventArgs

The getSidebetsWithMatchidCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidCompletedEventArgs Properties

The getSidebetsWithMatchidCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getSidebetsWithMatchidCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidCompletedEventArgs.Result Property

getSidebetsWithMatchidCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] Result { get; }

Property Value

oddsTypeData
See Also

Reference

getSidebetsWithMatchidCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidCompletedEventArgs Methods

The getSidebetsWithMatchidCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSidebetsWithMatchidCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSidebetsWithMatchidCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getSidebetsWithMatchidCompletedEventHandler : MulticastDelegate

The getSidebetsWithMatchidCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getSidebetsWithMatchidCompletedEventHandler | Initializes a new instance of the getSidebetsWithMatchidCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidCompletedEventHandler Constructor

Initializes a new instance of the getSidebetsWithMatchidCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getSidebetsWithMatchidCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getSidebetsWithMatchidCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidCompletedEventHandler Properties

The getSidebetsWithMatchidCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getSidebetsWithMatchidCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidCompletedEventHandler Methods

The getSidebetsWithMatchidCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSidebetsWithMatchidCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidCompletedEventHandler.BeginInvoke Method

getSidebetsWithMatchidCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getSidebetsWithMatchidCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getSidebetsWithMatchidCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getSidebetsWithMatchidCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidCompletedEventHandler.EndInvoke Method

getSidebetsWithMatchidCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getSidebetsWithMatchidCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithMatchidCompletedEventHandler.Invoke Method

getSidebetsWithMatchidCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getSidebetsWithMatchidCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventArgs)"]

e getSidebetsWithMatchidCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithMatchidCompletedEventArgs)"]

See Also

Reference

getSidebetsWithMatchidCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs : AsyncCompletedEventArgs

The getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Properties

The getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs.Result Property

getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] Result { get; }

Property Value

oddsTypeData
See Also

Reference

getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Methods

The getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler : MulticastDelegate

The getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler | Initializes a new instance of the getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Constructor

Initializes a new instance of the getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Properties

The getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Methods

The getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke Method

getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.EndInvoke Method

getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.Invoke Method

getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs)"]

e getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs)"]

See Also

Reference

getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSportsCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSportsCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getSportsCompletedEventArgs : AsyncCompletedEventArgs

The getSportsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSportsCompletedEventArgs Properties

The getSportsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getSportsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSportsCompletedEventArgs.Result Property

getSportsCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] Result { get; }

Property Value

staticInfoData
See Also

Reference

getSportsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSportsCompletedEventArgs Methods

The getSportsCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSportsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSportsCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSportsCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getSportsCompletedEventHandler : MulticastDelegate

The getSportsCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getSportsCompletedEventHandler | Initializes a new instance of the getSportsCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSportsCompletedEventHandler Constructor

Initializes a new instance of the getSportsCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getSportsCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getSportsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSportsCompletedEventHandler Properties

The getSportsCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getSportsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSportsCompletedEventHandler Methods

The getSportsCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSportsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSportsCompletedEventHandler.BeginInvoke Method

getSportsCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getSportsCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getSportsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getSportsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSportsCompletedEventHandler.EndInvoke Method

getSportsCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getSportsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSportsCompletedEventHandler.Invoke Method

getSportsCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getSportsCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventArgs)"]

e getSportsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSportsCompletedEventArgs)"]

See Also

Reference

getSportsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSurfacesCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSurfacesCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getSurfacesCompletedEventArgs : AsyncCompletedEventArgs

The getSurfacesCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSurfacesCompletedEventArgs Properties

The getSurfacesCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getSurfacesCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSurfacesCompletedEventArgs.Result Property

getSurfacesCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] Result { get; }

Property Value

staticInfoData
See Also

Reference

getSurfacesCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSurfacesCompletedEventArgs Methods

The getSurfacesCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSurfacesCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSurfacesCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetSurfacesCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getSurfacesCompletedEventHandler : MulticastDelegate

The getSurfacesCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getSurfacesCompletedEventHandler | Initializes a new instance of the getSurfacesCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSurfacesCompletedEventHandler Constructor

Initializes a new instance of the getSurfacesCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getSurfacesCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getSurfacesCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSurfacesCompletedEventHandler Properties

The getSurfacesCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getSurfacesCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSurfacesCompletedEventHandler Methods

The getSurfacesCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getSurfacesCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSurfacesCompletedEventHandler.BeginInvoke Method

getSurfacesCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getSurfacesCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getSurfacesCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getSurfacesCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSurfacesCompletedEventHandler.EndInvoke Method

getSurfacesCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getSurfacesCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getSurfacesCompletedEventHandler.Invoke Method

getSurfacesCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getSurfacesCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventArgs)"]

e getSurfacesCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getSurfacesCompletedEventArgs)"]

See Also

Reference

getSurfacesCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisMatchInfoCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetTennisMatchInfoCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getTennisMatchInfoCompletedEventArgs : AsyncCompletedEventArgs

The getTennisMatchInfoCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisMatchInfoCompletedEventArgs Properties

The getTennisMatchInfoCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getTennisMatchInfoCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisMatchInfoCompletedEventArgs.Result Property

getTennisMatchInfoCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] Result { get; }

Property Value

staticInfoData
See Also

Reference

getTennisMatchInfoCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisMatchInfoCompletedEventArgs Methods

The getTennisMatchInfoCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getTennisMatchInfoCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisMatchInfoCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetTennisMatchInfoCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getTennisMatchInfoCompletedEventHandler : MulticastDelegate

The getTennisMatchInfoCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getTennisMatchInfoCompletedEventHandler | Initializes a new instance of the getTennisMatchInfoCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisMatchInfoCompletedEventHandler Constructor

Initializes a new instance of the getTennisMatchInfoCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getTennisMatchInfoCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getTennisMatchInfoCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisMatchInfoCompletedEventHandler Properties

The getTennisMatchInfoCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getTennisMatchInfoCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisMatchInfoCompletedEventHandler Methods

The getTennisMatchInfoCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getTennisMatchInfoCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisMatchInfoCompletedEventHandler.BeginInvoke Method

getTennisMatchInfoCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getTennisMatchInfoCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getTennisMatchInfoCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getTennisMatchInfoCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisMatchInfoCompletedEventHandler.EndInvoke Method

getTennisMatchInfoCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getTennisMatchInfoCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisMatchInfoCompletedEventHandler.Invoke Method

getTennisMatchInfoCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getTennisMatchInfoCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventArgs)"]

e getTennisMatchInfoCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisMatchInfoCompletedEventArgs)"]

See Also

Reference

getTennisMatchInfoCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetTennisSidebetsCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getTennisSidebetsCompletedEventArgs : AsyncCompletedEventArgs

The getTennisSidebetsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsCompletedEventArgs Properties

The getTennisSidebetsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getTennisSidebetsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsCompletedEventArgs.Result Property

getTennisSidebetsCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] Result { get; }

Property Value

oddsTypeData
See Also

Reference

getTennisSidebetsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsCompletedEventArgs Methods

The getTennisSidebetsCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getTennisSidebetsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetTennisSidebetsCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getTennisSidebetsCompletedEventHandler : MulticastDelegate

The getTennisSidebetsCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getTennisSidebetsCompletedEventHandler | Initializes a new instance of the getTennisSidebetsCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsCompletedEventHandler Constructor

Initializes a new instance of the getTennisSidebetsCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getTennisSidebetsCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getTennisSidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsCompletedEventHandler Properties

The getTennisSidebetsCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getTennisSidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsCompletedEventHandler Methods

The getTennisSidebetsCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getTennisSidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsCompletedEventHandler.BeginInvoke Method

getTennisSidebetsCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getTennisSidebetsCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getTennisSidebetsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getTennisSidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsCompletedEventHandler.EndInvoke Method

getTennisSidebetsCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getTennisSidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsCompletedEventHandler.Invoke Method

getTennisSidebetsCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getTennisSidebetsCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventArgs)"]

e getTennisSidebetsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsCompletedEventArgs)"]

See Also

Reference

getTennisSidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithKeyCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetTennisSidebetsWithKeyCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getTennisSidebetsWithKeyCompletedEventArgs : AsyncCompletedEventArgs

The getTennisSidebetsWithKeyCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithKeyCompletedEventArgs Properties

The getTennisSidebetsWithKeyCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getTennisSidebetsWithKeyCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithKeyCompletedEventArgs.Result Property

getTennisSidebetsWithKeyCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] Result { get; }

Property Value

oddsTypeData
See Also

Reference

getTennisSidebetsWithKeyCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithKeyCompletedEventArgs Methods

The getTennisSidebetsWithKeyCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getTennisSidebetsWithKeyCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithKeyCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetTennisSidebetsWithKeyCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getTennisSidebetsWithKeyCompletedEventHandler : MulticastDelegate

The getTennisSidebetsWithKeyCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getTennisSidebetsWithKeyCompletedEventHandler | Initializes a new instance of the getTennisSidebetsWithKeyCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithKeyCompletedEventHandler Constructor

Initializes a new instance of the getTennisSidebetsWithKeyCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getTennisSidebetsWithKeyCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getTennisSidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithKeyCompletedEventHandler Properties

The getTennisSidebetsWithKeyCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getTennisSidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithKeyCompletedEventHandler Methods

The getTennisSidebetsWithKeyCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getTennisSidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithKeyCompletedEventHandler.BeginInvoke Method

getTennisSidebetsWithKeyCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getTennisSidebetsWithKeyCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getTennisSidebetsWithKeyCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getTennisSidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithKeyCompletedEventHandler.EndInvoke Method

getTennisSidebetsWithKeyCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getTennisSidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithKeyCompletedEventHandler.Invoke Method

getTennisSidebetsWithKeyCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getTennisSidebetsWithKeyCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventArgs)"]

e getTennisSidebetsWithKeyCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithKeyCompletedEventArgs)"]

See Also

Reference

getTennisSidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs : AsyncCompletedEventArgs

The getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Properties

The getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs.Result Property

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] Result { get; }

Property Value

oddsTypeData
See Also

Reference

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Methods

The getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler : MulticastDelegate

The getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler | Initializes a new instance of the getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Constructor

Initializes a new instance of the getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Properties

The getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Methods

The getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke Method

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.EndInvoke Method

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.Invoke Method

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs)"]

e getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventArgs)"]

See Also

Reference

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTournamentsCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetTournamentsCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getTournamentsCompletedEventArgs : AsyncCompletedEventArgs

The getTournamentsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTournamentsCompletedEventArgs Properties

The getTournamentsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getTournamentsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTournamentsCompletedEventArgs.Result Property

getTournamentsCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] Result { get; }

Property Value

staticInfoData
See Also

Reference

getTournamentsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTournamentsCompletedEventArgs Methods

The getTournamentsCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getTournamentsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTournamentsCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetTournamentsCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getTournamentsCompletedEventHandler : MulticastDelegate

The getTournamentsCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getTournamentsCompletedEventHandler | Initializes a new instance of the getTournamentsCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTournamentsCompletedEventHandler Constructor

Initializes a new instance of the getTournamentsCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getTournamentsCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getTournamentsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTournamentsCompletedEventHandler Properties

The getTournamentsCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getTournamentsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTournamentsCompletedEventHandler Methods

The getTournamentsCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getTournamentsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTournamentsCompletedEventHandler.BeginInvoke Method

getTournamentsCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getTournamentsCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getTournamentsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getTournamentsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTournamentsCompletedEventHandler.EndInvoke Method

getTournamentsCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getTournamentsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getTournamentsCompletedEventHandler.Invoke Method

getTournamentsCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getTournamentsCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventArgs)"]

e getTournamentsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getTournamentsCompletedEventArgs)"]

See Also

Reference

getTournamentsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetVolleySidebetsCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getVolleySidebetsCompletedEventArgs : AsyncCompletedEventArgs

The getVolleySidebetsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsCompletedEventArgs Properties

The getVolleySidebetsCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getVolleySidebetsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsCompletedEventArgs.Result Property

getVolleySidebetsCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] Result { get; }

Property Value

oddsTypeData
See Also

Reference

getVolleySidebetsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsCompletedEventArgs Methods

The getVolleySidebetsCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getVolleySidebetsCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetVolleySidebetsCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getVolleySidebetsCompletedEventHandler : MulticastDelegate

The getVolleySidebetsCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getVolleySidebetsCompletedEventHandler | Initializes a new instance of the getVolleySidebetsCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsCompletedEventHandler Constructor

Initializes a new instance of the getVolleySidebetsCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getVolleySidebetsCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getVolleySidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsCompletedEventHandler Properties

The getVolleySidebetsCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getVolleySidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsCompletedEventHandler Methods

The getVolleySidebetsCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getVolleySidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsCompletedEventHandler.BeginInvoke Method

getVolleySidebetsCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getVolleySidebetsCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getVolleySidebetsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getVolleySidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsCompletedEventHandler.EndInvoke Method

getVolleySidebetsCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getVolleySidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsCompletedEventHandler.Invoke Method

getVolleySidebetsCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getVolleySidebetsCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventArgs)"]

e getVolleySidebetsCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsCompletedEventArgs)"]

See Also

Reference

getVolleySidebetsCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithKeyCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetVolleySidebetsWithKeyCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getVolleySidebetsWithKeyCompletedEventArgs : AsyncCompletedEventArgs

The getVolleySidebetsWithKeyCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithKeyCompletedEventArgs Properties

The getVolleySidebetsWithKeyCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getVolleySidebetsWithKeyCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithKeyCompletedEventArgs.Result Property

getVolleySidebetsWithKeyCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] Result { get; }

Property Value

oddsTypeData
See Also

Reference

getVolleySidebetsWithKeyCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithKeyCompletedEventArgs Methods

The getVolleySidebetsWithKeyCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getVolleySidebetsWithKeyCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithKeyCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetVolleySidebetsWithKeyCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getVolleySidebetsWithKeyCompletedEventHandler : MulticastDelegate

The getVolleySidebetsWithKeyCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getVolleySidebetsWithKeyCompletedEventHandler | Initializes a new instance of the getVolleySidebetsWithKeyCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithKeyCompletedEventHandler Constructor

Initializes a new instance of the getVolleySidebetsWithKeyCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getVolleySidebetsWithKeyCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getVolleySidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithKeyCompletedEventHandler Properties

The getVolleySidebetsWithKeyCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getVolleySidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithKeyCompletedEventHandler Methods

The getVolleySidebetsWithKeyCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getVolleySidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithKeyCompletedEventHandler.BeginInvoke Method

getVolleySidebetsWithKeyCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getVolleySidebetsWithKeyCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getVolleySidebetsWithKeyCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getVolleySidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithKeyCompletedEventHandler.EndInvoke Method

getVolleySidebetsWithKeyCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getVolleySidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithKeyCompletedEventHandler.Invoke Method

getVolleySidebetsWithKeyCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getVolleySidebetsWithKeyCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventArgs)"]

e getVolleySidebetsWithKeyCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithKeyCompletedEventArgs)"]

See Also

Reference

getVolleySidebetsWithKeyCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs"]

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelAsyncCompletedEventArgs
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs : AsyncCompletedEventArgs

The getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Properties

The getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs)
Public property | Result |
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs)
Top
See Also

Reference

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs.Result Property

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgsResult Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs.Result"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] Result { get; }

Property Value

oddsTypeData
See Also

Reference

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Methods

The getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorgetVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler : MulticastDelegate

The getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler type exposes the following members.

Constructors
 | Name | Description
Public method | getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler | Initializes a new instance of the getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Constructor

Initializes a new instance of the getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Properties

The getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Methods

The getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke Method

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandlerBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    Object sender,
    getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs e,
    AsyncCallback callback,
    Object object
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

e getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.BeginInvoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs,System.AsyncCallback,System.Object)"]

See Also

Reference

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.EndInvoke Method

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandlerEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.Invoke Method

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandlerInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    Object sender,
    getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs e
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs)"]

e getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler.Invoke(System.Object,Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventArgs)"]

See Also

Reference

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService"]

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Web.Services.ProtocolsWebClientProtocol
System.Web.Services.ProtocolsHttpWebClientProtocol
System.Web.Services.ProtocolsSoapHttpClientProtocol
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorOddsCreatorService

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class OddsCreatorService : SoapHttpClientProtocol

The OddsCreatorService type exposes the following members.

Constructors
 | Name | Description
Public method | OddsCreatorService | Initializes a new instance of the OddsCreatorService class
Top
Properties
 | Name | Description
Public property | AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol)
Public property | ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol)
Public property | ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component)
Public property | CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol)
Public property | Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol)
Public property | EnableDecompression | Gets or sets a value that indicates whether decompression is enabled for this HttpWebClientProtocol. (Inherited from HttpWebClientProtocol)
Public property | PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol)
Public property | Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol)
Public property | RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component)
Public property | SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol)
Public property | Timeout | Indicates the time an XML Web service client waits for the reply to a synchronous XML Web service request to arrive (in milliseconds). (Inherited from WebClientProtocol)
Public property | UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol)
Public property | Url | Gets or sets the base URL of the XML Web service the client is requesting. (Inherited from WebClientProtocol)
Public property | UseDefaultCredentials | Gets or sets a value that indicates whether to set the Credentials property to the value of the DefaultCredentials property. (Inherited from WebClientProtocol)
Public property | UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol)
Top
Methods
 | Name | Description
Public method | Abort | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol)
Public method | BegincheckStatus |
Public method | BegingetCategories |
Public method | BegingetGenders |
Public method | BegingetOddsTypeIds |
Public method | BegingetOutcomeTypeIds |
Public method | BegingetSidebets |
Public method | BegingetSidebetsWithKey |
Public method | BegingetSidebetsWithMatchid |
Public method | BegingetSidebetsWithMatchidAndKey |
Public method | BegingetSidebetsWithTournamentIdAndCategoryId |
Public method | BegingetSports |
Public method | BegingetSurfaces |
Public method | BegingetTennisMatchInfo |
Public method | BegingetTennisSidebets |
Public method | BegingetTennisSidebetsWithKey |
Public method | BegingetTennisSidebetsWithTournamentIdAndCategoryId |
Public method | BegingetTournaments |
Public method | BegingetVolleySidebets |
Public method | BegingetVolleySidebetsWithKey |
Public method | BegingetVolleySidebetsWithTournamentIdAndCategoryId |
Public method | CancelAsync |
Public method | checkStatus |
Public method | checkStatusAsync |
Public method | checkStatusAsync(Object) |
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject)
Public method | Discover | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component)
Public method | EndcheckStatus |
Public method | EndgetCategories |
Public method | EndgetGenders |
Public method | EndgetOddsTypeIds |
Public method | EndgetOutcomeTypeIds |
Public method | EndgetSidebets |
Public method | EndgetSidebetsWithKey |
Public method | EndgetSidebetsWithMatchid |
Public method | EndgetSidebetsWithMatchidAndKey |
Public method | EndgetSidebetsWithTournamentIdAndCategoryId |
Public method | EndgetSports |
Public method | EndgetSurfaces |
Public method | EndgetTennisMatchInfo |
Public method | EndgetTennisSidebets |
Public method | EndgetTennisSidebetsWithKey |
Public method | EndgetTennisSidebetsWithTournamentIdAndCategoryId |
Public method | EndgetTournaments |
Public method | EndgetVolleySidebets |
Public method | EndgetVolleySidebetsWithKey |
Public method | EndgetVolleySidebetsWithTournamentIdAndCategoryId |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | getCategories |
Public method | getCategoriesAsync(Int32) |
Public method | getCategoriesAsync(Int32, Object) |
Public method | getGenders |
Public method | getGendersAsync |
Public method | getGendersAsync(Object) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Public method | getOddsTypeIds |
Public method | getOddsTypeIdsAsync(Int32, Boolean) |
Public method | getOddsTypeIdsAsync(Int32, Boolean, Object) |
Public method | getOutcomeTypeIds |
Public method | getOutcomeTypeIdsAsync(Int32, Int32) |
Public method | getOutcomeTypeIdsAsync(Int32, Int32, Object) |
Public method | getSidebets |
Public method | getSidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double) |
Public method | getSidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Object) |
Public method | getSidebetsWithKey |
Public method | getSidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Double) |
Public method | getSidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Double, Object) |
Public method | getSidebetsWithMatchid |
Public method | getSidebetsWithMatchidAndKey |
Public method | getSidebetsWithMatchidAndKeyAsync(Int64, Double, Double, Double, Double, Double, Double, Int32, Double) |
Public method | getSidebetsWithMatchidAndKeyAsync(Int64, Double, Double, Double, Double, Double, Double, Int32, Double, Object) |
Public method | getSidebetsWithMatchidAsync(Int64, NullableInt32, Double, Double, Double, Double, Double, Double) |
Public method | getSidebetsWithMatchidAsync(Int64, NullableInt32, Double, Double, Double, Double, Double, Double, Object) |
Public method | getSidebetsWithTournamentIdAndCategoryId |
Public method | getSidebetsWithTournamentIdAndCategoryIdAsync(Int32, Int32, Int32, NullableInt32, Double, Double, Double, Double, Double, Double) |
Public method | getSidebetsWithTournamentIdAndCategoryIdAsync(Int32, Int32, Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Object) |
Public method | getSports |
Public method | getSportsAsync |
Public method | getSportsAsync(Object) |
Public method | getSurfaces |
Public method | getSurfacesAsync |
Public method | getSurfacesAsync(Object) |
Public method | getTennisMatchInfo |
Public method | getTennisMatchInfoAsync(Int64) |
Public method | getTennisMatchInfoAsync(Int64, Object) |
Public method | getTennisSidebets |
Public method | getTennisSidebetsAsync(Double, Double, Int32, Int32, Int32) |
Public method | getTennisSidebetsAsync(Double, Double, Int32, Int32, Int32, Object) |
Public method | getTennisSidebetsWithKey |
Public method | getTennisSidebetsWithKeyAsync(Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | getTennisSidebetsWithKeyAsync(Double, Double, Int32, Int32, Int32, Int32, Double, Object) |
Public method | getTennisSidebetsWithTournamentIdAndCategoryId |
Public method | getTennisSidebetsWithTournamentIdAndCategoryIdAsync(Double, Double, Int32, Int32, Int32, Int32, Int32) |
Public method | getTennisSidebetsWithTournamentIdAndCategoryIdAsync(Double, Double, Int32, Int32, Int32, Int32, Int32, Object) |
Public method | getTournaments |
Public method | getTournamentsAsync(Int32) |
Public method | getTournamentsAsync(Int32, Object) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | getVolleySidebets |
Public method | getVolleySidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32) |
Public method | getVolleySidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32, Object) |
Public method | getVolleySidebetsWithKey |
Public method | getVolleySidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Double) |
Public method | getVolleySidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Double, Object) |
Public method | getVolleySidebetsWithTournamentIdAndCategoryId |
Public method | getVolleySidebetsWithTournamentIdAndCategoryIdAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | getVolleySidebetsWithTournamentIdAndCategoryIdAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Object) |
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component)
Top
Events
 | Name | Description
Public event | checkStatusCompleted |
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component)
Public event | getCategoriesCompleted |
Public event | getGendersCompleted |
Public event | getOddsTypeIdsCompleted |
Public event | getOutcomeTypeIdsCompleted |
Public event | getSidebetsCompleted |
Public event | getSidebetsWithKeyCompleted |
Public event | getSidebetsWithMatchidAndKeyCompleted |
Public event | getSidebetsWithMatchidCompleted |
Public event | getSidebetsWithTournamentIdAndCategoryIdCompleted |
Public event | getSportsCompleted |
Public event | getSurfacesCompleted |
Public event | getTennisMatchInfoCompleted |
Public event | getTennisSidebetsCompleted |
Public event | getTennisSidebetsWithKeyCompleted |
Public event | getTennisSidebetsWithTournamentIdAndCategoryIdCompleted |
Public event | getTournamentsCompleted |
Public event | getVolleySidebetsCompleted |
Public event | getVolleySidebetsWithKeyCompleted |
Public event | getVolleySidebetsWithTournamentIdAndCategoryIdCompleted |
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService Constructor

Initializes a new instance of the OddsCreatorService class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public OddsCreatorService()
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService Properties

The OddsCreatorService type exposes the following members.

Properties
 | Name | Description
Public property | AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol)
Public property | ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol)
Public property | ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component)
Public property | CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol)
Public property | Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol)
Public property | EnableDecompression | Gets or sets a value that indicates whether decompression is enabled for this HttpWebClientProtocol. (Inherited from HttpWebClientProtocol)
Public property | PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol)
Public property | Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol)
Public property | RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component)
Public property | SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol)
Public property | Timeout | Indicates the time an XML Web service client waits for the reply to a synchronous XML Web service request to arrive (in milliseconds). (Inherited from WebClientProtocol)
Public property | UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol)
Public property | Url | Gets or sets the base URL of the XML Web service the client is requesting. (Inherited from WebClientProtocol)
Public property | UseDefaultCredentials | Gets or sets a value that indicates whether to set the Credentials property to the value of the DefaultCredentials property. (Inherited from WebClientProtocol)
Public property | UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol)
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService Methods

The OddsCreatorService type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol)
Public method | BegincheckStatus |
Public method | BegingetCategories |
Public method | BegingetGenders |
Public method | BegingetOddsTypeIds |
Public method | BegingetOutcomeTypeIds |
Public method | BegingetSidebets |
Public method | BegingetSidebetsWithKey |
Public method | BegingetSidebetsWithMatchid |
Public method | BegingetSidebetsWithMatchidAndKey |
Public method | BegingetSidebetsWithTournamentIdAndCategoryId |
Public method | BegingetSports |
Public method | BegingetSurfaces |
Public method | BegingetTennisMatchInfo |
Public method | BegingetTennisSidebets |
Public method | BegingetTennisSidebetsWithKey |
Public method | BegingetTennisSidebetsWithTournamentIdAndCategoryId |
Public method | BegingetTournaments |
Public method | BegingetVolleySidebets |
Public method | BegingetVolleySidebetsWithKey |
Public method | BegingetVolleySidebetsWithTournamentIdAndCategoryId |
Public method | CancelAsync |
Public method | checkStatus |
Public method | checkStatusAsync |
Public method | checkStatusAsync(Object) |
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject)
Public method | Discover | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component)
Public method | EndcheckStatus |
Public method | EndgetCategories |
Public method | EndgetGenders |
Public method | EndgetOddsTypeIds |
Public method | EndgetOutcomeTypeIds |
Public method | EndgetSidebets |
Public method | EndgetSidebetsWithKey |
Public method | EndgetSidebetsWithMatchid |
Public method | EndgetSidebetsWithMatchidAndKey |
Public method | EndgetSidebetsWithTournamentIdAndCategoryId |
Public method | EndgetSports |
Public method | EndgetSurfaces |
Public method | EndgetTennisMatchInfo |
Public method | EndgetTennisSidebets |
Public method | EndgetTennisSidebetsWithKey |
Public method | EndgetTennisSidebetsWithTournamentIdAndCategoryId |
Public method | EndgetTournaments |
Public method | EndgetVolleySidebets |
Public method | EndgetVolleySidebetsWithKey |
Public method | EndgetVolleySidebetsWithTournamentIdAndCategoryId |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | getCategories |
Public method | getCategoriesAsync(Int32) |
Public method | getCategoriesAsync(Int32, Object) |
Public method | getGenders |
Public method | getGendersAsync |
Public method | getGendersAsync(Object) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Public method | getOddsTypeIds |
Public method | getOddsTypeIdsAsync(Int32, Boolean) |
Public method | getOddsTypeIdsAsync(Int32, Boolean, Object) |
Public method | getOutcomeTypeIds |
Public method | getOutcomeTypeIdsAsync(Int32, Int32) |
Public method | getOutcomeTypeIdsAsync(Int32, Int32, Object) |
Public method | getSidebets |
Public method | getSidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double) |
Public method | getSidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Object) |
Public method | getSidebetsWithKey |
Public method | getSidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Double) |
Public method | getSidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Double, Object) |
Public method | getSidebetsWithMatchid |
Public method | getSidebetsWithMatchidAndKey |
Public method | getSidebetsWithMatchidAndKeyAsync(Int64, Double, Double, Double, Double, Double, Double, Int32, Double) |
Public method | getSidebetsWithMatchidAndKeyAsync(Int64, Double, Double, Double, Double, Double, Double, Int32, Double, Object) |
Public method | getSidebetsWithMatchidAsync(Int64, NullableInt32, Double, Double, Double, Double, Double, Double) |
Public method | getSidebetsWithMatchidAsync(Int64, NullableInt32, Double, Double, Double, Double, Double, Double, Object) |
Public method | getSidebetsWithTournamentIdAndCategoryId |
Public method | getSidebetsWithTournamentIdAndCategoryIdAsync(Int32, Int32, Int32, NullableInt32, Double, Double, Double, Double, Double, Double) |
Public method | getSidebetsWithTournamentIdAndCategoryIdAsync(Int32, Int32, Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Object) |
Public method | getSports |
Public method | getSportsAsync |
Public method | getSportsAsync(Object) |
Public method | getSurfaces |
Public method | getSurfacesAsync |
Public method | getSurfacesAsync(Object) |
Public method | getTennisMatchInfo |
Public method | getTennisMatchInfoAsync(Int64) |
Public method | getTennisMatchInfoAsync(Int64, Object) |
Public method | getTennisSidebets |
Public method | getTennisSidebetsAsync(Double, Double, Int32, Int32, Int32) |
Public method | getTennisSidebetsAsync(Double, Double, Int32, Int32, Int32, Object) |
Public method | getTennisSidebetsWithKey |
Public method | getTennisSidebetsWithKeyAsync(Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | getTennisSidebetsWithKeyAsync(Double, Double, Int32, Int32, Int32, Int32, Double, Object) |
Public method | getTennisSidebetsWithTournamentIdAndCategoryId |
Public method | getTennisSidebetsWithTournamentIdAndCategoryIdAsync(Double, Double, Int32, Int32, Int32, Int32, Int32) |
Public method | getTennisSidebetsWithTournamentIdAndCategoryIdAsync(Double, Double, Int32, Int32, Int32, Int32, Int32, Object) |
Public method | getTournaments |
Public method | getTournamentsAsync(Int32) |
Public method | getTournamentsAsync(Int32, Object) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | getVolleySidebets |
Public method | getVolleySidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32) |
Public method | getVolleySidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32, Object) |
Public method | getVolleySidebetsWithKey |
Public method | getVolleySidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Double) |
Public method | getVolleySidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Double, Object) |
Public method | getVolleySidebetsWithTournamentIdAndCategoryId |
Public method | getVolleySidebetsWithTournamentIdAndCategoryIdAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | getVolleySidebetsWithTournamentIdAndCategoryIdAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Object) |
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component)
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegincheckStatus Method

OddsCreatorServiceBegincheckStatus Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegincheckStatus(System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegincheckStatus(
    AsyncCallback callback,
    Object asyncState
)

Parameters

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegincheckStatus(System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegincheckStatus(System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegincheckStatus(System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetCategories Method

OddsCreatorServiceBegingetCategories Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetCategories(System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetCategories(
    int sportId,
    AsyncCallback callback,
    Object asyncState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetCategories(System.Int32,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetCategories(System.Int32,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetCategories(System.Int32,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetCategories(System.Int32,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetGenders Method

OddsCreatorServiceBegingetGenders Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetGenders(System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetGenders(
    AsyncCallback callback,
    Object asyncState
)

Parameters

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetGenders(System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetGenders(System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetGenders(System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetOddsTypeIds Method

OddsCreatorServiceBegingetOddsTypeIds Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetOddsTypeIds(System.Int32,System.Boolean,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetOddsTypeIds(
    int sportId,
    bool needMatchId,
    AsyncCallback callback,
    Object asyncState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetOddsTypeIds(System.Int32,System.Boolean,System.AsyncCallback,System.Object)"]

needMatchId Boolean

[Missing <param name="needMatchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetOddsTypeIds(System.Int32,System.Boolean,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetOddsTypeIds(System.Int32,System.Boolean,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetOddsTypeIds(System.Int32,System.Boolean,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetOddsTypeIds(System.Int32,System.Boolean,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetOutcomeTypeIds Method

OddsCreatorServiceBegingetOutcomeTypeIds Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetOutcomeTypeIds(System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetOutcomeTypeIds(
    int sportId,
    int oddsTypeId,
    AsyncCallback callback,
    Object asyncState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetOutcomeTypeIds(System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetOutcomeTypeIds(System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetOutcomeTypeIds(System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetOutcomeTypeIds(System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetOutcomeTypeIds(System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetSidebets Method

OddsCreatorServiceBegingetSidebets Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetSidebets(
    int sportId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    AsyncCallback callback,
    Object asyncState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetSidebetsWithKey Method

OddsCreatorServiceBegingetSidebetsWithKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetSidebetsWithKey(
    int sportId,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int oddsTypeId,
    double oddsKey,
    AsyncCallback callback,
    Object asyncState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetSidebetsWithMatchid Method

OddsCreatorServiceBegingetSidebetsWithMatchid Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetSidebetsWithMatchid(
    long matchId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    AsyncCallback callback,
    Object asyncState
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetSidebetsWithMatchidAndKey Method

OddsCreatorServiceBegingetSidebetsWithMatchidAndKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetSidebetsWithMatchidAndKey(
    long matchId,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int oddsTypeId,
    double oddsKey,
    AsyncCallback callback,
    Object asyncState
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId Method

OddsCreatorServiceBegingetSidebetsWithTournamentIdAndCategoryId Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetSidebetsWithTournamentIdAndCategoryId(
    int sportId,
    int categoryId,
    int tournamentId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    AsyncCallback callback,
    Object asyncState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetSports Method

OddsCreatorServiceBegingetSports Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSports(System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetSports(
    AsyncCallback callback,
    Object asyncState
)

Parameters

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSports(System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSports(System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSports(System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetSurfaces Method

OddsCreatorServiceBegingetSurfaces Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSurfaces(System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetSurfaces(
    AsyncCallback callback,
    Object asyncState
)

Parameters

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSurfaces(System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSurfaces(System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetSurfaces(System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetTennisMatchInfo Method

OddsCreatorServiceBegingetTennisMatchInfo Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisMatchInfo(System.Int64,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetTennisMatchInfo(
    long matchId,
    AsyncCallback callback,
    Object asyncState
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisMatchInfo(System.Int64,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisMatchInfo(System.Int64,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisMatchInfo(System.Int64,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisMatchInfo(System.Int64,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetTennisSidebets Method

OddsCreatorServiceBegingetTennisSidebets Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetTennisSidebets(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    AsyncCallback callback,
    Object asyncState
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetTennisSidebetsWithKey Method

OddsCreatorServiceBegingetTennisSidebetsWithKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetTennisSidebetsWithKey(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    int oddsTypeId,
    double oddsKey,
    AsyncCallback callback,
    Object asyncState
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetTennisSidebetsWithTournamentIdAndCategoryId Method

OddsCreatorServiceBegingetTennisSidebetsWithTournamentIdAndCategoryId Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetTennisSidebetsWithTournamentIdAndCategoryId(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    int categoryId,
    int tournamentId,
    AsyncCallback callback,
    Object asyncState
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetTournaments Method

OddsCreatorServiceBegingetTournaments Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTournaments(System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetTournaments(
    int categoryId,
    AsyncCallback callback,
    Object asyncState
)

Parameters

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTournaments(System.Int32,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTournaments(System.Int32,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTournaments(System.Int32,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetTournaments(System.Int32,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetVolleySidebets Method

OddsCreatorServiceBegingetVolleySidebets Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetVolleySidebets(
    int sportId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int gender,
    int topLeague,
    AsyncCallback callback,
    Object asyncState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetVolleySidebetsWithKey Method

OddsCreatorServiceBegingetVolleySidebetsWithKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetVolleySidebetsWithKey(
    int sportId,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int gender,
    int topLeague,
    int oddsTypeId,
    double oddsKey,
    AsyncCallback callback,
    Object asyncState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId Method

OddsCreatorServiceBegingetVolleySidebetsWithTournamentIdAndCategoryId Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IAsyncResult BegingetVolleySidebetsWithTournamentIdAndCategoryId(
    int sportId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int gender,
    int topLeague,
    int categoryId,
    int tournamentId,
    AsyncCallback callback,
    Object asyncState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

asyncState Object

[Missing <param name="asyncState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.BegingetVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.CancelAsync Method

OddsCreatorServiceCancelAsync Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.CancelAsync(System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void CancelAsync(
    Object userState
)

Parameters

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.CancelAsync(System.Object)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.checkStatus Method

OddsCreatorServicecheckStatus Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.checkStatus"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string checkStatus()

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.checkStatus"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.checkStatusAsync Method

OddsCreatorServicecheckStatusAsync Method

Overload List
 | Name | Description
Public method | checkStatusAsync |
Public method | checkStatusAsync(Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.checkStatusAsync Method

OddsCreatorServicecheckStatusAsync Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.checkStatusAsync"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void checkStatusAsync()
See Also

Reference

OddsCreatorService Class
checkStatusAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.checkStatusAsync(Object) Method

OddsCreatorServicecheckStatusAsync(Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.checkStatusAsync(System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void checkStatusAsync(
    Object userState
)

Parameters

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.checkStatusAsync(System.Object)"]

See Also

Reference

OddsCreatorService Class
checkStatusAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndcheckStatus Method

OddsCreatorServiceEndcheckStatus Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndcheckStatus(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string EndcheckStatus(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndcheckStatus(System.IAsyncResult)"]

Return Value

String

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndcheckStatus(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetCategories Method

OddsCreatorServiceEndgetCategories Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetCategories(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] EndgetCategories(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetCategories(System.IAsyncResult)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetCategories(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetGenders Method

OddsCreatorServiceEndgetGenders Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetGenders(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] EndgetGenders(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetGenders(System.IAsyncResult)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetGenders(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetOddsTypeIds Method

OddsCreatorServiceEndgetOddsTypeIds Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetOddsTypeIds(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] EndgetOddsTypeIds(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetOddsTypeIds(System.IAsyncResult)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetOddsTypeIds(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetOutcomeTypeIds Method

OddsCreatorServiceEndgetOutcomeTypeIds Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetOutcomeTypeIds(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] EndgetOutcomeTypeIds(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetOutcomeTypeIds(System.IAsyncResult)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetOutcomeTypeIds(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetSidebets Method

OddsCreatorServiceEndgetSidebets Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebets(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] EndgetSidebets(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebets(System.IAsyncResult)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebets(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetSidebetsWithKey Method

OddsCreatorServiceEndgetSidebetsWithKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebetsWithKey(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] EndgetSidebetsWithKey(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebetsWithKey(System.IAsyncResult)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebetsWithKey(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetSidebetsWithMatchid Method

OddsCreatorServiceEndgetSidebetsWithMatchid Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebetsWithMatchid(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] EndgetSidebetsWithMatchid(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebetsWithMatchid(System.IAsyncResult)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebetsWithMatchid(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetSidebetsWithMatchidAndKey Method

OddsCreatorServiceEndgetSidebetsWithMatchidAndKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebetsWithMatchidAndKey(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] EndgetSidebetsWithMatchidAndKey(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebetsWithMatchidAndKey(System.IAsyncResult)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebetsWithMatchidAndKey(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetSidebetsWithTournamentIdAndCategoryId Method

OddsCreatorServiceEndgetSidebetsWithTournamentIdAndCategoryId Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebetsWithTournamentIdAndCategoryId(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] EndgetSidebetsWithTournamentIdAndCategoryId(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebetsWithTournamentIdAndCategoryId(System.IAsyncResult)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSidebetsWithTournamentIdAndCategoryId(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetSports Method

OddsCreatorServiceEndgetSports Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSports(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] EndgetSports(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSports(System.IAsyncResult)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSports(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetSurfaces Method

OddsCreatorServiceEndgetSurfaces Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSurfaces(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] EndgetSurfaces(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSurfaces(System.IAsyncResult)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetSurfaces(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetTennisMatchInfo Method

OddsCreatorServiceEndgetTennisMatchInfo Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTennisMatchInfo(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] EndgetTennisMatchInfo(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTennisMatchInfo(System.IAsyncResult)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTennisMatchInfo(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetTennisSidebets Method

OddsCreatorServiceEndgetTennisSidebets Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTennisSidebets(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] EndgetTennisSidebets(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTennisSidebets(System.IAsyncResult)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTennisSidebets(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetTennisSidebetsWithKey Method

OddsCreatorServiceEndgetTennisSidebetsWithKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTennisSidebetsWithKey(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] EndgetTennisSidebetsWithKey(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTennisSidebetsWithKey(System.IAsyncResult)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTennisSidebetsWithKey(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetTennisSidebetsWithTournamentIdAndCategoryId Method

OddsCreatorServiceEndgetTennisSidebetsWithTournamentIdAndCategoryId Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTennisSidebetsWithTournamentIdAndCategoryId(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] EndgetTennisSidebetsWithTournamentIdAndCategoryId(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTennisSidebetsWithTournamentIdAndCategoryId(System.IAsyncResult)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTennisSidebetsWithTournamentIdAndCategoryId(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetTournaments Method

OddsCreatorServiceEndgetTournaments Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTournaments(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] EndgetTournaments(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTournaments(System.IAsyncResult)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetTournaments(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetVolleySidebets Method

OddsCreatorServiceEndgetVolleySidebets Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetVolleySidebets(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] EndgetVolleySidebets(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetVolleySidebets(System.IAsyncResult)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetVolleySidebets(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetVolleySidebetsWithKey Method

OddsCreatorServiceEndgetVolleySidebetsWithKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetVolleySidebetsWithKey(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] EndgetVolleySidebetsWithKey(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetVolleySidebetsWithKey(System.IAsyncResult)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetVolleySidebetsWithKey(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.EndgetVolleySidebetsWithTournamentIdAndCategoryId Method

OddsCreatorServiceEndgetVolleySidebetsWithTournamentIdAndCategoryId Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetVolleySidebetsWithTournamentIdAndCategoryId(System.IAsyncResult)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] EndgetVolleySidebetsWithTournamentIdAndCategoryId(
    IAsyncResult asyncResult
)

Parameters

asyncResult IAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetVolleySidebetsWithTournamentIdAndCategoryId(System.IAsyncResult)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.EndgetVolleySidebetsWithTournamentIdAndCategoryId(System.IAsyncResult)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getCategories Method

OddsCreatorServicegetCategories Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getCategories(System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] getCategories(
    int sportId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getCategories(System.Int32)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getCategories(System.Int32)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getCategoriesAsync Method

OddsCreatorServicegetCategoriesAsync Method

Overload List
 | Name | Description
Public method | getCategoriesAsync(Int32) |
Public method | getCategoriesAsync(Int32, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getCategoriesAsync(Int32) Method

OddsCreatorServicegetCategoriesAsync(Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getCategoriesAsync(System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getCategoriesAsync(
    int sportId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getCategoriesAsync(System.Int32)"]

See Also

Reference

OddsCreatorService Class
getCategoriesAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getCategoriesAsync(Int32, Object) Method

OddsCreatorServicegetCategoriesAsync(Int32, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getCategoriesAsync(System.Int32,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getCategoriesAsync(
    int sportId,
    Object userState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getCategoriesAsync(System.Int32,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getCategoriesAsync(System.Int32,System.Object)"]

See Also

Reference

OddsCreatorService Class
getCategoriesAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getGenders Method

OddsCreatorServicegetGenders Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getGenders"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] getGenders()

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getGenders"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getGendersAsync Method

OddsCreatorServicegetGendersAsync Method

Overload List
 | Name | Description
Public method | getGendersAsync |
Public method | getGendersAsync(Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getGendersAsync Method

OddsCreatorServicegetGendersAsync Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getGendersAsync"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getGendersAsync()
See Also

Reference

OddsCreatorService Class
getGendersAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getGendersAsync(Object) Method

OddsCreatorServicegetGendersAsync(Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getGendersAsync(System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getGendersAsync(
    Object userState
)

Parameters

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getGendersAsync(System.Object)"]

See Also

Reference

OddsCreatorService Class
getGendersAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getOddsTypeIds Method

OddsCreatorServicegetOddsTypeIds Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOddsTypeIds(System.Int32,System.Boolean)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] getOddsTypeIds(
    int sportId,
    bool needMatchId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOddsTypeIds(System.Int32,System.Boolean)"]

needMatchId Boolean

[Missing <param name="needMatchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOddsTypeIds(System.Int32,System.Boolean)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOddsTypeIds(System.Int32,System.Boolean)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getOddsTypeIdsAsync Method

OddsCreatorServicegetOddsTypeIdsAsync Method

Overload List
 | Name | Description
Public method | getOddsTypeIdsAsync(Int32, Boolean) |
Public method | getOddsTypeIdsAsync(Int32, Boolean, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getOddsTypeIdsAsync(Int32, Boolean) Method

OddsCreatorServicegetOddsTypeIdsAsync(Int32, Boolean) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOddsTypeIdsAsync(System.Int32,System.Boolean)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getOddsTypeIdsAsync(
    int sportId,
    bool needMatchId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOddsTypeIdsAsync(System.Int32,System.Boolean)"]

needMatchId Boolean

[Missing <param name="needMatchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOddsTypeIdsAsync(System.Int32,System.Boolean)"]

See Also

Reference

OddsCreatorService Class
getOddsTypeIdsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getOddsTypeIdsAsync(Int32, Boolean, Object) Method

OddsCreatorServicegetOddsTypeIdsAsync(Int32, Boolean, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOddsTypeIdsAsync(System.Int32,System.Boolean,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getOddsTypeIdsAsync(
    int sportId,
    bool needMatchId,
    Object userState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOddsTypeIdsAsync(System.Int32,System.Boolean,System.Object)"]

needMatchId Boolean

[Missing <param name="needMatchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOddsTypeIdsAsync(System.Int32,System.Boolean,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOddsTypeIdsAsync(System.Int32,System.Boolean,System.Object)"]

See Also

Reference

OddsCreatorService Class
getOddsTypeIdsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getOutcomeTypeIds Method

OddsCreatorServicegetOutcomeTypeIds Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOutcomeTypeIds(System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] getOutcomeTypeIds(
    int sportId,
    int oddsTypeId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOutcomeTypeIds(System.Int32,System.Int32)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOutcomeTypeIds(System.Int32,System.Int32)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOutcomeTypeIds(System.Int32,System.Int32)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getOutcomeTypeIdsAsync Method

OddsCreatorServicegetOutcomeTypeIdsAsync Method

Overload List
 | Name | Description
Public method | getOutcomeTypeIdsAsync(Int32, Int32) |
Public method | getOutcomeTypeIdsAsync(Int32, Int32, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getOutcomeTypeIdsAsync(Int32, Int32) Method

OddsCreatorServicegetOutcomeTypeIdsAsync(Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOutcomeTypeIdsAsync(System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getOutcomeTypeIdsAsync(
    int sportId,
    int oddsTypeId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOutcomeTypeIdsAsync(System.Int32,System.Int32)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOutcomeTypeIdsAsync(System.Int32,System.Int32)"]

See Also

Reference

OddsCreatorService Class
getOutcomeTypeIdsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getOutcomeTypeIdsAsync(Int32, Int32, Object) Method

OddsCreatorServicegetOutcomeTypeIdsAsync(Int32, Int32, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOutcomeTypeIdsAsync(System.Int32,System.Int32,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getOutcomeTypeIdsAsync(
    int sportId,
    int oddsTypeId,
    Object userState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOutcomeTypeIdsAsync(System.Int32,System.Int32,System.Object)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOutcomeTypeIdsAsync(System.Int32,System.Int32,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOutcomeTypeIdsAsync(System.Int32,System.Int32,System.Object)"]

See Also

Reference

OddsCreatorService Class
getOutcomeTypeIdsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebets Method

OddsCreatorServicegetSidebets Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] getSidebets(
    int sportId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsAsync Method

OddsCreatorServicegetSidebetsAsync Method

Overload List
 | Name | Description
Public method | getSidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double) |
Public method | getSidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsAsync(Int32, Nullable<Int32>[], Double, Double, Double, Double, Double, Double) Method

OddsCreatorServicegetSidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSidebetsAsync(
    int sportId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

See Also

Reference

OddsCreatorService Class
getSidebetsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsAsync(Int32, Nullable<Int32>[], Double, Double, Double, Double, Double, Double, Object) Method

OddsCreatorServicegetSidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSidebetsAsync(
    int sportId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    Object userState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

See Also

Reference

OddsCreatorService Class
getSidebetsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithKey Method

OddsCreatorServicegetSidebetsWithKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] getSidebetsWithKey(
    int sportId,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int oddsTypeId,
    double oddsKey
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithKeyAsync Method

OddsCreatorServicegetSidebetsWithKeyAsync Method

Overload List
 | Name | Description
Public method | getSidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Double) |
Public method | getSidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Double, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Double) Method

OddsCreatorServicegetSidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSidebetsWithKeyAsync(
    int sportId,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int oddsTypeId,
    double oddsKey
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

See Also

Reference

OddsCreatorService Class
getSidebetsWithKeyAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Double, Object) Method

OddsCreatorServicegetSidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Double, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSidebetsWithKeyAsync(
    int sportId,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int oddsTypeId,
    double oddsKey,
    Object userState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

See Also

Reference

OddsCreatorService Class
getSidebetsWithKeyAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithMatchid Method

OddsCreatorServicegetSidebetsWithMatchid Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] getSidebetsWithMatchid(
    long matchId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchid(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithMatchidAndKey Method

OddsCreatorServicegetSidebetsWithMatchidAndKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] getSidebetsWithMatchidAndKey(
    long matchId,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int oddsTypeId,
    double oddsKey
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKey(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithMatchidAndKeyAsync Method

OddsCreatorServicegetSidebetsWithMatchidAndKeyAsync Method

Overload List
 | Name | Description
Public method | getSidebetsWithMatchidAndKeyAsync(Int64, Double, Double, Double, Double, Double, Double, Int32, Double) |
Public method | getSidebetsWithMatchidAndKeyAsync(Int64, Double, Double, Double, Double, Double, Double, Int32, Double, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(Int64, Double, Double, Double, Double, Double, Double, Int32, Double) Method

OddsCreatorServicegetSidebetsWithMatchidAndKeyAsync(Int64, Double, Double, Double, Double, Double, Double, Int32, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSidebetsWithMatchidAndKeyAsync(
    long matchId,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int oddsTypeId,
    double oddsKey
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double)"]

See Also

Reference

OddsCreatorService Class
getSidebetsWithMatchidAndKeyAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(Int64, Double, Double, Double, Double, Double, Double, Int32, Double, Object) Method

OddsCreatorServicegetSidebetsWithMatchidAndKeyAsync(Int64, Double, Double, Double, Double, Double, Double, Int32, Double, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSidebetsWithMatchidAndKeyAsync(
    long matchId,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int oddsTypeId,
    double oddsKey,
    Object userState
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyAsync(System.Int64,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Double,System.Object)"]

See Also

Reference

OddsCreatorService Class
getSidebetsWithMatchidAndKeyAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithMatchidAsync Method

OddsCreatorServicegetSidebetsWithMatchidAsync Method

Overload List
 | Name | Description
Public method | getSidebetsWithMatchidAsync(Int64, NullableInt32, Double, Double, Double, Double, Double, Double) |
Public method | getSidebetsWithMatchidAsync(Int64, NullableInt32, Double, Double, Double, Double, Double, Double, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithMatchidAsync(Int64, Nullable<Int32>[], Double, Double, Double, Double, Double, Double) Method

OddsCreatorServicegetSidebetsWithMatchidAsync(Int64, NullableInt32, Double, Double, Double, Double, Double, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSidebetsWithMatchidAsync(
    long matchId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

See Also

Reference

OddsCreatorService Class
getSidebetsWithMatchidAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithMatchidAsync(Int64, Nullable<Int32>[], Double, Double, Double, Double, Double, Double, Object) Method

OddsCreatorServicegetSidebetsWithMatchidAsync(Int64, NullableInt32, Double, Double, Double, Double, Double, Double, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSidebetsWithMatchidAsync(
    long matchId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    Object userState
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAsync(System.Int64,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

See Also

Reference

OddsCreatorService Class
getSidebetsWithMatchidAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId Method

OddsCreatorServicegetSidebetsWithTournamentIdAndCategoryId Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] getSidebetsWithTournamentIdAndCategoryId(
    int sportId,
    int categoryId,
    int tournamentId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryId(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync Method

OddsCreatorServicegetSidebetsWithTournamentIdAndCategoryIdAsync Method

Overload List
 | Name | Description
Public method | getSidebetsWithTournamentIdAndCategoryIdAsync(Int32, Int32, Int32, NullableInt32, Double, Double, Double, Double, Double, Double) |
Public method | getSidebetsWithTournamentIdAndCategoryIdAsync(Int32, Int32, Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(Int32, Int32, Int32, Nullable<Int32>[], Double, Double, Double, Double, Double, Double) Method

OddsCreatorServicegetSidebetsWithTournamentIdAndCategoryIdAsync(Int32, Int32, Int32, NullableInt32, Double, Double, Double, Double, Double, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSidebetsWithTournamentIdAndCategoryIdAsync(
    int sportId,
    int categoryId,
    int tournamentId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

See Also

Reference

OddsCreatorService Class
getSidebetsWithTournamentIdAndCategoryIdAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(Int32, Int32, Int32, Nullable<Int32>[], Double, Double, Double, Double, Double, Double, Object) Method

OddsCreatorServicegetSidebetsWithTournamentIdAndCategoryIdAsync(Int32, Int32, Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSidebetsWithTournamentIdAndCategoryIdAsync(
    int sportId,
    int categoryId,
    int tournamentId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    Object userState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Int32,System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Object)"]

See Also

Reference

OddsCreatorService Class
getSidebetsWithTournamentIdAndCategoryIdAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSports Method

OddsCreatorServicegetSports Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSports"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] getSports()

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSports"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSportsAsync Method

OddsCreatorServicegetSportsAsync Method

Overload List
 | Name | Description
Public method | getSportsAsync |
Public method | getSportsAsync(Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSportsAsync Method

OddsCreatorServicegetSportsAsync Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSportsAsync"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSportsAsync()
See Also

Reference

OddsCreatorService Class
getSportsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSportsAsync(Object) Method

OddsCreatorServicegetSportsAsync(Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSportsAsync(System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSportsAsync(
    Object userState
)

Parameters

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSportsAsync(System.Object)"]

See Also

Reference

OddsCreatorService Class
getSportsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSurfaces Method

OddsCreatorServicegetSurfaces Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSurfaces"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] getSurfaces()

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSurfaces"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSurfacesAsync Method

OddsCreatorServicegetSurfacesAsync Method

Overload List
 | Name | Description
Public method | getSurfacesAsync |
Public method | getSurfacesAsync(Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSurfacesAsync Method

OddsCreatorServicegetSurfacesAsync Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSurfacesAsync"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSurfacesAsync()
See Also

Reference

OddsCreatorService Class
getSurfacesAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSurfacesAsync(Object) Method

OddsCreatorServicegetSurfacesAsync(Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSurfacesAsync(System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getSurfacesAsync(
    Object userState
)

Parameters

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSurfacesAsync(System.Object)"]

See Also

Reference

OddsCreatorService Class
getSurfacesAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisMatchInfo Method

OddsCreatorServicegetTennisMatchInfo Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisMatchInfo(System.Int64)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] getTennisMatchInfo(
    long matchId
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisMatchInfo(System.Int64)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisMatchInfo(System.Int64)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisMatchInfoAsync Method

OddsCreatorServicegetTennisMatchInfoAsync Method

Overload List
 | Name | Description
Public method | getTennisMatchInfoAsync(Int64) |
Public method | getTennisMatchInfoAsync(Int64, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisMatchInfoAsync(Int64) Method

OddsCreatorServicegetTennisMatchInfoAsync(Int64) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisMatchInfoAsync(System.Int64)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getTennisMatchInfoAsync(
    long matchId
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisMatchInfoAsync(System.Int64)"]

See Also

Reference

OddsCreatorService Class
getTennisMatchInfoAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisMatchInfoAsync(Int64, Object) Method

OddsCreatorServicegetTennisMatchInfoAsync(Int64, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisMatchInfoAsync(System.Int64,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getTennisMatchInfoAsync(
    long matchId,
    Object userState
)

Parameters

matchId Int64

[Missing <param name="matchId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisMatchInfoAsync(System.Int64,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisMatchInfoAsync(System.Int64,System.Object)"]

See Also

Reference

OddsCreatorService Class
getTennisMatchInfoAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebets Method

OddsCreatorServicegetTennisSidebets Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] getTennisSidebets(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebets(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsAsync Method

OddsCreatorServicegetTennisSidebetsAsync Method

Overload List
 | Name | Description
Public method | getTennisSidebetsAsync(Double, Double, Int32, Int32, Int32) |
Public method | getTennisSidebetsAsync(Double, Double, Int32, Int32, Int32, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsAsync(Double, Double, Int32, Int32, Int32) Method

OddsCreatorServicegetTennisSidebetsAsync(Double, Double, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getTennisSidebetsAsync(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

OddsCreatorService Class
getTennisSidebetsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsAsync(Double, Double, Int32, Int32, Int32, Object) Method

OddsCreatorServicegetTennisSidebetsAsync(Double, Double, Int32, Int32, Int32, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getTennisSidebetsAsync(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    Object userState
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Object)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Object)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Object)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Object)"]

See Also

Reference

OddsCreatorService Class
getTennisSidebetsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsWithKey Method

OddsCreatorServicegetTennisSidebetsWithKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] getTennisSidebetsWithKey(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    int oddsTypeId,
    double oddsKey
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKey(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsWithKeyAsync Method

OddsCreatorServicegetTennisSidebetsWithKeyAsync Method

Overload List
 | Name | Description
Public method | getTennisSidebetsWithKeyAsync(Double, Double, Int32, Int32, Int32, Int32, Double) |
Public method | getTennisSidebetsWithKeyAsync(Double, Double, Int32, Int32, Int32, Int32, Double, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsWithKeyAsync(Double, Double, Int32, Int32, Int32, Int32, Double) Method

OddsCreatorServicegetTennisSidebetsWithKeyAsync(Double, Double, Int32, Int32, Int32, Int32, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getTennisSidebetsWithKeyAsync(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    int oddsTypeId,
    double oddsKey
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double)"]

See Also

Reference

OddsCreatorService Class
getTennisSidebetsWithKeyAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsWithKeyAsync(Double, Double, Int32, Int32, Int32, Int32, Double, Object) Method

OddsCreatorServicegetTennisSidebetsWithKeyAsync(Double, Double, Int32, Int32, Int32, Int32, Double, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getTennisSidebetsWithKeyAsync(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    int oddsTypeId,
    double oddsKey,
    Object userState
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

See Also

Reference

OddsCreatorService Class
getTennisSidebetsWithKeyAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryId Method

OddsCreatorServicegetTennisSidebetsWithTournamentIdAndCategoryId Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] getTennisSidebetsWithTournamentIdAndCategoryId(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    int categoryId,
    int tournamentId
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryId(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync Method

OddsCreatorServicegetTennisSidebetsWithTournamentIdAndCategoryIdAsync Method

Overload List
 | Name | Description
Public method | getTennisSidebetsWithTournamentIdAndCategoryIdAsync(Double, Double, Int32, Int32, Int32, Int32, Int32) |
Public method | getTennisSidebetsWithTournamentIdAndCategoryIdAsync(Double, Double, Int32, Int32, Int32, Int32, Int32, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(Double, Double, Int32, Int32, Int32, Int32, Int32) Method

OddsCreatorServicegetTennisSidebetsWithTournamentIdAndCategoryIdAsync(Double, Double, Int32, Int32, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getTennisSidebetsWithTournamentIdAndCategoryIdAsync(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    int categoryId,
    int tournamentId
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

OddsCreatorService Class
getTennisSidebetsWithTournamentIdAndCategoryIdAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(Double, Double, Int32, Int32, Int32, Int32, Int32, Object) Method

OddsCreatorServicegetTennisSidebetsWithTournamentIdAndCategoryIdAsync(Double, Double, Int32, Int32, Int32, Int32, Int32, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getTennisSidebetsWithTournamentIdAndCategoryIdAsync(
    double homeOdds,
    double awayOdds,
    int gender,
    int bestOfSets,
    int surface,
    int categoryId,
    int tournamentId,
    Object userState
)

Parameters

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

bestOfSets Int32

[Missing <param name="bestOfSets"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

surface Int32

[Missing <param name="surface"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdAsync(System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

See Also

Reference

OddsCreatorService Class
getTennisSidebetsWithTournamentIdAndCategoryIdAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTournaments Method

OddsCreatorServicegetTournaments Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTournaments(System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData[] getTournaments(
    int categoryId
)

Parameters

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTournaments(System.Int32)"]

Return Value

staticInfoData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTournaments(System.Int32)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTournamentsAsync Method

OddsCreatorServicegetTournamentsAsync Method

Overload List
 | Name | Description
Public method | getTournamentsAsync(Int32) |
Public method | getTournamentsAsync(Int32, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTournamentsAsync(Int32) Method

OddsCreatorServicegetTournamentsAsync(Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTournamentsAsync(System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getTournamentsAsync(
    int categoryId
)

Parameters

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTournamentsAsync(System.Int32)"]

See Also

Reference

OddsCreatorService Class
getTournamentsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTournamentsAsync(Int32, Object) Method

OddsCreatorServicegetTournamentsAsync(Int32, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTournamentsAsync(System.Int32,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getTournamentsAsync(
    int categoryId,
    Object userState
)

Parameters

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTournamentsAsync(System.Int32,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTournamentsAsync(System.Int32,System.Object)"]

See Also

Reference

OddsCreatorService Class
getTournamentsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebets Method

OddsCreatorServicegetVolleySidebets Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] getVolleySidebets(
    int sportId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int gender,
    int topLeague
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebets(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsAsync Method

OddsCreatorServicegetVolleySidebetsAsync Method

Overload List
 | Name | Description
Public method | getVolleySidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32) |
Public method | getVolleySidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsAsync(Int32, Nullable<Int32>[], Double, Double, Double, Double, Double, Double, Int32, Int32) Method

OddsCreatorServicegetVolleySidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getVolleySidebetsAsync(
    int sportId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int gender,
    int topLeague
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32)"]

See Also

Reference

OddsCreatorService Class
getVolleySidebetsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsAsync(Int32, Nullable<Int32>[], Double, Double, Double, Double, Double, Double, Int32, Int32, Object) Method

OddsCreatorServicegetVolleySidebetsAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getVolleySidebetsAsync(
    int sportId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int gender,
    int topLeague,
    Object userState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Object)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Object)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Object)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Object)"]

See Also

Reference

OddsCreatorService Class
getVolleySidebetsAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsWithKey Method

OddsCreatorServicegetVolleySidebetsWithKey Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] getVolleySidebetsWithKey(
    int sportId,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int gender,
    int topLeague,
    int oddsTypeId,
    double oddsKey
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKey(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsWithKeyAsync Method

OddsCreatorServicegetVolleySidebetsWithKeyAsync Method

Overload List
 | Name | Description
Public method | getVolleySidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Double) |
Public method | getVolleySidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Double, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Double) Method

OddsCreatorServicegetVolleySidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Double) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getVolleySidebetsWithKeyAsync(
    int sportId,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int gender,
    int topLeague,
    int oddsTypeId,
    double oddsKey
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double)"]

See Also

Reference

OddsCreatorService Class
getVolleySidebetsWithKeyAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Double, Object) Method

OddsCreatorServicegetVolleySidebetsWithKeyAsync(Int32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Double, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getVolleySidebetsWithKeyAsync(
    int sportId,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int gender,
    int topLeague,
    int oddsTypeId,
    double oddsKey,
    Object userState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

oddsTypeId Int32

[Missing <param name="oddsTypeId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

oddsKey Double

[Missing <param name="oddsKey"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyAsync(System.Int32,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Double,System.Object)"]

See Also

Reference

OddsCreatorService Class
getVolleySidebetsWithKeyAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId Method

OddsCreatorServicegetVolleySidebetsWithTournamentIdAndCategoryId Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData[] getVolleySidebetsWithTournamentIdAndCategoryId(
    int sportId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int gender,
    int topLeague,
    int categoryId,
    int tournamentId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

Return Value

oddsTypeData

[Missing <returns> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryId(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync Method

OddsCreatorServicegetVolleySidebetsWithTournamentIdAndCategoryIdAsync Method

Overload List
 | Name | Description
Public method | getVolleySidebetsWithTournamentIdAndCategoryIdAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) |
Public method | getVolleySidebetsWithTournamentIdAndCategoryIdAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Object) |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(Int32, Nullable<Int32>[], Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) Method

OddsCreatorServicegetVolleySidebetsWithTournamentIdAndCategoryIdAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getVolleySidebetsWithTournamentIdAndCategoryIdAsync(
    int sportId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int gender,
    int topLeague,
    int categoryId,
    int tournamentId
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

OddsCreatorService Class
getVolleySidebetsWithTournamentIdAndCategoryIdAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(Int32, Nullable<Int32>[], Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Object) Method

OddsCreatorServicegetVolleySidebetsWithTournamentIdAndCategoryIdAsync(Int32, NullableInt32, Double, Double, Double, Double, Double, Double, Int32, Int32, Int32, Int32, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void getVolleySidebetsWithTournamentIdAndCategoryIdAsync(
    int sportId,
    int?[] oddsTypeIds,
    double homeOdds,
    double drawOdds,
    double awayOdds,
    double totalSpread,
    double overOdds,
    double underOdds,
    int gender,
    int topLeague,
    int categoryId,
    int tournamentId,
    Object userState
)

Parameters

sportId Int32

[Missing <param name="sportId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

oddsTypeIds Nullable Int32

[Missing <param name="oddsTypeIds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

homeOdds Double

[Missing <param name="homeOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

drawOdds Double

[Missing <param name="drawOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

awayOdds Double

[Missing <param name="awayOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

totalSpread Double

[Missing <param name="totalSpread"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

overOdds Double

[Missing <param name="overOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

underOdds Double

[Missing <param name="underOdds"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

gender Int32

[Missing <param name="gender"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

topLeague Int32

[Missing <param name="topLeague"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

categoryId Int32

[Missing <param name="categoryId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

tournamentId Int32

[Missing <param name="tournamentId"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

userState Object

[Missing <param name="userState"/> documentation for "M:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdAsync(System.Int32,System.Nullable{System.Int32}[],System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Int32,System.Int32,System.Int32,System.Int32,System.Object)"]

See Also

Reference

OddsCreatorService Class
getVolleySidebetsWithTournamentIdAndCategoryIdAsync Overload
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService Events

The OddsCreatorService type exposes the following members.

Events
 | Name | Description
Public event | checkStatusCompleted |
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component)
Public event | getCategoriesCompleted |
Public event | getGendersCompleted |
Public event | getOddsTypeIdsCompleted |
Public event | getOutcomeTypeIdsCompleted |
Public event | getSidebetsCompleted |
Public event | getSidebetsWithKeyCompleted |
Public event | getSidebetsWithMatchidAndKeyCompleted |
Public event | getSidebetsWithMatchidCompleted |
Public event | getSidebetsWithTournamentIdAndCategoryIdCompleted |
Public event | getSportsCompleted |
Public event | getSurfacesCompleted |
Public event | getTennisMatchInfoCompleted |
Public event | getTennisSidebetsCompleted |
Public event | getTennisSidebetsWithKeyCompleted |
Public event | getTennisSidebetsWithTournamentIdAndCategoryIdCompleted |
Public event | getTournamentsCompleted |
Public event | getVolleySidebetsCompleted |
Public event | getVolleySidebetsWithKeyCompleted |
Public event | getVolleySidebetsWithTournamentIdAndCategoryIdCompleted |
Top
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.checkStatusCompleted Event

OddsCreatorServicecheckStatusCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.checkStatusCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event checkStatusCompletedEventHandler checkStatusCompleted

Value

checkStatusCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getCategoriesCompleted Event

OddsCreatorServicegetCategoriesCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getCategoriesCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getCategoriesCompletedEventHandler getCategoriesCompleted

Value

getCategoriesCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getGendersCompleted Event

OddsCreatorServicegetGendersCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getGendersCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getGendersCompletedEventHandler getGendersCompleted

Value

getGendersCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getOddsTypeIdsCompleted Event

OddsCreatorServicegetOddsTypeIdsCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOddsTypeIdsCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getOddsTypeIdsCompletedEventHandler getOddsTypeIdsCompleted

Value

getOddsTypeIdsCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getOutcomeTypeIdsCompleted Event

OddsCreatorServicegetOutcomeTypeIdsCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getOutcomeTypeIdsCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getOutcomeTypeIdsCompletedEventHandler getOutcomeTypeIdsCompleted

Value

getOutcomeTypeIdsCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsCompleted Event

OddsCreatorServicegetSidebetsCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getSidebetsCompletedEventHandler getSidebetsCompleted

Value

getSidebetsCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithKeyCompleted Event

OddsCreatorServicegetSidebetsWithKeyCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithKeyCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getSidebetsWithKeyCompletedEventHandler getSidebetsWithKeyCompleted

Value

getSidebetsWithKeyCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithMatchidAndKeyCompleted Event

OddsCreatorServicegetSidebetsWithMatchidAndKeyCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidAndKeyCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getSidebetsWithMatchidAndKeyCompletedEventHandler getSidebetsWithMatchidAndKeyCompleted

Value

getSidebetsWithMatchidAndKeyCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithMatchidCompleted Event

OddsCreatorServicegetSidebetsWithMatchidCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithMatchidCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getSidebetsWithMatchidCompletedEventHandler getSidebetsWithMatchidCompleted

Value

getSidebetsWithMatchidCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdCompleted Event

OddsCreatorServicegetSidebetsWithTournamentIdAndCategoryIdCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSidebetsWithTournamentIdAndCategoryIdCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler getSidebetsWithTournamentIdAndCategoryIdCompleted

Value

getSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSportsCompleted Event

OddsCreatorServicegetSportsCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSportsCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getSportsCompletedEventHandler getSportsCompleted

Value

getSportsCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getSurfacesCompleted Event

OddsCreatorServicegetSurfacesCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getSurfacesCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getSurfacesCompletedEventHandler getSurfacesCompleted

Value

getSurfacesCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisMatchInfoCompleted Event

OddsCreatorServicegetTennisMatchInfoCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisMatchInfoCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getTennisMatchInfoCompletedEventHandler getTennisMatchInfoCompleted

Value

getTennisMatchInfoCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsCompleted Event

OddsCreatorServicegetTennisSidebetsCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getTennisSidebetsCompletedEventHandler getTennisSidebetsCompleted

Value

getTennisSidebetsCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsWithKeyCompleted Event

OddsCreatorServicegetTennisSidebetsWithKeyCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithKeyCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getTennisSidebetsWithKeyCompletedEventHandler getTennisSidebetsWithKeyCompleted

Value

getTennisSidebetsWithKeyCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdCompleted Event

OddsCreatorServicegetTennisSidebetsWithTournamentIdAndCategoryIdCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTennisSidebetsWithTournamentIdAndCategoryIdCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler getTennisSidebetsWithTournamentIdAndCategoryIdCompleted

Value

getTennisSidebetsWithTournamentIdAndCategoryIdCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getTournamentsCompleted Event

OddsCreatorServicegetTournamentsCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getTournamentsCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getTournamentsCompletedEventHandler getTournamentsCompleted

Value

getTournamentsCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsCompleted Event

OddsCreatorServicegetVolleySidebetsCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getVolleySidebetsCompletedEventHandler getVolleySidebetsCompleted

Value

getVolleySidebetsCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsWithKeyCompleted Event

OddsCreatorServicegetVolleySidebetsWithKeyCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithKeyCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getVolleySidebetsWithKeyCompletedEventHandler getVolleySidebetsWithKeyCompleted

Value

getVolleySidebetsWithKeyCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdCompleted Event

OddsCreatorServicegetVolleySidebetsWithTournamentIdAndCategoryIdCompleted Event

[Missing <summary> documentation for "E:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.OddsCreatorService.getVolleySidebetsWithTournamentIdAndCategoryIdCompleted"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler getVolleySidebetsWithTournamentIdAndCategoryIdCompleted

Value

getVolleySidebetsWithTournamentIdAndCategoryIdCompletedEventHandler
See Also

Reference

OddsCreatorService Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


oddsTypeData Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.oddsTypeData"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatoroddsTypeData

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class oddsTypeData

The oddsTypeData type exposes the following members.

Constructors
 | Name | Description
Public method | oddsTypeData | Initializes a new instance of the oddsTypeData class
Top
Properties
 | Name | Description
Public property | description |
Public property | oddsTypeId |
Public property | outcomes |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


oddsTypeData Constructor

Initializes a new instance of the oddsTypeData class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public oddsTypeData()
See Also

Reference

oddsTypeData Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


oddsTypeData Properties

The oddsTypeData type exposes the following members.

Properties
 | Name | Description
Public property | description |
Public property | oddsTypeId |
Public property | outcomes |
Top
See Also

Reference

oddsTypeData Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


oddsTypeData.description Property

oddsTypeDatadescription Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.oddsTypeData.description"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string description { get; set; }

Property Value

String
See Also

Reference

oddsTypeData Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


oddsTypeData.oddsTypeId Property

oddsTypeDataoddsTypeId Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.oddsTypeData.oddsTypeId"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int oddsTypeId { get; set; }

Property Value

Int32
See Also

Reference

oddsTypeData Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


oddsTypeData.outcomes Property

oddsTypeDataoutcomes Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.oddsTypeData.outcomes"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public outcome[] outcomes { get; set; }

Property Value

outcome
See Also

Reference

oddsTypeData Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


oddsTypeData Methods

The oddsTypeData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

oddsTypeData Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


outcome Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.outcome"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatoroutcome

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class outcome

The outcome type exposes the following members.

Constructors
 | Name | Description
Public method | outcome | Initializes a new instance of the outcome class
Top
Properties
 | Name | Description
Public property | id |
Public property | odds |
Public property | spread |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


outcome Constructor

Initializes a new instance of the outcome class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public outcome()
See Also

Reference

outcome Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


outcome Properties

The outcome type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | odds |
Public property | spread |
Top
See Also

Reference

outcome Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


outcome.id Property

outcomeid Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.outcome.id"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int id { get; set; }

Property Value

Int32
See Also

Reference

outcome Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


outcome.odds Property

outcomeodds Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.outcome.odds"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public double odds { get; set; }

Property Value

Double
See Also

Reference

outcome Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


outcome.spread Property

outcomespread Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.outcome.spread"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string spread { get; set; }

Property Value

String
See Also

Reference

outcome Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


outcome Methods

The outcome type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

outcome Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


staticInfoData Class

[Missing <summary> documentation for "T:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.staticInfoData"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreatorstaticInfoData

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
[SerializableAttribute]
public class staticInfoData

The staticInfoData type exposes the following members.

Constructors
 | Name | Description
Public method | staticInfoData | Initializes a new instance of the staticInfoData class
Top
Properties
 | Name | Description
Public property | id |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


staticInfoData Constructor

Initializes a new instance of the staticInfoData class

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public staticInfoData()
See Also

Reference

staticInfoData Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


staticInfoData Properties

The staticInfoData type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | name |
Top
See Also

Reference

staticInfoData Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


staticInfoData.id Property

staticInfoDataid Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.staticInfoData.id"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int id { get; set; }

Property Value

Int32
See Also

Reference

staticInfoData Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


staticInfoData.name Property

staticInfoDataname Property

[Missing <summary> documentation for "P:Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator.staticInfoData.name"]

Namespace: Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator
Assembly: OddsCreatorProvider (in OddsCreatorProvider.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

staticInfoData Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


staticInfoData Methods

The staticInfoData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

staticInfoData Class
Sportradar.SDK.ProtocolProviders.ProtocolUnits.OddsCreator Namespace


Sportradar.SDK.Services.RateLimiter Namespace

Classes
 | Class | Description
Public class | AndRateGate |
Public class | RateGate |
Public class | RateGateExtensions |
Public class | TokenBucketT |
Public class | TokenBucketTForwardDelegate |
Public class | TokenBucketTObjToSizeDelegate |


AndRateGate Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.RateLimiter.AndRateGate"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.RateLimiterAndRateGate

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class AndRateGate : IRateGate,
    IDisposable

The AndRateGate type exposes the following members.

Constructors
 | Name | Description
Public method | AndRateGate | Initializes a new instance of the AndRateGate class
Top
Properties
 | Name | Description
Public property | Name |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AndRateGate
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Peek |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WaitToProceed(Int32) |
Public method | WaitToProceed(TimeSpan, Int32) |
Top
See Also

Reference

Sportradar.SDK.Services.RateLimiter Namespace


AndRateGate Constructor

Initializes a new instance of the AndRateGate class

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public AndRateGate(
    string name,
    params RateGate[] rate_gates
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.AndRateGate.#ctor(System.String,Sportradar.SDK.Services.RateLimiter.RateGate[])"]

rate_gates RateGate

[Missing <param name="rate_gates"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.AndRateGate.#ctor(System.String,Sportradar.SDK.Services.RateLimiter.RateGate[])"]

See Also

Reference

AndRateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


AndRateGate Properties

The AndRateGate type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

AndRateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


AndRateGate.Name Property

AndRateGateName Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.RateLimiter.AndRateGate.Name"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; }

Property Value

String

Implements

IRateGateName
See Also

Reference

AndRateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


AndRateGate Methods

The AndRateGate type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Peek |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WaitToProceed(Int32) |
Public method | WaitToProceed(TimeSpan, Int32) |
Top
See Also

Reference

AndRateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


AndRateGate.Dispose Method

AndRateGateDispose Method

Releases all resources used by the AndRateGate

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

AndRateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


AndRateGate.Peek Method

AndRateGatePeek Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.AndRateGate.Peek"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan Peek()

Return Value

TimeSpan

[Missing <returns> documentation for "M:Sportradar.SDK.Services.RateLimiter.AndRateGate.Peek"]

Implements

IRateGatePeek
See Also

Reference

AndRateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


AndRateGate.WaitToProceed Method

AndRateGateWaitToProceed Method

Overload List
 | Name | Description
Public method | WaitToProceed(Int32) |
Public method | WaitToProceed(TimeSpan, Int32) |
Top
See Also

Reference

AndRateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


AndRateGate.WaitToProceed(Int32) Method

AndRateGateWaitToProceed(Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.AndRateGate.WaitToProceed(System.Int32)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void WaitToProceed(
    int count
)

Parameters

count Int32

[Missing <param name="count"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.AndRateGate.WaitToProceed(System.Int32)"]

Implements

IRateGateWaitToProceed(Int32)
See Also

Reference

AndRateGate Class
WaitToProceed Overload
Sportradar.SDK.Services.RateLimiter Namespace


AndRateGate.WaitToProceed(TimeSpan, Int32) Method

AndRateGateWaitToProceed(TimeSpan, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.AndRateGate.WaitToProceed(System.TimeSpan,System.Int32)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool WaitToProceed(
    TimeSpan timeout,
    int count
)

Parameters

timeout TimeSpan

[Missing <param name="timeout"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.AndRateGate.WaitToProceed(System.TimeSpan,System.Int32)"]

count Int32

[Missing <param name="count"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.AndRateGate.WaitToProceed(System.TimeSpan,System.Int32)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Services.RateLimiter.AndRateGate.WaitToProceed(System.TimeSpan,System.Int32)"]

See Also

Reference

AndRateGate Class
WaitToProceed Overload
Sportradar.SDK.Services.RateLimiter Namespace


RateGate Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.RateLimiter.RateGate"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.RateLimiterRateGate

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class RateGate : IRateGate, IDisposable

The RateGate type exposes the following members.

Constructors
 | Name | Description
Public method | RateGate | Initializes a new instance of the RateGate class
Top
Properties
 | Name | Description
Public property | Name |
Public property | Occurrences |
Public property | TimeUnitMilliseconds |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RateGate
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Peek |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WaitToProceed(Int32) |
Public method | WaitToProceed(TimeSpan, Int32) |
Top
Fields
 | Name | Description
Public field | m_exit_times |
Top
See Also

Reference

Sportradar.SDK.Services.RateLimiter Namespace


RateGate Constructor

Initializes a new instance of the RateGate class

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public RateGate(
    string name,
    int occurrences,
    TimeSpan time_unit,
    int granularity = 1
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGate.#ctor(System.String,System.Int32,System.TimeSpan,System.Int32)"]

occurrences Int32

[Missing <param name="occurrences"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGate.#ctor(System.String,System.Int32,System.TimeSpan,System.Int32)"]

time_unit TimeSpan

[Missing <param name="time_unit"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGate.#ctor(System.String,System.Int32,System.TimeSpan,System.Int32)"]

granularity Int32 (Optional)

[Missing <param name="granularity"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGate.#ctor(System.String,System.Int32,System.TimeSpan,System.Int32)"]

See Also

Reference

RateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


RateGate Properties

The RateGate type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Occurrences |
Public property | TimeUnitMilliseconds |
Top
See Also

Reference

RateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


RateGate.Name Property

RateGateName Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.RateLimiter.RateGate.Name"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; }

Property Value

String

Implements

IRateGateName
See Also

Reference

RateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


RateGate.Occurrences Property

RateGateOccurrences Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.RateLimiter.RateGate.Occurrences"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Occurrences { get; }

Property Value

Int32
See Also

Reference

RateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


RateGate.TimeUnitMilliseconds Property

RateGateTimeUnitMilliseconds Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.RateLimiter.RateGate.TimeUnitMilliseconds"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int TimeUnitMilliseconds { get; }

Property Value

Int32
See Also

Reference

RateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


RateGate Methods

The RateGate type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Peek |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WaitToProceed(Int32) |
Public method | WaitToProceed(TimeSpan, Int32) |
Top
See Also

Reference

RateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


RateGate.Dispose Method

RateGateDispose Method

Releases all resources used by the RateGate

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

RateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


RateGate.Peek Method

RateGatePeek Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGate.Peek"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan Peek()

Return Value

TimeSpan

[Missing <returns> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGate.Peek"]

Implements

IRateGatePeek
See Also

Reference

RateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


RateGate.WaitToProceed Method

RateGateWaitToProceed Method

Overload List
 | Name | Description
Public method | WaitToProceed(Int32) |
Public method | WaitToProceed(TimeSpan, Int32) |
Top
See Also

Reference

RateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


RateGate.WaitToProceed(Int32) Method

RateGateWaitToProceed(Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGate.WaitToProceed(System.Int32)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void WaitToProceed(
    int count
)

Parameters

count Int32

[Missing <param name="count"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGate.WaitToProceed(System.Int32)"]

Implements

IRateGateWaitToProceed(Int32)
See Also

Reference

RateGate Class
WaitToProceed Overload
Sportradar.SDK.Services.RateLimiter Namespace


RateGate.WaitToProceed(TimeSpan, Int32) Method

RateGateWaitToProceed(TimeSpan, Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGate.WaitToProceed(System.TimeSpan,System.Int32)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool WaitToProceed(
    TimeSpan timeout,
    int count
)

Parameters

timeout TimeSpan

[Missing <param name="timeout"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGate.WaitToProceed(System.TimeSpan,System.Int32)"]

count Int32

[Missing <param name="count"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGate.WaitToProceed(System.TimeSpan,System.Int32)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGate.WaitToProceed(System.TimeSpan,System.Int32)"]

See Also

Reference

RateGate Class
WaitToProceed Overload
Sportradar.SDK.Services.RateLimiter Namespace


RateGate Fields

The RateGate type exposes the following members.

Fields
 | Name | Description
Public field | m_exit_times |
Top
See Also

Reference

RateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


RateGate.m_exit_times Field

RateGatem_exit_times Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.RateLimiter.RateGate.m_exit_times"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public readonly Queue<int> m_exit_times

Field Value

Queue Int32
See Also

Reference

RateGate Class
Sportradar.SDK.Services.RateLimiter Namespace


RateGateExtensions Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.RateLimiter.RateGateExtensions"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.RateLimiterRateGateExtensions

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class RateGateExtensions

The RateGateExtensions type exposes the following members.

Methods
 | Name | Description
Public Extension Method | LimitRateT |
Top
See Also

Reference

Sportradar.SDK.Services.RateLimiter Namespace


RateGateExtensions Methods

The RateGateExtensions type exposes the following members.

Methods
 | Name | Description
Public Extension Method | LimitRateT |
Top
See Also

Reference

RateGateExtensions Class
Sportradar.SDK.Services.RateLimiter Namespace


RateGateExtensions.LimitRate<T> Method

RateGateExtensionsLimitRateT Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGateExtensions.LimitRate``1(System.Collections.Generic.IEnumerable{``0},System.String,System.Int32,System.TimeSpan)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static IEnumerable<T> LimitRate<T>(
    this IEnumerable<T> source,
    string name,
    int count,
    TimeSpan timeUnit
)

Parameters

source IEnumerable T

[Missing <param name="source"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGateExtensions.LimitRate``1(System.Collections.Generic.IEnumerable{``0},System.String,System.Int32,System.TimeSpan)"]

name String

[Missing <param name="name"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGateExtensions.LimitRate``1(System.Collections.Generic.IEnumerable{``0},System.String,System.Int32,System.TimeSpan)"]

count Int32

[Missing <param name="count"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGateExtensions.LimitRate``1(System.Collections.Generic.IEnumerable{``0},System.String,System.Int32,System.TimeSpan)"]

timeUnit TimeSpan

[Missing <param name="timeUnit"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGateExtensions.LimitRate``1(System.Collections.Generic.IEnumerable{``0},System.String,System.Int32,System.TimeSpan)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGateExtensions.LimitRate``1(System.Collections.Generic.IEnumerable{``0},System.String,System.Int32,System.TimeSpan)"]

Return Value

IEnumerable T

[Missing <returns> documentation for "M:Sportradar.SDK.Services.RateLimiter.RateGateExtensions.LimitRate``1(System.Collections.Generic.IEnumerable{``0},System.String,System.Int32,System.TimeSpan)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RateGateExtensions Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T> Class

TokenBucketT Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.RateLimiter.TokenBucket`1"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.RateLimiterTokenBucketT

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class TokenBucket<T>

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Sportradar.SDK.Services.RateLimiter.TokenBucket`1"]

The TokenBucketT type exposes the following members.

Constructors
 | Name | Description
Public method | TokenBucketT | Initializes a new instance of the TokenBucketT class
Top
Properties
 | Name | Description
Public property | Name |
Top
Methods
 | Name | Description
Public method | Dispatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FillBucket(Int32) |
Public method | FillBucket(T) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | StartFilling |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Fields
Name | Description
DEF_QUEUE_SIZE |
Top
See Also

Reference

Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T> Constructor

TokenBucketT Constructor

Initializes a new instance of the TokenBucketT class

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TokenBucket(
    string name,
    int bucket_capacity,
    int initial_bucket_size,
    int bucket_fill_speed,
    int queue_size,
    TokenBucketTObjToSizeDelegate size_callback,
    TokenBucketTForwardDelegate forward_callback
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.#ctor(System.String,System.Int32,System.Int32,System.Int32,System.Int32,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ObjToSizeDelegate,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ForwardDelegate)"]

bucket_capacity Int32

[Missing <param name="bucket_capacity"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.#ctor(System.String,System.Int32,System.Int32,System.Int32,System.Int32,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ObjToSizeDelegate,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ForwardDelegate)"]

initial_bucket_size Int32

[Missing <param name="initial_bucket_size"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.#ctor(System.String,System.Int32,System.Int32,System.Int32,System.Int32,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ObjToSizeDelegate,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ForwardDelegate)"]

bucket_fill_speed Int32

[Missing <param name="bucket_fill_speed"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.#ctor(System.String,System.Int32,System.Int32,System.Int32,System.Int32,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ObjToSizeDelegate,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ForwardDelegate)"]

queue_size Int32

[Missing <param name="queue_size"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.#ctor(System.String,System.Int32,System.Int32,System.Int32,System.Int32,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ObjToSizeDelegate,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ForwardDelegate)"]

size_callback TokenBucketTObjToSizeDelegate

[Missing <param name="size_callback"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.#ctor(System.String,System.Int32,System.Int32,System.Int32,System.Int32,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ObjToSizeDelegate,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ForwardDelegate)"]

forward_callback TokenBucketTForwardDelegate

[Missing <param name="forward_callback"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.#ctor(System.String,System.Int32,System.Int32,System.Int32,System.Int32,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ObjToSizeDelegate,Sportradar.SDK.Services.RateLimiter.TokenBucket{`0}.ForwardDelegate)"]

See Also

Reference

TokenBucketT Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T> Properties

TokenBucketT Properties

The TokenBucketT type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

TokenBucketT Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.Name Property

TokenBucketTName Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.Name"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Name { get; }

Property Value

String
See Also

Reference

TokenBucketT Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T> Methods

TokenBucketT Methods

The TokenBucketT type exposes the following members.

Methods
 | Name | Description
Public method | Dispatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FillBucket(Int32) |
Public method | FillBucket(T) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | StartFilling |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TokenBucketT Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.Dispatch Method

TokenBucketTDispatch Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.Dispatch(`0)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Dispatch(
    T obj
)

Parameters

obj T

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.Dispatch(`0)"]

See Also

Reference

TokenBucketT Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.FillBucket Method

TokenBucketTFillBucket Method

Overload List
 | Name | Description
Public method | FillBucket(Int32) |
Public method | FillBucket(T) |
Top
See Also

Reference

TokenBucketT Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.FillBucket(Int32) Method

TokenBucketTFillBucket(Int32) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.FillBucket(System.Int32)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int FillBucket(
    int bytes
)

Parameters

bytes Int32

[Missing <param name="bytes"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.FillBucket(System.Int32)"]

Return Value

Int32

[Missing <returns> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.FillBucket(System.Int32)"]

See Also

Reference

TokenBucketT Class
FillBucket Overload
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.FillBucket(T) Method

TokenBucketTFillBucket(T) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.FillBucket(`0)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int FillBucket(
    T obj
)

Parameters

obj T

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.FillBucket(`0)"]

Return Value

Int32

[Missing <returns> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.FillBucket(`0)"]

See Also

Reference

TokenBucketT Class
FillBucket Overload
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.StartFilling Method

TokenBucketTStartFilling Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.StartFilling"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void StartFilling()
See Also

Reference

TokenBucketT Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T> Fields

TokenBucketT Fields

The TokenBucketT type exposes the following members.

Fields
Name | Description
DEF_QUEUE_SIZE |
Top
See Also

Reference

TokenBucketT Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.DEF_QUEUE_SIZE Field

TokenBucketTDEF_QUEUE_SIZE Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.DEF_QUEUE_SIZE"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const int DEF_QUEUE_SIZE = 512

Field Value

Int32
See Also

Reference

TokenBucketT Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.ForwardDelegate Class

TokenBucketTForwardDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ForwardDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Services.RateLimiterTokenBucketTForwardDelegate

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class ForwardDelegate : MulticastDelegate

The TokenBucketTForwardDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | TokenBucketTForwardDelegate | Initializes a new instance of the TokenBucketTForwardDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.ForwardDelegate Constructor

TokenBucketTForwardDelegate Constructor

Initializes a new instance of the TokenBucketTForwardDelegate class

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ForwardDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ForwardDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ForwardDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

TokenBucketTForwardDelegate Class
Sportradar.SDK.Services.RateLimiter Namespace


ForwardDelegate Properties

The TokenBucketTForwardDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

TokenBucketTForwardDelegate Class
Sportradar.SDK.Services.RateLimiter Namespace


ForwardDelegate Methods

The TokenBucketTForwardDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TokenBucketTForwardDelegate Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.ForwardDelegate.BeginInvoke Method

TokenBucketTForwardDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ForwardDelegate.BeginInvoke(`0,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    T obj,
    AsyncCallback callback,
    Object object
)

Parameters

obj T

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ForwardDelegate.BeginInvoke(`0,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ForwardDelegate.BeginInvoke(`0,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ForwardDelegate.BeginInvoke(`0,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ForwardDelegate.BeginInvoke(`0,System.AsyncCallback,System.Object)"]

See Also

Reference

TokenBucketTForwardDelegate Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.ForwardDelegate.EndInvoke Method

TokenBucketTForwardDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ForwardDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ForwardDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

TokenBucketTForwardDelegate Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.ForwardDelegate.Invoke Method

TokenBucketTForwardDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ForwardDelegate.Invoke(`0)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke(
    T obj
)

Parameters

obj T

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ForwardDelegate.Invoke(`0)"]

See Also

Reference

TokenBucketTForwardDelegate Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.ObjToSizeDelegate Class

TokenBucketTObjToSizeDelegate Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate"]

Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Services.RateLimiterTokenBucketTObjToSizeDelegate

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class ObjToSizeDelegate : MulticastDelegate

The TokenBucketTObjToSizeDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | TokenBucketTObjToSizeDelegate | Initializes a new instance of the TokenBucketTObjToSizeDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.ObjToSizeDelegate Constructor

TokenBucketTObjToSizeDelegate Constructor

Initializes a new instance of the TokenBucketTObjToSizeDelegate class

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ObjToSizeDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

TokenBucketTObjToSizeDelegate Class
Sportradar.SDK.Services.RateLimiter Namespace


ObjToSizeDelegate Properties

The TokenBucketTObjToSizeDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

TokenBucketTObjToSizeDelegate Class
Sportradar.SDK.Services.RateLimiter Namespace


ObjToSizeDelegate Methods

The TokenBucketTObjToSizeDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TokenBucketTObjToSizeDelegate Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.ObjToSizeDelegate.BeginInvoke Method

TokenBucketTObjToSizeDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.BeginInvoke(`0,System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    T obj,
    AsyncCallback callback,
    Object object
)

Parameters

obj T

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.BeginInvoke(`0,System.AsyncCallback,System.Object)"]

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.BeginInvoke(`0,System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.BeginInvoke(`0,System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.BeginInvoke(`0,System.AsyncCallback,System.Object)"]

See Also

Reference

TokenBucketTObjToSizeDelegate Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.ObjToSizeDelegate.EndInvoke Method

TokenBucketTObjToSizeDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual int EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.EndInvoke(System.IAsyncResult)"]

Return Value

Int32

[Missing <returns> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

TokenBucketTObjToSizeDelegate Class
Sportradar.SDK.Services.RateLimiter Namespace


TokenBucket<T>.ObjToSizeDelegate.Invoke Method

TokenBucketTObjToSizeDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.Invoke(`0)"]

Namespace: Sportradar.SDK.Services.RateLimiter
Assembly: RateLimiter (in RateLimiter.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual int Invoke(
    T obj
)

Parameters

obj T

[Missing <param name="obj"/> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.Invoke(`0)"]

Return Value

Int32

[Missing <returns> documentation for "M:Sportradar.SDK.Services.RateLimiter.TokenBucket`1.ObjToSizeDelegate.Invoke(`0)"]

See Also

Reference

TokenBucketTObjToSizeDelegate Class
Sportradar.SDK.Services.RateLimiter Namespace


Sportradar.SDK.Services.Sdk Namespace

Classes
 | Class | Description
Public class | DummyDeadLetterQueue |
Public class | DummyPersistentState |
Public class | LiveOddsFeedProviderVfc | Virtual football cup LiveOdds provider.
Public class | NonPublicActivator |
Public class | NonPublicConstructorDependenciesModelInspector |
Public class | QueueSupervisor |
 | Sdk | Main entry point for the SDK client application.


DummyDeadLetterQueue Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.DummyDeadLetterQueue"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.SdkDummyDeadLetterQueue

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class DummyDeadLetterQueue : IDeadLetterQueue

The DummyDeadLetterQueue type exposes the following members.

Constructors
 | Name | Description
Public method | DummyDeadLetterQueue | Initializes a new instance of the DummyDeadLetterQueue class
Top
Methods
 | Name | Description
Public method | Enqueue |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk Namespace


DummyDeadLetterQueue Constructor

Initializes a new instance of the DummyDeadLetterQueue class

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DummyDeadLetterQueue()
See Also

Reference

DummyDeadLetterQueue Class
Sportradar.SDK.Services.Sdk Namespace


DummyDeadLetterQueue Methods

The DummyDeadLetterQueue type exposes the following members.

Methods
 | Name | Description
Public method | Enqueue |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DummyDeadLetterQueue Class
Sportradar.SDK.Services.Sdk Namespace


DummyDeadLetterQueue.Enqueue Method

DummyDeadLetterQueueEnqueue Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.DummyDeadLetterQueue.Enqueue(Sportradar.SDK.Common.EntityBase)"]

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Enqueue(
    EntityBase failed_msg
)

Parameters

failed_msg EntityBase

[Missing <param name="failed_msg"/> documentation for "M:Sportradar.SDK.Services.Sdk.DummyDeadLetterQueue.Enqueue(Sportradar.SDK.Common.EntityBase)"]

Implements

IDeadLetterQueueEnqueue(EntityBase)
See Also

Reference

DummyDeadLetterQueue Class
Sportradar.SDK.Services.Sdk Namespace


DummyPersistentState Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.DummyPersistentState"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.SdkDummyPersistentState

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class DummyPersistentState : IClientPersistentState

The DummyPersistentState type exposes the following members.

Constructors
 | Name | Description
Public method | DummyPersistentState | Initializes a new instance of the DummyPersistentState class
Top
Methods
 | Name | Description
Public method | Clear |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Read |
Public method | ReadAll |
Public method | Remove |
Public method | RemoveOld |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Write |
Top
See Also

Reference

Sportradar.SDK.Services.Sdk Namespace


DummyPersistentState Constructor

Initializes a new instance of the DummyPersistentState class

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public DummyPersistentState()
See Also

Reference

DummyPersistentState Class
Sportradar.SDK.Services.Sdk Namespace


DummyPersistentState Methods

The DummyPersistentState type exposes the following members.

Methods
 | Name | Description
Public method | Clear |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Read |
Public method | ReadAll |
Public method | Remove |
Public method | RemoveOld |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Write |
Top
See Also

Reference

DummyPersistentState Class
Sportradar.SDK.Services.Sdk Namespace


DummyPersistentState.Clear Method

DummyPersistentStateClear Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.DummyPersistentState.Clear"]

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Clear()

Implements

IClientPersistentStateClear
See Also

Reference

DummyPersistentState Class
Sportradar.SDK.Services.Sdk Namespace


DummyPersistentState.Read Method

DummyPersistentStateRead Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.DummyPersistentState.Read(System.String)"]

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ClientPersistentStateItem Read(
    string key
)

Parameters

key String

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Services.Sdk.DummyPersistentState.Read(System.String)"]

Return Value

ClientPersistentStateItem

[Missing <returns> documentation for "M:Sportradar.SDK.Services.Sdk.DummyPersistentState.Read(System.String)"]

Implements

IClientPersistentStateRead(String)
See Also

Reference

DummyPersistentState Class
Sportradar.SDK.Services.Sdk Namespace


DummyPersistentState.ReadAll Method

DummyPersistentStateReadAll Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.DummyPersistentState.ReadAll"]

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IEnumerable<ClientPersistentStateItem> ReadAll()

Return Value

IEnumerable ClientPersistentStateItem

[Missing <returns> documentation for "M:Sportradar.SDK.Services.Sdk.DummyPersistentState.ReadAll"]

Implements

IClientPersistentStateReadAll
See Also

Reference

DummyPersistentState Class
Sportradar.SDK.Services.Sdk Namespace


DummyPersistentState.Remove Method

DummyPersistentStateRemove Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.DummyPersistentState.Remove(System.String)"]

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Remove(
    string key
)

Parameters

key String

[Missing <param name="key"/> documentation for "M:Sportradar.SDK.Services.Sdk.DummyPersistentState.Remove(System.String)"]

Implements

IClientPersistentStateRemove(String)
See Also

Reference

DummyPersistentState Class
Sportradar.SDK.Services.Sdk Namespace


DummyPersistentState.RemoveOld Method

DummyPersistentStateRemoveOld Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.DummyPersistentState.RemoveOld(System.DateTime)"]

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void RemoveOld(
    DateTime max_age
)

Parameters

max_age DateTime

[Missing <param name="max_age"/> documentation for "M:Sportradar.SDK.Services.Sdk.DummyPersistentState.RemoveOld(System.DateTime)"]

See Also

Reference

DummyPersistentState Class
Sportradar.SDK.Services.Sdk Namespace


DummyPersistentState.Write Method

DummyPersistentStateWrite Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.DummyPersistentState.Write(System.Collections.Generic.IList{Sportradar.SDK.Common.ClientPersistentStateItem})"]

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Write(
    IList<ClientPersistentStateItem> items
)

Parameters

items IList ClientPersistentStateItem

[Missing <param name="items"/> documentation for "M:Sportradar.SDK.Services.Sdk.DummyPersistentState.Write(System.Collections.Generic.IList{Sportradar.SDK.Common.ClientPersistentStateItem})"]

See Also

Reference

DummyPersistentState Class
Sportradar.SDK.Services.Sdk Namespace


LiveOddsFeedProviderVfc Class

Virtual football cup LiveOdds provider.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsCommonFeedProviderBase
Sportradar.SDK.FeedProviders.LiveOdds.InternalLiveOddsWithOutrightsFeedProvider
Sportradar.SDK.Services.SdkLiveOddsFeedProviderVfc

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsFeedProviderVfc : LiveOddsWithOutrightsFeedProvider

The LiveOddsFeedProviderVfc type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsFeedProviderVfc | Initializes a new instance of the LiveOddsFeedProviderVfc class
Top
Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsCommonFeedProviderBaseProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOutrightList | Request meta-information about outrights specified by it's ids (Inherited from LiveOddsWithOutrightsFeedProvider)
Public method | GetOutrightsStatus | Requests the outright statuses for a given time ("current" server request). This includes odds, activation of odds and status for the outright requested, current bet status and all bet clearing messages before the timestamp. (Inherited from LiveOddsWithOutrightsFeedProvider)
Public method | GetOutrightStatus | Requests the outright status for a given time ("current" server request). This includes odds, activation of odds and status for the ouright requested, current bet status and all bet clearing messages before the timestamp. (Inherited from LiveOddsWithOutrightsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | Start component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Stop | Stop / shutdown component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
Events
Name Description
Public event OnAliveWithOutrights Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
(Inherited from LiveOddsWithOutrightsFeedProvider)
Public event OnBetCancel Occurs when [on bet cancel].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetCancelUndo Occurs when [on bet cancel undone].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetClear Occurs when [on bet clear].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetClearRollback Occurs when [on bet clear rollback].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetStart Occurs when [on bet start].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetStop Occurs when [on bet stop].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnConnectionStable Occurs when connection stable.
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnConnectionUnstable Occurs when connection unstable.
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnEventMessages Occurs when [on match messages received].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnEventStatus Occurs when [on match status received].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnFeedError Occurs when [on feed error].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnMetaInfo Occurs when [on meta info received].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnOddsChange Occurs when [on odds change].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnOutrightBetCancel Signals that odds type for an outright should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
(Inherited from LiveOddsWithOutrightsFeedProvider)
Public event OnOutrightBetClear

Signals that bets placed on this outright can be settled Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

(Inherited from LiveOddsWithOutrightsFeedProvider)
Public event OnOutrightBetStart Signals that bets for a specific outright can open again after they have been stopped.
(Inherited from LiveOddsWithOutrightsFeedProvider)
Public event OnOutrightBetStop Signals that a bet stop situation occurred for a specific outright. OnBetStart event is triggered when the bets can open again.
(Inherited from LiveOddsWithOutrightsFeedProvider)
Public event OnOutrightOddsChange Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
(Inherited from LiveOddsWithOutrightsFeedProvider)
Public event OnOutrightStatus Occurs when outright status messages are received
(Inherited from LiveOddsWithOutrightsFeedProvider)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk Namespace


LiveOddsFeedProviderVfc Constructor

Initializes a new instance of the LiveOddsFeedProviderVfc class

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsFeedProviderVfc(
    IStartable sdk,
    IProtocolProvider proto_provider,
    VfcEntityFactory entity_factory,
    ILiveOddsFeedMonitor feed_monitor,
    ILiveOddsWithOutrightsDispatcher feed_dispatcher,
    ILiveOddsWithOutrightsRequestProducer request_producer,
    IErrorManager error_manager,
    ITimeKeeper server_timekeeper,
    ISdkLogger sdk_logger
)

Parameters

sdk IStartable

[Missing <param name="sdk"/> documentation for "M:Sportradar.SDK.Services.Sdk.LiveOddsFeedProviderVfc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces.ILiveOddsWithOutrightsDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

proto_provider IProtocolProvider

[Missing <param name="proto_provider"/> documentation for "M:Sportradar.SDK.Services.Sdk.LiveOddsFeedProviderVfc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces.ILiveOddsWithOutrightsDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

entity_factory VfcEntityFactory

[Missing <param name="entity_factory"/> documentation for "M:Sportradar.SDK.Services.Sdk.LiveOddsFeedProviderVfc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces.ILiveOddsWithOutrightsDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_monitor ILiveOddsFeedMonitor

[Missing <param name="feed_monitor"/> documentation for "M:Sportradar.SDK.Services.Sdk.LiveOddsFeedProviderVfc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces.ILiveOddsWithOutrightsDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

feed_dispatcher ILiveOddsWithOutrightsDispatcher

[Missing <param name="feed_dispatcher"/> documentation for "M:Sportradar.SDK.Services.Sdk.LiveOddsFeedProviderVfc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces.ILiveOddsWithOutrightsDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

request_producer ILiveOddsWithOutrightsRequestProducer

[Missing <param name="request_producer"/> documentation for "M:Sportradar.SDK.Services.Sdk.LiveOddsFeedProviderVfc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces.ILiveOddsWithOutrightsDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

error_manager IErrorManager

[Missing <param name="error_manager"/> documentation for "M:Sportradar.SDK.Services.Sdk.LiveOddsFeedProviderVfc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces.ILiveOddsWithOutrightsDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

server_timekeeper ITimeKeeper

[Missing <param name="server_timekeeper"/> documentation for "M:Sportradar.SDK.Services.Sdk.LiveOddsFeedProviderVfc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces.ILiveOddsWithOutrightsDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

sdk_logger ISdkLogger

[Missing <param name="sdk_logger"/> documentation for "M:Sportradar.SDK.Services.Sdk.LiveOddsFeedProviderVfc.#ctor(Sportradar.SDK.Common.Interfaces.IStartable,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.FeedProviders.LiveOdds.Internal.VfcEntityFactory,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsFeedMonitor,Sportradar.SDK.FeedProviders.LiveOdds.Internal.Interfaces.ILiveOddsWithOutrightsDispatcher,Sportradar.SDK.FeedProviders.LiveOdds.Internal.ILiveOddsWithOutrightsRequestProducer,Sportradar.SDK.FeedProviders.LiveOdds.Internal.IErrorManager,Sportradar.SDK.Common.Interfaces.ITimeKeeper,Sportradar.SDK.Services.SdkLogger.ISdkLogger)"]

See Also

Reference

LiveOddsFeedProviderVfc Class
Sportradar.SDK.Services.Sdk Namespace


LiveOddsFeedProviderVfc Properties

The LiveOddsFeedProviderVfc type exposes the following members.

Properties
 | Name | Description
Public property | AvailableMetadataTranslations | Gets the available metadata translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | AvailableTranslations | Language codes of the currently available translations. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | IsConnectionStable | Is the current connection stable enough to accept bets safely? (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastAliveMessage | Get time when the last alive message from the server was received. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | LastServerMessage | Get time when the last message from the server was received. This includes alive messages that are periodically sent. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProtoProvider | Underlying protocol provider. (Inherited from LiveOddsCommonFeedProviderBase)
Public property | ProviderType | Gets the type of the provider. (Overrides LiveOddsCommonFeedProviderBaseProviderType)
Public property | ServerTime | Get current server time (or null if it is stale). (Inherited from LiveOddsCommonFeedProviderBase)
Public property | SubscribedEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsFeedProviderVfc Class
Sportradar.SDK.Services.Sdk Namespace


LiveOddsFeedProviderVfc.ProviderType Property

LiveOddsFeedProviderVfcProviderType Property

Gets the type of the provider.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override ProtocolProviderType ProviderType { get; }

Property Value

ProtocolProviderType
The type of the provider.
See Also

Reference

LiveOddsFeedProviderVfc Class
Sportradar.SDK.Services.Sdk Namespace


LiveOddsFeedProviderVfc Methods

The LiveOddsFeedProviderVfc type exposes the following members.

Methods
 | Name | Description
Public method | BookEvents | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ClearState | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | DisableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | EnableErrorRecovery | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEventList(IEnumerableInt64) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventList(NullableDateTime, NullableDateTime, Boolean) | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventMessages | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventsStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetEventStatus | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOutrightList | Request meta-information about outrights specified by it's ids (Inherited from LiveOddsWithOutrightsFeedProvider)
Public method | GetOutrightsStatus | Requests the outright statuses for a given time ("current" server request). This includes odds, activation of odds and status for the outright requested, current bet status and all bet clearing messages before the timestamp. (Inherited from LiveOddsWithOutrightsFeedProvider)
Public method | GetOutrightStatus | Requests the outright status for a given time ("current" server request). This includes odds, activation of odds and status for the ouright requested, current bet status and all bet clearing messages before the timestamp. (Inherited from LiveOddsWithOutrightsFeedProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HandleEntity | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | RegisterMessageDispatcher | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Start | Start component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Stop | Stop / shutdown component. (Inherited from LiveOddsCommonFeedProviderBase)
Public method | Subscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unsubscribe | (Inherited from LiveOddsCommonFeedProviderBase)
Top
See Also

Reference

LiveOddsFeedProviderVfc Class
Sportradar.SDK.Services.Sdk Namespace


LiveOddsFeedProviderVfc Events

The LiveOddsFeedProviderVfc type exposes the following members.

Events
Name Description
Public event OnAliveWithOutrights Alive message is transmitted every 10 seconds and contains status, timestamp in UTC and match header info for the matches that we supply LiveOdds for at the time given. It also contains current bet status information for every match (started or stopped). Score indicates the current score in the match.
(Inherited from LiveOddsWithOutrightsFeedProvider)
Public event OnBetCancel Occurs when [on bet cancel].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetCancelUndo Occurs when [on bet cancel undone].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetClear Occurs when [on bet clear].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetClearRollback Occurs when [on bet clear rollback].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetStart Occurs when [on bet start].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnBetStop Occurs when [on bet stop].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnConnectionStable Occurs when connection stable.
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnConnectionUnstable Occurs when connection unstable.
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnEventMessages Occurs when [on match messages received].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnEventStatus Occurs when [on match status received].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnFeedError Occurs when [on feed error].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnMetaInfo Occurs when [on meta info received].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnOddsChange Occurs when [on odds change].
(Inherited from LiveOddsCommonFeedProviderBase)
Public event OnOutrightBetCancel Signals that odds type for an outright should be cancelled due to some reason. All bets accepted on the odds with that Id should be cancelled and cashed out with an odd of 1,0 (stakes returned). If the starttime and endtime are also specified, then only bets accepted in this interval should be cancelled. The starttime and endtime are timestamps in UTC.
(Inherited from LiveOddsWithOutrightsFeedProvider)
Public event OnOutrightBetClear

Signals that bets placed on this outright can be settled Timestamp - time indicates the time at which the bet clear event happened. The event also contains the cleared score with an Odds element indicating the odds type, and this again with each EventOddsField, and the status of the outcomes (true/false).

Id in the Odds element corresponds to the Odds elements in one of the previous OnOddsChange events. Evaluation of the bet outcomes is the responsibility of the client system.

(Inherited from LiveOddsWithOutrightsFeedProvider)
Public event OnOutrightBetStart Signals that bets for a specific outright can open again after they have been stopped.
(Inherited from LiveOddsWithOutrightsFeedProvider)
Public event OnOutrightBetStop Signals that a bet stop situation occurred for a specific outright. OnBetStart event is triggered when the bets can open again.
(Inherited from LiveOddsWithOutrightsFeedProvider)
Public event OnOutrightOddsChange Signals that an odds change has occurred, specifying all odds types for a particular match. Odds types that are active will contain odds fields, while inactive odds types will not. Each odds type also has a Changed flag indicating whether this odds type has been changed or not. Score indicates the current score in the match.
(Inherited from LiveOddsWithOutrightsFeedProvider)
Public event OnOutrightStatus Occurs when outright status messages are received
(Inherited from LiveOddsWithOutrightsFeedProvider)
Top
See Also

Reference

LiveOddsFeedProviderVfc Class
Sportradar.SDK.Services.Sdk Namespace


NonPublicActivator Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.NonPublicActivator"]

Inheritance Hierarchy
SystemObject
AbstractComponentActivator
DefaultComponentActivator
Sportradar.SDK.Services.SdkNonPublicActivator

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class NonPublicActivator : DefaultComponentActivator

The NonPublicActivator type exposes the following members.

Constructors
 | Name | Description
Public method | NonPublicActivator | Initializes a new instance of the NonPublicActivator class
Top
Properties
 | Name | Description
Public property | Kernel | (Inherited from AbstractComponentActivator)
Public property | Model | (Inherited from AbstractComponentActivator)
Public property | OnCreation | (Inherited from AbstractComponentActivator)
Public property | OnDestruction | (Inherited from AbstractComponentActivator)
Top
Methods
 | Name | Description
Public method | Create | (Inherited from AbstractComponentActivator)
Public method | Destroy | (Inherited from AbstractComponentActivator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk Namespace


NonPublicActivator Constructor

Initializes a new instance of the NonPublicActivator class

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public NonPublicActivator(
    ComponentModel model,
    IKernelInternal kernel,
    ComponentInstanceDelegate on_creation,
    ComponentInstanceDelegate on_destruction
)

Parameters

model ComponentModel

[Missing <param name="model"/> documentation for "M:Sportradar.SDK.Services.Sdk.NonPublicActivator.#ctor(Castle.Core.ComponentModel,Castle.MicroKernel.IKernelInternal,Castle.MicroKernel.ComponentInstanceDelegate,Castle.MicroKernel.ComponentInstanceDelegate)"]

kernel IKernelInternal

[Missing <param name="kernel"/> documentation for "M:Sportradar.SDK.Services.Sdk.NonPublicActivator.#ctor(Castle.Core.ComponentModel,Castle.MicroKernel.IKernelInternal,Castle.MicroKernel.ComponentInstanceDelegate,Castle.MicroKernel.ComponentInstanceDelegate)"]

on_creation ComponentInstanceDelegate

[Missing <param name="on_creation"/> documentation for "M:Sportradar.SDK.Services.Sdk.NonPublicActivator.#ctor(Castle.Core.ComponentModel,Castle.MicroKernel.IKernelInternal,Castle.MicroKernel.ComponentInstanceDelegate,Castle.MicroKernel.ComponentInstanceDelegate)"]

on_destruction ComponentInstanceDelegate

[Missing <param name="on_destruction"/> documentation for "M:Sportradar.SDK.Services.Sdk.NonPublicActivator.#ctor(Castle.Core.ComponentModel,Castle.MicroKernel.IKernelInternal,Castle.MicroKernel.ComponentInstanceDelegate,Castle.MicroKernel.ComponentInstanceDelegate)"]

See Also

Reference

NonPublicActivator Class
Sportradar.SDK.Services.Sdk Namespace


NonPublicActivator Properties

The NonPublicActivator type exposes the following members.

Properties
 | Name | Description
Public property | Kernel | (Inherited from AbstractComponentActivator)
Public property | Model | (Inherited from AbstractComponentActivator)
Public property | OnCreation | (Inherited from AbstractComponentActivator)
Public property | OnDestruction | (Inherited from AbstractComponentActivator)
Top
See Also

Reference

NonPublicActivator Class
Sportradar.SDK.Services.Sdk Namespace


NonPublicActivator Methods

The NonPublicActivator type exposes the following members.

Methods
 | Name | Description
Public method | Create | (Inherited from AbstractComponentActivator)
Public method | Destroy | (Inherited from AbstractComponentActivator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

NonPublicActivator Class
Sportradar.SDK.Services.Sdk Namespace


NonPublicConstructorDependenciesModelInspector Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.NonPublicConstructorDependenciesModelInspector"]

Inheritance Hierarchy
SystemObject
ConstructorDependenciesModelInspector
Sportradar.SDK.Services.SdkNonPublicConstructorDependenciesModelInspector

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class NonPublicConstructorDependenciesModelInspector : ConstructorDependenciesModelInspector

The NonPublicConstructorDependenciesModelInspector type exposes the following members.

Constructors
 | Name | Description
Public method | NonPublicConstructorDependenciesModelInspector | Initializes a new instance of the NonPublicConstructorDependenciesModelInspector class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ProcessModel | (Overrides ConstructorDependenciesModelInspector.ProcessModel(IKernel, ComponentModel))
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk Namespace


NonPublicConstructorDependenciesModelInspector Constructor

Initializes a new instance of the NonPublicConstructorDependenciesModelInspector class

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public NonPublicConstructorDependenciesModelInspector()
See Also

Reference

NonPublicConstructorDependenciesModelInspector Class
Sportradar.SDK.Services.Sdk Namespace


NonPublicConstructorDependenciesModelInspector Methods

The NonPublicConstructorDependenciesModelInspector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ProcessModel | (Overrides ConstructorDependenciesModelInspector.ProcessModel(IKernel, ComponentModel))
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

NonPublicConstructorDependenciesModelInspector Class
Sportradar.SDK.Services.Sdk Namespace


NonPublicConstructorDependenciesModelInspector.ProcessModel Method

NonPublicConstructorDependenciesModelInspectorProcessModel Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.NonPublicConstructorDependenciesModelInspector.ProcessModel(Castle.MicroKernel.IKernel,Castle.Core.ComponentModel)"]

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override void ProcessModel(
    IKernel kernel,
    ComponentModel model
)

Parameters

kernel IKernel

[Missing <param name="kernel"/> documentation for "M:Sportradar.SDK.Services.Sdk.NonPublicConstructorDependenciesModelInspector.ProcessModel(Castle.MicroKernel.IKernel,Castle.Core.ComponentModel)"]

model ComponentModel

[Missing <param name="model"/> documentation for "M:Sportradar.SDK.Services.Sdk.NonPublicConstructorDependenciesModelInspector.ProcessModel(Castle.MicroKernel.IKernel,Castle.Core.ComponentModel)"]

Implements

IContributeComponentModelConstruction.ProcessModel(IKernel, ComponentModel)
See Also

Reference

NonPublicConstructorDependenciesModelInspector Class
Sportradar.SDK.Services.Sdk Namespace


QueueSupervisor Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.QueueSupervisor"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.SdkQueueSupervisor

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class QueueSupervisor

The QueueSupervisor type exposes the following members.

Constructors
 | Name | Description
Public method | QueueSupervisor | Initializes a new instance of the QueueSupervisor class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | LimitReachedHandler |
Public method | RegisterConnectionProviders |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk Namespace


QueueSupervisor Constructor

Initializes a new instance of the QueueSupervisor class

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public QueueSupervisor()
See Also

Reference

QueueSupervisor Class
Sportradar.SDK.Services.Sdk Namespace


QueueSupervisor Methods

The QueueSupervisor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | LimitReachedHandler |
Public method | RegisterConnectionProviders |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

QueueSupervisor Class
Sportradar.SDK.Services.Sdk Namespace


QueueSupervisor.LimitReachedHandler Method

QueueSupervisorLimitReachedHandler Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.QueueSupervisor.LimitReachedHandler(System.Object,Sportradar.SDK.Common.Interfaces.QueueLimitEventArgs)"]

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void LimitReachedHandler(
    Object sender,
    QueueLimitEventArgs event_args
)

Parameters

sender Object

[Missing <param name="sender"/> documentation for "M:Sportradar.SDK.Services.Sdk.QueueSupervisor.LimitReachedHandler(System.Object,Sportradar.SDK.Common.Interfaces.QueueLimitEventArgs)"]

event_args QueueLimitEventArgs

[Missing <param name="event_args"/> documentation for "M:Sportradar.SDK.Services.Sdk.QueueSupervisor.LimitReachedHandler(System.Object,Sportradar.SDK.Common.Interfaces.QueueLimitEventArgs)"]

See Also

Reference

QueueSupervisor Class
Sportradar.SDK.Services.Sdk Namespace


QueueSupervisor.RegisterConnectionProviders Method

QueueSupervisorRegisterConnectionProviders Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.QueueSupervisor.RegisterConnectionProviders(System.Collections.Generic.IList{Sportradar.SDK.Common.Interfaces.IConnectionProvider})"]

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void RegisterConnectionProviders(
    IList<IConnectionProvider> conn_providers
)

Parameters

conn_providers IList IConnectionProvider

[Missing <param name="conn_providers"/> documentation for "M:Sportradar.SDK.Services.Sdk.QueueSupervisor.RegisterConnectionProviders(System.Collections.Generic.IList{Sportradar.SDK.Common.Interfaces.IConnectionProvider})"]

See Also

Reference

QueueSupervisor Class
Sportradar.SDK.Services.Sdk Namespace


Sdk Class

Main entry point for the SDK client application.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.SdkSdk

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class Sdk : IStartable, IDisposable

The Sdk type exposes the following members.

Properties
 | Name | Description
Public property | BetPal | BetPal provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
 | Instance | SDK singleton instance.
Public property | IsInitialized | True if the SDK initialized, false otherwise. See the Initialize.
Public property | IsStarted | True if the SDK started, false otherwise. See the Initialize.
Public property | Lcoo | Live Cycle of Odds provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOdds | LivePlex provider. BetPal and LiveOdds combined in single feed. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOddsVbl | LiveOdds Virtual Basketball League provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOddsVdr | LiveOdds Virtual Football League provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOddsVfc | LiveOdds Virtual Football cup provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOddsVfl | LiveOdds Virtual Football League provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOddsVhc | LiveOdds Virtual Football League provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOddsVto | LiveOdds Virtual Tennis Open provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LivePlex | LivePlex provider. BetPal and LiveOdds combined in single feed. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveScout | LiveScout provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | OddsCreator | OddsCreator provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | QueueStats | Queue statistics.
Public property | SoccerRoulette | SoccerRoulette provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Top
Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Initialize | Initialize the SDK. Default section name is used from the app.config. DEFAULT_SECTION_NAME
 | Initialize(IConfigFactory, IDeadLetterQueue) | Initialize the SDK.
Public method | Initialize(String, IDeadLetterQueue) | Initialize the SDK.
Public method | Start | Starts the SDK instance but does not start the configured feed providers (e.g. LiveScout or LiveOdds). SDK message dispatcher pump will start delivering messages after this. Remarks Feed providers should be started explicitly after SDK singleton is started.
Public method | Stop | Stops the SDK. Stops the message pump and all feeds.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | OnQueueLimits | Indicates that a queue limit (NORMAL, LOW, HIGH) was either reached or retreated for a specific queue.
Top
Example
C#
Copy
try
{
    Sdk.Instance.Initialize();

    Sdk.Instance.OnQueueLimits += QueueLimits;
    Sdk.Instance.OnQueueLimitRetreated += QueueLimitRetreated;

    Sdk.Instance.Start();

    if (Sdk.Instance.LiveOdds != null)
    {
        Sdk.Instance.LiveOdds.OnConnectionStable += FlagConnectionAsStable;
        Sdk.Instance.LiveOdds.OnConnectionUnstable += ConnectionUnstable;

        Sdk.Instance.LiveOdds.OnAlive += AliveReceived;
        Sdk.Instance.LiveOdds.OnFeedError += FeedErrorOccurred;
        Sdk.Instance.LiveOdds.OnBetCancel += MatchBetCancelled;
        Sdk.Instance.LiveOdds.OnBetCancelUndo += MatchBetCancelUndo;
        Sdk.Instance.LiveOdds.OnBetClear += MatchBetCleared;
        Sdk.Instance.LiveOdds.OnBetClearRollback += MatchBetClearRollbacked;
        Sdk.Instance.LiveOdds.OnBetStart += BetStarted;
        Sdk.Instance.LiveOdds.OnBetStop += BetStopped;
        Sdk.Instance.LiveOdds.OnMetaInfo += MetaInfoReceived;
        Sdk.Instance.LiveOdds.OnOddsChange += OddsChanged;
        Sdk.Instance.LiveOdds.OnScoreCardSummary += ScoreCardReceived;

        Sdk.Instance.LiveOdds.Start();
    }
    else
    {
        throw new ApplicationException("Error initializing SDK.LiveOdds provider");
    }

    /* ... start using the SDK ... */
    Console.ReadLine();
}
finally
{
    if (Sdk.Instance.LiveOdds != null)
    {
        Sdk.Instance.LiveOdds.Stop();

        Sdk.Instance.LiveOdds.OnConnectionStable -= FlagConnectionAsStable;
        Sdk.Instance.LiveOdds.OnConnectionUnstable -= ConnectionUnstable;

        Sdk.Instance.LiveOdds.OnAlive -= AliveReceived;
        Sdk.Instance.LiveOdds.OnFeedError -= FeedErrorOccurred;
        Sdk.Instance.LiveOdds.OnBetCancel -= MatchBetCancelled;
        Sdk.Instance.LiveOdds.OnBetCancelUndo -= MatchBetCancelUndo;
        Sdk.Instance.LiveOdds.OnBetClear -= MatchBetCleared;
        Sdk.Instance.LiveOdds.OnBetClearRollback -= MatchBetClearRollbacked;
        Sdk.Instance.LiveOdds.OnBetStart -= BetStarted;
        Sdk.Instance.LiveOdds.OnBetStop -= BetStopped;
        Sdk.Instance.LiveOdds.OnMetaInfo -= MetaInfoReceived;
        Sdk.Instance.LiveOdds.OnOddsChange -= OddsChanged;
        Sdk.Instance.LiveOdds.OnScoreCardSummary -= ScoreCardReceived;
    }

    Sdk.Instance.OnQueueLimits -= QueueLimits;
    Sdk.Instance.OnQueueLimitRetreated -= QueueLimitRetreated;

    Sdk.Instance.Stop();
}
See Also

Reference

Sportradar.SDK.Services.Sdk Namespace


Sdk Properties

The Sdk type exposes the following members.

Properties
 | Name | Description
Public property | BetPal | BetPal provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
 | Instance | SDK singleton instance.
Public property | IsInitialized | True if the SDK initialized, false otherwise. See the Initialize.
Public property | IsStarted | True if the SDK started, false otherwise. See the Initialize.
Public property | Lcoo | Live Cycle of Odds provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOdds | LivePlex provider. BetPal and LiveOdds combined in single feed. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOddsVbl | LiveOdds Virtual Basketball League provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOddsVdr | LiveOdds Virtual Football League provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOddsVfc | LiveOdds Virtual Football cup provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOddsVfl | LiveOdds Virtual Football League provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOddsVhc | LiveOdds Virtual Football League provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveOddsVto | LiveOdds Virtual Tennis Open provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LivePlex | LivePlex provider. BetPal and LiveOdds combined in single feed. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | LiveScout | LiveScout provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | OddsCreator | OddsCreator provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Public property | QueueStats | Queue statistics.
Public property | SoccerRoulette | SoccerRoulette provider. Remarks Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.
Top
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.BetPal Property

SdkBetPal Property

BetPal provider.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILiveOdds BetPal { get; }

Property Value

ILiveOdds
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.Instance Property

SdkInstance Property

SDK singleton instance.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static Sdk Instance { get; }

Property Value

Sdk
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.IsInitialized Property

SdkIsInitialized Property

True if the SDK initialized, false otherwise. See the Initialize.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsInitialized { get; }

Property Value

Boolean
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.IsStarted Property

SdkIsStarted Property

True if the SDK started, false otherwise. See the Initialize.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsStarted { get; }

Property Value

Boolean
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.Lcoo Property

SdkLcoo Property

Live Cycle of Odds provider.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILcoo Lcoo { get; }

Property Value

ILcoo
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.LiveOdds Property

SdkLiveOdds Property

LivePlex provider. BetPal and LiveOdds combined in single feed.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILiveOdds LiveOdds { get; }

Property Value

ILiveOdds
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.LiveOddsVbl Property

SdkLiveOddsVbl Property

LiveOdds Virtual Basketball League provider.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILiveOdds LiveOddsVbl { get; }

Property Value

ILiveOdds
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.LiveOddsVdr Property

SdkLiveOddsVdr Property

LiveOdds Virtual Football League provider.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILiveOddsRace LiveOddsVdr { get; }

Property Value

ILiveOddsRace
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.LiveOddsVfc Property

SdkLiveOddsVfc Property

LiveOdds Virtual Football cup provider.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILiveOddsWithOutrights LiveOddsVfc { get; }

Property Value

ILiveOddsWithOutrights
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.LiveOddsVfl Property

SdkLiveOddsVfl Property

LiveOdds Virtual Football League provider.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILiveOdds LiveOddsVfl { get; }

Property Value

ILiveOdds
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.LiveOddsVhc Property

SdkLiveOddsVhc Property

LiveOdds Virtual Football League provider.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILiveOddsRace LiveOddsVhc { get; }

Property Value

ILiveOddsRace
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.LiveOddsVto Property

SdkLiveOddsVto Property

LiveOdds Virtual Tennis Open provider.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILiveOdds LiveOddsVto { get; }

Property Value

ILiveOdds
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.LivePlex Property

SdkLivePlex Property

LivePlex provider. BetPal and LiveOdds combined in single feed.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILiveOdds LivePlex { get; }

Property Value

ILiveOdds
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.LiveScout Property

SdkLiveScout Property

LiveScout provider.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILiveScout LiveScout { get; }

Property Value

ILiveScout
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.OddsCreator Property

SdkOddsCreator Property

OddsCreator provider.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IOddsCreator OddsCreator { get; }

Property Value

IOddsCreator
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.QueueStats Property

SdkQueueStats Property

Queue statistics.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IList<ClientQueueStats> QueueStats { get; }

Property Value

IList ClientQueueStats
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.SoccerRoulette Property

SdkSoccerRoulette Property

SoccerRoulette provider.
Remarks
Initialize must be called before accessing this member. If provider is not enabled through configuration, this member will be null.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ILiveOdds SoccerRoulette { get; }

Property Value

ILiveOdds
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk Methods

The Sdk type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases unmanaged resources held by an instance of this class.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Initialize | Initialize the SDK. Default section name is used from the app.config. DEFAULT_SECTION_NAME
 | Initialize(IConfigFactory, IDeadLetterQueue) | Initialize the SDK.
Public method | Initialize(String, IDeadLetterQueue) | Initialize the SDK.
Public method | Start | Starts the SDK instance but does not start the configured feed providers (e.g. LiveScout or LiveOdds). SDK message dispatcher pump will start delivering messages after this. Remarks Feed providers should be started explicitly after SDK singleton is started.
Public method | Stop | Stops the SDK. Stops the message pump and all feeds.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.Dispose Method

SdkDispose Method

Releases unmanaged resources held by an instance of this class.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.Initialize Method

SdkInitialize Method

Overload List
 | Name | Description
Public method | Initialize | Initialize the SDK. Default section name is used from the app.config. DEFAULT_SECTION_NAME
 | Initialize(IConfigFactory, IDeadLetterQueue) | Initialize the SDK.
Public method | Initialize(String, IDeadLetterQueue) | Initialize the SDK.
Top
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.Initialize Method

SdkInitialize Method

Initialize the SDK. Default section name is used from the app.config. DEFAULT_SECTION_NAME

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Initialize()
See Also

Reference

Sdk Class
Initialize Overload
Sportradar.SDK.Services.Sdk Namespace


Sdk.Initialize(IConfigFactory, IDeadLetterQueue) Method

SdkInitialize(IConfigFactory, IDeadLetterQueue) Method

Initialize the SDK.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Initialize(
    IConfigFactory config_factory,
    IDeadLetterQueue dead_letter_queue = null
)

Parameters

config_factory IConfigFactory
A factory for obtaining the configuration AppConfigFactory
dead_letter_queue IDeadLetterQueue (Optional)
Optional interface where a client can be notified about messages that could not be delivered (can be null)
Remarks
Config factory is used explicitly instead of actual configuration to emphasize that configuration is immutable for the application after it is built (internally). It can (depending on the type of the factory) still be updated in run-time by changing the configuration file.
Example
Initialize(AppConfigFactory.FromSection("Sdk"), DeadLetterInstance)
See Also

Reference

Sdk Class
Initialize Overload
Sportradar.SDK.Services.Sdk Namespace


Sdk.Initialize(String, IDeadLetterQueue) Method

SdkInitialize(String, IDeadLetterQueue) Method

Initialize the SDK.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Initialize(
    string section_name,
    IDeadLetterQueue dead_letter_queue = null
)

Parameters

section_name String
Name of the section in the configuration file
dead_letter_queue IDeadLetterQueue (Optional)
Optional interface where a client can be notified about messages that could not be delivered (can be null)
See Also

Reference

Sdk Class
Initialize Overload
Sportradar.SDK.Services.Sdk Namespace


Sdk.Start Method

SdkStart Method

Starts the SDK instance but does not start the configured feed providers (e.g. LiveScout or LiveOdds). SDK message dispatcher pump will start delivering messages after this.
Remarks
Feed providers should be started explicitly after SDK singleton is started.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Start()

Implements

IStartableStart
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.Stop Method

SdkStop Method

Stops the SDK. Stops the message pump and all feeds.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Stop()

Implements

IStartableStop
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk Events

The Sdk type exposes the following members.

Events
 | Name | Description
Public event | OnQueueLimits | Indicates that a queue limit (NORMAL, LOW, HIGH) was either reached or retreated for a specific queue.
Top
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sdk.OnQueueLimits Event

SdkOnQueueLimits Event

Indicates that a queue limit (NORMAL, LOW, HIGH) was either reached or retreated for a specific queue.

Namespace: Sportradar.SDK.Services.Sdk
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event QueueLimitDelegate OnQueueLimits

Value

QueueLimitDelegate
See Also

Reference

Sdk Class
Sportradar.SDK.Services.Sdk Namespace


Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace

Classes
 | Class | Description
Public class | LcooResolver |
Public class | LiveOddsBetpalResolver |
Public class | LiveOddsLivePlexResolver |
Public class | LiveOddsResolver |
Public class | LiveOddsSoccerRouletteResolver |
Public class | LiveOddsVblResolver |
Public class | LiveOddsVdrResolver |
Public class | LiveOddsVflResolver |
Public class | LiveOddsVhcResolver |
Public class | LiveOddsVtoResolver |


LcooResolver Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.WindsorResolvers.LcooResolver"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.Sdk.WindsorResolversLcooResolver

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LcooResolver

The LcooResolver type exposes the following members.

Constructors
 | Name | Description
Public method | LcooResolver | Initializes a new instance of the LcooResolver class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LcooResolver Constructor

Initializes a new instance of the LcooResolver class

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LcooResolver(
    IWindsorContainer container,
    ISdkConfiguration sdk_config,
    SdkConfigurationLcoo feed_config,
    ILoggerData logger_data,
    ILogInterceptor log_interceptor
)

Parameters

container IWindsorContainer

[Missing <param name="container"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LcooResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLcoo,Sportradar.SDK.Common.Interfaces.ILoggerData,Sportradar.SDK.ReliableLog.ILogInterceptor)"]

sdk_config ISdkConfiguration

[Missing <param name="sdk_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LcooResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLcoo,Sportradar.SDK.Common.Interfaces.ILoggerData,Sportradar.SDK.ReliableLog.ILogInterceptor)"]

feed_config SdkConfigurationLcoo

[Missing <param name="feed_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LcooResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLcoo,Sportradar.SDK.Common.Interfaces.ILoggerData,Sportradar.SDK.ReliableLog.ILogInterceptor)"]

logger_data ILoggerData

[Missing <param name="logger_data"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LcooResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLcoo,Sportradar.SDK.Common.Interfaces.ILoggerData,Sportradar.SDK.ReliableLog.ILogInterceptor)"]

log_interceptor ILogInterceptor

[Missing <param name="log_interceptor"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LcooResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLcoo,Sportradar.SDK.Common.Interfaces.ILoggerData,Sportradar.SDK.ReliableLog.ILogInterceptor)"]

See Also

Reference

LcooResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LcooResolver Methods

The LcooResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LcooResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LcooResolver.RegisterAll Method

LcooResolverRegisterAll Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LcooResolver.RegisterAll(System.String)"]

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void RegisterAll(
    string postfix
)

Parameters

postfix String

[Missing <param name="postfix"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LcooResolver.RegisterAll(System.String)"]

See Also

Reference

LcooResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsBetpalResolver Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsBetpalResolver"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsResolver
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsBetpalResolver

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsBetpalResolver : LiveOddsResolver

The LiveOddsBetpalResolver type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsBetpalResolver | Initializes a new instance of the LiveOddsBetpalResolver class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll | (Inherited from LiveOddsResolver)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsBetpalResolver Constructor

Initializes a new instance of the LiveOddsBetpalResolver class

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsBetpalResolver(
    IWindsorContainer container,
    ProtocolProviderType provider_type,
    IProtocolProvider protocol_provider,
    ISdkConfiguration sdk_config,
    SdkConfigurationLiveOdds live_odds_config
)

Parameters

container IWindsorContainer

[Missing <param name="container"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsBetpalResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

provider_type ProtocolProviderType

[Missing <param name="provider_type"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsBetpalResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

protocol_provider IProtocolProvider

[Missing <param name="protocol_provider"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsBetpalResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

sdk_config ISdkConfiguration

[Missing <param name="sdk_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsBetpalResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

live_odds_config SdkConfigurationLiveOdds

[Missing <param name="live_odds_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsBetpalResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

LiveOddsBetpalResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsBetpalResolver Methods

The LiveOddsBetpalResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll | (Inherited from LiveOddsResolver)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsBetpalResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsLivePlexResolver Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsLivePlexResolver"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsResolver
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsLivePlexResolver

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsLivePlexResolver : LiveOddsResolver

The LiveOddsLivePlexResolver type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsLivePlexResolver | Initializes a new instance of the LiveOddsLivePlexResolver class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll | (Inherited from LiveOddsResolver)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsLivePlexResolver Constructor

Initializes a new instance of the LiveOddsLivePlexResolver class

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsLivePlexResolver(
    IWindsorContainer container,
    ProtocolProviderType provider_type,
    IProtocolProvider protocol_provider,
    ISdkConfiguration sdk_config,
    SdkConfigurationLiveOdds live_odds_config
)

Parameters

container IWindsorContainer

[Missing <param name="container"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsLivePlexResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

provider_type ProtocolProviderType

[Missing <param name="provider_type"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsLivePlexResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

protocol_provider IProtocolProvider

[Missing <param name="protocol_provider"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsLivePlexResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

sdk_config ISdkConfiguration

[Missing <param name="sdk_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsLivePlexResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

live_odds_config SdkConfigurationLiveOdds

[Missing <param name="live_odds_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsLivePlexResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

LiveOddsLivePlexResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsLivePlexResolver Methods

The LiveOddsLivePlexResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll | (Inherited from LiveOddsResolver)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsLivePlexResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsResolver Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsResolver"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsResolver
More

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsResolver

The LiveOddsResolver type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsResolver | Initializes a new instance of the LiveOddsResolver class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace
Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsResolver
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsBetpalResolver
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsLivePlexResolver
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsSoccerRouletteResolver
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsVblResolver
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsVflResolver
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsVtoResolver


LiveOddsResolver Constructor

Initializes a new instance of the LiveOddsResolver class

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsResolver(
    IWindsorContainer container,
    ProtocolProviderType provider_type,
    IProtocolProvider protocol_provider,
    ISdkConfiguration sdk_config,
    SdkConfigurationLiveOdds live_odds_config
)

Parameters

container IWindsorContainer

[Missing <param name="container"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

provider_type ProtocolProviderType

[Missing <param name="provider_type"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

protocol_provider IProtocolProvider

[Missing <param name="protocol_provider"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

sdk_config ISdkConfiguration

[Missing <param name="sdk_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

live_odds_config SdkConfigurationLiveOdds

[Missing <param name="live_odds_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

LiveOddsResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsResolver Methods

The LiveOddsResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsResolver.RegisterAll Method

LiveOddsResolverRegisterAll Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsResolver.RegisterAll(System.String)"]

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void RegisterAll(
    string postfix
)

Parameters

postfix String

[Missing <param name="postfix"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsResolver.RegisterAll(System.String)"]

See Also

Reference

LiveOddsResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsSoccerRouletteResolver Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsSoccerRouletteResolver"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsResolver
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsSoccerRouletteResolver

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsSoccerRouletteResolver : LiveOddsResolver

The LiveOddsSoccerRouletteResolver type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsSoccerRouletteResolver | Initializes a new instance of the LiveOddsSoccerRouletteResolver class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll | (Inherited from LiveOddsResolver)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsSoccerRouletteResolver Constructor

Initializes a new instance of the LiveOddsSoccerRouletteResolver class

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsSoccerRouletteResolver(
    IWindsorContainer container,
    ProtocolProviderType provider_type,
    IProtocolProvider protocol_provider,
    ISdkConfiguration sdk_config,
    SdkConfigurationLiveOdds live_odds_config
)

Parameters

container IWindsorContainer

[Missing <param name="container"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsSoccerRouletteResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

provider_type ProtocolProviderType

[Missing <param name="provider_type"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsSoccerRouletteResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

protocol_provider IProtocolProvider

[Missing <param name="protocol_provider"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsSoccerRouletteResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

sdk_config ISdkConfiguration

[Missing <param name="sdk_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsSoccerRouletteResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

live_odds_config SdkConfigurationLiveOdds

[Missing <param name="live_odds_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsSoccerRouletteResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

LiveOddsSoccerRouletteResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsSoccerRouletteResolver Methods

The LiveOddsSoccerRouletteResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll | (Inherited from LiveOddsResolver)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsSoccerRouletteResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVblResolver Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVblResolver"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsResolver
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsVblResolver

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsVblResolver : LiveOddsResolver

The LiveOddsVblResolver type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsVblResolver | Initializes a new instance of the LiveOddsVblResolver class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll | (Inherited from LiveOddsResolver)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVblResolver Constructor

Initializes a new instance of the LiveOddsVblResolver class

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsVblResolver(
    IWindsorContainer container,
    ProtocolProviderType provider_type,
    IProtocolProvider protocol_provider,
    ISdkConfiguration sdk_config,
    SdkConfigurationLiveOdds live_odds_config
)

Parameters

container IWindsorContainer

[Missing <param name="container"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVblResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

provider_type ProtocolProviderType

[Missing <param name="provider_type"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVblResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

protocol_provider IProtocolProvider

[Missing <param name="protocol_provider"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVblResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

sdk_config ISdkConfiguration

[Missing <param name="sdk_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVblResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

live_odds_config SdkConfigurationLiveOdds

[Missing <param name="live_odds_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVblResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

LiveOddsVblResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVblResolver Methods

The LiveOddsVblResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll | (Inherited from LiveOddsResolver)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsVblResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVdrResolver Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVdrResolver"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsVdrResolver

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsVdrResolver

The LiveOddsVdrResolver type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsVdrResolver | Initializes a new instance of the LiveOddsVdrResolver class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVdrResolver Constructor

Initializes a new instance of the LiveOddsVdrResolver class

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsVdrResolver(
    IWindsorContainer container,
    ProtocolProviderType provider_type,
    IProtocolProvider protocol_provider,
    ISdkConfiguration sdk_config,
    SdkConfigurationLiveOdds live_odds_config
)

Parameters

container IWindsorContainer

[Missing <param name="container"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVdrResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

provider_type ProtocolProviderType

[Missing <param name="provider_type"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVdrResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

protocol_provider IProtocolProvider

[Missing <param name="protocol_provider"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVdrResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

sdk_config ISdkConfiguration

[Missing <param name="sdk_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVdrResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

live_odds_config SdkConfigurationLiveOdds

[Missing <param name="live_odds_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVdrResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

LiveOddsVdrResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVdrResolver Methods

The LiveOddsVdrResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsVdrResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVdrResolver.RegisterAll Method

LiveOddsVdrResolverRegisterAll Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVdrResolver.RegisterAll(System.String)"]

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void RegisterAll(
    string postfix
)

Parameters

postfix String

[Missing <param name="postfix"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVdrResolver.RegisterAll(System.String)"]

See Also

Reference

LiveOddsVdrResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVflResolver Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVflResolver"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsResolver
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsVflResolver

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsVflResolver : LiveOddsResolver

The LiveOddsVflResolver type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsVflResolver | Initializes a new instance of the LiveOddsVflResolver class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll | (Inherited from LiveOddsResolver)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVflResolver Constructor

Initializes a new instance of the LiveOddsVflResolver class

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsVflResolver(
    IWindsorContainer container,
    ProtocolProviderType provider_type,
    IProtocolProvider protocol_provider,
    ISdkConfiguration sdk_config,
    SdkConfigurationLiveOdds live_odds_config
)

Parameters

container IWindsorContainer

[Missing <param name="container"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVflResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

provider_type ProtocolProviderType

[Missing <param name="provider_type"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVflResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

protocol_provider IProtocolProvider

[Missing <param name="protocol_provider"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVflResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

sdk_config ISdkConfiguration

[Missing <param name="sdk_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVflResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

live_odds_config SdkConfigurationLiveOdds

[Missing <param name="live_odds_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVflResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

LiveOddsVflResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVflResolver Methods

The LiveOddsVflResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll | (Inherited from LiveOddsResolver)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsVflResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVhcResolver Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVhcResolver"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsVhcResolver

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsVhcResolver

The LiveOddsVhcResolver type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsVhcResolver | Initializes a new instance of the LiveOddsVhcResolver class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVhcResolver Constructor

Initializes a new instance of the LiveOddsVhcResolver class

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsVhcResolver(
    IWindsorContainer container,
    ProtocolProviderType provider_type,
    IProtocolProvider protocol_provider,
    ISdkConfiguration sdk_config,
    SdkConfigurationLiveOdds live_odds_config
)

Parameters

container IWindsorContainer

[Missing <param name="container"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVhcResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

provider_type ProtocolProviderType

[Missing <param name="provider_type"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVhcResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

protocol_provider IProtocolProvider

[Missing <param name="protocol_provider"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVhcResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

sdk_config ISdkConfiguration

[Missing <param name="sdk_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVhcResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

live_odds_config SdkConfigurationLiveOdds

[Missing <param name="live_odds_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVhcResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

LiveOddsVhcResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVhcResolver Methods

The LiveOddsVhcResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsVhcResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVhcResolver.RegisterAll Method

LiveOddsVhcResolverRegisterAll Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVhcResolver.RegisterAll(System.String)"]

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void RegisterAll(
    string postfix
)

Parameters

postfix String

[Missing <param name="postfix"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVhcResolver.RegisterAll(System.String)"]

See Also

Reference

LiveOddsVhcResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVtoResolver Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVtoResolver"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsResolver
Sportradar.SDK.Services.Sdk.WindsorResolversLiveOddsVtoResolver

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class LiveOddsVtoResolver : LiveOddsResolver

The LiveOddsVtoResolver type exposes the following members.

Constructors
 | Name | Description
Public method | LiveOddsVtoResolver | Initializes a new instance of the LiveOddsVtoResolver class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll | (Inherited from LiveOddsResolver)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVtoResolver Constructor

Initializes a new instance of the LiveOddsVtoResolver class

Namespace: Sportradar.SDK.Services.Sdk.WindsorResolvers
Assembly: Sdk (in Sdk.dll) Version: 2.28.0.0
Syntax
C#
Copy
public LiveOddsVtoResolver(
    IWindsorContainer container,
    ProtocolProviderType provider_type,
    IProtocolProvider protocol_provider,
    ISdkConfiguration sdk_config,
    SdkConfigurationLiveOdds live_odds_config
)

Parameters

container IWindsorContainer

[Missing <param name="container"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVtoResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

provider_type ProtocolProviderType

[Missing <param name="provider_type"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVtoResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

protocol_provider IProtocolProvider

[Missing <param name="protocol_provider"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVtoResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

sdk_config ISdkConfiguration

[Missing <param name="sdk_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVtoResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

live_odds_config SdkConfigurationLiveOdds

[Missing <param name="live_odds_config"/> documentation for "M:Sportradar.SDK.Services.Sdk.WindsorResolvers.LiveOddsVtoResolver.#ctor(Castle.Windsor.IWindsorContainer,Sportradar.SDK.Common.ProtocolProviderType,Sportradar.SDK.ProtocolProviders.IProtocolProvider,Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOdds)"]

See Also

Reference

LiveOddsVtoResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


LiveOddsVtoResolver Methods

The LiveOddsVtoResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RegisterAll | (Inherited from LiveOddsResolver)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LiveOddsVtoResolver Class
Sportradar.SDK.Services.Sdk.WindsorResolvers Namespace


Sportradar.SDK.Services.SdkConfiguration Namespace

Classes
 | Class | Description
Public class | AppConfigFactory | Configuration factory that understands app.config file format. It is focused only on specific section of the configuration file (i.e. section reserved for SDK) and is able to detect changes of the configuration in run-time.
Public class | AppConfigWrapper | Problem is that users cache the ISdkConfiguration instance they get, and app.config is a bit awkward as a new instance has to be obtained all the time using GetSection(). This is a wrapper so that the underlying section can change, but the client has just this instance cached.
Public class | ConfigurationElementFeed | Base SDK configuration element for all feeds
Public class | FeedConfig |
Public class | FeedConfigServerType |
Public class | HardcodedConfigFactory |
Public class | PropertyValidators |
Public class | ProviderConfig |
Public class | SdkConfigurationCommon | SDK configuration element where common settings used throughout the SDK library are specified.
Public class | SdkConfigurationDelegates | Configuration delegates.
Public class | SdkConfigurationDelegatesConfigReloadedDelegate | Indicates that configuration has been reloaded/refreshed and might have changed. This is a good time for components to update their cached configuration settings, if any.
Public class | SdkConfigurationDynamic | SDK configuration element where settings for the server-side configuration service are specified (mostly access parameters).
Public class | SdkConfigurationLcoo | SDK configuration element with LCoO feed provider settings.
Public class | SdkConfigurationLiveFeed | SDK configuration element where common live feed provider settings are stored (connectivity, rate limiters, etc.).
Public class | SdkConfigurationLiveOdds | SDK configuration element with LiveOdds feed provider settings.
Public class | SdkConfigurationLiveOddsBetPal | SDK configuration element with BetPal feed provider settings.
Public class | SdkConfigurationLiveOddsBetTypes | SDK configuration element with LiveOdds BetType data feed provider settings.
Public class | SdkConfigurationLiveOddsLivePlex | SDK configuration element with LivePlex feed provider settings.
Public class | SdkConfigurationLiveOddsSoccerRoulette | SDK configuration element with Soccer Roulette feed provider settings.
Public class | SdkConfigurationLiveOddsVbl | SDK configuration element with LiveOdds VFL feed provider settings.
Public class | SdkConfigurationLiveOddsVdr | SDK configuration element with LiveOdds VHC feed provider settings.
Public class | SdkConfigurationLiveOddsVfc | SDK configuration element with LiveOdds VFC (virtual football cup) feed provider settings.
Public class | SdkConfigurationLiveOddsVfl | SDK configuration element with LiveOdds VFL feed provider settings.
Public class | SdkConfigurationLiveOddsVhc | SDK configuration element with LiveOdds VHC feed provider settings.
Public class | SdkConfigurationLiveOddsVirtual | SDK configuration element with virtual gaming feed provider settings.
Public class | SdkConfigurationLiveOddsVto | SDK configuration element with LiveOdds VFL feed provider settings.
Public class | SdkConfigurationLiveScout | SDK configuration element with LiveScout feed provider settings.
Public class | SdkConfigurationMessageDispatcher | SDK configuration element where Message Dispatcher settings are specified.
Public class | SdkConfigurationOddsCreator | SDK configuration element with OddsCreator feed provider settings.
Public class | SdkConfigurationPersistentState | SDK configuration element with Persistent State provider settings (SqLite database settings).
Public class | SdkConfigurationSection | SDK configuration section.
Public class | SdkLiveConfiguration |
Interfaces
 | Interface | Description
Public interface | IConfigFactory | Configuration factory interface.
Public interface | ISdkConfiguration | SDK configuration.


AppConfigFactory Class

Configuration factory that understands app.config file format. It is focused only on specific section of the configuration file (i.e. section reserved for SDK) and is able to detect changes of the configuration in run-time.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.SdkConfigurationAppConfigFactory

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class AppConfigFactory : IConfigFactory

The AppConfigFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildConfig | Assemble a configuration.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | FromSection | Create a configuration factory that uses a certain section of the app.config file.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Fields
Name | Description
DEFAULT_SECTION_NAME | Default section name in app.config when not specified otherwise.
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigFactory Methods

The AppConfigFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildConfig | Assemble a configuration.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | FromSection | Create a configuration factory that uses a certain section of the app.config file.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AppConfigFactory Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigFactory.BuildConfig Method

AppConfigFactoryBuildConfig Method

Assemble a configuration.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual ISdkConfiguration BuildConfig()

Return Value

ISdkConfiguration
A usuable configuration.

Implements

IConfigFactoryBuildConfig
See Also

Reference

AppConfigFactory Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigFactory.FromSection Method

AppConfigFactoryFromSection Method

Create a configuration factory that uses a certain section of the app.config file.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static AppConfigFactory FromSection(
    string section_name = "Sdk"
)

Parameters

section_name String (Optional)
Name of the section.

Return Value

AppConfigFactory
The factory.
See Also

Reference

AppConfigFactory Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigFactory Fields

The AppConfigFactory type exposes the following members.

Fields
Name | Description
DEFAULT_SECTION_NAME | Default section name in app.config when not specified otherwise.
Top
See Also

Reference

AppConfigFactory Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigFactory.DEFAULT_SECTION_NAME Field

AppConfigFactoryDEFAULT_SECTION_NAME Field

Default section name in app.config when not specified otherwise.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const string DEFAULT_SECTION_NAME = "Sdk"

Field Value

String
See Also

Reference

AppConfigFactory Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper Class

Problem is that users cache the ISdkConfiguration instance they get, and app.config is a bit awkward as a new instance has to be obtained all the time using GetSection(). This is a wrapper so that the underlying section can change, but the client has just this instance cached.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.SdkConfigurationAppConfigWrapper

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class AppConfigWrapper : ISdkConfiguration

The AppConfigWrapper type exposes the following members.

Constructors
 | Name | Description
Public method | AppConfigWrapper | Initializes a new instance of the AppConfigWrapper class
Top
Properties
 | Name | Description
Public property | Lcoo |
Public property | LiveOddsVbl |
Public property | LiveOddsVdr |
Public property | LiveOddsVhc |
Public property | LivePlex |
Public property | SoccerRoulette |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Reload |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | OnConfigurationReloaded |
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper Constructor

Initializes a new instance of the AppConfigWrapper class

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public AppConfigWrapper(
    SdkConfigurationSection section
)

Parameters

section SdkConfigurationSection

[Missing <param name="section"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.AppConfigWrapper.#ctor(Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationSection)"]

See Also

Reference

AppConfigWrapper Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper Properties

The AppConfigWrapper type exposes the following members.

Properties
 | Name | Description
Public property | Lcoo |
Public property | LiveOddsVbl |
Public property | LiveOddsVdr |
Public property | LiveOddsVhc |
Public property | LivePlex |
Public property | SoccerRoulette |
Top
See Also

Reference

AppConfigWrapper Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper.Lcoo Property

AppConfigWrapperLcoo Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.AppConfigWrapper.Lcoo"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLcoo Lcoo { get; }

Property Value

SdkConfigurationLcoo

Implements

ISdkConfigurationLcoo
See Also

Reference

AppConfigWrapper Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper.LiveOddsVbl Property

AppConfigWrapperLiveOddsVbl Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.AppConfigWrapper.LiveOddsVbl"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsVbl LiveOddsVbl { get; }

Property Value

SdkConfigurationLiveOddsVbl

Implements

ISdkConfigurationLiveOddsVbl
See Also

Reference

AppConfigWrapper Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper.LiveOddsVdr Property

AppConfigWrapperLiveOddsVdr Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.AppConfigWrapper.LiveOddsVdr"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsVdr LiveOddsVdr { get; }

Property Value

SdkConfigurationLiveOddsVdr

Implements

ISdkConfigurationLiveOddsVdr
See Also

Reference

AppConfigWrapper Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper.LiveOddsVhc Property

AppConfigWrapperLiveOddsVhc Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.AppConfigWrapper.LiveOddsVhc"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsVhc LiveOddsVhc { get; }

Property Value

SdkConfigurationLiveOddsVhc

Implements

ISdkConfigurationLiveOddsVhc
See Also

Reference

AppConfigWrapper Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper.LivePlex Property

AppConfigWrapperLivePlex Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.AppConfigWrapper.LivePlex"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsLivePlex LivePlex { get; }

Property Value

SdkConfigurationLiveOddsLivePlex

Implements

ISdkConfigurationLivePlex
See Also

Reference

AppConfigWrapper Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper.SoccerRoulette Property

AppConfigWrapperSoccerRoulette Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.AppConfigWrapper.SoccerRoulette"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsSoccerRoulette SoccerRoulette { get; }

Property Value

SdkConfigurationLiveOddsSoccerRoulette

Implements

ISdkConfigurationSoccerRoulette
See Also

Reference

AppConfigWrapper Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper Methods

The AppConfigWrapper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Reload |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AppConfigWrapper Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper.Reload Method

AppConfigWrapperReload Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.AppConfigWrapper.Reload(Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationSection)"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public void Reload(
    SdkConfigurationSection section
)

Parameters

section SdkConfigurationSection

[Missing <param name="section"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.AppConfigWrapper.Reload(Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationSection)"]

See Also

Reference

AppConfigWrapper Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper Events

The AppConfigWrapper type exposes the following members.

Events
 | Name | Description
Public event | OnConfigurationReloaded |
Top
See Also

Reference

AppConfigWrapper Class
Sportradar.SDK.Services.SdkConfiguration Namespace


AppConfigWrapper.OnConfigurationReloaded Event

AppConfigWrapperOnConfigurationReloaded Event

[Missing <summary> documentation for "E:Sportradar.SDK.Services.SdkConfiguration.AppConfigWrapper.OnConfigurationReloaded"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event SdkConfigurationDelegatesConfigReloadedDelegate OnConfigurationReloaded

Value

SdkConfigurationDelegatesConfigReloadedDelegate

Implements

ISdkConfigurationOnConfigurationReloaded
See Also

Reference

AppConfigWrapper Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed Class

Base SDK configuration element for all feeds
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLcoo
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationOddsCreator

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class ConfigurationElementFeed : ConfigurationElement

The ConfigurationElementFeed type exposes the following members.

Properties
 | Name | Description
Public property | AlertLogLevel | Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | ClientInteractionLogLevel | Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | ConfigLogLevel | Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | DeadLetterLogLevel | Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | InvalidMsgLogLevel | Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | LoggingFeedName | Prefix used to indicate feed
Public property | ReceiveBufferSize | Receive buffer size for one line of message (overrides automatic defaults for servers)
Public property | SchemaValidationStrictness | Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
Public property | StatsLogLevel | Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | TotalBufferSize | Total message buffer size (overrides automatic defaults for servers)
Public property | TrafficLogLevel | Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed Properties

The ConfigurationElementFeed type exposes the following members.

Properties
 | Name | Description
Public property | AlertLogLevel | Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | ClientInteractionLogLevel | Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | ConfigLogLevel | Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | DeadLetterLogLevel | Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | InvalidMsgLogLevel | Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | LoggingFeedName | Prefix used to indicate feed
Public property | ReceiveBufferSize | Receive buffer size for one line of message (overrides automatic defaults for servers)
Public property | SchemaValidationStrictness | Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
Public property | StatsLogLevel | Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | TotalBufferSize | Total message buffer size (overrides automatic defaults for servers)
Public property | TrafficLogLevel | Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
Top
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed.AlertLogLevel Property

ConfigurationElementFeedAlertLogLevel Property

Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(LevelTypeConverter))]
public Level AlertLogLevel { get; }

Property Value

Level
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed.ClientInteractionLogLevel Property

ConfigurationElementFeedClientInteractionLogLevel Property

Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(LevelTypeConverter))]
public Level ClientInteractionLogLevel { get; }

Property Value

Level
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed.ConfigLogLevel Property

ConfigurationElementFeedConfigLogLevel Property

Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(LevelTypeConverter))]
public Level ConfigLogLevel { get; }

Property Value

Level
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed.DeadLetterLogLevel Property

ConfigurationElementFeedDeadLetterLogLevel Property

Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(LevelTypeConverter))]
public Level DeadLetterLogLevel { get; }

Property Value

Level
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed.InvalidMsgLogLevel Property

ConfigurationElementFeedInvalidMsgLogLevel Property

Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(LevelTypeConverter))]
public Level InvalidMsgLogLevel { get; }

Property Value

Level
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed.LoggingFeedName Property

ConfigurationElementFeedLoggingFeedName Property

Prefix used to indicate feed

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string LoggingFeedName { get; }

Property Value

String
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed.ReceiveBufferSize Property

ConfigurationElementFeedReceiveBufferSize Property

Receive buffer size for one line of message (overrides automatic defaults for servers)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int ReceiveBufferSize { get; }

Property Value

Int32
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed.SchemaValidationStrictness Property

ConfigurationElementFeedSchemaValidationStrictness Property

Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int SchemaValidationStrictness { get; }

Property Value

Int32
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed.StatsLogLevel Property

ConfigurationElementFeedStatsLogLevel Property

Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(LevelTypeConverter))]
public Level StatsLogLevel { get; }

Property Value

Level
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed.TotalBufferSize Property

ConfigurationElementFeedTotalBufferSize Property

Total message buffer size (overrides automatic defaults for servers)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int TotalBufferSize { get; }

Property Value

Int32
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed.TrafficLogLevel Property

ConfigurationElementFeedTrafficLogLevel Property

Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(LevelTypeConverter))]
public Level TrafficLogLevel { get; }

Property Value

Level
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigurationElementFeed Methods

The ConfigurationElementFeed type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConfigurationElementFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.SdkConfiguration.FeedConfig"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.SdkConfigurationFeedConfig

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class FeedConfig

The FeedConfig type exposes the following members.

Fields
Name | Description
ConnectionData |
LoggerData |
ProtocolData |
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig Fields

The FeedConfig type exposes the following members.

Fields
Name | Description
ConnectionData |
LoggerData |
ProtocolData |
Top
See Also

Reference

FeedConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ConnectionData Field

FeedConfigConnectionData Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ConnectionData"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly IDictionary<FeedConfigServerType, IConnectionData> ConnectionData

Field Value

IDictionary FeedConfigServerType, IConnectionData
See Also

Reference

FeedConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.LoggerData Field

FeedConfigLoggerData Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.LoggerData"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly IDictionary<FeedConfigServerType, ILoggerData> LoggerData

Field Value

IDictionary FeedConfigServerType, ILoggerData
See Also

Reference

FeedConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ProtocolData Field

FeedConfigProtocolData Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ProtocolData"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static readonly IDictionary<FeedConfigServerType, IProtocolData> ProtocolData

Field Value

IDictionary FeedConfigServerType, IProtocolData
See Also

Reference

FeedConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType Class

FeedConfigServerType Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType"]

Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
Sportradar.SDK.Services.SdkConfigurationFeedConfigServerType

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class ServerType : Enum

The FeedConfigServerType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
Fields
 | Name | Description
 | LCOO |
 | LIVEODDS |
 | LIVEODDS_BETPAL |
 | LIVEODDS_BETPAL_TEST |
 | LIVEODDS_LIVEPLEX |
 | LIVEODDS_SOCCERROULETTE |
 | LIVEODDS_SOCCERROULETTE_TEST |
 | LIVEODDS_TEST |
 | LIVEODDS_TEST_UNSECURE |
 | LIVEODDS_UNSECURE |
 | LIVEODDS_VBL |
 | LIVEODDS_VBL_TEST |
 | LIVEODDS_VDR |
 | LIVEODDS_VDR_TEST |
 | LIVEODDS_VFC |
 | LIVEODDS_VFC_TEST |
 | LIVEODDS_VFL |
 | LIVEODDS_VFL_TEST |
 | LIVEODDS_VHC |
 | LIVEODDS_VHC_TEST |
 | LIVEODDS_VTO |
 | LIVEODDS_VTO_TEST |
 | LIVESCOUT |
 | LIVESCOUT_TEST |
 | ODDS_CREATOR |
Public field | value__ |
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


ServerType Methods

The FeedConfigServerType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from Enum)
Public method | Equals | Returns a value indicating whether this instance is equal to a specified object. (Inherited from Enum)
Public method | GetHashCode | Returns the hash code for the value of this instance. (Inherited from Enum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeCode | Returns the underlying TypeCode for this instance. (Inherited from Enum)
Public method | HasFlag | Determines whether one or more bit fields are set in the current instance. (Inherited from Enum)
Public method | ToString | Converts the value of this instance to its equivalent string representation. (Inherited from Enum)
Public method | ToString(IFormatProvider) | This method overload is obsolete; use ToString. (Inherited from Enum)
Public method | ToString(String) | Converts the value of this instance to its equivalent string representation using the specified format. (Inherited from Enum)
Public method | ToString(String, IFormatProvider) | This method overload is obsolete; use ToString(String). (Inherited from Enum)
Top
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ServerType Fields

The FeedConfigServerType type exposes the following members.

Fields
 | Name | Description
 | LCOO |
 | LIVEODDS |
 | LIVEODDS_BETPAL |
 | LIVEODDS_BETPAL_TEST |
 | LIVEODDS_LIVEPLEX |
 | LIVEODDS_SOCCERROULETTE |
 | LIVEODDS_SOCCERROULETTE_TEST |
 | LIVEODDS_TEST |
 | LIVEODDS_TEST_UNSECURE |
 | LIVEODDS_UNSECURE |
 | LIVEODDS_VBL |
 | LIVEODDS_VBL_TEST |
 | LIVEODDS_VDR |
 | LIVEODDS_VDR_TEST |
 | LIVEODDS_VFC |
 | LIVEODDS_VFC_TEST |
 | LIVEODDS_VFL |
 | LIVEODDS_VFL_TEST |
 | LIVEODDS_VHC |
 | LIVEODDS_VHC_TEST |
 | LIVEODDS_VTO |
 | LIVEODDS_VTO_TEST |
 | LIVESCOUT |
 | LIVESCOUT_TEST |
 | ODDS_CREATOR |
Public field | value__ |
Top
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LCOO Field

FeedConfigServerTypeLCOO Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LCOO"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LCOO = 24

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS Field

FeedConfigServerTypeLIVEODDS Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS = 12

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_BETPAL Field

FeedConfigServerTypeLIVEODDS_BETPAL Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_BETPAL"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_BETPAL = 17

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_BETPAL_TEST Field

FeedConfigServerTypeLIVEODDS_BETPAL_TEST Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_BETPAL_TEST"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_BETPAL_TEST = 16

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_LIVEPLEX Field

FeedConfigServerTypeLIVEODDS_LIVEPLEX Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_LIVEPLEX"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_LIVEPLEX = 18

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_SOCCERROULETTE Field

FeedConfigServerTypeLIVEODDS_SOCCERROULETTE Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_SOCCERROULETTE"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_SOCCERROULETTE = 19

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_SOCCERROULETTE_TEST Field

FeedConfigServerTypeLIVEODDS_SOCCERROULETTE_TEST Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_SOCCERROULETTE_TEST"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_SOCCERROULETTE_TEST = 20

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_TEST Field

FeedConfigServerTypeLIVEODDS_TEST Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_TEST"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_TEST = 14

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_TEST_UNSECURE Field

FeedConfigServerTypeLIVEODDS_TEST_UNSECURE Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_TEST_UNSECURE"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_TEST_UNSECURE = 15

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_UNSECURE Field

FeedConfigServerTypeLIVEODDS_UNSECURE Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_UNSECURE"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_UNSECURE = 13

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_VBL Field

FeedConfigServerTypeLIVEODDS_VBL Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_VBL"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_VBL = 2

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_VBL_TEST Field

FeedConfigServerTypeLIVEODDS_VBL_TEST Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_VBL_TEST"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_VBL_TEST = 3

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_VDR Field

FeedConfigServerTypeLIVEODDS_VDR Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_VDR"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_VDR = 10

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_VDR_TEST Field

FeedConfigServerTypeLIVEODDS_VDR_TEST Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_VDR_TEST"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_VDR_TEST = 11

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_VFC Field

FeedConfigServerTypeLIVEODDS_VFC Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_VFC"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_VFC = 0

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_VFC_TEST Field

FeedConfigServerTypeLIVEODDS_VFC_TEST Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_VFC_TEST"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_VFC_TEST = 1

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_VFL Field

FeedConfigServerTypeLIVEODDS_VFL Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_VFL"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_VFL = 4

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_VFL_TEST Field

FeedConfigServerTypeLIVEODDS_VFL_TEST Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_VFL_TEST"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_VFL_TEST = 5

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_VHC Field

FeedConfigServerTypeLIVEODDS_VHC Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_VHC"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_VHC = 6

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_VHC_TEST Field

FeedConfigServerTypeLIVEODDS_VHC_TEST Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_VHC_TEST"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_VHC_TEST = 7

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_VTO Field

FeedConfigServerTypeLIVEODDS_VTO Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_VTO"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_VTO = 8

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVEODDS_VTO_TEST Field

FeedConfigServerTypeLIVEODDS_VTO_TEST Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVEODDS_VTO_TEST"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVEODDS_VTO_TEST = 9

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVESCOUT Field

FeedConfigServerTypeLIVESCOUT Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVESCOUT"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVESCOUT = 21

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.LIVESCOUT_TEST Field

FeedConfigServerTypeLIVESCOUT_TEST Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.LIVESCOUT_TEST"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType LIVESCOUT_TEST = 22

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.ODDS_CREATOR Field

FeedConfigServerTypeODDS_CREATOR Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.ODDS_CREATOR"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public const FeedConfigServerType ODDS_CREATOR = 23

Field Value

FeedConfigServerType
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


FeedConfig.ServerType.value__ Field

FeedConfigServerTypevalue__ Field

[Missing <summary> documentation for "F:Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType.value__"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int value__

Field Value

Int32
See Also

Reference

FeedConfigServerType Class
Sportradar.SDK.Services.SdkConfiguration Namespace


HardcodedConfigFactory Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.SdkConfiguration.HardcodedConfigFactory"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.SdkConfigurationHardcodedConfigFactory

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class HardcodedConfigFactory : IConfigFactory

The HardcodedConfigFactory type exposes the following members.

Constructors
 | Name | Description
Public method | HardcodedConfigFactory | Initializes a new instance of the HardcodedConfigFactory class
Top
Methods
 | Name | Description
Public method | BuildConfig |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


HardcodedConfigFactory Constructor

Initializes a new instance of the HardcodedConfigFactory class

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public HardcodedConfigFactory(
    ISdkConfiguration config
)

Parameters

config ISdkConfiguration

[Missing <param name="config"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.HardcodedConfigFactory.#ctor(Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration)"]

See Also

Reference

HardcodedConfigFactory Class
Sportradar.SDK.Services.SdkConfiguration Namespace


HardcodedConfigFactory Methods

The HardcodedConfigFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildConfig |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HardcodedConfigFactory Class
Sportradar.SDK.Services.SdkConfiguration Namespace


HardcodedConfigFactory.BuildConfig Method

HardcodedConfigFactoryBuildConfig Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.HardcodedConfigFactory.BuildConfig"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ISdkConfiguration BuildConfig()

Return Value

ISdkConfiguration

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.HardcodedConfigFactory.BuildConfig"]

Implements

IConfigFactoryBuildConfig
See Also

Reference

HardcodedConfigFactory Class
Sportradar.SDK.Services.SdkConfiguration Namespace


IConfigFactory Interface

Configuration factory interface.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface IConfigFactory

The IConfigFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildConfig | Factory method to create (an immutable) configuration.
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


IConfigFactory Methods

The IConfigFactory type exposes the following members.

Methods
 | Name | Description
Public method | BuildConfig | Factory method to create (an immutable) configuration.
Top
See Also

Reference

IConfigFactory Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


IConfigFactory.BuildConfig Method

IConfigFactoryBuildConfig Method

Factory method to create (an immutable) configuration.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
ISdkConfiguration BuildConfig()

Return Value

ISdkConfiguration
SDK configuration
See Also

Reference

IConfigFactory Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration Interface

SDK configuration.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public interface ISdkConfiguration

The ISdkConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | BetPal | SDK configuration element with BetPal feed provider settings.
Public property | Common | SDK configuration element where common settings used throughout the SDK library are specified.
Public property | Dynamic | SDK configuration element where settings for the server-side configuration service are specified (mostly access parameters).
Public property | Lcoo | SDK configuration element with Live Cycle of Odds provider settings.
Public property | LiveOdds | SDK configuration element with LiveOdds feed provider settings.
Public property | LiveOddsBetTypes | SDK configuration element with LiveOdds BetType data feed provider settings.
Public property | LiveOddsVbl | SDK configuration element with LiveOdds VFL feed provider settings.
Public property | LiveOddsVdr | SDK configuration element with LiveOdds VFL feed provider settings.
Public property | LiveOddsVfc | SDK configuration element with LiveOdds VFC feed provider settings.
Public property | LiveOddsVfl | SDK configuration element with LiveOdds VFL feed provider settings.
Public property | LiveOddsVhc | SDK configuration element with LiveOdds VFL feed provider settings.
Public property | LiveOddsVto | SDK configuration element with LiveOdds VTO feed provider settings.
Public property | LivePlex | SDK configuration element with BetPal feed provider settings.
Public property | LiveScout | SDK configuration element with LiveScout feed provider settings.
Public property | MessageDispatcher | SDK configuration element where Message Dispatcher settings are specified.
Public property | OddsCreator | SDK configuration element with OddsCreator provider settings.
Public property | PersistentState | SDK configuration element with Persistent State provider settings (SqLite database settings).
Public property | SoccerRoulette | SDK configuration element with BetPal feed provider settings.
Top
Events
 | Name | Description
Public event | OnConfigurationReloaded | Event fired every time that configuration is reloaded / refreshed and might have changed. This is a good time for components to update their cached configuration settings, if any.
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration Properties

The ISdkConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | BetPal | SDK configuration element with BetPal feed provider settings.
Public property | Common | SDK configuration element where common settings used throughout the SDK library are specified.
Public property | Dynamic | SDK configuration element where settings for the server-side configuration service are specified (mostly access parameters).
Public property | Lcoo | SDK configuration element with Live Cycle of Odds provider settings.
Public property | LiveOdds | SDK configuration element with LiveOdds feed provider settings.
Public property | LiveOddsBetTypes | SDK configuration element with LiveOdds BetType data feed provider settings.
Public property | LiveOddsVbl | SDK configuration element with LiveOdds VFL feed provider settings.
Public property | LiveOddsVdr | SDK configuration element with LiveOdds VFL feed provider settings.
Public property | LiveOddsVfc | SDK configuration element with LiveOdds VFC feed provider settings.
Public property | LiveOddsVfl | SDK configuration element with LiveOdds VFL feed provider settings.
Public property | LiveOddsVhc | SDK configuration element with LiveOdds VFL feed provider settings.
Public property | LiveOddsVto | SDK configuration element with LiveOdds VTO feed provider settings.
Public property | LivePlex | SDK configuration element with BetPal feed provider settings.
Public property | LiveScout | SDK configuration element with LiveScout feed provider settings.
Public property | MessageDispatcher | SDK configuration element where Message Dispatcher settings are specified.
Public property | OddsCreator | SDK configuration element with OddsCreator provider settings.
Public property | PersistentState | SDK configuration element with Persistent State provider settings (SqLite database settings).
Public property | SoccerRoulette | SDK configuration element with BetPal feed provider settings.
Top
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.BetPal Property

ISdkConfigurationBetPal Property

SDK configuration element with BetPal feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLiveOddsBetPal BetPal { get; }

Property Value

SdkConfigurationLiveOddsBetPal
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.Common Property

ISdkConfigurationCommon Property

SDK configuration element where common settings used throughout the SDK library are specified.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationCommon Common { get; }

Property Value

SdkConfigurationCommon
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.Dynamic Property

ISdkConfigurationDynamic Property

SDK configuration element where settings for the server-side configuration service are specified (mostly access parameters).

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationDynamic Dynamic { get; }

Property Value

SdkConfigurationDynamic
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.Lcoo Property

ISdkConfigurationLcoo Property

SDK configuration element with Live Cycle of Odds provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLcoo Lcoo { get; }

Property Value

SdkConfigurationLcoo
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.LiveOdds Property

ISdkConfigurationLiveOdds Property

SDK configuration element with LiveOdds feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLiveOdds LiveOdds { get; }

Property Value

SdkConfigurationLiveOdds
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.LiveOddsBetTypes Property

ISdkConfigurationLiveOddsBetTypes Property

SDK configuration element with LiveOdds BetType data feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLiveOddsBetTypes LiveOddsBetTypes { get; }

Property Value

SdkConfigurationLiveOddsBetTypes
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.LiveOddsVbl Property

ISdkConfigurationLiveOddsVbl Property

SDK configuration element with LiveOdds VFL feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLiveOddsVbl LiveOddsVbl { get; }

Property Value

SdkConfigurationLiveOddsVbl
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.LiveOddsVdr Property

ISdkConfigurationLiveOddsVdr Property

SDK configuration element with LiveOdds VFL feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLiveOddsVdr LiveOddsVdr { get; }

Property Value

SdkConfigurationLiveOddsVdr
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.LiveOddsVfc Property

ISdkConfigurationLiveOddsVfc Property

SDK configuration element with LiveOdds VFC feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLiveOddsVfc LiveOddsVfc { get; }

Property Value

SdkConfigurationLiveOddsVfc
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.LiveOddsVfl Property

ISdkConfigurationLiveOddsVfl Property

SDK configuration element with LiveOdds VFL feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLiveOddsVfl LiveOddsVfl { get; }

Property Value

SdkConfigurationLiveOddsVfl
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.LiveOddsVhc Property

ISdkConfigurationLiveOddsVhc Property

SDK configuration element with LiveOdds VFL feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLiveOddsVhc LiveOddsVhc { get; }

Property Value

SdkConfigurationLiveOddsVhc
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.LiveOddsVto Property

ISdkConfigurationLiveOddsVto Property

SDK configuration element with LiveOdds VTO feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLiveOddsVto LiveOddsVto { get; }

Property Value

SdkConfigurationLiveOddsVto
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.LivePlex Property

ISdkConfigurationLivePlex Property

SDK configuration element with BetPal feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLiveOddsLivePlex LivePlex { get; }

Property Value

SdkConfigurationLiveOddsLivePlex
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.LiveScout Property

ISdkConfigurationLiveScout Property

SDK configuration element with LiveScout feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLiveScout LiveScout { get; }

Property Value

SdkConfigurationLiveScout
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.MessageDispatcher Property

ISdkConfigurationMessageDispatcher Property

SDK configuration element where Message Dispatcher settings are specified.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationMessageDispatcher MessageDispatcher { get; }

Property Value

SdkConfigurationMessageDispatcher
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.OddsCreator Property

ISdkConfigurationOddsCreator Property

SDK configuration element with OddsCreator provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationOddsCreator OddsCreator { get; }

Property Value

SdkConfigurationOddsCreator
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.PersistentState Property

ISdkConfigurationPersistentState Property

SDK configuration element with Persistent State provider settings (SqLite database settings).

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationPersistentState PersistentState { get; }

Property Value

SdkConfigurationPersistentState
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.SoccerRoulette Property

ISdkConfigurationSoccerRoulette Property

SDK configuration element with BetPal feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
SdkConfigurationLiveOddsSoccerRoulette SoccerRoulette { get; }

Property Value

SdkConfigurationLiveOddsSoccerRoulette
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration Events

The ISdkConfiguration type exposes the following members.

Events
 | Name | Description
Public event | OnConfigurationReloaded | Event fired every time that configuration is reloaded / refreshed and might have changed. This is a good time for components to update their cached configuration settings, if any.
Top
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


ISdkConfiguration.OnConfigurationReloaded Event

ISdkConfigurationOnConfigurationReloaded Event

Event fired every time that configuration is reloaded / refreshed and might have changed. This is a good time for components to update their cached configuration settings, if any.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
event SdkConfigurationDelegatesConfigReloadedDelegate OnConfigurationReloaded

Value

SdkConfigurationDelegatesConfigReloadedDelegate
See Also

Reference

ISdkConfiguration Interface
Sportradar.SDK.Services.SdkConfiguration Namespace


PropertyValidators Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.SdkConfiguration.PropertyValidators"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.SdkConfigurationPropertyValidators

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class PropertyValidators

The PropertyValidators type exposes the following members.

Methods
Name | Description
ValidateNullableInt |
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


PropertyValidators Methods

The PropertyValidators type exposes the following members.

Methods
Name | Description
ValidateNullableInt |
Top
See Also

Reference

PropertyValidators Class
Sportradar.SDK.Services.SdkConfiguration Namespace


PropertyValidators.ValidateNullableInt Method

PropertyValidatorsValidateNullableInt Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.PropertyValidators.ValidateNullableInt(System.Object)"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static void ValidateNullableInt(
    Object value
)

Parameters

value Object

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.PropertyValidators.ValidateNullableInt(System.Object)"]

See Also

Reference

PropertyValidators Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.SdkConfigurationProviderConfig

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class ProviderConfig : IProtocolData,
    ICloneable, IConnectionData, ICipherSettings, ILoggerData

The ProviderConfig type exposes the following members.

Constructors
 | Name | Description
Public method | ProviderConfig | Initializes a new instance of the ProviderConfig class
Top
Properties
 | Name | Description
Public property | AlertLogLevel |
Public property | BookmakerId |
Public property | BookmakerKey |
Public property | CipherSettings |
Public property | ClientAliveMsgTimeout |
Public property | ClientInteractionLogLevel |
Public property | DeadLetterLogLevel |
Public property | DisallowNonPrintableChars |
Public property | DoValidityCheck |
Public property | Encoding |
Public property | EventRequestLimiter |
Public property | Hostname |
Public property | InvalidDataReconnectWait |
Public property | InvalidMsgLogLevel |
Public property | LoggingFeedName |
Public property | LoginLimiter |
Public property | MaxReconnectWait |
Public property | MaxTimeSkew |
Public property | MinCipherStrength |
Public property | MinHashStrength |
Public property | MinKeyExchangeStrength |
Public property | MinReconnectWait |
Public property | Port |
Public property | ReceiveBufferSize |
Public property | ReceiveTimeout |
Public property | RequestLimiter |
Public property | RestartOnParseError |
Public property | SchemaStrictness |
Public property | ScoutPassword |
Public property | ScoutUsername |
Public property | SendClientTimeInRequest |
Public property | SendClientVersionInLogin |
Public property | SendTimeout |
Public property | ServerAliveMsgTimeout |
Public property | SSLThumbPrint |
Public property | TotalBufferSize |
Public property | TrafficLogLevel |
Public property | UseSSL |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig Constructor

Initializes a new instance of the ProviderConfig class

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ProviderConfig(
    ISdkConfiguration config,
    Func<ISdkConfiguration, SdkConfigurationLiveFeed> get_local_config,
    FeedConfigServerType type
)

Parameters

config ISdkConfiguration

[Missing <param name="config"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.#ctor(Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,System.Func{Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveFeed},Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType)"]

get_local_config Func ISdkConfiguration, SdkConfigurationLiveFeed

[Missing <param name="get_local_config"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.#ctor(Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,System.Func{Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveFeed},Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType)"]

type FeedConfigServerType

[Missing <param name="type"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.#ctor(Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,System.Func{Sportradar.SDK.Services.SdkConfiguration.ISdkConfiguration,Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveFeed},Sportradar.SDK.Services.SdkConfiguration.FeedConfig.ServerType)"]

See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig Properties

The ProviderConfig type exposes the following members.

Properties
 | Name | Description
Public property | AlertLogLevel |
Public property | BookmakerId |
Public property | BookmakerKey |
Public property | CipherSettings |
Public property | ClientAliveMsgTimeout |
Public property | ClientInteractionLogLevel |
Public property | DeadLetterLogLevel |
Public property | DisallowNonPrintableChars |
Public property | DoValidityCheck |
Public property | Encoding |
Public property | EventRequestLimiter |
Public property | Hostname |
Public property | InvalidDataReconnectWait |
Public property | InvalidMsgLogLevel |
Public property | LoggingFeedName |
Public property | LoginLimiter |
Public property | MaxReconnectWait |
Public property | MaxTimeSkew |
Public property | MinCipherStrength |
Public property | MinHashStrength |
Public property | MinKeyExchangeStrength |
Public property | MinReconnectWait |
Public property | Port |
Public property | ReceiveBufferSize |
Public property | ReceiveTimeout |
Public property | RequestLimiter |
Public property | RestartOnParseError |
Public property | SchemaStrictness |
Public property | ScoutPassword |
Public property | ScoutUsername |
Public property | SendClientTimeInRequest |
Public property | SendClientVersionInLogin |
Public property | SendTimeout |
Public property | ServerAliveMsgTimeout |
Public property | SSLThumbPrint |
Public property | TotalBufferSize |
Public property | TrafficLogLevel |
Public property | UseSSL |
Top
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.AlertLogLevel Property

ProviderConfigAlertLogLevel Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.AlertLogLevel"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Level AlertLogLevel { get; }

Property Value

Level

Implements

ILoggerDataAlertLogLevel
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.BookmakerId Property

ProviderConfigBookmakerId Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.BookmakerId"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public long BookmakerId { get; }

Property Value

Int64

Implements

IProtocolDataBookmakerId
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.BookmakerKey Property

ProviderConfigBookmakerKey Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.BookmakerKey"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SecureString BookmakerKey { get; }

Property Value

SecureString

Implements

IProtocolDataBookmakerKey
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.CipherSettings Property

ProviderConfigCipherSettings Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.CipherSettings"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ICipherSettings CipherSettings { get; }

Property Value

ICipherSettings

Implements

IConnectionDataCipherSettings
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.ClientAliveMsgTimeout Property

ProviderConfigClientAliveMsgTimeout Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.ClientAliveMsgTimeout"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan ClientAliveMsgTimeout { get; }

Property Value

TimeSpan

Implements

IConnectionDataClientAliveMsgTimeout
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.ClientInteractionLogLevel Property

ProviderConfigClientInteractionLogLevel Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.ClientInteractionLogLevel"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Level ClientInteractionLogLevel { get; }

Property Value

Level

Implements

ILoggerDataClientInteractionLogLevel
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.DeadLetterLogLevel Property

ProviderConfigDeadLetterLogLevel Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.DeadLetterLogLevel"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Level DeadLetterLogLevel { get; }

Property Value

Level

Implements

ILoggerDataDeadLetterLogLevel
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.DisallowNonPrintableChars Property

ProviderConfigDisallowNonPrintableChars Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.DisallowNonPrintableChars"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool DisallowNonPrintableChars { get; }

Property Value

Boolean

Implements

IConnectionDataDisallowNonPrintableChars
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.DoValidityCheck Property

ProviderConfigDoValidityCheck Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.DoValidityCheck"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool DoValidityCheck { get; }

Property Value

Boolean

Implements

IConnectionDataDoValidityCheck
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.Encoding Property

ProviderConfigEncoding Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.Encoding"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Encoding Encoding { get; }

Property Value

Encoding

Implements

IConnectionDataEncoding
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.EventRequestLimiter Property

ProviderConfigEventRequestLimiter Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.EventRequestLimiter"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IRateGate EventRequestLimiter { get; }

Property Value

IRateGate

Implements

IProtocolDataEventRequestLimiter
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.Hostname Property

ProviderConfigHostname Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.Hostname"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Hostname { get; }

Property Value

String

Implements

IConnectionDataHostname
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.InvalidDataReconnectWait Property

ProviderConfigInvalidDataReconnectWait Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.InvalidDataReconnectWait"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan InvalidDataReconnectWait { get; }

Property Value

TimeSpan

Implements

IConnectionDataInvalidDataReconnectWait
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.InvalidMsgLogLevel Property

ProviderConfigInvalidMsgLogLevel Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.InvalidMsgLogLevel"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Level InvalidMsgLogLevel { get; }

Property Value

Level

Implements

ILoggerDataInvalidMsgLogLevel
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.LoggingFeedName Property

ProviderConfigLoggingFeedName Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.LoggingFeedName"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string LoggingFeedName { get; }

Property Value

String

Implements

ILoggerDataLoggingFeedName
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.LoginLimiter Property

ProviderConfigLoginLimiter Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.LoginLimiter"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IRateGate LoginLimiter { get; }

Property Value

IRateGate

Implements

IProtocolDataLoginLimiter
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.MaxReconnectWait Property

ProviderConfigMaxReconnectWait Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.MaxReconnectWait"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan MaxReconnectWait { get; }

Property Value

TimeSpan

Implements

IConnectionDataMaxReconnectWait
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.MaxTimeSkew Property

ProviderConfigMaxTimeSkew Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.MaxTimeSkew"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan MaxTimeSkew { get; }

Property Value

TimeSpan

Implements

IProtocolDataMaxTimeSkew
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.MinCipherStrength Property

ProviderConfigMinCipherStrength Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.MinCipherStrength"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int MinCipherStrength { get; }

Property Value

Int32

Implements

ICipherSettingsMinCipherStrength
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.MinHashStrength Property

ProviderConfigMinHashStrength Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.MinHashStrength"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int MinHashStrength { get; }

Property Value

Int32

Implements

ICipherSettingsMinHashStrength
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.MinKeyExchangeStrength Property

ProviderConfigMinKeyExchangeStrength Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.MinKeyExchangeStrength"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int MinKeyExchangeStrength { get; }

Property Value

Int32

Implements

ICipherSettingsMinKeyExchangeStrength
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.MinReconnectWait Property

ProviderConfigMinReconnectWait Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.MinReconnectWait"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan MinReconnectWait { get; }

Property Value

TimeSpan

Implements

IConnectionDataMinReconnectWait
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.Port Property

ProviderConfigPort Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.Port"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Port { get; }

Property Value

Int32

Implements

IConnectionDataPort
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.ReceiveBufferSize Property

ProviderConfigReceiveBufferSize Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.ReceiveBufferSize"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int ReceiveBufferSize { get; }

Property Value

Int32

Implements

IConnectionDataReceiveBufferSize
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.ReceiveTimeout Property

ProviderConfigReceiveTimeout Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.ReceiveTimeout"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan ReceiveTimeout { get; }

Property Value

TimeSpan

Implements

IConnectionDataReceiveTimeout
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.RequestLimiter Property

ProviderConfigRequestLimiter Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.RequestLimiter"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public IRateGate RequestLimiter { get; }

Property Value

IRateGate

Implements

IProtocolDataRequestLimiter
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.RestartOnParseError Property

ProviderConfigRestartOnParseError Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.RestartOnParseError"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool RestartOnParseError { get; }

Property Value

Boolean

Implements

IProtocolDataRestartOnParseError
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.SchemaStrictness Property

ProviderConfigSchemaStrictness Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.SchemaStrictness"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SchemaValidationStrictness SchemaStrictness { get; }

Property Value

SchemaValidationStrictness

Implements

IProtocolDataSchemaStrictness
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.ScoutPassword Property

ProviderConfigScoutPassword Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.ScoutPassword"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SecureString ScoutPassword { get; }

Property Value

SecureString

Implements

IProtocolDataScoutPassword
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.ScoutUsername Property

ProviderConfigScoutUsername Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.ScoutUsername"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ScoutUsername { get; }

Property Value

String

Implements

IProtocolDataScoutUsername
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.SendClientTimeInRequest Property

ProviderConfigSendClientTimeInRequest Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.SendClientTimeInRequest"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool SendClientTimeInRequest { get; }

Property Value

Boolean

Implements

IProtocolDataSendClientTimeInRequest
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.SendClientVersionInLogin Property

ProviderConfigSendClientVersionInLogin Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.SendClientVersionInLogin"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool SendClientVersionInLogin { get; }

Property Value

Boolean

Implements

IProtocolDataSendClientVersionInLogin
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.SendTimeout Property

ProviderConfigSendTimeout Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.SendTimeout"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan SendTimeout { get; }

Property Value

TimeSpan

Implements

IConnectionDataSendTimeout
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.ServerAliveMsgTimeout Property

ProviderConfigServerAliveMsgTimeout Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.ServerAliveMsgTimeout"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan ServerAliveMsgTimeout { get; }

Property Value

TimeSpan

Implements

IConnectionDataServerAliveMsgTimeout
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.SSLThumbPrint Property

ProviderConfigSSLThumbPrint Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.SSLThumbPrint"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SSLThumbPrint { get; }

Property Value

String

Implements

ICipherSettingsSSLThumbPrint
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.TotalBufferSize Property

ProviderConfigTotalBufferSize Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.TotalBufferSize"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int TotalBufferSize { get; }

Property Value

Int32

Implements

IConnectionDataTotalBufferSize
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.TrafficLogLevel Property

ProviderConfigTrafficLogLevel Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.TrafficLogLevel"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Level TrafficLogLevel { get; }

Property Value

Level

Implements

ILoggerDataTrafficLogLevel
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.UseSSL Property

ProviderConfigUseSSL Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.UseSSL"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool UseSSL { get; }

Property Value

Boolean

Implements

IConnectionDataUseSSL
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig Methods

The ProviderConfig type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ProviderConfig.Clone Method

ProviderConfigClone Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.Clone"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public Object Clone()

Return Value

Object

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.ProviderConfig.Clone"]

Implements

ICloneableClone
See Also

Reference

ProviderConfig Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon Class

SDK configuration element where common settings used throughout the SDK library are specified.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationCommon

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationCommon : ConfigurationElement

The SdkConfigurationCommon type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Bookmaker id
Public property | ConfigLogLevel | Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | ExecutionLogLevel | Specifies log level threshold used while logging SDK library code execution. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | Logging | Indicates whether SDK logging should be enabled
Public property | LogPath | Root path where SDK logs will be stored (relative or absolute).
Public property | MaximumFileSize | A property that would be applied to all RollingFileAppender in SDK logs.
Public property | MaxSizeRollBackups | A property that would be applied to all RollingFileAppender in SDK logs.
Public property | MaxThreadPoolThreads | Maximum number of thread pool threads
Public property | OldLogCleanupInterval | Old log clean-up interval.
Public property | OldLogMaxAge | Old log max-age.
Public property | QueueHighWatermark | High watermark for all limited priority queue instances (number of items). Signals that a queue will soon reach its full capacity and that we should probably stop processing incoming messages until things calm down a bit.
Public property | QueueLowWatermark | Low watermark for all limited priority queue instances (number of items). Signals that a queue is getting filled up and that client may experience some additional latency in msg delivery.
Public property | QueueMaxCapacity | Capacity (max. number of items) that can be stored in any limited priority queue instance.
Public property | SafeMode | Indicates whether "safe-mode" SDK components are used instead of normal ones.
Public property | StatsLogLevel | Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | UniquenessStrictness | Verify whether we are the only instance running
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon Properties

The SdkConfigurationCommon type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Bookmaker id
Public property | ConfigLogLevel | Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | ExecutionLogLevel | Specifies log level threshold used while logging SDK library code execution. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | Logging | Indicates whether SDK logging should be enabled
Public property | LogPath | Root path where SDK logs will be stored (relative or absolute).
Public property | MaximumFileSize | A property that would be applied to all RollingFileAppender in SDK logs.
Public property | MaxSizeRollBackups | A property that would be applied to all RollingFileAppender in SDK logs.
Public property | MaxThreadPoolThreads | Maximum number of thread pool threads
Public property | OldLogCleanupInterval | Old log clean-up interval.
Public property | OldLogMaxAge | Old log max-age.
Public property | QueueHighWatermark | High watermark for all limited priority queue instances (number of items). Signals that a queue will soon reach its full capacity and that we should probably stop processing incoming messages until things calm down a bit.
Public property | QueueLowWatermark | Low watermark for all limited priority queue instances (number of items). Signals that a queue is getting filled up and that client may experience some additional latency in msg delivery.
Public property | QueueMaxCapacity | Capacity (max. number of items) that can be stored in any limited priority queue instance.
Public property | SafeMode | Indicates whether "safe-mode" SDK components are used instead of normal ones.
Public property | StatsLogLevel | Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
Public property | UniquenessStrictness | Verify whether we are the only instance running
Top
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.BookmakerId Property

SdkConfigurationCommonBookmakerId Property

Bookmaker id

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int BookmakerId { get; }

Property Value

Int32
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.ConfigLogLevel Property

SdkConfigurationCommonConfigLogLevel Property

Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(LevelTypeConverter))]
public Level ConfigLogLevel { get; }

Property Value

Level
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.ExecutionLogLevel Property

SdkConfigurationCommonExecutionLogLevel Property

Specifies log level threshold used while logging SDK library code execution. Possible values are: Debug, Info, Warn, Error, Fatal

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(LevelTypeConverter))]
public Level ExecutionLogLevel { get; }

Property Value

Level
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.Logging Property

SdkConfigurationCommonLogging Property

Indicates whether SDK logging should be enabled

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Logging { get; }

Property Value

Boolean
Remarks
If this is set to false we will be unable to help you with any SDK problems
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.LogPath Property

SdkConfigurationCommonLogPath Property

Root path where SDK logs will be stored (relative or absolute).

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string LogPath { get; }

Property Value

String
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.MaximumFileSize Property

SdkConfigurationCommonMaximumFileSize Property

A property that would be applied to all RollingFileAppender in SDK logs.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string MaximumFileSize { get; }

Property Value

String
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.MaxSizeRollBackups Property

SdkConfigurationCommonMaxSizeRollBackups Property

A property that would be applied to all RollingFileAppender in SDK logs.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int MaxSizeRollBackups { get; }

Property Value

Int32
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.MaxThreadPoolThreads Property

SdkConfigurationCommonMaxThreadPoolThreads Property

Maximum number of thread pool threads

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int MaxThreadPoolThreads { get; }

Property Value

Int32
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.OldLogCleanupInterval Property

SdkConfigurationCommonOldLogCleanupInterval Property

Old log clean-up interval.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan OldLogCleanupInterval { get; }

Property Value

TimeSpan
Remarks
How often the clean up task is invoked.
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.OldLogMaxAge Property

SdkConfigurationCommonOldLogMaxAge Property

Old log max-age.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan OldLogMaxAge { get; }

Property Value

TimeSpan
Remarks
Log files with a modified time older than that will be removed.
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.QueueHighWatermark Property

SdkConfigurationCommonQueueHighWatermark Property

High watermark for all limited priority queue instances (number of items). Signals that a queue will soon reach its full capacity and that we should probably stop processing incoming messages until things calm down a bit.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int QueueHighWatermark { get; }

Property Value

Int32
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.QueueLowWatermark Property

SdkConfigurationCommonQueueLowWatermark Property

Low watermark for all limited priority queue instances (number of items). Signals that a queue is getting filled up and that client may experience some additional latency in msg delivery.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int QueueLowWatermark { get; }

Property Value

Int32
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.QueueMaxCapacity Property

SdkConfigurationCommonQueueMaxCapacity Property

Capacity (max. number of items) that can be stored in any limited priority queue instance.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int QueueMaxCapacity { get; }

Property Value

Int32
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.SafeMode Property

SdkConfigurationCommonSafeMode Property

Indicates whether "safe-mode" SDK components are used instead of normal ones.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool SafeMode { get; }

Property Value

Boolean
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.StatsLogLevel Property

SdkConfigurationCommonStatsLogLevel Property

Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(LevelTypeConverter))]
public Level StatsLogLevel { get; }

Property Value

Level
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.UniquenessStrictness Property

SdkConfigurationCommonUniquenessStrictness Property

Verify whether we are the only instance running

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int UniquenessStrictness { get; }

Property Value

Int32
Remarks
0 means no checking, 1 means checking but no error, 2 means fail if there are more instances
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon Methods

The SdkConfigurationCommon type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationCommon.IsReadOnly Method

SdkConfigurationCommonIsReadOnly Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationCommon.IsReadOnly"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool IsReadOnly()

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationCommon.IsReadOnly"]

See Also

Reference

SdkConfigurationCommon Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDelegates Class

Configuration delegates.
Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationDelegates

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public static class SdkConfigurationDelegates
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDelegates.ConfigReloadedDelegate Class

SdkConfigurationDelegatesConfigReloadedDelegate Class

Indicates that configuration has been reloaded/refreshed and might have changed. This is a good time for components to update their cached configuration settings, if any.
Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationDelegatesConfigReloadedDelegate

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public sealed class ConfigReloadedDelegate : MulticastDelegate

The SdkConfigurationDelegatesConfigReloadedDelegate type exposes the following members.

Constructors
 | Name | Description
Public method | SdkConfigurationDelegatesConfigReloadedDelegate | Initializes a new instance of the SdkConfigurationDelegatesConfigReloadedDelegate class
Top
Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDelegates.ConfigReloadedDelegate Constructor

SdkConfigurationDelegatesConfigReloadedDelegate Constructor

Initializes a new instance of the SdkConfigurationDelegatesConfigReloadedDelegate class

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public ConfigReloadedDelegate(
    Object object,
    IntPtr method
)

Parameters

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationDelegates.ConfigReloadedDelegate.#ctor(System.Object,System.IntPtr)"]

method IntPtr

[Missing <param name="method"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationDelegates.ConfigReloadedDelegate.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

SdkConfigurationDelegatesConfigReloadedDelegate Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigReloadedDelegate Properties

The SdkConfigurationDelegatesConfigReloadedDelegate type exposes the following members.

Properties
 | Name | Description
Public property | Method | Gets the method represented by the delegate. (Inherited from Delegate)
Public property | Target | Gets the class instance on which the current delegate invokes the instance method. (Inherited from Delegate)
Top
See Also

Reference

SdkConfigurationDelegatesConfigReloadedDelegate Class
Sportradar.SDK.Services.SdkConfiguration Namespace


ConfigReloadedDelegate Methods

The SdkConfigurationDelegatesConfigReloadedDelegate type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | Clone | Creates a shallow copy of the delegate. (Inherited from Delegate)
Public method | DynamicInvoke | Dynamically invokes (late-bound) the method represented by the current delegate. (Inherited from Delegate)
Public method | EndInvoke |
Public method | Equals | Determines whether this multicast delegate and the specified object are equal. (Inherited from MulticastDelegate)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from MulticastDelegate)
Public method | GetInvocationList | Returns the invocation list of this multicast delegate, in invocation order. (Inherited from MulticastDelegate)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize this instance. (Inherited from MulticastDelegate)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Invoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationDelegatesConfigReloadedDelegate Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDelegates.ConfigReloadedDelegate.BeginInvoke Method

SdkConfigurationDelegatesConfigReloadedDelegateBeginInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationDelegates.ConfigReloadedDelegate.BeginInvoke(System.AsyncCallback,System.Object)"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual IAsyncResult BeginInvoke(
    AsyncCallback callback,
    Object object
)

Parameters

callback AsyncCallback

[Missing <param name="callback"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationDelegates.ConfigReloadedDelegate.BeginInvoke(System.AsyncCallback,System.Object)"]

object Object

[Missing <param name="object"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationDelegates.ConfigReloadedDelegate.BeginInvoke(System.AsyncCallback,System.Object)"]

Return Value

IAsyncResult

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationDelegates.ConfigReloadedDelegate.BeginInvoke(System.AsyncCallback,System.Object)"]

See Also

Reference

SdkConfigurationDelegatesConfigReloadedDelegate Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDelegates.ConfigReloadedDelegate.EndInvoke Method

SdkConfigurationDelegatesConfigReloadedDelegateEndInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationDelegates.ConfigReloadedDelegate.EndInvoke(System.IAsyncResult)"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void EndInvoke(
    IAsyncResult result
)

Parameters

result IAsyncResult

[Missing <param name="result"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationDelegates.ConfigReloadedDelegate.EndInvoke(System.IAsyncResult)"]

See Also

Reference

SdkConfigurationDelegatesConfigReloadedDelegate Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDelegates.ConfigReloadedDelegate.Invoke Method

SdkConfigurationDelegatesConfigReloadedDelegateInvoke Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationDelegates.ConfigReloadedDelegate.Invoke"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual void Invoke()
See Also

Reference

SdkConfigurationDelegatesConfigReloadedDelegate Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDynamic Class

SDK configuration element where settings for the server-side configuration service are specified (mostly access parameters).
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationDynamic

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationDynamic : ConfigurationElement

The SdkConfigurationDynamic type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Bookmaker id
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | HttpResponseTimeout | Time to wait for the HTTP request to complete.
Public property | HttpUrl | HTTP URL can have {ID}, {NS} and {VER} placeholders, else id=.., ver=.. and ns=.. query parameters are appended to the URL Example: "http://localhost:8080/abc"
Public property | IsInitialized | Is section initialized?
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | MaxFetchInterval | Max fetch interval
Public property | MinFetchInterval | Min fetch interval
Public property | SSLThumbprint | Optional SSL server certificate thumbprint
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDynamic Properties

The SdkConfigurationDynamic type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Bookmaker id
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | HttpResponseTimeout | Time to wait for the HTTP request to complete.
Public property | HttpUrl | HTTP URL can have {ID}, {NS} and {VER} placeholders, else id=.., ver=.. and ns=.. query parameters are appended to the URL Example: "http://localhost:8080/abc"
Public property | IsInitialized | Is section initialized?
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | MaxFetchInterval | Max fetch interval
Public property | MinFetchInterval | Min fetch interval
Public property | SSLThumbprint | Optional SSL server certificate thumbprint
Top
See Also

Reference

SdkConfigurationDynamic Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDynamic.BookmakerId Property

SdkConfigurationDynamicBookmakerId Property

Bookmaker id

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? BookmakerId { get; }

Property Value

Nullable Int32
Remarks
This one will override the common settings.
See Also

Reference

SdkConfigurationDynamic Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDynamic.HttpResponseTimeout Property

SdkConfigurationDynamicHttpResponseTimeout Property

Time to wait for the HTTP request to complete.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan HttpResponseTimeout { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationDynamic Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDynamic.HttpUrl Property

SdkConfigurationDynamicHttpUrl Property

HTTP URL can have {ID}, {NS} and {VER} placeholders, else id=.., ver=.. and ns=.. query parameters are appended to the URL Example: "http://localhost:8080/abc"

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string HttpUrl { get; }

Property Value

String
Remarks
ID means bookmaker ID, either common or local setting NS means namespace (usually: Sportradar.SDK, so config server can store configuration for multiple types of clients) VER means SDK (assembly) version
See Also

Reference

SdkConfigurationDynamic Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDynamic.IsInitialized Property

SdkConfigurationDynamicIsInitialized Property

Is section initialized?

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsInitialized { get; }

Property Value

Boolean
See Also

Reference

SdkConfigurationDynamic Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDynamic.MaxFetchInterval Property

SdkConfigurationDynamicMaxFetchInterval Property

Max fetch interval

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan MaxFetchInterval { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationDynamic Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDynamic.MinFetchInterval Property

SdkConfigurationDynamicMinFetchInterval Property

Min fetch interval

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public TimeSpan MinFetchInterval { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationDynamic Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDynamic.SSLThumbprint Property

SdkConfigurationDynamicSSLThumbprint Property

Optional SSL server certificate thumbprint

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SSLThumbprint { get; }

Property Value

String
See Also

Reference

SdkConfigurationDynamic Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDynamic Methods

The SdkConfigurationDynamic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationDynamic Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationDynamic.IsReadOnly Method

SdkConfigurationDynamicIsReadOnly Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationDynamic.IsReadOnly"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool IsReadOnly()

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationDynamic.IsReadOnly"]

See Also

Reference

SdkConfigurationDynamic Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo Class

SDK configuration element with LCoO feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLcoo

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLcoo : ConfigurationElementFeed

The SdkConfigurationLcoo type exposes the following members.

Constructors
 | Name | Description
Public method | SdkConfigurationLcoo | Initializes a new instance of the SdkConfigurationLcoo class
Top
Properties
 | Name | Description
Public property | AlertLogLevel | Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | ClearQueueUrl | String format of url to clear full queue
Public property | ClientInteractionLogLevel | Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | ConfigLogLevel | Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | DataFetchUrl | String format of url to fetch data from
Public property | DeadLetterLogLevel | Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | FeedName | Feed name. Usually FileGet or Fixtures.
Public property | FixtureTimezone | Timezone to use in parsing fixtures. Default Europe/Oslo
Public property | InitialFetchDelay | Initial delay between two consecutive data fetches (default: 7s)
Public property | InvalidMsgLogLevel | Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | IsInitialized | Is section initialized?
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | LoggingFeedName | Prefix used to indicate feed (Inherited from ConfigurationElementFeed)
Public property | Password | Password
Public property | ReceiveBufferSize | Receive buffer size for one line of message (overrides automatic defaults for servers) (Inherited from ConfigurationElementFeed)
Public property | RegularFetchDelay | Regular delay between two consecutive data fetches (default: 12s)
Public property | SchemaValidationStrictness | Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1 (Inherited from ConfigurationElementFeed)
Public property | StatsLogLevel | Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | TotalBufferSize | Total message buffer size (overrides automatic defaults for servers) (Inherited from ConfigurationElementFeed)
Public property | TrafficLogLevel | Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | Username | Username
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo Constructor

Initializes a new instance of the SdkConfigurationLcoo class

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLcoo()
See Also

Reference

SdkConfigurationLcoo Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo Properties

The SdkConfigurationLcoo type exposes the following members.

Properties
 | Name | Description
Public property | AlertLogLevel | Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | ClearQueueUrl | String format of url to clear full queue
Public property | ClientInteractionLogLevel | Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | ConfigLogLevel | Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | DataFetchUrl | String format of url to fetch data from
Public property | DeadLetterLogLevel | Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | FeedName | Feed name. Usually FileGet or Fixtures.
Public property | FixtureTimezone | Timezone to use in parsing fixtures. Default Europe/Oslo
Public property | InitialFetchDelay | Initial delay between two consecutive data fetches (default: 7s)
Public property | InvalidMsgLogLevel | Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | IsInitialized | Is section initialized?
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | LoggingFeedName | Prefix used to indicate feed (Inherited from ConfigurationElementFeed)
Public property | Password | Password
Public property | ReceiveBufferSize | Receive buffer size for one line of message (overrides automatic defaults for servers) (Inherited from ConfigurationElementFeed)
Public property | RegularFetchDelay | Regular delay between two consecutive data fetches (default: 12s)
Public property | SchemaValidationStrictness | Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1 (Inherited from ConfigurationElementFeed)
Public property | StatsLogLevel | Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | TotalBufferSize | Total message buffer size (overrides automatic defaults for servers) (Inherited from ConfigurationElementFeed)
Public property | TrafficLogLevel | Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | Username | Username
Top
See Also

Reference

SdkConfigurationLcoo Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo.ClearQueueUrl Property

SdkConfigurationLcooClearQueueUrl Property

String format of url to clear full queue

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ClearQueueUrl { get; }

Property Value

String
See Also

Reference

SdkConfigurationLcoo Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo.DataFetchUrl Property

SdkConfigurationLcooDataFetchUrl Property

String format of url to fetch data from

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string DataFetchUrl { get; }

Property Value

String
See Also

Reference

SdkConfigurationLcoo Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo.FeedName Property

SdkConfigurationLcooFeedName Property

Feed name. Usually FileGet or Fixtures.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string FeedName { get; }

Property Value

String
See Also

Reference

SdkConfigurationLcoo Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo.FixtureTimezone Property

SdkConfigurationLcooFixtureTimezone Property

Timezone to use in parsing fixtures. Default Europe/Oslo

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string FixtureTimezone { get; }

Property Value

String
See Also

Reference

SdkConfigurationLcoo Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo.InitialFetchDelay Property

SdkConfigurationLcooInitialFetchDelay Property

Initial delay between two consecutive data fetches (default: 7s)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan InitialFetchDelay { get; }

Property Value

TimeSpan
Remarks
You should not set this option unless you are sure what the implications are.
See Also

Reference

SdkConfigurationLcoo Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo.IsInitialized Property

SdkConfigurationLcooIsInitialized Property

Is section initialized?

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsInitialized { get; }

Property Value

Boolean
See Also

Reference

SdkConfigurationLcoo Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo.Password Property

SdkConfigurationLcooPassword Property

Password

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(SecureStringConverter))]
public SecureString Password { get; }

Property Value

SecureString
See Also

Reference

SdkConfigurationLcoo Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo.RegularFetchDelay Property

SdkConfigurationLcooRegularFetchDelay Property

Regular delay between two consecutive data fetches (default: 12s)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan RegularFetchDelay { get; }

Property Value

TimeSpan
Remarks
You should not set this option unless you are sure what the implications are.
See Also

Reference

SdkConfigurationLcoo Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo.Username Property

SdkConfigurationLcooUsername Property

Username

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Username { get; }

Property Value

String
See Also

Reference

SdkConfigurationLcoo Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLcoo Methods

The SdkConfigurationLcoo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLcoo Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed Class

SDK configuration element where common live feed provider settings are stored (connectivity, rate limiters, etc.).
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveScout

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public abstract class SdkConfigurationLiveFeed : ConfigurationElementFeed

The SdkConfigurationLiveFeed type exposes the following members.

Properties
Name | Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property | BookmakerId | Bookmaker (client) id.
Public property | ClientAliveMsgTimeout | Client alive message timeout.
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property | EventRequestLimiterInterval | MatchRequest limiter (interval).
Public property | EventRequestLimiterNumber | MatchRequest limiter (number).
Public property | Hostname | Host name (overrides automatic defaults for servers)
Public property | Insecure | Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
Public property | InvalidDataReconnectWait | Delay before we try reconnecting to server after we got invalid data.
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property | LoginLimiterInterval | Login limiter (interval).
Public property | LoginLimiterNumber | Login limiter (number).
Public property | MaxReconnectWait | Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
Public property | MaxRequestEventIds | Max number of match ids that a client can specify in any request.
Public property | MaxRequestTimeAllowance | Maximum amount of time for request response
Public property | MaxServerTimestampAge | Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)
Public property | MinReconnectWait | Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
Public property | Port | Port number (overrides automatic defaults for servers)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property | ReceiveTimeout | Amount of time to wait for (socket) receive operation to complete successfully.
Public property | RequestLimiterInterval | Request limiter (interval).
Public property | RequestLimiterNumber | Request limiter (number).
Public property | RestartOnParseError | If true, the feed will reconnect on any parse error
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property | SendTimeout | Amount of time to wait for (socket) send operation to complete successfully.
Public property | ServerAliveMsgTimeout | Server alive message timeout.
Public property | SSLThumbprint | Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property | Test | Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
Public property | TimeKeeperMaxSamples | TimeKeeper should keep that many samples.
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property | UseSSL | Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed Properties

The SdkConfigurationLiveFeed type exposes the following members.

Properties
Name | Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property | BookmakerId | Bookmaker (client) id.
Public property | ClientAliveMsgTimeout | Client alive message timeout.
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property | EventRequestLimiterInterval | MatchRequest limiter (interval).
Public property | EventRequestLimiterNumber | MatchRequest limiter (number).
Public property | Hostname | Host name (overrides automatic defaults for servers)
Public property | Insecure | Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
Public property | InvalidDataReconnectWait | Delay before we try reconnecting to server after we got invalid data.
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property | LoginLimiterInterval | Login limiter (interval).
Public property | LoginLimiterNumber | Login limiter (number).
Public property | MaxReconnectWait | Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
Public property | MaxRequestEventIds | Max number of match ids that a client can specify in any request.
Public property | MaxRequestTimeAllowance | Maximum amount of time for request response
Public property | MaxServerTimestampAge | Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)
Public property | MinReconnectWait | Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
Public property | Port | Port number (overrides automatic defaults for servers)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property | ReceiveTimeout | Amount of time to wait for (socket) receive operation to complete successfully.
Public property | RequestLimiterInterval | Request limiter (interval).
Public property | RequestLimiterNumber | Request limiter (number).
Public property | RestartOnParseError | If true, the feed will reconnect on any parse error
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property | SendTimeout | Amount of time to wait for (socket) send operation to complete successfully.
Public property | ServerAliveMsgTimeout | Server alive message timeout.
Public property | SSLThumbprint | Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property | Test | Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
Public property | TimeKeeperMaxSamples | TimeKeeper should keep that many samples.
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property | UseSSL | Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
Top
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.BookmakerId Property

SdkConfigurationLiveFeedBookmakerId Property

Bookmaker (client) id.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int? BookmakerId { get; }

Property Value

Nullable Int32
Remarks
This one will override the common settings.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.ClientAliveMsgTimeout Property

SdkConfigurationLiveFeedClientAliveMsgTimeout Property

Client alive message timeout.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan ClientAliveMsgTimeout { get; }

Property Value

TimeSpan
Remarks
TimeSpan.Zero means default timeout will be used. BEWARE: there is probably no need to change it unless the protocol updates.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.EventRequestLimiterInterval Property

SdkConfigurationLiveFeedEventRequestLimiterInterval Property

MatchRequest limiter (interval).

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan EventRequestLimiterInterval { get; }

Property Value

TimeSpan
Remarks
When TimeSpan.Zero the default settings as appropriate for the server are used.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.EventRequestLimiterNumber Property

SdkConfigurationLiveFeedEventRequestLimiterNumber Property

MatchRequest limiter (number).

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int EventRequestLimiterNumber { get; }

Property Value

Int32
Remarks
EventRequestLimiterInterval must not be set to TimeSpan.Zero.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.Hostname Property

SdkConfigurationLiveFeedHostname Property

Host name (overrides automatic defaults for servers)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Hostname { get; }

Property Value

String
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.Insecure Property

SdkConfigurationLiveFeedInsecure Property

Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Insecure { get; }

Property Value

Boolean
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.InvalidDataReconnectWait Property

SdkConfigurationLiveFeedInvalidDataReconnectWait Property

Delay before we try reconnecting to server after we got invalid data.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan InvalidDataReconnectWait { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.LoginLimiterInterval Property

SdkConfigurationLiveFeedLoginLimiterInterval Property

Login limiter (interval).

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan LoginLimiterInterval { get; }

Property Value

TimeSpan
Remarks
When TimeSpan.Zero the default settings as appropriate for the server are used.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.LoginLimiterNumber Property

SdkConfigurationLiveFeedLoginLimiterNumber Property

Login limiter (number).

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int LoginLimiterNumber { get; }

Property Value

Int32
Remarks
LoginLimiterInterval must not be set to TimeSpan.Zero.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.MaxReconnectWait Property

SdkConfigurationLiveFeedMaxReconnectWait Property

Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan MaxReconnectWait { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.MaxRequestEventIds Property

SdkConfigurationLiveFeedMaxRequestEventIds Property

Max number of match ids that a client can specify in any request.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int MaxRequestEventIds { get; }

Property Value

Int32
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.MaxRequestTimeAllowance Property

SdkConfigurationLiveFeedMaxRequestTimeAllowance Property

Maximum amount of time for request response

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan MaxRequestTimeAllowance { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.MaxServerTimestampAge Property

SdkConfigurationLiveFeedMaxServerTimestampAge Property

Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan MaxServerTimestampAge { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.MaxTimeSkew Property

SdkConfigurationLiveFeedMaxTimeSkew Property

Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan MaxTimeSkew { get; }

Property Value

TimeSpan
Remarks
BEWARE! Low values might prevent a successful connection to the server or cause undesired disconnecting / reconnecting. That in turn might lead to connection blocking on the server side.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.MinReconnectWait Property

SdkConfigurationLiveFeedMinReconnectWait Property

Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan MinReconnectWait { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.Port Property

SdkConfigurationLiveFeedPort Property

Port number (overrides automatic defaults for servers)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int Port { get; }

Property Value

Int32
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.ReceiveTimeout Property

SdkConfigurationLiveFeedReceiveTimeout Property

Amount of time to wait for (socket) receive operation to complete successfully.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan ReceiveTimeout { get; }

Property Value

TimeSpan
Remarks
TimeSpan.Zero means default timeout will be used, negative value means use maximum value.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.RequestLimiterInterval Property

SdkConfigurationLiveFeedRequestLimiterInterval Property

Request limiter (interval).

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan RequestLimiterInterval { get; }

Property Value

TimeSpan
Remarks
When TimeSpan.Zero the default settings as appropriate for the server are used.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.RequestLimiterNumber Property

SdkConfigurationLiveFeedRequestLimiterNumber Property

Request limiter (number).

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int RequestLimiterNumber { get; }

Property Value

Int32
Remarks
RequestLimiterInterval must not be set to TimeSpan.Zero.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.RestartOnParseError Property

SdkConfigurationLiveFeedRestartOnParseError Property

If true, the feed will reconnect on any parse error

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool RestartOnParseError { get; }

Property Value

Boolean
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.SendTimeout Property

SdkConfigurationLiveFeedSendTimeout Property

Amount of time to wait for (socket) send operation to complete successfully.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan SendTimeout { get; }

Property Value

TimeSpan
Remarks
TimeSpan.Zero means default timeout will be used, negative value means use maximum value.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.ServerAliveMsgTimeout Property

SdkConfigurationLiveFeedServerAliveMsgTimeout Property

Server alive message timeout.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan ServerAliveMsgTimeout { get; }

Property Value

TimeSpan
Remarks
TimeSpan.Zero means default timeout will be used. BEWARE: there is probably no need to change it unless the protocol updates.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.SSLThumbprint Property

SdkConfigurationLiveFeedSSLThumbprint Property

Optional SSL server certificate thumbprint (overrides automatic defaults for servers)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SSLThumbprint { get; }

Property Value

String
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.Test Property

SdkConfigurationLiveFeedTest Property

Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool Test { get; }

Property Value

Boolean
Remarks
Note that test accounts are disabled on weekends.
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.TimeKeeperMaxSamples Property

SdkConfigurationLiveFeedTimeKeeperMaxSamples Property

TimeKeeper should keep that many samples.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int TimeKeeperMaxSamples { get; }

Property Value

Int32
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.UseSSL Property

SdkConfigurationLiveFeedUseSSL Property

Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool UseSSL { get; }

Property Value

Boolean
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed Methods

The SdkConfigurationLiveFeed type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveFeed.IsReadOnly Method

SdkConfigurationLiveFeedIsReadOnly Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveFeed.IsReadOnly"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool IsReadOnly()

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveFeed.IsReadOnly"]

See Also

Reference

SdkConfigurationLiveFeed Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds Class

SDK configuration element with LiveOdds feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
More

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveOdds : SdkConfigurationLiveFeed

The SdkConfigurationLiveOdds type exposes the following members.

Properties
Name | Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property | BetTypeLanguages | List of languages for meta-data, separated by ';' (e.g. en;de)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property | BookmakerKey | Bookmaker key (overrides IProtocolData)
Public property | CleanupInterval | Clean-up interval.
Public property | CleanupMaxAge | Clean-up max-age.
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property | ErrorRecoveryDelay | Error recovery kicks-in this amount of time after "alive".
Public property | ErrorRecoveryMaxChunkSize | Max chunk size for an error recovery.
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property | IsInitialized | Is section initialized?
Public property | Languages | List of languages, separated by ';' (e.g. en;de)
Public property | LocalizeOdds | Localize odds.
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property | MaxMetaRequestInterval | Max interval when requesting meta-information about all matches.
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property | MetaLanguages | List of languages for meta-data, separated by ';' (e.g. en;de)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsBetPal
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsLivePlex
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsSoccerRoulette
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVbl
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVdr
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVfc
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVfl
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVhc
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVirtual
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVto


SdkConfigurationLiveOdds Properties

The SdkConfigurationLiveOdds type exposes the following members.

Properties
Name | Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property | BetTypeLanguages | List of languages for meta-data, separated by ';' (e.g. en;de)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property | BookmakerKey | Bookmaker key (overrides IProtocolData)
Public property | CleanupInterval | Clean-up interval.
Public property | CleanupMaxAge | Clean-up max-age.
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property | ErrorRecoveryDelay | Error recovery kicks-in this amount of time after "alive".
Public property | ErrorRecoveryMaxChunkSize | Max chunk size for an error recovery.
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property | IsInitialized | Is section initialized?
Public property | Languages | List of languages, separated by ';' (e.g. en;de)
Public property | LocalizeOdds | Localize odds.
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property | MaxMetaRequestInterval | Max interval when requesting meta-information about all matches.
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property | MetaLanguages | List of languages for meta-data, separated by ';' (e.g. en;de)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds.BetTypeLanguages Property

SdkConfigurationLiveOddsBetTypeLanguages Property

List of languages for meta-data, separated by ';' (e.g. en;de)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(StringArrayConverter))]
public string[] BetTypeLanguages { get; }

Property Value

String
Remarks
When null this falls back to Languages or null (which means use server defaults).
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds.BookmakerKey Property

SdkConfigurationLiveOddsBookmakerKey Property

Bookmaker key (overrides IProtocolData)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(SecureStringConverter))]
public SecureString BookmakerKey { get; }

Property Value

SecureString
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds.CleanupInterval Property

SdkConfigurationLiveOddsCleanupInterval Property

Clean-up interval.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan CleanupInterval { get; }

Property Value

TimeSpan
Remarks
You should not set this option unless you are sure what the implications are.
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds.CleanupMaxAge Property

SdkConfigurationLiveOddsCleanupMaxAge Property

Clean-up max-age.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan CleanupMaxAge { get; }

Property Value

TimeSpan
Remarks
You should not set this option unless you are sure what the implications are.
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds.ErrorRecoveryDelay Property

SdkConfigurationLiveOddsErrorRecoveryDelay Property

Error recovery kicks-in this amount of time after "alive".

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan ErrorRecoveryDelay { get; }

Property Value

TimeSpan
Remarks
You should not set this option unless you are sure what the implications are.
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds.ErrorRecoveryMaxChunkSize Property

SdkConfigurationLiveOddsErrorRecoveryMaxChunkSize Property

Max chunk size for an error recovery.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int ErrorRecoveryMaxChunkSize { get; }

Property Value

Int32
Remarks
You should not set this option unless you are sure what the implications are.
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds.IsInitialized Property

SdkConfigurationLiveOddsIsInitialized Property

Is section initialized?

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsInitialized { get; }

Property Value

Boolean
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds.Languages Property

SdkConfigurationLiveOddsLanguages Property

List of languages, separated by ';' (e.g. en;de)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(StringArrayConverter))]
public string[] Languages { get; }

Property Value

String
Remarks
This is the default languages specification which might be overridden in MetaLanguages or BetTypeLanguages. Null is valid and means use server defaults.
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds.LocalizeOdds Property

SdkConfigurationLiveOddsLocalizeOdds Property

Localize odds.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool LocalizeOdds { get; }

Property Value

Boolean
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds.MaxMetaRequestInterval Property

SdkConfigurationLiveOddsMaxMetaRequestInterval Property

Max interval when requesting meta-information about all matches.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan MaxMetaRequestInterval { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds.MetaLanguages Property

SdkConfigurationLiveOddsMetaLanguages Property

List of languages for meta-data, separated by ';' (e.g. en;de)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(StringArrayConverter))]
public string[] MetaLanguages { get; }

Property Value

String
Remarks
When null this falls back to Languages or null (which means use server defaults).
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOdds Methods

The SdkConfigurationLiveOdds type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveOdds Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsBetPal Class

SDK configuration element with BetPal feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsBetPal

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveOddsBetPal : SdkConfigurationLiveOdds

The SdkConfigurationLiveOddsBetPal type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsBetPal Properties

The SdkConfigurationLiveOddsBetPal type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
See Also

Reference

SdkConfigurationLiveOddsBetPal Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsBetPal Methods

The SdkConfigurationLiveOddsBetPal type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveOddsBetPal Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsBetTypes Class

SDK configuration element with LiveOdds BetType data feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsBetTypes

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveOddsBetTypes : ConfigurationElement

The SdkConfigurationLiveOddsBetTypes type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionTimeout | Time to wait for the connection with LiveOdds feed server to be established.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | IsEnabled | Is bet type translation enabled? true for yes; false for no.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | RefreshInterval | Bet type translation cache refresh interval.
Public property | ResponseTimeout | Time to wait for the bet types translation response message.
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsBetTypes Properties

The SdkConfigurationLiveOddsBetTypes type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionTimeout | Time to wait for the connection with LiveOdds feed server to be established.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | IsEnabled | Is bet type translation enabled? true for yes; false for no.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | RefreshInterval | Bet type translation cache refresh interval.
Public property | ResponseTimeout | Time to wait for the bet types translation response message.
Top
See Also

Reference

SdkConfigurationLiveOddsBetTypes Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsBetTypes.ConnectionTimeout Property

SdkConfigurationLiveOddsBetTypesConnectionTimeout Property

Time to wait for the connection with LiveOdds feed server to be established.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan ConnectionTimeout { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationLiveOddsBetTypes Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsBetTypes.IsEnabled Property

SdkConfigurationLiveOddsBetTypesIsEnabled Property

Is bet type translation enabled? true for yes; false for no.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsEnabled { get; }

Property Value

Boolean
Remarks
Use this to manually disable bet translations.
See Also

Reference

SdkConfigurationLiveOddsBetTypes Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsBetTypes.RefreshInterval Property

SdkConfigurationLiveOddsBetTypesRefreshInterval Property

Bet type translation cache refresh interval.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan RefreshInterval { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationLiveOddsBetTypes Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsBetTypes.ResponseTimeout Property

SdkConfigurationLiveOddsBetTypesResponseTimeout Property

Time to wait for the bet types translation response message.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan ResponseTimeout { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationLiveOddsBetTypes Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsBetTypes Methods

The SdkConfigurationLiveOddsBetTypes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveOddsBetTypes Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsBetTypes.IsReadOnly Method

SdkConfigurationLiveOddsBetTypesIsReadOnly Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOddsBetTypes.IsReadOnly"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool IsReadOnly()

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationLiveOddsBetTypes.IsReadOnly"]

See Also

Reference

SdkConfigurationLiveOddsBetTypes Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsLivePlex Class

SDK configuration element with LivePlex feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsLivePlex

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveOddsLivePlex : SdkConfigurationLiveOdds

The SdkConfigurationLiveOddsLivePlex type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsLivePlex Properties

The SdkConfigurationLiveOddsLivePlex type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
See Also

Reference

SdkConfigurationLiveOddsLivePlex Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsLivePlex Methods

The SdkConfigurationLiveOddsLivePlex type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveOddsLivePlex Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsSoccerRoulette Class

SDK configuration element with Soccer Roulette feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsSoccerRoulette

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveOddsSoccerRoulette : SdkConfigurationLiveOdds

The SdkConfigurationLiveOddsSoccerRoulette type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsSoccerRoulette Properties

The SdkConfigurationLiveOddsSoccerRoulette type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
See Also

Reference

SdkConfigurationLiveOddsSoccerRoulette Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsSoccerRoulette Methods

The SdkConfigurationLiveOddsSoccerRoulette type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveOddsSoccerRoulette Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVbl Class

SDK configuration element with LiveOdds VFL feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVbl

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveOddsVbl : SdkConfigurationLiveOdds

The SdkConfigurationLiveOddsVbl type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVbl Properties

The SdkConfigurationLiveOddsVbl type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
See Also

Reference

SdkConfigurationLiveOddsVbl Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVbl Methods

The SdkConfigurationLiveOddsVbl type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveOddsVbl Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVdr Class

SDK configuration element with LiveOdds VHC feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVdr

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveOddsVdr : SdkConfigurationLiveOdds

The SdkConfigurationLiveOddsVdr type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVdr Properties

The SdkConfigurationLiveOddsVdr type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
See Also

Reference

SdkConfigurationLiveOddsVdr Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVdr Methods

The SdkConfigurationLiveOddsVdr type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveOddsVdr Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVfc Class

SDK configuration element with LiveOdds VFC (virtual football cup) feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVfc

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveOddsVfc : SdkConfigurationLiveOdds

The SdkConfigurationLiveOddsVfc type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVfc Properties

The SdkConfigurationLiveOddsVfc type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
See Also

Reference

SdkConfigurationLiveOddsVfc Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVfc Methods

The SdkConfigurationLiveOddsVfc type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveOddsVfc Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVfl Class

SDK configuration element with LiveOdds VFL feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVfl

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveOddsVfl : SdkConfigurationLiveOdds

The SdkConfigurationLiveOddsVfl type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVfl Properties

The SdkConfigurationLiveOddsVfl type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
See Also

Reference

SdkConfigurationLiveOddsVfl Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVfl Methods

The SdkConfigurationLiveOddsVfl type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveOddsVfl Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVhc Class

SDK configuration element with LiveOdds VHC feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVhc

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveOddsVhc : SdkConfigurationLiveOdds

The SdkConfigurationLiveOddsVhc type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVhc Properties

The SdkConfigurationLiveOddsVhc type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
See Also

Reference

SdkConfigurationLiveOddsVhc Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVhc Methods

The SdkConfigurationLiveOddsVhc type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveOddsVhc Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVirtual Class

SDK configuration element with virtual gaming feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVirtual

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveOddsVirtual : SdkConfigurationLiveOdds

The SdkConfigurationLiveOddsVirtual type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Warning: not production ready yet
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVirtual Properties

The SdkConfigurationLiveOddsVirtual type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
See Also

Reference

SdkConfigurationLiveOddsVirtual Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVirtual Methods

The SdkConfigurationLiveOddsVirtual type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveOddsVirtual Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVto Class

SDK configuration element with LiveOdds VFL feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOdds
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveOddsVto

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveOddsVto : SdkConfigurationLiveOdds

The SdkConfigurationLiveOddsVto type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVto Properties

The SdkConfigurationLiveOddsVto type exposes the following members.

Properties
Name Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BetTypeLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property BookmakerKey Bookmaker key (overrides IProtocolData)
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupInterval Clean-up interval.
(Inherited from SdkConfigurationLiveOdds)
Public property CleanupMaxAge Clean-up max-age.
(Inherited from SdkConfigurationLiveOdds)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property ErrorRecoveryDelay Error recovery kicks-in this amount of time after "alive".
(Inherited from SdkConfigurationLiveOdds)
Public property ErrorRecoveryMaxChunkSize Max chunk size for an error recovery.
(Inherited from SdkConfigurationLiveOdds)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property IsInitialized Is section initialized?
(Inherited from SdkConfigurationLiveOdds)
Public property Languages List of languages, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property LocalizeOdds Localize odds.
(Inherited from SdkConfigurationLiveOdds)
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property MaxMetaRequestInterval Max interval when requesting meta-information about all matches.
(Inherited from SdkConfigurationLiveOdds)
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MetaLanguages List of languages for meta-data, separated by ';' (e.g. en;de)
(Inherited from SdkConfigurationLiveOdds)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
See Also

Reference

SdkConfigurationLiveOddsVto Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveOddsVto Methods

The SdkConfigurationLiveOddsVto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveOddsVto Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveScout Class

SDK configuration element with LiveScout feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationLiveScout

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationLiveScout : SdkConfigurationLiveFeed

The SdkConfigurationLiveScout type exposes the following members.

Properties
Name | Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property | IsInitialized | Is section initialized?
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property | MatchExpireCheckInterval | Specifies how frequently we should check for expiration of matches.
Public property | MatchExpireMaxAge | Specifies how long a match can not receive messages and still be actual.
Public property | MaxMatchListInterval | Timespan limit for when the scout match list is requested.
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property | ScoutPassword | Scout key (overrides IProtocolData)
Public property | ScoutUsername | Scout username (overrides IProtocolData)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property | ServerTimeSyncInterval | Specifies how frequently we should be requesting for the current scout server time.
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveScout Properties

The SdkConfigurationLiveScout type exposes the following members.

Properties
Name | Description
Public property AlertLogLevel Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property BookmakerId Bookmaker (client) id.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientAliveMsgTimeout Client alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property ClientInteractionLogLevel Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ConfigLogLevel Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property CurrentConfiguration Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement)
Public property DeadLetterLogLevel Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property ElementInformation Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement)
Public property EventRequestLimiterInterval MatchRequest limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property EventRequestLimiterNumber MatchRequest limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property Hostname Host name (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Insecure Whether insecure version of the connection provider should be used that doesn't check the SSL server certificate thumbprint. Implicitly set by SafeMode.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidDataReconnectWait Delay before we try reconnecting to server after we got invalid data.
(Inherited from SdkConfigurationLiveFeed)
Public property InvalidMsgLogLevel Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property | IsInitialized | Is section initialized?
Public property LockAllAttributesExcept Gets the collection of locked attributes.
(Inherited from ConfigurationElement)
Public property LockAllElementsExcept Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockAttributes Gets the collection of locked attributes
(Inherited from ConfigurationElement)
Public property LockElements Gets the collection of locked elements.
(Inherited from ConfigurationElement)
Public property LockItem Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement)
Public property LoggingFeedName Prefix used to indicate feed
(Inherited from ConfigurationElementFeed)
Public property LoginLimiterInterval Login limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property LoginLimiterNumber Login limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property | MatchExpireCheckInterval | Specifies how frequently we should check for expiration of matches.
Public property | MatchExpireMaxAge | Specifies how long a match can not receive messages and still be actual.
Public property | MaxMatchListInterval | Timespan limit for when the scout match list is requested.
Public property MaxReconnectWait Delay before we try reconnecting to server after we got disconnected (max, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestEventIds Max number of match ids that a client can specify in any request.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxRequestTimeAllowance Maximum amount of time for request response
(Inherited from SdkConfigurationLiveFeed)
Public property MaxServerTimestampAge Server timestamp is only usable to us if it is not outdated so that we can interpolate between two successive server timestamps.
(Inherited from SdkConfigurationLiveFeed)
Public property MaxTimeSkew Maximum time difference between local time and server time. When detected time skew is over this limit the connection to the server will be immediately dropped and a reconnect attempted. Usual time skew values should be:
  1. 10 minutes when no time synchronization is performed
  2. 5 seconds (if NTP protocol is used for time synchronization)
  3. TimeSpan.Zero means the setting is off (which is the default in SafeMode)

(Inherited from SdkConfigurationLiveFeed)
Public property MinReconnectWait Delay before we try reconnecting to server after we got disconnected (min, overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property Port Port number (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property ReceiveBufferSize Receive buffer size for one line of message (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property ReceiveTimeout Amount of time to wait for (socket) receive operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterInterval Request limiter (interval).
(Inherited from SdkConfigurationLiveFeed)
Public property RequestLimiterNumber Request limiter (number).
(Inherited from SdkConfigurationLiveFeed)
Public property RestartOnParseError If true, the feed will reconnect on any parse error
(Inherited from SdkConfigurationLiveFeed)
Public property SchemaValidationStrictness Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1
(Inherited from ConfigurationElementFeed)
Public property | ScoutPassword | Scout key (overrides IProtocolData)
Public property | ScoutUsername | Scout username (overrides IProtocolData)
Public property SendTimeout Amount of time to wait for (socket) send operation to complete successfully.
(Inherited from SdkConfigurationLiveFeed)
Public property ServerAliveMsgTimeout Server alive message timeout.
(Inherited from SdkConfigurationLiveFeed)
Public property | ServerTimeSyncInterval | Specifies how frequently we should be requesting for the current scout server time.
Public property SSLThumbprint Optional SSL server certificate thumbprint (overrides automatic defaults for servers)
(Inherited from SdkConfigurationLiveFeed)
Public property StatsLogLevel Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property Test Whether we should connect to development/test server instead of production one. Cannot be used for LiveOddsVfl and BetPal.
(Inherited from SdkConfigurationLiveFeed)
Public property TimeKeeperMaxSamples TimeKeeper should keep that many samples.
(Inherited from SdkConfigurationLiveFeed)
Public property TotalBufferSize Total message buffer size (overrides automatic defaults for servers)
(Inherited from ConfigurationElementFeed)
Public property TrafficLogLevel Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal
(Inherited from ConfigurationElementFeed)
Public property UseSSL Whether SSL sockets should be used for communication (overrides automatic defaults for servers). Cannot be used for LiveScout.
(Inherited from SdkConfigurationLiveFeed)
Top
See Also

Reference

SdkConfigurationLiveScout Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveScout.IsInitialized Property

SdkConfigurationLiveScoutIsInitialized Property

Is section initialized?

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsInitialized { get; }

Property Value

Boolean
See Also

Reference

SdkConfigurationLiveScout Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveScout.MatchExpireCheckInterval Property

SdkConfigurationLiveScoutMatchExpireCheckInterval Property

Specifies how frequently we should check for expiration of matches.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan MatchExpireCheckInterval { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationLiveScout Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveScout.MatchExpireMaxAge Property

SdkConfigurationLiveScoutMatchExpireMaxAge Property

Specifies how long a match can not receive messages and still be actual.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan MatchExpireMaxAge { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationLiveScout Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveScout.MaxMatchListInterval Property

SdkConfigurationLiveScoutMaxMatchListInterval Property

Timespan limit for when the scout match list is requested.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan MaxMatchListInterval { get; }

Property Value

TimeSpan
Remarks
This is the maximum "width" of the interval [hours_back, hours_forward]. Not settable in the configuration directly.
See Also

Reference

SdkConfigurationLiveScout Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveScout.ScoutPassword Property

SdkConfigurationLiveScoutScoutPassword Property

Scout key (overrides IProtocolData)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(SecureStringConverter))]
public SecureString ScoutPassword { get; }

Property Value

SecureString
See Also

Reference

SdkConfigurationLiveScout Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveScout.ScoutUsername Property

SdkConfigurationLiveScoutScoutUsername Property

Scout username (overrides IProtocolData)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string ScoutUsername { get; }

Property Value

String
See Also

Reference

SdkConfigurationLiveScout Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveScout.ServerTimeSyncInterval Property

SdkConfigurationLiveScoutServerTimeSyncInterval Property

Specifies how frequently we should be requesting for the current scout server time.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan ServerTimeSyncInterval { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationLiveScout Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationLiveScout Methods

The SdkConfigurationLiveScout type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Inherited from SdkConfigurationLiveFeed)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationLiveScout Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationMessageDispatcher Class

SDK configuration element where Message Dispatcher settings are specified.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationMessageDispatcher

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationMessageDispatcher : ConfigurationElement

The SdkConfigurationMessageDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | DispatcherThreadPingTimeout | If there is no alive ping received from any of the dispatcher threads in this timeout period, the dispatcher will update its health status to unresponsive. This can be caused by a client handler blocking the dispatcher thread execution.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | HealthCheckInterval | Interval at which dispatcher health status is checked (i.e. whether all dispatcher threads are live and kicking)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | MaxDispatchEventsPerSecond | Limits the rate at which events can be dispatched to client handlers.
Public property | NumDispatchers | Total number of message dispatcher threads
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationMessageDispatcher Properties

The SdkConfigurationMessageDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | DispatcherThreadPingTimeout | If there is no alive ping received from any of the dispatcher threads in this timeout period, the dispatcher will update its health status to unresponsive. This can be caused by a client handler blocking the dispatcher thread execution.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | HealthCheckInterval | Interval at which dispatcher health status is checked (i.e. whether all dispatcher threads are live and kicking)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | MaxDispatchEventsPerSecond | Limits the rate at which events can be dispatched to client handlers.
Public property | NumDispatchers | Total number of message dispatcher threads
Top
See Also

Reference

SdkConfigurationMessageDispatcher Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationMessageDispatcher.DispatcherThreadPingTimeout Property

SdkConfigurationMessageDispatcherDispatcherThreadPingTimeout Property

If there is no alive ping received from any of the dispatcher threads in this timeout period, the dispatcher will update its health status to unresponsive. This can be caused by a client handler blocking the dispatcher thread execution.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan DispatcherThreadPingTimeout { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationMessageDispatcher Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationMessageDispatcher.HealthCheckInterval Property

SdkConfigurationMessageDispatcherHealthCheckInterval Property

Interval at which dispatcher health status is checked (i.e. whether all dispatcher threads are live and kicking)

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan HealthCheckInterval { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationMessageDispatcher Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationMessageDispatcher.MaxDispatchEventsPerSecond Property

SdkConfigurationMessageDispatcherMaxDispatchEventsPerSecond Property

Limits the rate at which events can be dispatched to client handlers.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int MaxDispatchEventsPerSecond { get; }

Property Value

Int32
See Also

Reference

SdkConfigurationMessageDispatcher Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationMessageDispatcher.NumDispatchers Property

SdkConfigurationMessageDispatcherNumDispatchers Property

Total number of message dispatcher threads

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int NumDispatchers { get; }

Property Value

Int32
See Also

Reference

SdkConfigurationMessageDispatcher Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationMessageDispatcher Methods

The SdkConfigurationMessageDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationMessageDispatcher Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationMessageDispatcher.IsReadOnly Method

SdkConfigurationMessageDispatcherIsReadOnly Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationMessageDispatcher.IsReadOnly"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool IsReadOnly()

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationMessageDispatcher.IsReadOnly"]

See Also

Reference

SdkConfigurationMessageDispatcher Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationOddsCreator Class

SDK configuration element with OddsCreator feed provider settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationConfigurationElementFeed
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationOddsCreator

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationOddsCreator : ConfigurationElementFeed

The SdkConfigurationOddsCreator type exposes the following members.

Constructors
 | Name | Description
Public method | SdkConfigurationOddsCreator | Initializes a new instance of the SdkConfigurationOddsCreator class
Top
Properties
 | Name | Description
Public property | AlertLogLevel | Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | ClientInteractionLogLevel | Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | ConfigLogLevel | Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | DeadLetterLogLevel | Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | InvalidMsgLogLevel | Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | IsInitialized | Is section initialized?
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | LoggingFeedName | Prefix used to indicate feed (Inherited from ConfigurationElementFeed)
Public property | Password | Password
Public property | ReceiveBufferSize | Receive buffer size for one line of message (overrides automatic defaults for servers) (Inherited from ConfigurationElementFeed)
Public property | SchemaValidationStrictness | Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1 (Inherited from ConfigurationElementFeed)
Public property | StatsLogLevel | Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | TotalBufferSize | Total message buffer size (overrides automatic defaults for servers) (Inherited from ConfigurationElementFeed)
Public property | TrafficLogLevel | Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | Username | Username
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationOddsCreator Constructor

Initializes a new instance of the SdkConfigurationOddsCreator class

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationOddsCreator()
See Also

Reference

SdkConfigurationOddsCreator Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationOddsCreator Properties

The SdkConfigurationOddsCreator type exposes the following members.

Properties
 | Name | Description
Public property | AlertLogLevel | Specifies log level threshold used while logging alert messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | ClientInteractionLogLevel | Specifies log level threshold used while logging client interaction messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | ConfigLogLevel | Specifies log level threshold used while logging configuration settings used by client (server and local). Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | DeadLetterLogLevel | Specifies log level threshold used while logging dead letter messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | InvalidMsgLogLevel | Specifies log level threshold used while logging invalid/corrupt messages. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | IsInitialized | Is section initialized?
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | LoggingFeedName | Prefix used to indicate feed (Inherited from ConfigurationElementFeed)
Public property | Password | Password
Public property | ReceiveBufferSize | Receive buffer size for one line of message (overrides automatic defaults for servers) (Inherited from ConfigurationElementFeed)
Public property | SchemaValidationStrictness | Schema validation strictness. 0 = OFF, 1=ON, 2=STRICT, 3=VERY_STRICT Default = 1 (Inherited from ConfigurationElementFeed)
Public property | StatsLogLevel | Specifies log level threshold used while logging SDK statistics. Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | TotalBufferSize | Total message buffer size (overrides automatic defaults for servers) (Inherited from ConfigurationElementFeed)
Public property | TrafficLogLevel | Specifies log level threshold used while logging incoming and outgoing traffic (live feed messages). Possible values are: Debug, Info, Warn, Error, Fatal (Inherited from ConfigurationElementFeed)
Public property | Username | Username
Top
See Also

Reference

SdkConfigurationOddsCreator Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationOddsCreator.IsInitialized Property

SdkConfigurationOddsCreatorIsInitialized Property

Is section initialized?

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public bool IsInitialized { get; }

Property Value

Boolean
See Also

Reference

SdkConfigurationOddsCreator Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationOddsCreator.Password Property

SdkConfigurationOddsCreatorPassword Property

Password

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(SecureStringConverter))]
public SecureString Password { get; }

Property Value

SecureString
See Also

Reference

SdkConfigurationOddsCreator Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationOddsCreator.Username Property

SdkConfigurationOddsCreatorUsername Property

Username

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string Username { get; }

Property Value

String
See Also

Reference

SdkConfigurationOddsCreator Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationOddsCreator Methods

The SdkConfigurationOddsCreator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationOddsCreator Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationPersistentState Class

SDK configuration element with Persistent State provider settings (SqLite database settings).
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationPersistentState

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationPersistentState : ConfigurationElement

The SdkConfigurationPersistentState type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | ExpireInterval | Time interval to check for expired key value pairs stored in PersistentStateBuffer
Public property | FlushInterval | Time interval to flush key value pairs into provided persistant store
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | MaxAge | Max age for stored key value pairs in PersistentStateBuffer
Public property | MaxFlushBatchSize | Maximum number of key value pairs in state buffer before flushing
Public property | SqliteDatabaseDirectory | Directory for the Sqlite database file
Public property | SqliteDatabaseFilename | Filename for the Sqlite database file
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationPersistentState Properties

The SdkConfigurationPersistentState type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | ExpireInterval | Time interval to check for expired key value pairs stored in PersistentStateBuffer
Public property | FlushInterval | Time interval to flush key value pairs into provided persistant store
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | MaxAge | Max age for stored key value pairs in PersistentStateBuffer
Public property | MaxFlushBatchSize | Maximum number of key value pairs in state buffer before flushing
Public property | SqliteDatabaseDirectory | Directory for the Sqlite database file
Public property | SqliteDatabaseFilename | Filename for the Sqlite database file
Top
See Also

Reference

SdkConfigurationPersistentState Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationPersistentState.ExpireInterval Property

SdkConfigurationPersistentStateExpireInterval Property

Time interval to check for expired key value pairs stored in PersistentStateBuffer

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan ExpireInterval { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationPersistentState Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationPersistentState.FlushInterval Property

SdkConfigurationPersistentStateFlushInterval Property

Time interval to flush key value pairs into provided persistant store

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan FlushInterval { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationPersistentState Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationPersistentState.MaxAge Property

SdkConfigurationPersistentStateMaxAge Property

Max age for stored key value pairs in PersistentStateBuffer

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
[TypeConverterAttribute(typeof(TimeSpanConverter))]
public TimeSpan MaxAge { get; }

Property Value

TimeSpan
See Also

Reference

SdkConfigurationPersistentState Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationPersistentState.MaxFlushBatchSize Property

SdkConfigurationPersistentStateMaxFlushBatchSize Property

Maximum number of key value pairs in state buffer before flushing

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public int MaxFlushBatchSize { get; }

Property Value

Int32
See Also

Reference

SdkConfigurationPersistentState Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationPersistentState.SqliteDatabaseDirectory Property

SdkConfigurationPersistentStateSqliteDatabaseDirectory Property

Directory for the Sqlite database file

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SqliteDatabaseDirectory { get; set; }

Property Value

String
Remarks
By default AppDomain.CurrentDomain.BaseDirectory is used.
See Also

Reference

SdkConfigurationPersistentState Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationPersistentState.SqliteDatabaseFilename Property

SdkConfigurationPersistentStateSqliteDatabaseFilename Property

Filename for the Sqlite database file

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public string SqliteDatabaseFilename { get; set; }

Property Value

String
Remarks
By default "sdkstate.db" is used as the filename
See Also

Reference

SdkConfigurationPersistentState Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationPersistentState Methods

The SdkConfigurationPersistentState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationPersistentState Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationPersistentState.IsReadOnly Method

SdkConfigurationPersistentStateIsReadOnly Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationPersistentState.IsReadOnly"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool IsReadOnly()

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationPersistentState.IsReadOnly"]

See Also

Reference

SdkConfigurationPersistentState Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection Class

SDK configuration section.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
Sportradar.SDK.Services.SdkConfigurationSdkConfigurationSection

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkConfigurationSection : ConfigurationSection,
    ISdkConfiguration

The SdkConfigurationSection type exposes the following members.

Properties
 | Name | Description
Public property | BetPal | SDK configuration element with LiveOdds BetPal feed provider settings.
Public property | Common | SDK configuration element where common settings used throughout the SDK library are specified.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | Dynamic | SDK configuration element where settings for the server-side configuration service are specified (mostly access parameters).
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | Lcoo | SDK configuration element with Live Cycle of Odds provider settings.
Public property | LiveOdds | SDK configuration element with LiveOdds feed provider settings.
Public property | LiveOddsBetTypes | SDK configuration element with LiveOdds BetType data feed provider settings.
Public property | LiveOddsVbl | SDK configuration element with LiveOdds VBL feed provider settings.
Public property | LiveOddsVdr | SDK configuration element with LiveOdds BetPal feed provider settings.
Public property | LiveOddsVfc | SDK configuration element with LiveOdds VFC feed provider settings.
Public property | LiveOddsVfl | SDK configuration element with LiveOdds VFL feed provider settings.
Public property | LiveOddsVhc | SDK configuration element with LiveOdds BetPal feed provider settings.
Public property | LiveOddsVto | SDK configuration element with LiveOdds VTO feed provider settings.
Public property | LivePlex | SDK configuration element with LiveOdds LivePlex feed provider settings.
Public property | LiveScout | SDK configuration element with LiveScout feed provider settings.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | MessageDispatcher | SDK configuration element where Message Dispatcher settings are specified.
Public property | OddsCreator | SDK configuration element with OddsCreator provider settings.
Public property | PersistentState | SDK configuration element with Persistent State provider settings (SqLite database settings).
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection)
Public property | SoccerRoulette | SDK configuration element with LiveOdds SoccerRoulette feed provider settings.
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | OnConfigurationReloaded | Event fired every time that configuration is reloaded / refreshed and might have changed. This is a good time for components to update their cached configuration settings, if any.
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection Properties

The SdkConfigurationSection type exposes the following members.

Properties
 | Name | Description
Public property | BetPal | SDK configuration element with LiveOdds BetPal feed provider settings.
Public property | Common | SDK configuration element where common settings used throughout the SDK library are specified.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement)
Public property | Dynamic | SDK configuration element where settings for the server-side configuration service are specified (mostly access parameters).
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement)
Public property | Lcoo | SDK configuration element with Live Cycle of Odds provider settings.
Public property | LiveOdds | SDK configuration element with LiveOdds feed provider settings.
Public property | LiveOddsBetTypes | SDK configuration element with LiveOdds BetType data feed provider settings.
Public property | LiveOddsVbl | SDK configuration element with LiveOdds VBL feed provider settings.
Public property | LiveOddsVdr | SDK configuration element with LiveOdds BetPal feed provider settings.
Public property | LiveOddsVfc | SDK configuration element with LiveOdds VFC feed provider settings.
Public property | LiveOddsVfl | SDK configuration element with LiveOdds VFL feed provider settings.
Public property | LiveOddsVhc | SDK configuration element with LiveOdds BetPal feed provider settings.
Public property | LiveOddsVto | SDK configuration element with LiveOdds VTO feed provider settings.
Public property | LivePlex | SDK configuration element with LiveOdds LivePlex feed provider settings.
Public property | LiveScout | SDK configuration element with LiveScout feed provider settings.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement)
Public property | MessageDispatcher | SDK configuration element where Message Dispatcher settings are specified.
Public property | OddsCreator | SDK configuration element with OddsCreator provider settings.
Public property | PersistentState | SDK configuration element with Persistent State provider settings (SqLite database settings).
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection)
Public property | SoccerRoulette | SDK configuration element with LiveOdds SoccerRoulette feed provider settings.
Top
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.BetPal Property

SdkConfigurationSectionBetPal Property

SDK configuration element with LiveOdds BetPal feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsBetPal BetPal { get; }

Property Value

SdkConfigurationLiveOddsBetPal

Implements

ISdkConfigurationBetPal
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.Common Property

SdkConfigurationSectionCommon Property

SDK configuration element where common settings used throughout the SDK library are specified.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationCommon Common { get; }

Property Value

SdkConfigurationCommon

Implements

ISdkConfigurationCommon
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.Dynamic Property

SdkConfigurationSectionDynamic Property

SDK configuration element where settings for the server-side configuration service are specified (mostly access parameters).

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationDynamic Dynamic { get; }

Property Value

SdkConfigurationDynamic

Implements

ISdkConfigurationDynamic
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.Lcoo Property

SdkConfigurationSectionLcoo Property

SDK configuration element with Live Cycle of Odds provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLcoo Lcoo { get; }

Property Value

SdkConfigurationLcoo

Implements

ISdkConfigurationLcoo
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.LiveOdds Property

SdkConfigurationSectionLiveOdds Property

SDK configuration element with LiveOdds feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOdds LiveOdds { get; }

Property Value

SdkConfigurationLiveOdds

Implements

ISdkConfigurationLiveOdds
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.LiveOddsBetTypes Property

SdkConfigurationSectionLiveOddsBetTypes Property

SDK configuration element with LiveOdds BetType data feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsBetTypes LiveOddsBetTypes { get; }

Property Value

SdkConfigurationLiveOddsBetTypes

Implements

ISdkConfigurationLiveOddsBetTypes
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.LiveOddsVbl Property

SdkConfigurationSectionLiveOddsVbl Property

SDK configuration element with LiveOdds VBL feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsVbl LiveOddsVbl { get; }

Property Value

SdkConfigurationLiveOddsVbl

Implements

ISdkConfigurationLiveOddsVbl
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.LiveOddsVdr Property

SdkConfigurationSectionLiveOddsVdr Property

SDK configuration element with LiveOdds BetPal feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsVdr LiveOddsVdr { get; }

Property Value

SdkConfigurationLiveOddsVdr

Implements

ISdkConfigurationLiveOddsVdr
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.LiveOddsVfc Property

SdkConfigurationSectionLiveOddsVfc Property

SDK configuration element with LiveOdds VFC feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsVfc LiveOddsVfc { get; }

Property Value

SdkConfigurationLiveOddsVfc

Implements

ISdkConfigurationLiveOddsVfc
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.LiveOddsVfl Property

SdkConfigurationSectionLiveOddsVfl Property

SDK configuration element with LiveOdds VFL feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsVfl LiveOddsVfl { get; }

Property Value

SdkConfigurationLiveOddsVfl

Implements

ISdkConfigurationLiveOddsVfl
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.LiveOddsVhc Property

SdkConfigurationSectionLiveOddsVhc Property

SDK configuration element with LiveOdds BetPal feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsVhc LiveOddsVhc { get; }

Property Value

SdkConfigurationLiveOddsVhc

Implements

ISdkConfigurationLiveOddsVhc
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.LiveOddsVto Property

SdkConfigurationSectionLiveOddsVto Property

SDK configuration element with LiveOdds VTO feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsVto LiveOddsVto { get; }

Property Value

SdkConfigurationLiveOddsVto

Implements

ISdkConfigurationLiveOddsVto
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.LivePlex Property

SdkConfigurationSectionLivePlex Property

SDK configuration element with LiveOdds LivePlex feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsLivePlex LivePlex { get; }

Property Value

SdkConfigurationLiveOddsLivePlex

Implements

ISdkConfigurationLivePlex
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.LiveScout Property

SdkConfigurationSectionLiveScout Property

SDK configuration element with LiveScout feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveScout LiveScout { get; }

Property Value

SdkConfigurationLiveScout

Implements

ISdkConfigurationLiveScout
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.MessageDispatcher Property

SdkConfigurationSectionMessageDispatcher Property

SDK configuration element where Message Dispatcher settings are specified.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationMessageDispatcher MessageDispatcher { get; }

Property Value

SdkConfigurationMessageDispatcher

Implements

ISdkConfigurationMessageDispatcher
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.OddsCreator Property

SdkConfigurationSectionOddsCreator Property

SDK configuration element with OddsCreator provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationOddsCreator OddsCreator { get; }

Property Value

SdkConfigurationOddsCreator

Implements

ISdkConfigurationOddsCreator
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.PersistentState Property

SdkConfigurationSectionPersistentState Property

SDK configuration element with Persistent State provider settings (SqLite database settings).

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationPersistentState PersistentState { get; }

Property Value

SdkConfigurationPersistentState

Implements

ISdkConfigurationPersistentState
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.SoccerRoulette Property

SdkConfigurationSectionSoccerRoulette Property

SDK configuration element with LiveOdds SoccerRoulette feed provider settings.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsSoccerRoulette SoccerRoulette { get; }

Property Value

SdkConfigurationLiveOddsSoccerRoulette

Implements

ISdkConfigurationSoccerRoulette
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection Methods

The SdkConfigurationSection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsReadOnly | (Overrides ConfigurationElementIsReadOnly)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.IsReadOnly Method

SdkConfigurationSectionIsReadOnly Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationSection.IsReadOnly"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override bool IsReadOnly()

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationSection.IsReadOnly"]

See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection Events

The SdkConfigurationSection type exposes the following members.

Events
 | Name | Description
Public event | OnConfigurationReloaded | Event fired every time that configuration is reloaded / refreshed and might have changed. This is a good time for components to update their cached configuration settings, if any.
Top
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkConfigurationSection.OnConfigurationReloaded Event

SdkConfigurationSectionOnConfigurationReloaded Event

Event fired every time that configuration is reloaded / refreshed and might have changed. This is a good time for components to update their cached configuration settings, if any.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event SdkConfigurationDelegatesConfigReloadedDelegate OnConfigurationReloaded

Value

SdkConfigurationDelegatesConfigReloadedDelegate

Implements

ISdkConfigurationOnConfigurationReloaded
See Also

Reference

SdkConfigurationSection Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkLiveConfiguration Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.SdkConfiguration.SdkLiveConfiguration"]

Inheritance Hierarchy
SystemObject
Sportradar.SDK.Services.SdkConfigurationSdkLiveConfiguration

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SdkLiveConfiguration : ISdkConfiguration

The SdkLiveConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | SdkLiveConfiguration | Initializes a new instance of the SdkLiveConfiguration class
Top
Properties
 | Name | Description
Public property | Lcoo |
Public property | LiveOddsVbl |
Public property | LiveOddsVdr |
Public property | LiveOddsVhc |
Public property | LivePlex |
Public property | SoccerRoulette |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | OnConfigurationReloaded | Event fired every time that configuration is reloaded / refreshed and might have changed. This is a good time for components to update their cached configuration settings, if any.
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration Namespace


SdkLiveConfiguration Constructor

Initializes a new instance of the SdkLiveConfiguration class

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkLiveConfiguration(
    Func<SdkConfigurationSection> get_sdk_config
)

Parameters

get_sdk_config Func SdkConfigurationSection

[Missing <param name="get_sdk_config"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.SdkLiveConfiguration.#ctor(System.Func{Sportradar.SDK.Services.SdkConfiguration.SdkConfigurationSection})"]

See Also

Reference

SdkLiveConfiguration Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkLiveConfiguration Properties

The SdkLiveConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Lcoo |
Public property | LiveOddsVbl |
Public property | LiveOddsVdr |
Public property | LiveOddsVhc |
Public property | LivePlex |
Public property | SoccerRoulette |
Top
See Also

Reference

SdkLiveConfiguration Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkLiveConfiguration.Lcoo Property

SdkLiveConfigurationLcoo Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.SdkLiveConfiguration.Lcoo"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLcoo Lcoo { get; }

Property Value

SdkConfigurationLcoo

Implements

ISdkConfigurationLcoo
See Also

Reference

SdkLiveConfiguration Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkLiveConfiguration.LiveOddsVbl Property

SdkLiveConfigurationLiveOddsVbl Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.SdkLiveConfiguration.LiveOddsVbl"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsVbl LiveOddsVbl { get; }

Property Value

SdkConfigurationLiveOddsVbl

Implements

ISdkConfigurationLiveOddsVbl
See Also

Reference

SdkLiveConfiguration Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkLiveConfiguration.LiveOddsVdr Property

SdkLiveConfigurationLiveOddsVdr Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.SdkLiveConfiguration.LiveOddsVdr"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsVdr LiveOddsVdr { get; }

Property Value

SdkConfigurationLiveOddsVdr

Implements

ISdkConfigurationLiveOddsVdr
See Also

Reference

SdkLiveConfiguration Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkLiveConfiguration.LiveOddsVhc Property

SdkLiveConfigurationLiveOddsVhc Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.SdkLiveConfiguration.LiveOddsVhc"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsVhc LiveOddsVhc { get; }

Property Value

SdkConfigurationLiveOddsVhc

Implements

ISdkConfigurationLiveOddsVhc
See Also

Reference

SdkLiveConfiguration Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkLiveConfiguration.LivePlex Property

SdkLiveConfigurationLivePlex Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.SdkLiveConfiguration.LivePlex"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsLivePlex LivePlex { get; }

Property Value

SdkConfigurationLiveOddsLivePlex

Implements

ISdkConfigurationLivePlex
See Also

Reference

SdkLiveConfiguration Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkLiveConfiguration.SoccerRoulette Property

SdkLiveConfigurationSoccerRoulette Property

[Missing <summary> documentation for "P:Sportradar.SDK.Services.SdkConfiguration.SdkLiveConfiguration.SoccerRoulette"]

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SdkConfigurationLiveOddsSoccerRoulette SoccerRoulette { get; }

Property Value

SdkConfigurationLiveOddsSoccerRoulette

Implements

ISdkConfigurationSoccerRoulette
See Also

Reference

SdkLiveConfiguration Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkLiveConfiguration Methods

The SdkLiveConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SdkLiveConfiguration Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkLiveConfiguration Events

The SdkLiveConfiguration type exposes the following members.

Events
 | Name | Description
Public event | OnConfigurationReloaded | Event fired every time that configuration is reloaded / refreshed and might have changed. This is a good time for components to update their cached configuration settings, if any.
Top
See Also

Reference

SdkLiveConfiguration Class
Sportradar.SDK.Services.SdkConfiguration Namespace


SdkLiveConfiguration.OnConfigurationReloaded Event

SdkLiveConfigurationOnConfigurationReloaded Event

Event fired every time that configuration is reloaded / refreshed and might have changed. This is a good time for components to update their cached configuration settings, if any.

Namespace: Sportradar.SDK.Services.SdkConfiguration
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public event SdkConfigurationDelegatesConfigReloadedDelegate OnConfigurationReloaded

Value

SdkConfigurationDelegatesConfigReloadedDelegate

Implements

ISdkConfigurationOnConfigurationReloaded
See Also

Reference

SdkLiveConfiguration Class
Sportradar.SDK.Services.SdkConfiguration Namespace


Sportradar.SDK.Services.SdkConfiguration.Converters Namespace

Classes
 | Class | Description
Public class | SecureStringConverter |
Public class | StringArrayConverter |


SecureStringConverter Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.SdkConfiguration.Converters.SecureStringConverter"]

Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
System.ConfigurationConfigurationConverterBase
Sportradar.SDK.Services.SdkConfiguration.ConvertersSecureStringConverter

Namespace: Sportradar.SDK.Services.SdkConfiguration.Converters
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class SecureStringConverter : ConfigurationConverterBase

The SecureStringConverter type exposes the following members.

Constructors
 | Name | Description
Public method | SecureStringConverter | Initializes a new instance of the SecureStringConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Determines whether the conversion is allowed. (Inherited from ConfigurationConverterBase)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Determines whether the conversion is allowed. (Inherited from ConfigurationConverterBase)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) |
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) |
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


SecureStringConverter Constructor

Initializes a new instance of the SecureStringConverter class

Namespace: Sportradar.SDK.Services.SdkConfiguration.Converters
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public SecureStringConverter()
See Also

Reference

SecureStringConverter Class
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


SecureStringConverter Methods

The SecureStringConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Determines whether the conversion is allowed. (Inherited from ConfigurationConverterBase)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Determines whether the conversion is allowed. (Inherited from ConfigurationConverterBase)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) |
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) |
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SecureStringConverter Class
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


SecureStringConverter.ConvertFrom Method

SecureStringConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter.
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) |
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information.
Top
See Also

Reference

SecureStringConverter Class
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


SecureStringConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) Method

SecureStringConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.SecureStringConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

Namespace: Sportradar.SDK.Services.SdkConfiguration.Converters
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual Object ConvertFrom(
    ITypeDescriptorContext ctx,
    CultureInfo ci,
    Object data
)

Parameters

ctx ITypeDescriptorContext

[Missing <param name="ctx"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.SecureStringConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

ci CultureInfo

[Missing <param name="ci"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.SecureStringConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

data Object

[Missing <param name="data"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.SecureStringConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

Return Value

Object

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.SecureStringConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

See Also

Reference

SecureStringConverter Class
ConvertFrom Overload
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


SecureStringConverter.ConvertTo Method

SecureStringConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments.
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) |
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information.
Top
See Also

Reference

SecureStringConverter Class
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


SecureStringConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) Method

SecureStringConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.SecureStringConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

Namespace: Sportradar.SDK.Services.SdkConfiguration.Converters
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual Object ConvertTo(
    ITypeDescriptorContext ctx,
    CultureInfo ci,
    Object value,
    Type type
)

Parameters

ctx ITypeDescriptorContext

[Missing <param name="ctx"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.SecureStringConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

ci CultureInfo

[Missing <param name="ci"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.SecureStringConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

value Object

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.SecureStringConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

type Type

[Missing <param name="type"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.SecureStringConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

Return Value

Object

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.SecureStringConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

See Also

Reference

SecureStringConverter Class
ConvertTo Overload
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


StringArrayConverter Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter"]

Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
Sportradar.SDK.Services.SdkConfiguration.ConvertersStringArrayConverter

Namespace: Sportradar.SDK.Services.SdkConfiguration.Converters
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class StringArrayConverter : TypeConverter

The StringArrayConverter type exposes the following members.

Constructors
 | Name | Description
Public method | StringArrayConverter | Initializes a new instance of the StringArrayConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) |
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) |
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) |
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


StringArrayConverter Constructor

Initializes a new instance of the StringArrayConverter class

Namespace: Sportradar.SDK.Services.SdkConfiguration.Converters
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public StringArrayConverter()
See Also

Reference

StringArrayConverter Class
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


StringArrayConverter Methods

The StringArrayConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) |
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) |
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) |
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

StringArrayConverter Class
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


StringArrayConverter.CanConvertFrom Method

StringArrayConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter.
Public method | CanConvertFrom(ITypeDescriptorContext, Type) |
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.
Top
See Also

Reference

StringArrayConverter Class
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


StringArrayConverter.CanConvertFrom(ITypeDescriptorContext, Type) Method

StringArrayConverterCanConvertFrom(ITypeDescriptorContext, Type) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

Namespace: Sportradar.SDK.Services.SdkConfiguration.Converters
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type source_type
)

Parameters

context ITypeDescriptorContext

[Missing <param name="context"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

source_type Type

[Missing <param name="source_type"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

See Also

Reference

StringArrayConverter Class
CanConvertFrom Overload
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


StringArrayConverter.ConvertFrom Method

StringArrayConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter.
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) |
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information.
Top
See Also

Reference

StringArrayConverter Class
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


StringArrayConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) Method

StringArrayConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

Namespace: Sportradar.SDK.Services.SdkConfiguration.Converters
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)

Parameters

context ITypeDescriptorContext

[Missing <param name="context"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

culture CultureInfo

[Missing <param name="culture"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

value Object

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

Return Value

Object

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

See Also

Reference

StringArrayConverter Class
ConvertFrom Overload
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


StringArrayConverter.ConvertTo Method

StringArrayConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments.
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) |
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information.
Top
See Also

Reference

StringArrayConverter Class
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


StringArrayConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) Method

StringArrayConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

Namespace: Sportradar.SDK.Services.SdkConfiguration.Converters
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destination_type
)

Parameters

context ITypeDescriptorContext

[Missing <param name="context"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

culture CultureInfo

[Missing <param name="culture"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

value Object

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

destination_type Type

[Missing <param name="destination_type"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

Return Value

Object

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Converters.StringArrayConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

See Also

Reference

StringArrayConverter Class
ConvertTo Overload
Sportradar.SDK.Services.SdkConfiguration.Converters Namespace


Sportradar.SDK.Services.SdkConfiguration.Validators Namespace

Classes
 | Class | Description
Public class | NullableIntegerValidator |


NullableIntegerValidator Class

[Missing <summary> documentation for "T:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator"]

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationValidatorBase
Sportradar.SDK.Services.SdkConfiguration.ValidatorsNullableIntegerValidator

Namespace: Sportradar.SDK.Services.SdkConfiguration.Validators
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public class NullableIntegerValidator : ConfigurationValidatorBase

The NullableIntegerValidator type exposes the following members.

Constructors
 | Name | Description
Public method | NullableIntegerValidator | Initializes a new instance of the NullableIntegerValidator class
Public method | NullableIntegerValidator(Int32, Int32) | Initializes a new instance of the NullableIntegerValidator class
Public method | NullableIntegerValidator(Int32, Int32, Boolean) | Initializes a new instance of the NullableIntegerValidator class
Public method | NullableIntegerValidator(Int32, Int32, Boolean, Int32) | Initializes a new instance of the NullableIntegerValidator class
Top
Methods
 | Name | Description
Public method | CanValidate(Type) |
Public method | CanValidate(Type) | Determines whether an object can be validated based on type. (Inherited from ConfigurationValidatorBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Validate | (Overrides ConfigurationValidatorBaseValidate(Object))
Top
See Also

Reference

Sportradar.SDK.Services.SdkConfiguration.Validators Namespace


NullableIntegerValidator Constructor

Overload List
 | Name | Description
Public method | NullableIntegerValidator | Initializes a new instance of the NullableIntegerValidator class
Public method | NullableIntegerValidator(Int32, Int32) | Initializes a new instance of the NullableIntegerValidator class
Public method | NullableIntegerValidator(Int32, Int32, Boolean) | Initializes a new instance of the NullableIntegerValidator class
Public method | NullableIntegerValidator(Int32, Int32, Boolean, Int32) | Initializes a new instance of the NullableIntegerValidator class
Top
See Also

Reference

NullableIntegerValidator Class
Sportradar.SDK.Services.SdkConfiguration.Validators Namespace


NullableIntegerValidator Constructor

Initializes a new instance of the NullableIntegerValidator class

Namespace: Sportradar.SDK.Services.SdkConfiguration.Validators
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public NullableIntegerValidator()
See Also

Reference

NullableIntegerValidator Class
NullableIntegerValidator Overload
Sportradar.SDK.Services.SdkConfiguration.Validators Namespace


NullableIntegerValidator(Int32, Int32) Constructor

Initializes a new instance of the NullableIntegerValidator class

Namespace: Sportradar.SDK.Services.SdkConfiguration.Validators
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public NullableIntegerValidator(
    int min_value,
    int max_value
)

Parameters

min_value Int32

[Missing <param name="min_value"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.#ctor(System.Int32,System.Int32)"]

max_value Int32

[Missing <param name="max_value"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.#ctor(System.Int32,System.Int32)"]

See Also

Reference

NullableIntegerValidator Class
NullableIntegerValidator Overload
Sportradar.SDK.Services.SdkConfiguration.Validators Namespace


NullableIntegerValidator(Int32, Int32, Boolean) Constructor

Initializes a new instance of the NullableIntegerValidator class

Namespace: Sportradar.SDK.Services.SdkConfiguration.Validators
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public NullableIntegerValidator(
    int min_value,
    int max_value,
    bool range_is_exclusive
)

Parameters

min_value Int32

[Missing <param name="min_value"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.#ctor(System.Int32,System.Int32,System.Boolean)"]

max_value Int32

[Missing <param name="max_value"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.#ctor(System.Int32,System.Int32,System.Boolean)"]

range_is_exclusive Boolean

[Missing <param name="range_is_exclusive"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.#ctor(System.Int32,System.Int32,System.Boolean)"]

See Also

Reference

NullableIntegerValidator Class
NullableIntegerValidator Overload
Sportradar.SDK.Services.SdkConfiguration.Validators Namespace


NullableIntegerValidator(Int32, Int32, Boolean, Int32) Constructor

Initializes a new instance of the NullableIntegerValidator class

Namespace: Sportradar.SDK.Services.SdkConfiguration.Validators
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public NullableIntegerValidator(
    int min_value,
    int max_value,
    bool range_is_exclusive,
    int resolution
)

Parameters

min_value Int32

[Missing <param name="min_value"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.#ctor(System.Int32,System.Int32,System.Boolean,System.Int32)"]

max_value Int32

[Missing <param name="max_value"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.#ctor(System.Int32,System.Int32,System.Boolean,System.Int32)"]

range_is_exclusive Boolean

[Missing <param name="range_is_exclusive"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.#ctor(System.Int32,System.Int32,System.Boolean,System.Int32)"]

resolution Int32

[Missing <param name="resolution"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.#ctor(System.Int32,System.Int32,System.Boolean,System.Int32)"]

See Also

Reference

NullableIntegerValidator Class
NullableIntegerValidator Overload
Sportradar.SDK.Services.SdkConfiguration.Validators Namespace


NullableIntegerValidator Methods

The NullableIntegerValidator type exposes the following members.

Methods
 | Name | Description
Public method | CanValidate(Type) |
Public method | CanValidate(Type) | Determines whether an object can be validated based on type. (Inherited from ConfigurationValidatorBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Validate | (Overrides ConfigurationValidatorBaseValidate(Object))
Top
See Also

Reference

NullableIntegerValidator Class
Sportradar.SDK.Services.SdkConfiguration.Validators Namespace


NullableIntegerValidator.CanValidate Method

NullableIntegerValidatorCanValidate Method

Overload List
 | Name | Description
Public method | CanValidate(Type) |
Public method | CanValidate(Type) | Determines whether an object can be validated based on type.
Top
See Also

Reference

NullableIntegerValidator Class
Sportradar.SDK.Services.SdkConfiguration.Validators Namespace


NullableIntegerValidator.CanValidate(Type) Method

NullableIntegerValidatorCanValidate(Type) Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.CanValidate(System.Type)"]

Namespace: Sportradar.SDK.Services.SdkConfiguration.Validators
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public virtual bool CanValidate(
    Type type
)

Parameters

type Type

[Missing <param name="type"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.CanValidate(System.Type)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.CanValidate(System.Type)"]

See Also

Reference

NullableIntegerValidator Class
CanValidate Overload
Sportradar.SDK.Services.SdkConfiguration.Validators Namespace


NullableIntegerValidator.Validate Method

NullableIntegerValidatorValidate Method

[Missing <summary> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.Validate(System.Object)"]

Namespace: Sportradar.SDK.Services.SdkConfiguration.Validators
Assembly: SdkConfiguration (in SdkConfiguration.dll) Version: 2.28.0.0
Syntax
C#
Copy
public override void Validate(
    Object value
)

Parameters

value Object

[Missing <param name="value"/> documentation for "M:Sportradar.SDK.Services.SdkConfiguration.Validators.NullableIntegerValidator.Validate(System.Object)"]

See Also

Reference

NullableIntegerValidator Class
Sportradar.SDK.Services.SdkConfiguration.Validators Namespace