Sportradar MTS SDK .NET Standard

MTS SDK is a client library that enables easier integration with the Sportradar MTS. SDK exposes well defined API and hides ticket response parsing, proper connection handling, error recovery, event queuing and dispatching. It also makes a client solution easier to maintain with regular version updates.

SDK supports MTS ticket version 2.4.

Getting Started

Before starting to use the SDK please read the appropriate MTS documentation found on www.betradar.com under Help/Developer Zone/Downloads. SDK examples and code documentation is available on the https://sdk.sportradar.com.

Obtaining the SDK

The SDK is provided as a code library (Sportradar.MTS.SDK.dll), which is available on the SDK site and via the NuGet package manager. The usage of NuGet package manager is recommended, since it supports update notifications and makes it easier to obtain new releases of the SDK.

Copyright © 2017-2022, Sportradar AG

Send comments on this topic to SDK Team


Sportradar.MTS.SDK.API Namespace

Classes
 | Class | Description
Public class | MtsSdk | A IMtsSdk implementation acting as an entry point to the MTS SDK
Interfaces
 | Interface | Description
Public interface | IConnectionStatus | Defines a contract for classes providing information on connection to rabbit server
Public interface | ICustomBetManager | Defines methods used to perform various custom bet operations
Public interface | IMtsClientApi | Defines a contract used to send requests to MTS Client REST API
Public interface | IMtsSdk | Represents a root object of the MTS SDK (to create, send tickets and to handle responses)
Public interface | IReportManager | Defines methods used to get various reports
Public interface | ISdkConfigurationBuilder | Defines a contract for classes implementing builder for ISdkConfiguration


IConnectionStatus Interface

Defines a contract for classes providing information on connection to rabbit server

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IConnectionStatus type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionTime | Gets the time of when connection was made.
Public property | DisconnectionTime | Gets the time of disconnection.
Public property | IsConnected | Gets a value indicating whether this instance is connected.
Public property | LastReceivedTicketId | Gets the last received ticket identifier.
Public property | LastSendTicketId | Gets the last send ticket identifier.
Top
Events
 | Name | Description
Public event | ConnectionChange | Occurs when connection status change
Top
See Also

Reference

Sportradar.MTS.SDK.API Namespace


IConnectionStatus Properties

The IConnectionStatus type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionTime | Gets the time of when connection was made.
Public property | DisconnectionTime | Gets the time of disconnection.
Public property | IsConnected | Gets a value indicating whether this instance is connected.
Public property | LastReceivedTicketId | Gets the last received ticket identifier.
Public property | LastSendTicketId | Gets the last send ticket identifier.
Top
See Also

Reference

IConnectionStatus Interface
Sportradar.MTS.SDK.API Namespace


IConnectionStatus.ConnectionTime Property

MTS SDK Core Documentation

IConnectionStatusConnectionTime Property

Gets the time of when connection was made.

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IConnectionStatus Interface
Sportradar.MTS.SDK.API Namespace


IConnectionStatus.DisconnectionTime Property

IConnectionStatusDisconnectionTime Property

Gets the time of disconnection.

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IConnectionStatus Interface
Sportradar.MTS.SDK.API Namespace


IConnectionStatus.IsConnected Property

IConnectionStatusIsConnected Property

Gets a value indicating whether this instance is connected.

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IConnectionStatus Interface
Sportradar.MTS.SDK.API Namespace


IConnectionStatus.LastReceivedTicketId Property

IConnectionStatusLastReceivedTicketId Property

Gets the last received ticket identifier.

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IConnectionStatus Interface
Sportradar.MTS.SDK.API Namespace


IConnectionStatus.LastSendTicketId Property

IConnectionStatusLastSendTicketId Property

Gets the last send ticket identifier.

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IConnectionStatus Interface
Sportradar.MTS.SDK.API Namespace


IConnectionStatus Events

The IConnectionStatus type exposes the following members.

Events
 | Name | Description
Public event | ConnectionChange | Occurs when connection status change
Top
See Also

Reference

IConnectionStatus Interface
Sportradar.MTS.SDK.API Namespace


IConnectionStatus.ConnectionChange Event

IConnectionStatusConnectionChange Event

Occurs when connection status change

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
On disconnection all ticket sending is disabled. Event ticket creation should be omitted to avoid having old ticket timestamp.
See Also

Reference

IConnectionStatus Interface
Sportradar.MTS.SDK.API Namespace


ICustomBetManager Interface

Defines methods used to perform various custom bet operations

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ICustomBetManager type exposes the following members.

Properties
 | Name | Description
Public property | CustomBetSelectionBuilder | Returns an ICustomBetSelectionBuilder instance used to build selections
Top
Methods
 | Name | Description
Public method | CalculateProbabilityAsync | Returns an ICalculation instance providing the probability for the specified selections
Public method | GetAvailableSelectionsAsync | Returns an IAvailableSelections instance providing the available selections for the event associated with the provided String identifier
Top
See Also

Reference

Sportradar.MTS.SDK.API Namespace


ICustomBetManager Properties

The ICustomBetManager type exposes the following members.

Properties
 | Name | Description
Public property | CustomBetSelectionBuilder | Returns an ICustomBetSelectionBuilder instance used to build selections
Top
See Also

Reference

ICustomBetManager Interface
Sportradar.MTS.SDK.API Namespace


ICustomBetManager.CustomBetSelectionBuilder Property

ICustomBetManagerCustomBetSelectionBuilder Property

Returns an ICustomBetSelectionBuilder instance used to build selections

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICustomBetManager Interface
Sportradar.MTS.SDK.API Namespace


ICustomBetManager Methods

The ICustomBetManager type exposes the following members.

Methods
 | Name | Description
Public method | CalculateProbabilityAsync | Returns an ICalculation instance providing the probability for the specified selections
Public method | GetAvailableSelectionsAsync | Returns an IAvailableSelections instance providing the available selections for the event associated with the provided String identifier
Top
See Also

Reference

ICustomBetManager Interface
Sportradar.MTS.SDK.API Namespace


ICustomBetManager.CalculateProbabilityAsync Method

ICustomBetManagerCalculateProbabilityAsync Method

Returns an ICalculation instance providing the probability for the specified selections

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICustomBetManager Interface
Sportradar.MTS.SDK.API Namespace


ICustomBetManager.GetAvailableSelectionsAsync Method

ICustomBetManagerGetAvailableSelectionsAsync Method

Returns an IAvailableSelections instance providing the available selections for the event associated with the provided String identifier

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICustomBetManager Interface
Sportradar.MTS.SDK.API Namespace


IMtsClientApi Interface

Defines a contract used to send requests to MTS Client REST API

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IMtsClientApi type exposes the following members.

Methods
 | Name | Description
Public method | GetCcfAsync(String) | Gets customer confidence factor for a customer
Public method | GetCcfAsync(String, String, String) | Gets customer confidence factor for a customer
Public method | GetMaxStakeAsync(ITicket) | Gets maximum stake for a ticket
Public method | GetMaxStakeAsync(ITicket, String, String) | Gets maximum stake for a ticket
Top
See Also

Reference

Sportradar.MTS.SDK.API Namespace


IMtsClientApi Methods

The IMtsClientApi type exposes the following members.

Methods
 | Name | Description
Public method | GetCcfAsync(String) | Gets customer confidence factor for a customer
Public method | GetCcfAsync(String, String, String) | Gets customer confidence factor for a customer
Public method | GetMaxStakeAsync(ITicket) | Gets maximum stake for a ticket
Public method | GetMaxStakeAsync(ITicket, String, String) | Gets maximum stake for a ticket
Top
See Also

Reference

IMtsClientApi Interface
Sportradar.MTS.SDK.API Namespace


IMtsClientApi.GetCcfAsync Method

IMtsClientApiGetCcfAsync Method

Overload List
 | Name | Description
Public method | GetCcfAsync(String) | Gets customer confidence factor for a customer
Public method | GetCcfAsync(String, String, String) | Gets customer confidence factor for a customer
Top
See Also

Reference

IMtsClientApi Interface
Sportradar.MTS.SDK.API Namespace


IMtsClientApi.GetCcfAsync(String) Method

IMtsClientApiGetCcfAsync(String) Method

Gets customer confidence factor for a customer

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsClientApi Interface
GetCcfAsync Overload
Sportradar.MTS.SDK.API Namespace


IMtsClientApi.GetCcfAsync(String, String, String) Method

IMtsClientApiGetCcfAsync(String, String, String) Method

Gets customer confidence factor for a customer

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsClientApi Interface
GetCcfAsync Overload
Sportradar.MTS.SDK.API Namespace


IMtsClientApi.GetMaxStakeAsync Method

IMtsClientApiGetMaxStakeAsync Method

Overload List
 | Name | Description
Public method | GetMaxStakeAsync(ITicket) | Gets maximum stake for a ticket
Public method | GetMaxStakeAsync(ITicket, String, String) | Gets maximum stake for a ticket
Top
See Also

Reference

IMtsClientApi Interface
Sportradar.MTS.SDK.API Namespace


IMtsClientApi.GetMaxStakeAsync(ITicket) Method

IMtsClientApiGetMaxStakeAsync(ITicket) Method

Gets maximum stake for a ticket

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsClientApi Interface
GetMaxStakeAsync Overload
Sportradar.MTS.SDK.API Namespace


IMtsClientApi.GetMaxStakeAsync(ITicket, String, String) Method

IMtsClientApiGetMaxStakeAsync(ITicket, String, String) Method

Gets maximum stake for a ticket

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsClientApi Interface
GetMaxStakeAsync Overload
Sportradar.MTS.SDK.API Namespace


IMtsSdk Interface

Represents a root object of the MTS SDK (to create, send tickets and to handle responses)

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IMtsSdk type exposes the following members.

Properties
 | Name | Description
Public property | BuilderFactory | Gets the IBuilderFactory instance used to construct builders with some of the properties pre-loaded from the configuration
Public property | ClientApi | Gets the IMtsClientApi instance used to send requests to MTS REST API
Public property | ConnectionStatus | Gets the connection status.
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations
Public property | IsOpened | Gets a value indicating whether the current instance is opened (Inherited from IOpenable)
Public property | ReportManager | Gets a IReportManager instance used to get various reports
Top
Methods
 | Name | Description
Public method | Close | Closes the current instance (Inherited from IOpenable)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current instance (Inherited from IOpenable)
Public method | SendTicket | Sends the ticket to the MTS server. The response will raise TicketResponseReceived event.
Public method | SendTicketBlocking | Sends the ticket to the MTS server and wait for the response message on the feed
Public method | SendTicketCancelBlocking | Sends the cancel ticket to the MTS server and wait for the response message on the feed
Public method | SendTicketCashoutBlocking | Sends the cashout ticket to the MTS server and wait for the response message on the feed
Public method | SendTicketNonSrSettleBlocking | Sends the non-sr ticket to the MTS server and wait for the response message on the feed
Top
Events
 | Name | Description
Public event | SendTicketFailed | Raised when the attempt to send ticket failed
Public event | TicketResponseReceived | Raised when the current instance of IMtsSdk received ITicketResponse
Public event | TicketResponseTimedOut | Raised when the current instance of IMtsSdk did not receive ITicketResponse within timeout
Public event | UnparsableTicketResponseReceived | Raised when a message which cannot be parsed is received
Top
See Also

Reference

Sportradar.MTS.SDK.API Namespace


IMtsSdk Properties

The IMtsSdk type exposes the following members.

Properties
 | Name | Description
Public property | BuilderFactory | Gets the IBuilderFactory instance used to construct builders with some of the properties pre-loaded from the configuration
Public property | ClientApi | Gets the IMtsClientApi instance used to send requests to MTS REST API
Public property | ConnectionStatus | Gets the connection status.
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations
Public property | IsOpened | Gets a value indicating whether the current instance is opened (Inherited from IOpenable)
Public property | ReportManager | Gets a IReportManager instance used to get various reports
Top
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.BuilderFactory Property

IMtsSdkBuilderFactory Property

Gets the IBuilderFactory instance used to construct builders with some of the properties pre-loaded from the configuration

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.ClientApi Property

IMtsSdkClientApi Property

Gets the IMtsClientApi instance used to send requests to MTS REST API

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.ConnectionStatus Property

IMtsSdkConnectionStatus Property

Gets the connection status.

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.CustomBetManager Property

IMtsSdkCustomBetManager Property

Gets a ICustomBetManager instance used to perform various custom bet operations

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.ReportManager Property

IMtsSdkReportManager Property

Gets a IReportManager instance used to get various reports

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk Methods

The IMtsSdk type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current instance (Inherited from IOpenable)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current instance (Inherited from IOpenable)
Public method | SendTicket | Sends the ticket to the MTS server. The response will raise TicketResponseReceived event.
Public method | SendTicketBlocking | Sends the ticket to the MTS server and wait for the response message on the feed
Public method | SendTicketCancelBlocking | Sends the cancel ticket to the MTS server and wait for the response message on the feed
Public method | SendTicketCashoutBlocking | Sends the cashout ticket to the MTS server and wait for the response message on the feed
Public method | SendTicketNonSrSettleBlocking | Sends the non-sr ticket to the MTS server and wait for the response message on the feed
Top
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.SendTicket Method

IMtsSdkSendTicket Method

Sends the ticket to the MTS server. The response will raise TicketResponseReceived event.

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.SendTicketBlocking Method

IMtsSdkSendTicketBlocking Method

Sends the ticket to the MTS server and wait for the response message on the feed

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.SendTicketCancelBlocking Method

IMtsSdkSendTicketCancelBlocking Method

Sends the cancel ticket to the MTS server and wait for the response message on the feed

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.SendTicketCashoutBlocking Method

IMtsSdkSendTicketCashoutBlocking Method

Sends the cashout ticket to the MTS server and wait for the response message on the feed

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.SendTicketNonSrSettleBlocking Method

IMtsSdkSendTicketNonSrSettleBlocking Method

Sends the non-sr ticket to the MTS server and wait for the response message on the feed

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk Events

The IMtsSdk type exposes the following members.

Events
 | Name | Description
Public event | SendTicketFailed | Raised when the attempt to send ticket failed
Public event | TicketResponseReceived | Raised when the current instance of IMtsSdk received ITicketResponse
Public event | TicketResponseTimedOut | Raised when the current instance of IMtsSdk did not receive ITicketResponse within timeout
Public event | UnparsableTicketResponseReceived | Raised when a message which cannot be parsed is received
Top
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.SendTicketFailed Event

IMtsSdkSendTicketFailed Event

Raised when the attempt to send ticket failed

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.TicketResponseReceived Event

IMtsSdkTicketResponseReceived Event

Raised when the current instance of IMtsSdk received ITicketResponse

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.TicketResponseTimedOut Event

IMtsSdkTicketResponseTimedOut Event

Raised when the current instance of IMtsSdk did not receive ITicketResponse within timeout

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IMtsSdk.UnparsableTicketResponseReceived Event

IMtsSdkUnparsableTicketResponseReceived Event

Raised when a message which cannot be parsed is received

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMtsSdk Interface
Sportradar.MTS.SDK.API Namespace


IReportManager Interface

Defines methods used to get various reports

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IReportManager type exposes the following members.

Methods
 | Name | Description
Public method | GetHistoryCcfChangeCsvExportAsync(DateTime, DateTime, NullableInt32, ListInt32, String, SourceType, String, String) | Gets the customer ccf (confidence factor history change) as list of ICcfChange for bookmaker with filters
Public method | GetHistoryCcfChangeCsvExportAsync(Stream, DateTime, DateTime, NullableInt32, ListInt32, String, SourceType, String, String) | Gets the customer ccf (confidence factor history change) CSV output stream for bookmaker with filters
Top
See Also

Reference

Sportradar.MTS.SDK.API Namespace


IReportManager Methods

The IReportManager type exposes the following members.

Methods
 | Name | Description
Public method | GetHistoryCcfChangeCsvExportAsync(DateTime, DateTime, NullableInt32, ListInt32, String, SourceType, String, String) | Gets the customer ccf (confidence factor history change) as list of ICcfChange for bookmaker with filters
Public method | GetHistoryCcfChangeCsvExportAsync(Stream, DateTime, DateTime, NullableInt32, ListInt32, String, SourceType, String, String) | Gets the customer ccf (confidence factor history change) CSV output stream for bookmaker with filters
Top
See Also

Reference

IReportManager Interface
Sportradar.MTS.SDK.API Namespace


IReportManager.GetHistoryCcfChangeCsvExportAsync Method

IReportManagerGetHistoryCcfChangeCsvExportAsync Method

Overload List
 | Name | Description
Public method | GetHistoryCcfChangeCsvExportAsync(DateTime, DateTime, NullableInt32, ListInt32, String, SourceType, String, String) | Gets the customer ccf (confidence factor history change) as list of ICcfChange for bookmaker with filters
Public method | GetHistoryCcfChangeCsvExportAsync(Stream, DateTime, DateTime, NullableInt32, ListInt32, String, SourceType, String, String) | Gets the customer ccf (confidence factor history change) CSV output stream for bookmaker with filters
Top
See Also

Reference

IReportManager Interface
Sportradar.MTS.SDK.API Namespace


IReportManager.GetHistoryCcfChangeCsvExportAsync(DateTime, DateTime, Nullable<Int32>, List<Int32>, String, SourceType, String, String) Method

IReportManagerGetHistoryCcfChangeCsvExportAsync(DateTime, DateTime, NullableInt32, ListInt32, String, SourceType, String, String) Method

Gets the customer ccf (confidence factor history change) as list of ICcfChange for bookmaker with filters

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Exceptions
Exception | Condition
MtsReportException | If there is exception getting report data
See Also

Reference

IReportManager Interface
GetHistoryCcfChangeCsvExportAsync Overload
Sportradar.MTS.SDK.API Namespace


IReportManager.GetHistoryCcfChangeCsvExportAsync(Stream, DateTime, DateTime, Nullable<Int32>, List<Int32>, String, SourceType, String, String) Method

IReportManagerGetHistoryCcfChangeCsvExportAsync(Stream, DateTime, DateTime, NullableInt32, ListInt32, String, SourceType, String, String) Method

Gets the customer ccf (confidence factor history change) CSV output stream for bookmaker with filters

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Exceptions
Exception | Condition
MtsReportException | If there is exception getting report data
See Also

Reference

IReportManager Interface
GetHistoryCcfChangeCsvExportAsync Overload
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder Interface

Defines a contract for classes implementing builder for ISdkConfiguration

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ISdkConfigurationBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds the ISdkConfiguration
Public method | SetAccessToken | Sets the access token
Public method | SetBookmakerId | Sets the bookmakerId
Public method | SetCurrency | Sets the currency
Public method | SetExclusiveConsumer | Sets the value indicating whether the rabbit consumer channel should be exclusive
Public method | SetHost | Sets the host used to connect to AMQP broker
Public method | SetKeycloakHost | Sets the Keycloak host for authorization
Public method | SetKeycloakPassword | Sets the password used to connect authenticate to Keycloak
Public method | SetKeycloakSecret | Sets the secret used to connect authenticate to Keycloak
Public method | SetKeycloakUsername | Sets the username used to connect authenticate to Keycloak
Public method | SetLimitId | Sets the limitId
Public method | SetMtsClientApiHost | Sets the Client API host
Public method | SetNode | Sets the node id
Public method | SetNonSrSettleResponseTimeout | Sets the ticket non-sr settle response timeout(ms)
Public method | SetPassword | Sets the password
Public method | SetPort | Sets the port used to connect to AMQP broker
Public method | SetProvideAdditionalMarketSpecifiers | This value is used to indicate if the sdk should add market specifiers for specific markets. Only used when building selection using UnifiedOdds ids. (default: true)
Public method | SetSenderChannel | Sets the sender channel
Public method | SetSslServerName | Sets the server name that will be used to check against SSL certificate
Public method | SetTicketCancellationResponseTimeout | Sets the ticket cancellation response timeout(ms)
Public method | SetTicketCashoutResponseTimeout | Sets the ticket cashout response timeout(ms)
Public method | SetTicketResponseTimeout | Sets the ticket response timeout(ms) (sets both live and prematch timeouts)
Public method | SetTicketResponseTimeoutLive | Sets the ticket response timeout(ms) for tickets using "live" selectionId
Public method | SetTicketResponseTimeoutPrematch | Sets the ticket response timeout(ms) for tickets using "prematch" selectionId
Public method | SetUfEnvironment | Sets the uf environment
Public method | SetUsername | Sets the username
Public method | SetUseSsl | Sets the value indicating whether a secure connection to the message broker should be used
Public method | SetVirtualHost | Sets the vhost (format: '/vhost')
Top
See Also

Reference

Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder Methods

The ISdkConfigurationBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds the ISdkConfiguration
Public method | SetAccessToken | Sets the access token
Public method | SetBookmakerId | Sets the bookmakerId
Public method | SetCurrency | Sets the currency
Public method | SetExclusiveConsumer | Sets the value indicating whether the rabbit consumer channel should be exclusive
Public method | SetHost | Sets the host used to connect to AMQP broker
Public method | SetKeycloakHost | Sets the Keycloak host for authorization
Public method | SetKeycloakPassword | Sets the password used to connect authenticate to Keycloak
Public method | SetKeycloakSecret | Sets the secret used to connect authenticate to Keycloak
Public method | SetKeycloakUsername | Sets the username used to connect authenticate to Keycloak
Public method | SetLimitId | Sets the limitId
Public method | SetMtsClientApiHost | Sets the Client API host
Public method | SetNode | Sets the node id
Public method | SetNonSrSettleResponseTimeout | Sets the ticket non-sr settle response timeout(ms)
Public method | SetPassword | Sets the password
Public method | SetPort | Sets the port used to connect to AMQP broker
Public method | SetProvideAdditionalMarketSpecifiers | This value is used to indicate if the sdk should add market specifiers for specific markets. Only used when building selection using UnifiedOdds ids. (default: true)
Public method | SetSenderChannel | Sets the sender channel
Public method | SetSslServerName | Sets the server name that will be used to check against SSL certificate
Public method | SetTicketCancellationResponseTimeout | Sets the ticket cancellation response timeout(ms)
Public method | SetTicketCashoutResponseTimeout | Sets the ticket cashout response timeout(ms)
Public method | SetTicketResponseTimeout | Sets the ticket response timeout(ms) (sets both live and prematch timeouts)
Public method | SetTicketResponseTimeoutLive | Sets the ticket response timeout(ms) for tickets using "live" selectionId
Public method | SetTicketResponseTimeoutPrematch | Sets the ticket response timeout(ms) for tickets using "prematch" selectionId
Public method | SetUfEnvironment | Sets the uf environment
Public method | SetUsername | Sets the username
Public method | SetUseSsl | Sets the value indicating whether a secure connection to the message broker should be used
Public method | SetVirtualHost | Sets the vhost (format: '/vhost')
Top
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.Build Method

ISdkConfigurationBuilderBuild Method

Builds the ISdkConfiguration

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetAccessToken Method

ISdkConfigurationBuilderSetAccessToken Method

Sets the access token

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetBookmakerId Method

ISdkConfigurationBuilderSetBookmakerId Method

Sets the bookmakerId

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetCurrency Method

ISdkConfigurationBuilderSetCurrency Method

Sets the currency

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetExclusiveConsumer Method

ISdkConfigurationBuilderSetExclusiveConsumer Method

Sets the value indicating whether the rabbit consumer channel should be exclusive

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetHost Method

ISdkConfigurationBuilderSetHost Method

Sets the host used to connect to AMQP broker

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetKeycloakHost Method

ISdkConfigurationBuilderSetKeycloakHost Method

Sets the Keycloak host for authorization

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetKeycloakPassword Method

ISdkConfigurationBuilderSetKeycloakPassword Method

Sets the password used to connect authenticate to Keycloak

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetKeycloakSecret Method

ISdkConfigurationBuilderSetKeycloakSecret Method

Sets the secret used to connect authenticate to Keycloak

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetKeycloakUsername Method

ISdkConfigurationBuilderSetKeycloakUsername Method

Sets the username used to connect authenticate to Keycloak

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetLimitId Method

ISdkConfigurationBuilderSetLimitId Method

Sets the limitId

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetMtsClientApiHost Method

ISdkConfigurationBuilderSetMtsClientApiHost Method

Sets the Client API host

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetNode Method

ISdkConfigurationBuilderSetNode Method

Sets the node id

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetNonSrSettleResponseTimeout Method

ISdkConfigurationBuilderSetNonSrSettleResponseTimeout Method

Sets the ticket non-sr settle response timeout(ms)

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetPassword Method

ISdkConfigurationBuilderSetPassword Method

Sets the password

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetPort Method

ISdkConfigurationBuilderSetPort Method

Sets the port used to connect to AMQP broker

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
Port should be chosen through the UseSsl property. Manually setting port number should be used only when non-default port is required
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetProvideAdditionalMarketSpecifiers Method

ISdkConfigurationBuilderSetProvideAdditionalMarketSpecifiers Method

This value is used to indicate if the sdk should add market specifiers for specific markets. Only used when building selection using UnifiedOdds ids. (default: true)

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
If this is set to true and the user uses UOF markets, when there are special cases (market 215, or $score in SOV/SBV template), sdk automatically tries to add appropriate specifier; if set to false, user will need to add this manually
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetSenderChannel Method

ISdkConfigurationBuilderSetSenderChannel Method

Sets the sender channel

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetSslServerName Method

ISdkConfigurationBuilderSetSslServerName Method

Sets the server name that will be used to check against SSL certificate

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetTicketCancellationResponseTimeout Method

ISdkConfigurationBuilderSetTicketCancellationResponseTimeout Method

Sets the ticket cancellation response timeout(ms)

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetTicketCashoutResponseTimeout Method

ISdkConfigurationBuilderSetTicketCashoutResponseTimeout Method

Sets the ticket cashout response timeout(ms)

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetTicketResponseTimeout Method

ISdkConfigurationBuilderSetTicketResponseTimeout Method

Sets the ticket response timeout(ms) (sets both live and prematch timeouts)

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetTicketResponseTimeoutLive Method

ISdkConfigurationBuilderSetTicketResponseTimeoutLive Method

Sets the ticket response timeout(ms) for tickets using "live" selectionId

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetTicketResponseTimeoutPrematch Method

ISdkConfigurationBuilderSetTicketResponseTimeoutPrematch Method

Sets the ticket response timeout(ms) for tickets using "prematch" selectionId

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetUfEnvironment Method

ISdkConfigurationBuilderSetUfEnvironment Method

Sets the uf environment

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetUsername Method

ISdkConfigurationBuilderSetUsername Method

Sets the username

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetUseSsl Method

ISdkConfigurationBuilderSetUseSsl Method

Sets the value indicating whether a secure connection to the message broker should be used

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


ISdkConfigurationBuilder.SetVirtualHost Method

ISdkConfigurationBuilderSetVirtualHost Method

Sets the vhost (format: '/vhost')

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfigurationBuilder Interface
Sportradar.MTS.SDK.API Namespace


MtsSdk Class

A IMtsSdk implementation acting as an entry point to the MTS SDK
Inheritance Hierarchy
SystemObject
Sportradar.MTS.SDK.APIMtsSdk

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The MtsSdk type exposes the following members.

Constructors
 | Name | Description
Public method | MtsSdk | Constructs a new instance of the MtsSdk class
Top
Properties
 | Name | Description
Public property | BuilderFactory | Gets the IBuilderFactory instance used to construct builders with some of the properties pre-loaded from the configuration
Public property | ClientApi | Gets the IMtsClientApi instance used to send requests to MTS REST API
Public property | ConnectionStatus | Gets the connection status.
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations
Public property | IsOpened | Gets a value indicating whether the current instance is opened
Public property | ReportManager | Gets a IReportManager instance used to get various reports
Top
Methods
 | Name | Description
Public method | Close | Closes the current IMtsSdk instance and disposes resources used by it
 | CreateConfigurationBuilder | Creates the ISdkConfigurationBuilder for building the ISdkConfiguration
Public method | Dispose | Disposes the current instance and resources associated with it
Protected method | Dispose(Boolean) | Disposes the current instance and resources associated with it
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
 | GetConfiguration | Constructs a ISdkConfiguration instance with information read from application configuration file
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | Open | Opens the current feed
Public method | SendTicket | Sends the ticket to the MTS server. The response will raise TicketResponseReceived event
Public method | SendTicketBlocking | Sends the ticket to the MTS server and wait for the response message on the feed
Public method | SendTicketCancelBlocking | Sends the cancel ticket to the MTS server and wait for the response message on the feed
Public method | SendTicketCashoutBlocking | Sends the cashout ticket to the MTS server and wait for the response message on the feed
Public method | SendTicketNonSrSettleBlocking | Sends the cashout ticket to the MTS server and wait for the response message on the feed
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | SendTicketFailed | Raised when the attempt to send ticket failed
Public event | TicketResponseReceived | Raised when the current instance of IMtsSdk received ITicketResponse
Public event | TicketResponseTimedOut | Raised when the current instance of IMtsSdk did not receive ITicketResponse within timeout
Public event | UnparsableTicketResponseReceived | Raised when a message which cannot be parsed is received
Top
See Also

Reference

Sportradar.MTS.SDK.API Namespace


MtsSdk Constructor

Constructs a new instance of the MtsSdk class

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk Properties

The MtsSdk type exposes the following members.

Properties
 | Name | Description
Public property | BuilderFactory | Gets the IBuilderFactory instance used to construct builders with some of the properties pre-loaded from the configuration
Public property | ClientApi | Gets the IMtsClientApi instance used to send requests to MTS REST API
Public property | ConnectionStatus | Gets the connection status.
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations
Public property | IsOpened | Gets a value indicating whether the current instance is opened
Public property | ReportManager | Gets a IReportManager instance used to get various reports
Top
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.BuilderFactory Property

MtsSdkBuilderFactory Property

Gets the IBuilderFactory instance used to construct builders with some of the properties pre-loaded from the configuration

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.ClientApi Property

MtsSdkClientApi Property

Gets the IMtsClientApi instance used to send requests to MTS REST API

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.ConnectionStatus Property

MtsSdkConnectionStatus Property

Gets the connection status.

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.CustomBetManager Property

MtsSdkCustomBetManager Property

Gets a ICustomBetManager instance used to perform various custom bet operations

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.IsOpened Property

MtsSdkIsOpened Property

Gets a value indicating whether the current instance is opened

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.ReportManager Property

MtsSdkReportManager Property

Gets a IReportManager instance used to get various reports

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk Methods

The MtsSdk type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current IMtsSdk instance and disposes resources used by it
 | CreateConfigurationBuilder | Creates the ISdkConfigurationBuilder for building the ISdkConfiguration
Public method | Dispose | Disposes the current instance and resources associated with it
Protected method | Dispose(Boolean) | Disposes the current instance and resources associated with it
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
 | GetConfiguration | Constructs a ISdkConfiguration instance with information read from application configuration file
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | Open | Opens the current feed
Public method | SendTicket | Sends the ticket to the MTS server. The response will raise TicketResponseReceived event
Public method | SendTicketBlocking | Sends the ticket to the MTS server and wait for the response message on the feed
Public method | SendTicketCancelBlocking | Sends the cancel ticket to the MTS server and wait for the response message on the feed
Public method | SendTicketCashoutBlocking | Sends the cashout ticket to the MTS server and wait for the response message on the feed
Public method | SendTicketNonSrSettleBlocking | Sends the cashout ticket to the MTS server and wait for the response message on the feed
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.Close Method

MtsSdkClose Method

Closes the current IMtsSdk instance and disposes resources used by it

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.CreateConfigurationBuilder Method

MtsSdkCreateConfigurationBuilder Method

Creates the ISdkConfigurationBuilder for building the ISdkConfiguration

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.Dispose Method

MtsSdkDispose Method

Overload List
 | Name | Description
Public method | Dispose | Disposes the current instance and resources associated with it
Protected method | Dispose(Boolean) | Disposes the current instance and resources associated with it
Top
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.Dispose Method

MtsSdkDispose Method

Disposes the current instance and resources associated with it

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Dispose Overload
Sportradar.MTS.SDK.API Namespace


MtsSdk.Dispose(Boolean) Method

MtsSdkDispose(Boolean) Method

Disposes the current instance and resources associated with it

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Dispose Overload
Sportradar.MTS.SDK.API Namespace


MtsSdk.GetConfiguration Method

MtsSdkGetConfiguration Method

Constructs a ISdkConfiguration instance with information read from application configuration file

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Exceptions
Exception | Condition
InvalidOperationException | The configuration could not be loaded, or the requested section does not exist in the config file
ConfigurationErrorsException | The section read from the configuration file is not valid
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.Open Method

MtsSdkOpen Method

Opens the current feed

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Exceptions
Exception | Condition
ObjectDisposedException | The feed is already disposed
InvalidOperationException | The feed is already opened
CommunicationException | Connection to the message broker failed, Probable Reason={Invalid or expired token}
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.SendTicket Method

MtsSdkSendTicket Method

Sends the ticket to the MTS server. The response will raise TicketResponseReceived event

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.SendTicketBlocking Method

MtsSdkSendTicketBlocking Method

Sends the ticket to the MTS server and wait for the response message on the feed

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.SendTicketCancelBlocking Method

MtsSdkSendTicketCancelBlocking Method

Sends the cancel ticket to the MTS server and wait for the response message on the feed

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.SendTicketCashoutBlocking Method

MtsSdkSendTicketCashoutBlocking Method

Sends the cashout ticket to the MTS server and wait for the response message on the feed

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.SendTicketNonSrSettleBlocking Method

MtsSdkSendTicketNonSrSettleBlocking Method

Sends the cashout ticket to the MTS server and wait for the response message on the feed

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk Events

The MtsSdk type exposes the following members.

Events
 | Name | Description
Public event | SendTicketFailed | Raised when the attempt to send ticket failed
Public event | TicketResponseReceived | Raised when the current instance of IMtsSdk received ITicketResponse
Public event | TicketResponseTimedOut | Raised when the current instance of IMtsSdk did not receive ITicketResponse within timeout
Public event | UnparsableTicketResponseReceived | Raised when a message which cannot be parsed is received
Top
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.SendTicketFailed Event

MtsSdkSendTicketFailed Event

Raised when the attempt to send ticket failed

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.TicketResponseReceived Event

MtsSdkTicketResponseReceived Event

Raised when the current instance of IMtsSdk received ITicketResponse

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.TicketResponseTimedOut Event

MtsSdkTicketResponseTimedOut Event

Raised when the current instance of IMtsSdk did not receive ITicketResponse within timeout

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


MtsSdk.UnparsableTicketResponseReceived Event

MtsSdkUnparsableTicketResponseReceived Event

Raised when a message which cannot be parsed is received

Namespace: Sportradar.MTS.SDK.API
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsSdk Class
Sportradar.MTS.SDK.API Namespace


Sportradar.MTS.SDK.Common Namespace

Classes
 | Class | Description
Public class | SdkLoggerFactory | Provides methods to get logger for specific LoggerType
Public class | SdkMetricsFactory | Provides methods to get IMetricsRoot to record sdk metrics
Interfaces
 | Interface | Description
Public interface | IAcknowledgeable | Defines a contract for classes used to provide acknowledgment
Public interface | IOpenable | Defines a contract implemented by classes which can be opened and closed
Enumerations
 | Enumeration | Description
Public enumeration | LoggerType | Enumeration of all possible types of logger used in SDK. Each can have unique settings in log4net.config file.


IAcknowledgeable Interface

Defines a contract for classes used to provide acknowledgment

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IAcknowledgeable type exposes the following members.

Methods
 | Name | Description
Public method | Acknowledge(Boolean) | Send acknowledgment back to MTS
Public method | Acknowledge(Boolean, Int32, Int32, String) | Send acknowledgment back to MTS
Top
See Also

Reference

Sportradar.MTS.SDK.Common Namespace


IAcknowledgeable Methods

The IAcknowledgeable type exposes the following members.

Methods
 | Name | Description
Public method | Acknowledge(Boolean) | Send acknowledgment back to MTS
Public method | Acknowledge(Boolean, Int32, Int32, String) | Send acknowledgment back to MTS
Top
See Also

Reference

IAcknowledgeable Interface
Sportradar.MTS.SDK.Common Namespace


IAcknowledgeable.Acknowledge Method

IAcknowledgeableAcknowledge Method

Overload List
 | Name | Description
Public method | Acknowledge(Boolean) | Send acknowledgment back to MTS
Public method | Acknowledge(Boolean, Int32, Int32, String) | Send acknowledgment back to MTS
Top
See Also

Reference

IAcknowledgeable Interface
Sportradar.MTS.SDK.Common Namespace


IAcknowledgeable.Acknowledge(Boolean) Method

IAcknowledgeableAcknowledge(Boolean) Method

Send acknowledgment back to MTS

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IAcknowledgeable Interface
Acknowledge Overload
Sportradar.MTS.SDK.Common Namespace


IAcknowledgeable.Acknowledge(Boolean, Int32, Int32, String) Method

IAcknowledgeableAcknowledge(Boolean, Int32, Int32, String) Method

Send acknowledgment back to MTS

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IAcknowledgeable Interface
Acknowledge Overload
Sportradar.MTS.SDK.Common Namespace


IOpenable Interface

Defines a contract implemented by classes which can be opened and closed

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IOpenable type exposes the following members.

Properties
 | Name | Description
Public property | IsOpened | Gets a value indicating whether the current instance is opened
Top
Methods
 | Name | Description
Public method | Close | Closes the current instance
Public method | Open | Opens the current instance
Top
See Also

Reference

Sportradar.MTS.SDK.Common Namespace


IOpenable Properties

The IOpenable type exposes the following members.

Properties
 | Name | Description
Public property | IsOpened | Gets a value indicating whether the current instance is opened
Top
See Also

Reference

IOpenable Interface
Sportradar.MTS.SDK.Common Namespace


IOpenable.IsOpened Property

IOpenableIsOpened Property

Gets a value indicating whether the current instance is opened

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IOpenable Interface
Sportradar.MTS.SDK.Common Namespace


IOpenable Methods

The IOpenable type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current instance
Public method | Open | Opens the current instance
Top
See Also

Reference

IOpenable Interface
Sportradar.MTS.SDK.Common Namespace


IOpenable.Close Method

IOpenableClose Method

Closes the current instance

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IOpenable Interface
Sportradar.MTS.SDK.Common Namespace


IOpenable.Open Method

IOpenableOpen Method

Opens the current instance

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IOpenable Interface
Sportradar.MTS.SDK.Common Namespace


LoggerType Enumeration

Enumeration of all possible types of logger used in SDK. Each can have unique settings in log4net.config file.

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Execution | 0 | The execution log
FeedTraffic | 1 | Log for the feed traffic
RestTraffic | 2 | Log for the rest traffic
ClientInteraction | 3 | The client interaction log
Cache | 4 | Log for the cache
Stats | 5 | Log for the SDK statistics
Remarks
Default is basic execution log
See Also

Reference

Sportradar.MTS.SDK.Common Namespace


SdkLoggerFactory Class

Provides methods to get logger for specific LoggerType
Inheritance Hierarchy
SystemObject
Sportradar.MTS.SDK.CommonSdkLoggerFactory

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The SdkLoggerFactory type exposes the following members.

Properties
Name | Description
LoggerFactory | Gets the logger factory
Top
Methods
Name | Description
GetLogger | Method for getting correct ILogger for specific logger type
GetLoggerForCache | Method for getting log4net.ILog for cache
GetLoggerForClientInteraction | Method for getting log4net.ILog for client iteration
GetLoggerForExecution | Method for getting log4net.ILog for execution
GetLoggerForFeedTraffic | Method for getting log4net.ILog for feed traffic
GetLoggerForRestTraffic | Method for getting log4net.ILog for rest traffic
GetLoggerForStats | Method for getting log4net.ILog for statistics
Top
See Also

Reference

Sportradar.MTS.SDK.Common Namespace


SdkLoggerFactory Properties

The SdkLoggerFactory type exposes the following members.

Properties
Name | Description
LoggerFactory | Gets the logger factory
Top
See Also

Reference

SdkLoggerFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkLoggerFactory.LoggerFactory Property

SdkLoggerFactoryLoggerFactory Property

Gets the logger factory

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

SdkLoggerFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkLoggerFactory Methods

The SdkLoggerFactory type exposes the following members.

Methods
Name | Description
GetLogger | Method for getting correct ILogger for specific logger type
GetLoggerForCache | Method for getting log4net.ILog for cache
GetLoggerForClientInteraction | Method for getting log4net.ILog for client iteration
GetLoggerForExecution | Method for getting log4net.ILog for execution
GetLoggerForFeedTraffic | Method for getting log4net.ILog for feed traffic
GetLoggerForRestTraffic | Method for getting log4net.ILog for rest traffic
GetLoggerForStats | Method for getting log4net.ILog for statistics
Top
See Also

Reference

SdkLoggerFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkLoggerFactory.GetLogger Method

SdkLoggerFactoryGetLogger Method

Method for getting correct ILogger for specific logger type

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

SdkLoggerFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkLoggerFactory.GetLoggerForCache Method

SdkLoggerFactoryGetLoggerForCache Method

Method for getting log4net.ILog for cache

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

SdkLoggerFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkLoggerFactory.GetLoggerForClientInteraction Method

SdkLoggerFactoryGetLoggerForClientInteraction Method

Method for getting log4net.ILog for client iteration

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

SdkLoggerFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkLoggerFactory.GetLoggerForExecution Method

SdkLoggerFactoryGetLoggerForExecution Method

Method for getting log4net.ILog for execution

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

SdkLoggerFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkLoggerFactory.GetLoggerForFeedTraffic Method

SdkLoggerFactoryGetLoggerForFeedTraffic Method

Method for getting log4net.ILog for feed traffic

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

SdkLoggerFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkLoggerFactory.GetLoggerForRestTraffic Method

SdkLoggerFactoryGetLoggerForRestTraffic Method

Method for getting log4net.ILog for rest traffic

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

SdkLoggerFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkLoggerFactory.GetLoggerForStats Method

SdkLoggerFactoryGetLoggerForStats Method

Method for getting log4net.ILog for statistics

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

SdkLoggerFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkMetricsFactory Class

Provides methods to get IMetricsRoot to record sdk metrics
Inheritance Hierarchy
SystemObject
Sportradar.MTS.SDK.CommonSdkMetricsFactory

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The SdkMetricsFactory type exposes the following members.

Properties
Name | Description
MetricsRoot | Gets the metrics root
Top
Methods
Name | Description
GetMeasure | Method for getting IMeasureMetrics
Top
See Also

Reference

Sportradar.MTS.SDK.Common Namespace


SdkMetricsFactory Properties

The SdkMetricsFactory type exposes the following members.

Properties
Name | Description
MetricsRoot | Gets the metrics root
Top
See Also

Reference

SdkMetricsFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkMetricsFactory.MetricsRoot Property

SdkMetricsFactoryMetricsRoot Property

Gets the metrics root

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

SdkMetricsFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkMetricsFactory Methods

The SdkMetricsFactory type exposes the following members.

Methods
Name | Description
GetMeasure | Method for getting IMeasureMetrics
Top
See Also

Reference

SdkMetricsFactory Class
Sportradar.MTS.SDK.Common Namespace


SdkMetricsFactory.GetMeasure Method

SdkMetricsFactoryGetMeasure Method

Method for getting IMeasureMetrics

Namespace: Sportradar.MTS.SDK.Common
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

SdkMetricsFactory Class
Sportradar.MTS.SDK.Common Namespace


Sportradar.MTS.SDK.Common.Exceptions Namespace

Classes
 | Class | Description
Public class | CacheItemNotFoundException | An exception thrown by the SDK cache components when the requested key was not found in the cache
Public class | CommunicationException | An exception thrown by the SDK when an error occurred while communicating with external source (Feed REST-ful API)
Public class | DeserializationException | An exception thrown by the SDK when a deserialization of the xml received from the feed fails
Public class | FeedSdkException | A base class for all exceptions thrown by the feed SDK
Public class | MappingException | An exception thrown by the SDK when the entity received from the feed could not be mapped to entity used by the SDK
Public class | MtsApiException | An exception thrown by the SDK when there is a problem with communication with MTS API
Public class | MtsReportException | An exception thrown by the SDK when there is a problem with communication via IReportManager
Public class | RabbitMqException | An exception thrown by the SDK when there is a problem with communication with rabbit mq
Public class | ResponseTimeoutException | An exception thrown by the SDK when the timeout for receiving response expired


CacheItemNotFoundException Class

An exception thrown by the SDK cache components when the requested key was not found in the cache
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.MTS.SDK.Common.ExceptionsFeedSdkException
Sportradar.MTS.SDK.Common.ExceptionsCacheItemNotFoundException

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The CacheItemNotFoundException type exposes the following members.

Constructors
 | Name | Description
Public method | CacheItemNotFoundException | Initializes a new instance of the CacheItemNotFoundException class
Protected method | CacheItemNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the CacheItemNotFoundException class
Public method | CacheItemNotFoundException(String, String, Exception) | Initializes a new instance of the CacheItemNotFoundException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Key | Gets the key requested key
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance (Overrides ExceptionToString)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.MTS.SDK.Common.Exceptions Namespace
FeedSdkException


CacheItemNotFoundException Constructor

Overload List
 | Name | Description
Public method | CacheItemNotFoundException | Initializes a new instance of the CacheItemNotFoundException class
Protected method | CacheItemNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the CacheItemNotFoundException class
Public method | CacheItemNotFoundException(String, String, Exception) | Initializes a new instance of the CacheItemNotFoundException class
Top
See Also

Reference

CacheItemNotFoundException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CacheItemNotFoundException Constructor

Initializes a new instance of the CacheItemNotFoundException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CacheItemNotFoundException Class
CacheItemNotFoundException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


CacheItemNotFoundException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the CacheItemNotFoundException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CacheItemNotFoundException Class
CacheItemNotFoundException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


CacheItemNotFoundException(String, String, Exception) Constructor

Initializes a new instance of the CacheItemNotFoundException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CacheItemNotFoundException Class
CacheItemNotFoundException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


CacheItemNotFoundException Properties

The CacheItemNotFoundException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Key | Gets the key requested key
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

CacheItemNotFoundException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CacheItemNotFoundException.Key Property

CacheItemNotFoundExceptionKey Property

Gets the key requested key

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CacheItemNotFoundException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CacheItemNotFoundException Methods

The CacheItemNotFoundException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance (Overrides ExceptionToString)
Top
See Also

Reference

CacheItemNotFoundException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CacheItemNotFoundException.GetObjectData Method

CacheItemNotFoundExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CacheItemNotFoundException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CacheItemNotFoundException.ToString Method

CacheItemNotFoundExceptionToString Method

Returns a String that represents this instance

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CacheItemNotFoundException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CacheItemNotFoundException Events

The CacheItemNotFoundException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

CacheItemNotFoundException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException Class

An exception thrown by the SDK when an error occurred while communicating with external source (Feed REST-ful API)
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.MTS.SDK.Common.ExceptionsFeedSdkException
Sportradar.MTS.SDK.Common.ExceptionsCommunicationException

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The CommunicationException type exposes the following members.

Constructors
 | Name | Description
Public method | CommunicationException | Initializes a new instance of the CommunicationException class
Protected method | CommunicationException(SerializationInfo, StreamingContext) | Initializes a new instance of the CommunicationException class
Public method | CommunicationException(String, String, Exception) | Initializes a new instance of the CommunicationException class
Public method | CommunicationException(String, String, HttpStatusCode, Exception) | Initializes a new instance of the CommunicationException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | Url | Gets the String representation of the url specifying the resource which was being accessed
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ExceptionToString)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
Fields
 | Name | Description
Public field | ResponseCode | Gets the HttpStatusCode specifying the response's status code
Top
See Also

Reference

Sportradar.MTS.SDK.Common.Exceptions Namespace
FeedSdkException


CommunicationException Constructor

Overload List
 | Name | Description
Public method | CommunicationException | Initializes a new instance of the CommunicationException class
Protected method | CommunicationException(SerializationInfo, StreamingContext) | Initializes a new instance of the CommunicationException class
Public method | CommunicationException(String, String, Exception) | Initializes a new instance of the CommunicationException class
Public method | CommunicationException(String, String, HttpStatusCode, Exception) | Initializes a new instance of the CommunicationException class
Top
See Also

Reference

CommunicationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException Constructor

Initializes a new instance of the CommunicationException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CommunicationException Class
CommunicationException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the CommunicationException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CommunicationException Class
CommunicationException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException(String, String, Exception) Constructor

Initializes a new instance of the CommunicationException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CommunicationException Class
CommunicationException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException(String, String, HttpStatusCode, Exception) Constructor

Initializes a new instance of the CommunicationException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CommunicationException Class
CommunicationException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException Properties

The CommunicationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | Url | Gets the String representation of the url specifying the resource which was being accessed
Top
See Also

Reference

CommunicationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException.Url Property

CommunicationExceptionUrl Property

Gets the String representation of the url specifying the resource which was being accessed

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CommunicationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException Methods

The CommunicationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ExceptionToString)
Top
See Also

Reference

CommunicationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException.GetObjectData Method

CommunicationExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CommunicationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException.ToString Method

CommunicationExceptionToString Method

Returns a String that represents this instance.

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CommunicationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException Events

The CommunicationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

CommunicationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException Fields

The CommunicationException type exposes the following members.

Fields
 | Name | Description
Public field | ResponseCode | Gets the HttpStatusCode specifying the response's status code
Top
See Also

Reference

CommunicationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


CommunicationException.ResponseCode Field

CommunicationExceptionResponseCode Field

Gets the HttpStatusCode specifying the response's status code

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

CommunicationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


DeserializationException Class

An exception thrown by the SDK when a deserialization of the xml received from the feed fails
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.MTS.SDK.Common.ExceptionsFeedSdkException
Sportradar.MTS.SDK.Common.ExceptionsDeserializationException

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The DeserializationException type exposes the following members.

Constructors
 | Name | Description
Public method | DeserializationException | Initializes a new instance of the DeserializationException class
Protected method | DeserializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the DeserializationException class
Public method | DeserializationException(String, Exception) | Initializes a new instance of the DeserializationException class
Public method | DeserializationException(String, String, String, Exception) | Initializes a new instance of the DeserializationException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | RootElementName | Gets the name of the root xml element associated with the exception or a null reference if element name could not be determined
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | Xml | Gets the data which could not be deserialized
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents this instance (Overrides ExceptionToString)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.MTS.SDK.Common.Exceptions Namespace
FeedSdkException


DeserializationException Constructor

Overload List
 | Name | Description
Public method | DeserializationException | Initializes a new instance of the DeserializationException class
Protected method | DeserializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the DeserializationException class
Public method | DeserializationException(String, Exception) | Initializes a new instance of the DeserializationException class
Public method | DeserializationException(String, String, String, Exception) | Initializes a new instance of the DeserializationException class
Top
See Also

Reference

DeserializationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


DeserializationException Constructor

Initializes a new instance of the DeserializationException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

DeserializationException Class
DeserializationException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


DeserializationException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the DeserializationException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

DeserializationException Class
DeserializationException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


DeserializationException(String, Exception) Constructor

Initializes a new instance of the DeserializationException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

DeserializationException Class
DeserializationException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


DeserializationException(String, String, String, Exception) Constructor

Initializes a new instance of the DeserializationException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

DeserializationException Class
DeserializationException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


DeserializationException Properties

The DeserializationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | RootElementName | Gets the name of the root xml element associated with the exception or a null reference if element name could not be determined
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | Xml | Gets the data which could not be deserialized
Top
See Also

Reference

DeserializationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


DeserializationException.RootElementName Property

DeserializationExceptionRootElementName Property

Gets the name of the root xml element associated with the exception or a null reference if element name could not be determined

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

DeserializationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


DeserializationException.Xml Property

DeserializationExceptionXml Property

Gets the data which could not be deserialized

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

DeserializationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


DeserializationException Methods

The DeserializationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents this instance (Overrides ExceptionToString)
Top
See Also

Reference

DeserializationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


DeserializationException.GetObjectData Method

DeserializationExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

DeserializationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


DeserializationException.ToString Method

DeserializationExceptionToString Method

Returns a string that represents this instance

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

DeserializationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


DeserializationException Events

The DeserializationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

DeserializationException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


FeedSdkException Class

A base class for all exceptions thrown by the feed SDK
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.MTS.SDK.Common.ExceptionsFeedSdkException
More

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The FeedSdkException type exposes the following members.

Constructors
 | Name | Description
Protected method | FeedSdkException | Initializes a new instance of the FeedSdkException class
Protected method | FeedSdkException(SerializationInfo, StreamingContext) | Initializes a new instance of the FeedSdkException class
Protected method | FeedSdkException(String, Exception) | Initializes a new instance of the FeedSdkException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.MTS.SDK.Common.Exceptions Namespace
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.MTS.SDK.Common.ExceptionsFeedSdkException
Sportradar.MTS.SDK.Common.ExceptionsCacheItemNotFoundException
Sportradar.MTS.SDK.Common.ExceptionsCommunicationException
Sportradar.MTS.SDK.Common.ExceptionsDeserializationException
Sportradar.MTS.SDK.Common.ExceptionsMappingException
Sportradar.MTS.SDK.Common.ExceptionsMtsApiException
Sportradar.MTS.SDK.Common.ExceptionsMtsReportException
Sportradar.MTS.SDK.Common.ExceptionsRabbitMqException
Sportradar.MTS.SDK.Common.ExceptionsResponseTimeoutException


FeedSdkException Constructor

Overload List
 | Name | Description
Protected method | FeedSdkException | Initializes a new instance of the FeedSdkException class
Protected method | FeedSdkException(SerializationInfo, StreamingContext) | Initializes a new instance of the FeedSdkException class
Protected method | FeedSdkException(String, Exception) | Initializes a new instance of the FeedSdkException class
Top
See Also

Reference

FeedSdkException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


FeedSdkException Constructor

Initializes a new instance of the FeedSdkException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

FeedSdkException Class
FeedSdkException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


FeedSdkException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the FeedSdkException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

FeedSdkException Class
FeedSdkException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


FeedSdkException(String, Exception) Constructor

Initializes a new instance of the FeedSdkException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

FeedSdkException Class
FeedSdkException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


FeedSdkException Properties

The FeedSdkException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

FeedSdkException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


FeedSdkException Methods

The FeedSdkException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

FeedSdkException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


FeedSdkException Events

The FeedSdkException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

FeedSdkException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MappingException Class

An exception thrown by the SDK when the entity received from the feed could not be mapped to entity used by the SDK
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.MTS.SDK.Common.ExceptionsFeedSdkException
Sportradar.MTS.SDK.Common.ExceptionsMappingException

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The MappingException type exposes the following members.

Constructors
 | Name | Description
Protected method | MappingException(SerializationInfo, StreamingContext) | Initializes a new instance of the MappingException class
Public method | MappingException(String, String, String, String, Exception) | Initializes a new instance of the MappingException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | PropertyName | Gets the name of the property which caused the exception
Public property | PropertyValue | Gets the String representation of the property value which caused the exception.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | TargetTypeName | Gets the TargetTypeName of the target entity
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents this instance (Overrides ExceptionToString)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.MTS.SDK.Common.Exceptions Namespace
FeedSdkException


MappingException Constructor

Overload List
 | Name | Description
Protected method | MappingException(SerializationInfo, StreamingContext) | Initializes a new instance of the MappingException class
Public method | MappingException(String, String, String, String, Exception) | Initializes a new instance of the MappingException class
Top
See Also

Reference

MappingException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MappingException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the MappingException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MappingException Class
MappingException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


MappingException(String, String, String, String, Exception) Constructor

Initializes a new instance of the MappingException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MappingException Class
MappingException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


MappingException Properties

The MappingException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | PropertyName | Gets the name of the property which caused the exception
Public property | PropertyValue | Gets the String representation of the property value which caused the exception.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | TargetTypeName | Gets the TargetTypeName of the target entity
Top
See Also

Reference

MappingException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MappingException.PropertyName Property

MappingExceptionPropertyName Property

Gets the name of the property which caused the exception

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MappingException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MappingException.PropertyValue Property

MappingExceptionPropertyValue Property

Gets the String representation of the property value which caused the exception.

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MappingException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MappingException.TargetTypeName Property

MappingExceptionTargetTypeName Property

Gets the TargetTypeName of the target entity

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MappingException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MappingException Methods

The MappingException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents this instance (Overrides ExceptionToString)
Top
See Also

Reference

MappingException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MappingException.GetObjectData Method

MappingExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MappingException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MappingException.ToString Method

MappingExceptionToString Method

Returns a string that represents this instance

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MappingException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MappingException Events

The MappingException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

MappingException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MtsApiException Class

An exception thrown by the SDK when there is a problem with communication with MTS API
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.MTS.SDK.Common.ExceptionsFeedSdkException
Sportradar.MTS.SDK.Common.ExceptionsMtsApiException

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The MtsApiException type exposes the following members.

Constructors
 | Name | Description
Protected method | MtsApiException(SerializationInfo, StreamingContext) | Initializes a new instance of the MtsApiException class
Public method | MtsApiException(String, Exception) | Initializes a new instance of the MtsApiException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.MTS.SDK.Common.Exceptions Namespace
FeedSdkException


MtsApiException Constructor

Overload List
 | Name | Description
Protected method | MtsApiException(SerializationInfo, StreamingContext) | Initializes a new instance of the MtsApiException class
Public method | MtsApiException(String, Exception) | Initializes a new instance of the MtsApiException class
Top
See Also

Reference

MtsApiException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MtsApiException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the MtsApiException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsApiException Class
MtsApiException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


MtsApiException(String, Exception) Constructor

Initializes a new instance of the MtsApiException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsApiException Class
MtsApiException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


MtsApiException Properties

The MtsApiException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

MtsApiException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MtsApiException Methods

The MtsApiException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

MtsApiException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MtsApiException Events

The MtsApiException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

MtsApiException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MtsReportException Class

An exception thrown by the SDK when there is a problem with communication via IReportManager
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.MTS.SDK.Common.ExceptionsFeedSdkException
Sportradar.MTS.SDK.Common.ExceptionsMtsReportException

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The MtsReportException type exposes the following members.

Constructors
 | Name | Description
Protected method | MtsReportException(SerializationInfo, StreamingContext) | Initializes a new instance of the MtsReportException class
Public method | MtsReportException(String, Exception) | Initializes a new instance of the MtsReportException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.MTS.SDK.Common.Exceptions Namespace
FeedSdkException


MtsReportException Constructor

Overload List
 | Name | Description
Protected method | MtsReportException(SerializationInfo, StreamingContext) | Initializes a new instance of the MtsReportException class
Public method | MtsReportException(String, Exception) | Initializes a new instance of the MtsReportException class
Top
See Also

Reference

MtsReportException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MtsReportException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the MtsReportException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsReportException Class
MtsReportException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


MtsReportException(String, Exception) Constructor

Initializes a new instance of the MtsReportException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MtsReportException Class
MtsReportException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


MtsReportException Properties

The MtsReportException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

MtsReportException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MtsReportException Methods

The MtsReportException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

MtsReportException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


MtsReportException Events

The MtsReportException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

MtsReportException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


RabbitMqException Class

An exception thrown by the SDK when there is a problem with communication with rabbit mq
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.MTS.SDK.Common.ExceptionsFeedSdkException
Sportradar.MTS.SDK.Common.ExceptionsRabbitMqException

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The RabbitMqException type exposes the following members.

Constructors
 | Name | Description
Protected method | RabbitMqException(SerializationInfo, StreamingContext) | Initializes a new instance of the RabbitMqException class
Public method | RabbitMqException(String, Exception) | Initializes a new instance of the RabbitMqException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.MTS.SDK.Common.Exceptions Namespace
FeedSdkException


RabbitMqException Constructor

Overload List
 | Name | Description
Protected method | RabbitMqException(SerializationInfo, StreamingContext) | Initializes a new instance of the RabbitMqException class
Public method | RabbitMqException(String, Exception) | Initializes a new instance of the RabbitMqException class
Top
See Also

Reference

RabbitMqException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


RabbitMqException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the RabbitMqException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

RabbitMqException Class
RabbitMqException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


RabbitMqException(String, Exception) Constructor

Initializes a new instance of the RabbitMqException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

RabbitMqException Class
RabbitMqException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


RabbitMqException Properties

The RabbitMqException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

RabbitMqException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


RabbitMqException Methods

The RabbitMqException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

RabbitMqException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


RabbitMqException Events

The RabbitMqException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

RabbitMqException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


ResponseTimeoutException Class

An exception thrown by the SDK when the timeout for receiving response expired
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.MTS.SDK.Common.ExceptionsFeedSdkException
Sportradar.MTS.SDK.Common.ExceptionsResponseTimeoutException

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ResponseTimeoutException type exposes the following members.

Constructors
 | Name | Description
Protected method | ResponseTimeoutException(SerializationInfo, StreamingContext) | Initializes a new instance of the ResponseTimeoutException class
Public method | ResponseTimeoutException(String, Exception) | Initializes a new instance of the ResponseTimeoutException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.MTS.SDK.Common.Exceptions Namespace
FeedSdkException


ResponseTimeoutException Constructor

Overload List
 | Name | Description
Protected method | ResponseTimeoutException(SerializationInfo, StreamingContext) | Initializes a new instance of the ResponseTimeoutException class
Public method | ResponseTimeoutException(String, Exception) | Initializes a new instance of the ResponseTimeoutException class
Top
See Also

Reference

ResponseTimeoutException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


ResponseTimeoutException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the ResponseTimeoutException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ResponseTimeoutException Class
ResponseTimeoutException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


ResponseTimeoutException(String, Exception) Constructor

Initializes a new instance of the ResponseTimeoutException class

Namespace: Sportradar.MTS.SDK.Common.Exceptions
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ResponseTimeoutException Class
ResponseTimeoutException Overload
Sportradar.MTS.SDK.Common.Exceptions Namespace


ResponseTimeoutException Properties

The ResponseTimeoutException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

ResponseTimeoutException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


ResponseTimeoutException Methods

The ResponseTimeoutException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

ResponseTimeoutException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


ResponseTimeoutException Events

The ResponseTimeoutException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

ResponseTimeoutException Class
Sportradar.MTS.SDK.Common.Exceptions Namespace


Sportradar.MTS.SDK.Entities Namespace

Interfaces
 | Interface | Description
Public interface | ISdkConfiguration | Defines a contract implemented by classes representing configuration


ISdkConfiguration Interface

Defines a contract implemented by classes representing configuration

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ISdkConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AccessToken | Gets the access token for the UF feed (only necessary if UF selections will be build)
Public property | BookmakerId | Gets the BookmakerId associated with the current configuration or 0 if none is provided
Public property | Channel | Gets the SenderChannel specifying the associated channel or a null reference if none is specified
Public property | Currency | Gets the default currency associated with the current configuration or a null reference if none is provided
Public property | ExclusiveConsumer | Should the rabbit consumer channel be exclusive
Public property | Host | Gets a value specifying the host name of the AMQP broker
Public property | KeycloakHost | Gets the Keycloak host for authorization
Public property | KeycloakPassword | Gets the password used to connect authenticate to Keycloak
Public property | KeycloakSecret | Gets the secret used to connect authenticate to Keycloak
Public property | KeycloakUsername | Gets the username used to connect authenticate to Keycloak
Public property | LimitId | Gets the channel identifier associated with the current configuration or 0 if none is provided
Public property | MtsClientApiHost | Gets the Client API host
Public property | NodeId | Gets a nodeId
Public property | Password | Gets a password used when establishing connection to the AMQP broker
Public property | Port | Gets the port used to connect to AMQP broker
Public property | ProvideAdditionalMarketSpecifiers | Gets a value indicating whether additional market specifiers should be added
Public property | SslServerName | Gets the server name that will be used to check against SSL certificate
Public property | StatisticsEnabled | Gets a value indication whether statistics collection is enabled
Public property | StatisticsRecordLimit | Gets the limit of records for automatically writing statistics
Public property | StatisticsTimeout | Gets the timeout for automatically collecting statistics
Public property | TicketCancellationResponseTimeout | Gets the ticket cancellation response timeout(ms)
Public property | TicketCashoutResponseTimeout | Gets the ticket cashout response timeout(ms)
Public property | TicketNonSrSettleResponseTimeout | Gets the ticket non-sportradar settle response timeout(ms)
Public property | TicketResponseTimeoutLive | Gets the ticket response timeout(ms) for tickets using "live" selectionId
Public property | TicketResponseTimeoutPrematch | Gets the ticket response timeout(ms) for tickets using "prematch" selectionId
Public property | UfEnvironment | Gets the UF environment for the UF feed (only necessary if UF selections will be build)
Public property | Username | Gets an username used when establishing connection to the AMQP broker
Public property | UseSsl | Gets a value specifying whether the connection to AMQP broker should use SSL encryption
Public property | VirtualHost | Gets a value specifying the virtual host name of the AMQP broker
Top
See Also

Reference

Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration Properties

The ISdkConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AccessToken | Gets the access token for the UF feed (only necessary if UF selections will be build)
Public property | BookmakerId | Gets the BookmakerId associated with the current configuration or 0 if none is provided
Public property | Channel | Gets the SenderChannel specifying the associated channel or a null reference if none is specified
Public property | Currency | Gets the default currency associated with the current configuration or a null reference if none is provided
Public property | ExclusiveConsumer | Should the rabbit consumer channel be exclusive
Public property | Host | Gets a value specifying the host name of the AMQP broker
Public property | KeycloakHost | Gets the Keycloak host for authorization
Public property | KeycloakPassword | Gets the password used to connect authenticate to Keycloak
Public property | KeycloakSecret | Gets the secret used to connect authenticate to Keycloak
Public property | KeycloakUsername | Gets the username used to connect authenticate to Keycloak
Public property | LimitId | Gets the channel identifier associated with the current configuration or 0 if none is provided
Public property | MtsClientApiHost | Gets the Client API host
Public property | NodeId | Gets a nodeId
Public property | Password | Gets a password used when establishing connection to the AMQP broker
Public property | Port | Gets the port used to connect to AMQP broker
Public property | ProvideAdditionalMarketSpecifiers | Gets a value indicating whether additional market specifiers should be added
Public property | SslServerName | Gets the server name that will be used to check against SSL certificate
Public property | StatisticsEnabled | Gets a value indication whether statistics collection is enabled
Public property | StatisticsRecordLimit | Gets the limit of records for automatically writing statistics
Public property | StatisticsTimeout | Gets the timeout for automatically collecting statistics
Public property | TicketCancellationResponseTimeout | Gets the ticket cancellation response timeout(ms)
Public property | TicketCashoutResponseTimeout | Gets the ticket cashout response timeout(ms)
Public property | TicketNonSrSettleResponseTimeout | Gets the ticket non-sportradar settle response timeout(ms)
Public property | TicketResponseTimeoutLive | Gets the ticket response timeout(ms) for tickets using "live" selectionId
Public property | TicketResponseTimeoutPrematch | Gets the ticket response timeout(ms) for tickets using "prematch" selectionId
Public property | UfEnvironment | Gets the UF environment for the UF feed (only necessary if UF selections will be build)
Public property | Username | Gets an username used when establishing connection to the AMQP broker
Public property | UseSsl | Gets a value specifying whether the connection to AMQP broker should use SSL encryption
Public property | VirtualHost | Gets a value specifying the virtual host name of the AMQP broker
Top
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.AccessToken Property

ISdkConfigurationAccessToken Property

Gets the access token for the UF feed (only necessary if UF selections will be build)

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.BookmakerId Property

ISdkConfigurationBookmakerId Property

Gets the BookmakerId associated with the current configuration or 0 if none is provided

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.Channel Property

ISdkConfigurationChannel Property

Gets the SenderChannel specifying the associated channel or a null reference if none is specified

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.Currency Property

ISdkConfigurationCurrency Property

Gets the default currency associated with the current configuration or a null reference if none is provided

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.ExclusiveConsumer Property

ISdkConfigurationExclusiveConsumer Property

Should the rabbit consumer channel be exclusive

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.Host Property

ISdkConfigurationHost Property

Gets a value specifying the host name of the AMQP broker

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.KeycloakHost Property

ISdkConfigurationKeycloakHost Property

Gets the Keycloak host for authorization

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.KeycloakPassword Property

ISdkConfigurationKeycloakPassword Property

Gets the password used to connect authenticate to Keycloak

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.KeycloakSecret Property

ISdkConfigurationKeycloakSecret Property

Gets the secret used to connect authenticate to Keycloak

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.KeycloakUsername Property

ISdkConfigurationKeycloakUsername Property

Gets the username used to connect authenticate to Keycloak

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.LimitId Property

ISdkConfigurationLimitId Property

Gets the channel identifier associated with the current configuration or 0 if none is provided

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.MtsClientApiHost Property

ISdkConfigurationMtsClientApiHost Property

Gets the Client API host

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.NodeId Property

ISdkConfigurationNodeId Property

Gets a nodeId

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.Password Property

ISdkConfigurationPassword Property

Gets a password used when establishing connection to the AMQP broker

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.Port Property

ISdkConfigurationPort Property

Gets the port used to connect to AMQP broker

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.ProvideAdditionalMarketSpecifiers Property

ISdkConfigurationProvideAdditionalMarketSpecifiers Property

Gets a value indicating whether additional market specifiers should be added

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
If this is set to true and the user uses UOF markets, when there are special cases (market 215, or $score in SOV/SBV template), sdk automatically tries to add appropriate specifier; if set to false, user will need to add this manually
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.SslServerName Property

ISdkConfigurationSslServerName Property

Gets the server name that will be used to check against SSL certificate

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.StatisticsEnabled Property

ISdkConfigurationStatisticsEnabled Property

Gets a value indication whether statistics collection is enabled

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.StatisticsRecordLimit Property

ISdkConfigurationStatisticsRecordLimit Property

Gets the limit of records for automatically writing statistics

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.StatisticsTimeout Property

ISdkConfigurationStatisticsTimeout Property

Gets the timeout for automatically collecting statistics

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.TicketCancellationResponseTimeout Property

ISdkConfigurationTicketCancellationResponseTimeout Property

Gets the ticket cancellation response timeout(ms)

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.TicketCashoutResponseTimeout Property

ISdkConfigurationTicketCashoutResponseTimeout Property

Gets the ticket cashout response timeout(ms)

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.TicketNonSrSettleResponseTimeout Property

ISdkConfigurationTicketNonSrSettleResponseTimeout Property

Gets the ticket non-sportradar settle response timeout(ms)

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.TicketResponseTimeoutLive Property

ISdkConfigurationTicketResponseTimeoutLive Property

Gets the ticket response timeout(ms) for tickets using "live" selectionId

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.TicketResponseTimeoutPrematch Property

ISdkConfigurationTicketResponseTimeoutPrematch Property

Gets the ticket response timeout(ms) for tickets using "prematch" selectionId

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.UfEnvironment Property

ISdkConfigurationUfEnvironment Property

Gets the UF environment for the UF feed (only necessary if UF selections will be build)

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.Username Property

ISdkConfigurationUsername Property

Gets an username used when establishing connection to the AMQP broker

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.UseSsl Property

ISdkConfigurationUseSsl Property

Gets a value specifying whether the connection to AMQP broker should use SSL encryption

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


ISdkConfiguration.VirtualHost Property

ISdkConfigurationVirtualHost Property

Gets a value specifying the virtual host name of the AMQP broker

Namespace: Sportradar.MTS.SDK.Entities
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkConfiguration Interface
Sportradar.MTS.SDK.Entities Namespace


Sportradar.MTS.SDK.Entities.Builders Namespace

Interfaces
 | Interface | Description
Public interface | IBetBuilder | Defines a contract for classes implementing builder for IBet
Public interface | IBuilderFactory | Defines a contract used to construct builder instances used when constructing tickets and it's associated entities
Public interface | ICustomBetSelectionBuilder | Defines a contract for classes building a ICustomBetSelectionBuilder Implements the ISdkTicketBuilder
Public interface | IEndCustomerBuilder | Defines a contract for classes building IEndCustomer
Public interface | ISdkTicketBuilder | Defines a contract for classes implementing any ticket builder
Public interface | ISelectionBuilder | Defines a contract for classes implementing builder for ISelection
Public interface | ISenderBuilder | Defines a contract for classes implementing builder for ISender
Public interface | ISimpleBuilderFactory | Defines a contract used to construct simple builder instances(those not needing configuration) used when constructing tickets and it's associated entities
Public interface | ITicketAckBuilder | Defines a contract for classes implementing builder for ITicketAckBuilder
Public interface | ITicketAltStakeBuilder | Defines a contract for classes implementing builder for alternative stake ITicket
Public interface | ITicketBuilder | Defines a contract for classes implementing builder for ITicket
Public interface | ITicketCancelAckBuilder | Defines a contract for classes implementing builder for ITicketCancelAckBuilder
Public interface | ITicketCancelBuilder | Defines a contract for classes building a ITicketCancel
Public interface | ITicketCashoutBuilder | Defines a contract for classes building a ITicketCashout
Public interface | ITicketNonSrSettleBuilder | Defines a contract for classes building a ITicketNonSrSettleBuilder Implements the ISdkTicketBuilder
Public interface | ITicketReofferBuilder | Defines a contract for classes implementing builder for ITicket reoffer
Public interface | ITicketReofferCancelBuilder | Defines a contract for classes building a ITicketReofferCancel


IBetBuilder Interface

Defines a contract for classes implementing builder for IBet

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IBetBuilder type exposes the following members.

Properties
 | Name | Description
Public property | GetSelectedSystems | Gets the array of selected systems
Top
Methods
 | Name | Description
Public method | AddSelectedSystem | Add system to SelectedSystems
Public method | AddSelection | Adds the selection
Public method | Build | Builds the IBet
Public method | GetSelections | Gets the selections
Public method | SetBetBonus | Sets the IBetBonus
Public method | SetBetId | Sets the bet id
Public method | SetCalculationOdds | Sets the odds calculated for custom bet multiplied by 10_000 and rounded to int value
Public method | SetCustomBet | Sets the flag if bet is a custom bet (optional, default false)
Public method | SetEntireStake(Int64) | Sets the IStake
Public method | SetEntireStake(Int64, StakeType) | Sets the IStake
Public method | SetFreeStake | Sets the IFreeStake
Public method | SetReofferRefId | Sets the reoffer reference bet id
Public method | SetStake(Int64) | Sets the IStake
Public method | SetStake(Int64, StakeType) | Sets the IStake
Public method | SetSumOfWins | Sets the sum of all wins for all generated combinations for this bet (in ticket currency, used for validation)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder Properties

The IBetBuilder type exposes the following members.

Properties
 | Name | Description
Public property | GetSelectedSystems | Gets the array of selected systems
Top
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.GetSelectedSystems Property

IBetBuilderGetSelectedSystems Property

Gets the array of selected systems

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder Methods

The IBetBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddSelectedSystem | Add system to SelectedSystems
Public method | AddSelection | Adds the selection
Public method | Build | Builds the IBet
Public method | GetSelections | Gets the selections
Public method | SetBetBonus | Sets the IBetBonus
Public method | SetBetId | Sets the bet id
Public method | SetCalculationOdds | Sets the odds calculated for custom bet multiplied by 10_000 and rounded to int value
Public method | SetCustomBet | Sets the flag if bet is a custom bet (optional, default false)
Public method | SetEntireStake(Int64) | Sets the IStake
Public method | SetEntireStake(Int64, StakeType) | Sets the IStake
Public method | SetFreeStake | Sets the IFreeStake
Public method | SetReofferRefId | Sets the reoffer reference bet id
Public method | SetStake(Int64) | Sets the IStake
Public method | SetStake(Int64, StakeType) | Sets the IStake
Public method | SetSumOfWins | Sets the sum of all wins for all generated combinations for this bet (in ticket currency, used for validation)
Top
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.AddSelectedSystem Method

IBetBuilderAddSelectedSystem Method

Add system to SelectedSystems

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.AddSelection Method

IBetBuilderAddSelection Method

Adds the selection

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.Build Method

IBetBuilderBuild Method

Builds the IBet

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.GetSelections Method

IBetBuilderGetSelections Method

Gets the selections

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetBetBonus Method

IBetBuilderSetBetBonus Method

Sets the IBetBonus

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetBetId Method

IBetBuilderSetBetId Method

Sets the bet id

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetCalculationOdds Method

IBetBuilderSetCalculationOdds Method

Sets the odds calculated for custom bet multiplied by 10_000 and rounded to int value

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetCustomBet Method

IBetBuilderSetCustomBet Method

Sets the flag if bet is a custom bet (optional, default false)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetEntireStake Method

IBetBuilderSetEntireStake Method

Overload List
 | Name | Description
Public method | SetEntireStake(Int64) | Sets the IStake
Public method | SetEntireStake(Int64, StakeType) | Sets the IStake
Top
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetEntireStake(Int64) Method

IBetBuilderSetEntireStake(Int64) Method

Sets the IStake

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
SetEntireStake Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetEntireStake(Int64, StakeType) Method

IBetBuilderSetEntireStake(Int64, StakeType) Method

Sets the IStake

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
SetEntireStake Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetFreeStake Method

IBetBuilderSetFreeStake Method

Sets the IFreeStake

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetReofferRefId Method

IBetBuilderSetReofferRefId Method

Sets the reoffer reference bet id

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetStake Method

IBetBuilderSetStake Method

Overload List
 | Name | Description
Public method | SetStake(Int64) | Sets the IStake
Public method | SetStake(Int64, StakeType) | Sets the IStake
Top
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetStake(Int64) Method

IBetBuilderSetStake(Int64) Method

Sets the IStake

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
SetStake Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetStake(Int64, StakeType) Method

IBetBuilderSetStake(Int64, StakeType) Method

Sets the IStake

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
SetStake Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


IBetBuilder.SetSumOfWins Method

IBetBuilderSetSumOfWins Method

Sets the sum of all wins for all generated combinations for this bet (in ticket currency, used for validation)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBuilderFactory Interface

Defines a contract used to construct builder instances used when constructing tickets and it's associated entities

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IBuilderFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateAltStakeBuilder | Constructs and returns a new instance of the ITicketAltStakeBuilder class (Inherited from ISimpleBuilderFactory)
Public method | CreateBetBuilder | Constructs and returns a new instance of the IBetBuilder class (Inherited from ISimpleBuilderFactory)
Public method | CreateEndCustomerBuilder | Constructs and returns a new instance of the IEndCustomerBuilder class (Inherited from ISimpleBuilderFactory)
Public method | CreateSelectionBuilder | Constructs and returns a new instance of the ISelectionBuilder class
Public method | CreateSenderBuilder | Constructs and returns a new instance of the ISenderBuilder class
Public method | CreateTicketAckBuilder | Constructs and returns a new instance of the ITicketAckBuilder class
Public method | CreateTicketBuilder | Constructs and returns a new instance of the ITicketBuilder class (Inherited from ISimpleBuilderFactory)
Public method | CreateTicketCancelAckBuilder | Constructs and returns a new instance of the ITicketCancelAckBuilder class
Public method | CreateTicketCancelBuilder | Constructs and returns a new instance of the ITicketCancelBuilder class
Public method | CreateTicketCashoutBuilder | Constructs and returns a new instance of the ITicketCashoutBuilder class
Public method | CreateTicketNonSrSettleBuilder | Constructs and returns a new instance of the ITicketNonSrSettleBuilder class
Public method | CreateTicketReofferBuilder | Constructs and returns a new instance of the ITicketReofferBuilder class (Inherited from ISimpleBuilderFactory)
Public method | CreateTicketReofferCancelBuilder | Constructs and returns a new instance of the ITicketReofferCancelBuilder class
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


IBuilderFactory Methods

The IBuilderFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateAltStakeBuilder | Constructs and returns a new instance of the ITicketAltStakeBuilder class (Inherited from ISimpleBuilderFactory)
Public method | CreateBetBuilder | Constructs and returns a new instance of the IBetBuilder class (Inherited from ISimpleBuilderFactory)
Public method | CreateEndCustomerBuilder | Constructs and returns a new instance of the IEndCustomerBuilder class (Inherited from ISimpleBuilderFactory)
Public method | CreateSelectionBuilder | Constructs and returns a new instance of the ISelectionBuilder class
Public method | CreateSenderBuilder | Constructs and returns a new instance of the ISenderBuilder class
Public method | CreateTicketAckBuilder | Constructs and returns a new instance of the ITicketAckBuilder class
Public method | CreateTicketBuilder | Constructs and returns a new instance of the ITicketBuilder class (Inherited from ISimpleBuilderFactory)
Public method | CreateTicketCancelAckBuilder | Constructs and returns a new instance of the ITicketCancelAckBuilder class
Public method | CreateTicketCancelBuilder | Constructs and returns a new instance of the ITicketCancelBuilder class
Public method | CreateTicketCashoutBuilder | Constructs and returns a new instance of the ITicketCashoutBuilder class
Public method | CreateTicketNonSrSettleBuilder | Constructs and returns a new instance of the ITicketNonSrSettleBuilder class
Public method | CreateTicketReofferBuilder | Constructs and returns a new instance of the ITicketReofferBuilder class (Inherited from ISimpleBuilderFactory)
Public method | CreateTicketReofferCancelBuilder | Constructs and returns a new instance of the ITicketReofferCancelBuilder class
Top
See Also

Reference

IBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBuilderFactory.CreateSelectionBuilder Method

IBuilderFactoryCreateSelectionBuilder Method

Constructs and returns a new instance of the ISelectionBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBuilderFactory.CreateSenderBuilder Method

IBuilderFactoryCreateSenderBuilder Method

Constructs and returns a new instance of the ISenderBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBuilderFactory.CreateTicketAckBuilder Method

IBuilderFactoryCreateTicketAckBuilder Method

Constructs and returns a new instance of the ITicketAckBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBuilderFactory.CreateTicketCancelAckBuilder Method

IBuilderFactoryCreateTicketCancelAckBuilder Method

Constructs and returns a new instance of the ITicketCancelAckBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBuilderFactory.CreateTicketCancelBuilder Method

IBuilderFactoryCreateTicketCancelBuilder Method

Constructs and returns a new instance of the ITicketCancelBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBuilderFactory.CreateTicketCashoutBuilder Method

IBuilderFactoryCreateTicketCashoutBuilder Method

Constructs and returns a new instance of the ITicketCashoutBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBuilderFactory.CreateTicketNonSrSettleBuilder Method

IBuilderFactoryCreateTicketNonSrSettleBuilder Method

Constructs and returns a new instance of the ITicketNonSrSettleBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IBuilderFactory.CreateTicketReofferCancelBuilder Method

IBuilderFactoryCreateTicketReofferCancelBuilder Method

Constructs and returns a new instance of the ITicketReofferCancelBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ICustomBetSelectionBuilder Interface

Defines a contract for classes building a ICustomBetSelectionBuilder Implements the ISdkTicketBuilder

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ICustomBetSelectionBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a ISelection instance
Public method | Build(String, Int32, String, String) | Builds and returns a ISelection instance
Public method | SetEventId | Sets event id to the provided String
Public method | SetMarketId | Sets market id to the provided value
Public method | SetOutcomeId | Sets outcome id to the provided value
Public method | SetSpecifiers | Sets specifiers to the provided value
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace
ISdkTicketBuilder


ICustomBetSelectionBuilder Methods

The ICustomBetSelectionBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a ISelection instance
Public method | Build(String, Int32, String, String) | Builds and returns a ISelection instance
Public method | SetEventId | Sets event id to the provided String
Public method | SetMarketId | Sets market id to the provided value
Public method | SetOutcomeId | Sets outcome id to the provided value
Public method | SetSpecifiers | Sets specifiers to the provided value
Top
See Also

Reference

ICustomBetSelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ICustomBetSelectionBuilder.Build Method

ICustomBetSelectionBuilderBuild Method

Overload List
 | Name | Description
Public method | Build | Builds and returns a ISelection instance
Public method | Build(String, Int32, String, String) | Builds and returns a ISelection instance
Top
See Also

Reference

ICustomBetSelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ICustomBetSelectionBuilder.Build Method

ICustomBetSelectionBuilderBuild Method

Builds and returns a ISelection instance

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICustomBetSelectionBuilder Interface
Build Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ICustomBetSelectionBuilder.Build(String, Int32, String, String) Method

ICustomBetSelectionBuilderBuild(String, Int32, String, String) Method

Builds and returns a ISelection instance

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICustomBetSelectionBuilder Interface
Build Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ICustomBetSelectionBuilder.SetEventId Method

ICustomBetSelectionBuilderSetEventId Method

Sets event id to the provided String

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICustomBetSelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ICustomBetSelectionBuilder.SetMarketId Method

ICustomBetSelectionBuilderSetMarketId Method

Sets market id to the provided value

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICustomBetSelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ICustomBetSelectionBuilder.SetOutcomeId Method

ICustomBetSelectionBuilderSetOutcomeId Method

Sets outcome id to the provided value

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICustomBetSelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ICustomBetSelectionBuilder.SetSpecifiers Method

ICustomBetSelectionBuilderSetSpecifiers Method

Sets specifiers to the provided value

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICustomBetSelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IEndCustomerBuilder Interface

Defines a contract for classes building IEndCustomer

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IEndCustomerBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds the IEndCustomer
Public method | SetConfidence | Sets the suggested CCF of the customer multiplied by 10000 and rounded to a long value
Public method | SetDeviceId | Sets the device end user's device id
Public method | SetId | Sets the end user's unique id (in client's system)
Public method | SetIp | Sets the end user's ip
Public method | SetLanguageId | Sets the 2-letter ISO 639-1 language code
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


IEndCustomerBuilder Methods

The IEndCustomerBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds the IEndCustomer
Public method | SetConfidence | Sets the suggested CCF of the customer multiplied by 10000 and rounded to a long value
Public method | SetDeviceId | Sets the device end user's device id
Public method | SetId | Sets the end user's unique id (in client's system)
Public method | SetIp | Sets the end user's ip
Public method | SetLanguageId | Sets the 2-letter ISO 639-1 language code
Top
See Also

Reference

IEndCustomerBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IEndCustomerBuilder.Build Method

IEndCustomerBuilderBuild Method

Builds the IEndCustomer

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IEndCustomerBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IEndCustomerBuilder.SetConfidence Method

IEndCustomerBuilderSetConfidence Method

Sets the suggested CCF of the customer multiplied by 10000 and rounded to a long value

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IEndCustomerBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IEndCustomerBuilder.SetDeviceId Method

IEndCustomerBuilderSetDeviceId Method

Sets the device end user's device id

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IEndCustomerBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IEndCustomerBuilder.SetId Method

IEndCustomerBuilderSetId Method

Sets the end user's unique id (in client's system)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IEndCustomerBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IEndCustomerBuilder.SetIp Method

IEndCustomerBuilderSetIp Method

Sets the end user's ip

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IEndCustomerBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


IEndCustomerBuilder.SetLanguageId Method

IEndCustomerBuilderSetLanguageId Method

Sets the 2-letter ISO 639-1 language code

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IEndCustomerBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISdkTicketBuilder Interface

Defines a contract for classes implementing any ticket builder

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder Interface

Defines a contract for classes implementing builder for ISelection

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ISelectionBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds the ISelection
Public method | Set(Int64, String, NullableInt32, Boolean) | Sets the ISelection properties
Public method | Set(String, String, NullableInt32, Boolean) | Sets the ISelection properties
Public method | SetBanker | Sets the banker property
Public method | SetBoostedOdds | Sets the boosted odds multiplied by 10000 and rounded to int value
Public method | SetEventId | Sets the Betradar event (match or outright) id
Public method | SetId | Sets the selection id
Public method | SetIdLcoo | Sets the selection id for LCOO
Public method | SetIdLo | Sets the selection id for LiveOdds
Public method | SetIdUof(Int32, String, Int32, String, IReadOnlyDictionaryString, String, IReadOnlyDictionaryString, Object) | Sets the selection id for UOF
 | SetIdUof(Int32, String, Int32, String, String, IReadOnlyDictionaryString, Object) | Sets the selection id for UOF
Public method | SetOdds | Sets the odds multiplied by 10000 and rounded to int value
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder Methods

The ISelectionBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds the ISelection
Public method | Set(Int64, String, NullableInt32, Boolean) | Sets the ISelection properties
Public method | Set(String, String, NullableInt32, Boolean) | Sets the ISelection properties
Public method | SetBanker | Sets the banker property
Public method | SetBoostedOdds | Sets the boosted odds multiplied by 10000 and rounded to int value
Public method | SetEventId | Sets the Betradar event (match or outright) id
Public method | SetId | Sets the selection id
Public method | SetIdLcoo | Sets the selection id for LCOO
Public method | SetIdLo | Sets the selection id for LiveOdds
Public method | SetIdUof(Int32, String, Int32, String, IReadOnlyDictionaryString, String, IReadOnlyDictionaryString, Object) | Sets the selection id for UOF
 | SetIdUof(Int32, String, Int32, String, String, IReadOnlyDictionaryString, Object) | Sets the selection id for UOF
Public method | SetOdds | Sets the odds multiplied by 10000 and rounded to int value
Top
See Also

Reference

ISelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.Build Method

ISelectionBuilderBuild Method

Builds the ISelection

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.Set Method

ISelectionBuilderSet Method

Overload List
 | Name | Description
Public method | Set(Int64, String, NullableInt32, Boolean) | Sets the ISelection properties
Public method | Set(String, String, NullableInt32, Boolean) | Sets the ISelection properties
Top
See Also

Reference

ISelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.Set(Int64, String, Nullable<Int32>, Boolean) Method

ISelectionBuilderSet(Int64, String, NullableInt32, Boolean) Method

Sets the ISelection properties

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionBuilder Interface
Set Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.Set(String, String, Nullable<Int32>, Boolean) Method

ISelectionBuilderSet(String, String, NullableInt32, Boolean) Method

Sets the ISelection properties

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionBuilder Interface
Set Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.SetBanker Method

ISelectionBuilderSetBanker Method

Sets the banker property

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.SetBoostedOdds Method

ISelectionBuilderSetBoostedOdds Method

Sets the boosted odds multiplied by 10000 and rounded to int value

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.SetEventId Method

ISelectionBuilderSetEventId Method

Sets the Betradar event (match or outright) id

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.SetId Method

ISelectionBuilderSetId Method

Sets the selection id

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.SetIdLcoo Method

ISelectionBuilderSetIdLcoo Method

Sets the selection id for LCOO

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.SetIdLo Method

ISelectionBuilderSetIdLo Method

Sets the selection id for LiveOdds

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.SetIdUof Method

ISelectionBuilderSetIdUof Method

Overload List
 | Name | Description
Public method | SetIdUof(Int32, String, Int32, String, IReadOnlyDictionaryString, String, IReadOnlyDictionaryString, Object) | Sets the selection id for UOF
 | SetIdUof(Int32, String, Int32, String, String, IReadOnlyDictionaryString, Object) | Sets the selection id for UOF
Top
See Also

Reference

ISelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.SetIdUof(Int32, String, Int32, String, IReadOnlyDictionary<String, String>, IReadOnlyDictionary<String, Object>) Method

ISelectionBuilderSetIdUof(Int32, String, Int32, String, IReadOnlyDictionaryString, String, IReadOnlyDictionaryString, Object) Method

Sets the selection id for UOF

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
Method requires accessToken in configuration and access to https://global.api.betradar.com
See Also

Reference

ISelectionBuilder Interface
SetIdUof Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.SetIdUof(Int32, String, Int32, String, String, IReadOnlyDictionary<String, Object>) Method

ISelectionBuilderSetIdUof(Int32, String, Int32, String, String, IReadOnlyDictionaryString, Object) Method

Sets the selection id for UOF

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
Method requires accessToken in configuration and access to https://global.api.betradar.com
Example
SetIdUof(Product.LiveOdds, "sr:sport:1", 101, "10", "total=3.0|playerid=sr:player:10201");
See Also

Reference

ISelectionBuilder Interface
SetIdUof Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ISelectionBuilder.SetOdds Method

ISelectionBuilderSetOdds Method

Sets the odds multiplied by 10000 and rounded to int value

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISenderBuilder Interface

Defines a contract for classes implementing builder for ISender

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ISenderBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds the ISender
Public method | SetBookmakerId | Sets the ticket bookmaker id (client's id provided by Sportradar)
Public method | SetCurrency | Sets the 3 letter currency code
Public method | SetEndCustomer(IEndCustomer) | Set the identification of the end user (customer)
Public method | SetEndCustomer(IPAddress, String, String, String, Int64) | Set the identification of the end user (customer)
Public method | SetLimitId | Sets the client's limit id (provided by Sportradar to the client)
Public method | SetSenderChannel | Sets the senders communication channel
Public method | SetShopId | Sets the shop id
Public method | SetTerminalId | Sets the terminal id
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


ISenderBuilder Methods

The ISenderBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds the ISender
Public method | SetBookmakerId | Sets the ticket bookmaker id (client's id provided by Sportradar)
Public method | SetCurrency | Sets the 3 letter currency code
Public method | SetEndCustomer(IEndCustomer) | Set the identification of the end user (customer)
Public method | SetEndCustomer(IPAddress, String, String, String, Int64) | Set the identification of the end user (customer)
Public method | SetLimitId | Sets the client's limit id (provided by Sportradar to the client)
Public method | SetSenderChannel | Sets the senders communication channel
Public method | SetShopId | Sets the shop id
Public method | SetTerminalId | Sets the terminal id
Top
See Also

Reference

ISenderBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISenderBuilder.Build Method

ISenderBuilderBuild Method

Builds the ISender

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISenderBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISenderBuilder.SetBookmakerId Method

ISenderBuilderSetBookmakerId Method

Sets the ticket bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISenderBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISenderBuilder.SetCurrency Method

ISenderBuilderSetCurrency Method

Sets the 3 letter currency code

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISenderBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISenderBuilder.SetEndCustomer Method

ISenderBuilderSetEndCustomer Method

Overload List
 | Name | Description
Public method | SetEndCustomer(IEndCustomer) | Set the identification of the end user (customer)
Public method | SetEndCustomer(IPAddress, String, String, String, Int64) | Set the identification of the end user (customer)
Top
See Also

Reference

ISenderBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISenderBuilder.SetEndCustomer(IEndCustomer) Method

ISenderBuilderSetEndCustomer(IEndCustomer) Method

Set the identification of the end user (customer)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISenderBuilder Interface
SetEndCustomer Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ISenderBuilder.SetEndCustomer(IPAddress, String, String, String, Int64) Method

ISenderBuilderSetEndCustomer(IPAddress, String, String, String, Int64) Method

Set the identification of the end user (customer)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISenderBuilder Interface
SetEndCustomer Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ISenderBuilder.SetLimitId Method

ISenderBuilderSetLimitId Method

Sets the client's limit id (provided by Sportradar to the client)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISenderBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISenderBuilder.SetSenderChannel Method

ISenderBuilderSetSenderChannel Method

Sets the senders communication channel

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISenderBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISenderBuilder.SetShopId Method

ISenderBuilderSetShopId Method

Sets the shop id

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISenderBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISenderBuilder.SetTerminalId Method

ISenderBuilderSetTerminalId Method

Sets the terminal id

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISenderBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISimpleBuilderFactory Interface

Defines a contract used to construct simple builder instances(those not needing configuration) used when constructing tickets and it's associated entities

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ISimpleBuilderFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateAltStakeBuilder | Constructs and returns a new instance of the ITicketAltStakeBuilder class
Public method | CreateBetBuilder | Constructs and returns a new instance of the IBetBuilder class
Public method | CreateEndCustomerBuilder | Constructs and returns a new instance of the IEndCustomerBuilder class
Public method | CreateTicketBuilder | Constructs and returns a new instance of the ITicketBuilder class
Public method | CreateTicketReofferBuilder | Constructs and returns a new instance of the ITicketReofferBuilder class
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


ISimpleBuilderFactory Methods

The ISimpleBuilderFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateAltStakeBuilder | Constructs and returns a new instance of the ITicketAltStakeBuilder class
Public method | CreateBetBuilder | Constructs and returns a new instance of the IBetBuilder class
Public method | CreateEndCustomerBuilder | Constructs and returns a new instance of the IEndCustomerBuilder class
Public method | CreateTicketBuilder | Constructs and returns a new instance of the ITicketBuilder class
Public method | CreateTicketReofferBuilder | Constructs and returns a new instance of the ITicketReofferBuilder class
Top
See Also

Reference

ISimpleBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISimpleBuilderFactory.CreateAltStakeBuilder Method

ISimpleBuilderFactoryCreateAltStakeBuilder Method

Constructs and returns a new instance of the ITicketAltStakeBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISimpleBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISimpleBuilderFactory.CreateBetBuilder Method

ISimpleBuilderFactoryCreateBetBuilder Method

Constructs and returns a new instance of the IBetBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISimpleBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISimpleBuilderFactory.CreateEndCustomerBuilder Method

ISimpleBuilderFactoryCreateEndCustomerBuilder Method

Constructs and returns a new instance of the IEndCustomerBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISimpleBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISimpleBuilderFactory.CreateTicketBuilder Method

ISimpleBuilderFactoryCreateTicketBuilder Method

Constructs and returns a new instance of the ITicketBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISimpleBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ISimpleBuilderFactory.CreateTicketReofferBuilder Method

ISimpleBuilderFactoryCreateTicketReofferBuilder Method

Constructs and returns a new instance of the ITicketReofferBuilder class

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISimpleBuilderFactory Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketAckBuilder Interface

Defines a contract for classes implementing builder for ITicketAckBuilder

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketAckBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildTicket | Builds the ITicketAck
Public method | SetAck | Sets the acknowledgment parameters
Public method | SetBookmakerId | Sets the ticket bookmaker id (client's id provided by Sportradar)
Public method | SetTicketId | Sets the ticket id
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketAckBuilder Methods

The ITicketAckBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildTicket | Builds the ITicketAck
Public method | SetAck | Sets the acknowledgment parameters
Public method | SetBookmakerId | Sets the ticket bookmaker id (client's id provided by Sportradar)
Public method | SetTicketId | Sets the ticket id
Top
See Also

Reference

ITicketAckBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketAckBuilder.BuildTicket Method

ITicketAckBuilderBuildTicket Method

Builds the ITicketAck

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketAckBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketAckBuilder.SetAck Method

ITicketAckBuilderSetAck Method

Sets the acknowledgment parameters

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketAckBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketAckBuilder.SetBookmakerId Method

ITicketAckBuilderSetBookmakerId Method

Sets the ticket bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketAckBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketAckBuilder.SetTicketId Method

ITicketAckBuilderSetTicketId Method

Sets the ticket id

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketAckBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketAltStakeBuilder Interface

Defines a contract for classes implementing builder for alternative stake ITicket

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketAltStakeBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildTicket | Builds the new ITicket
Public method | Set(ITicket, ITicketResponse, String) | Sets the original ticket and the ticket response
Public method | Set(ITicket, Int64, String) | Sets the original ticket and the ticket response
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketAltStakeBuilder Methods

The ITicketAltStakeBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildTicket | Builds the new ITicket
Public method | Set(ITicket, ITicketResponse, String) | Sets the original ticket and the ticket response
Public method | Set(ITicket, Int64, String) | Sets the original ticket and the ticket response
Top
See Also

Reference

ITicketAltStakeBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketAltStakeBuilder.BuildTicket Method

ITicketAltStakeBuilderBuildTicket Method

Builds the new ITicket

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketAltStakeBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketAltStakeBuilder.Set Method

ITicketAltStakeBuilderSet Method

Overload List
 | Name | Description
Public method | Set(ITicket, ITicketResponse, String) | Sets the original ticket and the ticket response
Public method | Set(ITicket, Int64, String) | Sets the original ticket and the ticket response
Top
See Also

Reference

ITicketAltStakeBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketAltStakeBuilder.Set(ITicket, ITicketResponse, String) Method

ITicketAltStakeBuilderSet(ITicket, ITicketResponse, String) Method

Sets the original ticket and the ticket response

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
Only tickets with exactly 1 bet are supported
See Also

Reference

ITicketAltStakeBuilder Interface
Set Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketAltStakeBuilder.Set(ITicket, Int64, String) Method

ITicketAltStakeBuilderSet(ITicket, Int64, String) Method

Sets the original ticket and the ticket response

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
Only tickets with exactly 1 bet are supported
See Also

Reference

ITicketAltStakeBuilder Interface
Set Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder Interface

Defines a contract for classes implementing builder for ITicket

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddBet | Adds the IBet
Public method | BuildTicket | Builds the ITicket
Public method | GetBets | Gets the bets
Public method | SetAltStakeRefId | Sets the alternative stake reference ticket id
Public method | SetLastMatchEndTime | Sets end time of last (non Sportradar) match on ticket
Public method | SetOddsChange | Sets the odds change
Public method | SetReofferId | Sets the reoffer id
Public method | SetSender | Sets the sender
Public method | SetTestSource | Sets the test source
Public method | SetTicketId | Sets the ticket id
Public method | SetTotalCombinations | Sets the expected total number of generated combinations on this ticket (optional, default null). If present, it is used to validate against actual number of generated combinations.
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder Methods

The ITicketBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddBet | Adds the IBet
Public method | BuildTicket | Builds the ITicket
Public method | GetBets | Gets the bets
Public method | SetAltStakeRefId | Sets the alternative stake reference ticket id
Public method | SetLastMatchEndTime | Sets end time of last (non Sportradar) match on ticket
Public method | SetOddsChange | Sets the odds change
Public method | SetReofferId | Sets the reoffer id
Public method | SetSender | Sets the sender
Public method | SetTestSource | Sets the test source
Public method | SetTicketId | Sets the ticket id
Public method | SetTotalCombinations | Sets the expected total number of generated combinations on this ticket (optional, default null). If present, it is used to validate against actual number of generated combinations.
Top
See Also

Reference

ITicketBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder.AddBet Method

ITicketBuilderAddBet Method

Adds the IBet

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder.BuildTicket Method

ITicketBuilderBuildTicket Method

Builds the ITicket

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder.GetBets Method

ITicketBuilderGetBets Method

Gets the bets

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder.SetAltStakeRefId Method

ITicketBuilderSetAltStakeRefId Method

Sets the alternative stake reference ticket id

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder.SetLastMatchEndTime Method

ITicketBuilderSetLastMatchEndTime Method

Sets end time of last (non Sportradar) match on ticket

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder.SetOddsChange Method

ITicketBuilderSetOddsChange Method

Sets the odds change

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder.SetReofferId Method

ITicketBuilderSetReofferId Method

Sets the reoffer id

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder.SetSender Method

ITicketBuilderSetSender Method

Sets the sender

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder.SetTestSource Method

ITicketBuilderSetTestSource Method

Sets the test source

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder.SetTicketId Method

ITicketBuilderSetTicketId Method

Sets the ticket id

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketBuilder.SetTotalCombinations Method

ITicketBuilderSetTotalCombinations Method

Sets the expected total number of generated combinations on this ticket (optional, default null). If present, it is used to validate against actual number of generated combinations.

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelAckBuilder Interface

Defines a contract for classes implementing builder for ITicketCancelAckBuilder

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketCancelAckBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildTicket | Builds the ITicketCancelAck
Public method | SetAck | Sets the acknowledgment parameters
Public method | SetBookmakerId | Sets the ticket bookmaker id (client's id provided by Sportradar)
Public method | SetTicketId | Sets the ticket id
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelAckBuilder Methods

The ITicketCancelAckBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildTicket | Builds the ITicketCancelAck
Public method | SetAck | Sets the acknowledgment parameters
Public method | SetBookmakerId | Sets the ticket bookmaker id (client's id provided by Sportradar)
Public method | SetTicketId | Sets the ticket id
Top
See Also

Reference

ITicketCancelAckBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelAckBuilder.BuildTicket Method

ITicketCancelAckBuilderBuildTicket Method

Builds the ITicketCancelAck

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelAckBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelAckBuilder.SetAck Method

ITicketCancelAckBuilderSetAck Method

Sets the acknowledgment parameters

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelAckBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelAckBuilder.SetBookmakerId Method

ITicketCancelAckBuilderSetBookmakerId Method

Sets the ticket bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelAckBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelAckBuilder.SetTicketId Method

ITicketCancelAckBuilderSetTicketId Method

Sets the ticket id

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelAckBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelBuilder Interface

Defines a contract for classes building a ITicketCancel

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketCancelBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddBetCancel | Add the IBetCancel
Public method | BuildTicket | Builds the ITicketCancel
Public method | BuildTicket(String, Int32, TicketCancellationReason) | Build a ITicketCancel
Public method | SetBookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public method | SetCancelPercent | Sets the percent of cancellation
Public method | SetCode | Sets the cancellation code
Public method | SetTicketId | Sets the ticket id to cancel
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelBuilder Methods

The ITicketCancelBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddBetCancel | Add the IBetCancel
Public method | BuildTicket | Builds the ITicketCancel
Public method | BuildTicket(String, Int32, TicketCancellationReason) | Build a ITicketCancel
Public method | SetBookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public method | SetCancelPercent | Sets the percent of cancellation
Public method | SetCode | Sets the cancellation code
Public method | SetTicketId | Sets the ticket id to cancel
Top
See Also

Reference

ITicketCancelBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelBuilder.AddBetCancel Method

ITicketCancelBuilderAddBetCancel Method

Add the IBetCancel

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelBuilder.BuildTicket Method

ITicketCancelBuilderBuildTicket Method

Overload List
 | Name | Description
Public method | BuildTicket | Builds the ITicketCancel
Public method | BuildTicket(String, Int32, TicketCancellationReason) | Build a ITicketCancel
Top
See Also

Reference

ITicketCancelBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelBuilder.BuildTicket Method

ITicketCancelBuilderBuildTicket Method

Builds the ITicketCancel

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelBuilder Interface
BuildTicket Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelBuilder.BuildTicket(String, Int32, TicketCancellationReason) Method

ITicketCancelBuilderBuildTicket(String, Int32, TicketCancellationReason) Method

Build a ITicketCancel

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelBuilder Interface
BuildTicket Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelBuilder.SetBookmakerId Method

ITicketCancelBuilderSetBookmakerId Method

Get the bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelBuilder.SetCancelPercent Method

ITicketCancelBuilderSetCancelPercent Method

Sets the percent of cancellation

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelBuilder.SetCode Method

ITicketCancelBuilderSetCode Method

Sets the cancellation code

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCancelBuilder.SetTicketId Method

ITicketCancelBuilderSetTicketId Method

Sets the ticket id to cancel

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCashoutBuilder Interface

Defines a contract for classes building a ITicketCashout

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketCashoutBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddBetCashout | Add the bet cashout
Public method | BuildTicket | Builds the ITicketCashout
Public method | BuildTicket(String, Int32, Int64, NullableInt32) | Build a ITicketCashout
Public method | SetBookmakerId | Sets the bookmaker id (client's id provided by Sportradar)
Public method | SetCashoutPercent | Sets the cashout percent
Public method | SetCashoutStake | Sets the cashout stake
Public method | SetTicketId | Sets the ticket id to cashout
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCashoutBuilder Methods

The ITicketCashoutBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddBetCashout | Add the bet cashout
Public method | BuildTicket | Builds the ITicketCashout
Public method | BuildTicket(String, Int32, Int64, NullableInt32) | Build a ITicketCashout
Public method | SetBookmakerId | Sets the bookmaker id (client's id provided by Sportradar)
Public method | SetCashoutPercent | Sets the cashout percent
Public method | SetCashoutStake | Sets the cashout stake
Public method | SetTicketId | Sets the ticket id to cashout
Top
See Also

Reference

ITicketCashoutBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCashoutBuilder.AddBetCashout Method

ITicketCashoutBuilderAddBetCashout Method

Add the bet cashout

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashoutBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCashoutBuilder.BuildTicket Method

ITicketCashoutBuilderBuildTicket Method

Overload List
 | Name | Description
Public method | BuildTicket | Builds the ITicketCashout
Public method | BuildTicket(String, Int32, Int64, NullableInt32) | Build a ITicketCashout
Top
See Also

Reference

ITicketCashoutBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCashoutBuilder.BuildTicket Method

ITicketCashoutBuilderBuildTicket Method

Builds the ITicketCashout

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashoutBuilder Interface
BuildTicket Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCashoutBuilder.BuildTicket(String, Int32, Int64, Nullable<Int32>) Method

ITicketCashoutBuilderBuildTicket(String, Int32, Int64, NullableInt32) Method

Build a ITicketCashout

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashoutBuilder Interface
BuildTicket Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCashoutBuilder.SetBookmakerId Method

ITicketCashoutBuilderSetBookmakerId Method

Sets the bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashoutBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCashoutBuilder.SetCashoutPercent Method

ITicketCashoutBuilderSetCashoutPercent Method

Sets the cashout percent

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashoutBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCashoutBuilder.SetCashoutStake Method

ITicketCashoutBuilderSetCashoutStake Method

Sets the cashout stake

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashoutBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketCashoutBuilder.SetTicketId Method

ITicketCashoutBuilderSetTicketId Method

Sets the ticket id to cashout

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashoutBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketNonSrSettleBuilder Interface

Defines a contract for classes building a ITicketNonSrSettleBuilder Implements the ISdkTicketBuilder

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketNonSrSettleBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildTicket | Builds the ITicketNonSrSettle
Public method | BuildTicket(String, Int32, Int64) | Build a ITicketNonSrSettle
Public method | SetBookmakerId | Sets the bookmaker id (client's id provided by Sportradar)
Public method | SetNonSrSettleStake | Sets the non-sportradar settle stake
Public method | SetTicketId | Sets the ticket id to non-sportradar settle
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace
ISdkTicketBuilder


ITicketNonSrSettleBuilder Methods

The ITicketNonSrSettleBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildTicket | Builds the ITicketNonSrSettle
Public method | BuildTicket(String, Int32, Int64) | Build a ITicketNonSrSettle
Public method | SetBookmakerId | Sets the bookmaker id (client's id provided by Sportradar)
Public method | SetNonSrSettleStake | Sets the non-sportradar settle stake
Public method | SetTicketId | Sets the ticket id to non-sportradar settle
Top
See Also

Reference

ITicketNonSrSettleBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketNonSrSettleBuilder.BuildTicket Method

ITicketNonSrSettleBuilderBuildTicket Method

Overload List
 | Name | Description
Public method | BuildTicket | Builds the ITicketNonSrSettle
Public method | BuildTicket(String, Int32, Int64) | Build a ITicketNonSrSettle
Top
See Also

Reference

ITicketNonSrSettleBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketNonSrSettleBuilder.BuildTicket Method

ITicketNonSrSettleBuilderBuildTicket Method

Builds the ITicketNonSrSettle

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketNonSrSettleBuilder Interface
BuildTicket Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketNonSrSettleBuilder.BuildTicket(String, Int32, Int64) Method

ITicketNonSrSettleBuilderBuildTicket(String, Int32, Int64) Method

Build a ITicketNonSrSettle

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketNonSrSettleBuilder Interface
BuildTicket Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketNonSrSettleBuilder.SetBookmakerId Method

ITicketNonSrSettleBuilderSetBookmakerId Method

Sets the bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketNonSrSettleBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketNonSrSettleBuilder.SetNonSrSettleStake Method

ITicketNonSrSettleBuilderSetNonSrSettleStake Method

Sets the non-sportradar settle stake

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketNonSrSettleBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketNonSrSettleBuilder.SetTicketId Method

ITicketNonSrSettleBuilderSetTicketId Method

Sets the ticket id to non-sportradar settle

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketNonSrSettleBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferBuilder Interface

Defines a contract for classes implementing builder for ITicket reoffer

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketReofferBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildTicket | Builds the new ITicket
Public method | Set(ITicket, ITicketResponse, String) | Sets the original ticket and the ticket response
Public method | Set(ITicket, Int64, String) | Sets the original ticket and the ticket response
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferBuilder Methods

The ITicketReofferBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildTicket | Builds the new ITicket
Public method | Set(ITicket, ITicketResponse, String) | Sets the original ticket and the ticket response
Public method | Set(ITicket, Int64, String) | Sets the original ticket and the ticket response
Top
See Also

Reference

ITicketReofferBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferBuilder.BuildTicket Method

ITicketReofferBuilderBuildTicket Method

Builds the new ITicket

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketReofferBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferBuilder.Set Method

ITicketReofferBuilderSet Method

Overload List
 | Name | Description
Public method | Set(ITicket, ITicketResponse, String) | Sets the original ticket and the ticket response
Public method | Set(ITicket, Int64, String) | Sets the original ticket and the ticket response
Top
See Also

Reference

ITicketReofferBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferBuilder.Set(ITicket, ITicketResponse, String) Method

ITicketReofferBuilderSet(ITicket, ITicketResponse, String) Method

Sets the original ticket and the ticket response

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
Only tickets with exactly 1 bet are supported
See Also

Reference

ITicketReofferBuilder Interface
Set Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferBuilder.Set(ITicket, Int64, String) Method

ITicketReofferBuilderSet(ITicket, Int64, String) Method

Sets the original ticket and the ticket response

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
Only tickets with exactly 1 bet are supported
See Also

Reference

ITicketReofferBuilder Interface
Set Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferCancelBuilder Interface

Defines a contract for classes building a ITicketReofferCancel

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketReofferCancelBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildTicket | Builds the ITicketReofferCancel
Public method | BuildTicket(String, Int32) | Build a ITicketReofferCancel
Public method | SetBookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public method | SetTicketId | Sets the reoffer ticket id to cancel
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferCancelBuilder Methods

The ITicketReofferCancelBuilder type exposes the following members.

Methods
 | Name | Description
Public method | BuildTicket | Builds the ITicketReofferCancel
Public method | BuildTicket(String, Int32) | Build a ITicketReofferCancel
Public method | SetBookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public method | SetTicketId | Sets the reoffer ticket id to cancel
Top
See Also

Reference

ITicketReofferCancelBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferCancelBuilder.BuildTicket Method

ITicketReofferCancelBuilderBuildTicket Method

Overload List
 | Name | Description
Public method | BuildTicket | Builds the ITicketReofferCancel
Public method | BuildTicket(String, Int32) | Build a ITicketReofferCancel
Top
See Also

Reference

ITicketReofferCancelBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferCancelBuilder.BuildTicket Method

ITicketReofferCancelBuilderBuildTicket Method

Builds the ITicketReofferCancel

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketReofferCancelBuilder Interface
BuildTicket Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferCancelBuilder.BuildTicket(String, Int32) Method

ITicketReofferCancelBuilderBuildTicket(String, Int32) Method

Build a ITicketReofferCancel

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketReofferCancelBuilder Interface
BuildTicket Overload
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferCancelBuilder.SetBookmakerId Method

ITicketReofferCancelBuilderSetBookmakerId Method

Get the bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketReofferCancelBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


ITicketReofferCancelBuilder.SetTicketId Method

ITicketReofferCancelBuilderSetTicketId Method

Sets the reoffer ticket id to cancel

Namespace: Sportradar.MTS.SDK.Entities.Builders
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketReofferCancelBuilder Interface
Sportradar.MTS.SDK.Entities.Builders Namespace


Sportradar.MTS.SDK.Entities.Enums Namespace

Enumerations
 | Enumeration | Description
Public enumeration | BetBonusDescription | Defines possible values for Description
Public enumeration | BetBonusMode | Enum BetBonusMode
Public enumeration | BetBonusPaidAs | Defines possible values for PaidAs
Public enumeration | BetBonusType | Defines possible values for Type
Public enumeration | BetReofferType | Defines possible values for Type
Public enumeration | CashoutAcceptance | Possible values of cashout acceptance
Public enumeration | FreeStakeDescription | Defines possible values for Description
Public enumeration | FreeStakePaidAs | Defines possible values for PaidAs
Public enumeration | FreeStakeType | Defines possible values for Type
Public enumeration | NonSrSettleAcceptance | Possible values of non-sr settle acceptance
Public enumeration | OddsChangeType | Possible values of the odds
Public enumeration | SenderChannel | Possible values for senders communication channel
Public enumeration | SourceType | Possible values used for getting Ccf history change report
Public enumeration | StakeType | Enum of possible values for type of stake
Public enumeration | TicketAcceptance | Possible values of ticket acceptance
Public enumeration | TicketAckStatus | Possible values of the ticket acknowledgment status
Public enumeration | TicketCancelAcceptance | Possible values of ticket cancel acceptance
Public enumeration | TicketCancelAckStatus | Possible values for ticket cancel acknowledgment status
Public enumeration | TicketCancellationReason | Enum of possible reasons (codes) for ticket (bet) cancellation
Public enumeration | TicketResponseType | Defines possible values for responses from MTS
Public enumeration | UfEnvironment | Possible values for UF environment


BetBonusDescription Enumeration

Defines possible values for Description

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
AccaBonus | 0 | AccaBonus: default value, assumed if missing in the ticket)
OddsBooster | 1 | OddsBooster
Other | 2 | Other
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


BetBonusMode Enumeration

Enum BetBonusMode

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
All | 0 | All: all bets must win for bonus to be paid out
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


BetBonusPaidAs Enumeration

Defines possible values for PaidAs

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Cash | 0 | Cash: default value, assumed if missing in the ticket)
FreeBet | 1 | FreeBet
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


BetBonusType Enumeration

Defines possible values for Type

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Total | 0 | The total
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


BetReofferType Enumeration

Defines possible values for Type

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Auto | 0 | If auto then stake will be present
Manual | 1 | If manual you should wait for reoffer stake over Reply channel
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


CashoutAcceptance Enumeration

Possible values of cashout acceptance

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Accepted | 0 | The accepted value
Rejected | 1 | The rejected value
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


FreeStakeDescription Enumeration

Defines possible values for Description

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
FreeBet | 0 | FreeBet: default value, assumed if missing in the ticket)
PartialFreeBet | 1 | PartialFreeBet
Rollover | 2 | Rollover
MoneyBack | 3 | MoneyBack
OddsBooster | 4 | OddsBooster
Other | 5 | Other
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


FreeStakePaidAs Enumeration

Defines possible values for PaidAs

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Cash | 0 | Cash: default value, assumed if missing in the ticket)
FreeBet | 1 | FreeBet
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


FreeStakeType Enumeration

Defines possible values for Type

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Total | 0 | The total
Unit | 1 | Unit
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


NonSrSettleAcceptance Enumeration

Possible values of non-sr settle acceptance

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Accepted | 0 | The accepted value
Rejected | 1 | The rejected value
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


OddsChangeType Enumeration

Possible values of the odds

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
None | 0 | Default behavior
Any | 1 | Any odds change accepted
Higher | 2 | Accept higher odds
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


SenderChannel Enumeration

Possible values for senders communication channel

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Internet | 0 | The internet
Retail | 1 | The retail
Terminal | 2 | The terminal
Mobile | 3 | The mobile
Sms | 4 | The SMS
CallCentre | 5 | The call centre
TvApp | 6 | The TV app
Agent | 7 | The agent
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


SourceType Enumeration

Possible values used for getting Ccf history change report

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Shop | 0 | Shop
Terminal | 1 | Terminal
Customer | 2 | Customer
Bookmaker | 3 | Bookmaker
SubBookmaker | 4 | SubBookmaker
DistributionChannel | 5 | Distribution channel
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


StakeType Enumeration

Enum of possible values for type of stake

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Total | 0 | The total
Unit | 1 | The unit
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


TicketAcceptance Enumeration

Possible values of ticket acceptance

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Accepted | 0 | The accepted value
Rejected | 1 | The rejected value
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


TicketAckStatus Enumeration

Possible values of the ticket acknowledgment status

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Accepted | 0 | The accepted
Rejected | 1 | The rejected
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


TicketCancelAcceptance Enumeration

Possible values of ticket cancel acceptance

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Cancelled | 0 | The cancelled
NotCancelled | 1 | The not cancelled
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


TicketCancelAckStatus Enumeration

Possible values for ticket cancel acknowledgment status

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Cancelled | 0 | The cancelled
NotCancelled | 1 | The not cancelled
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


TicketCancellationReason Enumeration

Enum of possible reasons (codes) for ticket (bet) cancellation

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
CustomerTriggeredPrematch | 101 | The customer triggered prematch bet cancellation
TimeoutTriggered | 102 | The timeout triggered bet cancellation
BookmakerBackofficeTriggered | 103 | The bookmaker backoffice triggered bet cancellation
BookmakerTechnicalIssue | 104 | The bookmaker technical issue bet cancellation
ExceptionalBookmakerTriggered | 105 | The exceptional bookmaker triggered bet cancellation
BookmakerCashbackPromotionCancellation | 106 | The bookmaker cashback promotion cancellation
SogeiTriggered | 301 | The sogei triggered bet cancellation
SccsTriggered | 302 | The SCCS triggered bet cancellation
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


TicketResponseType Enumeration

Defines possible values for responses from MTS

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Ticket | 1 | The ticket
TicketCancel | 2 | The ticket cancel
TicketCashout | 3 | The ticket cashout
TicketNonSrSettle | 4 | The ticket non-sportradar settle
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


UfEnvironment Enumeration

Possible values for UF environment

Namespace: Sportradar.MTS.SDK.Entities.Enums
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Members
Member name | Value | Description
Integration | 0 | The integration
Production | 1 | The production
See Also

Reference

Sportradar.MTS.SDK.Entities.Enums Namespace


Sportradar.MTS.SDK.Entities.EventArguments Namespace

Classes
 | Class | Description
Public class | ConnectionChangeEventArgs | An event argument used by events raised to provide message about connection state to the rabbit server
Public class | MessageDeserializationFailedEventArgs | Event arguments for the MqMessageDeserializationFailed event
Public class | MessagePublishFailedEventArgs | Event arguments for the MqMessagePublishFailed event
Public class | MessageReceivedEventArgs | An event argument used by events raised when a message from the feed is received
Public class | TicketMessageEventArgs | An event argument used by events raised to provide message about sdk or ticket state
Public class | TicketResponseReceivedEventArgs | An event argument used by events raised when a response is received
Public class | TicketSendFailedEventArgs | An event argument used by events raised when an attempt to send ticket failed
Public class | UnparsableMessageEventArgs | Event arguments of UnparsableMessageReceived event


ConnectionChangeEventArgs Class

An event argument used by events raised to provide message about connection state to the rabbit server
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.MTS.SDK.Entities.EventArgumentsConnectionChangeEventArgs

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ConnectionChangeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionChangeEventArgs | Initializes a new instance of the ConnectionChangeEventArgs class
Top
Properties
 | Name | Description
Public property | IsConnected | Gets an indicator if the connection is on or not
Public property | Message | Gets the message
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.EventArguments Namespace


ConnectionChangeEventArgs Constructor

Initializes a new instance of the ConnectionChangeEventArgs class

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ConnectionChangeEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


ConnectionChangeEventArgs Properties

The ConnectionChangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | IsConnected | Gets an indicator if the connection is on or not
Public property | Message | Gets the message
Top
See Also

Reference

ConnectionChangeEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


ConnectionChangeEventArgs.IsConnected Property

ConnectionChangeEventArgsIsConnected Property

Gets an indicator if the connection is on or not

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ConnectionChangeEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


ConnectionChangeEventArgs.Message Property

ConnectionChangeEventArgsMessage Property

Gets the message

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ConnectionChangeEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


ConnectionChangeEventArgs Methods

The ConnectionChangeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionChangeEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageDeserializationFailedEventArgs Class

Event arguments for the MqMessageDeserializationFailed event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.MTS.SDK.Entities.EventArgumentsMessageDeserializationFailedEventArgs

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The MessageDeserializationFailedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MessageDeserializationFailedEventArgs | Initializes a new instance of the MessageDeserializationFailedEventArgs class
Top
Properties
 | Name | Description
Public property | RawData | Gets the IEnumerableT containing message unprocessed data
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageDeserializationFailedEventArgs Constructor

Initializes a new instance of the MessageDeserializationFailedEventArgs class

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessageDeserializationFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageDeserializationFailedEventArgs Properties

The MessageDeserializationFailedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | RawData | Gets the IEnumerableT containing message unprocessed data
Top
See Also

Reference

MessageDeserializationFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageDeserializationFailedEventArgs.RawData Property

MessageDeserializationFailedEventArgsRawData Property

Gets the IEnumerableT containing message unprocessed data

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessageDeserializationFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageDeserializationFailedEventArgs Methods

The MessageDeserializationFailedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MessageDeserializationFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessagePublishFailedEventArgs Class

Event arguments for the MqMessagePublishFailed event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.MTS.SDK.Entities.EventArgumentsMessagePublishFailedEventArgs

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The MessagePublishFailedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MessagePublishFailedEventArgs | Initializes a new instance of the MessagePublishFailedEventArgs class
Top
Properties
 | Name | Description
Public property | CorrelationId | Gets the correlation id
Public property | ErrorMessage | Gets the description of the error
Public property | RawData | Gets the IEnumerableT containing message data
Public property | RoutingKey | Gets the routing key to which data should be send
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessagePublishFailedEventArgs Constructor

Initializes a new instance of the MessagePublishFailedEventArgs class

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessagePublishFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessagePublishFailedEventArgs Properties

The MessagePublishFailedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CorrelationId | Gets the correlation id
Public property | ErrorMessage | Gets the description of the error
Public property | RawData | Gets the IEnumerableT containing message data
Public property | RoutingKey | Gets the routing key to which data should be send
Top
See Also

Reference

MessagePublishFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessagePublishFailedEventArgs.CorrelationId Property

MessagePublishFailedEventArgsCorrelationId Property

Gets the correlation id

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessagePublishFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessagePublishFailedEventArgs.ErrorMessage Property

MessagePublishFailedEventArgsErrorMessage Property

Gets the description of the error

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessagePublishFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessagePublishFailedEventArgs.RawData Property

MessagePublishFailedEventArgsRawData Property

Gets the IEnumerableT containing message data

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessagePublishFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessagePublishFailedEventArgs.RoutingKey Property

MessagePublishFailedEventArgsRoutingKey Property

Gets the routing key to which data should be send

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessagePublishFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessagePublishFailedEventArgs Methods

The MessagePublishFailedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MessagePublishFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageReceivedEventArgs Class

An event argument used by events raised when a message from the feed is received
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.MTS.SDK.Entities.EventArgumentsMessageReceivedEventArgs

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The MessageReceivedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MessageReceivedEventArgs | Initializes a new instance of the MessageReceivedEventArgs class
Top
Properties
 | Name | Description
Public property | AdditionalInfo | Gets the additional information
Public property | CorrelationId | Gets the correlation id of the received message
Public property | JsonBody | Gets a String representing deserialized message
Public property | ResponseType | Gets the expected type of the response.
Public property | RoutingKey | Gets the routing key of the received message
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageReceivedEventArgs Constructor

Initializes a new instance of the MessageReceivedEventArgs class

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessageReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageReceivedEventArgs Properties

The MessageReceivedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the additional information
Public property | CorrelationId | Gets the correlation id of the received message
Public property | JsonBody | Gets a String representing deserialized message
Public property | ResponseType | Gets the expected type of the response.
Public property | RoutingKey | Gets the routing key of the received message
Top
See Also

Reference

MessageReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageReceivedEventArgs.AdditionalInfo Property

MessageReceivedEventArgsAdditionalInfo Property

Gets the additional information

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessageReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageReceivedEventArgs.CorrelationId Property

MessageReceivedEventArgsCorrelationId Property

Gets the correlation id of the received message

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessageReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageReceivedEventArgs.JsonBody Property

MessageReceivedEventArgsJsonBody Property

Gets a String representing deserialized message

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessageReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageReceivedEventArgs.ResponseType Property

MessageReceivedEventArgsResponseType Property

Gets the expected type of the response.

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessageReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageReceivedEventArgs.RoutingKey Property

MessageReceivedEventArgsRoutingKey Property

Gets the routing key of the received message

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

MessageReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


MessageReceivedEventArgs Methods

The MessageReceivedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MessageReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketMessageEventArgs Class

An event argument used by events raised to provide message about sdk or ticket state
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.MTS.SDK.Entities.EventArgumentsTicketMessageEventArgs

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The TicketMessageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TicketMessageEventArgs | Initializes a new instance of the TicketMessageEventArgs class
Top
Properties
 | Name | Description
Public property | Message | Gets the message
Public property | Ticket | Gets a associated ticket
Public property | TicketId | Gets a ticketId
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketMessageEventArgs Constructor

Initializes a new instance of the TicketMessageEventArgs class

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

TicketMessageEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketMessageEventArgs Properties

The TicketMessageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Message | Gets the message
Public property | Ticket | Gets a associated ticket
Public property | TicketId | Gets a ticketId
Top
See Also

Reference

TicketMessageEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketMessageEventArgs.Message Property

TicketMessageEventArgsMessage Property

Gets the message

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

TicketMessageEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketMessageEventArgs.Ticket Property

TicketMessageEventArgsTicket Property

Gets a associated ticket

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

TicketMessageEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketMessageEventArgs.TicketId Property

TicketMessageEventArgsTicketId Property

Gets a ticketId

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

TicketMessageEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketMessageEventArgs Methods

The TicketMessageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TicketMessageEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketResponseReceivedEventArgs Class

An event argument used by events raised when a response is received
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.MTS.SDK.Entities.EventArgumentsTicketResponseReceivedEventArgs

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The TicketResponseReceivedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TicketResponseReceivedEventArgs | Initializes a new instance of the TicketResponseReceivedEventArgs class
Top
Properties
 | Name | Description
Public property | Response | Gets a ISdkTicket representing received response
Public property | Type | Gets a value indicating from which type of ticket is this response
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketResponseReceivedEventArgs Constructor

Initializes a new instance of the TicketResponseReceivedEventArgs class

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

TicketResponseReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketResponseReceivedEventArgs Properties

The TicketResponseReceivedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Response | Gets a ISdkTicket representing received response
Public property | Type | Gets a value indicating from which type of ticket is this response
Top
See Also

Reference

TicketResponseReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketResponseReceivedEventArgs.Response Property

TicketResponseReceivedEventArgsResponse Property

Gets a ISdkTicket representing received response

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

TicketResponseReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketResponseReceivedEventArgs.Type Property

TicketResponseReceivedEventArgsType Property

Gets a value indicating from which type of ticket is this response

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

TicketResponseReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketResponseReceivedEventArgs Methods

The TicketResponseReceivedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TicketResponseReceivedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketSendFailedEventArgs Class

An event argument used by events raised when an attempt to send ticket failed
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.MTS.SDK.Entities.EventArgumentsTicketSendFailedEventArgs

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The TicketSendFailedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TicketSendFailedEventArgs | Initializes a new instance of the TicketSendFailedEventArgs class
Top
Properties
 | Name | Description
Public property | ErrorMessage | Gets the error message
Public property | TicketBody | Gets a ticket representation as json string
Public property | TicketId | Gets a ticketId
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketSendFailedEventArgs Constructor

Initializes a new instance of the TicketSendFailedEventArgs class

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

TicketSendFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketSendFailedEventArgs Properties

The TicketSendFailedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ErrorMessage | Gets the error message
Public property | TicketBody | Gets a ticket representation as json string
Public property | TicketId | Gets a ticketId
Top
See Also

Reference

TicketSendFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketSendFailedEventArgs.ErrorMessage Property

TicketSendFailedEventArgsErrorMessage Property

Gets the error message

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

TicketSendFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketSendFailedEventArgs.TicketBody Property

TicketSendFailedEventArgsTicketBody Property

Gets a ticket representation as json string

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

TicketSendFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketSendFailedEventArgs.TicketId Property

TicketSendFailedEventArgsTicketId Property

Gets a ticketId

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

TicketSendFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


TicketSendFailedEventArgs Methods

The TicketSendFailedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TicketSendFailedEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


UnparsableMessageEventArgs Class

Event arguments of UnparsableMessageReceived event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.MTS.SDK.Entities.EventArgumentsUnparsableMessageEventArgs

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The UnparsableMessageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UnparsableMessageEventArgs | Initializes a new instance of the UnparsableMessageEventArgs class
Top
Properties
 | Name | Description
Public property | Body | Gets the String representation of the JSON body associated with the unparsable message
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.EventArguments Namespace


UnparsableMessageEventArgs Constructor

Initializes a new instance of the UnparsableMessageEventArgs class

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

UnparsableMessageEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


UnparsableMessageEventArgs Properties

The UnparsableMessageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets the String representation of the JSON body associated with the unparsable message
Top
See Also

Reference

UnparsableMessageEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


UnparsableMessageEventArgs.Body Property

UnparsableMessageEventArgsBody Property

Gets the String representation of the JSON body associated with the unparsable message

Namespace: Sportradar.MTS.SDK.Entities.EventArguments
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

UnparsableMessageEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


UnparsableMessageEventArgs Methods

The UnparsableMessageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

UnparsableMessageEventArgs Class
Sportradar.MTS.SDK.Entities.EventArguments Namespace


Sportradar.MTS.SDK.Entities.Interfaces Namespace

Interfaces
 | Interface | Description
Public interface | IAlternativeStake | Defines a contract for alternative stake, mutually exclusive with reoffer
Public interface | IAutoAcceptedOdds | Defines a contract for auto accepted odds
Public interface | IBet | Defines a contract for a ticket bet
Public interface | IBetBonus | Defines a contract for classes implementing the bet bonus
Public interface | IBetCancel | Defines a contract for bet-level cancellation
Public interface | IBetCashout | Defines a contract for bet-level cashout
Public interface | IBetDetail | Defines a contract for bet-level response details
Public interface | IBetReoffer | Defines a contract for bet reoffer details, mutually exclusive with IAlternativeStake
Public interface | ICcf | Defines a contract for a customer confidence factor
Public interface | ICcfChange | Defines a contract for objects containing CCF change data
Public interface | IEndCustomer | Defines a contract for the identification of the end user (customer)
Public interface | IFreeStake | Defines a contract for classes implementing the free stake
Public interface | IRejectionInfo | Defines a contract for object carrying information about rejection
Public interface | IResponseReason | Defines a contract for object carrying information about rejection cause
Public interface | ISdkTicket | Defines a contract for classes representing base sdk ticket
Public interface | ISelection | Defines a contract for ticket selection
Public interface | ISelectionDetail | Defines a contract for per-selection rejection reasons
Public interface | ISelectionRef | Defines a contract for selection references
Public interface | ISender | Defines a contract for a identification and settings of the ticket sender
Public interface | ISportCcf | Defines a contract for a customer confidence factor values for sport and prematch/live (if set for customer)
Public interface | IStake | Defines a contract for classes implementing the stake of the bet
Public interface | ITicket | Contract defining Ticket that can be send to the MTS
Public interface | ITicketAck | Defines a contract for ticket acknowledgment ticket
Public interface | ITicketCancel | Contract defining Ticket that can be send to the MTS
Public interface | ITicketCancelAck | Object that is send to MTS to acknowledge ticket cancellation
Public interface | ITicketCancelResponse | Defines a contract for ticket cancellation response
Public interface | ITicketCashout | Contract defining Ticket that can be send to the MTS
Public interface | ITicketCashoutResponse | Defines a contract for ticket submission response
Public interface | ITicketNonSrSettle | Contract defining Ticket that can be send to the MTS
Public interface | ITicketNonSrSettleResponse | Defines a contract for ticket submission response
Public interface | ITicketReofferCancel | Contract defining Ticket that can be send to the MTS
Public interface | ITicketResponse | Defines a contract for ticket submission response


IAlternativeStake Interface

Defines a contract for alternative stake, mutually exclusive with reoffer

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IAlternativeStake type exposes the following members.

Properties
 | Name | Description
Public property | Stake | Gets the stake
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IAlternativeStake Properties

The IAlternativeStake type exposes the following members.

Properties
 | Name | Description
Public property | Stake | Gets the stake
Top
See Also

Reference

IAlternativeStake Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IAlternativeStake.Stake Property

IAlternativeStakeStake Property

Gets the stake

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IAlternativeStake Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IAutoAcceptedOdds Interface

Defines a contract for auto accepted odds

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IAutoAcceptedOdds type exposes the following members.

Properties
 | Name | Description
Public property | RequestedOdds | Odds with which the ticket was placed
Public property | SelectionIndex | Selection index from 'ticket.selections' array (zero based)
Public property | UsedOdds | Odds with which the ticket was accepted
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IAutoAcceptedOdds Properties

The IAutoAcceptedOdds type exposes the following members.

Properties
 | Name | Description
Public property | RequestedOdds | Odds with which the ticket was placed
Public property | SelectionIndex | Selection index from 'ticket.selections' array (zero based)
Public property | UsedOdds | Odds with which the ticket was accepted
Top
See Also

Reference

IAutoAcceptedOdds Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IAutoAcceptedOdds.RequestedOdds Property

IAutoAcceptedOddsRequestedOdds Property

Odds with which the ticket was placed

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IAutoAcceptedOdds Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IAutoAcceptedOdds.SelectionIndex Property

IAutoAcceptedOddsSelectionIndex Property

Selection index from 'ticket.selections' array (zero based)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IAutoAcceptedOdds Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IAutoAcceptedOdds.UsedOdds Property

IAutoAcceptedOddsUsedOdds Property

Odds with which the ticket was accepted

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IAutoAcceptedOdds Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet Interface

Defines a contract for a ticket bet

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IBet type exposes the following members.

Properties
 | Name | Description
Public property | Bonus | Gets the bonus of the bet (optional, default null)
Public property | CalculationOdds | Gets the odds calculated for custom bet multiplied by 10_000 and rounded to int value
Public property | CustomBet | Gets the flag if bet is a custom bet (optional, default false)
Public property | EntireStake | Gets the entire stake of the bet
Public property | FreeStake | Gets the free stkae of the bet (optional, default null)
Public property | Id | Gets the id of the bet
Public property | ReofferRefId | Gets the reoffer reference bet id
Public property | SelectedSystems | Gets array of all the systems (optional, if missing then complete accumulator is used)
Public property | Selections | Gets the array of selections which form the bet
Public property | Stake | Gets the stake of the bet
Public property | SumOfWins | Gets the sum of all wins for all generated combinations for this bet (in ticket currency, used in validation)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet Properties

The IBet type exposes the following members.

Properties
 | Name | Description
Public property | Bonus | Gets the bonus of the bet (optional, default null)
Public property | CalculationOdds | Gets the odds calculated for custom bet multiplied by 10_000 and rounded to int value
Public property | CustomBet | Gets the flag if bet is a custom bet (optional, default false)
Public property | EntireStake | Gets the entire stake of the bet
Public property | FreeStake | Gets the free stkae of the bet (optional, default null)
Public property | Id | Gets the id of the bet
Public property | ReofferRefId | Gets the reoffer reference bet id
Public property | SelectedSystems | Gets array of all the systems (optional, if missing then complete accumulator is used)
Public property | Selections | Gets the array of selections which form the bet
Public property | Stake | Gets the stake of the bet
Public property | SumOfWins | Gets the sum of all wins for all generated combinations for this bet (in ticket currency, used in validation)
Top
See Also

Reference

IBet Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet.Bonus Property

IBetBonus Property

Gets the bonus of the bet (optional, default null)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBet Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet.CalculationOdds Property

IBetCalculationOdds Property

Gets the odds calculated for custom bet multiplied by 10_000 and rounded to int value

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBet Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet.CustomBet Property

IBetCustomBet Property

Gets the flag if bet is a custom bet (optional, default false)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBet Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet.EntireStake Property

IBetEntireStake Property

Gets the entire stake of the bet

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBet Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet.FreeStake Property

IBetFreeStake Property

Gets the free stkae of the bet (optional, default null)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBet Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet.Id Property

IBetId Property

Gets the id of the bet

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBet Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet.ReofferRefId Property

IBetReofferRefId Property

Gets the reoffer reference bet id

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBet Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet.SelectedSystems Property

IBetSelectedSystems Property

Gets array of all the systems (optional, if missing then complete accumulator is used)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBet Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet.Selections Property

IBetSelections Property

Gets the array of selections which form the bet

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBet Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet.Stake Property

IBetStake Property

Gets the stake of the bet

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBet Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBet.SumOfWins Property

IBetSumOfWins Property

Gets the sum of all wins for all generated combinations for this bet (in ticket currency, used in validation)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBet Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetBonus Interface

Defines a contract for classes implementing the bet bonus

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IBetBonus type exposes the following members.

Properties
 | Name | Description
Public property | Description | The field description is optional. Clients will choose one of the pre-defined types: "accaBonus" – default value, assumed if missing in the ticket "oddsBooster" "other"
Public property | Mode | Gets the Payout mode (optional, default proportional). Relevant mostly for system bets. Any: if at least one bet wins entire bonus is paid out. Proportional: paid out bonus is proportional to number of won bets. All: all bets must win for bonus to be paid out.
Public property | PaidAs | The field PaidAs is optional, description of the bonus payment type: "cash" – default value, assumed if missing in the ticket "freeBet"
Public property | Type | Gets the type of the bonus
Public property | Value | Gets the Quantity multiplied by 10000 and rounded to a long value
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetBonus Properties

The IBetBonus type exposes the following members.

Properties
 | Name | Description
Public property | Description | The field description is optional. Clients will choose one of the pre-defined types: "accaBonus" – default value, assumed if missing in the ticket "oddsBooster" "other"
Public property | Mode | Gets the Payout mode (optional, default proportional). Relevant mostly for system bets. Any: if at least one bet wins entire bonus is paid out. Proportional: paid out bonus is proportional to number of won bets. All: all bets must win for bonus to be paid out.
Public property | PaidAs | The field PaidAs is optional, description of the bonus payment type: "cash" – default value, assumed if missing in the ticket "freeBet"
Public property | Type | Gets the type of the bonus
Public property | Value | Gets the Quantity multiplied by 10000 and rounded to a long value
Top
See Also

Reference

IBetBonus Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetBonus.Description Property

IBetBonusDescription Property

The field description is optional. Clients will choose one of the pre-defined types: "accaBonus" – default value, assumed if missing in the ticket "oddsBooster" "other"

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBonus Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetBonus.Mode Property

IBetBonusMode Property

Gets the Payout mode (optional, default proportional). Relevant mostly for system bets. Any: if at least one bet wins entire bonus is paid out. Proportional: paid out bonus is proportional to number of won bets. All: all bets must win for bonus to be paid out.

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBonus Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetBonus.PaidAs Property

IBetBonusPaidAs Property

The field PaidAs is optional, description of the bonus payment type: "cash" – default value, assumed if missing in the ticket "freeBet"

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBonus Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetBonus.Type Property

IBetBonusType Property

Gets the type of the bonus

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBonus Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetBonus.Value Property

IBetBonusValue Property

Gets the Quantity multiplied by 10000 and rounded to a long value

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetBonus Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetCancel Interface

Defines a contract for bet-level cancellation

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IBetCancel type exposes the following members.

Properties
 | Name | Description
Public property | BetId | Gets the id of the bet
Public property | CancelPercent | Gets the cancel percent of the assigned bet
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetCancel Properties

The IBetCancel type exposes the following members.

Properties
 | Name | Description
Public property | BetId | Gets the id of the bet
Public property | CancelPercent | Gets the cancel percent of the assigned bet
Top
See Also

Reference

IBetCancel Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetCancel.BetId Property

IBetCancelBetId Property

Gets the id of the bet

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetCancel Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetCancel.CancelPercent Property

IBetCancelCancelPercent Property

Gets the cancel percent of the assigned bet

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetCancel Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetCashout Interface

Defines a contract for bet-level cashout

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IBetCashout type exposes the following members.

Properties
 | Name | Description
Public property | BetId | Gets the id of the bet
Public property | CashoutPercent | Gets the cashout percent of the assigned bet
Public property | CashoutStake | Gets the cashout stake of the assigned bet
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetCashout Properties

The IBetCashout type exposes the following members.

Properties
 | Name | Description
Public property | BetId | Gets the id of the bet
Public property | CashoutPercent | Gets the cashout percent of the assigned bet
Public property | CashoutStake | Gets the cashout stake of the assigned bet
Top
See Also

Reference

IBetCashout Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetCashout.BetId Property

IBetCashoutBetId Property

Gets the id of the bet

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetCashout Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetCashout.CashoutPercent Property

IBetCashoutCashoutPercent Property

Gets the cashout percent of the assigned bet

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetCashout Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetCashout.CashoutStake Property

IBetCashoutCashoutStake Property

Gets the cashout stake of the assigned bet

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetCashout Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetDetail Interface

Defines a contract for bet-level response details

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IBetDetail type exposes the following members.

Properties
 | Name | Description
Public property | AlternativeStake | Gets the alternative stake, mutually exclusive with IBetReoffer
Public property | BetId | Gets the id of the bet
Public property | Reason | Gets the bet response reason.
Public property | Reoffer | Gets the bet reoffer details (mutually exclusive with IAlternativeStake)
Public property | SelectionDetails | Gets the array of selection details
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetDetail Properties

The IBetDetail type exposes the following members.

Properties
 | Name | Description
Public property | AlternativeStake | Gets the alternative stake, mutually exclusive with IBetReoffer
Public property | BetId | Gets the id of the bet
Public property | Reason | Gets the bet response reason.
Public property | Reoffer | Gets the bet reoffer details (mutually exclusive with IAlternativeStake)
Public property | SelectionDetails | Gets the array of selection details
Top
See Also

Reference

IBetDetail Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetDetail.AlternativeStake Property

IBetDetailAlternativeStake Property

Gets the alternative stake, mutually exclusive with IBetReoffer

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetDetail Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetDetail.BetId Property

IBetDetailBetId Property

Gets the id of the bet

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetDetail Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetDetail.Reason Property

IBetDetailReason Property

Gets the bet response reason.

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetDetail Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetDetail.Reoffer Property

IBetDetailReoffer Property

Gets the bet reoffer details (mutually exclusive with IAlternativeStake)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetDetail Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetDetail.SelectionDetails Property

IBetDetailSelectionDetails Property

Gets the array of selection details

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetDetail Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetReoffer Interface

Defines a contract for bet reoffer details, mutually exclusive with IAlternativeStake

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IBetReoffer type exposes the following members.

Properties
 | Name | Description
Public property | Stake | Gets the stake
Public property | Type | Gets the reoffer type. If auto then stake will be present. If manual you should wait for reoffer stake over Reply channel.
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetReoffer Properties

The IBetReoffer type exposes the following members.

Properties
 | Name | Description
Public property | Stake | Gets the stake
Public property | Type | Gets the reoffer type. If auto then stake will be present. If manual you should wait for reoffer stake over Reply channel.
Top
See Also

Reference

IBetReoffer Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetReoffer.Stake Property

IBetReofferStake Property

Gets the stake

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetReoffer Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IBetReoffer.Type Property

IBetReofferType Property

Gets the reoffer type. If auto then stake will be present. If manual you should wait for reoffer stake over Reply channel.

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IBetReoffer Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcf Interface

Defines a contract for a customer confidence factor

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ICcf type exposes the following members.

Properties
 | Name | Description
Public property | Ccf | Gets the customer confidence factor (factor multiplied by 10000)
Public property | SportCcfDetails | Gets ISportCcf values for sport and prematch/live (if set for customer)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcf Properties

The ICcf type exposes the following members.

Properties
 | Name | Description
Public property | Ccf | Gets the customer confidence factor (factor multiplied by 10000)
Public property | SportCcfDetails | Gets ISportCcf values for sport and prematch/live (if set for customer)
Top
See Also

Reference

ICcf Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcf.Ccf Property

ICcfCcf Property

Gets the customer confidence factor (factor multiplied by 10000)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICcf Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcf.SportCcfDetails Property

ICcfSportCcfDetails Property

Gets ISportCcf values for sport and prematch/live (if set for customer)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICcf Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcfChange Interface

Defines a contract for objects containing CCF change data

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ICcfChange type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Gets the bookmaker id of the ccf value change
Public property | Ccf | Gets the customer confidence factor for the customer
Public property | IsLive | Gets a value indicating whether the change was for live only
Public property | PreviousCcf | Gets the previous customer confidence factor for the customer
Public property | SourceId | Gets the source id of the ccf value change
Public property | SourceType | Gets the source type customer of the ccf value change
Public property | SportId | Gets the sport id
Public property | SportName | Gets the name of the sport
Public property | SubBookmakerId | Gets the sub bookmaker id of the ccf value change
Public property | Timestamp | Gets the timestamp of the ccf value change
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcfChange Properties

The ICcfChange type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Gets the bookmaker id of the ccf value change
Public property | Ccf | Gets the customer confidence factor for the customer
Public property | IsLive | Gets a value indicating whether the change was for live only
Public property | PreviousCcf | Gets the previous customer confidence factor for the customer
Public property | SourceId | Gets the source id of the ccf value change
Public property | SourceType | Gets the source type customer of the ccf value change
Public property | SportId | Gets the sport id
Public property | SportName | Gets the name of the sport
Public property | SubBookmakerId | Gets the sub bookmaker id of the ccf value change
Public property | Timestamp | Gets the timestamp of the ccf value change
Top
See Also

Reference

ICcfChange Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcfChange.BookmakerId Property

ICcfChangeBookmakerId Property

Gets the bookmaker id of the ccf value change

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICcfChange Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcfChange.Ccf Property

ICcfChangeCcf Property

Gets the customer confidence factor for the customer

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICcfChange Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcfChange.IsLive Property

ICcfChangeIsLive Property

Gets a value indicating whether the change was for live only

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICcfChange Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcfChange.PreviousCcf Property

ICcfChangePreviousCcf Property

Gets the previous customer confidence factor for the customer

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICcfChange Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcfChange.SourceId Property

ICcfChangeSourceId Property

Gets the source id of the ccf value change

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICcfChange Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcfChange.SourceType Property

ICcfChangeSourceType Property

Gets the source type customer of the ccf value change

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICcfChange Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcfChange.SportId Property

ICcfChangeSportId Property

Gets the sport id

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICcfChange Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcfChange.SportName Property

ICcfChangeSportName Property

Gets the name of the sport

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICcfChange Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcfChange.SubBookmakerId Property

ICcfChangeSubBookmakerId Property

Gets the sub bookmaker id of the ccf value change

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICcfChange Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ICcfChange.Timestamp Property

ICcfChangeTimestamp Property

Gets the timestamp of the ccf value change

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICcfChange Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IEndCustomer Interface

Defines a contract for the identification of the end user (customer)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IEndCustomer type exposes the following members.

Properties
 | Name | Description
Public property | Confidence | Gets the suggested CCF of the customer multiplied by 10000 and rounded to a long value
Public property | DeviceId | Gets the device end user's device id
Public property | Id | Gets the end user's unique id (in client's system)
Public property | Ip | Gets the end user's ip
Public property | LanguageId | Gets the 2-letter ISO 639-1 language code
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IEndCustomer Properties

The IEndCustomer type exposes the following members.

Properties
 | Name | Description
Public property | Confidence | Gets the suggested CCF of the customer multiplied by 10000 and rounded to a long value
Public property | DeviceId | Gets the device end user's device id
Public property | Id | Gets the end user's unique id (in client's system)
Public property | Ip | Gets the end user's ip
Public property | LanguageId | Gets the 2-letter ISO 639-1 language code
Top
See Also

Reference

IEndCustomer Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IEndCustomer.Confidence Property

IEndCustomerConfidence Property

Gets the suggested CCF of the customer multiplied by 10000 and rounded to a long value

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IEndCustomer Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IEndCustomer.DeviceId Property

IEndCustomerDeviceId Property

Gets the device end user's device id

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IEndCustomer Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IEndCustomer.Id Property

IEndCustomerId Property

Gets the end user's unique id (in client's system)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IEndCustomer Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IEndCustomer.Ip Property

IEndCustomerIp Property

Gets the end user's ip

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IEndCustomer Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IEndCustomer.LanguageId Property

IEndCustomerLanguageId Property

Gets the 2-letter ISO 639-1 language code

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IEndCustomer Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IFreeStake Interface

Defines a contract for classes implementing the free stake

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IFreeStake type exposes the following members.

Properties
 | Name | Description
Public property | Description | The field description is optional. Clients will choose one of the pre-defined types: "freeBet" – default value, assumed if missing in the ticket "rollover" "moneyBack" "oddsBooster" "partialFreeBet" "other"
Public property | PaidAs | The field PaidAs is optional, description of the bonus payment type: "cash" – default value, assumed if missing in the ticket "freeBet"
Public property | Type | Gets the type of the free stake
Public property | Value | Gets the Quantity multiplied by 10000 and rounded to a long value
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IFreeStake Properties

The IFreeStake type exposes the following members.

Properties
 | Name | Description
Public property | Description | The field description is optional. Clients will choose one of the pre-defined types: "freeBet" – default value, assumed if missing in the ticket "rollover" "moneyBack" "oddsBooster" "partialFreeBet" "other"
Public property | PaidAs | The field PaidAs is optional, description of the bonus payment type: "cash" – default value, assumed if missing in the ticket "freeBet"
Public property | Type | Gets the type of the free stake
Public property | Value | Gets the Quantity multiplied by 10000 and rounded to a long value
Top
See Also

Reference

IFreeStake Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IFreeStake.Description Property

IFreeStakeDescription Property

The field description is optional. Clients will choose one of the pre-defined types: "freeBet" – default value, assumed if missing in the ticket "rollover" "moneyBack" "oddsBooster" "partialFreeBet" "other"

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IFreeStake Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IFreeStake.PaidAs Property

IFreeStakePaidAs Property

The field PaidAs is optional, description of the bonus payment type: "cash" – default value, assumed if missing in the ticket "freeBet"

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IFreeStake Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IFreeStake.Type Property

IFreeStakeType Property

Gets the type of the free stake

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IFreeStake Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IFreeStake.Value Property

IFreeStakeValue Property

Gets the Quantity multiplied by 10000 and rounded to a long value

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IFreeStake Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IRejectionInfo Interface

Defines a contract for object carrying information about rejection

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IRejectionInfo type exposes the following members.

Properties
 | Name | Description
Public property | EventId | Gets the rejected selection's related Betradar event (match or outright) id
Public property | Id | Gets the rejected selection's related selection id
Public property | Odds | Gets the rejected selection's related Odds
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IRejectionInfo Properties

The IRejectionInfo type exposes the following members.

Properties
 | Name | Description
Public property | EventId | Gets the rejected selection's related Betradar event (match or outright) id
Public property | Id | Gets the rejected selection's related selection id
Public property | Odds | Gets the rejected selection's related Odds
Top
See Also

Reference

IRejectionInfo Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IRejectionInfo.EventId Property

IRejectionInfoEventId Property

Gets the rejected selection's related Betradar event (match or outright) id

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IRejectionInfo Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IRejectionInfo.Id Property

IRejectionInfoId Property

Gets the rejected selection's related selection id

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IRejectionInfo Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IRejectionInfo.Odds Property

IRejectionInfoOdds Property

Gets the rejected selection's related Odds

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IRejectionInfo Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IResponseReason Interface

Defines a contract for object carrying information about rejection cause

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IResponseReason type exposes the following members.

Properties
 | Name | Description
Public property | Code | Gets the reason code
Public property | Message | Gets the reason message
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IResponseReason Properties

The IResponseReason type exposes the following members.

Properties
 | Name | Description
Public property | Code | Gets the reason code
Public property | Message | Gets the reason message
Top
See Also

Reference

IResponseReason Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IResponseReason.Code Property

IResponseReasonCode Property

Gets the reason code

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IResponseReason Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IResponseReason.Message Property

IResponseReasonMessage Property

Gets the reason message

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IResponseReason Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISdkTicket Interface

Defines a contract for classes representing base sdk ticket

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ISdkTicket type exposes the following members.

Properties
 | Name | Description
Public property | CorrelationId | Gets the correlation identifier
Public property | TicketId | Gets the ticket id
Public property | Timestamp | Gets the timestamp of ticket placement (UTC)
Public property | Version | Gets the ticket format version
Top
Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISdkTicket Properties

The ISdkTicket type exposes the following members.

Properties
 | Name | Description
Public property | CorrelationId | Gets the correlation identifier
Public property | TicketId | Gets the ticket id
Public property | Timestamp | Gets the timestamp of ticket placement (UTC)
Public property | Version | Gets the ticket format version
Top
See Also

Reference

ISdkTicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISdkTicket.CorrelationId Property

ISdkTicketCorrelationId Property

Gets the correlation identifier

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
Only used to relate ticket with its response
See Also

Reference

ISdkTicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISdkTicket.TicketId Property

ISdkTicketTicketId Property

Gets the ticket id

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkTicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISdkTicket.Timestamp Property

ISdkTicketTimestamp Property

Gets the timestamp of ticket placement (UTC)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkTicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISdkTicket.Version Property

ISdkTicketVersion Property

Gets the ticket format version

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkTicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISdkTicket Methods

The ISdkTicket type exposes the following members.

Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS
Top
See Also

Reference

ISdkTicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISdkTicket.ToJson Method

ISdkTicketToJson Method

Gets the json representation of the ticket which is sent to or received from MTS

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISdkTicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelection Interface

Defines a contract for ticket selection

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ISelection type exposes the following members.

Properties
 | Name | Description
Public property | BoostedOdds | Gets the boosted odds multiplied by 10000 and rounded to int value
Public property | EventId | Gets the Betradar event (match or outright) id
Public property | Id | Gets the selection id
Public property | IsBanker | Gets a value indicating whether this instance is banker
Public property | Odds | Gets the odds multiplied by 10000 and rounded to int value
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelection Properties

The ISelection type exposes the following members.

Properties
 | Name | Description
Public property | BoostedOdds | Gets the boosted odds multiplied by 10000 and rounded to int value
Public property | EventId | Gets the Betradar event (match or outright) id
Public property | Id | Gets the selection id
Public property | IsBanker | Gets a value indicating whether this instance is banker
Public property | Odds | Gets the odds multiplied by 10000 and rounded to int value
Top
See Also

Reference

ISelection Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelection.BoostedOdds Property

ISelectionBoostedOdds Property

Gets the boosted odds multiplied by 10000 and rounded to int value

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
It is optional value
See Also

Reference

ISelection Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelection.EventId Property

ISelectionEventId Property

Gets the Betradar event (match or outright) id

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelection Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelection.Id Property

ISelectionId Property

Gets the selection id

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelection Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelection.IsBanker Property

ISelectionIsBanker Property

Gets a value indicating whether this instance is banker

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelection Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelection.Odds Property

ISelectionOdds Property

Gets the odds multiplied by 10000 and rounded to int value

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
It may be null for custom bets
See Also

Reference

ISelection Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelectionDetail Interface

Defines a contract for per-selection rejection reasons

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ISelectionDetail type exposes the following members.

Properties
 | Name | Description
Public property | Reason | Gets the selection response reason
Public property | RejectionInfo | Gets the rejection information on selection level
Public property | SelectionIndex | Gets the index of the selection
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelectionDetail Properties

The ISelectionDetail type exposes the following members.

Properties
 | Name | Description
Public property | Reason | Gets the selection response reason
Public property | RejectionInfo | Gets the rejection information on selection level
Public property | SelectionIndex | Gets the index of the selection
Top
See Also

Reference

ISelectionDetail Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelectionDetail.Reason Property

ISelectionDetailReason Property

Gets the selection response reason

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionDetail Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelectionDetail.RejectionInfo Property

ISelectionDetailRejectionInfo Property

Gets the rejection information on selection level

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionDetail Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelectionDetail.SelectionIndex Property

ISelectionDetailSelectionIndex Property

Gets the index of the selection

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionDetail Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelectionRef Interface

Defines a contract for selection references

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ISelectionRef type exposes the following members.

Properties
 | Name | Description
Public property | Banker | Gets a value indicating whether this ISelectionRef is banker.
Public property | SelectionIndex | Gets the selection index from 'ticket.selections' array (zero based)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelectionRef Properties

The ISelectionRef type exposes the following members.

Properties
 | Name | Description
Public property | Banker | Gets a value indicating whether this ISelectionRef is banker.
Public property | SelectionIndex | Gets the selection index from 'ticket.selections' array (zero based)
Top
See Also

Reference

ISelectionRef Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelectionRef.Banker Property

ISelectionRefBanker Property

Gets a value indicating whether this ISelectionRef is banker.

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionRef Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISelectionRef.SelectionIndex Property

ISelectionRefSelectionIndex Property

Gets the selection index from 'ticket.selections' array (zero based)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelectionRef Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISender Interface

Defines a contract for a identification and settings of the ticket sender

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ISender type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Gets the ticket bookmaker id (client's id provided by Sportradar)
Public property | Channel | Gets the senders communication channel
Public property | Currency | Gets the 3 letter currency code
Public property | EndCustomer | Gets the identification of the end user (customer)
Public property | LimitId | Gets the client's limit id (provided by Sportradar to the client)
Public property | ShopId | Gets the shop id
Public property | TerminalId | Gets the terminal id
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISender Properties

The ISender type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Gets the ticket bookmaker id (client's id provided by Sportradar)
Public property | Channel | Gets the senders communication channel
Public property | Currency | Gets the 3 letter currency code
Public property | EndCustomer | Gets the identification of the end user (customer)
Public property | LimitId | Gets the client's limit id (provided by Sportradar to the client)
Public property | ShopId | Gets the shop id
Public property | TerminalId | Gets the terminal id
Top
See Also

Reference

ISender Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISender.BookmakerId Property

ISenderBookmakerId Property

Gets the ticket bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISender Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISender.Channel Property

ISenderChannel Property

Gets the senders communication channel

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISender Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISender.Currency Property

ISenderCurrency Property

Gets the 3 letter currency code

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISender Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISender.EndCustomer Property

ISenderEndCustomer Property

Gets the identification of the end user (customer)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISender Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISender.LimitId Property

ISenderLimitId Property

Gets the client's limit id (provided by Sportradar to the client)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISender Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISender.ShopId Property

ISenderShopId Property

Gets the shop id

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISender Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISender.TerminalId Property

ISenderTerminalId Property

Gets the terminal id

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISender Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISportCcf Interface

Defines a contract for a customer confidence factor values for sport and prematch/live (if set for customer)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ISportCcf type exposes the following members.

Properties
 | Name | Description
Public property | LiveCcf | Gets customer confidence factor for the sport for live selections (factor multiplied by 10000)
Public property | PrematchCcf | Gets customer confidence factor for the sport for prematch selections (factor multiplied by 10000)
Public property | SportId | Gets sport ID
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISportCcf Properties

The ISportCcf type exposes the following members.

Properties
 | Name | Description
Public property | LiveCcf | Gets customer confidence factor for the sport for live selections (factor multiplied by 10000)
Public property | PrematchCcf | Gets customer confidence factor for the sport for prematch selections (factor multiplied by 10000)
Public property | SportId | Gets sport ID
Top
See Also

Reference

ISportCcf Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISportCcf.LiveCcf Property

ISportCcfLiveCcf Property

Gets customer confidence factor for the sport for live selections (factor multiplied by 10000)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISportCcf Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISportCcf.PrematchCcf Property

ISportCcfPrematchCcf Property

Gets customer confidence factor for the sport for prematch selections (factor multiplied by 10000)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISportCcf Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ISportCcf.SportId Property

ISportCcfSportId Property

Gets sport ID

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISportCcf Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IStake Interface

Defines a contract for classes implementing the stake of the bet

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IStake type exposes the following members.

Properties
 | Name | Description
Public property | Type | Gets the type of the stake
Public property | Value | Gets the value
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


IStake Properties

The IStake type exposes the following members.

Properties
 | Name | Description
Public property | Type | Gets the type of the stake
Public property | Value | Gets the value
Top
See Also

Reference

IStake Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IStake.Type Property

IStakeType Property

Gets the type of the stake

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IStake Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


IStake.Value Property

IStakeValue Property

Gets the value

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IStake Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket Interface

Contract defining Ticket that can be send to the MTS

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicket type exposes the following members.

Properties
 | Name | Description
Public property | AltStakeRefId | Gets the alternative stake reference ticket id
Public property | Bets | Gets the collection of all bets
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | LastMatchEndTime | Gets end time of last (non Sportradar) match on ticket
Public property | OddsChange | Gets the type of the odds change Accept change in odds (optional, default none) None: default behavior Any: any odds change accepted Higher: accept higher odds
Public property | PayCap | Capped max payout of the ticket
Public property | ReofferId | Gets the reoffer reference ticket id
Public property | Selections | Gets the collection of all selections
Public property | Sender | Gets the identification and settings of the ticket sender
Public property | TestSource | Gets a value indicating whether this is for testing
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | TotalCombinations | Gets the expected total number of generated combinations on this ticket (optional, default null). If present, it is used to validate against actual number of generated combinations.
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket Properties

The ITicket type exposes the following members.

Properties
 | Name | Description
Public property | AltStakeRefId | Gets the alternative stake reference ticket id
Public property | Bets | Gets the collection of all bets
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | LastMatchEndTime | Gets end time of last (non Sportradar) match on ticket
Public property | OddsChange | Gets the type of the odds change Accept change in odds (optional, default none) None: default behavior Any: any odds change accepted Higher: accept higher odds
Public property | PayCap | Capped max payout of the ticket
Public property | ReofferId | Gets the reoffer reference ticket id
Public property | Selections | Gets the collection of all selections
Public property | Sender | Gets the identification and settings of the ticket sender
Public property | TestSource | Gets a value indicating whether this is for testing
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | TotalCombinations | Gets the expected total number of generated combinations on this ticket (optional, default null). If present, it is used to validate against actual number of generated combinations.
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
See Also

Reference

ITicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket.AltStakeRefId Property

ITicketAltStakeRefId Property

Gets the alternative stake reference ticket id

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket.Bets Property

ITicketBets Property

Gets the collection of all bets

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket.LastMatchEndTime Property

ITicketLastMatchEndTime Property

Gets end time of last (non Sportradar) match on ticket

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket.OddsChange Property

ITicketOddsChange Property

Gets the type of the odds change Accept change in odds (optional, default none) None: default behavior Any: any odds change accepted Higher: accept higher odds

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket.PayCap Property

ITicketPayCap Property

Capped max payout of the ticket

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket.ReofferId Property

ITicketReofferId Property

Gets the reoffer reference ticket id

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket.Selections Property

ITicketSelections Property

Gets the collection of all selections

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket.Sender Property

ITicketSender Property

Gets the identification and settings of the ticket sender

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket.TestSource Property

ITicketTestSource Property

Gets a value indicating whether this is for testing

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket.TotalCombinations Property

ITicketTotalCombinations Property

Gets the expected total number of generated combinations on this ticket (optional, default null). If present, it is used to validate against actual number of generated combinations.

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicket Methods

The ITicket type exposes the following members.

Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

ITicket Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketAck Interface

Defines a contract for ticket acknowledgment ticket

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketAck type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public property | Code | Get the code
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | Message | Gets the message.
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | TicketStatus | Gets the status of the ticket
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketAck Properties

The ITicketAck type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public property | Code | Get the code
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | Message | Gets the message.
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | TicketStatus | Gets the status of the ticket
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketAck Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketAck.BookmakerId Property

ITicketAckBookmakerId Property

Get the bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketAck Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketAck.Code Property

ITicketAckCode Property

Get the code

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketAck Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketAck.Message Property

ITicketAckMessage Property

Gets the message.

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketAck Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketAck.TicketStatus Property

ITicketAckTicketStatus Property

Gets the status of the ticket

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketAck Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketAck Methods

The ITicketAck type exposes the following members.

Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketAck Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancel Interface

Contract defining Ticket that can be send to the MTS

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketCancel type exposes the following members.

Properties
 | Name | Description
Public property | BetCancels | Gets the list of IBetCancel
Public property | BookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public property | CancelPercent | Gets the cancel percent
Public property | Code | Gets the cancellation code
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancel Properties

The ITicketCancel type exposes the following members.

Properties
 | Name | Description
Public property | BetCancels | Gets the list of IBetCancel
Public property | BookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public property | CancelPercent | Gets the cancel percent
Public property | Code | Gets the cancellation code
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketCancel Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancel.BetCancels Property

ITicketCancelBetCancels Property

Gets the list of IBetCancel

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancel Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancel.BookmakerId Property

ITicketCancelBookmakerId Property

Get the bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancel Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancel.CancelPercent Property

ITicketCancelCancelPercent Property

Gets the cancel percent

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancel Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancel.Code Property

ITicketCancelCode Property

Gets the cancellation code

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancel Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancel Methods

The ITicketCancel type exposes the following members.

Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketCancel Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelAck Interface

Object that is send to MTS to acknowledge ticket cancellation

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketCancelAck type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public property | Code | Gets the code
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | Message | Gets the message.
Public property | TicketCancelStatus | Gets the status of the ticket cancel
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelAck Properties

The ITicketCancelAck type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public property | Code | Gets the code
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | Message | Gets the message.
Public property | TicketCancelStatus | Gets the status of the ticket cancel
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketCancelAck Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelAck.BookmakerId Property

ITicketCancelAckBookmakerId Property

Get the bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelAck Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelAck.Code Property

ITicketCancelAckCode Property

Gets the code

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelAck Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelAck.Message Property

ITicketCancelAckMessage Property

Gets the message.

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelAck Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelAck.TicketCancelStatus Property

ITicketCancelAckTicketCancelStatus Property

Gets the status of the ticket cancel

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelAck Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelAck Methods

The ITicketCancelAck type exposes the following members.

Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketCancelAck Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelResponse Interface

Defines a contract for ticket cancellation response

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketCancelResponse type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the additional information about the response
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | Reason | Gets the response reason
Public property | Signature | Gets the response signature/hash (previous BetAcceptanceId)
Public property | Status | Gets the status of the cancellation
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
Methods
 | Name | Description
Public method | Acknowledge(Boolean) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | Acknowledge(Boolean, Int32, Int32, String) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelResponse Properties

The ITicketCancelResponse type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the additional information about the response
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | Reason | Gets the response reason
Public property | Signature | Gets the response signature/hash (previous BetAcceptanceId)
Public property | Status | Gets the status of the cancellation
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketCancelResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelResponse.AdditionalInfo Property

ITicketCancelResponseAdditionalInfo Property

Gets the additional information about the response

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
Contains timestamps describing mts processing (receivedUtcTimestamp, validatedUtcTimestamp, respondedUtcTimestamp)
See Also

Reference

ITicketCancelResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelResponse.Reason Property

ITicketCancelResponseReason Property

Gets the response reason

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelResponse.Signature Property

ITicketCancelResponseSignature Property

Gets the response signature/hash (previous BetAcceptanceId)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelResponse.Status Property

ITicketCancelResponseStatus Property

Gets the status of the cancellation

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCancelResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCancelResponse Methods

The ITicketCancelResponse type exposes the following members.

Methods
 | Name | Description
Public method | Acknowledge(Boolean) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | Acknowledge(Boolean, Int32, Int32, String) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketCancelResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashout Interface

Contract defining Ticket that can be send to the MTS

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketCashout type exposes the following members.

Properties
 | Name | Description
Public property | BetCashouts | Gets the list of IBetCashout
Public property | BookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public property | CashoutPercent | Gets the cashout percent
Public property | CashoutStake | Gets the cashout stake
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashout Properties

The ITicketCashout type exposes the following members.

Properties
 | Name | Description
Public property | BetCashouts | Gets the list of IBetCashout
Public property | BookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public property | CashoutPercent | Gets the cashout percent
Public property | CashoutStake | Gets the cashout stake
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketCashout Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashout.BetCashouts Property

ITicketCashoutBetCashouts Property

Gets the list of IBetCashout

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashout Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashout.BookmakerId Property

ITicketCashoutBookmakerId Property

Get the bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashout Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashout.CashoutPercent Property

ITicketCashoutCashoutPercent Property

Gets the cashout percent

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashout Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashout.CashoutStake Property

ITicketCashoutCashoutStake Property

Gets the cashout stake

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashout Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashout Methods

The ITicketCashout type exposes the following members.

Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketCashout Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashoutResponse Interface

Defines a contract for ticket submission response

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketCashoutResponse type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the additional information about the response
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | Reason | Gets the response reason
Public property | Signature | Gets the response signature/hash (previous BetAcceptanceId)
Public property | Status | Gets the status of the ticket cashout submission
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
Methods
 | Name | Description
Public method | Acknowledge(Boolean) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | Acknowledge(Boolean, Int32, Int32, String) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashoutResponse Properties

The ITicketCashoutResponse type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the additional information about the response
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | Reason | Gets the response reason
Public property | Signature | Gets the response signature/hash (previous BetAcceptanceId)
Public property | Status | Gets the status of the ticket cashout submission
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketCashoutResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashoutResponse.AdditionalInfo Property

ITicketCashoutResponseAdditionalInfo Property

Gets the additional information about the response

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
Contains timestamps describing mts processing (receivedUtcTimestamp, validatedUtcTimestamp, respondedUtcTimestamp)
See Also

Reference

ITicketCashoutResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashoutResponse.Reason Property

ITicketCashoutResponseReason Property

Gets the response reason

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashoutResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashoutResponse.Signature Property

ITicketCashoutResponseSignature Property

Gets the response signature/hash (previous BetAcceptanceId)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashoutResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashoutResponse.Status Property

ITicketCashoutResponseStatus Property

Gets the status of the ticket cashout submission

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketCashoutResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketCashoutResponse Methods

The ITicketCashoutResponse type exposes the following members.

Methods
 | Name | Description
Public method | Acknowledge(Boolean) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | Acknowledge(Boolean, Int32, Int32, String) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketCashoutResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketNonSrSettle Interface

Contract defining Ticket that can be send to the MTS

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketNonSrSettle type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | NonSrSettleStake | Gets the non-sportradar settle stake
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketNonSrSettle Properties

The ITicketNonSrSettle type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | NonSrSettleStake | Gets the non-sportradar settle stake
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketNonSrSettle Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketNonSrSettle.BookmakerId Property

ITicketNonSrSettleBookmakerId Property

Get the bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketNonSrSettle Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketNonSrSettle.NonSrSettleStake Property

ITicketNonSrSettleNonSrSettleStake Property

Gets the non-sportradar settle stake

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
If value is 0 means the ticket was not settled
See Also

Reference

ITicketNonSrSettle Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketNonSrSettle Methods

The ITicketNonSrSettle type exposes the following members.

Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketNonSrSettle Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketNonSrSettleResponse Interface

Defines a contract for ticket submission response

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketNonSrSettleResponse type exposes the following members.

Properties
 | Name | Description
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | Reason | Gets the response reason
Public property | Signature | Gets the response signature/hash (previous BetAcceptanceId)
Public property | Status | Gets the status of the ticket non-sportradar settle submission
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
Methods
 | Name | Description
Public method | Acknowledge(Boolean) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | Acknowledge(Boolean, Int32, Int32, String) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketNonSrSettleResponse Properties

The ITicketNonSrSettleResponse type exposes the following members.

Properties
 | Name | Description
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | Reason | Gets the response reason
Public property | Signature | Gets the response signature/hash (previous BetAcceptanceId)
Public property | Status | Gets the status of the ticket non-sportradar settle submission
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketNonSrSettleResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketNonSrSettleResponse.Reason Property

ITicketNonSrSettleResponseReason Property

Gets the response reason

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketNonSrSettleResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketNonSrSettleResponse.Signature Property

ITicketNonSrSettleResponseSignature Property

Gets the response signature/hash (previous BetAcceptanceId)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketNonSrSettleResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketNonSrSettleResponse.Status Property

ITicketNonSrSettleResponseStatus Property

Gets the status of the ticket non-sportradar settle submission

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketNonSrSettleResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketNonSrSettleResponse Methods

The ITicketNonSrSettleResponse type exposes the following members.

Methods
 | Name | Description
Public method | Acknowledge(Boolean) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | Acknowledge(Boolean, Int32, Int32, String) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketNonSrSettleResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketReofferCancel Interface

Contract defining Ticket that can be send to the MTS

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketReofferCancel type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketReofferCancel Properties

The ITicketReofferCancel type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Get the bookmaker id (client's id provided by Sportradar)
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketReofferCancel Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketReofferCancel.BookmakerId Property

ITicketReofferCancelBookmakerId Property

Get the bookmaker id (client's id provided by Sportradar)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketReofferCancel Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketReofferCancel Methods

The ITicketReofferCancel type exposes the following members.

Methods
 | Name | Description
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketReofferCancel Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketResponse Interface

Defines a contract for ticket submission response

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ITicketResponse type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the additional information about the response
Public property | AutoAcceptedOdds | Gets the automatic accepted odds
Public property | BetDetails | Gets the bet details
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | ExchangeRate | Gets the exchange rate used when converting currencies to EUR. Long multiplied by 10000 and rounded to a long value
Public property | Reason | Gets the response reason
Public property | Signature | Gets the response signature/hash (previous BetAcceptanceId)
Public property | Status | Gets the status of the ticket submission
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
Methods
 | Name | Description
Public method | Acknowledge(Boolean) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | Acknowledge(Boolean, Int32, Int32, String) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketResponse Properties

The ITicketResponse type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the additional information about the response
Public property | AutoAcceptedOdds | Gets the automatic accepted odds
Public property | BetDetails | Gets the bet details
Public property | CorrelationId | Gets the correlation identifier (Inherited from ISdkTicket)
Public property | ExchangeRate | Gets the exchange rate used when converting currencies to EUR. Long multiplied by 10000 and rounded to a long value
Public property | Reason | Gets the response reason
Public property | Signature | Gets the response signature/hash (previous BetAcceptanceId)
Public property | Status | Gets the status of the ticket submission
Public property | TicketId | Gets the ticket id (Inherited from ISdkTicket)
Public property | Timestamp | Gets the timestamp of ticket placement (UTC) (Inherited from ISdkTicket)
Public property | Version | Gets the ticket format version (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketResponse.AdditionalInfo Property

ITicketResponseAdditionalInfo Property

Gets the additional information about the response

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
Remarks
Contains timestamps describing mts processing (receivedUtcTimestamp, validatedUtcTimestamp, respondedUtcTimestamp)
See Also

Reference

ITicketResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketResponse.AutoAcceptedOdds Property

ITicketResponseAutoAcceptedOdds Property

Gets the automatic accepted odds

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketResponse.BetDetails Property

ITicketResponseBetDetails Property

Gets the bet details

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketResponse.ExchangeRate Property

ITicketResponseExchangeRate Property

Gets the exchange rate used when converting currencies to EUR. Long multiplied by 10000 and rounded to a long value

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketResponse.Reason Property

ITicketResponseReason Property

Gets the response reason

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketResponse.Signature Property

ITicketResponseSignature Property

Gets the response signature/hash (previous BetAcceptanceId)

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketResponse.Status Property

ITicketResponseStatus Property

Gets the status of the ticket submission

Namespace: Sportradar.MTS.SDK.Entities.Interfaces
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ITicketResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


ITicketResponse Methods

The ITicketResponse type exposes the following members.

Methods
 | Name | Description
Public method | Acknowledge(Boolean) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | Acknowledge(Boolean, Int32, Int32, String) | Send acknowledgment back to MTS (Inherited from IAcknowledgeable)
Public method | ToJson | Gets the json representation of the ticket which is sent to or received from MTS (Inherited from ISdkTicket)
Top
See Also

Reference

ITicketResponse Interface
Sportradar.MTS.SDK.Entities.Interfaces Namespace


Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace

Interfaces
 | Interface | Description
Public interface | IAvailableSelections | Provides an available selections for a particular event
Public interface | ICalculation | Provides a probability calculation
Public interface | IMarket | Provides an available selections for a particular market
Public interface | ISelection | Provides an requested selection


IAvailableSelections Interface

Provides an available selections for a particular event

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IAvailableSelections type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets the String of the event
Public property | Markets | Gets the list of markets for this event
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


IAvailableSelections Properties

The IAvailableSelections type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets the String of the event
Public property | Markets | Gets the list of markets for this event
Top
See Also

Reference

IAvailableSelections Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


IAvailableSelections.Event Property

IAvailableSelectionsEvent Property

Gets the String of the event

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IAvailableSelections Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


IAvailableSelections.Markets Property

IAvailableSelectionsMarkets Property

Gets the list of markets for this event

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IAvailableSelections Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


ICalculation Interface

Provides a probability calculation

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ICalculation type exposes the following members.

Properties
 | Name | Description
Public property | Odds | Gets the odds
Public property | Probability | Gets the probability
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


ICalculation Properties

The ICalculation type exposes the following members.

Properties
 | Name | Description
Public property | Odds | Gets the odds
Public property | Probability | Gets the probability
Top
See Also

Reference

ICalculation Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


ICalculation.Odds Property

ICalculationOdds Property

Gets the odds

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICalculation Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


ICalculation.Probability Property

ICalculationProbability Property

Gets the probability

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ICalculation Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


IMarket Interface

Provides an available selections for a particular market

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The IMarket type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the id of the market
Public property | Outcomes | Gets the outcomes for this market
Public property | Specifiers | Gets the specifiers for this market
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


IMarket Properties

The IMarket type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the id of the market
Public property | Outcomes | Gets the outcomes for this market
Public property | Specifiers | Gets the specifiers for this market
Top
See Also

Reference

IMarket Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


IMarket.Id Property

IMarketId Property

Gets the id of the market

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMarket Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


IMarket.Outcomes Property

IMarketOutcomes Property

Gets the outcomes for this market

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMarket Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


IMarket.Specifiers Property

IMarketSpecifiers Property

Gets the specifiers for this market

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

IMarket Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


ISelection Interface

Provides an requested selection

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The ISelection type exposes the following members.

Properties
 | Name | Description
Public property | EventId | Gets the event id.
Public property | MarketId | Gets the market id.
Public property | OutcomeId | Gets the outcome id.
Public property | Specifiers | Gets the specifiers.
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


ISelection Properties

The ISelection type exposes the following members.

Properties
 | Name | Description
Public property | EventId | Gets the event id.
Public property | MarketId | Gets the market id.
Public property | OutcomeId | Gets the outcome id.
Public property | Specifiers | Gets the specifiers.
Top
See Also

Reference

ISelection Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


ISelection.EventId Property

ISelectionEventId Property

Gets the event id.

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelection Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


ISelection.MarketId Property

ISelectionMarketId Property

Gets the market id.

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelection Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


ISelection.OutcomeId Property

ISelectionOutcomeId Property

Gets the outcome id.

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelection Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


ISelection.Specifiers Property

ISelectionSpecifiers Property

Gets the specifiers.

Namespace: Sportradar.MTS.SDK.Entities.Interfaces.CustomBet
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

ISelection Interface
Sportradar.MTS.SDK.Entities.Interfaces.CustomBet Namespace


Sportradar.MTS.SDK.Entities.Utils Namespace

Classes
 | Class | Description
Public class | JsonUtils | Helper class used to serialize tickets


JsonUtils Class

Helper class used to serialize tickets
Inheritance Hierarchy
SystemObject
Sportradar.MTS.SDK.Entities.UtilsJsonUtils

Namespace: Sportradar.MTS.SDK.Entities.Utils
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2

The JsonUtils type exposes the following members.

Methods
Name | Description
DeserializeT | Deserialize given ticket
Serialize | Serialize given ticket
Top
See Also

Reference

Sportradar.MTS.SDK.Entities.Utils Namespace


JsonUtils Methods

The JsonUtils type exposes the following members.

Methods
Name | Description
DeserializeT | Deserialize given ticket
Serialize | Serialize given ticket
Top
See Also

Reference

JsonUtils Class
Sportradar.MTS.SDK.Entities.Utils Namespace


JsonUtils.Deserialize<T> Method

JsonUtilsDeserializeT Method

Deserialize given ticket

Namespace: Sportradar.MTS.SDK.Entities.Utils
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

JsonUtils Class
Sportradar.MTS.SDK.Entities.Utils Namespace


JsonUtils.Serialize Method

JsonUtilsSerialize Method

Serialize given ticket

Namespace: Sportradar.MTS.SDK.Entities.Utils
Assembly: Sportradar.MTS.SDK (in Sportradar.MTS.SDK.dll) Version: 2.4.1.2
See Also

Reference

JsonUtils Class
Sportradar.MTS.SDK.Entities.Utils Namespace


SDK Technology Architecture1

Required introduction

Optional section title

Add one or more sections with content


Version 1.0.0.0

Version 1.0.0.0 was released on 10th Dec 2020.

Changes in This Release

  • First initial commit

  • First version
See Also

Other Resources

Version History


Version 1.0.1.0

Optional summary abstract

Required introduction

Optional section title

Add one or more sections with content

Sub-section 1

Sub-section content.

Media file from main project: Ticket Diagram

Media file from doc project: Sdk Tickets Diagram

Media file from doc project (ref Help): Help

Sub-section 2

Sub-section content. Version 1.0.0.0

C#
Copy
public class CSharpClass()
{
    // Members go here
}
VB
Copy
Public Class VBClass
    ' Members go here
End Class
See Also

Reference

[Sportradar.MTS.SDK.API.IMtsSdk]
IMtsSdk
ConnectionStatus
#ctor
[T:Sportradar.MTS.SDK.API.MtsSdk.#ctor]
GetLogger
LoggerType
MetricsRoot

Other Resources

Version History
Link inner text
External link text
Version History
Some other topic
SHFB on GitHub


Version 1.1.0.0

Required introduction

Optional section title

Add one or more sections with content


Glossary

Group #1

Group #1

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

1

1st term, Other term (if any)

The definition of the term(s)


Version History

The topics in this section describe the various changes made to the [TODO: Project Title] over the life of the project.

Version History

Select a version below to see a description of its changes.

  • Version 1.0.1.0

  • Version 1.0.0.0

See Also

Other Resources

Sportradar MTS SDK .NET Standard