UnifiedFeed SDK .NET

UnifiedFeed SDK is a client library that enables easier integration with the Betradar XML feeds. SDK exposes XML feed service interface in a more user-friendly way and isolates the client from having to do XML feed parsing, proper connection handling, error recovery, event queuing, data caching and dispatching. It also makes a client solution more stable and robust when it comes to feed handling, especially with the release of new and updated XML feed versions.

For a quick start consider consulting the Example project also found in Downloads.

Getting Started

For a quick start consider consulting the Example project also found in Downloads.

Obtaining the SDK

The SDK is provided as a code library (Sportradar.OddsFeed.SDK.dll), which is available on the SDK site and via the NuGet package manager. The usage of NuGet package manager is recommended, since it supports update notifications and makes it easier to obtain new releases of the SDK.

Copyright © 2016-2022, Sportradar AG

Send comments on this topic to SDK Team


Sportradar.OddsFeed.SDK.API Namespace

Classes
 | Class | Description
Public class | EntityDispatcherBase | A base class for classes used to dispatch messages
Public class | Feed | A IOddsFeed implementation acting as an entry point to the odds feed SDK
Public class | ReplayFeed | A IOddsFeed implementation acting as an entry point to the odds feed Replay Service for doing integration tests against played matches that are older than 48 hours
Interfaces
 | Interface | Description
Public interface | IBookingManager | Defines a contract for classes implementing booking manager to perform various booking calendar operations
Public interface | ICashOutProbabilitiesProvider | Defines a type used to retrieve market probabilities used for cash out
Public interface | IConfigurationAccessTokenSetter | Obsolete. Defines method used to set access token property on the configuration builder
Public interface | IConfigurationBuilder | Defines a contract implemented by classes used to set general configuration properties
Public interface | IConfigurationBuilderBaseT | A base contract custom and general configuration builders
Public interface | IConfigurationInactivitySecondsSetter | Obsolete. Defines method used to set inactivity seconds property on the configuration builder
Public interface | ICustomBetManager | Defines methods used to perform various custom bet operations
Public interface | ICustomBetSelectionBuilder | Defines methods used to build selections
Public interface | ICustomConfigurationBuilder | Defines a contract implemented by classes used to set general and custom configuration properties
Public interface | IEntityDispatcherT | Specifies a contract defining events used for user notification
Public interface | IEnvironmentSelector | Defines a contract implemented by classes taking care of the 2nd step when building configuration - selecting the environment.
Public interface | IEnvironmentSelectorV1 | Defines a contract implemented by classes taking care of the 2nd step when building configuration - selecting the environment.
Public interface | IEventChangeManager | Defines a contract implemented by classes capable of getting list of IFixtureChange and/or IResultChange
Public interface | IEventRecoveryRequestIssuer | Defines a contract implemented by classes used to issue event message recovery requests to the feed
Public interface | IMarketDescriptionManager | Used to obtain information about available markets and get translations for markets and outcomes including outrights
Public interface | IMarketDescriptionManagerV1 | Used to obtain information about available markets and get translations for markets and outcomes including outrights
Public interface | IOddsFeed | Represent a root object of the unified odds feed
Public interface | IOddsFeedConfiguration | Defines a contract implemented by classes representing odds feed configuration / settings
Public interface | IOddsFeedConfigurationBuilder | Obsolete. Defines methods used to set optional properties on the configuration builder
Public interface | IOddsFeedSession | Represents a session to the odds feed
Public interface | IOddsFeedSessionBuilder | Represents a first step when building a IOddsFeedSession instance
Public interface | IOddsFeedV1 | Represent a root object of the unified odds feed
Public interface | IOddsFeedV2 | Represent a root object of the unified odds feed
Public interface | IOddsFeedV3 | Represent a root object of the unified odds feed
Public interface | IOddsFeedV4 | Represent a root object of the unified odds feed
Public interface | IOddsFeedV5 | Represent a root object of the unified odds feed
Public interface | IOddsFeedV6 | Represent a root object of the unified odds feed
Public interface | IProducersProvider | Defines a type used to retrieve available producers on api
Public interface | IRecoveryConfigurationBuilderT | Defines a contract implemented by classes used to set recovery related configuration properties
Public interface | IReplayConfigurationBuilder | Defines a contract implemented by classes used to set replay configuration properties
Public interface | IReplayEvent | Defines a contract implemented by classes representing replay events
Public interface | IReplayManager | Defines a contract implemented by classes capable of interacting with Replay Server
Public interface | IReplayManagerV1 | Defines a contract implemented by classes capable of interacting with Replay Server
Public interface | IReplayManagerV2 | Defines a contract implemented by classes capable of interacting with Replay Server
Public interface | IReplayResponse | Defines a contract for responses from Replay Server
Public interface | IReplayScenario | Defines a contract for replay scenario instances
Public interface | IReplayStatus | Defines a contract for status of replay player
Public interface | ISessionBuilder | Represents a second step when building a IOddsFeedSession instance
Public interface | ISpecificEntityDispatcherT | Defines a contract implemented by classes capable of dispatching only specific entities
Public interface | ISportDataProvider | Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)
Public interface | ISportDataProviderV1 | Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)
Public interface | ISportDataProviderV10 | Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)
Public interface | ISportDataProviderV11 | Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)
Public interface | ISportDataProviderV2 | Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)
Public interface | ISportDataProviderV3 | Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)
Public interface | ISportDataProviderV4 | Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)
Public interface | ISportDataProviderV5 | Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)
Public interface | ISportDataProviderV6 | Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)
Public interface | ISportDataProviderV7 | Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)
Public interface | ISportDataProviderV8 | Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)
Public interface | ISportDataProviderV9 | Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)
Public interface | ITokenSetter | Defines a contract implemented by classes taking care of the 1st step when building configuration - setting the token
Enumerations
 | Enumeration | Description
Public enumeration | CacheType | Enumerates the types of the caches supported by the SDK
Public enumeration | MessageType | Enumerates the types of the messages received from the feed
Public enumeration | ReplayPlayerStatus | Status of the replay player


CacheType Enumeration

Enumerates the types of the caches supported by the SDK

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[FlagsAttribute]
public enum CacheType
Members
Member name | Value | Description
SportData | 1 | Cache used to hold sport data items (sports and categories)
SportEvent | 2 | Cache used to hold sport event items (tournaments, matches, seasons...)
Profile | 4 | Cache used to hold profile items (player and team profiles)
All | 7 | All caches
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


EntityDispatcherBase Class

A base class for classes used to dispatch messages
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.APIEntityDispatcherBase
Sportradar.OddsFeed.SDK.APIFeed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class EntityDispatcherBase

The EntityDispatcherBase type exposes the following members.

Constructors
 | Name | Description
Protected method | EntityDispatcherBase | Initializes a new instance of the EntityDispatcherBase
Top
Methods
Name | Description
Protected method DispatchT(EventHandlerT, T, FeedMessage) Dispatches the
C#
Copy
message
Protected method | DispatchT(EventHandlerT, T, String, Int32) | Raises the specified event
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Protected method Finalize Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
Protected method MemberwiseClone Creates a shallow copy of the current Object.
(Inherited from Object)
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


EntityDispatcherBase Constructor

Initializes a new instance of the EntityDispatcherBase

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected EntityDispatcherBase()
See Also

Reference

EntityDispatcherBase Class
Sportradar.OddsFeed.SDK.API Namespace


EntityDispatcherBase Methods

The EntityDispatcherBase type exposes the following members.

Methods
Name | Description
Protected method DispatchT(EventHandlerT, T, FeedMessage) Dispatches the
C#
Copy
message
Protected method | DispatchT(EventHandlerT, T, String, Int32) | Raises the specified event
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Protected method Finalize Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
Protected method MemberwiseClone Creates a shallow copy of the current Object.
(Inherited from Object)
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Top
See Also

Reference

EntityDispatcherBase Class
Sportradar.OddsFeed.SDK.API Namespace


EntityDispatcherBase.Dispatch Method

Odds Feed SDK Documentation

EntityDispatcherBaseDispatch Method

Overload List
Name | Description
Protected method DispatchT(EventHandlerT, T, FeedMessage) Dispatches the
C#
Copy
message
Protected method | DispatchT(EventHandlerT, T, String, Int32) | Raises the specified event
Top
See Also

Reference

EntityDispatcherBase Class
Sportradar.OddsFeed.SDK.API Namespace


EntityDispatcherBase.Dispatch<T>(EventHandler<T>, T, FeedMessage) Method

EntityDispatcherBaseDispatchT(EventHandlerT, T, FeedMessage) Method

Dispatches the
C#
Copy
message

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected void Dispatch<T>(
    EventHandler<T> handler,
    T eventArgs,
    FeedMessage message
)

Parameters

handler EventHandler T
Event delegate
eventArgs T
Event arguments
message FeedMessage
A message to dispatch

Type Parameters

T
The type of the event arguments
See Also

Reference

EntityDispatcherBase Class
Dispatch Overload
Sportradar.OddsFeed.SDK.API Namespace


EntityDispatcherBase.Dispatch<T>(EventHandler<T>, T, String, Int32) Method

EntityDispatcherBaseDispatchT(EventHandlerT, T, String, Int32) Method

Raises the specified event

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected void Dispatch<T>(
    EventHandler<T> handler,
    T eventArgs,
    string messageName,
    int producerId
)

Parameters

handler EventHandler T
A EventHandlerTEventArgs representing the event
eventArgs T
Event arguments
messageName String
The name of the event
producerId Int32
The producer id

Type Parameters

T
The type of the event arguments
See Also

Reference

EntityDispatcherBase Class
Dispatch Overload
Sportradar.OddsFeed.SDK.API Namespace


Feed Class

A IOddsFeed implementation acting as an entry point to the odds feed SDK
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.APIEntityDispatcherBase
Sportradar.OddsFeed.SDK.APIFeed
Sportradar.OddsFeed.SDK.API.ExtendedFeedExt
Sportradar.OddsFeed.SDK.APIReplayFeed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class Feed : EntityDispatcherBase, IOddsFeedV6, IOddsFeedV5,
    IOddsFeedV4, IOddsFeedV3, IOddsFeedV2, IOddsFeedV1, IOddsFeed,
    IDisposable

The Feed type exposes the following members.

Constructors
 | Name | Description
Public method | Feed(IOddsFeedConfiguration) | Constructs a new instance of the Feed class
Protected method | Feed(IOddsFeedConfiguration, Boolean) | Initializes a new instance of the Feed class
Top
Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used
Public property | CashOutProbabilitiesProvider | Gets theICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed
Top
Methods
Name | Description
AvailableLanguages | Get all available languages that can be used within SDK and are supported on feed messages
Public method | Close | Closes the current Feed instance and disposes resources used by it
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder
CreateConfigurationBuilder Obsolete.
Constructs a IOddsFeedConfiguration instance from provided information
Protected method DispatchT(EventHandlerT, T, FeedMessage) Dispatches the
C#
Copy
message

(Inherited from EntityDispatcherBase)
Protected method DispatchT(EventHandlerT, T, String, Int32) Raises the specified event
(Inherited from EntityDispatcherBase)
Public method | DispatchConnectionException | Dispatches the information that the exception was thrown in connection loop The information about the exception
Public method | Dispose | Disposes the current instance and resources associated with it
Protected method | Dispose(Boolean) | Disposes the current instance and resources associated with it
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Protected method Finalize Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object)
GetConfigurationBuilder | Constructs a IOddsFeedConfiguration instance from provided information
GetConfigurationBuilderFromConfig Obsolete.
Constructs a IConfigurationBuilder instance, which already contains information read from the configuration (app.config) file
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
Protected method | InitFeed | Initializes the feed (unity)
Public method | IsOpen | Returns an indicator if the feed instance is opened or not
Protected method MemberwiseClone Creates a shallow copy of the current Object.
(Inherited from Object)
Public method | Open | Opens the current feed by opening all created sessions
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Protected method | UpdateDependency | Option to change/update dependency injection before resolving resources
Top
Events
 | Name | Description
Public event | Closed | Occurs when feed is closed
Public event | ConnectionException | Occurs when an exception occurs in the connection loop
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online)
Public event | RecoveryInitiated | Occurs when a recovery initiation completes
Top
Fields
 | Name | Description
Protected field | FeedInitialized | The feed initialized
Protected field | UnityContainer | A IUnityContainer used to resolve
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


Feed Constructor

Overload List
 | Name | Description
Public method | Feed(IOddsFeedConfiguration) | Constructs a new instance of the Feed class
Protected method | Feed(IOddsFeedConfiguration, Boolean) | Initializes a new instance of the Feed class
Top
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed(IOddsFeedConfiguration) Constructor

Constructs a new instance of the Feed class

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Feed(
    IOddsFeedConfiguration config
)

Parameters

config IOddsFeedConfiguration
A IOddsFeedConfiguration instance representing feed configuration
See Also

Reference

Feed Class
Feed Overload
Sportradar.OddsFeed.SDK.API Namespace


Feed(IOddsFeedConfiguration, Boolean) Constructor

Initializes a new instance of the Feed class

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected Feed(
    IOddsFeedConfiguration config,
    bool isReplay
)

Parameters

config IOddsFeedConfiguration
A IOddsFeedConfiguration instance representing feed configuration
isReplay Boolean
Value indicating whether the constructed instance will be used to connect to replay server
See Also

Reference

Feed Class
Feed Overload
Sportradar.OddsFeed.SDK.API Namespace


Feed Properties

The Feed type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used
Public property | CashOutProbabilitiesProvider | Gets theICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed
Top
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.BookingManager Property

FeedBookingManager Property

Gets a IBookingManager instance used to perform various booking calendar operations

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IBookingManager BookingManager { get; }

Property Value

IBookingManager
The booking manager

Implements

IOddsFeedBookingManager
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.BookmakerDetails Property

FeedBookmakerDetails Property

Gets a IBookmakerDetails instance used to get info about bookmaker and token used

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IBookmakerDetails BookmakerDetails { get; }

Property Value

IBookmakerDetails

Implements

IOddsFeedV1BookmakerDetails
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.CashOutProbabilitiesProvider Property

FeedCashOutProbabilitiesProvider Property

Gets theICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ICashOutProbabilitiesProvider CashOutProbabilitiesProvider { get; }

Property Value

ICashOutProbabilitiesProvider

Implements

IOddsFeedCashOutProbabilitiesProvider
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.CustomBetManager Property

FeedCustomBetManager Property

Gets a ICustomBetManager instance used to perform various custom bet operations

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ICustomBetManager CustomBetManager { get; }

Property Value

ICustomBetManager
The custom bet manager

Implements

IOddsFeedV2CustomBetManager
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.EventChangeManager Property

FeedEventChangeManager Property

Gets a IEventChangeManager instance used to automatically receive fixture and result changes

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IEventChangeManager EventChangeManager { get; }

Property Value

IEventChangeManager

Implements

IOddsFeedV4EventChangeManager
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.EventRecoveryRequestIssuer Property

FeedEventRecoveryRequestIssuer Property

Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IEventRecoveryRequestIssuer EventRecoveryRequestIssuer { get; }

Property Value

IEventRecoveryRequestIssuer

Implements

IOddsFeedEventRecoveryRequestIssuer
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.MarketDescriptionManager Property

FeedMarketDescriptionManager Property

Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IMarketDescriptionManager MarketDescriptionManager { get; }

Property Value

IMarketDescriptionManager

Implements

IOddsFeedV2MarketDescriptionManager
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.ProducerManager Property

FeedProducerManager Property

Gets a IProducerManager instance used to retrieve producer related data

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IProducerManager ProducerManager { get; }

Property Value

IProducerManager
The producer manager

Implements

IOddsFeedProducerManager
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.SportDataProvider Property

FeedSportDataProvider Property

Gets a ISportDataProvider instance used to retrieve sport related data from the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ISportDataProvider SportDataProvider { get; }

Property Value

ISportDataProvider
The sport data provider

Implements

IOddsFeedSportDataProvider
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed Methods

The Feed type exposes the following members.

Methods
Name | Description
AvailableLanguages | Get all available languages that can be used within SDK and are supported on feed messages
Public method | Close | Closes the current Feed instance and disposes resources used by it
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder
CreateConfigurationBuilder Obsolete.
Constructs a IOddsFeedConfiguration instance from provided information
Protected method DispatchT(EventHandlerT, T, FeedMessage) Dispatches the
C#
Copy
message

(Inherited from EntityDispatcherBase)
Protected method DispatchT(EventHandlerT, T, String, Int32) Raises the specified event
(Inherited from EntityDispatcherBase)
Public method | DispatchConnectionException | Dispatches the information that the exception was thrown in connection loop The information about the exception
Public method | Dispose | Disposes the current instance and resources associated with it
Protected method | Dispose(Boolean) | Disposes the current instance and resources associated with it
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Protected method Finalize Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object)
GetConfigurationBuilder | Constructs a IOddsFeedConfiguration instance from provided information
GetConfigurationBuilderFromConfig Obsolete.
Constructs a IConfigurationBuilder instance, which already contains information read from the configuration (app.config) file
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
Protected method | InitFeed | Initializes the feed (unity)
Public method | IsOpen | Returns an indicator if the feed instance is opened or not
Protected method MemberwiseClone Creates a shallow copy of the current Object.
(Inherited from Object)
Public method | Open | Opens the current feed by opening all created sessions
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Protected method | UpdateDependency | Option to change/update dependency injection before resolving resources
Top
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.AvailableLanguages Method

FeedAvailableLanguages Method

Get all available languages that can be used within SDK and are supported on feed messages

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static IEnumerable<CultureInfo> AvailableLanguages()

Return Value

IEnumerable CultureInfo
List<CultureInfo>
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.Close Method

FeedClose Method

Closes the current Feed instance and disposes resources used by it

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public void Close()

Implements

IOddsFeedClose
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.CreateBuilder Method

FeedCreateBuilder Method

Constructs and returns a new instance of IOddsFeedSessionBuilder

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IOddsFeedSessionBuilder CreateBuilder()

Return Value

IOddsFeedSessionBuilder
Constructed instance of the IOddsFeedSessionBuilder

Implements

IOddsFeedCreateBuilder
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.CreateConfigurationBuilder Method

FeedCreateConfigurationBuilder Method

Note: This API is now obsolete.

Constructs a IOddsFeedConfiguration instance from provided information

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use GetConfigurationBuilder")]
public static IConfigurationAccessTokenSetter CreateConfigurationBuilder()

Return Value

IConfigurationAccessTokenSetter
A IOddsFeedConfiguration instance created from provided information
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.DispatchConnectionException Method

FeedDispatchConnectionException Method

Dispatches the information that the exception was thrown in connection loop The information about the exception

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public void DispatchConnectionException(
    CallbackExceptionEventArgs callbackExceptionEventArgs
)

Parameters

callbackExceptionEventArgs CallbackExceptionEventArgs

[Missing <param name="callbackExceptionEventArgs"/> documentation for "M:Sportradar.OddsFeed.SDK.API.Feed.DispatchConnectionException(RabbitMQ.Client.Events.CallbackExceptionEventArgs)"]

See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.Dispose Method

FeedDispose Method

Overload List
 | Name | Description
Public method | Dispose | Disposes the current instance and resources associated with it
Protected method | Dispose(Boolean) | Disposes the current instance and resources associated with it
Top
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.Dispose Method

FeedDispose Method

Disposes the current instance and resources associated with it

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

Feed Class
Dispose Overload
Sportradar.OddsFeed.SDK.API Namespace


Feed.Dispose(Boolean) Method

FeedDispose(Boolean) Method

Disposes the current instance and resources associated with it

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing Boolean
Value indicating whether the managed resources should also be disposed
See Also

Reference

Feed Class
Dispose Overload
Sportradar.OddsFeed.SDK.API Namespace


Feed.GetConfigurationBuilder Method

FeedGetConfigurationBuilder Method

Constructs a IOddsFeedConfiguration instance from provided information

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static ITokenSetter GetConfigurationBuilder()

Return Value

ITokenSetter
A IOddsFeedConfiguration instance created from provided information
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.GetConfigurationBuilderFromConfig Method

FeedGetConfigurationBuilderFromConfig Method

Note: This API is now obsolete.

Constructs a IConfigurationBuilder instance, which already contains information read from the configuration (app.config) file

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use GetConfigurationBuilder")]
public static IOddsFeedConfigurationBuilder GetConfigurationBuilderFromConfig()

Return Value

IOddsFeedConfigurationBuilder
A IConfigurationBuilder instance, which already contains information read from the configuration (app.config) file
Exceptions
Exception | Condition
InvalidOperationException | The configuration could not be loaded, or the requested section does not exist in the config file
ConfigurationErrorsException | The section read from the configuration file is not valid
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.InitFeed Method

FeedInitFeed Method

Initializes the feed (unity)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected virtual void InitFeed()
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.IsOpen Method

FeedIsOpen Method

Returns an indicator if the feed instance is opened or not

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool IsOpen()

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.OddsFeed.SDK.API.Feed.IsOpen"]

Implements

IOddsFeedV6IsOpen
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.Open Method

FeedOpen Method

Opens the current feed by opening all created sessions

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public void Open()

Implements

IOddsFeedOpen
Exceptions
Exception | Condition
ObjectDisposedException |
InvalidOperationException | The feed is already opened or The configuration is not valid
CommunicationException | Connection to the REST-ful API failed, Probable Reason={Invalid or expired token} or Connection to the message broker failed, Probable Reason={Invalid or expired token} or
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.UpdateDependency Method

FeedUpdateDependency Method

Option to change/update dependency injection before resolving resources

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected virtual void UpdateDependency()
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed Events

The Feed type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when feed is closed
Public event | ConnectionException | Occurs when an exception occurs in the connection loop
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online)
Public event | RecoveryInitiated | Occurs when a recovery initiation completes
Top
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.Closed Event

FeedClosed Event

Occurs when feed is closed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public event EventHandler<FeedCloseEventArgs> Closed

Value

EventHandler FeedCloseEventArgs

Implements

IOddsFeedClosed
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.ConnectionException Event

FeedConnectionException Event

Occurs when an exception occurs in the connection loop

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public event EventHandler<ConnectionExceptionEventArgs> ConnectionException

Value

EventHandler ConnectionExceptionEventArgs

Implements

IOddsFeedV3ConnectionException
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.Disconnected Event

FeedDisconnected Event

Raised when the current instance of IOddsFeed loses connection to the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public event EventHandler<EventArgs> Disconnected

Value

EventHandler EventArgs

Implements

IOddsFeedDisconnected
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.EventRecoveryCompleted Event

FeedEventRecoveryCompleted Event

Occurs when a requested event recovery completes

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public event EventHandler<EventRecoveryCompletedEventArgs> EventRecoveryCompleted

Value

EventHandler EventRecoveryCompletedEventArgs

Implements

IOddsFeedV2EventRecoveryCompleted
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.ProducerDown Event

FeedProducerDown Event

Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public event EventHandler<ProducerStatusChangeEventArgs> ProducerDown

Value

EventHandler ProducerStatusChangeEventArgs

Implements

IOddsFeedProducerDown
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.ProducerUp Event

FeedProducerUp Event

Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public event EventHandler<ProducerStatusChangeEventArgs> ProducerUp

Value

EventHandler ProducerStatusChangeEventArgs

Implements

IOddsFeedProducerUp
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.RecoveryInitiated Event

FeedRecoveryInitiated Event

Occurs when a recovery initiation completes

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public event EventHandler<RecoveryInitiatedEventArgs> RecoveryInitiated

Value

EventHandler RecoveryInitiatedEventArgs

Implements

IOddsFeedV5RecoveryInitiated
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed Fields

The Feed type exposes the following members.

Fields
 | Name | Description
Protected field | FeedInitialized | The feed initialized
Protected field | UnityContainer | A IUnityContainer used to resolve
Top
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.FeedInitialized Field

FeedFeedInitialized Field

The feed initialized

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected bool FeedInitialized

Field Value

Boolean
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


Feed.UnityContainer Field

FeedUnityContainer Field

A IUnityContainer used to resolve

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected readonly IUnityContainer UnityContainer

Field Value

IUnityContainer
See Also

Reference

Feed Class
Sportradar.OddsFeed.SDK.API Namespace


IBookingManager Interface

Defines a contract for classes implementing booking manager to perform various booking calendar operations

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IBookingManager

The IBookingManager type exposes the following members.

Methods
 | Name | Description
Public method | BookLiveOddsEvent | Books the live odds event associated with the provided {@link URN} identifier
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IBookingManager Methods

The IBookingManager type exposes the following members.

Methods
 | Name | Description
Public method | BookLiveOddsEvent | Books the live odds event associated with the provided {@link URN} identifier
Top
See Also

Reference

IBookingManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IBookingManager.BookLiveOddsEvent Method

IBookingManagerBookLiveOddsEvent Method

Books the live odds event associated with the provided {@link URN} identifier

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool BookLiveOddsEvent(
    URN eventId
)

Parameters

eventId URN
The event id

Return Value

Boolean
true if event was successfully booked, false otherwise
See Also

Reference

IBookingManager Interface
Sportradar.OddsFeed.SDK.API Namespace


ICashOutProbabilitiesProvider Interface

Defines a type used to retrieve market probabilities used for cash out

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICashOutProbabilitiesProvider

The ICashOutProbabilitiesProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetCashOutProbabilitiesAsyncT(URN, CultureInfo) | Asynchronously gets the cash out probabilities for the specified sport event.
Public method | GetCashOutProbabilitiesAsyncT(URN, Int32, IReadOnlyDictionaryString, String, CultureInfo) | Asynchronously gets the cash out probabilities for the specified market on the specified sport event.
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ICashOutProbabilitiesProvider Methods

The ICashOutProbabilitiesProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetCashOutProbabilitiesAsyncT(URN, CultureInfo) | Asynchronously gets the cash out probabilities for the specified sport event.
Public method | GetCashOutProbabilitiesAsyncT(URN, Int32, IReadOnlyDictionaryString, String, CultureInfo) | Asynchronously gets the cash out probabilities for the specified market on the specified sport event.
Top
See Also

Reference

ICashOutProbabilitiesProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ICashOutProbabilitiesProvider.GetCashOutProbabilitiesAsync Method

ICashOutProbabilitiesProviderGetCashOutProbabilitiesAsync Method

Overload List
 | Name | Description
Public method | GetCashOutProbabilitiesAsyncT(URN, CultureInfo) | Asynchronously gets the cash out probabilities for the specified sport event.
Public method | GetCashOutProbabilitiesAsyncT(URN, Int32, IReadOnlyDictionaryString, String, CultureInfo) | Asynchronously gets the cash out probabilities for the specified market on the specified sport event.
Top
See Also

Reference

ICashOutProbabilitiesProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ICashOutProbabilitiesProvider.GetCashOutProbabilitiesAsync<T>(URN, CultureInfo) Method

ICashOutProbabilitiesProviderGetCashOutProbabilitiesAsyncT(URN, CultureInfo) Method

Asynchronously gets the cash out probabilities for the specified sport event.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICashOutProbabilities<T>> GetCashOutProbabilitiesAsync<T>(
    URN eventId,
    CultureInfo culture = null
)
where T : ISportEvent

Parameters

eventId URN
The URN uniquely identifying the sport event.
culture CultureInfo (Optional)
A CultureInfo specifying the language of the returned data, or a null reference to use default languages

Type Parameters

T
The type of the sport event

Return Value

Task ICashOutProbabilities T
A TaskTResult representing the asynchronous operation.
See Also

Reference

ICashOutProbabilitiesProvider Interface
GetCashOutProbabilitiesAsync Overload
Sportradar.OddsFeed.SDK.API Namespace


ICashOutProbabilitiesProvider.GetCashOutProbabilitiesAsync<T>(URN, Int32, IReadOnlyDictionary<String, String>, CultureInfo) Method

ICashOutProbabilitiesProviderGetCashOutProbabilitiesAsyncT(URN, Int32, IReadOnlyDictionaryString, String, CultureInfo) Method

Asynchronously gets the cash out probabilities for the specified market on the specified sport event.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICashOutProbabilities<T>> GetCashOutProbabilitiesAsync<T>(
    URN eventId,
    int marketId,
    IReadOnlyDictionary<string, string> specifiers,
    CultureInfo culture = null
)
where T : ISportEvent

Parameters

eventId URN
The URN uniquely identifying the sport event.
marketId Int32
The id of the market for which to get the probabilities.
specifiers IReadOnlyDictionary String, String
A IDictionaryTKey, TValue containing market specifiers or a null reference if market has no specifiers.
culture CultureInfo (Optional)
A CultureInfo specifying the language of the returned data, or a null reference to use default languages

Type Parameters

T
The type of the sport event

Return Value

Task ICashOutProbabilities T
A TaskTResult representing the asynchronous operation.
See Also

Reference

ICashOutProbabilitiesProvider Interface
GetCashOutProbabilitiesAsync Overload
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationAccessTokenSetter Interface

Note: This API is now obsolete.

Defines method used to set access token property on the configuration builder

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use ITokenSetter")]
public interface IConfigurationAccessTokenSetter

The IConfigurationAccessTokenSetter type exposes the following members.

Methods
 | Name | Description
Public method | SetAccessToken | Sets the access token used for the authentication.
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IConfigurationAccessTokenSetter Methods

The IConfigurationAccessTokenSetter type exposes the following members.

Methods
 | Name | Description
Public method | SetAccessToken | Sets the access token used for the authentication.
Top
See Also

Reference

IConfigurationAccessTokenSetter Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationAccessTokenSetter.SetAccessToken Method

IConfigurationAccessTokenSetterSetAccessToken Method

Sets the access token used for the authentication.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IConfigurationInactivitySecondsSetter SetAccessToken(
    string accessToken
)

Parameters

accessToken String
The access token.

Return Value

IConfigurationInactivitySecondsSetter
The IConfigurationInactivitySecondsSetter instance used to set additional values.
Exceptions
Exception | Condition
ArgumentException | Value cannot be a null reference or empty string
See Also

Reference

IConfigurationAccessTokenSetter Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationBuilder Interface

Defines a contract implemented by classes used to set general configuration properties

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IConfigurationBuilder : IRecoveryConfigurationBuilder<IConfigurationBuilder>,
    IConfigurationBuilderBase<IConfigurationBuilder>

The IConfigurationBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a IOddsFeedConfiguration instance (Inherited from IConfigurationBuilderBaseT)
Public method | LoadFromConfigFile | Sets the general configuration properties to values read from configuration file. Only value which can be set through IConfigurationBuilderBaseT methods are set. Any values already set by methods on the current instance are overridden (Inherited from IConfigurationBuilderBaseT)
Public method | SetAdjustAfterAge | Sets the value indicating whether the after age should be adjusted before executing recovery request (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetDefaultLanguage | Sets the default language in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Public method | SetDisabledProducers | Specifies the producers which should be disabled (i.e. no recovery, ...) (Inherited from IConfigurationBuilderBaseT)
Public method | SetExceptionHandlingStrategy | Sets the value specifying how exceptions thrown in the SDK are handled. (Inherited from IConfigurationBuilderBaseT)
Public method | SetHttpClientTimeout | Sets the timeout for HTTP responses for this instance of the sdk (Inherited from IConfigurationBuilderBaseT)
Public method | SetInactivitySeconds | Sets the max time window between two consecutive alive messages before the associated producer is marked as down (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetMaxRecoveryTime | Sets the maximum time in seconds in which recovery must be completed (minimum 600 seconds) (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetMinIntervalBetweenRecoveryRequests | Sets the minimal interval between recovery requests initiated by alive messages (between 20 and 180 seconds) (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetNodeId | Sets the node id used to separate between SDK instances associated with the same account (Inherited from IConfigurationBuilderBaseT)
Public method | SetRecoveryHttpClientTimeout | Sets the timeout for recovery HTTP responses for this instance of the sdk (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetSupportedLanguages | Sets the languages in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Top
Remarks
Types associated with IConfigurationBuilder represent a re-factored approach to building SDK configuration and therefore make IConfigurationBuilder related instances obsolete. The IConfigurationBuilder and related instances cannot be removed in order not to introduce braking changes.
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IConfigurationBuilder Methods

The IConfigurationBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a IOddsFeedConfiguration instance (Inherited from IConfigurationBuilderBaseT)
Public method | LoadFromConfigFile | Sets the general configuration properties to values read from configuration file. Only value which can be set through IConfigurationBuilderBaseT methods are set. Any values already set by methods on the current instance are overridden (Inherited from IConfigurationBuilderBaseT)
Public method | SetAdjustAfterAge | Sets the value indicating whether the after age should be adjusted before executing recovery request (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetDefaultLanguage | Sets the default language in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Public method | SetDisabledProducers | Specifies the producers which should be disabled (i.e. no recovery, ...) (Inherited from IConfigurationBuilderBaseT)
Public method | SetExceptionHandlingStrategy | Sets the value specifying how exceptions thrown in the SDK are handled. (Inherited from IConfigurationBuilderBaseT)
Public method | SetHttpClientTimeout | Sets the timeout for HTTP responses for this instance of the sdk (Inherited from IConfigurationBuilderBaseT)
Public method | SetInactivitySeconds | Sets the max time window between two consecutive alive messages before the associated producer is marked as down (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetMaxRecoveryTime | Sets the maximum time in seconds in which recovery must be completed (minimum 600 seconds) (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetMinIntervalBetweenRecoveryRequests | Sets the minimal interval between recovery requests initiated by alive messages (between 20 and 180 seconds) (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetNodeId | Sets the node id used to separate between SDK instances associated with the same account (Inherited from IConfigurationBuilderBaseT)
Public method | SetRecoveryHttpClientTimeout | Sets the timeout for recovery HTTP responses for this instance of the sdk (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetSupportedLanguages | Sets the languages in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Top
See Also

Reference

IConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationBuilderBase<T> Interface

IConfigurationBuilderBaseT Interface

A base contract custom and general configuration builders

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IConfigurationBuilderBase<out T>

Type Parameters

T
The type of the builder extending the interface

The IConfigurationBuilderBaseT type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a IOddsFeedConfiguration instance
Public method | LoadFromConfigFile | Sets the general configuration properties to values read from configuration file. Only value which can be set through IConfigurationBuilderBaseT methods are set. Any values already set by methods on the current instance are overridden
Public method | SetDefaultLanguage | Sets the default language in which translatable data is available
Public method | SetDisabledProducers | Specifies the producers which should be disabled (i.e. no recovery, ...)
Public method | SetExceptionHandlingStrategy | Sets the value specifying how exceptions thrown in the SDK are handled.
Public method | SetHttpClientTimeout | Sets the timeout for HTTP responses for this instance of the sdk
Public method | SetNodeId | Sets the node id used to separate between SDK instances associated with the same account
Public method | SetSupportedLanguages | Sets the languages in which translatable data is available
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IConfigurationBuilderBase<T> Methods

IConfigurationBuilderBaseT Methods

The IConfigurationBuilderBaseT type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a IOddsFeedConfiguration instance
Public method | LoadFromConfigFile | Sets the general configuration properties to values read from configuration file. Only value which can be set through IConfigurationBuilderBaseT methods are set. Any values already set by methods on the current instance are overridden
Public method | SetDefaultLanguage | Sets the default language in which translatable data is available
Public method | SetDisabledProducers | Specifies the producers which should be disabled (i.e. no recovery, ...)
Public method | SetExceptionHandlingStrategy | Sets the value specifying how exceptions thrown in the SDK are handled.
Public method | SetHttpClientTimeout | Sets the timeout for HTTP responses for this instance of the sdk
Public method | SetNodeId | Sets the node id used to separate between SDK instances associated with the same account
Public method | SetSupportedLanguages | Sets the languages in which translatable data is available
Top
See Also

Reference

IConfigurationBuilderBaseT Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationBuilderBase<T>.Build Method

IConfigurationBuilderBaseTBuild Method

Builds and returns a IOddsFeedConfiguration instance

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfiguration Build()

Return Value

IOddsFeedConfiguration
The constructed IOddsFeedConfiguration instance
See Also

Reference

IConfigurationBuilderBaseT Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationBuilderBase<T>.LoadFromConfigFile Method

IConfigurationBuilderBaseTLoadFromConfigFile Method

Sets the general configuration properties to values read from configuration file. Only value which can be set through IConfigurationBuilderBaseT methods are set. Any values already set by methods on the current instance are overridden

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T LoadFromConfigFile()

Return Value

T
A IConfigurationBuilderBaseT derived instance used to set general configuration properties
See Also

Reference

IConfigurationBuilderBaseT Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationBuilderBase<T>.SetDefaultLanguage Method

IConfigurationBuilderBaseTSetDefaultLanguage Method

Sets the default language in which translatable data is available

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T SetDefaultLanguage(
    CultureInfo culture
)

Parameters

culture CultureInfo
A default language in which translatable data should be available

Return Value

T
A IConfigurationBuilderBaseT derived instance used to set general configuration properties
See Also

Reference

IConfigurationBuilderBaseT Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationBuilderBase<T>.SetDisabledProducers Method

IConfigurationBuilderBaseTSetDisabledProducers Method

Specifies the producers which should be disabled (i.e. no recovery, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T SetDisabledProducers(
    IEnumerable<int> producerIds
)

Parameters

producerIds IEnumerable Int32
The list of producer ids specifying the producers which should be disabled

Return Value

T
A IRecoveryConfigurationBuilderT derived instance used to set general configuration properties
See Also

Reference

IConfigurationBuilderBaseT Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationBuilderBase<T>.SetExceptionHandlingStrategy Method

IConfigurationBuilderBaseTSetExceptionHandlingStrategy Method

Sets the value specifying how exceptions thrown in the SDK are handled.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T SetExceptionHandlingStrategy(
    ExceptionHandlingStrategy strategy
)

Parameters

strategy ExceptionHandlingStrategy
A ExceptionHandlingStrategy enum specifying how exceptions thrown in the SDK are handled

Return Value

T
A IConfigurationBuilderBaseT derived instance used to set general configuration properties
See Also

Reference

IConfigurationBuilderBaseT Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationBuilderBase<T>.SetHttpClientTimeout Method

IConfigurationBuilderBaseTSetHttpClientTimeout Method

Sets the timeout for HTTP responses for this instance of the sdk

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T SetHttpClientTimeout(
    int httpClientTimeout
)

Parameters

httpClientTimeout Int32
The timeout for HTTP responses

Return Value

T
A IConfigurationBuilderBaseT derived instance used to set general configuration properties
See Also

Reference

IConfigurationBuilderBaseT Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationBuilderBase<T>.SetNodeId Method

IConfigurationBuilderBaseTSetNodeId Method

Sets the node id used to separate between SDK instances associated with the same account

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T SetNodeId(
    int nodeId
)

Parameters

nodeId Int32
The node id to be set

Return Value

T
A IConfigurationBuilderBaseT derived instance used to set general configuration properties
Remarks
MTS customer must set this value! Use only positive numbers; negative are reserved for internal use.
See Also

Reference

IConfigurationBuilderBaseT Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationBuilderBase<T>.SetSupportedLanguages Method

IConfigurationBuilderBaseTSetSupportedLanguages Method

Sets the languages in which translatable data is available

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T SetSupportedLanguages(
    IEnumerable<CultureInfo> cultures
)

Parameters

cultures IEnumerable CultureInfo
A IEnumerableT specifying languages in which translatable data should be available

Return Value

T
A IConfigurationBuilderBaseT derived instance used to set general configuration properties
See Also

Reference

IConfigurationBuilderBaseT Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationInactivitySecondsSetter Interface

Note: This API is now obsolete.

Defines method used to set inactivity seconds property on the configuration builder

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute]
public interface IConfigurationInactivitySecondsSetter

The IConfigurationInactivitySecondsSetter type exposes the following members.

Methods
 | Name | Description
Public method | SetInactivitySeconds | Sets the max time window between two messages before the producer is market as "down"
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IConfigurationInactivitySecondsSetter Methods

The IConfigurationInactivitySecondsSetter type exposes the following members.

Methods
 | Name | Description
Public method | SetInactivitySeconds | Sets the max time window between two messages before the producer is market as "down"
Top
See Also

Reference

IConfigurationInactivitySecondsSetter Interface
Sportradar.OddsFeed.SDK.API Namespace


IConfigurationInactivitySecondsSetter.SetInactivitySeconds Method

IConfigurationInactivitySecondsSetterSetInactivitySeconds Method

Sets the max time window between two messages before the producer is market as "down"

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfigurationBuilder SetInactivitySeconds(
    int inactivitySeconds
)

Parameters

inactivitySeconds Int32
The inactivity seconds Value must be between 20 and 180.

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | inactivitySeconds < 20 or inactivitySeconds > 180
See Also

Reference

IConfigurationInactivitySecondsSetter Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetManager Interface

Defines methods used to perform various custom bet operations

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICustomBetManager

The ICustomBetManager type exposes the following members.

Properties
 | Name | Description
Public property | CustomBetSelectionBuilder | Returns an ICustomBetSelectionBuilder instance used to build selections
Top
Methods
 | Name | Description
Public method | CalculateProbabilityAsync | Returns an Calculation instance providing the probability for the specified selections
Public method | CalculateProbabilityFilterAsync | Returns an Calculation instance providing the probability for the specified selections and filter out conflicting outcomes.
Public method | GetAvailableSelectionsAsync | Returns an AvailableSelections instance providing the available selections for the event associated with the provided URN identifier
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ICustomBetManager Properties

The ICustomBetManager type exposes the following members.

Properties
 | Name | Description
Public property | CustomBetSelectionBuilder | Returns an ICustomBetSelectionBuilder instance used to build selections
Top
See Also

Reference

ICustomBetManager Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetManager.CustomBetSelectionBuilder Property

ICustomBetManagerCustomBetSelectionBuilder Property

Returns an ICustomBetSelectionBuilder instance used to build selections

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomBetSelectionBuilder CustomBetSelectionBuilder { get; }

Return Value

ICustomBetSelectionBuilder
An ICustomBetSelectionBuilder instance used to build selections
See Also

Reference

ICustomBetManager Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetManager Methods

The ICustomBetManager type exposes the following members.

Methods
 | Name | Description
Public method | CalculateProbabilityAsync | Returns an Calculation instance providing the probability for the specified selections
Public method | CalculateProbabilityFilterAsync | Returns an Calculation instance providing the probability for the specified selections and filter out conflicting outcomes.
Public method | GetAvailableSelectionsAsync | Returns an AvailableSelections instance providing the available selections for the event associated with the provided URN identifier
Top
See Also

Reference

ICustomBetManager Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetManager.CalculateProbabilityAsync Method

ICustomBetManagerCalculateProbabilityAsync Method

Returns an Calculation instance providing the probability for the specified selections

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICalculation> CalculateProbabilityAsync(
    IEnumerable<ISelection> selections
)

Parameters

selections IEnumerable ISelection
The IEnumerableT containing selections for which the probability should be calculated

Return Value

Task ICalculation
An Calculation providing the probability for the specified selections
See Also

Reference

ICustomBetManager Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetManager.CalculateProbabilityFilterAsync Method

ICustomBetManagerCalculateProbabilityFilterAsync Method

Returns an Calculation instance providing the probability for the specified selections and filter out conflicting outcomes.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICalculationFilter> CalculateProbabilityFilterAsync(
    IEnumerable<ISelection> selections
)

Parameters

selections IEnumerable ISelection
The IEnumerableT containing selections for which the probability should be calculated

Return Value

Task ICalculationFilter
An Calculation providing the probability for the specified selections
See Also

Reference

ICustomBetManager Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetManager.GetAvailableSelectionsAsync Method

ICustomBetManagerGetAvailableSelectionsAsync Method

Returns an AvailableSelections instance providing the available selections for the event associated with the provided URN identifier

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IAvailableSelections> GetAvailableSelectionsAsync(
    URN eventId
)

Parameters

eventId URN
The URN identifier of the event for which the available selections should be returned

Return Value

Task IAvailableSelections
An AvailableSelections providing the available selections of the associated event
See Also

Reference

ICustomBetManager Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetSelectionBuilder Interface

Defines methods used to build selections

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICustomBetSelectionBuilder

The ICustomBetSelectionBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a ISelection instance
Public method | Build(URN, Int32, String, String) | Builds and returns a ISelection instance
Public method | SetEventId | Sets event id to the provided URN
Public method | SetMarketId | Sets market id to the provided value
Public method | SetOutcomeId | Sets outcome id to the provided value
Public method | SetSpecifiers | Sets specifiers to the provided value
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ICustomBetSelectionBuilder Methods

The ICustomBetSelectionBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a ISelection instance
Public method | Build(URN, Int32, String, String) | Builds and returns a ISelection instance
Public method | SetEventId | Sets event id to the provided URN
Public method | SetMarketId | Sets market id to the provided value
Public method | SetOutcomeId | Sets outcome id to the provided value
Public method | SetSpecifiers | Sets specifiers to the provided value
Top
See Also

Reference

ICustomBetSelectionBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetSelectionBuilder.Build Method

ICustomBetSelectionBuilderBuild Method

Overload List
 | Name | Description
Public method | Build | Builds and returns a ISelection instance
Public method | Build(URN, Int32, String, String) | Builds and returns a ISelection instance
Top
See Also

Reference

ICustomBetSelectionBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetSelectionBuilder.Build Method

ICustomBetSelectionBuilderBuild Method

Builds and returns a ISelection instance

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ISelection Build()

Return Value

ISelection
The constructed ISelection instance.
See Also

Reference

ICustomBetSelectionBuilder Interface
Build Overload
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetSelectionBuilder.Build(URN, Int32, String, String) Method

ICustomBetSelectionBuilderBuild(URN, Int32, String, String) Method

Builds and returns a ISelection instance

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ISelection Build(
    URN eventId,
    int marketId,
    string specifiers,
    string outcomeId
)

Parameters

eventId URN

[Missing <param name="eventId"/> documentation for "M:Sportradar.OddsFeed.SDK.API.ICustomBetSelectionBuilder.Build(Sportradar.OddsFeed.SDK.Messages.URN,System.Int32,System.String,System.String)"]

marketId Int32

[Missing <param name="marketId"/> documentation for "M:Sportradar.OddsFeed.SDK.API.ICustomBetSelectionBuilder.Build(Sportradar.OddsFeed.SDK.Messages.URN,System.Int32,System.String,System.String)"]

specifiers String

[Missing <param name="specifiers"/> documentation for "M:Sportradar.OddsFeed.SDK.API.ICustomBetSelectionBuilder.Build(Sportradar.OddsFeed.SDK.Messages.URN,System.Int32,System.String,System.String)"]

outcomeId String

[Missing <param name="outcomeId"/> documentation for "M:Sportradar.OddsFeed.SDK.API.ICustomBetSelectionBuilder.Build(Sportradar.OddsFeed.SDK.Messages.URN,System.Int32,System.String,System.String)"]

Return Value

ISelection
The constructed ISelection instance.
See Also

Reference

ICustomBetSelectionBuilder Interface
Build Overload
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetSelectionBuilder.SetEventId Method

ICustomBetSelectionBuilderSetEventId Method

Sets event id to the provided URN

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomBetSelectionBuilder SetEventId(
    URN eventId
)

Parameters

eventId URN
A URN representing the event id.

Return Value

ICustomBetSelectionBuilder
The ICustomBetSelectionBuilder instance used to set additional values.
See Also

Reference

ICustomBetSelectionBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetSelectionBuilder.SetMarketId Method

ICustomBetSelectionBuilderSetMarketId Method

Sets market id to the provided value

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomBetSelectionBuilder SetMarketId(
    int marketId
)

Parameters

marketId Int32
A value representing the market id.

Return Value

ICustomBetSelectionBuilder
The ICustomBetSelectionBuilder instance used to set additional values.
See Also

Reference

ICustomBetSelectionBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetSelectionBuilder.SetOutcomeId Method

ICustomBetSelectionBuilderSetOutcomeId Method

Sets outcome id to the provided value

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomBetSelectionBuilder SetOutcomeId(
    string outcomeId
)

Parameters

outcomeId String
A value representing the outcome id.

Return Value

ICustomBetSelectionBuilder
The ICustomBetSelectionBuilder instance used to set additional values.
See Also

Reference

ICustomBetSelectionBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomBetSelectionBuilder.SetSpecifiers Method

ICustomBetSelectionBuilderSetSpecifiers Method

Sets specifiers to the provided value

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomBetSelectionBuilder SetSpecifiers(
    string specifiers
)

Parameters

specifiers String
A value representing the specifiers.

Return Value

ICustomBetSelectionBuilder
The ICustomBetSelectionBuilder instance used to set additional values.
See Also

Reference

ICustomBetSelectionBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomConfigurationBuilder Interface

Defines a contract implemented by classes used to set general and custom configuration properties

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICustomConfigurationBuilder : IRecoveryConfigurationBuilder<ICustomConfigurationBuilder>,
    IConfigurationBuilderBase<ICustomConfigurationBuilder>

The ICustomConfigurationBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a IOddsFeedConfiguration instance (Inherited from IConfigurationBuilderBaseT)
Public method | LoadFromConfigFile | Sets the general configuration properties to values read from configuration file. Only value which can be set through IConfigurationBuilderBaseT methods are set. Any values already set by methods on the current instance are overridden (Inherited from IConfigurationBuilderBaseT)
Public method | SetAdjustAfterAge | Sets the value indicating whether the after age should be adjusted before executing recovery request (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetApiHost | Set the host name of the Sports API server
Public method | SetDefaultLanguage | Sets the default language in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Public method | SetDisabledProducers | Specifies the producers which should be disabled (i.e. no recovery, ...) (Inherited from IConfigurationBuilderBaseT)
Public method | SetExceptionHandlingStrategy | Sets the value specifying how exceptions thrown in the SDK are handled. (Inherited from IConfigurationBuilderBaseT)
Public method | SetHttpClientTimeout | Sets the timeout for HTTP responses for this instance of the sdk (Inherited from IConfigurationBuilderBaseT)
Public method | SetInactivitySeconds | Sets the max time window between two consecutive alive messages before the associated producer is marked as down (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetMaxRecoveryTime | Sets the maximum time in seconds in which recovery must be completed (minimum 600 seconds) (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetMessagingHost | Sets the host name of the AMQP server
Public method | SetMessagingPassword | Sets the password used to authenticate with the messaging server
Public method | SetMessagingPort | Sets the port used to connect to the AMQP server
Public method | SetMessagingUsername | Sets the username used to authenticate with the messaging server
Public method | SetMinIntervalBetweenRecoveryRequests | Sets the minimal interval between recovery requests initiated by alive messages (between 20 and 180 seconds) (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetNodeId | Sets the node id used to separate between SDK instances associated with the same account (Inherited from IConfigurationBuilderBaseT)
Public method | SetRecoveryHttpClientTimeout | Sets the timeout for recovery HTTP responses for this instance of the sdk (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetSupportedLanguages | Sets the languages in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Public method | SetVirtualHost | Sets the virtual host name of the AMQP server
Public method | UseApiSsl | Sets the value specifying whether SSL should be used to communicate with Sports API
Public method | UseMessagingSsl | Sets the value specifying whether SSL should be used to communicate with the messaging server
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ICustomConfigurationBuilder Methods

The ICustomConfigurationBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a IOddsFeedConfiguration instance (Inherited from IConfigurationBuilderBaseT)
Public method | LoadFromConfigFile | Sets the general configuration properties to values read from configuration file. Only value which can be set through IConfigurationBuilderBaseT methods are set. Any values already set by methods on the current instance are overridden (Inherited from IConfigurationBuilderBaseT)
Public method | SetAdjustAfterAge | Sets the value indicating whether the after age should be adjusted before executing recovery request (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetApiHost | Set the host name of the Sports API server
Public method | SetDefaultLanguage | Sets the default language in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Public method | SetDisabledProducers | Specifies the producers which should be disabled (i.e. no recovery, ...) (Inherited from IConfigurationBuilderBaseT)
Public method | SetExceptionHandlingStrategy | Sets the value specifying how exceptions thrown in the SDK are handled. (Inherited from IConfigurationBuilderBaseT)
Public method | SetHttpClientTimeout | Sets the timeout for HTTP responses for this instance of the sdk (Inherited from IConfigurationBuilderBaseT)
Public method | SetInactivitySeconds | Sets the max time window between two consecutive alive messages before the associated producer is marked as down (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetMaxRecoveryTime | Sets the maximum time in seconds in which recovery must be completed (minimum 600 seconds) (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetMessagingHost | Sets the host name of the AMQP server
Public method | SetMessagingPassword | Sets the password used to authenticate with the messaging server
Public method | SetMessagingPort | Sets the port used to connect to the AMQP server
Public method | SetMessagingUsername | Sets the username used to authenticate with the messaging server
Public method | SetMinIntervalBetweenRecoveryRequests | Sets the minimal interval between recovery requests initiated by alive messages (between 20 and 180 seconds) (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetNodeId | Sets the node id used to separate between SDK instances associated with the same account (Inherited from IConfigurationBuilderBaseT)
Public method | SetRecoveryHttpClientTimeout | Sets the timeout for recovery HTTP responses for this instance of the sdk (Inherited from IRecoveryConfigurationBuilderT)
Public method | SetSupportedLanguages | Sets the languages in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Public method | SetVirtualHost | Sets the virtual host name of the AMQP server
Public method | UseApiSsl | Sets the value specifying whether SSL should be used to communicate with Sports API
Public method | UseMessagingSsl | Sets the value specifying whether SSL should be used to communicate with the messaging server
Top
See Also

Reference

ICustomConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomConfigurationBuilder.SetApiHost Method

ICustomConfigurationBuilderSetApiHost Method

Set the host name of the Sports API server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomConfigurationBuilder SetApiHost(
    string apiHost
)

Parameters

apiHost String
The host name of the Sports API server

Return Value

ICustomConfigurationBuilder
The ICustomConfigurationBuilder instance used to set custom config values
See Also

Reference

ICustomConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomConfigurationBuilder.SetMessagingHost Method

ICustomConfigurationBuilderSetMessagingHost Method

Sets the host name of the AMQP server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomConfigurationBuilder SetMessagingHost(
    string host
)

Parameters

host String
The host name of the AMQP server

Return Value

ICustomConfigurationBuilder
The ICustomConfigurationBuilder instance used to set custom config values
See Also

Reference

ICustomConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomConfigurationBuilder.SetMessagingPassword Method

ICustomConfigurationBuilderSetMessagingPassword Method

Sets the password used to authenticate with the messaging server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomConfigurationBuilder SetMessagingPassword(
    string password
)

Parameters

password String
The password used to authenticate with the messaging server

Return Value

ICustomConfigurationBuilder
The ICustomConfigurationBuilder instance used to set custom config values
See Also

Reference

ICustomConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomConfigurationBuilder.SetMessagingPort Method

ICustomConfigurationBuilderSetMessagingPort Method

Sets the port used to connect to the AMQP server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomConfigurationBuilder SetMessagingPort(
    int port
)

Parameters

port Int32
The port used to connect to the AMQP server

Return Value

ICustomConfigurationBuilder
The ICustomConfigurationBuilder instance used to set custom config values
See Also

Reference

ICustomConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomConfigurationBuilder.SetMessagingUsername Method

ICustomConfigurationBuilderSetMessagingUsername Method

Sets the username used to authenticate with the messaging server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomConfigurationBuilder SetMessagingUsername(
    string username
)

Parameters

username String
The username used to authenticate with the messaging server

Return Value

ICustomConfigurationBuilder
The ICustomConfigurationBuilder instance used to set custom config values
See Also

Reference

ICustomConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomConfigurationBuilder.SetVirtualHost Method

ICustomConfigurationBuilderSetVirtualHost Method

Sets the virtual host name of the AMQP server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomConfigurationBuilder SetVirtualHost(
    string virtualHost
)

Parameters

virtualHost String
The virtual host name of the AMQP server

Return Value

ICustomConfigurationBuilder
The ICustomConfigurationBuilder instance used to set custom config values
See Also

Reference

ICustomConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomConfigurationBuilder.UseApiSsl Method

ICustomConfigurationBuilderUseApiSsl Method

Sets the value specifying whether SSL should be used to communicate with Sports API

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomConfigurationBuilder UseApiSsl(
    bool useApiSsl
)

Parameters

useApiSsl Boolean
The value specifying whether SSL should be used to communicate with Sports API

Return Value

ICustomConfigurationBuilder
The ICustomConfigurationBuilder instance used to set custom config values
See Also

Reference

ICustomConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ICustomConfigurationBuilder.UseMessagingSsl Method

ICustomConfigurationBuilderUseMessagingSsl Method

Sets the value specifying whether SSL should be used to communicate with the messaging server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomConfigurationBuilder UseMessagingSsl(
    bool useMessagingSsl
)

Parameters

useMessagingSsl Boolean
The value specifying whether SSL should be used to communicate with the messaging server

Return Value

ICustomConfigurationBuilder
The ICustomConfigurationBuilder instance used to set custom config values
See Also

Reference

ICustomConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IEntityDispatcher<T> Interface

IEntityDispatcherT Interface

Specifies a contract defining events used for user notification

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEntityDispatcher<T>
where T : ISportEvent

Type Parameters

T
A ICompetition derived type specifying the type of sport associated with IEntityDispatcherT

The IEntityDispatcherT type exposes the following members.

Events
 | Name | Description
Public event | OnBetCancel | Raised when a bet cancel message is received from the feed
Public event | OnBetSettlement | Raised when a bet settlement message is received from the feed
Public event | OnBetStop | Raised when a bet stop message is received from the feed
Public event | OnFixtureChange | Raised when a fixture change message is received from the feed
Public event | OnOddsChange | Raised when a odds change message is received from the feed
Public event | OnRollbackBetCancel | Raised when a rollback bet cancel message is received from the feed
Public event | OnRollbackBetSettlement | Raised when a rollback bet settlement is received from the feed
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IEntityDispatcher<T> Events

IEntityDispatcherT Events

The IEntityDispatcherT type exposes the following members.

Events
 | Name | Description
Public event | OnBetCancel | Raised when a bet cancel message is received from the feed
Public event | OnBetSettlement | Raised when a bet settlement message is received from the feed
Public event | OnBetStop | Raised when a bet stop message is received from the feed
Public event | OnFixtureChange | Raised when a fixture change message is received from the feed
Public event | OnOddsChange | Raised when a odds change message is received from the feed
Public event | OnRollbackBetCancel | Raised when a rollback bet cancel message is received from the feed
Public event | OnRollbackBetSettlement | Raised when a rollback bet settlement is received from the feed
Top
See Also

Reference

IEntityDispatcherT Interface
Sportradar.OddsFeed.SDK.API Namespace


IEntityDispatcher<T>.OnBetCancel Event

IEntityDispatcherTOnBetCancel Event

Raised when a bet cancel message is received from the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<BetCancelEventArgs<T>> OnBetCancel

Value

EventHandler BetCancelEventArgs T
See Also

Reference

IEntityDispatcherT Interface
Sportradar.OddsFeed.SDK.API Namespace


IEntityDispatcher<T>.OnBetSettlement Event

IEntityDispatcherTOnBetSettlement Event

Raised when a bet settlement message is received from the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<BetSettlementEventArgs<T>> OnBetSettlement

Value

EventHandler BetSettlementEventArgs T
See Also

Reference

IEntityDispatcherT Interface
Sportradar.OddsFeed.SDK.API Namespace


IEntityDispatcher<T>.OnBetStop Event

IEntityDispatcherTOnBetStop Event

Raised when a bet stop message is received from the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<BetStopEventArgs<T>> OnBetStop

Value

EventHandler BetStopEventArgs T
See Also

Reference

IEntityDispatcherT Interface
Sportradar.OddsFeed.SDK.API Namespace


IEntityDispatcher<T>.OnFixtureChange Event

IEntityDispatcherTOnFixtureChange Event

Raised when a fixture change message is received from the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<FixtureChangeEventArgs<T>> OnFixtureChange

Value

EventHandler FixtureChangeEventArgs T
See Also

Reference

IEntityDispatcherT Interface
Sportradar.OddsFeed.SDK.API Namespace


IEntityDispatcher<T>.OnOddsChange Event

IEntityDispatcherTOnOddsChange Event

Raised when a odds change message is received from the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<OddsChangeEventArgs<T>> OnOddsChange

Value

EventHandler OddsChangeEventArgs T
See Also

Reference

IEntityDispatcherT Interface
Sportradar.OddsFeed.SDK.API Namespace


IEntityDispatcher<T>.OnRollbackBetCancel Event

IEntityDispatcherTOnRollbackBetCancel Event

Raised when a rollback bet cancel message is received from the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<RollbackBetCancelEventArgs<T>> OnRollbackBetCancel

Value

EventHandler RollbackBetCancelEventArgs T
See Also

Reference

IEntityDispatcherT Interface
Sportradar.OddsFeed.SDK.API Namespace


IEntityDispatcher<T>.OnRollbackBetSettlement Event

IEntityDispatcherTOnRollbackBetSettlement Event

Raised when a rollback bet settlement is received from the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<RollbackBetSettlementEventArgs<T>> OnRollbackBetSettlement

Value

EventHandler RollbackBetSettlementEventArgs T
See Also

Reference

IEntityDispatcherT Interface
Sportradar.OddsFeed.SDK.API Namespace


IEnvironmentSelector Interface

Defines a contract implemented by classes taking care of the 2nd step when building configuration - selecting the environment.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEnvironmentSelector

The IEnvironmentSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectCustom | Returns a ICustomConfigurationBuilder allowing the properties to be set to custom values (useful for testing with non-standard AMQP)
Public method | SelectProduction | Returns a IConfigurationBuilder with properties set to values needed to access production environment
Public method | SelectReplay | Returns a IReplayConfigurationBuilder with properties set to values needed to access replay server
Public method | SelectStaging | Obsolete. Returns a IConfigurationBuilder with properties set to values needed to access integration environment
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IEnvironmentSelector Methods

The IEnvironmentSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectCustom | Returns a ICustomConfigurationBuilder allowing the properties to be set to custom values (useful for testing with non-standard AMQP)
Public method | SelectProduction | Returns a IConfigurationBuilder with properties set to values needed to access production environment
Public method | SelectReplay | Returns a IReplayConfigurationBuilder with properties set to values needed to access replay server
Public method | SelectStaging | Obsolete. Returns a IConfigurationBuilder with properties set to values needed to access integration environment
Top
See Also

Reference

IEnvironmentSelector Interface
Sportradar.OddsFeed.SDK.API Namespace


IEnvironmentSelector.SelectCustom Method

IEnvironmentSelectorSelectCustom Method

Returns a ICustomConfigurationBuilder allowing the properties to be set to custom values (useful for testing with non-standard AMQP)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomConfigurationBuilder SelectCustom()

Return Value

ICustomConfigurationBuilder
A ICustomConfigurationBuilder with properties set to values needed to access replay server
See Also

Reference

IEnvironmentSelector Interface
Sportradar.OddsFeed.SDK.API Namespace


IEnvironmentSelector.SelectProduction Method

IEnvironmentSelectorSelectProduction Method

Returns a IConfigurationBuilder with properties set to values needed to access production environment

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IConfigurationBuilder SelectProduction()

Return Value

IConfigurationBuilder
A IConfigurationBuilder with properties set to values needed to access production environment
See Also

Reference

IEnvironmentSelector Interface
Sportradar.OddsFeed.SDK.API Namespace


IEnvironmentSelector.SelectReplay Method

IEnvironmentSelectorSelectReplay Method

Returns a IReplayConfigurationBuilder with properties set to values needed to access replay server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReplayConfigurationBuilder SelectReplay()

Return Value

IReplayConfigurationBuilder
A IReplayConfigurationBuilder with properties set to values needed to access replay server
See Also

Reference

IEnvironmentSelector Interface
Sportradar.OddsFeed.SDK.API Namespace


IEnvironmentSelector.SelectStaging Method

IEnvironmentSelectorSelectStaging Method

Note: This API is now obsolete.

Returns a IConfigurationBuilder with properties set to values needed to access integration environment

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use IEnvironmentSelectorV1.SelectIntegration()")]
IConfigurationBuilder SelectStaging()

Return Value

IConfigurationBuilder
A IConfigurationBuilder with properties set to values needed to access integration environment
See Also

Reference

IEnvironmentSelector Interface
Sportradar.OddsFeed.SDK.API Namespace


IEnvironmentSelectorV1 Interface

Defines a contract implemented by classes taking care of the 2nd step when building configuration - selecting the environment.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEnvironmentSelectorV1 : IEnvironmentSelector

The IEnvironmentSelectorV1 type exposes the following members.

Methods
 | Name | Description
Public method | SelectCustom | Returns a ICustomConfigurationBuilder allowing the properties to be set to custom values (useful for testing with non-standard AMQP) (Inherited from IEnvironmentSelector)
Public method | SelectEnvironment | Returns a IConfigurationBuilder with properties set to values needed to access specified environment
Public method | SelectIntegration | Returns a IConfigurationBuilder with properties set to values needed to access integration environment
Public method | SelectProduction | Returns a IConfigurationBuilder with properties set to values needed to access production environment (Inherited from IEnvironmentSelector)
Public method | SelectReplay | Returns a IReplayConfigurationBuilder with properties set to values needed to access replay server (Inherited from IEnvironmentSelector)
Public method | SelectStaging | Obsolete. Returns a IConfigurationBuilder with properties set to values needed to access integration environment (Inherited from IEnvironmentSelector)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IEnvironmentSelectorV1 Methods

The IEnvironmentSelectorV1 type exposes the following members.

Methods
 | Name | Description
Public method | SelectCustom | Returns a ICustomConfigurationBuilder allowing the properties to be set to custom values (useful for testing with non-standard AMQP) (Inherited from IEnvironmentSelector)
Public method | SelectEnvironment | Returns a IConfigurationBuilder with properties set to values needed to access specified environment
Public method | SelectIntegration | Returns a IConfigurationBuilder with properties set to values needed to access integration environment
Public method | SelectProduction | Returns a IConfigurationBuilder with properties set to values needed to access production environment (Inherited from IEnvironmentSelector)
Public method | SelectReplay | Returns a IReplayConfigurationBuilder with properties set to values needed to access replay server (Inherited from IEnvironmentSelector)
Public method | SelectStaging | Obsolete. Returns a IConfigurationBuilder with properties set to values needed to access integration environment (Inherited from IEnvironmentSelector)
Top
See Also

Reference

IEnvironmentSelectorV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


IEnvironmentSelectorV1.SelectEnvironment Method

IEnvironmentSelectorV1SelectEnvironment Method

Returns a IConfigurationBuilder with properties set to values needed to access specified environment

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IConfigurationBuilder SelectEnvironment(
    SdkEnvironment ufEnvironment
)

Parameters

ufEnvironment SdkEnvironment
A SdkEnvironment specifying to which environment to connect

Return Value

IConfigurationBuilder
A IConfigurationBuilder with properties set to values needed to access production environment
Remarks
For accessing replay or custom server use SelectReplay or SelectCustom
See Also

Reference

IEnvironmentSelectorV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


IEnvironmentSelectorV1.SelectIntegration Method

IEnvironmentSelectorV1SelectIntegration Method

Returns a IConfigurationBuilder with properties set to values needed to access integration environment

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IConfigurationBuilder SelectIntegration()

Return Value

IConfigurationBuilder
A IConfigurationBuilder with properties set to values needed to access integration environment
See Also

Reference

IEnvironmentSelectorV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager Interface

Defines a contract implemented by classes capable of getting list of IFixtureChange and/or IResultChange

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEventChangeManager

The IEventChangeManager type exposes the following members.

Properties
 | Name | Description
Public property | FixtureChangeInterval | Gets the interval for getting new list of fixture changes
Public property | IsRunning | Gets a value indicating whether this instance is running.
Public property | LastFixtureChange | Gets the timestamp of last processed fixture change
Public property | LastResultChange | Gets the timestamp of last processed result change
Public property | ResultChangeInterval | Gets the interval for getting new list of result changes
Top
Methods
 | Name | Description
Public method | SetFixtureChangeInterval | Sets the fixture change interval between two Sports API requests. Must be between 1 min and 12 hours.
Public method | SetFixtureChangeTimestamp | Sets the last processed fixture change timestamp.
Public method | SetResultChangeInterval | Sets the result change interval between two Sports API requests. Must be between 1 min and 12 hours.
Public method | SetResultChangeTimestamp | Sets the last processed result change timestamp.
Public method | Start | Starts scheduled job for fetching fixture and result changes
Public method | Stop | Stops scheduled job for fetching fixture and result changes
Top
Events
 | Name | Description
Public event | FixtureChange | Raised for IFixtureChange message
Public event | ResultChange | Raised for IResultChange message
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager Properties

The IEventChangeManager type exposes the following members.

Properties
 | Name | Description
Public property | FixtureChangeInterval | Gets the interval for getting new list of fixture changes
Public property | IsRunning | Gets a value indicating whether this instance is running.
Public property | LastFixtureChange | Gets the timestamp of last processed fixture change
Public property | LastResultChange | Gets the timestamp of last processed result change
Public property | ResultChangeInterval | Gets the interval for getting new list of result changes
Top
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.FixtureChangeInterval Property

IEventChangeManagerFixtureChangeInterval Property

Gets the interval for getting new list of fixture changes

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
TimeSpan FixtureChangeInterval { get; }

Property Value

TimeSpan
The fixture change interval.
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.IsRunning Property

IEventChangeManagerIsRunning Property

Gets a value indicating whether this instance is running.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsRunning { get; }

Property Value

Boolean
true if this instance is running; otherwise, false.
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.LastFixtureChange Property

IEventChangeManagerLastFixtureChange Property

Gets the timestamp of last processed fixture change

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime LastFixtureChange { get; }

Property Value

DateTime
The last fixture change.
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.LastResultChange Property

IEventChangeManagerLastResultChange Property

Gets the timestamp of last processed result change

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime LastResultChange { get; }

Property Value

DateTime
The last result change.
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.ResultChangeInterval Property

IEventChangeManagerResultChangeInterval Property

Gets the interval for getting new list of result changes

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
TimeSpan ResultChangeInterval { get; }

Property Value

TimeSpan
The result change interval.
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager Methods

The IEventChangeManager type exposes the following members.

Methods
 | Name | Description
Public method | SetFixtureChangeInterval | Sets the fixture change interval between two Sports API requests. Must be between 1 min and 12 hours.
Public method | SetFixtureChangeTimestamp | Sets the last processed fixture change timestamp.
Public method | SetResultChangeInterval | Sets the result change interval between two Sports API requests. Must be between 1 min and 12 hours.
Public method | SetResultChangeTimestamp | Sets the last processed result change timestamp.
Public method | Start | Starts scheduled job for fetching fixture and result changes
Public method | Stop | Stops scheduled job for fetching fixture and result changes
Top
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.SetFixtureChangeInterval Method

IEventChangeManagerSetFixtureChangeInterval Method

Sets the fixture change interval between two Sports API requests. Must be between 1 min and 12 hours.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void SetFixtureChangeInterval(
    TimeSpan fixtureChangeInterval
)

Parameters

fixtureChangeInterval TimeSpan
The fixture change interval.
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.SetFixtureChangeTimestamp Method

IEventChangeManagerSetFixtureChangeTimestamp Method

Sets the last processed fixture change timestamp.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void SetFixtureChangeTimestamp(
    DateTime fixtureChangeTimestamp
)

Parameters

fixtureChangeTimestamp DateTime
The fixture change timestamp.
Remarks
It can be only set when it is stopped
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.SetResultChangeInterval Method

IEventChangeManagerSetResultChangeInterval Method

Sets the result change interval between two Sports API requests. Must be between 1 min and 12 hours.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void SetResultChangeInterval(
    TimeSpan resultChangeInterval
)

Parameters

resultChangeInterval TimeSpan
The result change interval.
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.SetResultChangeTimestamp Method

IEventChangeManagerSetResultChangeTimestamp Method

Sets the last processed result change timestamp.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void SetResultChangeTimestamp(
    DateTime resultChangeTimestamp
)

Parameters

resultChangeTimestamp DateTime
The result change timestamp.
Remarks
It can be only set when it is stopped
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.Start Method

IEventChangeManagerStart Method

Starts scheduled job for fetching fixture and result changes

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void Start()
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.Stop Method

IEventChangeManagerStop Method

Stops scheduled job for fetching fixture and result changes

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void Stop()
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager Events

The IEventChangeManager type exposes the following members.

Events
 | Name | Description
Public event | FixtureChange | Raised for IFixtureChange message
Public event | ResultChange | Raised for IResultChange message
Top
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.FixtureChange Event

IEventChangeManagerFixtureChange Event

Raised for IFixtureChange message

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<EventChangeEventArgs> FixtureChange

Value

EventHandler EventChangeEventArgs
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventChangeManager.ResultChange Event

IEventChangeManagerResultChange Event

Raised for IResultChange message

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<EventChangeEventArgs> ResultChange

Value

EventHandler EventChangeEventArgs
See Also

Reference

IEventChangeManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventRecoveryRequestIssuer Interface

Defines a contract implemented by classes used to issue event message recovery requests to the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEventRecoveryRequestIssuer

The IEventRecoveryRequestIssuer type exposes the following members.

Methods
 | Name | Description
Public method | RecoverEventMessagesAsync | Asynchronously requests messages for the specified sport event and returns a request number used when issuing the request
Public method | RecoverEventStatefulMessagesAsync | Asynchronously requests stateful messages for the specified sport event and returns a request number used when issuing the request
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IEventRecoveryRequestIssuer Methods

The IEventRecoveryRequestIssuer type exposes the following members.

Methods
 | Name | Description
Public method | RecoverEventMessagesAsync | Asynchronously requests messages for the specified sport event and returns a request number used when issuing the request
Public method | RecoverEventStatefulMessagesAsync | Asynchronously requests stateful messages for the specified sport event and returns a request number used when issuing the request
Top
See Also

Reference

IEventRecoveryRequestIssuer Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventRecoveryRequestIssuer.RecoverEventMessagesAsync Method

IEventRecoveryRequestIssuerRecoverEventMessagesAsync Method

Asynchronously requests messages for the specified sport event and returns a request number used when issuing the request

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<long> RecoverEventMessagesAsync(
    IProducer producer,
    URN eventId
)

Parameters

producer IProducer
An IProducer for which to make the recovery
eventId URN
A URN specifying the sport event for which to request the messages

Return Value

Task Int64
TaskTResult representing the async operation
See Also

Reference

IEventRecoveryRequestIssuer Interface
Sportradar.OddsFeed.SDK.API Namespace


IEventRecoveryRequestIssuer.RecoverEventStatefulMessagesAsync Method

IEventRecoveryRequestIssuerRecoverEventStatefulMessagesAsync Method

Asynchronously requests stateful messages for the specified sport event and returns a request number used when issuing the request

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<long> RecoverEventStatefulMessagesAsync(
    IProducer producer,
    URN eventId
)

Parameters

producer IProducer
An IProducer for which to make the recovery
eventId URN
A URN specifying the sport event for which to request the messages

Return Value

Task Int64
TaskTResult representing the async operation
See Also

Reference

IEventRecoveryRequestIssuer Interface
Sportradar.OddsFeed.SDK.API Namespace


IMarketDescriptionManager Interface

Used to obtain information about available markets and get translations for markets and outcomes including outrights

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketDescriptionManager

The IMarketDescriptionManager type exposes the following members.

Methods
 | Name | Description
Public method | GetMarketDescriptionsAsync | Asynchronously gets a IEnumerableT of all available static market descriptions
Public method | GetMarketMappingAsync(Int32, IProducer) | Asynchronously gets a IEnumerableT of available mappings for the provided marketId/producer combination
Public method | GetMarketMappingAsync(Int32, IReadOnlyDictionaryString, String, IProducer) | Asynchronously gets a IEnumerableT of available mappings for the provided marketId/producer combination
Public method | LoadMarketDescriptionsAsync | Asynchronously loads the invariant and variant list of market descriptions from the Sports API
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IMarketDescriptionManager Methods

The IMarketDescriptionManager type exposes the following members.

Methods
 | Name | Description
Public method | GetMarketDescriptionsAsync | Asynchronously gets a IEnumerableT of all available static market descriptions
Public method | GetMarketMappingAsync(Int32, IProducer) | Asynchronously gets a IEnumerableT of available mappings for the provided marketId/producer combination
Public method | GetMarketMappingAsync(Int32, IReadOnlyDictionaryString, String, IProducer) | Asynchronously gets a IEnumerableT of available mappings for the provided marketId/producer combination
Public method | LoadMarketDescriptionsAsync | Asynchronously loads the invariant and variant list of market descriptions from the Sports API
Top
See Also

Reference

IMarketDescriptionManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IMarketDescriptionManager.GetMarketDescriptionsAsync Method

IMarketDescriptionManagerGetMarketDescriptionsAsync Method

Asynchronously gets a IEnumerableT of all available static market descriptions

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IMarketDescription>> GetMarketDescriptionsAsync(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)

[Missing <param name="culture"/> documentation for "M:Sportradar.OddsFeed.SDK.API.IMarketDescriptionManager.GetMarketDescriptionsAsync(System.Globalization.CultureInfo)"]

Return Value

Task IEnumerable IMarketDescription
A IEnumerableT of available static market descriptions
See Also

Reference

IMarketDescriptionManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IMarketDescriptionManager.GetMarketMappingAsync Method

IMarketDescriptionManagerGetMarketMappingAsync Method

Overload List
 | Name | Description
Public method | GetMarketMappingAsync(Int32, IProducer) | Asynchronously gets a IEnumerableT of available mappings for the provided marketId/producer combination
Public method | GetMarketMappingAsync(Int32, IReadOnlyDictionaryString, String, IProducer) | Asynchronously gets a IEnumerableT of available mappings for the provided marketId/producer combination
Top
See Also

Reference

IMarketDescriptionManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IMarketDescriptionManager.GetMarketMappingAsync(Int32, IProducer) Method

IMarketDescriptionManagerGetMarketMappingAsync(Int32, IProducer) Method

Asynchronously gets a IEnumerableT of available mappings for the provided marketId/producer combination

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IMarketMappingData>> GetMarketMappingAsync(
    int marketId,
    IProducer producer
)

Parameters

marketId Int32
The id of the market for which you need the mapping
producer IProducer
The IProducer for which you need the mapping

Return Value

Task IEnumerable IMarketMappingData
A IEnumerableT of available mappings for the provided marketId/producer combination
See Also

Reference

IMarketDescriptionManager Interface
GetMarketMappingAsync Overload
Sportradar.OddsFeed.SDK.API Namespace


IMarketDescriptionManager.GetMarketMappingAsync(Int32, IReadOnlyDictionary<String, String>, IProducer) Method

IMarketDescriptionManagerGetMarketMappingAsync(Int32, IReadOnlyDictionaryString, String, IProducer) Method

Asynchronously gets a IEnumerableT of available mappings for the provided marketId/producer combination

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IMarketMappingData>> GetMarketMappingAsync(
    int marketId,
    IReadOnlyDictionary<string, string> specifiers,
    IProducer producer
)

Parameters

marketId Int32
The id of the market for which you need the mapping
specifiers IReadOnlyDictionary String, String
The associated market specifiers
producer IProducer
The IProducer for which you need the mapping

Return Value

Task IEnumerable IMarketMappingData
A IEnumerableT of available mappings for the provided marketId/producer combination
See Also

Reference

IMarketDescriptionManager Interface
GetMarketMappingAsync Overload
Sportradar.OddsFeed.SDK.API Namespace


IMarketDescriptionManager.LoadMarketDescriptionsAsync Method

IMarketDescriptionManagerLoadMarketDescriptionsAsync Method

Asynchronously loads the invariant and variant list of market descriptions from the Sports API

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<bool> LoadMarketDescriptionsAsync()

Return Value

Task Boolean
Returns true if the action succeeded
Remarks
To be used when manually changed market data via betradar control
See Also

Reference

IMarketDescriptionManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IMarketDescriptionManagerV1 Interface

Used to obtain information about available markets and get translations for markets and outcomes including outrights

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketDescriptionManagerV1 : IMarketDescriptionManager

The IMarketDescriptionManagerV1 type exposes the following members.

Methods
 | Name | Description
Public method | DeleteVariantMarketDescriptionFromCache | Deletes the variant market description from cache
Public method | GetMarketDescriptionsAsync | Asynchronously gets a IEnumerableT of all available static market descriptions (Inherited from IMarketDescriptionManager)
Public method | GetMarketMappingAsync(Int32, IProducer) | Asynchronously gets a IEnumerableT of available mappings for the provided marketId/producer combination (Inherited from IMarketDescriptionManager)
Public method | GetMarketMappingAsync(Int32, IReadOnlyDictionaryString, String, IProducer) | Asynchronously gets a IEnumerableT of available mappings for the provided marketId/producer combination (Inherited from IMarketDescriptionManager)
Public method | LoadMarketDescriptionsAsync | Asynchronously loads the invariant and variant list of market descriptions from the Sports API (Inherited from IMarketDescriptionManager)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IMarketDescriptionManagerV1 Methods

The IMarketDescriptionManagerV1 type exposes the following members.

Methods
 | Name | Description
Public method | DeleteVariantMarketDescriptionFromCache | Deletes the variant market description from cache
Public method | GetMarketDescriptionsAsync | Asynchronously gets a IEnumerableT of all available static market descriptions (Inherited from IMarketDescriptionManager)
Public method | GetMarketMappingAsync(Int32, IProducer) | Asynchronously gets a IEnumerableT of available mappings for the provided marketId/producer combination (Inherited from IMarketDescriptionManager)
Public method | GetMarketMappingAsync(Int32, IReadOnlyDictionaryString, String, IProducer) | Asynchronously gets a IEnumerableT of available mappings for the provided marketId/producer combination (Inherited from IMarketDescriptionManager)
Public method | LoadMarketDescriptionsAsync | Asynchronously loads the invariant and variant list of market descriptions from the Sports API (Inherited from IMarketDescriptionManager)
Top
See Also

Reference

IMarketDescriptionManagerV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


IMarketDescriptionManagerV1.DeleteVariantMarketDescriptionFromCache Method

IMarketDescriptionManagerV1DeleteVariantMarketDescriptionFromCache Method

Deletes the variant market description from cache

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void DeleteVariantMarketDescriptionFromCache(
    int marketId,
    string variantValue
)

Parameters

marketId Int32
The market identifier
variantValue String
The variant value
See Also

Reference

IMarketDescriptionManagerV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed Interface

Represent a root object of the unified odds feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsFeed : IDisposable

The IOddsFeed type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed
Top
Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current feed by opening all created sessions
Top
Events
 | Name | Description
Public event | Closed | Occurs when feed is closed
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed Properties

The IOddsFeed type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed
Top
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed.BookingManager Property

IOddsFeedBookingManager Property

Gets a IBookingManager instance used to perform various booking calendar operations

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IBookingManager BookingManager { get; }

Property Value

IBookingManager
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed.CashOutProbabilitiesProvider Property

IOddsFeedCashOutProbabilitiesProvider Property

Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICashOutProbabilitiesProvider CashOutProbabilitiesProvider { get; }

Property Value

ICashOutProbabilitiesProvider
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed.EventRecoveryRequestIssuer Property

IOddsFeedEventRecoveryRequestIssuer Property

Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEventRecoveryRequestIssuer EventRecoveryRequestIssuer { get; }

Property Value

IEventRecoveryRequestIssuer
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed.ProducerManager Property

IOddsFeedProducerManager Property

Gets a IProducerManager instance used to retrieve producer related data

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IProducerManager ProducerManager { get; }

Property Value

IProducerManager
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed.SportDataProvider Property

IOddsFeedSportDataProvider Property

Gets a ISportDataProvider instance used to retrieve sport related data from the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ISportDataProvider SportDataProvider { get; }

Property Value

ISportDataProvider
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed Methods

The IOddsFeed type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current feed by opening all created sessions
Top
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed.Close Method

IOddsFeedClose Method

Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void Close()
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed.CreateBuilder Method

IOddsFeedCreateBuilder Method

Constructs and returns a new instance of IOddsFeedSessionBuilder

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedSessionBuilder CreateBuilder()

Return Value

IOddsFeedSessionBuilder
Constructed instance of the IOddsFeedSessionBuilder
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed.Open Method

IOddsFeedOpen Method

Opens the current feed by opening all created sessions

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void Open()
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed Events

The IOddsFeed type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when feed is closed
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online)
Top
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed.Closed Event

IOddsFeedClosed Event

Occurs when feed is closed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<FeedCloseEventArgs> Closed

Value

EventHandler FeedCloseEventArgs
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed.Disconnected Event

IOddsFeedDisconnected Event

Raised when the current instance of IOddsFeed loses connection to the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<EventArgs> Disconnected

Value

EventHandler EventArgs
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed.ProducerDown Event

IOddsFeedProducerDown Event

Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<ProducerStatusChangeEventArgs> ProducerDown

Value

EventHandler ProducerStatusChangeEventArgs
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeed.ProducerUp Event

IOddsFeedProducerUp Event

Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<ProducerStatusChangeEventArgs> ProducerUp

Value

EventHandler ProducerStatusChangeEventArgs
See Also

Reference

IOddsFeed Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration Interface

Defines a contract implemented by classes representing odds feed configuration / settings

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsFeedConfiguration

The IOddsFeedConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AccessToken | Gets the access token used when accessing feed's REST interface
Public property | AdjustAfterAge | Gets a value indicating whether the after age should be adjusted before executing recovery request
Public property | ApiHost | Gets a host name of the Sports API
Public property | DefaultLocale | Gets a CultureInfo specifying default locale to which translatable values will be translated
Public property | DisabledProducers | Gets the comma delimited list of ids of disabled producers (default: none)
Public property | Environment | Gets the SdkEnvironment value specifying the environment to which to connect.
Public property | ExceptionHandlingStrategy | Gets the exception handling strategy
Public property | Host | Gets a value specifying the host name of the AQMP broker
Public property | HttpClientTimeout | Gets a value specifying timeout set for HTTP responses
Public property | InactivitySeconds | Gets the maximum allowed timeout in seconds, between consecutive AMQP messages associated with the same producer. If this value is exceeded, the producer is considered to be down
Public property | Locales | Gets a IEnumerableT specifying locales (languages) to which translatable values will be translated
Public property | MaxRecoveryTime | Gets the maximum recovery time
Public property | MinIntervalBetweenRecoveryRequests | Gets the minimal interval between recovery requests initiated by alive messages (seconds)
Public property | NodeId | Gets the node identifier
Public property | Password | Gets the password for connecting to the AQMP broker
Public property | Port | Gets the port used for connecting to the AQMP broker
Public property | RecoveryHttpClientTimeout | Gets a value specifying timeout set for recovery HTTP responses
Public property | UseApiSsl | Gets a value indicating whether the connection to Sports API should use SSL
Public property | Username | Gets the user name for connecting to the AQMP broker
Public property | UseSsl | Gets a value specifying whether the connection to AMQP broker should use SSL encryption
Public property | VirtualHost | Gets a value specifying the virtual host of the AQMP broker
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration Properties

The IOddsFeedConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AccessToken | Gets the access token used when accessing feed's REST interface
Public property | AdjustAfterAge | Gets a value indicating whether the after age should be adjusted before executing recovery request
Public property | ApiHost | Gets a host name of the Sports API
Public property | DefaultLocale | Gets a CultureInfo specifying default locale to which translatable values will be translated
Public property | DisabledProducers | Gets the comma delimited list of ids of disabled producers (default: none)
Public property | Environment | Gets the SdkEnvironment value specifying the environment to which to connect.
Public property | ExceptionHandlingStrategy | Gets the exception handling strategy
Public property | Host | Gets a value specifying the host name of the AQMP broker
Public property | HttpClientTimeout | Gets a value specifying timeout set for HTTP responses
Public property | InactivitySeconds | Gets the maximum allowed timeout in seconds, between consecutive AMQP messages associated with the same producer. If this value is exceeded, the producer is considered to be down
Public property | Locales | Gets a IEnumerableT specifying locales (languages) to which translatable values will be translated
Public property | MaxRecoveryTime | Gets the maximum recovery time
Public property | MinIntervalBetweenRecoveryRequests | Gets the minimal interval between recovery requests initiated by alive messages (seconds)
Public property | NodeId | Gets the node identifier
Public property | Password | Gets the password for connecting to the AQMP broker
Public property | Port | Gets the port used for connecting to the AQMP broker
Public property | RecoveryHttpClientTimeout | Gets a value specifying timeout set for recovery HTTP responses
Public property | UseApiSsl | Gets a value indicating whether the connection to Sports API should use SSL
Public property | Username | Gets the user name for connecting to the AQMP broker
Public property | UseSsl | Gets a value specifying whether the connection to AMQP broker should use SSL encryption
Public property | VirtualHost | Gets a value specifying the virtual host of the AQMP broker
Top
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.AccessToken Property

IOddsFeedConfigurationAccessToken Property

Gets the access token used when accessing feed's REST interface

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string AccessToken { get; }

Property Value

String
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.AdjustAfterAge Property

IOddsFeedConfigurationAdjustAfterAge Property

Gets a value indicating whether the after age should be adjusted before executing recovery request

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool AdjustAfterAge { get; }

Property Value

Boolean
true if [adjust after age]; otherwise, false
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.ApiHost Property

IOddsFeedConfigurationApiHost Property

Gets a host name of the Sports API

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string ApiHost { get; }

Property Value

String
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.DefaultLocale Property

IOddsFeedConfigurationDefaultLocale Property

Gets a CultureInfo specifying default locale to which translatable values will be translated

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
CultureInfo DefaultLocale { get; }

Property Value

CultureInfo
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.DisabledProducers Property

IOddsFeedConfigurationDisabledProducers Property

Gets the comma delimited list of ids of disabled producers (default: none)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<int> DisabledProducers { get; }

Property Value

IEnumerable Int32
The list of ids of disabled producers
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.Environment Property

IOddsFeedConfigurationEnvironment Property

Gets the SdkEnvironment value specifying the environment to which to connect.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
SdkEnvironment Environment { get; }

Property Value

SdkEnvironment
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.ExceptionHandlingStrategy Property

IOddsFeedConfigurationExceptionHandlingStrategy Property

Gets the exception handling strategy

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ExceptionHandlingStrategy ExceptionHandlingStrategy { get; }

Property Value

ExceptionHandlingStrategy
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.Host Property

IOddsFeedConfigurationHost Property

Gets a value specifying the host name of the AQMP broker

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Host { get; }

Property Value

String
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.HttpClientTimeout Property

IOddsFeedConfigurationHttpClientTimeout Property

Gets a value specifying timeout set for HTTP responses

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int HttpClientTimeout { get; }

Property Value

Int32
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.InactivitySeconds Property

IOddsFeedConfigurationInactivitySeconds Property

Gets the maximum allowed timeout in seconds, between consecutive AMQP messages associated with the same producer. If this value is exceeded, the producer is considered to be down

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int InactivitySeconds { get; }

Property Value

Int32
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.Locales Property

IOddsFeedConfigurationLocales Property

Gets a IEnumerableT specifying locales (languages) to which translatable values will be translated

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<CultureInfo> Locales { get; }

Property Value

IEnumerable CultureInfo
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.MaxRecoveryTime Property

IOddsFeedConfigurationMaxRecoveryTime Property

Gets the maximum recovery time

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int MaxRecoveryTime { get; }

Property Value

Int32
The maximum recovery time
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.MinIntervalBetweenRecoveryRequests Property

IOddsFeedConfigurationMinIntervalBetweenRecoveryRequests Property

Gets the minimal interval between recovery requests initiated by alive messages (seconds)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int MinIntervalBetweenRecoveryRequests { get; }

Property Value

Int32
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.NodeId Property

IOddsFeedConfigurationNodeId Property

Gets the node identifier

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int NodeId { get; }

Property Value

Int32
Remarks
MTS customer must set this value! Use only positive numbers; negative are reserved for internal use.
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.Password Property

IOddsFeedConfigurationPassword Property

Gets the password for connecting to the AQMP broker

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Password { get; }

Property Value

String
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.Port Property

IOddsFeedConfigurationPort Property

Gets the port used for connecting to the AQMP broker

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Port { get; }

Property Value

Int32
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.RecoveryHttpClientTimeout Property

IOddsFeedConfigurationRecoveryHttpClientTimeout Property

Gets a value specifying timeout set for recovery HTTP responses

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int RecoveryHttpClientTimeout { get; }

Property Value

Int32
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.UseApiSsl Property

IOddsFeedConfigurationUseApiSsl Property

Gets a value indicating whether the connection to Sports API should use SSL

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool UseApiSsl { get; }

Property Value

Boolean
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.Username Property

IOddsFeedConfigurationUsername Property

Gets the user name for connecting to the AQMP broker

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Username { get; }

Property Value

String
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.UseSsl Property

IOddsFeedConfigurationUseSsl Property

Gets a value specifying whether the connection to AMQP broker should use SSL encryption

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool UseSsl { get; }

Property Value

Boolean
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfiguration.VirtualHost Property

IOddsFeedConfigurationVirtualHost Property

Gets a value specifying the virtual host of the AQMP broker

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string VirtualHost { get; }

Property Value

String
See Also

Reference

IOddsFeedConfiguration Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder Interface

Note: This API is now obsolete.

Defines methods used to set optional properties on the configuration builder

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use IConfigurationBuilder")]
public interface IOddsFeedConfigurationBuilder

The IOddsFeedConfigurationBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddLocale | Adds a provided CultureInfo into the list of default locales
Public method | Build | Builds and returns a IOddsFeedConfiguration instance
Public method | RemoveLocale | Removes the specified CultureInfo from the list of default locales
Public method | SetApiHost | Sets the URL of the API host
Public method | SetHost | Sets the URL of the messaging host
Public method | SetHttpClientTimeout | Sets the timeout for HTTP responses for this instance of the sdk
Public method | SetMaxRecoveryTime | Sets the maximum time in seconds in which recovery must be completed (minimum 600 seconds)
Public method | SetNodeId | Sets the node id for this instance of the sdk
Public method | SetRecoveryHttpClientTimeout | Sets the timeout for recovery HTTP responses for this instance of the sdk
Public method | SetUseIntegrationEnvironment | Sets a value indicating whether the SDK should connect to the integration environment
Public method | SetUseSsl | Sets the value indicating whether a secure connection to the message broker should be used
Public method | SetUseStagingEnvironment | Obsolete. Sets a value indicating whether the SDK should connect to the integration environment
Public method | SetVirtualHost | Sets the name of the virtual host configured on the messaging server.
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder Methods

The IOddsFeedConfigurationBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddLocale | Adds a provided CultureInfo into the list of default locales
Public method | Build | Builds and returns a IOddsFeedConfiguration instance
Public method | RemoveLocale | Removes the specified CultureInfo from the list of default locales
Public method | SetApiHost | Sets the URL of the API host
Public method | SetHost | Sets the URL of the messaging host
Public method | SetHttpClientTimeout | Sets the timeout for HTTP responses for this instance of the sdk
Public method | SetMaxRecoveryTime | Sets the maximum time in seconds in which recovery must be completed (minimum 600 seconds)
Public method | SetNodeId | Sets the node id for this instance of the sdk
Public method | SetRecoveryHttpClientTimeout | Sets the timeout for recovery HTTP responses for this instance of the sdk
Public method | SetUseIntegrationEnvironment | Sets a value indicating whether the SDK should connect to the integration environment
Public method | SetUseSsl | Sets the value indicating whether a secure connection to the message broker should be used
Public method | SetUseStagingEnvironment | Obsolete. Sets a value indicating whether the SDK should connect to the integration environment
Public method | SetVirtualHost | Sets the name of the virtual host configured on the messaging server.
Top
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.AddLocale Method

IOddsFeedConfigurationBuilderAddLocale Method

Adds a provided CultureInfo into the list of default locales

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfigurationBuilder AddLocale(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo representing the locale.

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
Exceptions
Exception Condition
ArgumentNullException A
C#
Copy
culture
is a null reference
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.Build Method

IOddsFeedConfigurationBuilderBuild Method

Builds and returns a IOddsFeedConfiguration instance

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfiguration Build()

Return Value

IOddsFeedConfiguration
The constructed IOddsFeedConfiguration instance.
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.RemoveLocale Method

IOddsFeedConfigurationBuilderRemoveLocale Method

Removes the specified CultureInfo from the list of default locales

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfigurationBuilder RemoveLocale(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo representing the locale to be removed.

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
Exceptions
Exception Condition
ArgumentNullException The
C#
Copy
culture
is a null reference
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.SetApiHost Method

IOddsFeedConfigurationBuilderSetApiHost Method

Sets the URL of the API host

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfigurationBuilder SetApiHost(
    string apiHost
)

Parameters

apiHost String
The URL of the API host.

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.SetHost Method

IOddsFeedConfigurationBuilderSetHost Method

Sets the URL of the messaging host

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfigurationBuilder SetHost(
    string host
)

Parameters

host String
The URL of the messaging host.

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.SetHttpClientTimeout Method

IOddsFeedConfigurationBuilderSetHttpClientTimeout Method

Sets the timeout for HTTP responses for this instance of the sdk

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfigurationBuilder SetHttpClientTimeout(
    int httpClientTimeout
)

Parameters

httpClientTimeout Int32
The timeout for HTTP responses

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.SetMaxRecoveryTime Method

IOddsFeedConfigurationBuilderSetMaxRecoveryTime Method

Sets the maximum time in seconds in which recovery must be completed (minimum 600 seconds)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfigurationBuilder SetMaxRecoveryTime(
    int maxRecoveryTime
)

Parameters

maxRecoveryTime Int32
Maximum recovery time

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.SetNodeId Method

IOddsFeedConfigurationBuilderSetNodeId Method

Sets the node id for this instance of the sdk

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfigurationBuilder SetNodeId(
    int nodeId
)

Parameters

nodeId Int32
The node id

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.SetRecoveryHttpClientTimeout Method

IOddsFeedConfigurationBuilderSetRecoveryHttpClientTimeout Method

Sets the timeout for recovery HTTP responses for this instance of the sdk

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfigurationBuilder SetRecoveryHttpClientTimeout(
    int recoveryHttpClientTimeout
)

Parameters

recoveryHttpClientTimeout Int32
The timeout for recovery HTTP responses

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.SetUseIntegrationEnvironment Method

IOddsFeedConfigurationBuilderSetUseIntegrationEnvironment Method

Sets a value indicating whether the SDK should connect to the integration environment

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfigurationBuilder SetUseIntegrationEnvironment(
    bool useIntegrationEnvironment
)

Parameters

useIntegrationEnvironment Boolean

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.SetUseSsl Method

IOddsFeedConfigurationBuilderSetUseSsl Method

Sets the value indicating whether a secure connection to the message broker should be used

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfigurationBuilder SetUseSsl(
    bool useSsl
)

Parameters

useSsl Boolean
True if secure connection should be used; False otherwise.

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.SetUseStagingEnvironment Method

IOddsFeedConfigurationBuilderSetUseStagingEnvironment Method

Note: This API is now obsolete.

Sets a value indicating whether the SDK should connect to the integration environment

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use SetUseIntegrationEnvironment(bool useIntegrationEnvironment)")]
IOddsFeedConfigurationBuilder SetUseStagingEnvironment(
    bool useStagingEnvironment
)

Parameters

useStagingEnvironment Boolean

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedConfigurationBuilder.SetVirtualHost Method

IOddsFeedConfigurationBuilderSetVirtualHost Method

Sets the name of the virtual host configured on the messaging server.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfigurationBuilder SetVirtualHost(
    string virtualHost
)

Parameters

virtualHost String
The name virtual host.

Return Value

IOddsFeedConfigurationBuilder
The IOddsFeedConfigurationBuilder instance used to set additional values.
See Also

Reference

IOddsFeedConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedSession Interface

Represents a session to the odds feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsFeedSession : IEntityDispatcher<ISportEvent>

The IOddsFeedSession type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the session
Top
Methods
 | Name | Description
Public method | CreateSportSpecificMessageDispatcherT | Constructs and returns a sport-specific ISpecificEntityDispatcherT instance allowing processing of messages containing entity specific information
Top
Events
 | Name | Description
Public event | OnBetCancel | Raised when a bet cancel message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnBetSettlement | Raised when a bet settlement message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnBetStop | Raised when a bet stop message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnFixtureChange | Raised when a fixture change message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnOddsChange | Raised when a odds change message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnRollbackBetCancel | Raised when a rollback bet cancel message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnRollbackBetSettlement | Raised when a rollback bet settlement is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnUnparsableMessageReceived | Raised when a message which cannot be parsed is received
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedSession Properties

The IOddsFeedSession type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the session
Top
See Also

Reference

IOddsFeedSession Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedSession.Name Property

IOddsFeedSessionName Property

Gets the name of the session

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

String
See Also

Reference

IOddsFeedSession Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedSession Methods

The IOddsFeedSession type exposes the following members.

Methods
 | Name | Description
Public method | CreateSportSpecificMessageDispatcherT | Constructs and returns a sport-specific ISpecificEntityDispatcherT instance allowing processing of messages containing entity specific information
Top
See Also

Reference

IOddsFeedSession Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedSession.CreateSportSpecificMessageDispatcher<T> Method

IOddsFeedSessionCreateSportSpecificMessageDispatcherT Method

Constructs and returns a sport-specific ISpecificEntityDispatcherT instance allowing processing of messages containing entity specific information

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ISpecificEntityDispatcher<T> CreateSportSpecificMessageDispatcher<T>()
where T : ISportEvent

Type Parameters

T
A ICompetition derived type specifying the entities associated with the created IEntityDispatcherT instance

Return Value

ISpecificEntityDispatcher T
The constructed ISpecificEntityDispatcherT
See Also

Reference

IOddsFeedSession Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedSession Events

The IOddsFeedSession type exposes the following members.

Events
 | Name | Description
Public event | OnBetCancel | Raised when a bet cancel message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnBetSettlement | Raised when a bet settlement message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnBetStop | Raised when a bet stop message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnFixtureChange | Raised when a fixture change message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnOddsChange | Raised when a odds change message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnRollbackBetCancel | Raised when a rollback bet cancel message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnRollbackBetSettlement | Raised when a rollback bet settlement is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnUnparsableMessageReceived | Raised when a message which cannot be parsed is received
Top
See Also

Reference

IOddsFeedSession Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedSession.OnUnparsableMessageReceived Event

IOddsFeedSessionOnUnparsableMessageReceived Event

Raised when a message which cannot be parsed is received

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<UnparsableMessageEventArgs> OnUnparsableMessageReceived

Value

EventHandler UnparsableMessageEventArgs
See Also

Reference

IOddsFeedSession Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedSessionBuilder Interface

Represents a first step when building a IOddsFeedSession instance

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsFeedSessionBuilder

The IOddsFeedSessionBuilder type exposes the following members.

Methods
 | Name | Description
Public method | SetMessageInterest | Sets a MessageInterest specifying which type of messages should be received from the feed
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedSessionBuilder Methods

The IOddsFeedSessionBuilder type exposes the following members.

Methods
 | Name | Description
Public method | SetMessageInterest | Sets a MessageInterest specifying which type of messages should be received from the feed
Top
See Also

Reference

IOddsFeedSessionBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedSessionBuilder.SetMessageInterest Method

IOddsFeedSessionBuilderSetMessageInterest Method

Sets a MessageInterest specifying which type of messages should be received from the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ISessionBuilder SetMessageInterest(
    MessageInterest msgInterest
)

Parameters

msgInterest MessageInterest
a MessageInterest specifying which type of messages should be received from the feed

Return Value

ISessionBuilder
A ISessionBuilder representing the second step when building a IOddsFeedSession instance
See Also

Reference

IOddsFeedSessionBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV1 Interface

Represent a root object of the unified odds feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsFeedV1 : IOddsFeed,
    IDisposable

The IOddsFeedV1 type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Top
Remarks
Interface will be merged into base ITimelineEvent in next major version scheduled for January 2019
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV1 Properties

The IOddsFeedV1 type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV1.BookmakerDetails Property

IOddsFeedV1BookmakerDetails Property

Gets a IBookmakerDetails instance used to get info about bookmaker and token used

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IBookmakerDetails BookmakerDetails { get; }

Property Value

IBookmakerDetails
See Also

Reference

IOddsFeedV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV1 Methods

The IOddsFeedV1 type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV1 Events

The IOddsFeedV1 type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV2 Interface

Represent a root object of the unified odds feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsFeedV2 : IOddsFeedV1,
    IOddsFeed, IDisposable

The IOddsFeedV2 type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from IOddsFeedV1)
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV2 Properties

The IOddsFeedV2 type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from IOddsFeedV1)
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV2 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV2.CustomBetManager Property

IOddsFeedV2CustomBetManager Property

Gets a ICustomBetManager instance used to perform various custom bet operations

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICustomBetManager CustomBetManager { get; }

Property Value

ICustomBetManager
See Also

Reference

IOddsFeedV2 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV2.MarketDescriptionManager Property

IOddsFeedV2MarketDescriptionManager Property

Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IMarketDescriptionManager MarketDescriptionManager { get; }

Property Value

IMarketDescriptionManager
See Also

Reference

IOddsFeedV2 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV2 Methods

The IOddsFeedV2 type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV2 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV2 Events

The IOddsFeedV2 type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV2 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV2.EventRecoveryCompleted Event

IOddsFeedV2EventRecoveryCompleted Event

Occurs when a requested event recovery completes

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<EventRecoveryCompletedEventArgs> EventRecoveryCompleted

Value

EventHandler EventRecoveryCompletedEventArgs
See Also

Reference

IOddsFeedV2 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV3 Interface

Represent a root object of the unified odds feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsFeedV3 : IOddsFeedV2,
    IOddsFeedV1, IOddsFeed, IDisposable

The IOddsFeedV3 type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from IOddsFeedV1)
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from IOddsFeedV2)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from IOddsFeedV2)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from IOddsFeedV2)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV3 Properties

The IOddsFeedV3 type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from IOddsFeedV1)
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from IOddsFeedV2)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from IOddsFeedV2)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV3 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV3 Methods

The IOddsFeedV3 type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV3 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV3 Events

The IOddsFeedV3 type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from IOddsFeedV2)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV3 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV3.ConnectionException Event

IOddsFeedV3ConnectionException Event

Occurs when an exception occurs in the connection loop

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<ConnectionExceptionEventArgs> ConnectionException

Value

EventHandler ConnectionExceptionEventArgs
See Also

Reference

IOddsFeedV3 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV4 Interface

Represent a root object of the unified odds feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsFeedV4 : IOddsFeedV3,
    IOddsFeedV2, IOddsFeedV1, IOddsFeed, IDisposable

The IOddsFeedV4 type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from IOddsFeedV1)
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from IOddsFeedV2)
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from IOddsFeedV2)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop (Inherited from IOddsFeedV3)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from IOddsFeedV2)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV4 Properties

The IOddsFeedV4 type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from IOddsFeedV1)
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from IOddsFeedV2)
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from IOddsFeedV2)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV4 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV4.EventChangeManager Property

IOddsFeedV4EventChangeManager Property

Gets a IEventChangeManager instance used to automatically receive fixture and result changes

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEventChangeManager EventChangeManager { get; }

Property Value

IEventChangeManager
See Also

Reference

IOddsFeedV4 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV4 Methods

The IOddsFeedV4 type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV4 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV4 Events

The IOddsFeedV4 type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop (Inherited from IOddsFeedV3)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from IOddsFeedV2)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV4 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV5 Interface

Represent a root object of the unified odds feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsFeedV5 : IOddsFeedV4,
    IOddsFeedV3, IOddsFeedV2, IOddsFeedV1, IOddsFeed, IDisposable

The IOddsFeedV5 type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from IOddsFeedV1)
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from IOddsFeedV2)
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes (Inherited from IOddsFeedV4)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from IOddsFeedV2)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop (Inherited from IOddsFeedV3)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from IOddsFeedV2)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Public event | RecoveryInitiated | Occurs when a recovery initiation completes
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV5 Properties

The IOddsFeedV5 type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from IOddsFeedV1)
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from IOddsFeedV2)
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes (Inherited from IOddsFeedV4)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from IOddsFeedV2)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV5 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV5 Methods

The IOddsFeedV5 type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV5 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV5 Events

The IOddsFeedV5 type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop (Inherited from IOddsFeedV3)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from IOddsFeedV2)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Public event | RecoveryInitiated | Occurs when a recovery initiation completes
Top
See Also

Reference

IOddsFeedV5 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV5.RecoveryInitiated Event

IOddsFeedV5RecoveryInitiated Event

Occurs when a recovery initiation completes

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<RecoveryInitiatedEventArgs> RecoveryInitiated

Value

EventHandler RecoveryInitiatedEventArgs
See Also

Reference

IOddsFeedV5 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV6 Interface

Represent a root object of the unified odds feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsFeedV6 : IOddsFeedV5,
    IOddsFeedV4, IOddsFeedV3, IOddsFeedV2, IOddsFeedV1, IOddsFeed,
    IDisposable

The IOddsFeedV6 type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from IOddsFeedV1)
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from IOddsFeedV2)
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes (Inherited from IOddsFeedV4)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from IOddsFeedV2)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | IsOpen | Returns an indicator if the feed instance is opened or not
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop (Inherited from IOddsFeedV3)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from IOddsFeedV2)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Public event | RecoveryInitiated | Occurs when a recovery initiation completes (Inherited from IOddsFeedV5)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV6 Properties

The IOddsFeedV6 type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from IOddsFeedV1)
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from IOddsFeedV2)
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes (Inherited from IOddsFeedV4)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from IOddsFeedV2)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV6 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV6 Methods

The IOddsFeedV6 type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | IsOpen | Returns an indicator if the feed instance is opened or not
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedV6 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV6.IsOpen Method

IOddsFeedV6IsOpen Method

Returns an indicator if the feed instance is opened or not

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsOpen()

Return Value

Boolean

[Missing <returns> documentation for "M:Sportradar.OddsFeed.SDK.API.IOddsFeedV6.IsOpen"]

See Also

Reference

IOddsFeedV6 Interface
Sportradar.OddsFeed.SDK.API Namespace


IOddsFeedV6 Events

The IOddsFeedV6 type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop (Inherited from IOddsFeedV3)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from IOddsFeedV2)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Public event | RecoveryInitiated | Occurs when a recovery initiation completes (Inherited from IOddsFeedV5)
Top
See Also

Reference

IOddsFeedV6 Interface
Sportradar.OddsFeed.SDK.API Namespace


IProducersProvider Interface

Defines a type used to retrieve available producers on api

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IProducersProvider

The IProducersProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetProducers | Gets the available producers from api
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IProducersProvider Methods

The IProducersProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetProducers | Gets the available producers from api
Top
See Also

Reference

IProducersProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


IProducersProvider.GetProducers Method

IProducersProviderGetProducers Method

Gets the available producers from api

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IProducer> GetProducers()

Return Value

IEnumerable IProducer
A list of IProducer
See Also

Reference

IProducersProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


IRecoveryConfigurationBuilder<T> Interface

IRecoveryConfigurationBuilderT Interface

Defines a contract implemented by classes used to set recovery related configuration properties

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IRecoveryConfigurationBuilder<out T> : IConfigurationBuilderBase<T>

Type Parameters

T

The IRecoveryConfigurationBuilderT type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a IOddsFeedConfiguration instance (Inherited from IConfigurationBuilderBaseT)
Public method | LoadFromConfigFile | Sets the general configuration properties to values read from configuration file. Only value which can be set through IConfigurationBuilderBaseT methods are set. Any values already set by methods on the current instance are overridden (Inherited from IConfigurationBuilderBaseT)
Public method | SetAdjustAfterAge | Sets the value indicating whether the after age should be adjusted before executing recovery request
Public method | SetDefaultLanguage | Sets the default language in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Public method | SetDisabledProducers | Specifies the producers which should be disabled (i.e. no recovery, ...) (Inherited from IConfigurationBuilderBaseT)
Public method | SetExceptionHandlingStrategy | Sets the value specifying how exceptions thrown in the SDK are handled. (Inherited from IConfigurationBuilderBaseT)
Public method | SetHttpClientTimeout | Sets the timeout for HTTP responses for this instance of the sdk (Inherited from IConfigurationBuilderBaseT)
Public method | SetInactivitySeconds | Sets the max time window between two consecutive alive messages before the associated producer is marked as down
Public method | SetMaxRecoveryTime | Sets the maximum time in seconds in which recovery must be completed (minimum 600 seconds)
Public method | SetMinIntervalBetweenRecoveryRequests | Sets the minimal interval between recovery requests initiated by alive messages (between 20 and 180 seconds)
Public method | SetNodeId | Sets the node id used to separate between SDK instances associated with the same account (Inherited from IConfigurationBuilderBaseT)
Public method | SetRecoveryHttpClientTimeout | Sets the timeout for recovery HTTP responses for this instance of the sdk
Public method | SetSupportedLanguages | Sets the languages in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IRecoveryConfigurationBuilder<T> Methods

IRecoveryConfigurationBuilderT Methods

The IRecoveryConfigurationBuilderT type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a IOddsFeedConfiguration instance (Inherited from IConfigurationBuilderBaseT)
Public method | LoadFromConfigFile | Sets the general configuration properties to values read from configuration file. Only value which can be set through IConfigurationBuilderBaseT methods are set. Any values already set by methods on the current instance are overridden (Inherited from IConfigurationBuilderBaseT)
Public method | SetAdjustAfterAge | Sets the value indicating whether the after age should be adjusted before executing recovery request
Public method | SetDefaultLanguage | Sets the default language in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Public method | SetDisabledProducers | Specifies the producers which should be disabled (i.e. no recovery, ...) (Inherited from IConfigurationBuilderBaseT)
Public method | SetExceptionHandlingStrategy | Sets the value specifying how exceptions thrown in the SDK are handled. (Inherited from IConfigurationBuilderBaseT)
Public method | SetHttpClientTimeout | Sets the timeout for HTTP responses for this instance of the sdk (Inherited from IConfigurationBuilderBaseT)
Public method | SetInactivitySeconds | Sets the max time window between two consecutive alive messages before the associated producer is marked as down
Public method | SetMaxRecoveryTime | Sets the maximum time in seconds in which recovery must be completed (minimum 600 seconds)
Public method | SetMinIntervalBetweenRecoveryRequests | Sets the minimal interval between recovery requests initiated by alive messages (between 20 and 180 seconds)
Public method | SetNodeId | Sets the node id used to separate between SDK instances associated with the same account (Inherited from IConfigurationBuilderBaseT)
Public method | SetRecoveryHttpClientTimeout | Sets the timeout for recovery HTTP responses for this instance of the sdk
Public method | SetSupportedLanguages | Sets the languages in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Top
See Also

Reference

IRecoveryConfigurationBuilderT Interface
Sportradar.OddsFeed.SDK.API Namespace


IRecoveryConfigurationBuilder<T>.SetAdjustAfterAge Method

IRecoveryConfigurationBuilderTSetAdjustAfterAge Method

Sets the value indicating whether the after age should be adjusted before executing recovery request

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T SetAdjustAfterAge(
    bool adjustAfterAge
)

Parameters

adjustAfterAge Boolean
True if age should be adjusted; False otherwise

Return Value

T
The IRecoveryConfigurationBuilderT instance used to set additional values
See Also

Reference

IRecoveryConfigurationBuilderT Interface
Sportradar.OddsFeed.SDK.API Namespace


IRecoveryConfigurationBuilder<T>.SetInactivitySeconds Method

IRecoveryConfigurationBuilderTSetInactivitySeconds Method

Sets the max time window between two consecutive alive messages before the associated producer is marked as down

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T SetInactivitySeconds(
    int inactivitySeconds
)

Parameters

inactivitySeconds Int32
the max time window between two consecutive alive messages

Return Value

T
A IRecoveryConfigurationBuilderT derived instance used to set general configuration properties
See Also

Reference

IRecoveryConfigurationBuilderT Interface
Sportradar.OddsFeed.SDK.API Namespace


IRecoveryConfigurationBuilder<T>.SetMaxRecoveryTime Method

IRecoveryConfigurationBuilderTSetMaxRecoveryTime Method

Sets the maximum time in seconds in which recovery must be completed (minimum 600 seconds)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T SetMaxRecoveryTime(
    int maxRecoveryTimeInSeconds
)

Parameters

maxRecoveryTimeInSeconds Int32
Maximum recovery time in seconds

Return Value

T
A IRecoveryConfigurationBuilderT instance used to set general configuration properties
See Also

Reference

IRecoveryConfigurationBuilderT Interface
Sportradar.OddsFeed.SDK.API Namespace


IRecoveryConfigurationBuilder<T>.SetMinIntervalBetweenRecoveryRequests Method

IRecoveryConfigurationBuilderTSetMinIntervalBetweenRecoveryRequests Method

Sets the minimal interval between recovery requests initiated by alive messages (between 20 and 180 seconds)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T SetMinIntervalBetweenRecoveryRequests(
    int minIntervalBetweenRecoveryRequests
)

Parameters

minIntervalBetweenRecoveryRequests Int32
The minimal interval between recovery requests initiated by alive messages (seconds)

Return Value

T
A IRecoveryConfigurationBuilderT instance used to set general configuration properties
See Also

Reference

IRecoveryConfigurationBuilderT Interface
Sportradar.OddsFeed.SDK.API Namespace


IRecoveryConfigurationBuilder<T>.SetRecoveryHttpClientTimeout Method

IRecoveryConfigurationBuilderTSetRecoveryHttpClientTimeout Method

Sets the timeout for recovery HTTP responses for this instance of the sdk

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T SetRecoveryHttpClientTimeout(
    int recoveryHttpClientTimeout
)

Parameters

recoveryHttpClientTimeout Int32
The timeout for recovery HTTP responses

Return Value

T
A IConfigurationBuilderBaseT derived instance used to set general configuration properties
See Also

Reference

IRecoveryConfigurationBuilderT Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayConfigurationBuilder Interface

Defines a contract implemented by classes used to set replay configuration properties

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IReplayConfigurationBuilder : IConfigurationBuilderBase<IReplayConfigurationBuilder>

The IReplayConfigurationBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a IOddsFeedConfiguration instance (Inherited from IConfigurationBuilderBaseT)
Public method | LoadFromConfigFile | Sets the general configuration properties to values read from configuration file. Only value which can be set through IConfigurationBuilderBaseT methods are set. Any values already set by methods on the current instance are overridden (Inherited from IConfigurationBuilderBaseT)
Public method | SetDefaultLanguage | Sets the default language in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Public method | SetDisabledProducers | Specifies the producers which should be disabled (i.e. no recovery, ...) (Inherited from IConfigurationBuilderBaseT)
Public method | SetExceptionHandlingStrategy | Sets the value specifying how exceptions thrown in the SDK are handled. (Inherited from IConfigurationBuilderBaseT)
Public method | SetHttpClientTimeout | Sets the timeout for HTTP responses for this instance of the sdk (Inherited from IConfigurationBuilderBaseT)
Public method | SetNodeId | Sets the node id used to separate between SDK instances associated with the same account (Inherited from IConfigurationBuilderBaseT)
Public method | SetSupportedLanguages | Sets the languages in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IReplayConfigurationBuilder Methods

The IReplayConfigurationBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a IOddsFeedConfiguration instance (Inherited from IConfigurationBuilderBaseT)
Public method | LoadFromConfigFile | Sets the general configuration properties to values read from configuration file. Only value which can be set through IConfigurationBuilderBaseT methods are set. Any values already set by methods on the current instance are overridden (Inherited from IConfigurationBuilderBaseT)
Public method | SetDefaultLanguage | Sets the default language in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Public method | SetDisabledProducers | Specifies the producers which should be disabled (i.e. no recovery, ...) (Inherited from IConfigurationBuilderBaseT)
Public method | SetExceptionHandlingStrategy | Sets the value specifying how exceptions thrown in the SDK are handled. (Inherited from IConfigurationBuilderBaseT)
Public method | SetHttpClientTimeout | Sets the timeout for HTTP responses for this instance of the sdk (Inherited from IConfigurationBuilderBaseT)
Public method | SetNodeId | Sets the node id used to separate between SDK instances associated with the same account (Inherited from IConfigurationBuilderBaseT)
Public method | SetSupportedLanguages | Sets the languages in which translatable data is available (Inherited from IConfigurationBuilderBaseT)
Top
See Also

Reference

IReplayConfigurationBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayEvent Interface

Defines a contract implemented by classes representing replay events

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IReplayEvent

The IReplayEvent type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN specifying the event id
Public property | Position | Gets a Int32 specifying the position
Public property | StartTime | Gets a Int32 specifying the start time
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IReplayEvent Properties

The IReplayEvent type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN specifying the event id
Public property | Position | Gets a Int32 specifying the position
Public property | StartTime | Gets a Int32 specifying the start time
Top
See Also

Reference

IReplayEvent Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayEvent.Id Property

IReplayEventId Property

Gets a URN specifying the event id

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

IReplayEvent Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayEvent.Position Property

IReplayEventPosition Property

Gets a Int32 specifying the position

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Position { get; }

Property Value

Nullable Int32
See Also

Reference

IReplayEvent Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayEvent.StartTime Property

IReplayEventStartTime Property

Gets a Int32 specifying the start time

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? StartTime { get; }

Property Value

Nullable Int32
See Also

Reference

IReplayEvent Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManager Interface

Defines a contract implemented by classes capable of interacting with Replay Server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IReplayManager

The IReplayManager type exposes the following members.

Methods
 | Name | Description
Public method | AddMessagesToReplayQueue | Adds event {eventId} to the end of the replay queue
Public method | GetAvailableScenarios | Gets a list of available replay scenarios
Public method | GetEventsInQueue | Gets the events in replay queue.
Public method | GetStatusOfReplay | Return the status of player. Possible values are: player is playing, player is stopped, player was never playing.
Public method | RemoveEventFromReplayQueue | Removes the event from replay queue
Public method | StartReplay | Start replay the event from replay queue. Events are played in the order they were played in reality
Public method | StartReplayScenario | Starts playing a predefined scenario
Public method | StopAndClearReplay | Stop the player if it is currently playing and clear the replay queue. If player is already stopped, the queue is cleared.
Public method | StopReplay | Stop the player if it is currently playing. If player is already stopped, nothing will happen.
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IReplayManager Methods

The IReplayManager type exposes the following members.

Methods
 | Name | Description
Public method | AddMessagesToReplayQueue | Adds event {eventId} to the end of the replay queue
Public method | GetAvailableScenarios | Gets a list of available replay scenarios
Public method | GetEventsInQueue | Gets the events in replay queue.
Public method | GetStatusOfReplay | Return the status of player. Possible values are: player is playing, player is stopped, player was never playing.
Public method | RemoveEventFromReplayQueue | Removes the event from replay queue
Public method | StartReplay | Start replay the event from replay queue. Events are played in the order they were played in reality
Public method | StartReplayScenario | Starts playing a predefined scenario
Public method | StopAndClearReplay | Stop the player if it is currently playing and clear the replay queue. If player is already stopped, the queue is cleared.
Public method | StopReplay | Stop the player if it is currently playing. If player is already stopped, nothing will happen.
Top
See Also

Reference

IReplayManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManager.AddMessagesToReplayQueue Method

IReplayManagerAddMessagesToReplayQueue Method

Adds event {eventId} to the end of the replay queue

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReplayResponse AddMessagesToReplayQueue(
    URN eventId,
    int? startTime = null
)

Parameters

eventId URN
The URN of the IMatch
startTime Nullable Int32 (Optional)
The minutes relative to event start time

Return Value

IReplayResponse
Returns an IReplayResponse
See Also

Reference

IReplayManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManager.GetAvailableScenarios Method

IReplayManagerGetAvailableScenarios Method

Gets a list of available replay scenarios

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IReplayScenario> GetAvailableScenarios()

Return Value

IEnumerable IReplayScenario
A list of available replay scenarios
See Also

Reference

IReplayManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManager.GetEventsInQueue Method

IReplayManagerGetEventsInQueue Method

Gets the events in replay queue.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<URN> GetEventsInQueue()

Return Value

IEnumerable URN
Returns an array of event ids
See Also

Reference

IReplayManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManager.GetStatusOfReplay Method

IReplayManagerGetStatusOfReplay Method

Return the status of player. Possible values are: player is playing, player is stopped, player was never playing.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReplayStatus GetStatusOfReplay()

Return Value

IReplayStatus
Returns an IReplayResponse
See Also

Reference

IReplayManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManager.RemoveEventFromReplayQueue Method

IReplayManagerRemoveEventFromReplayQueue Method

Removes the event from replay queue

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReplayResponse RemoveEventFromReplayQueue(
    URN eventId
)

Parameters

eventId URN
The URN of the IMatch

Return Value

IReplayResponse
Returns an IReplayResponse
See Also

Reference

IReplayManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManager.StartReplay Method

IReplayManagerStartReplay Method

Start replay the event from replay queue. Events are played in the order they were played in reality

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReplayResponse StartReplay(
    int speed = 10,
    int maxDelay = 10000,
    int? producerId = null,
    bool? rewriteTimestamps = null
)

Parameters

speed Int32 (Optional)
The speed factor of the replay
maxDelay Int32 (Optional)
The maximum delay between messages in milliseconds
producerId Nullable Int32 (Optional)
The id of the producer from which we want to get messages, or null for messages from all producers
rewriteTimestamps Nullable Boolean (Optional)
Should the timestamp in messages be rewritten with current time

Return Value

IReplayResponse
Returns an IReplayResponse
Remarks
Start replay the event from replay queue. Events are played in the order they were played in reality, e.g. if there are some events that were played simultaneously in reality, they will be played in parallel as well here on replay server. If not specified, default values speed = 10 and max_delay = 10000 are used. This means that messages will be sent 10x faster than in reality, and that if there was some delay between messages that was longer than 10 seconds it will be reduced to exactly 10 seconds/10 000 ms (this is helpful especially in pre-match odds where delay can be even a few hours or more). If player is already in play, nothing will happen
See Also

Reference

IReplayManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManager.StartReplayScenario Method

IReplayManagerStartReplayScenario Method

Starts playing a predefined scenario

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReplayResponse StartReplayScenario(
    int scenarioId,
    int speed = 10,
    int maxDelay = 10000,
    int? producerId = null,
    bool? rewriteTimestamps = null
)

Parameters

scenarioId Int32
The identifier of the scenario that should be played
speed Int32 (Optional)
The speed factor of the replay
maxDelay Int32 (Optional)
The maximum delay between messages in milliseconds
producerId Nullable Int32 (Optional)
The id of the producer from which we want to get messages, or null for messages from all producers
rewriteTimestamps Nullable Boolean (Optional)
Should the timestamp in messages be rewritten with current time

Return Value

IReplayResponse
Returns an IReplayResponse
Remarks
Start replay the event from replay queue. Events are played in the order they were played in reality, e.g. if there are some events that were played simultaneously in reality, they will be played in parallel as well here on replay server. If not specified, default values speed = 10 and max_delay = 10000 are used. This means that messages will be sent 10x faster than in reality, and that if there was some delay between messages that was longer than 10 seconds it will be reduced to exactly 10 seconds/10 000 ms (this is helpful especially in pre-match odds where delay can be even a few hours or more). If player is already in play, nothing will happen
See Also

Reference

IReplayManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManager.StopAndClearReplay Method

IReplayManagerStopAndClearReplay Method

Stop the player if it is currently playing and clear the replay queue. If player is already stopped, the queue is cleared.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReplayResponse StopAndClearReplay()

Return Value

IReplayResponse
Returns an IReplayResponse
See Also

Reference

IReplayManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManager.StopReplay Method

IReplayManagerStopReplay Method

Stop the player if it is currently playing. If player is already stopped, nothing will happen.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReplayResponse StopReplay()

Return Value

IReplayResponse
Returns an IReplayResponse
See Also

Reference

IReplayManager Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManagerV1 Interface

Defines a contract implemented by classes capable of interacting with Replay Server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IReplayManagerV1 : IReplayManager

The IReplayManagerV1 type exposes the following members.

Methods
 | Name | Description
Public method | AddMessagesToReplayQueue | Adds event {eventId} to the end of the replay queue (Inherited from IReplayManager)
Public method | GetAvailableScenarios | Gets a list of available replay scenarios (Inherited from IReplayManager)
Public method | GetEventsInQueue | Gets the events in replay queue. (Inherited from IReplayManager)
Public method | GetStatusOfReplay | Return the status of player. Possible values are: player is playing, player is stopped, player was never playing. (Inherited from IReplayManager)
Public method | RemoveEventFromReplayQueue | Removes the event from replay queue (Inherited from IReplayManager)
Public method | StartReplay(Int32, Int32, NullableInt32, NullableBoolean) | Start replay the event from replay queue. Events are played in the order they were played in reality (Inherited from IReplayManager)
Public method | StartReplay(Int32, Int32, NullableInt32, NullableBoolean, NullableBoolean) | Start replay the event from replay queue. Events are played in the order they were played in reality
Public method | StartReplayScenario | Starts playing a predefined scenario (Inherited from IReplayManager)
Public method | StopAndClearReplay | Stop the player if it is currently playing and clear the replay queue. If player is already stopped, the queue is cleared. (Inherited from IReplayManager)
Public method | StopReplay | Stop the player if it is currently playing. If player is already stopped, nothing will happen. (Inherited from IReplayManager)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IReplayManagerV1 Methods

The IReplayManagerV1 type exposes the following members.

Methods
 | Name | Description
Public method | AddMessagesToReplayQueue | Adds event {eventId} to the end of the replay queue (Inherited from IReplayManager)
Public method | GetAvailableScenarios | Gets a list of available replay scenarios (Inherited from IReplayManager)
Public method | GetEventsInQueue | Gets the events in replay queue. (Inherited from IReplayManager)
Public method | GetStatusOfReplay | Return the status of player. Possible values are: player is playing, player is stopped, player was never playing. (Inherited from IReplayManager)
Public method | RemoveEventFromReplayQueue | Removes the event from replay queue (Inherited from IReplayManager)
Public method | StartReplay(Int32, Int32, NullableInt32, NullableBoolean) | Start replay the event from replay queue. Events are played in the order they were played in reality (Inherited from IReplayManager)
Public method | StartReplay(Int32, Int32, NullableInt32, NullableBoolean, NullableBoolean) | Start replay the event from replay queue. Events are played in the order they were played in reality
Public method | StartReplayScenario | Starts playing a predefined scenario (Inherited from IReplayManager)
Public method | StopAndClearReplay | Stop the player if it is currently playing and clear the replay queue. If player is already stopped, the queue is cleared. (Inherited from IReplayManager)
Public method | StopReplay | Stop the player if it is currently playing. If player is already stopped, nothing will happen. (Inherited from IReplayManager)
Top
See Also

Reference

IReplayManagerV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManagerV1.StartReplay Method

IReplayManagerV1StartReplay Method

Overload List
 | Name | Description
Public method | StartReplay(Int32, Int32, NullableInt32, NullableBoolean) | Start replay the event from replay queue. Events are played in the order they were played in reality
Public method | StartReplay(Int32, Int32, NullableInt32, NullableBoolean, NullableBoolean) | Start replay the event from replay queue. Events are played in the order they were played in reality
Top
See Also

Reference

IReplayManagerV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManagerV1.StartReplay(Int32, Int32, Nullable<Int32>, Nullable<Boolean>, Nullable<Boolean>) Method

IReplayManagerV1StartReplay(Int32, Int32, NullableInt32, NullableBoolean, NullableBoolean) Method

Start replay the event from replay queue. Events are played in the order they were played in reality

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReplayResponse StartReplay(
    int speed,
    int maxDelay,
    int? producerId,
    bool? rewriteTimestamps,
    bool? runParallel
)

Parameters

speed Int32
The speed factor of the replay
maxDelay Int32
The maximum delay between messages in milliseconds
producerId Nullable Int32
The id of the producer from which we want to get messages, or null for messages from all producers
rewriteTimestamps Nullable Boolean
Should the timestamp in messages be rewritten with current time
runParallel Nullable Boolean
Should the events in queue replay independently

Return Value

IReplayResponse
Returns an IReplayResponse
Remarks
Start replay the event from replay queue. Events are played in the order they were played in reality, e.g. if there are some events that were played simultaneously in reality, they will be played in parallel as well here on replay server. If not specified, default values speed = 10 and max_delay = 10000 are used. This means that messages will be sent 10x faster than in reality, and that if there was some delay between messages that was longer than 10 seconds it will be reduced to exactly 10 seconds/10 000 ms (this is helpful especially in pre-match odds where delay can be even a few hours or more). If player is already in play, nothing will happen
See Also

Reference

IReplayManagerV1 Interface
StartReplay Overload
Sportradar.OddsFeed.SDK.API Namespace


IReplayManagerV2 Interface

Defines a contract implemented by classes capable of interacting with Replay Server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IReplayManagerV2 : IReplayManagerV1,
    IReplayManager

The IReplayManagerV2 type exposes the following members.

Methods
 | Name | Description
Public method | AddMessagesToReplayQueue | Adds event {eventId} to the end of the replay queue (Inherited from IReplayManager)
Public method | GetAvailableScenarios | Gets a list of available replay scenarios (Inherited from IReplayManager)
Public method | GetEventsInQueue | Gets the events in replay queue. (Inherited from IReplayManager)
Public method | GetReplayEventsInQueue | Gets list of replay events in queue.
Public method | GetStatusOfReplay | Return the status of player. Possible values are: player is playing, player is stopped, player was never playing. (Inherited from IReplayManager)
Public method | RemoveEventFromReplayQueue | Removes the event from replay queue (Inherited from IReplayManager)
Public method | StartReplay(Int32, Int32, NullableInt32, NullableBoolean) | Start replay the event from replay queue. Events are played in the order they were played in reality (Inherited from IReplayManager)
Public method | StartReplay(Int32, Int32, NullableInt32, NullableBoolean, NullableBoolean) | Start replay the event from replay queue. Events are played in the order they were played in reality (Inherited from IReplayManagerV1)
Public method | StartReplayScenario | Starts playing a predefined scenario (Inherited from IReplayManager)
Public method | StopAndClearReplay | Stop the player if it is currently playing and clear the replay queue. If player is already stopped, the queue is cleared. (Inherited from IReplayManager)
Public method | StopReplay | Stop the player if it is currently playing. If player is already stopped, nothing will happen. (Inherited from IReplayManager)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IReplayManagerV2 Methods

The IReplayManagerV2 type exposes the following members.

Methods
 | Name | Description
Public method | AddMessagesToReplayQueue | Adds event {eventId} to the end of the replay queue (Inherited from IReplayManager)
Public method | GetAvailableScenarios | Gets a list of available replay scenarios (Inherited from IReplayManager)
Public method | GetEventsInQueue | Gets the events in replay queue. (Inherited from IReplayManager)
Public method | GetReplayEventsInQueue | Gets list of replay events in queue.
Public method | GetStatusOfReplay | Return the status of player. Possible values are: player is playing, player is stopped, player was never playing. (Inherited from IReplayManager)
Public method | RemoveEventFromReplayQueue | Removes the event from replay queue (Inherited from IReplayManager)
Public method | StartReplay(Int32, Int32, NullableInt32, NullableBoolean) | Start replay the event from replay queue. Events are played in the order they were played in reality (Inherited from IReplayManager)
Public method | StartReplay(Int32, Int32, NullableInt32, NullableBoolean, NullableBoolean) | Start replay the event from replay queue. Events are played in the order they were played in reality (Inherited from IReplayManagerV1)
Public method | StartReplayScenario | Starts playing a predefined scenario (Inherited from IReplayManager)
Public method | StopAndClearReplay | Stop the player if it is currently playing and clear the replay queue. If player is already stopped, the queue is cleared. (Inherited from IReplayManager)
Public method | StopReplay | Stop the player if it is currently playing. If player is already stopped, nothing will happen. (Inherited from IReplayManager)
Top
See Also

Reference

IReplayManagerV2 Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayManagerV2.GetReplayEventsInQueue Method

IReplayManagerV2GetReplayEventsInQueue Method

Gets list of replay events in queue.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IReplayEvent> GetReplayEventsInQueue()

Return Value

IEnumerable IReplayEvent
Returns a list of replay events
See Also

Reference

IReplayManagerV2 Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayResponse Interface

Defines a contract for responses from Replay Server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IReplayResponse

The IReplayResponse type exposes the following members.

Properties
 | Name | Description
Public property | ErrorMessage | Gets the error message, if error occurred, otherwise empty
Public property | Message | Gets the message of the response
Public property | Success | Gets a value indicating whether this IReplayResponse is success.
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IReplayResponse Properties

The IReplayResponse type exposes the following members.

Properties
 | Name | Description
Public property | ErrorMessage | Gets the error message, if error occurred, otherwise empty
Public property | Message | Gets the message of the response
Public property | Success | Gets a value indicating whether this IReplayResponse is success.
Top
See Also

Reference

IReplayResponse Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayResponse.ErrorMessage Property

IReplayResponseErrorMessage Property

Gets the error message, if error occurred, otherwise empty

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string ErrorMessage { get; }

Property Value

String
See Also

Reference

IReplayResponse Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayResponse.Message Property

IReplayResponseMessage Property

Gets the message of the response

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Message { get; }

Property Value

String
See Also

Reference

IReplayResponse Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayResponse.Success Property

IReplayResponseSuccess Property

Gets a value indicating whether this IReplayResponse is success.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool Success { get; }

Property Value

Boolean
See Also

Reference

IReplayResponse Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayScenario Interface

Defines a contract for replay scenario instances

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IReplayScenario

The IReplayScenario type exposes the following members.

Properties
 | Name | Description
Public property | AssociatedEventIds | Gets the associated event identifiers
Public property | Description | Gets the description of the scenario
Public property | Id | Gets the id of the scenario
Public property | RunParallel | Gets an indication if the scenario can be run in parallel
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IReplayScenario Properties

The IReplayScenario type exposes the following members.

Properties
 | Name | Description
Public property | AssociatedEventIds | Gets the associated event identifiers
Public property | Description | Gets the description of the scenario
Public property | Id | Gets the id of the scenario
Public property | RunParallel | Gets an indication if the scenario can be run in parallel
Top
See Also

Reference

IReplayScenario Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayScenario.AssociatedEventIds Property

IReplayScenarioAssociatedEventIds Property

Gets the associated event identifiers

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<URN> AssociatedEventIds { get; }

Property Value

IEnumerable URN
See Also

Reference

IReplayScenario Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayScenario.Description Property

IReplayScenarioDescription Property

Gets the description of the scenario

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Description { get; }

Property Value

String
See Also

Reference

IReplayScenario Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayScenario.Id Property

IReplayScenarioId Property

Gets the id of the scenario

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Id { get; }

Property Value

Int32
See Also

Reference

IReplayScenario Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayScenario.RunParallel Property

IReplayScenarioRunParallel Property

Gets an indication if the scenario can be run in parallel

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool RunParallel { get; }

Property Value

Boolean
See Also

Reference

IReplayScenario Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayStatus Interface

Defines a contract for status of replay player

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IReplayStatus

The IReplayStatus type exposes the following members.

Properties
 | Name | Description
Public property | LastMessageFromEvent | Gets the URN of the event in last message
Public property | PlayerStatus | Gets the player status. Possible values are: player is playing, player is stopped, player was never playing.
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


IReplayStatus Properties

The IReplayStatus type exposes the following members.

Properties
 | Name | Description
Public property | LastMessageFromEvent | Gets the URN of the event in last message
Public property | PlayerStatus | Gets the player status. Possible values are: player is playing, player is stopped, player was never playing.
Top
See Also

Reference

IReplayStatus Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayStatus.LastMessageFromEvent Property

IReplayStatusLastMessageFromEvent Property

Gets the URN of the event in last message

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN LastMessageFromEvent { get; }

Property Value

URN
The last message from event.
See Also

Reference

IReplayStatus Interface
Sportradar.OddsFeed.SDK.API Namespace


IReplayStatus.PlayerStatus Property

IReplayStatusPlayerStatus Property

Gets the player status. Possible values are: player is playing, player is stopped, player was never playing.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ReplayPlayerStatus PlayerStatus { get; }

Property Value

ReplayPlayerStatus
See Also

Reference

IReplayStatus Interface
Sportradar.OddsFeed.SDK.API Namespace


ISessionBuilder Interface

Represents a second step when building a IOddsFeedSession instance

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISessionBuilder

The ISessionBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a IOddsFeedSession instance
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISessionBuilder Methods

The ISessionBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Build | Builds and returns a IOddsFeedSession instance
Top
See Also

Reference

ISessionBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ISessionBuilder.Build Method

ISessionBuilderBuild Method

Builds and returns a IOddsFeedSession instance

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedSession Build()

Return Value

IOddsFeedSession
the built IOddsFeedSession instance
See Also

Reference

ISessionBuilder Interface
Sportradar.OddsFeed.SDK.API Namespace


ISpecificEntityDispatcher<T> Interface

ISpecificEntityDispatcherT Interface

Defines a contract implemented by classes capable of dispatching only specific entities

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISpecificEntityDispatcher<T> : IOpenable,
    IEntityDispatcher<T>
where T : ISportEvent

Type Parameters

T
Specifies the type of the entities that can be dispatched

The ISpecificEntityDispatcherT type exposes the following members.

Properties
 | Name | Description
Public property | IsOpened | Gets a value indicating whether the current instance is opened (Inherited from IOpenable)
Top
Methods
 | Name | Description
Public method | Close | Closes the current instance (Inherited from IOpenable)
Public method | Open | Opens the current instance (Inherited from IOpenable)
Top
Events
 | Name | Description
Public event | OnBetCancel | Raised when a bet cancel message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnBetSettlement | Raised when a bet settlement message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnBetStop | Raised when a bet stop message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnFixtureChange | Raised when a fixture change message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnOddsChange | Raised when a odds change message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnRollbackBetCancel | Raised when a rollback bet cancel message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnRollbackBetSettlement | Raised when a rollback bet settlement is received from the feed (Inherited from IEntityDispatcherT)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace
IOpenable
IEntityDispatcherT


ISpecificEntityDispatcher<T> Properties

ISpecificEntityDispatcherT Properties

The ISpecificEntityDispatcherT type exposes the following members.

Properties
 | Name | Description
Public property | IsOpened | Gets a value indicating whether the current instance is opened (Inherited from IOpenable)
Top
See Also

Reference

ISpecificEntityDispatcherT Interface
Sportradar.OddsFeed.SDK.API Namespace


ISpecificEntityDispatcher<T> Methods

ISpecificEntityDispatcherT Methods

The ISpecificEntityDispatcherT type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current instance (Inherited from IOpenable)
Public method | Open | Opens the current instance (Inherited from IOpenable)
Top
See Also

Reference

ISpecificEntityDispatcherT Interface
Sportradar.OddsFeed.SDK.API Namespace


ISpecificEntityDispatcher<T> Events

ISpecificEntityDispatcherT Events

The ISpecificEntityDispatcherT type exposes the following members.

Events
 | Name | Description
Public event | OnBetCancel | Raised when a bet cancel message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnBetSettlement | Raised when a bet settlement message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnBetStop | Raised when a bet stop message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnFixtureChange | Raised when a fixture change message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnOddsChange | Raised when a odds change message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnRollbackBetCancel | Raised when a rollback bet cancel message is received from the feed (Inherited from IEntityDispatcherT)
Public event | OnRollbackBetSettlement | Raised when a rollback bet settlement is received from the feed (Inherited from IEntityDispatcherT)
Top
See Also

Reference

ISpecificEntityDispatcherT Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider Interface

Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportDataProvider

The ISportDataProvider type exposes the following members.

Methods
Name | Description
Public method | DeleteCompetitorFromCache | Delete the competitor from cache
Public method | DeletePlayerProfileFromCache | Delete the player profile from cache
Public method | DeleteSportEventFromCache | Delete the sport event from cache
Public method | DeleteTournamentFromCache | Delete the tournament from cache
Public method GetCompetition Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
Public method | GetCompetitorAsync | Asynchronously gets a ICompetitor
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture
Public method | GetPlayerProfileAsync | Asynchronously gets a IPlayerProfile
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture
Public method | GetSportEventStatusAsync | Asynchronously gets a ICompetitionStatus for specific sport event
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider Methods

The ISportDataProvider type exposes the following members.

Methods
Name | Description
Public method | DeleteCompetitorFromCache | Delete the competitor from cache
Public method | DeletePlayerProfileFromCache | Delete the player profile from cache
Public method | DeleteSportEventFromCache | Delete the sport event from cache
Public method | DeleteTournamentFromCache | Delete the tournament from cache
Public method GetCompetition Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
Public method | GetCompetitorAsync | Asynchronously gets a ICompetitor
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture
Public method | GetPlayerProfileAsync | Asynchronously gets a IPlayerProfile
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture
Public method | GetSportEventStatusAsync | Asynchronously gets a ICompetitionStatus for specific sport event
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
Top
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.DeleteCompetitorFromCache Method

ISportDataProviderDeleteCompetitorFromCache Method

Delete the competitor from cache

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void DeleteCompetitorFromCache(
    URN id
)

Parameters

id URN
A URN specifying the id of ICompetitor to be deleted
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.DeletePlayerProfileFromCache Method

ISportDataProviderDeletePlayerProfileFromCache Method

Delete the player profile from cache

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void DeletePlayerProfileFromCache(
    URN id
)

Parameters

id URN
A URN specifying the id of IPlayerProfile to be deleted
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.DeleteSportEventFromCache Method

ISportDataProviderDeleteSportEventFromCache Method

Delete the sport event from cache

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void DeleteSportEventFromCache(
    URN id,
    bool includeEventStatusDeletion = false
)

Parameters

id URN
A URN specifying the id of ISportEvent to be deleted
includeEventStatusDeletion Boolean (Optional)
Delete also ISportEventStatus from the cache
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.DeleteTournamentFromCache Method

ISportDataProviderDeleteTournamentFromCache Method

Delete the tournament from cache

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void DeleteTournamentFromCache(
    URN id
)

Parameters

id URN
A URN specifying the id of ILongTermEvent to be deleted
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.GetCompetition Method

ISportDataProviderGetCompetition Method

Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICompetition GetCompetition(
    URN id,
    URN sportId,
    CultureInfo culture = null
)

Parameters

id URN
A URN specifying the sport event to retrieve
sportId URN
A URN of the sport this event belongs to
culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

ICompetition
A ICompetition representing the specified sport event or a null reference if the requested sport event does not exist
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.GetCompetitorAsync Method

ISportDataProviderGetCompetitorAsync Method

Asynchronously gets a ICompetitor

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICompetitor> GetCompetitorAsync(
    URN id,
    CultureInfo culture = null
)

Parameters

id URN
A URN specifying the id for which ICompetitor to be retrieved
culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task ICompetitor
A ICompetitor representing the specified competitor or a null reference
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.GetLiveSportEventsAsync Method

ISportDataProviderGetLiveSportEventsAsync Method

Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ICompetition>> GetLiveSportEventsAsync(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task IEnumerable ICompetition
A TaskTResult representing the async operation
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.GetPlayerProfileAsync Method

ISportDataProviderGetPlayerProfileAsync Method

Asynchronously gets a IPlayerProfile

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IPlayerProfile> GetPlayerProfileAsync(
    URN id,
    CultureInfo culture = null
)

Parameters

id URN
A URN specifying the id for which IPlayerProfile to be retrieved
culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task IPlayerProfile
A IPlayerProfile representing the specified player or a null reference
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.GetSportAsync Method

ISportDataProviderGetSportAsync Method

Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ISport> GetSportAsync(
    URN id,
    CultureInfo culture = null
)

Parameters

id URN
A URN identifying the sport to retrieve.
culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task ISport
A TaskTResult representing the async operation
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.GetSportEventsByDateAsync Method

ISportDataProviderGetSportEventsByDateAsync Method

Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ICompetition>> GetSportEventsByDateAsync(
    DateTime date,
    CultureInfo culture = null
)

Parameters

date DateTime
A DateTime specifying the day for which to retrieve the schedule
culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task IEnumerable ICompetition
A TaskTResult representing the async operation
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.GetSportEventStatusAsync Method

ISportDataProviderGetSportEventStatusAsync Method

Asynchronously gets a ICompetitionStatus for specific sport event

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICompetitionStatus> GetSportEventStatusAsync(
    URN id
)

Parameters

id URN
A URN specifying the event for which ICompetitionStatus to be retrieved

Return Value

Task ICompetitionStatus
A TaskTResult representing the async operation
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.GetSportsAsync Method

ISportDataProviderGetSportsAsync Method

Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ISport>> GetSportsAsync(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task IEnumerable ISport
A TaskTResult representing the async operation
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProvider.GetTournament Method

ISportDataProviderGetTournament Method

Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ILongTermEvent GetTournament(
    URN id,
    CultureInfo culture = null
)

Parameters

id URN
A URN specifying the tournament to retrieve
culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

ILongTermEvent
A ILongTermEvent representing the specified tournament or a null reference if requested tournament does not exist
See Also

Reference

ISportDataProvider Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV1 Interface

Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportDataProviderV1 : ISportDataProvider

The ISportDataProviderV1 type exposes the following members.

Methods
Name | Description
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method | GetFixtureChangesAsync | Gets the list of all fixtures that have changed in the last 24 hours
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV1 Methods

The ISportDataProviderV1 type exposes the following members.

Methods
Name | Description
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method | GetFixtureChangesAsync | Gets the list of all fixtures that have changed in the last 24 hours
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

ISportDataProviderV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV1.GetCompetition Method

ISportDataProviderV1GetCompetition Method

Overload List
Name Description
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
Top
See Also

Reference

ISportDataProviderV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV1.GetCompetition(URN, CultureInfo) Method

ISportDataProviderV1GetCompetition(URN, CultureInfo) Method

Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICompetition GetCompetition(
    URN id,
    CultureInfo culture = null
)

Parameters

id URN
A URN specifying the sport event to retrieve
culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

ICompetition
A ICompetition representing the specified sport event or a null reference if the requested sport event does not exist
See Also

Reference

ISportDataProviderV1 Interface
GetCompetition Overload
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV1.GetFixtureChangesAsync Method

ISportDataProviderV1GetFixtureChangesAsync Method

Gets the list of all fixtures that have changed in the last 24 hours

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IFixtureChange>> GetFixtureChangesAsync(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task IEnumerable IFixtureChange
A list of all fixtures that have changed in the last 24 hours
See Also

Reference

ISportDataProviderV1 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV10 Interface

Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportDataProviderV10 : ISportDataProviderV9,
    ISportDataProviderV8, ISportDataProviderV7, ISportDataProviderV6, ISportDataProviderV5, ISportDataProviderV4,
    ISportDataProviderV3, ISportDataProviderV2, ISportDataProviderV1, ISportDataProvider

The ISportDataProviderV10 type exposes the following members.

Methods
Name | Description
Public method CacheExportAsync Exports current items in the cache
(Inherited from ISportDataProviderV5)
Public method CacheImportAsync Imports provided items into caches
(Inherited from ISportDataProviderV5)
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync(CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetFixtureChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetLotteriesAsync Gets the list of available lotteries
(Inherited from ISportDataProviderV9)
Public method | GetPeriodStatusesAsync | Get sport event period summary as an asynchronous operation
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetResultChangesAsync(CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV6)
Public method GetResultChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEvent Gets a ISportEvent derived class representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV8)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV10 Methods

The ISportDataProviderV10 type exposes the following members.

Methods
Name | Description
Public method CacheExportAsync Exports current items in the cache
(Inherited from ISportDataProviderV5)
Public method CacheImportAsync Imports provided items into caches
(Inherited from ISportDataProviderV5)
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync(CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetFixtureChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetLotteriesAsync Gets the list of available lotteries
(Inherited from ISportDataProviderV9)
Public method | GetPeriodStatusesAsync | Get sport event period summary as an asynchronous operation
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetResultChangesAsync(CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV6)
Public method GetResultChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEvent Gets a ISportEvent derived class representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV8)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

ISportDataProviderV10 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV10.GetPeriodStatusesAsync Method

ISportDataProviderV10GetPeriodStatusesAsync Method

Get sport event period summary as an asynchronous operation

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IPeriodStatus>> GetPeriodStatusesAsync(
    URN id,
    CultureInfo culture = null,
    IEnumerable<URN> competitorIds = null,
    IEnumerable<int> periods = null
)

Parameters

id URN
The id of the sport event to be fetched
culture CultureInfo (Optional)
The language to be fetched
competitorIds IEnumerable URN (Optional)
The list of competitor ids to fetch the results for
periods IEnumerable Int32 (Optional)
The list of period ids to fetch the results for

Return Value

Task IEnumerable IPeriodStatus
The period statuses or empty if not found
See Also

Reference

ISportDataProviderV10 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV11 Interface

Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportDataProviderV11 : ISportDataProviderV10,
    ISportDataProviderV9, ISportDataProviderV8, ISportDataProviderV7, ISportDataProviderV6, ISportDataProviderV5,
    ISportDataProviderV4, ISportDataProviderV3, ISportDataProviderV2, ISportDataProviderV1, ISportDataProvider

The ISportDataProviderV11 type exposes the following members.

Methods
Name | Description
Public method CacheExportAsync Exports current items in the cache
(Inherited from ISportDataProviderV5)
Public method CacheImportAsync Imports provided items into caches
(Inherited from ISportDataProviderV5)
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync(CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetFixtureChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetLotteriesAsync Gets the list of available lotteries
(Inherited from ISportDataProviderV9)
Public method GetPeriodStatusesAsync Get sport event period summary as an asynchronous operation
(Inherited from ISportDataProviderV10)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetResultChangesAsync(CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV6)
Public method GetResultChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEvent Gets a ISportEvent derived class representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV8)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method | GetTimelineEventsAsync | Get the associated event timeline for single culture
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV11 Methods

The ISportDataProviderV11 type exposes the following members.

Methods
Name | Description
Public method CacheExportAsync Exports current items in the cache
(Inherited from ISportDataProviderV5)
Public method CacheImportAsync Imports provided items into caches
(Inherited from ISportDataProviderV5)
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync(CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetFixtureChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetLotteriesAsync Gets the list of available lotteries
(Inherited from ISportDataProviderV9)
Public method GetPeriodStatusesAsync Get sport event period summary as an asynchronous operation
(Inherited from ISportDataProviderV10)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetResultChangesAsync(CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV6)
Public method GetResultChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEvent Gets a ISportEvent derived class representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV8)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method | GetTimelineEventsAsync | Get the associated event timeline for single culture
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

ISportDataProviderV11 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV11.GetTimelineEventsAsync Method

ISportDataProviderV11GetTimelineEventsAsync Method

Get the associated event timeline for single culture

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ITimelineEvent>> GetTimelineEventsAsync(
    URN id,
    CultureInfo culture = null
)

Parameters

id URN
The id of the sport event to be fetched
culture CultureInfo (Optional)
The language to be fetched

Return Value

Task IEnumerable ITimelineEvent
The event timeline or empty if not found
See Also

Reference

ISportDataProviderV11 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV2 Interface

Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportDataProviderV2 : ISportDataProviderV1,
    ISportDataProvider

The ISportDataProviderV2 type exposes the following members.

Methods
Name | Description
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method | GetListOfSportEventsAsync | Asynchronously gets a list of IEnumerableT
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV2 Methods

The ISportDataProviderV2 type exposes the following members.

Methods
Name | Description
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method | GetListOfSportEventsAsync | Asynchronously gets a list of IEnumerableT
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

ISportDataProviderV2 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV2.GetListOfSportEventsAsync Method

ISportDataProviderV2GetListOfSportEventsAsync Method

Asynchronously gets a list of IEnumerableT

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ICompetition>> GetListOfSportEventsAsync(
    int startIndex,
    int limit,
    CultureInfo culture = null
)

Parameters

startIndex Int32
Starting record (this is an index, not time)
limit Int32
How many records to return (max: 1000)
culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task IEnumerable ICompetition
A TaskTResult representing the async operation
Remarks
Lists almost all events we are offering prematch odds for. This endpoint can be used during early startup to obtain almost all fixtures. This endpoint is one of the few that uses pagination.
See Also

Reference

ISportDataProviderV2 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV3 Interface

Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportDataProviderV3 : ISportDataProviderV2,
    ISportDataProviderV1, ISportDataProvider

The ISportDataProviderV3 type exposes the following members.

Methods
Name | Description
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method | GetActiveTournamentsAsync | Asynchronously gets a list of active IEnumerableT
Public method | GetAvailableTournamentsAsync | Asynchronously gets a list of available IEnumerableT for a specific sport
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV3 Methods

The ISportDataProviderV3 type exposes the following members.

Methods
Name | Description
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method | GetActiveTournamentsAsync | Asynchronously gets a list of active IEnumerableT
Public method | GetAvailableTournamentsAsync | Asynchronously gets a list of available IEnumerableT for a specific sport
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

ISportDataProviderV3 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV3.GetActiveTournamentsAsync Method

ISportDataProviderV3GetActiveTournamentsAsync Method

Asynchronously gets a list of active IEnumerableT

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ISportEvent>> GetActiveTournamentsAsync(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task IEnumerable ISportEvent
A TaskTResult representing the async operation
Remarks
Lists all ISportEvent that are cached (once schedule is loaded)
See Also

Reference

ISportDataProviderV3 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV3.GetAvailableTournamentsAsync Method

ISportDataProviderV3GetAvailableTournamentsAsync Method

Asynchronously gets a list of available IEnumerableT for a specific sport

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ISportEvent>> GetAvailableTournamentsAsync(
    URN sportId,
    CultureInfo culture = null
)

Parameters

sportId URN
A URN specifying the sport to retrieve
culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task IEnumerable ISportEvent
A TaskTResult representing the async operation
Remarks
Lists all available tournaments for a sport event we provide coverage for
See Also

Reference

ISportDataProviderV3 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV4 Interface

Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportDataProviderV4 : ISportDataProviderV3,
    ISportDataProviderV2, ISportDataProviderV1, ISportDataProvider

The ISportDataProviderV4 type exposes the following members.

Methods
Name | Description
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method | DeleteSportEventsFromCache | Deletes the sport events from cache which are scheduled before specified date
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV4 Methods

The ISportDataProviderV4 type exposes the following members.

Methods
Name | Description
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method | DeleteSportEventsFromCache | Deletes the sport events from cache which are scheduled before specified date
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

ISportDataProviderV4 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV4.DeleteSportEventsFromCache Method

ISportDataProviderV4DeleteSportEventsFromCache Method

Deletes the sport events from cache which are scheduled before specified date

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int DeleteSportEventsFromCache(
    DateTime before
)

Parameters

before DateTime
The scheduled DateTime used to delete sport events from cache

Return Value

Int32
Number of deleted items
See Also

Reference

ISportDataProviderV4 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV5 Interface

Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportDataProviderV5 : ISportDataProviderV4,
    ISportDataProviderV3, ISportDataProviderV2, ISportDataProviderV1, ISportDataProvider

The ISportDataProviderV5 type exposes the following members.

Methods
Name | Description
Public method | CacheExportAsync | Exports current items in the cache
Public method | CacheImportAsync | Imports provided items into caches
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV5 Methods

The ISportDataProviderV5 type exposes the following members.

Methods
Name | Description
Public method | CacheExportAsync | Exports current items in the cache
Public method | CacheImportAsync | Imports provided items into caches
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

ISportDataProviderV5 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV5.CacheExportAsync Method

ISportDataProviderV5CacheExportAsync Method

Exports current items in the cache

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ExportableCI>> CacheExportAsync(
    CacheType cacheType
)

Parameters

cacheType CacheType
Specifies what type of cache items will be exported

Return Value

Task IEnumerable ExportableCI
Collection of ExportableCI containing all the items currently in the cache
See Also

Reference

ISportDataProviderV5 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV5.CacheImportAsync Method

ISportDataProviderV5CacheImportAsync Method

Imports provided items into caches

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task CacheImportAsync(
    IEnumerable<ExportableCI> items
)

Parameters

items IEnumerable ExportableCI
Collection of ExportableCI containing the items to be imported

Return Value

Task

[Missing <returns> documentation for "M:Sportradar.OddsFeed.SDK.API.ISportDataProviderV5.CacheImportAsync(System.Collections.Generic.IEnumerable{Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable.ExportableCI})"]

See Also

Reference

ISportDataProviderV5 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV6 Interface

Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportDataProviderV6 : ISportDataProviderV5,
    ISportDataProviderV4, ISportDataProviderV3, ISportDataProviderV2, ISportDataProviderV1, ISportDataProvider

The ISportDataProviderV6 type exposes the following members.

Methods
Name | Description
Public method CacheExportAsync Exports current items in the cache
(Inherited from ISportDataProviderV5)
Public method CacheImportAsync Imports provided items into caches
(Inherited from ISportDataProviderV5)
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method | GetResultChangesAsync | Gets the list of all results that have changed in the last 24 hours
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV6 Methods

The ISportDataProviderV6 type exposes the following members.

Methods
Name | Description
Public method CacheExportAsync Exports current items in the cache
(Inherited from ISportDataProviderV5)
Public method CacheImportAsync Imports provided items into caches
(Inherited from ISportDataProviderV5)
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method | GetResultChangesAsync | Gets the list of all results that have changed in the last 24 hours
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

ISportDataProviderV6 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV6.GetResultChangesAsync Method

ISportDataProviderV6GetResultChangesAsync Method

Gets the list of all results that have changed in the last 24 hours

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IResultChange>> GetResultChangesAsync(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task IEnumerable IResultChange
A list of all results that have changed in the last 24 hours
See Also

Reference

ISportDataProviderV6 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV7 Interface

Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportDataProviderV7 : ISportDataProviderV6,
    ISportDataProviderV5, ISportDataProviderV4, ISportDataProviderV3, ISportDataProviderV2, ISportDataProviderV1,
    ISportDataProvider

The ISportDataProviderV7 type exposes the following members.

Methods
Name | Description
Public method CacheExportAsync Exports current items in the cache
(Inherited from ISportDataProviderV5)
Public method CacheImportAsync Imports provided items into caches
(Inherited from ISportDataProviderV5)
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync(CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method | GetFixtureChangesAsync(NullableDateTime, URN, CultureInfo) | Gets the list of all fixtures that have changed in the last 24 hours
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetResultChangesAsync(CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV6)
Public method | GetResultChangesAsync(NullableDateTime, URN, CultureInfo) | Gets the list of all results that have changed in the last 24 hours
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV7 Methods

The ISportDataProviderV7 type exposes the following members.

Methods
Name | Description
Public method CacheExportAsync Exports current items in the cache
(Inherited from ISportDataProviderV5)
Public method CacheImportAsync Imports provided items into caches
(Inherited from ISportDataProviderV5)
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync(CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method | GetFixtureChangesAsync(NullableDateTime, URN, CultureInfo) | Gets the list of all fixtures that have changed in the last 24 hours
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetResultChangesAsync(CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV6)
Public method | GetResultChangesAsync(NullableDateTime, URN, CultureInfo) | Gets the list of all results that have changed in the last 24 hours
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

ISportDataProviderV7 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV7.GetFixtureChangesAsync Method

ISportDataProviderV7GetFixtureChangesAsync Method

Overload List
 | Name | Description
Public method | GetFixtureChangesAsync(CultureInfo) | Gets the list of all fixtures that have changed in the last 24 hours
Public method | GetFixtureChangesAsync(NullableDateTime, URN, CultureInfo) | Gets the list of all fixtures that have changed in the last 24 hours
Top
See Also

Reference

ISportDataProviderV7 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV7.GetFixtureChangesAsync(Nullable<DateTime>, URN, CultureInfo) Method

ISportDataProviderV7GetFixtureChangesAsync(NullableDateTime, URN, CultureInfo) Method

Gets the list of all fixtures that have changed in the last 24 hours

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IFixtureChange>> GetFixtureChangesAsync(
    DateTime? after,
    URN sportId,
    CultureInfo culture = null
)

Parameters

after Nullable DateTime
A DateTime specifying the starting date and time for filtering
sportId URN
A URN specifying the sport for which the fixtures should be returned
culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task IEnumerable IFixtureChange
A list of all fixtures that have changed in the last 24 hours
See Also

Reference

ISportDataProviderV7 Interface
GetFixtureChangesAsync Overload
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV7.GetResultChangesAsync Method

ISportDataProviderV7GetResultChangesAsync Method

Overload List
 | Name | Description
Public method | GetResultChangesAsync(CultureInfo) | Gets the list of all results that have changed in the last 24 hours
Public method | GetResultChangesAsync(NullableDateTime, URN, CultureInfo) | Gets the list of all results that have changed in the last 24 hours
Top
See Also

Reference

ISportDataProviderV7 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV7.GetResultChangesAsync(Nullable<DateTime>, URN, CultureInfo) Method

ISportDataProviderV7GetResultChangesAsync(NullableDateTime, URN, CultureInfo) Method

Gets the list of all results that have changed in the last 24 hours

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IResultChange>> GetResultChangesAsync(
    DateTime? after,
    URN sportId,
    CultureInfo culture = null
)

Parameters

after Nullable DateTime
A DateTime specifying the starting date and time for filtering
sportId URN
A URN specifying the sport for which the fixtures should be returned
culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task IEnumerable IResultChange
A list of all results that have changed in the last 24 hours
See Also

Reference

ISportDataProviderV7 Interface
GetResultChangesAsync Overload
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV8 Interface

Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportDataProviderV8 : ISportDataProviderV7,
    ISportDataProviderV6, ISportDataProviderV5, ISportDataProviderV4, ISportDataProviderV3, ISportDataProviderV2,
    ISportDataProviderV1, ISportDataProvider

The ISportDataProviderV8 type exposes the following members.

Methods
Name Description
Public method CacheExportAsync Exports current items in the cache
(Inherited from ISportDataProviderV5)
Public method CacheImportAsync Imports provided items into caches
(Inherited from ISportDataProviderV5)
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync(CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetFixtureChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetResultChangesAsync(CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV6)
Public method GetResultChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEvent Gets a ISportEvent derived class representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV8 Methods

The ISportDataProviderV8 type exposes the following members.

Methods
Name Description
Public method CacheExportAsync Exports current items in the cache
(Inherited from ISportDataProviderV5)
Public method CacheImportAsync Imports provided items into caches
(Inherited from ISportDataProviderV5)
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync(CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetFixtureChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetResultChangesAsync(CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV6)
Public method GetResultChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEvent Gets a ISportEvent derived class representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

ISportDataProviderV8 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV8.GetSportEvent Method

ISportDataProviderV8GetSportEvent Method

Gets a ISportEvent derived class representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ISportEvent GetSportEvent(
    URN id,
    URN sportId = null,
    CultureInfo culture = null
)

Parameters

id URN
A URN specifying the sport event to retrieve
sportId URN (Optional)
A URN of the sport this event belongs to
culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

ISportEvent
A ISportEvent derived class representing the specified sport event or a null reference if the requested sport event does not exist
See Also

Reference

ISportDataProviderV8 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV9 Interface

Defines a contract implemented by classes used to provide sport related data (sports, tournaments, sport events, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportDataProviderV9 : ISportDataProviderV8,
    ISportDataProviderV7, ISportDataProviderV6, ISportDataProviderV5, ISportDataProviderV4, ISportDataProviderV3,
    ISportDataProviderV2, ISportDataProviderV1, ISportDataProvider

The ISportDataProviderV9 type exposes the following members.

Methods
Name | Description
Public method CacheExportAsync Exports current items in the cache
(Inherited from ISportDataProviderV5)
Public method CacheImportAsync Imports provided items into caches
(Inherited from ISportDataProviderV5)
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync(CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetFixtureChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method | GetLotteriesAsync | Gets the list of available lotteries
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetResultChangesAsync(CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV6)
Public method GetResultChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEvent Gets a ISportEvent derived class representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV8)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV9 Methods

The ISportDataProviderV9 type exposes the following members.

Methods
Name | Description
Public method CacheExportAsync Exports current items in the cache
(Inherited from ISportDataProviderV5)
Public method CacheImportAsync Imports provided items into caches
(Inherited from ISportDataProviderV5)
Public method DeleteCompetitorFromCache Delete the competitor from cache
(Inherited from ISportDataProvider)
Public method DeletePlayerProfileFromCache Delete the player profile from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventFromCache Delete the sport event from cache
(Inherited from ISportDataProvider)
Public method DeleteSportEventsFromCache Deletes the sport events from cache which are scheduled before specified date
(Inherited from ISportDataProviderV4)
Public method DeleteTournamentFromCache Delete the tournament from cache
(Inherited from ISportDataProvider)
Public method GetActiveTournamentsAsync Asynchronously gets a list of active IEnumerableT
(Inherited from ISportDataProviderV3)
Public method GetAvailableTournamentsAsync Asynchronously gets a list of available IEnumerableT for a specific sport
(Inherited from ISportDataProviderV3)
Public method GetCompetition(URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV1)
Public method GetCompetition(URN, URN, CultureInfo) Gets a ICompetition representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Public method GetCompetitorAsync Asynchronously gets a ICompetitor
(Inherited from ISportDataProvider)
Public method GetFixtureChangesAsync(CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV1)
Public method GetFixtureChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all fixtures that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetListOfSportEventsAsync Asynchronously gets a list of IEnumerableT
(Inherited from ISportDataProviderV2)
Public method GetLiveSportEventsAsync Asynchronously gets a IEnumerableT representing currently live sport events in the language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method | GetLotteriesAsync | Gets the list of available lotteries
Public method GetPlayerProfileAsync Asynchronously gets a IPlayerProfile
(Inherited from ISportDataProvider)
Public method GetResultChangesAsync(CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV6)
Public method GetResultChangesAsync(NullableDateTime, URN, CultureInfo) Gets the list of all results that have changed in the last 24 hours
(Inherited from ISportDataProviderV7)
Public method GetSportAsync Asynchronously gets a ISport instance representing the sport specified by it's id in the language specified by
C#
Copy
culture
, or a null reference if sport with specified id does not exist
(Inherited from ISportDataProvider)
Public method GetSportEvent Gets a ISportEvent derived class representing the specified sport event in language specified by
C#
Copy
culture
or a null reference if the sport event with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProviderV8)
Public method GetSportEventsByDateAsync Asynchronously gets a IEnumerableT representing sport events scheduled for date specified by
C#
Copy
date
in language specified by
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetSportEventStatusAsync Asynchronously gets a ICompetitionStatus for specific sport event
(Inherited from ISportDataProvider)
Public method GetSportsAsync Asynchronously gets a IEnumerableT representing all available sports in language specified by the
C#
Copy
culture

(Inherited from ISportDataProvider)
Public method GetTournament Gets a ILongTermEvent representing the specified tournament in language specified by
C#
Copy
culture
or a null reference if the tournament with specified
C#
Copy
id
does not exist
(Inherited from ISportDataProvider)
Top
See Also

Reference

ISportDataProviderV9 Interface
Sportradar.OddsFeed.SDK.API Namespace


ISportDataProviderV9.GetLotteriesAsync Method

ISportDataProviderV9GetLotteriesAsync Method

Gets the list of available lotteries

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ILottery>> GetLotteriesAsync(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language or a null reference to use the languages specified in the configuration

Return Value

Task IEnumerable ILottery
A list of available lotteries
See Also

Reference

ISportDataProviderV9 Interface
Sportradar.OddsFeed.SDK.API Namespace


ITokenSetter Interface

Defines a contract implemented by classes taking care of the 1st step when building configuration - setting the token

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITokenSetter

The ITokenSetter type exposes the following members.

Methods
 | Name | Description
Public method | BuildFromConfigFile | Gets the configuration properties from configuration file. Any values already set by methods on the current instance are overridden. Builds and returns a IOddsFeedConfiguration instance.
Public method | SetAccessToken | Sets the access token used to access feed resources (AMQP broker, Sports API, ...)
Public method | SetAccessTokenFromConfigFile | Sets the access token used to access feed resources (AMQP broker, Sports API, ...) to value read from configuration file
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ITokenSetter Methods

The ITokenSetter type exposes the following members.

Methods
 | Name | Description
Public method | BuildFromConfigFile | Gets the configuration properties from configuration file. Any values already set by methods on the current instance are overridden. Builds and returns a IOddsFeedConfiguration instance.
Public method | SetAccessToken | Sets the access token used to access feed resources (AMQP broker, Sports API, ...)
Public method | SetAccessTokenFromConfigFile | Sets the access token used to access feed resources (AMQP broker, Sports API, ...) to value read from configuration file
Top
See Also

Reference

ITokenSetter Interface
Sportradar.OddsFeed.SDK.API Namespace


ITokenSetter.BuildFromConfigFile Method

ITokenSetterBuildFromConfigFile Method

Gets the configuration properties from configuration file. Any values already set by methods on the current instance are overridden. Builds and returns a IOddsFeedConfiguration instance.

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsFeedConfiguration BuildFromConfigFile()

Return Value

IOddsFeedConfiguration
The constructed IOddsFeedConfiguration instance
See Also

Reference

ITokenSetter Interface
Sportradar.OddsFeed.SDK.API Namespace


ITokenSetter.SetAccessToken Method

ITokenSetterSetAccessToken Method

Sets the access token used to access feed resources (AMQP broker, Sports API, ...)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnvironmentSelectorV1 SetAccessToken(
    string accessToken
)

Parameters

accessToken String
The access token used to access feed resources

Return Value

IEnvironmentSelectorV1
The IEnvironmentSelector instance allowing the selection of target environment
See Also

Reference

ITokenSetter Interface
Sportradar.OddsFeed.SDK.API Namespace


ITokenSetter.SetAccessTokenFromConfigFile Method

ITokenSetterSetAccessTokenFromConfigFile Method

Sets the access token used to access feed resources (AMQP broker, Sports API, ...) to value read from configuration file

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnvironmentSelectorV1 SetAccessTokenFromConfigFile()

Return Value

IEnvironmentSelectorV1
The IEnvironmentSelector instance allowing the selection of target environment
See Also

Reference

ITokenSetter Interface
Sportradar.OddsFeed.SDK.API Namespace


MessageType Enumeration

Enumerates the types of the messages received from the feed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum MessageType
Members
Member name | Value | Description
UNKNOWN | 0 | Indicating the type of the message could not be determined
PRODUCER_DOWN | 1 | A message indicating that a producer associated with the feed went down
SNAPSHOT_COMPLETE | 2 | A message indicating all messages with a specific snapshot request were delivered
ALIVE | 3 | A message periodically send by all feed associated producers indicating their status
FIXTURE_CHANGE | 4 | A message indicating that a status of a specific fixture has changed
BET_STOP | 5 | A message indicating that betting on specified markets should be stopped
BET_CANCEL | 6 | A message indicating that bets placed on specified markets should be canceled
ROLLBACK_BET_CANCEL | 7 | A message specifying that changes made by the associated bet cancel should be un-done
BET_SETTLEMENT | 8 | A message specifying that bets associated with specified markets should be settled
ROLLBACK_BET_SETTLEMENT | 9 | A message specifying that changes made by the associated bet settlement should be un-done
ODDS_CHANGE | 10 | A message specifying that odds for specified markets have changed
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ReplayFeed Class

A IOddsFeed implementation acting as an entry point to the odds feed Replay Service for doing integration tests against played matches that are older than 48 hours
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.APIEntityDispatcherBase
Sportradar.OddsFeed.SDK.APIFeed
Sportradar.OddsFeed.SDK.APIReplayFeed

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class ReplayFeed : Feed

The ReplayFeed type exposes the following members.

Constructors
 | Name | Description
Public method | ReplayFeed | Initializes a new instance of the ReplayFeed class
Top
Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from Feed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from Feed)
Public property | CashOutProbabilitiesProvider | Gets theICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from Feed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from Feed)
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes (Inherited from Feed)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from Feed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from Feed)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from Feed)
Public property | ReplayManager | The replay manager for interaction with xReplay Server
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from Feed)
Top
Methods
Name Description
Public method Close Closes the current Feed instance and disposes resources used by it
(Inherited from Feed)
Public method CreateBuilder Constructs and returns a new instance of IOddsFeedSessionBuilder
(Inherited from Feed)
Protected method DispatchT(EventHandlerT, T, FeedMessage) Dispatches the
C#
Copy
message

(Inherited from EntityDispatcherBase)
Protected method DispatchT(EventHandlerT, T, String, Int32) Raises the specified event
(Inherited from EntityDispatcherBase)
Public method DispatchConnectionException Dispatches the information that the exception was thrown in connection loop The information about the exception
(Inherited from Feed)
Public method Dispose Disposes the current instance and resources associated with it
(Inherited from Feed)
Protected method Dispose(Boolean) Disposes the current instance and resources associated with it
(Inherited from Feed)
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Protected method Finalize Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
Protected method InitFeed Initializes the feed (unity)
(Overrides FeedInitFeed)
Public method IsOpen Returns an indicator if the feed instance is opened or not
(Inherited from Feed)
Protected method MemberwiseClone Creates a shallow copy of the current Object.
(Inherited from Object)
Public method Open Opens the current feed by opening all created sessions
(Inherited from Feed)
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Protected method UpdateDependency Option to change/update dependency injection before resolving resources
(Inherited from Feed)
Top
Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from Feed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop (Inherited from Feed)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from Feed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from Feed)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from Feed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from Feed)
Public event | RecoveryInitiated | Occurs when a recovery initiation completes (Inherited from Feed)
Top
Fields
 | Name | Description
Protected field | FeedInitialized | The feed initialized (Inherited from Feed)
Protected field | UnityContainer | A IUnityContainer used to resolve (Inherited from Feed)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


ReplayFeed Constructor

Initializes a new instance of the ReplayFeed class

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ReplayFeed(
    IOddsFeedConfiguration config
)

Parameters

config IOddsFeedConfiguration
A IOddsFeedConfiguration instance representing feed configuration.
See Also

Reference

ReplayFeed Class
Sportradar.OddsFeed.SDK.API Namespace


ReplayFeed Properties

The ReplayFeed type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from Feed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from Feed)
Public property | CashOutProbabilitiesProvider | Gets theICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from Feed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from Feed)
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes (Inherited from Feed)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from Feed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from Feed)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from Feed)
Public property | ReplayManager | The replay manager for interaction with xReplay Server
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from Feed)
Top
See Also

Reference

ReplayFeed Class
Sportradar.OddsFeed.SDK.API Namespace


ReplayFeed.ReplayManager Property

ReplayFeedReplayManager Property

The replay manager for interaction with xReplay Server

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IReplayManagerV1 ReplayManager { get; }

Property Value

IReplayManagerV1
See Also

Reference

ReplayFeed Class
Sportradar.OddsFeed.SDK.API Namespace


ReplayFeed Methods

The ReplayFeed type exposes the following members.

Methods
Name Description
Public method Close Closes the current Feed instance and disposes resources used by it
(Inherited from Feed)
Public method CreateBuilder Constructs and returns a new instance of IOddsFeedSessionBuilder
(Inherited from Feed)
Protected method DispatchT(EventHandlerT, T, FeedMessage) Dispatches the
C#
Copy
message

(Inherited from EntityDispatcherBase)
Protected method DispatchT(EventHandlerT, T, String, Int32) Raises the specified event
(Inherited from EntityDispatcherBase)
Public method DispatchConnectionException Dispatches the information that the exception was thrown in connection loop The information about the exception
(Inherited from Feed)
Public method Dispose Disposes the current instance and resources associated with it
(Inherited from Feed)
Protected method Dispose(Boolean) Disposes the current instance and resources associated with it
(Inherited from Feed)
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Protected method Finalize Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
Protected method InitFeed Initializes the feed (unity)
(Overrides FeedInitFeed)
Public method IsOpen Returns an indicator if the feed instance is opened or not
(Inherited from Feed)
Protected method MemberwiseClone Creates a shallow copy of the current Object.
(Inherited from Object)
Public method Open Opens the current feed by opening all created sessions
(Inherited from Feed)
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Protected method UpdateDependency Option to change/update dependency injection before resolving resources
(Inherited from Feed)
Top
See Also

Reference

ReplayFeed Class
Sportradar.OddsFeed.SDK.API Namespace


ReplayFeed.InitFeed Method

ReplayFeedInitFeed Method

Initializes the feed (unity)

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected override void InitFeed()
See Also

Reference

ReplayFeed Class
Sportradar.OddsFeed.SDK.API Namespace


ReplayFeed Events

The ReplayFeed type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from Feed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop (Inherited from Feed)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from Feed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from Feed)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from Feed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from Feed)
Public event | RecoveryInitiated | Occurs when a recovery initiation completes (Inherited from Feed)
Top
See Also

Reference

ReplayFeed Class
Sportradar.OddsFeed.SDK.API Namespace


ReplayFeed Fields

The ReplayFeed type exposes the following members.

Fields
 | Name | Description
Protected field | FeedInitialized | The feed initialized (Inherited from Feed)
Protected field | UnityContainer | A IUnityContainer used to resolve (Inherited from Feed)
Top
See Also

Reference

ReplayFeed Class
Sportradar.OddsFeed.SDK.API Namespace


ReplayPlayerStatus Enumeration

Status of the replay player

Namespace: Sportradar.OddsFeed.SDK.API
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum ReplayPlayerStatus
Members
Member name | Value | Description
NotStarted | 0 | Player was never playing
Playing | 1 | Player is currently playing
Stopped | 2 | Player is stopped
Setting_up | 3 | The setting up
See Also

Reference

Sportradar.OddsFeed.SDK.API Namespace


Sportradar.OddsFeed.SDK.API.EventArguments Namespace

Classes
 | Class | Description
Public class | BetCancelEventArgsT | Event arguments for the OnBetCancel event
Public class | BetSettlementEventArgsT | Event arguments for OnBetSettlement event
Public class | BetStopEventArgsT | Event arguments for OnBetStop event
Public class | ConnectionExceptionEventArgs | Event arguments for the ConnectionException events
Public class | EventChangeEventArgs | Event arguments for FixtureChange and ResultChange event
Public class | EventRecoveryCompletedEventArgs | Event arguments for the EventRecoveryCompleted events
Public class | FeedCloseEventArgs | Event arguments for the FeedClose events
Public class | FixtureChangeEventArgsT | Event arguments for the OnFixtureChange event
Public class | OddsChangeEventArgsT | Event arguments for OnOddsChange event
Public class | ProducerStatusChangeEventArgs | Event arguments for the ProducerDown events
Public class | RecoveryInitiatedEventArgs | Event arguments for the RecoveryInitiated events
Public class | RollbackBetCancelEventArgsT | Event arguments for the OnRollbackBetCancel event
Public class | RollbackBetSettlementEventArgsT | Event arguments for OnRollbackBetSettlement class
Public class | SnapshotCompleteEventArgs | Event arguments for the FeedMessageReceived event
Public class | UnparsableMessageEventArgs | Event arguments of OnUnparsableMessageReceived event


BetCancelEventArgs<T> Class

BetCancelEventArgsT Class

Event arguments for the OnBetCancel event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsBetCancelEventArgsT

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class BetCancelEventArgs<T> : EventArgs
where T : ISportEvent

Type Parameters

T
A ICompetition derived instance specifying the type of sport event associated with contained IBetCancelT

The BetCancelEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBetCancel | Gets the IBetCancelT implementation representing the received bet cancel message translated to the specified languages
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw XML message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


BetCancelEventArgs<T> Methods

BetCancelEventArgsT Methods

The BetCancelEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBetCancel | Gets the IBetCancelT implementation representing the received bet cancel message translated to the specified languages
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw XML message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BetCancelEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


BetCancelEventArgs<T>.GetBetCancel Method

BetCancelEventArgsTGetBetCancel Method

Gets the IBetCancelT implementation representing the received bet cancel message translated to the specified languages

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IBetCancel<T> GetBetCancel(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language of which to translate the message or a null reference to translate the message to languages specified in the configuration

Return Value

IBetCancel T
Returns the IBetCancelT implementation representing the received bet cancel message translated to the specified languages
See Also

Reference

BetCancelEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


BetCancelEventArgs<T>.GetRawMessage Method

BetCancelEventArgsTGetRawMessage Method

Note: This API is now obsolete.

Gets the raw XML message received from the feed

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("The message was moved to event")]
public string GetRawMessage()

Return Value

String
Returns the raw XML message received from the feed
See Also

Reference

BetCancelEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


BetSettlementEventArgs<T> Class

BetSettlementEventArgsT Class

Event arguments for OnBetSettlement event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsBetSettlementEventArgsT

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class BetSettlementEventArgs<T> : EventArgs
where T : ISportEvent

Type Parameters

T
A ICompetition derived instance specifying the type of sport event associated with contained IBetSettlementT

The BetSettlementEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBetSettlement | Gets the IBetSettlementT implementation representing the received bet settlement message translated to the specified languages
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


BetSettlementEventArgs<T> Methods

BetSettlementEventArgsT Methods

The BetSettlementEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBetSettlement | Gets the IBetSettlementT implementation representing the received bet settlement message translated to the specified languages
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BetSettlementEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


BetSettlementEventArgs<T>.GetBetSettlement Method

BetSettlementEventArgsTGetBetSettlement Method

Gets the IBetSettlementT implementation representing the received bet settlement message translated to the specified languages

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IBetSettlement<T> GetBetSettlement(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language of which to translate the message or a null reference to translate the message to languages specified in the configuration

Return Value

IBetSettlement T
Returns the IBetSettlementT implementation representing the received bet settlement message translated to the specified languages
See Also

Reference

BetSettlementEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


BetSettlementEventArgs<T>.GetRawMessage Method

BetSettlementEventArgsTGetRawMessage Method

Note: This API is now obsolete.

Gets the raw xml message received from the feed

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("The message was moved to event")]
public string GetRawMessage()

Return Value

String
Returns the raw xml message received from the feed
See Also

Reference

BetSettlementEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


BetStopEventArgs<T> Class

BetStopEventArgsT Class

Event arguments for OnBetStop event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsBetStopEventArgsT

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class BetStopEventArgs<T> : EventArgs
where T : ISportEvent

Type Parameters

T
A ICompetition derived instance specifying the type of sport event associated with contained IBetStopT

The BetStopEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBetStop | Gets the IBetStopT implementation representing the received bet stop message translated to the specified languages
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


BetStopEventArgs<T> Methods

BetStopEventArgsT Methods

The BetStopEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBetStop | Gets the IBetStopT implementation representing the received bet stop message translated to the specified languages
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BetStopEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


BetStopEventArgs<T>.GetBetStop Method

BetStopEventArgsTGetBetStop Method

Gets the IBetStopT implementation representing the received bet stop message translated to the specified languages

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IBetStop<T> GetBetStop(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language of which to translate the message or a null reference to translate the message to languages specified in the configuration

Return Value

IBetStop T
Returns the IBetStopT implementation representing the received bet stop message translated to the specified languages
See Also

Reference

BetStopEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


BetStopEventArgs<T>.GetRawMessage Method

BetStopEventArgsTGetRawMessage Method

Note: This API is now obsolete.

Gets the raw xml message received from the feed

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("The message was moved to event")]
public string GetRawMessage()

Return Value

String
Returns the raw xml message received from the feed
See Also

Reference

BetStopEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


ConnectionExceptionEventArgs Class

Event arguments for the ConnectionException events
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsConnectionExceptionEventArgs

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class ConnectionExceptionEventArgs : EventArgs

The ConnectionExceptionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionExceptionEventArgs | Initializes a new instance of the ConnectionExceptionEventArgs class
Top
Properties
 | Name | Description
Public property | Detail | Details about the error
Public property | Exception | The exception that caused an error
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


ConnectionExceptionEventArgs Constructor

Initializes a new instance of the ConnectionExceptionEventArgs class

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ConnectionExceptionEventArgs(
    Exception exception,
    IDictionary<string, Object> detail
)

Parameters

exception Exception
The exception that caused an error
detail IDictionary String, Object
Details about the error
See Also

Reference

ConnectionExceptionEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


ConnectionExceptionEventArgs Properties

The ConnectionExceptionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Detail | Details about the error
Public property | Exception | The exception that caused an error
Top
See Also

Reference

ConnectionExceptionEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


ConnectionExceptionEventArgs.Detail Property

ConnectionExceptionEventArgsDetail Property

Details about the error

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IDictionary<string, Object> Detail { get; }

Property Value

IDictionary String, Object
See Also

Reference

ConnectionExceptionEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


ConnectionExceptionEventArgs.Exception Property

ConnectionExceptionEventArgsException Property

The exception that caused an error

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Exception Exception { get; }

Property Value

Exception
See Also

Reference

ConnectionExceptionEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


ConnectionExceptionEventArgs Methods

The ConnectionExceptionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionExceptionEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


EventChangeEventArgs Class

Event arguments for FixtureChange and ResultChange event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsEventChangeEventArgs

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class EventChangeEventArgs : EventArgs

The EventChangeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | EventChangeEventArgs | Initializes a new instance of the EventChangeEventArgs class
Top
Properties
 | Name | Description
Public property | SportEvent | Gets the ISportEvent
Public property | SportEventId | Gets the URN specifying the sport event
Public property | UpdateTime | Gets the DateTime specifying the last update time
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


EventChangeEventArgs Constructor

Initializes a new instance of the EventChangeEventArgs class

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public EventChangeEventArgs(
    URN sportEventId,
    DateTime updateTime,
    ISportEvent sportEvent
)

Parameters

sportEventId URN

[Missing <param name="sportEventId"/> documentation for "M:Sportradar.OddsFeed.SDK.API.EventArguments.EventChangeEventArgs.#ctor(Sportradar.OddsFeed.SDK.Messages.URN,System.DateTime,Sportradar.OddsFeed.SDK.Entities.REST.ISportEvent)"]

updateTime DateTime

[Missing <param name="updateTime"/> documentation for "M:Sportradar.OddsFeed.SDK.API.EventArguments.EventChangeEventArgs.#ctor(Sportradar.OddsFeed.SDK.Messages.URN,System.DateTime,Sportradar.OddsFeed.SDK.Entities.REST.ISportEvent)"]

sportEvent ISportEvent

[Missing <param name="sportEvent"/> documentation for "M:Sportradar.OddsFeed.SDK.API.EventArguments.EventChangeEventArgs.#ctor(Sportradar.OddsFeed.SDK.Messages.URN,System.DateTime,Sportradar.OddsFeed.SDK.Entities.REST.ISportEvent)"]

See Also

Reference

EventChangeEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


EventChangeEventArgs Properties

The EventChangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SportEvent | Gets the ISportEvent
Public property | SportEventId | Gets the URN specifying the sport event
Public property | UpdateTime | Gets the DateTime specifying the last update time
Top
See Also

Reference

EventChangeEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


EventChangeEventArgs.SportEvent Property

EventChangeEventArgsSportEvent Property

Gets the ISportEvent

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ISportEvent SportEvent { get; }

Property Value

ISportEvent
See Also

Reference

EventChangeEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


EventChangeEventArgs.SportEventId Property

EventChangeEventArgsSportEventId Property

Gets the URN specifying the sport event

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public URN SportEventId { get; }

Property Value

URN
See Also

Reference

EventChangeEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


EventChangeEventArgs.UpdateTime Property

EventChangeEventArgsUpdateTime Property

Gets the DateTime specifying the last update time

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime UpdateTime { get; }

Property Value

DateTime
See Also

Reference

EventChangeEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


EventChangeEventArgs Methods

The EventChangeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EventChangeEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


EventRecoveryCompletedEventArgs Class

Event arguments for the EventRecoveryCompleted events
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsEventRecoveryCompletedEventArgs

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class EventRecoveryCompletedEventArgs : EventArgs

The EventRecoveryCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetEventId | Gets the associated event identifier
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRequestId | Gets the identifier of the recovery request
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


EventRecoveryCompletedEventArgs Methods

The EventRecoveryCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetEventId | Gets the associated event identifier
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRequestId | Gets the identifier of the recovery request
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EventRecoveryCompletedEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


EventRecoveryCompletedEventArgs.GetEventId Method

EventRecoveryCompletedEventArgsGetEventId Method

Gets the associated event identifier

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public URN GetEventId()

Return Value

URN
Returns the associated event identifier
See Also

Reference

EventRecoveryCompletedEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


EventRecoveryCompletedEventArgs.GetRequestId Method

EventRecoveryCompletedEventArgsGetRequestId Method

Gets the identifier of the recovery request

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long GetRequestId()

Return Value

Int64
Returns the identifier of the recovery request
See Also

Reference

EventRecoveryCompletedEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


FeedCloseEventArgs Class

Event arguments for the FeedClose events
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsFeedCloseEventArgs

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class FeedCloseEventArgs : EventArgs

The FeedCloseEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetReason | Gets a IProducerStatusChange implementation containing information about the producer status change
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


FeedCloseEventArgs Methods

The FeedCloseEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetReason | Gets a IProducerStatusChange implementation containing information about the producer status change
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FeedCloseEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


FeedCloseEventArgs.GetReason Method

FeedCloseEventArgsGetReason Method

Gets a IProducerStatusChange implementation containing information about the producer status change

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string GetReason()

Return Value

String
Returns a IProducerStatusChange implementation containing information about the producer status change
See Also

Reference

FeedCloseEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


FixtureChangeEventArgs<T> Class

FixtureChangeEventArgsT Class

Event arguments for the OnFixtureChange event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsFixtureChangeEventArgsT

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class FixtureChangeEventArgs<T> : EventArgs
where T : ISportEvent

Type Parameters

T
A ICompetition derived instance specifying the type of sport event associated with contained IFixtureChangeT

The FixtureChangeEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetFixtureChange | Gets the IFixtureChangeT implementation representing the received fixture change message translated to the specified languages
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


FixtureChangeEventArgs<T> Methods

FixtureChangeEventArgsT Methods

The FixtureChangeEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetFixtureChange | Gets the IFixtureChangeT implementation representing the received fixture change message translated to the specified languages
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FixtureChangeEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


FixtureChangeEventArgs<T>.GetFixtureChange Method

FixtureChangeEventArgsTGetFixtureChange Method

Gets the IFixtureChangeT implementation representing the received fixture change message translated to the specified languages

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IFixtureChange<T> GetFixtureChange(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language of which to translate the message or a null reference to translate the message to languages specified in the configuration

Return Value

IFixtureChange T
Returns the IFixtureChangeT implementation representing the received fixture change message translated to the specified languages
See Also

Reference

FixtureChangeEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


FixtureChangeEventArgs<T>.GetRawMessage Method

FixtureChangeEventArgsTGetRawMessage Method

Note: This API is now obsolete.

Gets the raw xml message received from the feed

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("The message was moved to event")]
public string GetRawMessage()

Return Value

String
Returns the raw xml message received from the feed
See Also

Reference

FixtureChangeEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


OddsChangeEventArgs<T> Class

OddsChangeEventArgsT Class

Event arguments for OnOddsChange event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsOddsChangeEventArgsT

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class OddsChangeEventArgs<T> : EventArgs
where T : ISportEvent

Type Parameters

T
A ICompetition derived instance specifying the type of sport event associated with contained IOddsChangeT

The OddsChangeEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOddsChange | Gets the IOddsChangeT implementation representing the received odds change message translated to the specified languages
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


OddsChangeEventArgs<T> Methods

OddsChangeEventArgsT Methods

The OddsChangeEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOddsChange | Gets the IOddsChangeT implementation representing the received odds change message translated to the specified languages
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OddsChangeEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


OddsChangeEventArgs<T>.GetOddsChange Method

OddsChangeEventArgsTGetOddsChange Method

Gets the IOddsChangeT implementation representing the received odds change message translated to the specified languages

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IOddsChange<T> GetOddsChange(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language of which to translate the message or a null reference to translate the message to languages specified in the configuration

Return Value

IOddsChange T
Returns the IOddsChangeT implementation representing the received odds change message translated to the specified languages
See Also

Reference

OddsChangeEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


OddsChangeEventArgs<T>.GetRawMessage Method

OddsChangeEventArgsTGetRawMessage Method

Note: This API is now obsolete.

Gets the raw xml message received from the feed

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("The message was moved to event")]
public string GetRawMessage()

Return Value

String
Returns the raw xml message received from the feed
See Also

Reference

OddsChangeEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


ProducerStatusChangeEventArgs Class

Event arguments for the ProducerDown events
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsProducerStatusChangeEventArgs

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class ProducerStatusChangeEventArgs : EventArgs

The ProducerStatusChangeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetProducerStatusChange | Gets a IProducerStatusChange implementation containing information about the producer status change
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


ProducerStatusChangeEventArgs Methods

The ProducerStatusChangeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetProducerStatusChange | Gets a IProducerStatusChange implementation containing information about the producer status change
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ProducerStatusChangeEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


ProducerStatusChangeEventArgs.GetProducerStatusChange Method

ProducerStatusChangeEventArgsGetProducerStatusChange Method

Gets a IProducerStatusChange implementation containing information about the producer status change

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IProducerStatusChange GetProducerStatusChange()

Return Value

IProducerStatusChange
Returns a IProducerStatusChange implementation containing information about the producer status change
See Also

Reference

ProducerStatusChangeEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RecoveryInitiatedEventArgs Class

Event arguments for the RecoveryInitiated events
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsRecoveryInitiatedEventArgs

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class RecoveryInitiatedEventArgs : EventArgs

The RecoveryInitiatedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetAfterTimestamp | Gets the after timestamp if applied
Public method | GetEventId | Gets the associated event identifier
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMessage | Gets the message associated with the recovery request
Public method | GetProducerId | Gets the associated producer identifier
Public method | GetRequestId | Gets the identifier of the recovery request
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RecoveryInitiatedEventArgs Methods

The RecoveryInitiatedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetAfterTimestamp | Gets the after timestamp if applied
Public method | GetEventId | Gets the associated event identifier
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMessage | Gets the message associated with the recovery request
Public method | GetProducerId | Gets the associated producer identifier
Public method | GetRequestId | Gets the identifier of the recovery request
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RecoveryInitiatedEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RecoveryInitiatedEventArgs.GetAfterTimestamp Method

RecoveryInitiatedEventArgsGetAfterTimestamp Method

Gets the after timestamp if applied

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long GetAfterTimestamp()

Return Value

Int64
Returns the after timestamp if applied
See Also

Reference

RecoveryInitiatedEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RecoveryInitiatedEventArgs.GetEventId Method

RecoveryInitiatedEventArgsGetEventId Method

Gets the associated event identifier

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public URN GetEventId()

Return Value

URN
Returns the associated event identifier
See Also

Reference

RecoveryInitiatedEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RecoveryInitiatedEventArgs.GetMessage Method

RecoveryInitiatedEventArgsGetMessage Method

Gets the message associated with the recovery request

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string GetMessage()

Return Value

String
Returns the message associated with the recovery request
See Also

Reference

RecoveryInitiatedEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RecoveryInitiatedEventArgs.GetProducerId Method

RecoveryInitiatedEventArgsGetProducerId Method

Gets the associated producer identifier

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int GetProducerId()

Return Value

Int32
Returns the associated producer identifier
See Also

Reference

RecoveryInitiatedEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RecoveryInitiatedEventArgs.GetRequestId Method

RecoveryInitiatedEventArgsGetRequestId Method

Gets the identifier of the recovery request

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long GetRequestId()

Return Value

Int64
Returns the identifier of the recovery request
See Also

Reference

RecoveryInitiatedEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RollbackBetCancelEventArgs<T> Class

RollbackBetCancelEventArgsT Class

Event arguments for the OnRollbackBetCancel event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsRollbackBetCancelEventArgsT

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class RollbackBetCancelEventArgs<T> : EventArgs
where T : ISportEvent

Type Parameters

T
A ICompetition derived instance specifying the type of sport event associated with contained IRollbackBetCancelT

The RollbackBetCancelEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBetCancelRollback | Gets the IRollbackBetCancelT implementation representing the received bet cancel rollback message translated to the specified languages
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RollbackBetCancelEventArgs<T> Methods

RollbackBetCancelEventArgsT Methods

The RollbackBetCancelEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBetCancelRollback | Gets the IRollbackBetCancelT implementation representing the received bet cancel rollback message translated to the specified languages
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RollbackBetCancelEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RollbackBetCancelEventArgs<T>.GetBetCancelRollback Method

RollbackBetCancelEventArgsTGetBetCancelRollback Method

Gets the IRollbackBetCancelT implementation representing the received bet cancel rollback message translated to the specified languages

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IRollbackBetCancel<T> GetBetCancelRollback(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language of which to translate the message or a null reference to translate the message to languages specified in the configuration

Return Value

IRollbackBetCancel T
Returns the IRollbackBetCancelT implementation representing the received bet cancel rollback message translated to the specified languages
See Also

Reference

RollbackBetCancelEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RollbackBetCancelEventArgs<T>.GetRawMessage Method

RollbackBetCancelEventArgsTGetRawMessage Method

Note: This API is now obsolete.

Gets the raw xml message received from the feed

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("The message was moved to event")]
public string GetRawMessage()

Return Value

String
Returns the raw xml message received from the feed
See Also

Reference

RollbackBetCancelEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RollbackBetSettlementEventArgs<T> Class

RollbackBetSettlementEventArgsT Class

Event arguments for OnRollbackBetSettlement class
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsRollbackBetSettlementEventArgsT

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class RollbackBetSettlementEventArgs<T> : EventArgs
where T : ISportEvent

Type Parameters

T
A ICompetition derived instance specifying the type of sport event associated with contained IRollbackBetSettlementT

The RollbackBetSettlementEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBetSettlementRollback | Gets the IRollbackBetSettlementT implementation representing the received bet settlement rollback message translated to the specified languages
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RollbackBetSettlementEventArgs<T> Methods

RollbackBetSettlementEventArgsT Methods

The RollbackBetSettlementEventArgsT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBetSettlementRollback | Gets the IRollbackBetSettlementT implementation representing the received bet settlement rollback message translated to the specified languages
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RollbackBetSettlementEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RollbackBetSettlementEventArgs<T>.GetBetSettlementRollback Method

RollbackBetSettlementEventArgsTGetBetSettlementRollback Method

Gets the IRollbackBetSettlementT implementation representing the received bet settlement rollback message translated to the specified languages

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IRollbackBetSettlement<T> GetBetSettlementRollback(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
A CultureInfo specifying the language of which to translate the message or a null reference to translate the message to languages specified in the configuration

Return Value

IRollbackBetSettlement T
Returns the IRollbackBetSettlementT implementation representing the received bet settlement rollback message translated to the specified languages
See Also

Reference

RollbackBetSettlementEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


RollbackBetSettlementEventArgs<T>.GetRawMessage Method

RollbackBetSettlementEventArgsTGetRawMessage Method

Note: This API is now obsolete.

Gets the raw xml message received from the feed

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("The message was moved to event")]
public string GetRawMessage()

Return Value

String
Returns the raw xml message received from the feed
See Also

Reference

RollbackBetSettlementEventArgsT Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


SnapshotCompleteEventArgs Class

Event arguments for the FeedMessageReceived event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsSnapshotCompleteEventArgs

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class SnapshotCompleteEventArgs : EventArgs

The SnapshotCompleteEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetSnapshotCompleted | Gets the ISnapshotCompleted implementation representing the received snapshot_complete message
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


SnapshotCompleteEventArgs Methods

The SnapshotCompleteEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Obsolete. Gets the raw xml message received from the feed
Public method | GetSnapshotCompleted | Gets the ISnapshotCompleted implementation representing the received snapshot_complete message
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SnapshotCompleteEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


SnapshotCompleteEventArgs.GetRawMessage Method

SnapshotCompleteEventArgsGetRawMessage Method

Note: This API is now obsolete.

Gets the raw xml message received from the feed

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("The message was moved to event")]
public string GetRawMessage()

Return Value

String
Returns the raw xml message received from the feed
See Also

Reference

SnapshotCompleteEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


SnapshotCompleteEventArgs.GetSnapshotCompleted Method

SnapshotCompleteEventArgsGetSnapshotCompleted Method

Gets the ISnapshotCompleted implementation representing the received snapshot_complete message

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ISnapshotCompleted GetSnapshotCompleted()

Return Value

ISnapshotCompleted
A ISnapshotCompleted representing the received snapshot_complete message
See Also

Reference

SnapshotCompleteEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


UnparsableMessageEventArgs Class

Event arguments of OnUnparsableMessageReceived event
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.API.EventArgumentsUnparsableMessageEventArgs

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class UnparsableMessageEventArgs : EventArgs

The UnparsableMessageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UnparsableMessageEventArgs | Initializes a new instance of the UnparsableMessageEventArgs class
Top
Properties
 | Name | Description
Public property | EventId | Gets the String representation of the sport event id associated with the unparsable message
Public property | MessageType | Gets the MessageType member specifying the type of the unparsable message
Public property | Producer | Gets the String representation of the producer associated with the unparsable message
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Gets the raw XML message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.EventArguments Namespace


UnparsableMessageEventArgs Constructor

Initializes a new instance of the UnparsableMessageEventArgs class

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public UnparsableMessageEventArgs(
    MessageType messageType,
    string producer,
    string eventId,
    byte[] rawMessage
)

Parameters

messageType MessageType
The MessageType member specifying the type of the unparsable message.
producer String
The String representation of the producer associated with the unparsable message.
eventId String
The String representation of the sport event id associated with the unparsable message.
rawMessage Byte
A raw message received from the feed
See Also

Reference

UnparsableMessageEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


UnparsableMessageEventArgs Properties

The UnparsableMessageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | EventId | Gets the String representation of the sport event id associated with the unparsable message
Public property | MessageType | Gets the MessageType member specifying the type of the unparsable message
Public property | Producer | Gets the String representation of the producer associated with the unparsable message
Top
See Also

Reference

UnparsableMessageEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


UnparsableMessageEventArgs.EventId Property

UnparsableMessageEventArgsEventId Property

Gets the String representation of the sport event id associated with the unparsable message

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string EventId { get; }

Property Value

String
See Also

Reference

UnparsableMessageEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


UnparsableMessageEventArgs.MessageType Property

UnparsableMessageEventArgsMessageType Property

Gets the MessageType member specifying the type of the unparsable message

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public MessageType MessageType { get; }

Property Value

MessageType
See Also

Reference

UnparsableMessageEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


UnparsableMessageEventArgs.Producer Property

UnparsableMessageEventArgsProducer Property

Gets the String representation of the producer associated with the unparsable message

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Producer { get; }

Property Value

String
See Also

Reference

UnparsableMessageEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


UnparsableMessageEventArgs Methods

The UnparsableMessageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRawMessage | Gets the raw XML message received from the feed
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

UnparsableMessageEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


UnparsableMessageEventArgs.GetRawMessage Method

UnparsableMessageEventArgsGetRawMessage Method

Gets the raw XML message received from the feed

Namespace: Sportradar.OddsFeed.SDK.API.EventArguments
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string GetRawMessage()

Return Value

String
Returns the raw XML message received from the feed
See Also

Reference

UnparsableMessageEventArgs Class
Sportradar.OddsFeed.SDK.API.EventArguments Namespace


Sportradar.OddsFeed.SDK.API.Extended Namespace

Classes
 | Class | Description
Public class | FeedExt | A IOddsFeed implementation acting as an entry point to the odds feed service with possibility to get raw feed and api data
Interfaces
 | Interface | Description
Public interface | IOddsFeedExt | Represent an extended unified odds feed


FeedExt Class

A IOddsFeed implementation acting as an entry point to the odds feed service with possibility to get raw feed and api data
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.APIEntityDispatcherBase
Sportradar.OddsFeed.SDK.APIFeed
Sportradar.OddsFeed.SDK.API.ExtendedFeedExt

Namespace: Sportradar.OddsFeed.SDK.API.Extended
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class FeedExt : Feed, IOddsFeedExt,
    IOddsFeedV6, IOddsFeedV5, IOddsFeedV4, IOddsFeedV3, IOddsFeedV2,
    IOddsFeedV1, IOddsFeed, IDisposable

The FeedExt type exposes the following members.

Constructors
 | Name | Description
Public method | FeedExt | Constructs a new instance of the Feed class
Top
Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from Feed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from Feed)
Public property | CashOutProbabilitiesProvider | Gets theICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from Feed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from Feed)
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes (Inherited from Feed)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from Feed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from Feed)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from Feed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from Feed)
Top
Methods
Name | Description
Public method | Close | Closes the current Feed instance and disposes resources used by it
Public method CreateBuilder Constructs and returns a new instance of IOddsFeedSessionBuilder
(Inherited from Feed)
Protected method DispatchT(EventHandlerT, T, FeedMessage) Dispatches the
C#
Copy
message

(Inherited from EntityDispatcherBase)
Protected method DispatchT(EventHandlerT, T, String, Int32) Raises the specified event
(Inherited from EntityDispatcherBase)
Public method DispatchConnectionException Dispatches the information that the exception was thrown in connection loop The information about the exception
(Inherited from Feed)
Public method Dispose Disposes the current instance and resources associated with it
(Inherited from Feed)
Protected method Dispose(Boolean) Disposes the current instance and resources associated with it
(Inherited from Feed)
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Protected method Finalize Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
Protected method InitFeed Initializes the feed (unity)
(Inherited from Feed)
Public method IsOpen Returns an indicator if the feed instance is opened or not
(Inherited from Feed)
Protected method MemberwiseClone Creates a shallow copy of the current Object.
(Inherited from Object)
Public method | Open | Opens the current feed by opening all created sessions
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Protected method UpdateDependency Option to change/update dependency injection before resolving resources
(Inherited from Feed)
Top
Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from Feed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop (Inherited from Feed)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from Feed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from Feed)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from Feed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from Feed)
Public event | RawApiDataReceived | Occurs when data from Sports API arrives
Public event | RawFeedMessageReceived | Occurs when any feed message arrives
Public event | RecoveryInitiated | Occurs when a recovery initiation completes (Inherited from Feed)
Top
Fields
 | Name | Description
Protected field | FeedInitialized | The feed initialized (Inherited from Feed)
Protected field | UnityContainer | A IUnityContainer used to resolve (Inherited from Feed)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.Extended Namespace


FeedExt Constructor

Constructs a new instance of the Feed class

Namespace: Sportradar.OddsFeed.SDK.API.Extended
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FeedExt(
    IOddsFeedConfiguration config
)

Parameters

config IOddsFeedConfiguration
A IOddsFeedConfiguration instance representing feed configuration
See Also

Reference

FeedExt Class
Sportradar.OddsFeed.SDK.API.Extended Namespace


FeedExt Properties

The FeedExt type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from Feed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from Feed)
Public property | CashOutProbabilitiesProvider | Gets theICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from Feed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from Feed)
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes (Inherited from Feed)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from Feed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from Feed)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from Feed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from Feed)
Top
See Also

Reference

FeedExt Class
Sportradar.OddsFeed.SDK.API.Extended Namespace


FeedExt Methods

The FeedExt type exposes the following members.

Methods
Name | Description
Public method | Close | Closes the current Feed instance and disposes resources used by it
Public method CreateBuilder Constructs and returns a new instance of IOddsFeedSessionBuilder
(Inherited from Feed)
Protected method DispatchT(EventHandlerT, T, FeedMessage) Dispatches the
C#
Copy
message

(Inherited from EntityDispatcherBase)
Protected method DispatchT(EventHandlerT, T, String, Int32) Raises the specified event
(Inherited from EntityDispatcherBase)
Public method DispatchConnectionException Dispatches the information that the exception was thrown in connection loop The information about the exception
(Inherited from Feed)
Public method Dispose Disposes the current instance and resources associated with it
(Inherited from Feed)
Protected method Dispose(Boolean) Disposes the current instance and resources associated with it
(Inherited from Feed)
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Protected method Finalize Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
Protected method InitFeed Initializes the feed (unity)
(Inherited from Feed)
Public method IsOpen Returns an indicator if the feed instance is opened or not
(Inherited from Feed)
Protected method MemberwiseClone Creates a shallow copy of the current Object.
(Inherited from Object)
Public method | Open | Opens the current feed by opening all created sessions
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Protected method UpdateDependency Option to change/update dependency injection before resolving resources
(Inherited from Feed)
Top
See Also

Reference

FeedExt Class
Sportradar.OddsFeed.SDK.API.Extended Namespace


FeedExt.Close Method

FeedExtClose Method

Closes the current Feed instance and disposes resources used by it

Namespace: Sportradar.OddsFeed.SDK.API.Extended
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public void Close()

Implements

IOddsFeedClose
See Also

Reference

FeedExt Class
Sportradar.OddsFeed.SDK.API.Extended Namespace


FeedExt.Open Method

FeedExtOpen Method

Opens the current feed by opening all created sessions

Namespace: Sportradar.OddsFeed.SDK.API.Extended
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public void Open()

Implements

IOddsFeedOpen
Exceptions
Exception | Condition
ObjectDisposedException |
InvalidOperationException | The feed is already opened or The configuration is not valid
CommunicationException | Connection to the REST-ful API failed, Probable Reason={Invalid or expired token} or Connection to the message broker failed, Probable Reason={Invalid or expired token} or
See Also

Reference

FeedExt Class
Sportradar.OddsFeed.SDK.API.Extended Namespace


FeedExt Events

The FeedExt type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from Feed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop (Inherited from Feed)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from Feed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from Feed)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from Feed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from Feed)
Public event | RawApiDataReceived | Occurs when data from Sports API arrives
Public event | RawFeedMessageReceived | Occurs when any feed message arrives
Public event | RecoveryInitiated | Occurs when a recovery initiation completes (Inherited from Feed)
Top
See Also

Reference

FeedExt Class
Sportradar.OddsFeed.SDK.API.Extended Namespace


FeedExt.RawApiDataReceived Event

FeedExtRawApiDataReceived Event

Occurs when data from Sports API arrives

Namespace: Sportradar.OddsFeed.SDK.API.Extended
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public event EventHandler<RawApiDataEventArgs> RawApiDataReceived

Value

EventHandler RawApiDataEventArgs

Implements

IOddsFeedExtRawApiDataReceived
See Also

Reference

FeedExt Class
Sportradar.OddsFeed.SDK.API.Extended Namespace


FeedExt.RawFeedMessageReceived Event

FeedExtRawFeedMessageReceived Event

Occurs when any feed message arrives

Namespace: Sportradar.OddsFeed.SDK.API.Extended
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public event EventHandler<RawFeedMessageEventArgs> RawFeedMessageReceived

Value

EventHandler RawFeedMessageEventArgs

Implements

IOddsFeedExtRawFeedMessageReceived
See Also

Reference

FeedExt Class
Sportradar.OddsFeed.SDK.API.Extended Namespace


FeedExt Fields

The FeedExt type exposes the following members.

Fields
 | Name | Description
Protected field | FeedInitialized | The feed initialized (Inherited from Feed)
Protected field | UnityContainer | A IUnityContainer used to resolve (Inherited from Feed)
Top
See Also

Reference

FeedExt Class
Sportradar.OddsFeed.SDK.API.Extended Namespace


IOddsFeedExt Interface

Represent an extended unified odds feed

Namespace: Sportradar.OddsFeed.SDK.API.Extended
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsFeedExt : IOddsFeedV6,
    IOddsFeedV5, IOddsFeedV4, IOddsFeedV3, IOddsFeedV2, IOddsFeedV1,
    IOddsFeed, IDisposable

The IOddsFeedExt type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from IOddsFeedV1)
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from IOddsFeedV2)
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes (Inherited from IOddsFeedV4)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from IOddsFeedV2)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | IsOpen | Returns an indicator if the feed instance is opened or not (Inherited from IOddsFeedV6)
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop (Inherited from IOddsFeedV3)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from IOddsFeedV2)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Public event | RawApiDataReceived | Occurs when data from Sports API arrives
Public event | RawFeedMessageReceived | Occurs when any feed message arrives
Public event | RecoveryInitiated | Occurs when a recovery initiation completes (Inherited from IOddsFeedV5)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.API.Extended Namespace


IOddsFeedExt Properties

The IOddsFeedExt type exposes the following members.

Properties
 | Name | Description
Public property | BookingManager | Gets a IBookingManager instance used to perform various booking calendar operations (Inherited from IOddsFeed)
Public property | BookmakerDetails | Gets a IBookmakerDetails instance used to get info about bookmaker and token used (Inherited from IOddsFeedV1)
Public property | CashOutProbabilitiesProvider | Gets the ICashOutProbabilitiesProvider instance used to retrieve cash out probabilities for betting markets (Inherited from IOddsFeed)
Public property | CustomBetManager | Gets a ICustomBetManager instance used to perform various custom bet operations (Inherited from IOddsFeedV2)
Public property | EventChangeManager | Gets a IEventChangeManager instance used to automatically receive fixture and result changes (Inherited from IOddsFeedV4)
Public property | EventRecoveryRequestIssuer | Gets a IEventRecoveryRequestIssuer instance used to issue recovery requests to the feed (Inherited from IOddsFeed)
Public property | MarketDescriptionManager | Gets a IMarketDescriptionManager instance used to get info about available markets, and to get translations for markets and outcomes including outrights (Inherited from IOddsFeedV2)
Public property | ProducerManager | Gets a IProducerManager instance used to retrieve producer related data (Inherited from IOddsFeed)
Public property | SportDataProvider | Gets a ISportDataProvider instance used to retrieve sport related data from the feed (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedExt Interface
Sportradar.OddsFeed.SDK.API.Extended Namespace


IOddsFeedExt Methods

The IOddsFeedExt type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current feed by closing all created sessions and disposing of all resources associated with the current instance (Inherited from IOddsFeed)
Public method | CreateBuilder | Constructs and returns a new instance of IOddsFeedSessionBuilder (Inherited from IOddsFeed)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable)
Public method | IsOpen | Returns an indicator if the feed instance is opened or not (Inherited from IOddsFeedV6)
Public method | Open | Opens the current feed by opening all created sessions (Inherited from IOddsFeed)
Top
See Also

Reference

IOddsFeedExt Interface
Sportradar.OddsFeed.SDK.API.Extended Namespace


IOddsFeedExt Events

The IOddsFeedExt type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when feed is closed (Inherited from IOddsFeed)
Public event | ConnectionException | Occurs when an exception occurs in the connection loop (Inherited from IOddsFeedV3)
Public event | Disconnected | Raised when the current instance of IOddsFeed loses connection to the feed (Inherited from IOddsFeed)
Public event | EventRecoveryCompleted | Occurs when a requested event recovery completes (Inherited from IOddsFeedV2)
Public event | ProducerDown | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went down (Inherited from IOddsFeed)
Public event | ProducerUp | Raised when the current IOddsFeed instance determines that the IProducer associated with the odds feed went up (back online) (Inherited from IOddsFeed)
Public event | RawApiDataReceived | Occurs when data from Sports API arrives
Public event | RawFeedMessageReceived | Occurs when any feed message arrives
Public event | RecoveryInitiated | Occurs when a recovery initiation completes (Inherited from IOddsFeedV5)
Top
See Also

Reference

IOddsFeedExt Interface
Sportradar.OddsFeed.SDK.API.Extended Namespace


IOddsFeedExt.RawApiDataReceived Event

IOddsFeedExtRawApiDataReceived Event

Occurs when data from Sports API arrives

Namespace: Sportradar.OddsFeed.SDK.API.Extended
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<RawApiDataEventArgs> RawApiDataReceived

Value

EventHandler RawApiDataEventArgs
See Also

Reference

IOddsFeedExt Interface
Sportradar.OddsFeed.SDK.API.Extended Namespace


IOddsFeedExt.RawFeedMessageReceived Event

IOddsFeedExtRawFeedMessageReceived Event

Occurs when any feed message arrives

Namespace: Sportradar.OddsFeed.SDK.API.Extended
Assembly: Sportradar.OddsFeed.SDK.API (in Sportradar.OddsFeed.SDK.API.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
event EventHandler<RawFeedMessageEventArgs> RawFeedMessageReceived

Value

EventHandler RawFeedMessageEventArgs
See Also

Reference

IOddsFeedExt Interface
Sportradar.OddsFeed.SDK.API.Extended Namespace


Sportradar.OddsFeed.SDK.Common Namespace

Classes
 | Class | Description
Public class | ExecutionHelper | Helper for execution actions
Public class | OperationManager | Defines methods used to get or set various values for sdk operations
Public class | SdkLoggerFactory | Provides methods to get logger for specific LoggerType
Interfaces
 | Interface | Description
Public interface | IOpenable | Defines a contract implemented by classes which can be opened and closed
Enumerations
 | Enumeration | Description
Public enumeration | ExceptionHandlingStrategy | Enumerates sdk exception handling strategies
Public enumeration | SdkEnvironment | Enumeration of all possible environments


ExceptionHandlingStrategy Enumeration

Enumerates sdk exception handling strategies

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum ExceptionHandlingStrategy
Members
Member name | Value | Description
THROW | 0 | Specifies a strategy in which none of the exceptions are thrown to caller
CATCH | 1 | Specifies a strategy in which all exceptions are handled by the called instance
See Also

Reference

Sportradar.OddsFeed.SDK.Common Namespace


ExecutionHelper Class

Helper for execution actions
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.CommonExecutionHelper

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static class ExecutionHelper

The ExecutionHelper type exposes the following members.

Methods
Name | Description
Safe | Try to safely execute action (exception ignored)
SafeAsync | Try to safely execute action (exception ignored)
WaitToComplete | Try to execute action till success or timeout
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Common Namespace


ExecutionHelper Methods

The ExecutionHelper type exposes the following members.

Methods
Name | Description
Safe | Try to safely execute action (exception ignored)
SafeAsync | Try to safely execute action (exception ignored)
WaitToComplete | Try to execute action till success or timeout
Top
See Also

Reference

ExecutionHelper Class
Sportradar.OddsFeed.SDK.Common Namespace


ExecutionHelper.Safe Method

ExecutionHelperSafe Method

Try to safely execute action (exception ignored)

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static bool Safe(
    Action action
)

Parameters

action Action
Action to be invoked

Return Value

Boolean
Indication if the action completed successfully
See Also

Reference

ExecutionHelper Class
Sportradar.OddsFeed.SDK.Common Namespace


ExecutionHelper.SafeAsync Method

ExecutionHelperSafeAsync Method

Try to safely execute action (exception ignored)

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static Task<bool> SafeAsync(
    Action action
)

Parameters

action Action
Action to be invoked

Return Value

Task Boolean
Indication if the action completed successfully
See Also

Reference

ExecutionHelper Class
Sportradar.OddsFeed.SDK.Common Namespace


ExecutionHelper.WaitToComplete Method

ExecutionHelperWaitToComplete Method

Try to execute action till success or timeout

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static bool WaitToComplete(
    Action action,
    int timeoutMs = 10000
)

Parameters

action Action
Action to be invoked
timeoutMs Int32 (Optional)
Maximum execution time

Return Value

Boolean
Indication if the action completed successfully
See Also

Reference

ExecutionHelper Class
Sportradar.OddsFeed.SDK.Common Namespace


IOpenable Interface

Defines a contract implemented by classes which can be opened and closed

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOpenable

The IOpenable type exposes the following members.

Properties
 | Name | Description
Public property | IsOpened | Gets a value indicating whether the current instance is opened
Top
Methods
 | Name | Description
Public method | Close | Closes the current instance
Public method | Open | Opens the current instance
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Common Namespace


IOpenable Properties

The IOpenable type exposes the following members.

Properties
 | Name | Description
Public property | IsOpened | Gets a value indicating whether the current instance is opened
Top
See Also

Reference

IOpenable Interface
Sportradar.OddsFeed.SDK.Common Namespace


IOpenable.IsOpened Property

IOpenableIsOpened Property

Gets a value indicating whether the current instance is opened

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsOpened { get; }

Property Value

Boolean
See Also

Reference

IOpenable Interface
Sportradar.OddsFeed.SDK.Common Namespace


IOpenable Methods

The IOpenable type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current instance
Public method | Open | Opens the current instance
Top
See Also

Reference

IOpenable Interface
Sportradar.OddsFeed.SDK.Common Namespace


IOpenable.Close Method

IOpenableClose Method

Closes the current instance

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void Close()
See Also

Reference

IOpenable Interface
Sportradar.OddsFeed.SDK.Common Namespace


IOpenable.Open Method

IOpenableOpen Method

Opens the current instance

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void Open()
See Also

Reference

IOpenable Interface
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager Class

Defines methods used to get or set various values for sdk operations
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.CommonOperationManager

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static class OperationManager

The OperationManager type exposes the following members.

Properties
Name | Description
FastHttpClientTimeout | Gets a timeout for HttpClient for fast api request (in seconds).
IgnoreBetPalTimelineSportEventStatus | Gets a value indicating whether to ignore sport event status from timeline endpoint for sport events on BetPal producer
IgnoreBetPalTimelineSportEventStatusCacheTimeout | Gets the ignore BetPal timeline sport event status cache timeout - how long cache item is cached. How long should the event id from BetPal producer be cached. SportEventStatus from timeline endpoint for these events are ignored.
MaxConnectionsPerServer | Gets the maximum number of concurrent connections (per server endpoint) allowed by an HttpClient object.
ProfileCacheTimeout | Gets the competitor/player cache timeout - how long cache item is cached
RabbitConnectionTimeout | Gets a rabbit timeout setting for connection attempts (in seconds).
RabbitHeartbeat | Gets a heartbeat timeout to use when negotiating with the server (in seconds).
SportEventStatusCacheTimeout | Gets the sport event status cache timeout - how long status is cached
VariantMarketDescriptionCacheTimeout | Gets the variant market description cache timeout - how long cache item is cached
Top
Methods
Name | Description
SetFastHttpClientTimeout | Sets a timeout for HttpClient for fast api request (in seconds).
SetIgnoreBetPalTimelineSportEventStatus | Sets the value indicating whether to ignore sport event status from timeline endpoint for sport events on BetPal producer
SetIgnoreBetPalTimelineSportEventStatusCacheTimeout | Sets the ignore BetPal timeline sport event status cache timeout. How long should the event id from BetPal be cached. SportEventStatus from timeline endpoint for these events are ignored.
SetMaxConnectionsPerServer | Sets the maximum number of concurrent connections (per server endpoint) allowed by an HttpClient object.
SetProfileCacheTimeout | Sets the profile cache timeout.
SetRabbitConnectionTimeout | Sets the rabbit timeout setting for connection attempts (in seconds).
SetRabbitHeartbeat | Sets a heartbeat timeout to use when negotiating with the rabbit server (in seconds).
SetSportEventStatusCacheTimeout | Sets the sport event status cache timeout
SetVariantMarketDescriptionCacheTimeout | Sets the variant market description cache timeout
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Common Namespace


OperationManager Properties

The OperationManager type exposes the following members.

Properties
Name | Description
FastHttpClientTimeout | Gets a timeout for HttpClient for fast api request (in seconds).
IgnoreBetPalTimelineSportEventStatus | Gets a value indicating whether to ignore sport event status from timeline endpoint for sport events on BetPal producer
IgnoreBetPalTimelineSportEventStatusCacheTimeout | Gets the ignore BetPal timeline sport event status cache timeout - how long cache item is cached. How long should the event id from BetPal producer be cached. SportEventStatus from timeline endpoint for these events are ignored.
MaxConnectionsPerServer | Gets the maximum number of concurrent connections (per server endpoint) allowed by an HttpClient object.
ProfileCacheTimeout | Gets the competitor/player cache timeout - how long cache item is cached
RabbitConnectionTimeout | Gets a rabbit timeout setting for connection attempts (in seconds).
RabbitHeartbeat | Gets a heartbeat timeout to use when negotiating with the server (in seconds).
SportEventStatusCacheTimeout | Gets the sport event status cache timeout - how long status is cached
VariantMarketDescriptionCacheTimeout | Gets the variant market description cache timeout - how long cache item is cached
Top
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.FastHttpClientTimeout Property

OperationManagerFastHttpClientTimeout Property

Gets a timeout for HttpClient for fast api request (in seconds).

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static TimeSpan FastHttpClientTimeout { get; }

Property Value

TimeSpan
A timeout for HttpClient for fast api request (in seconds).
Remarks
Between 1 and 30 (default 5s). Used for summary, competitor profile, player profile and variant description endpoint. Must be set before feed instance is created.
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.IgnoreBetPalTimelineSportEventStatus Property

OperationManagerIgnoreBetPalTimelineSportEventStatus Property

Gets a value indicating whether to ignore sport event status from timeline endpoint for sport events on BetPal producer

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static bool IgnoreBetPalTimelineSportEventStatus { get; }

Property Value

Boolean
true if sport event status from timeline endpoint should be ignored, otherwise false.
Remarks
Default false
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.IgnoreBetPalTimelineSportEventStatusCacheTimeout Property

OperationManagerIgnoreBetPalTimelineSportEventStatusCacheTimeout Property

Gets the ignore BetPal timeline sport event status cache timeout - how long cache item is cached. How long should the event id from BetPal producer be cached. SportEventStatus from timeline endpoint for these events are ignored.

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static TimeSpan IgnoreBetPalTimelineSportEventStatusCacheTimeout { get; }

Property Value

TimeSpan
The ignore BetPal timeline sport event status timeout.
Remarks
Can be between 1 hour and 24 hours - default 3 hours (sliding expiration)
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.MaxConnectionsPerServer Property

OperationManagerMaxConnectionsPerServer Property

Gets the maximum number of concurrent connections (per server endpoint) allowed by an HttpClient object.

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static int MaxConnectionsPerServer { get; }

Property Value

Int32
Remarks
At feed initialization sets the ServicePointManager.DefaultConnectionLimit
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.ProfileCacheTimeout Property

OperationManagerProfileCacheTimeout Property

Gets the competitor/player cache timeout - how long cache item is cached

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static TimeSpan ProfileCacheTimeout { get; }

Property Value

TimeSpan
The competitor/player cache timeout.
Remarks
Can be between 1 hour and 48 hours - default 24 hours (sliding expiration)
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.RabbitConnectionTimeout Property

OperationManagerRabbitConnectionTimeout Property

Gets a rabbit timeout setting for connection attempts (in seconds).

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static int RabbitConnectionTimeout { get; }

Property Value

Int32
A rabbit timeout setting for connection attempts (in seconds).
Remarks
Between 10 and 120 (default 30s)
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.RabbitHeartbeat Property

OperationManagerRabbitHeartbeat Property

Gets a heartbeat timeout to use when negotiating with the server (in seconds).

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static int RabbitHeartbeat { get; }

Property Value

Int32
A heartbeat timeout to use when negotiating with the server (in seconds).
Remarks
Between 10 and 180 (default 60s)
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.SportEventStatusCacheTimeout Property

OperationManagerSportEventStatusCacheTimeout Property

Gets the sport event status cache timeout - how long status is cached

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static TimeSpan SportEventStatusCacheTimeout { get; }

Property Value

TimeSpan
The sport event status cache timeout.
Remarks
Can be between 1 min and 60 min - default 5 min (absolute expiration)
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.VariantMarketDescriptionCacheTimeout Property

OperationManagerVariantMarketDescriptionCacheTimeout Property

Gets the variant market description cache timeout - how long cache item is cached

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static TimeSpan VariantMarketDescriptionCacheTimeout { get; }

Property Value

TimeSpan
The variant market description cache timeout.
Remarks
Can be between 1 hour and 24 hours - default 3 hours (sliding expiration)
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager Methods

The OperationManager type exposes the following members.

Methods
Name | Description
SetFastHttpClientTimeout | Sets a timeout for HttpClient for fast api request (in seconds).
SetIgnoreBetPalTimelineSportEventStatus | Sets the value indicating whether to ignore sport event status from timeline endpoint for sport events on BetPal producer
SetIgnoreBetPalTimelineSportEventStatusCacheTimeout | Sets the ignore BetPal timeline sport event status cache timeout. How long should the event id from BetPal be cached. SportEventStatus from timeline endpoint for these events are ignored.
SetMaxConnectionsPerServer | Sets the maximum number of concurrent connections (per server endpoint) allowed by an HttpClient object.
SetProfileCacheTimeout | Sets the profile cache timeout.
SetRabbitConnectionTimeout | Sets the rabbit timeout setting for connection attempts (in seconds).
SetRabbitHeartbeat | Sets a heartbeat timeout to use when negotiating with the rabbit server (in seconds).
SetSportEventStatusCacheTimeout | Sets the sport event status cache timeout
SetVariantMarketDescriptionCacheTimeout | Sets the variant market description cache timeout
Top
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.SetFastHttpClientTimeout Method

OperationManagerSetFastHttpClientTimeout Method

Sets a timeout for HttpClient for fast api request (in seconds).

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static void SetFastHttpClientTimeout(
    TimeSpan timeout
)

Parameters

timeout TimeSpan
The timeout to be set
Remarks
Between 1 and 30 (default 5s) - set before connection is made.
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.SetIgnoreBetPalTimelineSportEventStatus Method

OperationManagerSetIgnoreBetPalTimelineSportEventStatus Method

Sets the value indicating whether to ignore sport event status from timeline endpoint for sport events on BetPal producer

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static void SetIgnoreBetPalTimelineSportEventStatus(
    bool ignore
)

Parameters

ignore Boolean
if set to true ignore
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.SetIgnoreBetPalTimelineSportEventStatusCacheTimeout Method

OperationManagerSetIgnoreBetPalTimelineSportEventStatusCacheTimeout Method

Sets the ignore BetPal timeline sport event status cache timeout. How long should the event id from BetPal be cached. SportEventStatus from timeline endpoint for these events are ignored.

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static void SetIgnoreBetPalTimelineSportEventStatusCacheTimeout(
    TimeSpan timeout
)

Parameters

timeout TimeSpan
The timeout.
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.SetMaxConnectionsPerServer Method

OperationManagerSetMaxConnectionsPerServer Method

Sets the maximum number of concurrent connections (per server endpoint) allowed by an HttpClient object.

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static void SetMaxConnectionsPerServer(
    int maxConnectionsPerServer
)

Parameters

maxConnectionsPerServer Int32
The new maximum number of concurrent connections (per server endpoint) allowed by an HttpClient object.
Remarks
Sets the ServicePointManager.DefaultConnectionLimit
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.SetProfileCacheTimeout Method

OperationManagerSetProfileCacheTimeout Method

Sets the profile cache timeout.

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static void SetProfileCacheTimeout(
    TimeSpan timeout
)

Parameters

timeout TimeSpan
The timeout.
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.SetRabbitConnectionTimeout Method

OperationManagerSetRabbitConnectionTimeout Method

Sets the rabbit timeout setting for connection attempts (in seconds).

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static void SetRabbitConnectionTimeout(
    int rabbitConnectionTimeout
)

Parameters

rabbitConnectionTimeout Int32
The rabbit timeout setting for connection attempts (in seconds)
Remarks
Between 10 and 120 (default 30s) - set before connection is made
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.SetRabbitHeartbeat Method

OperationManagerSetRabbitHeartbeat Method

Sets a heartbeat timeout to use when negotiating with the rabbit server (in seconds).

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static void SetRabbitHeartbeat(
    int rabbitHeartbeat
)

Parameters

rabbitHeartbeat Int32
The heartbeat timeout to use when negotiating with the rabbit server (in seconds).
Remarks
Between 10 and 180 (default 60s) - set before connection is made
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.SetSportEventStatusCacheTimeout Method

OperationManagerSetSportEventStatusCacheTimeout Method

Sets the sport event status cache timeout

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static void SetSportEventStatusCacheTimeout(
    TimeSpan timeout
)

Parameters

timeout TimeSpan
The timeout.
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


OperationManager.SetVariantMarketDescriptionCacheTimeout Method

OperationManagerSetVariantMarketDescriptionCacheTimeout Method

Sets the variant market description cache timeout

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static void SetVariantMarketDescriptionCacheTimeout(
    TimeSpan timeout
)

Parameters

timeout TimeSpan
The timeout.
See Also

Reference

OperationManager Class
Sportradar.OddsFeed.SDK.Common Namespace


SdkEnvironment Enumeration

Enumeration of all possible environments

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum SdkEnvironment
Members
Member name | Value | Description
Staging | 0 | Obsolete. The staging
Production | 1 | The production
Custom | 2 | The custom
Replay | 3 | The replay
Integration | 4 | The integration
GlobalProduction | 5 | The global production
GlobalIntegration | 6 | The global integration
ProxySingapore | 7 | The Singapore proxy
ProxyTokyo | 8 | The Tokyo proxy
See Also

Reference

Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory Class

Provides methods to get logger for specific LoggerType
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.CommonSdkLoggerFactory

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static class SdkLoggerFactory

The SdkLoggerFactory type exposes the following members.

Methods
Name | Description
CheckAllLoggersExists | Obsolete. Method checks if all loggers are created for each LoggerType
Configure | Obsolete. Configures the LogManager for SDK
GetLogger | Method for getting correct ILog for specific logger type
GetLoggerForCache | Method for getting log4net.ILog for cache
GetLoggerForClientInteraction | Method for getting log4net.ILog for client iteration
GetLoggerForExecution | Method for getting log4net.ILog for execution
GetLoggerForFeedTraffic | Method for getting log4net.ILog for feed traffic
GetLoggerForRestTraffic | Method for getting log4net.ILog for rest traffic
GetLoggerForStats | Method for getting log4net.ILog for statistics
GetLoggerLogLevel | Get the logger level
GetWriteLogLevel | Get write logger level
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory Methods

The SdkLoggerFactory type exposes the following members.

Methods
Name | Description
CheckAllLoggersExists | Obsolete. Method checks if all loggers are created for each LoggerType
Configure | Obsolete. Configures the LogManager for SDK
GetLogger | Method for getting correct ILog for specific logger type
GetLoggerForCache | Method for getting log4net.ILog for cache
GetLoggerForClientInteraction | Method for getting log4net.ILog for client iteration
GetLoggerForExecution | Method for getting log4net.ILog for execution
GetLoggerForFeedTraffic | Method for getting log4net.ILog for feed traffic
GetLoggerForRestTraffic | Method for getting log4net.ILog for rest traffic
GetLoggerForStats | Method for getting log4net.ILog for statistics
GetLoggerLogLevel | Get the logger level
GetWriteLogLevel | Get write logger level
Top
See Also

Reference

SdkLoggerFactory Class
Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory.CheckAllLoggersExists Method

SdkLoggerFactoryCheckAllLoggersExists Method

Note: This API is now obsolete.

Method checks if all loggers are created for each LoggerType

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("This method is no longer required since the SDK uses Common.Logging facade")]
public static bool CheckAllLoggersExists(
    string repositoryName = "Sportradar.OddsFeed.SDK"
)

Parameters

repositoryName String (Optional)
Repository containing the loggers

Return Value

Boolean
Returns value indicating if all sdk defined loggers exists
See Also

Reference

SdkLoggerFactory Class
Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory.Configure Method

SdkLoggerFactoryConfigure Method

Note: This API is now obsolete.

Configures the LogManager for SDK

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("This method is no longer required since the SDK uses Common.Logging facade")]
public static void Configure(
    FileInfo configFile,
    string repositoryName = "Sportradar.OddsFeed.SDK"
)

Parameters

configFile FileInfo
The configuration file.
repositoryName String (Optional)
Repository name to be created containing the SDK loggers
See Also

Reference

SdkLoggerFactory Class
Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory.GetLogger Method

SdkLoggerFactoryGetLogger Method

Method for getting correct ILog for specific logger type

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static ILog GetLogger(
    Type type,
    string repositoryName = "Sportradar.OddsFeed.SDK",
    LoggerType loggerType = LoggerType.Execution
)

Parameters

type Type
A type to be used for creating new ILog
repositoryName String (Optional)
Repository containing the logger
loggerType LoggerType (Optional)
A value of LoggerType to be used to get ILog

Return Value

ILog
Returns ILog with specific settings for this LoggerType
See Also

Reference

SdkLoggerFactory Class
Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory.GetLoggerForCache Method

SdkLoggerFactoryGetLoggerForCache Method

Method for getting log4net.ILog for cache

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static ILog GetLoggerForCache(
    Type type,
    string repositoryName = "Sportradar.OddsFeed.SDK"
)

Parameters

type Type
A type to be used for creating new ILog
repositoryName String (Optional)
Repository containing the logger

Return Value

ILog
Returns default ILog with specified settings
See Also

Reference

SdkLoggerFactory Class
Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory.GetLoggerForClientInteraction Method

SdkLoggerFactoryGetLoggerForClientInteraction Method

Method for getting log4net.ILog for client iteration

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static ILog GetLoggerForClientInteraction(
    Type type,
    string repositoryName = "Sportradar.OddsFeed.SDK"
)

Parameters

type Type
A type to be used for creating new ILog
repositoryName String (Optional)
Repository containing the logger

Return Value

ILog
Returns default ILog with specified settings
See Also

Reference

SdkLoggerFactory Class
Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory.GetLoggerForExecution Method

SdkLoggerFactoryGetLoggerForExecution Method

Method for getting log4net.ILog for execution

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static ILog GetLoggerForExecution(
    Type type,
    string repositoryName = "Sportradar.OddsFeed.SDK"
)

Parameters

type Type
A type to be used for creating new ILog
repositoryName String (Optional)
Repository containing the logger

Return Value

ILog
Returns default ILog with specified settings
See Also

Reference

SdkLoggerFactory Class
Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory.GetLoggerForFeedTraffic Method

SdkLoggerFactoryGetLoggerForFeedTraffic Method

Method for getting log4net.ILog for feed traffic

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static ILog GetLoggerForFeedTraffic(
    Type type,
    string repositoryName = "Sportradar.OddsFeed.SDK"
)

Parameters

type Type
A type to be used for creating new ILog
repositoryName String (Optional)
Repository containing the logger

Return Value

ILog
Returns default ILog with specified settings
See Also

Reference

SdkLoggerFactory Class
Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory.GetLoggerForRestTraffic Method

SdkLoggerFactoryGetLoggerForRestTraffic Method

Method for getting log4net.ILog for rest traffic

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static ILog GetLoggerForRestTraffic(
    Type type,
    string repositoryName = "Sportradar.OddsFeed.SDK"
)

Parameters

type Type
A type to be used for creating new ILog
repositoryName String (Optional)
Repository containing the logger

Return Value

ILog
Returns default ILog with specified settings
See Also

Reference

SdkLoggerFactory Class
Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory.GetLoggerForStats Method

SdkLoggerFactoryGetLoggerForStats Method

Method for getting log4net.ILog for statistics

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static ILog GetLoggerForStats(
    Type type,
    string repositoryName = "Sportradar.OddsFeed.SDK"
)

Parameters

type Type
A type to be used for creating new ILog
repositoryName String (Optional)
Repository containing the logger

Return Value

ILog
Returns default ILog with specified settings
See Also

Reference

SdkLoggerFactory Class
Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory.GetLoggerLogLevel Method

SdkLoggerFactoryGetLoggerLogLevel Method

Get the logger level

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static LogLevel GetLoggerLogLevel(
    ILog logger
)

Parameters

logger ILog
The logger to check

Return Value

LogLevel
The log level supported by the logger
See Also

Reference

SdkLoggerFactory Class
Sportradar.OddsFeed.SDK.Common Namespace


SdkLoggerFactory.GetWriteLogLevel Method

SdkLoggerFactoryGetWriteLogLevel Method

Get write logger level

Namespace: Sportradar.OddsFeed.SDK.Common
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static LogLevel GetWriteLogLevel(
    ILog logger,
    LogLevel minLevel
)

Parameters

logger ILog
The logger to check
minLevel LogLevel
The minimum log level

Return Value

LogLevel
The log level supported by the logger which is not lower then specified minimum level
See Also

Reference

SdkLoggerFactory Class
Sportradar.OddsFeed.SDK.Common Namespace


Sportradar.OddsFeed.SDK.Common.Exceptions Namespace

Classes
 | Class | Description
Public class | CacheItemNotFoundException | An exception thrown by the SDK cache components when the requested key was not found in the cache
Public class | CommunicationException | An exception thrown by the SDK when an error occurred while communicating with external source (Feed REST-ful API)
Public class | DeserializationException | An exception thrown by the SDK when a deserialization of the xml received from the feed fails
Public class | FeedSdkException | A base class for all exceptions thrown by the feed SDK
Public class | MappingException | An exception thrown by the SDK when the entity received from the feed could not be mapped to entity used by the SDK
Public class | NameExpressionException | An exception thrown by name expressions when the name cannot be build
Public class | NameGenerationException | An exception when the name for a market or outcome could not be generated
Public class | ObjectNotFoundException | An exception thrown when the requested object is not found


CacheItemNotFoundException Class

An exception thrown by the SDK cache components when the requested key was not found in the cache
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.OddsFeed.SDK.Common.ExceptionsFeedSdkException
Sportradar.OddsFeed.SDK.Common.ExceptionsCacheItemNotFoundException

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class CacheItemNotFoundException : FeedSdkException

The CacheItemNotFoundException type exposes the following members.

Constructors
 | Name | Description
Public method | CacheItemNotFoundException | Initializes a new instance of the CacheItemNotFoundException class.
Public method | CacheItemNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the CacheItemNotFoundException class.
Public method | CacheItemNotFoundException(String, String, Exception) | Initializes a new instance of the CacheItemNotFoundException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Key | Gets the key requested key
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ExceptionToString)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Common.Exceptions Namespace
FeedSdkException


CacheItemNotFoundException Constructor

Overload List
 | Name | Description
Public method | CacheItemNotFoundException | Initializes a new instance of the CacheItemNotFoundException class.
Public method | CacheItemNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the CacheItemNotFoundException class.
Public method | CacheItemNotFoundException(String, String, Exception) | Initializes a new instance of the CacheItemNotFoundException class.
Top
See Also

Reference

CacheItemNotFoundException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CacheItemNotFoundException Constructor

Initializes a new instance of the CacheItemNotFoundException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CacheItemNotFoundException()
See Also

Reference

CacheItemNotFoundException Class
CacheItemNotFoundException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CacheItemNotFoundException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the CacheItemNotFoundException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CacheItemNotFoundException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

CacheItemNotFoundException Class
CacheItemNotFoundException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CacheItemNotFoundException(String, String, Exception) Constructor

Initializes a new instance of the CacheItemNotFoundException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CacheItemNotFoundException(
    string message,
    string key,
    Exception innerException
)

Parameters

message String
The error message that explains the reason for the exception.
key String
The key requested key
innerException Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

CacheItemNotFoundException Class
CacheItemNotFoundException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CacheItemNotFoundException Properties

The CacheItemNotFoundException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Key | Gets the key requested key
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

CacheItemNotFoundException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CacheItemNotFoundException.Key Property

CacheItemNotFoundExceptionKey Property

Gets the key requested key

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Key { get; }

Property Value

String
The key.
See Also

Reference

CacheItemNotFoundException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CacheItemNotFoundException Methods

The CacheItemNotFoundException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ExceptionToString)
Top
See Also

Reference

CacheItemNotFoundException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CacheItemNotFoundException.GetObjectData Method

CacheItemNotFoundExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CacheItemNotFoundException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CacheItemNotFoundException.ToString Method

CacheItemNotFoundExceptionToString Method

Returns a String that represents this instance.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
A String that represents this instance.

Implements

_ExceptionToString
See Also

Reference

CacheItemNotFoundException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CacheItemNotFoundException Events

The CacheItemNotFoundException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

CacheItemNotFoundException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException Class

An exception thrown by the SDK when an error occurred while communicating with external source (Feed REST-ful API)
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.OddsFeed.SDK.Common.ExceptionsFeedSdkException
Sportradar.OddsFeed.SDK.Common.ExceptionsCommunicationException

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class CommunicationException : FeedSdkException

The CommunicationException type exposes the following members.

Constructors
 | Name | Description
Public method | CommunicationException | Initializes a new instance of the CommunicationException class.
Public method | CommunicationException(SerializationInfo, StreamingContext) | Initializes a new instance of the CommunicationException class.
Public method | CommunicationException(String, String, Exception) | Initializes a new instance of the CommunicationException class.
Public method | CommunicationException(String, String, HttpStatusCode, Exception) | Initializes a new instance of the CommunicationException class.
Public method | CommunicationException(String, String, HttpStatusCode, String, Exception) | Initializes a new instance of the CommunicationException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | Url | Gets the String representation of the url specifying the resource which was being accessed
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ExceptionToString)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
Fields
 | Name | Description
Public field | Response | Gets the String representation of the response received from the external source
Public field | ResponseCode | Gets the HttpStatusCode specifying the response's status code
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Common.Exceptions Namespace
FeedSdkException


CommunicationException Constructor

Overload List
 | Name | Description
Public method | CommunicationException | Initializes a new instance of the CommunicationException class.
Public method | CommunicationException(SerializationInfo, StreamingContext) | Initializes a new instance of the CommunicationException class.
Public method | CommunicationException(String, String, Exception) | Initializes a new instance of the CommunicationException class.
Public method | CommunicationException(String, String, HttpStatusCode, Exception) | Initializes a new instance of the CommunicationException class.
Public method | CommunicationException(String, String, HttpStatusCode, String, Exception) | Initializes a new instance of the CommunicationException class.
Top
See Also

Reference

CommunicationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException Constructor

Initializes a new instance of the CommunicationException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CommunicationException()
See Also

Reference

CommunicationException Class
CommunicationException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the CommunicationException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CommunicationException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

CommunicationException Class
CommunicationException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException(String, String, Exception) Constructor

Initializes a new instance of the CommunicationException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CommunicationException(
    string message,
    string url,
    Exception innerException
)

Parameters

message String
The error message that explains the reason for the exception.
url String
The String representation of the url specifying the resource which was being accessed .
innerException Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

CommunicationException Class
CommunicationException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException(String, String, HttpStatusCode, Exception) Constructor

Initializes a new instance of the CommunicationException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CommunicationException(
    string message,
    string url,
    HttpStatusCode responseCode,
    Exception innerException
)

Parameters

message String
The error message that explains the reason for the exception.
url String
The String representation of the url specifying the resource which was being accessed .
responseCode HttpStatusCode
A HttpStatusCode specifying the response code
innerException Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

CommunicationException Class
CommunicationException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException(String, String, HttpStatusCode, String, Exception) Constructor

Initializes a new instance of the CommunicationException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CommunicationException(
    string message,
    string url,
    HttpStatusCode responseCode,
    string response,
    Exception innerException
)

Parameters

message String
The error message that explains the reason for the exception.
url String
The String representation of the url specifying the resource which was being accessed .
responseCode HttpStatusCode
A HttpStatusCode specifying the response code
response String
A String representation of the response received from the external source
innerException Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

CommunicationException Class
CommunicationException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException Properties

The CommunicationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | Url | Gets the String representation of the url specifying the resource which was being accessed
Top
See Also

Reference

CommunicationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException.Url Property

CommunicationExceptionUrl Property

Gets the String representation of the url specifying the resource which was being accessed

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Url { get; }

Property Value

String
The URL.
See Also

Reference

CommunicationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException Methods

The CommunicationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ExceptionToString)
Top
See Also

Reference

CommunicationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException.GetObjectData Method

CommunicationExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommunicationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException.ToString Method

CommunicationExceptionToString Method

Returns a String that represents this instance.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
A String that represents this instance.

Implements

_ExceptionToString
See Also

Reference

CommunicationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException Events

The CommunicationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

CommunicationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException Fields

The CommunicationException type exposes the following members.

Fields
 | Name | Description
Public field | Response | Gets the String representation of the response received from the external source
Public field | ResponseCode | Gets the HttpStatusCode specifying the response's status code
Top
See Also

Reference

CommunicationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException.Response Field

CommunicationExceptionResponse Field

Gets the String representation of the response received from the external source

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public readonly string Response

Field Value

String
See Also

Reference

CommunicationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


CommunicationException.ResponseCode Field

CommunicationExceptionResponseCode Field

Gets the HttpStatusCode specifying the response's status code

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public readonly HttpStatusCode ResponseCode

Field Value

HttpStatusCode
See Also

Reference

CommunicationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


DeserializationException Class

An exception thrown by the SDK when a deserialization of the xml received from the feed fails
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.OddsFeed.SDK.Common.ExceptionsFeedSdkException
Sportradar.OddsFeed.SDK.Common.ExceptionsDeserializationException

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class DeserializationException : FeedSdkException

The DeserializationException type exposes the following members.

Constructors
 | Name | Description
Public method | DeserializationException | Initializes a new instance of the DeserializationException class.
Public method | DeserializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the DeserializationException class.
Public method | DeserializationException(String, Exception) | Initializes a new instance of the DeserializationException class.
Public method | DeserializationException(String, String, String, Exception) | Initializes a new instance of the DeserializationException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | RootElementName | Gets the name of the root xml element associated with the exception or a null reference if element name could not be determined
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | Xml | Gets the data which could not be deserialized
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ExceptionToString)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Common.Exceptions Namespace
FeedSdkException


DeserializationException Constructor

Overload List
 | Name | Description
Public method | DeserializationException | Initializes a new instance of the DeserializationException class.
Public method | DeserializationException(SerializationInfo, StreamingContext) | Initializes a new instance of the DeserializationException class.
Public method | DeserializationException(String, Exception) | Initializes a new instance of the DeserializationException class.
Public method | DeserializationException(String, String, String, Exception) | Initializes a new instance of the DeserializationException class.
Top
See Also

Reference

DeserializationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


DeserializationException Constructor

Initializes a new instance of the DeserializationException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DeserializationException()
See Also

Reference

DeserializationException Class
DeserializationException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


DeserializationException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the DeserializationException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DeserializationException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

DeserializationException Class
DeserializationException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


DeserializationException(String, Exception) Constructor

Initializes a new instance of the DeserializationException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DeserializationException(
    string message,
    Exception innerException
)

Parameters

message String
The error message that explains the reason for the exception.
innerException Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

DeserializationException Class
DeserializationException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


DeserializationException(String, String, String, Exception) Constructor

Initializes a new instance of the DeserializationException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DeserializationException(
    string message,
    string xml,
    string rootElementName,
    Exception innerException
)

Parameters

message String
The error message that explains the reason for the exception.
xml String
The data which could not be deserialized
rootElementName String
The name of the root xml element associated with the exception or a null reference if element name could not be determined
innerException Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

DeserializationException Class
DeserializationException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


DeserializationException Properties

The DeserializationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | RootElementName | Gets the name of the root xml element associated with the exception or a null reference if element name could not be determined
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | Xml | Gets the data which could not be deserialized
Top
See Also

Reference

DeserializationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


DeserializationException.RootElementName Property

DeserializationExceptionRootElementName Property

Gets the name of the root xml element associated with the exception or a null reference if element name could not be determined

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string RootElementName { get; }

Property Value

String
The name of the root element.
See Also

Reference

DeserializationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


DeserializationException.Xml Property

DeserializationExceptionXml Property

Gets the data which could not be deserialized

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Xml { get; }

Property Value

String
The XML.
See Also

Reference

DeserializationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


DeserializationException Methods

The DeserializationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ExceptionToString)
Top
See Also

Reference

DeserializationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


DeserializationException.GetObjectData Method

DeserializationExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DeserializationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


DeserializationException.ToString Method

DeserializationExceptionToString Method

Returns a String that represents this instance.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
A String that represents this instance.

Implements

_ExceptionToString
See Also

Reference

DeserializationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


DeserializationException Events

The DeserializationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

DeserializationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


FeedSdkException Class

A base class for all exceptions thrown by the feed SDK
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.OddsFeed.SDK.Common.ExceptionsFeedSdkException
More

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public abstract class FeedSdkException : Exception

The FeedSdkException type exposes the following members.

Constructors
 | Name | Description
Protected method | FeedSdkException | Initializes a new instance of the FeedSdkException class.
Protected method | FeedSdkException(SerializationInfo, StreamingContext) | Initializes a new instance of the FeedSdkException class.
Protected method | FeedSdkException(String, Exception) | Initializes a new instance of the FeedSdkException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Common.Exceptions Namespace
Exception
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.OddsFeed.SDK.Common.ExceptionsFeedSdkException
Sportradar.OddsFeed.SDK.Common.ExceptionsCacheItemNotFoundException
Sportradar.OddsFeed.SDK.Common.ExceptionsCommunicationException
Sportradar.OddsFeed.SDK.Common.ExceptionsDeserializationException
Sportradar.OddsFeed.SDK.Common.ExceptionsMappingException
Sportradar.OddsFeed.SDK.Common.ExceptionsNameExpressionException
Sportradar.OddsFeed.SDK.Common.ExceptionsNameGenerationException
Sportradar.OddsFeed.SDK.Common.ExceptionsObjectNotFoundException


FeedSdkException Constructor

Overload List
 | Name | Description
Protected method | FeedSdkException | Initializes a new instance of the FeedSdkException class.
Protected method | FeedSdkException(SerializationInfo, StreamingContext) | Initializes a new instance of the FeedSdkException class.
Protected method | FeedSdkException(String, Exception) | Initializes a new instance of the FeedSdkException class.
Top
See Also

Reference

FeedSdkException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


FeedSdkException Constructor

Initializes a new instance of the FeedSdkException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected FeedSdkException()
See Also

Reference

FeedSdkException Class
FeedSdkException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


FeedSdkException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the FeedSdkException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected FeedSdkException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

FeedSdkException Class
FeedSdkException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


FeedSdkException(String, Exception) Constructor

Initializes a new instance of the FeedSdkException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected FeedSdkException(
    string message,
    Exception innerException
)

Parameters

message String
The error message that explains the reason for the exception.
innerException Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

FeedSdkException Class
FeedSdkException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


FeedSdkException Properties

The FeedSdkException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

FeedSdkException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


FeedSdkException Methods

The FeedSdkException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

FeedSdkException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


FeedSdkException Events

The FeedSdkException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

FeedSdkException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


MappingException Class

An exception thrown by the SDK when the entity received from the feed could not be mapped to entity used by the SDK
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.OddsFeed.SDK.Common.ExceptionsFeedSdkException
Sportradar.OddsFeed.SDK.Common.ExceptionsMappingException

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class MappingException : FeedSdkException

The MappingException type exposes the following members.

Constructors
 | Name | Description
Public method | MappingException | Initializes a new instance of the MappingException class.
Public method | MappingException(SerializationInfo, StreamingContext) | Initializes a new instance of the MappingException class.
Public method | MappingException(String, String, String, String, Exception) | Initializes a new instance of the MappingException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | PropertyName | Gets the name of the property which caused the exception.
Public property | PropertyValue | Gets the String representation of the property value which caused the exception.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | TargetTypeName | Gets the TargetTypeName of the target entity.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ExceptionToString)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Common.Exceptions Namespace
FeedSdkException


MappingException Constructor

Overload List
 | Name | Description
Public method | MappingException | Initializes a new instance of the MappingException class.
Public method | MappingException(SerializationInfo, StreamingContext) | Initializes a new instance of the MappingException class.
Public method | MappingException(String, String, String, String, Exception) | Initializes a new instance of the MappingException class.
Top
See Also

Reference

MappingException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


MappingException Constructor

Initializes a new instance of the MappingException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public MappingException()
See Also

Reference

MappingException Class
MappingException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


MappingException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the MappingException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public MappingException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

MappingException Class
MappingException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


MappingException(String, String, String, String, Exception) Constructor

Initializes a new instance of the MappingException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public MappingException(
    string message,
    string propertyName,
    string propertyValue,
    string targetTypeName,
    Exception innerException
)

Parameters

message String
The error message that explains the reason for the exception.
propertyName String
The name of the property which caused the exception
propertyValue String
The String representation of the property value which caused the exception
targetTypeName String
The TargetTypeName of the target entity
innerException Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

MappingException Class
MappingException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


MappingException Properties

The MappingException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | PropertyName | Gets the name of the property which caused the exception.
Public property | PropertyValue | Gets the String representation of the property value which caused the exception.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Public property | TargetTypeName | Gets the TargetTypeName of the target entity.
Top
See Also

Reference

MappingException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


MappingException.PropertyName Property

MappingExceptionPropertyName Property

Gets the name of the property which caused the exception.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string PropertyName { get; }

Property Value

String
The name of the property.
See Also

Reference

MappingException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


MappingException.PropertyValue Property

MappingExceptionPropertyValue Property

Gets the String representation of the property value which caused the exception.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string PropertyValue { get; }

Property Value

String
The property value.
See Also

Reference

MappingException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


MappingException.TargetTypeName Property

MappingExceptionTargetTypeName Property

Gets the TargetTypeName of the target entity.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string TargetTypeName { get; }

Property Value

String
The name of the target type.
See Also

Reference

MappingException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


MappingException Methods

The MappingException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ExceptionToString)
Top
See Also

Reference

MappingException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


MappingException.GetObjectData Method

MappingExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

MappingException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


MappingException.ToString Method

MappingExceptionToString Method

Returns a String that represents this instance.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
A String that represents this instance.

Implements

_ExceptionToString
See Also

Reference

MappingException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


MappingException Events

The MappingException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

MappingException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameExpressionException Class

An exception thrown by name expressions when the name cannot be build
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.OddsFeed.SDK.Common.ExceptionsFeedSdkException
Sportradar.OddsFeed.SDK.Common.ExceptionsNameExpressionException

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class NameExpressionException : FeedSdkException

The NameExpressionException type exposes the following members.

Constructors
 | Name | Description
Public method | NameExpressionException | Initializes a new instance of the NameExpressionException class.
Public method | NameExpressionException(SerializationInfo, StreamingContext) | Initializes a new instance of the NameExpressionException class.
Public method | NameExpressionException(String, Exception) | Initializes a new instance of the NameExpressionException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Common.Exceptions Namespace
FeedSdkException


NameExpressionException Constructor

Overload List
 | Name | Description
Public method | NameExpressionException | Initializes a new instance of the NameExpressionException class.
Public method | NameExpressionException(SerializationInfo, StreamingContext) | Initializes a new instance of the NameExpressionException class.
Public method | NameExpressionException(String, Exception) | Initializes a new instance of the NameExpressionException class.
Top
See Also

Reference

NameExpressionException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameExpressionException Constructor

Initializes a new instance of the NameExpressionException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public NameExpressionException()
See Also

Reference

NameExpressionException Class
NameExpressionException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameExpressionException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the NameExpressionException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public NameExpressionException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

NameExpressionException Class
NameExpressionException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameExpressionException(String, Exception) Constructor

Initializes a new instance of the NameExpressionException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public NameExpressionException(
    string message,
    Exception innerException
)

Parameters

message String
The error message that explains the reason for the exception.
innerException Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

NameExpressionException Class
NameExpressionException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameExpressionException Properties

The NameExpressionException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

NameExpressionException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameExpressionException Methods

The NameExpressionException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

NameExpressionException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameExpressionException Events

The NameExpressionException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

NameExpressionException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException Class

An exception when the name for a market or outcome could not be generated
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.OddsFeed.SDK.Common.ExceptionsFeedSdkException
Sportradar.OddsFeed.SDK.Common.ExceptionsNameGenerationException

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class NameGenerationException : FeedSdkException

The NameGenerationException type exposes the following members.

Constructors
 | Name | Description
Public method | NameGenerationException | Initializes a new instance of the NameGenerationException class.
Public method | NameGenerationException(SerializationInfo, StreamingContext) | Initializes a new instance of the NameGenerationException class.
Public method | NameGenerationException(String, Int32, IReadOnlyDictionaryString, String, String, String, CultureInfo, Exception) | Initializes a new instance of the NameGenerationException class.
Top
Properties
 | Name | Description
Public property | Culture | Gets the CultureInfo instance specifying the language associated with the name generation
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | MarketId | Gets the id of the market associated with name generation that caused the exception
Public property | MarketSpecifiers | Gets the specifiers of the market associated with name generation that caused the exception
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | NameDescriptor | Gets the name descriptor used when generating the name, or a null reference if name descriptor could not be found
Public property | OutcomeId | Gets the id of the outcome whose name generation caused the exception, or a null reference if the name generation was invoked on market
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ExceptionToString)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Common.Exceptions Namespace
FeedSdkException


NameGenerationException Constructor

Overload List
 | Name | Description
Public method | NameGenerationException | Initializes a new instance of the NameGenerationException class.
Public method | NameGenerationException(SerializationInfo, StreamingContext) | Initializes a new instance of the NameGenerationException class.
Public method | NameGenerationException(String, Int32, IReadOnlyDictionaryString, String, String, String, CultureInfo, Exception) | Initializes a new instance of the NameGenerationException class.
Top
See Also

Reference

NameGenerationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException Constructor

Initializes a new instance of the NameGenerationException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public NameGenerationException()
See Also

Reference

NameGenerationException Class
NameGenerationException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the NameGenerationException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public NameGenerationException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

NameGenerationException Class
NameGenerationException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException(String, Int32, IReadOnlyDictionary<String, String>, String, String, CultureInfo, Exception) Constructor

NameGenerationException(String, Int32, IReadOnlyDictionaryString, String, String, String, CultureInfo, Exception) Constructor

Initializes a new instance of the NameGenerationException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public NameGenerationException(
    string message,
    int marketId,
    IReadOnlyDictionary<string, string> marketSpecifiers,
    string outcomeId,
    string nameDescriptor,
    CultureInfo culture,
    Exception innerException
)

Parameters

message String
The error message that explains the reason for the exception.
marketId Int32
The id of the market associated with name generation that caused the exception
marketSpecifiers IReadOnlyDictionary String, String
The specifiers of the market associated with name generation that caused the exception
outcomeId String
The id of the outcome whose name generation caused the exception, or a null reference if the name generation was invoked on market
nameDescriptor String
The name descriptor used when generating the name, or a null reference if name descriptor could not be found
culture CultureInfo
The CultureInfo instance specifying the language associated with the name generation
innerException Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

NameGenerationException Class
NameGenerationException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException Properties

The NameGenerationException type exposes the following members.

Properties
 | Name | Description
Public property | Culture | Gets the CultureInfo instance specifying the language associated with the name generation
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | MarketId | Gets the id of the market associated with name generation that caused the exception
Public property | MarketSpecifiers | Gets the specifiers of the market associated with name generation that caused the exception
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | NameDescriptor | Gets the name descriptor used when generating the name, or a null reference if name descriptor could not be found
Public property | OutcomeId | Gets the id of the outcome whose name generation caused the exception, or a null reference if the name generation was invoked on market
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

NameGenerationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException.Culture Property

NameGenerationExceptionCulture Property

Gets the CultureInfo instance specifying the language associated with the name generation

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CultureInfo Culture { get; }

Property Value

CultureInfo
See Also

Reference

NameGenerationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException.MarketId Property

NameGenerationExceptionMarketId Property

Gets the id of the market associated with name generation that caused the exception

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int MarketId { get; }

Property Value

Int32
See Also

Reference

NameGenerationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException.MarketSpecifiers Property

NameGenerationExceptionMarketSpecifiers Property

Gets the specifiers of the market associated with name generation that caused the exception

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IReadOnlyDictionary<string, string> MarketSpecifiers { get; }

Property Value

IReadOnlyDictionary String, String
The market specifiers.
See Also

Reference

NameGenerationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException.NameDescriptor Property

NameGenerationExceptionNameDescriptor Property

Gets the name descriptor used when generating the name, or a null reference if name descriptor could not be found

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string NameDescriptor { get; }

Property Value

String
See Also

Reference

NameGenerationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException.OutcomeId Property

NameGenerationExceptionOutcomeId Property

Gets the id of the outcome whose name generation caused the exception, or a null reference if the name generation was invoked on market

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string OutcomeId { get; }

Property Value

String
See Also

Reference

NameGenerationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException Methods

The NameGenerationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext))
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ExceptionToString)
Top
See Also

Reference

NameGenerationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException.GetObjectData Method

NameGenerationExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

NameGenerationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException.ToString Method

NameGenerationExceptionToString Method

Returns a String that represents this instance.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
A String that represents this instance.

Implements

_ExceptionToString
See Also

Reference

NameGenerationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


NameGenerationException Events

The NameGenerationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

NameGenerationException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


ObjectNotFoundException Class

An exception thrown when the requested object is not found
Inheritance Hierarchy
SystemObject
SystemException
Sportradar.OddsFeed.SDK.Common.ExceptionsFeedSdkException
Sportradar.OddsFeed.SDK.Common.ExceptionsObjectNotFoundException

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ObjectNotFoundException : FeedSdkException

The ObjectNotFoundException type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectNotFoundException | Initializes a new instance of the ObjectNotFoundException class.
Public method | ObjectNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the ObjectNotFoundException class.
Public method | ObjectNotFoundException(String, Exception) | Initializes a new instance of the ObjectNotFoundException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Common.Exceptions Namespace
FeedSdkException


ObjectNotFoundException Constructor

Overload List
 | Name | Description
Public method | ObjectNotFoundException | Initializes a new instance of the ObjectNotFoundException class.
Public method | ObjectNotFoundException(SerializationInfo, StreamingContext) | Initializes a new instance of the ObjectNotFoundException class.
Public method | ObjectNotFoundException(String, Exception) | Initializes a new instance of the ObjectNotFoundException class.
Top
See Also

Reference

ObjectNotFoundException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


ObjectNotFoundException Constructor

Initializes a new instance of the ObjectNotFoundException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ObjectNotFoundException()
See Also

Reference

ObjectNotFoundException Class
ObjectNotFoundException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


ObjectNotFoundException(SerializationInfo, StreamingContext) Constructor

Initializes a new instance of the ObjectNotFoundException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ObjectNotFoundException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context StreamingContext
The StreamingContext that contains contextual information about the source or destination.
See Also

Reference

ObjectNotFoundException Class
ObjectNotFoundException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


ObjectNotFoundException(String, Exception) Constructor

Initializes a new instance of the ObjectNotFoundException class.

Namespace: Sportradar.OddsFeed.SDK.Common.Exceptions
Assembly: Sportradar.OddsFeed.SDK.Common (in Sportradar.OddsFeed.SDK.Common.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ObjectNotFoundException(
    string message,
    Exception innerException
)

Parameters

message String
The error message that explains the reason for the exception.
innerException Exception
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

ObjectNotFoundException Class
ObjectNotFoundException Overload
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


ObjectNotFoundException Properties

The ObjectNotFoundException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception)
Top
See Also

Reference

ObjectNotFoundException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


ObjectNotFoundException Methods

The ObjectNotFoundException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception)
Top
See Also

Reference

ObjectNotFoundException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


ObjectNotFoundException Events

The ObjectNotFoundException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception)
Top
See Also

Reference

ObjectNotFoundException Class
Sportradar.OddsFeed.SDK.Common.Exceptions Namespace


Sportradar.OddsFeed.SDK.Entities Namespace

Classes
 | Class | Description
Public class | MessageInterest | Defines which messages will be provided by feed
Interfaces
 | Interface | Description
Public interface | IAdditionalProbabilities | Additional probability attributes for markets which potentially will be (partly) refunded
Public interface | IBetCancelT | Defines a contract implemented by bet-cancel messages
Public interface | IBetSettlementT | Defines a contract implemented by bet-settlement messages
Public interface | IBetStopT | Defines a contract implemented by bet-stop messages
Public interface | ICashOutProbabilitiesT | Defines a contract implemented by cash-out probability messages
Public interface | IEventMessageT | Defines a contract implemented by all messages associated with sport events
Public interface | IFixtureChangeT | Defines a contract implemented by messages which indicate a fixture was changed
Public interface | IMarket | Represents a betting market
Public interface | IMarketCancel | Represents information for a market with void reason
Public interface | IMarketDefinition | Defines methods used to access market definition properties
Public interface | IMarketMessageT, T1 | Defines a contract implemented by all messages containing market related information
Public interface | IMarketMetadata | Defines a contract for classes implementing additional market information
Public interface | IMarketWithOdds | Defines a contract implemented by classes providing odds information for betting markets
Public interface | IMarketWithProbabilities | Defines a contract implemented by classes providing probability information for betting markets
Public interface | IMarketWithProbabilitiesV1 | Defines a contract implemented by classes providing probability information for betting markets
Public interface | IMarketWithProbabilitiesV2 | Defines a contract implemented by classes providing probability information for betting markets
Public interface | IMarketWithSettlement | Represents settlement information for a market
Public interface | IMessage | Defines a contract followed by all top-level messages produced by the feed
Public interface | IMessageTimestamp | Defines a contract for all message timestamps
Public interface | IMessageV1 | Defines a contract followed by all top-level messages produced by the feed
Public interface | IOddsChangeT | Defines a contract implemented by odds-change messages
Public interface | IOddsChangeV1T | Defines a contract implemented by odds-change messages
Public interface | IOddsGeneration | Provided by the prematch odds producer only, and contains a few key-parameters that can be used in a client’s own special odds model, or even offer spread betting bets based on it.
Public interface | IOutcome | Represent a betting market outcome
Public interface | IOutcomeDefinition | Defines methods used to access outcome definition properties
Public interface | IOutcomeOdds | Represents an odds for an outcome(selection)
Public interface | IOutcomeOddsV1 | Represents an odds for an outcome (selection)
Public interface | IOutcomeProbabilities | Represents a selection with probabilities information
Public interface | IOutcomeProbabilitiesV1 | Represents a selection with probabilities information
Public interface | IOutcomeSettlement | Represent settlement information for an outcome(market selection)
Public interface | IOutcomeSettlementV1 | Represent settlement information for an outcome(market selection)
Public interface | IOutcomeV1 | Represent a betting market outcome
Public interface | IPlayerOutcomeOdds | Represents an odds for a player outcome(selection)
Public interface | IProducerStatusChange | Defines a contract implemented by messages indicating that a producer status changed to down or up
Public interface | IRollbackBetCancelT | Defines a contract implemented by bet-cancel-rollback messages
Public interface | IRollbackBetSettlementT | Defines a contract implemented by bet-settlement-rollback messages
Public interface | ISnapshotCompleted | Defines a contract implemented by messages indicating that all messages from the requested snapshot were send
Enumerations
 | Enumeration | Description
Public enumeration | BetSettlementCertainty | Enum BetSettlementCertainty
Public enumeration | CashoutStatus | Enumerates market cash-out availability
Public enumeration | FixtureChangeType | Enumerates reasons why a IFixtureChangeT message was received
Public enumeration | MarketStatus | Enumerates market statuses
Public enumeration | OddsChangeReason | Enumerates possible reasons why the odds-change was generated
Public enumeration | OddsDisplayType | Enumerates possible options for displaying outcome odds


BetSettlementCertainty Enumeration

Enum BetSettlementCertainty

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum BetSettlementCertainty
Members
Member name | Value | Description
Unknown | 0 | The unknown
LiveScouted | 1 | The live scouted
Confirmed | 2 | The confirmed
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


CashoutStatus Enumeration

Enumerates market cash-out availability

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum CashoutStatus
Members
Member name | Value | Description
AVAILABLE | 1 | Indicates cashout for associated market is available
UNAVAILABLE | -1 | Indicates cashout for associated market is un-available
CLOSED | -2 | Indicates cashout for associated market is no longer available - is closed
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


FixtureChangeType Enumeration

Enumerates reasons why a IFixtureChangeT message was received

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum FixtureChangeType
Members
Member name | Value | Description
NEW | 1 | A new sport event has been added(typically used for events that are created and will start in the near-term)
START_TIME | 2 | The start time of the sport event has changed
CANCELLED | 3 | The sport event has been canceled
FORMAT | 4 | Format changes to the fixture
COVERAGE | 5 | Coverage of the sport event has been changed
PITCHER | 6 | Pitcher has been changed
OTHER | 101 | Other various changes to the fixture
NA | 102 | Type not specified (not available - equal null)
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IAdditionalProbabilities Interface

Additional probability attributes for markets which potentially will be (partly) refunded

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IAdditionalProbabilities

The IAdditionalProbabilities type exposes the following members.

Properties
 | Name | Description
Public property | HalfLose | The half_lose probability
Public property | HalfWin | The half_win probability
Public property | Lose | The lose probability
Public property | Refund | The refund probability
Public property | Win | The win probability
Top
Remarks
This is valid only for those markets which are sent with x.0, x.25 and x.75 lines and in addition the "no bet" markets (draw no bet, home no bet, ...)
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IAdditionalProbabilities Properties

The IAdditionalProbabilities type exposes the following members.

Properties
 | Name | Description
Public property | HalfLose | The half_lose probability
Public property | HalfWin | The half_win probability
Public property | Lose | The lose probability
Public property | Refund | The refund probability
Public property | Win | The win probability
Top
See Also

Reference

IAdditionalProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IAdditionalProbabilities.HalfLose Property

IAdditionalProbabilitiesHalfLose Property

The half_lose probability

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double? HalfLose { get; }

Property Value

Nullable Double
See Also

Reference

IAdditionalProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IAdditionalProbabilities.HalfWin Property

IAdditionalProbabilitiesHalfWin Property

The half_win probability

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double? HalfWin { get; }

Property Value

Nullable Double
See Also

Reference

IAdditionalProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IAdditionalProbabilities.Lose Property

IAdditionalProbabilitiesLose Property

The lose probability

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double? Lose { get; }

Property Value

Nullable Double
See Also

Reference

IAdditionalProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IAdditionalProbabilities.Refund Property

IAdditionalProbabilitiesRefund Property

The refund probability

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double? Refund { get; }

Property Value

Nullable Double
See Also

Reference

IAdditionalProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IAdditionalProbabilities.Win Property

IAdditionalProbabilitiesWin Property

The win probability

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double? Win { get; }

Property Value

Nullable Double
See Also

Reference

IAdditionalProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IBetCancel<T> Interface

IBetCancelT Interface

Defines a contract implemented by bet-cancel messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IBetCancel<out T> : IMarketMessage<IMarketCancel, T>,
    IEventMessage<T>, IMessageV1, IMessage
where T : ISportEvent

Type Parameters

T
A ICompetition derived type specifying the type of the associated sport event

The IBetCancelT type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | Gets number of milliseconds from UTC epoch representing the end of cancellation period. A null value indicates the period ended when the market was closed
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | StartTime | Gets number of milliseconds from UTC epoch representing the start of cancellation period. A null value indicates the period started with market activation
Public property | SupersededBy | If the market was cancelled because of a migration from a different sport event, it gets a URN specifying the sport event from which the market has migrated.
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IBetCancel<T> Properties

IBetCancelT Properties

The IBetCancelT type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | Gets number of milliseconds from UTC epoch representing the end of cancellation period. A null value indicates the period ended when the market was closed
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | StartTime | Gets number of milliseconds from UTC epoch representing the start of cancellation period. A null value indicates the period started with market activation
Public property | SupersededBy | If the market was cancelled because of a migration from a different sport event, it gets a URN specifying the sport event from which the market has migrated.
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

IBetCancelT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IBetCancel<T>.EndTime Property

IBetCancelTEndTime Property

Gets number of milliseconds from UTC epoch representing the end of cancellation period. A null value indicates the period ended when the market was closed

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long? EndTime { get; }

Property Value

Nullable Int64
See Also

Reference

IBetCancelT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IBetCancel<T>.StartTime Property

IBetCancelTStartTime Property

Gets number of milliseconds from UTC epoch representing the start of cancellation period. A null value indicates the period started with market activation

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long? StartTime { get; }

Property Value

Nullable Int64
See Also

Reference

IBetCancelT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IBetCancel<T>.SupersededBy Property

IBetCancelTSupersededBy Property

If the market was cancelled because of a migration from a different sport event, it gets a URN specifying the sport event from which the market has migrated.

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN SupersededBy { get; }

Property Value

URN
The superseded by.
See Also

Reference

IBetCancelT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IBetSettlement<T> Interface

IBetSettlementT Interface

Defines a contract implemented by bet-settlement messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IBetSettlement<out T> : IMarketMessage<IMarketWithSettlement, T>,
    IEventMessage<T>, IMessageV1, IMessage
where T : ISportEvent

Type Parameters

T
A ICompetition derived type specifying the type of the associated sport event

The IBetSettlementT type exposes the following members.

Properties
 | Name | Description
Public property | Certainty | Gets the certainty of the IBetSettlementT
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IBetSettlement<T> Properties

IBetSettlementT Properties

The IBetSettlementT type exposes the following members.

Properties
 | Name | Description
Public property | Certainty | Gets the certainty of the IBetSettlementT
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

IBetSettlementT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IBetSettlement<T>.Certainty Property

IBetSettlementTCertainty Property

Gets the certainty of the IBetSettlementT

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
BetSettlementCertainty Certainty { get; }

Property Value

BetSettlementCertainty
The certainty of the IBetSettlementT
See Also

Reference

IBetSettlementT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IBetStop<T> Interface

IBetStopT Interface

Defines a contract implemented by bet-stop messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IBetStop<out T> : IEventMessage<T>,
    IMessageV1, IMessage
where T : ISportEvent

Type Parameters

T
A ICompetition derived type specifying the type of the associated sport event

The IBetStopT type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Groups | Get a list of strings specifying which market groups needs to be stopped
Public property | MarketStatus | Gets a MarketStatus specifying the new status of the associated markets
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IBetStop<T> Properties

IBetStopT Properties

The IBetStopT type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Groups | Get a list of strings specifying which market groups needs to be stopped
Public property | MarketStatus | Gets a MarketStatus specifying the new status of the associated markets
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

IBetStopT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IBetStop<T>.Groups Property

IBetStopTGroups Property

Get a list of strings specifying which market groups needs to be stopped

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<string> Groups { get; }

Property Value

IEnumerable String
See Also

Reference

IBetStopT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IBetStop<T>.MarketStatus Property

IBetStopTMarketStatus Property

Gets a MarketStatus specifying the new status of the associated markets

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
MarketStatus MarketStatus { get; }

Property Value

MarketStatus
The market status.
See Also

Reference

IBetStopT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


ICashOutProbabilities<T> Interface

ICashOutProbabilitiesT Interface

Defines a contract implemented by cash-out probability messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICashOutProbabilities<out T> : IMarketMessage<IMarketWithProbabilities, T>,
    IEventMessage<T>, IMessageV1, IMessage
where T : ISportEvent

Type Parameters

T
A ISportEvent derived type specifying the type of the associated sport event

The ICashOutProbabilitiesT type exposes the following members.

Properties
 | Name | Description
Public property | BetStopReason | Gets the INamedValue specifying the reason for betting being stopped, or a null reference if the reason is not known
Public property | BettingStatus | Gets a INamedValue indicating the odds change was triggered by a possible event
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


ICashOutProbabilities<T> Properties

ICashOutProbabilitiesT Properties

The ICashOutProbabilitiesT type exposes the following members.

Properties
 | Name | Description
Public property | BetStopReason | Gets the INamedValue specifying the reason for betting being stopped, or a null reference if the reason is not known
Public property | BettingStatus | Gets a INamedValue indicating the odds change was triggered by a possible event
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

ICashOutProbabilitiesT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


ICashOutProbabilities<T>.BetStopReason Property

ICashOutProbabilitiesTBetStopReason Property

Gets the INamedValue specifying the reason for betting being stopped, or a null reference if the reason is not known

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
INamedValue BetStopReason { get; }

Property Value

INamedValue
The bet stop reason.
See Also

Reference

ICashOutProbabilitiesT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


ICashOutProbabilities<T>.BettingStatus Property

ICashOutProbabilitiesTBettingStatus Property

Gets a INamedValue indicating the odds change was triggered by a possible event

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
INamedValue BettingStatus { get; }

Property Value

INamedValue
See Also

Reference

ICashOutProbabilitiesT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IEventMessage<T> Interface

IEventMessageT Interface

Defines a contract implemented by all messages associated with sport events

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEventMessage<out T> : IMessageV1,
    IMessage
where T : ISportEvent

Type Parameters

T
A ISportEvent derived type used to describe the sport event associated with the fixture change

The IEventMessageT type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IEventMessage<T> Properties

IEventMessageT Properties

The IEventMessageT type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

IEventMessageT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IEventMessage<T>.Event Property

IEventMessageTEvent Property

Gets a ISportEvent derived instance representing the sport event associated with the current message

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
T Event { get; }

Property Value

T
See Also

Reference

IEventMessageT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IEventMessage<T>.RawMessage Property

IEventMessageTRawMessage Property

Gets the raw message

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
byte[] RawMessage { get; }

Property Value

Byte
The raw message
See Also

Reference

IEventMessageT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IEventMessage<T>.RequestId Property

IEventMessageTRequestId Property

Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long? RequestId { get; }

Property Value

Nullable Int64
See Also

Reference

IEventMessageT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IFixtureChange<T> Interface

IFixtureChangeT Interface

Defines a contract implemented by messages which indicate a fixture was changed

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IFixtureChange<out T> : IEventMessage<T>,
    IMessageV1, IMessage
where T : ISportEvent

Type Parameters

T
A ICompetition derived type used to describe the sport event associated with the fixture change

The IFixtureChangeT type exposes the following members.

Properties
 | Name | Description
Public property | ChangeType | Gets a FixtureChangeType indicating how the fixture was changed (added, re-scheduled, ...)
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | NextLiveTime | Gets a value specifying the start time of the fixture in milliseconds since EPOCH UTC after the fixture was re-scheduled
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | StartTime | Gets a value specifying the start time of the fixture in milliseconds since EPOCH UTC
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IFixtureChange<T> Properties

IFixtureChangeT Properties

The IFixtureChangeT type exposes the following members.

Properties
 | Name | Description
Public property | ChangeType | Gets a FixtureChangeType indicating how the fixture was changed (added, re-scheduled, ...)
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | NextLiveTime | Gets a value specifying the start time of the fixture in milliseconds since EPOCH UTC after the fixture was re-scheduled
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | StartTime | Gets a value specifying the start time of the fixture in milliseconds since EPOCH UTC
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

IFixtureChangeT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IFixtureChange<T>.ChangeType Property

IFixtureChangeTChangeType Property

Gets a FixtureChangeType indicating how the fixture was changed (added, re-scheduled, ...)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
FixtureChangeType ChangeType { get; }

Property Value

FixtureChangeType
Remarks
If not specified in message, returns NA
See Also

Reference

IFixtureChangeT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IFixtureChange<T>.NextLiveTime Property

IFixtureChangeTNextLiveTime Property

Gets a value specifying the start time of the fixture in milliseconds since EPOCH UTC after the fixture was re-scheduled

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long? NextLiveTime { get; }

Property Value

Nullable Int64
See Also

Reference

IFixtureChangeT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IFixtureChange<T>.StartTime Property

IFixtureChangeTStartTime Property

Gets a value specifying the start time of the fixture in milliseconds since EPOCH UTC

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long StartTime { get; }

Property Value

Int64
See Also

Reference

IFixtureChangeT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarket Interface

Represents a betting market

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarket

The IMarket type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information
Public property | Id | Gets a Int32 value specifying the market type
Public property | MarketDefinition | Gets the associated market definition instance
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers
Top
Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMarket Properties

The IMarket type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information
Public property | Id | Gets a Int32 value specifying the market type
Public property | MarketDefinition | Gets the associated market definition instance
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers
Top
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarket.AdditionalInfo Property

IMarketAdditionalInfo Property

Gets the IReadOnlyDictionaryTKey, TValue containing additional market information

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<string, string> AdditionalInfo { get; }

Property Value

IReadOnlyDictionary String, String
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarket.Id Property

IMarketId Property

Gets a Int32 value specifying the market type

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Id { get; }

Property Value

Int32
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarket.MarketDefinition Property

IMarketMarketDefinition Property

Gets the associated market definition instance

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IMarketDefinition MarketDefinition { get; }

Property Value

IMarketDefinition
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarket.Specifiers Property

IMarketSpecifiers Property

Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<string, string> Specifiers { get; }

Property Value

IReadOnlyDictionary String, String
Remarks
Note that the Id and Specifiers combined uniquely identify the market within the event
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarket Methods

The IMarket type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language
Top
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarket.GetMappedMarketIdAsync Method

IMarketGetMappedMarketIdAsync Method

Note: This API is now obsolete.

Asynchronously gets the mapping Id of the specified market

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Return only the first mapping. Use GetMappedMarketIdsAsync for all possible.")]
Task<IMarketMapping> GetMappedMarketIdAsync()

Return Value

Task IMarketMapping
Returns the mapping Id of the specified market
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarket.GetMappedMarketIdsAsync Method

IMarketGetMappedMarketIdsAsync Method

Asynchronously gets the mapping Ids of the specified market

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IMarketMapping>> GetMappedMarketIdsAsync()

Return Value

Task IEnumerable IMarketMapping
Returns the mapping Ids of the specified market
Remarks
The result is LoMarketMapping or LcooMarketMapping
Example
C#
Copy
foreach (var marketMapping in mappedIds)
{
    if (marketMapping is LcooMarketMapping lcooId)
    {
         _log.LogInformation($"Market {market.Id} mapping TypeId:{lcooId.TypeId}, Sov:'{lcooId.Sov}'");
    }
    else if (marketMapping is LoMarketMapping loId)
    {
        _log.LogInformation($"Market {market.Id} mapping TypeId:{loId.TypeId}, SubTypeId:{loId.SubTypeId}, Sov:'{loId.Sov}'");
    }
}
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarket.GetNameAsync Method

IMarketGetNameAsync Method

Asynchronously gets the name of the market in the specified language

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<string> GetNameAsync(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language in which to get the name

Return Value

Task String
A TaskTResult representing the async operation
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketCancel Interface

Represents information for a market with void reason

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketCancel : IMarket

The IMarketCancel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information (Inherited from IMarket)
Public property | Id | Gets a Int32 value specifying the market type (Inherited from IMarket)
Public property | MarketDefinition | Gets the associated market definition instance (Inherited from IMarket)
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers (Inherited from IMarket)
Public property | VoidReason | Gets a INamedValue specifying the void reason, or a null reference if no void reason is specified
Top
Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market (Inherited from IMarket)
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market (Inherited from IMarket)
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language (Inherited from IMarket)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMarketCancel Properties

The IMarketCancel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information (Inherited from IMarket)
Public property | Id | Gets a Int32 value specifying the market type (Inherited from IMarket)
Public property | MarketDefinition | Gets the associated market definition instance (Inherited from IMarket)
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers (Inherited from IMarket)
Public property | VoidReason | Gets a INamedValue specifying the void reason, or a null reference if no void reason is specified
Top
See Also

Reference

IMarketCancel Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketCancel.VoidReason Property

IMarketCancelVoidReason Property

Gets a INamedValue specifying the void reason, or a null reference if no void reason is specified

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
INamedValue VoidReason { get; }

Property Value

INamedValue
See Also

Reference

IMarketCancel Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketCancel Methods

The IMarketCancel type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market (Inherited from IMarket)
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market (Inherited from IMarket)
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language (Inherited from IMarket)
Top
See Also

Reference

IMarketCancel Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketDefinition Interface

Defines methods used to access market definition properties

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketDefinition

The IMarketDefinition type exposes the following members.

Methods
 | Name | Description
Public method | GetAttributes | Returns a dictionary of associated market attributes
Public method | GetGroups | Returns a list of groups to which the associated market belongs to
Public method | GetIncludesOutcomesOfType | Obsolete. Returns an indication of which kind of outcomes the associated market includes
Public method | GetNameTemplate | Returns the unmodified market name template
Public method | GetOutcomeType | Returns an indication of which kind of outcomes the associated market includes
Public method | GetValidMappings | Returns a list of valid market mappings
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMarketDefinition Methods

The IMarketDefinition type exposes the following members.

Methods
 | Name | Description
Public method | GetAttributes | Returns a dictionary of associated market attributes
Public method | GetGroups | Returns a list of groups to which the associated market belongs to
Public method | GetIncludesOutcomesOfType | Obsolete. Returns an indication of which kind of outcomes the associated market includes
Public method | GetNameTemplate | Returns the unmodified market name template
Public method | GetOutcomeType | Returns an indication of which kind of outcomes the associated market includes
Public method | GetValidMappings | Returns a list of valid market mappings
Top
See Also

Reference

IMarketDefinition Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketDefinition.GetAttributes Method

IMarketDefinitionGetAttributes Method

Returns a dictionary of associated market attributes

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IDictionary<string, string> GetAttributes()

Return Value

IDictionary String, String
A dictionary of associated market attributes
See Also

Reference

IMarketDefinition Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketDefinition.GetGroups Method

IMarketDefinitionGetGroups Method

Returns a list of groups to which the associated market belongs to

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IList<string> GetGroups()

Return Value

IList String
a list of groups to which the associated market belongs to
See Also

Reference

IMarketDefinition Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketDefinition.GetIncludesOutcomesOfType Method

IMarketDefinitionGetIncludesOutcomesOfType Method

Note: This API is now obsolete.

Returns an indication of which kind of outcomes the associated market includes

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use GetOutcomeType")]
string GetIncludesOutcomesOfType()

Return Value

String
An indication of which kind of outcomes the associated market includes
See Also

Reference

IMarketDefinition Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketDefinition.GetNameTemplate Method

IMarketDefinitionGetNameTemplate Method

Returns the unmodified market name template

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetNameTemplate(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture in which the name template should be provided

Return Value

String
The unmodified market name template
See Also

Reference

IMarketDefinition Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketDefinition.GetOutcomeType Method

IMarketDefinitionGetOutcomeType Method

Returns an indication of which kind of outcomes the associated market includes

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetOutcomeType()

Return Value

String
An indication of which kind of outcomes the associated market includes
See Also

Reference

IMarketDefinition Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketDefinition.GetValidMappings Method

IMarketDefinitionGetValidMappings Method

Returns a list of valid market mappings

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IMarketMappingData> GetValidMappings()

Return Value

IEnumerable IMarketMappingData
a list of valid market mappings
See Also

Reference

IMarketDefinition Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketMessage<T, T1> Interface

IMarketMessageT, T1 Interface

Defines a contract implemented by all messages containing market related information

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketMessage<out T, out T1> : IEventMessage<T1>,
    IMessageV1, IMessage
where T : IMarket
where T1 : ISportEvent

Type Parameters

T
A IMarket derived type specifying the type of markets
T1
A ISportEvent derived type specifying the type of the associated sport event

The IMarketMessageT, T1 type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMarketMessage<T, T1> Properties

IMarketMessageT, T1 Properties

The IMarketMessageT, T1 type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

IMarketMessageT, T1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketMessage<T, T1>.Markets Property

IMarketMessageT, T1Markets Property

Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<T> Markets { get; }

Property Value

IEnumerable T
See Also

Reference

IMarketMessageT, T1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketMetadata Interface

Defines a contract for classes implementing additional market information

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketMetadata

The IMarketMetadata type exposes the following members.

Properties
 | Name | Description
Public property | AamsId | Gets the Italian AAMS id for this outright
Public property | EndTime | Gets the end time of the event (as epoch timestamp)
Public property | EndTimeDate | Gets the end time of the event
Public property | NextBetstop | Gets a epoch timestamp in UTC when to betstop the associated market. Typically used for outrights and typically is the start-time of the event the market refers to
Public property | NextBetstopDate | Gets date/time when to betstop the associated market. Typically used for outrights and typically is the start-time of the event the market refers to
Public property | StartTime | Gets the start time of the event (as epoch timestamp)
Public property | StartTimeDate | Gets the start time of the event
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMarketMetadata Properties

The IMarketMetadata type exposes the following members.

Properties
 | Name | Description
Public property | AamsId | Gets the Italian AAMS id for this outright
Public property | EndTime | Gets the end time of the event (as epoch timestamp)
Public property | EndTimeDate | Gets the end time of the event
Public property | NextBetstop | Gets a epoch timestamp in UTC when to betstop the associated market. Typically used for outrights and typically is the start-time of the event the market refers to
Public property | NextBetstopDate | Gets date/time when to betstop the associated market. Typically used for outrights and typically is the start-time of the event the market refers to
Public property | StartTime | Gets the start time of the event (as epoch timestamp)
Public property | StartTimeDate | Gets the start time of the event
Top
See Also

Reference

IMarketMetadata Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketMetadata.AamsId Property

IMarketMetadataAamsId Property

Gets the Italian AAMS id for this outright

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long? AamsId { get; }

Property Value

Nullable Int64
The Italian AAMS id for this outright
See Also

Reference

IMarketMetadata Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketMetadata.EndTime Property

IMarketMetadataEndTime Property

Gets the end time of the event (as epoch timestamp)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long? EndTime { get; }

Property Value

Nullable Int64
The end time
See Also

Reference

IMarketMetadata Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketMetadata.EndTimeDate Property

IMarketMetadataEndTimeDate Property

Gets the end time of the event

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime? EndTimeDate { get; }

Property Value

Nullable DateTime
The end time
See Also

Reference

IMarketMetadata Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketMetadata.NextBetstop Property

IMarketMetadataNextBetstop Property

Gets a epoch timestamp in UTC when to betstop the associated market. Typically used for outrights and typically is the start-time of the event the market refers to

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long? NextBetstop { get; }

Property Value

Nullable Int64
The next betstop
See Also

Reference

IMarketMetadata Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketMetadata.NextBetstopDate Property

IMarketMetadataNextBetstopDate Property

Gets date/time when to betstop the associated market. Typically used for outrights and typically is the start-time of the event the market refers to

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime? NextBetstopDate { get; }

Property Value

Nullable DateTime
The next betstop
See Also

Reference

IMarketMetadata Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketMetadata.StartTime Property

IMarketMetadataStartTime Property

Gets the start time of the event (as epoch timestamp)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long? StartTime { get; }

Property Value

Nullable Int64
The start time
See Also

Reference

IMarketMetadata Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketMetadata.StartTimeDate Property

IMarketMetadataStartTimeDate Property

Gets the start time of the event

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime? StartTimeDate { get; }

Property Value

Nullable DateTime
The start time
See Also

Reference

IMarketMetadata Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithOdds Interface

Defines a contract implemented by classes providing odds information for betting markets

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketWithOdds : IMarket

The IMarketWithOdds type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information (Inherited from IMarket)
Public property | CashoutStatus | Gets a CashoutStatus enum member specifying the availability of cashout, or a null reference
Public property | Id | Gets a Int32 value specifying the market type (Inherited from IMarket)
Public property | IsFavorite | Gets a value indicating whether the market associated with the current instance is the favorite market (i.e. the one with most balanced odds)
Public property | MarketDefinition | Gets the associated market definition instance (Inherited from IMarket)
Public property | MarketMetadata | Gets the market metadata which contains the additional market information
Public property | OutcomeOdds | Gets an IEnumerableT where each IOutcomeOdds instance provides odds information for one outcome(selection)
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers (Inherited from IMarket)
Public property | Status | Gets a MarketStatus enum member specifying the status of the market associated with the current IMarketWithOdds instance
Top
Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market (Inherited from IMarket)
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market (Inherited from IMarket)
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language (Inherited from IMarket)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithOdds Properties

The IMarketWithOdds type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information (Inherited from IMarket)
Public property | CashoutStatus | Gets a CashoutStatus enum member specifying the availability of cashout, or a null reference
Public property | Id | Gets a Int32 value specifying the market type (Inherited from IMarket)
Public property | IsFavorite | Gets a value indicating whether the market associated with the current instance is the favorite market (i.e. the one with most balanced odds)
Public property | MarketDefinition | Gets the associated market definition instance (Inherited from IMarket)
Public property | MarketMetadata | Gets the market metadata which contains the additional market information
Public property | OutcomeOdds | Gets an IEnumerableT where each IOutcomeOdds instance provides odds information for one outcome(selection)
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers (Inherited from IMarket)
Public property | Status | Gets a MarketStatus enum member specifying the status of the market associated with the current IMarketWithOdds instance
Top
See Also

Reference

IMarketWithOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithOdds.CashoutStatus Property

IMarketWithOddsCashoutStatus Property

Gets a CashoutStatus enum member specifying the availability of cashout, or a null reference

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
CashoutStatus? CashoutStatus { get; }

Property Value

Nullable CashoutStatus
See Also

Reference

IMarketWithOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithOdds.IsFavorite Property

IMarketWithOddsIsFavorite Property

Gets a value indicating whether the market associated with the current instance is the favorite market (i.e. the one with most balanced odds)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsFavorite { get; }

Property Value

Boolean
See Also

Reference

IMarketWithOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithOdds.MarketMetadata Property

IMarketWithOddsMarketMetadata Property

Gets the market metadata which contains the additional market information

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IMarketMetadata MarketMetadata { get; }

Property Value

IMarketMetadata
The market metadata which contains the additional market information
See Also

Reference

IMarketWithOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithOdds.OutcomeOdds Property

IMarketWithOddsOutcomeOdds Property

Gets an IEnumerableT where each IOutcomeOdds instance provides odds information for one outcome(selection)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IOutcomeOdds> OutcomeOdds { get; }

Property Value

IEnumerable IOutcomeOdds
See Also

Reference

IMarketWithOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithOdds.Status Property

IMarketWithOddsStatus Property

Gets a MarketStatus enum member specifying the status of the market associated with the current IMarketWithOdds instance

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
MarketStatus Status { get; }

Property Value

MarketStatus
See Also

Reference

IMarketWithOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithOdds Methods

The IMarketWithOdds type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market (Inherited from IMarket)
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market (Inherited from IMarket)
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language (Inherited from IMarket)
Top
See Also

Reference

IMarketWithOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilities Interface

Defines a contract implemented by classes providing probability information for betting markets

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketWithProbabilities : IMarket

The IMarketWithProbabilities type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information (Inherited from IMarket)
Public property | Id | Gets a Int32 value specifying the market type (Inherited from IMarket)
Public property | MarketDefinition | Gets the associated market definition instance (Inherited from IMarket)
Public property | OutcomeProbabilities | Gets an IEnumerableT where each IOutcomeProbabilities instance provides probabilities information for one outcome(selection)
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers (Inherited from IMarket)
Public property | Status | Gets a MarketStatus enum member specifying the status of the market associated with the current market
Top
Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market (Inherited from IMarket)
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market (Inherited from IMarket)
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language (Inherited from IMarket)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilities Properties

The IMarketWithProbabilities type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information (Inherited from IMarket)
Public property | Id | Gets a Int32 value specifying the market type (Inherited from IMarket)
Public property | MarketDefinition | Gets the associated market definition instance (Inherited from IMarket)
Public property | OutcomeProbabilities | Gets an IEnumerableT where each IOutcomeProbabilities instance provides probabilities information for one outcome(selection)
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers (Inherited from IMarket)
Public property | Status | Gets a MarketStatus enum member specifying the status of the market associated with the current market
Top
See Also

Reference

IMarketWithProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilities.OutcomeProbabilities Property

IMarketWithProbabilitiesOutcomeProbabilities Property

Gets an IEnumerableT where each IOutcomeProbabilities instance provides probabilities information for one outcome(selection)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IOutcomeProbabilities> OutcomeProbabilities { get; }

Property Value

IEnumerable IOutcomeProbabilities
See Also

Reference

IMarketWithProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilities.Status Property

IMarketWithProbabilitiesStatus Property

Gets a MarketStatus enum member specifying the status of the market associated with the current market

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
MarketStatus Status { get; }

Property Value

MarketStatus
See Also

Reference

IMarketWithProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilities Methods

The IMarketWithProbabilities type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market (Inherited from IMarket)
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market (Inherited from IMarket)
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language (Inherited from IMarket)
Top
See Also

Reference

IMarketWithProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilitiesV1 Interface

Defines a contract implemented by classes providing probability information for betting markets

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketWithProbabilitiesV1 : IMarketWithProbabilities,
    IMarket

The IMarketWithProbabilitiesV1 type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information (Inherited from IMarket)
Public property | CashoutStatus | Gets a CashoutStatus enum member specifying the availability of cashout, or a null reference
Public property | Id | Gets a Int32 value specifying the market type (Inherited from IMarket)
Public property | MarketDefinition | Gets the associated market definition instance (Inherited from IMarket)
Public property | OutcomeProbabilities | Gets an IEnumerableT where each IOutcomeProbabilities instance provides probabilities information for one outcome(selection) (Inherited from IMarketWithProbabilities)
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers (Inherited from IMarket)
Public property | Status | Gets a MarketStatus enum member specifying the status of the market associated with the current market (Inherited from IMarketWithProbabilities)
Top
Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market (Inherited from IMarket)
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market (Inherited from IMarket)
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language (Inherited from IMarket)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilitiesV1 Properties

The IMarketWithProbabilitiesV1 type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information (Inherited from IMarket)
Public property | CashoutStatus | Gets a CashoutStatus enum member specifying the availability of cashout, or a null reference
Public property | Id | Gets a Int32 value specifying the market type (Inherited from IMarket)
Public property | MarketDefinition | Gets the associated market definition instance (Inherited from IMarket)
Public property | OutcomeProbabilities | Gets an IEnumerableT where each IOutcomeProbabilities instance provides probabilities information for one outcome(selection) (Inherited from IMarketWithProbabilities)
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers (Inherited from IMarket)
Public property | Status | Gets a MarketStatus enum member specifying the status of the market associated with the current market (Inherited from IMarketWithProbabilities)
Top
See Also

Reference

IMarketWithProbabilitiesV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilitiesV1.CashoutStatus Property

IMarketWithProbabilitiesV1CashoutStatus Property

Gets a CashoutStatus enum member specifying the availability of cashout, or a null reference

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
CashoutStatus? CashoutStatus { get; }

Property Value

Nullable CashoutStatus
See Also

Reference

IMarketWithProbabilitiesV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilitiesV1 Methods

The IMarketWithProbabilitiesV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market (Inherited from IMarket)
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market (Inherited from IMarket)
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language (Inherited from IMarket)
Top
See Also

Reference

IMarketWithProbabilitiesV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilitiesV2 Interface

Defines a contract implemented by classes providing probability information for betting markets

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketWithProbabilitiesV2 : IMarketWithProbabilitiesV1,
    IMarketWithProbabilities, IMarket

The IMarketWithProbabilitiesV2 type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information (Inherited from IMarket)
Public property | CashoutStatus | Gets a CashoutStatus enum member specifying the availability of cashout, or a null reference (Inherited from IMarketWithProbabilitiesV1)
Public property | Id | Gets a Int32 value specifying the market type (Inherited from IMarket)
Public property | MarketDefinition | Gets the associated market definition instance (Inherited from IMarket)
Public property | MarketMetadata | Gets the market metadata which contains the additional market information
Public property | OutcomeProbabilities | Gets an IEnumerableT where each IOutcomeProbabilities instance provides probabilities information for one outcome(selection) (Inherited from IMarketWithProbabilities)
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers (Inherited from IMarket)
Public property | Status | Gets a MarketStatus enum member specifying the status of the market associated with the current market (Inherited from IMarketWithProbabilities)
Top
Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market (Inherited from IMarket)
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market (Inherited from IMarket)
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language (Inherited from IMarket)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilitiesV2 Properties

The IMarketWithProbabilitiesV2 type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information (Inherited from IMarket)
Public property | CashoutStatus | Gets a CashoutStatus enum member specifying the availability of cashout, or a null reference (Inherited from IMarketWithProbabilitiesV1)
Public property | Id | Gets a Int32 value specifying the market type (Inherited from IMarket)
Public property | MarketDefinition | Gets the associated market definition instance (Inherited from IMarket)
Public property | MarketMetadata | Gets the market metadata which contains the additional market information
Public property | OutcomeProbabilities | Gets an IEnumerableT where each IOutcomeProbabilities instance provides probabilities information for one outcome(selection) (Inherited from IMarketWithProbabilities)
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers (Inherited from IMarket)
Public property | Status | Gets a MarketStatus enum member specifying the status of the market associated with the current market (Inherited from IMarketWithProbabilities)
Top
See Also

Reference

IMarketWithProbabilitiesV2 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilitiesV2.MarketMetadata Property

IMarketWithProbabilitiesV2MarketMetadata Property

Gets the market metadata which contains the additional market information

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IMarketMetadata MarketMetadata { get; }

Property Value

IMarketMetadata
The market metadata which contains the additional market information
See Also

Reference

IMarketWithProbabilitiesV2 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithProbabilitiesV2 Methods

The IMarketWithProbabilitiesV2 type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market (Inherited from IMarket)
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market (Inherited from IMarket)
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language (Inherited from IMarket)
Top
See Also

Reference

IMarketWithProbabilitiesV2 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithSettlement Interface

Represents settlement information for a market

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketWithSettlement : IMarketCancel,
    IMarket

The IMarketWithSettlement type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information (Inherited from IMarket)
Public property | Id | Gets a Int32 value specifying the market type (Inherited from IMarket)
Public property | MarketDefinition | Gets the associated market definition instance (Inherited from IMarket)
Public property | OutcomeSettlements | Gets an IEnumerableT where each IOutcomeSettlement instance provides settlement information for one outcome(selection)
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers (Inherited from IMarket)
Public property | VoidReason | Gets a INamedValue specifying the void reason, or a null reference if no void reason is specified (Inherited from IMarketCancel)
Top
Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market (Inherited from IMarket)
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market (Inherited from IMarket)
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language (Inherited from IMarket)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithSettlement Properties

The IMarketWithSettlement type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Gets the IReadOnlyDictionaryTKey, TValue containing additional market information (Inherited from IMarket)
Public property | Id | Gets a Int32 value specifying the market type (Inherited from IMarket)
Public property | MarketDefinition | Gets the associated market definition instance (Inherited from IMarket)
Public property | OutcomeSettlements | Gets an IEnumerableT where each IOutcomeSettlement instance provides settlement information for one outcome(selection)
Public property | Specifiers | Gets a IReadOnlyDictionaryTKey, TValue containing market specifiers (Inherited from IMarket)
Public property | VoidReason | Gets a INamedValue specifying the void reason, or a null reference if no void reason is specified (Inherited from IMarketCancel)
Top
See Also

Reference

IMarketWithSettlement Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithSettlement.OutcomeSettlements Property

IMarketWithSettlementOutcomeSettlements Property

Gets an IEnumerableT where each IOutcomeSettlement instance provides settlement information for one outcome(selection)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IOutcomeSettlement> OutcomeSettlements { get; }

Property Value

IEnumerable IOutcomeSettlement
See Also

Reference

IMarketWithSettlement Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMarketWithSettlement Methods

The IMarketWithSettlement type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedMarketIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified market (Inherited from IMarket)
 | GetMappedMarketIdsAsync | Asynchronously gets the mapping Ids of the specified market (Inherited from IMarket)
Public method | GetNameAsync | Asynchronously gets the name of the market in the specified language (Inherited from IMarket)
Top
See Also

Reference

IMarketWithSettlement Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMessage Interface

Defines a contract followed by all top-level messages produced by the feed

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMessage

The IMessage type exposes the following members.

Properties
 | Name | Description
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMessage Properties

The IMessage type exposes the following members.

Properties
 | Name | Description
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC
Top
See Also

Reference

IMessage Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMessage.Producer Property

IMessageProducer Property

Gets a Producer specifying the producer / service which dispatched the current IMessage message

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IProducer Producer { get; }

Property Value

IProducer
See Also

Reference

IMessage Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMessage.Timestamp Property

IMessageTimestamp Property

Note: This API is now obsolete.

Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Check Timestamps for all available timestamps")]
long Timestamp { get; }

Property Value

Int64
See Also

Reference

IMessage Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMessageTimestamp Interface

Defines a contract for all message timestamps

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMessageTimestamp

The IMessageTimestamp type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets the value specifying when the message was generated and put in queue on rabbit server (milliseconds since EPOCH UTC)
Public property | Dispatched | Gets the value specifying when the message was dispatched to the user from the sdk (milliseconds since EPOCH UTC)
Public property | Received | Gets the value specifying when the message was received for processing by the sdk (milliseconds since EPOCH UTC)
Public property | Sent | Gets the value specifying when the message was sent from the rabbit server (milliseconds since EPOCH UTC)
Top
Remarks
Created and Sent are generated on rabbit server and Received and Dispatched on a local machine running sdk. If the system clocks are not in-sync it may happen that Received is before Created. Similar logic applies also to other properties.
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMessageTimestamp Properties

The IMessageTimestamp type exposes the following members.

Properties
 | Name | Description
Public property | Created | Gets the value specifying when the message was generated and put in queue on rabbit server (milliseconds since EPOCH UTC)
Public property | Dispatched | Gets the value specifying when the message was dispatched to the user from the sdk (milliseconds since EPOCH UTC)
Public property | Received | Gets the value specifying when the message was received for processing by the sdk (milliseconds since EPOCH UTC)
Public property | Sent | Gets the value specifying when the message was sent from the rabbit server (milliseconds since EPOCH UTC)
Top
See Also

Reference

IMessageTimestamp Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMessageTimestamp.Created Property

IMessageTimestampCreated Property

Gets the value specifying when the message was generated and put in queue on rabbit server (milliseconds since EPOCH UTC)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long Created { get; }

Property Value

Int64
See Also

Reference

IMessageTimestamp Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMessageTimestamp.Dispatched Property

IMessageTimestampDispatched Property

Gets the value specifying when the message was dispatched to the user from the sdk (milliseconds since EPOCH UTC)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long Dispatched { get; }

Property Value

Int64
See Also

Reference

IMessageTimestamp Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMessageTimestamp.Received Property

IMessageTimestampReceived Property

Gets the value specifying when the message was received for processing by the sdk (milliseconds since EPOCH UTC)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long Received { get; }

Property Value

Int64
See Also

Reference

IMessageTimestamp Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMessageTimestamp.Sent Property

IMessageTimestampSent Property

Gets the value specifying when the message was sent from the rabbit server (milliseconds since EPOCH UTC)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long Sent { get; }

Property Value

Int64
See Also

Reference

IMessageTimestamp Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMessageV1 Interface

Defines a contract followed by all top-level messages produced by the feed

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMessageV1 : IMessage

The IMessageV1 type exposes the following members.

Properties
 | Name | Description
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IMessageV1 Properties

The IMessageV1 type exposes the following members.

Properties
 | Name | Description
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk
Top
See Also

Reference

IMessageV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IMessageV1.Timestamps Property

IMessageV1Timestamps Property

Gets the timestamps when the message was generated, sent, received and dispatched by the sdk

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IMessageTimestamp Timestamps { get; }

Property Value

IMessageTimestamp
The timestamps
See Also

Reference

IMessageV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOddsChange<T> Interface

IOddsChangeT Interface

Defines a contract implemented by odds-change messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsChange<out T> : IMarketMessage<IMarketWithOdds, T>,
    IEventMessage<T>, IMessageV1, IMessage
where T : ISportEvent

Type Parameters

T
A ICompetition derived type specifying the type of the associated sport event

The IOddsChangeT type exposes the following members.

Properties
 | Name | Description
Public property | BetStopReason | Gets the INamedValue specifying the reason for betting being stopped, or a null reference if the reason is not known
Public property | BettingStatus | Gets a INamedValue indicating the odds change was triggered by a possible event
Public property | ChangeReason | Gets a OddsChangeReason enum member specifying the reason for odds change or a null reference if the reason is not known
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IOddsChange<T> Properties

IOddsChangeT Properties

The IOddsChangeT type exposes the following members.

Properties
 | Name | Description
Public property | BetStopReason | Gets the INamedValue specifying the reason for betting being stopped, or a null reference if the reason is not known
Public property | BettingStatus | Gets a INamedValue indicating the odds change was triggered by a possible event
Public property | ChangeReason | Gets a OddsChangeReason enum member specifying the reason for odds change or a null reference if the reason is not known
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

IOddsChangeT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOddsChange<T>.BetStopReason Property

IOddsChangeTBetStopReason Property

Gets the INamedValue specifying the reason for betting being stopped, or a null reference if the reason is not known

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
INamedValue BetStopReason { get; }

Property Value

INamedValue
The bet stop reason.
See Also

Reference

IOddsChangeT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOddsChange<T>.BettingStatus Property

IOddsChangeTBettingStatus Property

Gets a INamedValue indicating the odds change was triggered by a possible event

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
INamedValue BettingStatus { get; }

Property Value

INamedValue
See Also

Reference

IOddsChangeT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOddsChange<T>.ChangeReason Property

IOddsChangeTChangeReason Property

Gets a OddsChangeReason enum member specifying the reason for odds change or a null reference if the reason is not known

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
OddsChangeReason? ChangeReason { get; }

Property Value

Nullable OddsChangeReason
See Also

Reference

IOddsChangeT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOddsChangeV1<T> Interface

IOddsChangeV1T Interface

Defines a contract implemented by odds-change messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsChangeV1<out T> : IOddsChange<T>,
    IMarketMessage<IMarketWithOdds, T>, IEventMessage<T>, IMessageV1, IMessage
where T : ISportEvent

Type Parameters

T
A ICompetition derived type specifying the type of the associated sport event

The IOddsChangeV1T type exposes the following members.

Properties
 | Name | Description
Public property | BetStopReason | Gets the INamedValue specifying the reason for betting being stopped, or a null reference if the reason is not known (Inherited from IOddsChangeT)
Public property | BettingStatus | Gets a INamedValue indicating the odds change was triggered by a possible event (Inherited from IOddsChangeT)
Public property | ChangeReason | Gets a OddsChangeReason enum member specifying the reason for odds change or a null reference if the reason is not known (Inherited from IOddsChangeT)
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | OddsGenerationProperties | Gets the odds generation properties (contains a few key-parameters that can be used in a client’s own special odds model, or even offer spread betting bets based on it)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IOddsChangeV1<T> Properties

IOddsChangeV1T Properties

The IOddsChangeV1T type exposes the following members.

Properties
 | Name | Description
Public property | BetStopReason | Gets the INamedValue specifying the reason for betting being stopped, or a null reference if the reason is not known (Inherited from IOddsChangeT)
Public property | BettingStatus | Gets a INamedValue indicating the odds change was triggered by a possible event (Inherited from IOddsChangeT)
Public property | ChangeReason | Gets a OddsChangeReason enum member specifying the reason for odds change or a null reference if the reason is not known (Inherited from IOddsChangeT)
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | OddsGenerationProperties | Gets the odds generation properties (contains a few key-parameters that can be used in a client’s own special odds model, or even offer spread betting bets based on it)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

IOddsChangeV1T Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOddsChangeV1<T>.OddsGenerationProperties Property

IOddsChangeV1TOddsGenerationProperties Property

Gets the odds generation properties (contains a few key-parameters that can be used in a client’s own special odds model, or even offer spread betting bets based on it)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOddsGeneration OddsGenerationProperties { get; }

Property Value

IOddsGeneration
The odds generation properties
See Also

Reference

IOddsChangeV1T Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOddsGeneration Interface

Provided by the prematch odds producer only, and contains a few key-parameters that can be used in a client’s own special odds model, or even offer spread betting bets based on it.

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOddsGeneration

The IOddsGeneration type exposes the following members.

Properties
 | Name | Description
Public property | ExpectedSupremacy | Gets the expected supremacy (how big is the expected goal supremacy)
Public property | ExpectedTotals | Gets the expected totals (how many goals are expected in total?)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IOddsGeneration Properties

The IOddsGeneration type exposes the following members.

Properties
 | Name | Description
Public property | ExpectedSupremacy | Gets the expected supremacy (how big is the expected goal supremacy)
Public property | ExpectedTotals | Gets the expected totals (how many goals are expected in total?)
Top
See Also

Reference

IOddsGeneration Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOddsGeneration.ExpectedSupremacy Property

IOddsGenerationExpectedSupremacy Property

Gets the expected supremacy (how big is the expected goal supremacy)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double? ExpectedSupremacy { get; }

Property Value

Nullable Double
The expected supremacy
See Also

Reference

IOddsGeneration Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOddsGeneration.ExpectedTotals Property

IOddsGenerationExpectedTotals Property

Gets the expected totals (how many goals are expected in total?)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double? ExpectedTotals { get; }

Property Value

Nullable Double
The expected totals
See Also

Reference

IOddsGeneration Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcome Interface

Represent a betting market outcome

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcome

The IOutcome type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the value uniquely identifying the current instance
Top
Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IOutcome Properties

The IOutcome type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the value uniquely identifying the current instance
Top
See Also

Reference

IOutcome Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcome.Id Property

IOutcomeId Property

Gets the value uniquely identifying the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Id { get; }

Property Value

String
See Also

Reference

IOutcome Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcome Methods

The IOutcome type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language
Top
See Also

Reference

IOutcome Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcome.GetMappedOutcomeIdAsync Method

IOutcomeGetMappedOutcomeIdAsync Method

Note: This API is now obsolete.

Asynchronously gets the mapping Id of the specified outcome

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Return only the first mapping. Use GetMappedOutcomeIdsAsync for all possible.")]
Task<IOutcomeMapping> GetMappedOutcomeIdAsync()

Return Value

Task IOutcomeMapping
Returns the mapping Id of the specified outcome
See Also

Reference

IOutcome Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcome.GetMappedOutcomeIdsAsync Method

IOutcomeGetMappedOutcomeIdsAsync Method

Asynchronously gets the mapping Ids of the specified outcome

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IOutcomeMapping>> GetMappedOutcomeIdsAsync()

Return Value

Task IEnumerable IOutcomeMapping
Returns the mapping Ids of the specified outcome
See Also

Reference

IOutcome Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcome.GetNameAsync Method

IOutcomeGetNameAsync Method

Asynchronously gets the name of the outcome in the specified language

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<string> GetNameAsync(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language in which to get the name

Return Value

Task String
A TaskTResult representing the async operation
See Also

Reference

IOutcome Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeDefinition Interface

Defines methods used to access outcome definition properties

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcomeDefinition

The IOutcomeDefinition type exposes the following members.

Methods
 | Name | Description
Public method | GetNameTemplate | Returns the unmodified outcome name template
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeDefinition Methods

The IOutcomeDefinition type exposes the following members.

Methods
 | Name | Description
Public method | GetNameTemplate | Returns the unmodified outcome name template
Top
See Also

Reference

IOutcomeDefinition Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeDefinition.GetNameTemplate Method

IOutcomeDefinitionGetNameTemplate Method

Returns the unmodified outcome name template

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetNameTemplate(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture in which the name template should be provided

Return Value

String
The unmodified name template
See Also

Reference

IOutcomeDefinition Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeOdds Interface

Represents an odds for an outcome(selection)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcomeOdds : IOutcomeProbabilitiesV1,
    IOutcomeProbabilities, IOutcome

The IOutcomeOdds type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets a value indicating whether the current IOutcome is active - i.e. should bets on it be accepted (Inherited from IOutcomeProbabilities)
Public property | AdditionalProbabilities | Additional probability attributes for markets which potentially will be (partly) refunded (Inherited from IOutcomeProbabilitiesV1)
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | Odds | Obsolete. Gets the odds for the current IOutcomeOdds instance
Public property | Probabilities | Gets the probabilities for the current IOutcome instance (Inherited from IOutcomeProbabilities)
Top
Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeOdds Properties

The IOutcomeOdds type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets a value indicating whether the current IOutcome is active - i.e. should bets on it be accepted (Inherited from IOutcomeProbabilities)
Public property | AdditionalProbabilities | Additional probability attributes for markets which potentially will be (partly) refunded (Inherited from IOutcomeProbabilitiesV1)
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | Odds | Obsolete. Gets the odds for the current IOutcomeOdds instance
Public property | Probabilities | Gets the probabilities for the current IOutcome instance (Inherited from IOutcomeProbabilities)
Top
See Also

Reference

IOutcomeOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeOdds.Odds Property

IOutcomeOddsOdds Property

Note: This API is now obsolete.

Gets the odds for the current IOutcomeOdds instance

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("This value returns Decimal odds value. Use IOutcomeOddsV1.GetOdds() to retrieve odds by desired format.")]
double Odds { get; }

Property Value

Double
See Also

Reference

IOutcomeOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeOdds Methods

The IOutcomeOdds type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Top
See Also

Reference

IOutcomeOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeOddsV1 Interface

Represents an odds for an outcome (selection)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcomeOddsV1 : IOutcomeOdds,
    IOutcomeProbabilitiesV1, IOutcomeProbabilities, IOutcome

The IOutcomeOddsV1 type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets a value indicating whether the current IOutcome is active - i.e. should bets on it be accepted (Inherited from IOutcomeProbabilities)
Public property | AdditionalProbabilities | Additional probability attributes for markets which potentially will be (partly) refunded (Inherited from IOutcomeProbabilitiesV1)
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | Odds | Obsolete. Gets the odds for the current IOutcomeOdds instance (Inherited from IOutcomeOdds)
Public property | Probabilities | Gets the probabilities for the current IOutcome instance (Inherited from IOutcomeProbabilities)
Top
Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Public method | GetOdds | Gets the odds in specified format
Top
Remarks
Interface will be merged into base IOutcomeOdds in next major version scheduled for January 2019
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeOddsV1 Properties

The IOutcomeOddsV1 type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets a value indicating whether the current IOutcome is active - i.e. should bets on it be accepted (Inherited from IOutcomeProbabilities)
Public property | AdditionalProbabilities | Additional probability attributes for markets which potentially will be (partly) refunded (Inherited from IOutcomeProbabilitiesV1)
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | Odds | Obsolete. Gets the odds for the current IOutcomeOdds instance (Inherited from IOutcomeOdds)
Public property | Probabilities | Gets the probabilities for the current IOutcome instance (Inherited from IOutcomeProbabilities)
Top
See Also

Reference

IOutcomeOddsV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeOddsV1 Methods

The IOutcomeOddsV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Public method | GetOdds | Gets the odds in specified format
Top
See Also

Reference

IOutcomeOddsV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeOddsV1.GetOdds Method

IOutcomeOddsV1GetOdds Method

Gets the odds in specified format

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double? GetOdds(
    OddsDisplayType oddsDisplayType = OddsDisplayType.Decimal
)

Parameters

oddsDisplayType OddsDisplayType (Optional)
Display type of the odds (default: Decimal)

Return Value

Nullable Double
The value of the outcome odds in specified format
See Also

Reference

IOutcomeOddsV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeProbabilities Interface

Represents a selection with probabilities information

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcomeProbabilities : IOutcome

The IOutcomeProbabilities type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets a value indicating whether the current IOutcome is active - i.e. should bets on it be accepted
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | Probabilities | Gets the probabilities for the current IOutcome instance
Top
Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace
IOutcome


IOutcomeProbabilities Properties

The IOutcomeProbabilities type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets a value indicating whether the current IOutcome is active - i.e. should bets on it be accepted
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | Probabilities | Gets the probabilities for the current IOutcome instance
Top
See Also

Reference

IOutcomeProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeProbabilities.Active Property

IOutcomeProbabilitiesActive Property

Gets a value indicating whether the current IOutcome is active - i.e. should bets on it be accepted

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool? Active { get; }

Property Value

Nullable Boolean
See Also

Reference

IOutcomeProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeProbabilities.Probabilities Property

IOutcomeProbabilitiesProbabilities Property

Gets the probabilities for the current IOutcome instance

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double? Probabilities { get; }

Property Value

Nullable Double
See Also

Reference

IOutcomeProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeProbabilities Methods

The IOutcomeProbabilities type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Top
See Also

Reference

IOutcomeProbabilities Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeProbabilitiesV1 Interface

Represents a selection with probabilities information

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcomeProbabilitiesV1 : IOutcomeProbabilities,
    IOutcome

The IOutcomeProbabilitiesV1 type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets a value indicating whether the current IOutcome is active - i.e. should bets on it be accepted (Inherited from IOutcomeProbabilities)
Public property | AdditionalProbabilities | Additional probability attributes for markets which potentially will be (partly) refunded
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | Probabilities | Gets the probabilities for the current IOutcome instance (Inherited from IOutcomeProbabilities)
Top
Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace
IOutcome


IOutcomeProbabilitiesV1 Properties

The IOutcomeProbabilitiesV1 type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets a value indicating whether the current IOutcome is active - i.e. should bets on it be accepted (Inherited from IOutcomeProbabilities)
Public property | AdditionalProbabilities | Additional probability attributes for markets which potentially will be (partly) refunded
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | Probabilities | Gets the probabilities for the current IOutcome instance (Inherited from IOutcomeProbabilities)
Top
See Also

Reference

IOutcomeProbabilitiesV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeProbabilitiesV1.AdditionalProbabilities Property

IOutcomeProbabilitiesV1AdditionalProbabilities Property

Additional probability attributes for markets which potentially will be (partly) refunded

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IAdditionalProbabilities AdditionalProbabilities { get; }

Property Value

IAdditionalProbabilities
See Also

Reference

IOutcomeProbabilitiesV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeProbabilitiesV1 Methods

The IOutcomeProbabilitiesV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Top
See Also

Reference

IOutcomeProbabilitiesV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeSettlement Interface

Represent settlement information for an outcome(market selection)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcomeSettlement : IOutcome

The IOutcomeSettlement type exposes the following members.

Properties
 | Name | Description
Public property | DeadHeatFactor | Gets a dead-heat factor for the current IOutcomeSettlement instance
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | Result | Obsolete. Gets a value indicating whether the outcome associated with current IOutcomeSettlement is winning - i.e. have the bets placed on this outcome winning or losing
Public property | VoidFactor | Gets the VoidFactor associated with a current IOutcomeSettlement or a null reference. The value indicates the percentage of the stake that should be voided (returned to the punter).
Top
Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeSettlement Properties

The IOutcomeSettlement type exposes the following members.

Properties
 | Name | Description
Public property | DeadHeatFactor | Gets a dead-heat factor for the current IOutcomeSettlement instance
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | Result | Obsolete. Gets a value indicating whether the outcome associated with current IOutcomeSettlement is winning - i.e. have the bets placed on this outcome winning or losing
Public property | VoidFactor | Gets the VoidFactor associated with a current IOutcomeSettlement or a null reference. The value indicates the percentage of the stake that should be voided (returned to the punter).
Top
See Also

Reference

IOutcomeSettlement Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeSettlement.DeadHeatFactor Property

IOutcomeSettlementDeadHeatFactor Property

Gets a dead-heat factor for the current IOutcomeSettlement instance

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double? DeadHeatFactor { get; }

Property Value

Nullable Double
Remarks
A dead heat is defined as an event in which there are two or more joint winning contracts Dead heat rules state that the stake should be divided by the number of competitors involved in the dead heat and then settled at the normal odds
See Also

Reference

IOutcomeSettlement Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeSettlement.Result Property

IOutcomeSettlementResult Property

Note: This API is now obsolete.

Gets a value indicating whether the outcome associated with current IOutcomeSettlement is winning - i.e. have the bets placed on this outcome winning or losing

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Results may also include other values. Use IOutcomeSettlementV1.OutcomeResult instead.")]
bool Result { get; }

Property Value

Boolean
See Also

Reference

IOutcomeSettlement Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeSettlement.VoidFactor Property

IOutcomeSettlementVoidFactor Property

Gets the VoidFactor associated with a current IOutcomeSettlement or a null reference. The value indicates the percentage of the stake that should be voided (returned to the punter).

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
VoidFactor? VoidFactor { get; }

Property Value

Nullable VoidFactor
See Also

Reference

IOutcomeSettlement Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeSettlement Methods

The IOutcomeSettlement type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Top
See Also

Reference

IOutcomeSettlement Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeSettlementV1 Interface

Represent settlement information for an outcome(market selection)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcomeSettlementV1 : IOutcomeSettlement,
    IOutcome

The IOutcomeSettlementV1 type exposes the following members.

Properties
 | Name | Description
Public property | DeadHeatFactor | Gets a dead-heat factor for the current IOutcomeSettlement instance (Inherited from IOutcomeSettlement)
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | OutcomeResult | Gets a value indicating whether the outcome associated with current IOutcomeSettlement is winning - i.e. have the bets placed on this outcome winning or losing
Public property | Result | Obsolete. Gets a value indicating whether the outcome associated with current IOutcomeSettlement is winning - i.e. have the bets placed on this outcome winning or losing (Inherited from IOutcomeSettlement)
Public property | VoidFactor | Gets the VoidFactor associated with a current IOutcomeSettlement or a null reference. The value indicates the percentage of the stake that should be voided (returned to the punter). (Inherited from IOutcomeSettlement)
Top
Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeSettlementV1 Properties

The IOutcomeSettlementV1 type exposes the following members.

Properties
 | Name | Description
Public property | DeadHeatFactor | Gets a dead-heat factor for the current IOutcomeSettlement instance (Inherited from IOutcomeSettlement)
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | OutcomeResult | Gets a value indicating whether the outcome associated with current IOutcomeSettlement is winning - i.e. have the bets placed on this outcome winning or losing
Public property | Result | Obsolete. Gets a value indicating whether the outcome associated with current IOutcomeSettlement is winning - i.e. have the bets placed on this outcome winning or losing (Inherited from IOutcomeSettlement)
Public property | VoidFactor | Gets the VoidFactor associated with a current IOutcomeSettlement or a null reference. The value indicates the percentage of the stake that should be voided (returned to the punter). (Inherited from IOutcomeSettlement)
Top
See Also

Reference

IOutcomeSettlementV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeSettlementV1.OutcomeResult Property

IOutcomeSettlementV1OutcomeResult Property

Gets a value indicating whether the outcome associated with current IOutcomeSettlement is winning - i.e. have the bets placed on this outcome winning or losing

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
OutcomeResult OutcomeResult { get; }

Property Value

OutcomeResult
See Also

Reference

IOutcomeSettlementV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeSettlementV1 Methods

The IOutcomeSettlementV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Top
See Also

Reference

IOutcomeSettlementV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeV1 Interface

Represent a betting market outcome

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcomeV1 : IOutcome

The IOutcomeV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | OutcomeDefinition | Gets the associated outcome definition instance
Top
Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeV1 Properties

The IOutcomeV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | OutcomeDefinition | Gets the associated outcome definition instance
Top
See Also

Reference

IOutcomeV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeV1.OutcomeDefinition Property

IOutcomeV1OutcomeDefinition Property

Gets the associated outcome definition instance

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IOutcomeDefinition OutcomeDefinition { get; }

Property Value

IOutcomeDefinition
See Also

Reference

IOutcomeV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IOutcomeV1 Methods

The IOutcomeV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Top
See Also

Reference

IOutcomeV1 Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IPlayerOutcomeOdds Interface

Represents an odds for a player outcome(selection)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IPlayerOutcomeOdds : IOutcomeOddsV1,
    IOutcomeOdds, IOutcomeProbabilitiesV1, IOutcomeProbabilities, IOutcome

The IPlayerOutcomeOdds type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets a value indicating whether the current IOutcome is active - i.e. should bets on it be accepted (Inherited from IOutcomeProbabilities)
Public property | AdditionalProbabilities | Additional probability attributes for markets which potentially will be (partly) refunded (Inherited from IOutcomeProbabilitiesV1)
Public property | HomeOrAwayTeam | Gets the value indicating whether the associated team is home or away
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | Odds | Obsolete. Gets the odds for the current IOutcomeOdds instance (Inherited from IOutcomeOdds)
Public property | Probabilities | Gets the probabilities for the current IOutcome instance (Inherited from IOutcomeProbabilities)
Top
Methods
 | Name | Description
Public method | GetCompetitorAsync | Asynchronously gets the team to which the associated player belongs to
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Public method | GetOdds | Gets the odds in specified format (Inherited from IOutcomeOddsV1)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace
IOutcomeOdds


IPlayerOutcomeOdds Properties

The IPlayerOutcomeOdds type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets a value indicating whether the current IOutcome is active - i.e. should bets on it be accepted (Inherited from IOutcomeProbabilities)
Public property | AdditionalProbabilities | Additional probability attributes for markets which potentially will be (partly) refunded (Inherited from IOutcomeProbabilitiesV1)
Public property | HomeOrAwayTeam | Gets the value indicating whether the associated team is home or away
Public property | Id | Gets the value uniquely identifying the current instance (Inherited from IOutcome)
Public property | Odds | Obsolete. Gets the odds for the current IOutcomeOdds instance (Inherited from IOutcomeOdds)
Public property | Probabilities | Gets the probabilities for the current IOutcome instance (Inherited from IOutcomeProbabilities)
Top
See Also

Reference

IPlayerOutcomeOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IPlayerOutcomeOdds.HomeOrAwayTeam Property

IPlayerOutcomeOddsHomeOrAwayTeam Property

Gets the value indicating whether the associated team is home or away

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
HomeAway HomeOrAwayTeam { get; }

Property Value

HomeAway
The value indicating whether the associated team is home or away
See Also

Reference

IPlayerOutcomeOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IPlayerOutcomeOdds Methods

The IPlayerOutcomeOdds type exposes the following members.

Methods
 | Name | Description
Public method | GetCompetitorAsync | Asynchronously gets the team to which the associated player belongs to
Public method | GetMappedOutcomeIdAsync | Obsolete. Asynchronously gets the mapping Id of the specified outcome (Inherited from IOutcome)
Public method | GetMappedOutcomeIdsAsync | Asynchronously gets the mapping Ids of the specified outcome (Inherited from IOutcome)
Public method | GetNameAsync | Asynchronously gets the name of the outcome in the specified language (Inherited from IOutcome)
Public method | GetOdds | Gets the odds in specified format (Inherited from IOutcomeOddsV1)
Top
See Also

Reference

IPlayerOutcomeOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IPlayerOutcomeOdds.GetCompetitorAsync Method

IPlayerOutcomeOddsGetCompetitorAsync Method

Asynchronously gets the team to which the associated player belongs to

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ITeamCompetitor> GetCompetitorAsync()

Return Value

Task ITeamCompetitor
A TaskTResult representing the async operation
See Also

Reference

IPlayerOutcomeOdds Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IProducerStatusChange Interface

Defines a contract implemented by messages indicating that a producer status changed to down or up

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IProducerStatusChange : IMessage

The IProducerStatusChange type exposes the following members.

Properties
 | Name | Description
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IProducerStatusChange Properties

The IProducerStatusChange type exposes the following members.

Properties
 | Name | Description
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Top
See Also

Reference

IProducerStatusChange Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IRollbackBetCancel<T> Interface

IRollbackBetCancelT Interface

Defines a contract implemented by bet-cancel-rollback messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IRollbackBetCancel<out T> : IMarketMessage<IMarketCancel, T>,
    IEventMessage<T>, IMessageV1, IMessage
where T : ISportEvent

Type Parameters

T
A ICompetition derived type specifying the type of the associated sport event

The IRollbackBetCancelT type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | Gets number of milliseconds from UTC epoch representing the end of rollback cancellation period. A null value indicates the period ended when the market was closed
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | StartTime | Gets number of milliseconds from UTC epoch representing the start of rollback cancellation period. A null value indicates the period started with market activation
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IRollbackBetCancel<T> Properties

IRollbackBetCancelT Properties

The IRollbackBetCancelT type exposes the following members.

Properties
 | Name | Description
Public property | EndTime | Gets number of milliseconds from UTC epoch representing the end of rollback cancellation period. A null value indicates the period ended when the market was closed
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | StartTime | Gets number of milliseconds from UTC epoch representing the start of rollback cancellation period. A null value indicates the period started with market activation
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

IRollbackBetCancelT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IRollbackBetCancel<T>.EndTime Property

IRollbackBetCancelTEndTime Property

Gets number of milliseconds from UTC epoch representing the end of rollback cancellation period. A null value indicates the period ended when the market was closed

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long? EndTime { get; }

Property Value

Nullable Int64
See Also

Reference

IRollbackBetCancelT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IRollbackBetCancel<T>.StartTime Property

IRollbackBetCancelTStartTime Property

Gets number of milliseconds from UTC epoch representing the start of rollback cancellation period. A null value indicates the period started with market activation

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long? StartTime { get; }

Property Value

Nullable Int64
See Also

Reference

IRollbackBetCancelT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


IRollbackBetSettlement<T> Interface

IRollbackBetSettlementT Interface

Defines a contract implemented by bet-settlement-rollback messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IRollbackBetSettlement<out T> : IMarketMessage<IMarketCancel, T>,
    IEventMessage<T>, IMessageV1, IMessage
where T : ISportEvent

Type Parameters

T
A ICompetition derived type specifying the type of the associated sport event

The IRollbackBetSettlementT type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


IRollbackBetSettlement<T> Properties

IRollbackBetSettlementT Properties

The IRollbackBetSettlementT type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets a ISportEvent derived instance representing the sport event associated with the current message (Inherited from IEventMessageT)
Public property | Markets | Gets a IEnumerableT describing markets associated with the current IMarketMessageT, T1 (Inherited from IMarketMessageT, T1)
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RawMessage | Gets the raw message (Inherited from IEventMessageT)
Public property | RequestId | Get the id of the request which triggered the current IEventMessageT message or a null reference if no requestId was provided to the request (Inherited from IEventMessageT)
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Public property | Timestamps | Gets the timestamps when the message was generated, sent, received and dispatched by the sdk (Inherited from IMessageV1)
Top
See Also

Reference

IRollbackBetSettlementT Interface
Sportradar.OddsFeed.SDK.Entities Namespace


ISnapshotCompleted Interface

Defines a contract implemented by messages indicating that all messages from the requested snapshot were send

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISnapshotCompleted : IMessage

The ISnapshotCompleted type exposes the following members.

Properties
 | Name | Description
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RequestId | Get the id of the request which triggered the current ISnapshotCompleted message
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


ISnapshotCompleted Properties

The ISnapshotCompleted type exposes the following members.

Properties
 | Name | Description
Public property | Producer | Gets a Producer specifying the producer / service which dispatched the current IMessage message (Inherited from IMessage)
Public property | RequestId | Get the id of the request which triggered the current ISnapshotCompleted message
Public property | Timestamp | Obsolete. Gets the value specifying when the message was generated in the milliseconds since EPOCH UTC (Inherited from IMessage)
Top
See Also

Reference

ISnapshotCompleted Interface
Sportradar.OddsFeed.SDK.Entities Namespace


ISnapshotCompleted.RequestId Property

ISnapshotCompletedRequestId Property

Get the id of the request which triggered the current ISnapshotCompleted message

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long RequestId { get; }

Property Value

Int64
See Also

Reference

ISnapshotCompleted Interface
Sportradar.OddsFeed.SDK.Entities Namespace


MarketStatus Enumeration

Enumerates market statuses

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum MarketStatus
Members
Member name | Value | Description
INACTIVE | 0 | Indicates the market should NOT be displayed and bets on it should NOT be accepted
ACTIVE | 1 | Indicating that the market should be displayed and bets on it should be accepted
SUSPENDED | -1 | Indicates that the market should be displayed but the bets on it should NOT be accepted
HANDED_OVER | -2 | Indicates the market was handed over from one odds producer to another. If the odds for this market were already received from another producer this update should be ignored, otherwise associated market should be suspended until such odds are received.
SETTLED | -3 | Indicates the markets has already been settled by a previous message
CANCELLED | -4 | Indicates the markets has already been cancelled by a previous message
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest Class

Defines which messages will be provided by feed
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.EntitiesMessageInterest

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class MessageInterest

The MessageInterest type exposes the following members.

Properties
 | Name | Description
Public property | IsScopeInterest | Gets the value indicating whether the current interest is a scope interest (live, prematch or virt)
Public property | Name | Gets the name of the message interest
Public property | ProducerId | Gets the routing key used to select appropriate AMQP exchange
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
 | FromScope | Gets a MessageInterest representing a scope specified by it's name.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsCombinationValid | Determines whether the provided list of MessageInterest is a valid combination of sessions
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
 | SpecificEventsOnly | Constructs a MessageInterest indicating an interest in messages associated with specific events
Public method | ToString | Constructs a String representation of the current instance (Overrides ObjectToString)
Top
Fields
Name | Description
AllMessages | Constructs a MessageInterest indicating an interest in all messages
DefinedInterests | Gets all available MessageInterest instances
HighPriorityMessages | Constructs a MessageInterest indicating an interest in hi priority messages
LiveMessagesOnly | Constructs a MessageInterest indicating an interest in live messages
LowPriorityMessages | Constructs a MessageInterest indicating an interest in low priority messages
MessageScopes | List of MessageInterest representing defined messages scopes
PrematchMessagesOnly | Constructs a MessageInterest indicating an interest in pre-match messages
VirtualSportMessages | Constructs a MessageInterest indicating an interest in messages for virtual sports
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest Properties

The MessageInterest type exposes the following members.

Properties
 | Name | Description
Public property | IsScopeInterest | Gets the value indicating whether the current interest is a scope interest (live, prematch or virt)
Public property | Name | Gets the name of the message interest
Public property | ProducerId | Gets the routing key used to select appropriate AMQP exchange
Top
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.IsScopeInterest Property

MessageInterestIsScopeInterest Property

Gets the value indicating whether the current interest is a scope interest (live, prematch or virt)

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool IsScopeInterest { get; }

Property Value

Boolean
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.Name Property

MessageInterestName Property

Gets the name of the message interest

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Name { get; }

Property Value

String
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.ProducerId Property

MessageInterestProducerId Property

Gets the routing key used to select appropriate AMQP exchange

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int ProducerId { get; }

Property Value

Int32
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest Methods

The MessageInterest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
 | FromScope | Gets a MessageInterest representing a scope specified by it's name.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsCombinationValid | Determines whether the provided list of MessageInterest is a valid combination of sessions
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
 | SpecificEventsOnly | Constructs a MessageInterest indicating an interest in messages associated with specific events
Public method | ToString | Constructs a String representation of the current instance (Overrides ObjectToString)
Top
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.FromScope Method

MessageInterestFromScope Method

Gets a MessageInterest representing a scope specified by it's name.

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static MessageInterest FromScope(
    string scopeName
)

Parameters

scopeName String
The name of the scope

Return Value

MessageInterest
The MessageInterest representing a scope specified by it's name.
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.IsCombinationValid Method

MessageInterestIsCombinationValid Method

Determines whether the provided list of MessageInterest is a valid combination of sessions

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static bool IsCombinationValid(
    IEnumerable<MessageInterest> interests
)

Parameters

interests IEnumerable MessageInterest

Return Value

Boolean
True if the provided combination is valid. Otherwise false
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.SpecificEventsOnly Method

MessageInterestSpecificEventsOnly Method

Constructs a MessageInterest indicating an interest in messages associated with specific events

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static MessageInterest SpecificEventsOnly(
    IEnumerable<URN> eventIds
)

Parameters

eventIds IEnumerable URN
A IEnumerableT specifying the target events

Return Value

MessageInterest
A MessageInterest indicating an interest in messages associated with specific events
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.ToString Method

MessageInterestToString Method

Constructs a String representation of the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
Returns current instance represented as string
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest Fields

The MessageInterest type exposes the following members.

Fields
Name | Description
AllMessages | Constructs a MessageInterest indicating an interest in all messages
DefinedInterests | Gets all available MessageInterest instances
HighPriorityMessages | Constructs a MessageInterest indicating an interest in hi priority messages
LiveMessagesOnly | Constructs a MessageInterest indicating an interest in live messages
LowPriorityMessages | Constructs a MessageInterest indicating an interest in low priority messages
MessageScopes | List of MessageInterest representing defined messages scopes
PrematchMessagesOnly | Constructs a MessageInterest indicating an interest in pre-match messages
VirtualSportMessages | Constructs a MessageInterest indicating an interest in messages for virtual sports
Top
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.AllMessages Field

MessageInterestAllMessages Field

Constructs a MessageInterest indicating an interest in all messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly MessageInterest AllMessages

Return Value

MessageInterest
A MessageInterest indicating an interest in all messages
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.DefinedInterests Field

MessageInterestDefinedInterests Field

Gets all available MessageInterest instances

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly IEnumerable<MessageInterest> DefinedInterests

Field Value

IEnumerable MessageInterest
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.HighPriorityMessages Field

MessageInterestHighPriorityMessages Field

Constructs a MessageInterest indicating an interest in hi priority messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly MessageInterest HighPriorityMessages

Return Value

MessageInterest
A MessageInterest indicating an interest in high priority messages
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.LiveMessagesOnly Field

MessageInterestLiveMessagesOnly Field

Constructs a MessageInterest indicating an interest in live messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly MessageInterest LiveMessagesOnly

Return Value

MessageInterest
A MessageInterest indicating an interest in live messages
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.LowPriorityMessages Field

MessageInterestLowPriorityMessages Field

Constructs a MessageInterest indicating an interest in low priority messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly MessageInterest LowPriorityMessages

Return Value

MessageInterest
A MessageInterest indicating an interest in low priority messages
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.MessageScopes Field

MessageInterestMessageScopes Field

List of MessageInterest representing defined messages scopes

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly MessageInterest[] MessageScopes

Field Value

MessageInterest
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.PrematchMessagesOnly Field

MessageInterestPrematchMessagesOnly Field

Constructs a MessageInterest indicating an interest in pre-match messages

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly MessageInterest PrematchMessagesOnly

Return Value

MessageInterest
A MessageInterest indicating an interest in pre-match messages
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


MessageInterest.VirtualSportMessages Field

MessageInterestVirtualSportMessages Field

Constructs a MessageInterest indicating an interest in messages for virtual sports

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly MessageInterest VirtualSportMessages

Return Value

MessageInterest
A MessageInterest indicating an interest in messages for virtual sports
See Also

Reference

MessageInterest Class
Sportradar.OddsFeed.SDK.Entities Namespace


OddsChangeReason Enumeration

Enumerates possible reasons why the odds-change was generated

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum OddsChangeReason
Members
Member name | Value | Description
NORMAL | 0 | Indicates the message was generated by normal service execution
RISK_ADJUSTMENT | 1 | Indicates the message was generated due to risk adjustment
SYSTEM_DOWN | 2 | Indicates the message was generated because the feed system went down
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


OddsDisplayType Enumeration

Enumerates possible options for displaying outcome odds

Namespace: Sportradar.OddsFeed.SDK.Entities
Assembly: Sportradar.OddsFeed.SDK.Entities (in Sportradar.OddsFeed.SDK.Entities.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum OddsDisplayType
Members
Member name | Value | Description
Decimal | 0 | The decimal format
American | 1 | The American odds format
See Also

Reference

Sportradar.OddsFeed.SDK.Entities Namespace


Sportradar.OddsFeed.SDK.Entities.REST Namespace

Interfaces
 | Interface | Description
Public interface | IAssist | Defines a contract implemented by classes representing assists on a sport event
Public interface | IBaseEntity | Defines a contract for classes implementing basic entity information, containing Id as URN and translatable Name
Public interface | IBasicTournament | Defines a contract for classes implementing tournament information
Public interface | IBasicTournamentV1 | Defines a contract for classes implementing tournament information
Public interface | IBasicTournamentV2 | Defines a contract for classes implementing tournament information
Public interface | IBonusInfo | Defines a contract for classes implementing the bonus info
Public interface | IBookmakerDetails | Defines a contract implemented by classes representing bookmaker information
Public interface | ICar | Represents a car
Public interface | ICategory | Defines a contract implemented by classes representing sport category
Public interface | ICategorySummary | Defines a contract implemented by classes representing sport category
Public interface | ICompetition | Defines a contract implemented by classes representing sport events regardless to which sport they belong
Public interface | ICompetitionStatistics | Defines a contract for classes implementing competition specific statistics
Public interface | ICompetitionStatus | Defines a contract implemented by classes representing the status of a ICompetition
Public interface | ICompetitionStatusV1 | Defines a contract implemented by classes representing the status of a ICompetition
Public interface | ICompetitionV1 | Defines a contract implemented by classes representing sport events regardless to which sport they belong
Public interface | ICompetitionV2 | Defines a contract implemented by classes representing sport events regardless to which sport they belong
Public interface | ICompetitionV3 | Defines a contract implemented by classes representing sport events regardless to which sport they belong
Public interface | ICompetitor | Represents a team competing in a sport event
Public interface | ICompetitorResult | Defines contract used by classes that provide competitor result information
Public interface | ICompetitorV1 | Represents a team competing in a sport event
Public interface | ICompetitorV2 | Represents a team competing in a sport event
Public interface | ICompetitorV3 | Represents a team competing in a sport event
Public interface | ICompetitorV4 | Represents a team competing in a sport event
Public interface | ICompetitorV5 | Represents a team competing in a sport event
Public interface | ICompetitorV6 | Represents a team competing in a sport event
Public interface | ICoverageInfo | Defines a contract implemented by classes providing coverage information
Public interface | ICoverageInfoV1 | Defines a contract implemented by classes providing coverage information
Public interface | ICurrentSeasonInfo | Defines a contract implemented by classes providing information about current season
Public interface | IDelayedInfo | Defines a contract implemented by classes representing delayed info in a sport event
Public interface | IDraw | Defines a contract implemented by classes, which represent information about a lottery draw
Public interface | IDrawInfo | Defines a contract for classes implementing the draw info
Public interface | IDrawResult | Defines a contract for classes implementing the draw result
Public interface | IDrawV1 | Defines a contract implemented by classes, which represent information about a lottery draw
Public interface | IEntityPrinter | A contract for implementing entity printer
Public interface | IEventClock | Defines a contract implemented by classes representing the event clock
Public interface | IEventPlayer | Defines a contract implemented by classes representing players or racers in a sport event timeline events
Public interface | IEventResult | Defines methods used by classes that provide event result information
Public interface | IEventResultV1 | Defines methods used by classes that provide event result information
Public interface | IEventResultV2 | Defines methods used by classes that provide event result information
Public interface | IEventTimeline | Defines a contract for classes implementing event timeline for specific ISportEvent
Public interface | IFixture | Defines a contract implemented by classes representing a fixture
Public interface | IFixtureChange | Defines a contract implemented by classes representing fixture change
Public interface | IGoalScorer | Defines a contract implemented by classes representing goal scorer in a sport event
Public interface | IGoalScorerV1 | Defines a contract implemented by classes representing goal scorer in a sport event
Public interface | IGroup | Defines a contract implemented by classes representing a competition group
Public interface | IGroupV1 | Defines a contract implemented by classes representing a competition group
Public interface | IHole | Defines a contract implemented by classes representing a hole of a golf course
Public interface | IJersey | Defines a contract for classes implementing jersey
Public interface | IJerseyV1 | Defines a contract for classes implementing jersey
Public interface | ILocalizedNamedValue | Specifies a contract implemented by classes representing values with localized / translatable descriptions
Public interface | ILongTermEvent | Defines a contract for classes implementing long term sport event
Public interface | ILottery | Defines a contract implemented by classes, which represent information about a lottery
Public interface | ILotteryV1 | Defines a contract implemented by classes, which represent information about a lottery
Public interface | IManager | Defines a contract for classes implementing manager info
Public interface | IMatch | Defines a contract implemented by classes representing sport events of match type
Public interface | IMatchStatus | Defines a contract implemented by classes representing a match status
Public interface | IMatchStatusV1 | Defines a contract implemented by classes representing a match status
Public interface | IMatchStatusV2 | Defines a contract implemented by classes representing a match status
Public interface | IMatchStatusV3 | Defines a contract implemented by classes representing a match status
Public interface | IMatchV1 | Defines a contract implemented by classes representing sport events of match type
Public interface | IMatchV2 | Defines a contract implemented by classes representing sport events of match type
Public interface | IMatchV3 | Defines a contract implemented by classes representing sport events of match type
Public interface | INamedValue | Specifies a contract implemented by classes representing values with names / descriptions
Public interface | IPeriodCompetitorResult | Defines a contract implemented by classes representing competitor result per period
Public interface | IPeriodScore | Defines a contract implemented by classes representing a score of a sport event period
Public interface | IPeriodStatistics | Defines a contract for classes implementing period statistics
Public interface | IPeriodStatus | Defines a contract implemented by classes representing period status
Public interface | IPitcher | Defines a contract implemented by classes representing sport event pitcher
Public interface | IPlayer | Defines a contract implemented by classes representing players or racers in a sport event
Public interface | IPlayerProfile | Defines a contract implemented by classes representing a player profile
Public interface | IPlayerProfileV1 | Defines a contract implemented by classes representing a player profile
Public interface | IPlayerProfileV2 | Defines a contract implemented by classes representing a player profile
Public interface | IProductInfo | Defines a contract implemented by classes providing product information
Public interface | IProductInfoLink | Defines a contract implemented by classes representing product info links
Public interface | IProductInfoV1 | Defines a contract implemented by classes providing product information
Public interface | IRaceDriverProfile | Represents a race driver profile
Public interface | IReferee | Defines a contract implemented by classes representing sport event referee
Public interface | IReference | A contract for classes implementing array a+of references
Public interface | IReferenceV1 | A contract for classes implementing array a+of references
Public interface | IRestMessage | Defines a contract implemented by all classes representing messages received from the feed's REST interface
Public interface | IResultChange | Defines a contract implemented by classes representing result change
Public interface | IRound | Defines a contract implemented by classes providing basic tournament round information
Public interface | IRoundV1 | Defines a contract implemented by classes providing basic tournament round information
Public interface | IRoundV2 | Defines a contract implemented by classes providing basic tournament round information
Public interface | IRoundV3 | Defines a contract implemented by classes providing basic tournament round information
Public interface | IScheduledStartTimeChange | Defines a contract implemented by classes providing schedule start time change
Public interface | ISeason | Defines a contract implemented by classes representing a tournament season
Public interface | ISeasonCoverage | Defines an interface representing season coverage info
Public interface | ISeasonInfo | Defines a contract for classes implementing
Public interface | ISeasonInfoV1 | Defines a contract for classes implementing
Public interface | ISoccerEvent | Defines a contract for classes representing soccer sport events
Public interface | ISoccerStatistics | Defines a contract for classes implementing soccer match specific statistics
Public interface | ISoccerStatus | Defines a contract for classes representing soccer status
Public interface | ISport | Defines a contract implemented by classes representing a sport
Public interface | ISportEvent | Defines a contract implemented by classes representing the target(tournament, match, race) of feed messages
Public interface | ISportEventConditions | Defines a contract implemented by classes representing sport event conditions
Public interface | ISportEventConditionsV1 | Defines a contract implemented by classes representing sport event conditions
Public interface | ISportEventStatus | Defines a contract implemented by classes representing the status of a sport event
Public interface | ISportEventV1 | Defines a contract implemented by classes representing the target(tournament, match, race) of feed messages
Public interface | ISportSummary | Defines a contract implemented by classes representing a sport
Public interface | IStage | Defines methods implemented by classes representing sport events of stage type
Public interface | IStageStatus | Defines a contract implemented by classes representing a stage status
Public interface | IStageV1 | Defines methods implemented by classes representing sport events of stage type
Public interface | IStageV2 | Defines methods implemented by classes representing sport events of stage type
Public interface | IStageV3 | Defines methods implemented by classes representing sport events of stage type
Public interface | IStreamingChannel | Defines a contract implemented by classes representing streaming channels
Public interface | ITeamCompetitor | Defines a contract implemented by classes representing a competing team
Public interface | ITeamCompetitorV1 | Defines a contract implemented by classes representing a competing team
Public interface | ITeamStatistics | Defines a contract for classes implementing team statistics
Public interface | ITeamStatisticsV1 | Defines a contract for classes implementing team statistics
Public interface | ITeamStatisticsV2 | Defines a contract for classes implementing team statistics
Public interface | ITimelineEvent | Defines a contract for classes implementing timeline event
Public interface | ITimelineEventV1 | Defines a contract for classes implementing timeline event
Public interface | ITimelineEventV2 | Defines a contract for classes implementing timeline event
Public interface | ITournament | Defines a contract implemented by classes providing information about tournament schedule
Public interface | ITournamentCoverage | Defines a contract for classes implementing tournament coverage information
Public interface | ITournamentInfo | Defines a contract for classes representing tournament info
Public interface | ITournamentV1 | Defines a contract implemented by classes providing information about tournament schedule
Public interface | ITournamentV2 | Defines a contract implemented by classes providing information about tournament schedule
Public interface | ITvChannel | Defines a contract implemented by classes representing TV channels
Public interface | ITvChannelV1 | Defines a contract implemented by classes representing TV channels
Public interface | IVenue | Defines a contract implemented by classes representing a sport event venue
Public interface | IVenueV1 | Defines a contract implemented by classes representing a sport event venue
Public interface | IVenueV2 | Defines a contract implemented by classes representing a sport event venue
Public interface | IWeatherInfo | Defines a contract implemented by classes representing weather conditions


IAssist Interface

Defines a contract implemented by classes representing assists on a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IAssist : IPlayer,
    IEntityPrinter

The IAssist type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | Type | Gets a String specifying the type of the assist
Top
Methods
 | Name | Description
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IAssist Properties

The IAssist type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | Type | Gets a String specifying the type of the assist
Top
See Also

Reference

IAssist Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IAssist.Type Property

IAssistType Property

Gets a String specifying the type of the assist

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Type { get; }

Property Value

String
See Also

Reference

IAssist Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IAssist Methods

The IAssist type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IAssist Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBaseEntity Interface

Defines a contract for classes implementing basic entity information, containing Id as URN and translatable Name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IBaseEntity : IEntityPrinter

The IBaseEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the URN identifying the current instance
Public property | Names | Gets the list of translated names
Top
Methods
 | Name | Description
Public method | GetName | Gets the name associated with this instance in specific language
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBaseEntity Properties

The IBaseEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the URN identifying the current instance
Public property | Names | Gets the list of translated names
Top
See Also

Reference

IBaseEntity Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBaseEntity.Id Property

IBaseEntityId Property

Gets the URN identifying the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
The URN identifying the current instance
See Also

Reference

IBaseEntity Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBaseEntity.Names Property

IBaseEntityNames Property

Gets the list of translated names

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Names { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
The list of translated names
See Also

Reference

IBaseEntity Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBaseEntity Methods

The IBaseEntity type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name associated with this instance in specific language
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IBaseEntity Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBaseEntity.GetName Method

IBaseEntityGetName Method

Gets the name associated with this instance in specific language

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
The language used to get the name

Return Value

String
Name if available in specified language or null
See Also

Reference

IBaseEntity Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBasicTournament Interface

Defines a contract for classes implementing tournament information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IBasicTournament : ILongTermEvent,
    ISportEvent

The IBasicTournament type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetCategoryAsync | Asynchronously gets the category
Public method | GetCompetitorsAsync | Asynchronously gets the competitors
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace
ILongTermEvent


IBasicTournament Properties

The IBasicTournament type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IBasicTournament Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBasicTournament Methods

The IBasicTournament type exposes the following members.

Methods
 | Name | Description
Public method | GetCategoryAsync | Asynchronously gets the category
Public method | GetCompetitorsAsync | Asynchronously gets the competitors
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

IBasicTournament Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBasicTournament.GetCategoryAsync Method

IBasicTournamentGetCategoryAsync Method

Asynchronously gets the category

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICategorySummary> GetCategoryAsync()

Return Value

Task ICategorySummary
The category
See Also

Reference

IBasicTournament Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBasicTournament.GetCompetitorsAsync Method

IBasicTournamentGetCompetitorsAsync Method

Asynchronously gets the competitors

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ICompetitor>> GetCompetitorsAsync()

Return Value

Task IEnumerable ICompetitor
The competitors
See Also

Reference

IBasicTournament Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBasicTournamentV1 Interface

Defines a contract for classes implementing tournament information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IBasicTournamentV1 : IBasicTournament,
    ILongTermEvent, ISportEvent

The IBasicTournamentV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetCategoryAsync | Asynchronously gets the category (Inherited from IBasicTournament)
Public method | GetCompetitorsAsync | Asynchronously gets the competitors (Inherited from IBasicTournament)
Public method | GetExhibitionGamesAsync | Asynchronously gets a Boolean specifying if the tournament is exhibition game
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace
ILongTermEvent


IBasicTournamentV1 Properties

The IBasicTournamentV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IBasicTournamentV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBasicTournamentV1 Methods

The IBasicTournamentV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetCategoryAsync | Asynchronously gets the category (Inherited from IBasicTournament)
Public method | GetCompetitorsAsync | Asynchronously gets the competitors (Inherited from IBasicTournament)
Public method | GetExhibitionGamesAsync | Asynchronously gets a Boolean specifying if the tournament is exhibition game
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

IBasicTournamentV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBasicTournamentV1.GetExhibitionGamesAsync Method

IBasicTournamentV1GetExhibitionGamesAsync Method

Asynchronously gets a Boolean specifying if the tournament is exhibition game

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<bool?> GetExhibitionGamesAsync()

Return Value

Task Nullable Boolean
A Boolean specifying if the tournament is exhibition game
See Also

Reference

IBasicTournamentV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBasicTournamentV2 Interface

Defines a contract for classes implementing tournament information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IBasicTournamentV2 : IBasicTournamentV1,
    IBasicTournament, ILongTermEvent, ISportEvent

The IBasicTournamentV2 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetCategoryAsync | Asynchronously gets the category (Inherited from IBasicTournament)
Public method | GetCompetitorsAsync | Asynchronously gets the competitors (Inherited from IBasicTournament)
Public method | GetExhibitionGamesAsync | Asynchronously gets a Boolean specifying if the tournament is exhibition game (Inherited from IBasicTournamentV1)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduleAsync | Gets the list of all ICompetition that belongs to the basic tournament schedule
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace
ILongTermEvent


IBasicTournamentV2 Properties

The IBasicTournamentV2 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IBasicTournamentV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBasicTournamentV2 Methods

The IBasicTournamentV2 type exposes the following members.

Methods
 | Name | Description
Public method | GetCategoryAsync | Asynchronously gets the category (Inherited from IBasicTournament)
Public method | GetCompetitorsAsync | Asynchronously gets the competitors (Inherited from IBasicTournament)
Public method | GetExhibitionGamesAsync | Asynchronously gets a Boolean specifying if the tournament is exhibition game (Inherited from IBasicTournamentV1)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduleAsync | Gets the list of all ICompetition that belongs to the basic tournament schedule
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

IBasicTournamentV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBasicTournamentV2.GetScheduleAsync Method

IBasicTournamentV2GetScheduleAsync Method

Gets the list of all ICompetition that belongs to the basic tournament schedule

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ISportEvent>> GetScheduleAsync()

Return Value

Task IEnumerable ISportEvent
The list of all ICompetition that belongs to the basic tournament schedule
See Also

Reference

IBasicTournamentV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBonusInfo Interface

Defines a contract for classes implementing the bonus info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IBonusInfo

The IBonusInfo type exposes the following members.

Properties
 | Name | Description
Public property | BonusBalls | Gets the bonus balls info
Public property | BonusDrumType | Gets the type of the bonus drum
Public property | BonusRange | Gets the bonus range
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBonusInfo Properties

The IBonusInfo type exposes the following members.

Properties
 | Name | Description
Public property | BonusBalls | Gets the bonus balls info
Public property | BonusDrumType | Gets the type of the bonus drum
Public property | BonusRange | Gets the bonus range
Top
See Also

Reference

IBonusInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBonusInfo.BonusBalls Property

IBonusInfoBonusBalls Property

Gets the bonus balls info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? BonusBalls { get; }

Property Value

Nullable Int32
The bonus balls info or null if not known
See Also

Reference

IBonusInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBonusInfo.BonusDrumType Property

IBonusInfoBonusDrumType Property

Gets the type of the bonus drum

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
BonusDrumType? BonusDrumType { get; }

Property Value

Nullable BonusDrumType
The type of the bonus drum or null if not known
See Also

Reference

IBonusInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBonusInfo.BonusRange Property

IBonusInfoBonusRange Property

Gets the bonus range

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string BonusRange { get; }

Property Value

String
The bonus range
See Also

Reference

IBonusInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBookmakerDetails Interface

Defines a contract implemented by classes representing bookmaker information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IBookmakerDetails : IEntityPrinter

The IBookmakerDetails type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Gets the Sportradar's provided bookmaker id of the associated bookmaker
Public property | ExpireAt | Gets a value specifying the bookmaker's token will expire
Public property | Message | Gets an optional message associated with the current instance
Public property | ResponseCode | Gets the response code of the server's response or a null reference
Public property | ServerTimeDifference | Gets the server time difference
Public property | VirtualHost | Gets the virtual host which should be used when connecting to the AMQP broker
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBookmakerDetails Properties

The IBookmakerDetails type exposes the following members.

Properties
 | Name | Description
Public property | BookmakerId | Gets the Sportradar's provided bookmaker id of the associated bookmaker
Public property | ExpireAt | Gets a value specifying the bookmaker's token will expire
Public property | Message | Gets an optional message associated with the current instance
Public property | ResponseCode | Gets the response code of the server's response or a null reference
Public property | ServerTimeDifference | Gets the server time difference
Public property | VirtualHost | Gets the virtual host which should be used when connecting to the AMQP broker
Top
See Also

Reference

IBookmakerDetails Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBookmakerDetails.BookmakerId Property

IBookmakerDetailsBookmakerId Property

Gets the Sportradar's provided bookmaker id of the associated bookmaker

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int BookmakerId { get; }

Property Value

Int32
See Also

Reference

IBookmakerDetails Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBookmakerDetails.ExpireAt Property

IBookmakerDetailsExpireAt Property

Gets a value specifying the bookmaker's token will expire

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime ExpireAt { get; }

Property Value

DateTime
See Also

Reference

IBookmakerDetails Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBookmakerDetails.Message Property

IBookmakerDetailsMessage Property

Gets an optional message associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Message { get; }

Property Value

String
See Also

Reference

IBookmakerDetails Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBookmakerDetails.ResponseCode Property

IBookmakerDetailsResponseCode Property

Gets the response code of the server's response or a null reference

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
HttpStatusCode? ResponseCode { get; }

Property Value

Nullable HttpStatusCode
See Also

Reference

IBookmakerDetails Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBookmakerDetails.ServerTimeDifference Property

IBookmakerDetailsServerTimeDifference Property

Gets the server time difference

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
TimeSpan ServerTimeDifference { get; }

Property Value

TimeSpan
The server time difference
See Also

Reference

IBookmakerDetails Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBookmakerDetails.VirtualHost Property

IBookmakerDetailsVirtualHost Property

Gets the virtual host which should be used when connecting to the AMQP broker

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string VirtualHost { get; }

Property Value

String
See Also

Reference

IBookmakerDetails Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IBookmakerDetails Methods

The IBookmakerDetails type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IBookmakerDetails Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICar Interface

Represents a car

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICar

The ICar type exposes the following members.

Properties
 | Name | Description
Public property | Chassis | Gets the car chassis
Public property | EngineName | Gets the car engine name
Public property | Name | Gets the car name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICar Properties

The ICar type exposes the following members.

Properties
 | Name | Description
Public property | Chassis | Gets the car chassis
Public property | EngineName | Gets the car engine name
Public property | Name | Gets the car name
Top
See Also

Reference

ICar Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICar.Chassis Property

ICarChassis Property

Gets the car chassis

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Chassis { get; }

Property Value

String
The car chassis
See Also

Reference

ICar Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICar.EngineName Property

ICarEngineName Property

Gets the car engine name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string EngineName { get; }

Property Value

String
The car engine name
See Also

Reference

ICar Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICar.Name Property

ICarName Property

Gets the car name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

String
The car name
See Also

Reference

ICar Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICategory Interface

Defines a contract implemented by classes representing sport category

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICategory : ICategorySummary,
    IEntityPrinter

The ICategory type exposes the following members.

Properties
 | Name | Description
Public property | CountryCode | Gets the country code (Inherited from ICategorySummary)
Public property | Id | Gets a URN uniquely identifying the category represented by the current instance (Inherited from ICategorySummary)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing translated category name (Inherited from ICategorySummary)
Public property | Tournaments | Gets a IEnumerableT representing the tournaments which belong to the category represented by the current instance
Top
Methods
 | Name | Description
Public method | GetName | Gets the name in specified culture language (Inherited from ICategorySummary)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICategory Properties

The ICategory type exposes the following members.

Properties
 | Name | Description
Public property | CountryCode | Gets the country code (Inherited from ICategorySummary)
Public property | Id | Gets a URN uniquely identifying the category represented by the current instance (Inherited from ICategorySummary)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing translated category name (Inherited from ICategorySummary)
Public property | Tournaments | Gets a IEnumerableT representing the tournaments which belong to the category represented by the current instance
Top
See Also

Reference

ICategory Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICategory.Tournaments Property

ICategoryTournaments Property

Gets a IEnumerableT representing the tournaments which belong to the category represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<ISportEvent> Tournaments { get; }

Property Value

IEnumerable ISportEvent
See Also

Reference

ICategory Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICategory Methods

The ICategory type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name in specified culture language (Inherited from ICategorySummary)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ICategory Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICategorySummary Interface

Defines a contract implemented by classes representing sport category

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICategorySummary : IEntityPrinter

The ICategorySummary type exposes the following members.

Properties
 | Name | Description
Public property | CountryCode | Gets the country code
Public property | Id | Gets a URN uniquely identifying the category represented by the current instance
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing translated category name
Top
Methods
 | Name | Description
Public method | GetName | Gets the name in specified culture language
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICategorySummary Properties

The ICategorySummary type exposes the following members.

Properties
 | Name | Description
Public property | CountryCode | Gets the country code
Public property | Id | Gets a URN uniquely identifying the category represented by the current instance
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing translated category name
Top
See Also

Reference

ICategorySummary Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICategorySummary.CountryCode Property

ICategorySummaryCountryCode Property

Gets the country code

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string CountryCode { get; }

Property Value

String
The country code
See Also

Reference

ICategorySummary Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICategorySummary.Id Property

ICategorySummaryId Property

Gets a URN uniquely identifying the category represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

ICategorySummary Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICategorySummary.Names Property

ICategorySummaryNames Property

Gets a IReadOnlyDictionaryTKey, TValue containing translated category name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Names { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

ICategorySummary Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICategorySummary Methods

The ICategorySummary type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name in specified culture language
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ICategorySummary Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICategorySummary.GetName Method

ICategorySummaryGetName Method

Gets the name in specified culture language

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture.

Return Value

String
System.String.
See Also

Reference

ICategorySummary Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetition Interface

Defines a contract implemented by classes representing sport events regardless to which sport they belong

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetition : ISportEvent

The ICompetition type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetition Properties

The ICompetition type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ICompetition Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetition Methods

The ICompetition type exposes the following members.

Methods
 | Name | Description
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place
Top
See Also

Reference

ICompetition Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetition.GetBookingStatusAsync Method

ICompetitionGetBookingStatusAsync Method

Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<BookingStatus?> GetBookingStatusAsync()

Return Value

Task Nullable BookingStatus
Returns a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known
See Also

Reference

ICompetition Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetition.GetCompetitorsAsync Method

ICompetitionGetCompetitorsAsync Method

Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ICompetitor>> GetCompetitorsAsync()

Return Value

Task IEnumerable ICompetitor
A TaskTResult representing the retrieval operation
See Also

Reference

ICompetition Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetition.GetConditionsAsync Method

ICompetitionGetConditionsAsync Method

Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ISportEventConditions> GetConditionsAsync()

Return Value

Task ISportEventConditions
A TaskTResult representing the retrieval operation
Remarks
A Fixture is a sport event that has been arranged for a particular time and place
See Also

Reference

ICompetition Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetition.GetStatusAsync Method

ICompetitionGetStatusAsync Method

Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICompetitionStatus> GetStatusAsync()

Return Value

Task ICompetitionStatus
A ICompetitionStatus instance containing information about the progress of the sport event
See Also

Reference

ICompetition Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetition.GetVenueAsync Method

ICompetitionGetVenueAsync Method

Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IVenue> GetVenueAsync()

Return Value

Task IVenue
A TaskTResult representing the retrieval operation
See Also

Reference

ICompetition Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatistics Interface

Defines a contract for classes implementing competition specific statistics

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitionStatistics
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatus Interface

Defines a contract implemented by classes representing the status of a ICompetition

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitionStatus

The ICompetitionStatus type exposes the following members.

Properties
 | Name | Description
Public property | EventResults | Gets the event results
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event
Public property | WinnerId | Gets the winner identifier
Top
Methods
 | Name | Description
Public method | GetPropertyValue | Gets the value of the property specified by it's name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatus Properties

The ICompetitionStatus type exposes the following members.

Properties
 | Name | Description
Public property | EventResults | Gets the event results
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event
Public property | WinnerId | Gets the winner identifier
Top
See Also

Reference

ICompetitionStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatus.EventResults Property

ICompetitionStatusEventResults Property

Gets the event results

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IEventResult> EventResults { get; }

Property Value

IEnumerable IEventResult
The event results
See Also

Reference

ICompetitionStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatus.Properties Property

ICompetitionStatusProperties Property

Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<string, Object> Properties { get; }

Property Value

IReadOnlyDictionary String, Object
a IReadOnlyDictionaryTKey, TValue containing additional event status values
See Also

Reference

ICompetitionStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatus.ReportingStatus Property

ICompetitionStatusReportingStatus Property

Returns a ReportingStatus describing the reporting status of the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ReportingStatus ReportingStatus { get; }

Property Value

ReportingStatus
See Also

Reference

ICompetitionStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatus.Status Property

ICompetitionStatusStatus Property

Gets a EventStatus describing the high-level status of the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
EventStatus Status { get; }

Property Value

EventStatus
See Also

Reference

ICompetitionStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatus.WinnerId Property

ICompetitionStatusWinnerId Property

Gets the winner identifier

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN WinnerId { get; }

Property Value

URN
The winner identifier, if available, otherwise null
See Also

Reference

ICompetitionStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatus Methods

The ICompetitionStatus type exposes the following members.

Methods
 | Name | Description
Public method | GetPropertyValue | Gets the value of the property specified by it's name
Top
See Also

Reference

ICompetitionStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatus.GetPropertyValue Method

ICompetitionStatusGetPropertyValue Method

Gets the value of the property specified by it's name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Object GetPropertyValue(
    string propertyName
)

Parameters

propertyName String
The name of the property

Return Value

Object
A Object representation of the value of the specified property, or a null reference if the value of the specified property was not specified
See Also

Reference

ICompetitionStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatusV1 Interface

Defines a contract implemented by classes representing the status of a ICompetition

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitionStatusV1 : ICompetitionStatus

The ICompetitionStatusV1 type exposes the following members.

Properties
 | Name | Description
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | PeriodOfLadder | Gets the period of ladder
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
Methods
 | Name | Description
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatusV1 Properties

The ICompetitionStatusV1 type exposes the following members.

Properties
 | Name | Description
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | PeriodOfLadder | Gets the period of ladder
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
See Also

Reference

ICompetitionStatusV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatusV1.PeriodOfLadder Property

ICompetitionStatusV1PeriodOfLadder Property

Gets the period of ladder

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? PeriodOfLadder { get; }

Property Value

Nullable Int32
The period of ladder
See Also

Reference

ICompetitionStatusV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionStatusV1 Methods

The ICompetitionStatusV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
See Also

Reference

ICompetitionStatusV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV1 Interface

Defines a contract implemented by classes representing sport events regardless to which sport they belong

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitionV1 : ICompetition,
    ISportEvent

The ICompetitionV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetEventStatusAsync | Gets the event status asynchronous
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance (Inherited from ICompetition)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV1 Properties

The ICompetitionV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ICompetitionV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV1 Methods

The ICompetitionV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetEventStatusAsync | Gets the event status asynchronous
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance (Inherited from ICompetition)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

ICompetitionV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV1.GetEventStatusAsync Method

ICompetitionV1GetEventStatusAsync Method

Gets the event status asynchronous

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<EventStatus?> GetEventStatusAsync()

Return Value

Task Nullable EventStatus
Get the event status
See Also

Reference

ICompetitionV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV2 Interface

Defines a contract implemented by classes representing sport events regardless to which sport they belong

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitionV2 : ICompetitionV1,
    ICompetition, ISportEvent, ISportEventV1

The ICompetitionV2 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetLiveOddsAsync | Asynchronously gets a liveOdds
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetReplacedByAsync | Asynchronously gets a URN specifying the replacement sport event for the associated sport event. (Inherited from ISportEventV1)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportEventTypeAsync | Asynchronously get the type of the stage
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStartTimeTbdAsync | Asynchronously gets a NullableT specifying if the start time to be determined is set for the associated sport event. (Inherited from ISportEventV1)
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance (Inherited from ICompetition)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV2 Properties

The ICompetitionV2 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ICompetitionV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV2 Methods

The ICompetitionV2 type exposes the following members.

Methods
 | Name | Description
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetLiveOddsAsync | Asynchronously gets a liveOdds
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetReplacedByAsync | Asynchronously gets a URN specifying the replacement sport event for the associated sport event. (Inherited from ISportEventV1)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportEventTypeAsync | Asynchronously get the type of the stage
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStartTimeTbdAsync | Asynchronously gets a NullableT specifying if the start time to be determined is set for the associated sport event. (Inherited from ISportEventV1)
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance (Inherited from ICompetition)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

ICompetitionV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV2.GetLiveOddsAsync Method

ICompetitionV2GetLiveOddsAsync Method

Asynchronously gets a liveOdds

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<string> GetLiveOddsAsync()

Return Value

Task String
A liveOdds
See Also

Reference

ICompetitionV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV2.GetSportEventTypeAsync Method

ICompetitionV2GetSportEventTypeAsync Method

Asynchronously get the type of the stage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<SportEventType?> GetSportEventTypeAsync()

Return Value

Task Nullable SportEventType
The type of the stage
See Also

Reference

ICompetitionV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV3 Interface

Defines a contract implemented by classes representing sport events regardless to which sport they belong

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitionV3 : ICompetitionV2,
    ICompetitionV1, ICompetition, ISportEvent, ISportEventV1

The ICompetitionV3 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorIdsAsync | Asynchronously gets a list of competitor ids associated with the current instance
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetCompetitorsAsync(CultureInfo) | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetLiveOddsAsync | Asynchronously gets a liveOdds (Inherited from ICompetitionV2)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetReplacedByAsync | Asynchronously gets a URN specifying the replacement sport event for the associated sport event. (Inherited from ISportEventV1)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportEventTypeAsync | Asynchronously get the type of the stage (Inherited from ICompetitionV2)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStartTimeTbdAsync | Asynchronously gets a NullableT specifying if the start time to be determined is set for the associated sport event. (Inherited from ISportEventV1)
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance (Inherited from ICompetition)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV3 Properties

The ICompetitionV3 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ICompetitionV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV3 Methods

The ICompetitionV3 type exposes the following members.

Methods
 | Name | Description
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorIdsAsync | Asynchronously gets a list of competitor ids associated with the current instance
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetCompetitorsAsync(CultureInfo) | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetLiveOddsAsync | Asynchronously gets a liveOdds (Inherited from ICompetitionV2)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetReplacedByAsync | Asynchronously gets a URN specifying the replacement sport event for the associated sport event. (Inherited from ISportEventV1)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportEventTypeAsync | Asynchronously get the type of the stage (Inherited from ICompetitionV2)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStartTimeTbdAsync | Asynchronously gets a NullableT specifying if the start time to be determined is set for the associated sport event. (Inherited from ISportEventV1)
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance (Inherited from ICompetition)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

ICompetitionV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV3.GetCompetitorIdsAsync Method

ICompetitionV3GetCompetitorIdsAsync Method

Asynchronously gets a list of competitor ids associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<URN>> GetCompetitorIdsAsync(
    CultureInfo culture = null
)

Parameters

culture CultureInfo (Optional)
Optional culture in which we want to fetch competitor data (otherwise default is used)

Return Value

Task IEnumerable URN
A list of competitor ids associated with the current instance
See Also

Reference

ICompetitionV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV3.GetCompetitorsAsync Method

ICompetitionV3GetCompetitorsAsync Method

Overload List
 | Name | Description
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance
Public method | GetCompetitorsAsync(CultureInfo) | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance
Top
See Also

Reference

ICompetitionV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitionV3.GetCompetitorsAsync(CultureInfo) Method

ICompetitionV3GetCompetitorsAsync(CultureInfo) Method

Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ICompetitor>> GetCompetitorsAsync(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture in which we want to return competitor data

Return Value

Task IEnumerable ICompetitor
A TaskTResult representing the retrieval operation
See Also

Reference

ICompetitionV3 Interface
GetCompetitorsAsync Overload
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor Interface

Represents a team competing in a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitor : IPlayer,
    IEntityPrinter

The ICompetitor type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages
Public property | AssociatedPlayers | Gets the list of associated player ids
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages
Public property | CountryCode | Gets the country code
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team
Public property | Jerseys | Gets the jerseys of known competitors
Public property | Manager | Gets the manager
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | References | Gets the reference ids
Public property | Venue | Gets the venue
Top
Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference.
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference.
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor Properties

The ICompetitor type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages
Public property | AssociatedPlayers | Gets the list of associated player ids
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages
Public property | CountryCode | Gets the country code
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team
Public property | Jerseys | Gets the jerseys of known competitors
Public property | Manager | Gets the manager
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | References | Gets the reference ids
Public property | Venue | Gets the venue
Top
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor.Abbreviations Property

ICompetitorAbbreviations Property

Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Abbreviations { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor.AssociatedPlayers Property

ICompetitorAssociatedPlayers Property

Gets the list of associated player ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IPlayer> AssociatedPlayers { get; }

Property Value

IEnumerable IPlayer
The associated player ids
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor.Countries Property

ICompetitorCountries Property

Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Countries { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor.CountryCode Property

ICompetitorCountryCode Property

Gets the country code

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string CountryCode { get; }

Property Value

String
The country code
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor.IsVirtual Property

ICompetitorIsVirtual Property

Gets a value indicating whether the current instance represents a placeholder team

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsVirtual { get; }

Property Value

Boolean
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor.Jerseys Property

ICompetitorJerseys Property

Gets the jerseys of known competitors

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IJersey> Jerseys { get; }

Property Value

IEnumerable IJersey
The jerseys
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor.Manager Property

ICompetitorManager Property

Gets the manager

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IManager Manager { get; }

Property Value

IManager
The manager
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor.References Property

ICompetitorReferences Property

Gets the reference ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReference References { get; }

Property Value

IReference
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor.Venue Property

ICompetitorVenue Property

Gets the venue

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IVenue Venue { get; }

Property Value

IVenue
The venue
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor Methods

The ICompetitor type exposes the following members.

Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference.
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference.
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor.GetAbbreviation Method

ICompetitorGetAbbreviation Method

Gets the competitor's abbreviation in the specified language or a null reference.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetAbbreviation(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language of the abbreviation.

Return Value

String
The competitor's abbreviation in the specified language or a null reference.
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitor.GetCountry Method

ICompetitorGetCountry Method

Gets the competitor's country name in the specified language or a null reference.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetCountry(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language of the country name.

Return Value

String
The competitor's country name in the specified language or a null reference.
See Also

Reference

ICompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorResult Interface

Defines contract used by classes that provide competitor result information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitorResult

The ICompetitorResult type exposes the following members.

Properties
 | Name | Description
Public property | Specifiers | Gets the specifiers
Public property | Type | Get the type
Public property | Value | Gets the value
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorResult Properties

The ICompetitorResult type exposes the following members.

Properties
 | Name | Description
Public property | Specifiers | Gets the specifiers
Public property | Type | Get the type
Public property | Value | Gets the value
Top
See Also

Reference

ICompetitorResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorResult.Specifiers Property

ICompetitorResultSpecifiers Property

Gets the specifiers

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Specifiers { get; }

Property Value

String
The specifiers
See Also

Reference

ICompetitorResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorResult.Type Property

ICompetitorResultType Property

Get the type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Type { get; }

Property Value

String
See Also

Reference

ICompetitorResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorResult.Value Property

ICompetitorResultValue Property

Gets the value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Value { get; }

Property Value

String
The value
See Also

Reference

ICompetitorResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV1 Interface

Represents a team competing in a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitorV1 : ICompetitor,
    IPlayer, IEntityPrinter

The ICompetitorV1 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Gender | Gets the gender
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV1 Properties

The ICompetitorV1 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Gender | Gets the gender
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
See Also

Reference

ICompetitorV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV1.Gender Property

ICompetitorV1Gender Property

Gets the gender

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Gender { get; }

Property Value

String
The gender
See Also

Reference

ICompetitorV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV1 Methods

The ICompetitorV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ICompetitorV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV2 Interface

Represents a team competing in a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitorV2 : ICompetitorV1,
    ICompetitor, IPlayer, IEntityPrinter

The ICompetitorV2 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Gender | Gets the gender (Inherited from ICompetitorV1)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | RaceDriverProfile | Gets the race driver profile
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV2 Properties

The ICompetitorV2 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Gender | Gets the gender (Inherited from ICompetitorV1)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | RaceDriverProfile | Gets the race driver profile
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
See Also

Reference

ICompetitorV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV2.RaceDriverProfile Property

ICompetitorV2RaceDriverProfile Property

Gets the race driver profile

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IRaceDriverProfile RaceDriverProfile { get; }

Property Value

IRaceDriverProfile
The race driver profile
See Also

Reference

ICompetitorV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV2 Methods

The ICompetitorV2 type exposes the following members.

Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ICompetitorV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV3 Interface

Represents a team competing in a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitorV3 : ICompetitorV2,
    ICompetitorV1, ICompetitor, IPlayer, IEntityPrinter

The ICompetitorV3 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AgeGroup | Gets the age group
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Gender | Gets the gender (Inherited from ICompetitorV1)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | RaceDriverProfile | Gets the race driver profile (Inherited from ICompetitorV2)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV3 Properties

The ICompetitorV3 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AgeGroup | Gets the age group
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Gender | Gets the gender (Inherited from ICompetitorV1)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | RaceDriverProfile | Gets the race driver profile (Inherited from ICompetitorV2)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
See Also

Reference

ICompetitorV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV3.AgeGroup Property

ICompetitorV3AgeGroup Property

Gets the age group

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string AgeGroup { get; }

Property Value

String
The age group
See Also

Reference

ICompetitorV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV3 Methods

The ICompetitorV3 type exposes the following members.

Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ICompetitorV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV4 Interface

Represents a team competing in a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitorV4 : ICompetitorV3,
    ICompetitorV2, ICompetitorV1, ICompetitor, IPlayer, IEntityPrinter

The ICompetitorV4 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AgeGroup | Gets the age group (Inherited from ICompetitorV3)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Gender | Gets the gender (Inherited from ICompetitorV1)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | RaceDriverProfile | Gets the race driver profile (Inherited from ICompetitorV2)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | State | Gets the state
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV4 Properties

The ICompetitorV4 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AgeGroup | Gets the age group (Inherited from ICompetitorV3)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Gender | Gets the gender (Inherited from ICompetitorV1)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | RaceDriverProfile | Gets the race driver profile (Inherited from ICompetitorV2)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | State | Gets the state
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
See Also

Reference

ICompetitorV4 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV4.State Property

ICompetitorV4State Property

Gets the state

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string State { get; }

Property Value

String
The state
See Also

Reference

ICompetitorV4 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV4 Methods

The ICompetitorV4 type exposes the following members.

Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ICompetitorV4 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV5 Interface

Represents a team competing in a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitorV5 : ICompetitorV4,
    ICompetitorV3, ICompetitorV2, ICompetitorV1, ICompetitor, IPlayer,
    IEntityPrinter

The ICompetitorV5 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AgeGroup | Gets the age group (Inherited from ICompetitorV3)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Gender | Gets the gender (Inherited from ICompetitorV1)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | RaceDriverProfile | Gets the race driver profile (Inherited from ICompetitorV2)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | State | Gets the state (Inherited from ICompetitorV4)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCategoryAsync | Gets associated category
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | GetSportAsync | Gets associated sport
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV5 Properties

The ICompetitorV5 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AgeGroup | Gets the age group (Inherited from ICompetitorV3)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Gender | Gets the gender (Inherited from ICompetitorV1)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | RaceDriverProfile | Gets the race driver profile (Inherited from ICompetitorV2)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | State | Gets the state (Inherited from ICompetitorV4)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
See Also

Reference

ICompetitorV5 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV5 Methods

The ICompetitorV5 type exposes the following members.

Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCategoryAsync | Gets associated category
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | GetSportAsync | Gets associated sport
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ICompetitorV5 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV5.GetCategoryAsync Method

ICompetitorV5GetCategoryAsync Method

Gets associated category

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICategorySummary> GetCategoryAsync()

Return Value

Task ICategorySummary
The associated category
See Also

Reference

ICompetitorV5 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV5.GetSportAsync Method

ICompetitorV5GetSportAsync Method

Gets associated sport

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ISport> GetSportAsync()

Return Value

Task ISport
The associated sport
See Also

Reference

ICompetitorV5 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV6 Interface

Represents a team competing in a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICompetitorV6 : ICompetitorV5,
    ICompetitorV4, ICompetitorV3, ICompetitorV2, ICompetitorV1, ICompetitor,
    IPlayer, IEntityPrinter

The ICompetitorV6 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AgeGroup | Gets the age group (Inherited from ICompetitorV3)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Gender | Gets the gender (Inherited from ICompetitorV1)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | RaceDriverProfile | Gets the race driver profile (Inherited from ICompetitorV2)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | ShortName | Gets the short name
Public property | State | Gets the state (Inherited from ICompetitorV4)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCategoryAsync | Gets associated category (Inherited from ICompetitorV5)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | GetSportAsync | Gets associated sport (Inherited from ICompetitorV5)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV6 Properties

The ICompetitorV6 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AgeGroup | Gets the age group (Inherited from ICompetitorV3)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Gender | Gets the gender (Inherited from ICompetitorV1)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | RaceDriverProfile | Gets the race driver profile (Inherited from ICompetitorV2)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | ShortName | Gets the short name
Public property | State | Gets the state (Inherited from ICompetitorV4)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
See Also

Reference

ICompetitorV6 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV6.ShortName Property

ICompetitorV6ShortName Property

Gets the short name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string ShortName { get; }

Property Value

String
The short name
See Also

Reference

ICompetitorV6 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICompetitorV6 Methods

The ICompetitorV6 type exposes the following members.

Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCategoryAsync | Gets associated category (Inherited from ICompetitorV5)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | GetSportAsync | Gets associated sport (Inherited from ICompetitorV5)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ICompetitorV6 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICoverageInfo Interface

Defines a contract implemented by classes providing coverage information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICoverageInfo : IEntityPrinter

The ICoverageInfo type exposes the following members.

Properties
 | Name | Description
Public property | Includes | Gets a IEnumerableT specifying what is included in the coverage represented by the current ICoverageInfo instance
Public property | IsLive | Gets a value indicating whether the coverage represented by current ICoverageInfo is live coverage
Public property | Level | Gets a String describing the level of the available coverage
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICoverageInfo Properties

The ICoverageInfo type exposes the following members.

Properties
 | Name | Description
Public property | Includes | Gets a IEnumerableT specifying what is included in the coverage represented by the current ICoverageInfo instance
Public property | IsLive | Gets a value indicating whether the coverage represented by current ICoverageInfo is live coverage
Public property | Level | Gets a String describing the level of the available coverage
Top
See Also

Reference

ICoverageInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICoverageInfo.Includes Property

ICoverageInfoIncludes Property

Gets a IEnumerableT specifying what is included in the coverage represented by the current ICoverageInfo instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<string> Includes { get; }

Property Value

IEnumerable String
See Also

Reference

ICoverageInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICoverageInfo.IsLive Property

ICoverageInfoIsLive Property

Gets a value indicating whether the coverage represented by current ICoverageInfo is live coverage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsLive { get; }

Property Value

Boolean
See Also

Reference

ICoverageInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICoverageInfo.Level Property

ICoverageInfoLevel Property

Gets a String describing the level of the available coverage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Level { get; }

Property Value

String
See Also

Reference

ICoverageInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICoverageInfo Methods

The ICoverageInfo type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ICoverageInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICoverageInfoV1 Interface

Defines a contract implemented by classes providing coverage information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICoverageInfoV1 : ICoverageInfo,
    IEntityPrinter

The ICoverageInfoV1 type exposes the following members.

Properties
 | Name | Description
Public property | CoveredFrom | Gets a CoveredFrom describing the coverage location
Public property | Includes | Gets a IEnumerableT specifying what is included in the coverage represented by the current ICoverageInfo instance (Inherited from ICoverageInfo)
Public property | IsLive | Gets a value indicating whether the coverage represented by current ICoverageInfo is live coverage (Inherited from ICoverageInfo)
Public property | Level | Gets a String describing the level of the available coverage (Inherited from ICoverageInfo)
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICoverageInfoV1 Properties

The ICoverageInfoV1 type exposes the following members.

Properties
 | Name | Description
Public property | CoveredFrom | Gets a CoveredFrom describing the coverage location
Public property | Includes | Gets a IEnumerableT specifying what is included in the coverage represented by the current ICoverageInfo instance (Inherited from ICoverageInfo)
Public property | IsLive | Gets a value indicating whether the coverage represented by current ICoverageInfo is live coverage (Inherited from ICoverageInfo)
Public property | Level | Gets a String describing the level of the available coverage (Inherited from ICoverageInfo)
Top
See Also

Reference

ICoverageInfoV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICoverageInfoV1.CoveredFrom Property

ICoverageInfoV1CoveredFrom Property

Gets a CoveredFrom describing the coverage location

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
CoveredFrom? CoveredFrom { get; }

Property Value

Nullable CoveredFrom
See Also

Reference

ICoverageInfoV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICoverageInfoV1 Methods

The ICoverageInfoV1 type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ICoverageInfoV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo Interface

Defines a contract implemented by classes providing information about current season

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICurrentSeasonInfo

The ICurrentSeasonInfo type exposes the following members.

Properties
 | Name | Description
Public property | Competitors | Gets the list of competitors
Public property | Coverage | Gets the ISeasonCoverage instance containing information about coverage available for the season associated with the current instance
Public property | CurrentRound | Gets the IRound specifying the current round of the tournament associated with the current instance
Public property | EndDate | Gets the end date of the season represented by the current instance
Public property | Groups | Gets the IEnumerableT specifying groups of tournament associated with the current instance
Public property | Id | Gets a URN uniquely identifying the current season
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing names of the season in different languages
Public property | Schedule | Gets the list of all ICompetition that belongs to the season schedule
Public property | StartDate | Gets the start date of the season represented by the current instance
Public property | Year | Gets a String representation of the current season year
Top
Methods
 | Name | Description
Public method | GetName | Gets the season name in the specified languages
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo Properties

The ICurrentSeasonInfo type exposes the following members.

Properties
 | Name | Description
Public property | Competitors | Gets the list of competitors
Public property | Coverage | Gets the ISeasonCoverage instance containing information about coverage available for the season associated with the current instance
Public property | CurrentRound | Gets the IRound specifying the current round of the tournament associated with the current instance
Public property | EndDate | Gets the end date of the season represented by the current instance
Public property | Groups | Gets the IEnumerableT specifying groups of tournament associated with the current instance
Public property | Id | Gets a URN uniquely identifying the current season
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing names of the season in different languages
Public property | Schedule | Gets the list of all ICompetition that belongs to the season schedule
Public property | StartDate | Gets the start date of the season represented by the current instance
Public property | Year | Gets a String representation of the current season year
Top
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo.Competitors Property

ICurrentSeasonInfoCompetitors Property

Gets the list of competitors

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<ICompetitor> Competitors { get; }

Property Value

IEnumerable ICompetitor
The list of competitors
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo.Coverage Property

ICurrentSeasonInfoCoverage Property

Gets the ISeasonCoverage instance containing information about coverage available for the season associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ISeasonCoverage Coverage { get; }

Return Value

ISeasonCoverage
The ISeasonCoverage instance containing information about coverage available for the season associated with the current instance
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo.CurrentRound Property

ICurrentSeasonInfoCurrentRound Property

Gets the IRound specifying the current round of the tournament associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IRound CurrentRound { get; }

Return Value

IRound
The IRound specifying the current round of the tournament associated with the current instance
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo.EndDate Property

ICurrentSeasonInfoEndDate Property

Gets the end date of the season represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime EndDate { get; }

Property Value

DateTime
The end date.
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo.Groups Property

ICurrentSeasonInfoGroups Property

Gets the IEnumerableT specifying groups of tournament associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IGroup> Groups { get; }

Return Value

IEnumerable IGroup
The IEnumerableT specifying groups of tournament associated with the current instance
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo.Id Property

ICurrentSeasonInfoId Property

Gets a URN uniquely identifying the current season

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo.Names Property

ICurrentSeasonInfoNames Property

Gets a IReadOnlyDictionaryTKey, TValue containing names of the season in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Names { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo.Schedule Property

ICurrentSeasonInfoSchedule Property

Gets the list of all ICompetition that belongs to the season schedule

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<ISportEvent> Schedule { get; }

Return Value

IEnumerable ISportEvent
The list of all ICompetition that belongs to the season schedule
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo.StartDate Property

ICurrentSeasonInfoStartDate Property

Gets the start date of the season represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime StartDate { get; }

Property Value

DateTime
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo.Year Property

ICurrentSeasonInfoYear Property

Gets a String representation of the current season year

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Year { get; }

Property Value

String
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo Methods

The ICurrentSeasonInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the season name in the specified languages
Top
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ICurrentSeasonInfo.GetName Method

ICurrentSeasonInfoGetName Method

Gets the season name in the specified languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language of the returned name.

Return Value

String
The season name in the specified languages.
See Also

Reference

ICurrentSeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDelayedInfo Interface

Defines a contract implemented by classes representing delayed info in a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IDelayedInfo

The IDelayedInfo type exposes the following members.

Properties
 | Name | Description
Public property | Descriptions | Gets the list of translated names
Public property | Id | Gets the id identifying the current instance
Top
Methods
 | Name | Description
Public method | GetDescription | Gets the description associated with this instance in specific language
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDelayedInfo Properties

The IDelayedInfo type exposes the following members.

Properties
 | Name | Description
Public property | Descriptions | Gets the list of translated names
Public property | Id | Gets the id identifying the current instance
Top
See Also

Reference

IDelayedInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDelayedInfo.Descriptions Property

IDelayedInfoDescriptions Property

Gets the list of translated names

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Descriptions { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
The list of translated names
See Also

Reference

IDelayedInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDelayedInfo.Id Property

IDelayedInfoId Property

Gets the id identifying the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Id { get; }

Property Value

Int32
The id identifying the current instance
See Also

Reference

IDelayedInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDelayedInfo Methods

The IDelayedInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetDescription | Gets the description associated with this instance in specific language
Top
See Also

Reference

IDelayedInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDelayedInfo.GetDescription Method

IDelayedInfoGetDescription Method

Gets the description associated with this instance in specific language

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetDescription(
    CultureInfo culture
)

Parameters

culture CultureInfo
The language used to get the description

Return Value

String
Description if available in specified language or null
See Also

Reference

IDelayedInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDraw Interface

Defines a contract implemented by classes, which represent information about a lottery draw

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IDraw : ISportEvent

The IDraw type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetLotteryIdAsync | Asynchronously gets a URN representing id of the associated ILottery
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetResultsAsync | Asynchronously gets IEnumerableT list of associated IDrawResult
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously gets DrawStatus associated with the current instance
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDraw Properties

The IDraw type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IDraw Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDraw Methods

The IDraw type exposes the following members.

Methods
 | Name | Description
Public method | GetLotteryIdAsync | Asynchronously gets a URN representing id of the associated ILottery
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetResultsAsync | Asynchronously gets IEnumerableT list of associated IDrawResult
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously gets DrawStatus associated with the current instance
Top
See Also

Reference

IDraw Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDraw.GetLotteryIdAsync Method

IDrawGetLotteryIdAsync Method

Asynchronously gets a URN representing id of the associated ILottery

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<URN> GetLotteryIdAsync()

Return Value

Task URN
The id of the associated lottery
See Also

Reference

IDraw Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDraw.GetResultsAsync Method

IDrawGetResultsAsync Method

Asynchronously gets IEnumerableT list of associated IDrawResult

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IDrawResult>> GetResultsAsync()

Return Value

Task IEnumerable IDrawResult
A TaskTResult representing an async operation
See Also

Reference

IDraw Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDraw.GetStatusAsync Method

IDrawGetStatusAsync Method

Asynchronously gets DrawStatus associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<DrawStatus> GetStatusAsync()

Return Value

Task DrawStatus
A TaskTResult representing an async operation
See Also

Reference

IDraw Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawInfo Interface

Defines a contract for classes implementing the draw info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IDrawInfo

The IDrawInfo type exposes the following members.

Properties
 | Name | Description
Public property | DrawType | Gets the type of the draw
Public property | GameType | Gets the type of the game
Public property | TimeType | Gets the type of the time
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawInfo Properties

The IDrawInfo type exposes the following members.

Properties
 | Name | Description
Public property | DrawType | Gets the type of the draw
Public property | GameType | Gets the type of the game
Public property | TimeType | Gets the type of the time
Top
See Also

Reference

IDrawInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawInfo.DrawType Property

IDrawInfoDrawType Property

Gets the type of the draw

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DrawType DrawType { get; }

Property Value

DrawType
The type of the draw
See Also

Reference

IDrawInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawInfo.GameType Property

IDrawInfoGameType Property

Gets the type of the game

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GameType { get; }

Property Value

String
The type of the game
See Also

Reference

IDrawInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawInfo.TimeType Property

IDrawInfoTimeType Property

Gets the type of the time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
TimeType TimeType { get; }

Property Value

TimeType
The type of the time
See Also

Reference

IDrawInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawResult Interface

Defines a contract for classes implementing the draw result

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IDrawResult

The IDrawResult type exposes the following members.

Properties
 | Name | Description
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing translated names
Public property | Value | Gets the value of the draw
Top
Methods
 | Name | Description
Public method | GetName | Gets the name in specified culture language
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawResult Properties

The IDrawResult type exposes the following members.

Properties
 | Name | Description
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing translated names
Public property | Value | Gets the value of the draw
Top
See Also

Reference

IDrawResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawResult.Names Property

IDrawResultNames Property

Gets a IReadOnlyDictionaryTKey, TValue containing translated names

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Names { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

IDrawResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawResult.Value Property

IDrawResultValue Property

Gets the value of the draw

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Value { get; }

Property Value

Nullable Int32
See Also

Reference

IDrawResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawResult Methods

The IDrawResult type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name in specified culture language
Top
See Also

Reference

IDrawResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawResult.GetName Method

IDrawResultGetName Method

Gets the name in specified culture language

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture

Return Value

String
System.String.
See Also

Reference

IDrawResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawV1 Interface

Defines a contract implemented by classes, which represent information about a lottery draw

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IDrawV1 : IDraw,
    ISportEvent

The IDrawV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetDisplayIdAsync | Asynchronously gets a Int32 representing display id
Public method | GetLotteryIdAsync | Asynchronously gets a URN representing id of the associated ILottery (Inherited from IDraw)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetResultsAsync | Asynchronously gets IEnumerableT list of associated IDrawResult (Inherited from IDraw)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously gets DrawStatus associated with the current instance (Inherited from IDraw)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawV1 Properties

The IDrawV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IDrawV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawV1 Methods

The IDrawV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetDisplayIdAsync | Asynchronously gets a Int32 representing display id
Public method | GetLotteryIdAsync | Asynchronously gets a URN representing id of the associated ILottery (Inherited from IDraw)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetResultsAsync | Asynchronously gets IEnumerableT list of associated IDrawResult (Inherited from IDraw)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously gets DrawStatus associated with the current instance (Inherited from IDraw)
Top
See Also

Reference

IDrawV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IDrawV1.GetDisplayIdAsync Method

IDrawV1GetDisplayIdAsync Method

Asynchronously gets a Int32 representing display id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<int?> GetDisplayIdAsync()

Return Value

Task Nullable Int32
The display id
See Also

Reference

IDrawV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEntityPrinter Interface

A contract for implementing entity printer

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEntityPrinter

The IEntityPrinter type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance.
Public method | ToString(IFormatProvider) | Returns a string that represents the current object
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format.
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEntityPrinter Methods

The IEntityPrinter type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance.
Public method | ToString(IFormatProvider) | Returns a string that represents the current object
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format.
Top
See Also

Reference

IEntityPrinter Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEntityPrinter.ToString Method

IEntityPrinterToString Method

Overload List
 | Name | Description
Public method | ToString | Returns a String that represents this instance.
Public method | ToString(IFormatProvider) | Returns a string that represents the current object
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format.
Top
See Also

Reference

IEntityPrinter Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEntityPrinter.ToString Method

IEntityPrinterToString Method

Returns a String that represents this instance.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string ToString()

Return Value

String
A String that represents this instance.
See Also

Reference

IEntityPrinter Interface
ToString Overload
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEntityPrinter.ToString(IFormatProvider) Method

IEntityPrinterToString(IFormatProvider) Method

Returns a string that represents the current object

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string ToString(
    IFormatProvider formatProvider
)

Parameters

formatProvider IFormatProvider
A format provider used to format the output string

Return Value

String
A string that represents the current object.
See Also

Reference

IEntityPrinter Interface
ToString Overload
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEntityPrinter.ToString(String, IFormatProvider) Method

IEntityPrinterToString(String, IFormatProvider) Method

Formats the value of the current instance using the specified format.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string ToString(
    string format,
    IFormatProvider formatProvider = null
)

Parameters

format String
The format to use.-or- A null reference (Nothing in Visual Basic) to use the default format defined for the type of the IFormattable implementation.
formatProvider IFormatProvider (Optional)
The provider to use to format the value.-or- A null reference (Nothing in Visual Basic) to obtain the numeric format information from the current locale setting of the operating system.

Return Value

String
The value of the current instance in the specified format.
See Also

Reference

IEntityPrinter Interface
ToString Overload
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventClock Interface

Defines a contract implemented by classes representing the event clock

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEventClock : IEntityPrinter

The IEventClock type exposes the following members.

Properties
 | Name | Description
Public property | EventTime | Gets the event time of the sport event associated with the current IEventClock instance
Public property | RemainingDate | Gets the remaining date
Public property | RemainingTimeInPeriod | Gets the remaining time in period
Public property | StoppageTime | Gets the representation of the time the event associated with the current IEventClock has been stopped
Public property | StoppageTimeAnnounced | Gets the announced stoppage time
Public property | Stopped | Gets a value indicating whether this IEventClock is stopped
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventClock Properties

The IEventClock type exposes the following members.

Properties
 | Name | Description
Public property | EventTime | Gets the event time of the sport event associated with the current IEventClock instance
Public property | RemainingDate | Gets the remaining date
Public property | RemainingTimeInPeriod | Gets the remaining time in period
Public property | StoppageTime | Gets the representation of the time the event associated with the current IEventClock has been stopped
Public property | StoppageTimeAnnounced | Gets the announced stoppage time
Public property | Stopped | Gets a value indicating whether this IEventClock is stopped
Top
See Also

Reference

IEventClock Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventClock.EventTime Property

IEventClockEventTime Property

Gets the event time of the sport event associated with the current IEventClock instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string EventTime { get; }

Property Value

String
See Also

Reference

IEventClock Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventClock.RemainingDate Property

IEventClockRemainingDate Property

Gets the remaining date

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string RemainingDate { get; }

Property Value

String
The remaining date
See Also

Reference

IEventClock Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventClock.RemainingTimeInPeriod Property

IEventClockRemainingTimeInPeriod Property

Gets the remaining time in period

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string RemainingTimeInPeriod { get; }

Property Value

String
The remaining time in period
See Also

Reference

IEventClock Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventClock.StoppageTime Property

IEventClockStoppageTime Property

Gets the representation of the time the event associated with the current IEventClock has been stopped

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string StoppageTime { get; }

Property Value

String
See Also

Reference

IEventClock Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventClock.StoppageTimeAnnounced Property

IEventClockStoppageTimeAnnounced Property

Gets the announced stoppage time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string StoppageTimeAnnounced { get; }

Property Value

String
See Also

Reference

IEventClock Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventClock.Stopped Property

IEventClockStopped Property

Gets a value indicating whether this IEventClock is stopped

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool? Stopped { get; }

Property Value

Nullable Boolean
true if stopped; otherwise, false
See Also

Reference

IEventClock Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventClock Methods

The IEventClock type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IEventClock Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventPlayer Interface

Defines a contract implemented by classes representing players or racers in a sport event timeline events

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEventPlayer : IEntityPrinter

The IEventPlayer type exposes the following members.

Properties
 | Name | Description
Public property | Bench | Gets the bench value
Public property | Id | Gets the URN uniquely identifying the current IPlayer instance
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages
Top
Methods
 | Name | Description
Public method | GetName | Gets the name of the player in the specified language or a null reference
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventPlayer Properties

The IEventPlayer type exposes the following members.

Properties
 | Name | Description
Public property | Bench | Gets the bench value
Public property | Id | Gets the URN uniquely identifying the current IPlayer instance
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages
Top
See Also

Reference

IEventPlayer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventPlayer.Bench Property

IEventPlayerBench Property

Gets the bench value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Bench { get; }

Property Value

String
The bench value - in case of yellow or red card event, it is relevant to know if the player who is getting the card is sitting on the bench at that exact moment.
Remarks
The attribute is equal to 1 if the player who gets the card is sitting on the bench. In case the player who gets the card is on the field, then the attribute is not added at all.
See Also

Reference

IEventPlayer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventPlayer.Id Property

IEventPlayerId Property

Gets the URN uniquely identifying the current IPlayer instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

IEventPlayer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventPlayer.Names Property

IEventPlayerNames Property

Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Names { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

IEventPlayer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventPlayer Methods

The IEventPlayer type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name of the player in the specified language or a null reference
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IEventPlayer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventPlayer.GetName Method

IEventPlayerGetName Method

Gets the name of the player in the specified language or a null reference

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language of the returned name

Return Value

String
The name of the player in the specified language or a null reference.
See Also

Reference

IEventPlayer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult Interface

Defines methods used by classes that provide event result information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEventResult

The IEventResult type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event
Public property | Climber | Obsolete. Gets the climber
Public property | ClimberDecimal | Gets the climber
Public property | ClimberRanking | Gets the climber ranking
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event
Public property | Id | Gets the id of the event result
Public property | MatchStatus | Obsolete. Gets the match status
Public property | Points | Obsolete. Gets the points of the result
Public property | PointsDecimal | Gets the points
Public property | Position | Gets the position of the result
Public property | Sprint | Obsolete. Gets the sprint of the result
Public property | SprintDecimal | Gets the sprint
Public property | SprintRanking | Gets the sprint ranking
Public property | Status | Gets the status of the result
Public property | StatusComment | Gets the status comment
Public property | Time | Gets the time of the result
Public property | TimeRanking | Gets the time ranking
Public property | WcPoints | Gets the wc?points
Top
Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult Properties

The IEventResult type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event
Public property | Climber | Obsolete. Gets the climber
Public property | ClimberDecimal | Gets the climber
Public property | ClimberRanking | Gets the climber ranking
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event
Public property | Id | Gets the id of the event result
Public property | MatchStatus | Obsolete. Gets the match status
Public property | Points | Obsolete. Gets the points of the result
Public property | PointsDecimal | Gets the points
Public property | Position | Gets the position of the result
Public property | Sprint | Obsolete. Gets the sprint of the result
Public property | SprintDecimal | Gets the sprint
Public property | SprintRanking | Gets the sprint ranking
Public property | Status | Gets the status of the result
Public property | StatusComment | Gets the status comment
Public property | Time | Gets the time of the result
Public property | TimeRanking | Gets the time ranking
Public property | WcPoints | Gets the wc?points
Top
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.AwayScore Property

IEventResultAwayScore Property

Gets the score of the away competitor competing on the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal? AwayScore { get; }

Property Value

Nullable Decimal
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.Climber Property

IEventResultClimber Property

Note: This API is now obsolete.

Gets the climber

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use ClimberDecimal")]
int? Climber { get; }

Property Value

Nullable Int32
The climber
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.ClimberDecimal Property

IEventResultClimberDecimal Property

Gets the climber

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal? ClimberDecimal { get; }

Property Value

Nullable Decimal
The climber
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.ClimberRanking Property

IEventResultClimberRanking Property

Gets the climber ranking

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? ClimberRanking { get; }

Property Value

Nullable Int32
The climber ranking
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.HomeScore Property

IEventResultHomeScore Property

Gets the score of the home competitor competing on the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal? HomeScore { get; }

Property Value

Nullable Decimal
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.Id Property

IEventResultId Property

Gets the id of the event result

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Id { get; }

Property Value

String
The id of the event result
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.MatchStatus Property

IEventResultMatchStatus Property

Note: This API is now obsolete.

Gets the match status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use GetMatchStatusAsync method instead")]
int MatchStatus { get; }

Property Value

Int32
The match status
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.Points Property

IEventResultPoints Property

Note: This API is now obsolete.

Gets the points of the result

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use PointsDecimal")]
int? Points { get; }

Property Value

Nullable Int32
The points of the result
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.PointsDecimal Property

IEventResultPointsDecimal Property

Gets the points

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal? PointsDecimal { get; }

Property Value

Nullable Decimal
The points
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.Position Property

IEventResultPosition Property

Gets the position of the result

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Position { get; }

Property Value

Nullable Int32
The position of the result
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.Sprint Property

IEventResultSprint Property

Note: This API is now obsolete.

Gets the sprint of the result

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use SprintDecimal")]
int? Sprint { get; }

Property Value

Nullable Int32
The sprint of the result
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.SprintDecimal Property

IEventResultSprintDecimal Property

Gets the sprint

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal? SprintDecimal { get; }

Property Value

Nullable Decimal
The sprint
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.SprintRanking Property

IEventResultSprintRanking Property

Gets the sprint ranking

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? SprintRanking { get; }

Property Value

Nullable Int32
The sprint ranking
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.Status Property

IEventResultStatus Property

Gets the status of the result

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Status { get; }

Property Value

String
The status of the result
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.StatusComment Property

IEventResultStatusComment Property

Gets the status comment

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string StatusComment { get; }

Property Value

String
The status comment
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.Time Property

IEventResultTime Property

Gets the time of the result

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Time { get; }

Property Value

String
The time of the result
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.TimeRanking Property

IEventResultTimeRanking Property

Gets the time ranking

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? TimeRanking { get; }

Property Value

Nullable Int32
The time ranking
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.WcPoints Property

IEventResultWcPoints Property

Gets the wc?points

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal? WcPoints { get; }

Property Value

Nullable Decimal
The wc?points
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult Methods

The IEventResult type exposes the following members.

Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status
Top
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResult.GetMatchStatusAsync Method

IEventResultGetMatchStatusAsync Method

Asynchronously gets the match status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ILocalizedNamedValue> GetMatchStatusAsync(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture used to get match status id and description

Return Value

Task ILocalizedNamedValue
Returns the match status id and description in selected culture
See Also

Reference

IEventResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResultV1 Interface

Defines methods used by classes that provide event result information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEventResultV1 : IEventResult

The IEventResultV1 type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event (Inherited from IEventResult)
Public property | Climber | Obsolete. Gets the climber (Inherited from IEventResult)
Public property | ClimberDecimal | Gets the climber (Inherited from IEventResult)
Public property | ClimberRanking | Gets the climber ranking (Inherited from IEventResult)
Public property | Grid | Gets the grid
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event (Inherited from IEventResult)
Public property | Id | Gets the id of the event result (Inherited from IEventResult)
Public property | MatchStatus | Obsolete. Gets the match status (Inherited from IEventResult)
Public property | Points | Obsolete. Gets the points of the result (Inherited from IEventResult)
Public property | PointsDecimal | Gets the points (Inherited from IEventResult)
Public property | Position | Gets the position of the result (Inherited from IEventResult)
Public property | Sprint | Obsolete. Gets the sprint of the result (Inherited from IEventResult)
Public property | SprintDecimal | Gets the sprint (Inherited from IEventResult)
Public property | SprintRanking | Gets the sprint ranking (Inherited from IEventResult)
Public property | Status | Gets the status of the result (Inherited from IEventResult)
Public property | StatusComment | Gets the status comment (Inherited from IEventResult)
Public property | Time | Gets the time of the result (Inherited from IEventResult)
Public property | TimeRanking | Gets the time ranking (Inherited from IEventResult)
Public property | WcPoints | Gets the wc?points (Inherited from IEventResult)
Top
Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status (Inherited from IEventResult)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResultV1 Properties

The IEventResultV1 type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event (Inherited from IEventResult)
Public property | Climber | Obsolete. Gets the climber (Inherited from IEventResult)
Public property | ClimberDecimal | Gets the climber (Inherited from IEventResult)
Public property | ClimberRanking | Gets the climber ranking (Inherited from IEventResult)
Public property | Grid | Gets the grid
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event (Inherited from IEventResult)
Public property | Id | Gets the id of the event result (Inherited from IEventResult)
Public property | MatchStatus | Obsolete. Gets the match status (Inherited from IEventResult)
Public property | Points | Obsolete. Gets the points of the result (Inherited from IEventResult)
Public property | PointsDecimal | Gets the points (Inherited from IEventResult)
Public property | Position | Gets the position of the result (Inherited from IEventResult)
Public property | Sprint | Obsolete. Gets the sprint of the result (Inherited from IEventResult)
Public property | SprintDecimal | Gets the sprint (Inherited from IEventResult)
Public property | SprintRanking | Gets the sprint ranking (Inherited from IEventResult)
Public property | Status | Gets the status of the result (Inherited from IEventResult)
Public property | StatusComment | Gets the status comment (Inherited from IEventResult)
Public property | Time | Gets the time of the result (Inherited from IEventResult)
Public property | TimeRanking | Gets the time ranking (Inherited from IEventResult)
Public property | WcPoints | Gets the wc?points (Inherited from IEventResult)
Top
See Also

Reference

IEventResultV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResultV1.Grid Property

IEventResultV1Grid Property

Gets the grid

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Grid { get; }

Property Value

Nullable Int32
The grid
See Also

Reference

IEventResultV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResultV1 Methods

The IEventResultV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status (Inherited from IEventResult)
Top
See Also

Reference

IEventResultV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResultV2 Interface

Defines methods used by classes that provide event result information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEventResultV2 : IEventResultV1,
    IEventResult

The IEventResultV2 type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event (Inherited from IEventResult)
Public property | Climber | Obsolete. Gets the climber (Inherited from IEventResult)
Public property | ClimberDecimal | Gets the climber (Inherited from IEventResult)
Public property | ClimberRanking | Gets the climber ranking (Inherited from IEventResult)
Public property | CompetitorResults | Gets the competitor results
Public property | Distance | Gets the distance
Public property | Grid | Gets the grid (Inherited from IEventResultV1)
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event (Inherited from IEventResult)
Public property | Id | Gets the id of the event result (Inherited from IEventResult)
Public property | MatchStatus | Obsolete. Gets the match status (Inherited from IEventResult)
Public property | Points | Obsolete. Gets the points of the result (Inherited from IEventResult)
Public property | PointsDecimal | Gets the points (Inherited from IEventResult)
Public property | Position | Gets the position of the result (Inherited from IEventResult)
Public property | Sprint | Obsolete. Gets the sprint of the result (Inherited from IEventResult)
Public property | SprintDecimal | Gets the sprint (Inherited from IEventResult)
Public property | SprintRanking | Gets the sprint ranking (Inherited from IEventResult)
Public property | Status | Gets the status of the result (Inherited from IEventResult)
Public property | StatusComment | Gets the status comment (Inherited from IEventResult)
Public property | Time | Gets the time of the result (Inherited from IEventResult)
Public property | TimeRanking | Gets the time ranking (Inherited from IEventResult)
Public property | WcPoints | Gets the wc?points (Inherited from IEventResult)
Top
Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status (Inherited from IEventResult)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResultV2 Properties

The IEventResultV2 type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event (Inherited from IEventResult)
Public property | Climber | Obsolete. Gets the climber (Inherited from IEventResult)
Public property | ClimberDecimal | Gets the climber (Inherited from IEventResult)
Public property | ClimberRanking | Gets the climber ranking (Inherited from IEventResult)
Public property | CompetitorResults | Gets the competitor results
Public property | Distance | Gets the distance
Public property | Grid | Gets the grid (Inherited from IEventResultV1)
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event (Inherited from IEventResult)
Public property | Id | Gets the id of the event result (Inherited from IEventResult)
Public property | MatchStatus | Obsolete. Gets the match status (Inherited from IEventResult)
Public property | Points | Obsolete. Gets the points of the result (Inherited from IEventResult)
Public property | PointsDecimal | Gets the points (Inherited from IEventResult)
Public property | Position | Gets the position of the result (Inherited from IEventResult)
Public property | Sprint | Obsolete. Gets the sprint of the result (Inherited from IEventResult)
Public property | SprintDecimal | Gets the sprint (Inherited from IEventResult)
Public property | SprintRanking | Gets the sprint ranking (Inherited from IEventResult)
Public property | Status | Gets the status of the result (Inherited from IEventResult)
Public property | StatusComment | Gets the status comment (Inherited from IEventResult)
Public property | Time | Gets the time of the result (Inherited from IEventResult)
Public property | TimeRanking | Gets the time ranking (Inherited from IEventResult)
Public property | WcPoints | Gets the wc?points (Inherited from IEventResult)
Top
See Also

Reference

IEventResultV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResultV2.CompetitorResults Property

IEventResultV2CompetitorResults Property

Gets the competitor results

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<ICompetitorResult> CompetitorResults { get; }

Property Value

IEnumerable ICompetitorResult
The results
See Also

Reference

IEventResultV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResultV2.Distance Property

IEventResultV2Distance Property

Gets the distance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double? Distance { get; }

Property Value

Nullable Double
The distance
See Also

Reference

IEventResultV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventResultV2 Methods

The IEventResultV2 type exposes the following members.

Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status (Inherited from IEventResult)
Top
See Also

Reference

IEventResultV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventTimeline Interface

Defines a contract for classes implementing event timeline for specific ISportEvent

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IEventTimeline

The IEventTimeline type exposes the following members.

Properties
 | Name | Description
Public property | TimelineEvents | Gets the chronological list of events
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventTimeline Properties

The IEventTimeline type exposes the following members.

Properties
 | Name | Description
Public property | TimelineEvents | Gets the chronological list of events
Top
See Also

Reference

IEventTimeline Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IEventTimeline.TimelineEvents Property

IEventTimelineTimelineEvents Property

Gets the chronological list of events

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<ITimelineEvent> TimelineEvents { get; }

Property Value

IEnumerable ITimelineEvent
The chronological list of events
See Also

Reference

IEventTimeline Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture Interface

Defines a contract implemented by classes representing a fixture

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IFixture : IEntityPrinter

The IFixture type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalParentsIds | Gets the list specifying the additional parent ids associated with the current instance
Public property | CoverageInfo | Gets a ICoverageInfo instance specifying what coverage is available for the sport event associated with current instance
Public property | ExtraInfo | Gets a IReadOnlyDictionaryTKey, TValue containing additional information about the fixture represented by current IFixture instance
Public property | NextLiveTime | Gets a DateTime specifying the live time in case the fixture represented by current IFixture instance was re-schedule, or a null reference if the fixture was not re-scheduled
Public property | ParentStageId | Gets an id of the parent stage associated with the current instance
Public property | ProductInfo | Gets a IProductInfo instance providing Sportradar related information about the sport event associated with the current instance.
Public property | References | Gets the reference ids
Public property | ReplacedBy | When sport event is postponed this field indicates with which event it is replaced
Public property | ScheduledStartTimeChanges | Gets the scheduled start time changes
Public property | StartTime | Gets a DateTime specifying when the fixture associated with the current IFixture is scheduled to start
Public property | StartTimeConfirmed | Gets a value indicating whether the start time of the fixture represented by current IFixture instance has been confirmed
Public property | StartTimeTBD | Gets a value indicating whether the start time is yet to be determent
Public property | TvChannels | Gets a IEnumerableT representing TV channels covering the sport event represented by the current IFixture instance
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
Remarks
A Fixture is a sport event that has been arranged for a particular time and place
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture Properties

The IFixture type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalParentsIds | Gets the list specifying the additional parent ids associated with the current instance
Public property | CoverageInfo | Gets a ICoverageInfo instance specifying what coverage is available for the sport event associated with current instance
Public property | ExtraInfo | Gets a IReadOnlyDictionaryTKey, TValue containing additional information about the fixture represented by current IFixture instance
Public property | NextLiveTime | Gets a DateTime specifying the live time in case the fixture represented by current IFixture instance was re-schedule, or a null reference if the fixture was not re-scheduled
Public property | ParentStageId | Gets an id of the parent stage associated with the current instance
Public property | ProductInfo | Gets a IProductInfo instance providing Sportradar related information about the sport event associated with the current instance.
Public property | References | Gets the reference ids
Public property | ReplacedBy | When sport event is postponed this field indicates with which event it is replaced
Public property | ScheduledStartTimeChanges | Gets the scheduled start time changes
Public property | StartTime | Gets a DateTime specifying when the fixture associated with the current IFixture is scheduled to start
Public property | StartTimeConfirmed | Gets a value indicating whether the start time of the fixture represented by current IFixture instance has been confirmed
Public property | StartTimeTBD | Gets a value indicating whether the start time is yet to be determent
Public property | TvChannels | Gets a IEnumerableT representing TV channels covering the sport event represented by the current IFixture instance
Top
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.AdditionalParentsIds Property

IFixtureAdditionalParentsIds Property

Gets the list specifying the additional parent ids associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<URN> AdditionalParentsIds { get; }

Property Value

IEnumerable URN
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.CoverageInfo Property

IFixtureCoverageInfo Property

Gets a ICoverageInfo instance specifying what coverage is available for the sport event associated with current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICoverageInfo CoverageInfo { get; }

Property Value

ICoverageInfo
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.ExtraInfo Property

IFixtureExtraInfo Property

Gets a IReadOnlyDictionaryTKey, TValue containing additional information about the fixture represented by current IFixture instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<string, string> ExtraInfo { get; }

Property Value

IReadOnlyDictionary String, String
Remarks
The collection may contain deprecated key 'streaming'.
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.NextLiveTime Property

IFixtureNextLiveTime Property

Gets a DateTime specifying the live time in case the fixture represented by current IFixture instance was re-schedule, or a null reference if the fixture was not re-scheduled

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime? NextLiveTime { get; }

Property Value

Nullable DateTime
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.ParentStageId Property

IFixtureParentStageId Property

Gets an id of the parent stage associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN ParentStageId { get; }

Property Value

URN
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.ProductInfo Property

IFixtureProductInfo Property

Gets a IProductInfo instance providing Sportradar related information about the sport event associated with the current instance.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IProductInfo ProductInfo { get; }

Property Value

IProductInfo
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.References Property

IFixtureReferences Property

Gets the reference ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReference References { get; }

Property Value

IReference
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.ReplacedBy Property

IFixtureReplacedBy Property

When sport event is postponed this field indicates with which event it is replaced

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN ReplacedBy { get; }

Property Value

URN
The URN this event is replaced by
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.ScheduledStartTimeChanges Property

IFixtureScheduledStartTimeChanges Property

Gets the scheduled start time changes

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IScheduledStartTimeChange> ScheduledStartTimeChanges { get; }

Property Value

IEnumerable IScheduledStartTimeChange
The scheduled start time changes
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.StartTime Property

IFixtureStartTime Property

Gets a DateTime specifying when the fixture associated with the current IFixture is scheduled to start

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime? StartTime { get; }

Property Value

Nullable DateTime
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.StartTimeConfirmed Property

IFixtureStartTimeConfirmed Property

Gets a value indicating whether the start time of the fixture represented by current IFixture instance has been confirmed

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool? StartTimeConfirmed { get; }

Property Value

Nullable Boolean
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.StartTimeTBD Property

IFixtureStartTimeTBD Property

Gets a value indicating whether the start time is yet to be determent

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool? StartTimeTBD { get; }

Property Value

Nullable Boolean
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture.TvChannels Property

IFixtureTvChannels Property

Gets a IEnumerableT representing TV channels covering the sport event represented by the current IFixture instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<ITvChannel> TvChannels { get; }

Property Value

IEnumerable ITvChannel
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixture Methods

The IFixture type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IFixture Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixtureChange Interface

Defines a contract implemented by classes representing fixture change

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IFixtureChange : IEntityPrinter

The IFixtureChange type exposes the following members.

Properties
 | Name | Description
Public property | SportEventId | Gets the URN specifying the sport event
Public property | UpdateTime | Gets the DateTime specifying the last update time
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixtureChange Properties

The IFixtureChange type exposes the following members.

Properties
 | Name | Description
Public property | SportEventId | Gets the URN specifying the sport event
Public property | UpdateTime | Gets the DateTime specifying the last update time
Top
See Also

Reference

IFixtureChange Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixtureChange.SportEventId Property

IFixtureChangeSportEventId Property

Gets the URN specifying the sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN SportEventId { get; }

Property Value

URN
See Also

Reference

IFixtureChange Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixtureChange.UpdateTime Property

IFixtureChangeUpdateTime Property

Gets the DateTime specifying the last update time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime UpdateTime { get; }

Property Value

DateTime
See Also

Reference

IFixtureChange Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IFixtureChange Methods

The IFixtureChange type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IFixtureChange Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGoalScorer Interface

Defines a contract implemented by classes representing goal scorer in a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IGoalScorer : IEntityPrinter

The IGoalScorer type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages
Top
Methods
 | Name | Description
Public method | GetName | Gets the name of the player in the specified language or a null reference
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGoalScorer Properties

The IGoalScorer type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages
Top
See Also

Reference

IGoalScorer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGoalScorer.Id Property

IGoalScorerId Property

Gets the URN uniquely identifying the current ICompetitor instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

IGoalScorer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGoalScorer.Names Property

IGoalScorerNames Property

Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Names { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

IGoalScorer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGoalScorer Methods

The IGoalScorer type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name of the player in the specified language or a null reference
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IGoalScorer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGoalScorer.GetName Method

IGoalScorerGetName Method

Gets the name of the player in the specified language or a null reference

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language of the returned name

Return Value

String
The name of the player in the specified language or a null reference.
See Also

Reference

IGoalScorer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGoalScorerV1 Interface

Defines a contract implemented by classes representing goal scorer in a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IGoalScorerV1 : IGoalScorer,
    IEntityPrinter

The IGoalScorerV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IGoalScorer)
Public property | Method | Gets the method value
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IGoalScorer)
Top
Methods
 | Name | Description
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IGoalScorer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGoalScorerV1 Properties

The IGoalScorerV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IGoalScorer)
Public property | Method | Gets the method value
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IGoalScorer)
Top
See Also

Reference

IGoalScorerV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGoalScorerV1.Method Property

IGoalScorerV1Method Property

Gets the method value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Method { get; }

Property Value

String
The method value
Remarks
The attribute can assume values such as 'penalty' and 'own goal'. In case the attribute is not inserted, then the goal is not own goal neither penalty.
See Also

Reference

IGoalScorerV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGoalScorerV1 Methods

The IGoalScorerV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IGoalScorer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IGoalScorerV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGroup Interface

Defines a contract implemented by classes representing a competition group

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IGroup : IEntityPrinter

The IGroup type exposes the following members.

Properties
 | Name | Description
Public property | Competitors | Gets the IEnumerableT representing group competitors
Public property | Name | Gets the name.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGroup Properties

The IGroup type exposes the following members.

Properties
 | Name | Description
Public property | Competitors | Gets the IEnumerableT representing group competitors
Public property | Name | Gets the name.
Top
See Also

Reference

IGroup Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGroup.Competitors Property

IGroupCompetitors Property

Gets the IEnumerableT representing group competitors

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<ICompetitor> Competitors { get; }

Property Value

IEnumerable ICompetitor
See Also

Reference

IGroup Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGroup.Name Property

IGroupName Property

Gets the name.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

String
The name.
See Also

Reference

IGroup Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGroup Methods

The IGroup type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IGroup Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGroupV1 Interface

Defines a contract implemented by classes representing a competition group

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IGroupV1 : IGroup,
    IEntityPrinter

The IGroupV1 type exposes the following members.

Properties
 | Name | Description
Public property | Competitors | Gets the IEnumerableT representing group competitors (Inherited from IGroup)
Public property | Id | Gets the id of the group represented by the current IGroup instance
Public property | Name | Gets the name. (Inherited from IGroup)
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGroupV1 Properties

The IGroupV1 type exposes the following members.

Properties
 | Name | Description
Public property | Competitors | Gets the IEnumerableT representing group competitors (Inherited from IGroup)
Public property | Id | Gets the id of the group represented by the current IGroup instance
Public property | Name | Gets the name. (Inherited from IGroup)
Top
See Also

Reference

IGroupV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGroupV1.Id Property

IGroupV1Id Property

Gets the id of the group represented by the current IGroup instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Id { get; }

Property Value

String
See Also

Reference

IGroupV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IGroupV1 Methods

The IGroupV1 type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IGroupV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IHole Interface

Defines a contract implemented by classes representing a hole of a golf course

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IHole

The IHole type exposes the following members.

Properties
 | Name | Description
Public property | Number | Gets the number of the hole
Public property | Par | Gets the par
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IHole Properties

The IHole type exposes the following members.

Properties
 | Name | Description
Public property | Number | Gets the number of the hole
Public property | Par | Gets the par
Top
See Also

Reference

IHole Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IHole.Number Property

IHoleNumber Property

Gets the number of the hole

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Number { get; }

Property Value

Int32
See Also

Reference

IHole Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IHole.Par Property

IHolePar Property

Gets the par

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Par { get; }

Property Value

Int32
The par
See Also

Reference

IHole Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJersey Interface

Defines a contract for classes implementing jersey

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IJersey

The IJersey type exposes the following members.

Properties
 | Name | Description
Public property | BaseColor | Gets the base color of the jersey
Public property | HorizontalStripes | Gets a value indicating whether jersey has horizontal stripes
Public property | Number | Gets the number of the jersey
Public property | SleeveColor | Gets the color of the sleeves
Public property | Split | Gets a value indicating whether this IJersey is split
Public property | Squares | Gets a value indicating whether this IJersey has squares
Public property | Stripes | Gets a value indicating whether this IJersey has stripes
Public property | Type | Gets the typ of the jersey
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJersey Properties

The IJersey type exposes the following members.

Properties
 | Name | Description
Public property | BaseColor | Gets the base color of the jersey
Public property | HorizontalStripes | Gets a value indicating whether jersey has horizontal stripes
Public property | Number | Gets the number of the jersey
Public property | SleeveColor | Gets the color of the sleeves
Public property | Split | Gets a value indicating whether this IJersey is split
Public property | Squares | Gets a value indicating whether this IJersey has squares
Public property | Stripes | Gets a value indicating whether this IJersey has stripes
Public property | Type | Gets the typ of the jersey
Top
See Also

Reference

IJersey Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJersey.BaseColor Property

IJerseyBaseColor Property

Gets the base color of the jersey

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string BaseColor { get; }

Property Value

String
The base color of the jersey
See Also

Reference

IJersey Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJersey.HorizontalStripes Property

IJerseyHorizontalStripes Property

Gets a value indicating whether jersey has horizontal stripes

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool? HorizontalStripes { get; }

Property Value

Nullable Boolean
null if [horizontal stripes] contains no value, true if [horizontal stripes]; otherwise, false.
See Also

Reference

IJersey Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJersey.Number Property

IJerseyNumber Property

Gets the number of the jersey

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Number { get; }

Property Value

String
The number of the jersey
See Also

Reference

IJersey Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJersey.SleeveColor Property

IJerseySleeveColor Property

Gets the color of the sleeves

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string SleeveColor { get; }

Property Value

String
The color of the sleeves
See Also

Reference

IJersey Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJersey.Split Property

IJerseySplit Property

Gets a value indicating whether this IJersey is split

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool? Split { get; }

Property Value

Nullable Boolean
null if [split] contains no value, true if [split]; otherwise, false.
See Also

Reference

IJersey Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJersey.Squares Property

IJerseySquares Property

Gets a value indicating whether this IJersey has squares

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool? Squares { get; }

Property Value

Nullable Boolean
null if [squares] contains no value, true if [squares]; otherwise, false.
See Also

Reference

IJersey Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJersey.Stripes Property

IJerseyStripes Property

Gets a value indicating whether this IJersey has stripes

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool? Stripes { get; }

Property Value

Nullable Boolean
null if [stripes] contains no value, true if [stripes]; otherwise, false.
See Also

Reference

IJersey Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJersey.Type Property

IJerseyType Property

Gets the typ of the jersey

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Type { get; }

Property Value

String
The type of the jersey
See Also

Reference

IJersey Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJerseyV1 Interface

Defines a contract for classes implementing jersey

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IJerseyV1 : IJersey

The IJerseyV1 type exposes the following members.

Properties
 | Name | Description
Public property | BaseColor | Gets the base color of the jersey (Inherited from IJersey)
Public property | HorizontalStripes | Gets a value indicating whether jersey has horizontal stripes (Inherited from IJersey)
Public property | Number | Gets the number of the jersey (Inherited from IJersey)
Public property | ShirtType | Gets the shirt type of the jersey
Public property | SleeveColor | Gets the color of the sleeves (Inherited from IJersey)
Public property | SleeveDetail | Gets the sleeve detail of the jersey
Public property | Split | Gets a value indicating whether this IJersey is split (Inherited from IJersey)
Public property | SplitColor | Gets the split color of the jersey
Public property | Squares | Gets a value indicating whether this IJersey has squares (Inherited from IJersey)
Public property | Stripes | Gets a value indicating whether this IJersey has stripes (Inherited from IJersey)
Public property | StripesColor | Gets the stripes color of the jersey
Public property | Type | Gets the typ of the jersey (Inherited from IJersey)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJerseyV1 Properties

The IJerseyV1 type exposes the following members.

Properties
 | Name | Description
Public property | BaseColor | Gets the base color of the jersey (Inherited from IJersey)
Public property | HorizontalStripes | Gets a value indicating whether jersey has horizontal stripes (Inherited from IJersey)
Public property | Number | Gets the number of the jersey (Inherited from IJersey)
Public property | ShirtType | Gets the shirt type of the jersey
Public property | SleeveColor | Gets the color of the sleeves (Inherited from IJersey)
Public property | SleeveDetail | Gets the sleeve detail of the jersey
Public property | Split | Gets a value indicating whether this IJersey is split (Inherited from IJersey)
Public property | SplitColor | Gets the split color of the jersey
Public property | Squares | Gets a value indicating whether this IJersey has squares (Inherited from IJersey)
Public property | Stripes | Gets a value indicating whether this IJersey has stripes (Inherited from IJersey)
Public property | StripesColor | Gets the stripes color of the jersey
Public property | Type | Gets the typ of the jersey (Inherited from IJersey)
Top
See Also

Reference

IJerseyV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJerseyV1.ShirtType Property

IJerseyV1ShirtType Property

Gets the shirt type of the jersey

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string ShirtType { get; }

Property Value

String
The shirt type of the jersey
See Also

Reference

IJerseyV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJerseyV1.SleeveDetail Property

IJerseyV1SleeveDetail Property

Gets the sleeve detail of the jersey

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string SleeveDetail { get; }

Property Value

String
The sleeve detail of the jersey
See Also

Reference

IJerseyV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJerseyV1.SplitColor Property

IJerseyV1SplitColor Property

Gets the split color of the jersey

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string SplitColor { get; }

Property Value

String
The split color of the jersey
See Also

Reference

IJerseyV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IJerseyV1.StripesColor Property

IJerseyV1StripesColor Property

Gets the stripes color of the jersey

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string StripesColor { get; }

Property Value

String
The stripes color of the jersey
See Also

Reference

IJerseyV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILocalizedNamedValue Interface

Specifies a contract implemented by classes representing values with localized / translatable descriptions

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ILocalizedNamedValue : INamedValue

The ILocalizedNamedValue type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description associated with the current instance (Inherited from INamedValue)
Public property | Descriptions | Gets a IReadOnlyDictionaryTKey, TValue containing translated descriptions
Public property | Id | Gets the value associated with the current instance (Inherited from INamedValue)
Top
Methods
 | Name | Description
Public method | GetDescription | Gets the description for specific locale
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace
INamedValue


ILocalizedNamedValue Properties

The ILocalizedNamedValue type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description associated with the current instance (Inherited from INamedValue)
Public property | Descriptions | Gets a IReadOnlyDictionaryTKey, TValue containing translated descriptions
Public property | Id | Gets the value associated with the current instance (Inherited from INamedValue)
Top
See Also

Reference

ILocalizedNamedValue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILocalizedNamedValue.Descriptions Property

ILocalizedNamedValueDescriptions Property

Gets a IReadOnlyDictionaryTKey, TValue containing translated descriptions

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Descriptions { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

ILocalizedNamedValue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILocalizedNamedValue Methods

The ILocalizedNamedValue type exposes the following members.

Methods
 | Name | Description
Public method | GetDescription | Gets the description for specific locale
Top
See Also

Reference

ILocalizedNamedValue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILocalizedNamedValue.GetDescription Method

ILocalizedNamedValueGetDescription Method

Gets the description for specific locale

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetDescription(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture.

Return Value

String
Return the Description if exists, or null.
See Also

Reference

ILocalizedNamedValue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILongTermEvent Interface

Defines a contract for classes implementing long term sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ILongTermEvent : ISportEvent

The ILongTermEvent type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILongTermEvent Properties

The ILongTermEvent type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ILongTermEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILongTermEvent Methods

The ILongTermEvent type exposes the following members.

Methods
 | Name | Description
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance
Top
See Also

Reference

ILongTermEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILongTermEvent.GetSportAsync Method

ILongTermEventGetSportAsync Method

Asynchronously get the ISportSummary instance representing the sport associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ISportSummary> GetSportAsync()

Return Value

Task ISportSummary
The ISportSummary instance representing the sport associated with the current instance
See Also

Reference

ILongTermEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILongTermEvent.GetTournamentCoverage Method

ILongTermEventGetTournamentCoverage Method

Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ITournamentCoverage> GetTournamentCoverage()

Return Value

Task ITournamentCoverage
The ITournamentCoverage instance representing the tournament coverage associated with the current instance
See Also

Reference

ILongTermEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILottery Interface

Defines a contract implemented by classes, which represent information about a lottery

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ILottery : ILongTermEvent,
    ISportEvent

The ILottery type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetBonusInfoAsync | Asynchronously gets IBonusInfo associated with the current instance
Public method | GetCategoryAsync | Asynchronously gets the associated category
Public method | GetDrawInfoAsync | Asynchronously gets IDrawInfo associated with the current instance
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledDrawsAsync | Asynchronously gets the list of ids of associated IDraw
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILottery Properties

The ILottery type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ILottery Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILottery Methods

The ILottery type exposes the following members.

Methods
 | Name | Description
Public method | GetBonusInfoAsync | Asynchronously gets IBonusInfo associated with the current instance
Public method | GetCategoryAsync | Asynchronously gets the associated category
Public method | GetDrawInfoAsync | Asynchronously gets IDrawInfo associated with the current instance
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledDrawsAsync | Asynchronously gets the list of ids of associated IDraw
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

ILottery Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILottery.GetBonusInfoAsync Method

ILotteryGetBonusInfoAsync Method

Asynchronously gets IBonusInfo associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IBonusInfo> GetBonusInfoAsync()

Return Value

Task IBonusInfo
A TaskTResult representing an async operation
See Also

Reference

ILottery Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILottery.GetCategoryAsync Method

ILotteryGetCategoryAsync Method

Asynchronously gets the associated category

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICategorySummary> GetCategoryAsync()

Return Value

Task ICategorySummary
The associated category
See Also

Reference

ILottery Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILottery.GetDrawInfoAsync Method

ILotteryGetDrawInfoAsync Method

Asynchronously gets IDrawInfo associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IDrawInfo> GetDrawInfoAsync()

Return Value

Task IDrawInfo
A TaskTResult representing an async operation
See Also

Reference

ILottery Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILottery.GetScheduledDrawsAsync Method

ILotteryGetScheduledDrawsAsync Method

Asynchronously gets the list of ids of associated IDraw

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<URN>> GetScheduledDrawsAsync()

Return Value

Task IEnumerable URN
A TaskTResult representing an async operation
See Also

Reference

ILottery Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILotteryV1 Interface

Defines a contract implemented by classes, which represent information about a lottery

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ILotteryV1 : ILottery,
    ILongTermEvent, ISportEvent

The ILotteryV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetBonusInfoAsync | Asynchronously gets IBonusInfo associated with the current instance (Inherited from ILottery)
Public method | GetCategoryAsync | Asynchronously gets the associated category (Inherited from ILottery)
Public method | GetDrawInfoAsync | Asynchronously gets IDrawInfo associated with the current instance (Inherited from ILottery)
Public method | GetDrawsAsync | Asynchronously gets the list of associated IDraw
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledDrawsAsync | Asynchronously gets the list of ids of associated IDraw (Inherited from ILottery)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILotteryV1 Properties

The ILotteryV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ILotteryV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILotteryV1 Methods

The ILotteryV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetBonusInfoAsync | Asynchronously gets IBonusInfo associated with the current instance (Inherited from ILottery)
Public method | GetCategoryAsync | Asynchronously gets the associated category (Inherited from ILottery)
Public method | GetDrawInfoAsync | Asynchronously gets IDrawInfo associated with the current instance (Inherited from ILottery)
Public method | GetDrawsAsync | Asynchronously gets the list of associated IDraw
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledDrawsAsync | Asynchronously gets the list of ids of associated IDraw (Inherited from ILottery)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

ILotteryV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ILotteryV1.GetDrawsAsync Method

ILotteryV1GetDrawsAsync Method

Asynchronously gets the list of associated IDraw

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IDraw>> GetDrawsAsync()

Return Value

Task IEnumerable IDraw
A TaskTResult representing an async operation
See Also

Reference

ILotteryV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IManager Interface

Defines a contract for classes implementing manager info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IManager

The IManager type exposes the following members.

Properties
 | Name | Description
Public property | CountryCode | Gets the country code
Public property | Id | Gets a URN specifying the id of the manager
Top
Methods
 | Name | Description
Public method | GetName | Gets the name of the manager
Public method | GetNationality | Gets the nationality of the manager
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IManager Properties

The IManager type exposes the following members.

Properties
 | Name | Description
Public property | CountryCode | Gets the country code
Public property | Id | Gets a URN specifying the id of the manager
Top
See Also

Reference

IManager Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IManager.CountryCode Property

IManagerCountryCode Property

Gets the country code

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string CountryCode { get; }

Property Value

String
The country code
See Also

Reference

IManager Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IManager.Id Property

IManagerId Property

Gets a URN specifying the id of the manager

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

IManager Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IManager Methods

The IManager type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name of the manager
Public method | GetNationality | Gets the nationality of the manager
Top
See Also

Reference

IManager Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IManager.GetName Method

IManagerGetName Method

Gets the name of the manager

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language of the returned name

Return Value

String
Return a name of the manager
See Also

Reference

IManager Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IManager.GetNationality Method

IManagerGetNationality Method

Gets the nationality of the manager

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetNationality(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language of the returned nationality

Return Value

String
Return a nationality of the manager
See Also

Reference

IManager Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatch Interface

Defines a contract implemented by classes representing sport events of match type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMatch : ICompetition, ISportEvent

The IMatch type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetAwayCompetitorAsync | Asynchronously gets a ITeamCompetitor representing away competitor of the match associated with the current instance
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetDelayedInfoAsync | Asynchronously gets the associated delayed info
Public method | GetEventTimelineAsync | Asynchronously gets the associated event timeline
Public method | GetFixtureAsync | Asynchronously gets a IFixture instance containing information about the arranged sport event
Public method | GetHomeCompetitorAsync | Asynchronously gets a ITeamCompetitor representing home competitor of the match associated with the current instance
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonAsync | Asynchronously gets a ISeasonInfo representing the season to which the sport event associated with the current instance belongs to
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously gets a IMatchStatus containing information about the progress of the match
Public method | GetTournamentAsync | Asynchronously gets a ILongTermEvent representing the season to which the sport event associated with the current instance belongs to
Public method | GetTournamentRoundAsync | Asynchronously gets a IRound representing the tournament round to which the sport event associated with the current instance belongs to
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatch Properties

The IMatch type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IMatch Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatch Methods

The IMatch type exposes the following members.

Methods
 | Name | Description
Public method | GetAwayCompetitorAsync | Asynchronously gets a ITeamCompetitor representing away competitor of the match associated with the current instance
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetDelayedInfoAsync | Asynchronously gets the associated delayed info
Public method | GetEventTimelineAsync | Asynchronously gets the associated event timeline
Public method | GetFixtureAsync | Asynchronously gets a IFixture instance containing information about the arranged sport event
Public method | GetHomeCompetitorAsync | Asynchronously gets a ITeamCompetitor representing home competitor of the match associated with the current instance
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonAsync | Asynchronously gets a ISeasonInfo representing the season to which the sport event associated with the current instance belongs to
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously gets a IMatchStatus containing information about the progress of the match
Public method | GetTournamentAsync | Asynchronously gets a ILongTermEvent representing the season to which the sport event associated with the current instance belongs to
Public method | GetTournamentRoundAsync | Asynchronously gets a IRound representing the tournament round to which the sport event associated with the current instance belongs to
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

IMatch Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatch.GetAwayCompetitorAsync Method

IMatchGetAwayCompetitorAsync Method

Asynchronously gets a ITeamCompetitor representing away competitor of the match associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ITeamCompetitor> GetAwayCompetitorAsync()

Return Value

Task ITeamCompetitor
A TaskTResult representing the retrieval operation
See Also

Reference

IMatch Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatch.GetDelayedInfoAsync Method

IMatchGetDelayedInfoAsync Method

Asynchronously gets the associated delayed info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IDelayedInfo> GetDelayedInfoAsync()

Return Value

Task IDelayedInfo
A TaskTResult representing the retrieval operation
See Also

Reference

IMatch Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatch.GetEventTimelineAsync Method

IMatchGetEventTimelineAsync Method

Asynchronously gets the associated event timeline

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEventTimeline> GetEventTimelineAsync()

Return Value

Task IEventTimeline
A TaskTResult representing the retrieval operation
See Also

Reference

IMatch Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatch.GetFixtureAsync Method

IMatchGetFixtureAsync Method

Asynchronously gets a IFixture instance containing information about the arranged sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IFixture> GetFixtureAsync()

Return Value

Task IFixture
A TaskTResult representing the retrieval operation
Remarks
A Fixture is a sport event that has been arranged for a particular time and place
See Also

Reference

IMatch Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatch.GetHomeCompetitorAsync Method

IMatchGetHomeCompetitorAsync Method

Asynchronously gets a ITeamCompetitor representing home competitor of the match associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ITeamCompetitor> GetHomeCompetitorAsync()

Return Value

Task ITeamCompetitor
A TaskTResult representing the retrieval operation
See Also

Reference

IMatch Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatch.GetSeasonAsync Method

IMatchGetSeasonAsync Method

Asynchronously gets a ISeasonInfo representing the season to which the sport event associated with the current instance belongs to

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ISeasonInfo> GetSeasonAsync()

Return Value

Task ISeasonInfo
A TaskTResult representing the retrieval operation
See Also

Reference

IMatch Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatch.GetStatusAsync Method

IMatchGetStatusAsync Method

Asynchronously gets a IMatchStatus containing information about the progress of the match

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IMatchStatus> GetStatusAsync()

Return Value

Task IMatchStatus
A TaskTResult containing information about the progress of the match
See Also

Reference

IMatch Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatch.GetTournamentAsync Method

IMatchGetTournamentAsync Method

Asynchronously gets a ILongTermEvent representing the season to which the sport event associated with the current instance belongs to

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ILongTermEvent> GetTournamentAsync()

Return Value

Task ILongTermEvent
A TaskTResult representing the retrieval operation
See Also

Reference

IMatch Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatch.GetTournamentRoundAsync Method

IMatchGetTournamentRoundAsync Method

Asynchronously gets a IRound representing the tournament round to which the sport event associated with the current instance belongs to

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IRound> GetTournamentRoundAsync()

Return Value

Task IRound
A TaskTResult representing the retrieval operation
See Also

Reference

IMatch Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatus Interface

Defines a contract implemented by classes representing a match status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMatchStatus : ICompetitionStatus

The IMatchStatus type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event
Public property | EventClock | Gets the IEventClock instance describing the timings in the current event
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event
Public property | PeriodScores | Gets the list of IPeriodScore
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace
ICompetitionStatus


IMatchStatus Properties

The IMatchStatus type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event
Public property | EventClock | Gets the IEventClock instance describing the timings in the current event
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event
Public property | PeriodScores | Gets the list of IPeriodScore
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
See Also

Reference

IMatchStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatus.AwayScore Property

IMatchStatusAwayScore Property

Gets the score of the away competitor competing on the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal AwayScore { get; }

Property Value

Decimal
The score of the away competitor competing on the associated sport event
See Also

Reference

IMatchStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatus.EventClock Property

IMatchStatusEventClock Property

Gets the IEventClock instance describing the timings in the current event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEventClock EventClock { get; }

Property Value

IEventClock
The IEventClock instance describing the timings in the current event
See Also

Reference

IMatchStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatus.HomeScore Property

IMatchStatusHomeScore Property

Gets the score of the home competitor competing on the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal HomeScore { get; }

Property Value

Decimal
The score of the home competitor competing on the associated sport event
See Also

Reference

IMatchStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatus.PeriodScores Property

IMatchStatusPeriodScores Property

Gets the list of IPeriodScore

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IPeriodScore> PeriodScores { get; }

Property Value

IEnumerable IPeriodScore
The list of IPeriodScore
See Also

Reference

IMatchStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatus Methods

The IMatchStatus type exposes the following members.

Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
See Also

Reference

IMatchStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatus.GetMatchStatusAsync Method

IMatchStatusGetMatchStatusAsync Method

Asynchronously gets the match status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ILocalizedNamedValue> GetMatchStatusAsync(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture used to get match status id and description

Return Value

Task ILocalizedNamedValue
Returns the match status id and description in selected culture
See Also

Reference

IMatchStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatusV1 Interface

Defines a contract implemented by classes representing a match status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMatchStatusV1 : IMatchStatus,
    ICompetitionStatus

The IMatchStatusV1 type exposes the following members.

Properties
 | Name | Description
Public property | AwayPenaltyScore | Gets the penalty score of the away competitor competing on the associated sport event (for Ice Hockey)
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event (Inherited from IMatchStatus)
Public property | EventClock | Gets the IEventClock instance describing the timings in the current event (Inherited from IMatchStatus)
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | HomePenaltyScore | Gets the penalty score of the home competitor competing on the associated sport event (for Ice Hockey)
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event (Inherited from IMatchStatus)
Public property | PeriodScores | Gets the list of IPeriodScore (Inherited from IMatchStatus)
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status (Inherited from IMatchStatus)
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
Remarks
Interface will be merged into base IMatchStatus in next major version scheduled for January 2019
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace
ICompetitionStatus


IMatchStatusV1 Properties

The IMatchStatusV1 type exposes the following members.

Properties
 | Name | Description
Public property | AwayPenaltyScore | Gets the penalty score of the away competitor competing on the associated sport event (for Ice Hockey)
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event (Inherited from IMatchStatus)
Public property | EventClock | Gets the IEventClock instance describing the timings in the current event (Inherited from IMatchStatus)
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | HomePenaltyScore | Gets the penalty score of the home competitor competing on the associated sport event (for Ice Hockey)
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event (Inherited from IMatchStatus)
Public property | PeriodScores | Gets the list of IPeriodScore (Inherited from IMatchStatus)
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
See Also

Reference

IMatchStatusV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatusV1.AwayPenaltyScore Property

IMatchStatusV1AwayPenaltyScore Property

Gets the penalty score of the away competitor competing on the associated sport event (for Ice Hockey)

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? AwayPenaltyScore { get; }

Property Value

Nullable Int32
See Also

Reference

IMatchStatusV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatusV1.HomePenaltyScore Property

IMatchStatusV1HomePenaltyScore Property

Gets the penalty score of the home competitor competing on the associated sport event (for Ice Hockey)

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? HomePenaltyScore { get; }

Property Value

Nullable Int32
See Also

Reference

IMatchStatusV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatusV1 Methods

The IMatchStatusV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status (Inherited from IMatchStatus)
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
See Also

Reference

IMatchStatusV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatusV2 Interface

Defines a contract implemented by classes representing a match status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMatchStatusV2 : IMatchStatusV1,
    IMatchStatus, ICompetitionStatus

The IMatchStatusV2 type exposes the following members.

Properties
 | Name | Description
Public property | AwayPenaltyScore | Gets the penalty score of the away competitor competing on the associated sport event (for Ice Hockey) (Inherited from IMatchStatusV1)
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event (Inherited from IMatchStatus)
Public property | DecidedByFed | Gets the indicator wither the event is decided by fed
Public property | EventClock | Gets the IEventClock instance describing the timings in the current event (Inherited from IMatchStatus)
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | HomePenaltyScore | Gets the penalty score of the home competitor competing on the associated sport event (for Ice Hockey) (Inherited from IMatchStatusV1)
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event (Inherited from IMatchStatus)
Public property | PeriodScores | Gets the list of IPeriodScore (Inherited from IMatchStatus)
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status (Inherited from IMatchStatus)
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
Remarks
Interface will be merged into base IMatchStatus in next major version scheduled for January 2019
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace
ICompetitionStatus


IMatchStatusV2 Properties

The IMatchStatusV2 type exposes the following members.

Properties
 | Name | Description
Public property | AwayPenaltyScore | Gets the penalty score of the away competitor competing on the associated sport event (for Ice Hockey) (Inherited from IMatchStatusV1)
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event (Inherited from IMatchStatus)
Public property | DecidedByFed | Gets the indicator wither the event is decided by fed
Public property | EventClock | Gets the IEventClock instance describing the timings in the current event (Inherited from IMatchStatus)
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | HomePenaltyScore | Gets the penalty score of the home competitor competing on the associated sport event (for Ice Hockey) (Inherited from IMatchStatusV1)
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event (Inherited from IMatchStatus)
Public property | PeriodScores | Gets the list of IPeriodScore (Inherited from IMatchStatus)
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
See Also

Reference

IMatchStatusV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatusV2.DecidedByFed Property

IMatchStatusV2DecidedByFed Property

Gets the indicator wither the event is decided by fed

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool? DecidedByFed { get; }

Property Value

Nullable Boolean
See Also

Reference

IMatchStatusV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatusV2 Methods

The IMatchStatusV2 type exposes the following members.

Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status (Inherited from IMatchStatus)
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
See Also

Reference

IMatchStatusV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatusV3 Interface

Defines a contract implemented by classes representing a match status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMatchStatusV3 : IMatchStatusV2,
    IMatchStatusV1, IMatchStatus, ICompetitionStatus

The IMatchStatusV3 type exposes the following members.

Properties
 | Name | Description
Public property | AwayPenaltyScore | Gets the penalty score of the away competitor competing on the associated sport event (for Ice Hockey) (Inherited from IMatchStatusV1)
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event
Public property | DecidedByFed | Gets the indicator wither the event is decided by fed (Inherited from IMatchStatusV2)
Public property | EventClock | Gets the IEventClock instance describing the timings in the current event (Inherited from IMatchStatus)
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | HomePenaltyScore | Gets the penalty score of the home competitor competing on the associated sport event (for Ice Hockey) (Inherited from IMatchStatusV1)
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event
Public property | PeriodScores | Gets the list of IPeriodScore (Inherited from IMatchStatus)
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status (Inherited from IMatchStatus)
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
Remarks
Interface will be merged into base IMatchStatus in next major version scheduled for January 2019
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace
ICompetitionStatus


IMatchStatusV3 Properties

The IMatchStatusV3 type exposes the following members.

Properties
 | Name | Description
Public property | AwayPenaltyScore | Gets the penalty score of the away competitor competing on the associated sport event (for Ice Hockey) (Inherited from IMatchStatusV1)
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event
Public property | DecidedByFed | Gets the indicator wither the event is decided by fed (Inherited from IMatchStatusV2)
Public property | EventClock | Gets the IEventClock instance describing the timings in the current event (Inherited from IMatchStatus)
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | HomePenaltyScore | Gets the penalty score of the home competitor competing on the associated sport event (for Ice Hockey) (Inherited from IMatchStatusV1)
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event
Public property | PeriodScores | Gets the list of IPeriodScore (Inherited from IMatchStatus)
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
See Also

Reference

IMatchStatusV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatusV3.AwayScore Property

IMatchStatusV3AwayScore Property

Gets the score of the away competitor competing on the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal? AwayScore { get; }

Property Value

Nullable Decimal
The score of the away competitor competing on the associated sport event
See Also

Reference

IMatchStatusV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatusV3.HomeScore Property

IMatchStatusV3HomeScore Property

Gets the score of the home competitor competing on the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal? HomeScore { get; }

Property Value

Nullable Decimal
The score of the home competitor competing on the associated sport event
See Also

Reference

IMatchStatusV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchStatusV3 Methods

The IMatchStatusV3 type exposes the following members.

Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status (Inherited from IMatchStatus)
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
See Also

Reference

IMatchStatusV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchV1 Interface

Defines a contract implemented by classes representing sport events of match type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMatchV1 : IMatch,
    ICompetition, ISportEvent, ICompetitionV1

The IMatchV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetAwayCompetitorAsync | Asynchronously gets a ITeamCompetitor representing away competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetDelayedInfoAsync | Asynchronously gets the associated delayed info (Inherited from IMatch)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetEventTimelineAsync | Asynchronously gets the associated event timeline (Inherited from IMatch)
Public method | GetFixtureAsync | Asynchronously gets a IFixture instance containing information about the arranged sport event (Inherited from IMatch)
Public method | GetHomeCompetitorAsync | Asynchronously gets a ITeamCompetitor representing home competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonAsync | Asynchronously gets a ISeasonInfo representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously gets a IMatchStatus containing information about the progress of the match (Inherited from IMatch)
Public method | GetTournamentAsync | Asynchronously gets a ILongTermEvent representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetTournamentRoundAsync | Asynchronously gets a IRound representing the tournament round to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchV1 Properties

The IMatchV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IMatchV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchV1 Methods

The IMatchV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetAwayCompetitorAsync | Asynchronously gets a ITeamCompetitor representing away competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetDelayedInfoAsync | Asynchronously gets the associated delayed info (Inherited from IMatch)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetEventTimelineAsync | Asynchronously gets the associated event timeline (Inherited from IMatch)
Public method | GetFixtureAsync | Asynchronously gets a IFixture instance containing information about the arranged sport event (Inherited from IMatch)
Public method | GetHomeCompetitorAsync | Asynchronously gets a ITeamCompetitor representing home competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonAsync | Asynchronously gets a ISeasonInfo representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously gets a IMatchStatus containing information about the progress of the match (Inherited from IMatch)
Public method | GetTournamentAsync | Asynchronously gets a ILongTermEvent representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetTournamentRoundAsync | Asynchronously gets a IRound representing the tournament round to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

IMatchV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchV2 Interface

Defines a contract implemented by classes representing sport events of match type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMatchV2 : IMatchV1,
    IMatch, ICompetition, ISportEvent, ICompetitionV1

The IMatchV2 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetAwayCompetitorAsync | Asynchronously gets a ITeamCompetitor representing away competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetCoverageInfoAsync | Asynchronously gets the associated coverage info
Public method | GetDelayedInfoAsync | Asynchronously gets the associated delayed info (Inherited from IMatch)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetEventTimelineAsync | Asynchronously gets the associated event timeline (Inherited from IMatch)
Public method | GetFixtureAsync | Asynchronously gets a IFixture instance containing information about the arranged sport event (Inherited from IMatch)
Public method | GetHomeCompetitorAsync | Asynchronously gets a ITeamCompetitor representing home competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonAsync | Asynchronously gets a ISeasonInfo representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously gets a IMatchStatus containing information about the progress of the match (Inherited from IMatch)
Public method | GetTournamentAsync | Asynchronously gets a ILongTermEvent representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetTournamentRoundAsync | Asynchronously gets a IRound representing the tournament round to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchV2 Properties

The IMatchV2 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IMatchV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchV2 Methods

The IMatchV2 type exposes the following members.

Methods
 | Name | Description
Public method | GetAwayCompetitorAsync | Asynchronously gets a ITeamCompetitor representing away competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetCoverageInfoAsync | Asynchronously gets the associated coverage info
Public method | GetDelayedInfoAsync | Asynchronously gets the associated delayed info (Inherited from IMatch)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetEventTimelineAsync | Asynchronously gets the associated event timeline (Inherited from IMatch)
Public method | GetFixtureAsync | Asynchronously gets a IFixture instance containing information about the arranged sport event (Inherited from IMatch)
Public method | GetHomeCompetitorAsync | Asynchronously gets a ITeamCompetitor representing home competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonAsync | Asynchronously gets a ISeasonInfo representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously gets a IMatchStatus containing information about the progress of the match (Inherited from IMatch)
Public method | GetTournamentAsync | Asynchronously gets a ILongTermEvent representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetTournamentRoundAsync | Asynchronously gets a IRound representing the tournament round to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

IMatchV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchV2.GetCoverageInfoAsync Method

IMatchV2GetCoverageInfoAsync Method

Asynchronously gets the associated coverage info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICoverageInfo> GetCoverageInfoAsync()

Return Value

Task ICoverageInfo
A Task representing the retrieval operation
See Also

Reference

IMatchV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchV3 Interface

Defines a contract implemented by classes representing sport events of match type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMatchV3 : IMatchV2,
    IMatchV1, IMatch, ICompetition, ISportEvent, ICompetitionV1

The IMatchV3 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetAwayCompetitorAsync | Asynchronously gets a ITeamCompetitor representing away competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetCoverageInfoAsync | Asynchronously gets the associated coverage info (Inherited from IMatchV2)
Public method | GetDelayedInfoAsync | Asynchronously gets the associated delayed info (Inherited from IMatch)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetEventTimelineAsync | Asynchronously gets the associated event timeline (Inherited from IMatch)
Public method | GetEventTimelineAsync(CultureInfo) | Asynchronously gets the associated event timeline for single culture
Public method | GetFixtureAsync | Asynchronously gets a IFixture instance containing information about the arranged sport event (Inherited from IMatch)
Public method | GetHomeCompetitorAsync | Asynchronously gets a ITeamCompetitor representing home competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonAsync | Asynchronously gets a ISeasonInfo representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously gets a IMatchStatus containing information about the progress of the match (Inherited from IMatch)
Public method | GetTournamentAsync | Asynchronously gets a ILongTermEvent representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetTournamentRoundAsync | Asynchronously gets a IRound representing the tournament round to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
Remarks
Added May 2021
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchV3 Properties

The IMatchV3 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IMatchV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchV3 Methods

The IMatchV3 type exposes the following members.

Methods
 | Name | Description
Public method | GetAwayCompetitorAsync | Asynchronously gets a ITeamCompetitor representing away competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetCoverageInfoAsync | Asynchronously gets the associated coverage info (Inherited from IMatchV2)
Public method | GetDelayedInfoAsync | Asynchronously gets the associated delayed info (Inherited from IMatch)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetEventTimelineAsync | Asynchronously gets the associated event timeline (Inherited from IMatch)
Public method | GetEventTimelineAsync(CultureInfo) | Asynchronously gets the associated event timeline for single culture
Public method | GetFixtureAsync | Asynchronously gets a IFixture instance containing information about the arranged sport event (Inherited from IMatch)
Public method | GetHomeCompetitorAsync | Asynchronously gets a ITeamCompetitor representing home competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonAsync | Asynchronously gets a ISeasonInfo representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously gets a IMatchStatus containing information about the progress of the match (Inherited from IMatch)
Public method | GetTournamentAsync | Asynchronously gets a ILongTermEvent representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetTournamentRoundAsync | Asynchronously gets a IRound representing the tournament round to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

IMatchV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchV3.GetEventTimelineAsync Method

IMatchV3GetEventTimelineAsync Method

Overload List
 | Name | Description
Public method | GetEventTimelineAsync | Asynchronously gets the associated event timeline
Public method | GetEventTimelineAsync(CultureInfo) | Asynchronously gets the associated event timeline for single culture
Top
See Also

Reference

IMatchV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IMatchV3.GetEventTimelineAsync(CultureInfo) Method

IMatchV3GetEventTimelineAsync(CultureInfo) Method

Asynchronously gets the associated event timeline for single culture

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEventTimeline> GetEventTimelineAsync(
    CultureInfo culture
)

Parameters

culture CultureInfo
The languages to which the returned instance should be translated

Return Value

Task IEventTimeline
A TaskTResult representing the retrieval operation
Remarks
Recommended to be used when only IEventTimeline is needed for this IMatch
See Also

Reference

IMatchV3 Interface
GetEventTimelineAsync Overload
Sportradar.OddsFeed.SDK.Entities.REST Namespace


INamedValue Interface

Specifies a contract implemented by classes representing values with names / descriptions

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface INamedValue

The INamedValue type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description associated with the current instance
Public property | Id | Gets the value associated with the current instance
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


INamedValue Properties

The INamedValue type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description associated with the current instance
Public property | Id | Gets the value associated with the current instance
Top
See Also

Reference

INamedValue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


INamedValue.Description Property

INamedValueDescription Property

Gets the description associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Description { get; }

Property Value

String
See Also

Reference

INamedValue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


INamedValue.Id Property

INamedValueId Property

Gets the value associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Id { get; }

Property Value

Int32
See Also

Reference

INamedValue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodCompetitorResult Interface

Defines a contract implemented by classes representing competitor result per period

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IPeriodCompetitorResult

The IPeriodCompetitorResult type exposes the following members.

Properties
 | Name | Description
Public property | CompetitorResults | Gets the competitor results
Public property | Id | Gets the competitor id
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodCompetitorResult Properties

The IPeriodCompetitorResult type exposes the following members.

Properties
 | Name | Description
Public property | CompetitorResults | Gets the competitor results
Public property | Id | Gets the competitor id
Top
See Also

Reference

IPeriodCompetitorResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodCompetitorResult.CompetitorResults Property

IPeriodCompetitorResultCompetitorResults Property

Gets the competitor results

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<ICompetitorResult> CompetitorResults { get; }

Property Value

IEnumerable ICompetitorResult
The results
See Also

Reference

IPeriodCompetitorResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodCompetitorResult.Id Property

IPeriodCompetitorResultId Property

Gets the competitor id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
The competitor id
See Also

Reference

IPeriodCompetitorResult Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodScore Interface

Defines a contract implemented by classes representing a score of a sport event period

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IPeriodScore : IEntityPrinter

The IPeriodScore type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away team in the period represented by the current IPeriodScore instance
Public property | HomeScore | Gets the score of the home team in the period represented by the current IPeriodScore instance
Public property | MatchStatusCode | Obsolete. Gets the match status code
Public property | Number | Number of the period
Public property | Type | Type of the period
Top
Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodScore Properties

The IPeriodScore type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away team in the period represented by the current IPeriodScore instance
Public property | HomeScore | Gets the score of the home team in the period represented by the current IPeriodScore instance
Public property | MatchStatusCode | Obsolete. Gets the match status code
Public property | Number | Number of the period
Public property | Type | Type of the period
Top
See Also

Reference

IPeriodScore Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodScore.AwayScore Property

IPeriodScoreAwayScore Property

Gets the score of the away team in the period represented by the current IPeriodScore instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal AwayScore { get; }

Property Value

Decimal
See Also

Reference

IPeriodScore Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodScore.HomeScore Property

IPeriodScoreHomeScore Property

Gets the score of the home team in the period represented by the current IPeriodScore instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal HomeScore { get; }

Property Value

Decimal
See Also

Reference

IPeriodScore Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodScore.MatchStatusCode Property

IPeriodScoreMatchStatusCode Property

Note: This API is now obsolete.

Gets the match status code

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use GetMatchStatusAsync method instead")]
int? MatchStatusCode { get; }

Property Value

Nullable Int32
The match status code
See Also

Reference

IPeriodScore Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodScore.Number Property

IPeriodScoreNumber Property

Number of the period

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Number { get; }

Property Value

Nullable Int32
See Also

Reference

IPeriodScore Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodScore.Type Property

IPeriodScoreType Property

Type of the period

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
PeriodType? Type { get; }

Property Value

Nullable PeriodType
See Also

Reference

IPeriodScore Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodScore Methods

The IPeriodScore type exposes the following members.

Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IPeriodScore Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodScore.GetMatchStatusAsync Method

IPeriodScoreGetMatchStatusAsync Method

Asynchronously gets the match status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ILocalizedNamedValue> GetMatchStatusAsync(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture used to get match status id and description

Return Value

Task ILocalizedNamedValue
Returns the match status id and description in selected culture
See Also

Reference

IPeriodScore Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodStatistics Interface

Defines a contract for classes implementing period statistics

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IPeriodStatistics

The IPeriodStatistics type exposes the following members.

Properties
 | Name | Description
Public property | PeriodName | Gets the name of the period
Public property | TeamStatistics | Gets the list of team statistics for specific period
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodStatistics Properties

The IPeriodStatistics type exposes the following members.

Properties
 | Name | Description
Public property | PeriodName | Gets the name of the period
Public property | TeamStatistics | Gets the list of team statistics for specific period
Top
See Also

Reference

IPeriodStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodStatistics.PeriodName Property

IPeriodStatisticsPeriodName Property

Gets the name of the period

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string PeriodName { get; }

Property Value

String
The name of the period
See Also

Reference

IPeriodStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodStatistics.TeamStatistics Property

IPeriodStatisticsTeamStatistics Property

Gets the list of team statistics for specific period

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<ITeamStatistics> TeamStatistics { get; }

Property Value

IEnumerable ITeamStatistics
The list of team statistics for specific period
See Also

Reference

IPeriodStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodStatus Interface

Defines a contract implemented by classes representing period status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IPeriodStatus

The IPeriodStatus type exposes the following members.

Properties
 | Name | Description
Public property | Number | Gets the number of the specific lap.
Public property | PeriodResults | Gets the period results
Public property | Status | Gets the status.
Public property | Type | Gets the type
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodStatus Properties

The IPeriodStatus type exposes the following members.

Properties
 | Name | Description
Public property | Number | Gets the number of the specific lap.
Public property | PeriodResults | Gets the period results
Public property | Status | Gets the status.
Public property | Type | Gets the type
Top
See Also

Reference

IPeriodStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodStatus.Number Property

IPeriodStatusNumber Property

Gets the number of the specific lap.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Number { get; }

Property Value

Nullable Int32
The number of the specific lap.
See Also

Reference

IPeriodStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodStatus.PeriodResults Property

IPeriodStatusPeriodResults Property

Gets the period results

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IPeriodCompetitorResult> PeriodResults { get; }

Property Value

IEnumerable IPeriodCompetitorResult
The results
See Also

Reference

IPeriodStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodStatus.Status Property

IPeriodStatusStatus Property

Gets the status.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Status { get; }

Property Value

String
The status.
Remarks
Possible values: not_started, started, completed.
See Also

Reference

IPeriodStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPeriodStatus.Type Property

IPeriodStatusType Property

Gets the type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Type { get; }

Property Value

String
The type
Remarks
Possible values: lap
See Also

Reference

IPeriodStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPitcher Interface

Defines a contract implemented by classes representing sport event pitcher

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IPitcher : IEntityPrinter

The IPitcher type exposes the following members.

Properties
 | Name | Description
Public property | Competitor | Gets the indicator if the competitor is Home or Away
Public property | Hand | Gets the hand with which player pitches
Public property | Id | Gets a URN used to uniquely identify the current IPitcher instance
Public property | Name | Gets the name of the referee represented by the current IPitcher instance
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPitcher Properties

The IPitcher type exposes the following members.

Properties
 | Name | Description
Public property | Competitor | Gets the indicator if the competitor is Home or Away
Public property | Hand | Gets the hand with which player pitches
Public property | Id | Gets a URN used to uniquely identify the current IPitcher instance
Public property | Name | Gets the name of the referee represented by the current IPitcher instance
Top
See Also

Reference

IPitcher Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPitcher.Competitor Property

IPitcherCompetitor Property

Gets the indicator if the competitor is Home or Away

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
HomeAway Competitor { get; }

Property Value

HomeAway
The indicator if the competitor is Home or Away
See Also

Reference

IPitcher Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPitcher.Hand Property

IPitcherHand Property

Gets the hand with which player pitches

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
PlayerHand Hand { get; }

Property Value

PlayerHand
The hand with which player pitches
See Also

Reference

IPitcher Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPitcher.Id Property

IPitcherId Property

Gets a URN used to uniquely identify the current IPitcher instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

IPitcher Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPitcher.Name Property

IPitcherName Property

Gets the name of the referee represented by the current IPitcher instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

String
See Also

Reference

IPitcher Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPitcher Methods

The IPitcher type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IPitcher Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayer Interface

Defines a contract implemented by classes representing players or racers in a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IPlayer : IEntityPrinter

The IPlayer type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages
Top
Methods
 | Name | Description
Public method | GetName | Gets the name of the player in the specified language or a null reference
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayer Properties

The IPlayer type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages
Top
See Also

Reference

IPlayer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayer.Id Property

IPlayerId Property

Gets the URN uniquely identifying the current ICompetitor instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

IPlayer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayer.Names Property

IPlayerNames Property

Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Names { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

IPlayer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayer Methods

The IPlayer type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name of the player in the specified language or a null reference
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IPlayer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayer.GetName Method

IPlayerGetName Method

Gets the name of the player in the specified language or a null reference

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language of the returned name

Return Value

String
The name of the player in the specified language or a null reference.
See Also

Reference

IPlayer Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfile Interface

Defines a contract implemented by classes representing a player profile

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IPlayerProfile : IPlayer,
    IEntityPrinter

The IPlayerProfile type exposes the following members.

Properties
 | Name | Description
Public property | DateOfBirth | Gets a DateTime specifying the date of birth of the player associated with the current instance
Public property | Height | Gets the height in centimeters of the player represented by the current instance or a null reference if height is not known
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | Nationalities | Gets a IReadOnlyDictionaryTKey, TValue containing player nationality in different languages
Public property | Type | Gets a value describing the type(e.g. forward, defense, ...) of the player represented by current instance
Public property | Weight | Gets the weight in kilograms of the player represented by the current instance or a null reference if weight is not known
Top
Methods
Name Description
Public method GetName Gets the name of the player in the specified language or a null reference
(Inherited from IPlayer)
Public method GetNationality Gets the nationality of the player represented by the current instance in the language specified by
C#
Copy
culture
Public method ToString Returns a String that represents this instance.
(Inherited from IEntityPrinter)
Public method ToString(IFormatProvider) Returns a string that represents the current object
(Inherited from IEntityPrinter)
Public method ToString(String, IFormatProvider) Formats the value of the current instance using the specified format.
(Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfile Properties

The IPlayerProfile type exposes the following members.

Properties
 | Name | Description
Public property | DateOfBirth | Gets a DateTime specifying the date of birth of the player associated with the current instance
Public property | Height | Gets the height in centimeters of the player represented by the current instance or a null reference if height is not known
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | Nationalities | Gets a IReadOnlyDictionaryTKey, TValue containing player nationality in different languages
Public property | Type | Gets a value describing the type(e.g. forward, defense, ...) of the player represented by current instance
Public property | Weight | Gets the weight in kilograms of the player represented by the current instance or a null reference if weight is not known
Top
See Also

Reference

IPlayerProfile Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfile.DateOfBirth Property

IPlayerProfileDateOfBirth Property

Gets a DateTime specifying the date of birth of the player associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime? DateOfBirth { get; }

Property Value

Nullable DateTime
See Also

Reference

IPlayerProfile Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfile.Height Property

IPlayerProfileHeight Property

Gets the height in centimeters of the player represented by the current instance or a null reference if height is not known

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Height { get; }

Property Value

Nullable Int32
See Also

Reference

IPlayerProfile Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfile.Nationalities Property

IPlayerProfileNationalities Property

Gets a IReadOnlyDictionaryTKey, TValue containing player nationality in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Nationalities { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

IPlayerProfile Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfile.Type Property

IPlayerProfileType Property

Gets a value describing the type(e.g. forward, defense, ...) of the player represented by current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Type { get; }

Property Value

String
See Also

Reference

IPlayerProfile Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfile.Weight Property

IPlayerProfileWeight Property

Gets the weight in kilograms of the player represented by the current instance or a null reference if weight is not known

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Weight { get; }

Property Value

Nullable Int32
See Also

Reference

IPlayerProfile Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfile Methods

The IPlayerProfile type exposes the following members.

Methods
Name Description
Public method GetName Gets the name of the player in the specified language or a null reference
(Inherited from IPlayer)
Public method GetNationality Gets the nationality of the player represented by the current instance in the language specified by
C#
Copy
culture
Public method ToString Returns a String that represents this instance.
(Inherited from IEntityPrinter)
Public method ToString(IFormatProvider) Returns a string that represents the current object
(Inherited from IEntityPrinter)
Public method ToString(String, IFormatProvider) Formats the value of the current instance using the specified format.
(Inherited from IEntityPrinter)
Top
See Also

Reference

IPlayerProfile Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfile.GetNationality Method

IPlayerProfileGetNationality Method

Gets the nationality of the player represented by the current instance in the language specified by
C#
Copy
culture

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetNationality(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language of the returned nationality

Return Value

String
The nationality of the player represented by the current instance in the language specified by
C#
Copy
culture
See Also

Reference

IPlayerProfile Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfileV1 Interface

Defines a contract implemented by classes representing a player profile

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IPlayerProfileV1 : IPlayerProfile,
    IPlayer, IEntityPrinter

The IPlayerProfileV1 type exposes the following members.

Properties
 | Name | Description
Public property | DateOfBirth | Gets a DateTime specifying the date of birth of the player associated with the current instance (Inherited from IPlayerProfile)
Public property | Gender | Gets the gender
Public property | Height | Gets the height in centimeters of the player represented by the current instance or a null reference if height is not known (Inherited from IPlayerProfile)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | Nationalities | Gets a IReadOnlyDictionaryTKey, TValue containing player nationality in different languages (Inherited from IPlayerProfile)
Public property | Type | Gets a value describing the type(e.g. forward, defense, ...) of the player represented by current instance (Inherited from IPlayerProfile)
Public property | Weight | Gets the weight in kilograms of the player represented by the current instance or a null reference if weight is not known (Inherited from IPlayerProfile)
Top
Methods
Name Description
Public method GetName Gets the name of the player in the specified language or a null reference
(Inherited from IPlayer)
Public method GetNationality Gets the nationality of the player represented by the current instance in the language specified by
C#
Copy
culture

(Inherited from IPlayerProfile)
Public method ToString Returns a String that represents this instance.
(Inherited from IEntityPrinter)
Public method ToString(IFormatProvider) Returns a string that represents the current object
(Inherited from IEntityPrinter)
Public method ToString(String, IFormatProvider) Formats the value of the current instance using the specified format.
(Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfileV1 Properties

The IPlayerProfileV1 type exposes the following members.

Properties
 | Name | Description
Public property | DateOfBirth | Gets a DateTime specifying the date of birth of the player associated with the current instance (Inherited from IPlayerProfile)
Public property | Gender | Gets the gender
Public property | Height | Gets the height in centimeters of the player represented by the current instance or a null reference if height is not known (Inherited from IPlayerProfile)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | Nationalities | Gets a IReadOnlyDictionaryTKey, TValue containing player nationality in different languages (Inherited from IPlayerProfile)
Public property | Type | Gets a value describing the type(e.g. forward, defense, ...) of the player represented by current instance (Inherited from IPlayerProfile)
Public property | Weight | Gets the weight in kilograms of the player represented by the current instance or a null reference if weight is not known (Inherited from IPlayerProfile)
Top
See Also

Reference

IPlayerProfileV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfileV1.Gender Property

IPlayerProfileV1Gender Property

Gets the gender

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Gender { get; }

Property Value

String
See Also

Reference

IPlayerProfileV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfileV1 Methods

The IPlayerProfileV1 type exposes the following members.

Methods
Name Description
Public method GetName Gets the name of the player in the specified language or a null reference
(Inherited from IPlayer)
Public method GetNationality Gets the nationality of the player represented by the current instance in the language specified by
C#
Copy
culture

(Inherited from IPlayerProfile)
Public method ToString Returns a String that represents this instance.
(Inherited from IEntityPrinter)
Public method ToString(IFormatProvider) Returns a string that represents the current object
(Inherited from IEntityPrinter)
Public method ToString(String, IFormatProvider) Formats the value of the current instance using the specified format.
(Inherited from IEntityPrinter)
Top
See Also

Reference

IPlayerProfileV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfileV2 Interface

Defines a contract implemented by classes representing a player profile

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IPlayerProfileV2 : IPlayerProfileV1,
    IPlayerProfile, IPlayer, IEntityPrinter

The IPlayerProfileV2 type exposes the following members.

Properties
 | Name | Description
Public property | CountryCode | Gets the country code
Public property | DateOfBirth | Gets a DateTime specifying the date of birth of the player associated with the current instance (Inherited from IPlayerProfile)
Public property | FullName | Gets the full name of the player
Public property | Gender | Gets the gender (Inherited from IPlayerProfileV1)
Public property | Height | Gets the height in centimeters of the player represented by the current instance or a null reference if height is not known (Inherited from IPlayerProfile)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | Nationalities | Gets a IReadOnlyDictionaryTKey, TValue containing player nationality in different languages (Inherited from IPlayerProfile)
Public property | Nickname | Gets the nickname of the player
Public property | Type | Gets a value describing the type(e.g. forward, defense, ...) of the player represented by current instance (Inherited from IPlayerProfile)
Public property | Weight | Gets the weight in kilograms of the player represented by the current instance or a null reference if weight is not known (Inherited from IPlayerProfile)
Top
Methods
Name Description
Public method GetName Gets the name of the player in the specified language or a null reference
(Inherited from IPlayer)
Public method GetNationality Gets the nationality of the player represented by the current instance in the language specified by
C#
Copy
culture

(Inherited from IPlayerProfile)
Public method ToString Returns a String that represents this instance.
(Inherited from IEntityPrinter)
Public method ToString(IFormatProvider) Returns a string that represents the current object
(Inherited from IEntityPrinter)
Public method ToString(String, IFormatProvider) Formats the value of the current instance using the specified format.
(Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfileV2 Properties

The IPlayerProfileV2 type exposes the following members.

Properties
 | Name | Description
Public property | CountryCode | Gets the country code
Public property | DateOfBirth | Gets a DateTime specifying the date of birth of the player associated with the current instance (Inherited from IPlayerProfile)
Public property | FullName | Gets the full name of the player
Public property | Gender | Gets the gender (Inherited from IPlayerProfileV1)
Public property | Height | Gets the height in centimeters of the player represented by the current instance or a null reference if height is not known (Inherited from IPlayerProfile)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | Nationalities | Gets a IReadOnlyDictionaryTKey, TValue containing player nationality in different languages (Inherited from IPlayerProfile)
Public property | Nickname | Gets the nickname of the player
Public property | Type | Gets a value describing the type(e.g. forward, defense, ...) of the player represented by current instance (Inherited from IPlayerProfile)
Public property | Weight | Gets the weight in kilograms of the player represented by the current instance or a null reference if weight is not known (Inherited from IPlayerProfile)
Top
See Also

Reference

IPlayerProfileV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfileV2.CountryCode Property

IPlayerProfileV2CountryCode Property

Gets the country code

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string CountryCode { get; }

Property Value

String
See Also

Reference

IPlayerProfileV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfileV2.FullName Property

IPlayerProfileV2FullName Property

Gets the full name of the player

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string FullName { get; }

Property Value

String
See Also

Reference

IPlayerProfileV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfileV2.Nickname Property

IPlayerProfileV2Nickname Property

Gets the nickname of the player

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Nickname { get; }

Property Value

String
See Also

Reference

IPlayerProfileV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IPlayerProfileV2 Methods

The IPlayerProfileV2 type exposes the following members.

Methods
Name Description
Public method GetName Gets the name of the player in the specified language or a null reference
(Inherited from IPlayer)
Public method GetNationality Gets the nationality of the player represented by the current instance in the language specified by
C#
Copy
culture

(Inherited from IPlayerProfile)
Public method ToString Returns a String that represents this instance.
(Inherited from IEntityPrinter)
Public method ToString(IFormatProvider) Returns a string that represents the current object
(Inherited from IEntityPrinter)
Public method ToString(String, IFormatProvider) Formats the value of the current instance using the specified format.
(Inherited from IEntityPrinter)
Top
See Also

Reference

IPlayerProfileV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfo Interface

Defines a contract implemented by classes providing product information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IProductInfo : IEntityPrinter

The IProductInfo type exposes the following members.

Properties
 | Name | Description
Public property | Channels | Gets a IEnumerableT representing streaming channel associated with product
Public property | IsAutoTraded | Gets a value indicating whether the sport event is auto traded
Public property | IsInHostedStatistics | Gets a value indicating whether the sport event associated with the current instance is available in hosted solutions
Public property | IsInLiveCenterSoccer | Gets a value indicating whether the sport event associated with the current instance is available in LiveCenterSoccer solution
Public property | IsInLiveScore | Gets a value indicating whether the sport event associated with the current instance is available in LiveScore solution
Public property | Links | Gets a IEnumerableT representing links to the product represented by current instance
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfo Properties

The IProductInfo type exposes the following members.

Properties
 | Name | Description
Public property | Channels | Gets a IEnumerableT representing streaming channel associated with product
Public property | IsAutoTraded | Gets a value indicating whether the sport event is auto traded
Public property | IsInHostedStatistics | Gets a value indicating whether the sport event associated with the current instance is available in hosted solutions
Public property | IsInLiveCenterSoccer | Gets a value indicating whether the sport event associated with the current instance is available in LiveCenterSoccer solution
Public property | IsInLiveScore | Gets a value indicating whether the sport event associated with the current instance is available in LiveScore solution
Public property | Links | Gets a IEnumerableT representing links to the product represented by current instance
Top
See Also

Reference

IProductInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfo.Channels Property

IProductInfoChannels Property

Gets a IEnumerableT representing streaming channel associated with product

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IStreamingChannel> Channels { get; }

Property Value

IEnumerable IStreamingChannel
See Also

Reference

IProductInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfo.IsAutoTraded Property

IProductInfoIsAutoTraded Property

Gets a value indicating whether the sport event is auto traded

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsAutoTraded { get; }

Property Value

Boolean
See Also

Reference

IProductInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfo.IsInHostedStatistics Property

IProductInfoIsInHostedStatistics Property

Gets a value indicating whether the sport event associated with the current instance is available in hosted solutions

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsInHostedStatistics { get; }

Property Value

Boolean
See Also

Reference

IProductInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfo.IsInLiveCenterSoccer Property

IProductInfoIsInLiveCenterSoccer Property

Gets a value indicating whether the sport event associated with the current instance is available in LiveCenterSoccer solution

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsInLiveCenterSoccer { get; }

Property Value

Boolean
See Also

Reference

IProductInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfo.IsInLiveScore Property

IProductInfoIsInLiveScore Property

Gets a value indicating whether the sport event associated with the current instance is available in LiveScore solution

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsInLiveScore { get; }

Property Value

Boolean
See Also

Reference

IProductInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfo.Links Property

IProductInfoLinks Property

Gets a IEnumerableT representing links to the product represented by current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IProductInfoLink> Links { get; }

Property Value

IEnumerable IProductInfoLink
See Also

Reference

IProductInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfo Methods

The IProductInfo type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IProductInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfoLink Interface

Defines a contract implemented by classes representing product info links

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IProductInfoLink : IEntityPrinter

The IProductInfoLink type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the product link represented by the current instance
Public property | Reference | Gets the reference to the product info represented by the current instance
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfoLink Properties

The IProductInfoLink type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the product link represented by the current instance
Public property | Reference | Gets the reference to the product info represented by the current instance
Top
See Also

Reference

IProductInfoLink Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfoLink.Name Property

IProductInfoLinkName Property

Gets the name of the product link represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

String
See Also

Reference

IProductInfoLink Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfoLink.Reference Property

IProductInfoLinkReference Property

Gets the reference to the product info represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Reference { get; }

Property Value

String
See Also

Reference

IProductInfoLink Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfoLink Methods

The IProductInfoLink type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IProductInfoLink Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfoV1 Interface

Defines a contract implemented by classes providing product information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IProductInfoV1 : IProductInfo,
    IEntityPrinter

The IProductInfoV1 type exposes the following members.

Properties
 | Name | Description
Public property | Channels | Gets a IEnumerableT representing streaming channel associated with product (Inherited from IProductInfo)
Public property | IsAutoTraded | Gets a value indicating whether the sport event is auto traded (Inherited from IProductInfo)
Public property | IsInHostedStatistics | Gets a value indicating whether the sport event associated with the current instance is available in hosted solutions (Inherited from IProductInfo)
Public property | IsInLiveCenterSoccer | Gets a value indicating whether the sport event associated with the current instance is available in LiveCenterSoccer solution (Inherited from IProductInfo)
Public property | IsInLiveMatchTracker | Gets a value indicating whether the sport event associated with the current instance is available in LiveMatchTracker solution
Public property | IsInLiveScore | Gets a value indicating whether the sport event associated with the current instance is available in LiveScore solution (Inherited from IProductInfo)
Public property | Links | Gets a IEnumerableT representing links to the product represented by current instance (Inherited from IProductInfo)
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfoV1 Properties

The IProductInfoV1 type exposes the following members.

Properties
 | Name | Description
Public property | Channels | Gets a IEnumerableT representing streaming channel associated with product (Inherited from IProductInfo)
Public property | IsAutoTraded | Gets a value indicating whether the sport event is auto traded (Inherited from IProductInfo)
Public property | IsInHostedStatistics | Gets a value indicating whether the sport event associated with the current instance is available in hosted solutions (Inherited from IProductInfo)
Public property | IsInLiveCenterSoccer | Gets a value indicating whether the sport event associated with the current instance is available in LiveCenterSoccer solution (Inherited from IProductInfo)
Public property | IsInLiveMatchTracker | Gets a value indicating whether the sport event associated with the current instance is available in LiveMatchTracker solution
Public property | IsInLiveScore | Gets a value indicating whether the sport event associated with the current instance is available in LiveScore solution (Inherited from IProductInfo)
Public property | Links | Gets a IEnumerableT representing links to the product represented by current instance (Inherited from IProductInfo)
Top
See Also

Reference

IProductInfoV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfoV1.IsInLiveMatchTracker Property

IProductInfoV1IsInLiveMatchTracker Property

Gets a value indicating whether the sport event associated with the current instance is available in LiveMatchTracker solution

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsInLiveMatchTracker { get; }

Property Value

Boolean
See Also

Reference

IProductInfoV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IProductInfoV1 Methods

The IProductInfoV1 type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IProductInfoV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRaceDriverProfile Interface

Represents a race driver profile

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IRaceDriverProfile

The IRaceDriverProfile type exposes the following members.

Properties
 | Name | Description
Public property | Car | Gets the car info
Public property | RaceDriverId | Gets the race driver id
Public property | RaceTeamId | Gets the race team id
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRaceDriverProfile Properties

The IRaceDriverProfile type exposes the following members.

Properties
 | Name | Description
Public property | Car | Gets the car info
Public property | RaceDriverId | Gets the race driver id
Public property | RaceTeamId | Gets the race team id
Top
See Also

Reference

IRaceDriverProfile Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRaceDriverProfile.Car Property

IRaceDriverProfileCar Property

Gets the car info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICar Car { get; }

Property Value

ICar
The car info
See Also

Reference

IRaceDriverProfile Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRaceDriverProfile.RaceDriverId Property

IRaceDriverProfileRaceDriverId Property

Gets the race driver id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN RaceDriverId { get; }

Property Value

URN
The race driver id
See Also

Reference

IRaceDriverProfile Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRaceDriverProfile.RaceTeamId Property

IRaceDriverProfileRaceTeamId Property

Gets the race team id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN RaceTeamId { get; }

Property Value

URN
The race team id
See Also

Reference

IRaceDriverProfile Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReferee Interface

Defines a contract implemented by classes representing sport event referee

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IReferee : IEntityPrinter

The IReferee type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN used to uniquely identify the current IReferee instance
Public property | Name | Gets the name of the referee represented by the current IReferee instance
Public property | Nationalities | Gets a IReadOnlyDictionaryTKey, TValue containing referee nationality in different languages
Top
Methods
 | Name | Description
Public method | GetNationality | Gets the referee nationality in the specified language
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReferee Properties

The IReferee type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN used to uniquely identify the current IReferee instance
Public property | Name | Gets the name of the referee represented by the current IReferee instance
Public property | Nationalities | Gets a IReadOnlyDictionaryTKey, TValue containing referee nationality in different languages
Top
See Also

Reference

IReferee Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReferee.Id Property

IRefereeId Property

Gets a URN used to uniquely identify the current IReferee instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

IReferee Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReferee.Name Property

IRefereeName Property

Gets the name of the referee represented by the current IReferee instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

String
See Also

Reference

IReferee Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReferee.Nationalities Property

IRefereeNationalities Property

Gets a IReadOnlyDictionaryTKey, TValue containing referee nationality in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Nationalities { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

IReferee Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReferee Methods

The IReferee type exposes the following members.

Methods
 | Name | Description
Public method | GetNationality | Gets the referee nationality in the specified language
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IReferee Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReferee.GetNationality Method

IRefereeGetNationality Method

Gets the referee nationality in the specified language

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetNationality(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language.

Return Value

String
The referee nationality in the specified language.
See Also

Reference

IReferee Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReference Interface

A contract for classes implementing array a+of references

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IReference : IEntityPrinter

The IReference type exposes the following members.

Properties
 | Name | Description
Public property | BetfairId | Gets the Betfair id for this instance if provided amount reference ids
Public property | BetradarId | Gets the Betradar id for this instance if provided amount reference ids
Public property | References | Gets all the reference ids
Public property | RotationNumber | Gets the rotation number if provided among reference ids
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReference Properties

The IReference type exposes the following members.

Properties
 | Name | Description
Public property | BetfairId | Gets the Betfair id for this instance if provided amount reference ids
Public property | BetradarId | Gets the Betradar id for this instance if provided amount reference ids
Public property | References | Gets all the reference ids
Public property | RotationNumber | Gets the rotation number if provided among reference ids
Top
See Also

Reference

IReference Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReference.BetfairId Property

IReferenceBetfairId Property

Gets the Betfair id for this instance if provided amount reference ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int BetfairId { get; }

Return Value

Int32
If exists among reference ids, result is greater then 0
See Also

Reference

IReference Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReference.BetradarId Property

IReferenceBetradarId Property

Gets the Betradar id for this instance if provided amount reference ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int BetradarId { get; }

Return Value

Int32
If exists among reference ids, result is greater then 0
See Also

Reference

IReference Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReference.References Property

IReferenceReferences Property

Gets all the reference ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<string, string> References { get; }

Property Value

IReadOnlyDictionary String, String
See Also

Reference

IReference Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReference.RotationNumber Property

IReferenceRotationNumber Property

Gets the rotation number if provided among reference ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int RotationNumber { get; }

Property Value

Int32
If exists among reference ids, result is greater then 0
Remarks
This id only exists for US leagues
See Also

Reference

IReference Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReference Methods

The IReference type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IReference Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReferenceV1 Interface

A contract for classes implementing array a+of references

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IReferenceV1 : IReference,
    IEntityPrinter

The IReferenceV1 type exposes the following members.

Properties
 | Name | Description
Public property | AamsId | Returns the AAMS id for this instance if provided among reference ids, null otherwise
Public property | BetfairId | Gets the Betfair id for this instance if provided amount reference ids (Inherited from IReference)
Public property | BetradarId | Gets the Betradar id for this instance if provided amount reference ids (Inherited from IReference)
Public property | References | Gets all the reference ids (Inherited from IReference)
Public property | RotationNumber | Gets the rotation number if provided among reference ids (Inherited from IReference)
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReferenceV1 Properties

The IReferenceV1 type exposes the following members.

Properties
 | Name | Description
Public property | AamsId | Returns the AAMS id for this instance if provided among reference ids, null otherwise
Public property | BetfairId | Gets the Betfair id for this instance if provided amount reference ids (Inherited from IReference)
Public property | BetradarId | Gets the Betradar id for this instance if provided amount reference ids (Inherited from IReference)
Public property | References | Gets all the reference ids (Inherited from IReference)
Public property | RotationNumber | Gets the rotation number if provided among reference ids (Inherited from IReference)
Top
See Also

Reference

IReferenceV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReferenceV1.AamsId Property

IReferenceV1AamsId Property

Returns the AAMS id for this instance if provided among reference ids, null otherwise

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? AamsId { get; }

Return Value

Nullable Int32
The AAMS id for this instance if provided among reference ids, null otherwise
See Also

Reference

IReferenceV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IReferenceV1 Methods

The IReferenceV1 type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IReferenceV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRestMessage Interface

Defines a contract implemented by all classes representing messages received from the feed's REST interface

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IRestMessage

The IRestMessage type exposes the following members.

Properties
 | Name | Description
Public property | GeneratedAt | Gets a DateTime instance specifying when the message represented by the current IRestMessage was generated, or a null reference if time of generation is not defined
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRestMessage Properties

The IRestMessage type exposes the following members.

Properties
 | Name | Description
Public property | GeneratedAt | Gets a DateTime instance specifying when the message represented by the current IRestMessage was generated, or a null reference if time of generation is not defined
Top
See Also

Reference

IRestMessage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRestMessage.GeneratedAt Property

IRestMessageGeneratedAt Property

Gets a DateTime instance specifying when the message represented by the current IRestMessage was generated, or a null reference if time of generation is not defined

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime? GeneratedAt { get; }

Property Value

Nullable DateTime
See Also

Reference

IRestMessage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IResultChange Interface

Defines a contract implemented by classes representing result change

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IResultChange : IEntityPrinter

The IResultChange type exposes the following members.

Properties
 | Name | Description
Public property | SportEventId | Gets the URN specifying the sport event
Public property | UpdateTime | Gets the DateTime specifying the last update time
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IResultChange Properties

The IResultChange type exposes the following members.

Properties
 | Name | Description
Public property | SportEventId | Gets the URN specifying the sport event
Public property | UpdateTime | Gets the DateTime specifying the last update time
Top
See Also

Reference

IResultChange Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IResultChange.SportEventId Property

IResultChangeSportEventId Property

Gets the URN specifying the sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN SportEventId { get; }

Property Value

URN
See Also

Reference

IResultChange Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IResultChange.UpdateTime Property

IResultChangeUpdateTime Property

Gets the DateTime specifying the last update time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime UpdateTime { get; }

Property Value

DateTime
See Also

Reference

IResultChange Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IResultChange Methods

The IResultChange type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IResultChange Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound Interface

Defines a contract implemented by classes providing basic tournament round information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IRound : IEntityPrinter

The IRound type exposes the following members.

Properties
 | Name | Description
Public property | BetradarId | Gets the betradar identifier
Public property | CupRoundMatches | Gets a value specifying the number of matches in the current cup round or a null reference if number of matches is not applicable to current IRound instance
Public property | CupRoundMatchNumber | Gets a value specifying the number of the match in the current cup round or a null reference if match number is not applicable to current IRound instance
Public property | Group | Gets the name of the group associated with the current round
Public property | GroupName | Obsolete. Gets the group name of the current IRound per language
Public property | Name | Gets the name of the current IRound per locale
Public property | Number | Gets a value specifying the round number or a null reference if round number is not defined
Public property | OtherMatchId | Gets the id of the other match
Public property | PhaseOrGroupLongName | Gets the phase or group long name of the current IRound per locale
Public property | Type | Gets the type of the round
Top
Methods
 | Name | Description
Public method | GetGroupName | Gets the group name for specific language
Public method | GetName | Gets the name for specific locale
Public method | GetPhaseOrGroupLongName | Gets the phase or group long name for specific locale
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound Properties

The IRound type exposes the following members.

Properties
 | Name | Description
Public property | BetradarId | Gets the betradar identifier
Public property | CupRoundMatches | Gets a value specifying the number of matches in the current cup round or a null reference if number of matches is not applicable to current IRound instance
Public property | CupRoundMatchNumber | Gets a value specifying the number of the match in the current cup round or a null reference if match number is not applicable to current IRound instance
Public property | Group | Gets the name of the group associated with the current round
Public property | GroupName | Obsolete. Gets the group name of the current IRound per language
Public property | Name | Gets the name of the current IRound per locale
Public property | Number | Gets a value specifying the round number or a null reference if round number is not defined
Public property | OtherMatchId | Gets the id of the other match
Public property | PhaseOrGroupLongName | Gets the phase or group long name of the current IRound per locale
Public property | Type | Gets the type of the round
Top
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.BetradarId Property

IRoundBetradarId Property

Gets the betradar identifier

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int BetradarId { get; }

Property Value

Int32
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.CupRoundMatches Property

IRoundCupRoundMatches Property

Gets a value specifying the number of matches in the current cup round or a null reference if number of matches is not applicable to current IRound instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? CupRoundMatches { get; }

Property Value

Nullable Int32
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.CupRoundMatchNumber Property

IRoundCupRoundMatchNumber Property

Gets a value specifying the number of the match in the current cup round or a null reference if match number is not applicable to current IRound instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? CupRoundMatchNumber { get; }

Property Value

Nullable Int32
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.Group Property

IRoundGroup Property

Gets the name of the group associated with the current round

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Group { get; }

Property Value

String
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.GroupName Property

IRoundGroupName Property

Note: This API is now obsolete.

Gets the group name of the current IRound per language

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("GroupName was removed from API")]
IDictionary<CultureInfo, string> GroupName { get; }

Property Value

IDictionary CultureInfo, String
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.Name Property

IRoundName Property

Gets the name of the current IRound per locale

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IDictionary<CultureInfo, string> Name { get; }

Property Value

IDictionary CultureInfo, String
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.Number Property

IRoundNumber Property

Gets a value specifying the round number or a null reference if round number is not defined

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Number { get; }

Property Value

Nullable Int32
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.OtherMatchId Property

IRoundOtherMatchId Property

Gets the id of the other match

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string OtherMatchId { get; }

Property Value

String
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.PhaseOrGroupLongName Property

IRoundPhaseOrGroupLongName Property

Gets the phase or group long name of the current IRound per locale

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IDictionary<CultureInfo, string> PhaseOrGroupLongName { get; }

Property Value

IDictionary CultureInfo, String
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.Type Property

IRoundType Property

Gets the type of the round

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Type { get; }

Property Value

String
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound Methods

The IRound type exposes the following members.

Methods
 | Name | Description
Public method | GetGroupName | Gets the group name for specific language
Public method | GetName | Gets the name for specific locale
Public method | GetPhaseOrGroupLongName | Gets the phase or group long name for specific locale
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.GetGroupName Method

IRoundGetGroupName Method

Gets the group name for specific language

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetGroupName(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture

Return Value

String
Return the group name if exists, or null
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.GetName Method

IRoundGetName Method

Gets the name for specific locale

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture

Return Value

String
Return the Name if exists, or null
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRound.GetPhaseOrGroupLongName Method

IRoundGetPhaseOrGroupLongName Method

Gets the phase or group long name for specific locale

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetPhaseOrGroupLongName(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture

Return Value

String
Return the phase or group long name if exists, or null
See Also

Reference

IRound Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRoundV1 Interface

Defines a contract implemented by classes providing basic tournament round information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IRoundV1 : IRound,
    IEntityPrinter

The IRoundV1 type exposes the following members.

Properties
 | Name | Description
Public property | BetradarId | Gets the betradar identifier (Inherited from IRound)
Public property | CupRoundMatches | Gets a value specifying the number of matches in the current cup round or a null reference if number of matches is not applicable to current IRound instance (Inherited from IRound)
Public property | CupRoundMatchNumber | Gets a value specifying the number of the match in the current cup round or a null reference if match number is not applicable to current IRound instance (Inherited from IRound)
Public property | Group | Gets the name of the group associated with the current round (Inherited from IRound)
Public property | GroupId | Gets the id of the group associated with the current round
Public property | GroupName | Obsolete. Gets the group name of the current IRound per language (Inherited from IRound)
Public property | Name | Gets the name of the current IRound per locale (Inherited from IRound)
Public property | Number | Gets a value specifying the round number or a null reference if round number is not defined (Inherited from IRound)
Public property | OtherMatchId | Gets the id of the other match (Inherited from IRound)
Public property | PhaseOrGroupLongName | Gets the phase or group long name of the current IRound per locale (Inherited from IRound)
Public property | Type | Gets the type of the round (Inherited from IRound)
Top
Methods
 | Name | Description
Public method | GetGroupName | Gets the group name for specific language (Inherited from IRound)
Public method | GetName | Gets the name for specific locale (Inherited from IRound)
Public method | GetPhaseOrGroupLongName | Gets the phase or group long name for specific locale (Inherited from IRound)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRoundV1 Properties

The IRoundV1 type exposes the following members.

Properties
 | Name | Description
Public property | BetradarId | Gets the betradar identifier (Inherited from IRound)
Public property | CupRoundMatches | Gets a value specifying the number of matches in the current cup round or a null reference if number of matches is not applicable to current IRound instance (Inherited from IRound)
Public property | CupRoundMatchNumber | Gets a value specifying the number of the match in the current cup round or a null reference if match number is not applicable to current IRound instance (Inherited from IRound)
Public property | Group | Gets the name of the group associated with the current round (Inherited from IRound)
Public property | GroupId | Gets the id of the group associated with the current round
Public property | GroupName | Obsolete. Gets the group name of the current IRound per language (Inherited from IRound)
Public property | Name | Gets the name of the current IRound per locale (Inherited from IRound)
Public property | Number | Gets a value specifying the round number or a null reference if round number is not defined (Inherited from IRound)
Public property | OtherMatchId | Gets the id of the other match (Inherited from IRound)
Public property | PhaseOrGroupLongName | Gets the phase or group long name of the current IRound per locale (Inherited from IRound)
Public property | Type | Gets the type of the round (Inherited from IRound)
Top
See Also

Reference

IRoundV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRoundV1.GroupId Property

IRoundV1GroupId Property

Gets the id of the group associated with the current round

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN GroupId { get; }

Property Value

URN
See Also

Reference

IRoundV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRoundV1 Methods

The IRoundV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetGroupName | Gets the group name for specific language (Inherited from IRound)
Public method | GetName | Gets the name for specific locale (Inherited from IRound)
Public method | GetPhaseOrGroupLongName | Gets the phase or group long name for specific locale (Inherited from IRound)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IRoundV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRoundV2 Interface

Defines a contract implemented by classes providing basic tournament round information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IRoundV2 : IRoundV1,
    IRound, IEntityPrinter

The IRoundV2 type exposes the following members.

Properties
 | Name | Description
Public property | BetradarId | Gets the betradar identifier (Inherited from IRound)
Public property | CupRoundMatches | Gets a value specifying the number of matches in the current cup round or a null reference if number of matches is not applicable to current IRound instance (Inherited from IRound)
Public property | CupRoundMatchNumber | Gets a value specifying the number of the match in the current cup round or a null reference if match number is not applicable to current IRound instance (Inherited from IRound)
Public property | Group | Gets the name of the group associated with the current round (Inherited from IRound)
Public property | GroupId | Gets the id of the group associated with the current round (Inherited from IRoundV1)
Public property | GroupName | Obsolete. Gets the group name of the current IRound per language (Inherited from IRound)
Public property | Name | Gets the name of the current IRound per locale (Inherited from IRound)
Public property | Number | Gets a value specifying the round number or a null reference if round number is not defined (Inherited from IRound)
Public property | OtherMatchId | Gets the id of the other match (Inherited from IRound)
Public property | Phase | Gets the phase of the associated round
Public property | PhaseOrGroupLongName | Gets the phase or group long name of the current IRound per locale (Inherited from IRound)
Public property | Type | Gets the type of the round (Inherited from IRound)
Top
Methods
 | Name | Description
Public method | GetGroupName | Gets the group name for specific language (Inherited from IRound)
Public method | GetName | Gets the name for specific locale (Inherited from IRound)
Public method | GetPhaseOrGroupLongName | Gets the phase or group long name for specific locale (Inherited from IRound)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRoundV2 Properties

The IRoundV2 type exposes the following members.

Properties
 | Name | Description
Public property | BetradarId | Gets the betradar identifier (Inherited from IRound)
Public property | CupRoundMatches | Gets a value specifying the number of matches in the current cup round or a null reference if number of matches is not applicable to current IRound instance (Inherited from IRound)
Public property | CupRoundMatchNumber | Gets a value specifying the number of the match in the current cup round or a null reference if match number is not applicable to current IRound instance (Inherited from IRound)
Public property | Group | Gets the name of the group associated with the current round (Inherited from IRound)
Public property | GroupId | Gets the id of the group associated with the current round (Inherited from IRoundV1)
Public property | GroupName | Obsolete. Gets the group name of the current IRound per language (Inherited from IRound)
Public property | Name | Gets the name of the current IRound per locale (Inherited from IRound)
Public property | Number | Gets a value specifying the round number or a null reference if round number is not defined (Inherited from IRound)
Public property | OtherMatchId | Gets the id of the other match (Inherited from IRound)
Public property | Phase | Gets the phase of the associated round
Public property | PhaseOrGroupLongName | Gets the phase or group long name of the current IRound per locale (Inherited from IRound)
Public property | Type | Gets the type of the round (Inherited from IRound)
Top
See Also

Reference

IRoundV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRoundV2.Phase Property

IRoundV2Phase Property

Gets the phase of the associated round

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Phase { get; }

Property Value

String
See Also

Reference

IRoundV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRoundV2 Methods

The IRoundV2 type exposes the following members.

Methods
 | Name | Description
Public method | GetGroupName | Gets the group name for specific language (Inherited from IRound)
Public method | GetName | Gets the name for specific locale (Inherited from IRound)
Public method | GetPhaseOrGroupLongName | Gets the phase or group long name for specific locale (Inherited from IRound)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IRoundV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRoundV3 Interface

Defines a contract implemented by classes providing basic tournament round information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IRoundV3 : IRoundV2,
    IRoundV1, IRound, IEntityPrinter

The IRoundV3 type exposes the following members.

Properties
 | Name | Description
Public property | BetradarId | Gets the betradar identifier (Inherited from IRound)
Public property | BetradarName | A betradar name
Public property | CupRoundMatches | Gets a value specifying the number of matches in the current cup round or a null reference if number of matches is not applicable to current IRound instance (Inherited from IRound)
Public property | CupRoundMatchNumber | Gets a value specifying the number of the match in the current cup round or a null reference if match number is not applicable to current IRound instance (Inherited from IRound)
Public property | Group | Gets the name of the group associated with the current round (Inherited from IRound)
Public property | GroupId | Gets the id of the group associated with the current round (Inherited from IRoundV1)
Public property | GroupName | Obsolete. Gets the group name of the current IRound per language (Inherited from IRound)
Public property | Name | Gets the name of the current IRound per locale (Inherited from IRound)
Public property | Number | Gets a value specifying the round number or a null reference if round number is not defined (Inherited from IRound)
Public property | OtherMatchId | Gets the id of the other match (Inherited from IRound)
Public property | Phase | Gets the phase of the associated round (Inherited from IRoundV2)
Public property | PhaseOrGroupLongName | Gets the phase or group long name of the current IRound per locale (Inherited from IRound)
Public property | Type | Gets the type of the round (Inherited from IRound)
Top
Methods
 | Name | Description
Public method | GetGroupName | Gets the group name for specific language (Inherited from IRound)
Public method | GetName | Gets the name for specific locale (Inherited from IRound)
Public method | GetPhaseOrGroupLongName | Gets the phase or group long name for specific locale (Inherited from IRound)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRoundV3 Properties

The IRoundV3 type exposes the following members.

Properties
 | Name | Description
Public property | BetradarId | Gets the betradar identifier (Inherited from IRound)
Public property | BetradarName | A betradar name
Public property | CupRoundMatches | Gets a value specifying the number of matches in the current cup round or a null reference if number of matches is not applicable to current IRound instance (Inherited from IRound)
Public property | CupRoundMatchNumber | Gets a value specifying the number of the match in the current cup round or a null reference if match number is not applicable to current IRound instance (Inherited from IRound)
Public property | Group | Gets the name of the group associated with the current round (Inherited from IRound)
Public property | GroupId | Gets the id of the group associated with the current round (Inherited from IRoundV1)
Public property | GroupName | Obsolete. Gets the group name of the current IRound per language (Inherited from IRound)
Public property | Name | Gets the name of the current IRound per locale (Inherited from IRound)
Public property | Number | Gets a value specifying the round number or a null reference if round number is not defined (Inherited from IRound)
Public property | OtherMatchId | Gets the id of the other match (Inherited from IRound)
Public property | Phase | Gets the phase of the associated round (Inherited from IRoundV2)
Public property | PhaseOrGroupLongName | Gets the phase or group long name of the current IRound per locale (Inherited from IRound)
Public property | Type | Gets the type of the round (Inherited from IRound)
Top
See Also

Reference

IRoundV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRoundV3.BetradarName Property

IRoundV3BetradarName Property

A betradar name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string BetradarName { get; }

Property Value

String
See Also

Reference

IRoundV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IRoundV3 Methods

The IRoundV3 type exposes the following members.

Methods
 | Name | Description
Public method | GetGroupName | Gets the group name for specific language (Inherited from IRound)
Public method | GetName | Gets the name for specific locale (Inherited from IRound)
Public method | GetPhaseOrGroupLongName | Gets the phase or group long name for specific locale (Inherited from IRound)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IRoundV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IScheduledStartTimeChange Interface

Defines a contract implemented by classes providing schedule start time change

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IScheduledStartTimeChange

The IScheduledStartTimeChange type exposes the following members.

Properties
 | Name | Description
Public property | ChangedAt | Gets the changed at
Public property | NewTime | Gets the new time
Public property | OldTime | Gets the old time
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IScheduledStartTimeChange Properties

The IScheduledStartTimeChange type exposes the following members.

Properties
 | Name | Description
Public property | ChangedAt | Gets the changed at
Public property | NewTime | Gets the new time
Public property | OldTime | Gets the old time
Top
See Also

Reference

IScheduledStartTimeChange Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IScheduledStartTimeChange.ChangedAt Property

IScheduledStartTimeChangeChangedAt Property

Gets the changed at

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime ChangedAt { get; }

Property Value

DateTime
The changed at
See Also

Reference

IScheduledStartTimeChange Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IScheduledStartTimeChange.NewTime Property

IScheduledStartTimeChangeNewTime Property

Gets the new time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime NewTime { get; }

Property Value

DateTime
The new time
See Also

Reference

IScheduledStartTimeChange Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IScheduledStartTimeChange.OldTime Property

IScheduledStartTimeChangeOldTime Property

Gets the old time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime OldTime { get; }

Property Value

DateTime
The old time
See Also

Reference

IScheduledStartTimeChange Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeason Interface

Defines a contract implemented by classes representing a tournament season

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISeason : ILongTermEvent,
    ISportEvent

The ISeason type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetCompetitorsAsync | Asynchronously gets the list of competitors
Public method | GetCurrentRoundAsync | Asynchronously gets the IRound specifying the current round of the tournament associated with the current instance
Public method | GetGroupsAsync | Asynchronously gets the list of the IGroup instances belonging to the season
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduleAsync | Asynchronously gets the list of all ICompetition that belongs to the season schedule
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonCoverageAsync | Asynchronously gets a ISeasonCoverage representing the season coverage
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Public method | GetTournamentInfoAsync | Asynchronously gets a ITournamentInfo representing the tournament info
Public method | GetYearAsync | Asynchronously gets a String representation of the current season year
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeason Properties

The ISeason type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ISeason Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeason Methods

The ISeason type exposes the following members.

Methods
 | Name | Description
Public method | GetCompetitorsAsync | Asynchronously gets the list of competitors
Public method | GetCurrentRoundAsync | Asynchronously gets the IRound specifying the current round of the tournament associated with the current instance
Public method | GetGroupsAsync | Asynchronously gets the list of the IGroup instances belonging to the season
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduleAsync | Asynchronously gets the list of all ICompetition that belongs to the season schedule
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonCoverageAsync | Asynchronously gets a ISeasonCoverage representing the season coverage
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Public method | GetTournamentInfoAsync | Asynchronously gets a ITournamentInfo representing the tournament info
Public method | GetYearAsync | Asynchronously gets a String representation of the current season year
Top
See Also

Reference

ISeason Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeason.GetCompetitorsAsync Method

ISeasonGetCompetitorsAsync Method

Asynchronously gets the list of competitors

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ICompetitor>> GetCompetitorsAsync()

Return Value

Task IEnumerable ICompetitor
The list of competitors
See Also

Reference

ISeason Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeason.GetCurrentRoundAsync Method

ISeasonGetCurrentRoundAsync Method

Asynchronously gets the IRound specifying the current round of the tournament associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IRound> GetCurrentRoundAsync()

Return Value

Task IRound
The IRound specifying the current round of the tournament associated with the current instance
See Also

Reference

ISeason Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeason.GetGroupsAsync Method

ISeasonGetGroupsAsync Method

Asynchronously gets the list of the IGroup instances belonging to the season

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IGroup>> GetGroupsAsync()

Return Value

Task IEnumerable IGroup
A Task representing the asynchronous operation
See Also

Reference

ISeason Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeason.GetScheduleAsync Method

ISeasonGetScheduleAsync Method

Asynchronously gets the list of all ICompetition that belongs to the season schedule

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ICompetition>> GetScheduleAsync()

Return Value

Task IEnumerable ICompetition
The list of all ICompetition that belongs to the season schedule
See Also

Reference

ISeason Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeason.GetSeasonCoverageAsync Method

ISeasonGetSeasonCoverageAsync Method

Asynchronously gets a ISeasonCoverage representing the season coverage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ISeasonCoverage> GetSeasonCoverageAsync()

Return Value

Task ISeasonCoverage
A TaskTResult representing the asynchronous operation
See Also

Reference

ISeason Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeason.GetTournamentInfoAsync Method

ISeasonGetTournamentInfoAsync Method

Asynchronously gets a ITournamentInfo representing the tournament info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ITournamentInfo> GetTournamentInfoAsync()

Return Value

Task ITournamentInfo
A TaskTResult representing the asynchronous operation
See Also

Reference

ISeason Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeason.GetYearAsync Method

ISeasonGetYearAsync Method

Asynchronously gets a String representation of the current season year

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<string> GetYearAsync()

Return Value

Task String
Asynchronously returns a String representation of the season year
See Also

Reference

ISeason Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonCoverage Interface

Defines an interface representing season coverage info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISeasonCoverage

The ISeasonCoverage type exposes the following members.

Properties
 | Name | Description
Public property | MaxCoverageLevel | Gets the string representation of the maximum coverage available for the season associated with the current instance
Public property | MaxCovered | Gets the max covered value
Public property | MinCoverageLevel | Gets the name of the minimum coverage guaranteed for the season associated with the current instance
Public property | Played | Gets the played value
Public property | Scheduled | Gets the scheduled value
Public property | SeasonId | Gets the identifier of the season
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonCoverage Properties

The ISeasonCoverage type exposes the following members.

Properties
 | Name | Description
Public property | MaxCoverageLevel | Gets the string representation of the maximum coverage available for the season associated with the current instance
Public property | MaxCovered | Gets the max covered value
Public property | MinCoverageLevel | Gets the name of the minimum coverage guaranteed for the season associated with the current instance
Public property | Played | Gets the played value
Public property | Scheduled | Gets the scheduled value
Public property | SeasonId | Gets the identifier of the season
Top
See Also

Reference

ISeasonCoverage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonCoverage.MaxCoverageLevel Property

ISeasonCoverageMaxCoverageLevel Property

Gets the string representation of the maximum coverage available for the season associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string MaxCoverageLevel { get; }

Property Value

String
See Also

Reference

ISeasonCoverage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonCoverage.MaxCovered Property

ISeasonCoverageMaxCovered Property

Gets the max covered value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? MaxCovered { get; }

Property Value

Nullable Int32
See Also

Reference

ISeasonCoverage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonCoverage.MinCoverageLevel Property

ISeasonCoverageMinCoverageLevel Property

Gets the name of the minimum coverage guaranteed for the season associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string MinCoverageLevel { get; }

Property Value

String
See Also

Reference

ISeasonCoverage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonCoverage.Played Property

ISeasonCoveragePlayed Property

Gets the played value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Played { get; }

Property Value

Int32
See Also

Reference

ISeasonCoverage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonCoverage.Scheduled Property

ISeasonCoverageScheduled Property

Gets the scheduled value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Scheduled { get; }

Property Value

Int32
See Also

Reference

ISeasonCoverage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonCoverage.SeasonId Property

ISeasonCoverageSeasonId Property

Gets the identifier of the season

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN SeasonId { get; }

Property Value

URN
See Also

Reference

ISeasonCoverage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfo Interface

Defines a contract for classes implementing

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISeasonInfo

The ISeasonInfo type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the URN identifying the current instance
Public property | Names | Gets the list of translated names
Top
Methods
 | Name | Description
Public method | GetName | Gets the name.
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfo Properties

The ISeasonInfo type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the URN identifying the current instance
Public property | Names | Gets the list of translated names
Top
See Also

Reference

ISeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfo.Id Property

ISeasonInfoId Property

Gets the URN identifying the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
The URN identifying the current instance
See Also

Reference

ISeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfo.Names Property

ISeasonInfoNames Property

Gets the list of translated names

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Names { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
The list of translated names
See Also

Reference

ISeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfo Methods

The ISeasonInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name.
Top
See Also

Reference

ISeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfo.GetName Method

ISeasonInfoGetName Method

Gets the name.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture

Return Value

String
System.String
See Also

Reference

ISeasonInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfoV1 Interface

Defines a contract for classes implementing

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISeasonInfoV1 : ISeasonInfo

The ISeasonInfoV1 type exposes the following members.

Properties
 | Name | Description
Public property | EndDate | Gets the end date of the season represented by the current instance
Public property | Id | Gets the URN identifying the current instance (Inherited from ISeasonInfo)
Public property | Names | Gets the list of translated names (Inherited from ISeasonInfo)
Public property | StartDate | Gets the start date of the season represented by the current instance
Public property | TournamentId | Gets the associated tournament identifier.
Public property | Year | Gets a String representation of the current season year
Top
Methods
 | Name | Description
Public method | GetName | Gets the name. (Inherited from ISeasonInfo)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfoV1 Properties

The ISeasonInfoV1 type exposes the following members.

Properties
 | Name | Description
Public property | EndDate | Gets the end date of the season represented by the current instance
Public property | Id | Gets the URN identifying the current instance (Inherited from ISeasonInfo)
Public property | Names | Gets the list of translated names (Inherited from ISeasonInfo)
Public property | StartDate | Gets the start date of the season represented by the current instance
Public property | TournamentId | Gets the associated tournament identifier.
Public property | Year | Gets a String representation of the current season year
Top
See Also

Reference

ISeasonInfoV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfoV1.EndDate Property

ISeasonInfoV1EndDate Property

Gets the end date of the season represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime EndDate { get; }

Property Value

DateTime
The end date.
See Also

Reference

ISeasonInfoV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfoV1.StartDate Property

ISeasonInfoV1StartDate Property

Gets the start date of the season represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime StartDate { get; }

Property Value

DateTime
See Also

Reference

ISeasonInfoV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfoV1.TournamentId Property

ISeasonInfoV1TournamentId Property

Gets the associated tournament identifier.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN TournamentId { get; }

Property Value

URN
The associated tournament identifier.
See Also

Reference

ISeasonInfoV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfoV1.Year Property

ISeasonInfoV1Year Property

Gets a String representation of the current season year

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Year { get; }

Property Value

String
See Also

Reference

ISeasonInfoV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISeasonInfoV1 Methods

The ISeasonInfoV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name. (Inherited from ISeasonInfo)
Top
See Also

Reference

ISeasonInfoV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISoccerEvent Interface

Defines a contract for classes representing soccer sport events

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISoccerEvent : IMatch,
    ICompetition, ISportEvent

The ISoccerEvent type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetAwayCompetitorAsync | Asynchronously gets a ITeamCompetitor representing away competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetDelayedInfoAsync | Asynchronously gets the associated delayed info (Inherited from IMatch)
Public method | GetEventTimelineAsync | Asynchronously gets the associated event timeline (Inherited from IMatch)
Public method | GetFixtureAsync | Asynchronously gets a IFixture instance containing information about the arranged sport event (Inherited from IMatch)
Public method | GetHomeCompetitorAsync | Asynchronously gets a ITeamCompetitor representing home competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonAsync | Asynchronously gets a ISeasonInfo representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously get the status of the soccer match
Public method | GetTournamentAsync | Asynchronously gets a ILongTermEvent representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetTournamentRoundAsync | Asynchronously gets a IRound representing the tournament round to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISoccerEvent Properties

The ISoccerEvent type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ISoccerEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISoccerEvent Methods

The ISoccerEvent type exposes the following members.

Methods
 | Name | Description
Public method | GetAwayCompetitorAsync | Asynchronously gets a ITeamCompetitor representing away competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetDelayedInfoAsync | Asynchronously gets the associated delayed info (Inherited from IMatch)
Public method | GetEventTimelineAsync | Asynchronously gets the associated event timeline (Inherited from IMatch)
Public method | GetFixtureAsync | Asynchronously gets a IFixture instance containing information about the arranged sport event (Inherited from IMatch)
Public method | GetHomeCompetitorAsync | Asynchronously gets a ITeamCompetitor representing home competitor of the match associated with the current instance (Inherited from IMatch)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonAsync | Asynchronously gets a ISeasonInfo representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStatusAsync | Asynchronously get the status of the soccer match
Public method | GetTournamentAsync | Asynchronously gets a ILongTermEvent representing the season to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetTournamentRoundAsync | Asynchronously gets a IRound representing the tournament round to which the sport event associated with the current instance belongs to (Inherited from IMatch)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

ISoccerEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISoccerEvent.GetStatusAsync Method

ISoccerEventGetStatusAsync Method

Asynchronously get the status of the soccer match

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ISoccerStatus> GetStatusAsync()

Return Value

Task ISoccerStatus
The status of the soccer match
See Also

Reference

ISoccerEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISoccerStatistics Interface

Defines a contract for classes implementing soccer match specific statistics

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISoccerStatistics

The ISoccerStatistics type exposes the following members.

Properties
 | Name | Description
Public property | PeriodStatistics | Gets the list of separate period statistics
Public property | TotalStatistics | Gets the list of complete team statistics data
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISoccerStatistics Properties

The ISoccerStatistics type exposes the following members.

Properties
 | Name | Description
Public property | PeriodStatistics | Gets the list of separate period statistics
Public property | TotalStatistics | Gets the list of complete team statistics data
Top
See Also

Reference

ISoccerStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISoccerStatistics.PeriodStatistics Property

ISoccerStatisticsPeriodStatistics Property

Gets the list of separate period statistics

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IPeriodStatistics> PeriodStatistics { get; }

Property Value

IEnumerable IPeriodStatistics
The list of separate period statistics
See Also

Reference

ISoccerStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISoccerStatistics.TotalStatistics Property

ISoccerStatisticsTotalStatistics Property

Gets the list of complete team statistics data

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<ITeamStatistics> TotalStatistics { get; }

Property Value

IEnumerable ITeamStatistics
The list of complete team statistics data
See Also

Reference

ISoccerStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISoccerStatus Interface

Defines a contract for classes representing soccer status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISoccerStatus : IMatchStatus,
    ICompetitionStatus

The ISoccerStatus type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event (Inherited from IMatchStatus)
Public property | EventClock | Gets the IEventClock instance describing the timings in the current event (Inherited from IMatchStatus)
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event (Inherited from IMatchStatus)
Public property | PeriodScores | Gets the list of IPeriodScore (Inherited from IMatchStatus)
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Statistics | Gets the soccer match statistics
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status (Inherited from IMatchStatus)
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace
IMatchStatus


ISoccerStatus Properties

The ISoccerStatus type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event (Inherited from IMatchStatus)
Public property | EventClock | Gets the IEventClock instance describing the timings in the current event (Inherited from IMatchStatus)
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event (Inherited from IMatchStatus)
Public property | PeriodScores | Gets the list of IPeriodScore (Inherited from IMatchStatus)
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Statistics | Gets the soccer match statistics
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
See Also

Reference

ISoccerStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISoccerStatus.Statistics Property

ISoccerStatusStatistics Property

Gets the soccer match statistics

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ISoccerStatistics Statistics { get; }

Property Value

ISoccerStatistics
The soccer match statistics
See Also

Reference

ISoccerStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISoccerStatus Methods

The ISoccerStatus type exposes the following members.

Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the match status (Inherited from IMatchStatus)
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
See Also

Reference

ISoccerStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISport Interface

Defines a contract implemented by classes representing a sport

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISport : ISportSummary, IEntityPrinter

The ISport type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Gets a IEnumerableT representing categories which belong to the sport represented by the current instance
Public property | Id | Gets a URN uniquely identifying the sport represented by the current instance (Inherited from ISportSummary)
Public property | Names | Gets the name of the sport represented by the current instance (Inherited from ISportSummary)
Top
Methods
 | Name | Description
Public method | GetName | Gets the name in specified culture language (Inherited from ISportSummary)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISport Properties

The ISport type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Gets a IEnumerableT representing categories which belong to the sport represented by the current instance
Public property | Id | Gets a URN uniquely identifying the sport represented by the current instance (Inherited from ISportSummary)
Public property | Names | Gets the name of the sport represented by the current instance (Inherited from ISportSummary)
Top
See Also

Reference

ISport Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISport.Categories Property

ISportCategories Property

Gets a IEnumerableT representing categories which belong to the sport represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<ICategory> Categories { get; }

Property Value

IEnumerable ICategory
See Also

Reference

ISport Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISport Methods

The ISport type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name in specified culture language (Inherited from ISportSummary)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ISport Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEvent Interface

Defines a contract implemented by classes representing the target(tournament, match, race) of feed messages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportEvent

The ISportEvent type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance
Top
Methods
 | Name | Description
Public method | GetNameAsync | Asynchronously gets the name of the sport event
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEvent Properties

The ISportEvent type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance
Top
See Also

Reference

ISportEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEvent.Id Property

ISportEventId Property

Gets a URN uniquely identifying the sport event associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

ISportEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEvent Methods

The ISportEvent type exposes the following members.

Methods
 | Name | Description
Public method | GetNameAsync | Asynchronously gets the name of the sport event
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance
Top
See Also

Reference

ISportEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEvent.GetNameAsync Method

ISportEventGetNameAsync Method

Asynchronously gets the name of the sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<string> GetNameAsync(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language of the returned name

Return Value

Task String
Return a name of the race, or match
See Also

Reference

ISportEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEvent.GetScheduledEndTimeAsync Method

ISportEventGetScheduledEndTimeAsync Method

Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<DateTime?> GetScheduledEndTimeAsync()

Return Value

Task Nullable DateTime
A TaskTResult representing the retrieval operation
See Also

Reference

ISportEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEvent.GetScheduledTimeAsync Method

ISportEventGetScheduledTimeAsync Method

Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<DateTime?> GetScheduledTimeAsync()

Return Value

Task Nullable DateTime
A TaskTResult representing the retrieval operation
See Also

Reference

ISportEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEvent.GetSportIdAsync Method

ISportEventGetSportIdAsync Method

Asynchronously gets a URN uniquely identifying the sport associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<URN> GetSportIdAsync()

Return Value

Task URN
Returns a URN uniquely identifying the sport associated with the current instance
See Also

Reference

ISportEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventConditions Interface

Defines a contract implemented by classes representing sport event conditions

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportEventConditions : IEntityPrinter

The ISportEventConditions type exposes the following members.

Properties
 | Name | Description
Public property | Attendance | Gets a String specifying the attendance of the associated sport event
Public property | EventMode | TODO: Add comments
Public property | Referee | Gets the IReferee instance representing the referee presiding over the associated sport event
Public property | WeatherInfo | Gets a IWeatherInfo instance representing the expected weather on the associated sport event
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventConditions Properties

The ISportEventConditions type exposes the following members.

Properties
 | Name | Description
Public property | Attendance | Gets a String specifying the attendance of the associated sport event
Public property | EventMode | TODO: Add comments
Public property | Referee | Gets the IReferee instance representing the referee presiding over the associated sport event
Public property | WeatherInfo | Gets a IWeatherInfo instance representing the expected weather on the associated sport event
Top
See Also

Reference

ISportEventConditions Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventConditions.Attendance Property

ISportEventConditionsAttendance Property

Gets a String specifying the attendance of the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Attendance { get; }

Property Value

String
See Also

Reference

ISportEventConditions Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventConditions.EventMode Property

ISportEventConditionsEventMode Property

TODO: Add comments

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string EventMode { get; }

Property Value

String
See Also

Reference

ISportEventConditions Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventConditions.Referee Property

ISportEventConditionsReferee Property

Gets the IReferee instance representing the referee presiding over the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReferee Referee { get; }

Property Value

IReferee
See Also

Reference

ISportEventConditions Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventConditions.WeatherInfo Property

ISportEventConditionsWeatherInfo Property

Gets a IWeatherInfo instance representing the expected weather on the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IWeatherInfo WeatherInfo { get; }

Property Value

IWeatherInfo
See Also

Reference

ISportEventConditions Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventConditions Methods

The ISportEventConditions type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ISportEventConditions Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventConditionsV1 Interface

Defines a contract implemented by classes representing sport event conditions

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportEventConditionsV1 : ISportEventConditions,
    IEntityPrinter

The ISportEventConditionsV1 type exposes the following members.

Properties
 | Name | Description
Public property | Attendance | Gets a String specifying the attendance of the associated sport event (Inherited from ISportEventConditions)
Public property | EventMode | TODO: Add comments (Inherited from ISportEventConditions)
Public property | Pitchers | Gets the pitchers
Public property | Referee | Gets the IReferee instance representing the referee presiding over the associated sport event (Inherited from ISportEventConditions)
Public property | WeatherInfo | Gets a IWeatherInfo instance representing the expected weather on the associated sport event (Inherited from ISportEventConditions)
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventConditionsV1 Properties

The ISportEventConditionsV1 type exposes the following members.

Properties
 | Name | Description
Public property | Attendance | Gets a String specifying the attendance of the associated sport event (Inherited from ISportEventConditions)
Public property | EventMode | TODO: Add comments (Inherited from ISportEventConditions)
Public property | Pitchers | Gets the pitchers
Public property | Referee | Gets the IReferee instance representing the referee presiding over the associated sport event (Inherited from ISportEventConditions)
Public property | WeatherInfo | Gets a IWeatherInfo instance representing the expected weather on the associated sport event (Inherited from ISportEventConditions)
Top
See Also

Reference

ISportEventConditionsV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventConditionsV1.Pitchers Property

ISportEventConditionsV1Pitchers Property

Gets the pitchers

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IPitcher> Pitchers { get; }

Property Value

IEnumerable IPitcher
See Also

Reference

ISportEventConditionsV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventConditionsV1 Methods

The ISportEventConditionsV1 type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ISportEventConditionsV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventStatus Interface

Defines a contract implemented by classes representing the status of a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportEventStatus

The ISportEventStatus type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event
Public property | IsReported | Gets a value indicating whether a data journalist is present od the associated sport event, or a null reference if the information is not available
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event
Top
Methods
 | Name | Description
Public method | GetMatchStatusAsync | Gets the match status for specific locale
Public method | GetPropertyValue | Gets the value of the property specified by it's name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventStatus Properties

The ISportEventStatus type exposes the following members.

Properties
 | Name | Description
Public property | AwayScore | Gets the score of the away competitor competing on the associated sport event
Public property | HomeScore | Gets the score of the home competitor competing on the associated sport event
Public property | IsReported | Gets a value indicating whether a data journalist is present od the associated sport event, or a null reference if the information is not available
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event
Top
See Also

Reference

ISportEventStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventStatus.AwayScore Property

ISportEventStatusAwayScore Property

Gets the score of the away competitor competing on the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal? AwayScore { get; }

Property Value

Nullable Decimal
See Also

Reference

ISportEventStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventStatus.HomeScore Property

ISportEventStatusHomeScore Property

Gets the score of the home competitor competing on the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal? HomeScore { get; }

Property Value

Nullable Decimal
See Also

Reference

ISportEventStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventStatus.IsReported Property

ISportEventStatusIsReported Property

Gets a value indicating whether a data journalist is present od the associated sport event, or a null reference if the information is not available

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? IsReported { get; }

Property Value

Nullable Int32
See Also

Reference

ISportEventStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventStatus.Properties Property

ISportEventStatusProperties Property

Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<string, Object> Properties { get; }

Property Value

IReadOnlyDictionary String, Object
a IReadOnlyDictionaryTKey, TValue containing additional event status values
Remarks

List of possible keys:

  • AggregateAwayScore
  • AggregateHomeScore
  • AggregateWinnerId
  • AwayBatter
  • AwayDismissals
  • AwayGameScore
  • AwayLegScore
  • AwayPenaltyRuns
  • AwayRemainingBowls
  • AwayScore
  • AwaySuspend
  • Balls
  • Bases
  • Clock_MatchTime
  • Clock_RemainingTime
  • Clock_RemainingTimeInPeriod
  • Clock_StoppageTime
  • Clock_StoppageTimeAnnounced
  • Clock_Stopped
  • Clock{ClockNumber}_MatchTime
  • Clock{ClockNumber}_StoppageTime
  • Clock{ClockNumber}_StoppageTimeAnnounced
  • CurrentCtTeam
  • CurrentEnd
  • CurrentServer
  • DecidedByFed
  • Delivery
  • ExpeditedMode
  • HomeBatter
  • HomeDismissals
  • HomeGameScore
  • HomeLegScore
  • HomePenaltyRuns
  • HomeRemainingBowls
  • HomeScore
  • HomeSuspend
  • Innings
  • Outs
  • Over
  • Period
  • PeriodScore{PeriodScoreNumber}_AwayScore
  • PeriodScore{PeriodScoreNumber}_HomeScore
  • PeriodScore{PeriodScoreNumber}_MatchStatusCode
  • PeriodScore{PeriodScoreNumber}_Number
  • Position
  • Possession
  • RemainingReds
  • Reporting
  • Result{ResultNumber}_AwayScore
  • Result{ResultNumber}_Climber
  • Result{ResultNumber}_ClimberRanking
  • Result{ResultNumber}_HomeScore
  • Result{ResultNumber}_Id
  • Result{ResultNumber}_MatchStatusCode
  • Result{ResultNumber}_Points
  • Result{ResultNumber}_Sprint
  • Result{ResultNumber}_SprintRanking
  • Result{ResultNumber}_Status
  • Result{ResultNumber}_StatusComment
  • Result{ResultNumber}_Time
  • Result{ResultNumber}_TimeRanking
  • Status
  • Strikes
  • Throw
  • Tiebreak
  • Try
  • Visit
  • WinnerId
  • WinningReason
  • Yards
See Also

Reference

ISportEventStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventStatus.Status Property

ISportEventStatusStatus Property

Gets a EventStatus describing the high-level status of the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
EventStatus Status { get; }

Property Value

EventStatus
See Also

Reference

ISportEventStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventStatus Methods

The ISportEventStatus type exposes the following members.

Methods
 | Name | Description
Public method | GetMatchStatusAsync | Gets the match status for specific locale
Public method | GetPropertyValue | Gets the value of the property specified by it's name
Top
See Also

Reference

ISportEventStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventStatus.GetMatchStatusAsync Method

ISportEventStatusGetMatchStatusAsync Method

Gets the match status for specific locale

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ILocalizedNamedValue> GetMatchStatusAsync()

Return Value

Task ILocalizedNamedValue
Returns the match status for specific locale
See Also

Reference

ISportEventStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventStatus.GetPropertyValue Method

ISportEventStatusGetPropertyValue Method

Gets the value of the property specified by it's name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Object GetPropertyValue(
    string propertyName
)

Parameters

propertyName String
The name of the property

Return Value

Object
A Object representation of the value of the specified property, or a null reference if the value of the specified property was not specified
See Also

Reference

ISportEventStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventV1 Interface

Defines a contract implemented by classes representing the target(tournament, match, race) of feed messages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportEventV1 : ISportEvent

The ISportEventV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetReplacedByAsync | Asynchronously gets a URN specifying the replacement sport event for the associated sport event.
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStartTimeTbdAsync | Asynchronously gets a NullableT specifying if the start time to be determined is set for the associated sport event.
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventV1 Properties

The ISportEventV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ISportEventV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventV1 Methods

The ISportEventV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetReplacedByAsync | Asynchronously gets a URN specifying the replacement sport event for the associated sport event.
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStartTimeTbdAsync | Asynchronously gets a NullableT specifying if the start time to be determined is set for the associated sport event.
Top
See Also

Reference

ISportEventV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventV1.GetReplacedByAsync Method

ISportEventV1GetReplacedByAsync Method

Asynchronously gets a URN specifying the replacement sport event for the associated sport event.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<URN> GetReplacedByAsync()

Return Value

Task URN
A URN specifying the replacement sport event for the associated sport event.
See Also

Reference

ISportEventV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportEventV1.GetStartTimeTbdAsync Method

ISportEventV1GetStartTimeTbdAsync Method

Asynchronously gets a NullableT specifying if the start time to be determined is set for the associated sport event.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<bool?> GetStartTimeTbdAsync()

Return Value

Task Nullable Boolean
A NullableT specifying if the start time to be determined is set for the associated sport event.
See Also

Reference

ISportEventV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportSummary Interface

Defines a contract implemented by classes representing a sport

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISportSummary : IEntityPrinter

The ISportSummary type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport represented by the current instance
Public property | Names | Gets the name of the sport represented by the current instance
Top
Methods
 | Name | Description
Public method | GetName | Gets the name in specified culture language
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportSummary Properties

The ISportSummary type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport represented by the current instance
Public property | Names | Gets the name of the sport represented by the current instance
Top
See Also

Reference

ISportSummary Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportSummary.Id Property

ISportSummaryId Property

Gets a URN uniquely identifying the sport represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

ISportSummary Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportSummary.Names Property

ISportSummaryNames Property

Gets the name of the sport represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Names { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

ISportSummary Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportSummary Methods

The ISportSummary type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name in specified culture language
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ISportSummary Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ISportSummary.GetName Method

ISportSummaryGetName Method

Gets the name in specified culture language

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture.

Return Value

String
System.String.
See Also

Reference

ISportSummary Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStage Interface

Defines methods implemented by classes representing sport events of stage type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IStage : ICompetition, ISportEvent

The IStage type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCategoryAsync | Asynchronously get the ICategorySummary instance associated with the current IStage instance
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetParentStageAsync | Asynchronously get the parent stage
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance associated with the current IStage instance
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStagesAsync | Asynchronously get the list of stages representing stages of the multi-stage stage
Public method | GetStageTypeAsync | Obsolete. Asynchronously get the type of the stage
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance (Inherited from ICompetition)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStage Properties

The IStage type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IStage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStage Methods

The IStage type exposes the following members.

Methods
 | Name | Description
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCategoryAsync | Asynchronously get the ICategorySummary instance associated with the current IStage instance
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetParentStageAsync | Asynchronously get the parent stage
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance associated with the current IStage instance
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStagesAsync | Asynchronously get the list of stages representing stages of the multi-stage stage
Public method | GetStageTypeAsync | Obsolete. Asynchronously get the type of the stage
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance (Inherited from ICompetition)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

IStage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStage.GetCategoryAsync Method

IStageGetCategoryAsync Method

Asynchronously get the ICategorySummary instance associated with the current IStage instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICategorySummary> GetCategoryAsync()

Return Value

Task ICategorySummary
The ICategorySummary instance associated with the current IStage instance
See Also

Reference

IStage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStage.GetParentStageAsync Method

IStageGetParentStageAsync Method

Asynchronously get the parent stage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IStage> GetParentStageAsync()

Return Value

Task IStage
The parent stage
See Also

Reference

IStage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStage.GetSportAsync Method

IStageGetSportAsync Method

Asynchronously get the ISportSummary instance associated with the current IStage instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ISportSummary> GetSportAsync()

Return Value

Task ISportSummary
The ISportSummary instance associated with the current IStage instance
See Also

Reference

IStage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStage.GetStagesAsync Method

IStageGetStagesAsync Method

Asynchronously get the list of stages representing stages of the multi-stage stage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IStage>> GetStagesAsync()

Return Value

Task IEnumerable IStage
The list of stages representing stages of the multi-stage stage
See Also

Reference

IStage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStage.GetStageTypeAsync Method

IStageGetStageTypeAsync Method

Note: This API is now obsolete.

Asynchronously get the type of the stage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use Task<StageType?> GetStageTypeAsync() available on IStageV2")]
Task<StageType> GetStageTypeAsync()

Return Value

Task StageType
The type of the stage
See Also

Reference

IStage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageStatus Interface

Defines a contract implemented by classes representing a stage status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IStageStatus : ICompetitionStatus

The IStageStatus type exposes the following members.

Properties
 | Name | Description
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the stage match status
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace
ICompetitionStatus


IStageStatus Properties

The IStageStatus type exposes the following members.

Properties
 | Name | Description
Public property | EventResults | Gets the event results (Inherited from ICompetitionStatus)
Public property | Properties | Gets a IReadOnlyDictionaryTKey, TValue containing additional event status values (Inherited from ICompetitionStatus)
Public property | ReportingStatus | Returns a ReportingStatus describing the reporting status of the associated sport event (Inherited from ICompetitionStatus)
Public property | Status | Gets a EventStatus describing the high-level status of the associated sport event (Inherited from ICompetitionStatus)
Public property | WinnerId | Gets the winner identifier (Inherited from ICompetitionStatus)
Top
See Also

Reference

IStageStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageStatus Methods

The IStageStatus type exposes the following members.

Methods
 | Name | Description
Public method | GetMatchStatusAsync | Asynchronously gets the stage match status
Public method | GetPropertyValue | Gets the value of the property specified by it's name (Inherited from ICompetitionStatus)
Top
See Also

Reference

IStageStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageStatus.GetMatchStatusAsync Method

IStageStatusGetMatchStatusAsync Method

Asynchronously gets the stage match status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ILocalizedNamedValue> GetMatchStatusAsync(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture used to get stage match status id and description

Return Value

Task ILocalizedNamedValue
Returns the stage match status id and description in selected culture
See Also

Reference

IStageStatus Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageV1 Interface

Defines methods implemented by classes representing sport events of stage type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IStageV1 : IStage,
    ICompetition, ISportEvent, ICompetitionV1

The IStageV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCategoryAsync | Asynchronously get the ICategorySummary instance associated with the current IStage instance (Inherited from IStage)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetParentStageAsync | Asynchronously get the parent stage (Inherited from IStage)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance associated with the current IStage instance (Inherited from IStage)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStagesAsync | Asynchronously get the list of stages representing stages of the multi-stage stage (Inherited from IStage)
Public method | GetStageTypeAsync | Obsolete. Asynchronously get the type of the stage (Inherited from IStage)
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance (Inherited from ICompetition)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageV1 Properties

The IStageV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IStageV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageV1 Methods

The IStageV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCategoryAsync | Asynchronously get the ICategorySummary instance associated with the current IStage instance (Inherited from IStage)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetParentStageAsync | Asynchronously get the parent stage (Inherited from IStage)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance associated with the current IStage instance (Inherited from IStage)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStagesAsync | Asynchronously get the list of stages representing stages of the multi-stage stage (Inherited from IStage)
Public method | GetStageTypeAsync | Obsolete. Asynchronously get the type of the stage (Inherited from IStage)
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance (Inherited from ICompetition)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

IStageV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageV2 Interface

Defines methods implemented by classes representing sport events of stage type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IStageV2 : IStageV1,
    IStage, ICompetition, ISportEvent, ICompetitionV1, ICompetitionV2,
    ISportEventV1

The IStageV2 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetAdditionalParentStagesAsync | Asynchronously gets a list of additional ids of the parent stages of the current instance or a null reference if the represented stage does not have the parent stages
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCategoryAsync | Asynchronously get the ICategorySummary instance associated with the current IStage instance (Inherited from IStage)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetLiveOddsAsync | Asynchronously gets a liveOdds (Inherited from ICompetitionV2)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetParentStageAsync | Asynchronously get the parent stage (Inherited from IStage)
Public method | GetReplacedByAsync | Asynchronously gets a URN specifying the replacement sport event for the associated sport event. (Inherited from ISportEventV1)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance associated with the current IStage instance (Inherited from IStage)
Public method | GetSportEventTypeAsync | Asynchronously get the type of the stage (Inherited from ICompetitionV2)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStagesAsync | Asynchronously get the list of stages representing stages of the multi-stage stage (Inherited from IStage)
Public method | GetStageTypeAsync | Asynchronously get the type of the stage
Public method | GetStartTimeTbdAsync | Asynchronously gets a NullableT specifying if the start time to be determined is set for the associated sport event. (Inherited from ISportEventV1)
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance (Inherited from ICompetition)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageV2 Properties

The IStageV2 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IStageV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageV2 Methods

The IStageV2 type exposes the following members.

Methods
 | Name | Description
Public method | GetAdditionalParentStagesAsync | Asynchronously gets a list of additional ids of the parent stages of the current instance or a null reference if the represented stage does not have the parent stages
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCategoryAsync | Asynchronously get the ICategorySummary instance associated with the current IStage instance (Inherited from IStage)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetLiveOddsAsync | Asynchronously gets a liveOdds (Inherited from ICompetitionV2)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetParentStageAsync | Asynchronously get the parent stage (Inherited from IStage)
Public method | GetReplacedByAsync | Asynchronously gets a URN specifying the replacement sport event for the associated sport event. (Inherited from ISportEventV1)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance associated with the current IStage instance (Inherited from IStage)
Public method | GetSportEventTypeAsync | Asynchronously get the type of the stage (Inherited from ICompetitionV2)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStagesAsync | Asynchronously get the list of stages representing stages of the multi-stage stage (Inherited from IStage)
Public method | GetStageTypeAsync | Asynchronously get the type of the stage
Public method | GetStartTimeTbdAsync | Asynchronously gets a NullableT specifying if the start time to be determined is set for the associated sport event. (Inherited from ISportEventV1)
Public method | GetStatusAsync | Gets a ICompetitionStatus instance containing information about the progress of a sport event associated with the current instance (Inherited from ICompetition)
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

IStageV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageV2.GetAdditionalParentStagesAsync Method

IStageV2GetAdditionalParentStagesAsync Method

Asynchronously gets a list of additional ids of the parent stages of the current instance or a null reference if the represented stage does not have the parent stages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<IStage>> GetAdditionalParentStagesAsync()

Return Value

Task IEnumerable IStage
A TaskTResult representing the asynchronous operation
See Also

Reference

IStageV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageV2.GetStageTypeAsync Method

IStageV2GetStageTypeAsync Method

Asynchronously get the type of the stage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<StageType?> GetStageTypeAsync()

Return Value

Task Nullable StageType
The type of the stage
See Also

Reference

IStageV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageV3 Interface

Defines methods implemented by classes representing sport events of stage type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IStageV3 : IStageV2,
    IStageV1, IStage, ICompetition, ISportEvent, ICompetitionV1,
    ICompetitionV2, ISportEventV1

The IStageV3 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetAdditionalParentStagesAsync | Asynchronously gets a list of additional ids of the parent stages of the current instance or a null reference if the represented stage does not have the parent stages (Inherited from IStageV2)
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCategoryAsync | Asynchronously get the ICategorySummary instance associated with the current IStage instance (Inherited from IStage)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetLiveOddsAsync | Asynchronously gets a liveOdds (Inherited from ICompetitionV2)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetParentStageAsync | Asynchronously get the parent stage (Inherited from IStage)
Public method | GetReplacedByAsync | Asynchronously gets a URN specifying the replacement sport event for the associated sport event. (Inherited from ISportEventV1)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance associated with the current IStage instance (Inherited from IStage)
Public method | GetSportEventTypeAsync | Asynchronously get the type of the stage (Inherited from ICompetitionV2)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStagesAsync | Asynchronously get the list of stages representing stages of the multi-stage stage (Inherited from IStage)
Public method | GetStageTypeAsync | Asynchronously get the type of the stage (Inherited from IStageV2)
Public method | GetStartTimeTbdAsync | Asynchronously gets a NullableT specifying if the start time to be determined is set for the associated sport event. (Inherited from ISportEventV1)
Public method | GetStatusAsync | Asynchronously gets a IStageStatus containing information about the progress of the stage
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageV3 Properties

The IStageV3 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

IStageV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageV3 Methods

The IStageV3 type exposes the following members.

Methods
 | Name | Description
Public method | GetAdditionalParentStagesAsync | Asynchronously gets a list of additional ids of the parent stages of the current instance or a null reference if the represented stage does not have the parent stages (Inherited from IStageV2)
Public method | GetBookingStatusAsync | Asynchronously gets a BookingStatus enum member providing booking status for the associated entity or a null reference if booking status is not known (Inherited from ICompetition)
Public method | GetCategoryAsync | Asynchronously get the ICategorySummary instance associated with the current IStage instance (Inherited from IStage)
Public method | GetCompetitorsAsync | Asynchronously gets a IEnumerableT representing competitors in the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetConditionsAsync | Asynchronously gets a ISportEventConditions instance representing live conditions of the sport event associated with the current instance (Inherited from ICompetition)
Public method | GetEventStatusAsync | Gets the event status asynchronous (Inherited from ICompetitionV1)
Public method | GetLiveOddsAsync | Asynchronously gets a liveOdds (Inherited from ICompetitionV2)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetParentStageAsync | Asynchronously get the parent stage (Inherited from IStage)
Public method | GetReplacedByAsync | Asynchronously gets a URN specifying the replacement sport event for the associated sport event. (Inherited from ISportEventV1)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance associated with the current IStage instance (Inherited from IStage)
Public method | GetSportEventTypeAsync | Asynchronously get the type of the stage (Inherited from ICompetitionV2)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetStagesAsync | Asynchronously get the list of stages representing stages of the multi-stage stage (Inherited from IStage)
Public method | GetStageTypeAsync | Asynchronously get the type of the stage (Inherited from IStageV2)
Public method | GetStartTimeTbdAsync | Asynchronously gets a NullableT specifying if the start time to be determined is set for the associated sport event. (Inherited from ISportEventV1)
Public method | GetStatusAsync | Asynchronously gets a IStageStatus containing information about the progress of the stage
Public method | GetVenueAsync | Asynchronously gets a IVenue instance representing a venue where the sport event associated with the current instance will take place (Inherited from ICompetition)
Top
See Also

Reference

IStageV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStageV3.GetStatusAsync Method

IStageV3GetStatusAsync Method

Asynchronously gets a IStageStatus containing information about the progress of the stage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IStageStatus> GetStatusAsync()

Return Value

Task IStageStatus
A TaskTResult containing information about the progress of the stage
See Also

Reference

IStageV3 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStreamingChannel Interface

Defines a contract implemented by classes representing streaming channels

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IStreamingChannel : IEntityPrinter

The IStreamingChannel type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a value uniquely identifying the current streaming channel
Public property | Name | Gets the name of the streaming channel represented by the current instance
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStreamingChannel Properties

The IStreamingChannel type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a value uniquely identifying the current streaming channel
Public property | Name | Gets the name of the streaming channel represented by the current instance
Top
See Also

Reference

IStreamingChannel Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStreamingChannel.Id Property

IStreamingChannelId Property

Gets a value uniquely identifying the current streaming channel

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Id { get; }

Property Value

Int32
See Also

Reference

IStreamingChannel Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStreamingChannel.Name Property

IStreamingChannelName Property

Gets the name of the streaming channel represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

String
See Also

Reference

IStreamingChannel Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IStreamingChannel Methods

The IStreamingChannel type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IStreamingChannel Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamCompetitor Interface

Defines a contract implemented by classes representing a competing team

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITeamCompetitor : ICompetitor,
    IPlayer, IEntityPrinter

The ITeamCompetitor type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | Qualifier | Gets a qualifier additionally describing the competitor (e.g. home, away, ...)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamCompetitor Properties

The ITeamCompetitor type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | Qualifier | Gets a qualifier additionally describing the competitor (e.g. home, away, ...)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
See Also

Reference

ITeamCompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamCompetitor.Qualifier Property

ITeamCompetitorQualifier Property

Gets a qualifier additionally describing the competitor (e.g. home, away, ...)

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Qualifier { get; }

Property Value

String
See Also

Reference

ITeamCompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamCompetitor Methods

The ITeamCompetitor type exposes the following members.

Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ITeamCompetitor Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamCompetitorV1 Interface

Defines a contract implemented by classes representing a competing team

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITeamCompetitorV1 : ITeamCompetitor,
    ICompetitor, IPlayer, IEntityPrinter

The ITeamCompetitorV1 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Division | Gets the division
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | Qualifier | Gets a qualifier additionally describing the competitor (e.g. home, away, ...) (Inherited from ITeamCompetitor)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamCompetitorV1 Properties

The ITeamCompetitorV1 type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's abbreviations in different languages (Inherited from ICompetitor)
Public property | AssociatedPlayers | Gets the list of associated player ids (Inherited from ICompetitor)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing competitor's country names in different languages (Inherited from ICompetitor)
Public property | CountryCode | Gets the country code (Inherited from ICompetitor)
Public property | Division | Gets the division
Public property | Id | Gets the URN uniquely identifying the current ICompetitor instance (Inherited from IPlayer)
Public property | IsVirtual | Gets a value indicating whether the current instance represents a placeholder team (Inherited from ICompetitor)
Public property | Jerseys | Gets the jerseys of known competitors (Inherited from ICompetitor)
Public property | Manager | Gets the manager (Inherited from ICompetitor)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing player names in different languages (Inherited from IPlayer)
Public property | Qualifier | Gets a qualifier additionally describing the competitor (e.g. home, away, ...) (Inherited from ITeamCompetitor)
Public property | References | Gets the reference ids (Inherited from ICompetitor)
Public property | Venue | Gets the venue (Inherited from ICompetitor)
Top
See Also

Reference

ITeamCompetitorV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamCompetitorV1.Division Property

ITeamCompetitorV1Division Property

Gets the division

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Division { get; }

Property Value

Nullable Int32
See Also

Reference

ITeamCompetitorV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamCompetitorV1 Methods

The ITeamCompetitorV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetAbbreviation | Gets the competitor's abbreviation in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetCountry | Gets the competitor's country name in the specified language or a null reference. (Inherited from ICompetitor)
Public method | GetName | Gets the name of the player in the specified language or a null reference (Inherited from IPlayer)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ITeamCompetitorV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatistics Interface

Defines a contract for classes implementing team statistics

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITeamStatistics

The ITeamStatistics type exposes the following members.

Properties
 | Name | Description
Public property | Cards | Gets the total count of received cards
Public property | CornerKicks | Gets the total count of corner kicks
Public property | HomeAway | Gets an indication if the statistics are for the home or away team
Public property | RedCards | Gets the total count of red cards
Public property | YellowCards | Gets the total count of yellow cards
Public property | YellowRedCards | Gets the total count of yellow-red cards
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatistics Properties

The ITeamStatistics type exposes the following members.

Properties
 | Name | Description
Public property | Cards | Gets the total count of received cards
Public property | CornerKicks | Gets the total count of corner kicks
Public property | HomeAway | Gets an indication if the statistics are for the home or away team
Public property | RedCards | Gets the total count of red cards
Public property | YellowCards | Gets the total count of yellow cards
Public property | YellowRedCards | Gets the total count of yellow-red cards
Top
See Also

Reference

ITeamStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatistics.Cards Property

ITeamStatisticsCards Property

Gets the total count of received cards

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Cards { get; }

Property Value

Nullable Int32
The total count of received cards
See Also

Reference

ITeamStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatistics.CornerKicks Property

ITeamStatisticsCornerKicks Property

Gets the total count of corner kicks

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? CornerKicks { get; }

Property Value

Nullable Int32
The total count of corner kicks
See Also

Reference

ITeamStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatistics.HomeAway Property

ITeamStatisticsHomeAway Property

Gets an indication if the statistics are for the home or away team

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
HomeAway? HomeAway { get; }

Property Value

Nullable HomeAway
An indication if the statistics are for the home or away team
See Also

Reference

ITeamStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatistics.RedCards Property

ITeamStatisticsRedCards Property

Gets the total count of red cards

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? RedCards { get; }

Property Value

Nullable Int32
The total count of red cards
See Also

Reference

ITeamStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatistics.YellowCards Property

ITeamStatisticsYellowCards Property

Gets the total count of yellow cards

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? YellowCards { get; }

Property Value

Nullable Int32
The total count of yellow cards
See Also

Reference

ITeamStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatistics.YellowRedCards Property

ITeamStatisticsYellowRedCards Property

Gets the total count of yellow-red cards

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? YellowRedCards { get; }

Property Value

Nullable Int32
The total count of yellow-red cards
See Also

Reference

ITeamStatistics Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatisticsV1 Interface

Defines a contract for classes implementing team statistics

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITeamStatisticsV1 : ITeamStatistics

The ITeamStatisticsV1 type exposes the following members.

Properties
 | Name | Description
Public property | Cards | Gets the total count of received cards (Inherited from ITeamStatistics)
Public property | CornerKicks | Gets the total count of corner kicks (Inherited from ITeamStatistics)
Public property | HomeAway | Gets an indication if the statistics are for the home or away team (Inherited from ITeamStatistics)
Public property | Name | Gets the name
Public property | RedCards | Gets the total count of red cards (Inherited from ITeamStatistics)
Public property | TeamId | Gets the team id
Public property | YellowCards | Gets the total count of yellow cards (Inherited from ITeamStatistics)
Public property | YellowRedCards | Gets the total count of yellow-red cards (Inherited from ITeamStatistics)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatisticsV1 Properties

The ITeamStatisticsV1 type exposes the following members.

Properties
 | Name | Description
Public property | Cards | Gets the total count of received cards (Inherited from ITeamStatistics)
Public property | CornerKicks | Gets the total count of corner kicks (Inherited from ITeamStatistics)
Public property | HomeAway | Gets an indication if the statistics are for the home or away team (Inherited from ITeamStatistics)
Public property | Name | Gets the name
Public property | RedCards | Gets the total count of red cards (Inherited from ITeamStatistics)
Public property | TeamId | Gets the team id
Public property | YellowCards | Gets the total count of yellow cards (Inherited from ITeamStatistics)
Public property | YellowRedCards | Gets the total count of yellow-red cards (Inherited from ITeamStatistics)
Top
See Also

Reference

ITeamStatisticsV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatisticsV1.Name Property

ITeamStatisticsV1Name Property

Gets the name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

String
The name
See Also

Reference

ITeamStatisticsV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatisticsV1.TeamId Property

ITeamStatisticsV1TeamId Property

Gets the team id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN TeamId { get; }

Property Value

URN
The team id
See Also

Reference

ITeamStatisticsV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatisticsV2 Interface

Defines a contract for classes implementing team statistics

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITeamStatisticsV2 : ITeamStatisticsV1,
    ITeamStatistics

The ITeamStatisticsV2 type exposes the following members.

Properties
 | Name | Description
Public property | Cards | Gets the total count of received cards (Inherited from ITeamStatistics)
Public property | CornerKicks | Gets the total count of corner kicks (Inherited from ITeamStatistics)
Public property | GreenCards | Gets the total count of green cards
Public property | HomeAway | Gets an indication if the statistics are for the home or away team (Inherited from ITeamStatistics)
Public property | Name | Gets the name (Inherited from ITeamStatisticsV1)
Public property | RedCards | Gets the total count of red cards (Inherited from ITeamStatistics)
Public property | TeamId | Gets the team id (Inherited from ITeamStatisticsV1)
Public property | YellowCards | Gets the total count of yellow cards (Inherited from ITeamStatistics)
Public property | YellowRedCards | Gets the total count of yellow-red cards (Inherited from ITeamStatistics)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatisticsV2 Properties

The ITeamStatisticsV2 type exposes the following members.

Properties
 | Name | Description
Public property | Cards | Gets the total count of received cards (Inherited from ITeamStatistics)
Public property | CornerKicks | Gets the total count of corner kicks (Inherited from ITeamStatistics)
Public property | GreenCards | Gets the total count of green cards
Public property | HomeAway | Gets an indication if the statistics are for the home or away team (Inherited from ITeamStatistics)
Public property | Name | Gets the name (Inherited from ITeamStatisticsV1)
Public property | RedCards | Gets the total count of red cards (Inherited from ITeamStatistics)
Public property | TeamId | Gets the team id (Inherited from ITeamStatisticsV1)
Public property | YellowCards | Gets the total count of yellow cards (Inherited from ITeamStatistics)
Public property | YellowRedCards | Gets the total count of yellow-red cards (Inherited from ITeamStatistics)
Top
See Also

Reference

ITeamStatisticsV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITeamStatisticsV2.GreenCards Property

ITeamStatisticsV2GreenCards Property

Gets the total count of green cards

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? GreenCards { get; }

Property Value

Nullable Int32
The total count of green cards
See Also

Reference

ITeamStatisticsV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent Interface

Defines a contract for classes implementing timeline event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITimelineEvent

The ITimelineEvent type exposes the following members.

Properties
 | Name | Description
Public property | Assists | Gets the list of assists
Public property | AwayScore | Gets the away score
Public property | GoalScorer | Gets the goal scorer
Public property | HomeScore | Gets the home score
Public property | Id | Gets the timeline event identifier
Public property | MatchTime | Gets the match time
Public property | Period | Gets the period
Public property | PeriodName | Gets the name of the period
Public property | Player | Gets the player
Public property | Points | Gets the points
Public property | StoppageTime | Gets the stoppage time
Public property | Team | Gets the team
Public property | Time | Gets the time
Public property | Type | Gets the type
Public property | Value | Gets the value
Public property | X | Gets the x
Public property | Y | Gets the y
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent Properties

The ITimelineEvent type exposes the following members.

Properties
 | Name | Description
Public property | Assists | Gets the list of assists
Public property | AwayScore | Gets the away score
Public property | GoalScorer | Gets the goal scorer
Public property | HomeScore | Gets the home score
Public property | Id | Gets the timeline event identifier
Public property | MatchTime | Gets the match time
Public property | Period | Gets the period
Public property | PeriodName | Gets the name of the period
Public property | Player | Gets the player
Public property | Points | Gets the points
Public property | StoppageTime | Gets the stoppage time
Public property | Team | Gets the team
Public property | Time | Gets the time
Public property | Type | Gets the type
Public property | Value | Gets the value
Public property | X | Gets the x
Public property | Y | Gets the y
Top
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.Assists Property

ITimelineEventAssists Property

Gets the list of assists

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IAssist> Assists { get; }

Property Value

IEnumerable IAssist
The assists
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.AwayScore Property

ITimelineEventAwayScore Property

Gets the away score

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal? AwayScore { get; }

Property Value

Nullable Decimal
The away score
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.GoalScorer Property

ITimelineEventGoalScorer Property

Gets the goal scorer

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IGoalScorer GoalScorer { get; }

Property Value

IGoalScorer
The goal scorer
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.HomeScore Property

ITimelineEventHomeScore Property

Gets the home score

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
decimal? HomeScore { get; }

Property Value

Nullable Decimal
The home score
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.Id Property

ITimelineEventId Property

Gets the timeline event identifier

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Id { get; }

Property Value

Int32
The id of timeline event
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.MatchTime Property

ITimelineEventMatchTime Property

Gets the match time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? MatchTime { get; }

Property Value

Nullable Int32
The match time
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.Period Property

ITimelineEventPeriod Property

Gets the period

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Period { get; }

Property Value

String
The period
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.PeriodName Property

ITimelineEventPeriodName Property

Gets the name of the period

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string PeriodName { get; }

Property Value

String
The name of the period
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.Player Property

ITimelineEventPlayer Property

Gets the player

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IPlayer Player { get; }

Property Value

IPlayer
The player
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.Points Property

ITimelineEventPoints Property

Gets the points

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Points { get; }

Property Value

String
The points
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.StoppageTime Property

ITimelineEventStoppageTime Property

Gets the stoppage time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string StoppageTime { get; }

Property Value

String
The stoppage time
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.Team Property

ITimelineEventTeam Property

Gets the team

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
HomeAway? Team { get; }

Property Value

Nullable HomeAway
The team
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.Time Property

ITimelineEventTime Property

Gets the time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime Time { get; }

Property Value

DateTime
The time
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.Type Property

ITimelineEventType Property

Gets the type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Type { get; }

Property Value

String
The type
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.Value Property

ITimelineEventValue Property

Gets the value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Value { get; }

Property Value

String
The value
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.X Property

ITimelineEventX Property

Gets the x

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int X { get; }

Property Value

Int32
The x
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEvent.Y Property

ITimelineEventY Property

Gets the y

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Y { get; }

Property Value

Int32
The y
See Also

Reference

ITimelineEvent Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEventV1 Interface

Defines a contract for classes implementing timeline event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITimelineEventV1 : ITimelineEvent

The ITimelineEventV1 type exposes the following members.

Properties
 | Name | Description
Public property | Assists | Gets the list of assists (Inherited from ITimelineEvent)
Public property | AwayScore | Gets the away score (Inherited from ITimelineEvent)
Public property | GoalScorer | Gets the goal scorer (Inherited from ITimelineEvent)
Public property | HomeScore | Gets the home score (Inherited from ITimelineEvent)
Public property | Id | Gets the timeline event identifier (Inherited from ITimelineEvent)
Public property | MatchClock | Gets the match clock
Public property | MatchStatusCode | Gets the match status code
Public property | MatchTime | Gets the match time (Inherited from ITimelineEvent)
Public property | Period | Gets the period (Inherited from ITimelineEvent)
Public property | PeriodName | Gets the name of the period (Inherited from ITimelineEvent)
Public property | Player | Gets the player (Inherited from ITimelineEvent)
Public property | Points | Gets the points (Inherited from ITimelineEvent)
Public property | StoppageTime | Gets the stoppage time (Inherited from ITimelineEvent)
Public property | Team | Gets the team (Inherited from ITimelineEvent)
Public property | Time | Gets the time (Inherited from ITimelineEvent)
Public property | Type | Gets the type (Inherited from ITimelineEvent)
Public property | Value | Gets the value (Inherited from ITimelineEvent)
Public property | X | Gets the x
Public property | Y | Gets the y
Top
Remarks
Interface will be merged into base ITimelineEvent in next major version scheduled for January 2019
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEventV1 Properties

The ITimelineEventV1 type exposes the following members.

Properties
 | Name | Description
Public property | Assists | Gets the list of assists (Inherited from ITimelineEvent)
Public property | AwayScore | Gets the away score (Inherited from ITimelineEvent)
Public property | GoalScorer | Gets the goal scorer (Inherited from ITimelineEvent)
Public property | HomeScore | Gets the home score (Inherited from ITimelineEvent)
Public property | Id | Gets the timeline event identifier (Inherited from ITimelineEvent)
Public property | MatchClock | Gets the match clock
Public property | MatchStatusCode | Gets the match status code
Public property | MatchTime | Gets the match time (Inherited from ITimelineEvent)
Public property | Period | Gets the period (Inherited from ITimelineEvent)
Public property | PeriodName | Gets the name of the period (Inherited from ITimelineEvent)
Public property | Player | Gets the player (Inherited from ITimelineEvent)
Public property | Points | Gets the points (Inherited from ITimelineEvent)
Public property | StoppageTime | Gets the stoppage time (Inherited from ITimelineEvent)
Public property | Team | Gets the team (Inherited from ITimelineEvent)
Public property | Time | Gets the time (Inherited from ITimelineEvent)
Public property | Type | Gets the type (Inherited from ITimelineEvent)
Public property | Value | Gets the value (Inherited from ITimelineEvent)
Public property | X | Gets the x
Public property | Y | Gets the y
Top
See Also

Reference

ITimelineEventV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEventV1.MatchClock Property

ITimelineEventV1MatchClock Property

Gets the match clock

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string MatchClock { get; }

Property Value

String
The match clock
See Also

Reference

ITimelineEventV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEventV1.MatchStatusCode Property

ITimelineEventV1MatchStatusCode Property

Gets the match status code

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? MatchStatusCode { get; }

Property Value

Nullable Int32
The match status code
See Also

Reference

ITimelineEventV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEventV1.X Property

ITimelineEventV1X Property

Gets the x

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? X { get; }

Property Value

Nullable Int32
The x
See Also

Reference

ITimelineEventV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEventV1.Y Property

ITimelineEventV1Y Property

Gets the y

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Y { get; }

Property Value

Nullable Int32
The y
See Also

Reference

ITimelineEventV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEventV2 Interface

Defines a contract for classes implementing timeline event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITimelineEventV2 : ITimelineEventV1,
    ITimelineEvent

The ITimelineEventV2 type exposes the following members.

Properties
 | Name | Description
Public property | Assists | Gets the list of assists (Inherited from ITimelineEvent)
Public property | AwayScore | Gets the away score (Inherited from ITimelineEvent)
Public property | GoalScorer | Gets the goal scorer (Inherited from ITimelineEvent)
Public property | HomeScore | Gets the home score (Inherited from ITimelineEvent)
Public property | Id | Gets the timeline event identifier (Inherited from ITimelineEvent)
Public property | MatchClock | Gets the match clock (Inherited from ITimelineEventV1)
Public property | MatchStatusCode | Gets the match status code (Inherited from ITimelineEventV1)
Public property | MatchTime | Gets the match time (Inherited from ITimelineEvent)
Public property | Period | Gets the period (Inherited from ITimelineEvent)
Public property | PeriodName | Gets the name of the period (Inherited from ITimelineEvent)
Public property | Player | Gets the player
Public property | Points | Gets the points (Inherited from ITimelineEvent)
Public property | StoppageTime | Gets the stoppage time (Inherited from ITimelineEvent)
Public property | Team | Gets the team (Inherited from ITimelineEvent)
Public property | Time | Gets the time (Inherited from ITimelineEvent)
Public property | Type | Gets the type (Inherited from ITimelineEvent)
Public property | Value | Gets the value (Inherited from ITimelineEvent)
Public property | X | Gets the x (Inherited from ITimelineEventV1)
Public property | Y | Gets the y (Inherited from ITimelineEventV1)
Top
Remarks
Interface will be merged into base ITimelineEvent in next major version scheduled for January 2019
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEventV2 Properties

The ITimelineEventV2 type exposes the following members.

Properties
 | Name | Description
Public property | Assists | Gets the list of assists (Inherited from ITimelineEvent)
Public property | AwayScore | Gets the away score (Inherited from ITimelineEvent)
Public property | GoalScorer | Gets the goal scorer (Inherited from ITimelineEvent)
Public property | HomeScore | Gets the home score (Inherited from ITimelineEvent)
Public property | Id | Gets the timeline event identifier (Inherited from ITimelineEvent)
Public property | MatchClock | Gets the match clock (Inherited from ITimelineEventV1)
Public property | MatchStatusCode | Gets the match status code (Inherited from ITimelineEventV1)
Public property | MatchTime | Gets the match time (Inherited from ITimelineEvent)
Public property | Period | Gets the period (Inherited from ITimelineEvent)
Public property | PeriodName | Gets the name of the period (Inherited from ITimelineEvent)
Public property | Player | Gets the player
Public property | Points | Gets the points (Inherited from ITimelineEvent)
Public property | StoppageTime | Gets the stoppage time (Inherited from ITimelineEvent)
Public property | Team | Gets the team (Inherited from ITimelineEvent)
Public property | Time | Gets the time (Inherited from ITimelineEvent)
Public property | Type | Gets the type (Inherited from ITimelineEvent)
Public property | Value | Gets the value (Inherited from ITimelineEvent)
Public property | X | Gets the x (Inherited from ITimelineEventV1)
Public property | Y | Gets the y (Inherited from ITimelineEventV1)
Top
See Also

Reference

ITimelineEventV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITimelineEventV2.Player Property

ITimelineEventV2Player Property

Gets the player

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEventPlayer Player { get; }

Property Value

IEventPlayer
The player
See Also

Reference

ITimelineEventV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournament Interface

Defines a contract implemented by classes providing information about tournament schedule

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITournament : ILongTermEvent,
    ISportEvent

The ITournament type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetCategoryAsync | Asynchronously gets a ICategorySummary representing the category to which the tournament belongs to
Public method | GetCurrentSeasonAsync | Asynchronously gets ICurrentSeasonInfo instance containing detailed information about the current season of the tournament
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonsAsync | Asynchronously gets a list of ISeason associated with this tournament
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournament Properties

The ITournament type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ITournament Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournament Methods

The ITournament type exposes the following members.

Methods
 | Name | Description
Public method | GetCategoryAsync | Asynchronously gets a ICategorySummary representing the category to which the tournament belongs to
Public method | GetCurrentSeasonAsync | Asynchronously gets ICurrentSeasonInfo instance containing detailed information about the current season of the tournament
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonsAsync | Asynchronously gets a list of ISeason associated with this tournament
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

ITournament Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournament.GetCategoryAsync Method

ITournamentGetCategoryAsync Method

Asynchronously gets a ICategorySummary representing the category to which the tournament belongs to

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICategorySummary> GetCategoryAsync()

Return Value

Task ICategorySummary
A TaskTResult representing the asynchronous operation
See Also

Reference

ITournament Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournament.GetCurrentSeasonAsync Method

ITournamentGetCurrentSeasonAsync Method

Asynchronously gets ICurrentSeasonInfo instance containing detailed information about the current season of the tournament

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<ICurrentSeasonInfo> GetCurrentSeasonAsync()

Return Value

Task ICurrentSeasonInfo
A TaskTResult representing the asynchronous operation
See Also

Reference

ITournament Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournament.GetSeasonsAsync Method

ITournamentGetSeasonsAsync Method

Asynchronously gets a list of ISeason associated with this tournament

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ISeason>> GetSeasonsAsync()

Return Value

Task IEnumerable ISeason
A list of ISeason associated with this tournament
See Also

Reference

ITournament Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentCoverage Interface

Defines a contract for classes implementing tournament coverage information

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITournamentCoverage

The ITournamentCoverage type exposes the following members.

Properties
 | Name | Description
Public property | LiveCoverage | Gets a value indicating whether live coverage is available
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentCoverage Properties

The ITournamentCoverage type exposes the following members.

Properties
 | Name | Description
Public property | LiveCoverage | Gets a value indicating whether live coverage is available
Top
See Also

Reference

ITournamentCoverage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentCoverage.LiveCoverage Property

ITournamentCoverageLiveCoverage Property

Gets a value indicating whether live coverage is available

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool LiveCoverage { get; }

Property Value

Boolean
true if [live coverage]; otherwise, false.
See Also

Reference

ITournamentCoverage Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentInfo Interface

Defines a contract for classes representing tournament info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITournamentInfo

The ITournamentInfo type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets the ICategorySummary representing the category associated with the current instance
Public property | CurrentSeason | Gets the ICurrentSeasonInfo which contains data for the season in which the current tournament is happening
Public property | Id | Gets a URN uniquely identifying the current season
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing names of the season in different languages
Top
Methods
 | Name | Description
Public method | GetName | Gets the name for specific culture
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentInfo Properties

The ITournamentInfo type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets the ICategorySummary representing the category associated with the current instance
Public property | CurrentSeason | Gets the ICurrentSeasonInfo which contains data for the season in which the current tournament is happening
Public property | Id | Gets a URN uniquely identifying the current season
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing names of the season in different languages
Top
See Also

Reference

ITournamentInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentInfo.Category Property

ITournamentInfoCategory Property

Gets the ICategorySummary representing the category associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICategorySummary Category { get; }

Property Value

ICategorySummary
The ICategorySummary representing the category associated with the current instance
See Also

Reference

ITournamentInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentInfo.CurrentSeason Property

ITournamentInfoCurrentSeason Property

Gets the ICurrentSeasonInfo which contains data for the season in which the current tournament is happening

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
ICurrentSeasonInfo CurrentSeason { get; }

Property Value

ICurrentSeasonInfo
The ICurrentSeasonInfo which contains data for the season in which the current tournament is happening
See Also

Reference

ITournamentInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentInfo.Id Property

ITournamentInfoId Property

Gets a URN uniquely identifying the current season

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

ITournamentInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentInfo.Names Property

ITournamentInfoNames Property

Gets a IReadOnlyDictionaryTKey, TValue containing names of the season in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Names { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

ITournamentInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentInfo Methods

The ITournamentInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name for specific culture
Top
See Also

Reference

ITournamentInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentInfo.GetName Method

ITournamentInfoGetName Method

Gets the name for specific culture

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture

Return Value

String
the name in specific culture
See Also

Reference

ITournamentInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentV1 Interface

Defines a contract implemented by classes providing information about tournament schedule

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITournamentV1 : ITournament,
    ILongTermEvent, ISportEvent

The ITournamentV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetCategoryAsync | Asynchronously gets a ICategorySummary representing the category to which the tournament belongs to (Inherited from ITournament)
Public method | GetCurrentSeasonAsync | Asynchronously gets ICurrentSeasonInfo instance containing detailed information about the current season of the tournament (Inherited from ITournament)
Public method | GetExhibitionGamesAsync | Asynchronously gets a Boolean specifying if the tournament is exhibition game
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonsAsync | Asynchronously gets a list of ISeason associated with this tournament (Inherited from ITournament)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentV1 Properties

The ITournamentV1 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ITournamentV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentV1 Methods

The ITournamentV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetCategoryAsync | Asynchronously gets a ICategorySummary representing the category to which the tournament belongs to (Inherited from ITournament)
Public method | GetCurrentSeasonAsync | Asynchronously gets ICurrentSeasonInfo instance containing detailed information about the current season of the tournament (Inherited from ITournament)
Public method | GetExhibitionGamesAsync | Asynchronously gets a Boolean specifying if the tournament is exhibition game
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonsAsync | Asynchronously gets a list of ISeason associated with this tournament (Inherited from ITournament)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

ITournamentV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentV1.GetExhibitionGamesAsync Method

ITournamentV1GetExhibitionGamesAsync Method

Asynchronously gets a Boolean specifying if the tournament is exhibition game

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<bool?> GetExhibitionGamesAsync()

Return Value

Task Nullable Boolean
A Boolean specifying if the tournament is exhibition game
See Also

Reference

ITournamentV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentV2 Interface

Defines a contract implemented by classes providing information about tournament schedule

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITournamentV2 : ITournamentV1,
    ITournament, ILongTermEvent, ISportEvent

The ITournamentV2 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
Methods
 | Name | Description
Public method | GetCategoryAsync | Asynchronously gets a ICategorySummary representing the category to which the tournament belongs to (Inherited from ITournament)
Public method | GetCurrentSeasonAsync | Asynchronously gets ICurrentSeasonInfo instance containing detailed information about the current season of the tournament (Inherited from ITournament)
Public method | GetExhibitionGamesAsync | Asynchronously gets a Boolean specifying if the tournament is exhibition game (Inherited from ITournamentV1)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduleAsync | Gets the list of all ICompetition that belongs to the basic tournament schedule
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonsAsync | Asynchronously gets a list of ISeason associated with this tournament (Inherited from ITournament)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentV2 Properties

The ITournamentV2 type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a URN uniquely identifying the sport event associated with the current instance (Inherited from ISportEvent)
Top
See Also

Reference

ITournamentV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentV2 Methods

The ITournamentV2 type exposes the following members.

Methods
 | Name | Description
Public method | GetCategoryAsync | Asynchronously gets a ICategorySummary representing the category to which the tournament belongs to (Inherited from ITournament)
Public method | GetCurrentSeasonAsync | Asynchronously gets ICurrentSeasonInfo instance containing detailed information about the current season of the tournament (Inherited from ITournament)
Public method | GetExhibitionGamesAsync | Asynchronously gets a Boolean specifying if the tournament is exhibition game (Inherited from ITournamentV1)
Public method | GetNameAsync | Asynchronously gets the name of the sport event (Inherited from ISportEvent)
Public method | GetScheduleAsync | Gets the list of all ICompetition that belongs to the basic tournament schedule
Public method | GetScheduledEndTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled to end or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetScheduledTimeAsync | Asynchronously gets a DateTime instance specifying for when the sport event associated with the current instance is scheduled or a null reference if the value is not known (Inherited from ISportEvent)
Public method | GetSeasonsAsync | Asynchronously gets a list of ISeason associated with this tournament (Inherited from ITournament)
Public method | GetSportAsync | Asynchronously get the ISportSummary instance representing the sport associated with the current instance (Inherited from ILongTermEvent)
Public method | GetSportIdAsync | Asynchronously gets a URN uniquely identifying the sport associated with the current instance (Inherited from ISportEvent)
Public method | GetTournamentCoverage | Asynchronously get the ITournamentCoverage instance representing the tournament coverage associated with the current instance (Inherited from ILongTermEvent)
Top
See Also

Reference

ITournamentV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITournamentV2.GetScheduleAsync Method

ITournamentV2GetScheduleAsync Method

Gets the list of all ICompetition that belongs to the basic tournament schedule

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
Task<IEnumerable<ISportEvent>> GetScheduleAsync()

Return Value

Task IEnumerable ISportEvent
The list of all ICompetition that belongs to the basic tournament schedule
See Also

Reference

ITournamentV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITvChannel Interface

Defines a contract implemented by classes representing TV channels

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITvChannel : IEntityPrinter

The ITvChannel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets a name of the channel represented by the current ITvChannel instance
Public property | StartTime | Gets a DateTime specifying when the coverage on the channel represented by the current ITvChannel starts, or a null reference if the time is not known.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITvChannel Properties

The ITvChannel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets a name of the channel represented by the current ITvChannel instance
Public property | StartTime | Gets a DateTime specifying when the coverage on the channel represented by the current ITvChannel starts, or a null reference if the time is not known.
Top
See Also

Reference

ITvChannel Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITvChannel.Name Property

ITvChannelName Property

Gets a name of the channel represented by the current ITvChannel instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

String
See Also

Reference

ITvChannel Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITvChannel.StartTime Property

ITvChannelStartTime Property

Gets a DateTime specifying when the coverage on the channel represented by the current ITvChannel starts, or a null reference if the time is not known.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime? StartTime { get; }

Property Value

Nullable DateTime
See Also

Reference

ITvChannel Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITvChannel Methods

The ITvChannel type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ITvChannel Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITvChannelV1 Interface

Defines a contract implemented by classes representing TV channels

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ITvChannelV1 : ITvChannel,
    IEntityPrinter

The ITvChannelV1 type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets a name of the channel represented by the current ITvChannel instance (Inherited from ITvChannel)
Public property | StartTime | Gets a DateTime specifying when the coverage on the channel represented by the current ITvChannel starts, or a null reference if the time is not known. (Inherited from ITvChannel)
Public property | StreamUrl | Gets the stream url of the channel represented by the current ITvChannelV1 instance
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITvChannelV1 Properties

The ITvChannelV1 type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets a name of the channel represented by the current ITvChannel instance (Inherited from ITvChannel)
Public property | StartTime | Gets a DateTime specifying when the coverage on the channel represented by the current ITvChannel starts, or a null reference if the time is not known. (Inherited from ITvChannel)
Public property | StreamUrl | Gets the stream url of the channel represented by the current ITvChannelV1 instance
Top
See Also

Reference

ITvChannelV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITvChannelV1.StreamUrl Property

ITvChannelV1StreamUrl Property

Gets the stream url of the channel represented by the current ITvChannelV1 instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string StreamUrl { get; }

Property Value

String
See Also

Reference

ITvChannelV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


ITvChannelV1 Methods

The ITvChannelV1 type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

ITvChannelV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue Interface

Defines a contract implemented by classes representing a sport event venue

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IVenue : IEntityPrinter

The IVenue type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets the capacity of the venue associated with current IVenue instance, or a null reference if the capacity is not specified
Public property | Cities | Gets a IReadOnlyDictionaryTKey, TValue containing venue's city names in different languages
Public property | Coordinates | Gets a map coordinates specifying the exact location of the venue represented by current IVenue instance
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing venue's country names in different languages
Public property | CountryCode | Gets a country code of the venue represented by current IVenue instance
Public property | Id | Gets a URN uniquely identifying the current IVenue instance
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing venue's names in different languages
Top
Methods
 | Name | Description
Public method | GetCity | Gets the city name for specific locale
Public method | GetCountry | Gets the country name for specific locale
Public method | GetName | Gets the name for specific locale
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue Properties

The IVenue type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets the capacity of the venue associated with current IVenue instance, or a null reference if the capacity is not specified
Public property | Cities | Gets a IReadOnlyDictionaryTKey, TValue containing venue's city names in different languages
Public property | Coordinates | Gets a map coordinates specifying the exact location of the venue represented by current IVenue instance
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing venue's country names in different languages
Public property | CountryCode | Gets a country code of the venue represented by current IVenue instance
Public property | Id | Gets a URN uniquely identifying the current IVenue instance
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing venue's names in different languages
Top
See Also

Reference

IVenue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue.Capacity Property

IVenueCapacity Property

Gets the capacity of the venue associated with current IVenue instance, or a null reference if the capacity is not specified

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Capacity { get; }

Property Value

Nullable Int32
See Also

Reference

IVenue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue.Cities Property

IVenueCities Property

Gets a IReadOnlyDictionaryTKey, TValue containing venue's city names in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Cities { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

IVenue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue.Coordinates Property

IVenueCoordinates Property

Gets a map coordinates specifying the exact location of the venue represented by current IVenue instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Coordinates { get; }

Property Value

String
See Also

Reference

IVenue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue.Countries Property

IVenueCountries Property

Gets a IReadOnlyDictionaryTKey, TValue containing venue's country names in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Countries { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

IVenue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue.CountryCode Property

IVenueCountryCode Property

Gets a country code of the venue represented by current IVenue instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string CountryCode { get; }

Property Value

String
See Also

Reference

IVenue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue.Id Property

IVenueId Property

Gets a URN uniquely identifying the current IVenue instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Id { get; }

Property Value

URN
See Also

Reference

IVenue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue.Names Property

IVenueNames Property

Gets a IReadOnlyDictionaryTKey, TValue containing venue's names in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<CultureInfo, string> Names { get; }

Property Value

IReadOnlyDictionary CultureInfo, String
See Also

Reference

IVenue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue Methods

The IVenue type exposes the following members.

Methods
 | Name | Description
Public method | GetCity | Gets the city name for specific locale
Public method | GetCountry | Gets the country name for specific locale
Public method | GetName | Gets the name for specific locale
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IVenue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue.GetCity Method

IVenueGetCity Method

Gets the city name for specific locale

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetCity(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture

Return Value

String
Return the city name if exists, or null
See Also

Reference

IVenue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue.GetCountry Method

IVenueGetCountry Method

Gets the country name for specific locale

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetCountry(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture

Return Value

String
Return the country name if exists, or null
See Also

Reference

IVenue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenue.GetName Method

IVenueGetName Method

Gets the name for specific locale

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
The culture

Return Value

String
Return the name if exists, or null
See Also

Reference

IVenue Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenueV1 Interface

Defines a contract implemented by classes representing a sport event venue

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IVenueV1 : IVenue,
    IEntityPrinter

The IVenueV1 type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets the capacity of the venue associated with current IVenue instance, or a null reference if the capacity is not specified (Inherited from IVenue)
Public property | Cities | Gets a IReadOnlyDictionaryTKey, TValue containing venue's city names in different languages (Inherited from IVenue)
Public property | Coordinates | Gets a map coordinates specifying the exact location of the venue represented by current IVenue instance (Inherited from IVenue)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing venue's country names in different languages (Inherited from IVenue)
Public property | CountryCode | Gets a country code of the venue represented by current IVenue instance (Inherited from IVenue)
Public property | Id | Gets a URN uniquely identifying the current IVenue instance (Inherited from IVenue)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing venue's names in different languages (Inherited from IVenue)
Public property | State | Gets a state of the venue represented by current IVenue instance
Top
Methods
 | Name | Description
Public method | GetCity | Gets the city name for specific locale (Inherited from IVenue)
Public method | GetCountry | Gets the country name for specific locale (Inherited from IVenue)
Public method | GetName | Gets the name for specific locale (Inherited from IVenue)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenueV1 Properties

The IVenueV1 type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets the capacity of the venue associated with current IVenue instance, or a null reference if the capacity is not specified (Inherited from IVenue)
Public property | Cities | Gets a IReadOnlyDictionaryTKey, TValue containing venue's city names in different languages (Inherited from IVenue)
Public property | Coordinates | Gets a map coordinates specifying the exact location of the venue represented by current IVenue instance (Inherited from IVenue)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing venue's country names in different languages (Inherited from IVenue)
Public property | CountryCode | Gets a country code of the venue represented by current IVenue instance (Inherited from IVenue)
Public property | Id | Gets a URN uniquely identifying the current IVenue instance (Inherited from IVenue)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing venue's names in different languages (Inherited from IVenue)
Public property | State | Gets a state of the venue represented by current IVenue instance
Top
See Also

Reference

IVenueV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenueV1.State Property

IVenueV1State Property

Gets a state of the venue represented by current IVenue instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string State { get; }

Property Value

String
See Also

Reference

IVenueV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenueV1 Methods

The IVenueV1 type exposes the following members.

Methods
 | Name | Description
Public method | GetCity | Gets the city name for specific locale (Inherited from IVenue)
Public method | GetCountry | Gets the country name for specific locale (Inherited from IVenue)
Public method | GetName | Gets the name for specific locale (Inherited from IVenue)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IVenueV1 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenueV2 Interface

Defines a contract implemented by classes representing a sport event venue

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IVenueV2 : IVenueV1,
    IVenue, IEntityPrinter

The IVenueV2 type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets the capacity of the venue associated with current IVenue instance, or a null reference if the capacity is not specified (Inherited from IVenue)
Public property | Cities | Gets a IReadOnlyDictionaryTKey, TValue containing venue's city names in different languages (Inherited from IVenue)
Public property | Coordinates | Gets a map coordinates specifying the exact location of the venue represented by current IVenue instance (Inherited from IVenue)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing venue's country names in different languages (Inherited from IVenue)
Public property | CountryCode | Gets a country code of the venue represented by current IVenue instance (Inherited from IVenue)
Public property | Course | Gets the course
Public property | Id | Gets a URN uniquely identifying the current IVenue instance (Inherited from IVenue)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing venue's names in different languages (Inherited from IVenue)
Public property | State | Gets a state of the venue represented by current IVenue instance (Inherited from IVenueV1)
Top
Methods
 | Name | Description
Public method | GetCity | Gets the city name for specific locale (Inherited from IVenue)
Public method | GetCountry | Gets the country name for specific locale (Inherited from IVenue)
Public method | GetName | Gets the name for specific locale (Inherited from IVenue)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenueV2 Properties

The IVenueV2 type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets the capacity of the venue associated with current IVenue instance, or a null reference if the capacity is not specified (Inherited from IVenue)
Public property | Cities | Gets a IReadOnlyDictionaryTKey, TValue containing venue's city names in different languages (Inherited from IVenue)
Public property | Coordinates | Gets a map coordinates specifying the exact location of the venue represented by current IVenue instance (Inherited from IVenue)
Public property | Countries | Gets a IReadOnlyDictionaryTKey, TValue containing venue's country names in different languages (Inherited from IVenue)
Public property | CountryCode | Gets a country code of the venue represented by current IVenue instance (Inherited from IVenue)
Public property | Course | Gets the course
Public property | Id | Gets a URN uniquely identifying the current IVenue instance (Inherited from IVenue)
Public property | Names | Gets a IReadOnlyDictionaryTKey, TValue containing venue's names in different languages (Inherited from IVenue)
Public property | State | Gets a state of the venue represented by current IVenue instance (Inherited from IVenueV1)
Top
See Also

Reference

IVenueV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenueV2.Course Property

IVenueV2Course Property

Gets the course

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IHole> Course { get; }

Property Value

IEnumerable IHole
The course
See Also

Reference

IVenueV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IVenueV2 Methods

The IVenueV2 type exposes the following members.

Methods
 | Name | Description
Public method | GetCity | Gets the city name for specific locale (Inherited from IVenue)
Public method | GetCountry | Gets the country name for specific locale (Inherited from IVenue)
Public method | GetName | Gets the name for specific locale (Inherited from IVenue)
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IVenueV2 Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IWeatherInfo Interface

Defines a contract implemented by classes representing weather conditions

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IWeatherInfo : IEntityPrinter

The IWeatherInfo type exposes the following members.

Properties
 | Name | Description
Public property | Pitch | Get the pitch
Public property | Temperature | Gets the temperature in degrees Celsius or a null reference if the expected temperature is not known
Public property | WeatherConditions | Gets a String specifying the weather conditions (cloudy, sunny, ...)
Public property | Wind | Gets a String specifying the wind conditions
Public property | WindAdvantage | Get the wind advantage
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST Namespace


IWeatherInfo Properties

The IWeatherInfo type exposes the following members.

Properties
 | Name | Description
Public property | Pitch | Get the pitch
Public property | Temperature | Gets the temperature in degrees Celsius or a null reference if the expected temperature is not known
Public property | WeatherConditions | Gets a String specifying the weather conditions (cloudy, sunny, ...)
Public property | Wind | Gets a String specifying the wind conditions
Public property | WindAdvantage | Get the wind advantage
Top
See Also

Reference

IWeatherInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IWeatherInfo.Pitch Property

IWeatherInfoPitch Property

Get the pitch

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Pitch { get; }

Property Value

String
See Also

Reference

IWeatherInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IWeatherInfo.Temperature Property

IWeatherInfoTemperature Property

Gets the temperature in degrees Celsius or a null reference if the expected temperature is not known

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? Temperature { get; }

Property Value

Nullable Int32
See Also

Reference

IWeatherInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IWeatherInfo.WeatherConditions Property

IWeatherInfoWeatherConditions Property

Gets a String specifying the weather conditions (cloudy, sunny, ...)

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string WeatherConditions { get; }

Property Value

String
See Also

Reference

IWeatherInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IWeatherInfo.Wind Property

IWeatherInfoWind Property

Gets a String specifying the wind conditions

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Wind { get; }

Property Value

String
See Also

Reference

IWeatherInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IWeatherInfo.WindAdvantage Property

IWeatherInfoWindAdvantage Property

Get the wind advantage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string WindAdvantage { get; }

Property Value

String
See Also

Reference

IWeatherInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


IWeatherInfo Methods

The IWeatherInfo type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Inherited from IEntityPrinter)
Public method | ToString(IFormatProvider) | Returns a string that represents the current object (Inherited from IEntityPrinter)
Public method | ToString(String, IFormatProvider) | Formats the value of the current instance using the specified format. (Inherited from IEntityPrinter)
Top
See Also

Reference

IWeatherInfo Interface
Sportradar.OddsFeed.SDK.Entities.REST Namespace


Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace

Classes
 | Class | Description
Public class | ExportableBonusInfoCI | Class used to export/import bonus info cache item properties
Public class | ExportableCarCI | Class used to export/import car item properties
Public class | ExportableCategoryCI | Class used to export/import category cache item properties
Public class | ExportableCI | Abstract class used to export/import cache item properties
Public class | ExportableCompetitionCI | Class used to export/import competition cache item properties
Public class | ExportableCompetitorCI | Class used to export/import competitor cache item properties
Public class | ExportableCoverageInfoCI | Class used to export/import coverage info cache item properties
Public class | ExportableCurrentSeasonInfoCI | Class used to export/import current season info cache item properties
Public class | ExportableDelayedInfoCI | Class used to export/import referee cache item properties
Public class | ExportableDrawCI | Class used to export/import draw cache item properties
Public class | ExportableDrawInfoCI | Class used to export/import draw info cache item properties
Public class | ExportableDrawResultCI | Class used to export/import draw result cache item properties
Public class | ExportableEventPlayerAssistCI | Class used to export/import event player assist cache item properties
Public class | ExportableEventPlayerCI | Class used to export/import event player cache item properties
Public class | ExportableEventTimelineCI | Class used to export/import event timeline cache item properties
Public class | ExportableFixtureCI | Class used to export/import fixture cache item properties
Public class | ExportableGroupCI | Class used to export/import group cache item properties
Public class | ExportableHoleCI | Class used to export/import hole item properties
Public class | ExportableJerseyCI | Class used to export/import jersey item properties
Public class | ExportableLotteryCI | Class used to export/import lottery cache item properties
Public class | ExportableManagerCI | Class used to export/import manager item properties
Public class | ExportableMatchCI | Class used to export/import match cache item properties
Public class | ExportablePitcherCI | Class used to export/import pitcher cache item properties
Public class | ExportablePlayerProfileCI | Class used to export/import player profile cache item properties
Public class | ExportableProductInfoCI | Class used to export/import product info cache item properties
Public class | ExportableProductInfoLinkCI | Class used to export/import product info cache item properties
Public class | ExportableRaceDriverProfileCI | Class used to export/import race driver profile item properties
Public class | ExportableRefereeCI | Class used to export/import referee cache item properties
Public class | ExportableRoundCI | Class used to export/import round cache item properties
Public class | ExportableScheduledStartTimeChangeCI | Class used to export/import scheduled start time change cache item properties
Public class | ExportableSeasonCI | Class used to export/import season cache item properties
Public class | ExportableSeasonCoverageCI | Class used to export/import season coverage cache item properties
Public class | ExportableSportCI | Class used to export/import sport cache item properties
Public class | ExportableSportEventCI | Class used to export/import sport event cache item properties
Public class | ExportableSportEventConditionsCI | Class used to export/import sport event conditions cache item properties
Public class | ExportableStageCI | Class used to export/import pitcher cache item properties
Public class | ExportableStreamingChannelCI | Class used to export/import product info cache item properties
Public class | ExportableTeamCompetitorCI | Class used to export/import team competitor cache item properties
Public class | ExportableTimelineEventCI | Class used to export/import pitcher cache item properties
Public class | ExportableTournamentCoverageCI | Class used to export/import tournament coverage cache item properties
Public class | ExportableTournamentInfoBasicCI | Class used to export/import tournament info basic cache item properties
Public class | ExportableTournamentInfoCI | Class used to export/import tournament info cache item properties
Public class | ExportableTvChannelCI | Class used to export/import tv channel cache item properties
Public class | ExportableVenueCI | Class used to export/import venue item properties
Public class | ExportableWeatherInfoCI | Class used to export/import weather info cache item properties


ExportableBonusInfoCI Class

Class used to export/import bonus info cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableBonusInfoCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableBonusInfoCI

The ExportableBonusInfoCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableBonusInfoCI | Initializes a new instance of the ExportableBonusInfoCI class
Top
Properties
 | Name | Description
Public property | BonusBalls | A Int32 representing the bonus balls
Public property | BonusDrumType | A BonusDrumType representing the bonus drum type
Public property | BonusRange | A String representing the bonus range
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableBonusInfoCI Constructor

Initializes a new instance of the ExportableBonusInfoCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableBonusInfoCI()
See Also

Reference

ExportableBonusInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableBonusInfoCI Properties

The ExportableBonusInfoCI type exposes the following members.

Properties
 | Name | Description
Public property | BonusBalls | A Int32 representing the bonus balls
Public property | BonusDrumType | A BonusDrumType representing the bonus drum type
Public property | BonusRange | A String representing the bonus range
Top
See Also

Reference

ExportableBonusInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableBonusInfoCI.BonusBalls Property

ExportableBonusInfoCIBonusBalls Property

A Int32 representing the bonus balls

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? BonusBalls { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableBonusInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableBonusInfoCI.BonusDrumType Property

ExportableBonusInfoCIBonusDrumType Property

A BonusDrumType representing the bonus drum type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public BonusDrumType? BonusDrumType { get; set; }

Property Value

Nullable BonusDrumType
See Also

Reference

ExportableBonusInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableBonusInfoCI.BonusRange Property

ExportableBonusInfoCIBonusRange Property

A String representing the bonus range

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string BonusRange { get; set; }

Property Value

String
See Also

Reference

ExportableBonusInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableBonusInfoCI Methods

The ExportableBonusInfoCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableBonusInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCarCI Class

Class used to export/import car item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCarCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableCarCI

The ExportableCarCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableCarCI | Initializes a new instance of the ExportableCarCI class
Top
Properties
 | Name | Description
Public property | Chassis | A String representing the chassis
Public property | EngineName | A String representing the engine name
Public property | Name | A String representing the name
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCarCI Constructor

Initializes a new instance of the ExportableCarCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableCarCI()
See Also

Reference

ExportableCarCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCarCI Properties

The ExportableCarCI type exposes the following members.

Properties
 | Name | Description
Public property | Chassis | A String representing the chassis
Public property | EngineName | A String representing the engine name
Public property | Name | A String representing the name
Top
See Also

Reference

ExportableCarCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCarCI.Chassis Property

ExportableCarCIChassis Property

A String representing the chassis

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Chassis { get; set; }

Property Value

String
See Also

Reference

ExportableCarCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCarCI.EngineName Property

ExportableCarCIEngineName Property

A String representing the engine name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string EngineName { get; set; }

Property Value

String
See Also

Reference

ExportableCarCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCarCI.Name Property

ExportableCarCIName Property

A String representing the name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

ExportableCarCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCarCI Methods

The ExportableCarCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableCarCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCategoryCI Class

Class used to export/import category cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCategoryCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableCategoryCI : ExportableCI

The ExportableCategoryCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableCategoryCI | Initializes a new instance of the ExportableCategoryCI class
Top
Properties
 | Name | Description
Public property | CountryCode | Gets the country code
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | SportId | Gets the String specifying the id of the parent sport
Public property | TournamentIds | Gets a ListT containing the ids of child tournaments
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCategoryCI Constructor

Initializes a new instance of the ExportableCategoryCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableCategoryCI()
See Also

Reference

ExportableCategoryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCategoryCI Properties

The ExportableCategoryCI type exposes the following members.

Properties
 | Name | Description
Public property | CountryCode | Gets the country code
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | SportId | Gets the String specifying the id of the parent sport
Public property | TournamentIds | Gets a ListT containing the ids of child tournaments
Top
See Also

Reference

ExportableCategoryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCategoryCI.CountryCode Property

ExportableCategoryCICountryCode Property

Gets the country code

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string CountryCode { get; set; }

Property Value

String
The country code
See Also

Reference

ExportableCategoryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCategoryCI.SportId Property

ExportableCategoryCISportId Property

Gets the String specifying the id of the parent sport

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string SportId { get; set; }

Property Value

String
See Also

Reference

ExportableCategoryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCategoryCI.TournamentIds Property

ExportableCategoryCITournamentIds Property

Gets a ListT containing the ids of child tournaments

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> TournamentIds { get; set; }

Property Value

List String
See Also

Reference

ExportableCategoryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCategoryCI Methods

The ExportableCategoryCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableCategoryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCI Class

Abstract class used to export/import cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
More

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableCI

The ExportableCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableCI | Initializes a new instance of the ExportableCI class
Top
Properties
 | Name | Description
Public property | Id | A String representing id of the related entity
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCategoryCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCompetitorCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCurrentSeasonInfoCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableEventPlayerAssistCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableEventPlayerCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableManagerCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportablePlayerProfileCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSportCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSportEventCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableTournamentInfoBasicCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableVenueCI


ExportableCI Constructor

Initializes a new instance of the ExportableCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableCI()
See Also

Reference

ExportableCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCI Properties

The ExportableCI type exposes the following members.

Properties
 | Name | Description
Public property | Id | A String representing id of the related entity
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item
Top
See Also

Reference

ExportableCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCI.Id Property

ExportableCIId Property

A String representing id of the related entity

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Id { get; set; }

Property Value

String
See Also

Reference

ExportableCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCI.Name Property

ExportableCIName Property

A IDictionaryTKey, TValue containing translated name of the item

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> Name { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCI Methods

The ExportableCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI Class

Class used to export/import competition cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSportEventCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCompetitionCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableMatchCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableStageCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableCompetitionCI : ExportableSportEventCI

The ExportableCompetitionCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableCompetitionCI | Initializes a new instance of the ExportableCompetitionCI class
Top
Properties
 | Name | Description
Public property | BookingStatus | Gets the BookingStatus specifying the booking status
Public property | Competitors | Gets the ListT specifying the competitors
Public property | CompetitorsQualifiers | Gets the IDictionaryTKey, TValue specifying the competitors qualifiers
Public property | CompetitorsReferences | Gets the IDictionaryTKey, TValue specifying the competitors qualifiers
Public property | CompetitorsVirtual | Gets the IListT specifying the competitors which are market virtual
Public property | Conditions | Gets the ExportableSportEventConditionsCI specifying the conditions
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LiveOdds | Gets a liveOdds
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures (Inherited from ExportableSportEventCI)
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries (Inherited from ExportableSportEventCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ReferenceId | Gets the IDictionaryTKey, TValue specifying the reference ids
Public property | ReplacedBy | Gets the String specifying the replacement sport event id (Inherited from ExportableSportEventCI)
Public property | Scheduled | Gets the DateTime specifying the start time (Inherited from ExportableSportEventCI)
Public property | ScheduledEnd | Gets the DateTime specifying the end time (Inherited from ExportableSportEventCI)
Public property | SportEventType | Gets a SportEventType for the associated sport event.
Public property | SportId | Gets the String specifying the id of the parent sport (Inherited from ExportableSportEventCI)
Public property | StageType | Gets a StageType for the associated sport event.
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined (Inherited from ExportableSportEventCI)
Public property | Venue | Gets the ExportableVenueCI specifying the venue
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI Constructor

Initializes a new instance of the ExportableCompetitionCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableCompetitionCI()
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI Properties

The ExportableCompetitionCI type exposes the following members.

Properties
 | Name | Description
Public property | BookingStatus | Gets the BookingStatus specifying the booking status
Public property | Competitors | Gets the ListT specifying the competitors
Public property | CompetitorsQualifiers | Gets the IDictionaryTKey, TValue specifying the competitors qualifiers
Public property | CompetitorsReferences | Gets the IDictionaryTKey, TValue specifying the competitors qualifiers
Public property | CompetitorsVirtual | Gets the IListT specifying the competitors which are market virtual
Public property | Conditions | Gets the ExportableSportEventConditionsCI specifying the conditions
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LiveOdds | Gets a liveOdds
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures (Inherited from ExportableSportEventCI)
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries (Inherited from ExportableSportEventCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ReferenceId | Gets the IDictionaryTKey, TValue specifying the reference ids
Public property | ReplacedBy | Gets the String specifying the replacement sport event id (Inherited from ExportableSportEventCI)
Public property | Scheduled | Gets the DateTime specifying the start time (Inherited from ExportableSportEventCI)
Public property | ScheduledEnd | Gets the DateTime specifying the end time (Inherited from ExportableSportEventCI)
Public property | SportEventType | Gets a SportEventType for the associated sport event.
Public property | SportId | Gets the String specifying the id of the parent sport (Inherited from ExportableSportEventCI)
Public property | StageType | Gets a StageType for the associated sport event.
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined (Inherited from ExportableSportEventCI)
Public property | Venue | Gets the ExportableVenueCI specifying the venue
Top
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI.BookingStatus Property

ExportableCompetitionCIBookingStatus Property

Gets the BookingStatus specifying the booking status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public BookingStatus? BookingStatus { get; set; }

Property Value

Nullable BookingStatus
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI.Competitors Property

ExportableCompetitionCICompetitors Property

Gets the ListT specifying the competitors

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> Competitors { get; set; }

Property Value

List String
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI.CompetitorsQualifiers Property

ExportableCompetitionCICompetitorsQualifiers Property

Gets the IDictionaryTKey, TValue specifying the competitors qualifiers

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<string, string> CompetitorsQualifiers { get; set; }

Property Value

Dictionary String, String
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI.CompetitorsReferences Property

ExportableCompetitionCICompetitorsReferences Property

Gets the IDictionaryTKey, TValue specifying the competitors qualifiers

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<string, IDictionary<string, string>> CompetitorsReferences { get; set; }

Property Value

Dictionary String, IDictionary String, String
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI.CompetitorsVirtual Property

ExportableCompetitionCICompetitorsVirtual Property

Gets the IListT specifying the competitors which are market virtual

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> CompetitorsVirtual { get; set; }

Property Value

List String
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI.Conditions Property

ExportableCompetitionCIConditions Property

Gets the ExportableSportEventConditionsCI specifying the conditions

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableSportEventConditionsCI Conditions { get; set; }

Property Value

ExportableSportEventConditionsCI
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI.LiveOdds Property

ExportableCompetitionCILiveOdds Property

Gets a liveOdds

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string LiveOdds { get; set; }

Return Value

String
A liveOdds
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI.ReferenceId Property

ExportableCompetitionCIReferenceId Property

Gets the IDictionaryTKey, TValue specifying the reference ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<string, string> ReferenceId { get; set; }

Property Value

Dictionary String, String
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI.SportEventType Property

ExportableCompetitionCISportEventType Property

Gets a SportEventType for the associated sport event.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public SportEventType? SportEventType { get; set; }

Return Value

Nullable SportEventType
A SportEventType for the associated sport event.
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI.StageType Property

ExportableCompetitionCIStageType Property

Gets a StageType for the associated sport event.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public StageType? StageType { get; set; }

Return Value

Nullable StageType
A StageType for the associated sport event.
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI.Venue Property

ExportableCompetitionCIVenue Property

Gets the ExportableVenueCI specifying the venue

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableVenueCI Venue { get; set; }

Property Value

ExportableVenueCI
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitionCI Methods

The ExportableCompetitionCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableCompetitionCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI Class

Class used to export/import competitor cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCompetitorCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableTeamCompetitorCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableCompetitorCI : ExportableCI

The ExportableCompetitorCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableCompetitorCI | Initializes a new instance of the ExportableCompetitorCI class
Top
Properties
 | Name | Description
Public property | Abbreviations | A IDictionaryTKey, TValue containing competitor abbreviations in different languages
Public property | AgeGroup | A String representing the age group
Public property | AssociatedPlayerIds | A ListT containing associated player ids
Public property | CategoryId | A String representing the category id
Public property | CountryCode | A String representing the country code
Public property | CountryNames | A IDictionaryTKey, TValue containing competitor's country name in different languages
Public property | CultureCompetitorProfileFetched | The list of CultureInfo used to fetch competitor profiles
Public property | Gender | A String representing the gender
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | IsVirtual | A Boolean indicating whether represented competitor is virtual
Public property | Jerseys | A ListT containing jerseys
Public property | Manager | A ExportableManagerCI representing the manager
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | PrimaryCulture | A CultureInfo representing the primary culture
Public property | RaceDriverProfile | A ExportableRaceDriverProfileCI representing the race driver profile
Public property | ReferenceIds | A IDictionaryTKey, TValue containing reference ids
Public property | ShortName | Gets the short name
Public property | SportId | A String representing the sport id
Public property | State | A String representing the state
Public property | Venue | A ExportableVenueCI representing the venue
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI Constructor

Initializes a new instance of the ExportableCompetitorCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableCompetitorCI()
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI Properties

The ExportableCompetitorCI type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | A IDictionaryTKey, TValue containing competitor abbreviations in different languages
Public property | AgeGroup | A String representing the age group
Public property | AssociatedPlayerIds | A ListT containing associated player ids
Public property | CategoryId | A String representing the category id
Public property | CountryCode | A String representing the country code
Public property | CountryNames | A IDictionaryTKey, TValue containing competitor's country name in different languages
Public property | CultureCompetitorProfileFetched | The list of CultureInfo used to fetch competitor profiles
Public property | Gender | A String representing the gender
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | IsVirtual | A Boolean indicating whether represented competitor is virtual
Public property | Jerseys | A ListT containing jerseys
Public property | Manager | A ExportableManagerCI representing the manager
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | PrimaryCulture | A CultureInfo representing the primary culture
Public property | RaceDriverProfile | A ExportableRaceDriverProfileCI representing the race driver profile
Public property | ReferenceIds | A IDictionaryTKey, TValue containing reference ids
Public property | ShortName | Gets the short name
Public property | SportId | A String representing the sport id
Public property | State | A String representing the state
Public property | Venue | A ExportableVenueCI representing the venue
Top
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.Abbreviations Property

ExportableCompetitorCIAbbreviations Property

A IDictionaryTKey, TValue containing competitor abbreviations in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> Abbreviations { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.AgeGroup Property

ExportableCompetitorCIAgeGroup Property

A String representing the age group

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string AgeGroup { get; set; }

Property Value

String
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.AssociatedPlayerIds Property

ExportableCompetitorCIAssociatedPlayerIds Property

A ListT containing associated player ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> AssociatedPlayerIds { get; set; }

Property Value

List String
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.CategoryId Property

ExportableCompetitorCICategoryId Property

A String representing the category id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string CategoryId { get; set; }

Property Value

String
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.CountryCode Property

ExportableCompetitorCICountryCode Property

A String representing the country code

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string CountryCode { get; set; }

Property Value

String
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.CountryNames Property

ExportableCompetitorCICountryNames Property

A IDictionaryTKey, TValue containing competitor's country name in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> CountryNames { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.CultureCompetitorProfileFetched Property

ExportableCompetitorCICultureCompetitorProfileFetched Property

The list of CultureInfo used to fetch competitor profiles

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, DateTime> CultureCompetitorProfileFetched { get; set; }

Property Value

Dictionary CultureInfo, DateTime
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.Gender Property

ExportableCompetitorCIGender Property

A String representing the gender

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Gender { get; set; }

Property Value

String
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.IsVirtual Property

ExportableCompetitorCIIsVirtual Property

A Boolean indicating whether represented competitor is virtual

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool IsVirtual { get; set; }

Property Value

Boolean
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.Jerseys Property

ExportableCompetitorCIJerseys Property

A ListT containing jerseys

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<ExportableJerseyCI> Jerseys { get; set; }

Property Value

List ExportableJerseyCI
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.Manager Property

ExportableCompetitorCIManager Property

A ExportableManagerCI representing the manager

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableManagerCI Manager { get; set; }

Property Value

ExportableManagerCI
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.PrimaryCulture Property

ExportableCompetitorCIPrimaryCulture Property

A CultureInfo representing the primary culture

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CultureInfo PrimaryCulture { get; set; }

Property Value

CultureInfo
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.RaceDriverProfile Property

ExportableCompetitorCIRaceDriverProfile Property

A ExportableRaceDriverProfileCI representing the race driver profile

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableRaceDriverProfileCI RaceDriverProfile { get; set; }

Property Value

ExportableRaceDriverProfileCI
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.ReferenceIds Property

ExportableCompetitorCIReferenceIds Property

A IDictionaryTKey, TValue containing reference ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<string, string> ReferenceIds { get; set; }

Property Value

Dictionary String, String
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.ShortName Property

ExportableCompetitorCIShortName Property

Gets the short name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string ShortName { get; set; }

Property Value

String
The short name
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.SportId Property

ExportableCompetitorCISportId Property

A String representing the sport id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string SportId { get; set; }

Property Value

String
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.State Property

ExportableCompetitorCIState Property

A String representing the state

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string State { get; set; }

Property Value

String
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI.Venue Property

ExportableCompetitorCIVenue Property

A ExportableVenueCI representing the venue

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableVenueCI Venue { get; set; }

Property Value

ExportableVenueCI
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCompetitorCI Methods

The ExportableCompetitorCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCoverageInfoCI Class

Class used to export/import coverage info cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCoverageInfoCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableCoverageInfoCI

The ExportableCoverageInfoCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableCoverageInfoCI | Initializes a new instance of the ExportableCoverageInfoCI class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Fields
 | Name | Description
Public field | CoveredFrom | A CoveredFrom representation of the covered from
Public field | Includes | A ListT representation of the includes
Public field | IsLive | A Boolean indicating if the coverage is live
Public field | Level | A String representation of the level
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCoverageInfoCI Constructor

Initializes a new instance of the ExportableCoverageInfoCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableCoverageInfoCI()
See Also

Reference

ExportableCoverageInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCoverageInfoCI Methods

The ExportableCoverageInfoCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableCoverageInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCoverageInfoCI Fields

The ExportableCoverageInfoCI type exposes the following members.

Fields
 | Name | Description
Public field | CoveredFrom | A CoveredFrom representation of the covered from
Public field | Includes | A ListT representation of the includes
Public field | IsLive | A Boolean indicating if the coverage is live
Public field | Level | A String representation of the level
Top
See Also

Reference

ExportableCoverageInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCoverageInfoCI.CoveredFrom Field

ExportableCoverageInfoCICoveredFrom Field

A CoveredFrom representation of the covered from

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CoveredFrom? CoveredFrom

Field Value

Nullable CoveredFrom
See Also

Reference

ExportableCoverageInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCoverageInfoCI.Includes Field

ExportableCoverageInfoCIIncludes Field

A ListT representation of the includes

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> Includes

Field Value

List String
See Also

Reference

ExportableCoverageInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCoverageInfoCI.IsLive Field

ExportableCoverageInfoCIIsLive Field

A Boolean indicating if the coverage is live

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool IsLive

Field Value

Boolean
See Also

Reference

ExportableCoverageInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCoverageInfoCI.Level Field

ExportableCoverageInfoCILevel Field

A String representation of the level

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Level

Field Value

String
See Also

Reference

ExportableCoverageInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCurrentSeasonInfoCI Class

Class used to export/import current season info cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCurrentSeasonInfoCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableCurrentSeasonInfoCI : ExportableCI

The ExportableCurrentSeasonInfoCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableCurrentSeasonInfoCI | Initializes a new instance of the ExportableCurrentSeasonInfoCI class
Top
Properties
 | Name | Description
Public property | Competitors | A ListT representation of the competitors ids
Public property | CurrentRound | A String representation of the current round
Public property | EndDate | A DateTime representation of the end date
Public property | Groups | A ListT representation of the groups
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | Schedule | A ListT representation of the schedule
Public property | SeasonCoverage | A ExportableSeasonCoverageCI representation of the coverage
Public property | StartDate | A DateTime representation of the start date
Public property | Year | A String representation of the year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCurrentSeasonInfoCI Constructor

Initializes a new instance of the ExportableCurrentSeasonInfoCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableCurrentSeasonInfoCI()
See Also

Reference

ExportableCurrentSeasonInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCurrentSeasonInfoCI Properties

The ExportableCurrentSeasonInfoCI type exposes the following members.

Properties
 | Name | Description
Public property | Competitors | A ListT representation of the competitors ids
Public property | CurrentRound | A String representation of the current round
Public property | EndDate | A DateTime representation of the end date
Public property | Groups | A ListT representation of the groups
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | Schedule | A ListT representation of the schedule
Public property | SeasonCoverage | A ExportableSeasonCoverageCI representation of the coverage
Public property | StartDate | A DateTime representation of the start date
Public property | Year | A String representation of the year
Top
See Also

Reference

ExportableCurrentSeasonInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCurrentSeasonInfoCI.Competitors Property

ExportableCurrentSeasonInfoCICompetitors Property

A ListT representation of the competitors ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> Competitors { get; set; }

Property Value

List String
See Also

Reference

ExportableCurrentSeasonInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCurrentSeasonInfoCI.CurrentRound Property

ExportableCurrentSeasonInfoCICurrentRound Property

A String representation of the current round

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableRoundCI CurrentRound { get; set; }

Property Value

ExportableRoundCI
See Also

Reference

ExportableCurrentSeasonInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCurrentSeasonInfoCI.EndDate Property

ExportableCurrentSeasonInfoCIEndDate Property

A DateTime representation of the end date

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime EndDate { get; set; }

Property Value

DateTime
See Also

Reference

ExportableCurrentSeasonInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCurrentSeasonInfoCI.Groups Property

ExportableCurrentSeasonInfoCIGroups Property

A ListT representation of the groups

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<ExportableGroupCI> Groups { get; set; }

Property Value

List ExportableGroupCI
See Also

Reference

ExportableCurrentSeasonInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCurrentSeasonInfoCI.Schedule Property

ExportableCurrentSeasonInfoCISchedule Property

A ListT representation of the schedule

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> Schedule { get; set; }

Property Value

List String
See Also

Reference

ExportableCurrentSeasonInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCurrentSeasonInfoCI.SeasonCoverage Property

ExportableCurrentSeasonInfoCISeasonCoverage Property

A ExportableSeasonCoverageCI representation of the coverage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableSeasonCoverageCI SeasonCoverage { get; set; }

Property Value

ExportableSeasonCoverageCI
See Also

Reference

ExportableCurrentSeasonInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCurrentSeasonInfoCI.StartDate Property

ExportableCurrentSeasonInfoCIStartDate Property

A DateTime representation of the start date

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime StartDate { get; set; }

Property Value

DateTime
See Also

Reference

ExportableCurrentSeasonInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCurrentSeasonInfoCI.Year Property

ExportableCurrentSeasonInfoCIYear Property

A String representation of the year

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Year { get; set; }

Property Value

String
See Also

Reference

ExportableCurrentSeasonInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableCurrentSeasonInfoCI Methods

The ExportableCurrentSeasonInfoCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableCurrentSeasonInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDelayedInfoCI Class

Class used to export/import referee cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableDelayedInfoCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableDelayedInfoCI

The ExportableDelayedInfoCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableDelayedInfoCI | Initializes a new instance of the ExportableDelayedInfoCI class
Top
Properties
 | Name | Description
Public property | Descriptions | A DictionaryTKey, TValue containing descriptions in different languages
Public property | Id | A String specifying the id
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDelayedInfoCI Constructor

Initializes a new instance of the ExportableDelayedInfoCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableDelayedInfoCI()
See Also

Reference

ExportableDelayedInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDelayedInfoCI Properties

The ExportableDelayedInfoCI type exposes the following members.

Properties
 | Name | Description
Public property | Descriptions | A DictionaryTKey, TValue containing descriptions in different languages
Public property | Id | A String specifying the id
Top
See Also

Reference

ExportableDelayedInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDelayedInfoCI.Descriptions Property

ExportableDelayedInfoCIDescriptions Property

A DictionaryTKey, TValue containing descriptions in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> Descriptions { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableDelayedInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDelayedInfoCI.Id Property

ExportableDelayedInfoCIId Property

A String specifying the id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int Id { get; set; }

Property Value

Int32
See Also

Reference

ExportableDelayedInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDelayedInfoCI Methods

The ExportableDelayedInfoCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableDelayedInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawCI Class

Class used to export/import draw cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSportEventCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableDrawCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableDrawCI : ExportableSportEventCI

The ExportableDrawCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableDrawCI | Initializes a new instance of the ExportableDrawCI class
Top
Properties
 | Name | Description
Public property | DisplayId | A Int32 representing the display id
Public property | DrawStatus | A DrawStatus representing the draw status
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures (Inherited from ExportableSportEventCI)
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries (Inherited from ExportableSportEventCI)
Public property | LotteryId | A String representing the lottery id
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ReplacedBy | Gets the String specifying the replacement sport event id (Inherited from ExportableSportEventCI)
Public property | Results | A ListT representing the results
Public property | ResultsChronological | A Boolean indicating if the results are chronological
Public property | Scheduled | Gets the DateTime specifying the start time (Inherited from ExportableSportEventCI)
Public property | ScheduledEnd | Gets the DateTime specifying the end time (Inherited from ExportableSportEventCI)
Public property | SportId | Gets the String specifying the id of the parent sport (Inherited from ExportableSportEventCI)
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined (Inherited from ExportableSportEventCI)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawCI Constructor

Initializes a new instance of the ExportableDrawCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableDrawCI()
See Also

Reference

ExportableDrawCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawCI Properties

The ExportableDrawCI type exposes the following members.

Properties
 | Name | Description
Public property | DisplayId | A Int32 representing the display id
Public property | DrawStatus | A DrawStatus representing the draw status
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures (Inherited from ExportableSportEventCI)
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries (Inherited from ExportableSportEventCI)
Public property | LotteryId | A String representing the lottery id
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ReplacedBy | Gets the String specifying the replacement sport event id (Inherited from ExportableSportEventCI)
Public property | Results | A ListT representing the results
Public property | ResultsChronological | A Boolean indicating if the results are chronological
Public property | Scheduled | Gets the DateTime specifying the start time (Inherited from ExportableSportEventCI)
Public property | ScheduledEnd | Gets the DateTime specifying the end time (Inherited from ExportableSportEventCI)
Public property | SportId | Gets the String specifying the id of the parent sport (Inherited from ExportableSportEventCI)
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined (Inherited from ExportableSportEventCI)
Top
See Also

Reference

ExportableDrawCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawCI.DisplayId Property

ExportableDrawCIDisplayId Property

A Int32 representing the display id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? DisplayId { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableDrawCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawCI.DrawStatus Property

ExportableDrawCIDrawStatus Property

A DrawStatus representing the draw status

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DrawStatus DrawStatus { get; set; }

Property Value

DrawStatus
See Also

Reference

ExportableDrawCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawCI.LotteryId Property

ExportableDrawCILotteryId Property

A String representing the lottery id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string LotteryId { get; set; }

Property Value

String
See Also

Reference

ExportableDrawCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawCI.Results Property

ExportableDrawCIResults Property

A ListT representing the results

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<ExportableDrawResultCI> Results { get; set; }

Property Value

List ExportableDrawResultCI
See Also

Reference

ExportableDrawCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawCI.ResultsChronological Property

ExportableDrawCIResultsChronological Property

A Boolean indicating if the results are chronological

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool ResultsChronological { get; set; }

Property Value

Boolean
See Also

Reference

ExportableDrawCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawCI Methods

The ExportableDrawCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableDrawCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawInfoCI Class

Class used to export/import draw info cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableDrawInfoCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableDrawInfoCI

The ExportableDrawInfoCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableDrawInfoCI | Initializes a new instance of the ExportableDrawInfoCI class
Top
Properties
 | Name | Description
Public property | DrawType | A DrawType representing the draw type
Public property | GameType | A String representing the game type
Public property | TimeType | A TimeType representing the time type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawInfoCI Constructor

Initializes a new instance of the ExportableDrawInfoCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableDrawInfoCI()
See Also

Reference

ExportableDrawInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawInfoCI Properties

The ExportableDrawInfoCI type exposes the following members.

Properties
 | Name | Description
Public property | DrawType | A DrawType representing the draw type
Public property | GameType | A String representing the game type
Public property | TimeType | A TimeType representing the time type
Top
See Also

Reference

ExportableDrawInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawInfoCI.DrawType Property

ExportableDrawInfoCIDrawType Property

A DrawType representing the draw type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DrawType DrawType { get; set; }

Property Value

DrawType
See Also

Reference

ExportableDrawInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawInfoCI.GameType Property

ExportableDrawInfoCIGameType Property

A String representing the game type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string GameType { get; set; }

Property Value

String
See Also

Reference

ExportableDrawInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawInfoCI.TimeType Property

ExportableDrawInfoCITimeType Property

A TimeType representing the time type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public TimeType TimeType { get; set; }

Property Value

TimeType
See Also

Reference

ExportableDrawInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawInfoCI Methods

The ExportableDrawInfoCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableDrawInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawResultCI Class

Class used to export/import draw result cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableDrawResultCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableDrawResultCI

The ExportableDrawResultCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableDrawResultCI | Initializes a new instance of the ExportableDrawResultCI class
Top
Properties
 | Name | Description
Public property | Names | A DictionaryTKey, TValue containing translated names
Public property | Value | A Int32 representing the value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawResultCI Constructor

Initializes a new instance of the ExportableDrawResultCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableDrawResultCI()
See Also

Reference

ExportableDrawResultCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawResultCI Properties

The ExportableDrawResultCI type exposes the following members.

Properties
 | Name | Description
Public property | Names | A DictionaryTKey, TValue containing translated names
Public property | Value | A Int32 representing the value
Top
See Also

Reference

ExportableDrawResultCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawResultCI.Names Property

ExportableDrawResultCINames Property

A DictionaryTKey, TValue containing translated names

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> Names { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableDrawResultCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawResultCI.Value Property

ExportableDrawResultCIValue Property

A Int32 representing the value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? Value { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableDrawResultCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableDrawResultCI Methods

The ExportableDrawResultCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableDrawResultCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventPlayerAssistCI Class

Class used to export/import event player assist cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableEventPlayerAssistCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableEventPlayerAssistCI : ExportableCI

The ExportableEventPlayerAssistCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableEventPlayerAssistCI | Initializes a new instance of the ExportableEventPlayerAssistCI class
Top
Properties
 | Name | Description
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | Type | A String representing the type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventPlayerAssistCI Constructor

Initializes a new instance of the ExportableEventPlayerAssistCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableEventPlayerAssistCI()
See Also

Reference

ExportableEventPlayerAssistCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventPlayerAssistCI Properties

The ExportableEventPlayerAssistCI type exposes the following members.

Properties
 | Name | Description
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | Type | A String representing the type
Top
See Also

Reference

ExportableEventPlayerAssistCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventPlayerAssistCI.Type Property

ExportableEventPlayerAssistCIType Property

A String representing the type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Type { get; set; }

Property Value

String
See Also

Reference

ExportableEventPlayerAssistCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventPlayerAssistCI Methods

The ExportableEventPlayerAssistCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableEventPlayerAssistCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventPlayerCI Class

Class used to export/import event player cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableEventPlayerCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableEventPlayerCI : ExportableCI

The ExportableEventPlayerCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableEventPlayerCI | Initializes a new instance of the ExportableEventPlayerCI class
Top
Properties
 | Name | Description
Public property | Bench | A String representing the bench value
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Method | A String representing the method value
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventPlayerCI Constructor

Initializes a new instance of the ExportableEventPlayerCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableEventPlayerCI()
See Also

Reference

ExportableEventPlayerCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventPlayerCI Properties

The ExportableEventPlayerCI type exposes the following members.

Properties
 | Name | Description
Public property | Bench | A String representing the bench value
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Method | A String representing the method value
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Top
See Also

Reference

ExportableEventPlayerCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventPlayerCI.Bench Property

ExportableEventPlayerCIBench Property

A String representing the bench value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Bench { get; set; }

Property Value

String
See Also

Reference

ExportableEventPlayerCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventPlayerCI.Method Property

ExportableEventPlayerCIMethod Property

A String representing the method value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Method { get; set; }

Property Value

String
See Also

Reference

ExportableEventPlayerCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventPlayerCI Methods

The ExportableEventPlayerCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableEventPlayerCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventTimelineCI Class

Class used to export/import event timeline cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableEventTimelineCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableEventTimelineCI

The ExportableEventTimelineCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableEventTimelineCI | Initializes a new instance of the ExportableEventTimelineCI class
Top
Properties
 | Name | Description
Public property | FetchedCultures | A ListT representation of the fetched cultures
Public property | IsFinalized | A Boolean indicating if the time line is finished
Public property | Timeline | A ListT representation of the timeline
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventTimelineCI Constructor

Initializes a new instance of the ExportableEventTimelineCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableEventTimelineCI()
See Also

Reference

ExportableEventTimelineCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventTimelineCI Properties

The ExportableEventTimelineCI type exposes the following members.

Properties
 | Name | Description
Public property | FetchedCultures | A ListT representation of the fetched cultures
Public property | IsFinalized | A Boolean indicating if the time line is finished
Public property | Timeline | A ListT representation of the timeline
Top
See Also

Reference

ExportableEventTimelineCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventTimelineCI.FetchedCultures Property

ExportableEventTimelineCIFetchedCultures Property

A ListT representation of the fetched cultures

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<CultureInfo> FetchedCultures { get; set; }

Property Value

List CultureInfo
See Also

Reference

ExportableEventTimelineCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventTimelineCI.IsFinalized Property

ExportableEventTimelineCIIsFinalized Property

A Boolean indicating if the time line is finished

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool IsFinalized { get; set; }

Property Value

Boolean
See Also

Reference

ExportableEventTimelineCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventTimelineCI.Timeline Property

ExportableEventTimelineCITimeline Property

A ListT representation of the timeline

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<ExportableTimelineEventCI> Timeline { get; set; }

Property Value

List ExportableTimelineEventCI
See Also

Reference

ExportableEventTimelineCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableEventTimelineCI Methods

The ExportableEventTimelineCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableEventTimelineCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI Class

Class used to export/import fixture cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableFixtureCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableFixtureCI

The ExportableFixtureCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableFixtureCI | Initializes a new instance of the ExportableFixtureCI class
Top
Properties
 | Name | Description
Public property | AdditionalParentsIds | Gets a ListT specifying the additional parent stages associated with the current instance
Public property | CoverageInfo | A ExportableCoverageInfoCI representation of the coverage info
Public property | ExtraInfo | A DictionaryTKey, TValue representation of the extra info
Public property | NextLiveTime | A DateTime representation of the next live time
Public property | ParentStageId | Gets a id of the parent stage associated with the current instance
Public property | ProductInfo | A ExportableProductInfoCI representation of the product info
Public property | References | A DictionaryTKey, TValue representation of the references
Public property | ReplacedBy | A String representation of the replaced by
Public property | ScheduledStartTimeChanges | A ListT representation of the scheduled start time changes
Public property | StartTime | A DateTime representation of the start time
Public property | StartTimeConfirmed | A Boolean indicating if the start time is confirmed
Public property | StartTimeTBD | A Boolean indicating if the start time is TBD
Public property | TvChannels | A ListT representation of the tv channels
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI Constructor

Initializes a new instance of the ExportableFixtureCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableFixtureCI()
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI Properties

The ExportableFixtureCI type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalParentsIds | Gets a ListT specifying the additional parent stages associated with the current instance
Public property | CoverageInfo | A ExportableCoverageInfoCI representation of the coverage info
Public property | ExtraInfo | A DictionaryTKey, TValue representation of the extra info
Public property | NextLiveTime | A DateTime representation of the next live time
Public property | ParentStageId | Gets a id of the parent stage associated with the current instance
Public property | ProductInfo | A ExportableProductInfoCI representation of the product info
Public property | References | A DictionaryTKey, TValue representation of the references
Public property | ReplacedBy | A String representation of the replaced by
Public property | ScheduledStartTimeChanges | A ListT representation of the scheduled start time changes
Public property | StartTime | A DateTime representation of the start time
Public property | StartTimeConfirmed | A Boolean indicating if the start time is confirmed
Public property | StartTimeTBD | A Boolean indicating if the start time is TBD
Public property | TvChannels | A ListT representation of the tv channels
Top
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.AdditionalParentsIds Property

ExportableFixtureCIAdditionalParentsIds Property

Gets a ListT specifying the additional parent stages associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> AdditionalParentsIds { get; set; }

Property Value

List String
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.CoverageInfo Property

ExportableFixtureCICoverageInfo Property

A ExportableCoverageInfoCI representation of the coverage info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableCoverageInfoCI CoverageInfo { get; set; }

Property Value

ExportableCoverageInfoCI
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.ExtraInfo Property

ExportableFixtureCIExtraInfo Property

A DictionaryTKey, TValue representation of the extra info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<string, string> ExtraInfo { get; set; }

Property Value

Dictionary String, String
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.NextLiveTime Property

ExportableFixtureCINextLiveTime Property

A DateTime representation of the next live time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime? NextLiveTime { get; set; }

Property Value

Nullable DateTime
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.ParentStageId Property

ExportableFixtureCIParentStageId Property

Gets a id of the parent stage associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string ParentStageId { get; set; }

Property Value

String
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.ProductInfo Property

ExportableFixtureCIProductInfo Property

A ExportableProductInfoCI representation of the product info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableProductInfoCI ProductInfo { get; set; }

Property Value

ExportableProductInfoCI
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.References Property

ExportableFixtureCIReferences Property

A DictionaryTKey, TValue representation of the references

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<string, string> References { get; set; }

Property Value

Dictionary String, String
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.ReplacedBy Property

ExportableFixtureCIReplacedBy Property

A String representation of the replaced by

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string ReplacedBy { get; set; }

Property Value

String
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.ScheduledStartTimeChanges Property

ExportableFixtureCIScheduledStartTimeChanges Property

A ListT representation of the scheduled start time changes

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<ExportableScheduledStartTimeChangeCI> ScheduledStartTimeChanges { get; set; }

Property Value

List ExportableScheduledStartTimeChangeCI
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.StartTime Property

ExportableFixtureCIStartTime Property

A DateTime representation of the start time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime? StartTime { get; set; }

Property Value

Nullable DateTime
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.StartTimeConfirmed Property

ExportableFixtureCIStartTimeConfirmed Property

A Boolean indicating if the start time is confirmed

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool? StartTimeConfirmed { get; set; }

Property Value

Nullable Boolean
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.StartTimeTBD Property

ExportableFixtureCIStartTimeTBD Property

A Boolean indicating if the start time is TBD

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool? StartTimeTBD { get; set; }

Property Value

Nullable Boolean
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI.TvChannels Property

ExportableFixtureCITvChannels Property

A ListT representation of the tv channels

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<ExportableTvChannelCI> TvChannels { get; set; }

Property Value

List ExportableTvChannelCI
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableFixtureCI Methods

The ExportableFixtureCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableFixtureCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableGroupCI Class

Class used to export/import group cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableGroupCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableGroupCI

The ExportableGroupCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableGroupCI | Initializes a new instance of the ExportableGroupCI class
Top
Properties
 | Name | Description
Public property | Competitors | A ListT representation of the competitors ids
Public property | CompetitorsReferences | A dictionary of competitor ids and references representation of the competitor references
Public property | Id | A String representation of the id
Public property | Name | A String representation of the name
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableGroupCI Constructor

Initializes a new instance of the ExportableGroupCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableGroupCI()
See Also

Reference

ExportableGroupCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableGroupCI Properties

The ExportableGroupCI type exposes the following members.

Properties
 | Name | Description
Public property | Competitors | A ListT representation of the competitors ids
Public property | CompetitorsReferences | A dictionary of competitor ids and references representation of the competitor references
Public property | Id | A String representation of the id
Public property | Name | A String representation of the name
Top
See Also

Reference

ExportableGroupCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableGroupCI.Competitors Property

ExportableGroupCICompetitors Property

A ListT representation of the competitors ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> Competitors { get; set; }

Property Value

List String
See Also

Reference

ExportableGroupCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableGroupCI.CompetitorsReferences Property

ExportableGroupCICompetitorsReferences Property

A dictionary of competitor ids and references representation of the competitor references

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<string, string> CompetitorsReferences { get; set; }

Property Value

Dictionary String, String
See Also

Reference

ExportableGroupCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableGroupCI.Id Property

ExportableGroupCIId Property

A String representation of the id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Id { get; set; }

Property Value

String
See Also

Reference

ExportableGroupCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableGroupCI.Name Property

ExportableGroupCIName Property

A String representation of the name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

ExportableGroupCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableGroupCI Methods

The ExportableGroupCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableGroupCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableHoleCI Class

Class used to export/import hole item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableHoleCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableHoleCI

The ExportableHoleCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableHoleCI | Initializes a new instance of the ExportableHoleCI class
Top
Properties
 | Name | Description
Public property | Number | Gets the number of the hole
Public property | Par | Gets the par
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableHoleCI Constructor

Initializes a new instance of the ExportableHoleCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableHoleCI()
See Also

Reference

ExportableHoleCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableHoleCI Properties

The ExportableHoleCI type exposes the following members.

Properties
 | Name | Description
Public property | Number | Gets the number of the hole
Public property | Par | Gets the par
Top
See Also

Reference

ExportableHoleCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableHoleCI.Number Property

ExportableHoleCINumber Property

Gets the number of the hole

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int Number { get; set; }

Property Value

Int32
See Also

Reference

ExportableHoleCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableHoleCI.Par Property

ExportableHoleCIPar Property

Gets the par

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int Par { get; set; }

Property Value

Int32
The par
See Also

Reference

ExportableHoleCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableHoleCI Methods

The ExportableHoleCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableHoleCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI Class

Class used to export/import jersey item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableJerseyCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableJerseyCI

The ExportableJerseyCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableJerseyCI | Initializes a new instance of the ExportableJerseyCI class
Top
Properties
 | Name | Description
Public property | BaseColor | Gets the String specifying the base color
Public property | HorizontalStripes | Gets the Boolean specifying the horizontal stripes
Public property | Number | Gets the String specifying the number
Public property | ShirtType | Gets the String specifying the shirt type
Public property | SleeveColor | Gets the String specifying the sleeve color
Public property | SleeveDetail | Gets the String specifying the sleeve detail
Public property | Split | Gets the Boolean specifying the split
Public property | SplitColor | Gets the String specifying the split color
Public property | Squares | Gets the Boolean specifying the squares
Public property | Stripes | Gets the Boolean specifying the stripes
Public property | StripesColor | Gets the String specifying the stripes color
Public property | Type | Gets the String specifying the type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI Constructor

Initializes a new instance of the ExportableJerseyCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableJerseyCI()
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI Properties

The ExportableJerseyCI type exposes the following members.

Properties
 | Name | Description
Public property | BaseColor | Gets the String specifying the base color
Public property | HorizontalStripes | Gets the Boolean specifying the horizontal stripes
Public property | Number | Gets the String specifying the number
Public property | ShirtType | Gets the String specifying the shirt type
Public property | SleeveColor | Gets the String specifying the sleeve color
Public property | SleeveDetail | Gets the String specifying the sleeve detail
Public property | Split | Gets the Boolean specifying the split
Public property | SplitColor | Gets the String specifying the split color
Public property | Squares | Gets the Boolean specifying the squares
Public property | Stripes | Gets the Boolean specifying the stripes
Public property | StripesColor | Gets the String specifying the stripes color
Public property | Type | Gets the String specifying the type
Top
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI.BaseColor Property

ExportableJerseyCIBaseColor Property

Gets the String specifying the base color

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string BaseColor { get; set; }

Property Value

String
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI.HorizontalStripes Property

ExportableJerseyCIHorizontalStripes Property

Gets the Boolean specifying the horizontal stripes

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool? HorizontalStripes { get; set; }

Property Value

Nullable Boolean
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI.Number Property

ExportableJerseyCINumber Property

Gets the String specifying the number

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Number { get; set; }

Property Value

String
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI.ShirtType Property

ExportableJerseyCIShirtType Property

Gets the String specifying the shirt type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string ShirtType { get; set; }

Property Value

String
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI.SleeveColor Property

ExportableJerseyCISleeveColor Property

Gets the String specifying the sleeve color

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string SleeveColor { get; set; }

Property Value

String
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI.SleeveDetail Property

ExportableJerseyCISleeveDetail Property

Gets the String specifying the sleeve detail

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string SleeveDetail { get; set; }

Property Value

String
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI.Split Property

ExportableJerseyCISplit Property

Gets the Boolean specifying the split

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool? Split { get; set; }

Property Value

Nullable Boolean
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI.SplitColor Property

ExportableJerseyCISplitColor Property

Gets the String specifying the split color

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string SplitColor { get; set; }

Property Value

String
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI.Squares Property

ExportableJerseyCISquares Property

Gets the Boolean specifying the squares

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool? Squares { get; set; }

Property Value

Nullable Boolean
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI.Stripes Property

ExportableJerseyCIStripes Property

Gets the Boolean specifying the stripes

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool? Stripes { get; set; }

Property Value

Nullable Boolean
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI.StripesColor Property

ExportableJerseyCIStripesColor Property

Gets the String specifying the stripes color

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string StripesColor { get; set; }

Property Value

String
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI.Type Property

ExportableJerseyCIType Property

Gets the String specifying the type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Type { get; set; }

Property Value

String
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableJerseyCI Methods

The ExportableJerseyCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableJerseyCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableLotteryCI Class

Class used to export/import lottery cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSportEventCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableLotteryCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableLotteryCI : ExportableSportEventCI

The ExportableLotteryCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableLotteryCI | Initializes a new instance of the ExportableLotteryCI class
Top
Properties
 | Name | Description
Public property | BonusInfo | A ExportableBonusInfoCI representing the bonus info
Public property | CategoryId | A String representing the category id
Public property | DrawInfo | A ExportableDrawInfoCI representing the draw info
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures (Inherited from ExportableSportEventCI)
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries (Inherited from ExportableSportEventCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ReplacedBy | Gets the String specifying the replacement sport event id (Inherited from ExportableSportEventCI)
Public property | Scheduled | Gets the DateTime specifying the start time (Inherited from ExportableSportEventCI)
Public property | ScheduledDraws | A ListT representing the scheduled draws
Public property | ScheduledEnd | Gets the DateTime specifying the end time (Inherited from ExportableSportEventCI)
Public property | SportId | Gets the String specifying the id of the parent sport (Inherited from ExportableSportEventCI)
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined (Inherited from ExportableSportEventCI)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableLotteryCI Constructor

Initializes a new instance of the ExportableLotteryCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableLotteryCI()
See Also

Reference

ExportableLotteryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableLotteryCI Properties

The ExportableLotteryCI type exposes the following members.

Properties
 | Name | Description
Public property | BonusInfo | A ExportableBonusInfoCI representing the bonus info
Public property | CategoryId | A String representing the category id
Public property | DrawInfo | A ExportableDrawInfoCI representing the draw info
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures (Inherited from ExportableSportEventCI)
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries (Inherited from ExportableSportEventCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ReplacedBy | Gets the String specifying the replacement sport event id (Inherited from ExportableSportEventCI)
Public property | Scheduled | Gets the DateTime specifying the start time (Inherited from ExportableSportEventCI)
Public property | ScheduledDraws | A ListT representing the scheduled draws
Public property | ScheduledEnd | Gets the DateTime specifying the end time (Inherited from ExportableSportEventCI)
Public property | SportId | Gets the String specifying the id of the parent sport (Inherited from ExportableSportEventCI)
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined (Inherited from ExportableSportEventCI)
Top
See Also

Reference

ExportableLotteryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableLotteryCI.BonusInfo Property

ExportableLotteryCIBonusInfo Property

A ExportableBonusInfoCI representing the bonus info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableBonusInfoCI BonusInfo { get; set; }

Property Value

ExportableBonusInfoCI
See Also

Reference

ExportableLotteryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableLotteryCI.CategoryId Property

ExportableLotteryCICategoryId Property

A String representing the category id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string CategoryId { get; set; }

Property Value

String
See Also

Reference

ExportableLotteryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableLotteryCI.DrawInfo Property

ExportableLotteryCIDrawInfo Property

A ExportableDrawInfoCI representing the draw info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableDrawInfoCI DrawInfo { get; set; }

Property Value

ExportableDrawInfoCI
See Also

Reference

ExportableLotteryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableLotteryCI.ScheduledDraws Property

ExportableLotteryCIScheduledDraws Property

A ListT representing the scheduled draws

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> ScheduledDraws { get; set; }

Property Value

List String
See Also

Reference

ExportableLotteryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableLotteryCI Methods

The ExportableLotteryCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableLotteryCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableManagerCI Class

Class used to export/import manager item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableManagerCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableManagerCI : ExportableCI

The ExportableManagerCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableManagerCI | Initializes a new instance of the ExportableManagerCI class
Top
Properties
 | Name | Description
Public property | CountryCode | A String representing the country code of the manager
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | Nationality | A DictionaryTKey, TValue containing translated nationality of the item
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableManagerCI Constructor

Initializes a new instance of the ExportableManagerCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableManagerCI()
See Also

Reference

ExportableManagerCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableManagerCI Properties

The ExportableManagerCI type exposes the following members.

Properties
 | Name | Description
Public property | CountryCode | A String representing the country code of the manager
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | Nationality | A DictionaryTKey, TValue containing translated nationality of the item
Top
See Also

Reference

ExportableManagerCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableManagerCI.CountryCode Property

ExportableManagerCICountryCode Property

A String representing the country code of the manager

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string CountryCode { get; set; }

Property Value

String
See Also

Reference

ExportableManagerCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableManagerCI.Nationality Property

ExportableManagerCINationality Property

A DictionaryTKey, TValue containing translated nationality of the item

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> Nationality { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableManagerCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableManagerCI Methods

The ExportableManagerCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableManagerCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableMatchCI Class

Class used to export/import match cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSportEventCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCompetitionCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableMatchCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableMatchCI : ExportableCompetitionCI

The ExportableMatchCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableMatchCI | Initializes a new instance of the ExportableMatchCI class
Top
Properties
 | Name | Description
Public property | BookingStatus | Gets the BookingStatus specifying the booking status (Inherited from ExportableCompetitionCI)
Public property | Competitors | Gets the ListT specifying the competitors (Inherited from ExportableCompetitionCI)
Public property | CompetitorsQualifiers | Gets the IDictionaryTKey, TValue specifying the competitors qualifiers (Inherited from ExportableCompetitionCI)
Public property | CompetitorsReferences | Gets the IDictionaryTKey, TValue specifying the competitors qualifiers (Inherited from ExportableCompetitionCI)
Public property | CompetitorsVirtual | Gets the IListT specifying the competitors which are market virtual (Inherited from ExportableCompetitionCI)
Public property | Conditions | Gets the ExportableSportEventConditionsCI specifying the conditions (Inherited from ExportableCompetitionCI)
Public property | CoverageInfo | A ExportableCoverageInfoCI representation of the coverage info
Public property | DelayedInfo | A ExportableDelayedInfoCI representation of the delayed info
Public property | EventTimeline | A ExportableEventTimelineCI representation of the event timeline
Public property | Fixture | A ExportableFixtureCI representation of the fixture
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LiveOdds | Gets a liveOdds (Inherited from ExportableCompetitionCI)
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures (Inherited from ExportableSportEventCI)
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries (Inherited from ExportableSportEventCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ReferenceId | Gets the IDictionaryTKey, TValue specifying the reference ids (Inherited from ExportableCompetitionCI)
Public property | ReplacedBy | Gets the String specifying the replacement sport event id (Inherited from ExportableSportEventCI)
Public property | Scheduled | Gets the DateTime specifying the start time (Inherited from ExportableSportEventCI)
Public property | ScheduledEnd | Gets the DateTime specifying the end time (Inherited from ExportableSportEventCI)
Public property | Season | A ExportableCI representation of the season
Public property | SportEventType | Gets a SportEventType for the associated sport event. (Inherited from ExportableCompetitionCI)
Public property | SportId | Gets the String specifying the id of the parent sport (Inherited from ExportableSportEventCI)
Public property | StageType | Gets a StageType for the associated sport event. (Inherited from ExportableCompetitionCI)
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined (Inherited from ExportableSportEventCI)
Public property | TournamentId | A String representation of the tournament id
Public property | TournamentRound | A ExportableRoundCI representation of the tournament round
Public property | Venue | Gets the ExportableVenueCI specifying the venue (Inherited from ExportableCompetitionCI)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableMatchCI Constructor

Initializes a new instance of the ExportableMatchCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableMatchCI()
See Also

Reference

ExportableMatchCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableMatchCI Properties

The ExportableMatchCI type exposes the following members.

Properties
 | Name | Description
Public property | BookingStatus | Gets the BookingStatus specifying the booking status (Inherited from ExportableCompetitionCI)
Public property | Competitors | Gets the ListT specifying the competitors (Inherited from ExportableCompetitionCI)
Public property | CompetitorsQualifiers | Gets the IDictionaryTKey, TValue specifying the competitors qualifiers (Inherited from ExportableCompetitionCI)
Public property | CompetitorsReferences | Gets the IDictionaryTKey, TValue specifying the competitors qualifiers (Inherited from ExportableCompetitionCI)
Public property | CompetitorsVirtual | Gets the IListT specifying the competitors which are market virtual (Inherited from ExportableCompetitionCI)
Public property | Conditions | Gets the ExportableSportEventConditionsCI specifying the conditions (Inherited from ExportableCompetitionCI)
Public property | CoverageInfo | A ExportableCoverageInfoCI representation of the coverage info
Public property | DelayedInfo | A ExportableDelayedInfoCI representation of the delayed info
Public property | EventTimeline | A ExportableEventTimelineCI representation of the event timeline
Public property | Fixture | A ExportableFixtureCI representation of the fixture
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LiveOdds | Gets a liveOdds (Inherited from ExportableCompetitionCI)
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures (Inherited from ExportableSportEventCI)
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries (Inherited from ExportableSportEventCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ReferenceId | Gets the IDictionaryTKey, TValue specifying the reference ids (Inherited from ExportableCompetitionCI)
Public property | ReplacedBy | Gets the String specifying the replacement sport event id (Inherited from ExportableSportEventCI)
Public property | Scheduled | Gets the DateTime specifying the start time (Inherited from ExportableSportEventCI)
Public property | ScheduledEnd | Gets the DateTime specifying the end time (Inherited from ExportableSportEventCI)
Public property | Season | A ExportableCI representation of the season
Public property | SportEventType | Gets a SportEventType for the associated sport event. (Inherited from ExportableCompetitionCI)
Public property | SportId | Gets the String specifying the id of the parent sport (Inherited from ExportableSportEventCI)
Public property | StageType | Gets a StageType for the associated sport event. (Inherited from ExportableCompetitionCI)
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined (Inherited from ExportableSportEventCI)
Public property | TournamentId | A String representation of the tournament id
Public property | TournamentRound | A ExportableRoundCI representation of the tournament round
Public property | Venue | Gets the ExportableVenueCI specifying the venue (Inherited from ExportableCompetitionCI)
Top
See Also

Reference

ExportableMatchCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableMatchCI.CoverageInfo Property

ExportableMatchCICoverageInfo Property

A ExportableCoverageInfoCI representation of the coverage info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableCoverageInfoCI CoverageInfo { get; set; }

Property Value

ExportableCoverageInfoCI
See Also

Reference

ExportableMatchCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableMatchCI.DelayedInfo Property

ExportableMatchCIDelayedInfo Property

A ExportableDelayedInfoCI representation of the delayed info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableDelayedInfoCI DelayedInfo { get; set; }

Property Value

ExportableDelayedInfoCI
See Also

Reference

ExportableMatchCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableMatchCI.EventTimeline Property

ExportableMatchCIEventTimeline Property

A ExportableEventTimelineCI representation of the event timeline

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableEventTimelineCI EventTimeline { get; set; }

Property Value

ExportableEventTimelineCI
See Also

Reference

ExportableMatchCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableMatchCI.Fixture Property

ExportableMatchCIFixture Property

A ExportableFixtureCI representation of the fixture

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableFixtureCI Fixture { get; set; }

Property Value

ExportableFixtureCI
See Also

Reference

ExportableMatchCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableMatchCI.Season Property

ExportableMatchCISeason Property

A ExportableCI representation of the season

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableSeasonCI Season { get; set; }

Property Value

ExportableSeasonCI
See Also

Reference

ExportableMatchCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableMatchCI.TournamentId Property

ExportableMatchCITournamentId Property

A String representation of the tournament id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string TournamentId { get; set; }

Property Value

String
See Also

Reference

ExportableMatchCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableMatchCI.TournamentRound Property

ExportableMatchCITournamentRound Property

A ExportableRoundCI representation of the tournament round

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableRoundCI TournamentRound { get; set; }

Property Value

ExportableRoundCI
See Also

Reference

ExportableMatchCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableMatchCI Methods

The ExportableMatchCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableMatchCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePitcherCI Class

Class used to export/import pitcher cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportablePitcherCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportablePitcherCI

The ExportablePitcherCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportablePitcherCI | Initializes a new instance of the ExportablePitcherCI class
Top
Properties
 | Name | Description
Public property | Competitor | A HomeAway indicating if the competitor is Home or Away
Public property | Hand | A PlayerHand specifying the hand with which player pitches
Public property | Id | A String representing id of the related entity
Public property | Name | A String specifying the name
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePitcherCI Constructor

Initializes a new instance of the ExportablePitcherCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportablePitcherCI()
See Also

Reference

ExportablePitcherCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePitcherCI Properties

The ExportablePitcherCI type exposes the following members.

Properties
 | Name | Description
Public property | Competitor | A HomeAway indicating if the competitor is Home or Away
Public property | Hand | A PlayerHand specifying the hand with which player pitches
Public property | Id | A String representing id of the related entity
Public property | Name | A String specifying the name
Top
See Also

Reference

ExportablePitcherCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePitcherCI.Competitor Property

ExportablePitcherCICompetitor Property

A HomeAway indicating if the competitor is Home or Away

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public HomeAway Competitor { get; set; }

Property Value

HomeAway
See Also

Reference

ExportablePitcherCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePitcherCI.Hand Property

ExportablePitcherCIHand Property

A PlayerHand specifying the hand with which player pitches

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public PlayerHand Hand { get; set; }

Property Value

PlayerHand
See Also

Reference

ExportablePitcherCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePitcherCI.Id Property

ExportablePitcherCIId Property

A String representing id of the related entity

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Id { get; set; }

Property Value

String
See Also

Reference

ExportablePitcherCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePitcherCI.Name Property

ExportablePitcherCIName Property

A String specifying the name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

ExportablePitcherCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePitcherCI Methods

The ExportablePitcherCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportablePitcherCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI Class

Class used to export/import player profile cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportablePlayerProfileCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportablePlayerProfileCI : ExportableCI

The ExportablePlayerProfileCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportablePlayerProfileCI | Initializes a new instance of the ExportablePlayerProfileCI class
Top
Properties
 | Name | Description
Public property | Abbreviation | A String representing the abbreviation
Public property | CompetitorId | The competitor id this player belongs to
Public property | CountryCode | Gets the country code
Public property | DateOfBirth | A DateTime representing the date of birth
Public property | FullName | Gets the full name of the player
Public property | Gender | A String representing the gender
Public property | Height | A Int32 representing the height
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | Nationalities | A DictionaryTKey, TValue containing nationalities in different languages
Public property | Nickname | Gets the nickname of the player
Public property | Type | A String representing the type
Public property | Weight | A Int32 representing the weight
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI Constructor

Initializes a new instance of the ExportablePlayerProfileCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportablePlayerProfileCI()
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI Properties

The ExportablePlayerProfileCI type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviation | A String representing the abbreviation
Public property | CompetitorId | The competitor id this player belongs to
Public property | CountryCode | Gets the country code
Public property | DateOfBirth | A DateTime representing the date of birth
Public property | FullName | Gets the full name of the player
Public property | Gender | A String representing the gender
Public property | Height | A Int32 representing the height
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | Nationalities | A DictionaryTKey, TValue containing nationalities in different languages
Public property | Nickname | Gets the nickname of the player
Public property | Type | A String representing the type
Public property | Weight | A Int32 representing the weight
Top
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI.Abbreviation Property

ExportablePlayerProfileCIAbbreviation Property

A String representing the abbreviation

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Abbreviation { get; set; }

Property Value

String
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI.CompetitorId Property

ExportablePlayerProfileCICompetitorId Property

The competitor id this player belongs to

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string CompetitorId { get; set; }

Property Value

String
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI.CountryCode Property

ExportablePlayerProfileCICountryCode Property

Gets the country code

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string CountryCode { get; set; }

Property Value

String
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI.DateOfBirth Property

ExportablePlayerProfileCIDateOfBirth Property

A DateTime representing the date of birth

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime? DateOfBirth { get; set; }

Property Value

Nullable DateTime
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI.FullName Property

ExportablePlayerProfileCIFullName Property

Gets the full name of the player

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string FullName { get; set; }

Property Value

String
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI.Gender Property

ExportablePlayerProfileCIGender Property

A String representing the gender

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Gender { get; set; }

Property Value

String
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI.Height Property

ExportablePlayerProfileCIHeight Property

A Int32 representing the height

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? Height { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI.Nationalities Property

ExportablePlayerProfileCINationalities Property

A DictionaryTKey, TValue containing nationalities in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> Nationalities { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI.Nickname Property

ExportablePlayerProfileCINickname Property

Gets the nickname of the player

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Nickname { get; set; }

Property Value

String
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI.Type Property

ExportablePlayerProfileCIType Property

A String representing the type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Type { get; set; }

Property Value

String
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI.Weight Property

ExportablePlayerProfileCIWeight Property

A Int32 representing the weight

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? Weight { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportablePlayerProfileCI Methods

The ExportablePlayerProfileCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportablePlayerProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoCI Class

Class used to export/import product info cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableProductInfoCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableProductInfoCI

The ExportableProductInfoCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableProductInfoCI | Initializes a new instance of the ExportableProductInfoCI class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Fields
 | Name | Description
Public field | Channels | A ListT representation of the channels
Public field | IsAutoTraded | A Boolean indicating if the product is auto traded
Public field | IsInHostedStatistics | A Boolean indicating if the product is in hosted statistics
Public field | IsInLiveCenterSoccer | A Boolean indicating if the product is in live center soccer
Public field | IsInLiveMatchTracker | The Boolean indicating if the product is in live match tracker
Public field | IsInLiveScore | A Boolean indicating if the product is in live score
Public field | Links | A ListT representation of the links
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoCI Constructor

Initializes a new instance of the ExportableProductInfoCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableProductInfoCI()
See Also

Reference

ExportableProductInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoCI Methods

The ExportableProductInfoCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableProductInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoCI Fields

The ExportableProductInfoCI type exposes the following members.

Fields
 | Name | Description
Public field | Channels | A ListT representation of the channels
Public field | IsAutoTraded | A Boolean indicating if the product is auto traded
Public field | IsInHostedStatistics | A Boolean indicating if the product is in hosted statistics
Public field | IsInLiveCenterSoccer | A Boolean indicating if the product is in live center soccer
Public field | IsInLiveMatchTracker | The Boolean indicating if the product is in live match tracker
Public field | IsInLiveScore | A Boolean indicating if the product is in live score
Public field | Links | A ListT representation of the links
Top
See Also

Reference

ExportableProductInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoCI.Channels Field

ExportableProductInfoCIChannels Field

A ListT representation of the channels

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<ExportableStreamingChannelCI> Channels

Field Value

List ExportableStreamingChannelCI
See Also

Reference

ExportableProductInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoCI.IsAutoTraded Field

ExportableProductInfoCIIsAutoTraded Field

A Boolean indicating if the product is auto traded

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool IsAutoTraded

Field Value

Boolean
See Also

Reference

ExportableProductInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoCI.IsInHostedStatistics Field

ExportableProductInfoCIIsInHostedStatistics Field

A Boolean indicating if the product is in hosted statistics

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool IsInHostedStatistics

Field Value

Boolean
See Also

Reference

ExportableProductInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoCI.IsInLiveCenterSoccer Field

ExportableProductInfoCIIsInLiveCenterSoccer Field

A Boolean indicating if the product is in live center soccer

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool IsInLiveCenterSoccer

Field Value

Boolean
See Also

Reference

ExportableProductInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoCI.IsInLiveMatchTracker Field

ExportableProductInfoCIIsInLiveMatchTracker Field

The Boolean indicating if the product is in live match tracker

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool IsInLiveMatchTracker

Field Value

Boolean
See Also

Reference

ExportableProductInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoCI.IsInLiveScore Field

ExportableProductInfoCIIsInLiveScore Field

A Boolean indicating if the product is in live score

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool IsInLiveScore

Field Value

Boolean
See Also

Reference

ExportableProductInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoCI.Links Field

ExportableProductInfoCILinks Field

A ListT representation of the links

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<ExportableProductInfoLinkCI> Links

Field Value

List ExportableProductInfoLinkCI
See Also

Reference

ExportableProductInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoLinkCI Class

Class used to export/import product info cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableProductInfoLinkCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableProductInfoLinkCI

The ExportableProductInfoLinkCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableProductInfoLinkCI | Initializes a new instance of the ExportableProductInfoLinkCI class
Top
Properties
 | Name | Description
Public property | Name | A String representing the name
Public property | Reference | A String representing the reference
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoLinkCI Constructor

Initializes a new instance of the ExportableProductInfoLinkCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableProductInfoLinkCI()
See Also

Reference

ExportableProductInfoLinkCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoLinkCI Properties

The ExportableProductInfoLinkCI type exposes the following members.

Properties
 | Name | Description
Public property | Name | A String representing the name
Public property | Reference | A String representing the reference
Top
See Also

Reference

ExportableProductInfoLinkCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoLinkCI.Name Property

ExportableProductInfoLinkCIName Property

A String representing the name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

ExportableProductInfoLinkCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoLinkCI.Reference Property

ExportableProductInfoLinkCIReference Property

A String representing the reference

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Reference { get; set; }

Property Value

String
See Also

Reference

ExportableProductInfoLinkCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableProductInfoLinkCI Methods

The ExportableProductInfoLinkCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableProductInfoLinkCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRaceDriverProfileCI Class

Class used to export/import race driver profile item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableRaceDriverProfileCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableRaceDriverProfileCI

The ExportableRaceDriverProfileCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableRaceDriverProfileCI | Initializes a new instance of the ExportableRaceDriverProfileCI class
Top
Properties
 | Name | Description
Public property | Car | A ExportableCarCI representing the car
Public property | RaceDriverId | A String representing the race driver id
Public property | RaceTeamId | A String representing the race team id
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRaceDriverProfileCI Constructor

Initializes a new instance of the ExportableRaceDriverProfileCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableRaceDriverProfileCI()
See Also

Reference

ExportableRaceDriverProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRaceDriverProfileCI Properties

The ExportableRaceDriverProfileCI type exposes the following members.

Properties
 | Name | Description
Public property | Car | A ExportableCarCI representing the car
Public property | RaceDriverId | A String representing the race driver id
Public property | RaceTeamId | A String representing the race team id
Top
See Also

Reference

ExportableRaceDriverProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRaceDriverProfileCI.Car Property

ExportableRaceDriverProfileCICar Property

A ExportableCarCI representing the car

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableCarCI Car { get; set; }

Property Value

ExportableCarCI
See Also

Reference

ExportableRaceDriverProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRaceDriverProfileCI.RaceDriverId Property

ExportableRaceDriverProfileCIRaceDriverId Property

A String representing the race driver id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string RaceDriverId { get; set; }

Property Value

String
See Also

Reference

ExportableRaceDriverProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRaceDriverProfileCI.RaceTeamId Property

ExportableRaceDriverProfileCIRaceTeamId Property

A String representing the race team id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string RaceTeamId { get; set; }

Property Value

String
See Also

Reference

ExportableRaceDriverProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRaceDriverProfileCI Methods

The ExportableRaceDriverProfileCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableRaceDriverProfileCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRefereeCI Class

Class used to export/import referee cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableRefereeCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableRefereeCI

The ExportableRefereeCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableRefereeCI | Initializes a new instance of the ExportableRefereeCI class
Top
Properties
 | Name | Description
Public property | Id | A String representing id of the related entity
Public property | Name | A String specifying the name
Public property | Nationality | A DictionaryTKey, TValue containing referee nationality in different languages
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRefereeCI Constructor

Initializes a new instance of the ExportableRefereeCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableRefereeCI()
See Also

Reference

ExportableRefereeCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRefereeCI Properties

The ExportableRefereeCI type exposes the following members.

Properties
 | Name | Description
Public property | Id | A String representing id of the related entity
Public property | Name | A String specifying the name
Public property | Nationality | A DictionaryTKey, TValue containing referee nationality in different languages
Top
See Also

Reference

ExportableRefereeCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRefereeCI.Id Property

ExportableRefereeCIId Property

A String representing id of the related entity

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Id { get; set; }

Property Value

String
See Also

Reference

ExportableRefereeCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRefereeCI.Name Property

ExportableRefereeCIName Property

A String specifying the name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

ExportableRefereeCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRefereeCI.Nationality Property

ExportableRefereeCINationality Property

A DictionaryTKey, TValue containing referee nationality in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> Nationality { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableRefereeCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRefereeCI Methods

The ExportableRefereeCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableRefereeCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI Class

Class used to export/import round cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableRoundCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableRoundCI

The ExportableRoundCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableRoundCI | Initializes a new instance of the ExportableRoundCI class
Top
Properties
 | Name | Description
Public property | BetradarId | A Int32 representation of the betradar id
Public property | BetradarName | A String representation of the betradar name
Public property | CupRoundMatches | A Int32 representation of the cup round matches
Public property | CupRoundMatchNumber | A Int32 representation of the cup round match number
Public property | Group | A String representation of the group
Public property | GroupId | A String representation of the group id
Public property | GroupNames | A DictionaryTKey, TValue representation of the round group names in different languages
Public property | Names | A DictionaryTKey, TValue representation of the round names in different languages
Public property | Number | A Int32 representation of the number
Public property | OtherMatchId | A String representation of the other match id
Public property | Phase | A String representation of the phase
Public property | PhaseOrGroupLongName | A DictionaryTKey, TValue representation of the phase or group long name in different languages
Public property | Type | A String representation of the type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI Constructor

Initializes a new instance of the ExportableRoundCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableRoundCI()
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI Properties

The ExportableRoundCI type exposes the following members.

Properties
 | Name | Description
Public property | BetradarId | A Int32 representation of the betradar id
Public property | BetradarName | A String representation of the betradar name
Public property | CupRoundMatches | A Int32 representation of the cup round matches
Public property | CupRoundMatchNumber | A Int32 representation of the cup round match number
Public property | Group | A String representation of the group
Public property | GroupId | A String representation of the group id
Public property | GroupNames | A DictionaryTKey, TValue representation of the round group names in different languages
Public property | Names | A DictionaryTKey, TValue representation of the round names in different languages
Public property | Number | A Int32 representation of the number
Public property | OtherMatchId | A String representation of the other match id
Public property | Phase | A String representation of the phase
Public property | PhaseOrGroupLongName | A DictionaryTKey, TValue representation of the phase or group long name in different languages
Public property | Type | A String representation of the type
Top
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.BetradarId Property

ExportableRoundCIBetradarId Property

A Int32 representation of the betradar id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? BetradarId { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.BetradarName Property

ExportableRoundCIBetradarName Property

A String representation of the betradar name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string BetradarName { get; set; }

Property Value

String
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.CupRoundMatches Property

ExportableRoundCICupRoundMatches Property

A Int32 representation of the cup round matches

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? CupRoundMatches { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.CupRoundMatchNumber Property

ExportableRoundCICupRoundMatchNumber Property

A Int32 representation of the cup round match number

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? CupRoundMatchNumber { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.Group Property

ExportableRoundCIGroup Property

A String representation of the group

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Group { get; set; }

Property Value

String
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.GroupId Property

ExportableRoundCIGroupId Property

A String representation of the group id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string GroupId { get; set; }

Property Value

String
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.GroupNames Property

ExportableRoundCIGroupNames Property

A DictionaryTKey, TValue representation of the round group names in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> GroupNames { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.Names Property

ExportableRoundCINames Property

A DictionaryTKey, TValue representation of the round names in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> Names { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.Number Property

ExportableRoundCINumber Property

A Int32 representation of the number

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? Number { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.OtherMatchId Property

ExportableRoundCIOtherMatchId Property

A String representation of the other match id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string OtherMatchId { get; set; }

Property Value

String
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.Phase Property

ExportableRoundCIPhase Property

A String representation of the phase

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Phase { get; set; }

Property Value

String
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.PhaseOrGroupLongName Property

ExportableRoundCIPhaseOrGroupLongName Property

A DictionaryTKey, TValue representation of the phase or group long name in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> PhaseOrGroupLongName { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI.Type Property

ExportableRoundCIType Property

A String representation of the type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Type { get; set; }

Property Value

String
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableRoundCI Methods

The ExportableRoundCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableRoundCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableScheduledStartTimeChangeCI Class

Class used to export/import scheduled start time change cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableScheduledStartTimeChangeCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableScheduledStartTimeChangeCI

The ExportableScheduledStartTimeChangeCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableScheduledStartTimeChangeCI | Initializes a new instance of the ExportableScheduledStartTimeChangeCI class
Top
Properties
 | Name | Description
Public property | ChangedAt | A DateTime representation of the changed at
Public property | NewTime | A DateTime representation of the new time
Public property | OldTime | A DateTime representation of the old time
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableScheduledStartTimeChangeCI Constructor

Initializes a new instance of the ExportableScheduledStartTimeChangeCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableScheduledStartTimeChangeCI()
See Also

Reference

ExportableScheduledStartTimeChangeCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableScheduledStartTimeChangeCI Properties

The ExportableScheduledStartTimeChangeCI type exposes the following members.

Properties
 | Name | Description
Public property | ChangedAt | A DateTime representation of the changed at
Public property | NewTime | A DateTime representation of the new time
Public property | OldTime | A DateTime representation of the old time
Top
See Also

Reference

ExportableScheduledStartTimeChangeCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableScheduledStartTimeChangeCI.ChangedAt Property

ExportableScheduledStartTimeChangeCIChangedAt Property

A DateTime representation of the changed at

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime ChangedAt { get; set; }

Property Value

DateTime
See Also

Reference

ExportableScheduledStartTimeChangeCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableScheduledStartTimeChangeCI.NewTime Property

ExportableScheduledStartTimeChangeCINewTime Property

A DateTime representation of the new time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime NewTime { get; set; }

Property Value

DateTime
See Also

Reference

ExportableScheduledStartTimeChangeCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableScheduledStartTimeChangeCI.OldTime Property

ExportableScheduledStartTimeChangeCIOldTime Property

A DateTime representation of the old time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime OldTime { get; set; }

Property Value

DateTime
See Also

Reference

ExportableScheduledStartTimeChangeCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableScheduledStartTimeChangeCI Methods

The ExportableScheduledStartTimeChangeCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableScheduledStartTimeChangeCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCI Class

Class used to export/import season cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSeasonCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableSeasonCI

The ExportableSeasonCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableSeasonCI | Initializes a new instance of the ExportableSeasonCI class
Top
Properties
 | Name | Description
Public property | EndDate | Gets the end date of the season represented by the current instance
Public property | Names | A DictionaryTKey, TValue containing round names in different languages
Public property | SeasonId | Gets a string representing the ID of the represented sport entity
Public property | StartDate | Gets the start date of the season represented by the current instance
Public property | TournamentId | Gets the associated tournament identifier.
Public property | Year | Gets a String representation of the current season year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCI Constructor

Initializes a new instance of the ExportableSeasonCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableSeasonCI()
See Also

Reference

ExportableSeasonCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCI Properties

The ExportableSeasonCI type exposes the following members.

Properties
 | Name | Description
Public property | EndDate | Gets the end date of the season represented by the current instance
Public property | Names | A DictionaryTKey, TValue containing round names in different languages
Public property | SeasonId | Gets a string representing the ID of the represented sport entity
Public property | StartDate | Gets the start date of the season represented by the current instance
Public property | TournamentId | Gets the associated tournament identifier.
Public property | Year | Gets a String representation of the current season year
Top
See Also

Reference

ExportableSeasonCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCI.EndDate Property

ExportableSeasonCIEndDate Property

Gets the end date of the season represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime EndDate { get; set; }

Property Value

DateTime
The end time.
See Also

Reference

ExportableSeasonCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCI.Names Property

ExportableSeasonCINames Property

A DictionaryTKey, TValue containing round names in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> Names { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableSeasonCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCI.SeasonId Property

ExportableSeasonCISeasonId Property

Gets a string representing the ID of the represented sport entity

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string SeasonId { get; set; }

Property Value

String
The identifier
See Also

Reference

ExportableSeasonCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCI.StartDate Property

ExportableSeasonCIStartDate Property

Gets the start date of the season represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime StartDate { get; set; }

Property Value

DateTime
See Also

Reference

ExportableSeasonCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCI.TournamentId Property

ExportableSeasonCITournamentId Property

Gets the associated tournament identifier.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string TournamentId { get; set; }

Property Value

String
The associated tournament identifier.
See Also

Reference

ExportableSeasonCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCI.Year Property

ExportableSeasonCIYear Property

Gets a String representation of the current season year

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Year { get; set; }

Property Value

String
See Also

Reference

ExportableSeasonCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCI Methods

The ExportableSeasonCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableSeasonCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCoverageCI Class

Class used to export/import season coverage cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSeasonCoverageCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableSeasonCoverageCI

The ExportableSeasonCoverageCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableSeasonCoverageCI | Initializes a new instance of the ExportableSeasonCoverageCI class
Top
Properties
 | Name | Description
Public property | MaxCoverageLevel | A String representation of the max coverage level
Public property | MaxCovered | A Int32 representation of the max covered
Public property | MinCoverageLevel | A String representation of the min coverage level
Public property | Played | A String representation of the year
Public property | Scheduled | A Int32 representation of the scheduled
Public property | SeasonId | A String representation of the season id
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCoverageCI Constructor

Initializes a new instance of the ExportableSeasonCoverageCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableSeasonCoverageCI()
See Also

Reference

ExportableSeasonCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCoverageCI Properties

The ExportableSeasonCoverageCI type exposes the following members.

Properties
 | Name | Description
Public property | MaxCoverageLevel | A String representation of the max coverage level
Public property | MaxCovered | A Int32 representation of the max covered
Public property | MinCoverageLevel | A String representation of the min coverage level
Public property | Played | A String representation of the year
Public property | Scheduled | A Int32 representation of the scheduled
Public property | SeasonId | A String representation of the season id
Top
See Also

Reference

ExportableSeasonCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCoverageCI.MaxCoverageLevel Property

ExportableSeasonCoverageCIMaxCoverageLevel Property

A String representation of the max coverage level

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string MaxCoverageLevel { get; set; }

Property Value

String
See Also

Reference

ExportableSeasonCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCoverageCI.MaxCovered Property

ExportableSeasonCoverageCIMaxCovered Property

A Int32 representation of the max covered

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? MaxCovered { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableSeasonCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCoverageCI.MinCoverageLevel Property

ExportableSeasonCoverageCIMinCoverageLevel Property

A String representation of the min coverage level

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string MinCoverageLevel { get; set; }

Property Value

String
See Also

Reference

ExportableSeasonCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCoverageCI.Played Property

ExportableSeasonCoverageCIPlayed Property

A String representation of the year

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int Played { get; set; }

Property Value

Int32
See Also

Reference

ExportableSeasonCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCoverageCI.Scheduled Property

ExportableSeasonCoverageCIScheduled Property

A Int32 representation of the scheduled

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int Scheduled { get; set; }

Property Value

Int32
See Also

Reference

ExportableSeasonCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCoverageCI.SeasonId Property

ExportableSeasonCoverageCISeasonId Property

A String representation of the season id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string SeasonId { get; set; }

Property Value

String
See Also

Reference

ExportableSeasonCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSeasonCoverageCI Methods

The ExportableSeasonCoverageCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableSeasonCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportCI Class

Class used to export/import sport cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSportCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableSportCI : ExportableCI

The ExportableSportCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableSportCI | Initializes a new instance of the ExportableSportCI class
Top
Properties
 | Name | Description
Public property | CategoryIds | A ListT specifying the id's of child categories
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LoadedCategories | A ListT specifying the loaded categories for tournament
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportCI Constructor

Initializes a new instance of the ExportableSportCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableSportCI()
See Also

Reference

ExportableSportCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportCI Properties

The ExportableSportCI type exposes the following members.

Properties
 | Name | Description
Public property | CategoryIds | A ListT specifying the id's of child categories
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LoadedCategories | A ListT specifying the loaded categories for tournament
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Top
See Also

Reference

ExportableSportCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportCI.CategoryIds Property

ExportableSportCICategoryIds Property

A ListT specifying the id's of child categories

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> CategoryIds { get; set; }

Property Value

List String
See Also

Reference

ExportableSportCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportCI.LoadedCategories Property

ExportableSportCILoadedCategories Property

A ListT specifying the loaded categories for tournament

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<CultureInfo> LoadedCategories { get; set; }

Property Value

List CultureInfo
See Also

Reference

ExportableSportCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportCI Methods

The ExportableSportCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableSportCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventCI Class

Class used to export/import sport event cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSportEventCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCompetitionCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableDrawCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableLotteryCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableTournamentInfoCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableSportEventCI : ExportableCI

The ExportableSportEventCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableSportEventCI | Initializes a new instance of the ExportableSportEventCI class
Top
Properties
 | Name | Description
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ReplacedBy | Gets the String specifying the replacement sport event id
Public property | Scheduled | Gets the DateTime specifying the start time
Public property | ScheduledEnd | Gets the DateTime specifying the end time
Public property | SportId | Gets the String specifying the id of the parent sport
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventCI Constructor

Initializes a new instance of the ExportableSportEventCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableSportEventCI()
See Also

Reference

ExportableSportEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventCI Properties

The ExportableSportEventCI type exposes the following members.

Properties
 | Name | Description
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ReplacedBy | Gets the String specifying the replacement sport event id
Public property | Scheduled | Gets the DateTime specifying the start time
Public property | ScheduledEnd | Gets the DateTime specifying the end time
Public property | SportId | Gets the String specifying the id of the parent sport
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined
Top
See Also

Reference

ExportableSportEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventCI.LoadedFixtures Property

ExportableSportEventCILoadedFixtures Property

Gets the ListT specifying the loaded fixtures

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<CultureInfo> LoadedFixtures { get; set; }

Property Value

List CultureInfo
See Also

Reference

ExportableSportEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventCI.LoadedSummaries Property

ExportableSportEventCILoadedSummaries Property

Gets the ListT specifying the loaded summaries

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<CultureInfo> LoadedSummaries { get; set; }

Property Value

List CultureInfo
See Also

Reference

ExportableSportEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventCI.ReplacedBy Property

ExportableSportEventCIReplacedBy Property

Gets the String specifying the replacement sport event id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string ReplacedBy { get; set; }

Property Value

String
See Also

Reference

ExportableSportEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventCI.Scheduled Property

ExportableSportEventCIScheduled Property

Gets the DateTime specifying the start time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime? Scheduled { get; set; }

Property Value

Nullable DateTime
See Also

Reference

ExportableSportEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventCI.ScheduledEnd Property

ExportableSportEventCIScheduledEnd Property

Gets the DateTime specifying the end time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime? ScheduledEnd { get; set; }

Property Value

Nullable DateTime
See Also

Reference

ExportableSportEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventCI.SportId Property

ExportableSportEventCISportId Property

Gets the String specifying the id of the parent sport

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string SportId { get; set; }

Property Value

String
See Also

Reference

ExportableSportEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventCI.StartTimeTbd Property

ExportableSportEventCIStartTimeTbd Property

Gets the Boolean indicating if the start time is to be determined

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool? StartTimeTbd { get; set; }

Property Value

Nullable Boolean
See Also

Reference

ExportableSportEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventCI Methods

The ExportableSportEventCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableSportEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventConditionsCI Class

Class used to export/import sport event conditions cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSportEventConditionsCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableSportEventConditionsCI

The ExportableSportEventConditionsCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableSportEventConditionsCI | Initializes a new instance of the ExportableSportEventConditionsCI class
Top
Properties
 | Name | Description
Public property | Attendance | A String specifying the attendance of the associated sport event
Public property | EventMode | A String specifying the event mode
Public property | Pitchers | A ListT specifying the pitchers
Public property | Referee | A ExportableRefereeCI specifying the referee
Public property | WeatherInfo | A ExportableWeatherInfoCI specifying the weather info
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventConditionsCI Constructor

Initializes a new instance of the ExportableSportEventConditionsCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableSportEventConditionsCI()
See Also

Reference

ExportableSportEventConditionsCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventConditionsCI Properties

The ExportableSportEventConditionsCI type exposes the following members.

Properties
 | Name | Description
Public property | Attendance | A String specifying the attendance of the associated sport event
Public property | EventMode | A String specifying the event mode
Public property | Pitchers | A ListT specifying the pitchers
Public property | Referee | A ExportableRefereeCI specifying the referee
Public property | WeatherInfo | A ExportableWeatherInfoCI specifying the weather info
Top
See Also

Reference

ExportableSportEventConditionsCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventConditionsCI.Attendance Property

ExportableSportEventConditionsCIAttendance Property

A String specifying the attendance of the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Attendance { get; set; }

Property Value

String
See Also

Reference

ExportableSportEventConditionsCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventConditionsCI.EventMode Property

ExportableSportEventConditionsCIEventMode Property

A String specifying the event mode

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string EventMode { get; set; }

Property Value

String
See Also

Reference

ExportableSportEventConditionsCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventConditionsCI.Pitchers Property

ExportableSportEventConditionsCIPitchers Property

A ListT specifying the pitchers

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<ExportablePitcherCI> Pitchers { get; set; }

Property Value

List ExportablePitcherCI
See Also

Reference

ExportableSportEventConditionsCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventConditionsCI.Referee Property

ExportableSportEventConditionsCIReferee Property

A ExportableRefereeCI specifying the referee

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableRefereeCI Referee { get; set; }

Property Value

ExportableRefereeCI
See Also

Reference

ExportableSportEventConditionsCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventConditionsCI.WeatherInfo Property

ExportableSportEventConditionsCIWeatherInfo Property

A ExportableWeatherInfoCI specifying the weather info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableWeatherInfoCI WeatherInfo { get; set; }

Property Value

ExportableWeatherInfoCI
See Also

Reference

ExportableSportEventConditionsCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableSportEventConditionsCI Methods

The ExportableSportEventConditionsCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableSportEventConditionsCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStageCI Class

Class used to export/import pitcher cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSportEventCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCompetitionCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableStageCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableStageCI : ExportableCompetitionCI

The ExportableStageCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableStageCI | Initializes a new instance of the ExportableStageCI class
Top
Properties
 | Name | Description
Public property | AdditionalParentIds | A list of additional parents ids
Public property | BookingStatus | Gets the BookingStatus specifying the booking status (Inherited from ExportableCompetitionCI)
Public property | CategoryId | A String representing the category id
Public property | ChildStages | A IEnumerableT representing the child stages
Public property | Competitors | Gets the ListT specifying the competitors (Inherited from ExportableCompetitionCI)
Public property | CompetitorsQualifiers | Gets the IDictionaryTKey, TValue specifying the competitors qualifiers (Inherited from ExportableCompetitionCI)
Public property | CompetitorsReferences | Gets the IDictionaryTKey, TValue specifying the competitors qualifiers (Inherited from ExportableCompetitionCI)
Public property | CompetitorsVirtual | Gets the IListT specifying the competitors which are market virtual (Inherited from ExportableCompetitionCI)
Public property | Conditions | Gets the ExportableSportEventConditionsCI specifying the conditions (Inherited from ExportableCompetitionCI)
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LiveOdds | Gets a liveOdds (Inherited from ExportableCompetitionCI)
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures (Inherited from ExportableSportEventCI)
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries (Inherited from ExportableSportEventCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ParentStageId | A id representing the parent stage
Public property | ReferenceId | Gets the IDictionaryTKey, TValue specifying the reference ids (Inherited from ExportableCompetitionCI)
Public property | ReplacedBy | Gets the String specifying the replacement sport event id (Inherited from ExportableSportEventCI)
Public property | Scheduled | Gets the DateTime specifying the start time (Inherited from ExportableSportEventCI)
Public property | ScheduledEnd | Gets the DateTime specifying the end time (Inherited from ExportableSportEventCI)
Public property | SportEventType | Gets a SportEventType for the associated sport event. (Inherited from ExportableCompetitionCI)
Public property | SportId | Gets the String specifying the id of the parent sport (Inherited from ExportableSportEventCI)
Public property | StageType | Gets a StageType for the associated sport event. (Inherited from ExportableCompetitionCI)
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined (Inherited from ExportableSportEventCI)
Public property | Venue | Gets the ExportableVenueCI specifying the venue (Inherited from ExportableCompetitionCI)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStageCI Constructor

Initializes a new instance of the ExportableStageCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableStageCI()
See Also

Reference

ExportableStageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStageCI Properties

The ExportableStageCI type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalParentIds | A list of additional parents ids
Public property | BookingStatus | Gets the BookingStatus specifying the booking status (Inherited from ExportableCompetitionCI)
Public property | CategoryId | A String representing the category id
Public property | ChildStages | A IEnumerableT representing the child stages
Public property | Competitors | Gets the ListT specifying the competitors (Inherited from ExportableCompetitionCI)
Public property | CompetitorsQualifiers | Gets the IDictionaryTKey, TValue specifying the competitors qualifiers (Inherited from ExportableCompetitionCI)
Public property | CompetitorsReferences | Gets the IDictionaryTKey, TValue specifying the competitors qualifiers (Inherited from ExportableCompetitionCI)
Public property | CompetitorsVirtual | Gets the IListT specifying the competitors which are market virtual (Inherited from ExportableCompetitionCI)
Public property | Conditions | Gets the ExportableSportEventConditionsCI specifying the conditions (Inherited from ExportableCompetitionCI)
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LiveOdds | Gets a liveOdds (Inherited from ExportableCompetitionCI)
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures (Inherited from ExportableSportEventCI)
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries (Inherited from ExportableSportEventCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ParentStageId | A id representing the parent stage
Public property | ReferenceId | Gets the IDictionaryTKey, TValue specifying the reference ids (Inherited from ExportableCompetitionCI)
Public property | ReplacedBy | Gets the String specifying the replacement sport event id (Inherited from ExportableSportEventCI)
Public property | Scheduled | Gets the DateTime specifying the start time (Inherited from ExportableSportEventCI)
Public property | ScheduledEnd | Gets the DateTime specifying the end time (Inherited from ExportableSportEventCI)
Public property | SportEventType | Gets a SportEventType for the associated sport event. (Inherited from ExportableCompetitionCI)
Public property | SportId | Gets the String specifying the id of the parent sport (Inherited from ExportableSportEventCI)
Public property | StageType | Gets a StageType for the associated sport event. (Inherited from ExportableCompetitionCI)
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined (Inherited from ExportableSportEventCI)
Public property | Venue | Gets the ExportableVenueCI specifying the venue (Inherited from ExportableCompetitionCI)
Top
See Also

Reference

ExportableStageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStageCI.AdditionalParentIds Property

ExportableStageCIAdditionalParentIds Property

A list of additional parents ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> AdditionalParentIds { get; set; }

Property Value

List String
See Also

Reference

ExportableStageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStageCI.CategoryId Property

ExportableStageCICategoryId Property

A String representing the category id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string CategoryId { get; set; }

Property Value

String
See Also

Reference

ExportableStageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStageCI.ChildStages Property

ExportableStageCIChildStages Property

A IEnumerableT representing the child stages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> ChildStages { get; set; }

Property Value

List String
See Also

Reference

ExportableStageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStageCI.ParentStageId Property

ExportableStageCIParentStageId Property

A id representing the parent stage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string ParentStageId { get; set; }

Property Value

String
See Also

Reference

ExportableStageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStageCI Methods

The ExportableStageCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableStageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStreamingChannelCI Class

Class used to export/import product info cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableStreamingChannelCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableStreamingChannelCI

The ExportableStreamingChannelCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableStreamingChannelCI | Initializes a new instance of the ExportableStreamingChannelCI class
Top
Properties
 | Name | Description
Public property | Id | A Int32 representing the id
Public property | Name | A String representing the name
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStreamingChannelCI Constructor

Initializes a new instance of the ExportableStreamingChannelCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableStreamingChannelCI()
See Also

Reference

ExportableStreamingChannelCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStreamingChannelCI Properties

The ExportableStreamingChannelCI type exposes the following members.

Properties
 | Name | Description
Public property | Id | A Int32 representing the id
Public property | Name | A String representing the name
Top
See Also

Reference

ExportableStreamingChannelCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStreamingChannelCI.Id Property

ExportableStreamingChannelCIId Property

A Int32 representing the id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int Id { get; set; }

Property Value

Int32
See Also

Reference

ExportableStreamingChannelCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStreamingChannelCI.Name Property

ExportableStreamingChannelCIName Property

A String representing the name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

ExportableStreamingChannelCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableStreamingChannelCI Methods

The ExportableStreamingChannelCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableStreamingChannelCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTeamCompetitorCI Class

Class used to export/import team competitor cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCompetitorCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableTeamCompetitorCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableTeamCompetitorCI : ExportableCompetitorCI

The ExportableTeamCompetitorCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableTeamCompetitorCI | Initializes a new instance of the ExportableTeamCompetitorCI class
Top
Properties
 | Name | Description
Public property | Abbreviations | A IDictionaryTKey, TValue containing competitor abbreviations in different languages (Inherited from ExportableCompetitorCI)
Public property | AgeGroup | A String representing the age group (Inherited from ExportableCompetitorCI)
Public property | AssociatedPlayerIds | A ListT containing associated player ids (Inherited from ExportableCompetitorCI)
Public property | CategoryId | A String representing the category id (Inherited from ExportableCompetitorCI)
Public property | CountryCode | A String representing the country code (Inherited from ExportableCompetitorCI)
Public property | CountryNames | A IDictionaryTKey, TValue containing competitor's country name in different languages (Inherited from ExportableCompetitorCI)
Public property | CultureCompetitorProfileFetched | The list of CultureInfo used to fetch competitor profiles (Inherited from ExportableCompetitorCI)
Public property | Division | A Int32 representing the division
Public property | Gender | A String representing the gender (Inherited from ExportableCompetitorCI)
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | IsVirtual | A Boolean indicating whether represented competitor is virtual (Inherited from ExportableCompetitorCI)
Public property | Jerseys | A ListT containing jerseys (Inherited from ExportableCompetitorCI)
Public property | Manager | A ExportableManagerCI representing the manager (Inherited from ExportableCompetitorCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | PrimaryCulture | A CultureInfo representing the primary culture (Inherited from ExportableCompetitorCI)
Public property | Qualifier | A String representing the qualifier additionally describing the competitor (e.g. home, away, ...)
Public property | RaceDriverProfile | A ExportableRaceDriverProfileCI representing the race driver profile (Inherited from ExportableCompetitorCI)
Public property | ReferenceIds | A IDictionaryTKey, TValue containing reference ids (Inherited from ExportableCompetitorCI)
Public property | ShortName | Gets the short name (Inherited from ExportableCompetitorCI)
Public property | SportId | A String representing the sport id (Inherited from ExportableCompetitorCI)
Public property | State | A String representing the state (Inherited from ExportableCompetitorCI)
Public property | Venue | A ExportableVenueCI representing the venue (Inherited from ExportableCompetitorCI)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTeamCompetitorCI Constructor

Initializes a new instance of the ExportableTeamCompetitorCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableTeamCompetitorCI()
See Also

Reference

ExportableTeamCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTeamCompetitorCI Properties

The ExportableTeamCompetitorCI type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviations | A IDictionaryTKey, TValue containing competitor abbreviations in different languages (Inherited from ExportableCompetitorCI)
Public property | AgeGroup | A String representing the age group (Inherited from ExportableCompetitorCI)
Public property | AssociatedPlayerIds | A ListT containing associated player ids (Inherited from ExportableCompetitorCI)
Public property | CategoryId | A String representing the category id (Inherited from ExportableCompetitorCI)
Public property | CountryCode | A String representing the country code (Inherited from ExportableCompetitorCI)
Public property | CountryNames | A IDictionaryTKey, TValue containing competitor's country name in different languages (Inherited from ExportableCompetitorCI)
Public property | CultureCompetitorProfileFetched | The list of CultureInfo used to fetch competitor profiles (Inherited from ExportableCompetitorCI)
Public property | Division | A Int32 representing the division
Public property | Gender | A String representing the gender (Inherited from ExportableCompetitorCI)
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | IsVirtual | A Boolean indicating whether represented competitor is virtual (Inherited from ExportableCompetitorCI)
Public property | Jerseys | A ListT containing jerseys (Inherited from ExportableCompetitorCI)
Public property | Manager | A ExportableManagerCI representing the manager (Inherited from ExportableCompetitorCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | PrimaryCulture | A CultureInfo representing the primary culture (Inherited from ExportableCompetitorCI)
Public property | Qualifier | A String representing the qualifier additionally describing the competitor (e.g. home, away, ...)
Public property | RaceDriverProfile | A ExportableRaceDriverProfileCI representing the race driver profile (Inherited from ExportableCompetitorCI)
Public property | ReferenceIds | A IDictionaryTKey, TValue containing reference ids (Inherited from ExportableCompetitorCI)
Public property | ShortName | Gets the short name (Inherited from ExportableCompetitorCI)
Public property | SportId | A String representing the sport id (Inherited from ExportableCompetitorCI)
Public property | State | A String representing the state (Inherited from ExportableCompetitorCI)
Public property | Venue | A ExportableVenueCI representing the venue (Inherited from ExportableCompetitorCI)
Top
See Also

Reference

ExportableTeamCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTeamCompetitorCI.Division Property

ExportableTeamCompetitorCIDivision Property

A Int32 representing the division

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? Division { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableTeamCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTeamCompetitorCI.Qualifier Property

ExportableTeamCompetitorCIQualifier Property

A String representing the qualifier additionally describing the competitor (e.g. home, away, ...)

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Qualifier { get; set; }

Property Value

String
See Also

Reference

ExportableTeamCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTeamCompetitorCI Methods

The ExportableTeamCompetitorCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableTeamCompetitorCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI Class

Class used to export/import pitcher cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableTimelineEventCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableTimelineEventCI

The ExportableTimelineEventCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableTimelineEventCI | Initializes a new instance of the ExportableTimelineEventCI class
Top
Properties
 | Name | Description
Public property | Assists | A ListT specifying the assists
Public property | AwayScore | A Decimal specifying the away score
Public property | GoalScorer | A ExportableEventPlayerCI specifying the goal scorer
Public property | HomeScore | A Decimal specifying the home score
Public property | Id | A Int32 specifying the id
Public property | MatchClock | A String specifying the match clock
Public property | MatchStatusCode | A Int32 specifying the match status code
Public property | MatchTime | A Int32 specifying the match time
Public property | Period | A String specifying the period
Public property | PeriodName | A String specifying the period name
Public property | Player | A ExportableEventPlayerCI specifying the player
Public property | Points | A String specifying the points
Public property | StoppageTime | A String specifying the stoppage time
Public property | Team | A HomeAway specifying the team
Public property | Time | A DateTime specifying the time
Public property | Type | A String specifying the type
Public property | Value | A String specifying the value
Public property | X | A Int32 specifying the x
Public property | Y | A Int32 specifying the y
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI Constructor

Initializes a new instance of the ExportableTimelineEventCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableTimelineEventCI()
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI Properties

The ExportableTimelineEventCI type exposes the following members.

Properties
 | Name | Description
Public property | Assists | A ListT specifying the assists
Public property | AwayScore | A Decimal specifying the away score
Public property | GoalScorer | A ExportableEventPlayerCI specifying the goal scorer
Public property | HomeScore | A Decimal specifying the home score
Public property | Id | A Int32 specifying the id
Public property | MatchClock | A String specifying the match clock
Public property | MatchStatusCode | A Int32 specifying the match status code
Public property | MatchTime | A Int32 specifying the match time
Public property | Period | A String specifying the period
Public property | PeriodName | A String specifying the period name
Public property | Player | A ExportableEventPlayerCI specifying the player
Public property | Points | A String specifying the points
Public property | StoppageTime | A String specifying the stoppage time
Public property | Team | A HomeAway specifying the team
Public property | Time | A DateTime specifying the time
Public property | Type | A String specifying the type
Public property | Value | A String specifying the value
Public property | X | A Int32 specifying the x
Public property | Y | A Int32 specifying the y
Top
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.Assists Property

ExportableTimelineEventCIAssists Property

A ListT specifying the assists

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<ExportableEventPlayerAssistCI> Assists { get; set; }

Property Value

List ExportableEventPlayerAssistCI
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.AwayScore Property

ExportableTimelineEventCIAwayScore Property

A Decimal specifying the away score

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public decimal? AwayScore { get; set; }

Property Value

Nullable Decimal
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.GoalScorer Property

ExportableTimelineEventCIGoalScorer Property

A ExportableEventPlayerCI specifying the goal scorer

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableEventPlayerCI GoalScorer { get; set; }

Property Value

ExportableEventPlayerCI
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.HomeScore Property

ExportableTimelineEventCIHomeScore Property

A Decimal specifying the home score

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public decimal? HomeScore { get; set; }

Property Value

Nullable Decimal
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.Id Property

ExportableTimelineEventCIId Property

A Int32 specifying the id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int Id { get; set; }

Property Value

Int32
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.MatchClock Property

ExportableTimelineEventCIMatchClock Property

A String specifying the match clock

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string MatchClock { get; set; }

Property Value

String
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.MatchStatusCode Property

ExportableTimelineEventCIMatchStatusCode Property

A Int32 specifying the match status code

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? MatchStatusCode { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.MatchTime Property

ExportableTimelineEventCIMatchTime Property

A Int32 specifying the match time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? MatchTime { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.Period Property

ExportableTimelineEventCIPeriod Property

A String specifying the period

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Period { get; set; }

Property Value

String
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.PeriodName Property

ExportableTimelineEventCIPeriodName Property

A String specifying the period name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string PeriodName { get; set; }

Property Value

String
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.Player Property

ExportableTimelineEventCIPlayer Property

A ExportableEventPlayerCI specifying the player

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableEventPlayerCI Player { get; set; }

Property Value

ExportableEventPlayerCI
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.Points Property

ExportableTimelineEventCIPoints Property

A String specifying the points

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Points { get; set; }

Property Value

String
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.StoppageTime Property

ExportableTimelineEventCIStoppageTime Property

A String specifying the stoppage time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string StoppageTime { get; set; }

Property Value

String
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.Team Property

ExportableTimelineEventCITeam Property

A HomeAway specifying the team

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public HomeAway? Team { get; set; }

Property Value

Nullable HomeAway
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.Time Property

ExportableTimelineEventCITime Property

A DateTime specifying the time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime Time { get; set; }

Property Value

DateTime
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.Type Property

ExportableTimelineEventCIType Property

A String specifying the type

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Type { get; set; }

Property Value

String
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.Value Property

ExportableTimelineEventCIValue Property

A String specifying the value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Value { get; set; }

Property Value

String
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.X Property

ExportableTimelineEventCIX Property

A Int32 specifying the x

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? X { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI.Y Property

ExportableTimelineEventCIY Property

A Int32 specifying the y

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? Y { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTimelineEventCI Methods

The ExportableTimelineEventCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableTimelineEventCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentCoverageCI Class

Class used to export/import tournament coverage cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableTournamentCoverageCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableTournamentCoverageCI

The ExportableTournamentCoverageCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableTournamentCoverageCI | Initializes a new instance of the ExportableTournamentCoverageCI class
Top
Properties
 | Name | Description
Public property | LiveCoverage | A Boolean indicating if the tournament has live coverage
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentCoverageCI Constructor

Initializes a new instance of the ExportableTournamentCoverageCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableTournamentCoverageCI()
See Also

Reference

ExportableTournamentCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentCoverageCI Properties

The ExportableTournamentCoverageCI type exposes the following members.

Properties
 | Name | Description
Public property | LiveCoverage | A Boolean indicating if the tournament has live coverage
Top
See Also

Reference

ExportableTournamentCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentCoverageCI.LiveCoverage Property

ExportableTournamentCoverageCILiveCoverage Property

A Boolean indicating if the tournament has live coverage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool LiveCoverage { get; set; }

Property Value

Boolean
See Also

Reference

ExportableTournamentCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentCoverageCI Methods

The ExportableTournamentCoverageCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableTournamentCoverageCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoBasicCI Class

Class used to export/import tournament info basic cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableTournamentInfoBasicCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableTournamentInfoBasicCI : ExportableCI

The ExportableTournamentInfoBasicCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableTournamentInfoBasicCI | Initializes a new instance of the ExportableTournamentInfoBasicCI class
Top
Properties
 | Name | Description
Public property | Category | A String representation of the category
Public property | CurrentSeason | A ExportableCurrentSeasonInfoCI representation of the current season
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoBasicCI Constructor

Initializes a new instance of the ExportableTournamentInfoBasicCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableTournamentInfoBasicCI()
See Also

Reference

ExportableTournamentInfoBasicCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoBasicCI Properties

The ExportableTournamentInfoBasicCI type exposes the following members.

Properties
 | Name | Description
Public property | Category | A String representation of the category
Public property | CurrentSeason | A ExportableCurrentSeasonInfoCI representation of the current season
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Top
See Also

Reference

ExportableTournamentInfoBasicCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoBasicCI.Category Property

ExportableTournamentInfoBasicCICategory Property

A String representation of the category

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Category { get; set; }

Property Value

String
See Also

Reference

ExportableTournamentInfoBasicCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoBasicCI.CurrentSeason Property

ExportableTournamentInfoBasicCICurrentSeason Property

A ExportableCurrentSeasonInfoCI representation of the current season

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableCurrentSeasonInfoCI CurrentSeason { get; set; }

Property Value

ExportableCurrentSeasonInfoCI
See Also

Reference

ExportableTournamentInfoBasicCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoBasicCI Methods

The ExportableTournamentInfoBasicCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableTournamentInfoBasicCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI Class

Class used to export/import tournament info cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableSportEventCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableTournamentInfoCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableTournamentInfoCI : ExportableSportEventCI

The ExportableTournamentInfoCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableTournamentInfoCI | Initializes a new instance of the ExportableTournamentInfoCI class
Top
Properties
 | Name | Description
Public property | CategoryId | A String representing the category id
Public property | Competitors | A ListT representing the competitors ids
Public property | CompetitorsReferences | A DictionaryTKey, TValue representing the competitors references
Public property | CurrentSeasonInfo | A ExportableCurrentSeasonInfoCI representing the season info
Public property | ExhibitionGames | A Boolean representing the exhibition games
Public property | Groups | A ListT representing the groups
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures (Inherited from ExportableSportEventCI)
Public property | LoadedSchedules | A ListT representing the loaded schedules
Public property | LoadedSeasons | A ListT representing the loaded seasons
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries (Inherited from ExportableSportEventCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ReferenceId | A DictionaryTKey, TValue representing the reference id
Public property | ReplacedBy | Gets the String specifying the replacement sport event id (Inherited from ExportableSportEventCI)
Public property | Round | A ExportableRoundCI representing the round
Public property | Scheduled | Gets the DateTime specifying the start time (Inherited from ExportableSportEventCI)
Public property | ScheduledEnd | Gets the DateTime specifying the end time (Inherited from ExportableSportEventCI)
Public property | ScheduleUrns | A ListT representing the schedule urns
Public property | SeasonCoverage | A ExportableSeasonCoverageCI representing the season coverage
Public property | Seasons | A ListT representing the seasons
Public property | SportId | Gets the String specifying the id of the parent sport (Inherited from ExportableSportEventCI)
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined (Inherited from ExportableSportEventCI)
Public property | TournamentCoverage | A ExportableTournamentCoverageCI representing the coverage
Public property | TournamentInfoBasic | A ExportableTournamentInfoBasicCI representing the basic info
Public property | Year | A String representing the year
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI Constructor

Initializes a new instance of the ExportableTournamentInfoCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableTournamentInfoCI()
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI Properties

The ExportableTournamentInfoCI type exposes the following members.

Properties
 | Name | Description
Public property | CategoryId | A String representing the category id
Public property | Competitors | A ListT representing the competitors ids
Public property | CompetitorsReferences | A DictionaryTKey, TValue representing the competitors references
Public property | CurrentSeasonInfo | A ExportableCurrentSeasonInfoCI representing the season info
Public property | ExhibitionGames | A Boolean representing the exhibition games
Public property | Groups | A ListT representing the groups
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | LoadedFixtures | Gets the ListT specifying the loaded fixtures (Inherited from ExportableSportEventCI)
Public property | LoadedSchedules | A ListT representing the loaded schedules
Public property | LoadedSeasons | A ListT representing the loaded seasons
Public property | LoadedSummaries | Gets the ListT specifying the loaded summaries (Inherited from ExportableSportEventCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | ReferenceId | A DictionaryTKey, TValue representing the reference id
Public property | ReplacedBy | Gets the String specifying the replacement sport event id (Inherited from ExportableSportEventCI)
Public property | Round | A ExportableRoundCI representing the round
Public property | Scheduled | Gets the DateTime specifying the start time (Inherited from ExportableSportEventCI)
Public property | ScheduledEnd | Gets the DateTime specifying the end time (Inherited from ExportableSportEventCI)
Public property | ScheduleUrns | A ListT representing the schedule urns
Public property | SeasonCoverage | A ExportableSeasonCoverageCI representing the season coverage
Public property | Seasons | A ListT representing the seasons
Public property | SportId | Gets the String specifying the id of the parent sport (Inherited from ExportableSportEventCI)
Public property | StartTimeTbd | Gets the Boolean indicating if the start time is to be determined (Inherited from ExportableSportEventCI)
Public property | TournamentCoverage | A ExportableTournamentCoverageCI representing the coverage
Public property | TournamentInfoBasic | A ExportableTournamentInfoBasicCI representing the basic info
Public property | Year | A String representing the year
Top
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.CategoryId Property

ExportableTournamentInfoCICategoryId Property

A String representing the category id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string CategoryId { get; set; }

Property Value

String
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.Competitors Property

ExportableTournamentInfoCICompetitors Property

A ListT representing the competitors ids

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> Competitors { get; set; }

Property Value

List String
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.CompetitorsReferences Property

ExportableTournamentInfoCICompetitorsReferences Property

A DictionaryTKey, TValue representing the competitors references

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<string, Dictionary<string, string>> CompetitorsReferences { get; set; }

Property Value

Dictionary String, Dictionary String, String
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.CurrentSeasonInfo Property

ExportableTournamentInfoCICurrentSeasonInfo Property

A ExportableCurrentSeasonInfoCI representing the season info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableCurrentSeasonInfoCI CurrentSeasonInfo { get; set; }

Property Value

ExportableCurrentSeasonInfoCI
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.ExhibitionGames Property

ExportableTournamentInfoCIExhibitionGames Property

A Boolean representing the exhibition games

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool? ExhibitionGames { get; set; }

Property Value

Nullable Boolean
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.Groups Property

ExportableTournamentInfoCIGroups Property

A ListT representing the groups

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<ExportableGroupCI> Groups { get; set; }

Property Value

List ExportableGroupCI
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.LoadedSchedules Property

ExportableTournamentInfoCILoadedSchedules Property

A ListT representing the loaded schedules

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<CultureInfo> LoadedSchedules { get; set; }

Property Value

List CultureInfo
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.LoadedSeasons Property

ExportableTournamentInfoCILoadedSeasons Property

A ListT representing the loaded seasons

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<CultureInfo> LoadedSeasons { get; set; }

Property Value

List CultureInfo
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.ReferenceId Property

ExportableTournamentInfoCIReferenceId Property

A DictionaryTKey, TValue representing the reference id

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<string, string> ReferenceId { get; set; }

Property Value

Dictionary String, String
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.Round Property

ExportableTournamentInfoCIRound Property

A ExportableRoundCI representing the round

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableRoundCI Round { get; set; }

Property Value

ExportableRoundCI
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.ScheduleUrns Property

ExportableTournamentInfoCIScheduleUrns Property

A ListT representing the schedule urns

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> ScheduleUrns { get; set; }

Property Value

List String
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.SeasonCoverage Property

ExportableTournamentInfoCISeasonCoverage Property

A ExportableSeasonCoverageCI representing the season coverage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableSeasonCoverageCI SeasonCoverage { get; set; }

Property Value

ExportableSeasonCoverageCI
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.Seasons Property

ExportableTournamentInfoCISeasons Property

A ListT representing the seasons

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<string> Seasons { get; set; }

Property Value

List String
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.TournamentCoverage Property

ExportableTournamentInfoCITournamentCoverage Property

A ExportableTournamentCoverageCI representing the coverage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableTournamentCoverageCI TournamentCoverage { get; set; }

Property Value

ExportableTournamentCoverageCI
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.TournamentInfoBasic Property

ExportableTournamentInfoCITournamentInfoBasic Property

A ExportableTournamentInfoBasicCI representing the basic info

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableTournamentInfoBasicCI TournamentInfoBasic { get; set; }

Property Value

ExportableTournamentInfoBasicCI
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI.Year Property

ExportableTournamentInfoCIYear Property

A String representing the year

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Year { get; set; }

Property Value

String
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTournamentInfoCI Methods

The ExportableTournamentInfoCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableTournamentInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTvChannelCI Class

Class used to export/import tv channel cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableTvChannelCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableTvChannelCI

The ExportableTvChannelCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableTvChannelCI | Initializes a new instance of the ExportableTvChannelCI class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Fields
 | Name | Description
Public field | Name | A String representation of the name
Public field | StartTime | A DateTime representation of the start time
Public field | StreamUrl | A String representation of the stream url
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTvChannelCI Constructor

Initializes a new instance of the ExportableTvChannelCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableTvChannelCI()
See Also

Reference

ExportableTvChannelCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTvChannelCI Methods

The ExportableTvChannelCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableTvChannelCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTvChannelCI Fields

The ExportableTvChannelCI type exposes the following members.

Fields
 | Name | Description
Public field | Name | A String representation of the name
Public field | StartTime | A DateTime representation of the start time
Public field | StreamUrl | A String representation of the stream url
Top
See Also

Reference

ExportableTvChannelCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTvChannelCI.Name Field

ExportableTvChannelCIName Field

A String representation of the name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Name

Field Value

String
See Also

Reference

ExportableTvChannelCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTvChannelCI.StartTime Field

ExportableTvChannelCIStartTime Field

A DateTime representation of the start time

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime? StartTime

Field Value

Nullable DateTime
See Also

Reference

ExportableTvChannelCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableTvChannelCI.StreamUrl Field

ExportableTvChannelCIStreamUrl Field

A String representation of the stream url

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string StreamUrl

Field Value

String
See Also

Reference

ExportableTvChannelCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableVenueCI Class

Class used to export/import venue item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableCI
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableVenueCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableVenueCI : ExportableCI

The ExportableVenueCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableVenueCI | Initializes a new instance of the ExportableVenueCI class
Top
Properties
 | Name | Description
Public property | Capacity | Gets the capacity of the venue
Public property | CityNames | A DictionaryTKey, TValue containing city of the venue in different languages
Public property | Coordinates | Gets a map coordinates specifying the exact location of the venue
Public property | CountryCode | Gets a country code of the venue
Public property | CountryNames | A DictionaryTKey, TValue containing country of the venue in different languages
Public property | Course | Gets the course
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | State | Gets a state of the venue
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableVenueCI Constructor

Initializes a new instance of the ExportableVenueCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableVenueCI()
See Also

Reference

ExportableVenueCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableVenueCI Properties

The ExportableVenueCI type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets the capacity of the venue
Public property | CityNames | A DictionaryTKey, TValue containing city of the venue in different languages
Public property | Coordinates | Gets a map coordinates specifying the exact location of the venue
Public property | CountryCode | Gets a country code of the venue
Public property | CountryNames | A DictionaryTKey, TValue containing country of the venue in different languages
Public property | Course | Gets the course
Public property | Id | A String representing id of the related entity (Inherited from ExportableCI)
Public property | Name | A IDictionaryTKey, TValue containing translated name of the item (Inherited from ExportableCI)
Public property | State | Gets a state of the venue
Top
See Also

Reference

ExportableVenueCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableVenueCI.Capacity Property

ExportableVenueCICapacity Property

Gets the capacity of the venue

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? Capacity { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableVenueCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableVenueCI.CityNames Property

ExportableVenueCICityNames Property

A DictionaryTKey, TValue containing city of the venue in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> CityNames { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableVenueCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableVenueCI.Coordinates Property

ExportableVenueCICoordinates Property

Gets a map coordinates specifying the exact location of the venue

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Coordinates { get; set; }

Property Value

String
See Also

Reference

ExportableVenueCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableVenueCI.CountryCode Property

ExportableVenueCICountryCode Property

Gets a country code of the venue

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string CountryCode { get; set; }

Property Value

String
See Also

Reference

ExportableVenueCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableVenueCI.CountryNames Property

ExportableVenueCICountryNames Property

A DictionaryTKey, TValue containing country of the venue in different languages

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Dictionary<CultureInfo, string> CountryNames { get; set; }

Property Value

Dictionary CultureInfo, String
See Also

Reference

ExportableVenueCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableVenueCI.Course Property

ExportableVenueCICourse Property

Gets the course

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public List<ExportableHoleCI> Course { get; set; }

Property Value

List ExportableHoleCI
The course
See Also

Reference

ExportableVenueCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableVenueCI.State Property

ExportableVenueCIState Property

Gets a state of the venue

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string State { get; set; }

Property Value

String
See Also

Reference

ExportableVenueCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableVenueCI Methods

The ExportableVenueCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableVenueCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableWeatherInfoCI Class

Class used to export/import weather info cache item properties
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.Caching.ExportableExportableWeatherInfoCI

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class ExportableWeatherInfoCI

The ExportableWeatherInfoCI type exposes the following members.

Constructors
 | Name | Description
Public method | ExportableWeatherInfoCI | Initializes a new instance of the ExportableWeatherInfoCI class
Top
Properties
 | Name | Description
Public property | Pitch | A String specifying the pitch
Public property | TemperatureCelsius | A Int32 specifying the temperature
Public property | WeatherConditions | A String specifying the weather conditions
Public property | Wind | A String specifying the wind
Public property | WindAdvantage | A String specifying the wind advantage
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableWeatherInfoCI Constructor

Initializes a new instance of the ExportableWeatherInfoCI class

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ExportableWeatherInfoCI()
See Also

Reference

ExportableWeatherInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableWeatherInfoCI Properties

The ExportableWeatherInfoCI type exposes the following members.

Properties
 | Name | Description
Public property | Pitch | A String specifying the pitch
Public property | TemperatureCelsius | A Int32 specifying the temperature
Public property | WeatherConditions | A String specifying the weather conditions
Public property | Wind | A String specifying the wind
Public property | WindAdvantage | A String specifying the wind advantage
Top
See Also

Reference

ExportableWeatherInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableWeatherInfoCI.Pitch Property

ExportableWeatherInfoCIPitch Property

A String specifying the pitch

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Pitch { get; set; }

Property Value

String
See Also

Reference

ExportableWeatherInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableWeatherInfoCI.TemperatureCelsius Property

ExportableWeatherInfoCITemperatureCelsius Property

A Int32 specifying the temperature

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int? TemperatureCelsius { get; set; }

Property Value

Nullable Int32
See Also

Reference

ExportableWeatherInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableWeatherInfoCI.WeatherConditions Property

ExportableWeatherInfoCIWeatherConditions Property

A String specifying the weather conditions

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string WeatherConditions { get; set; }

Property Value

String
See Also

Reference

ExportableWeatherInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableWeatherInfoCI.Wind Property

ExportableWeatherInfoCIWind Property

A String specifying the wind

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Wind { get; set; }

Property Value

String
See Also

Reference

ExportableWeatherInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableWeatherInfoCI.WindAdvantage Property

ExportableWeatherInfoCIWindAdvantage Property

A String specifying the wind advantage

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string WindAdvantage { get; set; }

Property Value

String
See Also

Reference

ExportableWeatherInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


ExportableWeatherInfoCI Methods

The ExportableWeatherInfoCI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportableWeatherInfoCI Class
Sportradar.OddsFeed.SDK.Entities.REST.Caching.Exportable Namespace


Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace

Interfaces
 | Interface | Description
Public interface | IAvailableSelections | Provides an available selections for a particular event
Public interface | IAvailableSelectionsFilter | Provides an available selections for a particular event
Public interface | ICalculation | Provides a probability calculation
Public interface | ICalculationFilter | Provides a probability calculation filter
Public interface | IMarket | Provides an available selections for a particular market
Public interface | IMarketFilter | Provides an available selections for a particular market
Public interface | IOutcomeFilter | Provides an outcomes
Public interface | ISelection | Provides an requested selection


IAvailableSelections Interface

Provides an available selections for a particular event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IAvailableSelections

The IAvailableSelections type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets the URN of the event
Public property | Markets | Gets the list of markets for this event
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IAvailableSelections Properties

The IAvailableSelections type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets the URN of the event
Public property | Markets | Gets the list of markets for this event
Top
See Also

Reference

IAvailableSelections Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IAvailableSelections.Event Property

IAvailableSelectionsEvent Property

Gets the URN of the event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Event { get; }

Property Value

URN
See Also

Reference

IAvailableSelections Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IAvailableSelections.Markets Property

IAvailableSelectionsMarkets Property

Gets the list of markets for this event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IMarket> Markets { get; }

Property Value

IEnumerable IMarket
See Also

Reference

IAvailableSelections Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IAvailableSelectionsFilter Interface

Provides an available selections for a particular event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IAvailableSelectionsFilter

The IAvailableSelectionsFilter type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets the URN of the event
Public property | Markets | Gets the list of markets for this event
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IAvailableSelectionsFilter Properties

The IAvailableSelectionsFilter type exposes the following members.

Properties
 | Name | Description
Public property | Event | Gets the URN of the event
Public property | Markets | Gets the list of markets for this event
Top
See Also

Reference

IAvailableSelectionsFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IAvailableSelectionsFilter.Event Property

IAvailableSelectionsFilterEvent Property

Gets the URN of the event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN Event { get; }

Property Value

URN
See Also

Reference

IAvailableSelectionsFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IAvailableSelectionsFilter.Markets Property

IAvailableSelectionsFilterMarkets Property

Gets the list of markets for this event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IMarketFilter> Markets { get; }

Property Value

IEnumerable IMarketFilter
See Also

Reference

IAvailableSelectionsFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ICalculation Interface

Provides a probability calculation

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICalculation

The ICalculation type exposes the following members.

Properties
 | Name | Description
Public property | AvailableSelections | The available selections
Public property | GeneratedAt | DateTime when API response was generated
Public property | Odds | Gets the odds
Public property | Probability | Gets the probability
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ICalculation Properties

The ICalculation type exposes the following members.

Properties
 | Name | Description
Public property | AvailableSelections | The available selections
Public property | GeneratedAt | DateTime when API response was generated
Public property | Odds | Gets the odds
Public property | Probability | Gets the probability
Top
See Also

Reference

ICalculation Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ICalculation.AvailableSelections Property

ICalculationAvailableSelections Property

The available selections

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IAvailableSelections> AvailableSelections { get; }

Property Value

IEnumerable IAvailableSelections
See Also

Reference

ICalculation Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ICalculation.GeneratedAt Property

ICalculationGeneratedAt Property

DateTime when API response was generated

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime? GeneratedAt { get; }

Property Value

Nullable DateTime
See Also

Reference

ICalculation Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ICalculation.Odds Property

ICalculationOdds Property

Gets the odds

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double Odds { get; }

Property Value

Double
See Also

Reference

ICalculation Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ICalculation.Probability Property

ICalculationProbability Property

Gets the probability

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double Probability { get; }

Property Value

Double
See Also

Reference

ICalculation Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ICalculationFilter Interface

Provides a probability calculation filter

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ICalculationFilter

The ICalculationFilter type exposes the following members.

Properties
 | Name | Description
Public property | AvailableSelections | The available selections
Public property | GeneratedAt | DateTime when API response was generated
Public property | Odds | Gets the odds
Public property | Probability | Gets the probability
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ICalculationFilter Properties

The ICalculationFilter type exposes the following members.

Properties
 | Name | Description
Public property | AvailableSelections | The available selections
Public property | GeneratedAt | DateTime when API response was generated
Public property | Odds | Gets the odds
Public property | Probability | Gets the probability
Top
See Also

Reference

ICalculationFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ICalculationFilter.AvailableSelections Property

ICalculationFilterAvailableSelections Property

The available selections

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IAvailableSelectionsFilter> AvailableSelections { get; }

Property Value

IEnumerable IAvailableSelectionsFilter
See Also

Reference

ICalculationFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ICalculationFilter.GeneratedAt Property

ICalculationFilterGeneratedAt Property

DateTime when API response was generated

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime? GeneratedAt { get; }

Property Value

Nullable DateTime
See Also

Reference

ICalculationFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ICalculationFilter.Odds Property

ICalculationFilterOdds Property

Gets the odds

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double Odds { get; }

Property Value

Double
See Also

Reference

ICalculationFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ICalculationFilter.Probability Property

ICalculationFilterProbability Property

Gets the probability

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
double Probability { get; }

Property Value

Double
See Also

Reference

ICalculationFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IMarket Interface

Provides an available selections for a particular market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarket

The IMarket type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the id of the market
Public property | Outcomes | Gets the outcomes for this market
Public property | Specifiers | Gets the specifiers for this market
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IMarket Properties

The IMarket type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the id of the market
Public property | Outcomes | Gets the outcomes for this market
Public property | Specifiers | Gets the specifiers for this market
Top
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IMarket.Id Property

IMarketId Property

Gets the id of the market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Id { get; }

Property Value

Int32
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IMarket.Outcomes Property

IMarketOutcomes Property

Gets the outcomes for this market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<string> Outcomes { get; }

Property Value

IEnumerable String
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IMarket.Specifiers Property

IMarketSpecifiers Property

Gets the specifiers for this market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Specifiers { get; }

Property Value

String
See Also

Reference

IMarket Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IMarketFilter Interface

Provides an available selections for a particular market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketFilter

The IMarketFilter type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the id of the market
Public property | IsConflict | Value indicating if this market is in conflict
Public property | Outcomes | Gets the outcomes for this market
Public property | Specifiers | Gets the specifiers for this market
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IMarketFilter Properties

The IMarketFilter type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the id of the market
Public property | IsConflict | Value indicating if this market is in conflict
Public property | Outcomes | Gets the outcomes for this market
Public property | Specifiers | Gets the specifiers for this market
Top
See Also

Reference

IMarketFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IMarketFilter.Id Property

IMarketFilterId Property

Gets the id of the market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Id { get; }

Property Value

Int32
See Also

Reference

IMarketFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IMarketFilter.IsConflict Property

IMarketFilterIsConflict Property

Value indicating if this market is in conflict

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool? IsConflict { get; }

Property Value

Nullable Boolean
See Also

Reference

IMarketFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IMarketFilter.Outcomes Property

IMarketFilterOutcomes Property

Gets the outcomes for this market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IOutcomeFilter> Outcomes { get; }

Property Value

IEnumerable IOutcomeFilter
See Also

Reference

IMarketFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IMarketFilter.Specifiers Property

IMarketFilterSpecifiers Property

Gets the specifiers for this market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Specifiers { get; }

Property Value

String
See Also

Reference

IMarketFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IOutcomeFilter Interface

Provides an outcomes

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcomeFilter

The IOutcomeFilter type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the id of the outcome
Public property | IsConflict | Value indicating if this outcome is in conflict
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IOutcomeFilter Properties

The IOutcomeFilter type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the id of the outcome
Public property | IsConflict | Value indicating if this outcome is in conflict
Top
See Also

Reference

IOutcomeFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IOutcomeFilter.Id Property

IOutcomeFilterId Property

Gets the id of the outcome

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Id { get; }

Property Value

String
See Also

Reference

IOutcomeFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


IOutcomeFilter.IsConflict Property

IOutcomeFilterIsConflict Property

Value indicating if this outcome is in conflict

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool? IsConflict { get; }

Property Value

Nullable Boolean
See Also

Reference

IOutcomeFilter Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ISelection Interface

Provides an requested selection

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISelection

The ISelection type exposes the following members.

Properties
 | Name | Description
Public property | EventId | Gets the event id.
Public property | MarketId | Gets the market id.
Public property | OutcomeId | Gets the outcome id.
Public property | Specifiers | Gets the specifiers.
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ISelection Properties

The ISelection type exposes the following members.

Properties
 | Name | Description
Public property | EventId | Gets the event id.
Public property | MarketId | Gets the market id.
Public property | OutcomeId | Gets the outcome id.
Public property | Specifiers | Gets the specifiers.
Top
See Also

Reference

ISelection Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ISelection.EventId Property

ISelectionEventId Property

Gets the event id.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN EventId { get; }

Property Value

URN
See Also

Reference

ISelection Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ISelection.MarketId Property

ISelectionMarketId Property

Gets the market id.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int MarketId { get; }

Property Value

Int32
See Also

Reference

ISelection Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ISelection.OutcomeId Property

ISelectionOutcomeId Property

Gets the outcome id.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string OutcomeId { get; }

Property Value

String
See Also

Reference

ISelection Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


ISelection.Specifiers Property

ISelectionSpecifiers Property

Gets the specifiers.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.CustomBet
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Specifiers { get; }

Property Value

String
See Also

Reference

ISelection Interface
Sportradar.OddsFeed.SDK.Entities.REST.CustomBet Namespace


Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace

Enumerations
 | Enumeration | Description
Public enumeration | BonusDrumType | Enumeration of possible bonus drum types
Public enumeration | BookingStatus | Enumerates values providing information on the booking status of an event
Public enumeration | CoveredFrom | Enumeration of possible coverage locations
Public enumeration | DrawStatus | Enumeration of possible draw statuses
Public enumeration | DrawType | Enumeration of possible draw types
Public enumeration | EventStatus | Describes a high-level status of the sport event
Public enumeration | HomeAway | An indication if the associated entity is home/away
Public enumeration | OutcomeResult | An indication of the outcome result
Public enumeration | PeriodType | Enumeration of all possible period types
Public enumeration | PlayerHand | Enumeration of possible player hand
Public enumeration | ReportingStatus | An enum describing the reporting status of a sport event
Public enumeration | SportEventType | Enumerates available types of sport event types
Public enumeration | StageType | An enumeration of possible stage types
Public enumeration | TimeType | Enumeration of possible time types
Public enumeration | VoidFactor | Specifies the void factor of the associated outcome. The value indicates the percentage of the stake that should be voided (returned to the punter).


BonusDrumType Enumeration

Enumeration of possible bonus drum types

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum BonusDrumType
Members
Member name | Value | Description
Same | 0 | The same
Additional | 1 | The additional
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


BookingStatus Enumeration

Enumerates values providing information on the booking status of an event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum BookingStatus
Members
Member name | Value | Description
Buyable | 0 | Indicates if the associated event is buyable
Bookable | 1 | Indicates that the associated event is not booked and information associated with it will not be provided, but the event could be booked
Booked | 2 | Indicates that the associated event is booked and information associated with it will be provided
Unavailable | 3 | Indicates that the associated event is not available for booking
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


CoveredFrom Enumeration

Enumeration of possible coverage locations

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum CoveredFrom
Members
Member name | Value | Description
Tv | 0 | Covered from TV
Venue | 1 | Covered from venue
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


DrawStatus Enumeration

Enumeration of possible draw statuses

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum DrawStatus
Members
Member name | Value | Description
Open | 0 | The open
Closed | 1 | The closed
Finished | 2 | The finished
Cancelled | 3 | The cancelled
Unknown | 4 | The unknown
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


DrawType Enumeration

Enumeration of possible draw types

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum DrawType
Members
Member name | Value | Description
Drum | 0 | The drum
Rng | 1 | The RNG
Unknown | 2 | The unknown
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


EventStatus Enumeration

Describes a high-level status of the sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum EventStatus
Members
Member name | Value | Description
Not_Started | 0 | Indicates that the associated sport event has not yet been started
Live | 1 | Indicates that the associated sport event is currently live (the match could be over-time, extended time or between periods too)
Suspended | 2 | Indicates that the associated sport event has already been started, but is currently suspended
Ended | 3 | Indicates that the associated sport event has already ended according to our own data, the final results may not be ready yet
Closed | 4 | Indicates that the associated sport event has already ended and no more changes for this event will be transmitted by the system (event closed)
Cancelled | 5 | The sport event has been cancelled, the event will not take place, there will be no results
Delayed | 6 | If a match has passed its scheduled start time but is delayed, unknown when it will start this is something that often happens in Tennis
Interrupted | 7 | Indicates that the associated sport event is interrupted. Interruption is expected to be just a few minutes. Longer interruptions may lead to a match being suspended, or possibly postponed.
Postponed | 8 | Indicates that the associated sport event is postponed
Abandoned | 9 | Sportradar aborts scouting the match - this means there will be no live reporting; the match will likely take place anyhow, and after the match has been played Sportradar will likely enter the results and the match will be moved to closed/finished
Unknown | 10 | If a hitherto unsupported sport-event-status is received
MatchAboutToStart | 11 | The match is about to start
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


HomeAway Enumeration

An indication if the associated entity is home/away

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum HomeAway
Members
Member name | Value | Description
Home | 0 | The associated entity is home
Away | 1 | The associated entity is away
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


OutcomeResult Enumeration

An indication of the outcome result

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum OutcomeResult
Members
Member name | Value | Description
Lost | 0 | Lost
Won | 1 | Won
UndecidedYet | 2 | Undecided yet
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


PeriodType Enumeration

Enumeration of all possible period types

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum PeriodType
Members
Member name | Value | Description
RegularPeriod | 0 | The regular period
Overtime | 1 | The overtime
Penalties | 2 | The penalties
Other | 3 | The other
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


PlayerHand Enumeration

Enumeration of possible player hand

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum PlayerHand
Members
Member name | Value | Description
Left | 0 | The left hand player
Right | 1 | The right hand player
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


ReportingStatus Enumeration

An enum describing the reporting status of a sport event

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum ReportingStatus
Members
Member name | Value | Description
NotAvailable | 0 | The reporting status of the sport event is not available
Live | 1 | The reporting status of the sport event is currently live
Suspended | -1 | The reporting status of the sport event is suspended or temporary lost contact
Unknown | 99 | The reporting status of the sport event is unknown
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


SportEventType Enumeration

Enumerates available types of sport event types

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum SportEventType
Members
Member name | Value | Description
Parent | 0 | Indicates a parent sport event type (multi-stage race event, ...)
Child | 1 | Indicates a child sport event type(a specific stage in multi-stage race event, ...)
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


StageType Enumeration

An enumeration of possible stage types

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum StageType
Members
Member name | Value | Description
Parent | 0 | The parent
Child | 1 | The child
Event | 2 | The event
Round | 3 | The round
Season | 4 | The season
CompetitionGroup | 5 | The competition group
Discipline | 6 | The discipline
Race | 7 | The race
Stage | 8 | The stage
Practice | 9 | The practice
Qualifying | 10 | The qualifying
QualifyingPart | 11 | The qualifying part
Lap | 12 | The lap
Prologue | 13 | The prologue
Run | 14 | The run
SprintRace | 15 | The sprint race
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


TimeType Enumeration

Enumeration of possible time types

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum TimeType
Members
Member name | Value | Description
Interval | 0 | The interval
Fixed | 1 | The fixed
Unknown | 2 | The unknown
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


VoidFactor Enumeration

Specifies the void factor of the associated outcome. The value indicates the percentage of the stake that should be voided (returned to the punter).

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Enums
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum VoidFactor
Members
Member name | Value | Description
Zero | 0 | Indicates that the entire bet(stake) should be settled according to the result of the outcome
Half | 1 | Indicates that the half of bet(stake) should be settled according to the result of the outcome and the other have should be voided (returned to the punter)
One | 2 | Indicates that the entire bet(stake) should be voided (returned to the punter)
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Enums Namespace


Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace

Interfaces
 | Interface | Description
Public interface | IMarketAttribute | Represents market attribute used to provide additional information about a market
Public interface | IMarketDescription | Defines a contract implemented by classes representing market description
Public interface | IOutcomeDescription | Defines a contract implemented by classes representing betting outcome description
Public interface | ISpecifier | Defines a contract implemented by classes representing market / outright / outcome specifiers representing a part of unique identifiers


IMarketAttribute Interface

Represents market attribute used to provide additional information about a market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketAttribute

The IMarketAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the attribute description
Public property | Name | Gets the attribute name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketAttribute Properties

The IMarketAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the attribute description
Public property | Name | Gets the attribute name
Top
See Also

Reference

IMarketAttribute Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketAttribute.Description Property

IMarketAttributeDescription Property

Gets the attribute description

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Description { get; }

Property Value

String
See Also

Reference

IMarketAttribute Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketAttribute.Name Property

IMarketAttributeName Property

Gets the attribute name

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

String
See Also

Reference

IMarketAttribute Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription Interface

Defines a contract implemented by classes representing market description

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketDescription

The IMarketDescription type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets the IEnumerableT representing market attributes providing additional information about the market.
Public property | Groups | Gets a list of groups to which the market belongs to
Public property | Id | Gets the id of the market described by the current instance
Public property | IncludesOutcomesOfType | Obsolete. Gets the includes_outcomes_of_type market attribute - an indication of which type of outcomes the market includes
Public property | Mappings | Gets the IEnumerableT representing the mappings of the market described by the current instance
Public property | Outcomes | Gets the IEnumerableT describing the outcomes of the market described by the current instance
Public property | OutcomeType | Gets the outcome_type market attribute - an indication of which type of outcomes the market includes
Public property | Specifiers | Gets the IEnumerableT representing the specifiers of the market described by the current instance
Top
Methods
Name Description
Public method GetDescription Gets the description of the market description in the language specified by the passed
C#
Copy
culture
Public method GetName Gets the name of the market description in the language specified by the passed
C#
Copy
culture
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription Properties

The IMarketDescription type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets the IEnumerableT representing market attributes providing additional information about the market.
Public property | Groups | Gets a list of groups to which the market belongs to
Public property | Id | Gets the id of the market described by the current instance
Public property | IncludesOutcomesOfType | Obsolete. Gets the includes_outcomes_of_type market attribute - an indication of which type of outcomes the market includes
Public property | Mappings | Gets the IEnumerableT representing the mappings of the market described by the current instance
Public property | Outcomes | Gets the IEnumerableT describing the outcomes of the market described by the current instance
Public property | OutcomeType | Gets the outcome_type market attribute - an indication of which type of outcomes the market includes
Public property | Specifiers | Gets the IEnumerableT representing the specifiers of the market described by the current instance
Top
See Also

Reference

IMarketDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription.Attributes Property

IMarketDescriptionAttributes Property

Gets the IEnumerableT representing market attributes providing additional information about the market.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IMarketAttribute> Attributes { get; }

Property Value

IEnumerable IMarketAttribute
See Also

Reference

IMarketDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription.Groups Property

IMarketDescriptionGroups Property

Gets a list of groups to which the market belongs to

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<string> Groups { get; }

Property Value

IEnumerable String
See Also

Reference

IMarketDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription.Id Property

IMarketDescriptionId Property

Gets the id of the market described by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long Id { get; }

Property Value

Int64
See Also

Reference

IMarketDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription.IncludesOutcomesOfType Property

IMarketDescriptionIncludesOutcomesOfType Property

Note: This API is now obsolete.

Gets the includes_outcomes_of_type market attribute - an indication of which type of outcomes the market includes

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Use OutcomeType")]
string IncludesOutcomesOfType { get; }

Property Value

String
See Also

Reference

IMarketDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription.Mappings Property

IMarketDescriptionMappings Property

Gets the IEnumerableT representing the mappings of the market described by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IMarketMappingData> Mappings { get; }

Property Value

IEnumerable IMarketMappingData
See Also

Reference

IMarketDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription.Outcomes Property

IMarketDescriptionOutcomes Property

Gets the IEnumerableT describing the outcomes of the market described by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IOutcomeDescription> Outcomes { get; }

Property Value

IEnumerable IOutcomeDescription
See Also

Reference

IMarketDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription.OutcomeType Property

IMarketDescriptionOutcomeType Property

Gets the outcome_type market attribute - an indication of which type of outcomes the market includes

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string OutcomeType { get; }

Property Value

String
See Also

Reference

IMarketDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription.Specifiers Property

IMarketDescriptionSpecifiers Property

Gets the IEnumerableT representing the specifiers of the market described by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<ISpecifier> Specifiers { get; }

Property Value

IEnumerable ISpecifier
See Also

Reference

IMarketDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription Methods

The IMarketDescription type exposes the following members.

Methods
Name Description
Public method GetDescription Gets the description of the market description in the language specified by the passed
C#
Copy
culture
Public method GetName Gets the name of the market description in the language specified by the passed
C#
Copy
culture
Top
See Also

Reference

IMarketDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription.GetDescription Method

IMarketDescriptionGetDescription Method

Gets the description of the market description in the language specified by the passed
C#
Copy
culture

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetDescription(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language of the retrieved description

Return Value

String

[Missing <returns> documentation for "M:Sportradar.OddsFeed.SDK.Entities.REST.Market.IMarketDescription.GetDescription(System.Globalization.CultureInfo)"]

See Also

Reference

IMarketDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IMarketDescription.GetName Method

IMarketDescriptionGetName Method

Gets the name of the market description in the language specified by the passed
C#
Copy
culture

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language of the retrieved name

Return Value

String

[Missing <returns> documentation for "M:Sportradar.OddsFeed.SDK.Entities.REST.Market.IMarketDescription.GetName(System.Globalization.CultureInfo)"]

See Also

Reference

IMarketDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IOutcomeDescription Interface

Defines a contract implemented by classes representing betting outcome description

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcomeDescription

The IOutcomeDescription type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a value uniquely identifying the current outcome within the market
Top
Methods
 | Name | Description
Public method | GetDescription | Gets the description of the betting outcome represented by the current instance
Public method | GetName | Gets the name of the betting outcome represented by the current instance
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IOutcomeDescription Properties

The IOutcomeDescription type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets a value uniquely identifying the current outcome within the market
Top
See Also

Reference

IOutcomeDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IOutcomeDescription.Id Property

IOutcomeDescriptionId Property

Gets a value uniquely identifying the current outcome within the market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Id { get; }

Property Value

String
See Also

Reference

IOutcomeDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IOutcomeDescription Methods

The IOutcomeDescription type exposes the following members.

Methods
 | Name | Description
Public method | GetDescription | Gets the description of the betting outcome represented by the current instance
Public method | GetName | Gets the name of the betting outcome represented by the current instance
Top
See Also

Reference

IOutcomeDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IOutcomeDescription.GetDescription Method

IOutcomeDescriptionGetDescription Method

Gets the description of the betting outcome represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetDescription(
    CultureInfo culture
)

Parameters

culture CultureInfo

[Missing <param name="culture"/> documentation for "M:Sportradar.OddsFeed.SDK.Entities.REST.Market.IOutcomeDescription.GetDescription(System.Globalization.CultureInfo)"]

Return Value

String

[Missing <returns> documentation for "M:Sportradar.OddsFeed.SDK.Entities.REST.Market.IOutcomeDescription.GetDescription(System.Globalization.CultureInfo)"]

See Also

Reference

IOutcomeDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


IOutcomeDescription.GetName Method

IOutcomeDescriptionGetName Method

Gets the name of the betting outcome represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo

[Missing <param name="culture"/> documentation for "M:Sportradar.OddsFeed.SDK.Entities.REST.Market.IOutcomeDescription.GetName(System.Globalization.CultureInfo)"]

Return Value

String

[Missing <returns> documentation for "M:Sportradar.OddsFeed.SDK.Entities.REST.Market.IOutcomeDescription.GetName(System.Globalization.CultureInfo)"]

See Also

Reference

IOutcomeDescription Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


ISpecifier Interface

Defines a contract implemented by classes representing market / outright / outcome specifiers representing a part of unique identifiers

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface ISpecifier

The ISpecifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the specifier represented by the current instance
Public property | Type | Gets the type name of the specifier represented by the current instance
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


ISpecifier Properties

The ISpecifier type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the specifier represented by the current instance
Public property | Type | Gets the type name of the specifier represented by the current instance
Top
See Also

Reference

ISpecifier Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


ISpecifier.Name Property

ISpecifierName Property

Gets the name of the specifier represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

String
See Also

Reference

ISpecifier Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


ISpecifier.Type Property

ISpecifierType Property

Gets the type name of the specifier represented by the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.Market
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Type { get; }

Property Value

String
See Also

Reference

ISpecifier Interface
Sportradar.OddsFeed.SDK.Entities.REST.Market Namespace


Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace

Classes
 | Class | Description
Public class | LcooMarketMapping | Implementation of the IMarketMapping for the LiveCycleOfOdds feed
Public class | LoMarketMapping | Implementation of the IMarketMapping for the LiveOdds feed
Interfaces
 | Interface | Description
Public interface | IMarketMapping | Defines a contract implemented by classes representing mapping ids of markets and outcomes
Public interface | IMarketMappingData | Represents mapping information used to map markets and outright to the sport / producer to which they belong
Public interface | IOutcomeMapping | Defines a contract implemented by classes representing mapping id of outcome
Public interface | IOutcomeMappingData | Represents mapping information used to map market outcomes


IMarketMapping Interface

Defines a contract implemented by classes representing mapping ids of markets and outcomes

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketMapping

The IMarketMapping type exposes the following members.

Properties
 | Name | Description
Public property | Sov | Gets the special odds value
Public property | TypeId | Gets the type identifier
Top
Remarks
The result is LoMarketMapping or LcooMarketMapping
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMapping Properties

The IMarketMapping type exposes the following members.

Properties
 | Name | Description
Public property | Sov | Gets the special odds value
Public property | TypeId | Gets the type identifier
Top
See Also

Reference

IMarketMapping Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMapping.Sov Property

IMarketMappingSov Property

Gets the special odds value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Sov { get; }

Property Value

String
See Also

Reference

IMarketMapping Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMapping.TypeId Property

IMarketMappingTypeId Property

Gets the type identifier

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int TypeId { get; }

Property Value

Int32
See Also

Reference

IMarketMapping Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData Interface

Represents mapping information used to map markets and outright to the sport / producer to which they belong

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IMarketMappingData

The IMarketMappingData type exposes the following members.

Properties
 | Name | Description
Public property | MarketId | Gets the id of the market associated with the current instance
Public property | MarketSubTypeId | Gets the market sub type identifier
Public property | MarketTypeId | Gets the market type identifier
Public property | OutcomeMappings | Gets the outcome mappings
Public property | ProducerId | Obsolete. Gets the id of the producer to which the associated market / outright belongs to
Public property | ProducerIds | Gets the ids of the producers to which the associated market / outright belongs to
Public property | SovTemplate | Gets the special odds value template value
Public property | SportId | Gets the id of the sport to which the associated market / outright belongs to
Public property | ValidFor | Gets the valid_for value
Top
Methods
 | Name | Description
Public method | CanMap | Determines whether the current mapping can map market with provided specifiers associated with provided producer and sport
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData Properties

The IMarketMappingData type exposes the following members.

Properties
 | Name | Description
Public property | MarketId | Gets the id of the market associated with the current instance
Public property | MarketSubTypeId | Gets the market sub type identifier
Public property | MarketTypeId | Gets the market type identifier
Public property | OutcomeMappings | Gets the outcome mappings
Public property | ProducerId | Obsolete. Gets the id of the producer to which the associated market / outright belongs to
Public property | ProducerIds | Gets the ids of the producers to which the associated market / outright belongs to
Public property | SovTemplate | Gets the special odds value template value
Public property | SportId | Gets the id of the sport to which the associated market / outright belongs to
Public property | ValidFor | Gets the valid_for value
Top
See Also

Reference

IMarketMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData.MarketId Property

IMarketMappingDataMarketId Property

Gets the id of the market associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string MarketId { get; }

Property Value

String
See Also

Reference

IMarketMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData.MarketSubTypeId Property

IMarketMappingDataMarketSubTypeId Property

Gets the market sub type identifier

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int? MarketSubTypeId { get; }

Property Value

Nullable Int32
See Also

Reference

IMarketMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData.MarketTypeId Property

IMarketMappingDataMarketTypeId Property

Gets the market type identifier

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int MarketTypeId { get; }

Property Value

Int32
See Also

Reference

IMarketMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData.OutcomeMappings Property

IMarketMappingDataOutcomeMappings Property

Gets the outcome mappings

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<IOutcomeMappingData> OutcomeMappings { get; }

Property Value

IEnumerable IOutcomeMappingData
See Also

Reference

IMarketMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData.ProducerId Property

IMarketMappingDataProducerId Property

Note: This API is now obsolete.

Gets the id of the producer to which the associated market / outright belongs to

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Changed with ProducerIds property")]
int ProducerId { get; }

Property Value

Int32
See Also

Reference

IMarketMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData.ProducerIds Property

IMarketMappingDataProducerIds Property

Gets the ids of the producers to which the associated market / outright belongs to

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IEnumerable<int> ProducerIds { get; }

Property Value

IEnumerable Int32
The producer ids
See Also

Reference

IMarketMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData.SovTemplate Property

IMarketMappingDataSovTemplate Property

Gets the special odds value template value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string SovTemplate { get; }

Property Value

String
See Also

Reference

IMarketMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData.SportId Property

IMarketMappingDataSportId Property

Gets the id of the sport to which the associated market / outright belongs to

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
URN SportId { get; }

Property Value

URN
See Also

Reference

IMarketMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData.ValidFor Property

IMarketMappingDataValidFor Property

Gets the valid_for value

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string ValidFor { get; }

Property Value

String
See Also

Reference

IMarketMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData Methods

The IMarketMappingData type exposes the following members.

Methods
 | Name | Description
Public method | CanMap | Determines whether the current mapping can map market with provided specifiers associated with provided producer and sport
Top
See Also

Reference

IMarketMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IMarketMappingData.CanMap Method

IMarketMappingDataCanMap Method

Determines whether the current mapping can map market with provided specifiers associated with provided producer and sport

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool CanMap(
    int producerId,
    URN sportId,
    IReadOnlyDictionary<string, string> specifiers
)

Parameters

producerId Int32
The id of the IProducer associated with the market
sportId URN
The URN specifying the sport associated with the market
specifiers IReadOnlyDictionary String, String
The market specifiers

Return Value

Boolean
True if the current mapping can be used to map the specified market. False otherwise
Exceptions
Exception | Condition
InvalidOperationException | The provided specifiers are not valid
See Also

Reference

IMarketMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMapping Interface

Defines a contract implemented by classes representing mapping id of outcome

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcomeMapping

The IOutcomeMapping type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the identifier
Public property | MarketId | Gets the id of the mapped market
Top
Methods
 | Name | Description
Public method | GetName | Gets the name of the outcome in the specified language
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMapping Properties

The IOutcomeMapping type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the identifier
Public property | MarketId | Gets the id of the mapped market
Top
See Also

Reference

IOutcomeMapping Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMapping.Id Property

IOutcomeMappingId Property

Gets the identifier

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Id { get; }

Property Value

String
See Also

Reference

IOutcomeMapping Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMapping.MarketId Property

IOutcomeMappingMarketId Property

Gets the id of the mapped market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string MarketId { get; }

Property Value

String
The id of the mapped market
See Also

Reference

IOutcomeMapping Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMapping Methods

The IOutcomeMapping type exposes the following members.

Methods
 | Name | Description
Public method | GetName | Gets the name of the outcome in the specified language
Top
See Also

Reference

IOutcomeMapping Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMapping.GetName Method

IOutcomeMappingGetName Method

Gets the name of the outcome in the specified language

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetName(
    CultureInfo culture
)

Parameters

culture CultureInfo
A CultureInfo specifying the language in which to get the name

Return Value

String
The name in the specific language
See Also

Reference

IOutcomeMapping Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMappingData Interface

Represents mapping information used to map market outcomes

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IOutcomeMappingData

The IOutcomeMappingData type exposes the following members.

Properties
 | Name | Description
Public property | MarketId | Gets the mapped market identifier
Public property | OutcomeId | Gets the id of the outcome
Public property | ProducerOutcomeId | Gets the producer outcome identifier
Top
Methods
 | Name | Description
Public method | GetProducerOutcomeName | Gets the name of the producer outcome in specified language
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMappingData Properties

The IOutcomeMappingData type exposes the following members.

Properties
 | Name | Description
Public property | MarketId | Gets the mapped market identifier
Public property | OutcomeId | Gets the id of the outcome
Public property | ProducerOutcomeId | Gets the producer outcome identifier
Top
See Also

Reference

IOutcomeMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMappingData.MarketId Property

IOutcomeMappingDataMarketId Property

Gets the mapped market identifier

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string MarketId { get; }

Property Value

String
The mapped market identifier
See Also

Reference

IOutcomeMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMappingData.OutcomeId Property

IOutcomeMappingDataOutcomeId Property

Gets the id of the outcome

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string OutcomeId { get; }

Property Value

String
See Also

Reference

IOutcomeMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMappingData.ProducerOutcomeId Property

IOutcomeMappingDataProducerOutcomeId Property

Gets the producer outcome identifier

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string ProducerOutcomeId { get; }

Property Value

String
See Also

Reference

IOutcomeMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMappingData Methods

The IOutcomeMappingData type exposes the following members.

Methods
 | Name | Description
Public method | GetProducerOutcomeName | Gets the name of the producer outcome in specified language
Top
See Also

Reference

IOutcomeMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


IOutcomeMappingData.GetProducerOutcomeName Method

IOutcomeMappingDataGetProducerOutcomeName Method

Gets the name of the producer outcome in specified language

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string GetProducerOutcomeName(
    CultureInfo culture
)

Parameters

culture CultureInfo

[Missing <param name="culture"/> documentation for "M:Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping.IOutcomeMappingData.GetProducerOutcomeName(System.Globalization.CultureInfo)"]

Return Value

String

[Missing <returns> documentation for "M:Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping.IOutcomeMappingData.GetProducerOutcomeName(System.Globalization.CultureInfo)"]

See Also

Reference

IOutcomeMappingData Interface
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


LcooMarketMapping Class

Implementation of the IMarketMapping for the LiveCycleOfOdds feed
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.MarketMappingLcooMarketMapping

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class LcooMarketMapping : IMarketMapping

The LcooMarketMapping type exposes the following members.

Properties
 | Name | Description
Public property | Sov | Gets the special odds value for the Lcoo market
Public property | TypeId | Gets the TypeId of the Lcoo market
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace
IMarketMapping


LcooMarketMapping Properties

The LcooMarketMapping type exposes the following members.

Properties
 | Name | Description
Public property | Sov | Gets the special odds value for the Lcoo market
Public property | TypeId | Gets the TypeId of the Lcoo market
Top
See Also

Reference

LcooMarketMapping Class
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


LcooMarketMapping.Sov Property

LcooMarketMappingSov Property

Gets the special odds value for the Lcoo market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Sov { get; }

Property Value

String

Implements

IMarketMappingSov
See Also

Reference

LcooMarketMapping Class
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


LcooMarketMapping.TypeId Property

LcooMarketMappingTypeId Property

Gets the TypeId of the Lcoo market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int TypeId { get; }

Property Value

Int32

Implements

IMarketMappingTypeId
See Also

Reference

LcooMarketMapping Class
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


LcooMarketMapping Methods

The LcooMarketMapping type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

LcooMarketMapping Class
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


LcooMarketMapping.ToString Method

LcooMarketMappingToString Method

Returns a string that represents the current object.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
See Also

Reference

LcooMarketMapping Class
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


LoMarketMapping Class

Implementation of the IMarketMapping for the LiveOdds feed
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Entities.REST.MarketMappingLoMarketMapping

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class LoMarketMapping : IMarketMapping

The LoMarketMapping type exposes the following members.

Properties
 | Name | Description
Public property | Sov | Gets the special odds value for the LO market
Public property | SubTypeId | Gets the sub type identifier for the LO market
Public property | TypeId | Gets the TypeId for the LO market
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace
IMarketMapping


LoMarketMapping Properties

The LoMarketMapping type exposes the following members.

Properties
 | Name | Description
Public property | Sov | Gets the special odds value for the LO market
Public property | SubTypeId | Gets the sub type identifier for the LO market
Public property | TypeId | Gets the TypeId for the LO market
Top
See Also

Reference

LoMarketMapping Class
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


LoMarketMapping.Sov Property

LoMarketMappingSov Property

Gets the special odds value for the LO market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Sov { get; }

Property Value

String

Implements

IMarketMappingSov
See Also

Reference

LoMarketMapping Class
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


LoMarketMapping.SubTypeId Property

LoMarketMappingSubTypeId Property

Gets the sub type identifier for the LO market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int SubTypeId { get; }

Property Value

Int32
See Also

Reference

LoMarketMapping Class
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


LoMarketMapping.TypeId Property

LoMarketMappingTypeId Property

Gets the TypeId for the LO market

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int TypeId { get; }

Property Value

Int32

Implements

IMarketMappingTypeId
See Also

Reference

LoMarketMapping Class
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


LoMarketMapping Methods

The LoMarketMapping type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString)
Top
See Also

Reference

LoMarketMapping Class
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


LoMarketMapping.ToString Method

LoMarketMappingToString Method

Returns a string that represents the current object.

Namespace: Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping
Assembly: Sportradar.OddsFeed.SDK.Entities.REST (in Sportradar.OddsFeed.SDK.Entities.REST.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
A string that represents the current object.
See Also

Reference

LoMarketMapping Class
Sportradar.OddsFeed.SDK.Entities.REST.MarketMapping Namespace


Sportradar.OddsFeed.SDK.Messages Namespace

Classes
 | Class | Description
Public class | URN | Represents a Uniform Resource Name
Interfaces
 | Interface | Description
Public interface | IProducer | Defines a contract for producer which use the feed to dispatch messages
Public interface | IProducerManager | Defines a contract implemented by classes used to manage feed producers
Public interface | IProducerV1 | Defines a contract for producer which use the feed to dispatch messages
Public interface | IProducerV2 | Defines a contract for producer which use the feed to dispatch messages
Public interface | IProducerV3 | Defines a contract for producer which use the feed to dispatch messages
Public interface | IRecoveryInfo | Defines a contract for recovery info which contains data about last recovery attempt
Enumerations
 | Enumeration | Description
Public enumeration | ResourceTypeGroup | Enumerates groups of resources represented by the URN


IProducer Interface

Defines a contract for producer which use the feed to dispatch messages

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IProducer

The IProducer type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the producer
Public property | Id | Gets the id of the producer
Public property | IsAvailable | Gets a value indicating whether the producer is available on feed
Public property | IsDisabled | Gets a value indicating whether the producer is disabled
Public property | IsProducerDown | Gets a value indicating whether the producer is marked as down
Public property | LastTimestampBeforeDisconnect | Gets the last timestamp before disconnect for this producer
Public property | MaxInactivitySeconds | Gets the maximum inactivity seconds
Public property | MaxRecoveryTime | Gets the maximum recovery time (in seconds)
Public property | Name | Gets the name of the producer
Public property | TimeOfLastAlive | Obsolete. Gets the time of last alive message received from feed
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages Namespace


IProducer Properties

The IProducer type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the producer
Public property | Id | Gets the id of the producer
Public property | IsAvailable | Gets a value indicating whether the producer is available on feed
Public property | IsDisabled | Gets a value indicating whether the producer is disabled
Public property | IsProducerDown | Gets a value indicating whether the producer is marked as down
Public property | LastTimestampBeforeDisconnect | Gets the last timestamp before disconnect for this producer
Public property | MaxInactivitySeconds | Gets the maximum inactivity seconds
Public property | MaxRecoveryTime | Gets the maximum recovery time (in seconds)
Public property | Name | Gets the name of the producer
Public property | TimeOfLastAlive | Obsolete. Gets the time of last alive message received from feed
Top
See Also

Reference

IProducer Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducer.Description Property

IProducerDescription Property

Gets the description of the producer

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Description { get; }

Property Value

String
The description
See Also

Reference

IProducer Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducer.Id Property

IProducerId Property

Gets the id of the producer

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int Id { get; }

Property Value

Int32
The id
See Also

Reference

IProducer Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducer.IsAvailable Property

IProducerIsAvailable Property

Gets a value indicating whether the producer is available on feed

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsAvailable { get; }

Property Value

Boolean
true if this instance is active; otherwise, false
See Also

Reference

IProducer Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducer.IsDisabled Property

IProducerIsDisabled Property

Gets a value indicating whether the producer is disabled

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsDisabled { get; }

Property Value

Boolean
true if this instance is disabled; otherwise, false
See Also

Reference

IProducer Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducer.IsProducerDown Property

IProducerIsProducerDown Property

Gets a value indicating whether the producer is marked as down

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool IsProducerDown { get; }

Property Value

Boolean
true if this instance is down; otherwise, false
See Also

Reference

IProducer Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducer.LastTimestampBeforeDisconnect Property

IProducerLastTimestampBeforeDisconnect Property

Gets the last timestamp before disconnect for this producer

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
DateTime LastTimestampBeforeDisconnect { get; }

Property Value

DateTime
The last timestamp before disconnect
See Also

Reference

IProducer Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducer.MaxInactivitySeconds Property

IProducerMaxInactivitySeconds Property

Gets the maximum inactivity seconds

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int MaxInactivitySeconds { get; }

Property Value

Int32
The maximum inactivity seconds
See Also

Reference

IProducer Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducer.MaxRecoveryTime Property

IProducerMaxRecoveryTime Property

Gets the maximum recovery time (in seconds)

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int MaxRecoveryTime { get; }

Property Value

Int32
The maximum recovery time (in seconds)
See Also

Reference

IProducer Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducer.Name Property

IProducerName Property

Gets the name of the producer

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string Name { get; }

Property Value

String
The name
See Also

Reference

IProducer Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducer.TimeOfLastAlive Property

IProducerTimeOfLastAlive Property

Note: This API is now obsolete.

Gets the time of last alive message received from feed

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[ObsoleteAttribute("Replaced by LastTimestampBeforeDisconnect")]
DateTime TimeOfLastAlive { get; }

Property Value

DateTime
The time of last alive message
See Also

Reference

IProducer Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager Interface

Defines a contract implemented by classes used to manage feed producers

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IProducerManager

The IProducerManager type exposes the following members.

Properties
 | Name | Description
Public property | Producers | Gets the available producers
Top
Methods
 | Name | Description
Public method | AddTimestampBeforeDisconnect | Sets the timestamp of the last processed message for a specific producer
Public method | DisableProducer | Disables the producer (no recovery will be made and not message will be received)
Public method | Exists(Int32) | Check if the IProducer exists in manager
Public method | Exists(String) | Check if the IProducer exists in manager
Public method | Get(Int32) | Gets the producer if exists, otherwise 'unknown' producer is returned
Public method | Get(String) | Gets the producer by name if exists, otherwise 'unknown' producer is returned
Public method | RemoveTimestampBeforeDisconnect | Removes the timestamp of the last message processed for a specific producer
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager Properties

The IProducerManager type exposes the following members.

Properties
 | Name | Description
Public property | Producers | Gets the available producers
Top
See Also

Reference

IProducerManager Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager.Producers Property

IProducerManagerProducers Property

Gets the available producers

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyCollection<IProducer> Producers { get; }

Property Value

IReadOnlyCollection IProducer
The producers
See Also

Reference

IProducerManager Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager Methods

The IProducerManager type exposes the following members.

Methods
 | Name | Description
Public method | AddTimestampBeforeDisconnect | Sets the timestamp of the last processed message for a specific producer
Public method | DisableProducer | Disables the producer (no recovery will be made and not message will be received)
Public method | Exists(Int32) | Check if the IProducer exists in manager
Public method | Exists(String) | Check if the IProducer exists in manager
Public method | Get(Int32) | Gets the producer if exists, otherwise 'unknown' producer is returned
Public method | Get(String) | Gets the producer by name if exists, otherwise 'unknown' producer is returned
Public method | RemoveTimestampBeforeDisconnect | Removes the timestamp of the last message processed for a specific producer
Top
See Also

Reference

IProducerManager Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager.AddTimestampBeforeDisconnect Method

IProducerManagerAddTimestampBeforeDisconnect Method

Sets the timestamp of the last processed message for a specific producer

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void AddTimestampBeforeDisconnect(
    int id,
    DateTime timestamp
)

Parameters

id Int32
The id of the IProducer for which to set timestamp
timestamp DateTime
A DateTime specifying the message timestamp
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The timestamp is in the future or to far in the past
See Also

Reference

IProducerManager Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager.DisableProducer Method

IProducerManagerDisableProducer Method

Disables the producer (no recovery will be made and not message will be received)

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void DisableProducer(
    int id
)

Parameters

id Int32
The id of the producer
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The id of the producer is not found
See Also

Reference

IProducerManager Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager.Exists Method

IProducerManagerExists Method

Overload List
 | Name | Description
Public method | Exists(Int32) | Check if the IProducer exists in manager
Public method | Exists(String) | Check if the IProducer exists in manager
Top
See Also

Reference

IProducerManager Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager.Exists(Int32) Method

IProducerManagerExists(Int32) Method

Check if the IProducer exists in manager

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool Exists(
    int id
)

Parameters

id Int32
The id to check

Return Value

Boolean
true if exists, false otherwise
See Also

Reference

IProducerManager Interface
Exists Overload
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager.Exists(String) Method

IProducerManagerExists(String) Method

Check if the IProducer exists in manager

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
bool Exists(
    string name
)

Parameters

name String
The name to check

Return Value

Boolean
true if exists, false otherwise
See Also

Reference

IProducerManager Interface
Exists Overload
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager.Get Method

IProducerManagerGet Method

Overload List
 | Name | Description
Public method | Get(Int32) | Gets the producer if exists, otherwise 'unknown' producer is returned
Public method | Get(String) | Gets the producer by name if exists, otherwise 'unknown' producer is returned
Top
See Also

Reference

IProducerManager Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager.Get(Int32) Method

IProducerManagerGet(Int32) Method

Gets the producer if exists, otherwise 'unknown' producer is returned

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IProducer Get(
    int id
)

Parameters

id Int32
The id of the producer to retrieve

Return Value

IProducer
An IProducer
See Also

Reference

IProducerManager Interface
Get Overload
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager.Get(String) Method

IProducerManagerGet(String) Method

Gets the producer by name if exists, otherwise 'unknown' producer is returned

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IProducer Get(
    string name
)

Parameters

name String
The name of the producer to retrieve

Return Value

IProducer
An IProducer
Remarks
Search is case insensitive
See Also

Reference

IProducerManager Interface
Get Overload
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerManager.RemoveTimestampBeforeDisconnect Method

IProducerManagerRemoveTimestampBeforeDisconnect Method

Removes the timestamp of the last message processed for a specific producer

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
void RemoveTimestampBeforeDisconnect(
    int id
)

Parameters

id Int32
An id of the IProducer for which to remove the timestamp
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The id of the producer is not found
See Also

Reference

IProducerManager Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerV1 Interface

Defines a contract for producer which use the feed to dispatch messages

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IProducerV1 : IProducer

The IProducerV1 type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the producer (Inherited from IProducer)
Public property | Id | Gets the id of the producer (Inherited from IProducer)
Public property | IsAvailable | Gets a value indicating whether the producer is available on feed (Inherited from IProducer)
Public property | IsDisabled | Gets a value indicating whether the producer is disabled (Inherited from IProducer)
Public property | IsProducerDown | Gets a value indicating whether the producer is marked as down (Inherited from IProducer)
Public property | LastTimestampBeforeDisconnect | Gets the last timestamp before disconnect for this producer (Inherited from IProducer)
Public property | MaxInactivitySeconds | Gets the maximum inactivity seconds (Inherited from IProducer)
Public property | MaxRecoveryTime | Gets the maximum recovery time (in seconds) (Inherited from IProducer)
Public property | Name | Gets the name of the producer (Inherited from IProducer)
Public property | RecoveryInfo | Gets the recovery info about last recovery attempt
Public property | TimeOfLastAlive | Obsolete. Gets the time of last alive message received from feed (Inherited from IProducer)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages Namespace


IProducerV1 Properties

The IProducerV1 type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the producer (Inherited from IProducer)
Public property | Id | Gets the id of the producer (Inherited from IProducer)
Public property | IsAvailable | Gets a value indicating whether the producer is available on feed (Inherited from IProducer)
Public property | IsDisabled | Gets a value indicating whether the producer is disabled (Inherited from IProducer)
Public property | IsProducerDown | Gets a value indicating whether the producer is marked as down (Inherited from IProducer)
Public property | LastTimestampBeforeDisconnect | Gets the last timestamp before disconnect for this producer (Inherited from IProducer)
Public property | MaxInactivitySeconds | Gets the maximum inactivity seconds (Inherited from IProducer)
Public property | MaxRecoveryTime | Gets the maximum recovery time (in seconds) (Inherited from IProducer)
Public property | Name | Gets the name of the producer (Inherited from IProducer)
Public property | RecoveryInfo | Gets the recovery info about last recovery attempt
Public property | TimeOfLastAlive | Obsolete. Gets the time of last alive message received from feed (Inherited from IProducer)
Top
See Also

Reference

IProducerV1 Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerV1.RecoveryInfo Property

IProducerV1RecoveryInfo Property

Gets the recovery info about last recovery attempt

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IRecoveryInfo RecoveryInfo { get; }

Property Value

IRecoveryInfo
The recovery info about last recovery attempt
See Also

Reference

IProducerV1 Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerV2 Interface

Defines a contract for producer which use the feed to dispatch messages

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IProducerV2 : IProducerV1,
    IProducer

The IProducerV2 type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the producer (Inherited from IProducer)
Public property | Id | Gets the id of the producer (Inherited from IProducer)
Public property | IsAvailable | Gets a value indicating whether the producer is available on feed (Inherited from IProducer)
Public property | IsDisabled | Gets a value indicating whether the producer is disabled (Inherited from IProducer)
Public property | IsProducerDown | Gets a value indicating whether the producer is marked as down (Inherited from IProducer)
Public property | LastTimestampBeforeDisconnect | Gets the last timestamp before disconnect for this producer (Inherited from IProducer)
Public property | MaxInactivitySeconds | Gets the maximum inactivity seconds (Inherited from IProducer)
Public property | MaxRecoveryTime | Gets the maximum recovery time (in seconds) (Inherited from IProducer)
Public property | Name | Gets the name of the producer (Inherited from IProducer)
Public property | RecoveryInfo | Gets the recovery info about last recovery attempt (Inherited from IProducerV1)
Public property | StatefulRecoveryWindow | Gets the stateful recovery window in minutes.
Public property | TimeOfLastAlive | Obsolete. Gets the time of last alive message received from feed (Inherited from IProducer)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages Namespace


IProducerV2 Properties

The IProducerV2 type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the producer (Inherited from IProducer)
Public property | Id | Gets the id of the producer (Inherited from IProducer)
Public property | IsAvailable | Gets a value indicating whether the producer is available on feed (Inherited from IProducer)
Public property | IsDisabled | Gets a value indicating whether the producer is disabled (Inherited from IProducer)
Public property | IsProducerDown | Gets a value indicating whether the producer is marked as down (Inherited from IProducer)
Public property | LastTimestampBeforeDisconnect | Gets the last timestamp before disconnect for this producer (Inherited from IProducer)
Public property | MaxInactivitySeconds | Gets the maximum inactivity seconds (Inherited from IProducer)
Public property | MaxRecoveryTime | Gets the maximum recovery time (in seconds) (Inherited from IProducer)
Public property | Name | Gets the name of the producer (Inherited from IProducer)
Public property | RecoveryInfo | Gets the recovery info about last recovery attempt (Inherited from IProducerV1)
Public property | StatefulRecoveryWindow | Gets the stateful recovery window in minutes.
Public property | TimeOfLastAlive | Obsolete. Gets the time of last alive message received from feed (Inherited from IProducer)
Top
See Also

Reference

IProducerV2 Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerV2.StatefulRecoveryWindow Property

IProducerV2StatefulRecoveryWindow Property

Gets the stateful recovery window in minutes.

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int StatefulRecoveryWindow { get; }

Property Value

Int32
The stateful recovery window in minutes.
See Also

Reference

IProducerV2 Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerV3 Interface

Defines a contract for producer which use the feed to dispatch messages

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IProducerV3 : IProducerV2,
    IProducerV1, IProducer

The IProducerV3 type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the producer (Inherited from IProducer)
Public property | Id | Gets the id of the producer (Inherited from IProducer)
Public property | IsAvailable | Gets a value indicating whether the producer is available on feed (Inherited from IProducer)
Public property | IsDisabled | Gets a value indicating whether the producer is disabled (Inherited from IProducer)
Public property | IsProducerDown | Gets a value indicating whether the producer is marked as down (Inherited from IProducer)
Public property | LastTimestampBeforeDisconnect | Gets the last timestamp before disconnect for this producer (Inherited from IProducer)
Public property | MaxInactivitySeconds | Gets the maximum inactivity seconds (Inherited from IProducer)
Public property | MaxRecoveryTime | Gets the maximum recovery time (in seconds) (Inherited from IProducer)
Public property | Name | Gets the name of the producer (Inherited from IProducer)
Public property | RecoveryInfo | Gets the recovery info about last recovery attempt (Inherited from IProducerV1)
Public property | Scope | Gets the scope of the producer
Public property | StatefulRecoveryWindow | Gets the stateful recovery window in minutes. (Inherited from IProducerV2)
Public property | TimeOfLastAlive | Obsolete. Gets the time of last alive message received from feed (Inherited from IProducer)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages Namespace


IProducerV3 Properties

The IProducerV3 type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the producer (Inherited from IProducer)
Public property | Id | Gets the id of the producer (Inherited from IProducer)
Public property | IsAvailable | Gets a value indicating whether the producer is available on feed (Inherited from IProducer)
Public property | IsDisabled | Gets a value indicating whether the producer is disabled (Inherited from IProducer)
Public property | IsProducerDown | Gets a value indicating whether the producer is marked as down (Inherited from IProducer)
Public property | LastTimestampBeforeDisconnect | Gets the last timestamp before disconnect for this producer (Inherited from IProducer)
Public property | MaxInactivitySeconds | Gets the maximum inactivity seconds (Inherited from IProducer)
Public property | MaxRecoveryTime | Gets the maximum recovery time (in seconds) (Inherited from IProducer)
Public property | Name | Gets the name of the producer (Inherited from IProducer)
Public property | RecoveryInfo | Gets the recovery info about last recovery attempt (Inherited from IProducerV1)
Public property | Scope | Gets the scope of the producer
Public property | StatefulRecoveryWindow | Gets the stateful recovery window in minutes. (Inherited from IProducerV2)
Public property | TimeOfLastAlive | Obsolete. Gets the time of last alive message received from feed (Inherited from IProducer)
Top
See Also

Reference

IProducerV3 Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IProducerV3.Scope Property

IProducerV3Scope Property

Gets the scope of the producer

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
IReadOnlyCollection<string> Scope { get; }

Property Value

IReadOnlyCollection String
The scope
See Also

Reference

IProducerV3 Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IRecoveryInfo Interface

Defines a contract for recovery info which contains data about last recovery attempt

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public interface IRecoveryInfo

The IRecoveryInfo type exposes the following members.

Properties
 | Name | Description
Public property | After | Gets the after timestamp of the recovery or 0 if full recovery was done
Public property | NodeId | Gets the node identifier
Public property | RequestId | Gets the request identifier
Public property | ResponseCode | Gets the response code of the recovery request
Public property | ResponseMessage | Gets the response message of the recovery request
Public property | Timestamp | Gets the timestamp specifying when the recovery was initiated
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages Namespace


IRecoveryInfo Properties

The IRecoveryInfo type exposes the following members.

Properties
 | Name | Description
Public property | After | Gets the after timestamp of the recovery or 0 if full recovery was done
Public property | NodeId | Gets the node identifier
Public property | RequestId | Gets the request identifier
Public property | ResponseCode | Gets the response code of the recovery request
Public property | ResponseMessage | Gets the response message of the recovery request
Public property | Timestamp | Gets the timestamp specifying when the recovery was initiated
Top
See Also

Reference

IRecoveryInfo Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IRecoveryInfo.After Property

IRecoveryInfoAfter Property

Gets the after timestamp of the recovery or 0 if full recovery was done

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long After { get; }

Property Value

Int64
The after
See Also

Reference

IRecoveryInfo Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IRecoveryInfo.NodeId Property

IRecoveryInfoNodeId Property

Gets the node identifier

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int NodeId { get; }

Property Value

Int32
The node identifier
See Also

Reference

IRecoveryInfo Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IRecoveryInfo.RequestId Property

IRecoveryInfoRequestId Property

Gets the request identifier

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long RequestId { get; }

Property Value

Int64
The request identifier
See Also

Reference

IRecoveryInfo Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IRecoveryInfo.ResponseCode Property

IRecoveryInfoResponseCode Property

Gets the response code of the recovery request

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
int ResponseCode { get; }

Property Value

Int32
The response code of the recovery request
See Also

Reference

IRecoveryInfo Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IRecoveryInfo.ResponseMessage Property

IRecoveryInfoResponseMessage Property

Gets the response message of the recovery request

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
string ResponseMessage { get; }

Property Value

String
the response message of the recovery request
See Also

Reference

IRecoveryInfo Interface
Sportradar.OddsFeed.SDK.Messages Namespace


IRecoveryInfo.Timestamp Property

IRecoveryInfoTimestamp Property

Gets the timestamp specifying when the recovery was initiated

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
long Timestamp { get; }

Property Value

Int64
The timestamp
See Also

Reference

IRecoveryInfo Interface
Sportradar.OddsFeed.SDK.Messages Namespace


ResourceTypeGroup Enumeration

Enumerates groups of resources represented by the URN

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum ResourceTypeGroup
Members
Member name | Value | Description
MATCH | 0 | The resource represents a sport event of match type
STAGE | 1 | The resource represents a sport event of stage type
TOURNAMENT | 2 | The resource represents a tournament
BASIC_TOURNAMENT | 3 | The basic tournament
SEASON | 4 | The resource represents a (tournament) season
OTHER | 5 | The non-specific URN type specifier
UNKNOWN | 6 | The unknown resource type
DRAW | 7 | The resource represents lottery draw
LOTTERY | 8 | The resource represents lottery
See Also

Reference

Sportradar.OddsFeed.SDK.Messages Namespace


URN Class

Represents a Uniform Resource Name
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.MessagesURN

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class URN

The URN type exposes the following members.

Constructors
 | Name | Description
Public method | URN(URN) | Initializes a new instance of the URN class.
Public method | URN(String, String, Int64) | Initializes a new instance of the URN class.
Top
Properties
 | Name | Description
Public property | Id | Gets the numerical part of the identifier associated with the current instance
Public property | Prefix | Gets the prefix of the current instance.
Public property | Type | Gets a String specifying the type of the resource associated with the current instance
Public property | TypeGroup | Gets a ResourceTypeGroup enum member describing the group of the resource
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object))
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsSimpleTeam | Determines whether URN represents a simple team
 | IsSimpleTeam(String) | Determines whether URN represents a simple team
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
 | Parse(String) | Constructs a URN instance by parsing the provided String
 | Parse(String, Boolean) | Constructs a URN instance by parsing the provided String
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString)
 | TryParse(String, URN) | Tries to construct a URN instance by parsing the provided String
 | TryParse(String, Boolean, URN) | Tries to construct a URN instance by parsing the provided String
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages Namespace


URN Constructor

Overload List
 | Name | Description
Public method | URN(URN) | Initializes a new instance of the URN class.
Public method | URN(String, String, Int64) | Initializes a new instance of the URN class.
Top
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace


URN(URN) Constructor

Initializes a new instance of the URN class.

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public URN(
    URN urn
)

Parameters

urn URN
The urn to be used as a template
See Also

Reference

URN Class
URN Overload
Sportradar.OddsFeed.SDK.Messages Namespace


URN(String, String, Int64) Constructor

Initializes a new instance of the URN class.

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public URN(
    string prefix,
    string type,
    long id
)

Parameters

prefix String
The prefix of the URN
type String
The type of the resource associated with the URN
id Int64
The numerical identifier of the resource associated with the URN
See Also

Reference

URN Class
URN Overload
Sportradar.OddsFeed.SDK.Messages Namespace


URN Properties

The URN type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the numerical part of the identifier associated with the current instance
Public property | Prefix | Gets the prefix of the current instance.
Public property | Type | Gets a String specifying the type of the resource associated with the current instance
Public property | TypeGroup | Gets a ResourceTypeGroup enum member describing the group of the resource
Top
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace


URN.Id Property

URNId Property

Gets the numerical part of the identifier associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long Id { get; }

Property Value

Int64
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace


URN.Prefix Property

URNPrefix Property

Gets the prefix of the current instance.

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Prefix { get; }

Property Value

String
The prefix.
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace


URN.Type Property

URNType Property

Gets a String specifying the type of the resource associated with the current instance

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Type { get; }

Property Value

String
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace


URN.TypeGroup Property

URNTypeGroup Property

Gets a ResourceTypeGroup enum member describing the group of the resource

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ResourceTypeGroup TypeGroup { get; }

Property Value

ResourceTypeGroup
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace
ResourceTypeGroup


URN Methods

The URN type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object))
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsSimpleTeam | Determines whether URN represents a simple team
 | IsSimpleTeam(String) | Determines whether URN represents a simple team
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
 | Parse(String) | Constructs a URN instance by parsing the provided String
 | Parse(String, Boolean) | Constructs a URN instance by parsing the provided String
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString)
 | TryParse(String, URN) | Tries to construct a URN instance by parsing the provided String
 | TryParse(String, Boolean, URN) | Tries to construct a URN instance by parsing the provided String
Top
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace


URN.Equals Method

URNEquals Method

Determines whether the specified Object is equal to this instance.

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object
The object to compare with the current object.

Return Value

Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace


URN.GetHashCode Method

URNGetHashCode Method

Returns a hash code for this instance.

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace


URN.IsSimpleTeam Method

URNIsSimpleTeam Method

Overload List
 | Name | Description
Public method | IsSimpleTeam | Determines whether URN represents a simple team
 | IsSimpleTeam(String) | Determines whether URN represents a simple team
Top
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace


URN.IsSimpleTeam Method

URNIsSimpleTeam Method

Determines whether URN represents a simple team

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool IsSimpleTeam()

Return Value

Boolean
true if represents simple team; otherwise, false.
See Also

Reference

URN Class
IsSimpleTeam Overload
Sportradar.OddsFeed.SDK.Messages Namespace


URN.IsSimpleTeam(String) Method

URNIsSimpleTeam(String) Method

Determines whether URN represents a simple team

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static bool IsSimpleTeam(
    string urn
)

Parameters

urn String

[Missing <param name="urn"/> documentation for "M:Sportradar.OddsFeed.SDK.Messages.URN.IsSimpleTeam(System.String)"]

Return Value

Boolean
true if represents simple team; otherwise, false.
See Also

Reference

URN Class
IsSimpleTeam Overload
Sportradar.OddsFeed.SDK.Messages Namespace


URN.Parse Method

URNParse Method

Overload List
Name | Description
Parse(String) | Constructs a URN instance by parsing the provided String
Parse(String, Boolean) | Constructs a URN instance by parsing the provided String
Top
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace


URN.Parse(String) Method

URNParse(String) Method

Constructs a URN instance by parsing the provided String

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static URN Parse(
    string urnString
)

Parameters

urnString String
The String representation of the URN

Return Value

URN
A URN constructed by parsing the provided string representation
Exceptions
Exception | Condition
FormatException | The format of the provided representation is not correct
See Also

Reference

URN Class
Parse Overload
Sportradar.OddsFeed.SDK.Messages Namespace


URN.Parse(String, Boolean) Method

URNParse(String, Boolean) Method

Constructs a URN instance by parsing the provided String

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static URN Parse(
    string urnString,
    bool isCustomType
)

Parameters

urnString String
The String representation of the URN
isCustomType Boolean
Indicates if the urn type is for custom use

Return Value

URN
A URN constructed by parsing the provided string representation
Exceptions
Exception | Condition
FormatException | The format of the provided representation is not correct
See Also

Reference

URN Class
Parse Overload
Sportradar.OddsFeed.SDK.Messages Namespace


URN.ToString Method

URNToString Method

Returns a String that represents this instance.

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
A String that represents this instance.
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace


URN.TryParse Method

URNTryParse Method

Overload List
Name | Description
TryParse(String, URN) | Tries to construct a URN instance by parsing the provided String
TryParse(String, Boolean, URN) | Tries to construct a URN instance by parsing the provided String
Top
See Also

Reference

URN Class
Sportradar.OddsFeed.SDK.Messages Namespace


URN.TryParse(String, URN) Method

URNTryParse(String, URN) Method

Tries to construct a URN instance by parsing the provided String

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static bool TryParse(
    string urnString,
    out URN urn
)

Parameters

urnString String
The String representation of the URN
urn URN
When the method returns it contains the URN constructed by parsing the provided string if the parsing was successful, otherwise null

Return Value

Boolean
true if XXXX, false otherwise.
See Also

Reference

URN Class
TryParse Overload
Sportradar.OddsFeed.SDK.Messages Namespace


URN.TryParse(String, Boolean, URN) Method

URNTryParse(String, Boolean, URN) Method

Tries to construct a URN instance by parsing the provided String

Namespace: Sportradar.OddsFeed.SDK.Messages
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static bool TryParse(
    string urnString,
    bool isCustomType,
    out URN urn
)

Parameters

urnString String
The String representation of the URN
isCustomType Boolean
Indicates if the urn type is for custom use
urn URN
When the method returns it contains the URN constructed by parsing the provided string if the parsing was successful, otherwise null

Return Value

Boolean
true if XXXX, false otherwise.
See Also

Reference

URN Class
TryParse Overload
Sportradar.OddsFeed.SDK.Messages Namespace


Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace

Classes
 | Class | Description
Public class | RawApiDataEventArgs | Event arguments for the RawApiDataReceived events
Public class | RawFeedMessageEventArgs | Event arguments for the RawFeedMessageReceived events


RawApiDataEventArgs Class

Event arguments for the RawApiDataReceived events
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.Messages.EventArgumentsRawApiDataEventArgs

Namespace: Sportradar.OddsFeed.SDK.Messages.EventArguments
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class RawApiDataEventArgs : EventArgs

The RawApiDataEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RawApiDataEventArgs | Initializes a new instance of the RawApiDataEventArgs class
Top
Properties
 | Name | Description
Public property | Language | The language associated with the request
Public property | RequestParams | The parameters associated with the request (if present)
Public property | RequestTime | The time it took for the request to execute
Public property | RestMessage | The rest message
Public property | Uri | The associated event identifier
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawApiDataEventArgs Constructor

Initializes a new instance of the RawApiDataEventArgs class

Namespace: Sportradar.OddsFeed.SDK.Messages.EventArguments
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public RawApiDataEventArgs(
    Uri uri,
    RestMessage restMessage,
    string requestParams,
    TimeSpan requestTime,
    string language
)

Parameters

uri Uri
The Uri used to get the api data
restMessage RestMessage
The rest message
requestParams String
The parameters associated with the request
requestTime TimeSpan
The time needed to execute request
language String
The language associated with the request
See Also

Reference

RawApiDataEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawApiDataEventArgs Properties

The RawApiDataEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Language | The language associated with the request
Public property | RequestParams | The parameters associated with the request (if present)
Public property | RequestTime | The time it took for the request to execute
Public property | RestMessage | The rest message
Public property | Uri | The associated event identifier
Top
See Also

Reference

RawApiDataEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawApiDataEventArgs.Language Property

RawApiDataEventArgsLanguage Property

The language associated with the request

Namespace: Sportradar.OddsFeed.SDK.Messages.EventArguments
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string Language { get; }

Property Value

String
See Also

Reference

RawApiDataEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawApiDataEventArgs.RequestParams Property

RawApiDataEventArgsRequestParams Property

The parameters associated with the request (if present)

Namespace: Sportradar.OddsFeed.SDK.Messages.EventArguments
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string RequestParams { get; }

Property Value

String
See Also

Reference

RawApiDataEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawApiDataEventArgs.RequestTime Property

RawApiDataEventArgsRequestTime Property

The time it took for the request to execute

Namespace: Sportradar.OddsFeed.SDK.Messages.EventArguments
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public TimeSpan RequestTime { get; }

Property Value

TimeSpan
See Also

Reference

RawApiDataEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawApiDataEventArgs.RestMessage Property

RawApiDataEventArgsRestMessage Property

The rest message

Namespace: Sportradar.OddsFeed.SDK.Messages.EventArguments
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public RestMessage RestMessage { get; }

Property Value

RestMessage
See Also

Reference

RawApiDataEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawApiDataEventArgs.Uri Property

RawApiDataEventArgsUri Property

The associated event identifier

Namespace: Sportradar.OddsFeed.SDK.Messages.EventArguments
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public Uri Uri { get; }

Property Value

Uri
See Also

Reference

RawApiDataEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawApiDataEventArgs Methods

The RawApiDataEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RawApiDataEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawFeedMessageEventArgs Class

Event arguments for the RawFeedMessageReceived events
Inheritance Hierarchy
SystemObject
SystemEventArgs
Sportradar.OddsFeed.SDK.Messages.EventArgumentsRawFeedMessageEventArgs

Namespace: Sportradar.OddsFeed.SDK.Messages.EventArguments
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public class RawFeedMessageEventArgs : EventArgs

The RawFeedMessageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RawFeedMessageEventArgs | Initializes a new instance of the RawFeedMessageEventArgs class
Top
Properties
 | Name | Description
Public property | FeedMessage | The feed message
Public property | MessageInterest | Gets the associated message interest
Public property | RoutingKey | The routing key associated with the feed message
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawFeedMessageEventArgs Constructor

Initializes a new instance of the RawFeedMessageEventArgs class

Namespace: Sportradar.OddsFeed.SDK.Messages.EventArguments
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public RawFeedMessageEventArgs(
    string routingKey,
    FeedMessage feedMessage,
    string messageInterest
)

Parameters

routingKey String
The routing key associated with the feed message
feedMessage FeedMessage
The feed message
messageInterest String
The associated message interest
See Also

Reference

RawFeedMessageEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawFeedMessageEventArgs Properties

The RawFeedMessageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FeedMessage | The feed message
Public property | MessageInterest | Gets the associated message interest
Public property | RoutingKey | The routing key associated with the feed message
Top
See Also

Reference

RawFeedMessageEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawFeedMessageEventArgs.FeedMessage Property

RawFeedMessageEventArgsFeedMessage Property

The feed message

Namespace: Sportradar.OddsFeed.SDK.Messages.EventArguments
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FeedMessage FeedMessage { get; }

Property Value

FeedMessage
See Also

Reference

RawFeedMessageEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawFeedMessageEventArgs.MessageInterest Property

RawFeedMessageEventArgsMessageInterest Property

Gets the associated message interest

Namespace: Sportradar.OddsFeed.SDK.Messages.EventArguments
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string MessageInterest { get; }

Property Value

String
The associated message interest
See Also

Reference

RawFeedMessageEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawFeedMessageEventArgs.RoutingKey Property

RawFeedMessageEventArgsRoutingKey Property

The routing key associated with the feed message

Namespace: Sportradar.OddsFeed.SDK.Messages.EventArguments
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string RoutingKey { get; }

Property Value

String
See Also

Reference

RawFeedMessageEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


RawFeedMessageEventArgs Methods

The RawFeedMessageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RawFeedMessageEventArgs Class
Sportradar.OddsFeed.SDK.Messages.EventArguments Namespace


Sportradar.OddsFeed.SDK.Messages.Feed Namespace

Classes
 | Class | Description
Public class | alive |
Public class | bet_cancel |
Public class | bet_settlement |
Public class | bet_stop |
Public class | betSettlementMarket |
Public class | betSettlementMarketOutcome |
Public class | clockType |
Public class | FeedMarket | Base FeedMarket class
Public class | FeedMessage | Represents a base class for messages received from the feed
Public class | fixture_change |
Public class | market |
Public class | marketMetadata |
Public class | odds_change |
Public class | odds_changeOdds |
Public class | oddsChangeMarket |
Public class | oddsChangeMarketOutcome |
Public class | oddsGenerationProperties |
Public class | periodScoreType |
Public class | resultType |
Public class | rollback_bet_cancel |
Public class | rollback_bet_settlement |
Public class | snapshot_complete |
Public class | sportEventStatus |
Public class | statisticsScoreType |
Public class | statisticsType |
Enumerations
 | Enumeration | Description
Public enumeration | PropertyUsage | Enumerates property usage requirements


alive Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.alive"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMessage
Sportradar.OddsFeed.SDK.Messages.Feedalive

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class alive : FeedMessage

The alive type exposes the following members.

Constructors
 | Name | Description
Public method | alive | Initializes a new instance of the alive class
Top
Properties
 | Name | Description
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | subscribed |
Public property | timestamp |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive Constructor

Initializes a new instance of the alive class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public alive()
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive Properties

The alive type exposes the following members.

Properties
 | Name | Description
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | subscribed |
Public property | timestamp |
Top
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.EventId Property

aliveEventId Property

When overridden in derived class it gets the event identifier.

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string EventId { get; }

Property Value

String
The event identifier
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.GeneratedAt Property

aliveGeneratedAt Property

Gets the timestamp of when the message was generated

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long GeneratedAt { get; }

Property Value

Int64
The timestamp of the message
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.IsEventRelated Property

aliveIsEventRelated Property

When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsEventRelated { get; }

Property Value

Boolean
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.IsStateful Property

aliveIsStateful Property

When override in derived class, it gets a value indicating whether current message is state-ful

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsStateful { get; }

Property Value

Boolean
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.Name Property

aliveName Property

When overridden in derived class, gets the name of the current message

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string Name { get; }

Property Value

String
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.ProducerId Property

aliveProducerId Property

When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override int ProducerId { get; }

Property Value

Int32
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.product Property

aliveproduct Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.alive.product"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int product { get; set; }

Property Value

Int32
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.ReceivedAt Property

aliveReceivedAt Property

Gets the timestamp of when the message was received (picked up) by the sdk

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long ReceivedAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.RequestId Property

aliveRequestId Property

Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long? RequestId { get; }

Property Value

Nullable Int64
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.RequestIdUsage Property

aliveRequestIdUsage Property

When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override PropertyUsage RequestIdUsage { get; }

Property Value

PropertyUsage
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.SentAt Property

aliveSentAt Property

Gets the timestamp of when the message was sent

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long SentAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.subscribed Property

alivesubscribed Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.alive.subscribed"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int subscribed { get; set; }

Property Value

Int32
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.timestamp Property

alivetimestamp Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.alive.timestamp"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long timestamp { get; set; }

Property Value

Int64
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive Methods

The alive type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive Fields

The alive type exposes the following members.

Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


alive.MessageName Field

aliveMessageName Field

The message name

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly string MessageName

Field Value

String
See Also

Reference

alive Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.bet_cancel"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMessage
Sportradar.OddsFeed.SDK.Messages.Feedbet_cancel

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class bet_cancel : FeedMessage

The bet_cancel type exposes the following members.

Constructors
 | Name | Description
Public method | bet_cancel | Initializes a new instance of the bet_cancel class
Top
Properties
 | Name | Description
Public property | end_time |
Public property | end_timeSpecified |
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | market |
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | start_time |
Public property | start_timeSpecified |
Public property | superceded_by |
Public property | timestamp |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel Constructor

Initializes a new instance of the bet_cancel class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bet_cancel()
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel Properties

The bet_cancel type exposes the following members.

Properties
 | Name | Description
Public property | end_time |
Public property | end_timeSpecified |
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | market |
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | start_time |
Public property | start_timeSpecified |
Public property | superceded_by |
Public property | timestamp |
Top
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.end_time Property

bet_cancelend_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_cancel.end_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long end_time { get; set; }

Property Value

Int64
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.end_timeSpecified Property

bet_cancelend_timeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_cancel.end_timeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool end_timeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.event_id Property

bet_cancelevent_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_cancel.event_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string event_id { get; set; }

Property Value

String
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.EventId Property

bet_cancelEventId Property

When overridden in derived class it gets the event identifier.

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string EventId { get; }

Property Value

String
The event identifier
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.GeneratedAt Property

bet_cancelGeneratedAt Property

Gets the timestamp of when the message was generated

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long GeneratedAt { get; }

Property Value

Int64
The timestamp of the message
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.IsEventRelated Property

bet_cancelIsEventRelated Property

When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsEventRelated { get; }

Property Value

Boolean
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.IsStateful Property

bet_cancelIsStateful Property

When override in derived class, it gets a value indicating whether current message is state-ful

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsStateful { get; }

Property Value

Boolean
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.market Property

bet_cancelmarket Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_cancel.market"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public market[] market { get; set; }

Property Value

market
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.Name Property

bet_cancelName Property

When overridden in derived class, gets the name of the current message

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string Name { get; }

Property Value

String
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.ProducerId Property

bet_cancelProducerId Property

When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override int ProducerId { get; }

Property Value

Int32
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.product Property

bet_cancelproduct Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_cancel.product"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int product { get; set; }

Property Value

Int32
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.ReceivedAt Property

bet_cancelReceivedAt Property

Gets the timestamp of when the message was received (picked up) by the sdk

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long ReceivedAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.request_id Property

bet_cancelrequest_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_cancel.request_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long request_id { get; set; }

Property Value

Int64
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.request_idSpecified Property

bet_cancelrequest_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_cancel.request_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool request_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.RequestId Property

bet_cancelRequestId Property

Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long? RequestId { get; }

Property Value

Nullable Int64
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.RequestIdUsage Property

bet_cancelRequestIdUsage Property

When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override PropertyUsage RequestIdUsage { get; }

Property Value

PropertyUsage
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.SentAt Property

bet_cancelSentAt Property

Gets the timestamp of when the message was sent

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long SentAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.start_time Property

bet_cancelstart_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_cancel.start_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long start_time { get; set; }

Property Value

Int64
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.start_timeSpecified Property

bet_cancelstart_timeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_cancel.start_timeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_timeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.superceded_by Property

bet_cancelsuperceded_by Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_cancel.superceded_by"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string superceded_by { get; set; }

Property Value

String
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.timestamp Property

bet_canceltimestamp Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_cancel.timestamp"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long timestamp { get; set; }

Property Value

Int64
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel Methods

The bet_cancel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel Fields

The bet_cancel type exposes the following members.

Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_cancel.MessageName Field

bet_cancelMessageName Field

The message name

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly string MessageName

Field Value

String
See Also

Reference

bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.bet_settlement"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMessage
Sportradar.OddsFeed.SDK.Messages.Feedbet_settlement

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class bet_settlement : FeedMessage

The bet_settlement type exposes the following members.

Constructors
 | Name | Description
Public method | bet_settlement | Initializes a new instance of the bet_settlement class
Top
Properties
 | Name | Description
Public property | certainty |
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | outcomes |
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | timestamp |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement Constructor

Initializes a new instance of the bet_settlement class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bet_settlement()
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement Properties

The bet_settlement type exposes the following members.

Properties
 | Name | Description
Public property | certainty |
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | outcomes |
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | timestamp |
Top
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.certainty Property

bet_settlementcertainty Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_settlement.certainty"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int certainty { get; set; }

Property Value

Int32
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.event_id Property

bet_settlementevent_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_settlement.event_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string event_id { get; set; }

Property Value

String
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.EventId Property

bet_settlementEventId Property

When overridden in derived class it gets the event identifier.

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string EventId { get; }

Property Value

String
The event identifier
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.GeneratedAt Property

bet_settlementGeneratedAt Property

Gets the timestamp of when the message was generated

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long GeneratedAt { get; }

Property Value

Int64
The timestamp of the message
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.IsEventRelated Property

bet_settlementIsEventRelated Property

When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsEventRelated { get; }

Property Value

Boolean
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.IsStateful Property

bet_settlementIsStateful Property

When override in derived class, it gets a value indicating whether current message is state-ful

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsStateful { get; }

Property Value

Boolean
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.Name Property

bet_settlementName Property

When overridden in derived class, gets the name of the current message

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string Name { get; }

Property Value

String
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.outcomes Property

bet_settlementoutcomes Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_settlement.outcomes"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public betSettlementMarket[] outcomes { get; set; }

Property Value

betSettlementMarket
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.ProducerId Property

bet_settlementProducerId Property

When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override int ProducerId { get; }

Property Value

Int32
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.product Property

bet_settlementproduct Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_settlement.product"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int product { get; set; }

Property Value

Int32
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.ReceivedAt Property

bet_settlementReceivedAt Property

Gets the timestamp of when the message was received (picked up) by the sdk

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long ReceivedAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.request_id Property

bet_settlementrequest_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_settlement.request_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long request_id { get; set; }

Property Value

Int64
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.request_idSpecified Property

bet_settlementrequest_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_settlement.request_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool request_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.RequestId Property

bet_settlementRequestId Property

Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long? RequestId { get; }

Property Value

Nullable Int64
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.RequestIdUsage Property

bet_settlementRequestIdUsage Property

When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override PropertyUsage RequestIdUsage { get; }

Property Value

PropertyUsage
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.SentAt Property

bet_settlementSentAt Property

Gets the timestamp of when the message was sent

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long SentAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.timestamp Property

bet_settlementtimestamp Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_settlement.timestamp"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long timestamp { get; set; }

Property Value

Int64
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement Methods

The bet_settlement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement Fields

The bet_settlement type exposes the following members.

Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_settlement.MessageName Field

bet_settlementMessageName Field

The message name

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly string MessageName

Field Value

String
See Also

Reference

bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.bet_stop"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMessage
Sportradar.OddsFeed.SDK.Messages.Feedbet_stop

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class bet_stop : FeedMessage

The bet_stop type exposes the following members.

Constructors
 | Name | Description
Public method | bet_stop | Initializes a new instance of the bet_stop class
Top
Properties
 | Name | Description
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | groups |
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | market_status |
Public property | market_statusSpecified |
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | timestamp |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop Constructor

Initializes a new instance of the bet_stop class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bet_stop()
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop Properties

The bet_stop type exposes the following members.

Properties
 | Name | Description
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | groups |
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | market_status |
Public property | market_statusSpecified |
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | timestamp |
Top
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.event_id Property

bet_stopevent_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_stop.event_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string event_id { get; set; }

Property Value

String
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.EventId Property

bet_stopEventId Property

When overridden in derived class it gets the event identifier.

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string EventId { get; }

Property Value

String
The event identifier
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.GeneratedAt Property

bet_stopGeneratedAt Property

Gets the timestamp of when the message was generated

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long GeneratedAt { get; }

Property Value

Int64
The timestamp of the message
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.groups Property

bet_stopgroups Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_stop.groups"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string groups { get; set; }

Property Value

String
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.IsEventRelated Property

bet_stopIsEventRelated Property

When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsEventRelated { get; }

Property Value

Boolean
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.IsStateful Property

bet_stopIsStateful Property

When override in derived class, it gets a value indicating whether current message is state-ful

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsStateful { get; }

Property Value

Boolean
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.market_status Property

bet_stopmarket_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_stop.market_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int market_status { get; set; }

Property Value

Int32
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.market_statusSpecified Property

bet_stopmarket_statusSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_stop.market_statusSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool market_statusSpecified { get; set; }

Property Value

Boolean
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.Name Property

bet_stopName Property

When overridden in derived class, gets the name of the current message

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string Name { get; }

Property Value

String
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.ProducerId Property

bet_stopProducerId Property

When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override int ProducerId { get; }

Property Value

Int32
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.product Property

bet_stopproduct Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_stop.product"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int product { get; set; }

Property Value

Int32
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.ReceivedAt Property

bet_stopReceivedAt Property

Gets the timestamp of when the message was received (picked up) by the sdk

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long ReceivedAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.request_id Property

bet_stoprequest_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_stop.request_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long request_id { get; set; }

Property Value

Int64
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.request_idSpecified Property

bet_stoprequest_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_stop.request_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool request_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.RequestId Property

bet_stopRequestId Property

Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long? RequestId { get; }

Property Value

Nullable Int64
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.RequestIdUsage Property

bet_stopRequestIdUsage Property

When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override PropertyUsage RequestIdUsage { get; }

Property Value

PropertyUsage
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.SentAt Property

bet_stopSentAt Property

Gets the timestamp of when the message was sent

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long SentAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.timestamp Property

bet_stoptimestamp Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.bet_stop.timestamp"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long timestamp { get; set; }

Property Value

Int64
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop Methods

The bet_stop type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop Fields

The bet_stop type exposes the following members.

Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


bet_stop.MessageName Field

bet_stopMessageName Field

The message name

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly string MessageName

Field Value

String
See Also

Reference

bet_stop Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarket Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarket"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMarket
Sportradar.OddsFeed.SDK.Messages.FeedbetSettlementMarket

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class betSettlementMarket : FeedMarket

The betSettlementMarket type exposes the following members.

Constructors
 | Name | Description
Public method | betSettlementMarket | Initializes a new instance of the betSettlementMarket class
Top
Properties
 | Name | Description
Public property | extended_specifiers |
Public property | id |
Public property | Items |
Public property | result |
Public property | specifiers |
Public property | Specifiers | Gets or sets a IReadOnlyDictionaryTKey, TValue representing parsed specifiers (Inherited from FeedMarket)
Public property | SpecifierString | Gets the specifiers string (Overrides FeedMarketSpecifierString)
Public property | ValidationFailed | Gets or sets a indicating whether the validation of the market has failed and should not be mapped to exposed entity (Inherited from FeedMarket)
Public property | void_reason |
Public property | void_reasonSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarket Constructor

Initializes a new instance of the betSettlementMarket class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public betSettlementMarket()
See Also

Reference

betSettlementMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarket Properties

The betSettlementMarket type exposes the following members.

Properties
 | Name | Description
Public property | extended_specifiers |
Public property | id |
Public property | Items |
Public property | result |
Public property | specifiers |
Public property | Specifiers | Gets or sets a IReadOnlyDictionaryTKey, TValue representing parsed specifiers (Inherited from FeedMarket)
Public property | SpecifierString | Gets the specifiers string (Overrides FeedMarketSpecifierString)
Public property | ValidationFailed | Gets or sets a indicating whether the validation of the market has failed and should not be mapped to exposed entity (Inherited from FeedMarket)
Public property | void_reason |
Public property | void_reasonSpecified |
Top
See Also

Reference

betSettlementMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarket.extended_specifiers Property

betSettlementMarketextended_specifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarket.extended_specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string extended_specifiers { get; set; }

Property Value

String
See Also

Reference

betSettlementMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarket.id Property

betSettlementMarketid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarket.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int id { get; set; }

Property Value

Int32
See Also

Reference

betSettlementMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarket.Items Property

betSettlementMarketItems Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarket.Items"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public betSettlementMarketOutcome[] Items { get; set; }

Property Value

betSettlementMarketOutcome
See Also

Reference

betSettlementMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarket.result Property

betSettlementMarketresult Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarket.result"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string result { get; set; }

Property Value

String
See Also

Reference

betSettlementMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarket.specifiers Property

betSettlementMarketspecifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarket.specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string specifiers { get; set; }

Property Value

String
See Also

Reference

betSettlementMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarket.SpecifierString Property

betSettlementMarketSpecifierString Property

Gets the specifiers string

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string SpecifierString { get; }

Property Value

String
See Also

Reference

betSettlementMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarket.void_reason Property

betSettlementMarketvoid_reason Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarket.void_reason"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int void_reason { get; set; }

Property Value

Int32
See Also

Reference

betSettlementMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarket.void_reasonSpecified Property

betSettlementMarketvoid_reasonSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarket.void_reasonSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool void_reasonSpecified { get; set; }

Property Value

Boolean
See Also

Reference

betSettlementMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarket Methods

The betSettlementMarket type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

betSettlementMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarketOutcome Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarketOutcome"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedbetSettlementMarketOutcome

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class betSettlementMarketOutcome

The betSettlementMarketOutcome type exposes the following members.

Constructors
 | Name | Description
Public method | betSettlementMarketOutcome | Initializes a new instance of the betSettlementMarketOutcome class
Top
Properties
 | Name | Description
Public property | dead_heat_factor |
Public property | dead_heat_factorSpecified |
Public property | id |
Public property | result |
Public property | void_factor |
Public property | void_factorSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarketOutcome Constructor

Initializes a new instance of the betSettlementMarketOutcome class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public betSettlementMarketOutcome()
See Also

Reference

betSettlementMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarketOutcome Properties

The betSettlementMarketOutcome type exposes the following members.

Properties
 | Name | Description
Public property | dead_heat_factor |
Public property | dead_heat_factorSpecified |
Public property | id |
Public property | result |
Public property | void_factor |
Public property | void_factorSpecified |
Top
See Also

Reference

betSettlementMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarketOutcome.dead_heat_factor Property

betSettlementMarketOutcomedead_heat_factor Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarketOutcome.dead_heat_factor"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double dead_heat_factor { get; set; }

Property Value

Double
See Also

Reference

betSettlementMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarketOutcome.dead_heat_factorSpecified Property

betSettlementMarketOutcomedead_heat_factorSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarketOutcome.dead_heat_factorSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool dead_heat_factorSpecified { get; set; }

Property Value

Boolean
See Also

Reference

betSettlementMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarketOutcome.id Property

betSettlementMarketOutcomeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarketOutcome.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

betSettlementMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarketOutcome.result Property

betSettlementMarketOutcomeresult Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarketOutcome.result"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int result { get; set; }

Property Value

Int32
See Also

Reference

betSettlementMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarketOutcome.void_factor Property

betSettlementMarketOutcomevoid_factor Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarketOutcome.void_factor"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double void_factor { get; set; }

Property Value

Double
See Also

Reference

betSettlementMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarketOutcome.void_factorSpecified Property

betSettlementMarketOutcomevoid_factorSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.betSettlementMarketOutcome.void_factorSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool void_factorSpecified { get; set; }

Property Value

Boolean
See Also

Reference

betSettlementMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


betSettlementMarketOutcome Methods

The betSettlementMarketOutcome type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

betSettlementMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


clockType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.clockType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedclockType

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class clockType

The clockType type exposes the following members.

Constructors
 | Name | Description
Public method | clockType | Initializes a new instance of the clockType class
Top
Properties
 | Name | Description
Public property | match_time |
Public property | remaining_time |
Public property | remaining_time_in_period |
Public property | stoppage_time |
Public property | stoppage_time_announced |
Public property | stopped |
Public property | stoppedSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


clockType Constructor

Initializes a new instance of the clockType class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public clockType()
See Also

Reference

clockType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


clockType Properties

The clockType type exposes the following members.

Properties
 | Name | Description
Public property | match_time |
Public property | remaining_time |
Public property | remaining_time_in_period |
Public property | stoppage_time |
Public property | stoppage_time_announced |
Public property | stopped |
Public property | stoppedSpecified |
Top
See Also

Reference

clockType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


clockType.match_time Property

clockTypematch_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.clockType.match_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string match_time { get; set; }

Property Value

String
See Also

Reference

clockType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


clockType.remaining_time Property

clockTyperemaining_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.clockType.remaining_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string remaining_time { get; set; }

Property Value

String
See Also

Reference

clockType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


clockType.remaining_time_in_period Property

clockTyperemaining_time_in_period Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.clockType.remaining_time_in_period"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string remaining_time_in_period { get; set; }

Property Value

String
See Also

Reference

clockType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


clockType.stoppage_time Property

clockTypestoppage_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.clockType.stoppage_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string stoppage_time { get; set; }

Property Value

String
See Also

Reference

clockType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


clockType.stoppage_time_announced Property

clockTypestoppage_time_announced Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.clockType.stoppage_time_announced"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string stoppage_time_announced { get; set; }

Property Value

String
See Also

Reference

clockType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


clockType.stopped Property

clockTypestopped Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.clockType.stopped"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool stopped { get; set; }

Property Value

Boolean
See Also

Reference

clockType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


clockType.stoppedSpecified Property

clockTypestoppedSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.clockType.stoppedSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool stoppedSpecified { get; set; }

Property Value

Boolean
See Also

Reference

clockType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


clockType Methods

The clockType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

clockType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMarket Class

Base FeedMarket class
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMarket
Sportradar.OddsFeed.SDK.Messages.FeedbetSettlementMarket
Sportradar.OddsFeed.SDK.Messages.Feedmarket
Sportradar.OddsFeed.SDK.Messages.FeedoddsChangeMarket

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract class FeedMarket

The FeedMarket type exposes the following members.

Constructors
 | Name | Description
Protected method | FeedMarket | Initializes a new instance of the FeedMarket class
Top
Properties
 | Name | Description
Public property | Specifiers | Gets or sets a IReadOnlyDictionaryTKey, TValue representing parsed specifiers
Public property | SpecifierString | Gets the specifiers string
Public property | ValidationFailed | Gets or sets a indicating whether the validation of the market has failed and should not be mapped to exposed entity
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMarket Constructor

Initializes a new instance of the FeedMarket class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected FeedMarket()
See Also

Reference

FeedMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMarket Properties

The FeedMarket type exposes the following members.

Properties
 | Name | Description
Public property | Specifiers | Gets or sets a IReadOnlyDictionaryTKey, TValue representing parsed specifiers
Public property | SpecifierString | Gets the specifiers string
Public property | ValidationFailed | Gets or sets a indicating whether the validation of the market has failed and should not be mapped to exposed entity
Top
See Also

Reference

FeedMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMarket.Specifiers Property

FeedMarketSpecifiers Property

Gets or sets a IReadOnlyDictionaryTKey, TValue representing parsed specifiers

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public IReadOnlyDictionary<string, string> Specifiers { get; set; }

Property Value

IReadOnlyDictionary String, String
See Also

Reference

FeedMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMarket.SpecifierString Property

FeedMarketSpecifierString Property

Gets the specifiers string

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract string SpecifierString { get; }

Property Value

String
See Also

Reference

FeedMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMarket.ValidationFailed Property

FeedMarketValidationFailed Property

Gets or sets a indicating whether the validation of the market has failed and should not be mapped to exposed entity

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool ValidationFailed { get; set; }

Property Value

Boolean
See Also

Reference

FeedMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMarket Methods

The FeedMarket type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FeedMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage Class

Represents a base class for messages received from the feed
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMessage
More

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract class FeedMessage

The FeedMessage type exposes the following members.

Constructors
 | Name | Description
Protected method | FeedMessage | Initializes a new instance of the FeedMessage class
Top
Properties
 | Name | Description
Public property | EventId | When overridden in derived class it gets the event identifier.
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event
Public property | GeneratedAt | Gets the timestamp of when the message was generated
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful
Public property | Name | When overridden in derived class, gets the name of the current message
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property
Public property | SentAt | Gets the timestamp of when the message was sent
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMessage
Sportradar.OddsFeed.SDK.Messages.Feedalive
Sportradar.OddsFeed.SDK.Messages.Feedbet_cancel
Sportradar.OddsFeed.SDK.Messages.Feedbet_settlement
Sportradar.OddsFeed.SDK.Messages.Feedbet_stop
Sportradar.OddsFeed.SDK.Messages.Feedfixture_change
Sportradar.OddsFeed.SDK.Messages.Feedodds_change
Sportradar.OddsFeed.SDK.Messages.Feedrollback_bet_cancel
Sportradar.OddsFeed.SDK.Messages.Feedrollback_bet_settlement
Sportradar.OddsFeed.SDK.Messages.Feedsnapshot_complete
Sportradar.OddsFeed.SDK.Messages.RESTcashout


FeedMessage Constructor

Initializes a new instance of the FeedMessage class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected FeedMessage()
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage Properties

The FeedMessage type exposes the following members.

Properties
 | Name | Description
Public property | EventId | When overridden in derived class it gets the event identifier.
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event
Public property | GeneratedAt | Gets the timestamp of when the message was generated
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful
Public property | Name | When overridden in derived class, gets the name of the current message
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property
Public property | SentAt | Gets the timestamp of when the message was sent
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance
Top
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.EventId Property

FeedMessageEventId Property

When overridden in derived class it gets the event identifier.

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract string EventId { get; }

Property Value

String
The event identifier
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.EventURN Property

FeedMessageEventURN Property

When overridden in derived class, it gets a URN specifying the id of the associated sport event

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public URN EventURN { get; set; }

Property Value

URN
The event urn
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.GeneratedAt Property

FeedMessageGeneratedAt Property

Gets the timestamp of when the message was generated

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract long GeneratedAt { get; }

Property Value

Int64
The timestamp of the message
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.IsEventRelated Property

FeedMessageIsEventRelated Property

When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract bool IsEventRelated { get; }

Property Value

Boolean
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.IsStateful Property

FeedMessageIsStateful Property

When override in derived class, it gets a value indicating whether current message is state-ful

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract bool IsStateful { get; }

Property Value

Boolean
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.Name Property

FeedMessageName Property

When overridden in derived class, gets the name of the current message

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract string Name { get; }

Property Value

String
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.ProducerId Property

FeedMessageProducerId Property

When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract int ProducerId { get; }

Property Value

Int32
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.ReceivedAt Property

FeedMessageReceivedAt Property

Gets the timestamp of when the message was received (picked up) by the sdk

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract long ReceivedAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.RequestId Property

FeedMessageRequestId Property

Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract long? RequestId { get; }

Property Value

Nullable Int64
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.RequestIdUsage Property

FeedMessageRequestIdUsage Property

When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract PropertyUsage RequestIdUsage { get; }

Property Value

PropertyUsage
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.SentAt Property

FeedMessageSentAt Property

Gets the timestamp of when the message was sent

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract long SentAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.SportId Property

FeedMessageSportId Property

Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public URN SportId { get; set; }

Property Value

URN
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage Methods

The FeedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString)
Top
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


FeedMessage.ToString Method

FeedMessageToString Method

Returns a String that represents this instance.

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

String
A String that represents this instance
See Also

Reference

FeedMessage Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.fixture_change"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMessage
Sportradar.OddsFeed.SDK.Messages.Feedfixture_change

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class fixture_change : FeedMessage

The fixture_change type exposes the following members.

Constructors
 | Name | Description
Public method | fixture_change | Initializes a new instance of the fixture_change class
Top
Properties
 | Name | Description
Public property | change_type |
Public property | change_typeSpecified |
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | next_live_time |
Public property | next_live_timeSpecified |
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | start_time |
Public property | timestamp |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change Constructor

Initializes a new instance of the fixture_change class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public fixture_change()
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change Properties

The fixture_change type exposes the following members.

Properties
 | Name | Description
Public property | change_type |
Public property | change_typeSpecified |
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | next_live_time |
Public property | next_live_timeSpecified |
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | start_time |
Public property | timestamp |
Top
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.change_type Property

fixture_changechange_type Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.fixture_change.change_type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int change_type { get; set; }

Property Value

Int32
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.change_typeSpecified Property

fixture_changechange_typeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.fixture_change.change_typeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool change_typeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.event_id Property

fixture_changeevent_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.fixture_change.event_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string event_id { get; set; }

Property Value

String
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.EventId Property

fixture_changeEventId Property

When overridden in derived class it gets the event identifier.

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string EventId { get; }

Property Value

String
The event identifier
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.GeneratedAt Property

fixture_changeGeneratedAt Property

Gets the timestamp of when the message was generated

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long GeneratedAt { get; }

Property Value

Int64
The timestamp of the message
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.IsEventRelated Property

fixture_changeIsEventRelated Property

When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsEventRelated { get; }

Property Value

Boolean
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.IsStateful Property

fixture_changeIsStateful Property

When override in derived class, it gets a value indicating whether current message is state-ful

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsStateful { get; }

Property Value

Boolean
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.Name Property

fixture_changeName Property

When overridden in derived class, gets the name of the current message

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string Name { get; }

Property Value

String
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.next_live_time Property

fixture_changenext_live_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.fixture_change.next_live_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long next_live_time { get; set; }

Property Value

Int64
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.next_live_timeSpecified Property

fixture_changenext_live_timeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.fixture_change.next_live_timeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool next_live_timeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.ProducerId Property

fixture_changeProducerId Property

When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override int ProducerId { get; }

Property Value

Int32
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.product Property

fixture_changeproduct Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.fixture_change.product"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int product { get; set; }

Property Value

Int32
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.ReceivedAt Property

fixture_changeReceivedAt Property

Gets the timestamp of when the message was received (picked up) by the sdk

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long ReceivedAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.request_id Property

fixture_changerequest_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.fixture_change.request_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long request_id { get; set; }

Property Value

Int64
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.request_idSpecified Property

fixture_changerequest_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.fixture_change.request_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool request_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.RequestId Property

fixture_changeRequestId Property

Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long? RequestId { get; }

Property Value

Nullable Int64
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.RequestIdUsage Property

fixture_changeRequestIdUsage Property

When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override PropertyUsage RequestIdUsage { get; }

Property Value

PropertyUsage
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.SentAt Property

fixture_changeSentAt Property

Gets the timestamp of when the message was sent

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long SentAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.start_time Property

fixture_changestart_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.fixture_change.start_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long start_time { get; set; }

Property Value

Int64
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.timestamp Property

fixture_changetimestamp Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.fixture_change.timestamp"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long timestamp { get; set; }

Property Value

Int64
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change Methods

The fixture_change type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change Fields

The fixture_change type exposes the following members.

Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


fixture_change.MessageName Field

fixture_changeMessageName Field

The message name

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly string MessageName

Field Value

String
See Also

Reference

fixture_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


market Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.market"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMarket
Sportradar.OddsFeed.SDK.Messages.Feedmarket

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class market : FeedMarket

The market type exposes the following members.

Constructors
 | Name | Description
Public method | market | Initializes a new instance of the market class
Top
Properties
 | Name | Description
Public property | extended_specifiers |
Public property | id |
Public property | specifiers |
Public property | Specifiers | Gets or sets a IReadOnlyDictionaryTKey, TValue representing parsed specifiers (Inherited from FeedMarket)
Public property | SpecifierString | Gets the specifiers string (Overrides FeedMarketSpecifierString)
Public property | ValidationFailed | Gets or sets a indicating whether the validation of the market has failed and should not be mapped to exposed entity (Inherited from FeedMarket)
Public property | void_reason |
Public property | void_reasonSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


market Constructor

Initializes a new instance of the market class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public market()
See Also

Reference

market Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


market Properties

The market type exposes the following members.

Properties
 | Name | Description
Public property | extended_specifiers |
Public property | id |
Public property | specifiers |
Public property | Specifiers | Gets or sets a IReadOnlyDictionaryTKey, TValue representing parsed specifiers (Inherited from FeedMarket)
Public property | SpecifierString | Gets the specifiers string (Overrides FeedMarketSpecifierString)
Public property | ValidationFailed | Gets or sets a indicating whether the validation of the market has failed and should not be mapped to exposed entity (Inherited from FeedMarket)
Public property | void_reason |
Public property | void_reasonSpecified |
Top
See Also

Reference

market Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


market.extended_specifiers Property

marketextended_specifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.market.extended_specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string extended_specifiers { get; set; }

Property Value

String
See Also

Reference

market Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


market.id Property

marketid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.market.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int id { get; set; }

Property Value

Int32
See Also

Reference

market Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


market.specifiers Property

marketspecifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.market.specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string specifiers { get; set; }

Property Value

String
See Also

Reference

market Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


market.SpecifierString Property

marketSpecifierString Property

Gets the specifiers string

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string SpecifierString { get; }

Property Value

String
See Also

Reference

market Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


market.void_reason Property

marketvoid_reason Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.market.void_reason"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int void_reason { get; set; }

Property Value

Int32
See Also

Reference

market Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


market.void_reasonSpecified Property

marketvoid_reasonSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.market.void_reasonSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool void_reasonSpecified { get; set; }

Property Value

Boolean
See Also

Reference

market Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


market Methods

The market type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

market Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


marketMetadata Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.marketMetadata"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedmarketMetadata

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class marketMetadata

The marketMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | marketMetadata | Initializes a new instance of the marketMetadata class
Top
Properties
 | Name | Description
Public property | aams_id |
Public property | aams_idSpecified |
Public property | end_time |
Public property | end_timeSpecified |
Public property | next_betstop |
Public property | next_betstopSpecified |
Public property | start_time |
Public property | start_timeSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


marketMetadata Constructor

Initializes a new instance of the marketMetadata class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public marketMetadata()
See Also

Reference

marketMetadata Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


marketMetadata Properties

The marketMetadata type exposes the following members.

Properties
 | Name | Description
Public property | aams_id |
Public property | aams_idSpecified |
Public property | end_time |
Public property | end_timeSpecified |
Public property | next_betstop |
Public property | next_betstopSpecified |
Public property | start_time |
Public property | start_timeSpecified |
Top
See Also

Reference

marketMetadata Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


marketMetadata.aams_id Property

marketMetadataaams_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.marketMetadata.aams_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long aams_id { get; set; }

Property Value

Int64
See Also

Reference

marketMetadata Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


marketMetadata.aams_idSpecified Property

marketMetadataaams_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.marketMetadata.aams_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool aams_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

marketMetadata Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


marketMetadata.end_time Property

marketMetadataend_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.marketMetadata.end_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long end_time { get; set; }

Property Value

Int64
See Also

Reference

marketMetadata Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


marketMetadata.end_timeSpecified Property

marketMetadataend_timeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.marketMetadata.end_timeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool end_timeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

marketMetadata Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


marketMetadata.next_betstop Property

marketMetadatanext_betstop Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.marketMetadata.next_betstop"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long next_betstop { get; set; }

Property Value

Int64
See Also

Reference

marketMetadata Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


marketMetadata.next_betstopSpecified Property

marketMetadatanext_betstopSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.marketMetadata.next_betstopSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool next_betstopSpecified { get; set; }

Property Value

Boolean
See Also

Reference

marketMetadata Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


marketMetadata.start_time Property

marketMetadatastart_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.marketMetadata.start_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long start_time { get; set; }

Property Value

Int64
See Also

Reference

marketMetadata Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


marketMetadata.start_timeSpecified Property

marketMetadatastart_timeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.marketMetadata.start_timeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_timeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

marketMetadata Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


marketMetadata Methods

The marketMetadata type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

marketMetadata Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.odds_change"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMessage
Sportradar.OddsFeed.SDK.Messages.Feedodds_change

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class odds_change : FeedMessage

The odds_change type exposes the following members.

Constructors
 | Name | Description
Public method | odds_change | Initializes a new instance of the odds_change class
Top
Properties
 | Name | Description
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | odds |
Public property | odds_change_reason |
Public property | odds_change_reasonSpecified |
Public property | odds_generation_properties |
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | sport_event_status |
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | timestamp |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change Constructor

Initializes a new instance of the odds_change class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public odds_change()
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change Properties

The odds_change type exposes the following members.

Properties
 | Name | Description
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | odds |
Public property | odds_change_reason |
Public property | odds_change_reasonSpecified |
Public property | odds_generation_properties |
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | sport_event_status |
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | timestamp |
Top
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.event_id Property

odds_changeevent_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_change.event_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string event_id { get; set; }

Property Value

String
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.EventId Property

odds_changeEventId Property

When overridden in derived class it gets the event identifier.

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string EventId { get; }

Property Value

String
The event identifier
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.GeneratedAt Property

odds_changeGeneratedAt Property

Gets the timestamp of when the message was generated

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long GeneratedAt { get; }

Property Value

Int64
The timestamp of the message
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.IsEventRelated Property

odds_changeIsEventRelated Property

When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsEventRelated { get; }

Property Value

Boolean
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.IsStateful Property

odds_changeIsStateful Property

When override in derived class, it gets a value indicating whether current message is state-ful

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsStateful { get; }

Property Value

Boolean
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.Name Property

odds_changeName Property

When overridden in derived class, gets the name of the current message

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string Name { get; }

Property Value

String
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.odds Property

odds_changeodds Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_change.odds"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public odds_changeOdds odds { get; set; }

Property Value

odds_changeOdds
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.odds_change_reason Property

odds_changeodds_change_reason Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_change.odds_change_reason"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int odds_change_reason { get; set; }

Property Value

Int32
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.odds_change_reasonSpecified Property

odds_changeodds_change_reasonSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_change.odds_change_reasonSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool odds_change_reasonSpecified { get; set; }

Property Value

Boolean
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.odds_generation_properties Property

odds_changeodds_generation_properties Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_change.odds_generation_properties"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public oddsGenerationProperties odds_generation_properties { get; set; }

Property Value

oddsGenerationProperties
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.ProducerId Property

odds_changeProducerId Property

When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override int ProducerId { get; }

Property Value

Int32
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.product Property

odds_changeproduct Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_change.product"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int product { get; set; }

Property Value

Int32
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.ReceivedAt Property

odds_changeReceivedAt Property

Gets the timestamp of when the message was received (picked up) by the sdk

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long ReceivedAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.request_id Property

odds_changerequest_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_change.request_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long request_id { get; set; }

Property Value

Int64
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.request_idSpecified Property

odds_changerequest_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_change.request_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool request_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.RequestId Property

odds_changeRequestId Property

Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long? RequestId { get; }

Property Value

Nullable Int64
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.RequestIdUsage Property

odds_changeRequestIdUsage Property

When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override PropertyUsage RequestIdUsage { get; }

Property Value

PropertyUsage
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.SentAt Property

odds_changeSentAt Property

Gets the timestamp of when the message was sent

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long SentAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.sport_event_status Property

odds_changesport_event_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_change.sport_event_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEventStatus sport_event_status { get; set; }

Property Value

sportEventStatus
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.timestamp Property

odds_changetimestamp Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_change.timestamp"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long timestamp { get; set; }

Property Value

Int64
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change Methods

The odds_change type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change Fields

The odds_change type exposes the following members.

Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_change.MessageName Field

odds_changeMessageName Field

The message name

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly string MessageName

Field Value

String
See Also

Reference

odds_change Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_changeOdds Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.odds_changeOdds"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.Feedodds_changeOdds

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class odds_changeOdds

The odds_changeOdds type exposes the following members.

Constructors
 | Name | Description
Public method | odds_changeOdds | Initializes a new instance of the odds_changeOdds class
Top
Properties
 | Name | Description
Public property | betstop_reason |
Public property | betstop_reasonSpecified |
Public property | betting_status |
Public property | betting_statusSpecified |
Public property | market |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_changeOdds Constructor

Initializes a new instance of the odds_changeOdds class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public odds_changeOdds()
See Also

Reference

odds_changeOdds Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_changeOdds Properties

The odds_changeOdds type exposes the following members.

Properties
 | Name | Description
Public property | betstop_reason |
Public property | betstop_reasonSpecified |
Public property | betting_status |
Public property | betting_statusSpecified |
Public property | market |
Top
See Also

Reference

odds_changeOdds Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_changeOdds.betstop_reason Property

odds_changeOddsbetstop_reason Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_changeOdds.betstop_reason"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int betstop_reason { get; set; }

Property Value

Int32
See Also

Reference

odds_changeOdds Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_changeOdds.betstop_reasonSpecified Property

odds_changeOddsbetstop_reasonSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_changeOdds.betstop_reasonSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool betstop_reasonSpecified { get; set; }

Property Value

Boolean
See Also

Reference

odds_changeOdds Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_changeOdds.betting_status Property

odds_changeOddsbetting_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_changeOdds.betting_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int betting_status { get; set; }

Property Value

Int32
See Also

Reference

odds_changeOdds Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_changeOdds.betting_statusSpecified Property

odds_changeOddsbetting_statusSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_changeOdds.betting_statusSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool betting_statusSpecified { get; set; }

Property Value

Boolean
See Also

Reference

odds_changeOdds Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_changeOdds.market Property

odds_changeOddsmarket Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.odds_changeOdds.market"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public oddsChangeMarket[] market { get; set; }

Property Value

oddsChangeMarket
See Also

Reference

odds_changeOdds Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


odds_changeOdds Methods

The odds_changeOdds type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

odds_changeOdds Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarket"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMarket
Sportradar.OddsFeed.SDK.Messages.FeedoddsChangeMarket

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class oddsChangeMarket : FeedMarket

The oddsChangeMarket type exposes the following members.

Constructors
 | Name | Description
Public method | oddsChangeMarket | Initializes a new instance of the oddsChangeMarket class
Top
Properties
 | Name | Description
Public property | cashout_status |
Public property | cashout_statusSpecified |
Public property | extended_specifiers |
Public property | favourite |
Public property | favouriteSpecified |
Public property | id |
Public property | market_metadata |
Public property | outcome |
Public property | specifiers |
Public property | Specifiers | Gets or sets a IReadOnlyDictionaryTKey, TValue representing parsed specifiers (Inherited from FeedMarket)
Public property | SpecifierString | Gets the specifiers string (Overrides FeedMarketSpecifierString)
Public property | status |
Public property | statusSpecified |
Public property | ValidationFailed | Gets or sets a indicating whether the validation of the market has failed and should not be mapped to exposed entity (Inherited from FeedMarket)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket Constructor

Initializes a new instance of the oddsChangeMarket class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public oddsChangeMarket()
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket Properties

The oddsChangeMarket type exposes the following members.

Properties
 | Name | Description
Public property | cashout_status |
Public property | cashout_statusSpecified |
Public property | extended_specifiers |
Public property | favourite |
Public property | favouriteSpecified |
Public property | id |
Public property | market_metadata |
Public property | outcome |
Public property | specifiers |
Public property | Specifiers | Gets or sets a IReadOnlyDictionaryTKey, TValue representing parsed specifiers (Inherited from FeedMarket)
Public property | SpecifierString | Gets the specifiers string (Overrides FeedMarketSpecifierString)
Public property | status |
Public property | statusSpecified |
Public property | ValidationFailed | Gets or sets a indicating whether the validation of the market has failed and should not be mapped to exposed entity (Inherited from FeedMarket)
Top
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket.cashout_status Property

oddsChangeMarketcashout_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarket.cashout_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int cashout_status { get; set; }

Property Value

Int32
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket.cashout_statusSpecified Property

oddsChangeMarketcashout_statusSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarket.cashout_statusSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool cashout_statusSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket.extended_specifiers Property

oddsChangeMarketextended_specifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarket.extended_specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string extended_specifiers { get; set; }

Property Value

String
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket.favourite Property

oddsChangeMarketfavourite Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarket.favourite"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int favourite { get; set; }

Property Value

Int32
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket.favouriteSpecified Property

oddsChangeMarketfavouriteSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarket.favouriteSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool favouriteSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket.id Property

oddsChangeMarketid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarket.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int id { get; set; }

Property Value

Int32
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket.market_metadata Property

oddsChangeMarketmarket_metadata Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarket.market_metadata"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public marketMetadata market_metadata { get; set; }

Property Value

marketMetadata
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket.outcome Property

oddsChangeMarketoutcome Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarket.outcome"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public oddsChangeMarketOutcome[] outcome { get; set; }

Property Value

oddsChangeMarketOutcome
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket.specifiers Property

oddsChangeMarketspecifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarket.specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string specifiers { get; set; }

Property Value

String
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket.SpecifierString Property

oddsChangeMarketSpecifierString Property

Gets the specifiers string

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string SpecifierString { get; }

Property Value

String
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket.status Property

oddsChangeMarketstatus Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarket.status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int status { get; set; }

Property Value

Int32
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket.statusSpecified Property

oddsChangeMarketstatusSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarket.statusSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool statusSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarket Methods

The oddsChangeMarket type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

oddsChangeMarket Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedoddsChangeMarketOutcome

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class oddsChangeMarketOutcome

The oddsChangeMarketOutcome type exposes the following members.

Constructors
 | Name | Description
Public method | oddsChangeMarketOutcome | Initializes a new instance of the oddsChangeMarketOutcome class
Top
Properties
 | Name | Description
Public property | active |
Public property | activeSpecified |
Public property | half_lose_probabilities |
Public property | half_lose_probabilitiesSpecified |
Public property | half_win_probabilities |
Public property | half_win_probabilitiesSpecified |
Public property | id |
Public property | lose_probabilities |
Public property | lose_probabilitiesSpecified |
Public property | odds |
Public property | oddsSpecified |
Public property | probabilities |
Public property | probabilitiesSpecified |
Public property | refund_probabilities |
Public property | refund_probabilitiesSpecified |
Public property | team |
Public property | teamSpecified |
Public property | win_probabilities |
Public property | win_probabilitiesSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome Constructor

Initializes a new instance of the oddsChangeMarketOutcome class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public oddsChangeMarketOutcome()
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome Properties

The oddsChangeMarketOutcome type exposes the following members.

Properties
 | Name | Description
Public property | active |
Public property | activeSpecified |
Public property | half_lose_probabilities |
Public property | half_lose_probabilitiesSpecified |
Public property | half_win_probabilities |
Public property | half_win_probabilitiesSpecified |
Public property | id |
Public property | lose_probabilities |
Public property | lose_probabilitiesSpecified |
Public property | odds |
Public property | oddsSpecified |
Public property | probabilities |
Public property | probabilitiesSpecified |
Public property | refund_probabilities |
Public property | refund_probabilitiesSpecified |
Public property | team |
Public property | teamSpecified |
Public property | win_probabilities |
Public property | win_probabilitiesSpecified |
Top
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.active Property

oddsChangeMarketOutcomeactive Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.active"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int active { get; set; }

Property Value

Int32
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.activeSpecified Property

oddsChangeMarketOutcomeactiveSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.activeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool activeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.half_lose_probabilities Property

oddsChangeMarketOutcomehalf_lose_probabilities Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.half_lose_probabilities"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double half_lose_probabilities { get; set; }

Property Value

Double
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.half_lose_probabilitiesSpecified Property

oddsChangeMarketOutcomehalf_lose_probabilitiesSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.half_lose_probabilitiesSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool half_lose_probabilitiesSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.half_win_probabilities Property

oddsChangeMarketOutcomehalf_win_probabilities Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.half_win_probabilities"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double half_win_probabilities { get; set; }

Property Value

Double
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.half_win_probabilitiesSpecified Property

oddsChangeMarketOutcomehalf_win_probabilitiesSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.half_win_probabilitiesSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool half_win_probabilitiesSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.id Property

oddsChangeMarketOutcomeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.lose_probabilities Property

oddsChangeMarketOutcomelose_probabilities Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.lose_probabilities"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double lose_probabilities { get; set; }

Property Value

Double
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.lose_probabilitiesSpecified Property

oddsChangeMarketOutcomelose_probabilitiesSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.lose_probabilitiesSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool lose_probabilitiesSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.odds Property

oddsChangeMarketOutcomeodds Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.odds"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double odds { get; set; }

Property Value

Double
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.oddsSpecified Property

oddsChangeMarketOutcomeoddsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.oddsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool oddsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.probabilities Property

oddsChangeMarketOutcomeprobabilities Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.probabilities"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double probabilities { get; set; }

Property Value

Double
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.probabilitiesSpecified Property

oddsChangeMarketOutcomeprobabilitiesSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.probabilitiesSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool probabilitiesSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.refund_probabilities Property

oddsChangeMarketOutcomerefund_probabilities Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.refund_probabilities"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double refund_probabilities { get; set; }

Property Value

Double
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.refund_probabilitiesSpecified Property

oddsChangeMarketOutcomerefund_probabilitiesSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.refund_probabilitiesSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool refund_probabilitiesSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.team Property

oddsChangeMarketOutcometeam Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.team"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int team { get; set; }

Property Value

Int32
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.teamSpecified Property

oddsChangeMarketOutcometeamSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.teamSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool teamSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.win_probabilities Property

oddsChangeMarketOutcomewin_probabilities Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.win_probabilities"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double win_probabilities { get; set; }

Property Value

Double
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome.win_probabilitiesSpecified Property

oddsChangeMarketOutcomewin_probabilitiesSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsChangeMarketOutcome.win_probabilitiesSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool win_probabilitiesSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsChangeMarketOutcome Methods

The oddsChangeMarketOutcome type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

oddsChangeMarketOutcome Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsGenerationProperties Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.oddsGenerationProperties"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedoddsGenerationProperties

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class oddsGenerationProperties

The oddsGenerationProperties type exposes the following members.

Constructors
 | Name | Description
Public method | oddsGenerationProperties | Initializes a new instance of the oddsGenerationProperties class
Top
Properties
 | Name | Description
Public property | expected_supremacy |
Public property | expected_supremacySpecified |
Public property | expected_totals |
Public property | expected_totalsSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsGenerationProperties Constructor

Initializes a new instance of the oddsGenerationProperties class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public oddsGenerationProperties()
See Also

Reference

oddsGenerationProperties Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsGenerationProperties Properties

The oddsGenerationProperties type exposes the following members.

Properties
 | Name | Description
Public property | expected_supremacy |
Public property | expected_supremacySpecified |
Public property | expected_totals |
Public property | expected_totalsSpecified |
Top
See Also

Reference

oddsGenerationProperties Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsGenerationProperties.expected_supremacy Property

oddsGenerationPropertiesexpected_supremacy Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsGenerationProperties.expected_supremacy"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double expected_supremacy { get; set; }

Property Value

Double
See Also

Reference

oddsGenerationProperties Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsGenerationProperties.expected_supremacySpecified Property

oddsGenerationPropertiesexpected_supremacySpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsGenerationProperties.expected_supremacySpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool expected_supremacySpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsGenerationProperties Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsGenerationProperties.expected_totals Property

oddsGenerationPropertiesexpected_totals Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsGenerationProperties.expected_totals"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double expected_totals { get; set; }

Property Value

Double
See Also

Reference

oddsGenerationProperties Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsGenerationProperties.expected_totalsSpecified Property

oddsGenerationPropertiesexpected_totalsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.oddsGenerationProperties.expected_totalsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool expected_totalsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

oddsGenerationProperties Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


oddsGenerationProperties Methods

The oddsGenerationProperties type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

oddsGenerationProperties Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


periodScoreType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.periodScoreType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedperiodScoreType

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class periodScoreType

The periodScoreType type exposes the following members.

Constructors
 | Name | Description
Public method | periodScoreType | Initializes a new instance of the periodScoreType class
Top
Properties
 | Name | Description
Public property | away_score |
Public property | home_score |
Public property | match_status_code |
Public property | number |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


periodScoreType Constructor

Initializes a new instance of the periodScoreType class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public periodScoreType()
See Also

Reference

periodScoreType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


periodScoreType Properties

The periodScoreType type exposes the following members.

Properties
 | Name | Description
Public property | away_score |
Public property | home_score |
Public property | match_status_code |
Public property | number |
Top
See Also

Reference

periodScoreType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


periodScoreType.away_score Property

periodScoreTypeaway_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.periodScoreType.away_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public decimal away_score { get; set; }

Property Value

Decimal
See Also

Reference

periodScoreType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


periodScoreType.home_score Property

periodScoreTypehome_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.periodScoreType.home_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public decimal home_score { get; set; }

Property Value

Decimal
See Also

Reference

periodScoreType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


periodScoreType.match_status_code Property

periodScoreTypematch_status_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.periodScoreType.match_status_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int match_status_code { get; set; }

Property Value

Int32
See Also

Reference

periodScoreType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


periodScoreType.number Property

periodScoreTypenumber Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.periodScoreType.number"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int number { get; set; }

Property Value

Int32
See Also

Reference

periodScoreType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


periodScoreType Methods

The periodScoreType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

periodScoreType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


PropertyUsage Enumeration

Enumerates property usage requirements

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public enum PropertyUsage
Members
Member name | Value | Description
FORBBIDEN | 0 | The value of the property must not be specified
OPTIONAL | 1 | The usage of the property is optional
REQUIRED | 2 | The usage of the property is required
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


resultType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.resultType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedresultType

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class resultType

The resultType type exposes the following members.

Constructors
 | Name | Description
Public method | resultType | Initializes a new instance of the resultType class
Top
Properties
 | Name | Description
Public property | away_score |
Public property | home_score |
Public property | match_status_code |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


resultType Constructor

Initializes a new instance of the resultType class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public resultType()
See Also

Reference

resultType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


resultType Properties

The resultType type exposes the following members.

Properties
 | Name | Description
Public property | away_score |
Public property | home_score |
Public property | match_status_code |
Top
See Also

Reference

resultType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


resultType.away_score Property

resultTypeaway_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.resultType.away_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public decimal away_score { get; set; }

Property Value

Decimal
See Also

Reference

resultType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


resultType.home_score Property

resultTypehome_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.resultType.home_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public decimal home_score { get; set; }

Property Value

Decimal
See Also

Reference

resultType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


resultType.match_status_code Property

resultTypematch_status_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.resultType.match_status_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int match_status_code { get; set; }

Property Value

Int32
See Also

Reference

resultType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


resultType Methods

The resultType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

resultType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_cancel"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMessage
Sportradar.OddsFeed.SDK.Messages.Feedrollback_bet_cancel

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class rollback_bet_cancel : FeedMessage

The rollback_bet_cancel type exposes the following members.

Constructors
 | Name | Description
Public method | rollback_bet_cancel | Initializes a new instance of the rollback_bet_cancel class
Top
Properties
 | Name | Description
Public property | end_time |
Public property | end_timeSpecified |
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | market |
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | start_time |
Public property | start_timeSpecified |
Public property | timestamp |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel Constructor

Initializes a new instance of the rollback_bet_cancel class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public rollback_bet_cancel()
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel Properties

The rollback_bet_cancel type exposes the following members.

Properties
 | Name | Description
Public property | end_time |
Public property | end_timeSpecified |
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | market |
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | start_time |
Public property | start_timeSpecified |
Public property | timestamp |
Top
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.end_time Property

rollback_bet_cancelend_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_cancel.end_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long end_time { get; set; }

Property Value

Int64
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.end_timeSpecified Property

rollback_bet_cancelend_timeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_cancel.end_timeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool end_timeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.event_id Property

rollback_bet_cancelevent_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_cancel.event_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string event_id { get; set; }

Property Value

String
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.EventId Property

rollback_bet_cancelEventId Property

When overridden in derived class it gets the event identifier.

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string EventId { get; }

Property Value

String
The event identifier
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.GeneratedAt Property

rollback_bet_cancelGeneratedAt Property

Gets the timestamp of when the message was generated

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long GeneratedAt { get; }

Property Value

Int64
The timestamp of the message
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.IsEventRelated Property

rollback_bet_cancelIsEventRelated Property

When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsEventRelated { get; }

Property Value

Boolean
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.IsStateful Property

rollback_bet_cancelIsStateful Property

When override in derived class, it gets a value indicating whether current message is state-ful

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsStateful { get; }

Property Value

Boolean
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.market Property

rollback_bet_cancelmarket Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_cancel.market"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public market[] market { get; set; }

Property Value

market
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.Name Property

rollback_bet_cancelName Property

When overridden in derived class, gets the name of the current message

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string Name { get; }

Property Value

String
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.ProducerId Property

rollback_bet_cancelProducerId Property

When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override int ProducerId { get; }

Property Value

Int32
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.product Property

rollback_bet_cancelproduct Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_cancel.product"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int product { get; set; }

Property Value

Int32
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.ReceivedAt Property

rollback_bet_cancelReceivedAt Property

Gets the timestamp of when the message was received (picked up) by the sdk

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long ReceivedAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.request_id Property

rollback_bet_cancelrequest_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_cancel.request_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long request_id { get; set; }

Property Value

Int64
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.request_idSpecified Property

rollback_bet_cancelrequest_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_cancel.request_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool request_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.RequestId Property

rollback_bet_cancelRequestId Property

Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long? RequestId { get; }

Property Value

Nullable Int64
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.RequestIdUsage Property

rollback_bet_cancelRequestIdUsage Property

When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override PropertyUsage RequestIdUsage { get; }

Property Value

PropertyUsage
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.SentAt Property

rollback_bet_cancelSentAt Property

Gets the timestamp of when the message was sent

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long SentAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.start_time Property

rollback_bet_cancelstart_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_cancel.start_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long start_time { get; set; }

Property Value

Int64
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.start_timeSpecified Property

rollback_bet_cancelstart_timeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_cancel.start_timeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_timeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.timestamp Property

rollback_bet_canceltimestamp Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_cancel.timestamp"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long timestamp { get; set; }

Property Value

Int64
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel Methods

The rollback_bet_cancel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel Fields

The rollback_bet_cancel type exposes the following members.

Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_cancel.MessageName Field

rollback_bet_cancelMessageName Field

The message name

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly string MessageName

Field Value

String
See Also

Reference

rollback_bet_cancel Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_settlement"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMessage
Sportradar.OddsFeed.SDK.Messages.Feedrollback_bet_settlement

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class rollback_bet_settlement : FeedMessage

The rollback_bet_settlement type exposes the following members.

Constructors
 | Name | Description
Public method | rollback_bet_settlement | Initializes a new instance of the rollback_bet_settlement class
Top
Properties
 | Name | Description
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | market |
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | timestamp |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement Constructor

Initializes a new instance of the rollback_bet_settlement class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public rollback_bet_settlement()
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement Properties

The rollback_bet_settlement type exposes the following members.

Properties
 | Name | Description
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | market |
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | timestamp |
Top
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.event_id Property

rollback_bet_settlementevent_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_settlement.event_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string event_id { get; set; }

Property Value

String
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.EventId Property

rollback_bet_settlementEventId Property

When overridden in derived class it gets the event identifier.

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string EventId { get; }

Property Value

String
The event identifier
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.GeneratedAt Property

rollback_bet_settlementGeneratedAt Property

Gets the timestamp of when the message was generated

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long GeneratedAt { get; }

Property Value

Int64
The timestamp of the message
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.IsEventRelated Property

rollback_bet_settlementIsEventRelated Property

When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsEventRelated { get; }

Property Value

Boolean
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.IsStateful Property

rollback_bet_settlementIsStateful Property

When override in derived class, it gets a value indicating whether current message is state-ful

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsStateful { get; }

Property Value

Boolean
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.market Property

rollback_bet_settlementmarket Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_settlement.market"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public market[] market { get; set; }

Property Value

market
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.Name Property

rollback_bet_settlementName Property

When overridden in derived class, gets the name of the current message

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string Name { get; }

Property Value

String
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.ProducerId Property

rollback_bet_settlementProducerId Property

When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override int ProducerId { get; }

Property Value

Int32
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.product Property

rollback_bet_settlementproduct Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_settlement.product"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int product { get; set; }

Property Value

Int32
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.ReceivedAt Property

rollback_bet_settlementReceivedAt Property

Gets the timestamp of when the message was received (picked up) by the sdk

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long ReceivedAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.request_id Property

rollback_bet_settlementrequest_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_settlement.request_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long request_id { get; set; }

Property Value

Int64
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.request_idSpecified Property

rollback_bet_settlementrequest_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_settlement.request_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool request_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.RequestId Property

rollback_bet_settlementRequestId Property

Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long? RequestId { get; }

Property Value

Nullable Int64
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.RequestIdUsage Property

rollback_bet_settlementRequestIdUsage Property

When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override PropertyUsage RequestIdUsage { get; }

Property Value

PropertyUsage
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.SentAt Property

rollback_bet_settlementSentAt Property

Gets the timestamp of when the message was sent

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long SentAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.timestamp Property

rollback_bet_settlementtimestamp Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.rollback_bet_settlement.timestamp"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long timestamp { get; set; }

Property Value

Int64
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement Methods

The rollback_bet_settlement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement Fields

The rollback_bet_settlement type exposes the following members.

Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


rollback_bet_settlement.MessageName Field

rollback_bet_settlementMessageName Field

The message name

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly string MessageName

Field Value

String
See Also

Reference

rollback_bet_settlement Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.snapshot_complete"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMessage
Sportradar.OddsFeed.SDK.Messages.Feedsnapshot_complete

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class snapshot_complete : FeedMessage

The snapshot_complete type exposes the following members.

Constructors
 | Name | Description
Public method | snapshot_complete | Initializes a new instance of the snapshot_complete class
Top
Properties
 | Name | Description
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | timestamp |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete Constructor

Initializes a new instance of the snapshot_complete class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public snapshot_complete()
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete Properties

The snapshot_complete type exposes the following members.

Properties
 | Name | Description
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of when the message was generated (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | timestamp |
Top
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.EventId Property

snapshot_completeEventId Property

When overridden in derived class it gets the event identifier.

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string EventId { get; }

Property Value

String
The event identifier
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.GeneratedAt Property

snapshot_completeGeneratedAt Property

Gets the timestamp of when the message was generated

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long GeneratedAt { get; }

Property Value

Int64
The timestamp of the message
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.IsEventRelated Property

snapshot_completeIsEventRelated Property

When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsEventRelated { get; }

Property Value

Boolean
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.IsStateful Property

snapshot_completeIsStateful Property

When override in derived class, it gets a value indicating whether current message is state-ful

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsStateful { get; }

Property Value

Boolean
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.Name Property

snapshot_completeName Property

When overridden in derived class, gets the name of the current message

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string Name { get; }

Property Value

String
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.ProducerId Property

snapshot_completeProducerId Property

When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override int ProducerId { get; }

Property Value

Int32
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.product Property

snapshot_completeproduct Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.snapshot_complete.product"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int product { get; set; }

Property Value

Int32
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.ReceivedAt Property

snapshot_completeReceivedAt Property

Gets the timestamp of when the message was received (picked up) by the sdk

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long ReceivedAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.request_id Property

snapshot_completerequest_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.snapshot_complete.request_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long request_id { get; set; }

Property Value

Int64
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.RequestId Property

snapshot_completeRequestId Property

Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long? RequestId { get; }

Property Value

Nullable Int64
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.RequestIdUsage Property

snapshot_completeRequestIdUsage Property

When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override PropertyUsage RequestIdUsage { get; }

Property Value

PropertyUsage
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.SentAt Property

snapshot_completeSentAt Property

Gets the timestamp of when the message was sent

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long SentAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.timestamp Property

snapshot_completetimestamp Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.snapshot_complete.timestamp"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long timestamp { get; set; }

Property Value

Int64
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete Methods

The snapshot_complete type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete Fields

The snapshot_complete type exposes the following members.

Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


snapshot_complete.MessageName Field

snapshot_completeMessageName Field

The message name

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly string MessageName

Field Value

String
See Also

Reference

snapshot_complete Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedsportEventStatus

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class sportEventStatus

The sportEventStatus type exposes the following members.

Constructors
 | Name | Description
Public method | sportEventStatus | Initializes a new instance of the sportEventStatus class
Top
Properties
 | Name | Description
Public property | away_batter |
Public property | away_batterSpecified |
Public property | away_dismissals |
Public property | away_dismissalsSpecified |
Public property | away_drive_count |
Public property | away_drive_countSpecified |
Public property | away_gamescore |
Public property | away_gamescoreSpecified |
Public property | away_legscore |
Public property | away_legscoreSpecified |
Public property | away_penalty_runs |
Public property | away_penalty_runsSpecified |
Public property | away_penalty_score |
Public property | away_penalty_scoreSpecified |
Public property | away_play_count |
Public property | away_play_countSpecified |
Public property | away_remaining_bowls |
Public property | away_remaining_bowlsSpecified |
Public property | away_score |
Public property | away_scoreSpecified |
Public property | away_suspend |
Public property | away_suspendSpecified |
Public property | balls |
Public property | ballsSpecified |
Public property | bases |
Public property | batter |
Public property | clock |
Public property | current_ct_team |
Public property | current_ct_teamSpecified |
Public property | current_end |
Public property | current_endSpecified |
Public property | current_server |
Public property | current_serverSpecified |
Public property | delivery |
Public property | deliverySpecified |
Public property | expedite_mode |
Public property | expedite_modeSpecified |
Public property | home_batter |
Public property | home_batterSpecified |
Public property | home_dismissals |
Public property | home_dismissalsSpecified |
Public property | home_drive_count |
Public property | home_drive_countSpecified |
Public property | home_gamescore |
Public property | home_gamescoreSpecified |
Public property | home_legscore |
Public property | home_legscoreSpecified |
Public property | home_penalty_runs |
Public property | home_penalty_runsSpecified |
Public property | home_penalty_score |
Public property | home_penalty_scoreSpecified |
Public property | home_play_count |
Public property | home_play_countSpecified |
Public property | home_remaining_bowls |
Public property | home_remaining_bowlsSpecified |
Public property | home_score |
Public property | home_scoreSpecified |
Public property | home_suspend |
Public property | home_suspendSpecified |
Public property | innings |
Public property | inningsSpecified |
Public property | match_status |
Public property | outs |
Public property | outsSpecified |
Public property | over |
Public property | overSpecified |
Public property | period_of_leader |
Public property | period_of_leaderSpecified |
Public property | period_scores |
Public property | pitch_count |
Public property | pitch_countSpecified |
Public property | pitcher |
Public property | pitches_seen |
Public property | pitches_seenSpecified |
Public property | position |
Public property | positionSpecified |
Public property | possession |
Public property | possessionSpecified |
Public property | remaining_reds |
Public property | remaining_redsSpecified |
Public property | reporting |
Public property | reportingSpecified |
Public property | results |
Public property | statistics |
Public property | status |
Public property | strikes |
Public property | strikesSpecified |
Public property | throw |
Public property | throwSpecified |
Public property | tiebreak |
Public property | tiebreakSpecified |
Public property | total_hits |
Public property | total_hitsSpecified |
Public property | total_pitches |
Public property | total_pitchesSpecified |
Public property | try |
Public property | trySpecified |
Public property | visit |
Public property | visitSpecified |
Public property | yards |
Public property | yardsSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus Constructor

Initializes a new instance of the sportEventStatus class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEventStatus()
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus Properties

The sportEventStatus type exposes the following members.

Properties
 | Name | Description
Public property | away_batter |
Public property | away_batterSpecified |
Public property | away_dismissals |
Public property | away_dismissalsSpecified |
Public property | away_drive_count |
Public property | away_drive_countSpecified |
Public property | away_gamescore |
Public property | away_gamescoreSpecified |
Public property | away_legscore |
Public property | away_legscoreSpecified |
Public property | away_penalty_runs |
Public property | away_penalty_runsSpecified |
Public property | away_penalty_score |
Public property | away_penalty_scoreSpecified |
Public property | away_play_count |
Public property | away_play_countSpecified |
Public property | away_remaining_bowls |
Public property | away_remaining_bowlsSpecified |
Public property | away_score |
Public property | away_scoreSpecified |
Public property | away_suspend |
Public property | away_suspendSpecified |
Public property | balls |
Public property | ballsSpecified |
Public property | bases |
Public property | batter |
Public property | clock |
Public property | current_ct_team |
Public property | current_ct_teamSpecified |
Public property | current_end |
Public property | current_endSpecified |
Public property | current_server |
Public property | current_serverSpecified |
Public property | delivery |
Public property | deliverySpecified |
Public property | expedite_mode |
Public property | expedite_modeSpecified |
Public property | home_batter |
Public property | home_batterSpecified |
Public property | home_dismissals |
Public property | home_dismissalsSpecified |
Public property | home_drive_count |
Public property | home_drive_countSpecified |
Public property | home_gamescore |
Public property | home_gamescoreSpecified |
Public property | home_legscore |
Public property | home_legscoreSpecified |
Public property | home_penalty_runs |
Public property | home_penalty_runsSpecified |
Public property | home_penalty_score |
Public property | home_penalty_scoreSpecified |
Public property | home_play_count |
Public property | home_play_countSpecified |
Public property | home_remaining_bowls |
Public property | home_remaining_bowlsSpecified |
Public property | home_score |
Public property | home_scoreSpecified |
Public property | home_suspend |
Public property | home_suspendSpecified |
Public property | innings |
Public property | inningsSpecified |
Public property | match_status |
Public property | outs |
Public property | outsSpecified |
Public property | over |
Public property | overSpecified |
Public property | period_of_leader |
Public property | period_of_leaderSpecified |
Public property | period_scores |
Public property | pitch_count |
Public property | pitch_countSpecified |
Public property | pitcher |
Public property | pitches_seen |
Public property | pitches_seenSpecified |
Public property | position |
Public property | positionSpecified |
Public property | possession |
Public property | possessionSpecified |
Public property | remaining_reds |
Public property | remaining_redsSpecified |
Public property | reporting |
Public property | reportingSpecified |
Public property | results |
Public property | statistics |
Public property | status |
Public property | strikes |
Public property | strikesSpecified |
Public property | throw |
Public property | throwSpecified |
Public property | tiebreak |
Public property | tiebreakSpecified |
Public property | total_hits |
Public property | total_hitsSpecified |
Public property | total_pitches |
Public property | total_pitchesSpecified |
Public property | try |
Public property | trySpecified |
Public property | visit |
Public property | visitSpecified |
Public property | yards |
Public property | yardsSpecified |
Top
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_batter Property

sportEventStatusaway_batter Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_batter"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int away_batter { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_batterSpecified Property

sportEventStatusaway_batterSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_batterSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool away_batterSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_dismissals Property

sportEventStatusaway_dismissals Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_dismissals"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int away_dismissals { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_dismissalsSpecified Property

sportEventStatusaway_dismissalsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_dismissalsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool away_dismissalsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_drive_count Property

sportEventStatusaway_drive_count Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_drive_count"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int away_drive_count { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_drive_countSpecified Property

sportEventStatusaway_drive_countSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_drive_countSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool away_drive_countSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_gamescore Property

sportEventStatusaway_gamescore Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_gamescore"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int away_gamescore { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_gamescoreSpecified Property

sportEventStatusaway_gamescoreSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_gamescoreSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool away_gamescoreSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_legscore Property

sportEventStatusaway_legscore Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_legscore"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int away_legscore { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_legscoreSpecified Property

sportEventStatusaway_legscoreSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_legscoreSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool away_legscoreSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_penalty_runs Property

sportEventStatusaway_penalty_runs Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_penalty_runs"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int away_penalty_runs { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_penalty_runsSpecified Property

sportEventStatusaway_penalty_runsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_penalty_runsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool away_penalty_runsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_penalty_score Property

sportEventStatusaway_penalty_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_penalty_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int away_penalty_score { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_penalty_scoreSpecified Property

sportEventStatusaway_penalty_scoreSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_penalty_scoreSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool away_penalty_scoreSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_play_count Property

sportEventStatusaway_play_count Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_play_count"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int away_play_count { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_play_countSpecified Property

sportEventStatusaway_play_countSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_play_countSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool away_play_countSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_remaining_bowls Property

sportEventStatusaway_remaining_bowls Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_remaining_bowls"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int away_remaining_bowls { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_remaining_bowlsSpecified Property

sportEventStatusaway_remaining_bowlsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_remaining_bowlsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool away_remaining_bowlsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_score Property

sportEventStatusaway_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public decimal away_score { get; set; }

Property Value

Decimal
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_scoreSpecified Property

sportEventStatusaway_scoreSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_scoreSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool away_scoreSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_suspend Property

sportEventStatusaway_suspend Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_suspend"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int away_suspend { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.away_suspendSpecified Property

sportEventStatusaway_suspendSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.away_suspendSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool away_suspendSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.balls Property

sportEventStatusballs Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.balls"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int balls { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.ballsSpecified Property

sportEventStatusballsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.ballsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool ballsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.bases Property

sportEventStatusbases Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.bases"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string bases { get; set; }

Property Value

String
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.batter Property

sportEventStatusbatter Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.batter"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string batter { get; set; }

Property Value

String
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.clock Property

sportEventStatusclock Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.clock"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public clockType clock { get; set; }

Property Value

clockType
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.current_ct_team Property

sportEventStatuscurrent_ct_team Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.current_ct_team"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int current_ct_team { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.current_ct_teamSpecified Property

sportEventStatuscurrent_ct_teamSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.current_ct_teamSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool current_ct_teamSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.current_end Property

sportEventStatuscurrent_end Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.current_end"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int current_end { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.current_endSpecified Property

sportEventStatuscurrent_endSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.current_endSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool current_endSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.current_server Property

sportEventStatuscurrent_server Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.current_server"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int current_server { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.current_serverSpecified Property

sportEventStatuscurrent_serverSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.current_serverSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool current_serverSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.delivery Property

sportEventStatusdelivery Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.delivery"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int delivery { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.deliverySpecified Property

sportEventStatusdeliverySpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.deliverySpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool deliverySpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.expedite_mode Property

sportEventStatusexpedite_mode Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.expedite_mode"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool expedite_mode { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.expedite_modeSpecified Property

sportEventStatusexpedite_modeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.expedite_modeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool expedite_modeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_batter Property

sportEventStatushome_batter Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_batter"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int home_batter { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_batterSpecified Property

sportEventStatushome_batterSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_batterSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool home_batterSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_dismissals Property

sportEventStatushome_dismissals Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_dismissals"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int home_dismissals { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_dismissalsSpecified Property

sportEventStatushome_dismissalsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_dismissalsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool home_dismissalsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_drive_count Property

sportEventStatushome_drive_count Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_drive_count"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int home_drive_count { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_drive_countSpecified Property

sportEventStatushome_drive_countSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_drive_countSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool home_drive_countSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_gamescore Property

sportEventStatushome_gamescore Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_gamescore"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int home_gamescore { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_gamescoreSpecified Property

sportEventStatushome_gamescoreSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_gamescoreSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool home_gamescoreSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_legscore Property

sportEventStatushome_legscore Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_legscore"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int home_legscore { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_legscoreSpecified Property

sportEventStatushome_legscoreSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_legscoreSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool home_legscoreSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_penalty_runs Property

sportEventStatushome_penalty_runs Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_penalty_runs"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int home_penalty_runs { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_penalty_runsSpecified Property

sportEventStatushome_penalty_runsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_penalty_runsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool home_penalty_runsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_penalty_score Property

sportEventStatushome_penalty_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_penalty_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int home_penalty_score { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_penalty_scoreSpecified Property

sportEventStatushome_penalty_scoreSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_penalty_scoreSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool home_penalty_scoreSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_play_count Property

sportEventStatushome_play_count Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_play_count"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int home_play_count { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_play_countSpecified Property

sportEventStatushome_play_countSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_play_countSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool home_play_countSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_remaining_bowls Property

sportEventStatushome_remaining_bowls Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_remaining_bowls"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int home_remaining_bowls { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_remaining_bowlsSpecified Property

sportEventStatushome_remaining_bowlsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_remaining_bowlsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool home_remaining_bowlsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_score Property

sportEventStatushome_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public decimal home_score { get; set; }

Property Value

Decimal
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_scoreSpecified Property

sportEventStatushome_scoreSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_scoreSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool home_scoreSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_suspend Property

sportEventStatushome_suspend Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_suspend"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int home_suspend { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.home_suspendSpecified Property

sportEventStatushome_suspendSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.home_suspendSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool home_suspendSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.innings Property

sportEventStatusinnings Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.innings"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int innings { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.inningsSpecified Property

sportEventStatusinningsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.inningsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool inningsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.match_status Property

sportEventStatusmatch_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.match_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int match_status { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.outs Property

sportEventStatusouts Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.outs"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int outs { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.outsSpecified Property

sportEventStatusoutsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.outsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool outsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.over Property

sportEventStatusover Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.over"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int over { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.overSpecified Property

sportEventStatusoverSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.overSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool overSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.period_of_leader Property

sportEventStatusperiod_of_leader Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.period_of_leader"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int period_of_leader { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.period_of_leaderSpecified Property

sportEventStatusperiod_of_leaderSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.period_of_leaderSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool period_of_leaderSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.period_scores Property

sportEventStatusperiod_scores Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.period_scores"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public periodScoreType[] period_scores { get; set; }

Property Value

periodScoreType
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.pitch_count Property

sportEventStatuspitch_count Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.pitch_count"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int pitch_count { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.pitch_countSpecified Property

sportEventStatuspitch_countSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.pitch_countSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool pitch_countSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.pitcher Property

sportEventStatuspitcher Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.pitcher"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string pitcher { get; set; }

Property Value

String
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.pitches_seen Property

sportEventStatuspitches_seen Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.pitches_seen"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int pitches_seen { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.pitches_seenSpecified Property

sportEventStatuspitches_seenSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.pitches_seenSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool pitches_seenSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.position Property

sportEventStatusposition Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.position"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int position { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.positionSpecified Property

sportEventStatuspositionSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.positionSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool positionSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.possession Property

sportEventStatuspossession Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.possession"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int possession { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.possessionSpecified Property

sportEventStatuspossessionSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.possessionSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool possessionSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.remaining_reds Property

sportEventStatusremaining_reds Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.remaining_reds"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int remaining_reds { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.remaining_redsSpecified Property

sportEventStatusremaining_redsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.remaining_redsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool remaining_redsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.reporting Property

sportEventStatusreporting Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.reporting"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int reporting { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.reportingSpecified Property

sportEventStatusreportingSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.reportingSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool reportingSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.results Property

sportEventStatusresults Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.results"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public resultType[] results { get; set; }

Property Value

resultType
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.statistics Property

sportEventStatusstatistics Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.statistics"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public statisticsType statistics { get; set; }

Property Value

statisticsType
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.status Property

sportEventStatusstatus Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int status { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.strikes Property

sportEventStatusstrikes Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.strikes"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int strikes { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.strikesSpecified Property

sportEventStatusstrikesSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.strikesSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool strikesSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.throw Property

sportEventStatusthrow Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.throw"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int throw { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.throwSpecified Property

sportEventStatusthrowSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.throwSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool throwSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.tiebreak Property

sportEventStatustiebreak Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.tiebreak"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool tiebreak { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.tiebreakSpecified Property

sportEventStatustiebreakSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.tiebreakSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool tiebreakSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.total_hits Property

sportEventStatustotal_hits Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.total_hits"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int total_hits { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.total_hitsSpecified Property

sportEventStatustotal_hitsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.total_hitsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool total_hitsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.total_pitches Property

sportEventStatustotal_pitches Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.total_pitches"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int total_pitches { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.total_pitchesSpecified Property

sportEventStatustotal_pitchesSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.total_pitchesSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool total_pitchesSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.try Property

sportEventStatustry Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.try"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int try { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.trySpecified Property

sportEventStatustrySpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.trySpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool trySpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.visit Property

sportEventStatusvisit Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.visit"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int visit { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.visitSpecified Property

sportEventStatusvisitSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.visitSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool visitSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.yards Property

sportEventStatusyards Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.yards"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int yards { get; set; }

Property Value

Int32
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus.yardsSpecified Property

sportEventStatusyardsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.sportEventStatus.yardsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool yardsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


sportEventStatus Methods

The sportEventStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

sportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsScoreType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.statisticsScoreType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedstatisticsScoreType

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class statisticsScoreType

The statisticsScoreType type exposes the following members.

Constructors
 | Name | Description
Public method | statisticsScoreType | Initializes a new instance of the statisticsScoreType class
Top
Properties
 | Name | Description
Public property | away |
Public property | home |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsScoreType Constructor

Initializes a new instance of the statisticsScoreType class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public statisticsScoreType()
See Also

Reference

statisticsScoreType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsScoreType Properties

The statisticsScoreType type exposes the following members.

Properties
 | Name | Description
Public property | away |
Public property | home |
Top
See Also

Reference

statisticsScoreType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsScoreType.away Property

statisticsScoreTypeaway Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.statisticsScoreType.away"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int away { get; set; }

Property Value

Int32
See Also

Reference

statisticsScoreType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsScoreType.home Property

statisticsScoreTypehome Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.statisticsScoreType.home"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int home { get; set; }

Property Value

Int32
See Also

Reference

statisticsScoreType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsScoreType Methods

The statisticsScoreType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

statisticsScoreType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.Feed.statisticsType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedstatisticsType

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class statisticsType

The statisticsType type exposes the following members.

Constructors
 | Name | Description
Public method | statisticsType | Initializes a new instance of the statisticsType class
Top
Properties
 | Name | Description
Public property | corners |
Public property | green_cards |
Public property | red_cards |
Public property | yellow_cards |
Public property | yellow_red_cards |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsType Constructor

Initializes a new instance of the statisticsType class

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public statisticsType()
See Also

Reference

statisticsType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsType Properties

The statisticsType type exposes the following members.

Properties
 | Name | Description
Public property | corners |
Public property | green_cards |
Public property | red_cards |
Public property | yellow_cards |
Public property | yellow_red_cards |
Top
See Also

Reference

statisticsType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsType.corners Property

statisticsTypecorners Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.statisticsType.corners"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public statisticsScoreType corners { get; set; }

Property Value

statisticsScoreType
See Also

Reference

statisticsType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsType.green_cards Property

statisticsTypegreen_cards Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.statisticsType.green_cards"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public statisticsScoreType green_cards { get; set; }

Property Value

statisticsScoreType
See Also

Reference

statisticsType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsType.red_cards Property

statisticsTypered_cards Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.statisticsType.red_cards"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public statisticsScoreType red_cards { get; set; }

Property Value

statisticsScoreType
See Also

Reference

statisticsType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsType.yellow_cards Property

statisticsTypeyellow_cards Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.statisticsType.yellow_cards"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public statisticsScoreType yellow_cards { get; set; }

Property Value

statisticsScoreType
See Also

Reference

statisticsType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsType.yellow_red_cards Property

statisticsTypeyellow_red_cards Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.Feed.statisticsType.yellow_red_cards"]

Namespace: Sportradar.OddsFeed.SDK.Messages.Feed
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public statisticsScoreType yellow_red_cards { get; set; }

Property Value

statisticsScoreType
See Also

Reference

statisticsType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


statisticsType Methods

The statisticsType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

statisticsType Class
Sportradar.OddsFeed.SDK.Messages.Feed Namespace


Sportradar.OddsFeed.SDK.Messages.REST Namespace

Classes
 | Class | Description
Public class | attributesAttribute |
Public class | AvailableSelectionsType |
Public class | basicEvent |
Public class | betstop_reasons_descriptions |
Public class | betting_status_descriptions |
Public class | bookmaker_details |
Public class | CalculationResponseType |
Public class | CalculationResultType |
Public class | car |
Public class | cashout |
Public class | cashoutOdds |
Public class | category |
Public class | clock |
Public class | competitorProfileEndpoint |
Public class | competitorReferenceIdsReference_id |
Public class | course |
Public class | coverage |
Public class | coverageInfo |
Public class | currentSeason |
Public class | delayedInfo |
Public class | desc_betstop_reason |
Public class | desc_betting_status |
Public class | desc_market |
Public class | desc_match_status |
Public class | desc_match_statusSports |
Public class | desc_match_statusSportsSport |
Public class | desc_outcome_reason |
Public class | desc_outcomesOutcome |
Public class | desc_specifiersSpecifier |
Public class | desc_variant |
Public class | desc_variant_outcomesOutcome |
Public class | desc_void_reason |
Public class | draw_event |
Public class | draw_fixture |
Public class | draw_fixtures |
Public class | draw_result |
Public class | draw_resultDraws |
Public class | draw_resultDrawsDraw |
Public class | draw_summary |
Public class | eventPlayer |
Public class | eventPlayerAssist |
Public class | EventType |
Public class | FilteredCalculationResponseType |
Public class | FilteredCalculationResultType |
Public class | FilteredEventType |
Public class | FilteredMarketType |
Public class | FilteredOutcomeType |
Public class | FilterSelectionMarketType |
Public class | FilterSelectionsType |
Public class | FilterSelectionType |
Public class | fixture |
Public class | fixtureChange |
Public class | fixtureChangesEndpoint |
Public class | fixturesEndpoint |
Public class | hole |
Public class | info |
Public class | jersey |
Public class | lotteries |
Public class | lottery |
Public class | lottery_schedule |
Public class | lotteryBonus_info |
Public class | lotteryDraw_info |
Public class | manager |
Public class | mappingsMapping |
Public class | mappingsMappingMapping_outcome |
Public class | market_descriptions |
Public class | MarketType |
Public class | match_status_descriptions |
Public class | matchPeriod |
Public class | matchRound |
Public class | matchStatistics |
Public class | matchSummaryEndpoint |
Public class | matchTimelineEndpoint |
Public class | outcome_reasons_descriptions |
Public class | OutcomeType |
Public class | parentStage |
Public class | periodScore |
Public class | periodScoreBase |
Public class | periodStatus |
Public class | periodStatusCompetitor |
Public class | periodStatusCompetitorResult |
Public class | pitcher |
Public class | player |
Public class | playerCompetitor |
Public class | playerExtended |
Public class | playerLineup | Obsolete.
Public class | playerProfileEndpoint |
Public class | playerSubstitute | Obsolete.
Public class | producer |
Public class | producers |
Public class | productInfo |
Public class | productInfoItem |
Public class | productInfoLink |
Public class | raceDriver |
Public class | raceDriverProfile |
Public class | raceScheduleEndpoint |
Public class | raceTeam |
Public class | raceTournamentInfoEndpoint |
Public class | referee |
Public class | referenceIdsReference_id |
Public class | response |
Public class | ResponseType | Obsolete.
Public class | RestMessage | Represents all messages (entities) received from the feed's REST API
Public class | restSportEventStatus |
Public class | restSportEventStatusBase |
Public class | result |
Public class | resultChange |
Public class | resultChangesEndpoint |
Public class | resultEndpoint | Obsolete.
Public class | resultScore |
Public class | resultsEndpoint | Obsolete.
Public class | scheduledStartTimeChange |
Public class | scheduleEndpoint |
Public class | season |
Public class | seasonCoverageInfo |
Public class | seasonExtended |
Public class | SelectionsType |
Public class | SelectionType |
Public class | simpleTeamProfileEndpoint |
Public class | simpleTournamentInfoEndpoint |
Public class | sport |
Public class | sportCategoriesEndpoint |
Public class | sportEvent |
Public class | sportEventChildrenSport_event |
Public class | sportEventConditions |
Public class | sportsEndpoint |
Public class | sportTournamentsEndpoint |
Public class | stagePeriodEndpoint |
Public class | stageResult |
Public class | stageResultCompetitor |
Public class | stageResultCompetitorResult |
Public class | stageSportEventStatus |
Public class | stageSummaryEndpoint |
Public class | standardTournamentInfoEndpoint |
Public class | streamingChannel |
Public class | team |
Public class | teamCompetitor |
Public class | teamExtended |
Public class | teamStatistics |
Public class | teamStatisticsStatistics |
Public class | tournament |
Public class | tournamentExtended |
Public class | tournamentGroup |
Public class | tournamentInfoEndpoint |
Public class | tournamentLength |
Public class | tournamentLiveCoverageInfo |
Public class | tournamentSchedule |
Public class | tournamentSeasons |
Public class | tournamentsEndpoint |
Public class | tvChannel |
Public class | variant_descriptions |
Public class | variant_mappingsMapping |
Public class | variant_mappingsMappingMapping_outcome |
Public class | venue |
Public class | venueSummaryEndpoint | Obsolete.
Public class | void_reasons_descriptions |
Public class | weatherInfo |
Enumerations
 | Enumeration | Description
Public enumeration | bonusDrumType |
Public enumeration | drawStatus |
Public enumeration | drawType |
Public enumeration | response_code |
Public enumeration | timeType |


attributesAttribute Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.attributesAttribute"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTattributesAttribute

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class attributesAttribute

The attributesAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | attributesAttribute | Initializes a new instance of the attributesAttribute class
Top
Properties
 | Name | Description
Public property | description |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


attributesAttribute Constructor

Initializes a new instance of the attributesAttribute class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public attributesAttribute()
See Also

Reference

attributesAttribute Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


attributesAttribute Properties

The attributesAttribute type exposes the following members.

Properties
 | Name | Description
Public property | description |
Public property | name |
Top
See Also

Reference

attributesAttribute Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


attributesAttribute.description Property

attributesAttributedescription Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.attributesAttribute.description"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string description { get; set; }

Property Value

String
See Also

Reference

attributesAttribute Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


attributesAttribute.name Property

attributesAttributename Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.attributesAttribute.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

attributesAttribute Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


attributesAttribute Methods

The attributesAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

attributesAttribute Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


AvailableSelectionsType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.AvailableSelectionsType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTAvailableSelectionsType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class AvailableSelectionsType : RestMessage

The AvailableSelectionsType type exposes the following members.

Constructors
 | Name | Description
Public method | AvailableSelectionsType | Initializes a new instance of the AvailableSelectionsType class
Top
Properties
 | Name | Description
Public property | event |
Public property | generated_at |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


AvailableSelectionsType Constructor

Initializes a new instance of the AvailableSelectionsType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public AvailableSelectionsType()
See Also

Reference

AvailableSelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


AvailableSelectionsType Properties

The AvailableSelectionsType type exposes the following members.

Properties
 | Name | Description
Public property | event |
Public property | generated_at |
Top
See Also

Reference

AvailableSelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


AvailableSelectionsType.event Property

AvailableSelectionsTypeevent Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.AvailableSelectionsType.event"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public EventType event { get; set; }

Property Value

EventType
See Also

Reference

AvailableSelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


AvailableSelectionsType.generated_at Property

AvailableSelectionsTypegenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.AvailableSelectionsType.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string generated_at { get; set; }

Property Value

String
See Also

Reference

AvailableSelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


AvailableSelectionsType Methods

The AvailableSelectionsType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AvailableSelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTbasicEvent

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class basicEvent

The basicEvent type exposes the following members.

Constructors
 | Name | Description
Public method | basicEvent | Initializes a new instance of the basicEvent class
Top
Properties
 | Name | Description
Public property | assist |
Public property | away_score |
Public property | goal_scorer |
Public property | home_score |
Public property | id |
Public property | match_clock |
Public property | match_status_code |
Public property | match_status_codeSpecified |
Public property | match_time |
Public property | match_timeSpecified |
Public property | period |
Public property | period_name |
Public property | player |
Public property | points |
Public property | stoppage_time |
Public property | team |
Public property | time |
Public property | type |
Public property | value |
Public property | x |
Public property | xSpecified |
Public property | y |
Public property | ySpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent Constructor

Initializes a new instance of the basicEvent class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public basicEvent()
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent Properties

The basicEvent type exposes the following members.

Properties
 | Name | Description
Public property | assist |
Public property | away_score |
Public property | goal_scorer |
Public property | home_score |
Public property | id |
Public property | match_clock |
Public property | match_status_code |
Public property | match_status_codeSpecified |
Public property | match_time |
Public property | match_timeSpecified |
Public property | period |
Public property | period_name |
Public property | player |
Public property | points |
Public property | stoppage_time |
Public property | team |
Public property | time |
Public property | type |
Public property | value |
Public property | x |
Public property | xSpecified |
Public property | y |
Public property | ySpecified |
Top
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.assist Property

basicEventassist Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.assist"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public eventPlayerAssist[] assist { get; set; }

Property Value

eventPlayerAssist
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.away_score Property

basicEventaway_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.away_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string away_score { get; set; }

Property Value

String
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.goal_scorer Property

basicEventgoal_scorer Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.goal_scorer"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public eventPlayer goal_scorer { get; set; }

Property Value

eventPlayer
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.home_score Property

basicEventhome_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.home_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string home_score { get; set; }

Property Value

String
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.id Property

basicEventid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int id { get; set; }

Property Value

Int32
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.match_clock Property

basicEventmatch_clock Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.match_clock"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string match_clock { get; set; }

Property Value

String
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.match_status_code Property

basicEventmatch_status_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.match_status_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int match_status_code { get; set; }

Property Value

Int32
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.match_status_codeSpecified Property

basicEventmatch_status_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.match_status_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool match_status_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.match_time Property

basicEventmatch_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.match_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int match_time { get; set; }

Property Value

Int32
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.match_timeSpecified Property

basicEventmatch_timeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.match_timeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool match_timeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.period Property

basicEventperiod Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.period"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string period { get; set; }

Property Value

String
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.period_name Property

basicEventperiod_name Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.period_name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string period_name { get; set; }

Property Value

String
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.player Property

basicEventplayer Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.player"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public eventPlayer player { get; set; }

Property Value

eventPlayer
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.points Property

basicEventpoints Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.points"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string points { get; set; }

Property Value

String
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.stoppage_time Property

basicEventstoppage_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.stoppage_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string stoppage_time { get; set; }

Property Value

String
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.team Property

basicEventteam Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.team"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string team { get; set; }

Property Value

String
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.time Property

basicEventtime Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime time { get; set; }

Property Value

DateTime
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.type Property

basicEventtype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.value Property

basicEventvalue Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.value"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string value { get; set; }

Property Value

String
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.x Property

basicEventx Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.x"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int x { get; set; }

Property Value

Int32
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.xSpecified Property

basicEventxSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.xSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool xSpecified { get; set; }

Property Value

Boolean
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.y Property

basicEventy Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.y"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int y { get; set; }

Property Value

Int32
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent.ySpecified Property

basicEventySpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.basicEvent.ySpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool ySpecified { get; set; }

Property Value

Boolean
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


basicEvent Methods

The basicEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

basicEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betstop_reasons_descriptions Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.betstop_reasons_descriptions"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTbetstop_reasons_descriptions

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class betstop_reasons_descriptions

The betstop_reasons_descriptions type exposes the following members.

Constructors
 | Name | Description
Public method | betstop_reasons_descriptions | Initializes a new instance of the betstop_reasons_descriptions class
Top
Properties
 | Name | Description
Public property | betstop_reason |
Public property | location |
Public property | response_code |
Public property | response_codeSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


betstop_reasons_descriptions Constructor

Initializes a new instance of the betstop_reasons_descriptions class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public betstop_reasons_descriptions()
See Also

Reference

betstop_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betstop_reasons_descriptions Properties

The betstop_reasons_descriptions type exposes the following members.

Properties
 | Name | Description
Public property | betstop_reason |
Public property | location |
Public property | response_code |
Public property | response_codeSpecified |
Top
See Also

Reference

betstop_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betstop_reasons_descriptions.betstop_reason Property

betstop_reasons_descriptionsbetstop_reason Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.betstop_reasons_descriptions.betstop_reason"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_betstop_reason[] betstop_reason { get; set; }

Property Value

desc_betstop_reason
See Also

Reference

betstop_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betstop_reasons_descriptions.location Property

betstop_reasons_descriptionslocation Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.betstop_reasons_descriptions.location"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string location { get; set; }

Property Value

String
See Also

Reference

betstop_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betstop_reasons_descriptions.response_code Property

betstop_reasons_descriptionsresponse_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.betstop_reasons_descriptions.response_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public response_code response_code { get; set; }

Property Value

response_code
See Also

Reference

betstop_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betstop_reasons_descriptions.response_codeSpecified Property

betstop_reasons_descriptionsresponse_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.betstop_reasons_descriptions.response_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool response_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

betstop_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betstop_reasons_descriptions Methods

The betstop_reasons_descriptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

betstop_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betting_status_descriptions Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.betting_status_descriptions"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTbetting_status_descriptions

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class betting_status_descriptions

The betting_status_descriptions type exposes the following members.

Constructors
 | Name | Description
Public method | betting_status_descriptions | Initializes a new instance of the betting_status_descriptions class
Top
Properties
 | Name | Description
Public property | betting_status |
Public property | location |
Public property | response_code |
Public property | response_codeSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


betting_status_descriptions Constructor

Initializes a new instance of the betting_status_descriptions class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public betting_status_descriptions()
See Also

Reference

betting_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betting_status_descriptions Properties

The betting_status_descriptions type exposes the following members.

Properties
 | Name | Description
Public property | betting_status |
Public property | location |
Public property | response_code |
Public property | response_codeSpecified |
Top
See Also

Reference

betting_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betting_status_descriptions.betting_status Property

betting_status_descriptionsbetting_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.betting_status_descriptions.betting_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_betting_status[] betting_status { get; set; }

Property Value

desc_betting_status
See Also

Reference

betting_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betting_status_descriptions.location Property

betting_status_descriptionslocation Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.betting_status_descriptions.location"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string location { get; set; }

Property Value

String
See Also

Reference

betting_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betting_status_descriptions.response_code Property

betting_status_descriptionsresponse_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.betting_status_descriptions.response_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public response_code response_code { get; set; }

Property Value

response_code
See Also

Reference

betting_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betting_status_descriptions.response_codeSpecified Property

betting_status_descriptionsresponse_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.betting_status_descriptions.response_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool response_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

betting_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


betting_status_descriptions Methods

The betting_status_descriptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

betting_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


bonusDrumType Enumeration

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.bonusDrumType"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public enum bonusDrumType
Members
Member name | Value | Description
same | 0 |
additional | 1 |
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


bookmaker_details Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.bookmaker_details"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTbookmaker_details

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class bookmaker_details : RestMessage

The bookmaker_details type exposes the following members.

Constructors
 | Name | Description
Public method | bookmaker_details | Initializes a new instance of the bookmaker_details class
Top
Properties
 | Name | Description
Public property | bookmaker_id |
Public property | bookmaker_idSpecified |
Public property | expire_at |
Public property | expire_atSpecified |
Public property | message |
Public property | response_code |
Public property | response_codeSpecified |
Public property | virtual_host |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


bookmaker_details Constructor

Initializes a new instance of the bookmaker_details class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bookmaker_details()
See Also

Reference

bookmaker_details Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


bookmaker_details Properties

The bookmaker_details type exposes the following members.

Properties
 | Name | Description
Public property | bookmaker_id |
Public property | bookmaker_idSpecified |
Public property | expire_at |
Public property | expire_atSpecified |
Public property | message |
Public property | response_code |
Public property | response_codeSpecified |
Public property | virtual_host |
Top
See Also

Reference

bookmaker_details Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


bookmaker_details.bookmaker_id Property

bookmaker_detailsbookmaker_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.bookmaker_details.bookmaker_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int bookmaker_id { get; set; }

Property Value

Int32
See Also

Reference

bookmaker_details Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


bookmaker_details.bookmaker_idSpecified Property

bookmaker_detailsbookmaker_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.bookmaker_details.bookmaker_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool bookmaker_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

bookmaker_details Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


bookmaker_details.expire_at Property

bookmaker_detailsexpire_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.bookmaker_details.expire_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime expire_at { get; set; }

Property Value

DateTime
See Also

Reference

bookmaker_details Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


bookmaker_details.expire_atSpecified Property

bookmaker_detailsexpire_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.bookmaker_details.expire_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool expire_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

bookmaker_details Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


bookmaker_details.message Property

bookmaker_detailsmessage Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.bookmaker_details.message"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string message { get; set; }

Property Value

String
See Also

Reference

bookmaker_details Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


bookmaker_details.response_code Property

bookmaker_detailsresponse_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.bookmaker_details.response_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public response_code response_code { get; set; }

Property Value

response_code
See Also

Reference

bookmaker_details Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


bookmaker_details.response_codeSpecified Property

bookmaker_detailsresponse_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.bookmaker_details.response_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool response_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

bookmaker_details Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


bookmaker_details.virtual_host Property

bookmaker_detailsvirtual_host Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.bookmaker_details.virtual_host"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string virtual_host { get; set; }

Property Value

String
See Also

Reference

bookmaker_details Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


bookmaker_details Methods

The bookmaker_details type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

bookmaker_details Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResponseType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.CalculationResponseType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTCalculationResponseType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class CalculationResponseType : RestMessage

The CalculationResponseType type exposes the following members.

Constructors
 | Name | Description
Public method | CalculationResponseType | Initializes a new instance of the CalculationResponseType class
Top
Properties
 | Name | Description
Public property | available_selections |
Public property | calculation |
Public property | generated_at |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResponseType Constructor

Initializes a new instance of the CalculationResponseType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CalculationResponseType()
See Also

Reference

CalculationResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResponseType Properties

The CalculationResponseType type exposes the following members.

Properties
 | Name | Description
Public property | available_selections |
Public property | calculation |
Public property | generated_at |
Top
See Also

Reference

CalculationResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResponseType.available_selections Property

CalculationResponseTypeavailable_selections Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.CalculationResponseType.available_selections"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public EventType[] available_selections { get; set; }

Property Value

EventType
See Also

Reference

CalculationResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResponseType.calculation Property

CalculationResponseTypecalculation Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.CalculationResponseType.calculation"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CalculationResultType calculation { get; set; }

Property Value

CalculationResultType
See Also

Reference

CalculationResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResponseType.generated_at Property

CalculationResponseTypegenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.CalculationResponseType.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string generated_at { get; set; }

Property Value

String
See Also

Reference

CalculationResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResponseType Methods

The CalculationResponseType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CalculationResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResultType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.CalculationResultType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTCalculationResultType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class CalculationResultType

The CalculationResultType type exposes the following members.

Constructors
 | Name | Description
Public method | CalculationResultType | Initializes a new instance of the CalculationResultType class
Top
Properties
 | Name | Description
Public property | odds |
Public property | probability |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResultType Constructor

Initializes a new instance of the CalculationResultType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public CalculationResultType()
See Also

Reference

CalculationResultType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResultType Properties

The CalculationResultType type exposes the following members.

Properties
 | Name | Description
Public property | odds |
Public property | probability |
Top
See Also

Reference

CalculationResultType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResultType.odds Property

CalculationResultTypeodds Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.CalculationResultType.odds"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double odds { get; set; }

Property Value

Double
See Also

Reference

CalculationResultType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResultType.probability Property

CalculationResultTypeprobability Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.CalculationResultType.probability"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double probability { get; set; }

Property Value

Double
See Also

Reference

CalculationResultType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


CalculationResultType Methods

The CalculationResultType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CalculationResultType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


car Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.car"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTcar

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class car

The car type exposes the following members.

Constructors
 | Name | Description
Public method | car | Initializes a new instance of the car class
Top
Properties
 | Name | Description
Public property | chassis |
Public property | engine_name |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


car Constructor

Initializes a new instance of the car class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public car()
See Also

Reference

car Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


car Properties

The car type exposes the following members.

Properties
 | Name | Description
Public property | chassis |
Public property | engine_name |
Public property | name |
Top
See Also

Reference

car Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


car.chassis Property

carchassis Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.car.chassis"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string chassis { get; set; }

Property Value

String
See Also

Reference

car Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


car.engine_name Property

carengine_name Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.car.engine_name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string engine_name { get; set; }

Property Value

String
See Also

Reference

car Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


car.name Property

carname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.car.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

car Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


car Methods

The car type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

car Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.cashout"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.FeedFeedMessage
Sportradar.OddsFeed.SDK.Messages.RESTcashout

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class cashout : FeedMessage

The cashout type exposes the following members.

Constructors
 | Name | Description
Public method | cashout | Initializes a new instance of the cashout class
Top
Properties
 | Name | Description
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of the message (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | odds |
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | sport_event_status |
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | timestamp |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout Constructor

Initializes a new instance of the cashout class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public cashout()
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout Properties

The cashout type exposes the following members.

Properties
 | Name | Description
Public property | event_id |
Public property | EventId | When overridden in derived class it gets the event identifier. (Overrides FeedMessageEventId)
Public property | EventURN | When overridden in derived class, it gets a URN specifying the id of the associated sport event (Inherited from FeedMessage)
Public property | GeneratedAt | Gets the timestamp of the message (Overrides FeedMessageGeneratedAt)
Public property | IsEventRelated | When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event (Overrides FeedMessageIsEventRelated)
Public property | IsStateful | When override in derived class, it gets a value indicating whether current message is state-ful (Overrides FeedMessageIsStateful)
Public property | Name | When overridden in derived class, gets the name of the current message (Overrides FeedMessageName)
Public property | odds |
Public property | ProducerId | When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage (Overrides FeedMessageProducerId)
Public property | product |
Public property | ReceivedAt | Gets the timestamp of when the message was received (picked up) by the sdk (Overrides FeedMessageReceivedAt)
Public property | request_id |
Public property | request_idSpecified |
Public property | RequestId | Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request (Overrides FeedMessageRequestId)
Public property | RequestIdUsage | When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property (Overrides FeedMessageRequestIdUsage)
Public property | SentAt | Gets the timestamp of when the message was sent (Overrides FeedMessageSentAt)
Public property | sport_event_status |
Public property | SportId | Gets or sets a URN representing the id of the sport associated with the current FeedMessage instance (Inherited from FeedMessage)
Public property | timestamp |
Top
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.event_id Property

cashoutevent_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.cashout.event_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string event_id { get; set; }

Property Value

String
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.EventId Property

cashoutEventId Property

When overridden in derived class it gets the event identifier.

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string EventId { get; }

Property Value

String
The event identifier
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.GeneratedAt Property

cashoutGeneratedAt Property

Gets the timestamp of the message

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long GeneratedAt { get; }

Property Value

Int64
The timestamp of the message
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.IsEventRelated Property

cashoutIsEventRelated Property

When overridden in derived class, it gets a value indicating whether the current FeedMessage instance is related to sport event

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsEventRelated { get; }

Property Value

Boolean
true if this instance is event related; otherwise, false.
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.IsStateful Property

cashoutIsStateful Property

When override in derived class, it gets a value indicating whether current message is state-ful

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override bool IsStateful { get; }

Property Value

Boolean
true if this instance is stateful; otherwise, false.
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.Name Property

cashoutName Property

When overridden in derived class, gets the name of the current message

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override string Name { get; }

Property Value

String
The name.
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.odds Property

cashoutodds Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.cashout.odds"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public cashoutOdds odds { get; set; }

Property Value

cashoutOdds
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.ProducerId Property

cashoutProducerId Property

When overridden in derived class, it gets a value indicating the producer associated with current FeedMessage

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override int ProducerId { get; }

Property Value

Int32
The producer identifier.
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.product Property

cashoutproduct Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.cashout.product"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int product { get; set; }

Property Value

Int32
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.ReceivedAt Property

cashoutReceivedAt Property

Gets the timestamp of when the message was received (picked up) by the sdk

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long ReceivedAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.request_id Property

cashoutrequest_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.cashout.request_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long request_id { get; set; }

Property Value

Int64
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.request_idSpecified Property

cashoutrequest_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.cashout.request_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool request_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.RequestId Property

cashoutRequestId Property

Gets a value specified when making a request which generated this message, or null reference if this messages is not resulted with the request

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long? RequestId { get; }

Property Value

Nullable Int64
The request identifier.
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.RequestIdUsage Property

cashoutRequestIdUsage Property

When overridden in derived class, it gets a value specifying the usage requirements of the RequestId property

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override PropertyUsage RequestIdUsage { get; }

Property Value

PropertyUsage
The request identifier usage.
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.SentAt Property

cashoutSentAt Property

Gets the timestamp of when the message was sent

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public override long SentAt { get; set; }

Property Value

Int64
The timestamp of the message
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.sport_event_status Property

cashoutsport_event_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.cashout.sport_event_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public restSportEventStatus sport_event_status { get; set; }

Property Value

restSportEventStatus
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.timestamp Property

cashouttimestamp Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.cashout.timestamp"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long timestamp { get; set; }

Property Value

Int64
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout Methods

The cashout type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a String that represents this instance. (Inherited from FeedMessage)
Top
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout Fields

The cashout type exposes the following members.

Fields
Name | Description
MessageName | The message name
Top
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashout.MessageName Field

cashoutMessageName Field

The message name

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public static readonly string MessageName

Field Value

String
See Also

Reference

cashout Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashoutOdds Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.cashoutOdds"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTcashoutOdds

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class cashoutOdds

The cashoutOdds type exposes the following members.

Constructors
 | Name | Description
Public method | cashoutOdds | Initializes a new instance of the cashoutOdds class
Top
Properties
 | Name | Description
Public property | betstop_reason |
Public property | betstop_reasonSpecified |
Public property | betting_status |
Public property | betting_statusSpecified |
Public property | market |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashoutOdds Constructor

Initializes a new instance of the cashoutOdds class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public cashoutOdds()
See Also

Reference

cashoutOdds Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashoutOdds Properties

The cashoutOdds type exposes the following members.

Properties
 | Name | Description
Public property | betstop_reason |
Public property | betstop_reasonSpecified |
Public property | betting_status |
Public property | betting_statusSpecified |
Public property | market |
Top
See Also

Reference

cashoutOdds Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashoutOdds.betstop_reason Property

cashoutOddsbetstop_reason Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.cashoutOdds.betstop_reason"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int betstop_reason { get; set; }

Property Value

Int32
See Also

Reference

cashoutOdds Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashoutOdds.betstop_reasonSpecified Property

cashoutOddsbetstop_reasonSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.cashoutOdds.betstop_reasonSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool betstop_reasonSpecified { get; set; }

Property Value

Boolean
See Also

Reference

cashoutOdds Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashoutOdds.betting_status Property

cashoutOddsbetting_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.cashoutOdds.betting_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int betting_status { get; set; }

Property Value

Int32
See Also

Reference

cashoutOdds Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashoutOdds.betting_statusSpecified Property

cashoutOddsbetting_statusSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.cashoutOdds.betting_statusSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool betting_statusSpecified { get; set; }

Property Value

Boolean
See Also

Reference

cashoutOdds Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashoutOdds.market Property

cashoutOddsmarket Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.cashoutOdds.market"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public oddsChangeMarket[] market { get; set; }

Property Value

oddsChangeMarket
See Also

Reference

cashoutOdds Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


cashoutOdds Methods

The cashoutOdds type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

cashoutOdds Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


category Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.category"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTcategory

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class category

The category type exposes the following members.

Constructors
 | Name | Description
Public method | category | Initializes a new instance of the category class
Top
Properties
 | Name | Description
Public property | country_code |
Public property | id |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


category Constructor

Initializes a new instance of the category class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public category()
See Also

Reference

category Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


category Properties

The category type exposes the following members.

Properties
 | Name | Description
Public property | country_code |
Public property | id |
Public property | name |
Top
See Also

Reference

category Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


category.country_code Property

categorycountry_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.category.country_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string country_code { get; set; }

Property Value

String
See Also

Reference

category Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


category.id Property

categoryid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.category.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

category Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


category.name Property

categoryname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.category.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

category Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


category Methods

The category type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

category Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


clock Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.clock"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTclock

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class clock

The clock type exposes the following members.

Constructors
 | Name | Description
Public method | clock | Initializes a new instance of the clock class
Top
Properties
 | Name | Description
Public property | match_time |
Public property | stoppage_time |
Public property | stoppage_time_announced |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


clock Constructor

Initializes a new instance of the clock class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public clock()
See Also

Reference

clock Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


clock Properties

The clock type exposes the following members.

Properties
 | Name | Description
Public property | match_time |
Public property | stoppage_time |
Public property | stoppage_time_announced |
Top
See Also

Reference

clock Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


clock.match_time Property

clockmatch_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.clock.match_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string match_time { get; set; }

Property Value

String
See Also

Reference

clock Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


clock.stoppage_time Property

clockstoppage_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.clock.stoppage_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string stoppage_time { get; set; }

Property Value

String
See Also

Reference

clock Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


clock.stoppage_time_announced Property

clockstoppage_time_announced Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.clock.stoppage_time_announced"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string stoppage_time_announced { get; set; }

Property Value

String
See Also

Reference

clock Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


clock Methods

The clock type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

clock Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorProfileEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.competitorProfileEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTcompetitorProfileEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class competitorProfileEndpoint : RestMessage

The competitorProfileEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | competitorProfileEndpoint | Initializes a new instance of the competitorProfileEndpoint class
Top
Properties
 | Name | Description
Public property | competitor |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | jerseys |
Public property | manager |
Public property | players |
Public property | race_driver_profile |
Public property | venue |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorProfileEndpoint Constructor

Initializes a new instance of the competitorProfileEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public competitorProfileEndpoint()
See Also

Reference

competitorProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorProfileEndpoint Properties

The competitorProfileEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | competitor |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | jerseys |
Public property | manager |
Public property | players |
Public property | race_driver_profile |
Public property | venue |
Top
See Also

Reference

competitorProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorProfileEndpoint.competitor Property

competitorProfileEndpointcompetitor Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.competitorProfileEndpoint.competitor"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public teamExtended competitor { get; set; }

Property Value

teamExtended
See Also

Reference

competitorProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorProfileEndpoint.generated_at Property

competitorProfileEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.competitorProfileEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

competitorProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorProfileEndpoint.generated_atSpecified Property

competitorProfileEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.competitorProfileEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

competitorProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorProfileEndpoint.jerseys Property

competitorProfileEndpointjerseys Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.competitorProfileEndpoint.jerseys"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public jersey[] jerseys { get; set; }

Property Value

jersey
See Also

Reference

competitorProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorProfileEndpoint.manager Property

competitorProfileEndpointmanager Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.competitorProfileEndpoint.manager"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public manager manager { get; set; }

Property Value

manager
See Also

Reference

competitorProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorProfileEndpoint.players Property

competitorProfileEndpointplayers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.competitorProfileEndpoint.players"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public playerExtended[] players { get; set; }

Property Value

playerExtended
See Also

Reference

competitorProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorProfileEndpoint.race_driver_profile Property

competitorProfileEndpointrace_driver_profile Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.competitorProfileEndpoint.race_driver_profile"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public raceDriverProfile race_driver_profile { get; set; }

Property Value

raceDriverProfile
See Also

Reference

competitorProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorProfileEndpoint.venue Property

competitorProfileEndpointvenue Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.competitorProfileEndpoint.venue"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public venue venue { get; set; }

Property Value

venue
See Also

Reference

competitorProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorProfileEndpoint Methods

The competitorProfileEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

competitorProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorReferenceIdsReference_id Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.competitorReferenceIdsReference_id"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTcompetitorReferenceIdsReference_id

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class competitorReferenceIdsReference_id

The competitorReferenceIdsReference_id type exposes the following members.

Constructors
 | Name | Description
Public method | competitorReferenceIdsReference_id | Initializes a new instance of the competitorReferenceIdsReference_id class
Top
Properties
 | Name | Description
Public property | name |
Public property | value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorReferenceIdsReference_id Constructor

Initializes a new instance of the competitorReferenceIdsReference_id class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public competitorReferenceIdsReference_id()
See Also

Reference

competitorReferenceIdsReference_id Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorReferenceIdsReference_id Properties

The competitorReferenceIdsReference_id type exposes the following members.

Properties
 | Name | Description
Public property | name |
Public property | value |
Top
See Also

Reference

competitorReferenceIdsReference_id Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorReferenceIdsReference_id.name Property

competitorReferenceIdsReference_idname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.competitorReferenceIdsReference_id.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

competitorReferenceIdsReference_id Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorReferenceIdsReference_id.value Property

competitorReferenceIdsReference_idvalue Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.competitorReferenceIdsReference_id.value"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string value { get; set; }

Property Value

String
See Also

Reference

competitorReferenceIdsReference_id Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


competitorReferenceIdsReference_id Methods

The competitorReferenceIdsReference_id type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

competitorReferenceIdsReference_id Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


course Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.course"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTcourse

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class course

The course type exposes the following members.

Constructors
 | Name | Description
Public method | course | Initializes a new instance of the course class
Top
Properties
 | Name | Description
Public property | hole |
Public property | id |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


course Constructor

Initializes a new instance of the course class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public course()
See Also

Reference

course Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


course Properties

The course type exposes the following members.

Properties
 | Name | Description
Public property | hole |
Public property | id |
Public property | name |
Top
See Also

Reference

course Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


course.hole Property

coursehole Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.course.hole"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public hole[] hole { get; set; }

Property Value

hole
See Also

Reference

course Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


course.id Property

courseid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.course.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

course Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


course.name Property

coursename Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.course.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

course Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


course Methods

The course type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

course Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverage Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.coverage"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTcoverage

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class coverage

The coverage type exposes the following members.

Constructors
 | Name | Description
Public method | coverage | Initializes a new instance of the coverage class
Top
Properties
 | Name | Description
Public property | includes |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverage Constructor

Initializes a new instance of the coverage class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public coverage()
See Also

Reference

coverage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverage Properties

The coverage type exposes the following members.

Properties
 | Name | Description
Public property | includes |
Top
See Also

Reference

coverage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverage.includes Property

coverageincludes Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.coverage.includes"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string includes { get; set; }

Property Value

String
See Also

Reference

coverage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverage Methods

The coverage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

coverage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverageInfo Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.coverageInfo"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTcoverageInfo

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class coverageInfo

The coverageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | coverageInfo | Initializes a new instance of the coverageInfo class
Top
Properties
 | Name | Description
Public property | coverage |
Public property | covered_from |
Public property | level |
Public property | live_coverage |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverageInfo Constructor

Initializes a new instance of the coverageInfo class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public coverageInfo()
See Also

Reference

coverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverageInfo Properties

The coverageInfo type exposes the following members.

Properties
 | Name | Description
Public property | coverage |
Public property | covered_from |
Public property | level |
Public property | live_coverage |
Top
See Also

Reference

coverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverageInfo.coverage Property

coverageInfocoverage Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.coverageInfo.coverage"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public coverage[] coverage { get; set; }

Property Value

coverage
See Also

Reference

coverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverageInfo.covered_from Property

coverageInfocovered_from Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.coverageInfo.covered_from"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string covered_from { get; set; }

Property Value

String
See Also

Reference

coverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverageInfo.level Property

coverageInfolevel Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.coverageInfo.level"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string level { get; set; }

Property Value

String
See Also

Reference

coverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverageInfo.live_coverage Property

coverageInfolive_coverage Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.coverageInfo.live_coverage"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool live_coverage { get; set; }

Property Value

Boolean
See Also

Reference

coverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


coverageInfo Methods

The coverageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

coverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


currentSeason Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.currentSeason"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTseason
Sportradar.OddsFeed.SDK.Messages.RESTseasonExtended
Sportradar.OddsFeed.SDK.Messages.RESTcurrentSeason

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class currentSeason : seasonExtended

The currentSeason type exposes the following members.

Constructors
 | Name | Description
Public method | currentSeason | Initializes a new instance of the currentSeason class
Top
Properties
 | Name | Description
Public property | end_date | (Inherited from seasonExtended)
Public property | end_time | (Inherited from seasonExtended)
Public property | end_timeSpecified | (Inherited from seasonExtended)
Public property | id | (Inherited from season)
Public property | name | (Inherited from season)
Public property | start_date | (Inherited from seasonExtended)
Public property | start_time | (Inherited from seasonExtended)
Public property | start_timeSpecified | (Inherited from seasonExtended)
Public property | tournament_id | (Inherited from seasonExtended)
Public property | year | (Inherited from seasonExtended)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


currentSeason Constructor

Initializes a new instance of the currentSeason class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public currentSeason()
See Also

Reference

currentSeason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


currentSeason Properties

The currentSeason type exposes the following members.

Properties
 | Name | Description
Public property | end_date | (Inherited from seasonExtended)
Public property | end_time | (Inherited from seasonExtended)
Public property | end_timeSpecified | (Inherited from seasonExtended)
Public property | id | (Inherited from season)
Public property | name | (Inherited from season)
Public property | start_date | (Inherited from seasonExtended)
Public property | start_time | (Inherited from seasonExtended)
Public property | start_timeSpecified | (Inherited from seasonExtended)
Public property | tournament_id | (Inherited from seasonExtended)
Public property | year | (Inherited from seasonExtended)
Top
See Also

Reference

currentSeason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


currentSeason Methods

The currentSeason type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

currentSeason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


delayedInfo Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.delayedInfo"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdelayedInfo

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class delayedInfo

The delayedInfo type exposes the following members.

Constructors
 | Name | Description
Public method | delayedInfo | Initializes a new instance of the delayedInfo class
Top
Properties
 | Name | Description
Public property | description |
Public property | id |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


delayedInfo Constructor

Initializes a new instance of the delayedInfo class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public delayedInfo()
See Also

Reference

delayedInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


delayedInfo Properties

The delayedInfo type exposes the following members.

Properties
 | Name | Description
Public property | description |
Public property | id |
Top
See Also

Reference

delayedInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


delayedInfo.description Property

delayedInfodescription Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.delayedInfo.description"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string description { get; set; }

Property Value

String
See Also

Reference

delayedInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


delayedInfo.id Property

delayedInfoid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.delayedInfo.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int id { get; set; }

Property Value

Int32
See Also

Reference

delayedInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


delayedInfo Methods

The delayedInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

delayedInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_betstop_reason Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.desc_betstop_reason"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdesc_betstop_reason

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class desc_betstop_reason

The desc_betstop_reason type exposes the following members.

Constructors
 | Name | Description
Public method | desc_betstop_reason | Initializes a new instance of the desc_betstop_reason class
Top
Properties
 | Name | Description
Public property | description |
Public property | id |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_betstop_reason Constructor

Initializes a new instance of the desc_betstop_reason class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_betstop_reason()
See Also

Reference

desc_betstop_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_betstop_reason Properties

The desc_betstop_reason type exposes the following members.

Properties
 | Name | Description
Public property | description |
Public property | id |
Top
See Also

Reference

desc_betstop_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_betstop_reason.description Property

desc_betstop_reasondescription Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_betstop_reason.description"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string description { get; set; }

Property Value

String
See Also

Reference

desc_betstop_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_betstop_reason.id Property

desc_betstop_reasonid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_betstop_reason.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long id { get; set; }

Property Value

Int64
See Also

Reference

desc_betstop_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_betstop_reason Methods

The desc_betstop_reason type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

desc_betstop_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_betting_status Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.desc_betting_status"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdesc_betting_status

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class desc_betting_status

The desc_betting_status type exposes the following members.

Constructors
 | Name | Description
Public method | desc_betting_status | Initializes a new instance of the desc_betting_status class
Top
Properties
 | Name | Description
Public property | description |
Public property | id |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_betting_status Constructor

Initializes a new instance of the desc_betting_status class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_betting_status()
See Also

Reference

desc_betting_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_betting_status Properties

The desc_betting_status type exposes the following members.

Properties
 | Name | Description
Public property | description |
Public property | id |
Top
See Also

Reference

desc_betting_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_betting_status.description Property

desc_betting_statusdescription Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_betting_status.description"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string description { get; set; }

Property Value

String
See Also

Reference

desc_betting_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_betting_status.id Property

desc_betting_statusid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_betting_status.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long id { get; set; }

Property Value

Int64
See Also

Reference

desc_betting_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_betting_status Methods

The desc_betting_status type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

desc_betting_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.desc_market"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdesc_market

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class desc_market

The desc_market type exposes the following members.

Constructors
 | Name | Description
Public method | desc_market | Initializes a new instance of the desc_market class
Top
Properties
 | Name | Description
Public property | attributes |
Public property | description |
Public property | groups |
Public property | id |
Public property | includes_outcomes_of_type |
Public property | mappings |
Public property | name |
Public property | outcome_type |
Public property | outcomes |
Public property | specifiers |
Public property | variant |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market Constructor

Initializes a new instance of the desc_market class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_market()
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market Properties

The desc_market type exposes the following members.

Properties
 | Name | Description
Public property | attributes |
Public property | description |
Public property | groups |
Public property | id |
Public property | includes_outcomes_of_type |
Public property | mappings |
Public property | name |
Public property | outcome_type |
Public property | outcomes |
Public property | specifiers |
Public property | variant |
Top
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market.attributes Property

desc_marketattributes Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_market.attributes"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public attributesAttribute[] attributes { get; set; }

Property Value

attributesAttribute
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market.description Property

desc_marketdescription Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_market.description"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string description { get; set; }

Property Value

String
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market.groups Property

desc_marketgroups Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_market.groups"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string groups { get; set; }

Property Value

String
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market.id Property

desc_marketid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_market.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int id { get; set; }

Property Value

Int32
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market.includes_outcomes_of_type Property

desc_marketincludes_outcomes_of_type Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_market.includes_outcomes_of_type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string includes_outcomes_of_type { get; set; }

Property Value

String
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market.mappings Property

desc_marketmappings Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_market.mappings"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public mappingsMapping[] mappings { get; set; }

Property Value

mappingsMapping
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market.name Property

desc_marketname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_market.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market.outcome_type Property

desc_marketoutcome_type Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_market.outcome_type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string outcome_type { get; set; }

Property Value

String
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market.outcomes Property

desc_marketoutcomes Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_market.outcomes"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_outcomesOutcome[] outcomes { get; set; }

Property Value

desc_outcomesOutcome
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market.specifiers Property

desc_marketspecifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_market.specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_specifiersSpecifier[] specifiers { get; set; }

Property Value

desc_specifiersSpecifier
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market.variant Property

desc_marketvariant Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_market.variant"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string variant { get; set; }

Property Value

String
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_market Methods

The desc_market type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

desc_market Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_status Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.desc_match_status"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdesc_match_status

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class desc_match_status

The desc_match_status type exposes the following members.

Constructors
 | Name | Description
Public method | desc_match_status | Initializes a new instance of the desc_match_status class
Top
Properties
 | Name | Description
Public property | description |
Public property | id |
Public property | period_number |
Public property | period_numberSpecified |
Public property | sports |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_status Constructor

Initializes a new instance of the desc_match_status class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_match_status()
See Also

Reference

desc_match_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_status Properties

The desc_match_status type exposes the following members.

Properties
 | Name | Description
Public property | description |
Public property | id |
Public property | period_number |
Public property | period_numberSpecified |
Public property | sports |
Top
See Also

Reference

desc_match_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_status.description Property

desc_match_statusdescription Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_match_status.description"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string description { get; set; }

Property Value

String
See Also

Reference

desc_match_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_status.id Property

desc_match_statusid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_match_status.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long id { get; set; }

Property Value

Int64
See Also

Reference

desc_match_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_status.period_number Property

desc_match_statusperiod_number Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_match_status.period_number"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int period_number { get; set; }

Property Value

Int32
See Also

Reference

desc_match_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_status.period_numberSpecified Property

desc_match_statusperiod_numberSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_match_status.period_numberSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool period_numberSpecified { get; set; }

Property Value

Boolean
See Also

Reference

desc_match_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_status.sports Property

desc_match_statussports Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_match_status.sports"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_match_statusSports sports { get; set; }

Property Value

desc_match_statusSports
See Also

Reference

desc_match_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_status Methods

The desc_match_status type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

desc_match_status Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_statusSports Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.desc_match_statusSports"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdesc_match_statusSports

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class desc_match_statusSports

The desc_match_statusSports type exposes the following members.

Constructors
 | Name | Description
Public method | desc_match_statusSports | Initializes a new instance of the desc_match_statusSports class
Top
Properties
 | Name | Description
Public property | all |
Public property | sport |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_statusSports Constructor

Initializes a new instance of the desc_match_statusSports class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_match_statusSports()
See Also

Reference

desc_match_statusSports Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_statusSports Properties

The desc_match_statusSports type exposes the following members.

Properties
 | Name | Description
Public property | all |
Public property | sport |
Top
See Also

Reference

desc_match_statusSports Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_statusSports.all Property

desc_match_statusSportsall Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_match_statusSports.all"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool all { get; set; }

Property Value

Boolean
See Also

Reference

desc_match_statusSports Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_statusSports.sport Property

desc_match_statusSportssport Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_match_statusSports.sport"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_match_statusSportsSport[] sport { get; set; }

Property Value

desc_match_statusSportsSport
See Also

Reference

desc_match_statusSports Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_statusSports Methods

The desc_match_statusSports type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

desc_match_statusSports Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_statusSportsSport Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.desc_match_statusSportsSport"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdesc_match_statusSportsSport

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class desc_match_statusSportsSport

The desc_match_statusSportsSport type exposes the following members.

Constructors
 | Name | Description
Public method | desc_match_statusSportsSport | Initializes a new instance of the desc_match_statusSportsSport class
Top
Properties
 | Name | Description
Public property | id |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_statusSportsSport Constructor

Initializes a new instance of the desc_match_statusSportsSport class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_match_statusSportsSport()
See Also

Reference

desc_match_statusSportsSport Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_statusSportsSport Properties

The desc_match_statusSportsSport type exposes the following members.

Properties
 | Name | Description
Public property | id |
Top
See Also

Reference

desc_match_statusSportsSport Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_statusSportsSport.id Property

desc_match_statusSportsSportid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_match_statusSportsSport.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

desc_match_statusSportsSport Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_match_statusSportsSport Methods

The desc_match_statusSportsSport type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

desc_match_statusSportsSport Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcome_reason Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.desc_outcome_reason"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdesc_outcome_reason

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class desc_outcome_reason

The desc_outcome_reason type exposes the following members.

Constructors
 | Name | Description
Public method | desc_outcome_reason | Initializes a new instance of the desc_outcome_reason class
Top
Properties
 | Name | Description
Public property | description |
Public property | id |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcome_reason Constructor

Initializes a new instance of the desc_outcome_reason class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_outcome_reason()
See Also

Reference

desc_outcome_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcome_reason Properties

The desc_outcome_reason type exposes the following members.

Properties
 | Name | Description
Public property | description |
Public property | id |
Top
See Also

Reference

desc_outcome_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcome_reason.description Property

desc_outcome_reasondescription Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_outcome_reason.description"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string description { get; set; }

Property Value

String
See Also

Reference

desc_outcome_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcome_reason.id Property

desc_outcome_reasonid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_outcome_reason.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long id { get; set; }

Property Value

Int64
See Also

Reference

desc_outcome_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcome_reason Methods

The desc_outcome_reason type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

desc_outcome_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcomesOutcome Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.desc_outcomesOutcome"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdesc_outcomesOutcome

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class desc_outcomesOutcome

The desc_outcomesOutcome type exposes the following members.

Constructors
 | Name | Description
Public method | desc_outcomesOutcome | Initializes a new instance of the desc_outcomesOutcome class
Top
Properties
 | Name | Description
Public property | description |
Public property | id |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcomesOutcome Constructor

Initializes a new instance of the desc_outcomesOutcome class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_outcomesOutcome()
See Also

Reference

desc_outcomesOutcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcomesOutcome Properties

The desc_outcomesOutcome type exposes the following members.

Properties
 | Name | Description
Public property | description |
Public property | id |
Public property | name |
Top
See Also

Reference

desc_outcomesOutcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcomesOutcome.description Property

desc_outcomesOutcomedescription Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_outcomesOutcome.description"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string description { get; set; }

Property Value

String
See Also

Reference

desc_outcomesOutcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcomesOutcome.id Property

desc_outcomesOutcomeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_outcomesOutcome.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

desc_outcomesOutcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcomesOutcome.name Property

desc_outcomesOutcomename Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_outcomesOutcome.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

desc_outcomesOutcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_outcomesOutcome Methods

The desc_outcomesOutcome type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

desc_outcomesOutcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_specifiersSpecifier Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.desc_specifiersSpecifier"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdesc_specifiersSpecifier

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class desc_specifiersSpecifier

The desc_specifiersSpecifier type exposes the following members.

Constructors
 | Name | Description
Public method | desc_specifiersSpecifier | Initializes a new instance of the desc_specifiersSpecifier class
Top
Properties
 | Name | Description
Public property | description |
Public property | name |
Public property | type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_specifiersSpecifier Constructor

Initializes a new instance of the desc_specifiersSpecifier class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_specifiersSpecifier()
See Also

Reference

desc_specifiersSpecifier Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_specifiersSpecifier Properties

The desc_specifiersSpecifier type exposes the following members.

Properties
 | Name | Description
Public property | description |
Public property | name |
Public property | type |
Top
See Also

Reference

desc_specifiersSpecifier Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_specifiersSpecifier.description Property

desc_specifiersSpecifierdescription Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_specifiersSpecifier.description"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string description { get; set; }

Property Value

String
See Also

Reference

desc_specifiersSpecifier Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_specifiersSpecifier.name Property

desc_specifiersSpecifiername Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_specifiersSpecifier.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

desc_specifiersSpecifier Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_specifiersSpecifier.type Property

desc_specifiersSpecifiertype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_specifiersSpecifier.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

desc_specifiersSpecifier Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_specifiersSpecifier Methods

The desc_specifiersSpecifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

desc_specifiersSpecifier Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.desc_variant"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdesc_variant

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class desc_variant

The desc_variant type exposes the following members.

Constructors
 | Name | Description
Public method | desc_variant | Initializes a new instance of the desc_variant class
Top
Properties
 | Name | Description
Public property | id |
Public property | mappings |
Public property | outcomes |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant Constructor

Initializes a new instance of the desc_variant class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_variant()
See Also

Reference

desc_variant Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant Properties

The desc_variant type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | mappings |
Public property | outcomes |
Top
See Also

Reference

desc_variant Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant.id Property

desc_variantid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_variant.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

desc_variant Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant.mappings Property

desc_variantmappings Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_variant.mappings"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public variant_mappingsMapping[] mappings { get; set; }

Property Value

variant_mappingsMapping
See Also

Reference

desc_variant Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant.outcomes Property

desc_variantoutcomes Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_variant.outcomes"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_variant_outcomesOutcome[] outcomes { get; set; }

Property Value

desc_variant_outcomesOutcome
See Also

Reference

desc_variant Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant Methods

The desc_variant type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

desc_variant Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant_outcomesOutcome Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.desc_variant_outcomesOutcome"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdesc_variant_outcomesOutcome

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class desc_variant_outcomesOutcome

The desc_variant_outcomesOutcome type exposes the following members.

Constructors
 | Name | Description
Public method | desc_variant_outcomesOutcome | Initializes a new instance of the desc_variant_outcomesOutcome class
Top
Properties
 | Name | Description
Public property | id |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant_outcomesOutcome Constructor

Initializes a new instance of the desc_variant_outcomesOutcome class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_variant_outcomesOutcome()
See Also

Reference

desc_variant_outcomesOutcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant_outcomesOutcome Properties

The desc_variant_outcomesOutcome type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | name |
Top
See Also

Reference

desc_variant_outcomesOutcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant_outcomesOutcome.id Property

desc_variant_outcomesOutcomeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_variant_outcomesOutcome.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

desc_variant_outcomesOutcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant_outcomesOutcome.name Property

desc_variant_outcomesOutcomename Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_variant_outcomesOutcome.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

desc_variant_outcomesOutcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_variant_outcomesOutcome Methods

The desc_variant_outcomesOutcome type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

desc_variant_outcomesOutcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_void_reason Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.desc_void_reason"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdesc_void_reason

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class desc_void_reason

The desc_void_reason type exposes the following members.

Constructors
 | Name | Description
Public method | desc_void_reason | Initializes a new instance of the desc_void_reason class
Top
Properties
 | Name | Description
Public property | description |
Public property | id |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_void_reason Constructor

Initializes a new instance of the desc_void_reason class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_void_reason()
See Also

Reference

desc_void_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_void_reason Properties

The desc_void_reason type exposes the following members.

Properties
 | Name | Description
Public property | description |
Public property | id |
Top
See Also

Reference

desc_void_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_void_reason.description Property

desc_void_reasondescription Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_void_reason.description"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string description { get; set; }

Property Value

String
See Also

Reference

desc_void_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_void_reason.id Property

desc_void_reasonid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.desc_void_reason.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long id { get; set; }

Property Value

Int64
See Also

Reference

desc_void_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


desc_void_reason Methods

The desc_void_reason type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

desc_void_reason Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_event Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.draw_event"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdraw_event

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class draw_event

The draw_event type exposes the following members.

Constructors
 | Name | Description
Public method | draw_event | Initializes a new instance of the draw_event class
Top
Properties
 | Name | Description
Public property | display_id |
Public property | display_idSpecified |
Public property | id |
Public property | scheduled |
Public property | scheduledSpecified |
Public property | status |
Public property | statusSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_event Constructor

Initializes a new instance of the draw_event class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_event()
See Also

Reference

draw_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_event Properties

The draw_event type exposes the following members.

Properties
 | Name | Description
Public property | display_id |
Public property | display_idSpecified |
Public property | id |
Public property | scheduled |
Public property | scheduledSpecified |
Public property | status |
Public property | statusSpecified |
Top
See Also

Reference

draw_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_event.display_id Property

draw_eventdisplay_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_event.display_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int display_id { get; set; }

Property Value

Int32
See Also

Reference

draw_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_event.display_idSpecified Property

draw_eventdisplay_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_event.display_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool display_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

draw_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_event.id Property

draw_eventid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_event.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

draw_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_event.scheduled Property

draw_eventscheduled Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_event.scheduled"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime scheduled { get; set; }

Property Value

DateTime
See Also

Reference

draw_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_event.scheduledSpecified Property

draw_eventscheduledSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_event.scheduledSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool scheduledSpecified { get; set; }

Property Value

Boolean
See Also

Reference

draw_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_event.status Property

draw_eventstatus Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_event.status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public drawStatus status { get; set; }

Property Value

drawStatus
See Also

Reference

draw_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_event.statusSpecified Property

draw_eventstatusSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_event.statusSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool statusSpecified { get; set; }

Property Value

Boolean
See Also

Reference

draw_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_event Methods

The draw_event type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

draw_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixture Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixture"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTdraw_fixture

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class draw_fixture : RestMessage

The draw_fixture type exposes the following members.

Constructors
 | Name | Description
Public method | draw_fixture | Initializes a new instance of the draw_fixture class
Top
Properties
 | Name | Description
Public property | display_id |
Public property | display_idSpecified |
Public property | draw_date |
Public property | draw_dateSpecified |
Public property | id |
Public property | lottery |
Public property | status |
Public property | statusSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixture Constructor

Initializes a new instance of the draw_fixture class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_fixture()
See Also

Reference

draw_fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixture Properties

The draw_fixture type exposes the following members.

Properties
 | Name | Description
Public property | display_id |
Public property | display_idSpecified |
Public property | draw_date |
Public property | draw_dateSpecified |
Public property | id |
Public property | lottery |
Public property | status |
Public property | statusSpecified |
Top
See Also

Reference

draw_fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixture.display_id Property

draw_fixturedisplay_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixture.display_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int display_id { get; set; }

Property Value

Int32
See Also

Reference

draw_fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixture.display_idSpecified Property

draw_fixturedisplay_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixture.display_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool display_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

draw_fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixture.draw_date Property

draw_fixturedraw_date Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixture.draw_date"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime draw_date { get; set; }

Property Value

DateTime
See Also

Reference

draw_fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixture.draw_dateSpecified Property

draw_fixturedraw_dateSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixture.draw_dateSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool draw_dateSpecified { get; set; }

Property Value

Boolean
See Also

Reference

draw_fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixture.id Property

draw_fixtureid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixture.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

draw_fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixture.lottery Property

draw_fixturelottery Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixture.lottery"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public lottery lottery { get; set; }

Property Value

lottery
See Also

Reference

draw_fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixture.status Property

draw_fixturestatus Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixture.status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public drawStatus status { get; set; }

Property Value

drawStatus
See Also

Reference

draw_fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixture.statusSpecified Property

draw_fixturestatusSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixture.statusSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool statusSpecified { get; set; }

Property Value

Boolean
See Also

Reference

draw_fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixture Methods

The draw_fixture type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

draw_fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixtures Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixtures"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTdraw_fixtures

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class draw_fixtures : RestMessage

The draw_fixtures type exposes the following members.

Constructors
 | Name | Description
Public method | draw_fixtures | Initializes a new instance of the draw_fixtures class
Top
Properties
 | Name | Description
Public property | draw_fixture |
Public property | generated_at |
Public property | generated_atSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixtures Constructor

Initializes a new instance of the draw_fixtures class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_fixtures()
See Also

Reference

draw_fixtures Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixtures Properties

The draw_fixtures type exposes the following members.

Properties
 | Name | Description
Public property | draw_fixture |
Public property | generated_at |
Public property | generated_atSpecified |
Top
See Also

Reference

draw_fixtures Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixtures.draw_fixture Property

draw_fixturesdraw_fixture Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixtures.draw_fixture"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_fixture draw_fixture { get; set; }

Property Value

draw_fixture
See Also

Reference

draw_fixtures Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixtures.generated_at Property

draw_fixturesgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixtures.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

draw_fixtures Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixtures.generated_atSpecified Property

draw_fixturesgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_fixtures.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

draw_fixtures Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_fixtures Methods

The draw_fixtures type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

draw_fixtures Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_result Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.draw_result"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdraw_result

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class draw_result

The draw_result type exposes the following members.

Constructors
 | Name | Description
Public method | draw_result | Initializes a new instance of the draw_result class
Top
Properties
 | Name | Description
Public property | draws |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_result Constructor

Initializes a new instance of the draw_result class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_result()
See Also

Reference

draw_result Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_result Properties

The draw_result type exposes the following members.

Properties
 | Name | Description
Public property | draws |
Top
See Also

Reference

draw_result Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_result.draws Property

draw_resultdraws Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_result.draws"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_resultDraws draws { get; set; }

Property Value

draw_resultDraws
See Also

Reference

draw_result Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_result Methods

The draw_result type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

draw_result Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDraws Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.draw_resultDraws"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdraw_resultDraws

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class draw_resultDraws

The draw_resultDraws type exposes the following members.

Constructors
 | Name | Description
Public method | draw_resultDraws | Initializes a new instance of the draw_resultDraws class
Top
Properties
 | Name | Description
Public property | chronological |
Public property | chronologicalSpecified |
Public property | draw |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDraws Constructor

Initializes a new instance of the draw_resultDraws class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_resultDraws()
See Also

Reference

draw_resultDraws Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDraws Properties

The draw_resultDraws type exposes the following members.

Properties
 | Name | Description
Public property | chronological |
Public property | chronologicalSpecified |
Public property | draw |
Top
See Also

Reference

draw_resultDraws Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDraws.chronological Property

draw_resultDrawschronological Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_resultDraws.chronological"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool chronological { get; set; }

Property Value

Boolean
See Also

Reference

draw_resultDraws Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDraws.chronologicalSpecified Property

draw_resultDrawschronologicalSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_resultDraws.chronologicalSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool chronologicalSpecified { get; set; }

Property Value

Boolean
See Also

Reference

draw_resultDraws Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDraws.draw Property

draw_resultDrawsdraw Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_resultDraws.draw"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_resultDrawsDraw[] draw { get; set; }

Property Value

draw_resultDrawsDraw
See Also

Reference

draw_resultDraws Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDraws Methods

The draw_resultDraws type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

draw_resultDraws Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDrawsDraw Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.draw_resultDrawsDraw"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTdraw_resultDrawsDraw

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class draw_resultDrawsDraw

The draw_resultDrawsDraw type exposes the following members.

Constructors
 | Name | Description
Public method | draw_resultDrawsDraw | Initializes a new instance of the draw_resultDrawsDraw class
Top
Properties
 | Name | Description
Public property | name |
Public property | value |
Public property | valueSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDrawsDraw Constructor

Initializes a new instance of the draw_resultDrawsDraw class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_resultDrawsDraw()
See Also

Reference

draw_resultDrawsDraw Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDrawsDraw Properties

The draw_resultDrawsDraw type exposes the following members.

Properties
 | Name | Description
Public property | name |
Public property | value |
Public property | valueSpecified |
Top
See Also

Reference

draw_resultDrawsDraw Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDrawsDraw.name Property

draw_resultDrawsDrawname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_resultDrawsDraw.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

draw_resultDrawsDraw Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDrawsDraw.value Property

draw_resultDrawsDrawvalue Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_resultDrawsDraw.value"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int value { get; set; }

Property Value

Int32
See Also

Reference

draw_resultDrawsDraw Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDrawsDraw.valueSpecified Property

draw_resultDrawsDrawvalueSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_resultDrawsDraw.valueSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool valueSpecified { get; set; }

Property Value

Boolean
See Also

Reference

draw_resultDrawsDraw Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_resultDrawsDraw Methods

The draw_resultDrawsDraw type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

draw_resultDrawsDraw Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_summary Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.draw_summary"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTdraw_summary

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class draw_summary : RestMessage

The draw_summary type exposes the following members.

Constructors
 | Name | Description
Public method | draw_summary | Initializes a new instance of the draw_summary class
Top
Properties
 | Name | Description
Public property | draw_fixture |
Public property | draw_result |
Public property | generated_at |
Public property | generated_atSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_summary Constructor

Initializes a new instance of the draw_summary class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_summary()
See Also

Reference

draw_summary Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_summary Properties

The draw_summary type exposes the following members.

Properties
 | Name | Description
Public property | draw_fixture |
Public property | draw_result |
Public property | generated_at |
Public property | generated_atSpecified |
Top
See Also

Reference

draw_summary Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_summary.draw_fixture Property

draw_summarydraw_fixture Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_summary.draw_fixture"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_fixture draw_fixture { get; set; }

Property Value

draw_fixture
See Also

Reference

draw_summary Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_summary.draw_result Property

draw_summarydraw_result Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_summary.draw_result"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_result draw_result { get; set; }

Property Value

draw_result
See Also

Reference

draw_summary Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_summary.generated_at Property

draw_summarygenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_summary.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

draw_summary Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_summary.generated_atSpecified Property

draw_summarygenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.draw_summary.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

draw_summary Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


draw_summary Methods

The draw_summary type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

draw_summary Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


drawStatus Enumeration

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.drawStatus"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public enum drawStatus
Members
Member name | Value | Description
open | 0 |
closed | 1 |
finished | 2 |
canceled | 3 |
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


drawType Enumeration

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.drawType"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public enum drawType
Members
Member name | Value | Description
drum | 0 |
rng | 1 |
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayer Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.eventPlayer"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTeventPlayer
Sportradar.OddsFeed.SDK.Messages.RESTeventPlayerAssist

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class eventPlayer

The eventPlayer type exposes the following members.

Constructors
 | Name | Description
Public method | eventPlayer | Initializes a new instance of the eventPlayer class
Top
Properties
 | Name | Description
Public property | bench |
Public property | id |
Public property | method |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayer Constructor

Initializes a new instance of the eventPlayer class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public eventPlayer()
See Also

Reference

eventPlayer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayer Properties

The eventPlayer type exposes the following members.

Properties
 | Name | Description
Public property | bench |
Public property | id |
Public property | method |
Public property | name |
Top
See Also

Reference

eventPlayer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayer.bench Property

eventPlayerbench Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.eventPlayer.bench"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string bench { get; set; }

Property Value

String
See Also

Reference

eventPlayer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayer.id Property

eventPlayerid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.eventPlayer.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

eventPlayer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayer.method Property

eventPlayermethod Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.eventPlayer.method"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string method { get; set; }

Property Value

String
See Also

Reference

eventPlayer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayer.name Property

eventPlayername Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.eventPlayer.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

eventPlayer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayer Methods

The eventPlayer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

eventPlayer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayerAssist Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.eventPlayerAssist"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTeventPlayer
Sportradar.OddsFeed.SDK.Messages.RESTeventPlayerAssist

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class eventPlayerAssist : eventPlayer

The eventPlayerAssist type exposes the following members.

Constructors
 | Name | Description
Public method | eventPlayerAssist | Initializes a new instance of the eventPlayerAssist class
Top
Properties
 | Name | Description
Public property | bench | (Inherited from eventPlayer)
Public property | id | (Inherited from eventPlayer)
Public property | method | (Inherited from eventPlayer)
Public property | name | (Inherited from eventPlayer)
Public property | type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayerAssist Constructor

Initializes a new instance of the eventPlayerAssist class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public eventPlayerAssist()
See Also

Reference

eventPlayerAssist Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayerAssist Properties

The eventPlayerAssist type exposes the following members.

Properties
 | Name | Description
Public property | bench | (Inherited from eventPlayer)
Public property | id | (Inherited from eventPlayer)
Public property | method | (Inherited from eventPlayer)
Public property | name | (Inherited from eventPlayer)
Public property | type |
Top
See Also

Reference

eventPlayerAssist Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayerAssist.type Property

eventPlayerAssisttype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.eventPlayerAssist.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

eventPlayerAssist Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


eventPlayerAssist Methods

The eventPlayerAssist type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

eventPlayerAssist Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


EventType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.EventType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTEventType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class EventType

The EventType type exposes the following members.

Constructors
 | Name | Description
Public method | EventType | Initializes a new instance of the EventType class
Top
Properties
 | Name | Description
Public property | id |
Public property | markets |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


EventType Constructor

Initializes a new instance of the EventType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public EventType()
See Also

Reference

EventType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


EventType Properties

The EventType type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | markets |
Top
See Also

Reference

EventType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


EventType.id Property

EventTypeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.EventType.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

EventType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


EventType.markets Property

EventTypemarkets Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.EventType.markets"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public MarketType[] markets { get; set; }

Property Value

MarketType
See Also

Reference

EventType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


EventType Methods

The EventType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EventType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResponseType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.FilteredCalculationResponseType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTFilteredCalculationResponseType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class FilteredCalculationResponseType : RestMessage

The FilteredCalculationResponseType type exposes the following members.

Constructors
 | Name | Description
Public method | FilteredCalculationResponseType | Initializes a new instance of the FilteredCalculationResponseType class
Top
Properties
 | Name | Description
Public property | available_selections |
Public property | calculation |
Public property | generated_at |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResponseType Constructor

Initializes a new instance of the FilteredCalculationResponseType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilteredCalculationResponseType()
See Also

Reference

FilteredCalculationResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResponseType Properties

The FilteredCalculationResponseType type exposes the following members.

Properties
 | Name | Description
Public property | available_selections |
Public property | calculation |
Public property | generated_at |
Top
See Also

Reference

FilteredCalculationResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResponseType.available_selections Property

FilteredCalculationResponseTypeavailable_selections Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredCalculationResponseType.available_selections"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilteredEventType[] available_selections { get; set; }

Property Value

FilteredEventType
See Also

Reference

FilteredCalculationResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResponseType.calculation Property

FilteredCalculationResponseTypecalculation Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredCalculationResponseType.calculation"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilteredCalculationResultType calculation { get; set; }

Property Value

FilteredCalculationResultType
See Also

Reference

FilteredCalculationResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResponseType.generated_at Property

FilteredCalculationResponseTypegenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredCalculationResponseType.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string generated_at { get; set; }

Property Value

String
See Also

Reference

FilteredCalculationResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResponseType Methods

The FilteredCalculationResponseType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilteredCalculationResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResultType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.FilteredCalculationResultType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTFilteredCalculationResultType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class FilteredCalculationResultType

The FilteredCalculationResultType type exposes the following members.

Constructors
 | Name | Description
Public method | FilteredCalculationResultType | Initializes a new instance of the FilteredCalculationResultType class
Top
Properties
 | Name | Description
Public property | odds |
Public property | probability |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResultType Constructor

Initializes a new instance of the FilteredCalculationResultType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilteredCalculationResultType()
See Also

Reference

FilteredCalculationResultType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResultType Properties

The FilteredCalculationResultType type exposes the following members.

Properties
 | Name | Description
Public property | odds |
Public property | probability |
Top
See Also

Reference

FilteredCalculationResultType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResultType.odds Property

FilteredCalculationResultTypeodds Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredCalculationResultType.odds"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double odds { get; set; }

Property Value

Double
See Also

Reference

FilteredCalculationResultType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResultType.probability Property

FilteredCalculationResultTypeprobability Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredCalculationResultType.probability"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double probability { get; set; }

Property Value

Double
See Also

Reference

FilteredCalculationResultType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredCalculationResultType Methods

The FilteredCalculationResultType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilteredCalculationResultType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredEventType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.FilteredEventType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTFilteredEventType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class FilteredEventType

The FilteredEventType type exposes the following members.

Constructors
 | Name | Description
Public method | FilteredEventType | Initializes a new instance of the FilteredEventType class
Top
Properties
 | Name | Description
Public property | id |
Public property | markets |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredEventType Constructor

Initializes a new instance of the FilteredEventType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilteredEventType()
See Also

Reference

FilteredEventType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredEventType Properties

The FilteredEventType type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | markets |
Top
See Also

Reference

FilteredEventType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredEventType.id Property

FilteredEventTypeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredEventType.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

FilteredEventType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredEventType.markets Property

FilteredEventTypemarkets Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredEventType.markets"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilteredMarketType[] markets { get; set; }

Property Value

FilteredMarketType
See Also

Reference

FilteredEventType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredEventType Methods

The FilteredEventType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilteredEventType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredMarketType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.FilteredMarketType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTFilteredMarketType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class FilteredMarketType

The FilteredMarketType type exposes the following members.

Constructors
 | Name | Description
Public method | FilteredMarketType | Initializes a new instance of the FilteredMarketType class
Top
Properties
 | Name | Description
Public property | conflict |
Public property | conflictSpecified |
Public property | id |
Public property | outcome |
Public property | specifiers |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredMarketType Constructor

Initializes a new instance of the FilteredMarketType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilteredMarketType()
See Also

Reference

FilteredMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredMarketType Properties

The FilteredMarketType type exposes the following members.

Properties
 | Name | Description
Public property | conflict |
Public property | conflictSpecified |
Public property | id |
Public property | outcome |
Public property | specifiers |
Top
See Also

Reference

FilteredMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredMarketType.conflict Property

FilteredMarketTypeconflict Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredMarketType.conflict"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool conflict { get; set; }

Property Value

Boolean
See Also

Reference

FilteredMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredMarketType.conflictSpecified Property

FilteredMarketTypeconflictSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredMarketType.conflictSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool conflictSpecified { get; set; }

Property Value

Boolean
See Also

Reference

FilteredMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredMarketType.id Property

FilteredMarketTypeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredMarketType.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int id { get; set; }

Property Value

Int32
See Also

Reference

FilteredMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredMarketType.outcome Property

FilteredMarketTypeoutcome Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredMarketType.outcome"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilteredOutcomeType[] outcome { get; set; }

Property Value

FilteredOutcomeType
See Also

Reference

FilteredMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredMarketType.specifiers Property

FilteredMarketTypespecifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredMarketType.specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string specifiers { get; set; }

Property Value

String
See Also

Reference

FilteredMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredMarketType Methods

The FilteredMarketType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilteredMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredOutcomeType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.FilteredOutcomeType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTFilteredOutcomeType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class FilteredOutcomeType

The FilteredOutcomeType type exposes the following members.

Constructors
 | Name | Description
Public method | FilteredOutcomeType | Initializes a new instance of the FilteredOutcomeType class
Top
Properties
 | Name | Description
Public property | conflict |
Public property | conflictSpecified |
Public property | id |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredOutcomeType Constructor

Initializes a new instance of the FilteredOutcomeType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilteredOutcomeType()
See Also

Reference

FilteredOutcomeType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredOutcomeType Properties

The FilteredOutcomeType type exposes the following members.

Properties
 | Name | Description
Public property | conflict |
Public property | conflictSpecified |
Public property | id |
Top
See Also

Reference

FilteredOutcomeType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredOutcomeType.conflict Property

FilteredOutcomeTypeconflict Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredOutcomeType.conflict"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool conflict { get; set; }

Property Value

Boolean
See Also

Reference

FilteredOutcomeType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredOutcomeType.conflictSpecified Property

FilteredOutcomeTypeconflictSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredOutcomeType.conflictSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool conflictSpecified { get; set; }

Property Value

Boolean
See Also

Reference

FilteredOutcomeType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredOutcomeType.id Property

FilteredOutcomeTypeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilteredOutcomeType.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

FilteredOutcomeType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilteredOutcomeType Methods

The FilteredOutcomeType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilteredOutcomeType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionMarketType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.FilterSelectionMarketType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTFilterSelectionMarketType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class FilterSelectionMarketType

The FilterSelectionMarketType type exposes the following members.

Constructors
 | Name | Description
Public method | FilterSelectionMarketType | Initializes a new instance of the FilterSelectionMarketType class
Top
Properties
 | Name | Description
Public property | market_id |
Public property | outcome_id |
Public property | specifiers |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionMarketType Constructor

Initializes a new instance of the FilterSelectionMarketType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilterSelectionMarketType()
See Also

Reference

FilterSelectionMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionMarketType Properties

The FilterSelectionMarketType type exposes the following members.

Properties
 | Name | Description
Public property | market_id |
Public property | outcome_id |
Public property | specifiers |
Top
See Also

Reference

FilterSelectionMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionMarketType.market_id Property

FilterSelectionMarketTypemarket_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilterSelectionMarketType.market_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int market_id { get; set; }

Property Value

Int32
See Also

Reference

FilterSelectionMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionMarketType.outcome_id Property

FilterSelectionMarketTypeoutcome_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilterSelectionMarketType.outcome_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string outcome_id { get; set; }

Property Value

String
See Also

Reference

FilterSelectionMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionMarketType.specifiers Property

FilterSelectionMarketTypespecifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilterSelectionMarketType.specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string specifiers { get; set; }

Property Value

String
See Also

Reference

FilterSelectionMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionMarketType Methods

The FilterSelectionMarketType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterSelectionMarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionsType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.FilterSelectionsType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTFilterSelectionsType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class FilterSelectionsType

The FilterSelectionsType type exposes the following members.

Constructors
 | Name | Description
Public method | FilterSelectionsType | Initializes a new instance of the FilterSelectionsType class
Top
Properties
 | Name | Description
Public property | selection |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionsType Constructor

Initializes a new instance of the FilterSelectionsType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilterSelectionsType()
See Also

Reference

FilterSelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionsType Properties

The FilterSelectionsType type exposes the following members.

Properties
 | Name | Description
Public property | selection |
Top
See Also

Reference

FilterSelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionsType.selection Property

FilterSelectionsTypeselection Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilterSelectionsType.selection"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilterSelectionType[] selection { get; set; }

Property Value

FilterSelectionType
See Also

Reference

FilterSelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionsType Methods

The FilterSelectionsType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterSelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.FilterSelectionType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTFilterSelectionType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class FilterSelectionType

The FilterSelectionType type exposes the following members.

Constructors
 | Name | Description
Public method | FilterSelectionType | Initializes a new instance of the FilterSelectionType class
Top
Properties
 | Name | Description
Public property | id |
Public property | market |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionType Constructor

Initializes a new instance of the FilterSelectionType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilterSelectionType()
See Also

Reference

FilterSelectionType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionType Properties

The FilterSelectionType type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | market |
Top
See Also

Reference

FilterSelectionType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionType.id Property

FilterSelectionTypeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilterSelectionType.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

FilterSelectionType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionType.market Property

FilterSelectionTypemarket Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.FilterSelectionType.market"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public FilterSelectionMarketType[] market { get; set; }

Property Value

FilterSelectionMarketType
See Also

Reference

FilterSelectionType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


FilterSelectionType Methods

The FilterSelectionType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterSelectionType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.fixture"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTsportEvent
Sportradar.OddsFeed.SDK.Messages.RESTfixture

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class fixture : sportEvent

The fixture type exposes the following members.

Constructors
 | Name | Description
Public method | fixture | Initializes a new instance of the fixture class
Top
Properties
 | Name | Description
Public property | additional_parents | (Inherited from sportEvent)
Public property | competitors | (Inherited from sportEvent)
Public property | coverage_info |
Public property | delayed_info |
Public property | extra_info |
Public property | id | (Inherited from sportEvent)
Public property | liveodds | (Inherited from sportEvent)
Public property | name | (Inherited from sportEvent)
Public property | next_live_time | (Inherited from sportEvent)
Public property | parent | (Inherited from sportEvent)
Public property | product_info |
Public property | races | (Inherited from sportEvent)
Public property | reference_ids |
Public property | replaced_by | (Inherited from sportEvent)
Public property | scheduled | (Inherited from sportEvent)
Public property | scheduled_end | (Inherited from sportEvent)
Public property | scheduled_endSpecified | (Inherited from sportEvent)
Public property | scheduled_start_time_changes |
Public property | scheduledSpecified | (Inherited from sportEvent)
Public property | season | (Inherited from sportEvent)
Public property | sport_event_conditions | (Inherited from sportEvent)
Public property | stage_type | (Inherited from sportEvent)
Public property | start_time |
Public property | start_time_confirmed |
Public property | start_time_confirmedSpecified |
Public property | start_time_tbd | (Inherited from sportEvent)
Public property | start_time_tbdSpecified | (Inherited from sportEvent)
Public property | start_timeSpecified |
Public property | status | (Inherited from sportEvent)
Public property | tournament | (Inherited from sportEvent)
Public property | tournament_round | (Inherited from sportEvent)
Public property | tv_channels |
Public property | type | (Inherited from sportEvent)
Public property | venue | (Inherited from sportEvent)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture Constructor

Initializes a new instance of the fixture class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public fixture()
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture Properties

The fixture type exposes the following members.

Properties
 | Name | Description
Public property | additional_parents | (Inherited from sportEvent)
Public property | competitors | (Inherited from sportEvent)
Public property | coverage_info |
Public property | delayed_info |
Public property | extra_info |
Public property | id | (Inherited from sportEvent)
Public property | liveodds | (Inherited from sportEvent)
Public property | name | (Inherited from sportEvent)
Public property | next_live_time | (Inherited from sportEvent)
Public property | parent | (Inherited from sportEvent)
Public property | product_info |
Public property | races | (Inherited from sportEvent)
Public property | reference_ids |
Public property | replaced_by | (Inherited from sportEvent)
Public property | scheduled | (Inherited from sportEvent)
Public property | scheduled_end | (Inherited from sportEvent)
Public property | scheduled_endSpecified | (Inherited from sportEvent)
Public property | scheduled_start_time_changes |
Public property | scheduledSpecified | (Inherited from sportEvent)
Public property | season | (Inherited from sportEvent)
Public property | sport_event_conditions | (Inherited from sportEvent)
Public property | stage_type | (Inherited from sportEvent)
Public property | start_time |
Public property | start_time_confirmed |
Public property | start_time_confirmedSpecified |
Public property | start_time_tbd | (Inherited from sportEvent)
Public property | start_time_tbdSpecified | (Inherited from sportEvent)
Public property | start_timeSpecified |
Public property | status | (Inherited from sportEvent)
Public property | tournament | (Inherited from sportEvent)
Public property | tournament_round | (Inherited from sportEvent)
Public property | tv_channels |
Public property | type | (Inherited from sportEvent)
Public property | venue | (Inherited from sportEvent)
Top
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture.coverage_info Property

fixturecoverage_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixture.coverage_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public coverageInfo coverage_info { get; set; }

Property Value

coverageInfo
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture.delayed_info Property

fixturedelayed_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixture.delayed_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public delayedInfo delayed_info { get; set; }

Property Value

delayedInfo
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture.extra_info Property

fixtureextra_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixture.extra_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public info[] extra_info { get; set; }

Property Value

info
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture.product_info Property

fixtureproduct_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixture.product_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public productInfo product_info { get; set; }

Property Value

productInfo
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture.reference_ids Property

fixturereference_ids Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixture.reference_ids"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public referenceIdsReference_id[] reference_ids { get; set; }

Property Value

referenceIdsReference_id
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture.scheduled_start_time_changes Property

fixturescheduled_start_time_changes Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixture.scheduled_start_time_changes"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public scheduledStartTimeChange[] scheduled_start_time_changes { get; set; }

Property Value

scheduledStartTimeChange
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture.start_time Property

fixturestart_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixture.start_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime start_time { get; set; }

Property Value

DateTime
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture.start_time_confirmed Property

fixturestart_time_confirmed Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixture.start_time_confirmed"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_time_confirmed { get; set; }

Property Value

Boolean
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture.start_time_confirmedSpecified Property

fixturestart_time_confirmedSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixture.start_time_confirmedSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_time_confirmedSpecified { get; set; }

Property Value

Boolean
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture.start_timeSpecified Property

fixturestart_timeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixture.start_timeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_timeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture.tv_channels Property

fixturetv_channels Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixture.tv_channels"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tvChannel[] tv_channels { get; set; }

Property Value

tvChannel
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixture Methods

The fixture type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

fixture Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChange Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.fixtureChange"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTfixtureChange

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class fixtureChange

The fixtureChange type exposes the following members.

Constructors
 | Name | Description
Public method | fixtureChange | Initializes a new instance of the fixtureChange class
Top
Properties
 | Name | Description
Public property | sport_event_id |
Public property | update_time |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChange Constructor

Initializes a new instance of the fixtureChange class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public fixtureChange()
See Also

Reference

fixtureChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChange Properties

The fixtureChange type exposes the following members.

Properties
 | Name | Description
Public property | sport_event_id |
Public property | update_time |
Top
See Also

Reference

fixtureChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChange.sport_event_id Property

fixtureChangesport_event_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixtureChange.sport_event_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string sport_event_id { get; set; }

Property Value

String
See Also

Reference

fixtureChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChange.update_time Property

fixtureChangeupdate_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixtureChange.update_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime update_time { get; set; }

Property Value

DateTime
See Also

Reference

fixtureChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChange Methods

The fixtureChange type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

fixtureChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChangesEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.fixtureChangesEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTfixtureChangesEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class fixtureChangesEndpoint : RestMessage

The fixtureChangesEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | fixtureChangesEndpoint | Initializes a new instance of the fixtureChangesEndpoint class
Top
Properties
 | Name | Description
Public property | fixture_change |
Public property | generated_at |
Public property | generated_atSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChangesEndpoint Constructor

Initializes a new instance of the fixtureChangesEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public fixtureChangesEndpoint()
See Also

Reference

fixtureChangesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChangesEndpoint Properties

The fixtureChangesEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | fixture_change |
Public property | generated_at |
Public property | generated_atSpecified |
Top
See Also

Reference

fixtureChangesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChangesEndpoint.fixture_change Property

fixtureChangesEndpointfixture_change Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixtureChangesEndpoint.fixture_change"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public fixtureChange[] fixture_change { get; set; }

Property Value

fixtureChange
See Also

Reference

fixtureChangesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChangesEndpoint.generated_at Property

fixtureChangesEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixtureChangesEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

fixtureChangesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChangesEndpoint.generated_atSpecified Property

fixtureChangesEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixtureChangesEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

fixtureChangesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixtureChangesEndpoint Methods

The fixtureChangesEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

fixtureChangesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixturesEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.fixturesEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTfixturesEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class fixturesEndpoint : RestMessage

The fixturesEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | fixturesEndpoint | Initializes a new instance of the fixturesEndpoint class
Top
Properties
 | Name | Description
Public property | fixture |
Public property | generated_at |
Public property | generated_atSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixturesEndpoint Constructor

Initializes a new instance of the fixturesEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public fixturesEndpoint()
See Also

Reference

fixturesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixturesEndpoint Properties

The fixturesEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | fixture |
Public property | generated_at |
Public property | generated_atSpecified |
Top
See Also

Reference

fixturesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixturesEndpoint.fixture Property

fixturesEndpointfixture Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixturesEndpoint.fixture"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public fixture fixture { get; set; }

Property Value

fixture
See Also

Reference

fixturesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixturesEndpoint.generated_at Property

fixturesEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixturesEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

fixturesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixturesEndpoint.generated_atSpecified Property

fixturesEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.fixturesEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

fixturesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


fixturesEndpoint Methods

The fixturesEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

fixturesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


hole Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.hole"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESThole

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class hole

The hole type exposes the following members.

Constructors
 | Name | Description
Public method | hole | Initializes a new instance of the hole class
Top
Properties
 | Name | Description
Public property | number |
Public property | par |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


hole Constructor

Initializes a new instance of the hole class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public hole()
See Also

Reference

hole Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


hole Properties

The hole type exposes the following members.

Properties
 | Name | Description
Public property | number |
Public property | par |
Top
See Also

Reference

hole Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


hole.number Property

holenumber Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.hole.number"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int number { get; set; }

Property Value

Int32
See Also

Reference

hole Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


hole.par Property

holepar Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.hole.par"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int par { get; set; }

Property Value

Int32
See Also

Reference

hole Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


hole Methods

The hole type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

hole Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


info Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.info"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTinfo

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class info

The info type exposes the following members.

Constructors
 | Name | Description
Public method | info | Initializes a new instance of the info class
Top
Properties
 | Name | Description
Public property | key |
Public property | value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


info Constructor

Initializes a new instance of the info class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public info()
See Also

Reference

info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


info Properties

The info type exposes the following members.

Properties
 | Name | Description
Public property | key |
Public property | value |
Top
See Also

Reference

info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


info.key Property

infokey Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.info.key"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string key { get; set; }

Property Value

String
See Also

Reference

info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


info.value Property

infovalue Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.info.value"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string value { get; set; }

Property Value

String
See Also

Reference

info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


info Methods

The info type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.jersey"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTjersey

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class jersey

The jersey type exposes the following members.

Constructors
 | Name | Description
Public method | jersey | Initializes a new instance of the jersey class
Top
Properties
 | Name | Description
Public property | base |
Public property | horizontal_stripes |
Public property | horizontal_stripes_color |
Public property | horizontal_stripesSpecified |
Public property | number |
Public property | shirt_type |
Public property | sleeve |
Public property | sleeve_detail |
Public property | split |
Public property | split_color |
Public property | splitSpecified |
Public property | squares |
Public property | squares_color |
Public property | squaresSpecified |
Public property | stripes |
Public property | stripes_color |
Public property | stripesSpecified |
Public property | type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey Constructor

Initializes a new instance of the jersey class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public jersey()
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey Properties

The jersey type exposes the following members.

Properties
 | Name | Description
Public property | base |
Public property | horizontal_stripes |
Public property | horizontal_stripes_color |
Public property | horizontal_stripesSpecified |
Public property | number |
Public property | shirt_type |
Public property | sleeve |
Public property | sleeve_detail |
Public property | split |
Public property | split_color |
Public property | splitSpecified |
Public property | squares |
Public property | squares_color |
Public property | squaresSpecified |
Public property | stripes |
Public property | stripes_color |
Public property | stripesSpecified |
Public property | type |
Top
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.base Property

jerseybase Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.base"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string base { get; set; }

Property Value

String
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.horizontal_stripes Property

jerseyhorizontal_stripes Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.horizontal_stripes"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool horizontal_stripes { get; set; }

Property Value

Boolean
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.horizontal_stripes_color Property

jerseyhorizontal_stripes_color Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.horizontal_stripes_color"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string horizontal_stripes_color { get; set; }

Property Value

String
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.horizontal_stripesSpecified Property

jerseyhorizontal_stripesSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.horizontal_stripesSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool horizontal_stripesSpecified { get; set; }

Property Value

Boolean
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.number Property

jerseynumber Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.number"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string number { get; set; }

Property Value

String
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.shirt_type Property

jerseyshirt_type Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.shirt_type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string shirt_type { get; set; }

Property Value

String
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.sleeve Property

jerseysleeve Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.sleeve"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string sleeve { get; set; }

Property Value

String
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.sleeve_detail Property

jerseysleeve_detail Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.sleeve_detail"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string sleeve_detail { get; set; }

Property Value

String
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.split Property

jerseysplit Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.split"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool split { get; set; }

Property Value

Boolean
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.split_color Property

jerseysplit_color Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.split_color"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string split_color { get; set; }

Property Value

String
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.splitSpecified Property

jerseysplitSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.splitSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool splitSpecified { get; set; }

Property Value

Boolean
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.squares Property

jerseysquares Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.squares"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool squares { get; set; }

Property Value

Boolean
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.squares_color Property

jerseysquares_color Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.squares_color"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string squares_color { get; set; }

Property Value

String
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.squaresSpecified Property

jerseysquaresSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.squaresSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool squaresSpecified { get; set; }

Property Value

Boolean
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.stripes Property

jerseystripes Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.stripes"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool stripes { get; set; }

Property Value

Boolean
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.stripes_color Property

jerseystripes_color Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.stripes_color"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string stripes_color { get; set; }

Property Value

String
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.stripesSpecified Property

jerseystripesSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.stripesSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool stripesSpecified { get; set; }

Property Value

Boolean
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey.type Property

jerseytype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.jersey.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


jersey Methods

The jersey type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

jersey Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteries Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.lotteries"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTlotteries

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class lotteries : RestMessage

The lotteries type exposes the following members.

Constructors
 | Name | Description
Public method | lotteries | Initializes a new instance of the lotteries class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | lottery |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteries Constructor

Initializes a new instance of the lotteries class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public lotteries()
See Also

Reference

lotteries Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteries Properties

The lotteries type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | lottery |
Top
See Also

Reference

lotteries Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteries.generated_at Property

lotteriesgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteries.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

lotteries Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteries.generated_atSpecified Property

lotteriesgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteries.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

lotteries Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteries.lottery Property

lotterieslottery Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteries.lottery"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public lottery[] lottery { get; set; }

Property Value

lottery
See Also

Reference

lotteries Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteries Methods

The lotteries type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

lotteries Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.lottery"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTlottery

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class lottery

The lottery type exposes the following members.

Constructors
 | Name | Description
Public method | lottery | Initializes a new instance of the lottery class
Top
Properties
 | Name | Description
Public property | bonus_info |
Public property | category |
Public property | draw_info |
Public property | id |
Public property | name |
Public property | sport |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery Constructor

Initializes a new instance of the lottery class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public lottery()
See Also

Reference

lottery Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery Properties

The lottery type exposes the following members.

Properties
 | Name | Description
Public property | bonus_info |
Public property | category |
Public property | draw_info |
Public property | id |
Public property | name |
Public property | sport |
Top
See Also

Reference

lottery Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery.bonus_info Property

lotterybonus_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lottery.bonus_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public lotteryBonus_info bonus_info { get; set; }

Property Value

lotteryBonus_info
See Also

Reference

lottery Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery.category Property

lotterycategory Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lottery.category"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public category category { get; set; }

Property Value

category
See Also

Reference

lottery Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery.draw_info Property

lotterydraw_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lottery.draw_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public lotteryDraw_info draw_info { get; set; }

Property Value

lotteryDraw_info
See Also

Reference

lottery Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery.id Property

lotteryid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lottery.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

lottery Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery.name Property

lotteryname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lottery.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

lottery Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery.sport Property

lotterysport Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lottery.sport"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sport sport { get; set; }

Property Value

sport
See Also

Reference

lottery Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery Methods

The lottery type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

lottery Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery_schedule Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.lottery_schedule"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTlottery_schedule

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class lottery_schedule : RestMessage

The lottery_schedule type exposes the following members.

Constructors
 | Name | Description
Public method | lottery_schedule | Initializes a new instance of the lottery_schedule class
Top
Properties
 | Name | Description
Public property | draw_events |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | lottery |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery_schedule Constructor

Initializes a new instance of the lottery_schedule class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public lottery_schedule()
See Also

Reference

lottery_schedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery_schedule Properties

The lottery_schedule type exposes the following members.

Properties
 | Name | Description
Public property | draw_events |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | lottery |
Top
See Also

Reference

lottery_schedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery_schedule.draw_events Property

lottery_scheduledraw_events Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lottery_schedule.draw_events"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public draw_event[] draw_events { get; set; }

Property Value

draw_event
See Also

Reference

lottery_schedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery_schedule.generated_at Property

lottery_schedulegenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lottery_schedule.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

lottery_schedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery_schedule.generated_atSpecified Property

lottery_schedulegenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lottery_schedule.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

lottery_schedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery_schedule.lottery Property

lottery_schedulelottery Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lottery_schedule.lottery"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public lottery lottery { get; set; }

Property Value

lottery
See Also

Reference

lottery_schedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lottery_schedule Methods

The lottery_schedule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

lottery_schedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryBonus_info Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.lotteryBonus_info"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTlotteryBonus_info

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class lotteryBonus_info

The lotteryBonus_info type exposes the following members.

Constructors
 | Name | Description
Public method | lotteryBonus_info | Initializes a new instance of the lotteryBonus_info class
Top
Properties
 | Name | Description
Public property | bonus_balls |
Public property | bonus_ballsSpecified |
Public property | bonus_drum |
Public property | bonus_drumSpecified |
Public property | bonus_range |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryBonus_info Constructor

Initializes a new instance of the lotteryBonus_info class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public lotteryBonus_info()
See Also

Reference

lotteryBonus_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryBonus_info Properties

The lotteryBonus_info type exposes the following members.

Properties
 | Name | Description
Public property | bonus_balls |
Public property | bonus_ballsSpecified |
Public property | bonus_drum |
Public property | bonus_drumSpecified |
Public property | bonus_range |
Top
See Also

Reference

lotteryBonus_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryBonus_info.bonus_balls Property

lotteryBonus_infobonus_balls Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteryBonus_info.bonus_balls"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int bonus_balls { get; set; }

Property Value

Int32
See Also

Reference

lotteryBonus_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryBonus_info.bonus_ballsSpecified Property

lotteryBonus_infobonus_ballsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteryBonus_info.bonus_ballsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool bonus_ballsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

lotteryBonus_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryBonus_info.bonus_drum Property

lotteryBonus_infobonus_drum Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteryBonus_info.bonus_drum"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bonusDrumType bonus_drum { get; set; }

Property Value

bonusDrumType
See Also

Reference

lotteryBonus_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryBonus_info.bonus_drumSpecified Property

lotteryBonus_infobonus_drumSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteryBonus_info.bonus_drumSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool bonus_drumSpecified { get; set; }

Property Value

Boolean
See Also

Reference

lotteryBonus_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryBonus_info.bonus_range Property

lotteryBonus_infobonus_range Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteryBonus_info.bonus_range"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string bonus_range { get; set; }

Property Value

String
See Also

Reference

lotteryBonus_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryBonus_info Methods

The lotteryBonus_info type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

lotteryBonus_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryDraw_info Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.lotteryDraw_info"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTlotteryDraw_info

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class lotteryDraw_info

The lotteryDraw_info type exposes the following members.

Constructors
 | Name | Description
Public method | lotteryDraw_info | Initializes a new instance of the lotteryDraw_info class
Top
Properties
 | Name | Description
Public property | draw_type |
Public property | draw_typeSpecified |
Public property | game_type |
Public property | time_type |
Public property | time_typeSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryDraw_info Constructor

Initializes a new instance of the lotteryDraw_info class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public lotteryDraw_info()
See Also

Reference

lotteryDraw_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryDraw_info Properties

The lotteryDraw_info type exposes the following members.

Properties
 | Name | Description
Public property | draw_type |
Public property | draw_typeSpecified |
Public property | game_type |
Public property | time_type |
Public property | time_typeSpecified |
Top
See Also

Reference

lotteryDraw_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryDraw_info.draw_type Property

lotteryDraw_infodraw_type Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteryDraw_info.draw_type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public drawType draw_type { get; set; }

Property Value

drawType
See Also

Reference

lotteryDraw_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryDraw_info.draw_typeSpecified Property

lotteryDraw_infodraw_typeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteryDraw_info.draw_typeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool draw_typeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

lotteryDraw_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryDraw_info.game_type Property

lotteryDraw_infogame_type Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteryDraw_info.game_type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string game_type { get; set; }

Property Value

String
See Also

Reference

lotteryDraw_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryDraw_info.time_type Property

lotteryDraw_infotime_type Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteryDraw_info.time_type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public timeType time_type { get; set; }

Property Value

timeType
See Also

Reference

lotteryDraw_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryDraw_info.time_typeSpecified Property

lotteryDraw_infotime_typeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.lotteryDraw_info.time_typeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool time_typeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

lotteryDraw_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


lotteryDraw_info Methods

The lotteryDraw_info type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

lotteryDraw_info Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


manager Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.manager"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTmanager

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class manager

The manager type exposes the following members.

Constructors
 | Name | Description
Public method | manager | Initializes a new instance of the manager class
Top
Properties
 | Name | Description
Public property | country_code |
Public property | id |
Public property | name |
Public property | nationality |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


manager Constructor

Initializes a new instance of the manager class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public manager()
See Also

Reference

manager Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


manager Properties

The manager type exposes the following members.

Properties
 | Name | Description
Public property | country_code |
Public property | id |
Public property | name |
Public property | nationality |
Top
See Also

Reference

manager Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


manager.country_code Property

managercountry_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.manager.country_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string country_code { get; set; }

Property Value

String
See Also

Reference

manager Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


manager.id Property

managerid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.manager.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

manager Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


manager.name Property

managername Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.manager.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

manager Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


manager.nationality Property

managernationality Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.manager.nationality"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string nationality { get; set; }

Property Value

String
See Also

Reference

manager Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


manager Methods

The manager type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

manager Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMapping Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.mappingsMapping"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTmappingsMapping

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class mappingsMapping

The mappingsMapping type exposes the following members.

Constructors
 | Name | Description
Public method | mappingsMapping | Initializes a new instance of the mappingsMapping class
Top
Properties
 | Name | Description
Public property | mapping_outcome |
Public property | market_id |
Public property | product_id |
Public property | product_ids |
Public property | sov_template |
Public property | sport_id |
Public property | valid_for |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMapping Constructor

Initializes a new instance of the mappingsMapping class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public mappingsMapping()
See Also

Reference

mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMapping Properties

The mappingsMapping type exposes the following members.

Properties
 | Name | Description
Public property | mapping_outcome |
Public property | market_id |
Public property | product_id |
Public property | product_ids |
Public property | sov_template |
Public property | sport_id |
Public property | valid_for |
Top
See Also

Reference

mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMapping.mapping_outcome Property

mappingsMappingmapping_outcome Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.mappingsMapping.mapping_outcome"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public mappingsMappingMapping_outcome[] mapping_outcome { get; set; }

Property Value

mappingsMappingMapping_outcome
See Also

Reference

mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMapping.market_id Property

mappingsMappingmarket_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.mappingsMapping.market_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string market_id { get; set; }

Property Value

String
See Also

Reference

mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMapping.product_id Property

mappingsMappingproduct_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.mappingsMapping.product_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int product_id { get; set; }

Property Value

Int32
See Also

Reference

mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMapping.product_ids Property

mappingsMappingproduct_ids Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.mappingsMapping.product_ids"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string product_ids { get; set; }

Property Value

String
See Also

Reference

mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMapping.sov_template Property

mappingsMappingsov_template Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.mappingsMapping.sov_template"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string sov_template { get; set; }

Property Value

String
See Also

Reference

mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMapping.sport_id Property

mappingsMappingsport_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.mappingsMapping.sport_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string sport_id { get; set; }

Property Value

String
See Also

Reference

mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMapping.valid_for Property

mappingsMappingvalid_for Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.mappingsMapping.valid_for"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string valid_for { get; set; }

Property Value

String
See Also

Reference

mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMapping Methods

The mappingsMapping type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMappingMapping_outcome Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.mappingsMappingMapping_outcome"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTmappingsMappingMapping_outcome

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class mappingsMappingMapping_outcome

The mappingsMappingMapping_outcome type exposes the following members.

Constructors
 | Name | Description
Public method | mappingsMappingMapping_outcome | Initializes a new instance of the mappingsMappingMapping_outcome class
Top
Properties
 | Name | Description
Public property | outcome_id |
Public property | product_outcome_id |
Public property | product_outcome_name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMappingMapping_outcome Constructor

Initializes a new instance of the mappingsMappingMapping_outcome class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public mappingsMappingMapping_outcome()
See Also

Reference

mappingsMappingMapping_outcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMappingMapping_outcome Properties

The mappingsMappingMapping_outcome type exposes the following members.

Properties
 | Name | Description
Public property | outcome_id |
Public property | product_outcome_id |
Public property | product_outcome_name |
Top
See Also

Reference

mappingsMappingMapping_outcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMappingMapping_outcome.outcome_id Property

mappingsMappingMapping_outcomeoutcome_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.mappingsMappingMapping_outcome.outcome_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string outcome_id { get; set; }

Property Value

String
See Also

Reference

mappingsMappingMapping_outcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMappingMapping_outcome.product_outcome_id Property

mappingsMappingMapping_outcomeproduct_outcome_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.mappingsMappingMapping_outcome.product_outcome_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string product_outcome_id { get; set; }

Property Value

String
See Also

Reference

mappingsMappingMapping_outcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMappingMapping_outcome.product_outcome_name Property

mappingsMappingMapping_outcomeproduct_outcome_name Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.mappingsMappingMapping_outcome.product_outcome_name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string product_outcome_name { get; set; }

Property Value

String
See Also

Reference

mappingsMappingMapping_outcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


mappingsMappingMapping_outcome Methods

The mappingsMappingMapping_outcome type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

mappingsMappingMapping_outcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


market_descriptions Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.market_descriptions"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTmarket_descriptions

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class market_descriptions : RestMessage

The market_descriptions type exposes the following members.

Constructors
 | Name | Description
Public method | market_descriptions | Initializes a new instance of the market_descriptions class
Top
Properties
 | Name | Description
Public property | location |
Public property | market |
Public property | response_code |
Public property | response_codeSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


market_descriptions Constructor

Initializes a new instance of the market_descriptions class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public market_descriptions()
See Also

Reference

market_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


market_descriptions Properties

The market_descriptions type exposes the following members.

Properties
 | Name | Description
Public property | location |
Public property | market |
Public property | response_code |
Public property | response_codeSpecified |
Top
See Also

Reference

market_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


market_descriptions.location Property

market_descriptionslocation Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.market_descriptions.location"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string location { get; set; }

Property Value

String
See Also

Reference

market_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


market_descriptions.market Property

market_descriptionsmarket Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.market_descriptions.market"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_market[] market { get; set; }

Property Value

desc_market
See Also

Reference

market_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


market_descriptions.response_code Property

market_descriptionsresponse_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.market_descriptions.response_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public response_code response_code { get; set; }

Property Value

response_code
See Also

Reference

market_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


market_descriptions.response_codeSpecified Property

market_descriptionsresponse_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.market_descriptions.response_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool response_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

market_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


market_descriptions Methods

The market_descriptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

market_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


MarketType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.MarketType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTMarketType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class MarketType

The MarketType type exposes the following members.

Constructors
 | Name | Description
Public method | MarketType | Initializes a new instance of the MarketType class
Top
Properties
 | Name | Description
Public property | id |
Public property | outcome |
Public property | specifiers |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


MarketType Constructor

Initializes a new instance of the MarketType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public MarketType()
See Also

Reference

MarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


MarketType Properties

The MarketType type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | outcome |
Public property | specifiers |
Top
See Also

Reference

MarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


MarketType.id Property

MarketTypeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.MarketType.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int id { get; set; }

Property Value

Int32
See Also

Reference

MarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


MarketType.outcome Property

MarketTypeoutcome Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.MarketType.outcome"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public OutcomeType[] outcome { get; set; }

Property Value

OutcomeType
See Also

Reference

MarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


MarketType.specifiers Property

MarketTypespecifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.MarketType.specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string specifiers { get; set; }

Property Value

String
See Also

Reference

MarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


MarketType Methods

The MarketType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MarketType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


match_status_descriptions Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.match_status_descriptions"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTmatch_status_descriptions

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class match_status_descriptions

The match_status_descriptions type exposes the following members.

Constructors
 | Name | Description
Public method | match_status_descriptions | Initializes a new instance of the match_status_descriptions class
Top
Properties
 | Name | Description
Public property | location |
Public property | match_status |
Public property | response_code |
Public property | response_codeSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


match_status_descriptions Constructor

Initializes a new instance of the match_status_descriptions class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public match_status_descriptions()
See Also

Reference

match_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


match_status_descriptions Properties

The match_status_descriptions type exposes the following members.

Properties
 | Name | Description
Public property | location |
Public property | match_status |
Public property | response_code |
Public property | response_codeSpecified |
Top
See Also

Reference

match_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


match_status_descriptions.location Property

match_status_descriptionslocation Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.match_status_descriptions.location"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string location { get; set; }

Property Value

String
See Also

Reference

match_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


match_status_descriptions.match_status Property

match_status_descriptionsmatch_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.match_status_descriptions.match_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_match_status[] match_status { get; set; }

Property Value

desc_match_status
See Also

Reference

match_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


match_status_descriptions.response_code Property

match_status_descriptionsresponse_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.match_status_descriptions.response_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public response_code response_code { get; set; }

Property Value

response_code
See Also

Reference

match_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


match_status_descriptions.response_codeSpecified Property

match_status_descriptionsresponse_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.match_status_descriptions.response_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool response_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

match_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


match_status_descriptions Methods

The match_status_descriptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

match_status_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchPeriod Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.matchPeriod"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTmatchPeriod

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class matchPeriod

The matchPeriod type exposes the following members.

Constructors
 | Name | Description
Public method | matchPeriod | Initializes a new instance of the matchPeriod class
Top
Properties
 | Name | Description
Public property | name |
Public property | teams |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchPeriod Constructor

Initializes a new instance of the matchPeriod class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public matchPeriod()
See Also

Reference

matchPeriod Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchPeriod Properties

The matchPeriod type exposes the following members.

Properties
 | Name | Description
Public property | name |
Public property | teams |
Top
See Also

Reference

matchPeriod Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchPeriod.name Property

matchPeriodname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchPeriod.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

matchPeriod Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchPeriod.teams Property

matchPeriodteams Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchPeriod.teams"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public teamStatistics[] teams { get; set; }

Property Value

teamStatistics
See Also

Reference

matchPeriod Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchPeriod Methods

The matchPeriod type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

matchPeriod Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.matchRound"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTmatchRound

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class matchRound

The matchRound type exposes the following members.

Constructors
 | Name | Description
Public method | matchRound | Initializes a new instance of the matchRound class
Top
Properties
 | Name | Description
Public property | betradar_id |
Public property | betradar_idSpecified |
Public property | betradar_name |
Public property | cup_round_match_number |
Public property | cup_round_match_numberSpecified |
Public property | cup_round_matches |
Public property | cup_round_matchesSpecified |
Public property | group |
Public property | group_id |
Public property | group_long_name |
Public property | name |
Public property | number |
Public property | numberSpecified |
Public property | other_match_id |
Public property | phase |
Public property | type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound Constructor

Initializes a new instance of the matchRound class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public matchRound()
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound Properties

The matchRound type exposes the following members.

Properties
 | Name | Description
Public property | betradar_id |
Public property | betradar_idSpecified |
Public property | betradar_name |
Public property | cup_round_match_number |
Public property | cup_round_match_numberSpecified |
Public property | cup_round_matches |
Public property | cup_round_matchesSpecified |
Public property | group |
Public property | group_id |
Public property | group_long_name |
Public property | name |
Public property | number |
Public property | numberSpecified |
Public property | other_match_id |
Public property | phase |
Public property | type |
Top
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.betradar_id Property

matchRoundbetradar_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.betradar_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int betradar_id { get; set; }

Property Value

Int32
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.betradar_idSpecified Property

matchRoundbetradar_idSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.betradar_idSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool betradar_idSpecified { get; set; }

Property Value

Boolean
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.betradar_name Property

matchRoundbetradar_name Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.betradar_name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string betradar_name { get; set; }

Property Value

String
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.cup_round_match_number Property

matchRoundcup_round_match_number Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.cup_round_match_number"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int cup_round_match_number { get; set; }

Property Value

Int32
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.cup_round_match_numberSpecified Property

matchRoundcup_round_match_numberSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.cup_round_match_numberSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool cup_round_match_numberSpecified { get; set; }

Property Value

Boolean
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.cup_round_matches Property

matchRoundcup_round_matches Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.cup_round_matches"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int cup_round_matches { get; set; }

Property Value

Int32
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.cup_round_matchesSpecified Property

matchRoundcup_round_matchesSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.cup_round_matchesSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool cup_round_matchesSpecified { get; set; }

Property Value

Boolean
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.group Property

matchRoundgroup Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.group"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string group { get; set; }

Property Value

String
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.group_id Property

matchRoundgroup_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.group_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string group_id { get; set; }

Property Value

String
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.group_long_name Property

matchRoundgroup_long_name Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.group_long_name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string group_long_name { get; set; }

Property Value

String
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.name Property

matchRoundname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.number Property

matchRoundnumber Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.number"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int number { get; set; }

Property Value

Int32
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.numberSpecified Property

matchRoundnumberSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.numberSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool numberSpecified { get; set; }

Property Value

Boolean
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.other_match_id Property

matchRoundother_match_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.other_match_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string other_match_id { get; set; }

Property Value

String
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.phase Property

matchRoundphase Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.phase"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string phase { get; set; }

Property Value

String
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound.type Property

matchRoundtype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchRound.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchRound Methods

The matchRound type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

matchRound Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchStatistics Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.matchStatistics"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTmatchStatistics

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class matchStatistics

The matchStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | matchStatistics | Initializes a new instance of the matchStatistics class
Top
Properties
 | Name | Description
Public property | periods |
Public property | totals |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchStatistics Constructor

Initializes a new instance of the matchStatistics class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public matchStatistics()
See Also

Reference

matchStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchStatistics Properties

The matchStatistics type exposes the following members.

Properties
 | Name | Description
Public property | periods |
Public property | totals |
Top
See Also

Reference

matchStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchStatistics.periods Property

matchStatisticsperiods Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchStatistics.periods"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public matchPeriod[] periods { get; set; }

Property Value

matchPeriod
See Also

Reference

matchStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchStatistics.totals Property

matchStatisticstotals Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchStatistics.totals"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public teamStatistics[][] totals { get; set; }

Property Value

teamStatistics
See Also

Reference

matchStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchStatistics Methods

The matchStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

matchStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchSummaryEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.matchSummaryEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTmatchSummaryEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class matchSummaryEndpoint : RestMessage

The matchSummaryEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | matchSummaryEndpoint | Initializes a new instance of the matchSummaryEndpoint class
Top
Properties
 | Name | Description
Public property | coverage_info |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_event |
Public property | sport_event_conditions |
Public property | sport_event_status |
Public property | statistics |
Public property | venue |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchSummaryEndpoint Constructor

Initializes a new instance of the matchSummaryEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public matchSummaryEndpoint()
See Also

Reference

matchSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchSummaryEndpoint Properties

The matchSummaryEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | coverage_info |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_event |
Public property | sport_event_conditions |
Public property | sport_event_status |
Public property | statistics |
Public property | venue |
Top
See Also

Reference

matchSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchSummaryEndpoint.coverage_info Property

matchSummaryEndpointcoverage_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchSummaryEndpoint.coverage_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public coverageInfo coverage_info { get; set; }

Property Value

coverageInfo
See Also

Reference

matchSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchSummaryEndpoint.generated_at Property

matchSummaryEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchSummaryEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

matchSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchSummaryEndpoint.generated_atSpecified Property

matchSummaryEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchSummaryEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

matchSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchSummaryEndpoint.sport_event Property

matchSummaryEndpointsport_event Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchSummaryEndpoint.sport_event"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEvent sport_event { get; set; }

Property Value

sportEvent
See Also

Reference

matchSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchSummaryEndpoint.sport_event_conditions Property

matchSummaryEndpointsport_event_conditions Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchSummaryEndpoint.sport_event_conditions"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEventConditions sport_event_conditions { get; set; }

Property Value

sportEventConditions
See Also

Reference

matchSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchSummaryEndpoint.sport_event_status Property

matchSummaryEndpointsport_event_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchSummaryEndpoint.sport_event_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public restSportEventStatus sport_event_status { get; set; }

Property Value

restSportEventStatus
See Also

Reference

matchSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchSummaryEndpoint.statistics Property

matchSummaryEndpointstatistics Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchSummaryEndpoint.statistics"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public matchStatistics statistics { get; set; }

Property Value

matchStatistics
See Also

Reference

matchSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchSummaryEndpoint.venue Property

matchSummaryEndpointvenue Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchSummaryEndpoint.venue"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public venue venue { get; set; }

Property Value

venue
See Also

Reference

matchSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchSummaryEndpoint Methods

The matchSummaryEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

matchSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchTimelineEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.matchTimelineEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTmatchTimelineEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class matchTimelineEndpoint : RestMessage

The matchTimelineEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | matchTimelineEndpoint | Initializes a new instance of the matchTimelineEndpoint class
Top
Properties
 | Name | Description
Public property | coverage_info |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_event |
Public property | sport_event_conditions |
Public property | sport_event_status |
Public property | timeline |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchTimelineEndpoint Constructor

Initializes a new instance of the matchTimelineEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public matchTimelineEndpoint()
See Also

Reference

matchTimelineEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchTimelineEndpoint Properties

The matchTimelineEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | coverage_info |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_event |
Public property | sport_event_conditions |
Public property | sport_event_status |
Public property | timeline |
Top
See Also

Reference

matchTimelineEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchTimelineEndpoint.coverage_info Property

matchTimelineEndpointcoverage_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchTimelineEndpoint.coverage_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public coverageInfo coverage_info { get; set; }

Property Value

coverageInfo
See Also

Reference

matchTimelineEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchTimelineEndpoint.generated_at Property

matchTimelineEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchTimelineEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

matchTimelineEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchTimelineEndpoint.generated_atSpecified Property

matchTimelineEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchTimelineEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

matchTimelineEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchTimelineEndpoint.sport_event Property

matchTimelineEndpointsport_event Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchTimelineEndpoint.sport_event"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEvent sport_event { get; set; }

Property Value

sportEvent
See Also

Reference

matchTimelineEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchTimelineEndpoint.sport_event_conditions Property

matchTimelineEndpointsport_event_conditions Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchTimelineEndpoint.sport_event_conditions"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEventConditions sport_event_conditions { get; set; }

Property Value

sportEventConditions
See Also

Reference

matchTimelineEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchTimelineEndpoint.sport_event_status Property

matchTimelineEndpointsport_event_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchTimelineEndpoint.sport_event_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public restSportEventStatus sport_event_status { get; set; }

Property Value

restSportEventStatus
See Also

Reference

matchTimelineEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchTimelineEndpoint.timeline Property

matchTimelineEndpointtimeline Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.matchTimelineEndpoint.timeline"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public basicEvent[] timeline { get; set; }

Property Value

basicEvent
See Also

Reference

matchTimelineEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


matchTimelineEndpoint Methods

The matchTimelineEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

matchTimelineEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


outcome_reasons_descriptions Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.outcome_reasons_descriptions"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESToutcome_reasons_descriptions

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class outcome_reasons_descriptions

The outcome_reasons_descriptions type exposes the following members.

Constructors
 | Name | Description
Public method | outcome_reasons_descriptions | Initializes a new instance of the outcome_reasons_descriptions class
Top
Properties
 | Name | Description
Public property | location |
Public property | outcome_reason |
Public property | response_code |
Public property | response_codeSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


outcome_reasons_descriptions Constructor

Initializes a new instance of the outcome_reasons_descriptions class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public outcome_reasons_descriptions()
See Also

Reference

outcome_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


outcome_reasons_descriptions Properties

The outcome_reasons_descriptions type exposes the following members.

Properties
 | Name | Description
Public property | location |
Public property | outcome_reason |
Public property | response_code |
Public property | response_codeSpecified |
Top
See Also

Reference

outcome_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


outcome_reasons_descriptions.location Property

outcome_reasons_descriptionslocation Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.outcome_reasons_descriptions.location"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string location { get; set; }

Property Value

String
See Also

Reference

outcome_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


outcome_reasons_descriptions.outcome_reason Property

outcome_reasons_descriptionsoutcome_reason Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.outcome_reasons_descriptions.outcome_reason"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_outcome_reason[] outcome_reason { get; set; }

Property Value

desc_outcome_reason
See Also

Reference

outcome_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


outcome_reasons_descriptions.response_code Property

outcome_reasons_descriptionsresponse_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.outcome_reasons_descriptions.response_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public response_code response_code { get; set; }

Property Value

response_code
See Also

Reference

outcome_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


outcome_reasons_descriptions.response_codeSpecified Property

outcome_reasons_descriptionsresponse_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.outcome_reasons_descriptions.response_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool response_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

outcome_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


outcome_reasons_descriptions Methods

The outcome_reasons_descriptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

outcome_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


OutcomeType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.OutcomeType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTOutcomeType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class OutcomeType

The OutcomeType type exposes the following members.

Constructors
 | Name | Description
Public method | OutcomeType | Initializes a new instance of the OutcomeType class
Top
Properties
 | Name | Description
Public property | id |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


OutcomeType Constructor

Initializes a new instance of the OutcomeType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public OutcomeType()
See Also

Reference

OutcomeType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


OutcomeType Properties

The OutcomeType type exposes the following members.

Properties
 | Name | Description
Public property | id |
Top
See Also

Reference

OutcomeType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


OutcomeType.id Property

OutcomeTypeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.OutcomeType.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

OutcomeType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


OutcomeType Methods

The OutcomeType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OutcomeType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.parentStage"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTparentStage

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class parentStage

The parentStage type exposes the following members.

Constructors
 | Name | Description
Public method | parentStage | Initializes a new instance of the parentStage class
Top
Properties
 | Name | Description
Public property | id |
Public property | name |
Public property | replaced_by |
Public property | scheduled |
Public property | scheduled_end |
Public property | scheduled_endSpecified |
Public property | scheduledSpecified |
Public property | stage_type |
Public property | start_time_tbd |
Public property | start_time_tbdSpecified |
Public property | type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage Constructor

Initializes a new instance of the parentStage class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public parentStage()
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage Properties

The parentStage type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | name |
Public property | replaced_by |
Public property | scheduled |
Public property | scheduled_end |
Public property | scheduled_endSpecified |
Public property | scheduledSpecified |
Public property | stage_type |
Public property | start_time_tbd |
Public property | start_time_tbdSpecified |
Public property | type |
Top
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage.id Property

parentStageid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.parentStage.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage.name Property

parentStagename Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.parentStage.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage.replaced_by Property

parentStagereplaced_by Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.parentStage.replaced_by"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string replaced_by { get; set; }

Property Value

String
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage.scheduled Property

parentStagescheduled Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.parentStage.scheduled"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime scheduled { get; set; }

Property Value

DateTime
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage.scheduled_end Property

parentStagescheduled_end Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.parentStage.scheduled_end"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime scheduled_end { get; set; }

Property Value

DateTime
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage.scheduled_endSpecified Property

parentStagescheduled_endSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.parentStage.scheduled_endSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool scheduled_endSpecified { get; set; }

Property Value

Boolean
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage.scheduledSpecified Property

parentStagescheduledSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.parentStage.scheduledSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool scheduledSpecified { get; set; }

Property Value

Boolean
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage.stage_type Property

parentStagestage_type Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.parentStage.stage_type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string stage_type { get; set; }

Property Value

String
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage.start_time_tbd Property

parentStagestart_time_tbd Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.parentStage.start_time_tbd"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_time_tbd { get; set; }

Property Value

Boolean
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage.start_time_tbdSpecified Property

parentStagestart_time_tbdSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.parentStage.start_time_tbdSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_time_tbdSpecified { get; set; }

Property Value

Boolean
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage.type Property

parentStagetype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.parentStage.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


parentStage Methods

The parentStage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

parentStage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScore Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.periodScore"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTperiodScoreBase
Sportradar.OddsFeed.SDK.Messages.RESTperiodScore

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class periodScore : periodScoreBase

The periodScore type exposes the following members.

Constructors
 | Name | Description
Public method | periodScore | Initializes a new instance of the periodScore class
Top
Properties
 | Name | Description
Public property | away_score |
Public property | home_score |
Public property | match_status_code |
Public property | number | (Inherited from periodScoreBase)
Public property | numberSpecified | (Inherited from periodScoreBase)
Public property | type | (Inherited from periodScoreBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScore Constructor

Initializes a new instance of the periodScore class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public periodScore()
See Also

Reference

periodScore Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScore Properties

The periodScore type exposes the following members.

Properties
 | Name | Description
Public property | away_score |
Public property | home_score |
Public property | match_status_code |
Public property | number | (Inherited from periodScoreBase)
Public property | numberSpecified | (Inherited from periodScoreBase)
Public property | type | (Inherited from periodScoreBase)
Top
See Also

Reference

periodScore Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScore.away_score Property

periodScoreaway_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodScore.away_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string away_score { get; set; }

Property Value

String
See Also

Reference

periodScore Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScore.home_score Property

periodScorehome_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodScore.home_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string home_score { get; set; }

Property Value

String
See Also

Reference

periodScore Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScore.match_status_code Property

periodScorematch_status_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodScore.match_status_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int match_status_code { get; set; }

Property Value

Int32
See Also

Reference

periodScore Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScore Methods

The periodScore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

periodScore Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScoreBase Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.periodScoreBase"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTperiodScoreBase
Sportradar.OddsFeed.SDK.Messages.RESTperiodScore

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class periodScoreBase

The periodScoreBase type exposes the following members.

Constructors
 | Name | Description
Public method | periodScoreBase | Initializes a new instance of the periodScoreBase class
Top
Properties
 | Name | Description
Public property | number |
Public property | numberSpecified |
Public property | type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScoreBase Constructor

Initializes a new instance of the periodScoreBase class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public periodScoreBase()
See Also

Reference

periodScoreBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScoreBase Properties

The periodScoreBase type exposes the following members.

Properties
 | Name | Description
Public property | number |
Public property | numberSpecified |
Public property | type |
Top
See Also

Reference

periodScoreBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScoreBase.number Property

periodScoreBasenumber Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodScoreBase.number"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int number { get; set; }

Property Value

Int32
See Also

Reference

periodScoreBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScoreBase.numberSpecified Property

periodScoreBasenumberSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodScoreBase.numberSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool numberSpecified { get; set; }

Property Value

Boolean
See Also

Reference

periodScoreBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScoreBase.type Property

periodScoreBasetype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodScoreBase.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

periodScoreBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodScoreBase Methods

The periodScoreBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

periodScoreBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatus Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.periodStatus"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTperiodStatus

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class periodStatus

The periodStatus type exposes the following members.

Constructors
 | Name | Description
Public method | periodStatus | Initializes a new instance of the periodStatus class
Top
Properties
 | Name | Description
Public property | competitor |
Public property | number |
Public property | numberSpecified |
Public property | status |
Public property | type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatus Constructor

Initializes a new instance of the periodStatus class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public periodStatus()
See Also

Reference

periodStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatus Properties

The periodStatus type exposes the following members.

Properties
 | Name | Description
Public property | competitor |
Public property | number |
Public property | numberSpecified |
Public property | status |
Public property | type |
Top
See Also

Reference

periodStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatus.competitor Property

periodStatuscompetitor Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodStatus.competitor"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public periodStatusCompetitor[] competitor { get; set; }

Property Value

periodStatusCompetitor
See Also

Reference

periodStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatus.number Property

periodStatusnumber Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodStatus.number"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int number { get; set; }

Property Value

Int32
See Also

Reference

periodStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatus.numberSpecified Property

periodStatusnumberSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodStatus.numberSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool numberSpecified { get; set; }

Property Value

Boolean
See Also

Reference

periodStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatus.status Property

periodStatusstatus Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodStatus.status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string status { get; set; }

Property Value

String
See Also

Reference

periodStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatus.type Property

periodStatustype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodStatus.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

periodStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatus Methods

The periodStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

periodStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitor Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.periodStatusCompetitor"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTperiodStatusCompetitor

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class periodStatusCompetitor

The periodStatusCompetitor type exposes the following members.

Constructors
 | Name | Description
Public method | periodStatusCompetitor | Initializes a new instance of the periodStatusCompetitor class
Top
Properties
 | Name | Description
Public property | id |
Public property | result |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitor Constructor

Initializes a new instance of the periodStatusCompetitor class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public periodStatusCompetitor()
See Also

Reference

periodStatusCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitor Properties

The periodStatusCompetitor type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | result |
Top
See Also

Reference

periodStatusCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitor.id Property

periodStatusCompetitorid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodStatusCompetitor.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

periodStatusCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitor.result Property

periodStatusCompetitorresult Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodStatusCompetitor.result"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public periodStatusCompetitorResult[] result { get; set; }

Property Value

periodStatusCompetitorResult
See Also

Reference

periodStatusCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitor Methods

The periodStatusCompetitor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

periodStatusCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitorResult Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.periodStatusCompetitorResult"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTperiodStatusCompetitorResult

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class periodStatusCompetitorResult

The periodStatusCompetitorResult type exposes the following members.

Constructors
 | Name | Description
Public method | periodStatusCompetitorResult | Initializes a new instance of the periodStatusCompetitorResult class
Top
Properties
 | Name | Description
Public property | specifiers |
Public property | type |
Public property | value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitorResult Constructor

Initializes a new instance of the periodStatusCompetitorResult class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public periodStatusCompetitorResult()
See Also

Reference

periodStatusCompetitorResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitorResult Properties

The periodStatusCompetitorResult type exposes the following members.

Properties
 | Name | Description
Public property | specifiers |
Public property | type |
Public property | value |
Top
See Also

Reference

periodStatusCompetitorResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitorResult.specifiers Property

periodStatusCompetitorResultspecifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodStatusCompetitorResult.specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string specifiers { get; set; }

Property Value

String
See Also

Reference

periodStatusCompetitorResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitorResult.type Property

periodStatusCompetitorResulttype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodStatusCompetitorResult.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

periodStatusCompetitorResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitorResult.value Property

periodStatusCompetitorResultvalue Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.periodStatusCompetitorResult.value"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string value { get; set; }

Property Value

String
See Also

Reference

periodStatusCompetitorResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


periodStatusCompetitorResult Methods

The periodStatusCompetitorResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

periodStatusCompetitorResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


pitcher Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.pitcher"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTpitcher

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class pitcher

The pitcher type exposes the following members.

Constructors
 | Name | Description
Public method | pitcher | Initializes a new instance of the pitcher class
Top
Properties
 | Name | Description
Public property | changed_at |
Public property | changed_atSpecified |
Public property | competitor |
Public property | hand |
Public property | id |
Public property | name |
Public property | short_name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


pitcher Constructor

Initializes a new instance of the pitcher class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public pitcher()
See Also

Reference

pitcher Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


pitcher Properties

The pitcher type exposes the following members.

Properties
 | Name | Description
Public property | changed_at |
Public property | changed_atSpecified |
Public property | competitor |
Public property | hand |
Public property | id |
Public property | name |
Public property | short_name |
Top
See Also

Reference

pitcher Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


pitcher.changed_at Property

pitcherchanged_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.pitcher.changed_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime changed_at { get; set; }

Property Value

DateTime
See Also

Reference

pitcher Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


pitcher.changed_atSpecified Property

pitcherchanged_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.pitcher.changed_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool changed_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

pitcher Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


pitcher.competitor Property

pitchercompetitor Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.pitcher.competitor"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string competitor { get; set; }

Property Value

String
See Also

Reference

pitcher Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


pitcher.hand Property

pitcherhand Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.pitcher.hand"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string hand { get; set; }

Property Value

String
See Also

Reference

pitcher Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


pitcher.id Property

pitcherid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.pitcher.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

pitcher Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


pitcher.name Property

pitchername Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.pitcher.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

pitcher Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


pitcher.short_name Property

pitchershort_name Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.pitcher.short_name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string short_name { get; set; }

Property Value

String
See Also

Reference

pitcher Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


pitcher Methods

The pitcher type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

pitcher Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


player Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.player"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTplayer
Sportradar.OddsFeed.SDK.Messages.RESTplayerExtended
Sportradar.OddsFeed.SDK.Messages.RESTplayerLineup
Sportradar.OddsFeed.SDK.Messages.RESTplayerSubstitute

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class player

The player type exposes the following members.

Constructors
 | Name | Description
Public method | player | Initializes a new instance of the player class
Top
Properties
 | Name | Description
Public property | id |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


player Constructor

Initializes a new instance of the player class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public player()
See Also

Reference

player Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


player Properties

The player type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | name |
Top
See Also

Reference

player Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


player.id Property

playerid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.player.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

player Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


player.name Property

playername Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.player.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

player Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


player Methods

The player type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

player Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerCompetitor Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.playerCompetitor"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTplayerCompetitor

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class playerCompetitor

The playerCompetitor type exposes the following members.

Constructors
 | Name | Description
Public method | playerCompetitor | Initializes a new instance of the playerCompetitor class
Top
Properties
 | Name | Description
Public property | abbreviation |
Public property | id |
Public property | name |
Public property | nationality |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerCompetitor Constructor

Initializes a new instance of the playerCompetitor class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public playerCompetitor()
See Also

Reference

playerCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerCompetitor Properties

The playerCompetitor type exposes the following members.

Properties
 | Name | Description
Public property | abbreviation |
Public property | id |
Public property | name |
Public property | nationality |
Top
See Also

Reference

playerCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerCompetitor.abbreviation Property

playerCompetitorabbreviation Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerCompetitor.abbreviation"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string abbreviation { get; set; }

Property Value

String
See Also

Reference

playerCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerCompetitor.id Property

playerCompetitorid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerCompetitor.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

playerCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerCompetitor.name Property

playerCompetitorname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerCompetitor.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

playerCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerCompetitor.nationality Property

playerCompetitornationality Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerCompetitor.nationality"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string nationality { get; set; }

Property Value

String
See Also

Reference

playerCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerCompetitor Methods

The playerCompetitor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

playerCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTplayer
Sportradar.OddsFeed.SDK.Messages.RESTplayerExtended

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class playerExtended : player

The playerExtended type exposes the following members.

Constructors
 | Name | Description
Public method | playerExtended | Initializes a new instance of the playerExtended class
Top
Properties
 | Name | Description
Public property | country_code |
Public property | date_of_birth |
Public property | full_name |
Public property | gender |
Public property | height |
Public property | heightSpecified |
Public property | id | (Inherited from player)
Public property | jersey_number |
Public property | jersey_numberSpecified |
Public property | name | (Inherited from player)
Public property | nationality |
Public property | nickname |
Public property | type |
Public property | weight |
Public property | weightSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended Constructor

Initializes a new instance of the playerExtended class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public playerExtended()
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended Properties

The playerExtended type exposes the following members.

Properties
 | Name | Description
Public property | country_code |
Public property | date_of_birth |
Public property | full_name |
Public property | gender |
Public property | height |
Public property | heightSpecified |
Public property | id | (Inherited from player)
Public property | jersey_number |
Public property | jersey_numberSpecified |
Public property | name | (Inherited from player)
Public property | nationality |
Public property | nickname |
Public property | type |
Public property | weight |
Public property | weightSpecified |
Top
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.country_code Property

playerExtendedcountry_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.country_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string country_code { get; set; }

Property Value

String
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.date_of_birth Property

playerExtendeddate_of_birth Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.date_of_birth"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string date_of_birth { get; set; }

Property Value

String
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.full_name Property

playerExtendedfull_name Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.full_name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string full_name { get; set; }

Property Value

String
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.gender Property

playerExtendedgender Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.gender"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string gender { get; set; }

Property Value

String
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.height Property

playerExtendedheight Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.height"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int height { get; set; }

Property Value

Int32
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.heightSpecified Property

playerExtendedheightSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.heightSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool heightSpecified { get; set; }

Property Value

Boolean
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.jersey_number Property

playerExtendedjersey_number Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.jersey_number"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int jersey_number { get; set; }

Property Value

Int32
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.jersey_numberSpecified Property

playerExtendedjersey_numberSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.jersey_numberSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool jersey_numberSpecified { get; set; }

Property Value

Boolean
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.nationality Property

playerExtendednationality Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.nationality"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string nationality { get; set; }

Property Value

String
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.nickname Property

playerExtendednickname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.nickname"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string nickname { get; set; }

Property Value

String
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.type Property

playerExtendedtype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.weight Property

playerExtendedweight Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.weight"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int weight { get; set; }

Property Value

Int32
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended.weightSpecified Property

playerExtendedweightSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerExtended.weightSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool weightSpecified { get; set; }

Property Value

Boolean
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerExtended Methods

The playerExtended type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

playerExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerLineup Class

Note: This API is now obsolete.

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.playerLineup"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTplayer
Sportradar.OddsFeed.SDK.Messages.RESTplayerLineup

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
[ObsoleteAttribute("Not used")]
public class playerLineup : player

The playerLineup type exposes the following members.

Constructors
 | Name | Description
Public method | playerLineup | Initializes a new instance of the playerLineup class
Top
Properties
 | Name | Description
Public property | id | (Inherited from player)
Public property | jersey_number |
Public property | jersey_numberSpecified |
Public property | name | (Inherited from player)
Public property | position |
Public property | type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerLineup Constructor

Initializes a new instance of the playerLineup class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public playerLineup()
See Also

Reference

playerLineup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerLineup Properties

The playerLineup type exposes the following members.

Properties
 | Name | Description
Public property | id | (Inherited from player)
Public property | jersey_number |
Public property | jersey_numberSpecified |
Public property | name | (Inherited from player)
Public property | position |
Public property | type |
Top
See Also

Reference

playerLineup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerLineup.jersey_number Property

playerLineupjersey_number Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerLineup.jersey_number"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int jersey_number { get; set; }

Property Value

Int32
See Also

Reference

playerLineup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerLineup.jersey_numberSpecified Property

playerLineupjersey_numberSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerLineup.jersey_numberSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool jersey_numberSpecified { get; set; }

Property Value

Boolean
See Also

Reference

playerLineup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerLineup.position Property

playerLineupposition Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerLineup.position"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string position { get; set; }

Property Value

String
See Also

Reference

playerLineup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerLineup.type Property

playerLineuptype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerLineup.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

playerLineup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerLineup Methods

The playerLineup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

playerLineup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerProfileEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.playerProfileEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTplayerProfileEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class playerProfileEndpoint : RestMessage

The playerProfileEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | playerProfileEndpoint | Initializes a new instance of the playerProfileEndpoint class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | player |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerProfileEndpoint Constructor

Initializes a new instance of the playerProfileEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public playerProfileEndpoint()
See Also

Reference

playerProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerProfileEndpoint Properties

The playerProfileEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | player |
Top
See Also

Reference

playerProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerProfileEndpoint.generated_at Property

playerProfileEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerProfileEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

playerProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerProfileEndpoint.generated_atSpecified Property

playerProfileEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerProfileEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

playerProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerProfileEndpoint.player Property

playerProfileEndpointplayer Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerProfileEndpoint.player"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public playerExtended player { get; set; }

Property Value

playerExtended
See Also

Reference

playerProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerProfileEndpoint Methods

The playerProfileEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

playerProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerSubstitute Class

Note: This API is now obsolete.

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.playerSubstitute"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTplayer
Sportradar.OddsFeed.SDK.Messages.RESTplayerSubstitute

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
[ObsoleteAttribute("Not used")]
public class playerSubstitute : player

The playerSubstitute type exposes the following members.

Constructors
 | Name | Description
Public method | playerSubstitute | Initializes a new instance of the playerSubstitute class
Top
Properties
 | Name | Description
Public property | id | (Inherited from player)
Public property | jersey_number |
Public property | jersey_numberSpecified |
Public property | name | (Inherited from player)
Public property | type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerSubstitute Constructor

Initializes a new instance of the playerSubstitute class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public playerSubstitute()
See Also

Reference

playerSubstitute Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerSubstitute Properties

The playerSubstitute type exposes the following members.

Properties
 | Name | Description
Public property | id | (Inherited from player)
Public property | jersey_number |
Public property | jersey_numberSpecified |
Public property | name | (Inherited from player)
Public property | type |
Top
See Also

Reference

playerSubstitute Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerSubstitute.jersey_number Property

playerSubstitutejersey_number Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerSubstitute.jersey_number"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int jersey_number { get; set; }

Property Value

Int32
See Also

Reference

playerSubstitute Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerSubstitute.jersey_numberSpecified Property

playerSubstitutejersey_numberSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerSubstitute.jersey_numberSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool jersey_numberSpecified { get; set; }

Property Value

Boolean
See Also

Reference

playerSubstitute Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerSubstitute.type Property

playerSubstitutetype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.playerSubstitute.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

playerSubstitute Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


playerSubstitute Methods

The playerSubstitute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

playerSubstitute Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producer Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.producer"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTproducer

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class producer

The producer type exposes the following members.

Constructors
 | Name | Description
Public method | producer | Initializes a new instance of the producer class
Top
Properties
 | Name | Description
Public property | active |
Public property | api_url |
Public property | description |
Public property | id |
Public property | name |
Public property | scope |
Public property | stateful_recovery_window_in_minutes |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


producer Constructor

Initializes a new instance of the producer class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public producer()
See Also

Reference

producer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producer Properties

The producer type exposes the following members.

Properties
 | Name | Description
Public property | active |
Public property | api_url |
Public property | description |
Public property | id |
Public property | name |
Public property | scope |
Public property | stateful_recovery_window_in_minutes |
Top
See Also

Reference

producer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producer.active Property

produceractive Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.producer.active"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool active { get; set; }

Property Value

Boolean
See Also

Reference

producer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producer.api_url Property

producerapi_url Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.producer.api_url"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string api_url { get; set; }

Property Value

String
See Also

Reference

producer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producer.description Property

producerdescription Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.producer.description"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string description { get; set; }

Property Value

String
See Also

Reference

producer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producer.id Property

producerid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.producer.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public long id { get; set; }

Property Value

Int64
See Also

Reference

producer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producer.name Property

producername Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.producer.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

producer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producer.scope Property

producerscope Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.producer.scope"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string scope { get; set; }

Property Value

String
See Also

Reference

producer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producer.stateful_recovery_window_in_minutes Property

producerstateful_recovery_window_in_minutes Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.producer.stateful_recovery_window_in_minutes"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int stateful_recovery_window_in_minutes { get; set; }

Property Value

Int32
See Also

Reference

producer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producer Methods

The producer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

producer Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producers Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.producers"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTproducers

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class producers : RestMessage

The producers type exposes the following members.

Constructors
 | Name | Description
Public method | producers | Initializes a new instance of the producers class
Top
Properties
 | Name | Description
Public property | location |
Public property | producer |
Public property | response_code |
Public property | response_codeSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


producers Constructor

Initializes a new instance of the producers class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public producers()
See Also

Reference

producers Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producers Properties

The producers type exposes the following members.

Properties
 | Name | Description
Public property | location |
Public property | producer |
Public property | response_code |
Public property | response_codeSpecified |
Top
See Also

Reference

producers Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producers.location Property

producerslocation Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.producers.location"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string location { get; set; }

Property Value

String
See Also

Reference

producers Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producers.producer Property

producersproducer Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.producers.producer"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public producer[] producer { get; set; }

Property Value

producer
See Also

Reference

producers Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producers.response_code Property

producersresponse_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.producers.response_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public response_code response_code { get; set; }

Property Value

response_code
See Also

Reference

producers Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producers.response_codeSpecified Property

producersresponse_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.producers.response_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool response_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

producers Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


producers Methods

The producers type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

producers Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfo Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.productInfo"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTproductInfo

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class productInfo

The productInfo type exposes the following members.

Constructors
 | Name | Description
Public method | productInfo | Initializes a new instance of the productInfo class
Top
Properties
 | Name | Description
Public property | is_auto_traded |
Public property | is_in_hosted_statistics |
Public property | is_in_live_center_soccer |
Public property | is_in_live_match_tracker |
Public property | is_in_live_score |
Public property | links |
Public property | streaming |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfo Constructor

Initializes a new instance of the productInfo class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public productInfo()
See Also

Reference

productInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfo Properties

The productInfo type exposes the following members.

Properties
 | Name | Description
Public property | is_auto_traded |
Public property | is_in_hosted_statistics |
Public property | is_in_live_center_soccer |
Public property | is_in_live_match_tracker |
Public property | is_in_live_score |
Public property | links |
Public property | streaming |
Top
See Also

Reference

productInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfo.is_auto_traded Property

productInfois_auto_traded Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.productInfo.is_auto_traded"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public productInfoItem is_auto_traded { get; set; }

Property Value

productInfoItem
See Also

Reference

productInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfo.is_in_hosted_statistics Property

productInfois_in_hosted_statistics Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.productInfo.is_in_hosted_statistics"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public productInfoItem is_in_hosted_statistics { get; set; }

Property Value

productInfoItem
See Also

Reference

productInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfo.is_in_live_center_soccer Property

productInfois_in_live_center_soccer Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.productInfo.is_in_live_center_soccer"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public productInfoItem is_in_live_center_soccer { get; set; }

Property Value

productInfoItem
See Also

Reference

productInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfo.is_in_live_match_tracker Property

productInfois_in_live_match_tracker Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.productInfo.is_in_live_match_tracker"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public productInfoItem is_in_live_match_tracker { get; set; }

Property Value

productInfoItem
See Also

Reference

productInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfo.is_in_live_score Property

productInfois_in_live_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.productInfo.is_in_live_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public productInfoItem is_in_live_score { get; set; }

Property Value

productInfoItem
See Also

Reference

productInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfo.links Property

productInfolinks Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.productInfo.links"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public productInfoLink[] links { get; set; }

Property Value

productInfoLink
See Also

Reference

productInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfo.streaming Property

productInfostreaming Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.productInfo.streaming"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public streamingChannel[] streaming { get; set; }

Property Value

streamingChannel
See Also

Reference

productInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfo Methods

The productInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

productInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfoItem Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.productInfoItem"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTproductInfoItem

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class productInfoItem

The productInfoItem type exposes the following members.

Constructors
 | Name | Description
Public method | productInfoItem | Initializes a new instance of the productInfoItem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfoItem Constructor

Initializes a new instance of the productInfoItem class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public productInfoItem()
See Also

Reference

productInfoItem Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfoItem Methods

The productInfoItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

productInfoItem Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfoLink Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.productInfoLink"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTproductInfoLink

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class productInfoLink

The productInfoLink type exposes the following members.

Constructors
 | Name | Description
Public method | productInfoLink | Initializes a new instance of the productInfoLink class
Top
Properties
 | Name | Description
Public property | name |
Public property | ref |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfoLink Constructor

Initializes a new instance of the productInfoLink class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public productInfoLink()
See Also

Reference

productInfoLink Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfoLink Properties

The productInfoLink type exposes the following members.

Properties
 | Name | Description
Public property | name |
Public property | ref |
Top
See Also

Reference

productInfoLink Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfoLink.name Property

productInfoLinkname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.productInfoLink.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

productInfoLink Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfoLink.ref Property

productInfoLinkref Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.productInfoLink.ref"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string ref { get; set; }

Property Value

String
See Also

Reference

productInfoLink Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


productInfoLink Methods

The productInfoLink type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

productInfoLink Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriver Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.raceDriver"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTteam
Sportradar.OddsFeed.SDK.Messages.RESTraceDriver

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class raceDriver : team

The raceDriver type exposes the following members.

Constructors
 | Name | Description
Public method | raceDriver | Initializes a new instance of the raceDriver class
Top
Properties
 | Name | Description
Public property | abbreviation | (Inherited from team)
Public property | age_group | (Inherited from team)
Public property | country | (Inherited from team)
Public property | country_code | (Inherited from team)
Public property | date_of_birth |
Public property | division | (Inherited from team)
Public property | division_name | (Inherited from team)
Public property | divisionSpecified | (Inherited from team)
Public property | gender | (Inherited from team)
Public property | id | (Inherited from team)
Public property | name | (Inherited from team)
Public property | nationality |
Public property | players | (Inherited from team)
Public property | reference_ids | (Inherited from team)
Public property | short_name | (Inherited from team)
Public property | state | (Inherited from team)
Public property | virtual | (Inherited from team)
Public property | virtualSpecified | (Inherited from team)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriver Constructor

Initializes a new instance of the raceDriver class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public raceDriver()
See Also

Reference

raceDriver Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriver Properties

The raceDriver type exposes the following members.

Properties
 | Name | Description
Public property | abbreviation | (Inherited from team)
Public property | age_group | (Inherited from team)
Public property | country | (Inherited from team)
Public property | country_code | (Inherited from team)
Public property | date_of_birth |
Public property | division | (Inherited from team)
Public property | division_name | (Inherited from team)
Public property | divisionSpecified | (Inherited from team)
Public property | gender | (Inherited from team)
Public property | id | (Inherited from team)
Public property | name | (Inherited from team)
Public property | nationality |
Public property | players | (Inherited from team)
Public property | reference_ids | (Inherited from team)
Public property | short_name | (Inherited from team)
Public property | state | (Inherited from team)
Public property | virtual | (Inherited from team)
Public property | virtualSpecified | (Inherited from team)
Top
See Also

Reference

raceDriver Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriver.date_of_birth Property

raceDriverdate_of_birth Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.raceDriver.date_of_birth"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string date_of_birth { get; set; }

Property Value

String
See Also

Reference

raceDriver Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriver.nationality Property

raceDrivernationality Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.raceDriver.nationality"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string nationality { get; set; }

Property Value

String
See Also

Reference

raceDriver Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriver Methods

The raceDriver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

raceDriver Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriverProfile Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.raceDriverProfile"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTraceDriverProfile

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class raceDriverProfile

The raceDriverProfile type exposes the following members.

Constructors
 | Name | Description
Public method | raceDriverProfile | Initializes a new instance of the raceDriverProfile class
Top
Properties
 | Name | Description
Public property | car |
Public property | race_driver |
Public property | race_team |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriverProfile Constructor

Initializes a new instance of the raceDriverProfile class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public raceDriverProfile()
See Also

Reference

raceDriverProfile Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriverProfile Properties

The raceDriverProfile type exposes the following members.

Properties
 | Name | Description
Public property | car |
Public property | race_driver |
Public property | race_team |
Top
See Also

Reference

raceDriverProfile Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriverProfile.car Property

raceDriverProfilecar Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.raceDriverProfile.car"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public car car { get; set; }

Property Value

car
See Also

Reference

raceDriverProfile Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriverProfile.race_driver Property

raceDriverProfilerace_driver Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.raceDriverProfile.race_driver"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public raceDriver race_driver { get; set; }

Property Value

raceDriver
See Also

Reference

raceDriverProfile Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriverProfile.race_team Property

raceDriverProfilerace_team Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.raceDriverProfile.race_team"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public raceTeam race_team { get; set; }

Property Value

raceTeam
See Also

Reference

raceDriverProfile Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceDriverProfile Methods

The raceDriverProfile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

raceDriverProfile Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceScheduleEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.raceScheduleEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTraceScheduleEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class raceScheduleEndpoint : RestMessage

The raceScheduleEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | raceScheduleEndpoint | Initializes a new instance of the raceScheduleEndpoint class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_events |
Public property | tournament |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceScheduleEndpoint Constructor

Initializes a new instance of the raceScheduleEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public raceScheduleEndpoint()
See Also

Reference

raceScheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceScheduleEndpoint Properties

The raceScheduleEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_events |
Public property | tournament |
Top
See Also

Reference

raceScheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceScheduleEndpoint.generated_at Property

raceScheduleEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.raceScheduleEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

raceScheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceScheduleEndpoint.generated_atSpecified Property

raceScheduleEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.raceScheduleEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

raceScheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceScheduleEndpoint.sport_events Property

raceScheduleEndpointsport_events Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.raceScheduleEndpoint.sport_events"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEventChildrenSport_event[] sport_events { get; set; }

Property Value

sportEventChildrenSport_event
See Also

Reference

raceScheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceScheduleEndpoint.tournament Property

raceScheduleEndpointtournament Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.raceScheduleEndpoint.tournament"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournament tournament { get; set; }

Property Value

tournament
See Also

Reference

raceScheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceScheduleEndpoint Methods

The raceScheduleEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

raceScheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceTeam Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.raceTeam"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTteam
Sportradar.OddsFeed.SDK.Messages.RESTraceTeam

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class raceTeam : team

The raceTeam type exposes the following members.

Constructors
 | Name | Description
Public method | raceTeam | Initializes a new instance of the raceTeam class
Top
Properties
 | Name | Description
Public property | abbreviation | (Inherited from team)
Public property | age_group | (Inherited from team)
Public property | country | (Inherited from team)
Public property | country_code | (Inherited from team)
Public property | division | (Inherited from team)
Public property | division_name | (Inherited from team)
Public property | divisionSpecified | (Inherited from team)
Public property | gender | (Inherited from team)
Public property | id | (Inherited from team)
Public property | name | (Inherited from team)
Public property | players | (Inherited from team)
Public property | reference_ids | (Inherited from team)
Public property | short_name | (Inherited from team)
Public property | state | (Inherited from team)
Public property | virtual | (Inherited from team)
Public property | virtualSpecified | (Inherited from team)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceTeam Constructor

Initializes a new instance of the raceTeam class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public raceTeam()
See Also

Reference

raceTeam Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceTeam Properties

The raceTeam type exposes the following members.

Properties
 | Name | Description
Public property | abbreviation | (Inherited from team)
Public property | age_group | (Inherited from team)
Public property | country | (Inherited from team)
Public property | country_code | (Inherited from team)
Public property | division | (Inherited from team)
Public property | division_name | (Inherited from team)
Public property | divisionSpecified | (Inherited from team)
Public property | gender | (Inherited from team)
Public property | id | (Inherited from team)
Public property | name | (Inherited from team)
Public property | players | (Inherited from team)
Public property | reference_ids | (Inherited from team)
Public property | short_name | (Inherited from team)
Public property | state | (Inherited from team)
Public property | virtual | (Inherited from team)
Public property | virtualSpecified | (Inherited from team)
Top
See Also

Reference

raceTeam Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceTeam Methods

The raceTeam type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

raceTeam Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceTournamentInfoEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.raceTournamentInfoEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTtournamentInfoEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTraceTournamentInfoEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class raceTournamentInfoEndpoint : tournamentInfoEndpoint

The raceTournamentInfoEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | raceTournamentInfoEndpoint | Initializes a new instance of the raceTournamentInfoEndpoint class
Top
Properties
 | Name | Description
Public property | children | (Inherited from tournamentInfoEndpoint)
Public property | competitors | (Inherited from tournamentInfoEndpoint)
Public property | coverage_info | (Inherited from tournamentInfoEndpoint)
Public property | generated_at | (Inherited from tournamentInfoEndpoint)
Public property | generated_atSpecified | (Inherited from tournamentInfoEndpoint)
Public property | groups | (Inherited from tournamentInfoEndpoint)
Public property | round | (Inherited from tournamentInfoEndpoint)
Public property | season | (Inherited from tournamentInfoEndpoint)
Public property | season_coverage_info | (Inherited from tournamentInfoEndpoint)
Public property | tournament | (Inherited from tournamentInfoEndpoint)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceTournamentInfoEndpoint Constructor

Initializes a new instance of the raceTournamentInfoEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public raceTournamentInfoEndpoint()
See Also

Reference

raceTournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceTournamentInfoEndpoint Properties

The raceTournamentInfoEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | children | (Inherited from tournamentInfoEndpoint)
Public property | competitors | (Inherited from tournamentInfoEndpoint)
Public property | coverage_info | (Inherited from tournamentInfoEndpoint)
Public property | generated_at | (Inherited from tournamentInfoEndpoint)
Public property | generated_atSpecified | (Inherited from tournamentInfoEndpoint)
Public property | groups | (Inherited from tournamentInfoEndpoint)
Public property | round | (Inherited from tournamentInfoEndpoint)
Public property | season | (Inherited from tournamentInfoEndpoint)
Public property | season_coverage_info | (Inherited from tournamentInfoEndpoint)
Public property | tournament | (Inherited from tournamentInfoEndpoint)
Top
See Also

Reference

raceTournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


raceTournamentInfoEndpoint Methods

The raceTournamentInfoEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

raceTournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


referee Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.referee"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTreferee

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class referee

The referee type exposes the following members.

Constructors
 | Name | Description
Public method | referee | Initializes a new instance of the referee class
Top
Properties
 | Name | Description
Public property | id |
Public property | name |
Public property | nationality |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


referee Constructor

Initializes a new instance of the referee class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public referee()
See Also

Reference

referee Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


referee Properties

The referee type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | name |
Public property | nationality |
Top
See Also

Reference

referee Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


referee.id Property

refereeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.referee.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

referee Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


referee.name Property

refereename Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.referee.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

referee Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


referee.nationality Property

refereenationality Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.referee.nationality"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string nationality { get; set; }

Property Value

String
See Also

Reference

referee Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


referee Methods

The referee type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

referee Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


referenceIdsReference_id Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.referenceIdsReference_id"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTreferenceIdsReference_id

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class referenceIdsReference_id

The referenceIdsReference_id type exposes the following members.

Constructors
 | Name | Description
Public method | referenceIdsReference_id | Initializes a new instance of the referenceIdsReference_id class
Top
Properties
 | Name | Description
Public property | name |
Public property | value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


referenceIdsReference_id Constructor

Initializes a new instance of the referenceIdsReference_id class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public referenceIdsReference_id()
See Also

Reference

referenceIdsReference_id Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


referenceIdsReference_id Properties

The referenceIdsReference_id type exposes the following members.

Properties
 | Name | Description
Public property | name |
Public property | value |
Top
See Also

Reference

referenceIdsReference_id Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


referenceIdsReference_id.name Property

referenceIdsReference_idname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.referenceIdsReference_id.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

referenceIdsReference_id Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


referenceIdsReference_id.value Property

referenceIdsReference_idvalue Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.referenceIdsReference_id.value"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string value { get; set; }

Property Value

String
See Also

Reference

referenceIdsReference_id Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


referenceIdsReference_id Methods

The referenceIdsReference_id type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

referenceIdsReference_id Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


response Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.response"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTresponse

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class response : RestMessage

The response type exposes the following members.

Constructors
 | Name | Description
Public method | response | Initializes a new instance of the response class
Top
Properties
 | Name | Description
Public property | action |
Public property | message |
Public property | response_code |
Public property | response_codeSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


response Constructor

Initializes a new instance of the response class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public response()
See Also

Reference

response Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


response Properties

The response type exposes the following members.

Properties
 | Name | Description
Public property | action |
Public property | message |
Public property | response_code |
Public property | response_codeSpecified |
Top
See Also

Reference

response Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


response.action Property

responseaction Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.response.action"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string action { get; set; }

Property Value

String
See Also

Reference

response Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


response.message Property

responsemessage Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.response.message"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string message { get; set; }

Property Value

String
See Also

Reference

response Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


response.response_code Property

responseresponse_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.response.response_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public response_code response_code { get; set; }

Property Value

response_code
See Also

Reference

response Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


response.response_codeSpecified Property

responseresponse_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.response.response_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool response_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

response Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


response Methods

The response type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

response Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


response_code Enumeration

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.response_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public enum response_code
Members
Member name | Value | Description
OK | 0 |
CREATED | 1 |
ACCEPTED | 2 |
FORBIDDEN | 3 |
NOT_FOUND | 4 |
CONFLICT | 5 |
SERVICE_UNAVAILABLE | 6 |
NOT_IMPLEMENTED | 7 |
MOVED_PERMANENTLY | 8 |
BAD_REQUEST | 9 |
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


ResponseType Class

Note: This API is now obsolete.

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.ResponseType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTResponseType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
[ObsoleteAttribute("Not used")]
public class ResponseType

The ResponseType type exposes the following members.

Constructors
 | Name | Description
Public method | ResponseType | Initializes a new instance of the ResponseType class
Top
Properties
 | Name | Description
Public property | errors |
Public property | generated_at |
Public property | message |
Public property | response_code |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


ResponseType Constructor

Initializes a new instance of the ResponseType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public ResponseType()
See Also

Reference

ResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


ResponseType Properties

The ResponseType type exposes the following members.

Properties
 | Name | Description
Public property | errors |
Public property | generated_at |
Public property | message |
Public property | response_code |
Top
See Also

Reference

ResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


ResponseType.errors Property

ResponseTypeerrors Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.ResponseType.errors"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string errors { get; set; }

Property Value

String
See Also

Reference

ResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


ResponseType.generated_at Property

ResponseTypegenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.ResponseType.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string generated_at { get; set; }

Property Value

String
See Also

Reference

ResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


ResponseType.message Property

ResponseTypemessage Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.ResponseType.message"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string message { get; set; }

Property Value

String
See Also

Reference

ResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


ResponseType.response_code Property

ResponseTyperesponse_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.ResponseType.response_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string response_code { get; set; }

Property Value

String
See Also

Reference

ResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


ResponseType Methods

The ResponseType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ResponseType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


RestMessage Class

Represents all messages (entities) received from the feed's REST API
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
More

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public abstract class RestMessage

The RestMessage type exposes the following members.

Constructors
 | Name | Description
Protected method | RestMessage | Initializes a new instance of the RestMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace
Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTAvailableSelectionsType
Sportradar.OddsFeed.SDK.Messages.RESTbookmaker_details
Sportradar.OddsFeed.SDK.Messages.RESTCalculationResponseType
Sportradar.OddsFeed.SDK.Messages.RESTcompetitorProfileEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTdraw_fixture
Sportradar.OddsFeed.SDK.Messages.RESTdraw_fixtures
Sportradar.OddsFeed.SDK.Messages.RESTdraw_summary
Sportradar.OddsFeed.SDK.Messages.RESTFilteredCalculationResponseType
Sportradar.OddsFeed.SDK.Messages.RESTfixtureChangesEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTfixturesEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTlotteries
Sportradar.OddsFeed.SDK.Messages.RESTlottery_schedule
Sportradar.OddsFeed.SDK.Messages.RESTmarket_descriptions
Sportradar.OddsFeed.SDK.Messages.RESTmatchSummaryEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTmatchTimelineEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTplayerProfileEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTproducers
Sportradar.OddsFeed.SDK.Messages.RESTraceScheduleEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTresponse
Sportradar.OddsFeed.SDK.Messages.RESTresultChangesEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTscheduleEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTsimpleTeamProfileEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTsportCategoriesEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTsportsEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTsportTournamentsEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTstagePeriodEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTstageSummaryEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTtournamentInfoEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTtournamentSchedule
Sportradar.OddsFeed.SDK.Messages.RESTtournamentSeasons
Sportradar.OddsFeed.SDK.Messages.RESTtournamentsEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTvariant_descriptions


RestMessage Constructor

Initializes a new instance of the RestMessage class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
protected RestMessage()
See Also

Reference

RestMessage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


RestMessage Methods

The RestMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RestMessage Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatus"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTrestSportEventStatusBase
Sportradar.OddsFeed.SDK.Messages.RESTrestSportEventStatus

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class restSportEventStatus : restSportEventStatusBase

The restSportEventStatus type exposes the following members.

Constructors
 | Name | Description
Public method | restSportEventStatus | Initializes a new instance of the restSportEventStatus class
Top
Properties
 | Name | Description
Public property | aggregate_away_score |
Public property | aggregate_home_score |
Public property | aggregate_winner_id |
Public property | away_score |
Public property | clock | (Inherited from restSportEventStatusBase)
Public property | decided_by_fed | (Inherited from restSportEventStatusBase)
Public property | decided_by_fedSpecified | (Inherited from restSportEventStatusBase)
Public property | home_score |
Public property | match_status | (Inherited from restSportEventStatusBase)
Public property | match_status_code |
Public property | match_status_codeSpecified |
Public property | period | (Inherited from restSportEventStatusBase)
Public property | period_scores | (Inherited from restSportEventStatusBase)
Public property | periodSpecified | (Inherited from restSportEventStatusBase)
Public property | results | (Inherited from restSportEventStatusBase)
Public property | status | (Inherited from restSportEventStatusBase)
Public property | status_code |
Public property | status_codeSpecified |
Public property | winner_id | (Inherited from restSportEventStatusBase)
Public property | winning_reason | (Inherited from restSportEventStatusBase)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus Constructor

Initializes a new instance of the restSportEventStatus class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public restSportEventStatus()
See Also

Reference

restSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus Properties

The restSportEventStatus type exposes the following members.

Properties
 | Name | Description
Public property | aggregate_away_score |
Public property | aggregate_home_score |
Public property | aggregate_winner_id |
Public property | away_score |
Public property | clock | (Inherited from restSportEventStatusBase)
Public property | decided_by_fed | (Inherited from restSportEventStatusBase)
Public property | decided_by_fedSpecified | (Inherited from restSportEventStatusBase)
Public property | home_score |
Public property | match_status | (Inherited from restSportEventStatusBase)
Public property | match_status_code |
Public property | match_status_codeSpecified |
Public property | period | (Inherited from restSportEventStatusBase)
Public property | period_scores | (Inherited from restSportEventStatusBase)
Public property | periodSpecified | (Inherited from restSportEventStatusBase)
Public property | results | (Inherited from restSportEventStatusBase)
Public property | status | (Inherited from restSportEventStatusBase)
Public property | status_code |
Public property | status_codeSpecified |
Public property | winner_id | (Inherited from restSportEventStatusBase)
Public property | winning_reason | (Inherited from restSportEventStatusBase)
Top
See Also

Reference

restSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus.aggregate_away_score Property

restSportEventStatusaggregate_away_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatus.aggregate_away_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string aggregate_away_score { get; set; }

Property Value

String
See Also

Reference

restSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus.aggregate_home_score Property

restSportEventStatusaggregate_home_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatus.aggregate_home_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string aggregate_home_score { get; set; }

Property Value

String
See Also

Reference

restSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus.aggregate_winner_id Property

restSportEventStatusaggregate_winner_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatus.aggregate_winner_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string aggregate_winner_id { get; set; }

Property Value

String
See Also

Reference

restSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus.away_score Property

restSportEventStatusaway_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatus.away_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string away_score { get; set; }

Property Value

String
See Also

Reference

restSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus.home_score Property

restSportEventStatushome_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatus.home_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string home_score { get; set; }

Property Value

String
See Also

Reference

restSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus.match_status_code Property

restSportEventStatusmatch_status_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatus.match_status_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int match_status_code { get; set; }

Property Value

Int32
See Also

Reference

restSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus.match_status_codeSpecified Property

restSportEventStatusmatch_status_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatus.match_status_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool match_status_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

restSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus.status_code Property

restSportEventStatusstatus_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatus.status_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int status_code { get; set; }

Property Value

Int32
See Also

Reference

restSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus.status_codeSpecified Property

restSportEventStatusstatus_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatus.status_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool status_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

restSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatus Methods

The restSportEventStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

restSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatusBase"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTrestSportEventStatusBase
Sportradar.OddsFeed.SDK.Messages.RESTrestSportEventStatus

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class restSportEventStatusBase

The restSportEventStatusBase type exposes the following members.

Constructors
 | Name | Description
Public method | restSportEventStatusBase | Initializes a new instance of the restSportEventStatusBase class
Top
Properties
 | Name | Description
Public property | clock |
Public property | decided_by_fed |
Public property | decided_by_fedSpecified |
Public property | match_status |
Public property | period |
Public property | period_scores |
Public property | periodSpecified |
Public property | results |
Public property | status |
Public property | winner_id |
Public property | winning_reason |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase Constructor

Initializes a new instance of the restSportEventStatusBase class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public restSportEventStatusBase()
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase Properties

The restSportEventStatusBase type exposes the following members.

Properties
 | Name | Description
Public property | clock |
Public property | decided_by_fed |
Public property | decided_by_fedSpecified |
Public property | match_status |
Public property | period |
Public property | period_scores |
Public property | periodSpecified |
Public property | results |
Public property | status |
Public property | winner_id |
Public property | winning_reason |
Top
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase.clock Property

restSportEventStatusBaseclock Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatusBase.clock"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public clock[] clock { get; set; }

Property Value

clock
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase.decided_by_fed Property

restSportEventStatusBasedecided_by_fed Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatusBase.decided_by_fed"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool decided_by_fed { get; set; }

Property Value

Boolean
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase.decided_by_fedSpecified Property

restSportEventStatusBasedecided_by_fedSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatusBase.decided_by_fedSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool decided_by_fedSpecified { get; set; }

Property Value

Boolean
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase.match_status Property

restSportEventStatusBasematch_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatusBase.match_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string match_status { get; set; }

Property Value

String
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase.period Property

restSportEventStatusBaseperiod Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatusBase.period"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int period { get; set; }

Property Value

Int32
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase.period_scores Property

restSportEventStatusBaseperiod_scores Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatusBase.period_scores"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public periodScore[] period_scores { get; set; }

Property Value

periodScore
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase.periodSpecified Property

restSportEventStatusBaseperiodSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatusBase.periodSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool periodSpecified { get; set; }

Property Value

Boolean
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase.results Property

restSportEventStatusBaseresults Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatusBase.results"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public resultScore[] results { get; set; }

Property Value

resultScore
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase.status Property

restSportEventStatusBasestatus Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatusBase.status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string status { get; set; }

Property Value

String
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase.winner_id Property

restSportEventStatusBasewinner_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatusBase.winner_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string winner_id { get; set; }

Property Value

String
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase.winning_reason Property

restSportEventStatusBasewinning_reason Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.restSportEventStatusBase.winning_reason"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string winning_reason { get; set; }

Property Value

String
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


restSportEventStatusBase Methods

The restSportEventStatusBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

restSportEventStatusBase Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


result Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.result"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTresult

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class result

The result type exposes the following members.

Constructors
 | Name | Description
Public method | result | Initializes a new instance of the result class
Top
Properties
 | Name | Description
Public property | sport_event |
Public property | sport_event_status |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


result Constructor

Initializes a new instance of the result class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public result()
See Also

Reference

result Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


result Properties

The result type exposes the following members.

Properties
 | Name | Description
Public property | sport_event |
Public property | sport_event_status |
Top
See Also

Reference

result Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


result.sport_event Property

resultsport_event Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.result.sport_event"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEvent[] sport_event { get; set; }

Property Value

sportEvent
See Also

Reference

result Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


result.sport_event_status Property

resultsport_event_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.result.sport_event_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public restSportEventStatus[] sport_event_status { get; set; }

Property Value

restSportEventStatus
See Also

Reference

result Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


result Methods

The result type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

result Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChange Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.resultChange"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTresultChange

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class resultChange

The resultChange type exposes the following members.

Constructors
 | Name | Description
Public method | resultChange | Initializes a new instance of the resultChange class
Top
Properties
 | Name | Description
Public property | sport_event_id |
Public property | update_time |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChange Constructor

Initializes a new instance of the resultChange class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public resultChange()
See Also

Reference

resultChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChange Properties

The resultChange type exposes the following members.

Properties
 | Name | Description
Public property | sport_event_id |
Public property | update_time |
Top
See Also

Reference

resultChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChange.sport_event_id Property

resultChangesport_event_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultChange.sport_event_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string sport_event_id { get; set; }

Property Value

String
See Also

Reference

resultChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChange.update_time Property

resultChangeupdate_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultChange.update_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime update_time { get; set; }

Property Value

DateTime
See Also

Reference

resultChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChange Methods

The resultChange type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

resultChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChangesEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.resultChangesEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTresultChangesEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class resultChangesEndpoint : RestMessage

The resultChangesEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | resultChangesEndpoint | Initializes a new instance of the resultChangesEndpoint class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | result_change |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChangesEndpoint Constructor

Initializes a new instance of the resultChangesEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public resultChangesEndpoint()
See Also

Reference

resultChangesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChangesEndpoint Properties

The resultChangesEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | result_change |
Top
See Also

Reference

resultChangesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChangesEndpoint.generated_at Property

resultChangesEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultChangesEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

resultChangesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChangesEndpoint.generated_atSpecified Property

resultChangesEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultChangesEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

resultChangesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChangesEndpoint.result_change Property

resultChangesEndpointresult_change Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultChangesEndpoint.result_change"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public resultChange[] result_change { get; set; }

Property Value

resultChange
See Also

Reference

resultChangesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultChangesEndpoint Methods

The resultChangesEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

resultChangesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultEndpoint Class

Note: This API is now obsolete.

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.resultEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTresultEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
[ObsoleteAttribute("Not used")]
public class resultEndpoint

The resultEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | resultEndpoint | Initializes a new instance of the resultEndpoint class
Top
Properties
 | Name | Description
Public property | coverage_info |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_event |
Public property | sport_event_conditions |
Public property | sport_event_status |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultEndpoint Constructor

Initializes a new instance of the resultEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public resultEndpoint()
See Also

Reference

resultEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultEndpoint Properties

The resultEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | coverage_info |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_event |
Public property | sport_event_conditions |
Public property | sport_event_status |
Top
See Also

Reference

resultEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultEndpoint.coverage_info Property

resultEndpointcoverage_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultEndpoint.coverage_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public coverageInfo coverage_info { get; set; }

Property Value

coverageInfo
See Also

Reference

resultEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultEndpoint.generated_at Property

resultEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

resultEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultEndpoint.generated_atSpecified Property

resultEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

resultEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultEndpoint.sport_event Property

resultEndpointsport_event Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultEndpoint.sport_event"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEvent sport_event { get; set; }

Property Value

sportEvent
See Also

Reference

resultEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultEndpoint.sport_event_conditions Property

resultEndpointsport_event_conditions Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultEndpoint.sport_event_conditions"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEventConditions sport_event_conditions { get; set; }

Property Value

sportEventConditions
See Also

Reference

resultEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultEndpoint.sport_event_status Property

resultEndpointsport_event_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultEndpoint.sport_event_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public restSportEventStatus sport_event_status { get; set; }

Property Value

restSportEventStatus
See Also

Reference

resultEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultEndpoint Methods

The resultEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

resultEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultScore Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.resultScore"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTresultScore

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class resultScore

The resultScore type exposes the following members.

Constructors
 | Name | Description
Public method | resultScore | Initializes a new instance of the resultScore class
Top
Properties
 | Name | Description
Public property | away_score |
Public property | home_score |
Public property | match_status_code |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultScore Constructor

Initializes a new instance of the resultScore class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public resultScore()
See Also

Reference

resultScore Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultScore Properties

The resultScore type exposes the following members.

Properties
 | Name | Description
Public property | away_score |
Public property | home_score |
Public property | match_status_code |
Top
See Also

Reference

resultScore Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultScore.away_score Property

resultScoreaway_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultScore.away_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string away_score { get; set; }

Property Value

String
See Also

Reference

resultScore Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultScore.home_score Property

resultScorehome_score Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultScore.home_score"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string home_score { get; set; }

Property Value

String
See Also

Reference

resultScore Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultScore.match_status_code Property

resultScorematch_status_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultScore.match_status_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int match_status_code { get; set; }

Property Value

Int32
See Also

Reference

resultScore Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultScore Methods

The resultScore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

resultScore Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultsEndpoint Class

Note: This API is now obsolete.

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.resultsEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTresultsEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
[ObsoleteAttribute("Not used")]
public class resultsEndpoint

The resultsEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | resultsEndpoint | Initializes a new instance of the resultsEndpoint class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | result |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultsEndpoint Constructor

Initializes a new instance of the resultsEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public resultsEndpoint()
See Also

Reference

resultsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultsEndpoint Properties

The resultsEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | result |
Top
See Also

Reference

resultsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultsEndpoint.generated_at Property

resultsEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultsEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

resultsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultsEndpoint.generated_atSpecified Property

resultsEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultsEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

resultsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultsEndpoint.result Property

resultsEndpointresult Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.resultsEndpoint.result"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public result[] result { get; set; }

Property Value

result
See Also

Reference

resultsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


resultsEndpoint Methods

The resultsEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

resultsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduledStartTimeChange Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.scheduledStartTimeChange"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTscheduledStartTimeChange

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class scheduledStartTimeChange

The scheduledStartTimeChange type exposes the following members.

Constructors
 | Name | Description
Public method | scheduledStartTimeChange | Initializes a new instance of the scheduledStartTimeChange class
Top
Properties
 | Name | Description
Public property | changed_at |
Public property | new_time |
Public property | old_time |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduledStartTimeChange Constructor

Initializes a new instance of the scheduledStartTimeChange class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public scheduledStartTimeChange()
See Also

Reference

scheduledStartTimeChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduledStartTimeChange Properties

The scheduledStartTimeChange type exposes the following members.

Properties
 | Name | Description
Public property | changed_at |
Public property | new_time |
Public property | old_time |
Top
See Also

Reference

scheduledStartTimeChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduledStartTimeChange.changed_at Property

scheduledStartTimeChangechanged_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.scheduledStartTimeChange.changed_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime changed_at { get; set; }

Property Value

DateTime
See Also

Reference

scheduledStartTimeChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduledStartTimeChange.new_time Property

scheduledStartTimeChangenew_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.scheduledStartTimeChange.new_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime new_time { get; set; }

Property Value

DateTime
See Also

Reference

scheduledStartTimeChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduledStartTimeChange.old_time Property

scheduledStartTimeChangeold_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.scheduledStartTimeChange.old_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime old_time { get; set; }

Property Value

DateTime
See Also

Reference

scheduledStartTimeChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduledStartTimeChange Methods

The scheduledStartTimeChange type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

scheduledStartTimeChange Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduleEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.scheduleEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTscheduleEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class scheduleEndpoint : RestMessage

The scheduleEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | scheduleEndpoint | Initializes a new instance of the scheduleEndpoint class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_event |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduleEndpoint Constructor

Initializes a new instance of the scheduleEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public scheduleEndpoint()
See Also

Reference

scheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduleEndpoint Properties

The scheduleEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_event |
Top
See Also

Reference

scheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduleEndpoint.generated_at Property

scheduleEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.scheduleEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

scheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduleEndpoint.generated_atSpecified Property

scheduleEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.scheduleEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

scheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduleEndpoint.sport_event Property

scheduleEndpointsport_event Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.scheduleEndpoint.sport_event"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEvent[] sport_event { get; set; }

Property Value

sportEvent
See Also

Reference

scheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


scheduleEndpoint Methods

The scheduleEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

scheduleEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


season Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.season"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTseason
Sportradar.OddsFeed.SDK.Messages.RESTseasonExtended

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class season

The season type exposes the following members.

Constructors
 | Name | Description
Public method | season | Initializes a new instance of the season class
Top
Properties
 | Name | Description
Public property | id |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


season Constructor

Initializes a new instance of the season class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public season()
See Also

Reference

season Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


season Properties

The season type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | name |
Top
See Also

Reference

season Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


season.id Property

seasonid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.season.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

season Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


season.name Property

seasonname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.season.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

season Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


season Methods

The season type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

season Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonCoverageInfo Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.seasonCoverageInfo"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTseasonCoverageInfo

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class seasonCoverageInfo

The seasonCoverageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | seasonCoverageInfo | Initializes a new instance of the seasonCoverageInfo class
Top
Properties
 | Name | Description
Public property | max_coverage_level |
Public property | max_covered |
Public property | max_coveredSpecified |
Public property | min_coverage_level |
Public property | played |
Public property | scheduled |
Public property | season_id |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonCoverageInfo Constructor

Initializes a new instance of the seasonCoverageInfo class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public seasonCoverageInfo()
See Also

Reference

seasonCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonCoverageInfo Properties

The seasonCoverageInfo type exposes the following members.

Properties
 | Name | Description
Public property | max_coverage_level |
Public property | max_covered |
Public property | max_coveredSpecified |
Public property | min_coverage_level |
Public property | played |
Public property | scheduled |
Public property | season_id |
Top
See Also

Reference

seasonCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonCoverageInfo.max_coverage_level Property

seasonCoverageInfomax_coverage_level Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonCoverageInfo.max_coverage_level"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string max_coverage_level { get; set; }

Property Value

String
See Also

Reference

seasonCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonCoverageInfo.max_covered Property

seasonCoverageInfomax_covered Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonCoverageInfo.max_covered"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int max_covered { get; set; }

Property Value

Int32
See Also

Reference

seasonCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonCoverageInfo.max_coveredSpecified Property

seasonCoverageInfomax_coveredSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonCoverageInfo.max_coveredSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool max_coveredSpecified { get; set; }

Property Value

Boolean
See Also

Reference

seasonCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonCoverageInfo.min_coverage_level Property

seasonCoverageInfomin_coverage_level Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonCoverageInfo.min_coverage_level"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string min_coverage_level { get; set; }

Property Value

String
See Also

Reference

seasonCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonCoverageInfo.played Property

seasonCoverageInfoplayed Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonCoverageInfo.played"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int played { get; set; }

Property Value

Int32
See Also

Reference

seasonCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonCoverageInfo.scheduled Property

seasonCoverageInfoscheduled Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonCoverageInfo.scheduled"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int scheduled { get; set; }

Property Value

Int32
See Also

Reference

seasonCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonCoverageInfo.season_id Property

seasonCoverageInfoseason_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonCoverageInfo.season_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string season_id { get; set; }

Property Value

String
See Also

Reference

seasonCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonCoverageInfo Methods

The seasonCoverageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

seasonCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonExtended Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.seasonExtended"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTseason
Sportradar.OddsFeed.SDK.Messages.RESTseasonExtended
Sportradar.OddsFeed.SDK.Messages.RESTcurrentSeason

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class seasonExtended : season

The seasonExtended type exposes the following members.

Constructors
 | Name | Description
Public method | seasonExtended | Initializes a new instance of the seasonExtended class
Top
Properties
 | Name | Description
Public property | end_date |
Public property | end_time |
Public property | end_timeSpecified |
Public property | id | (Inherited from season)
Public property | name | (Inherited from season)
Public property | start_date |
Public property | start_time |
Public property | start_timeSpecified |
Public property | tournament_id |
Public property | year |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonExtended Constructor

Initializes a new instance of the seasonExtended class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public seasonExtended()
See Also

Reference

seasonExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonExtended Properties

The seasonExtended type exposes the following members.

Properties
 | Name | Description
Public property | end_date |
Public property | end_time |
Public property | end_timeSpecified |
Public property | id | (Inherited from season)
Public property | name | (Inherited from season)
Public property | start_date |
Public property | start_time |
Public property | start_timeSpecified |
Public property | tournament_id |
Public property | year |
Top
See Also

Reference

seasonExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonExtended.end_date Property

seasonExtendedend_date Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonExtended.end_date"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime end_date { get; set; }

Property Value

DateTime
See Also

Reference

seasonExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonExtended.end_time Property

seasonExtendedend_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonExtended.end_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime end_time { get; set; }

Property Value

DateTime
See Also

Reference

seasonExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonExtended.end_timeSpecified Property

seasonExtendedend_timeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonExtended.end_timeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool end_timeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

seasonExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonExtended.start_date Property

seasonExtendedstart_date Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonExtended.start_date"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime start_date { get; set; }

Property Value

DateTime
See Also

Reference

seasonExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonExtended.start_time Property

seasonExtendedstart_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonExtended.start_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime start_time { get; set; }

Property Value

DateTime
See Also

Reference

seasonExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonExtended.start_timeSpecified Property

seasonExtendedstart_timeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonExtended.start_timeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_timeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

seasonExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonExtended.tournament_id Property

seasonExtendedtournament_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonExtended.tournament_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string tournament_id { get; set; }

Property Value

String
See Also

Reference

seasonExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonExtended.year Property

seasonExtendedyear Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.seasonExtended.year"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string year { get; set; }

Property Value

String
See Also

Reference

seasonExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


seasonExtended Methods

The seasonExtended type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

seasonExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionsType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.SelectionsType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTSelectionsType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class SelectionsType

The SelectionsType type exposes the following members.

Constructors
 | Name | Description
Public method | SelectionsType | Initializes a new instance of the SelectionsType class
Top
Properties
 | Name | Description
Public property | selection |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionsType Constructor

Initializes a new instance of the SelectionsType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public SelectionsType()
See Also

Reference

SelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionsType Properties

The SelectionsType type exposes the following members.

Properties
 | Name | Description
Public property | selection |
Top
See Also

Reference

SelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionsType.selection Property

SelectionsTypeselection Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.SelectionsType.selection"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public SelectionType[] selection { get; set; }

Property Value

SelectionType
See Also

Reference

SelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionsType Methods

The SelectionsType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SelectionsType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionType Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.SelectionType"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTSelectionType

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class SelectionType

The SelectionType type exposes the following members.

Constructors
 | Name | Description
Public method | SelectionType | Initializes a new instance of the SelectionType class
Top
Properties
 | Name | Description
Public property | id |
Public property | market_id |
Public property | outcome_id |
Public property | specifiers |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionType Constructor

Initializes a new instance of the SelectionType class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public SelectionType()
See Also

Reference

SelectionType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionType Properties

The SelectionType type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | market_id |
Public property | outcome_id |
Public property | specifiers |
Top
See Also

Reference

SelectionType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionType.id Property

SelectionTypeid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.SelectionType.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

SelectionType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionType.market_id Property

SelectionTypemarket_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.SelectionType.market_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int market_id { get; set; }

Property Value

Int32
See Also

Reference

SelectionType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionType.outcome_id Property

SelectionTypeoutcome_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.SelectionType.outcome_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string outcome_id { get; set; }

Property Value

String
See Also

Reference

SelectionType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionType.specifiers Property

SelectionTypespecifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.SelectionType.specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string specifiers { get; set; }

Property Value

String
See Also

Reference

SelectionType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


SelectionType Methods

The SelectionType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SelectionType Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


simpleTeamProfileEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.simpleTeamProfileEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTsimpleTeamProfileEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class simpleTeamProfileEndpoint : RestMessage

The simpleTeamProfileEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | simpleTeamProfileEndpoint | Initializes a new instance of the simpleTeamProfileEndpoint class
Top
Properties
 | Name | Description
Public property | competitor |
Public property | generated_at |
Public property | generated_atSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


simpleTeamProfileEndpoint Constructor

Initializes a new instance of the simpleTeamProfileEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public simpleTeamProfileEndpoint()
See Also

Reference

simpleTeamProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


simpleTeamProfileEndpoint Properties

The simpleTeamProfileEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | competitor |
Public property | generated_at |
Public property | generated_atSpecified |
Top
See Also

Reference

simpleTeamProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


simpleTeamProfileEndpoint.competitor Property

simpleTeamProfileEndpointcompetitor Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.simpleTeamProfileEndpoint.competitor"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public team competitor { get; set; }

Property Value

team
See Also

Reference

simpleTeamProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


simpleTeamProfileEndpoint.generated_at Property

simpleTeamProfileEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.simpleTeamProfileEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

simpleTeamProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


simpleTeamProfileEndpoint.generated_atSpecified Property

simpleTeamProfileEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.simpleTeamProfileEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

simpleTeamProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


simpleTeamProfileEndpoint Methods

The simpleTeamProfileEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

simpleTeamProfileEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


simpleTournamentInfoEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.simpleTournamentInfoEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTtournamentInfoEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTsimpleTournamentInfoEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class simpleTournamentInfoEndpoint : tournamentInfoEndpoint

The simpleTournamentInfoEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | simpleTournamentInfoEndpoint | Initializes a new instance of the simpleTournamentInfoEndpoint class
Top
Properties
 | Name | Description
Public property | children | (Inherited from tournamentInfoEndpoint)
Public property | competitors | (Inherited from tournamentInfoEndpoint)
Public property | coverage_info | (Inherited from tournamentInfoEndpoint)
Public property | generated_at | (Inherited from tournamentInfoEndpoint)
Public property | generated_atSpecified | (Inherited from tournamentInfoEndpoint)
Public property | groups | (Inherited from tournamentInfoEndpoint)
Public property | round | (Inherited from tournamentInfoEndpoint)
Public property | season | (Inherited from tournamentInfoEndpoint)
Public property | season_coverage_info | (Inherited from tournamentInfoEndpoint)
Public property | tournament | (Inherited from tournamentInfoEndpoint)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


simpleTournamentInfoEndpoint Constructor

Initializes a new instance of the simpleTournamentInfoEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public simpleTournamentInfoEndpoint()
See Also

Reference

simpleTournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


simpleTournamentInfoEndpoint Properties

The simpleTournamentInfoEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | children | (Inherited from tournamentInfoEndpoint)
Public property | competitors | (Inherited from tournamentInfoEndpoint)
Public property | coverage_info | (Inherited from tournamentInfoEndpoint)
Public property | generated_at | (Inherited from tournamentInfoEndpoint)
Public property | generated_atSpecified | (Inherited from tournamentInfoEndpoint)
Public property | groups | (Inherited from tournamentInfoEndpoint)
Public property | round | (Inherited from tournamentInfoEndpoint)
Public property | season | (Inherited from tournamentInfoEndpoint)
Public property | season_coverage_info | (Inherited from tournamentInfoEndpoint)
Public property | tournament | (Inherited from tournamentInfoEndpoint)
Top
See Also

Reference

simpleTournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


simpleTournamentInfoEndpoint Methods

The simpleTournamentInfoEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

simpleTournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sport Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.sport"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTsport

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class sport

The sport type exposes the following members.

Constructors
 | Name | Description
Public method | sport | Initializes a new instance of the sport class
Top
Properties
 | Name | Description
Public property | id |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


sport Constructor

Initializes a new instance of the sport class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sport()
See Also

Reference

sport Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sport Properties

The sport type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | name |
Top
See Also

Reference

sport Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sport.id Property

sportid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sport.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

sport Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sport.name Property

sportname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sport.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

sport Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sport Methods

The sport type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

sport Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportCategoriesEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.sportCategoriesEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTsportCategoriesEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class sportCategoriesEndpoint : RestMessage

The sportCategoriesEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | sportCategoriesEndpoint | Initializes a new instance of the sportCategoriesEndpoint class
Top
Properties
 | Name | Description
Public property | categories |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportCategoriesEndpoint Constructor

Initializes a new instance of the sportCategoriesEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportCategoriesEndpoint()
See Also

Reference

sportCategoriesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportCategoriesEndpoint Properties

The sportCategoriesEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | categories |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport |
Top
See Also

Reference

sportCategoriesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportCategoriesEndpoint.categories Property

sportCategoriesEndpointcategories Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportCategoriesEndpoint.categories"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public category[] categories { get; set; }

Property Value

category
See Also

Reference

sportCategoriesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportCategoriesEndpoint.generated_at Property

sportCategoriesEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportCategoriesEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

sportCategoriesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportCategoriesEndpoint.generated_atSpecified Property

sportCategoriesEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportCategoriesEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportCategoriesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportCategoriesEndpoint.sport Property

sportCategoriesEndpointsport Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportCategoriesEndpoint.sport"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sport sport { get; set; }

Property Value

sport
See Also

Reference

sportCategoriesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportCategoriesEndpoint Methods

The sportCategoriesEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

sportCategoriesEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTsportEvent
Sportradar.OddsFeed.SDK.Messages.RESTfixture

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class sportEvent

The sportEvent type exposes the following members.

Constructors
 | Name | Description
Public method | sportEvent | Initializes a new instance of the sportEvent class
Top
Properties
 | Name | Description
Public property | additional_parents |
Public property | competitors |
Public property | id |
Public property | liveodds |
Public property | name |
Public property | next_live_time |
Public property | parent |
Public property | races |
Public property | replaced_by |
Public property | scheduled |
Public property | scheduled_end |
Public property | scheduled_endSpecified |
Public property | scheduledSpecified |
Public property | season |
Public property | sport_event_conditions |
Public property | stage_type |
Public property | start_time_tbd |
Public property | start_time_tbdSpecified |
Public property | status |
Public property | tournament |
Public property | tournament_round |
Public property | type |
Public property | venue |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent Constructor

Initializes a new instance of the sportEvent class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEvent()
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent Properties

The sportEvent type exposes the following members.

Properties
 | Name | Description
Public property | additional_parents |
Public property | competitors |
Public property | id |
Public property | liveodds |
Public property | name |
Public property | next_live_time |
Public property | parent |
Public property | races |
Public property | replaced_by |
Public property | scheduled |
Public property | scheduled_end |
Public property | scheduled_endSpecified |
Public property | scheduledSpecified |
Public property | season |
Public property | sport_event_conditions |
Public property | stage_type |
Public property | start_time_tbd |
Public property | start_time_tbdSpecified |
Public property | status |
Public property | tournament |
Public property | tournament_round |
Public property | type |
Public property | venue |
Top
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.additional_parents Property

sportEventadditional_parents Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.additional_parents"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public parentStage[] additional_parents { get; set; }

Property Value

parentStage
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.competitors Property

sportEventcompetitors Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.competitors"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public teamCompetitor[] competitors { get; set; }

Property Value

teamCompetitor
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.id Property

sportEventid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.liveodds Property

sportEventliveodds Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.liveodds"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string liveodds { get; set; }

Property Value

String
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.name Property

sportEventname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.next_live_time Property

sportEventnext_live_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.next_live_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string next_live_time { get; set; }

Property Value

String
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.parent Property

sportEventparent Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.parent"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public parentStage parent { get; set; }

Property Value

parentStage
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.races Property

sportEventraces Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.races"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEventChildrenSport_event[] races { get; set; }

Property Value

sportEventChildrenSport_event
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.replaced_by Property

sportEventreplaced_by Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.replaced_by"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string replaced_by { get; set; }

Property Value

String
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.scheduled Property

sportEventscheduled Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.scheduled"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime scheduled { get; set; }

Property Value

DateTime
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.scheduled_end Property

sportEventscheduled_end Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.scheduled_end"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime scheduled_end { get; set; }

Property Value

DateTime
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.scheduled_endSpecified Property

sportEventscheduled_endSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.scheduled_endSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool scheduled_endSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.scheduledSpecified Property

sportEventscheduledSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.scheduledSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool scheduledSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.season Property

sportEventseason Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.season"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public seasonExtended season { get; set; }

Property Value

seasonExtended
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.sport_event_conditions Property

sportEventsport_event_conditions Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.sport_event_conditions"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEventConditions sport_event_conditions { get; set; }

Property Value

sportEventConditions
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.stage_type Property

sportEventstage_type Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.stage_type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string stage_type { get; set; }

Property Value

String
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.start_time_tbd Property

sportEventstart_time_tbd Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.start_time_tbd"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_time_tbd { get; set; }

Property Value

Boolean
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.start_time_tbdSpecified Property

sportEventstart_time_tbdSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.start_time_tbdSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_time_tbdSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.status Property

sportEventstatus Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string status { get; set; }

Property Value

String
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.tournament Property

sportEventtournament Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.tournament"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournament tournament { get; set; }

Property Value

tournament
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.tournament_round Property

sportEventtournament_round Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.tournament_round"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public matchRound tournament_round { get; set; }

Property Value

matchRound
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.type Property

sportEventtype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent.venue Property

sportEventvenue Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEvent.venue"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public venue venue { get; set; }

Property Value

venue
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEvent Methods

The sportEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

sportEvent Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.sportEventChildrenSport_event"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTsportEventChildrenSport_event

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class sportEventChildrenSport_event

The sportEventChildrenSport_event type exposes the following members.

Constructors
 | Name | Description
Public method | sportEventChildrenSport_event | Initializes a new instance of the sportEventChildrenSport_event class
Top
Properties
 | Name | Description
Public property | id |
Public property | name |
Public property | replaced_by |
Public property | scheduled |
Public property | scheduled_end |
Public property | scheduled_endSpecified |
Public property | scheduledSpecified |
Public property | stage_type |
Public property | start_time_tbd |
Public property | start_time_tbdSpecified |
Public property | type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event Constructor

Initializes a new instance of the sportEventChildrenSport_event class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEventChildrenSport_event()
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event Properties

The sportEventChildrenSport_event type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | name |
Public property | replaced_by |
Public property | scheduled |
Public property | scheduled_end |
Public property | scheduled_endSpecified |
Public property | scheduledSpecified |
Public property | stage_type |
Public property | start_time_tbd |
Public property | start_time_tbdSpecified |
Public property | type |
Top
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event.id Property

sportEventChildrenSport_eventid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventChildrenSport_event.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event.name Property

sportEventChildrenSport_eventname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventChildrenSport_event.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event.replaced_by Property

sportEventChildrenSport_eventreplaced_by Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventChildrenSport_event.replaced_by"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string replaced_by { get; set; }

Property Value

String
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event.scheduled Property

sportEventChildrenSport_eventscheduled Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventChildrenSport_event.scheduled"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime scheduled { get; set; }

Property Value

DateTime
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event.scheduled_end Property

sportEventChildrenSport_eventscheduled_end Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventChildrenSport_event.scheduled_end"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime scheduled_end { get; set; }

Property Value

DateTime
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event.scheduled_endSpecified Property

sportEventChildrenSport_eventscheduled_endSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventChildrenSport_event.scheduled_endSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool scheduled_endSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event.scheduledSpecified Property

sportEventChildrenSport_eventscheduledSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventChildrenSport_event.scheduledSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool scheduledSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event.stage_type Property

sportEventChildrenSport_eventstage_type Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventChildrenSport_event.stage_type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string stage_type { get; set; }

Property Value

String
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event.start_time_tbd Property

sportEventChildrenSport_eventstart_time_tbd Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventChildrenSport_event.start_time_tbd"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_time_tbd { get; set; }

Property Value

Boolean
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event.start_time_tbdSpecified Property

sportEventChildrenSport_eventstart_time_tbdSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventChildrenSport_event.start_time_tbdSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_time_tbdSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event.type Property

sportEventChildrenSport_eventtype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventChildrenSport_event.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventChildrenSport_event Methods

The sportEventChildrenSport_event type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

sportEventChildrenSport_event Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventConditions Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.sportEventConditions"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTsportEventConditions

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class sportEventConditions

The sportEventConditions type exposes the following members.

Constructors
 | Name | Description
Public method | sportEventConditions | Initializes a new instance of the sportEventConditions class
Top
Properties
 | Name | Description
Public property | attendance |
Public property | match_mode |
Public property | pitcherHistory |
Public property | pitchers |
Public property | referee |
Public property | venue |
Public property | weather_info |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventConditions Constructor

Initializes a new instance of the sportEventConditions class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEventConditions()
See Also

Reference

sportEventConditions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventConditions Properties

The sportEventConditions type exposes the following members.

Properties
 | Name | Description
Public property | attendance |
Public property | match_mode |
Public property | pitcherHistory |
Public property | pitchers |
Public property | referee |
Public property | venue |
Public property | weather_info |
Top
See Also

Reference

sportEventConditions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventConditions.attendance Property

sportEventConditionsattendance Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventConditions.attendance"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string attendance { get; set; }

Property Value

String
See Also

Reference

sportEventConditions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventConditions.match_mode Property

sportEventConditionsmatch_mode Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventConditions.match_mode"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string match_mode { get; set; }

Property Value

String
See Also

Reference

sportEventConditions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventConditions.pitcherHistory Property

sportEventConditionspitcherHistory Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventConditions.pitcherHistory"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public pitcher[] pitcherHistory { get; set; }

Property Value

pitcher
See Also

Reference

sportEventConditions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventConditions.pitchers Property

sportEventConditionspitchers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventConditions.pitchers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public pitcher[] pitchers { get; set; }

Property Value

pitcher
See Also

Reference

sportEventConditions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventConditions.referee Property

sportEventConditionsreferee Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventConditions.referee"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public referee referee { get; set; }

Property Value

referee
See Also

Reference

sportEventConditions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventConditions.venue Property

sportEventConditionsvenue Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventConditions.venue"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public venue venue { get; set; }

Property Value

venue
See Also

Reference

sportEventConditions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventConditions.weather_info Property

sportEventConditionsweather_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportEventConditions.weather_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public weatherInfo weather_info { get; set; }

Property Value

weatherInfo
See Also

Reference

sportEventConditions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportEventConditions Methods

The sportEventConditions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

sportEventConditions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportsEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.sportsEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTsportsEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class sportsEndpoint : RestMessage

The sportsEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | sportsEndpoint | Initializes a new instance of the sportsEndpoint class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportsEndpoint Constructor

Initializes a new instance of the sportsEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportsEndpoint()
See Also

Reference

sportsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportsEndpoint Properties

The sportsEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport |
Top
See Also

Reference

sportsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportsEndpoint.generated_at Property

sportsEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportsEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

sportsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportsEndpoint.generated_atSpecified Property

sportsEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportsEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportsEndpoint.sport Property

sportsEndpointsport Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportsEndpoint.sport"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sport[] sport { get; set; }

Property Value

sport
See Also

Reference

sportsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportsEndpoint Methods

The sportsEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

sportsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportTournamentsEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.sportTournamentsEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTsportTournamentsEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class sportTournamentsEndpoint : RestMessage

The sportTournamentsEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | sportTournamentsEndpoint | Initializes a new instance of the sportTournamentsEndpoint class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport |
Public property | tournaments |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportTournamentsEndpoint Constructor

Initializes a new instance of the sportTournamentsEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportTournamentsEndpoint()
See Also

Reference

sportTournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportTournamentsEndpoint Properties

The sportTournamentsEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport |
Public property | tournaments |
Top
See Also

Reference

sportTournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportTournamentsEndpoint.generated_at Property

sportTournamentsEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportTournamentsEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

sportTournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportTournamentsEndpoint.generated_atSpecified Property

sportTournamentsEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportTournamentsEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

sportTournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportTournamentsEndpoint.sport Property

sportTournamentsEndpointsport Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportTournamentsEndpoint.sport"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sport sport { get; set; }

Property Value

sport
See Also

Reference

sportTournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportTournamentsEndpoint.tournaments Property

sportTournamentsEndpointtournaments Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.sportTournamentsEndpoint.tournaments"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournament[] tournaments { get; set; }

Property Value

tournament
See Also

Reference

sportTournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


sportTournamentsEndpoint Methods

The sportTournamentsEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

sportTournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stagePeriodEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.stagePeriodEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTstagePeriodEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class stagePeriodEndpoint : RestMessage

The stagePeriodEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | stagePeriodEndpoint | Initializes a new instance of the stagePeriodEndpoint class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | period_statuses |
Public property | sport_event |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


stagePeriodEndpoint Constructor

Initializes a new instance of the stagePeriodEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public stagePeriodEndpoint()
See Also

Reference

stagePeriodEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stagePeriodEndpoint Properties

The stagePeriodEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | period_statuses |
Public property | sport_event |
Top
See Also

Reference

stagePeriodEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stagePeriodEndpoint.generated_at Property

stagePeriodEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stagePeriodEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

stagePeriodEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stagePeriodEndpoint.generated_atSpecified Property

stagePeriodEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stagePeriodEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stagePeriodEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stagePeriodEndpoint.period_statuses Property

stagePeriodEndpointperiod_statuses Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stagePeriodEndpoint.period_statuses"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public periodStatus[] period_statuses { get; set; }

Property Value

periodStatus
See Also

Reference

stagePeriodEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stagePeriodEndpoint.sport_event Property

stagePeriodEndpointsport_event Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stagePeriodEndpoint.sport_event"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEvent sport_event { get; set; }

Property Value

sportEvent
See Also

Reference

stagePeriodEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stagePeriodEndpoint Methods

The stagePeriodEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

stagePeriodEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResult Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.stageResult"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTstageResult

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class stageResult

The stageResult type exposes the following members.

Constructors
 | Name | Description
Public method | stageResult | Initializes a new instance of the stageResult class
Top
Properties
 | Name | Description
Public property | competitor |
Public property | coverage |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResult Constructor

Initializes a new instance of the stageResult class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public stageResult()
See Also

Reference

stageResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResult Properties

The stageResult type exposes the following members.

Properties
 | Name | Description
Public property | competitor |
Public property | coverage |
Top
See Also

Reference

stageResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResult.competitor Property

stageResultcompetitor Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResult.competitor"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public stageResultCompetitor[] competitor { get; set; }

Property Value

stageResultCompetitor
See Also

Reference

stageResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResult.coverage Property

stageResultcoverage Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResult.coverage"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string coverage { get; set; }

Property Value

String
See Also

Reference

stageResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResult Methods

The stageResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

stageResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTstageResultCompetitor

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class stageResultCompetitor

The stageResultCompetitor type exposes the following members.

Constructors
 | Name | Description
Public method | stageResultCompetitor | Initializes a new instance of the stageResultCompetitor class
Top
Properties
 | Name | Description
Public property | climber |
Public property | climber_ranking |
Public property | climber_rankingSpecified |
Public property | climberSpecified |
Public property | distance |
Public property | distanceSpecified |
Public property | grid |
Public property | gridSpecified |
Public property | id |
Public property | points |
Public property | pointsSpecified |
Public property | position |
Public property | positionSpecified |
Public property | result |
Public property | sprint |
Public property | sprint_ranking |
Public property | sprint_rankingSpecified |
Public property | sprintSpecified |
Public property | status |
Public property | status_comment |
Public property | time |
Public property | time_ranking |
Public property | time_rankingSpecified |
Public property | wc_points |
Public property | wc_pointsSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor Constructor

Initializes a new instance of the stageResultCompetitor class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public stageResultCompetitor()
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor Properties

The stageResultCompetitor type exposes the following members.

Properties
 | Name | Description
Public property | climber |
Public property | climber_ranking |
Public property | climber_rankingSpecified |
Public property | climberSpecified |
Public property | distance |
Public property | distanceSpecified |
Public property | grid |
Public property | gridSpecified |
Public property | id |
Public property | points |
Public property | pointsSpecified |
Public property | position |
Public property | positionSpecified |
Public property | result |
Public property | sprint |
Public property | sprint_ranking |
Public property | sprint_rankingSpecified |
Public property | sprintSpecified |
Public property | status |
Public property | status_comment |
Public property | time |
Public property | time_ranking |
Public property | time_rankingSpecified |
Public property | wc_points |
Public property | wc_pointsSpecified |
Top
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.climber Property

stageResultCompetitorclimber Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.climber"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double climber { get; set; }

Property Value

Double
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.climber_ranking Property

stageResultCompetitorclimber_ranking Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.climber_ranking"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int climber_ranking { get; set; }

Property Value

Int32
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.climber_rankingSpecified Property

stageResultCompetitorclimber_rankingSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.climber_rankingSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool climber_rankingSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.climberSpecified Property

stageResultCompetitorclimberSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.climberSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool climberSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.distance Property

stageResultCompetitordistance Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.distance"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double distance { get; set; }

Property Value

Double
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.distanceSpecified Property

stageResultCompetitordistanceSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.distanceSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool distanceSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.grid Property

stageResultCompetitorgrid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.grid"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int grid { get; set; }

Property Value

Int32
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.gridSpecified Property

stageResultCompetitorgridSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.gridSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool gridSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.id Property

stageResultCompetitorid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.points Property

stageResultCompetitorpoints Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.points"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double points { get; set; }

Property Value

Double
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.pointsSpecified Property

stageResultCompetitorpointsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.pointsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool pointsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.position Property

stageResultCompetitorposition Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.position"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int position { get; set; }

Property Value

Int32
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.positionSpecified Property

stageResultCompetitorpositionSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.positionSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool positionSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.result Property

stageResultCompetitorresult Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.result"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public stageResultCompetitorResult[] result { get; set; }

Property Value

stageResultCompetitorResult
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.sprint Property

stageResultCompetitorsprint Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.sprint"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double sprint { get; set; }

Property Value

Double
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.sprint_ranking Property

stageResultCompetitorsprint_ranking Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.sprint_ranking"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int sprint_ranking { get; set; }

Property Value

Int32
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.sprint_rankingSpecified Property

stageResultCompetitorsprint_rankingSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.sprint_rankingSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool sprint_rankingSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.sprintSpecified Property

stageResultCompetitorsprintSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.sprintSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool sprintSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.status Property

stageResultCompetitorstatus Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string status { get; set; }

Property Value

String
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.status_comment Property

stageResultCompetitorstatus_comment Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.status_comment"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string status_comment { get; set; }

Property Value

String
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.time Property

stageResultCompetitortime Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string time { get; set; }

Property Value

String
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.time_ranking Property

stageResultCompetitortime_ranking Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.time_ranking"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int time_ranking { get; set; }

Property Value

Int32
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.time_rankingSpecified Property

stageResultCompetitortime_rankingSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.time_rankingSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool time_rankingSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.wc_points Property

stageResultCompetitorwc_points Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.wc_points"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public double wc_points { get; set; }

Property Value

Double
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor.wc_pointsSpecified Property

stageResultCompetitorwc_pointsSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitor.wc_pointsSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool wc_pointsSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitor Methods

The stageResultCompetitor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

stageResultCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitorResult Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitorResult"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTstageResultCompetitorResult

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class stageResultCompetitorResult

The stageResultCompetitorResult type exposes the following members.

Constructors
 | Name | Description
Public method | stageResultCompetitorResult | Initializes a new instance of the stageResultCompetitorResult class
Top
Properties
 | Name | Description
Public property | specifiers |
Public property | type |
Public property | value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitorResult Constructor

Initializes a new instance of the stageResultCompetitorResult class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public stageResultCompetitorResult()
See Also

Reference

stageResultCompetitorResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitorResult Properties

The stageResultCompetitorResult type exposes the following members.

Properties
 | Name | Description
Public property | specifiers |
Public property | type |
Public property | value |
Top
See Also

Reference

stageResultCompetitorResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitorResult.specifiers Property

stageResultCompetitorResultspecifiers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitorResult.specifiers"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string specifiers { get; set; }

Property Value

String
See Also

Reference

stageResultCompetitorResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitorResult.type Property

stageResultCompetitorResulttype Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitorResult.type"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string type { get; set; }

Property Value

String
See Also

Reference

stageResultCompetitorResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitorResult.value Property

stageResultCompetitorResultvalue Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageResultCompetitorResult.value"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string value { get; set; }

Property Value

String
See Also

Reference

stageResultCompetitorResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageResultCompetitorResult Methods

The stageResultCompetitorResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

stageResultCompetitorResult Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSportEventStatus Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.stageSportEventStatus"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTstageSportEventStatus

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class stageSportEventStatus

The stageSportEventStatus type exposes the following members.

Constructors
 | Name | Description
Public method | stageSportEventStatus | Initializes a new instance of the stageSportEventStatus class
Top
Properties
 | Name | Description
Public property | period_of_leader |
Public property | period_of_leaderSpecified |
Public property | results |
Public property | status |
Public property | winner_id |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSportEventStatus Constructor

Initializes a new instance of the stageSportEventStatus class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public stageSportEventStatus()
See Also

Reference

stageSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSportEventStatus Properties

The stageSportEventStatus type exposes the following members.

Properties
 | Name | Description
Public property | period_of_leader |
Public property | period_of_leaderSpecified |
Public property | results |
Public property | status |
Public property | winner_id |
Top
See Also

Reference

stageSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSportEventStatus.period_of_leader Property

stageSportEventStatusperiod_of_leader Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageSportEventStatus.period_of_leader"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int period_of_leader { get; set; }

Property Value

Int32
See Also

Reference

stageSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSportEventStatus.period_of_leaderSpecified Property

stageSportEventStatusperiod_of_leaderSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageSportEventStatus.period_of_leaderSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool period_of_leaderSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stageSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSportEventStatus.results Property

stageSportEventStatusresults Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageSportEventStatus.results"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public stageResult results { get; set; }

Property Value

stageResult
See Also

Reference

stageSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSportEventStatus.status Property

stageSportEventStatusstatus Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageSportEventStatus.status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string status { get; set; }

Property Value

String
See Also

Reference

stageSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSportEventStatus.winner_id Property

stageSportEventStatuswinner_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageSportEventStatus.winner_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string winner_id { get; set; }

Property Value

String
See Also

Reference

stageSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSportEventStatus Methods

The stageSportEventStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

stageSportEventStatus Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSummaryEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.stageSummaryEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTstageSummaryEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class stageSummaryEndpoint : RestMessage

The stageSummaryEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | stageSummaryEndpoint | Initializes a new instance of the stageSummaryEndpoint class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_event |
Public property | sport_event_status |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSummaryEndpoint Constructor

Initializes a new instance of the stageSummaryEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public stageSummaryEndpoint()
See Also

Reference

stageSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSummaryEndpoint Properties

The stageSummaryEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_event |
Public property | sport_event_status |
Top
See Also

Reference

stageSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSummaryEndpoint.generated_at Property

stageSummaryEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageSummaryEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

stageSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSummaryEndpoint.generated_atSpecified Property

stageSummaryEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageSummaryEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

stageSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSummaryEndpoint.sport_event Property

stageSummaryEndpointsport_event Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageSummaryEndpoint.sport_event"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEvent sport_event { get; set; }

Property Value

sportEvent
See Also

Reference

stageSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSummaryEndpoint.sport_event_status Property

stageSummaryEndpointsport_event_status Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.stageSummaryEndpoint.sport_event_status"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public stageSportEventStatus sport_event_status { get; set; }

Property Value

stageSportEventStatus
See Also

Reference

stageSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


stageSummaryEndpoint Methods

The stageSummaryEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

stageSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


standardTournamentInfoEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.standardTournamentInfoEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTtournamentInfoEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTstandardTournamentInfoEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class standardTournamentInfoEndpoint : tournamentInfoEndpoint

The standardTournamentInfoEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | standardTournamentInfoEndpoint | Initializes a new instance of the standardTournamentInfoEndpoint class
Top
Properties
 | Name | Description
Public property | children | (Inherited from tournamentInfoEndpoint)
Public property | competitors | (Inherited from tournamentInfoEndpoint)
Public property | coverage_info | (Inherited from tournamentInfoEndpoint)
Public property | generated_at | (Inherited from tournamentInfoEndpoint)
Public property | generated_atSpecified | (Inherited from tournamentInfoEndpoint)
Public property | groups | (Inherited from tournamentInfoEndpoint)
Public property | round | (Inherited from tournamentInfoEndpoint)
Public property | season | (Inherited from tournamentInfoEndpoint)
Public property | season_coverage_info | (Inherited from tournamentInfoEndpoint)
Public property | tournament | (Inherited from tournamentInfoEndpoint)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


standardTournamentInfoEndpoint Constructor

Initializes a new instance of the standardTournamentInfoEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public standardTournamentInfoEndpoint()
See Also

Reference

standardTournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


standardTournamentInfoEndpoint Properties

The standardTournamentInfoEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | children | (Inherited from tournamentInfoEndpoint)
Public property | competitors | (Inherited from tournamentInfoEndpoint)
Public property | coverage_info | (Inherited from tournamentInfoEndpoint)
Public property | generated_at | (Inherited from tournamentInfoEndpoint)
Public property | generated_atSpecified | (Inherited from tournamentInfoEndpoint)
Public property | groups | (Inherited from tournamentInfoEndpoint)
Public property | round | (Inherited from tournamentInfoEndpoint)
Public property | season | (Inherited from tournamentInfoEndpoint)
Public property | season_coverage_info | (Inherited from tournamentInfoEndpoint)
Public property | tournament | (Inherited from tournamentInfoEndpoint)
Top
See Also

Reference

standardTournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


standardTournamentInfoEndpoint Methods

The standardTournamentInfoEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

standardTournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


streamingChannel Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.streamingChannel"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTstreamingChannel

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class streamingChannel

The streamingChannel type exposes the following members.

Constructors
 | Name | Description
Public method | streamingChannel | Initializes a new instance of the streamingChannel class
Top
Properties
 | Name | Description
Public property | id |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


streamingChannel Constructor

Initializes a new instance of the streamingChannel class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public streamingChannel()
See Also

Reference

streamingChannel Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


streamingChannel Properties

The streamingChannel type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | name |
Top
See Also

Reference

streamingChannel Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


streamingChannel.id Property

streamingChannelid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.streamingChannel.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int id { get; set; }

Property Value

Int32
See Also

Reference

streamingChannel Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


streamingChannel.name Property

streamingChannelname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.streamingChannel.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

streamingChannel Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


streamingChannel Methods

The streamingChannel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

streamingChannel Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.team"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTteam
Sportradar.OddsFeed.SDK.Messages.RESTraceDriver
Sportradar.OddsFeed.SDK.Messages.RESTraceTeam
Sportradar.OddsFeed.SDK.Messages.RESTteamCompetitor
Sportradar.OddsFeed.SDK.Messages.RESTteamExtended

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class team

The team type exposes the following members.

Constructors
 | Name | Description
Public method | team | Initializes a new instance of the team class
Top
Properties
 | Name | Description
Public property | abbreviation |
Public property | age_group |
Public property | country |
Public property | country_code |
Public property | division |
Public property | division_name |
Public property | divisionSpecified |
Public property | gender |
Public property | id |
Public property | name |
Public property | players |
Public property | reference_ids |
Public property | short_name |
Public property | state |
Public property | virtual |
Public property | virtualSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


team Constructor

Initializes a new instance of the team class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public team()
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team Properties

The team type exposes the following members.

Properties
 | Name | Description
Public property | abbreviation |
Public property | age_group |
Public property | country |
Public property | country_code |
Public property | division |
Public property | division_name |
Public property | divisionSpecified |
Public property | gender |
Public property | id |
Public property | name |
Public property | players |
Public property | reference_ids |
Public property | short_name |
Public property | state |
Public property | virtual |
Public property | virtualSpecified |
Top
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.abbreviation Property

teamabbreviation Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.abbreviation"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string abbreviation { get; set; }

Property Value

String
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.age_group Property

teamage_group Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.age_group"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string age_group { get; set; }

Property Value

String
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.country Property

teamcountry Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.country"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string country { get; set; }

Property Value

String
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.country_code Property

teamcountry_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.country_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string country_code { get; set; }

Property Value

String
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.division Property

teamdivision Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.division"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int division { get; set; }

Property Value

Int32
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.division_name Property

teamdivision_name Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.division_name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string division_name { get; set; }

Property Value

String
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.divisionSpecified Property

teamdivisionSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.divisionSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool divisionSpecified { get; set; }

Property Value

Boolean
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.gender Property

teamgender Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.gender"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string gender { get; set; }

Property Value

String
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.id Property

teamid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.name Property

teamname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.players Property

teamplayers Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.players"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public playerCompetitor[] players { get; set; }

Property Value

playerCompetitor
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.reference_ids Property

teamreference_ids Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.reference_ids"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public competitorReferenceIdsReference_id[] reference_ids { get; set; }

Property Value

competitorReferenceIdsReference_id
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.short_name Property

teamshort_name Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.short_name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string short_name { get; set; }

Property Value

String
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.state Property

teamstate Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.state"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string state { get; set; }

Property Value

String
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.virtual Property

teamvirtual Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.virtual"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool virtual { get; set; }

Property Value

Boolean
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team.virtualSpecified Property

teamvirtualSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.team.virtualSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool virtualSpecified { get; set; }

Property Value

Boolean
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


team Methods

The team type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

team Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamCompetitor Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.teamCompetitor"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTteam
Sportradar.OddsFeed.SDK.Messages.RESTteamCompetitor

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class teamCompetitor : team

The teamCompetitor type exposes the following members.

Constructors
 | Name | Description
Public method | teamCompetitor | Initializes a new instance of the teamCompetitor class
Top
Properties
 | Name | Description
Public property | abbreviation | (Inherited from team)
Public property | age_group | (Inherited from team)
Public property | country | (Inherited from team)
Public property | country_code | (Inherited from team)
Public property | division | (Inherited from team)
Public property | division_name | (Inherited from team)
Public property | divisionSpecified | (Inherited from team)
Public property | gender | (Inherited from team)
Public property | id | (Inherited from team)
Public property | name | (Inherited from team)
Public property | players | (Inherited from team)
Public property | qualifier |
Public property | reference_ids | (Inherited from team)
Public property | short_name | (Inherited from team)
Public property | state | (Inherited from team)
Public property | virtual | (Inherited from team)
Public property | virtualSpecified | (Inherited from team)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamCompetitor Constructor

Initializes a new instance of the teamCompetitor class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public teamCompetitor()
See Also

Reference

teamCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamCompetitor Properties

The teamCompetitor type exposes the following members.

Properties
 | Name | Description
Public property | abbreviation | (Inherited from team)
Public property | age_group | (Inherited from team)
Public property | country | (Inherited from team)
Public property | country_code | (Inherited from team)
Public property | division | (Inherited from team)
Public property | division_name | (Inherited from team)
Public property | divisionSpecified | (Inherited from team)
Public property | gender | (Inherited from team)
Public property | id | (Inherited from team)
Public property | name | (Inherited from team)
Public property | players | (Inherited from team)
Public property | qualifier |
Public property | reference_ids | (Inherited from team)
Public property | short_name | (Inherited from team)
Public property | state | (Inherited from team)
Public property | virtual | (Inherited from team)
Public property | virtualSpecified | (Inherited from team)
Top
See Also

Reference

teamCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamCompetitor.qualifier Property

teamCompetitorqualifier Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.teamCompetitor.qualifier"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string qualifier { get; set; }

Property Value

String
See Also

Reference

teamCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamCompetitor Methods

The teamCompetitor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

teamCompetitor Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamExtended Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.teamExtended"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTteam
Sportradar.OddsFeed.SDK.Messages.RESTteamExtended

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class teamExtended : team

The teamExtended type exposes the following members.

Constructors
 | Name | Description
Public method | teamExtended | Initializes a new instance of the teamExtended class
Top
Properties
 | Name | Description
Public property | abbreviation | (Inherited from team)
Public property | age_group | (Inherited from team)
Public property | category |
Public property | country | (Inherited from team)
Public property | country_code | (Inherited from team)
Public property | division | (Inherited from team)
Public property | division_name | (Inherited from team)
Public property | divisionSpecified | (Inherited from team)
Public property | gender | (Inherited from team)
Public property | id | (Inherited from team)
Public property | name | (Inherited from team)
Public property | players | (Inherited from team)
Public property | reference_ids | (Inherited from team)
Public property | short_name | (Inherited from team)
Public property | sport |
Public property | state | (Inherited from team)
Public property | virtual | (Inherited from team)
Public property | virtualSpecified | (Inherited from team)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamExtended Constructor

Initializes a new instance of the teamExtended class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public teamExtended()
See Also

Reference

teamExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamExtended Properties

The teamExtended type exposes the following members.

Properties
 | Name | Description
Public property | abbreviation | (Inherited from team)
Public property | age_group | (Inherited from team)
Public property | category |
Public property | country | (Inherited from team)
Public property | country_code | (Inherited from team)
Public property | division | (Inherited from team)
Public property | division_name | (Inherited from team)
Public property | divisionSpecified | (Inherited from team)
Public property | gender | (Inherited from team)
Public property | id | (Inherited from team)
Public property | name | (Inherited from team)
Public property | players | (Inherited from team)
Public property | reference_ids | (Inherited from team)
Public property | short_name | (Inherited from team)
Public property | sport |
Public property | state | (Inherited from team)
Public property | virtual | (Inherited from team)
Public property | virtualSpecified | (Inherited from team)
Top
See Also

Reference

teamExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamExtended.category Property

teamExtendedcategory Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.teamExtended.category"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public category category { get; set; }

Property Value

category
See Also

Reference

teamExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamExtended.sport Property

teamExtendedsport Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.teamExtended.sport"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sport sport { get; set; }

Property Value

sport
See Also

Reference

teamExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamExtended Methods

The teamExtended type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

teamExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatistics Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.teamStatistics"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTteamStatistics

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class teamStatistics

The teamStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | teamStatistics | Initializes a new instance of the teamStatistics class
Top
Properties
 | Name | Description
Public property | id |
Public property | name |
Public property | statistics |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatistics Constructor

Initializes a new instance of the teamStatistics class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public teamStatistics()
See Also

Reference

teamStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatistics Properties

The teamStatistics type exposes the following members.

Properties
 | Name | Description
Public property | id |
Public property | name |
Public property | statistics |
Top
See Also

Reference

teamStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatistics.id Property

teamStatisticsid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.teamStatistics.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

teamStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatistics.name Property

teamStatisticsname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.teamStatistics.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

teamStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatistics.statistics Property

teamStatisticsstatistics Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.teamStatistics.statistics"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public teamStatisticsStatistics statistics { get; set; }

Property Value

teamStatisticsStatistics
See Also

Reference

teamStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatistics Methods

The teamStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

teamStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatisticsStatistics Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.teamStatisticsStatistics"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTteamStatisticsStatistics

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class teamStatisticsStatistics

The teamStatisticsStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | teamStatisticsStatistics | Initializes a new instance of the teamStatisticsStatistics class
Top
Properties
 | Name | Description
Public property | cards |
Public property | corner_kicks |
Public property | red_cards |
Public property | yellow_cards |
Public property | yellow_red_cards |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatisticsStatistics Constructor

Initializes a new instance of the teamStatisticsStatistics class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public teamStatisticsStatistics()
See Also

Reference

teamStatisticsStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatisticsStatistics Properties

The teamStatisticsStatistics type exposes the following members.

Properties
 | Name | Description
Public property | cards |
Public property | corner_kicks |
Public property | red_cards |
Public property | yellow_cards |
Public property | yellow_red_cards |
Top
See Also

Reference

teamStatisticsStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatisticsStatistics.cards Property

teamStatisticsStatisticscards Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.teamStatisticsStatistics.cards"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string cards { get; set; }

Property Value

String
See Also

Reference

teamStatisticsStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatisticsStatistics.corner_kicks Property

teamStatisticsStatisticscorner_kicks Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.teamStatisticsStatistics.corner_kicks"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string corner_kicks { get; set; }

Property Value

String
See Also

Reference

teamStatisticsStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatisticsStatistics.red_cards Property

teamStatisticsStatisticsred_cards Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.teamStatisticsStatistics.red_cards"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string red_cards { get; set; }

Property Value

String
See Also

Reference

teamStatisticsStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatisticsStatistics.yellow_cards Property

teamStatisticsStatisticsyellow_cards Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.teamStatisticsStatistics.yellow_cards"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string yellow_cards { get; set; }

Property Value

String
See Also

Reference

teamStatisticsStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatisticsStatistics.yellow_red_cards Property

teamStatisticsStatisticsyellow_red_cards Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.teamStatisticsStatistics.yellow_red_cards"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string yellow_red_cards { get; set; }

Property Value

String
See Also

Reference

teamStatisticsStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


teamStatisticsStatistics Methods

The teamStatisticsStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

teamStatisticsStatistics Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


timeType Enumeration

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.timeType"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public enum timeType
Members
Member name | Value | Description
interval | 0 |
fixed | 1 |
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.tournament"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTtournament
Sportradar.OddsFeed.SDK.Messages.RESTtournamentExtended

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class tournament

The tournament type exposes the following members.

Constructors
 | Name | Description
Public method | tournament | Initializes a new instance of the tournament class
Top
Properties
 | Name | Description
Public property | category |
Public property | exhibition_games |
Public property | exhibition_gamesSpecified |
Public property | id |
Public property | name |
Public property | scheduled |
Public property | scheduled_end |
Public property | scheduled_endSpecified |
Public property | scheduledSpecified |
Public property | sport |
Public property | tournament_length |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament Constructor

Initializes a new instance of the tournament class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournament()
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament Properties

The tournament type exposes the following members.

Properties
 | Name | Description
Public property | category |
Public property | exhibition_games |
Public property | exhibition_gamesSpecified |
Public property | id |
Public property | name |
Public property | scheduled |
Public property | scheduled_end |
Public property | scheduled_endSpecified |
Public property | scheduledSpecified |
Public property | sport |
Public property | tournament_length |
Top
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament.category Property

tournamentcategory Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournament.category"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public category category { get; set; }

Property Value

category
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament.exhibition_games Property

tournamentexhibition_games Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournament.exhibition_games"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool exhibition_games { get; set; }

Property Value

Boolean
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament.exhibition_gamesSpecified Property

tournamentexhibition_gamesSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournament.exhibition_gamesSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool exhibition_gamesSpecified { get; set; }

Property Value

Boolean
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament.id Property

tournamentid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournament.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament.name Property

tournamentname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournament.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament.scheduled Property

tournamentscheduled Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournament.scheduled"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime scheduled { get; set; }

Property Value

DateTime
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament.scheduled_end Property

tournamentscheduled_end Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournament.scheduled_end"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime scheduled_end { get; set; }

Property Value

DateTime
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament.scheduled_endSpecified Property

tournamentscheduled_endSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournament.scheduled_endSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool scheduled_endSpecified { get; set; }

Property Value

Boolean
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament.scheduledSpecified Property

tournamentscheduledSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournament.scheduledSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool scheduledSpecified { get; set; }

Property Value

Boolean
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament.sport Property

tournamentsport Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournament.sport"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sport sport { get; set; }

Property Value

sport
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament.tournament_length Property

tournamenttournament_length Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournament.tournament_length"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentLength tournament_length { get; set; }

Property Value

tournamentLength
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournament Methods

The tournament type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

tournament Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentExtended Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.tournamentExtended"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTtournament
Sportradar.OddsFeed.SDK.Messages.RESTtournamentExtended

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class tournamentExtended : tournament

The tournamentExtended type exposes the following members.

Constructors
 | Name | Description
Public method | tournamentExtended | Initializes a new instance of the tournamentExtended class
Top
Properties
 | Name | Description
Public property | category | (Inherited from tournament)
Public property | competitors |
Public property | current_season |
Public property | exhibition_games | (Inherited from tournament)
Public property | exhibition_gamesSpecified | (Inherited from tournament)
Public property | id | (Inherited from tournament)
Public property | name | (Inherited from tournament)
Public property | scheduled | (Inherited from tournament)
Public property | scheduled_end | (Inherited from tournament)
Public property | scheduled_endSpecified | (Inherited from tournament)
Public property | scheduledSpecified | (Inherited from tournament)
Public property | season_coverage_info |
Public property | sport | (Inherited from tournament)
Public property | tournament_length | (Inherited from tournament)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentExtended Constructor

Initializes a new instance of the tournamentExtended class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentExtended()
See Also

Reference

tournamentExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentExtended Properties

The tournamentExtended type exposes the following members.

Properties
 | Name | Description
Public property | category | (Inherited from tournament)
Public property | competitors |
Public property | current_season |
Public property | exhibition_games | (Inherited from tournament)
Public property | exhibition_gamesSpecified | (Inherited from tournament)
Public property | id | (Inherited from tournament)
Public property | name | (Inherited from tournament)
Public property | scheduled | (Inherited from tournament)
Public property | scheduled_end | (Inherited from tournament)
Public property | scheduled_endSpecified | (Inherited from tournament)
Public property | scheduledSpecified | (Inherited from tournament)
Public property | season_coverage_info |
Public property | sport | (Inherited from tournament)
Public property | tournament_length | (Inherited from tournament)
Top
See Also

Reference

tournamentExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentExtended.competitors Property

tournamentExtendedcompetitors Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentExtended.competitors"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public team[] competitors { get; set; }

Property Value

team
See Also

Reference

tournamentExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentExtended.current_season Property

tournamentExtendedcurrent_season Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentExtended.current_season"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public currentSeason current_season { get; set; }

Property Value

currentSeason
See Also

Reference

tournamentExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentExtended.season_coverage_info Property

tournamentExtendedseason_coverage_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentExtended.season_coverage_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public seasonCoverageInfo season_coverage_info { get; set; }

Property Value

seasonCoverageInfo
See Also

Reference

tournamentExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentExtended Methods

The tournamentExtended type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

tournamentExtended Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentGroup Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.tournamentGroup"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTtournamentGroup

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class tournamentGroup

The tournamentGroup type exposes the following members.

Constructors
 | Name | Description
Public method | tournamentGroup | Initializes a new instance of the tournamentGroup class
Top
Properties
 | Name | Description
Public property | competitor |
Public property | id |
Public property | name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentGroup Constructor

Initializes a new instance of the tournamentGroup class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentGroup()
See Also

Reference

tournamentGroup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentGroup Properties

The tournamentGroup type exposes the following members.

Properties
 | Name | Description
Public property | competitor |
Public property | id |
Public property | name |
Top
See Also

Reference

tournamentGroup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentGroup.competitor Property

tournamentGroupcompetitor Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentGroup.competitor"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public team[] competitor { get; set; }

Property Value

team
See Also

Reference

tournamentGroup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentGroup.id Property

tournamentGroupid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentGroup.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

tournamentGroup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentGroup.name Property

tournamentGroupname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentGroup.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

tournamentGroup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentGroup Methods

The tournamentGroup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

tournamentGroup Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.tournamentInfoEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTtournamentInfoEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTraceTournamentInfoEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTsimpleTournamentInfoEndpoint
Sportradar.OddsFeed.SDK.Messages.RESTstandardTournamentInfoEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class tournamentInfoEndpoint : RestMessage

The tournamentInfoEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | tournamentInfoEndpoint | Initializes a new instance of the tournamentInfoEndpoint class
Top
Properties
 | Name | Description
Public property | children |
Public property | competitors |
Public property | coverage_info |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | groups |
Public property | round |
Public property | season |
Public property | season_coverage_info |
Public property | tournament |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint Constructor

Initializes a new instance of the tournamentInfoEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentInfoEndpoint()
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint Properties

The tournamentInfoEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | children |
Public property | competitors |
Public property | coverage_info |
Public property | generated_at |
Public property | generated_atSpecified |
Public property | groups |
Public property | round |
Public property | season |
Public property | season_coverage_info |
Public property | tournament |
Top
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint.children Property

tournamentInfoEndpointchildren Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentInfoEndpoint.children"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentExtended[] children { get; set; }

Property Value

tournamentExtended
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint.competitors Property

tournamentInfoEndpointcompetitors Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentInfoEndpoint.competitors"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public team[] competitors { get; set; }

Property Value

team
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint.coverage_info Property

tournamentInfoEndpointcoverage_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentInfoEndpoint.coverage_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentLiveCoverageInfo coverage_info { get; set; }

Property Value

tournamentLiveCoverageInfo
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint.generated_at Property

tournamentInfoEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentInfoEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint.generated_atSpecified Property

tournamentInfoEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentInfoEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint.groups Property

tournamentInfoEndpointgroups Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentInfoEndpoint.groups"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentGroup[] groups { get; set; }

Property Value

tournamentGroup
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint.round Property

tournamentInfoEndpointround Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentInfoEndpoint.round"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public matchRound round { get; set; }

Property Value

matchRound
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint.season Property

tournamentInfoEndpointseason Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentInfoEndpoint.season"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public seasonExtended season { get; set; }

Property Value

seasonExtended
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint.season_coverage_info Property

tournamentInfoEndpointseason_coverage_info Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentInfoEndpoint.season_coverage_info"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public seasonCoverageInfo season_coverage_info { get; set; }

Property Value

seasonCoverageInfo
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint.tournament Property

tournamentInfoEndpointtournament Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentInfoEndpoint.tournament"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentExtended tournament { get; set; }

Property Value

tournamentExtended
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentInfoEndpoint Methods

The tournamentInfoEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

tournamentInfoEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLength Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.tournamentLength"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTtournamentLength

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class tournamentLength

The tournamentLength type exposes the following members.

Constructors
 | Name | Description
Public method | tournamentLength | Initializes a new instance of the tournamentLength class
Top
Properties
 | Name | Description
Public property | end_date |
Public property | end_dateSpecified |
Public property | start_date |
Public property | start_dateSpecified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLength Constructor

Initializes a new instance of the tournamentLength class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentLength()
See Also

Reference

tournamentLength Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLength Properties

The tournamentLength type exposes the following members.

Properties
 | Name | Description
Public property | end_date |
Public property | end_dateSpecified |
Public property | start_date |
Public property | start_dateSpecified |
Top
See Also

Reference

tournamentLength Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLength.end_date Property

tournamentLengthend_date Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentLength.end_date"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime end_date { get; set; }

Property Value

DateTime
See Also

Reference

tournamentLength Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLength.end_dateSpecified Property

tournamentLengthend_dateSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentLength.end_dateSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool end_dateSpecified { get; set; }

Property Value

Boolean
See Also

Reference

tournamentLength Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLength.start_date Property

tournamentLengthstart_date Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentLength.start_date"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime start_date { get; set; }

Property Value

DateTime
See Also

Reference

tournamentLength Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLength.start_dateSpecified Property

tournamentLengthstart_dateSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentLength.start_dateSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_dateSpecified { get; set; }

Property Value

Boolean
See Also

Reference

tournamentLength Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLength Methods

The tournamentLength type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

tournamentLength Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLiveCoverageInfo Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.tournamentLiveCoverageInfo"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTtournamentLiveCoverageInfo

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class tournamentLiveCoverageInfo

The tournamentLiveCoverageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | tournamentLiveCoverageInfo | Initializes a new instance of the tournamentLiveCoverageInfo class
Top
Properties
 | Name | Description
Public property | live_coverage |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLiveCoverageInfo Constructor

Initializes a new instance of the tournamentLiveCoverageInfo class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentLiveCoverageInfo()
See Also

Reference

tournamentLiveCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLiveCoverageInfo Properties

The tournamentLiveCoverageInfo type exposes the following members.

Properties
 | Name | Description
Public property | live_coverage |
Top
See Also

Reference

tournamentLiveCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLiveCoverageInfo.live_coverage Property

tournamentLiveCoverageInfolive_coverage Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentLiveCoverageInfo.live_coverage"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string live_coverage { get; set; }

Property Value

String
See Also

Reference

tournamentLiveCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentLiveCoverageInfo Methods

The tournamentLiveCoverageInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

tournamentLiveCoverageInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSchedule Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.tournamentSchedule"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTtournamentSchedule

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class tournamentSchedule : RestMessage

The tournamentSchedule type exposes the following members.

Constructors
 | Name | Description
Public method | tournamentSchedule | Initializes a new instance of the tournamentSchedule class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_events |
Public property | tournament |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSchedule Constructor

Initializes a new instance of the tournamentSchedule class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentSchedule()
See Also

Reference

tournamentSchedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSchedule Properties

The tournamentSchedule type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | sport_events |
Public property | tournament |
Top
See Also

Reference

tournamentSchedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSchedule.generated_at Property

tournamentSchedulegenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentSchedule.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

tournamentSchedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSchedule.generated_atSpecified Property

tournamentSchedulegenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentSchedule.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

tournamentSchedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSchedule.sport_events Property

tournamentSchedulesport_events Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentSchedule.sport_events"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public sportEvent[] sport_events { get; set; }

Property Value

sportEvent
See Also

Reference

tournamentSchedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSchedule.tournament Property

tournamentScheduletournament Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentSchedule.tournament"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentExtended[] tournament { get; set; }

Property Value

tournamentExtended
See Also

Reference

tournamentSchedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSchedule Methods

The tournamentSchedule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

tournamentSchedule Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSeasons Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.tournamentSeasons"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTtournamentSeasons

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class tournamentSeasons : RestMessage

The tournamentSeasons type exposes the following members.

Constructors
 | Name | Description
Public method | tournamentSeasons | Initializes a new instance of the tournamentSeasons class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | seasons |
Public property | tournament |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSeasons Constructor

Initializes a new instance of the tournamentSeasons class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentSeasons()
See Also

Reference

tournamentSeasons Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSeasons Properties

The tournamentSeasons type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | seasons |
Public property | tournament |
Top
See Also

Reference

tournamentSeasons Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSeasons.generated_at Property

tournamentSeasonsgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentSeasons.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

tournamentSeasons Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSeasons.generated_atSpecified Property

tournamentSeasonsgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentSeasons.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

tournamentSeasons Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSeasons.seasons Property

tournamentSeasonsseasons Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentSeasons.seasons"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public seasonExtended[] seasons { get; set; }

Property Value

seasonExtended
See Also

Reference

tournamentSeasons Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSeasons.tournament Property

tournamentSeasonstournament Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentSeasons.tournament"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournament tournament { get; set; }

Property Value

tournament
See Also

Reference

tournamentSeasons Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentSeasons Methods

The tournamentSeasons type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

tournamentSeasons Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentsEndpoint Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.tournamentsEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTtournamentsEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class tournamentsEndpoint : RestMessage

The tournamentsEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | tournamentsEndpoint | Initializes a new instance of the tournamentsEndpoint class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | tournament |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentsEndpoint Constructor

Initializes a new instance of the tournamentsEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentsEndpoint()
See Also

Reference

tournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentsEndpoint Properties

The tournamentsEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | generated_atSpecified |
Public property | tournament |
Top
See Also

Reference

tournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentsEndpoint.generated_at Property

tournamentsEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentsEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

tournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentsEndpoint.generated_atSpecified Property

tournamentsEndpointgenerated_atSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentsEndpoint.generated_atSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool generated_atSpecified { get; set; }

Property Value

Boolean
See Also

Reference

tournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentsEndpoint.tournament Property

tournamentsEndpointtournament Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tournamentsEndpoint.tournament"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tournamentExtended[] tournament { get; set; }

Property Value

tournamentExtended
See Also

Reference

tournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tournamentsEndpoint Methods

The tournamentsEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

tournamentsEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tvChannel Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.tvChannel"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTtvChannel

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class tvChannel

The tvChannel type exposes the following members.

Constructors
 | Name | Description
Public method | tvChannel | Initializes a new instance of the tvChannel class
Top
Properties
 | Name | Description
Public property | name |
Public property | start_time |
Public property | start_timeSpecified |
Public property | stream_url |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


tvChannel Constructor

Initializes a new instance of the tvChannel class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public tvChannel()
See Also

Reference

tvChannel Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tvChannel Properties

The tvChannel type exposes the following members.

Properties
 | Name | Description
Public property | name |
Public property | start_time |
Public property | start_timeSpecified |
Public property | stream_url |
Top
See Also

Reference

tvChannel Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tvChannel.name Property

tvChannelname Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tvChannel.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

tvChannel Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tvChannel.start_time Property

tvChannelstart_time Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tvChannel.start_time"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime start_time { get; set; }

Property Value

DateTime
See Also

Reference

tvChannel Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tvChannel.start_timeSpecified Property

tvChannelstart_timeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tvChannel.start_timeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool start_timeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

tvChannel Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tvChannel.stream_url Property

tvChannelstream_url Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.tvChannel.stream_url"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string stream_url { get; set; }

Property Value

String
See Also

Reference

tvChannel Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


tvChannel Methods

The tvChannel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

tvChannel Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_descriptions Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.variant_descriptions"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTRestMessage
Sportradar.OddsFeed.SDK.Messages.RESTvariant_descriptions

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class variant_descriptions : RestMessage

The variant_descriptions type exposes the following members.

Constructors
 | Name | Description
Public method | variant_descriptions | Initializes a new instance of the variant_descriptions class
Top
Properties
 | Name | Description
Public property | response_code |
Public property | response_codeSpecified |
Public property | variant |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_descriptions Constructor

Initializes a new instance of the variant_descriptions class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public variant_descriptions()
See Also

Reference

variant_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_descriptions Properties

The variant_descriptions type exposes the following members.

Properties
 | Name | Description
Public property | response_code |
Public property | response_codeSpecified |
Public property | variant |
Top
See Also

Reference

variant_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_descriptions.response_code Property

variant_descriptionsresponse_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_descriptions.response_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public response_code response_code { get; set; }

Property Value

response_code
See Also

Reference

variant_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_descriptions.response_codeSpecified Property

variant_descriptionsresponse_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_descriptions.response_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool response_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

variant_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_descriptions.variant Property

variant_descriptionsvariant Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_descriptions.variant"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_variant[] variant { get; set; }

Property Value

desc_variant
See Also

Reference

variant_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_descriptions Methods

The variant_descriptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

variant_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMapping Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMapping"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTvariant_mappingsMapping

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class variant_mappingsMapping

The variant_mappingsMapping type exposes the following members.

Constructors
 | Name | Description
Public method | variant_mappingsMapping | Initializes a new instance of the variant_mappingsMapping class
Top
Properties
 | Name | Description
Public property | mapping_outcome |
Public property | market_id |
Public property | product_id |
Public property | product_ids |
Public property | product_market_id |
Public property | sov_template |
Public property | sport_id |
Public property | valid_for |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMapping Constructor

Initializes a new instance of the variant_mappingsMapping class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public variant_mappingsMapping()
See Also

Reference

variant_mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMapping Properties

The variant_mappingsMapping type exposes the following members.

Properties
 | Name | Description
Public property | mapping_outcome |
Public property | market_id |
Public property | product_id |
Public property | product_ids |
Public property | product_market_id |
Public property | sov_template |
Public property | sport_id |
Public property | valid_for |
Top
See Also

Reference

variant_mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMapping.mapping_outcome Property

variant_mappingsMappingmapping_outcome Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMapping.mapping_outcome"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public variant_mappingsMappingMapping_outcome[] mapping_outcome { get; set; }

Property Value

variant_mappingsMappingMapping_outcome
See Also

Reference

variant_mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMapping.market_id Property

variant_mappingsMappingmarket_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMapping.market_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string market_id { get; set; }

Property Value

String
See Also

Reference

variant_mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMapping.product_id Property

variant_mappingsMappingproduct_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMapping.product_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int product_id { get; set; }

Property Value

Int32
See Also

Reference

variant_mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMapping.product_ids Property

variant_mappingsMappingproduct_ids Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMapping.product_ids"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string product_ids { get; set; }

Property Value

String
See Also

Reference

variant_mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMapping.product_market_id Property

variant_mappingsMappingproduct_market_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMapping.product_market_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string product_market_id { get; set; }

Property Value

String
See Also

Reference

variant_mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMapping.sov_template Property

variant_mappingsMappingsov_template Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMapping.sov_template"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string sov_template { get; set; }

Property Value

String
See Also

Reference

variant_mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMapping.sport_id Property

variant_mappingsMappingsport_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMapping.sport_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string sport_id { get; set; }

Property Value

String
See Also

Reference

variant_mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMapping.valid_for Property

variant_mappingsMappingvalid_for Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMapping.valid_for"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string valid_for { get; set; }

Property Value

String
See Also

Reference

variant_mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMapping Methods

The variant_mappingsMapping type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

variant_mappingsMapping Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMappingMapping_outcome Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMappingMapping_outcome"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTvariant_mappingsMappingMapping_outcome

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class variant_mappingsMappingMapping_outcome

The variant_mappingsMappingMapping_outcome type exposes the following members.

Constructors
 | Name | Description
Public method | variant_mappingsMappingMapping_outcome | Initializes a new instance of the variant_mappingsMappingMapping_outcome class
Top
Properties
 | Name | Description
Public property | outcome_id |
Public property | product_outcome_id |
Public property | product_outcome_name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMappingMapping_outcome Constructor

Initializes a new instance of the variant_mappingsMappingMapping_outcome class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public variant_mappingsMappingMapping_outcome()
See Also

Reference

variant_mappingsMappingMapping_outcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMappingMapping_outcome Properties

The variant_mappingsMappingMapping_outcome type exposes the following members.

Properties
 | Name | Description
Public property | outcome_id |
Public property | product_outcome_id |
Public property | product_outcome_name |
Top
See Also

Reference

variant_mappingsMappingMapping_outcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMappingMapping_outcome.outcome_id Property

variant_mappingsMappingMapping_outcomeoutcome_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMappingMapping_outcome.outcome_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string outcome_id { get; set; }

Property Value

String
See Also

Reference

variant_mappingsMappingMapping_outcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMappingMapping_outcome.product_outcome_id Property

variant_mappingsMappingMapping_outcomeproduct_outcome_id Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMappingMapping_outcome.product_outcome_id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string product_outcome_id { get; set; }

Property Value

String
See Also

Reference

variant_mappingsMappingMapping_outcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMappingMapping_outcome.product_outcome_name Property

variant_mappingsMappingMapping_outcomeproduct_outcome_name Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.variant_mappingsMappingMapping_outcome.product_outcome_name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string product_outcome_name { get; set; }

Property Value

String
See Also

Reference

variant_mappingsMappingMapping_outcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


variant_mappingsMappingMapping_outcome Methods

The variant_mappingsMappingMapping_outcome type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

variant_mappingsMappingMapping_outcome Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.venue"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTvenue

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class venue

The venue type exposes the following members.

Constructors
 | Name | Description
Public method | venue | Initializes a new instance of the venue class
Top
Properties
 | Name | Description
Public property | capacity |
Public property | capacitySpecified |
Public property | city_name |
Public property | country_code |
Public property | country_name |
Public property | course |
Public property | id |
Public property | map_coordinates |
Public property | name |
Public property | state |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue Constructor

Initializes a new instance of the venue class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public venue()
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue Properties

The venue type exposes the following members.

Properties
 | Name | Description
Public property | capacity |
Public property | capacitySpecified |
Public property | city_name |
Public property | country_code |
Public property | country_name |
Public property | course |
Public property | id |
Public property | map_coordinates |
Public property | name |
Public property | state |
Top
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue.capacity Property

venuecapacity Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venue.capacity"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int capacity { get; set; }

Property Value

Int32
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue.capacitySpecified Property

venuecapacitySpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venue.capacitySpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool capacitySpecified { get; set; }

Property Value

Boolean
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue.city_name Property

venuecity_name Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venue.city_name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string city_name { get; set; }

Property Value

String
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue.country_code Property

venuecountry_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venue.country_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string country_code { get; set; }

Property Value

String
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue.country_name Property

venuecountry_name Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venue.country_name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string country_name { get; set; }

Property Value

String
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue.course Property

venuecourse Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venue.course"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public course[] course { get; set; }

Property Value

course
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue.id Property

venueid Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venue.id"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue.map_coordinates Property

venuemap_coordinates Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venue.map_coordinates"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string map_coordinates { get; set; }

Property Value

String
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue.name Property

venuename Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venue.name"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string name { get; set; }

Property Value

String
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue.state Property

venuestate Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venue.state"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string state { get; set; }

Property Value

String
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venue Methods

The venue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

venue Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venueSummaryEndpoint Class

Note: This API is now obsolete.

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.venueSummaryEndpoint"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTvenueSummaryEndpoint

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
[ObsoleteAttribute("Not used")]
public class venueSummaryEndpoint

The venueSummaryEndpoint type exposes the following members.

Constructors
 | Name | Description
Public method | venueSummaryEndpoint | Initializes a new instance of the venueSummaryEndpoint class
Top
Properties
 | Name | Description
Public property | generated_at |
Public property | home_teams |
Public property | venue |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


venueSummaryEndpoint Constructor

Initializes a new instance of the venueSummaryEndpoint class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public venueSummaryEndpoint()
See Also

Reference

venueSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venueSummaryEndpoint Properties

The venueSummaryEndpoint type exposes the following members.

Properties
 | Name | Description
Public property | generated_at |
Public property | home_teams |
Public property | venue |
Top
See Also

Reference

venueSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venueSummaryEndpoint.generated_at Property

venueSummaryEndpointgenerated_at Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venueSummaryEndpoint.generated_at"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public DateTime generated_at { get; set; }

Property Value

DateTime
See Also

Reference

venueSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venueSummaryEndpoint.home_teams Property

venueSummaryEndpointhome_teams Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venueSummaryEndpoint.home_teams"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public teamExtended[] home_teams { get; set; }

Property Value

teamExtended
See Also

Reference

venueSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venueSummaryEndpoint.venue Property

venueSummaryEndpointvenue Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.venueSummaryEndpoint.venue"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public venue venue { get; set; }

Property Value

venue
See Also

Reference

venueSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


venueSummaryEndpoint Methods

The venueSummaryEndpoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

venueSummaryEndpoint Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


void_reasons_descriptions Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.void_reasons_descriptions"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTvoid_reasons_descriptions

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class void_reasons_descriptions

The void_reasons_descriptions type exposes the following members.

Constructors
 | Name | Description
Public method | void_reasons_descriptions | Initializes a new instance of the void_reasons_descriptions class
Top
Properties
 | Name | Description
Public property | location |
Public property | response_code |
Public property | response_codeSpecified |
Public property | void_reason |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


void_reasons_descriptions Constructor

Initializes a new instance of the void_reasons_descriptions class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public void_reasons_descriptions()
See Also

Reference

void_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


void_reasons_descriptions Properties

The void_reasons_descriptions type exposes the following members.

Properties
 | Name | Description
Public property | location |
Public property | response_code |
Public property | response_codeSpecified |
Public property | void_reason |
Top
See Also

Reference

void_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


void_reasons_descriptions.location Property

void_reasons_descriptionslocation Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.void_reasons_descriptions.location"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string location { get; set; }

Property Value

String
See Also

Reference

void_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


void_reasons_descriptions.response_code Property

void_reasons_descriptionsresponse_code Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.void_reasons_descriptions.response_code"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public response_code response_code { get; set; }

Property Value

response_code
See Also

Reference

void_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


void_reasons_descriptions.response_codeSpecified Property

void_reasons_descriptionsresponse_codeSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.void_reasons_descriptions.response_codeSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool response_codeSpecified { get; set; }

Property Value

Boolean
See Also

Reference

void_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


void_reasons_descriptions.void_reason Property

void_reasons_descriptionsvoid_reason Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.void_reasons_descriptions.void_reason"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public desc_void_reason[] void_reason { get; set; }

Property Value

desc_void_reason
See Also

Reference

void_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


void_reasons_descriptions Methods

The void_reasons_descriptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

void_reasons_descriptions Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


weatherInfo Class

[Missing <summary> documentation for "T:Sportradar.OddsFeed.SDK.Messages.REST.weatherInfo"]

Inheritance Hierarchy
SystemObject
Sportradar.OddsFeed.SDK.Messages.RESTweatherInfo

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class weatherInfo

The weatherInfo type exposes the following members.

Constructors
 | Name | Description
Public method | weatherInfo | Initializes a new instance of the weatherInfo class
Top
Properties
 | Name | Description
Public property | pitch |
Public property | temperature_celsius |
Public property | temperature_celsiusSpecified |
Public property | weather_conditions |
Public property | wind |
Public property | wind_advantage |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sportradar.OddsFeed.SDK.Messages.REST Namespace


weatherInfo Constructor

Initializes a new instance of the weatherInfo class

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public weatherInfo()
See Also

Reference

weatherInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


weatherInfo Properties

The weatherInfo type exposes the following members.

Properties
 | Name | Description
Public property | pitch |
Public property | temperature_celsius |
Public property | temperature_celsiusSpecified |
Public property | weather_conditions |
Public property | wind |
Public property | wind_advantage |
Top
See Also

Reference

weatherInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


weatherInfo.pitch Property

weatherInfopitch Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.weatherInfo.pitch"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string pitch { get; set; }

Property Value

String
See Also

Reference

weatherInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


weatherInfo.temperature_celsius Property

weatherInfotemperature_celsius Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.weatherInfo.temperature_celsius"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public int temperature_celsius { get; set; }

Property Value

Int32
See Also

Reference

weatherInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


weatherInfo.temperature_celsiusSpecified Property

weatherInfotemperature_celsiusSpecified Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.weatherInfo.temperature_celsiusSpecified"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public bool temperature_celsiusSpecified { get; set; }

Property Value

Boolean
See Also

Reference

weatherInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


weatherInfo.weather_conditions Property

weatherInfoweather_conditions Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.weatherInfo.weather_conditions"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string weather_conditions { get; set; }

Property Value

String
See Also

Reference

weatherInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


weatherInfo.wind Property

weatherInfowind Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.weatherInfo.wind"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string wind { get; set; }

Property Value

String
See Also

Reference

weatherInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


weatherInfo.wind_advantage Property

weatherInfowind_advantage Property

[Missing <summary> documentation for "P:Sportradar.OddsFeed.SDK.Messages.REST.weatherInfo.wind_advantage"]

Namespace: Sportradar.OddsFeed.SDK.Messages.REST
Assembly: Sportradar.OddsFeed.SDK.Messages (in Sportradar.OddsFeed.SDK.Messages.dll) Version: 1.59.0.0 (1.59.0.0)
Syntax
C#
Copy
public string wind_advantage { get; set; }

Property Value

String
See Also

Reference

weatherInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


weatherInfo Methods

The weatherInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

weatherInfo Class
Sportradar.OddsFeed.SDK.Messages.REST Namespace


Version History

The topics in this section describe the various changes made to the [TODO: Project Title] over the life of the project.

Version History

Select a version below to see a description of its changes.

  • Version 1.0.0.0

  • [TODO: Add links to each specific version page]

See Also

Other Resources

UnifiedFeed SDK .NET


Version 1.0.0.0

Version [TODO: Version] was released on [TODO: Date].

Changes in This Release

  • [TODO: Add change items here]

See Also

Other Resources

Version History